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CHAPTER 1

Viewing Used File Tags
You can view a list of all file tags used in your project. The list shows the tag type and the file that it
is associated with. You can quickly rename or remove multiple file tag occurrences in a single
batch.

For more information about file tags and how they are used in projects, see the online Help in Flare.

CHAPTER 1  4



HOW TO VIEW USED FILE TAGS

1. Open a project.

2. Select the View ribbon. In the Dynamic Reports section, select Used Items > Used File Tags.

The Used File Tags window pane opens, listing all of the file tags used throughout the project.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider:

n File Tag Displays the name of the file tag set and the tag within it. The file tag set is listed
first, followed by a period and then the name of the file tag (e.g., AuthorTagSet.Bob).

n Type Displays the type of file tag (e.g., Status, Author). It also indicates if a file tag is
undefined. In that case, use the Undefined File Tags window pane to fix the problem.

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You also have the option to view all items at once in one long list. This is called the View All
option. You can toggle these views by clicking the View All/View as Pages button in the local
toolbar. The button displays the opposite of whatever view is currently activated (e.g., If the
View All option is currently active, the button shows View as Pages to indicate that if clicked,
the button will switch the window pane to the View as Pages option).
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5. You can open any file in the list to view or modify it in an editor. You can open the file in the
Analyzer interface or in the Flare project.

TO OPEN THE FILE IN THE ANALYZER INTERFACE

Double-click the file in the window pane. The benefit of using this method is that it is quick and
convenient. You have access to the features normally available in the editor (but not neces-
sarily to all of the features available elsewhere in Flare).

TO OPEN THE FILE IN FLARE

a. In the window pane, click on the file.

b. Select File > Send to Flare.

The benefit of using this method is that you have access to all of the features in the applic-
ation, not just those available from the editor.

HOW TO RENAME FILE TAG OCCURRENCES

1. In the window pane, select all file tag occurrences that you want to rename. If you want to

select all rows click . You can hold the SHIFT key to select a range, or you can hold the
CTRL key to select individual items.

NOTE: All file tag occurrences that you select will be renamed to the same file tag
that you provide in the following steps.

2. In the local toolbar, click the Rename button. The Rename File Tag(s) dialog opens.

3. In the New file tag name field, enter a new file tag name. Type the name of the file tag set, fol-
lowed by a period, then the name of the file tag (e.g., AuthorTagSet.Bob).

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected file tag
occurrences are renamed.

NOTE: If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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CHAPTER 2

Viewing Undefined File Tags
You can view a list of all files that are associated with file tags, but those file tags have not been
defined. This might occur, for example, if you have associated a file tag with a topic and then later
change the name of the tag or file tag set. The old tag or set name is still used for the topic. There-
fore, a problem exists. From the Undefined File Tags window pane, you can open the file in question
and fix the undefined tag. You can also quickly rename or remove multiple file tag occurrences in a
single batch.
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HOW TO VIEW UNDEFINED FILE TAGS

1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select the View ribbon. Then in the Dynamic Reports section, select Undefined
Items > Undefined File Tags.

n Analyzer Summary Window Pane Double-click the row that mentions undefined file tags.

The Undefined File Tags window pane opens, displaying a list of undefined file tags.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider:

n File Tag Displays the name of the file tag set and the tag within it. The file tag set is listed
first, followed by a period and then the name of the file tag (e.g., AuthorTagSet.Bob).

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You also have the option to view all items at once in one long list. This is called the View All
option. You can toggle these views by clicking the View All/View as Pages button in the local
toolbar. The button displays the opposite of whatever view is currently activated (e.g., If the
View All option is currently active, the button shows View as Pages to indicate that if clicked,
the button will switch the window pane to the View as Pages option).
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HOW TO FIX UNDEFINED FILE TAGS

There are a couple of basic ways to fix an undefined file tag. First, you can rename the file tag or file
tag set so that it matches what you have associated with the file. Otherwise, you can re-associate
the file tag with the file so that it uses an existing file tag set/file tag.

TO RENAME FILE TAGS

1. In the window pane, select all file tag occurrences that you want to rename. If you want to

select all rows click . You can hold the SHIFT key to select a range, or you can hold the
CTRL key to select individual items.

NOTE: All file tag occurrences that you select will be renamed to the same file tag
that you provide in the following steps.

2. In the local toolbar, click the Rename button. The Rename File Tag(s) dialog opens.

3. In the New file tag name field, enter a new file tag name. Type the name of the file tag set, fol-
lowed by a period, then the name of the file tag (e.g., AuthorTagSet.Bob).

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected file tag
occurrences are renamed.

NOTE: If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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TO RE-ASSOCIATE FILE TAGS

1. Open the Flare project that contains the file.

2. In the Content Explore or Project Organizer, right-click on the file and select Properties.

3. Select the File Tags tab.

4. Select the appropriate file tag set and file tag.

5. Click OK.

NOTE: Another way to associate a different file tag to many places throughout a project is
to use the Find and Replace in Files feature in Flare. For example, let's say that you originally
associated a file tag named "Completed" (from the "Status" file tag set) with a lot of files in
your project. Later, you renamed the file tag "Finished." You can perform a find and replace
in your entire project. In the "Find" field, you can enter Status.Completed, and in the
"Replace with" field, you can enter Status.Finished. Also, make sure you select the
"Find in source code" option in the Find and Replace in Files window pane. After replacing
this text throughout your project, that file tag will no longer be considered "undefined" in Ana-
lyzer. For information about using the Find and Replace in Files feature, see the online Help
in Flare.
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CHAPTER 3

Viewing Unused File Tags
You can view a list of all file tags that have been created in your project but have not yet been used
in any files. You can quickly delete any of the file tags that you do not plan to use.

For more information about file tags and how they are used in projects, see the online Help in Flare.
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HOW TO VIEW UNUSED FILE TAGS

1. Open a project.

2. Select the View ribbon. In the Dynamic Reports section, select More Reports > Unused Items.

The Unused Items window pane opens, which allows you to view various unused elements in
the project (such as bookmarks, condition tags, content files, CSH IDs, images, variables,
styles, file tags, and topics not linked).

3. Click the drop-down field at the top of the window pane and select Unused File Tags. The
unused file tags in the project are listed.

4. To see more of the information in the window pane, drag the divider bar to make the pane
wider:

n File Tag Displays the name of the file tag not being used.

n Type Displays the type of file tag (e.g., Status, Author).

n File Displays the name of the file.

5. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You also have the option to view all items at once in one long list. This is called the View All
option. You can toggle these views by clicking the View All/View as Pages button in the local
toolbar. The button displays the opposite of whatever view is currently activated (e.g., If the
View All option is currently active, the button shows View as Pages to indicate that if clicked,
the button will switch the window pane to the View as Pages option).

6. If you want to remove any unused file tags from Analyzer, as well as from the project being

analyzed, select the file tag in the list and click in the local toolbar.

7. You can open the set file for any file tag in the list to view it in the File Tag Set Editor. You can
open the file tag set in the Analyzer interface or in the Flare project.

TO OPEN THE FILE IN THE ANALYZER INTERFACE

Double-click the file in the window pane. The benefit of using this method is that it is quick and
convenient. You have access to the features normally available in the editor (but not neces-
sarily to all of the features available elsewhere in Flare).
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TO OPEN THE FILE IN FLARE

a. In the window pane, click on the file.

b. Select File > Send to Flare.

The benefit of using this method is that you have access to all of the features in the applic-
ation, not just those available from the editor.
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CHAPTER 4

Viewing Files Without File Tags
You can view a list of all content files in the project that do not have file tags. Then you can open the
properties for a file and associate one or more file tags with it.

For more information about file tags and how they are used in projects, see the online Help in Flare.
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HOW TO VIEW FILES THAT DO NOT HAVE FILE TAGS

1. Open a project.

2. Do one of the following:

n Ribbon Select the View ribbon. In the Dynamic Reports section, select More Reports >
Files Without File Tags.

n Analyzer Summary Window Pane Double-click the row that mentions files without file
tags.

The Files Without File Tags window pane opens, listing all content files that do not have file
tags associated with them.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider:

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You also have the option to view all items at once in one long list. This is called the View All
option. You can toggle these views by clicking the View All/View as Pages button in the local
toolbar. The button displays the opposite of whatever view is currently activated (e.g., If the
View All option is currently active, the button shows View as Pages to indicate that if clicked,
the button will switch the window pane to the View as Pages option).

5. You can open a file and associate file tags with it. You can open the file in the Analyzer inter-
face or in the Flare project.

TO OPEN THE FILE IN THE ANALYZER INTERFACE

Double-click the file in the window pane. The benefit of using this method is that it is quick and
convenient. You have access to the features normally available in the editor (but not neces-
sarily to all of the features available elsewhere in Flare).
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TO OPEN THE FILE IN FLARE

a. In the window pane, click on the file.

b. Select File > Send to Flare.

The benefit of using this method is that you have access to all of the features in the applic-
ation, not just those available from the editor.

6. Once the file is open, select File > Properties. In the Properties dialog, you can use the File
Tags tab to associate file tags.
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APPENDIX

PDFs
The following PDFs are available for download from the online Help.

Concepts Guide Statistics & Charts Guide

Condition Tags Guide Styles Guide

Context-sensitive Help Guide Suggestions Guide

File Tags Guide Tables of Contents Guide

Frequent Segments Guide Topics Guide

Getting Started Guide Touring the Workspace Guide

Index Guide Track Changes Guide

Key Features Guide Undefined Items Guide

Links Guide Unused Items Guide

Reports Guide Variables Guide

Shortcuts Guide What's New Guide

Snippets Guide
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