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CHAPTER 1

Introduction
Analyzer lets you view lists of segments that occur frequently throughout your project. Why is this
important? It's important because by viewing repeated information in your project, you can convert
that text to reusable content (snippets or variables), thereby taking advantage of single-sourcing.

For each frequent segment shown, the following information is displayed.

n Segment Displays the segment that occurs multiple times throughout your project.

n Count Displays the number of times a particular segment occurs throughout your project.

n Word Count Displays the number of words contained in a particular segment.

n Character Count Displays the number of characters contained in a particular segment.

In addition, you can view a list of segments of text in your project that are similar, but not identical,
to each other. You may want to modify similar segments so that they become identical to each
other, or even convert them to snippets. You can also use the "Start Search" button to limit or
expand the list of similar segments that are displayed. See "Viewing Similar Segments" on page 17.
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Tasks Associated with Frequent Segments
You can do the following with frequent segments:

n View You can view a list of segments that occur frequently in your project. For more inform-
ation see "Viewing Frequent Segments" on page 7. You can also see segments that are similar
to each other. See "Viewing Similar Segments" on page 17.

n Customize Segments Shown If you want to limit or expand the list of the frequent segments
that are displayed, you can easily do so by setting the minimum and maximum word counts,
as well as the minimum number of occurrences. See "Frequent Segments Shown" on page
10.

n Convert to Snippets or Variables If you notice that certain segments are repeated numerous
times in your project, you can easily convert them to snippets or variables. See "Converting
Segments to Snippets" on page 11 and "Converting Segments to Variables" on page 14.
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CHAPTER 2

Viewing Frequent Segments
You can view a list of segments that occur frequently in your project. You can see the segment text,
the number of occurrences of each segment, and the number of words and characters in each seg-
ment.

CHAPTER 2  7



HOW TO VIEW FREQUENT SEGMENTS

1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select the View ribbon. In the Dynamic Reports section, select Suggestions >
Frequent Segments.

n Analyzer Summary Window Pane If you have the Analyzer Summary window pane in
view, double-click the row that mentions frequent segements.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider:

n Segment Displays the segment that occurs multiple times throughout your project.

n Count Displays the number of times a particular segment occurs throughout your pro-
ject.

n Word Count Displays the number of words contained in a particular segment.

n Character Count Displays the number of characters contained in a particular segment.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You also have the option to view all items at once in one long list. This is called the View All
option. You can toggle these views by clicking the View All/View as Pages button in the local
toolbar. The button displays the opposite of whatever view is currently activated (e.g., If the
View All option is currently active, the button shows View as Pages to indicate that if clicked,
the button will switch the window pane to the View as Pages option).
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NOTE: You can use the Topics For Selected window pane to view the topics where a par-
ticular segment is located. See "Viewing Topics for a Selected Item" on page 20.
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CHAPTER 3

Frequent Segments Shown
If you want to limit or expand the list of frequent segments that are displayed, you can easily do so
by setting the minimum and maximum word counts, as well as the minimum number of occur-
rences.

HOW TO CUSTOMIZE WHICH SEGMENTS ARE SHOWN IN THE WINDOW PANE

1. View the frequent segments. See "Viewing Frequent Segments" on page 7.

2. In the local toolbar of the Frequent Segments window pane, click Search Properties.The Fre-
quent Segment Search Properties dialog opens.

3. Adjust any of the fields in the dialog.

n Min Word Count Use this field to set the minimum number of words that must be con-
tained in a segment in order for it to be displayed in the Frequent Segments window
pane.

n Max Word Count Use this field to set the maximum number of words that can be con-
tained in a segment in order for it to be displayed in the Frequent Segments window
pane. The highest number you can enter is 30. If you want to convert content con-
taining more than 30 words to snippets, you can use Analyzer to find multiple instances
of partial content. Then you need to open Flare and manually replace the large chunks
of content with snippets.

n Min Segment Count Use this field to set the minimum number of times that a segment
must occur throughout a project in order for it to be displayed in the Frequent Seg-
ments window pane.

4. Click OK.
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CHAPTER 4

Converting Segments to
Snippets
You can view a list of segments that occur frequently in your project. You can see the segment text,
the number of occurrences of each segment, and the number of words and characters in each
segment. If you notice that certain segments are repeated numerous times in your project, you can
easily convert them to snippets.
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HOW TO CONVERT A FREQUENT SEGMENT TO A SNIPPET

1. Open the Frequent Segments window pane.

2. Select the segment that you want to convert to a snippet.

3. In the local toolbar, click the Create drop-down button and select Create Snippet. The Create
Snippet dialog opens.

4. In the Snippet File field, type a new name for the snippet.

It is recommended that you leave the project folder selection as "Resources/Snippets" (or
select a subfolder that you have created in the Snippets folder). After the snippet is created,
you can see the snippet file in the Content Explorer of the Flare project.

5. Click Create. The snippet is created and added to the Flare project that you are analyzing.

6. Open the Snippet Suggestions window pane.

7. Do one of the following, depending on whether you want to convert multiple suggestions sim-
ultaneously, or if you want to convert only one snippet suggestion at a time.

TO CONVERT MULTIPLE SUGGESTIONS SIMULTANEOUSLY

a. In the window pane, select all suggestions that you want to convert. If you want to

select all rows click . You can hold the SHIFT key to select a range, or you can hold
the CTRL key to select individual items.

b. In the local toolbar, click the Apply button.

c. In the message that opens, click OK. Another message lets you know how many files
were changed.

d. Click OK. All of the selected suggestions are converted to snippets.

NOTE: If you want to undo the conversions, you can use the Backups window
pane (View > Backups).

TO CONVERT ONE SUGGESTION AT A TIME

a. In the Snippet Suggestions window pane, select the row that you want to convert to a
snippet.
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b. Select File > Send to Flare. The file opens in the application with the suggested content
highlighted.

c. In Flare, insert the snippet (e.g., select Insert > Snippet).

See the online Help in Flare for more information about inserting snippets.

CHAPTER 4  13



CHAPTER 5

Converting Segments to
Variables
You can view a list of segments that occur frequently in your project. You can see the segment text,
the number of occurrences of each segment, and the number of words and characters in each
segment. If you notice that certain segments are repeated numerous times in your project, you can
easily convert them to variables.
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HOW TO CONVERT A FREQUENT SEGMENT TO A VARIABLE

1. Open the Frequent Segments window pane.

2. Select the segment that you want to convert to a variable.

3. In the local toolbar, click the Create drop-down button and select Create Variable. The Create
Variable dialog opens.

4. In the Variable Name field, type a new name for the variable.

5. Click in the Variable Set field and select an existing variable set.

6. Click Create. The variable is created and added to the Flare project that you are analyzing.

7. Open the Variable Suggestions window pane.

8. Do one of the following, depending on whether you want to convert multiple suggestions to a
variable simultaneously, or if you want to convert only one variable suggestion at a time.

TO CONVERT MULTIPLE SUGGESTIONS SIMULTANEOUSLY

a. In the window pane, select all suggestions that you want to convert. If you want to

select all rows click . You can hold the SHIFT key to select a range, or you can hold
the CTRL key to select individual items.

b. In the local toolbar, click the Apply button.

c. In the message that opens, click OK. Another message lets you know how many files
were changed.

d. Click OK. All of the selected suggestions are converted to variables.

NOTE: If you want to undo the conversions, you can use the Backups window
pane (View > Backups).

TO CONVERT ONE SUGGESTION AT A TIME

a. In the Variable Suggestions window pane, select the row that you want to convert to a
variable.

b. Select File > Send to Flare. The file opens in the application with the suggested content
highlighted.
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c. In Flare, insert the variable (e.g., select Insert > Variable).

See the online Help in Flare for more information about inserting variables.
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CHAPTER 6

Viewing Similar Segments
You can view a list of segments of text in your project that are similar, but not identical, to each
other. You may want to modify similar segments so that they become identical to each other, or
even convert them to snippets. You can also use the "Start Search" button to limit or expand the list
of similar segments that are displayed.

The Similar Segments window pane displays similar segments in pairs. In other words, one row dis-
plays a segment of text in one column, with a similar segment in the next column. If you double-click
the row, the file containing the first segment opens. In the row directly beneath the first, the same
segments are shown, only in reverse order. If you double-click that row, the file containing the other
segment opens.
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HOW TO VIEW SIMILAR SEGMENTS

1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select the View ribbon. In the Dynamic Reports section, select Suggestions > Sim-
ilar Segments.

n Analyzer Summary Window Pane Double-click the row that mentions similar segments.

The Similar Segments window pane opens.

3. In the local toolbar, click the Start Search button. (Even if you do not want to change the
search properties, you need to click this button to initiate a new search for similar segments.)
The Similar Segments Search Properties dialog opens.

4. You can modify any of the search property settings to limit or expand the list of similar seg-
ments shown in the list.

n Min Word Count Use this field to set the minimum number of words that must be con-
tained in a segment in order for it to be displayed in the Similar Segments window pane.
The highest number you can enter is 1000.

n Max Word Count Use this field to set the maximum number of words that can be con-
tained in a segment in order for it to be displayed in the Similar Segments window pane.
The highest number you can enter is 1000.

n Max "Edit Distance" Use this field to set the maximum amount of difference that can
exist between segments in order for them to be displayed in the Similar Segments win-
dow. The value has to do with the number of characters that are different between the
two segments. The smaller the number, the more alike the segments are. The larger the
number, the greater the difference that exists between the segments. You can modify
this value to limit or increase the number of segments displayed in the window. The
highest number you can enter is 10000.

5. Click OK. The window pane populates with similar segments found in the project.
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6. To see more of the information in the window pane, drag the divider bar to make the pane
wider:

n Pair Index Displays the number that identifies a pair of segments. Segments are always
compared in pairs. The first row displays the "primary" segment (in the "Segment 1"
column), and it displays a segment that is similar to it in the "Segment2" column. In the
other row, the segments are reversed, with the second segment displayed in the "Seg-
ment1" column.

n Segment1 Displays the "primary" segment in the row. If you double-click the row, the
topic containing the segment in the "Segment1" column opens.

n Segment2 Displays the secondary segment (i.e., the segment that is similar to the one
displayed in the "Segment1" column).

n Edit Distance Displays the numerical value that indicates how much difference exists
between the segments (see the "Max Edit Distance" option mentioned above).

n File Displays the file where the segment of text is found.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

7. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You also have the option to view all items at once in one long list. This is called the View All
option. You can toggle these views by clicking the View All/View as Pages button in the local
toolbar. The button displays the opposite of whatever view is currently activated (e.g., If the
View All option is currently active, the button shows View as Pages to indicate that if clicked,
the button will switch the window pane to the View as Pages option).

NOTE: You can use the Topics For Selected window pane to view the topics where a par-
ticular segment is located. See "Viewing Topics for a Selected Item" on page 20.
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CHAPTER 7

Viewing Topics for a Selected
Item
You can view a list of topics associated with a segment (as selected in the Frequent Segments win-
dow pane or Similar Segments window pane). This is simply a quick way to open a file where a par-
ticular segment exists.
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HOW TO VIEW TOPICS FOR A SELECTED ITEM

1. Open a project.

2. Select the View ribbon. In the Analysis section select Topics For Selected. The Topics For
Selected window pane opens (by default on the right side of the interface).

3. Do one of the following, depending on the part of the user interface you are using and the type
of segments.

FREQUENT SEGMENTS

n Ribbon Select the View ribbon. In the Dynamic Reports section, select Suggestions > Fre-
quent Segments.

n Tool Strip Select View > Suggestions > Frequent Segments.

The Frequent Segments window pane opens, displaying segments that occur a certain num-
ber of times throughout your project.

SIMILAR SEGMENTS

n Ribbon Select the View ribbon. In the Dynamic Reports section, select Suggestions > Sim-
ilar Segments.

n Tool Strip Select View > Suggestions > Similar Segments.

The Similar Segments window pane opens, displaying segments that are similar in your pro-
ject. (You need to click the Start Search button in the local toolbar to initiate a search of sim-
ilar segments.)

4. In the window pane, select a row. The Topics For Selected window pane lists all of the topics
where the frequent segment is found.

5. To see more of the information in the window pane, drag the divider bar to make the pane
wider:

n File Displays the name of the file where the segment occurs.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

n Extension Displays the extension of the file (e.g., .htm).
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6. You can open any file in the list to view or modify it in an editor. You can open the file in the
Analyzer interface or in the Flare project.

TO OPEN THE FILE IN THE ANALYZER INTERFACE

Double-click the file in the window pane. The benefit of using this method is that it is quick and
convenient. You have access to the features normally available in the editor (but not neces-
sarily to all of the features available elsewhere in Flare).

TO OPEN THE FILE IN FLARE

a. In the window pane, click on the file.

b. Select File > Send to Flare.

The benefit of using this method is that you have access to all of the features in the applic-
ation, not just those available from the editor.
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