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CHAPTER 1

Get Started
See the following for basic information about how to get started with Analyzer:

n "Enabling Analyzer Scans" on page 6

n "Opening Projects" on page 9

n "Viewing Current Issues" on page 11

n "Viewing Issues for Specific Files" on page 16

n "Reports" on page 20

Getting Additional Help
You can use any of the following resources for additional help not provided in this manual.

Knowledge Base
You can browse the online Knowledge Base for articles covering common support issues.

http://kb.madcapsoftware.com/

Peer-to-Peer Online Forums
You can visit the online forums to learn from other users or share your own expertise.

http://forums.madcapsoftware.com/
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Contact Analyzer Support
You can contact the Analyzer support team and get answers to your specific support issues.

http://madcapsoftware.com/support/
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CHAPTER 2

Enabling Analyzer Scans
You can enable or disable the collection of different types of information when Analyzer scans a pro-
ject for possible issues and problems. Also, by disabling scans, you may find that your system per-
formance is improved somewhat. In addition to disabling scans, you can limit the number of results
returned.

HOW TO ENABLE ANALYZER SCANS

1. Open Analyzer, but do not open a project yet.

2. Select File > Options. The Options dialog opens.

3. Select the Analyzer tab.

4. Enable or disable any of the following:

n Collect Segments Select this check box if you want Analyzer to collect segments of text
while scanning your project. Segment collection allows you to view information about
your project such as frequent segments found and index keyword suggestions.

n Collect Variable Prospects Select this check box if you want Analyzer to look for text that
you might want to convert to variables.

n Collect Snippet Prospects Select this check box if you want Analyzer to look for text that
you might want to convert to snippets.

n Collect Local Style Prospects Select this check box if you want Analyzer to look for
places where you have applied local formatting and might want to apply styles to those
areas instead.

CHAPTER 2  6



n Collect Embedded Stylesheet Prospects Select this check box if you want Analyzer to
look for style information (embedded styles in <style> elements) in your topic files. Dis-
abling this scan limits the results found in the style reports.

NOTE: You should select this option if you have imported topics that have
embedded styles. Otherwise, it is not usually necessary to select this option.

n Collect Accessibility Prospects Select this check box if you want Analyzer to look for text
where you might want to add web accessibility features (e.g., captions, alternate text).

n Collect Markup Prospects Select this check box if you want Analyzer to look for a variety
of XHTML markup issues in your content (e.g., extra spaces, empty attributes). You can
open the affected files and clean up the markup in them. You may be able to fix some
issues in the XML Editor, but other issues may require you to open the behind-the-scenes
code in the Internal Text Editor.

NOTE: In order for these options to be effective, you must set the options before
opening your project. If you have your project open and a scan is in process, setting
these options will not improve your system performance.

5. You can click in the Search Limits field to limit the number of results returned from some Ana-
lyzer reports. You can limit the search results to 100, 500, 1000, or 5000. If All is selected,
there are no limitations for the search results. You might want to use this new feature to
improve performance.

When a limit is selected, it is applied to the following window panes and reports:

n Index Keyword Suggestions

n New Style Suggestions

n Replace Local Style Suggestions

n Undefined Styles
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6. Click OK.
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CHAPTER 3

Opening Projects
There are two ways to open an existing project in Analyzer. You can use interface options or drag
files from Windows Explorer.

HOW TO OPEN A PROJECT USING INTERFACE OPTIONS

Do one of the following, depending on the part of the user interface you are using:

n Start Page On the left side of the Start Page, click Open. You can also click a recently opened
project and other files. If you do not see the Start Page, select View > Start Page.

n Ribbon Select File > Open. The Open dialog displays. The Flare project file extension (.flprj)
appears in the File Type field. In the Open dialog navigate to the project you want, select it,
and click Open.

n Keyboard Shortcut Press CTRL+O. The Open dialog displays. The Flare project file extension
(.flprj) appears in the File Type field. In the Open dialog navigate to the project you want,
select it, and click Open.

HOW TO OPEN A PROJECT BY DRAGGING A FILE FROM WINDOWS EXPLORER

1. Open Windows and navigate to a folder containing a project file.

2. Launch Analyzer.

3. Drag the project file from Windows to the application window and drop it on the title bar in Ana-
lyzer.
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NOTE: You can also use this method to open any file type that is supported in Ana-
lyzer.
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CHAPTER 4

Viewing Current Issues
After opening a Flare project in MadCap Analyzer, the project is immediately scanned for possible
issues, which are then listed in the Analyzer Summary window pane. From the Analyzer Summary
window pane, you can double-click any of the issue rows. Doing this opens the appropriate window
pane in the interface so that you can see more information about the reported issues and take
action (e.g., fix broken links).

CHAPTER 4  11



HOW TO VIEW CURRENT ISSUES

1. Open a project. When you do this, the Analyzer Summary window pane opens automatically,
listing any issues in your project. You can also perform a manual scan of the project by click-

ing in the local toolbar.

This window pane displays the kind of issue that has been uncovered. It might be a "critical"
issue displayed in a red font (such as a broken link or undefined style) that you should fix as
soon as possible. Otherwise, it might be an "informative" issue (such as a suggestion for a new
style), which might be a good change to consider, but not necessarily urgent.

2. Double-click any row to open the appropriate window pane to deal with the issue.

For example, if you double-click the broken links row, the Broken Links window pane opens. If
you double-click the new style suggestions row, the New Style Suggestions window pane
opens.

Following are the main tasks that you can perform when dealing with current issues. For more
information and steps about each of these, see the online Help or the relevant PDF guide.
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LINKS

n Absolute links—viewing and fixing

n Broken bookmarks—viewing and fixing

n Broken links—viewing and fixing

n External links—viewing and checking

n Incoming and outgoing links—viewing

n Named destinations—viewing

n Topics not linked—viewing

SNIPPETS

n Suggestions—viewing and converting

n Files with snippet conditions—viewing

VARIABLES

n Suggestions—viewing and converting

n Undefined variables—viewing and fixing

n Unused variables—viewing

n Used variables—viewing and renaming

SEGMENTS

n Frequent segments—viewing, customizing, and converting to snippets or variables

n Similar segments—viewing

n Topics for a selected item—viewing

STYLES

n Duplicate styles—viewing

n Local style suggestions—viewing and replacing

n New style suggestions—viewing and converting
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n Undefined styles—viewing and fixing

n Unused styles—viewing

TOCS

n Duplicate items in TOC—viewing

n Topics not in TOC—viewing

INDEXES

n Links—viewing and renaming

n Suggestions—viewing and adding

n Topics not indexed—viewing

n Used index keywords—viewing and renaming

CONDITION TAGS

n Undefined condition tags—viewing and fixing

n Unused condition tags—viewing

n Used condition tags—viewing and renaming

FILE TAGS

n Undefined file tags—viewing and fixing

n Unused file tags—viewing

n Used file tags—viewing and renaming

OTHER FEATURES

n Annotations and tracked changes—viewing

n Concepts (used)—viewing and renaming

n Concepts within concept links—viewing and renaming

n Content files (unused)—viewing

n Cross-reference suggestions—viewing and converting

n CSH IDs (unused)—viewing
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n Empty content folders—viewing

n Glossary term links (undefined)—viewing and fixing

n Images (unused)—viewing

n Language tags (used)—viewing

n Markup suggestions—viewing

n Non-XML topics—viewing and converting

n Topics not linked by map ID—viewing

n Writing suggestions—viewing
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CHAPTER 5

Viewing Issues for Specific
Files
Using the File Issues Viewer, you can see any issues associated with specific topics in the Flare pro-
ject you are analyzing. You can also view issues associated with specific targets in the Flare project.
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HOW TO VIEW ISSUES FOR SPECIFIC FILES

1. Open a project.

2. Do one of the following:

TO ADD MANY FILES TO THE FILE ISSUES VIEWER

a. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select the View ribbon. In the Analysis section, select File List.

n Keyboard Shortcut Press CTRL+SHIFT+J.

The File List window pane opens.

b. In the File List window pane select the files you want to view. You can hold the SHIFT key
to select a range, or you can hold the CTRL key to select individual items.

c. Once the files are selected, do one of the following.

n Local Toolbar Click .

n Right-Click Right-click any of the selected files and from the context menu, select
Send to File Issues Viewer.

The File Issues window pane opens with all the selected files listed in the Files field.
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TO ADD ONE FILE AT A TIME TO THE FILE ISSUES VIEWER

a. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select the View ribbon. In the Analysis section, select File Issues.

n Local Toolbar Click .

The File Issues Viewer window pane opens.

b. Do one of the following:

n Local Toolbar Click .

n Right-Click Right-click in the list area at the top of the Viewer and select Add.

NOTE: Files cannot be added or removed unless the By Target field is specified
as “(Selected Files)”.

c. In the dialog that opens, find and select the content file(s) you want to add to the Viewer.
Then click Open. You can use the buttons in the local toolbar to view all files in a list, view
files in their folder structure, etc.

Shows or hides the folders that the files are stored in.

Shows or hides the files. If you click this button when the Show Folders button
is selected, the area splits into two halves. The folder is shown on the left

side, and the files and subfolders within it are shown on the right.

Shows or hides hidden files and folders.

If the Show Files button is the only one selected, you can click this button
to move up one folder level.

The bottom of the Viewer shows the types of issues found for the file(s) in the viewer, and
how many.
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3. Double-click any row at the bottom of the Viewer to open the appropriate window pane to deal
with the issue.

HOW TO VIEW ISSUES FOR SPECIFIC TARGETS

1. Open a project.

2. Select the View ribbon. In the Analysis section, select File Issues.

The File Issues Viewer opens.

3. From the By Target field, select the target for which you want to view issues.

The bottom of the Viewer shows the types of issues found for the file(s) in the target, and how
many.

4. Double-click any row at the bottom of the Viewer to open the appropriate window pane to deal
with the issue.

NOTE: Files cannot be added or removed unless the By Target field is specified as “(Selec-
ted Files)”.
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CHAPTER 6

Reports
In Analyzer you can generate custom reports based on the information contained in your project, for
just about any type of information that MadCap Analyzer captures. In addition, you can design the
look and feel of reports, save them for future access, and open them in a browser window (where
you can print them). 

You can easily create a report based on the information captured in Analyzer. When doing this, you
can provide a name for the report and select the types of information that you want to include in it.
Another option is to immediately print the report after it is generated. You can also design the look
and feel of the report, and then compile it so that it displays the selected data in the format you
provide.

HOW TO GENERATE A REPORT

1. Open a project.

2. Select View > Reports. The Reports window pane opens.

3. In the local toolbar, click . The Add Report dialog opens.

4. In the File Name field, type a new name for the report file.

5. Click Add.

6. Click OK. The report file is added to the Project\Reports folder where the project is located.
The Report Editor opens.

7. Select the General tab.

8. In the Title field, enter a title for the report you want to generate.
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9. In the Tables section, click in the check boxes next to any information that you want to
include in the report. Some items appear in multiple categories. Click the appropriate Select
All check box to choose all items in a category.
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10. (Optional) Select Skip empty reports if you want to see only reports that contain information.

EXAMPLE

Let's say you are generating a report and have selected ten different types of
information to include. Perhaps one of those types of information—"Unused
Condition Tags"—will not return any results because all of your condition tags
have been used somewhere. However, the other nine types of information do
have data to report.

If you select the "skip" option, the generated report will include nine sections, one
for each type of information containing data. You will not see a section in the gen-
erated report for "unused condition tags."

If you do not select the "skip" option, you will see ten sections in the generated
result. Nine of those sections will show data, and the tenth (for "unused condition
tags") will simply mention that no data exists.

11. (Optional) Select Print report after generation if you want to print a report immediately after
you generate it. If this option is selected, the Print dialog opens as soon as a report is finished
generating.

12. (Optional) If you want to modify the look of the report, use the following steps.

a. Select the Styles tab.

b. Select the style item that you want to modify (e.g., ReportEntry, ReportHeading,
ReportText). You can select a basic style node, or you can expand the node and select
an option under it.

n ReportEntry This affects the individual lines of data in a report, displaying the
information you selected when generating the report. You can add borders, pad-
ding, and margins to those entries. Depending on the depth of the information in
the report, the data may display on one of three levels. You can expand the style
item and use the Level1, Level2, and Level 3 options to specify settings for each
level.

n ReportGroup This affects the chunks or groups of data in a report, displaying the
information you selected when generating the report. You can add borders, pad-
ding, and margins to those entries.
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n ReportHeading This affects the individual headings that display in the report, based
on the types of information that you selected when generating the report. For
example, if you select four different types of data for the report (e.g., Absolute
Links, Broken Links, External Links, Snippet Suggestions), you will see a different
heading for each of those. You can change the heading label, as well as font, bor-
der, padding, and margin settings.

n ReportPrefix This affects the prefix text that is displayed before the individual lines
of data in a report so that you know what you are looking at in an entry (e.g., File,
Condition Tag, Link, Bookmark). You can change the font settings for those pre-
fixes. Depending on the depth of the information in the report, the data may display
on one of three levels. You can expand the style item and use the Level1, Level2,
and Level 3 options to specify settings for each level.

n ReportSection This affects the entire section where a type of information is dis-
played in a report. For example, if you selected to view absolute links and external
links in a report, you can modify the section for each, to change the look of the area
where the heading and individual entries are shown. You can add borders, padding,
and margins to those sections. You can also specify that a page break should be
inserted before or after the heading in a report.

n ReportText This affects the text of the individual lines of data in a report. You can
change the font settings for the text. Depending on the depth of the information in
the report, the data may display on one of three levels. You can expand the style
item and use the Level1, Level2, and Level 3 options to specify settings for each
level.

c. Select the Property Groups or Alphabetical List option to display the properties for the
style item.

d. In the Properties section, set the values for the properties that you want modify.

13. Click to save your work.

14. Select the General tab.

15. In the Report section, click the Generate button. The report is generated and displays below.
If you change the options and click Generate again, the report will be replaced with a new one.
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APPENDIX

PDFs
The following PDFs are available for download from the online Help.

Concepts Guide Statistics & Charts Guide

Condition Tags Guide Styles Guide

Context-sensitive Help Guide Suggestions Guide

File Tags Guide Tables of Contents Guide

Frequent Segments Guide Topics Guide

Getting Started Guide Touring the Workspace Guide

Index Guide Track Changes Guide

Key Features Guide Undefined Items Guide

Links Guide Unused Items Guide

Reports Guide Variables Guide

Shortcuts Guide What's New Guide

Snippets Guide
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