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CHAPTER 1

Viewing Used Condition Tags
You can view a list of all condition tags that have been applied in files throughout your project. The
list shows not only the condition tags, but each file where they have been used. You can also quickly
rename or remove multiple condition tag occurrences in a single batch.

For more information about condition tags and how they are used in projects, see the online Help in
Flare.
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HOW TO VIEW USED CONDITION TAGS

1. Open a project.

2. Select the View ribbon. In the Dynamic Reports section, select Used Items > Used Condition
Tags.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider:

n Condition Tag Displays the name of the condition tag set and the tag within it. The con-
dition tag set is listed first, followed by a period and then the name of the condition tag
(e.g., Primary.Print).

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

n Tag Displays the tag being used by the condition tagvariable.

n Exclude Action Displays the kind of "exclude" action tied to the condition tag. In most
cases, the exclude action is "remove." However, in some instances, this action might be
"unbind." For example, you might have the unbind action for a condition tag if you have
applied the tag to a hyperlink and want the link to be removed from the text in some out-
puts, but you still want the text to be shown in those outputs.
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4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You also have the option to view all items at once in one long list. This is called the View All
option. You can toggle these views by clicking the View All/View as Pages button in the local
toolbar. The button displays the opposite of whatever view is currently activated (e.g., If the
View All option is currently active, the button shows View as Pages to indicate that if clicked,
the button will switch the window pane to the View as Pages option).

5. You can open any file in the list to view or modify it in an editor. You can open the file in the
Analyzer interface or in the Flare project.

TO OPEN THE FILE IN THE ANALYZER INTERFACE

Double-click the file in the window pane. The benefit of using this method is that it is quick and
convenient. You have access to the features normally available in the editor (but not neces-
sarily to all of the features available elsewhere in Flare).

TO OPEN THE FILE IN FLARE

a. In the window pane, click on the file.

b. Select File > Send to Flare.

The benefit of using this method is that you have access to all of the features in the applic-
ation, not just those available from the editor.
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HOW TO RENAME CONDITION TAGS

1. In the window pane, select all of the condition tags that you want to rename. If you want to

select all rows click . You can hold the SHIFT key to select a range, or you can hold the
CTRL key to select individual items.

NOTE: All condition tags that you select will be renamed to the same condition tag
that you provide in the following steps.

2. In the local toolbar, click the Rename button. The Rename Condition tag(s) dialog opens.

3. In the New condition tag name field, enter a new name.

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected con-
dition tags are renamed.

NOTE: If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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CHAPTER 2

Viewing Undefined Condition
Tags
You can view a list of all files where you have condition tags in the content, but those condition tags
have not been defined. This might occur, for example, if you have applied a condition tag in a topic
and then later change the name of the tag or condition tag set. The old tag or set name is still used
at the location where it was previously applied in the topic. Therefore, a problem exists. From the
Undefined Condition Tags window pane, you can open the file in question and fix the undefined con-
dition tag. You can also quickly rename or remove multiple condition tag occurrences in a single
batch, add the undefined tag to the project, or map the undefined tag to an existing condition tag.
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HOW TO VIEW UNDEFINED CONDITION TAGS

1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select the View ribbon. In the Dynamic Reports section, select Undefined Items
> Undefined Condition Tags.

n Analyzer Summary Window Pane Double-click the row that mentions undefined con-
dition tags.

The Undefined Condition Tags window pane opens, displaying a list of undefined condition
tags.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider:

n Condition Tag Displays the name of the condition tag set and the tag within it. The con-
dition tag set is listed first, followed by a period and then the name of the condition tag
(e.g., Primary.Print).

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

n Tag Displays the tag being used by the condition tag.

n Exclude Action Displays the kind of "exclude" action tied to the condition tag. In most
cases, the exclude action is "remove." However, in some instances, this action might be
"unbind." For example, you might have the unbind action for a condition tag if you have
applied the tag to a hyperlink and want the link to be removed from the text in some out-
puts, but you still want the text to be shown in those outputs.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You also have the option to view all items at once in one long list. This is called the View All
option. You can toggle these views by clicking the View All/View as Pages button in the local
toolbar. The button displays the opposite of whatever view is currently activated (e.g., If the
View All option is currently active, the button shows View as Pages to indicate that if clicked,
the button will switch the window pane to the View as Pages option).
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HOW TO FIX UNDEFINED CONDITION TAGS

There are a few different ways to fix an undefined condition tag: (1) You can rename the condition
tag or condition tag set so that it matches what you have used in the topic; (2) you can reapply the
condition tag in the topic so that it uses an existing condition tag set/condition tag; (3) you can add
the undefined condition tag to the project as a new condition tag; and (4) you can map the
undefined condition tag to an existing condition tag.

TO RENAME CONDITION TAGS

1. In the window pane, select all condition tag occurrences that you want to rename. If you want

to select all rows click . You can hold the SHIFT key to select a range, or you can hold the
CTRL key to select individual items.

NOTE: All condition tag occurrences that you select will be renamed to the same con-
dition tag that you provide in the following steps.

2. In the local toolbar, click the Rename button. The Rename Condition Tag(s) dialog opens.

3. In the New condition tag name field, enter a new condition tag. Type the name of the con-
dition tag set, followed by a period, then the name of the condition tag (e.g., Primary.Print).

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected con-
dition tag occurrences are renamed.

NOTE: If you want to undo the conversions, you can use the Backups window pane
(View > Backups).

CHAPTER 2  10



TO REAPPLY CONDITION TAGS

1. Do one of the following, depending on whether you want to open the file in the Analyzer inter-
face or within Flare.

TO OPEN THE FILE IN THE ANALYZER INTERFACE

Double-click the file in the window pane. The benefit of using this method is that it is quick and
convenient. You have access to the features normally available in the editor (but not neces-
sarily to all of the features available elsewhere in Flare).

TO OPEN THE FILE IN FLARE

a. In the window pane, click on the file.

b. Select File > Send to Flare.

The benefit of using this method is that you have access to all of the features in the applic-
ation, not just those available from the editor.

2. Reapply the condition tag to the content, selecting an existing name from a condition tag set.
See the online Help in Flare for more information about applying condition tags to content.
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TO ADD A NEW CONDITION TAG

1. In the window pane, select all condition tag occurrences that you want to add to the project. If

you want to select all rows click . You can hold the SHIFT key to select a range, or you can
hold the CTRL key to select individual items.

2. Do one of the following, depending on the part of the user interface you are using:

n Local Toolbar Click .

n Right-Click Right-click on the condition tag you want to add and from the context menu
select Add New Condition Tag.

The Condition Tag Set Editor opens, with the new condition tag(s) displayed.

NOTE: When you create a new condition tag, one of two things will happen:

1. If the Condition Tag Set file specified exists in the project, Analyzer will add the
new condition tag to the existing file.

2. If the Condition Tag Set file specified does not exist in the project, Analyzer will
create a brand new Condition Tag Set file and add the new condition tag to that
file.

3. (Optional) In the Condition Tag Set Editor, edit the condition tag's properties (e.g., name,
color, comment).

4. Click to save your work.
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TO MAP TO AN EXISTING CONDITION TAG

1. In the window pane, select all condition tag occurrences that you want to map to an existing

condition tag. If you want to select all rows click . You can hold the SHIFT key to select a
range, or you can hold the CTRL key to select individual items.

2. Do one of the following, depending on the part of the user interface you are using:

n Local Toolbar Click .

n Right-Click Right-click on the condition tag you want to add and from the context menu
select Map to Existing Condition Tag.

The Condition Tags dialog opens.

3. In the dialog, select the existing condition tag in the project to overwrite the current undefined
condition tag reference.

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected con-
dition tag occurrences are overwritten with the new condition tag.

NOTE: If you want to undo the conversions, you can use the Backups window pane
(View > Backups).

6. Click to save your work.

NOTE: Another way to apply a different condition tag to many places throughout a project
is to use the Find and Replace in Files feature in Flare. For example, let's say that you ori-
ginally applied a condition tag named "Print" (from the "Primary" condition tag set) to a lot of
content in your project. Later, you renamed the condition tag "PDF." You can perform a find
and replace in your entire project. In the "Find" field, you can enter Primary.Print, and in
the "Replace with" field, you can enter Primary.PDF. Also, make sure you select the "Find
in source code" option in the Find and Replace in Files window pane. After replacing this text
throughout your project, that condition tag will no longer be considered "undefined" in Ana-
lyzer. For information about using the Find and Replace in Files feature, see the online Help
in Flare.
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CHAPTER 3

Viewing Unused Condition Tags
You can view a list of all condition tags that have been created in your project but have not yet been
used in any topics or other files. You can quickly delete any of the condition tags that you do not
plan to use. For more information about condition tags and how they are used in projects, see the
online Help in Flare.
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HOW TO VIEW UNUSED CONDITION TAGS

1. Open a project.

2. Select the View ribbon. In the Dynamic Reports section, select More Reports > Unused Items.

The Unused Items window pane opens, which allows you to view various unused elements in
the project (such as bookmarks, condition tags, content files, CSH IDs, images, variables,
styles, file tags, and topics not linked).

3. Click the drop-down field at the top of the window pane and select Unused Condition Tags.
The unused condition tags in the project are listed.

4. To see more of the information in the window pane, drag the divider bar to make the pane
wider:

n Condition Tag Displays the name of the condition tag not being used.

n File Displays the name of the condition tag set file where the condition tag is located.

5. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You also have the option to view all items at once in one long list. This is called the View All
option. You can toggle these views by clicking the View All/View as Pages button in the local
toolbar. The button displays the opposite of whatever view is currently activated (e.g., If the
View All option is currently active, the button shows View as Pages to indicate that if clicked,
the button will switch the window pane to the View as Pages option).

6. If you want to remove any unused condition tags from Analyzer, as well as from the project

being analyzed, select the condition tag in the list and click in the local toolbar.

7. You can open the set file for any condition tag in the list to view or modify it in the Condition
Tag Set Editor. You can open the condition tag set in the Analyzer interface or in the Flare pro-
ject.

TO OPEN THE FILE IN THE ANALYZER INTERFACE

Double-click the file in the window pane. The benefit of using this method is that it is quick and
convenient. You have access to the features normally available in the editor (but not neces-
sarily to all of the features available elsewhere in Flare).
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TO OPEN THE FILE IN FLARE

a. In the window pane, click on the file.

b. Select File > Send to Flare.

The benefit of using this method is that you have access to all of the features in the applic-
ation, not just those available from the editor.

CHAPTER 3  16



APPENDIX

PDFs
The following PDFs are available for download from the online Help.

Concepts Guide Statistics & Charts Guide

Condition Tags Guide Styles Guide

Context-sensitive Help Guide Suggestions Guide

File Tags Guide Tables of Contents Guide

Frequent Segments Guide Topics Guide

Getting Started Guide Touring the Workspace Guide

Index Guide Track Changes Guide

Key Features Guide Undefined Items Guide

Links Guide Unused Items Guide

Reports Guide Variables Guide

Shortcuts Guide What's New Guide

Snippets Guide
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