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CHAPTER 1

Introduction
A snippet is an important file used for single-sourcing that acts sort of like a miniature topic. In a
snippet, you can insert and format text, tables, pictures, and whatever else can be included in a nor-
mal topic. We’re not usually talking about single words or phrases; that’s what variables are for. A
snippet can be inserted into one or more topics throughout your project. You can even insert them
into other snippets, creating nested snippets.

EXAMPLE

Let's say you are writing a manual about dogs. In one topic, you have created a colorful
table with images that lists the top five breeds. Let's say you want to place that same
table in seven other topics. You have a choice. (1) You can re-create that table manu-
ally in each of those topics. (2) You can copy the first table and paste it into the other
topics. This is a better solution, but if you need to make changes to the table in the
future, you'll need to do so in all eight topics. (3) You can create a snippet from the
table and insert it into each of the other topics. This is the best solution because, if you
need to make changes in the future, you only need to do so within the snippet and the
changes are automatically reflected in all eight topics.

For more information about snippets, see the Flare online Help.
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Following are Analyzer tasks associated with snippets.

n View and Convert Snippet Suggestions You can view content that matches existing snippets
in your project, and you can quickly convert these occurrences to snippets. You can also
double-click a row to open the topic in question, with the potential snippet content highlighted.
See "Viewing Snippet Suggestions" on page 6.

n Convert Frequent Segments to Snippets You can view a list of segments that occur fre-
quently in your project. You can see the segment text, the number of occurrences of each
segment, and the number of words and characters in each segment.

If you notice that certain segments are repeated numerous times in your project, you can eas-
ily convert them to snippets or variables. For more information see "Converting Segments to
Snippets" on page 10.

n View Topics With Snippet Conditions You can view a list of all files where snippet conditions
have been applied. You can also double-click a row to open the topic in question. See "Files
with Snippet Conditions" on page 13.

n Replace Existing Snippets with New Snippets After you create or add a new snippet to your
project, you can insert it into any of your topics. Later, if you decide that a different snippet is
a better fit for the topic, you can select a new snippet to replace it.
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CHAPTER 2

Viewing Snippet Suggestions
You can view content that matches existing snippets in your project, and you can quickly convert
these occurrences to snippets. You can also double-click a row to open the topic in question, with
the potential snippet content highlighted.
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HOW TO VIEW SNIPPET SUGGESTIONS

1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select the View ribbon. In the Dynamic Reports section, select Suggestions >
Snippet Suggestions.

n Analyzer Summary Window Pane Double-click the row that mentions snippet sug-
gestions.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider:

n Apply Displays a check box next to the suggestion. If you decide to replace the content
with the suggested snippet, you need to make sure the check box is selected. If you do
not want to replace the content with the snippet, but you do want to replace other con-
tent in the list, you can click the check box to remove the check mark.

n Suggestion Displays the suggestion that Analyzer is making to you (i.e., "Replace with
Snippet").

n Snippet Path Displays the location in your project's Content Explorer where the snippet is
found, as well as the name of the snippet (e.g., Resources/Snippets/NewSnippet.flsnp).

n File Displays the path and name of the file where the content in question is found.

n Folder Displays the folder where the file is found.

n Xml Text Displays the exact XML tag structure of the content in question.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You also have the option to view all items at once in one long list. This is called the View All
option. You can toggle these views by clicking the View All/View as Pages button in the local
toolbar. The button displays the opposite of whatever view is currently activated (e.g., If the
View All option is currently active, the button shows View as Pages to indicate that if clicked,
the button will switch the window pane to the View as Pages option).
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HOW TO CONVERT SUGGESTIONS TO SNIPPETS

Do one of the following, depending on whether you want to convert multiple suggestions to a snip-
pet simultaneously, or if you want to convert only one snippet suggestion at a time.

TO CONVERT MULTIPLE SUGGESTIONS SIMULTANEOUSLY

1. In the window pane, select all suggestions that you want to convert. If you want to select all

rows click . You can hold the SHIFT key to select a range, or you can hold the CTRL key to
select individual items.

2. In the local toolbar, click the Apply button.

3. In the message that opens, click OK. Another message lets you know how many files were
changed.

4. Click OK. All of the selected suggestions are converted to snippets.

NOTE: If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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TO CONVERT ONE SUGGESTION AT A TIME

1. In the Snippet Suggestions window pane, select the row that you want to convert to a snippet.

2. Select File > Send to Flare. The file opens in the application with the suggested content high-
lighted.

3. In Flare, insert the snippet (e.g., select Insert > Snippet).

See the online Help in Flare for more information about inserting snippets.

NOTE: Keep in mind that in order for content to be found and included in the Snippet
Suggestions window pane, it must match the tag of the existing snippet exactly. For
example, let's say that your snippet is a paragraph within a div tag. If you simply type the
same text as the snippet on a simple paragraph in a topic, that content will not be found by
Analyzer as a snippet suggestion. However, if you were to place that paragraph within a div
tag in the topic, then it would be found as a snippet suggestion.

NOTE: You can also include this information in reports that you create.
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CHAPTER 3

Converting Segments to
Snippets
You can view a list of segments that occur frequently in your project. You can see the segment text,
the number of occurrences of each segment, and the number of words and characters in each
segment. If you notice that certain segments are repeated numerous times in your project, you can
easily convert them to snippets.
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HOW TO CONVERT A FREQUENT SEGMENT TO A SNIPPET

1. Open the Frequent Segments window pane.

2. Select the segment that you want to convert to a snippet.

3. In the local toolbar, click the Create drop-down button and select Create Snippet. The Create
Snippet dialog opens.

4. In the Snippet File field, type a new name for the snippet.

It is recommended that you leave the project folder selection as "Resources/Snippets" (or
select a subfolder that you have created in the Snippets folder). After the snippet is created,
you can see the snippet file in the Content Explorer of the Flare project.

5. Click Create. The snippet is created and added to the Flare project that you are analyzing.

6. Open the Snippet Suggestions window pane.

7. Do one of the following, depending on whether you want to convert multiple suggestions sim-
ultaneously, or if you want to convert only one snippet suggestion at a time.

TO CONVERT MULTIPLE SUGGESTIONS SIMULTANEOUSLY

a. In the window pane, select all suggestions that you want to convert. If you want to

select all rows click . You can hold the SHIFT key to select a range, or you can hold
the CTRL key to select individual items.

b. In the local toolbar, click the Apply button.

c. In the message that opens, click OK. Another message lets you know how many files
were changed.

d. Click OK. All of the selected suggestions are converted to snippets.

NOTE: If you want to undo the conversions, you can use the Backups window
pane (View > Backups).
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TO CONVERT ONE SUGGESTION AT A TIME

a. In the Snippet Suggestions window pane, select the row that you want to convert to a
snippet.

b. Select File > Send to Flare. The file opens in the application with the suggested content
highlighted.

c. In Flare, insert the snippet (e.g., select Insert > Snippet).

See the online Help in Flare for more information about inserting snippets.
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CHAPTER 4

Files with Snippet Conditions
You can view a list of all files where snippet conditions have been applied. You can also double-click
a row to open the topic in question.
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HOW TO VIEW TOPICS WITH SNIPPET CONDITIONS

1. Open a project.

2. Select the View ribbon. In the Dynamic Reports section select More Reports > Files With Snip-
pet Conditions.

The Files With Snippet Conditions window pane opens, displaying all files in your project where
snippet conditions have been applied.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider:

n File Displays the name of the file.

n Location Displays the location of the snippet condition (e.g., topic, snippet block).

n Folder Displays the folder where the file is found.

n Expression Displays the condition expression used.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You also have the option to view all items at once in one long list. This is called the View All
option. You can toggle these views by clicking the View All/View as Pages button in the local
toolbar. The button displays the opposite of whatever view is currently activated (e.g., If the
View All option is currently active, the button shows View as Pages to indicate that if clicked,
the button will switch the window pane to the View as Pages option).
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5. You can open any file in the list to view or modify it. You can open the file in the Analyzer inter-
face or in the Flare project.

TO OPEN THE FILE IN THE ANALYZER INTERFACE

Double-click the file in the window pane. The benefit of using this method is that it is quick and
convenient. You have access to the features normally available in the editor (but not neces-
sarily to all of the features available elsewhere in Flare).

TO OPEN THE FILE IN FLARE

a. In the window pane, click on the file.

b. Select File > Send to Flare.

The benefit of using this method is that you have access to all of the features in the applic-
ation, not just those available from the editor.

CHAPTER 4  15



APPENDIX

PDFs
The following PDFs are available for download from the online Help.

Concepts Guide Statistics & Charts Guide

Condition Tags Guide Styles Guide

Context-sensitive Help Guide Suggestions Guide

File Tags Guide Tables of Contents Guide

Frequent Segments Guide Topics Guide

Getting Started Guide Touring the Workspace Guide

Index Guide Track Changes Guide

Key Features Guide Undefined Items Guide

Links Guide Unused Items Guide

Reports Guide Variables Guide

Shortcuts Guide What's New Guide

Snippets Guide
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