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CHAPTER 1

Viewing New Style Suggestions
You can view the places in your project where you have used local formatting. MadCap Analyzer
suggests that you convert these instances of formatting to new styles. You can use the Create New
Style dialog to do just that. You can also double-click a row to open the file where the formatted con-
tent exists.

Local formatting is simply a way to change the look and feel of content directly so that the changes
are applied only to that specific content (as opposed to applying the changes throughout your pro-
ject via the use of styles). Many easy-to-use tools are provided in Analyzer for editing and formatting
topics directly in the XML Editor to give them the look and feel you want, without having to know
XML at all. Simply open the topic that you want to format, and use the tool that suits your needs
best. For example, if you want certain text to be bold, you can highlight the text and click the Bold
button in the Text Format toolbar. This direct approach to formatting topics (sometimes called
"inline" formatting) can be very attractive because it is quick and easy. However, it is recommended
that you use style classes instead of local formatting whenever possible. Although local formatting
is very convenient in the short-term, using style classes is much more efficient and can save you a
great deal of time in the long-term.
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HOW TO VIEW NEW STYLE SUGGESTIONS

1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select the View ribbon. In the Dynamic Reports section, select New Style Sugges-
tions.

n Analyzer Summary Window Pane Double-click the row that mentions new style sug-
gestions.

The New Style Suggestions window pane opens, listing all of the new style suggestions for the
project.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider:

n Selector Displays the parent tag(s) where the formatting is found in the topic (e.g., p, div,
ul, li).

n Properties Displays the formatting already set on the tag (including the local formatting
that you may have applied to the content).

n File Displays the name of the file.

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You also have the option to view all items at once in one long list. This is called the View All
option. You can toggle these views by clicking the View All/View as Pages button in the local
toolbar. The button displays the opposite of whatever view is currently activated (e.g., If the
View All option is currently active, the button shows View as Pages to indicate that if clicked,
the button will switch the window pane to the View as Pages option).
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HOW TO CONVERT SUGGESTIONS TO NEW STYLES

1. In the New Style Suggestions window pane, select the row that you want to convert to a new
style.

2. In the local toolbar, click the Create Style button. The Create New Style dialog opens.

3. In the Stylesheet field, select the stylesheet where you want to create the new style.

4. In the Class field, type a name for the new style class.

EXAMPLE

If you have selected a row based on the p style and you type Yel-
lowBackground in this field, a new class called p.YellowBackground will be cre-
ated.

5. Click OK.

6. If a message displays, stating that the backups folder is not empty, click OK to empty the
folder and continue.

7. Another message lets you know how many files were changed. Click OK.

NOTE: If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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CHAPTER 2

Viewing Local Style
Suggestions
You can view the places in your project where you have used local formatting. MadCap Analyzer
suggests that you replace these instances of formatting with existing styles in your stylesheet that
match the formatting that you have applied manually. This is different from a new style suggestion
in the following way: With a new style suggestion, the properties in the tag do not match an existing
style exactly; therefore, Analyzer suggests that you create a new style. On the other hand, if you
make formatting changes that happen to result in an exact match to all of the properties in an exist-
ing style, Analyzer suggests that you replace the formatting with that style (rather than creating a
new style).

CHAPTER 2  7



HOW TO VIEW LOCAL STYLE REPLACEMENT SUGGESTIONS

1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select the View ribbon. In the Dynamic Reports section, select Suggestions >
Replace Local Style Suggestions.

n Analyzer Summary Window Pane Double-click the row that mentions local style replace-
ment suggestions.

The Replace Local Style Suggestions window pane opens.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider:

n Apply Displays a check box next to the style suggestion. If you decide to replace the
formatting with the suggested style, you need to make sure the check box is selected. If
you do not want to replace the formatting with the existing style, but you do want to
replace other formatting in the list, you can click the check box to remove the check
mark.

n Selector Displays the base tag(s) where the formatting is found in the topic (e.g., p, div,
ul, li), followed by a period and the name of the style class that Analyzer suggests you
use.

n Properties Displays the formatting properties already set on the tag, which matches the
formatting properties that you have applied manually.

n File Displays the path and name of the file where the formatting is found.

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You also have the option to view all items at once in one long list. This is called the View All
option. You can toggle these views by clicking the View All/View as Pages button in the local
toolbar. The button displays the opposite of whatever view is currently activated (e.g., If the
View All option is currently active, the button shows View as Pages to indicate that if clicked,
the button will switch the window pane to the View as Pages option).
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HOW TO REPLACE LOCAL FORMATTING WITH EXISTING STYLES

1. In the window pane, select all suggestions that you want to convert. If you want to select all

rows click . You can hold the SHIFT key to select a range, or you can hold the CTRL key to
select individual items.

2. In the local toolbar, click the Apply button.

3. In the message that opens, click OK. Another message lets you know how many files were
changed.

4. Click OK. All of the selected suggestions are converted to styles.

NOTE: If you want to undo the conversions, you can use the Backups window pane
(View > Backups).

CHAPTER 2  9



CHAPTER 3

Viewing Duplicate Styles
You can view a list of all styles in your project where the same properties have been set. For
example, let's say you have a style called "p.tip" and another style called "p.note." If you have spe-
cified the same settings for each of these styles (e.g., red font, 12 pt), with no other properties set,
these styles will be included in the Duplicate Styles window pane. Groups or pairs of duplicate styles
are displayed in alternating shaded rows (e.g., the rows for the first pair of duplicate styles are not
shaded, the rows for the next group are shaded, the rows for the next group are not shaded, and so
on). If you encounter duplicate styles, you may want to modify the settings for one or both styles, or
you can remove one of the style classes from the stylesheet.
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HOW TO VIEW DUPLICATE STYLES

1. Open a project.

2. Select the View ribbon. In the Dynamic Reports section, select More Reports > Duplicate
Styles. The Duplicate Styles window pane opens, displaying all topics in your project where
there are duplicate styles.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider:

n Pair Index Displays a number to represent the group of duplicate styles. The first group of
duplicate styles has an index of 1. The next group of duplicate styles has an index of 2.
The next group has an index of 3, and so on.

n Selector Displays the style name.

n Declarations Displays the properties that have been set for the style. For all styles in an
"index pair," these properties are identical.

n Medium Displays the medium to which the style properties are applied. If this cell is
blank, the style properties are simply used in the default medium. For more information
about style medium types, please see the Flare online Help.

n File Displays the name of the file.

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You also have the option to view all items at once in one long list. This is called the View All
option. You can toggle these views by clicking the View All/View as Pages button in the local
toolbar. The button displays the opposite of whatever view is currently activated (e.g., If the
View All option is currently active, the button shows View as Pages to indicate that if clicked,
the button will switch the window pane to the View as Pages option).
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5. You can open the stylesheet for any style in the list to view or modify it in the Stylesheet
Editor. You can open the stylesheet in the Analyzer interface or in the Flare project.

TO OPEN THE FILE IN THE ANALYZER INTERFACE

Double-click the file in the window pane. The benefit of using this method is that it is quick and
convenient. You have access to the features normally available in the editor (but not neces-
sarily to all of the features available elsewhere in Flare).

TO OPEN THE FILE IN FLARE

a. In the window pane, click on the file.

b. Select File > Send to Flare.

The benefit of using this method is that you have access to all of the features in the applic-
ation, not just those available from the editor.

NOTE: Duplicate styles are displayed only if they are based on the same tag. For example, if
you have identical properties set for the styles "p.tip" and "p.note," they will be included in
the window pane (because they are both based on the p style). However, if you have
identical properties set for the styles "p.tip" and "h4.note," they will not be included in the win-
dow pane (because one is based on the p style, whereas the other is based on the h4 style).
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CHAPTER 4

Viewing Undefined Styles
You can view a list of all files where you have style classes applied to content, but those styles have
not been defined. This might occur, for example, if you have created a new style class and applied it
to a paragraph in a topic. Later, you remove that style class from the stylesheet. Therefore, you now
have a style in a topic that is no longer defined in the stylesheet. You need to either apply a different,
existing style class to that content, or you need to add the style class to the stylesheet again. You
can also quickly rename or remove multiple style occurrences in a single batch, add the undefined
style to the project, or map the undefined style to an existing style.
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HOW TO VIEW UNDEFINED STYLES

1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select the View ribbon. Then in the Dynamic Reports section, select Undefined
Items > Undefined Styles.

n Analyzer Summary Window Pane Double-click the row that mentions undefined styles.

The Undefined Styles window pane opens.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider:

n Tag Displays the parent tag for the class.

n Style Displays the child style class that is applied to content in the file.

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You also have the option to view all items at once in one long list. This is called the View All
option. You can toggle these views by clicking the View All/View as Pages button in the local
toolbar. The button displays the opposite of whatever view is currently activated (e.g., If the
View All option is currently active, the button shows View as Pages to indicate that if clicked,
the button will switch the window pane to the View as Pages option).
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HOW TO FIX UNDEFINED STYLES

There are a few basic ways to fix an undefined style: (1) You can rename the style; (2) you can
remove the style from the content; (3) you can apply a different style class to the affected content;
(4) you can add a new style to the stylesheet; and (5) you can map the undefined style to an existing
style.

TO RENAME STYLE CLASSES

1. In the window pane, select all style class occurrences that you want to rename. If you want to

select all rows click . You can hold the SHIFT key to select a range, or you can hold the
CTRL key to select individual items.

NOTE: All style class occurrences that you select will be renamed to the same style
that you provide in the following steps.

2. In the local toolbar, click the Rename button. The Rename Style(s) dialog opens.

3. In the New style name field, enter a new style class.

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected style
class occurrences are renamed.

NOTE: If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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TO REMOVE STYLE CLASSES

1. In the window pane, select all style class occurrences that you want to delete. If you want to

select all rows click . You can hold the SHIFT key to select a range, or you can hold the
CTRL key to select individual items.

2. In the local toolbar, click .

3. Click OK.

4. A message lets you know how many files were changed. Click OK. All of the selected style
class occurrences are removed.

NOTE: If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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TO APPLY DIFFERENT STYLE CLASSES

1. Do one of the following, depending on whether you want to open the file in the Analyzer inter-
face or within Flare.

TO OPEN THE FILE IN THE ANALYZER INTERFACE

Double-click the file in the window pane. The benefit of using this method is that it is quick and
convenient. You have access to the features normally available in the editor (but not neces-
sarily to all of the features available elsewhere in Flare).

TO OPEN THE FILE IN FLARE

a. In the window pane, click on the file.

b. Select File > Send to Flare.

The benefit of using this method is that you have access to all of the features in the applic-
ation, not just those available from the editor.

2. Make sure the style select drop-down menu is accessible. Do one of the following, depending
on the part of the user interface you are using:

n Ribbon Select the Home ribbon.

n Tool Strip Select View > Toolbars > Text Formatting. The Text Format toolbar opens.

3. Click the down arrow in the field displaying styles. From the drop-down, select a new style
class. See the online Help in Flare for more information about styles and how to apply them.

4. Click to save your work.
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TO ADD A NEW STYLE

1. In the window pane, select the style that you want to add to the project.

2. Do one of the following, depending on the part of the user interface you are using:

n Local Toolbar Click .

n Right-Click Right-click on the condition tag you want to add and from the context menu
select Add New Style.

The Create Style dialog opens.

3. On the left side of the dialog, select one of the following:

n Class Select this if you want to create a simple class (e.g., a special paragraph intended
to serve as a tip or note).

n ID Identifiers (IDs) are similar to classes, except that IDs are unique. An element in your
stylesheet can have only one ID on it, whereas it can have multiple classes. And each
page of your output can have only one element with a particular ID. For many authors,
using an ID may not be important, but for others—such as those making use of Javas-
cript—IDs can be very useful.

4. In the field after your selection, type a name for the new style class or ID, without using
spaces.

5. On the right side of the dialog, select the stylesheet to which you want to add the new style.

6. The property values already applied to the selected content are shown. If you do not want to
include certain property values in the new selector, click the check box next to the value (in
the Include column) to remove the check mark.

7. If you want the new style to immediately be applied to the content selected in the topic, select
Create style and update the source element. If you do not want the new style to immediately
be applied to the content selected in the topic, select Create style without updating the
source element.

8. Click OK. The style is added to the currently linked stylesheet.

9. Click to save your work.
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TO MAP TO AN EXISTING STYLE

1. In the window pane, select the style that you want to map to an existing style.

2. Do one of the following, depending on the part of the user interface you are using:

n Local Toolbar Click .

n Right-Click Right-click on the condition tag you want to add and from the context menu
select Map to Existing Style.

The Select Class or ID dialog opens.

3. In the dialog, select the existing style class or ID in the project to overwrite the current
undefined style.

4. Click OK. All of the selected style occurrences are overwritten with the new style.

5. Click to save your work.
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CHAPTER 5

Viewing Unused Styles
You can view a list of styles in your project that have not yet been applied to content in any files. If
you do not use a particular style class, you can remove it from the stylesheet. You can also use the
"disable" feature to hide styles that you do not want to be displayed in the stylesheet; you can
access this feature from the Options drop-down button in the local toolbar of the Stylesheet Editor.
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HOW TO VIEW UNUSED STYLES

1. Open a project.

2. Select the View ribbon. In the Dynamic Reports section, select More Reports > Unused Items.

The Unused Items window pane opens, which allows you to view various unused elements in
the project (such as bookmarks, condition tags, content files, CSH IDs, images, variables,
styles, file tags, and topics not linked).

3. Click the drop-down field at the top of the window pane and select Unused Styles. The unused
styles in the project are listed.

4. To see more of the information in the window pane, drag the divider bar to make the pane
wider:

n Selector Displays the name of the parent style, followed by a period and the name of the
class under that style (e.g., p.tip).

n Declarations Displays any property settings that you have set for the style class.

n File Displays the name of the file.

5. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You also have the option to view all items at once in one long list. This is called the View All
option. You can toggle these views by clicking the View All/View as Pages button in the local
toolbar. The button displays the opposite of whatever view is currently activated (e.g., If the
View All option is currently active, the button shows View as Pages to indicate that if clicked,
the button will switch the window pane to the View as Pages option).

6. If you want to remove any unused styles from Analyzer, as well as from the project being ana-

lyzed, select the style in the list and click in the local toolbar.

7. You can open the stylesheet for any style in the list to view or modify it in the Stylesheet
Editor. You can open the stylesheet in the Analyzer interface or in the Flare project.

TO OPEN THE FILE IN THE ANALYZER INTERFACE

Double-click the file in the window pane. The benefit of using this method is that it is quick and
convenient. You have access to the features normally available in the editor (but not neces-
sarily to all of the features available elsewhere in Flare).
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TO OPEN THE FILE IN FLARE

a. In the window pane, click on the file.

b. Select File > Send to Flare.

The benefit of using this method is that you have access to all of the features in the applic-
ation, not just those available from the editor.
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PDFs
The following PDFs are available for download from the online Help.

Concepts Guide Statistics & Charts Guide

Condition Tags Guide Styles Guide

Context-sensitive Help Guide Suggestions Guide

File Tags Guide Tables of Contents Guide

Frequent Segments Guide Topics Guide

Getting Started Guide Touring the Workspace Guide

Index Guide Track Changes Guide

Key Features Guide Undefined Items Guide

Links Guide Unused Items Guide

Reports Guide Variables Guide

Shortcuts Guide What's New Guide

Snippets Guide
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