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CHAPTER 1

Accessibility Suggestions
Analyzer provides you with various accessibility suggestions for the content in your project. That
way, you can make sure your documentation can be accessed by people with disabilities (i.e., indi-
viduals who have visual, hearing, and mobility impairments). Documentation is considered access-
ible when it is easier for those with disabilities to use and easier to read using assistive technologies
such as Microsoft Windows Narrator, Connect Outloud, and JAWS (Job AccessWith Speech).

This chapter discusses the following:

Viewing Accessibility Suggestions 5

Customizing Accessibility Suggestions Shown 7

Resolving Accessibility Issues 9
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Viewing Accessibility Suggestions
Using the Accessibility Suggestions window pane, you can view places in your project where you
can make accessibility improvements for WebHelp and PDF outputs in Flare. This includes the abil-
ity to identify tables that are missing certain elements and finding objects—such as images, equa-
tions, and QR codes—that are missing alternate text. You can use the Accessibility Suggestions
Search Properties dialog to customize which types of issues to display in the window pane.

HOW TO VIEW ACCESSIBILITY SUGGESTIONS

1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select the View ribbon. In the Dynamic Reports section, select Suggestions >
Accessibility Suggestions.

n Analyzer Summary Window Pane If you have the Analyzer Summary window pane in
view, double-click the row that mentions accessibility suggestions.

The Accessibility Suggestions window pane opens.
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3. To see more of the information in the window pane, drag the divider bar to make the pane
wider:

n Tag Displays the tag where the issue occurs (e.g., img, table, qrCode, equation).

n Issue Displays the issue with the tag (e.g., needs alternate text, caption, summary,
header elements).

n Context Displays the context of the issue in question. For example, if the issue is that a
tag is missing alternate text, this shows the name and path of the image.

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You also have the option to view all items at once in one long list. This is called the View All
option. You can toggle these views by clicking the View All/View as Pages button in the local
toolbar. The button displays the opposite of whatever view is currently activated (e.g., If the
View All option is currently active, the button shows View as Pages to indicate that if clicked,
the button will switch the window pane to the View as Pages option).
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Customizing Accessibility Suggestions
Shown
You can use the Accessibility Suggestions Search Properties dialog to customize which types of
accessibility issues to look for when analyzing Flare projects. Based on your selections in this dialog,
the Accessibility Suggestions window pane updates accordingly.

HOW TO CUSTOMIZE THE ACCESSIBILITY SUGGESTIONS SHOWN IN THE WINDOW
PANE

1. Open the Accessibility Suggestions window pane. See "Accessibility Suggestions" on page 4.

2. In the local toolbar of the Accessibility Suggestions window pane, click Search Properties.
The Accessibility Suggestions Search Properties dialog opens.

3. Select any of the options in the dialog.

n Images without alt text

n Equations without alt text

n QR Codes without alt text

n Tables missing both a caption and summary

n Form elements without labels

n Frame elements missing title and name

n Tables missing header elements

n Table captions that are not the first table element
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4. Click OK.
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Resolving Accessibility Issues
When you see issues listed in the Accessibility Suggestions window pane, you can resolve them in a
couple of different ways. If the issue has to do with missing alternate text, you can use the Apply
Accessibility SuggestionsWizard to automatically add this to the elements in question; you can also
add empty alt text to multiple images at once. If the issue has to do with alternate text or something
else—such asmissing captions, labels, or table header elements—you can fix the issue manually in
the user interface.

HOW TO RESOLVE ACCESSIBILITY ISSUES (ALT TEXT) AUTOMATICALLY IN A WIZARD

1. Open the Accessibility Suggestions window pane. See "Accessibility Suggestions" on page 4.

2. In the Accessibility Suggestions window pane, select all "alt text" issues that you want to

resolve. If you want to select all rows click . You can hold the SHIFT key to select a range,
or you can hold the CTRL key to select individual items.

3. In the local toolbar, click the Apply Alt Text button.

4. A message asks if you want to apply the selected suggestions. Click OK. The Apply Access-
ibility SuggestionsWizard opens.

5. Select one or more items in the list. (Select multiple items if you want the same alt text to
apply to them all.)

6. (Optional) If you selected only one item, you can click View, which opens the Media Viewer
and lets you see a preview of the object (e.g., equation, QR code, image, video). For videos
and images, file information is displayed in addition to a list of files that link to the media file.
Click OK when you are finished.

7. Click Set Text. The Change Alt Text dialog opens.

8. In the Alt Text field, you can enter the alternate text for the object (e.g., description of the
image that you want screen readers to interpret). If you want to apply empty alt text to image
(s) that you selected, leave the field blank.

9. Click OK.

10. If you are setting different alternate text for different items, repeat steps 5-9 for each item in
the wizard.

11. Click Next. A preview of your settings is shown.

12. Click Finish.
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13. Click OK.

NOTE: If you want to undo the conversions, you can use the Backups window pane
(View > Backups).

HOW TO RESOLVE ACCESSIBILITY ISSUES MANUALLY IN THE INTERFACE

1. Open the Accessibility Suggestions window pane. See "Accessibility Suggestions" on page 4.

2. You can open any file in the list to view or modify it in an editor. You can open the file in the
Analyzer interface or in the Flare project.

TO OPEN THE FILE IN THE ANALYZER INTERFACE

Double-click the file in the window pane. The benefit of using this method is that it is quick and
convenient. You have access to the features normally available in the editor (but not neces-
sarily to all of the features available elsewhere in Flare).

TO OPEN THE FILE IN FLARE

a. In the window pane, click on the file.

b. Select File > Send to Flare.

The benefit of using this method is that you have access to all of the features in the applic-
ation, not just those available from the editor.

3. Depending on the type of issue, use the appropriate areas of the interface to make changes.
See the online Help in Flare for more information about using different features.

n Image Elements You can fix the issue by editing the image and entering a description in
the Alternate Text field.

n Equation Elements You can fix the issue by editing the equation and entering a descrip-
tion in the Alternate Text field.

n QR Code Elements You can fix the issue by editing the QR code and entering a descrip-
tion in the Alternate Text field.

n Tables You can fix the issue by editing the table properties and entering caption text
(above the table) and/or adding a header row.
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n Form Elements You can fix the issue by opening the markup for the document and adding
a label to the form. To edit the markup, you can use the Internal Text Editor or Notepad.
For more information about working with form elements (and labels within them), see
w3.org.

n Frame Elements You can fix the issue by opening the markup for the document and
adding a title to the frame element. To edit the markup, you can use the Internal Text
Editor or Notepad. For more information about working with frame elements (and titles/-
names within them), see w3.org.
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CHAPTER 2

Markup Suggestions
Analyzer provides you with various markup suggestions for the content in your project to make sure
the code is as "clean" as possible.

This chapter discusses the following:

Viewing and Applying Markup Suggestions 13

Customizing Markup Suggestions Shown 17
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Viewing and Applying Markup Suggestions
The Markup Suggestions window pane lets you see a list of files where the XHTML markup (code)
can be improved (e.g., empty tags, CDATA tags, empty attributes, excessive spaces). When Ana-
lyzer finds markup issues, there are a couple of ways that you can "clean them up." First, you can
click the Apply button in the local toolbar to automatically apply the suggestions to the selected
files. Alternatively, you can double-click a row to open that file and work on the issuesmanually. You
may be able to fix some issues for a specific file in the XML Editor. Other issues may require you to
open the behind-the-scenes code in the Internal Text Editor.

HOW TO VIEW MARKUP SUGGESTIONS

1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select the View ribbon. In the Dynamic Reports section, select Suggestions >
Markup Suggestions.

n Analyzer Summary Window Pane Double-click the row that mentions markup sug-
gestions.

The Markup Suggestions window pane opens.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider:

n Suggestion Displays the suggestion to resolve the issue (e.g., "Remove empty attribute,"
"Make single space").

n Tag Displays the tag where the issue occurs (e.g., img, p, h1, li).

n Context Displays the context of the issue in question. For example, if the issue is that a
tag has an empty attribute, this shows the tag and name of the attribute within it.

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.
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4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You also have the option to view all items at once in one long list. This is called the View All
option. You can toggle these views by clicking the View All/View as Pages button in the local
toolbar. The button displays the opposite of whatever view is currently activated (e.g., If the
View All option is currently active, the button shows View as Pages to indicate that if clicked,
the button will switch the window pane to the View as Pages option).
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HOW TO APPLY MARKUP SUGGESTIONS AUTOMATICALLY

1. View the markup suggestions.

2. In the Markup Suggestions window pane, select all issues that you want to resolve. If you

want to select all rows click . You can hold the SHIFT key to select a range, or you can hold
the CTRL key to select individual items.

3. In the local toolbar, click the Apply button.

4. A message asks if you want to apply the selected suggestions. Click OK.

5. If your Backups folder is not empty, a message asks if you want to empty it and continue. If
so, click OK.

6. Click OK once more.

CHAPTER 2  15



NOTE: If you want to undo the conversions, you can use the Backups window pane
(View > Backups).

HOW TO RESOLVE MARKUP ISSUES MANUALLY

1. View the markup suggestions.

2. You can open any file in the list to view or modify it in an editor. You can open the file in the
Analyzer interface or in the Flare project.

TO OPEN THE FILE IN THE ANALYZER INTERFACE

Double-click the file in the window pane. The benefit of using this method is that it is quick and
convenient. You have access to the features normally available in the editor (but not neces-
sarily to all of the features available elsewhere in Flare).

TO OPEN THE FILE IN FLARE

a. In the window pane, click on the file.

b. Select File > Send to Flare.

The benefit of using this method is that you have access to all of the features in the applic-
ation, not just those available from the editor.

3. If necessary, you can open the file in the Internal Text Editor to work directly in the markup
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Customizing Markup Suggestions Shown
You can use the Markup Suggestions Search Properties dialog to customize which types of markup
issues to look for when analyzing Flare projects. Based on your selections in this dialog, the Markup
Suggestions window pane updates accordingly.

HOW TO CUSTOMIZE THE MARKUP SUGGESTIONS SHOWN IN THE WINDOW PANE

1. View the markup suggestions. See "Markup Suggestions" on page 12.

2. In the local toolbar of the Markup Suggestions window pane, click Search Properties. The
Markup Suggestions Search Properties dialog opens.

3. Select any of the options in the dialog.

n CDATA tags

n Empty tags

n Line breaks

n Underscores in topic title

n Untagged text in topic body

n Empty attributes

n Tags with only spaces

n Non-breaking spaces

n Multiple spaces
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4. Click OK.
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CHAPTER 3

Writing Suggestions
Analyzer provides you with various writing suggestions for the content in your project.

This chapter discusses the following:

Viewing Writing Suggestions 20

Customizing Writing Suggestions Shown 22

CHAPTER 3  19



Viewing Writing Suggestions
You can view places in your project where you can make writing improvements based on industry-
wide standards. For example, Analyzer can locate files where an h1 or h2 heading has only one sub-
heading (i.e., an h1 heading with only one h2 heading under it, or an h2 heading with only one h3
heading under it). It is recommended that you have more than one subheading under a parent head-
ing. Therefore, occurrences such as these are raised as concerns. Analyzer can also locate files
where a heading level has been skipped (e.g., an h1 heading is followed by an h3 heading, rather
than h2), as well as any files where consecutive headings exist (e.g., an h1 heading is followed by an
h2 heading, with no other content between them). You can use the Writing Suggestions Search
Properties dialog to customize which types of suggestions to display in the window pane.

HOW TO VIEW WRITING SUGGESTIONS

1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select the View ribbon. In the Dynamic Reports section, select Suggestions > Writ-
ing Suggestions.

n Analyzer Summary Window Pane Double-click the row that mentions writing suggestions.

The Writing Suggestions window pane opens.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider:

n Suggestion Displays the issue (e.g., "H1s with single child," "Skipped heading"). Following
are the types of issues that might be found, depending on your selections in the Writing
Suggestions Search Properties dialog.

l Heading 1s with only one child heading Locates files where an h1 heading has only
one h2 heading under it. For more information about styles (including h1 through h6
heading styles), see the online Help.

l Heading 2s with only one child heading Locates files where an h2 heading has only
one h3 heading under it.

l Heading 3s with only one child heading Locates files where an h3 heading has only
one h4 heading under it.
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l Heading 4s with only one child heading Locates files where an h4 heading has only
one h5 heading under it.

l Heading 5s with only one child heading Locates files where an h5 heading has only
one h6 heading under it.

l Skipped headings Locates files where a heading level has been skipped (e.g., an h1
heading is followed by an h3 heading, rather than h2).

l Consecutive headings Locates files where one heading is followed immediately by
another heading with no other content in between.

n Tag Displays the tag where the issue occurs.

n File Displays the name of the file.

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You also have the option to view all items at once in one long list. This is called the View All
option. You can toggle these views by clicking the View All/View as Pages button in the local
toolbar. The button displays the opposite of whatever view is currently activated (e.g., If the
View All option is currently active, the button shows View as Pages to indicate that if clicked,
the button will switch the window pane to the View as Pages option).

After viewing writing suggestions, you can open each file and make changes accordingly. To open a
file in the Analyzer interface, double-click the row in the Writing Suggestions window pane. To open
a file in Flare, select the row and select File > Send to Flare.
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Customizing Writing Suggestions Shown
If you want to limit or expand the list of the writing suggestions that are displayed, you can easily do
so by selecting various options.

HOW TO CUSTOMIZE THE WRITING SUGGESTIONS SHOWN IN THE WINDOW PANE

1. View the writing suggestions.

2. In the local toolbar of the Writing Suggestions window pane, click Search Properties. The Writ-
ing Suggestions Search Properties dialog opens.

3. Select any of the options in the dialog.

n Heading 1s with only one child heading Locates files where an h1 heading has only one h2
heading under it. For more information about styles (including h1 through h6 heading
styles), see the online Help.

n Heading 2s with only one child heading Locates files where an h2 heading has only one h3
heading under it.

n Heading 3s with only one child heading Locates files where an h3 heading has only one h4
heading under it.

n Heading 4s with only one child heading Locates files where an h4 heading has only one h5
heading under it.

n Heading 5s with only one child heading Locates files where an h5 heading has only one h6
heading under it.

n Skipped headings Locates files where a heading level has been skipped (e.g., an h1 head-
ing is followed by an h3 heading, rather than h2).

n Consecutive headings Locates files where one heading is followed immediately by
another heading with no other content in between.

4. Click OK.
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CHAPTER 4

Cross-Reference Suggestions
The Cross-Reference Suggestions window pane displays links in a project that you might want to
convert to cross-references. This window pane also provides you with the option to convert the
selected links to cross-references.

For example, if you have regular text hyperlinks (<a> tags), you might want to convert them,
because cross-references change dynamically and are therefore usually preferred over text hyper-
links.
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HOW TO VIEW CROSS-REFERENCE SUGGESTIONS

1. Open a project.

2. Select the View ribbon. In the Dynamic Reports section, select Suggestions > Cross-Refer-
ence Suggestions.

The Cross-Reference Suggestions window pane opens.

3. Double-click a file to open it in the XML Editor. The file opens and highlights the cross-ref-
erence suggestion.
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HOW TO CONVERT CROSS-REFERENCE SUGGESTIONS

1. Open a project.

2. Select the View ribbon. In the Dynamic Reports section, select Suggestions > Cross-Refer-
ence Suggestions.

The Cross-Reference Suggestions window pane opens.

3. Do one of the following:

n Click the Convert to Cross-References button in the local toolbar.

OR

n Right-click any file in the Cross-References Suggestions window pane and from the con-
text menu, select Convert to Cross-References.

The Convert to Cross-Reference dialog opens.

4. In the Convert to Cross-References dialog, you can make selections from the following
options.

TARGET OPTIONS

In the Target Option field, select one of the following to indicate how you want the destination
file to open when the link is clicked.

n Link Target This uses the target that is set in the original link.

n Target Frame This enables the Target Frame field (immediately below), which you can
use to select one of the following target frame options.

l (default) The destination file opens in the same window as the output window.

l Parent Frame The destination file opens in the parent frame of the current topic
while hiding that topic.

l NewWindow/Tab The destination file opens in a new browser window or tab.

l Same Frame The destination file opens in the same window frame as the current
topic.
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l Top Frame The destination file opens in the same output window, removing all other
framesets. You might use this option, for example, if the destination topic has its
own frameset.

l Popup Window The destination file opens in a popup box on top of the current topic.
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SCREEN TIP OPTIONS

In the Screen Tip Option field, select one of the following to add a screen tip to the link. This is
useful when it comes to accessibility.

n Link Alt Text This uses the screen tip text that is set in the original link.
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n Screen Tip This uses the screen tip text that you enter in the Screen Tip field (imme-
diately below).
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CROSS-REFERENCE STYLE CLASS

In the XRef Class field, you can set the cross-reference's style class and format . The style
class is previewed to the right.
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n Edit You can click Edit to change the selected cross-reference style class. This opens the
Edit Cross-Reference Style Class Dialog.
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n New You can click New to create a new cross-reference style. This opens the New
Cross-Reference Style Class Dialog.

5. Click OK. A message indicates how many files have been updated.
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HOW TO INCLUDE CROSS-REFERENCE SUGGESTIONS IN A REPORT

1. Open a report.

2. In the Report Editor, click the General tab.

3. In the Tables field, scroll down to the Links section.

4. Click the Cross-Reference Suggestions check box.

5. Click Generate. The generated report will include cross-reference suggestions.

CHAPTER 4  32



APPENDIX

PDFs
The following PDFs are available for download from the online Help.

Concepts Guide Statistics & Charts Guide

Condition Tags Guide Styles Guide

Context-sensitive Help Guide Suggestions Guide

File Tags Guide Tables of Contents Guide

Frequent Segments Guide Topics Guide

Getting Started Guide Touring the Workspace Guide

Index Guide Track Changes Guide

Key Features Guide Undefined Items Guide

Links Guide Unused Items Guide

Reports Guide Variables Guide

Shortcuts Guide What's New Guide

Snippets Guide
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