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CHAPTER 1

Undefined Glossary Term Links
You can view a list of all files where you have glossary term links inserted into content, but those
glossary terms do not appear in any of your glossary files. This might occur, for example, if you have
created a new term in a glossary and then inserted that term into a topic as a glossary term link.
Later, you remove that term from the glossary. You now have a glossary term link in a topic, but the
term no longer exists in the glossary. Therefore, a problem exists. You need to either remove the
glossary term link from the content, or you need to add the term to the glossary again. From the
Undefined Glossary Term Links window pane, you can quickly unbind or rename multiple glossary
term link occurrences in a single batch, add a new glossary term, or map the undefined term to an
existing glossary term.
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HOW TO VIEW UNDEFINED GLOSSARY TERM LINKS

1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select the View ribbon. Then in the Dynamic Reports section, select Undefined
Items > Undefined Glossary Term Links.

n Analyzer Summary Window Pane Double-click the row that mentions undefined glossary
term links.

The Undefined Glossary Term Links window pane opens.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider:

n Term Displays the term that is used in a glossary term link in the file.

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You also have the option to view all items at once in one long list. This is called the View All
option. You can toggle these views by clicking the View All/View as Pages button in the local
toolbar. The button displays the opposite of whatever view is currently activated (e.g., If the
View All option is currently active, the button shows View as Pages to indicate that if clicked,
the button will switch the window pane to the View as Pages option).
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HOW TO FIX UNDEFINED GLOSSARY TERM LINKS

There are a few basic ways to fix an undefined glossary term link: (1) You can rename the glossary
term; (2) you can unbind the glossary term link; (3) you can remove the glossary term link from the
file; (4) you can add the same glossary term to the glossary file; (5) you can replace an undefined
glossary term with an existing glossary term; and (6) you can create a new glossary term.

TO RENAME GLOSSARY TERMS IN A FILE

1. In the window pane, select all glossary term link occurrences that you want to rename. If you

want to select all rows click . You can hold the SHIFT key to select a range, or you can hold
the CTRL key to select individual items.

NOTE: All glossary term occurrences that you select will be renamed to the same
glossary term that you provide in the following steps.

2. In the local toolbar, click the Rename button.

3. In the New glossary term link name field, enter a new glossary term.

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected glossary
term link occurrences are renamed.

NOTE: If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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TO UNBIND GLOSSARY TERM LINKS IN A FILE

1. In the window pane, select all glossary term link occurrences that you want to unbind. If you

want to select all rows click . You can hold the SHIFT key to select a range, or you can hold
the CTRL key to select individual items.

NOTE: The links for all glossary term occurrences that you select will be removed.

2. In the local toolbar, click the Unbind button.

3. Click OK.

4. A message lets you know how many files were changed. Click OK. The links for all of the selec-
ted glossary term link occurrences are removed.

NOTE: If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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TO REMOVE GLOSSARY TERM LINKS FROM A FILE

1. Do one of the following, depending on whether you want to open the file in the Analyzer inter-
face or within Flare.

TO OPEN THE FILE IN THE ANALYZER INTERFACE

Double-click the file in the window pane. The benefit of using this method is that it is quick and
convenient. You have access to the features normally available in the editor (but not neces-
sarily to all of the features available elsewhere in Flare).

TO OPEN THE FILE IN FLARE

a. In the window pane, click on the file.

b. Select File > Send to Flare.

The benefit of using this method is that you have access to all of the features in the applic-
ation, not just those available from the editor.

2. On your keyboard press DELETE. Add regular text if necessary.

3. Click to save your work.
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TO ADD MATCHING TERMS TO THE GLOSSARY

1. In the Undefined Glossary Term Links window pane, select the row that you want to correct.
Then select File > Send to Flare. The file opens in the XML Editor of the application, with the
glossary term link highlighted.

2. Open the glossary and add a matching glossary term. See the online Help in Flare for more
information about opening glossaries and adding terms.

TO REPLACE AN UNDEFINED GLOSSARY TERM WITH AN EXISTING TERM

1. In the window pane, select all glossary term link occurrences that you want to replace. If you

want to select all rows click . You can hold the SHIFT key to select a range, or you can hold
the CTRL key to select individual items.

2. Do one of the following, depending on the part of the user interface you are using:

n Local Toolbar Click .

n Right-Click Right-click on the glossary term you want to replace and from the context
menu select Create Glossary Term Link.

The Create Glossary Link dialog opens.

3. On the right side of the dialog, select the existing glossary term you want to link to the
undefined term.

4. Click OK. The undefined glossary terms are replaced with the term you selected.
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TO CREATE A NEW GLOSSARY TERM

1. In the window pane, select the glossary term link occurrences that you want to add to the pro-
ject.

2. Do one of the following, depending on the part of the user interface you are using:

n Local Toolbar Click .

n Right-Click Right-click on the glossary term you want to replace and from the context
menu select Create Glossary Term Link.

The Create Glossary Link dialog opens.

3. Click Add New Term.

The Create Glossary Term dialog opens.

4. Enter a new term and definition, which will be added to the glossary when you are finished.

5. (Optional) You can also use the Insert Variable button , if you want to add a variable to the
definition.

6. (Optional) If you want to sort a glossary entry using a different term, in the Sort As field, enter
the term you want to use for sorting. "Sort As" terms appear in the Sort As column of the gloss-
ary.

TIP: Use a "Sort As" term if you want to sort a glossary term as something else. This
can be useful when a term begins with a symbol (e.g., place <html> in the "h" section,
instead of at the top of the glossary), or if you are using character sets that need to be
sorted phonetically.

7. Click OK.

8. In the Create Glossary Link dialog, click OK. The undefined glossary terms are replaced with
the new glossary term.
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CHAPTER 2

Undefined Condition Tags
You can view a list of all files where you have condition tags in the content, but those condition tags
have not been defined. This might occur, for example, if you have applied a condition tag in a topic
and then later change the name of the tag or condition tag set. The old tag or set name is still used
at the location where it was previously applied in the topic. Therefore, a problem exists. From the
Undefined Condition Tags window pane, you can open the file in question and fix the undefined con-
dition tag. You can also quickly rename or remove multiple condition tag occurrences in a single
batch, add the undefined tag to the project, or map the undefined tag to an existing condition tag.
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HOW TO VIEW UNDEFINED CONDITION TAGS

1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select the View ribbon. In the Dynamic Reports section, select Undefined Items
> Undefined Condition Tags.

n Analyzer Summary Window Pane Double-click the row that mentions undefined con-
dition tags.

The Undefined Condition Tags window pane opens, displaying a list of undefined condition
tags.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider:

n Condition Tag Displays the name of the condition tag set and the tag within it. The con-
dition tag set is listed first, followed by a period and then the name of the condition tag
(e.g., Primary.Print).

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

n Tag Displays the tag being used by the condition tag.

n Exclude Action Displays the kind of "exclude" action tied to the condition tag. In most
cases, the exclude action is "remove." However, in some instances, this action might be
"unbind." For example, you might have the unbind action for a condition tag if you have
applied the tag to a hyperlink and want the link to be removed from the text in some out-
puts, but you still want the text to be shown in those outputs.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You also have the option to view all items at once in one long list. This is called the View All
option. You can toggle these views by clicking the View All/View as Pages button in the local
toolbar. The button displays the opposite of whatever view is currently activated (e.g., If the
View All option is currently active, the button shows View as Pages to indicate that if clicked,
the button will switch the window pane to the View as Pages option).
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HOW TO FIX UNDEFINED CONDITION TAGS

There are a few different ways to fix an undefined condition tag: (1) You can rename the condition
tag or condition tag set so that it matches what you have used in the topic; (2) you can reapply the
condition tag in the topic so that it uses an existing condition tag set/condition tag; (3) you can add
the undefined condition tag to the project as a new condition tag; and (4) you can map the
undefined condition tag to an existing condition tag.

TO RENAME CONDITION TAGS

1. In the window pane, select all condition tag occurrences that you want to rename. If you want

to select all rows click . You can hold the SHIFT key to select a range, or you can hold the
CTRL key to select individual items.

NOTE: All condition tag occurrences that you select will be renamed to the same con-
dition tag that you provide in the following steps.

2. In the local toolbar, click the Rename button. The Rename Condition Tag(s) dialog opens.

3. In the New condition tag name field, enter a new condition tag. Type the name of the con-
dition tag set, followed by a period, then the name of the condition tag (e.g., Primary.Print).

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected con-
dition tag occurrences are renamed.

NOTE: If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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TO REAPPLY CONDITION TAGS

1. Do one of the following, depending on whether you want to open the file in the Analyzer inter-
face or within Flare.

TO OPEN THE FILE IN THE ANALYZER INTERFACE

Double-click the file in the window pane. The benefit of using this method is that it is quick and
convenient. You have access to the features normally available in the editor (but not neces-
sarily to all of the features available elsewhere in Flare).

TO OPEN THE FILE IN FLARE

a. In the window pane, click on the file.

b. Select File > Send to Flare.

The benefit of using this method is that you have access to all of the features in the applic-
ation, not just those available from the editor.

2. Reapply the condition tag to the content, selecting an existing name from a condition tag set.
See the online Help in Flare for more information about applying condition tags to content.
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TO ADD A NEW CONDITION TAG

1. In the window pane, select all condition tag occurrences that you want to add to the project. If

you want to select all rows click . You can hold the SHIFT key to select a range, or you can
hold the CTRL key to select individual items.

2. Do one of the following, depending on the part of the user interface you are using:

n Local Toolbar Click .

n Right-Click Right-click on the condition tag you want to add and from the context menu
select Add New Condition Tag.

The Condition Tag Set Editor opens, with the new condition tag(s) displayed.

NOTE: When you create a new condition tag, one of two things will happen:

1. If the Condition Tag Set file specified exists in the project, Analyzer will add the
new condition tag to the existing file.

2. If the Condition Tag Set file specified does not exist in the project, Analyzer will
create a brand new Condition Tag Set file and add the new condition tag to that
file.

3. (Optional) In the Condition Tag Set Editor, edit the condition tag's properties (e.g., name,
color, comment).

4. Click to save your work.
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TO MAP TO AN EXISTING CONDITION TAG

1. In the window pane, select all condition tag occurrences that you want to map to an existing

condition tag. If you want to select all rows click . You can hold the SHIFT key to select a
range, or you can hold the CTRL key to select individual items.

2. Do one of the following, depending on the part of the user interface you are using:

n Local Toolbar Click .

n Right-Click Right-click on the condition tag you want to add and from the context menu
select Map to Existing Condition Tag.

The Condition Tags dialog opens.

3. In the dialog, select the existing condition tag in the project to overwrite the current undefined
condition tag reference.

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected con-
dition tag occurrences are overwritten with the new condition tag.

NOTE: If you want to undo the conversions, you can use the Backups window pane
(View > Backups).

6. Click to save your work.

NOTE: Another way to apply a different condition tag to many places throughout a project
is to use the Find and Replace in Files feature in Flare. For example, let's say that you ori-
ginally applied a condition tag named "Print" (from the "Primary" condition tag set) to a lot of
content in your project. Later, you renamed the condition tag "PDF." You can perform a find
and replace in your entire project. In the "Find" field, you can enter Primary.Print, and in
the "Replace with" field, you can enter Primary.PDF. Also, make sure you select the "Find
in source code" option in the Find and Replace in Files window pane. After replacing this text
throughout your project, that condition tag will no longer be considered "undefined" in Ana-
lyzer. For information about using the Find and Replace in Files feature, see the online Help
in Flare.
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CHAPTER 3

Undefined File Tags
You can view a list of all files that are associated with file tags, but those file tags have not been
defined. This might occur, for example, if you have associated a file tag with a topic and then later
change the name of the tag or file tag set. The old tag or set name is still used for the topic. There-
fore, a problem exists. From the Undefined File Tags window pane, you can open the file in question
and fix the undefined tag. You can also quickly rename or remove multiple file tag occurrences in a
single batch.
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HOW TO VIEW UNDEFINED FILE TAGS

1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select the View ribbon. Then in the Dynamic Reports section, select Undefined
Items > Undefined File Tags.

n Analyzer Summary Window Pane Double-click the row that mentions undefined file tags.

The Undefined File Tags window pane opens, displaying a list of undefined file tags.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider:

n File Tag Displays the name of the file tag set and the tag within it. The file tag set is listed
first, followed by a period and then the name of the file tag (e.g., AuthorTagSet.Bob).

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You also have the option to view all items at once in one long list. This is called the View All
option. You can toggle these views by clicking the View All/View as Pages button in the local
toolbar. The button displays the opposite of whatever view is currently activated (e.g., If the
View All option is currently active, the button shows View as Pages to indicate that if clicked,
the button will switch the window pane to the View as Pages option).
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HOW TO FIX UNDEFINED FILE TAGS

There are a couple of basic ways to fix an undefined file tag. First, you can rename the file tag or file
tag set so that it matches what you have associated with the file. Otherwise, you can re-associate
the file tag with the file so that it uses an existing file tag set/file tag.

TO RENAME FILE TAGS

1. In the window pane, select all file tag occurrences that you want to rename. If you want to

select all rows click . You can hold the SHIFT key to select a range, or you can hold the
CTRL key to select individual items.

NOTE: All file tag occurrences that you select will be renamed to the same file tag
that you provide in the following steps.

2. In the local toolbar, click the Rename button. The Rename File Tag(s) dialog opens.

3. In the New file tag name field, enter a new file tag name. Type the name of the file tag set, fol-
lowed by a period, then the name of the file tag (e.g., AuthorTagSet.Bob).

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected file tag
occurrences are renamed.

NOTE: If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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TO RE-ASSOCIATE FILE TAGS

1. Open the Flare project that contains the file.

2. In the Content Explore or Project Organizer, right-click on the file and select Properties.

3. Select the File Tags tab.

4. Select the appropriate file tag set and file tag.

5. Click OK.

NOTE: Another way to associate a different file tag to many places throughout a project is
to use the Find and Replace in Files feature in Flare. For example, let's say that you originally
associated a file tag named "Completed" (from the "Status" file tag set) with a lot of files in
your project. Later, you renamed the file tag "Finished." You can perform a find and replace
in your entire project. In the "Find" field, you can enter Status.Completed, and in the
"Replace with" field, you can enter Status.Finished. Also, make sure you select the
"Find in source code" option in the Find and Replace in Files window pane. After replacing
this text throughout your project, that file tag will no longer be considered "undefined" in Ana-
lyzer. For information about using the Find and Replace in Files feature, see the online Help
in Flare.
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CHAPTER 4

Undefined Styles
You can view a list of all files where you have style classes applied to content, but those styles have
not been defined. This might occur, for example, if you have created a new style class and applied it
to a paragraph in a topic. Later, you remove that style class from the stylesheet. Therefore, you now
have a style in a topic that is no longer defined in the stylesheet. You need to either apply a different,
existing style class to that content, or you need to add the style class to the stylesheet again. You
can also quickly rename or remove multiple style occurrences in a single batch, add the undefined
style to the project, or map the undefined style to an existing style.
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HOW TO VIEW UNDEFINED STYLES

1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select the View ribbon. Then in the Dynamic Reports section, select Undefined
Items > Undefined Styles.

n Analyzer Summary Window Pane Double-click the row that mentions undefined styles.

The Undefined Styles window pane opens.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider:

n Tag Displays the parent tag for the class.

n Style Displays the child style class that is applied to content in the file.

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You also have the option to view all items at once in one long list. This is called the View All
option. You can toggle these views by clicking the View All/View as Pages button in the local
toolbar. The button displays the opposite of whatever view is currently activated (e.g., If the
View All option is currently active, the button shows View as Pages to indicate that if clicked,
the button will switch the window pane to the View as Pages option).
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HOW TO FIX UNDEFINED STYLES

There are a few basic ways to fix an undefined style: (1) You can rename the style; (2) you can
remove the style from the content; (3) you can apply a different style class to the affected content;
(4) you can add a new style to the stylesheet; and (5) you can map the undefined style to an existing
style.

TO RENAME STYLE CLASSES

1. In the window pane, select all style class occurrences that you want to rename. If you want to

select all rows click . You can hold the SHIFT key to select a range, or you can hold the
CTRL key to select individual items.

NOTE: All style class occurrences that you select will be renamed to the same style
that you provide in the following steps.

2. In the local toolbar, click the Rename button. The Rename Style(s) dialog opens.

3. In the New style name field, enter a new style class.

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected style
class occurrences are renamed.

NOTE: If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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TO REMOVE STYLE CLASSES

1. In the window pane, select all style class occurrences that you want to delete. If you want to

select all rows click . You can hold the SHIFT key to select a range, or you can hold the
CTRL key to select individual items.

2. In the local toolbar, click .

3. Click OK.

4. A message lets you know how many files were changed. Click OK. All of the selected style
class occurrences are removed.

NOTE: If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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TO APPLY DIFFERENT STYLE CLASSES

1. Do one of the following, depending on whether you want to open the file in the Analyzer inter-
face or within Flare.

TO OPEN THE FILE IN THE ANALYZER INTERFACE

Double-click the file in the window pane. The benefit of using this method is that it is quick and
convenient. You have access to the features normally available in the editor (but not neces-
sarily to all of the features available elsewhere in Flare).

TO OPEN THE FILE IN FLARE

a. In the window pane, click on the file.

b. Select File > Send to Flare.

The benefit of using this method is that you have access to all of the features in the applic-
ation, not just those available from the editor.

2. Make sure the style select drop-down menu is accessible. Do one of the following, depending
on the part of the user interface you are using:

n Ribbon Select the Home ribbon.

n Tool Strip Select View > Toolbars > Text Formatting. The Text Format toolbar opens.

3. Click the down arrow in the field displaying styles. From the drop-down, select a new style
class. See the online Help in Flare for more information about styles and how to apply them.

4. Click to save your work.

CHAPTER 4  25



TO ADD A NEW STYLE

1. In the window pane, select the style that you want to add to the project.

2. Do one of the following, depending on the part of the user interface you are using:

n Local Toolbar Click .

n Right-Click Right-click on the condition tag you want to add and from the context menu
select Add New Style.

The Create Style dialog opens.

3. On the left side of the dialog, select one of the following:

n Class Select this if you want to create a simple class (e.g., a special paragraph intended
to serve as a tip or note).

n ID Identifiers (IDs) are similar to classes, except that IDs are unique. An element in your
stylesheet can have only one ID on it, whereas it can have multiple classes. And each
page of your output can have only one element with a particular ID. For many authors,
using an ID may not be important, but for others—such as those making use of Javas-
cript—IDs can be very useful.

4. In the field after your selection, type a name for the new style class or ID, without using
spaces.

5. On the right side of the dialog, select the stylesheet to which you want to add the new style.

6. The property values already applied to the selected content are shown. If you do not want to
include certain property values in the new selector, click the check box next to the value (in
the Include column) to remove the check mark.

7. If you want the new style to immediately be applied to the content selected in the topic, select
Create style and update the source element. If you do not want the new style to immediately
be applied to the content selected in the topic, select Create style without updating the
source element.

8. Click OK. The style is added to the currently linked stylesheet.

9. Click to save your work.
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TO MAP TO AN EXISTING STYLE

1. In the window pane, select the style that you want to map to an existing style.

2. Do one of the following, depending on the part of the user interface you are using:

n Local Toolbar Click .

n Right-Click Right-click on the condition tag you want to add and from the context menu
select Map to Existing Style.

The Select Class or ID dialog opens.

3. In the dialog, select the existing style class or ID in the project to overwrite the current
undefined style.

4. Click OK. All of the selected style occurrences are overwritten with the new style.

5. Click to save your work.
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CHAPTER 5

Undefined Variables
You can view a list of all files where you have variables inserted in the content, but those variables
have not been defined. This might occur, for example, if you have inserted a variable in a topic and
then later change the name of the variable or variable set. The old variable or set name is still used
at the location where it was previously inserted in the topic; therefore, a problem exists. From the
Undefined Variables window pane, you can open the topic in question and fix the undefined variable.
You can also quickly rename or remove multiple variables in a single batch, add the undefined vari-
able to the project, or map the undefined variable to an existing variable.
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HOW TO VIEW UNDEFINED VARIABLES

1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select the View ribbon. Then in the Dynamic Reports section, select Undefined
Items > Undefined Variables.

n Analyzer Summary Window Pane Double-click the row that mentions undefined vari-
ables.

The Undefined Variables window pane opens.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider:

n Variable Displays the name of the variable set and the variable within it. The variable set
is listed first, followed by a period and then the name of the variable (e.g., Primary.Com-
panyName).

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

n Tag Displays the tag being used by the variable.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You also have the option to view all items at once in one long list. This is called the View All
option. You can toggle these views by clicking the View All/View as Pages button in the local
toolbar. The button displays the opposite of whatever view is currently activated (e.g., If the
View All option is currently active, the button shows View as Pages to indicate that if clicked,
the button will switch the window pane to the View as Pages option).
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HOW TO FIX UNDEFINED VARIABLES

There are a few ways to fix an undefined variable: (1) You can rename the variable or variable set so
that it matches what you have used in the topic; (2) you can re-insert the variable in the topic so that
it uses an existing variable set/variable name, (3) you can add the undefined variable to the project
as a new variable; and (4) you can map the the undefined variable to an existing variable.

TO RENAME VARIABLES

1. In the window pane, select all variable occurrences that you want to rename. If you want to

select all rows click . You can hold the SHIFT key to select a range, or you can hold the
CTRL key to select individual items.

NOTE: All variable occurrences that you select will be renamed to the same variable
that you provide in the following steps.

2. In the local toolbar, click the Rename button. The Rename Variable(s) dialog opens.

3. In the New variable name field, enter a new variable. Type the name of the variable set, fol-
lowed by a period, then the name of the variable (e.g., MyVariableSet.MyVariableName).

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected variable
occurrences are renamed.

NOTE: If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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TO RE-INSERT VARIABLES

1. Do one of the following, depending on whether you want to open the file in the Analyzer inter-
face or within Flare.

TO OPEN THE FILE IN THE ANALYZER INTERFACE

Double-click the file in the window pane. The benefit of using this method is that it is quick and
convenient. You have access to the features normally available in the editor (but not neces-
sarily to all of the features available elsewhere in Flare).

TO OPEN THE FILE IN FLARE

a. In the window pane, click on the file.

b. Select File > Send to Flare.

The benefit of using this method is that you have access to all of the features in the applic-
ation, not just those available from the editor.

2. Re-insert the variable in the topic, selecting an existing name from a variable set. See the
online Help in Flare for more information about inserting variables.
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TO ADD A NEW VARIABLE

1. In the window pane, select all variable occurrences that you want to add to the project. If you

want to select all rows click . You can hold the SHIFT key to select a range, or you can hold
the CTRL key to select individual items.

2. Do one of the following, depending on the part of the user interface you are using:

n Local Toolbar Click .

n Right-Click Right-click on the variable you want to add and from the context menu
select Add Variable.

The Variable Set Editor opens, with the new variable(s) displayed.

NOTE: When you create a new variable, one of two things will happen:

1. If the Variable Set file specified for the undefined variable exists in the project,
Analyzer will add the new variable to the existing Variable Set file.

2. If the Variable Set file specified for the undefined variable does not exist in the
project, Analyzer will create a brand new Variable Set file in the project and add
the variable to that file.

3. (Optional) In the Variable Set Editor, edit the variable's properties (e.g., name, definition, com-
ment).

4. Click to save your work.
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TO MAP TO AN EXISTING VARIABLE

1. In the window pane, select all variable occurrences that you want to map to an existing vari-

able. If you want to select all rows click . You can hold the SHIFT key to select a range, or
you can hold the CTRL key to select individual items.

2. Do one of the following, depending on the part of the user interface you are using:

n Local Toolbar Click .

n Right-Click Right-click on the variable you want to add and from the context menu
select Map to Existing Variable.

The Variables dialog opens.

3. In the dialog, select the existing variable in the project to overwrite the current undefined vari-
able reference.

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected variable
occurrences are overwritten with the new variable.

NOTE: If you want to undo the conversions, you can use the Backups window pane
(View > Backups).

6. Click to save your work.

NOTE: Another way to replace a variable in many places throughout a project is to use the
Find and Replace in Files feature in Flare. For example, let's say that you originally inserted a
variable named "Company" (from the "Primary" variable set) in a lot of places in your project.
Later, you renamed the variable "Branch." You can perform a find and replace throughout
your entire project. In the "Find" field, you can enter Primary.Company, and in the
"Replace with" field, you can enter Primary.Branch. Also, make sure you select the "Find
in source code" option in the Find and Replace in Files window pane. After replacing this text
throughout your project, that variable will no longer be considered "undefined" in Analyzer.
For information about using the Find and Replace in Files feature, see the online Help in
Flare.
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APPENDIX

PDFs
The following PDFs are available for download from the online Help.

Concepts Guide Statistics & Charts Guide

Condition Tags Guide Styles Guide

Context-sensitive Help Guide Suggestions Guide

File Tags Guide Tables of Contents Guide

Frequent Segments Guide Topics Guide

Getting Started Guide Touring the Workspace Guide

Index Guide Track Changes Guide

Key Features Guide Undefined Items Guide

Links Guide Unused Items Guide

Reports Guide Variables Guide

Shortcuts Guide What's New Guide

Snippets Guide
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