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CHAPTER 1

Viewing Used Variables
You can view a list of variables that have been inserted in your project. The list shows not only the
variables, but each topic where they have been used. You can also quickly rename or remove mul-
tiple variable occurrences in a single batch.
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HOW TO VIEW USED VARIABLES

1. Open a project.

2. Select the View ribbon. In the Dynamic Reports section, select Used Items > Used Variables.

The Used Variables window pane opens, listing all of the variables used throughout the pro-
ject, including snippet variables.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider:

n Variable Displays the name of the variable set and the variable within it. The variable set
is listed first, followed by a period and then the name of the variable (e.g., Primary.Com-
panyName).

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

n Tag Displays the tag being used by the variable.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You also have the option to view all items at once in one long list. This is called the View All
option. You can toggle these views by clicking the View All/View as Pages button in the local
toolbar. The button displays the opposite of whatever view is currently activated (e.g., If the
View All option is currently active, the button shows View as Pages to indicate that if clicked,
the button will switch the window pane to the View as Pages option).

5. You can open any file in the list to view or modify it in an editor. You can open the file in the
Analyzer interface or in the Flare project.

TO OPEN THE FILE IN THE ANALYZER INTERFACE

Double-click the file in the window pane. The benefit of using this method is that it is quick and
convenient. You have access to the features normally available in the editor (but not neces-
sarily to all of the features available elsewhere in Flare).

TO OPEN THE FILE IN FLARE

a. In the window pane, click on the file.

b. Select File > Send to Flare.
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The benefit of using this method is that you have access to all of the features in the applic-
ation, not just those available from the editor.

HOW TO RENAME VARIABLE OCCURRENCES

1. In the window pane, select all variable occurrences that you want to rename. If you want to

select all rows click . You can hold the SHIFT key to select a range, or you can hold the
CTRL key to select individual items.

NOTE: All variable occurrences that you select will be renamed to the same variable
that you provide in the following steps.

2. In the local toolbar, click the Rename button. The Rename Variable(s) dialog opens.

3. In the New variable name field, enter a new variable. Type the name of the variable set, fol-
lowed by a period, then the name of the variable (e.g., MyVariableSet.MyVariableName).

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected variable
occurrences are renamed.

NOTE: If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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CHAPTER 2

Viewing Undefined Variables
You can view a list of all files where you have variables inserted in the content, but those variables
have not been defined. This might occur, for example, if you have inserted a variable in a topic and
then later change the name of the variable or variable set. The old variable or set name is still used
at the location where it was previously inserted in the topic; therefore, a problem exists. From the
Undefined Variables window pane, you can open the topic in question and fix the undefined variable.
You can also quickly rename or remove multiple variables in a single batch, add the undefined vari-
able to the project, or map the undefined variable to an existing variable.
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HOW TO VIEW UNDEFINED VARIABLES

1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select the View ribbon. Then in the Dynamic Reports section, select Undefined
Items > Undefined Variables.

n Analyzer Summary Window Pane Double-click the row that mentions undefined vari-
ables.

The Undefined Variables window pane opens.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider:

n Variable Displays the name of the variable set and the variable within it. The variable set
is listed first, followed by a period and then the name of the variable (e.g., Primary.Com-
panyName).

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

n Tag Displays the tag being used by the variable.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You also have the option to view all items at once in one long list. This is called the View All
option. You can toggle these views by clicking the View All/View as Pages button in the local
toolbar. The button displays the opposite of whatever view is currently activated (e.g., If the
View All option is currently active, the button shows View as Pages to indicate that if clicked,
the button will switch the window pane to the View as Pages option).
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HOW TO FIX UNDEFINED VARIABLES

There are a few ways to fix an undefined variable: (1) You can rename the variable or variable set so
that it matches what you have used in the topic; (2) you can re-insert the variable in the topic so that
it uses an existing variable set/variable name, (3) you can add the undefined variable to the project
as a new variable; and (4) you can map the the undefined variable to an existing variable.

TO RENAME VARIABLES

1. In the window pane, select all variable occurrences that you want to rename. If you want to

select all rows click . You can hold the SHIFT key to select a range, or you can hold the
CTRL key to select individual items.

NOTE: All variable occurrences that you select will be renamed to the same variable
that you provide in the following steps.

2. In the local toolbar, click the Rename button. The Rename Variable(s) dialog opens.

3. In the New variable name field, enter a new variable. Type the name of the variable set, fol-
lowed by a period, then the name of the variable (e.g., MyVariableSet.MyVariableName).

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected variable
occurrences are renamed.

NOTE: If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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TO RE-INSERT VARIABLES

1. Do one of the following, depending on whether you want to open the file in the Analyzer inter-
face or within Flare.

TO OPEN THE FILE IN THE ANALYZER INTERFACE

Double-click the file in the window pane. The benefit of using this method is that it is quick and
convenient. You have access to the features normally available in the editor (but not neces-
sarily to all of the features available elsewhere in Flare).

TO OPEN THE FILE IN FLARE

a. In the window pane, click on the file.

b. Select File > Send to Flare.

The benefit of using this method is that you have access to all of the features in the applic-
ation, not just those available from the editor.

2. Re-insert the variable in the topic, selecting an existing name from a variable set. See the
online Help in Flare for more information about inserting variables.
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TO ADD A NEW VARIABLE

1. In the window pane, select all variable occurrences that you want to add to the project. If you

want to select all rows click . You can hold the SHIFT key to select a range, or you can hold
the CTRL key to select individual items.

2. Do one of the following, depending on the part of the user interface you are using:

n Local Toolbar Click .

n Right-Click Right-click on the variable you want to add and from the context menu
select Add Variable.

The Variable Set Editor opens, with the new variable(s) displayed.

NOTE: When you create a new variable, one of two things will happen:

1. If the Variable Set file specified for the undefined variable exists in the project,
Analyzer will add the new variable to the existing Variable Set file.

2. If the Variable Set file specified for the undefined variable does not exist in the
project, Analyzer will create a brand new Variable Set file in the project and add
the variable to that file.

3. (Optional) In the Variable Set Editor, edit the variable's properties (e.g., name, definition, com-
ment).

4. Click to save your work.
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TO MAP TO AN EXISTING VARIABLE

1. In the window pane, select all variable occurrences that you want to map to an existing vari-

able. If you want to select all rows click . You can hold the SHIFT key to select a range, or
you can hold the CTRL key to select individual items.

2. Do one of the following, depending on the part of the user interface you are using:

n Local Toolbar Click .

n Right-Click Right-click on the variable you want to add and from the context menu
select Map to Existing Variable.

The Variables dialog opens.

3. In the dialog, select the existing variable in the project to overwrite the current undefined vari-
able reference.

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected variable
occurrences are overwritten with the new variable.

NOTE: If you want to undo the conversions, you can use the Backups window pane
(View > Backups).

6. Click to save your work.

NOTE: Another way to replace a variable in many places throughout a project is to use the
Find and Replace in Files feature in Flare. For example, let's say that you originally inserted a
variable named "Company" (from the "Primary" variable set) in a lot of places in your project.
Later, you renamed the variable "Branch." You can perform a find and replace throughout
your entire project. In the "Find" field, you can enter Primary.Company, and in the
"Replace with" field, you can enter Primary.Branch. Also, make sure you select the "Find
in source code" option in the Find and Replace in Files window pane. After replacing this text
throughout your project, that variable will no longer be considered "undefined" in Analyzer.
For information about using the Find and Replace in Files feature, see the online Help in
Flare.
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CHAPTER 3

Viewing Unused Variables
You can view a list of all variables that have been created in your project but have not yet been used
in any topics or other files. You can quickly delete any of the variables that you do not plan to use.
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HOW TO VIEW UNUSED VARIABLES

1. Open a project.

2. Select the View ribbon. In the Dynamic Reports section, select More Reports > Unused Items.

The Unused Items window pane opens, which allows you to view various unused elements in
the project (such as bookmarks, condition tags, content files, CSH IDs, images, variables,
styles, file tags, and topics not linked).

3. Click the drop-down field at the top of the window pane and select Unused Variables. The
unused variables in the project are listed.

4. To see more of the information in the window pane, drag the divider bar to make the pane
wider:

n Variable Displays the name of the variable not being used.

n File Displays the name of the variable set where the variable is located.

n Definition Displays the text associated with the variable.

5. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You also have the option to view all items at once in one long list. This is called the View All
option. You can toggle these views by clicking the View All/View as Pages button in the local
toolbar. The button displays the opposite of whatever view is currently activated (e.g., If the
View All option is currently active, the button shows View as Pages to indicate that if clicked,
the button will switch the window pane to the View as Pages option).

6. If you want to remove any unused variables from Analyzer, as well as from the project being

analyzed, select the variable in the list and click in the local toolbar.

7. You can open the set file for any variable in the list to view or modify it in the Variable Set
Editor. You can open the variable set in the Analyzer interface or in the Flare project.

TO OPEN THE FILE IN THE ANALYZER INTERFACE

Double-click the file in the window pane. The benefit of using this method is that it is quick and
convenient. You have access to the features normally available in the editor (but not neces-
sarily to all of the features available elsewhere in Flare).
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TO OPEN THE FILE IN FLARE

a. In the window pane, click on the file.

b. Select File > Send to Flare.

The benefit of using this method is that you have access to all of the features in the applic-
ation, not just those available from the editor.
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CHAPTER 4

Viewing Variable Suggestions
You can view regular text that matches existing variables in your project, and then quickly convert
these occurrences to variables. You can also double-click a row to open the topic in question, with
the potential variable text highlighted.
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HOW TO VIEW VARIABLE SUGGESTIONS

1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select the View ribbon. In the Dynamic Reports section, select Variable Sugges-
tions.

n Analyzer Summary Window Pane Double-click the row that mentions variable sug-
gestions.

The Variable Suggestions window pane opens, listing all of the variable suggestions for the
project.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider:

n Apply Displays a check box next to the variable suggestion. If you decide to replace the
content with the suggested variable, you need to make sure the check box is selected. If
you do not want to replace the content with the variable, but you do want to replace other
content in the list, you can click the check box to remove the check mark.

n Suggestion Displays the suggestion that Analyzer is making to you (i.e., "Replace with
Variable").

n Type Displays the name of the variable set and the name of the variable (e.g.,
Primary.CompanyName).

n Context Displays the context of the variable in question. In other words, it displays words
that are found before the variable tag.

n File Displays the path and name of the file where the content in question is found.

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You also have the option to view all items at once in one long list. This is called the View All
option. You can toggle these views by clicking the View All/View as Pages button in the local
toolbar. The button displays the opposite of whatever view is currently activated (e.g., If the
View All option is currently active, the button shows View as Pages to indicate that if clicked,
the button will switch the window pane to the View as Pages option).
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HOW TO CONVERT SUGGESTIONS TO VARIABLES

Do one of the following, depending on whether you want to convert multiple suggestions to a vari-
able simultaneously, or if you want to convert only one suggestion at a time.

TO CONVERT MULTIPLE SUGGESTIONS SIMULTANEOUSLY

1. In the window pane, select all suggestions that you want to convert. If you want to select all

rows click . You can hold the SHIFT key to select a range, or you can hold the CTRL key to
select individual items.

2. In the local toolbar, click the Apply button.

3. In the message that opens, click OK. Another message lets you know how many files were
changed.

4. Click OK. All of the selected suggestions are converted to variables.

NOTE: If you want to undo the conversions, you can use the Backups window pane
(View > Backups).

TO CONVERT ONE SUGGESTION AT A TIME

1. In the Variable Suggestions window pane, select the row that you want to convert to a vari-
able.

2. Select File > Send to Flare. The file opens in the application with the suggested content high-
lighted.

3. In Flare, insert the variable (e.g., select Insert > Variable).

See the online Help in Flare for more information about inserting variables.
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APPENDIX

PDFs
The following PDFs are available for download from the online Help.

Concepts Guide Statistics & Charts Guide

Condition Tags Guide Styles Guide

Context-sensitive Help Guide Suggestions Guide

File Tags Guide Tables of Contents Guide

Frequent Segments Guide Topics Guide

Getting Started Guide Touring the Workspace Guide

Index Guide Track Changes Guide

Key Features Guide Undefined Items Guide

Links Guide Unused Items Guide

Reports Guide Variables Guide

Shortcuts Guide What's New Guide

Snippets Guide
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