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CHAPTER1 Introduction

Welcome toMadCapMovieSync—a unique application used for quickly transferringmovie and frame
properties from oneMadCapMimicmovie to another. These properties can include objects (e.g.,
shapes, cursors, typing boxes), timing, sizes, andmore.

MovieSync is especially usefulwhen you are recording a new version of amovie wheremost of the
framesare the same as those in the older version of themovie. It is designed to replace themanual
work involved in copying or re-creating all of the variousproperties in each frame so that the new
movie looksand behaves the samewayas the older movie.

This chapter discusses the following.

Basic Steps 2

Getting Additional Help 4
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Basic Steps

Following are the basic steps for usingMovieSync.

1. Open old and new movies In order to transfer properties from onemovie to another, you first need
to open bothmovies in MovieSync. The frames for eachmovie are shown side-by-side in the Frames
window pane. The frames for the oldmovie are displayed on the left, and the frames for the new
movie are shown on the right. See "OpeningMimicMovies" on page 11.

2. Align frames After your old and newmoviesare loaded, you canmake sure that the frames for each
are aligned properly.When you perform the transfer, the properties and objects from the frame on the
left (old movie) will be copied to whatever frame is immediately to its right (newmovie). See "Aligning
Frames" on page 15.

3. (Optional) View and select properties After aligning frames, you can immediately transfer the
properties. However, before you do that, youmight want to examine all of the properties that
MovieSynchas identified, just in case there are some that you do not want to transfer. As you select
each aligned frame, the Propertieswindow pane lists all of the properties for eachmovie. It also
displaysanydifferencesbetween the old and newmoviesby showing those properties in red. You can
select or deselect anyproperties to be copied. See "Viewing and Selecting Properties" on page 17.

4. Transfer properties Once you are satisfied that the old and newmoviesare aligned properly and all
of the correct properties for each frame are selected, you can transfer (copy) properties and objects
from the oldmovie to the newmovie. You can do this one frame at a time, or you can click a button to
transfer properties and objects for all framesat the same time. See "Transferring Properties" on page
19.

5. Save movie After transferring properties successfully from the oldmovie to the newmovie, you can
save your changes. Then you can open the newmovie in Mimic tomake further edits to themovie and
generate output for it. See "SavingMovies" on page 21.

.
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CHAPTER 1 Introduction

E X A M P L E

Let's say you have created a 75-framemovie that showsend users how to use your company's
software application. In all of those framesyou have spent hours adding objects such as callouts and
buttons, placing actionson those objects, specifying precise timing for your cursor movements, and
more.

Later, your company releasesa new version of that software, and youmust update your movie
accordingly. Because the user interface of the software application has changed and there are a few
new features that need to be included, you will need to completely re-record themovie. Suppose that
when you are finished, the newmovie is 96 frames long, and 71 of those framesare virtually the same
as those in the oldmovie.

Now that you are finished with the recording task, youmust make sure all of your objects, actions,
timing, and other settingsare in place. You could spend hoursmanually re-creating all of those
properties, but instead you useMovieSync to do this automatically.

Therefore you open both the old and newmovies in MovieSync. You align the framesso that theyare
partnered with their correct counterparts, and you use the Propertieswindow pane to take a lookat
the exact properties that will be transferred. Because there aremore frames in the newmovie, there
will be some frames that do not havematching frames. These aremarked as "new frames."

Once the framesare aligned and you are satisfied with all of the properties listed in the Properties
window pane, you click a button and copyall of the properties from the oldmovie to the newmovie.
Finally, you save the newmovie so that you can open it in Mimic and continue workon it and generate
output. Although there are some frames in the newmovie for which you will need to provide
properties, there are 71 frames that are already finished and only require testing.
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Getting Additional Help
You can use anyof the following resources for additional help not provided in thismanual.

Knowledge Base

You can browse the online Knowledge Base for articles covering common support issues.

http://kb.madcapsoftware.com/

Peer-to-Peer Online Forums

You can visit the online forums to learn from other users or share your own expertise.

http://forums.madcapsoftware.com/

Contact MovieSync Support

You can contact theMovieSync support team and get answers to your specific support issues.

http://madcapsoftware.com/support/

MADCAP MOVIESYNC
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CHAPTER2 Touring theWorkspace

MovieSync'sworkspace is flexible, usesamodernMultiple Document Interface (MDI), and gives you
several options to work the way that you want.

This chapter discusses the following.

Main Sections of the Interface 6

Start Page 8

Frames Window Pane 9

Properties Window Pane 10

Frame Editor 10
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Main SectionsOf The Interface

MovieSync's user interface consists of the followingmajor sections.

Top The top portion of theMovieSync interface displayseither a ribbon view, or amenu/toolbar view,
which are used to access features.

Left The left side of theMovieSync interface is the default location for somewindow paneswhen you
open them. This includes the Frameswindow pane, which is probably themost important window
pane inMovieSync.

Middle The largemiddle section of theMovieSync interface is the default location for editors such as
the Frame Editor, which iswhere you can edit the currently selected frame for the newmovie. It also
displays the Start Page, which is used for quickly performing high-level tasksand accessing
information.

Right The right side of theMovieSync interface (like the left side) is the default location for various
window panes (e.g., DynamicHelp window pane) when you open them.

Bottom The bottom area of theMovieSync interface is the default location for yet more window
panes (e.g., Propertieswindow pane).

MADCAP MOVIESYNC
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CHAPTER 2 Touring the Workspace

The elements in this example are somewhat "scrunched together" and therefore difficult to see. However, you
have the flexibility to close or move elements around as you like, so it is not mandatory that everywindow pane
remain permanently in its default location or at its current size.

In addition to themain areas, the interface also consists of menus, global toolbars, and local toolbars.
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Start Page

The Start Page is a handywindow pane that displayswhen you first launchMovieSyncand remainsopen
unless you close it. Thiswindow pane consists of three sections (Recent Files, Getting Started, and Newsand
Updates), which contain links to high-level tasksand information.

MADCAP MOVIESYNC
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CHAPTER 2 Touring the Workspace

FramesWindow Pane

The Frameswindow pane is probably themost important element in the interface. It is split into two halves,
showing the frames from both your old and newmovie.With thiswindow pane you can align frames for your
movies. You can then transfer the properties and objects from your oldmovie to the newmovie. In addition, you
can use thiswindow pane to view the oldmovie version or switch to a different old movie version.
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PropertiesWindow Pane

After aligning frames, you can immediately transfer the properties. However, before you do that, youmight
want to examine all of the properties that MovieSynchas identified, just in case there are some that you do not
want to transfer. As you select each aligned frame, the Propertieswindow pane lists all of the properties for
eachmovie. It also displaysanydifferencesbetween the old and newmoviesby showing those properties in
red. You can select or deselect anyproperties to be copied.

Frame Editor

When you openmovies in MovieSync, the current frame for the newmovie is shown in this editor. It is the same
editor that is used inMimic, but with fewer features (e.g., you can draw objects, but you cannot set properties
for them; youmust do this in Mimic).

MADCAP MOVIESYNC
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CHAPTER3 OpeningMimic Movies

In order to transfer properties from onemovie to another, you first need to open bothmovies in
MovieSync. The frames for eachmovie are shown side-by-side in the Frameswindow pane. The
frames for the oldmovie are displayed on the left, and the frames for the newmovie are shown on the
right.

This chapter discusses the following.

Methods for Opening Movies 12

Changing the Old Movie Version 14
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Methods For OpeningMovies
There aremultiple ways to openmovies.

HOW TO OPEN MOVIES USING THE OPEN DIALOG

1. Do one of the following, depending on the part of the user interface you are using.

Ribbon Select File>Open.

You can use theOptionsdialog to switch between ribbonsand the classicmenu/toolbar
layout. For more information see the online Help.

Keep inmind that the smaller the application window becomes, themore the options in a
ribbon shrink. Therefore, youmight only see a small icon instead of text, or youmight see only
a section name displayed with a down arrow to access the options in it. You can hover over
small icons to see tooltips that describe them. You can also enlarge the application window or
click one of the section drop-downs in the ribbon to locate a hidden feature.

Menu Select File>Open.

Standard toolbarClick .

Keyboard shortcut PressCTRL+Oon the keyboard.

Getting Started Wizard SelectOpen.

2. In the Open dialog, click theBrowse button in each of the fields to find and select your old movie and
newmovie (MIMOV files).

3. ClickOK.Themoviesare loaded. The frames for eachmovie are shown in the Frameswindow pane.
The "newmovie" frame that is selected is also shown in the Frame Editor to the right.

HOW TO OPEN A RECENT MOVIE USING THE FILE MENU

Select File>Recent Files>[Name of MIMOV file].If you use this option to select amovie, the other
movie that waspreviously opened with it is also loaded into the interface.

.
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CHAPTER 3 Opening Mimic Movies

HOW TO OPEN A RECENT MOVIE USING THE START PAGE

On the Start Page, the area labeledRecent Files lists themost recently openedmovies.

To open the start page, do one of the depending on the part of the user interface you are using.

Ribbon Select theHome ribbon. In theView section, selectStart Page.

Menu SelectView>Start Page.

Standard toolbarClick .

Click the file you want to open. Themovie is loaded into the interface. If you use this option to select a
movie, the other movie that waspreviously opened with it is also loaded into the interface.

HOW TO OPEN MOVIES BY DRAGGING FILES FROM WINDOWS

1. OpenWindowsand navigate to a folder containing aMimicmovie file.

2. LaunchMovieSync.

3. Drag themovie file fromWindows to the application window and drop it on the title bar in MovieSync.

13



Changing TheOldMovie Version
After openingmovie files, you can select a different "old" movie to replace the one currently loaded.

HOW TO CHANGE THE OLD MOVIE VERSION

1. Select File>Change Old Version.

2. In the Open dialog, click theBrowse button, then find and double-click another movie (MIMOV file).

3. ClickOK. Themovie on the left side of the Frameswindow pane is replaced with themovie you
selected.

MADCAP MOVIESYNC
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CHAPTER4 Aligning Frames

After your old and newmoviesare loaded, you canmake sure that the frames for each are aligned
properly.When you perform the transfer, the properties and objects from the frame on the left (old
movie) will be copied to whatever frame is immediately to its right (newmovie).

HOW TO ALIGN FRAMES

1. Make sure the split Frameswindow pane is open.

2. (Optional) If the frameson one side are larger or smaller than the frameson the other side,
you can drag the divider bar to the left or right until the framesare roughly the same size.
This helps to see which framesare aligned with which.

3. You can use anyof the following in the local toolbar to make sure that the framesare aligned
the way that you want.

Drag and
Drop

You can drag any frame up or down and drop it where you want.

Click this button if you want to marka frame on the left (old movie) side as
removed. That is, the framewas relevant in the oldmovie, but not in the
newmovie.When you click this button, the frameson the right will be
shifted downward so that no corresponding frame is next to it.

Click this button tomove the selected frame up.

Click this button tomove the selected frame down.

Click this button to inserted the selected frame into the newmovie, thus
shifting the other frames in the newmovie downward as the new frame is
added.
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Click this button if you want to marka frame on the right (newmovie) side
asnew. That is, the frame doesnot appear in the oldmovie, but was
added when you recorded the newmovie.When you click this button, the
frameson the left will be shifted downward so that no corresponding
frame is next to it.

MADCAP MOVIESYNC
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CHAPTER5 Viewing and Selecting Properties

After aligning frames, you can immediately transfer the properties. However, before you do that, you
might want to examine all of the properties that MovieSynchas identified, just in case there are some
that you do not want to transfer. As you select each aligned frame, the Propertieswindow pane lists
all of the properties for eachmovie. It also displaysanydifferencesbetween the old and newmovies
by showing those properties in red. You can select or deselect anyproperties to be copied.

HOW TO VIEW AND SELECT PROPERTIES FOR TRANSFER

1. If the Propertieswindow pane is not alreadydisplayed, open it by doing one of the following.

SelectHome>Properties Window (if using ribbon view) or View>Properties
Window (if using tool strip view).

OR

In the Standard toolbar, click .

2. If the split Frameswindow pane is not alreadydisplayed, open it by doing one of the
following.

SelectHome>Frames Window (if using ribbon view) or View>Frames Window
(if using tool strip view).

OR

In the Standard toolbar, click .

3. In the Frameswindow pane, select a frame.

The properties are shown in the Propertieswindow pane (the "Level" column indicates
whether a particular property is set at the frame or movie level). MovieSynchighlights in red
anyproperties that are different in the old and newmovies, and the checkbox is
automatically selected, whichmeans that those propertieswill be transferred.
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4. If you want to select or deselect anyproperties, click in the appropriate checkbox. If the property is the
same in the old and newmovies, there is no need to select the checkboxnext to it.

Note: Anyobjects (e.g., shapes, cursor trajectories) from the oldmovie are automatically transferred,
even though theyare not shown in the Propertieswindow pane. In addition, anyobjects that might
have been in the newmovie are automatically removed from those frames.

MADCAP MOVIESYNC
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CHAPTER6 Transferring Properties

Once you are satisfied that the old and newmoviesare aligned properly and all of the correct
properties for each frame are selected, you can transfer (copy) properties and objects from the old
movie to the newmovie. You can do this one frame at a time, or you can click a button to transfer
properties and objects for all framesat the same time.

HOW TO TRANSFER PROPERTIES

1. In the Frameswindow pane, do one of the following.

If you want to transfer the properties for all frames, click in the local toolbar.

OR

If you want to transfer the properties for only the frame that is currently selected,

click in the local toolbar.

2. In the confirmation dialog that opens, clickOK.

The properties (at least those selected in the Propertieswindow pane) are transferred from
the oldmovie to the newmovie.

Note: Anyobjects (e.g., shapes, cursor trajectories) from the oldmovie are
automatically transferred, even though theyare not shown in the Properties
window pane. In addition, anyobjects that might have been in the newmovie are
automatically removed from those frames.
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CHAPTER7 SavingMovies

After transferring properties successfully from the oldmovie to the newmovie, you can save your
changes. Then you can open the newmovie in Mimic tomake further edits to themovie and generate
output for it.

HOW TO SAVE A MOVIE

Use one of the following save options from the File drop-down, File menu, Standard toolbar, or
keyboard shortcuts.

File>Save Saves changes to the active file.

File>Save As Opens the Save Asdialog, which lets you save the active file under a different
name and/or file type and to a particular location. The new file is then
displayed in the editor.

File>Save To Opens the Save Asdialog, which lets you save the active file under a different
name and/or file type and to a particular location. The new file is not
automatically displayed in the editor.

File>Save All Saves changes to all of the open files.

File>Send To Opensa submenu, which lets you open the active file in another application,
attach it to an email, or open theWindows folder where it is stored.

CTRL+S Saves changes to the active file.

CTRL+SHIFT+S Saves changes to all of the open files.

21
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CHAPTER8 PreviewingMovies

Previewing amovie is an extremely important and useful part of creating amovie. This gives you a
chance to see how amovie looksand workswithout having to build themovie or collection.

You can preview amovie in various "chunks," depending on howmuch you want to see—preview
entire movie, current frame, starting at the current frame, next 5 frames, or next 10 frames.

There is no need to wait for the application to process your movie when you want to preview it (or part
of it). In MovieSync, the preview is immediate, whether you are previewing 1 frame, 10 frames, or
100 frames.

HOW TO PREVIEW A MOVIE

1. Open themovie.

2. In the local toolbar of the Frame Editor, click the down arrow next to theQuick Preview

button and select one of the preview options.

MoviePreviews the entire movie.

This FramePreviews the frame currently selected.

Start at this FramePreviews themovie starting with the current frame, until the
end of themovie.

Next 5 FramesPreviews the current frame and the next 4 frames.

Next 10 FramesPreviews the current frame and the next 9 frames.

TheMadCapMovie Viewer opensand plays the selected portionsof themovie.

3. Close the viewer when you are finished.
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Note:When you preview amovie, it alwaysopens in theMadCapMovie Viewer (which is used for
displaying output generated from theMadCapMimicMovie Format). Even if you plan to createmovie
output using browser-based output (HTML5, Adobe AIR, Adobe Flash, Microsoft Silverlight), the
MadCapMovie Viewer is used for the preview feature.

MADCAP MOVIESYNC
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CHAPTER9 Viewing theOldMovie Version

When youmake a selection in the Frameswindow pane, the current frame for the newmovie is
shown to the right in the Frame Editor. If you want to see frames for the oldmovie, you can do so by

clicking the appropriate button in the local toolbar of the Frameswindow pane or the Frame
Editor.

HOW TO VIEW THE OLD MOVIE VERSION

1. In the local toolbar of the Frameswindow pane or Frame Editor, click .

Awindow opens, showing the first frame of the oldmovie. Thiswindow ismuch like the
Frame Editor, in that it lets you navigate through the framesand use the scale buttonsat the
bottom to increase or decrease the size of the frames. You can also use a drop-down field at
the bottom to show or hide anymaster frames that might be part of a frame. Finally, you can
selectView>Draw Trajectories to hide or show any cursor trajectories on the frame.

Button Description

OK Closes the window.

Opens the first frame in themovie.

Opens the previous frame in the sequence of themovie.

Opens the next frame in themovie.

Opens the last frame in themovie.

Lets you select a specific percentage to scale the frame.
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Button Description

Reduces the scale of the frame by100%each time you click
the button.

Resets the scale of the frame to 100%.

Increases the scale of the frame by100%each time you click
the button.

Scales the frame so that itswidth fits in the Frame Editor.

Scales the frame so that its height fits in the Frame Editor.

2. When you are finished, clickOK to close the window.

MADCAP MOVIESYNC
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APPENDIX PDFGuides

You can download anyof the following PDF guides from the online Help. Just open the topic called
"PDF Guides" and click anyof the download links. You can also scan anyof the followingQR codes to
open the PDF on your mobile device.

Getting Started What's New Shortcuts
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