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1 Introduction

Welcome toMadCap Flare—the first native XML content authoring application.

Flare offers the following:

Single-source XML authoring

Styling with cascading stylesheets (CSS)

Multi-channel publishing for theWeb, desktop, print, andmobile devices

A flexible, open-architecture; you can edit files outside of Flare

Full support for left-to-right (LTR) as well as right-to-left (RTL) languages

Knowledge of XML or HTML not required
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Where Do I Begin?
Following are some suggestions to help ease you into the world of Flare.

Training
Consider signing up for a training course. It’s well worth your time and will go a long way toward getting you
off on the right foot. See http://www.madcapsoftware.com/services/training/flaretraining.aspx.

Website Resources
Just by taking a quick look around themadcapsoftware.com website, you’ll find some great free resources,
such as webinars (both live and recorded) and theMadCap blog (with tips and tricks).

Videos
Several videos were developed to familiarize you with Flare quickly. To see these videos open the Start
Page (View>Start Page) and select the Tutorials tab.

PDFGuides
You can download and read the Flare PDFmanuals. See "PDF Guides" on page 39.

http://www.madcapsoftware.com/services/training/flaretraining.aspx
http://www.madcapsoftware.com/
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Introduction Topics
Here are a few topics that we recommend for new users. See the online Help to view these topics.

Basic Steps for Creating and Developing a Project

The Flare workflow can be reduced to just a handful of steps. The real strength of Flare is that you
canmaintain content in one place but generate it in multiple formats.

Key Features

This topic discusses some of the key features that make Flare unique.

Touring the Workspace

Flare's workspace is flexible, uses amodernMultiple Document Interface (MDI), and gives you sev-
eral options to work the way that you want. This topic introduces you to themain parts of the Flare
user interface.
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Project Templates
When you’re ready to start working in Flare, there’s something else we suggest you do before tackling your
own content—create a test project. Treat it like a sandbox. Play around with things. See how it feels.

On the Start Page, select the Tem-
plates tab. Then choose any tem-
plate that you like. Youmight want
to begin with a basic template and
later move on to an advanced one.
After selecting a template, complete
the information in the wizard in just a
few steps. See "Creating a New Pro-
ject" on page 15.

What you’ve got now is an actual
Flare project that already has con-
tent and various pieces in place. You

can do anything with this project that you want, including replacing the content and styles with your own,
and building output from it.
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Tutorials—HowDid You Do That?
Take a look around at the various outputs that you can generate from the different project templates. Click
on things. See what things look like and what they do. Then at some point, when you’re a little bit more com-
fortable with Flare, open the web version of the online Help (at webhelp.madcapsoftware.com) and click
the Tutorialsmenu. You can use the "How Did You Do That?" tutorial topics to learn how we created the
features found in some of Flare's factory project templates.

http://webhelp.madcapsoftware.com/
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Content Reuse andMore
There are seemingly an endless number of things you can do in Flare. But you don't have to do them all.
There are actually just a few concepts and features that are themost important to grasp. Don’t expect to be
an expert at everything right away. Instead, begin by trying to wrap your brain around a few concepts and
features that aremost important when it comes to learning Flare. These concepts and features all tend to
revolve around the idea of content reuse (or single-sourcing), whichmeans that you can take the same con-
tent, re-use it, and producemultiple outputs from it.

Building Blocks—Content Reuse
In other authoring tools, you’re probably used to everything being a part of a single file—the content, the
table of contents, the glossary, the styles, and so on. It’s not like that in Flare. Instead, most of the pieces
are separate. This is one of the things that helps make Flare so powerful and give you somuch flexibility in
how to create your output.

Your content is stored in topic files and in smaller snippet files. And images exist separately as image files
and are included in topics and snippets by reference. Your table of contents is a different file. The glossary
is yet another file. The styles are stored in a separate cascading stylesheet file. In fact, youmight even
have a project with multiple TOCs, multiple glossaries, andmultiple stylesheets. It all depends on how you
want to work.

As far as indexes are concerned, they're created in part by inserting index keywords into topics and snip-
pets. There is no separate index file in the Flare project. However, for themost part, you’re dealing with sep-
arate files as building blocks.

Then you use another file called a "target" to take all of these pieces, merge them together, and generate
the output you want. It’s kind of like putting a bunch of ingredients into a food processor and ending up with
a smoothie.

Topic-based Authoring
Topics are where you type your text and other content. If you come from the world of print publishing, you’ll
probably be tempted at first to create really long topics—such as one topic for each chapter or even one
topic for an entire PDFmanual. And while Flare lets you create very long topics and theremay be cases
where you need to do that, for themost part, you want your topics to be smaller, digestible chunks of con-
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tent that you can reuse for different outputs. One chapter in a PDF that you create from Flare will usually
consist of several separate topics.

But don’t make your topics too short either. We’re not necessarily talking about single sentences or short
paragraphs.

Think about a longmagazine article. It sometimes has several subheadings throughout it to break the art-
icle up into logical sections. That’s how topics are. It all comes back to content reuse and single-sourcing.
By using smaller topics, you can reuse them in different outputs—print, online, andmobile.

Table of Contents
Creating a table of contents in Flare can be very easy to do for both online and print output. For online out-
put, it can be as easy as dragging topics into the TOC Editor. You can create a TOC by adding books and
items with links. The links usually point to topics, but for online outputs they can also point to external files,
other Help systems, andmovies. You put all of these books and items in a structure that you think would
be useful for the individual. End users then browse through a TOC to find information. And in HTML5 Top
Navigation output, the TOC items become links in menus.

You have the option to customize your TOCs in lots of ways, getting as fancy as you want. However, there
are some things you should know. Themost important thing to understand is that the TOC files that you
see in the Project Organizer work differently for online output than they do for print-based output. For online
outputs, TOC files are exactly as their name suggests; they are files that create TOCs ormenus in the out-
put. But for print-based outputs, that same TOC file functions more like an outline. The element that actu-
ally generates a TOC in print-based output is called a "proxy." You canmanually create that proxy yourself,
or you can select an option in the Advanced tab of the Target Editor and let Flare do it all for you. There are
pros and cons for bothmethods.

You can see both online and print TOCs in action by looking at Flare's many project templates on the Start
Page. Typically, the templates labeled as "Basic" use the easy auto-generationmethod for creating print
TOCs, and the "Advanced" templates use themore robust method by making use of a combination of a
TOC proxy, styles, and page layouts.

Snippets and Variables
Think of snippets as miniature topics. It’s content that you want to reuse inmany different topics, but you
don’t want to have to keep retyping that content, so you just type it once in a snippet. Then you insert that
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snippet into as many topics as you need it to be in. Normally snippets aremade up of one or more para-
graphs, perhaps including elements such as lists, images, tables, or text. We’re not usually talking about
single words or phrases here. That’s what variables are for.

If you’ve got single words or short phrases that you need to reuse again and again, create variables. Think
of your company’s product name or version number. Ormaybe a phone number. Those are good things to
turn into variables.

Condition Tags
This is where Flare gets really powerful. Condition tags are used to tell Flare, "Hey, this piece of content or
this file—I want it to be in this output but not that one." For example, maybe you plan to have two versions
of some online output—one version for beginners and one version for advanced users. Much of the content
you create is going to be the same for both audiences, but some of it is going to be written only for a spe-
cific audience. So you can create condition tags for each audience and use them to separate the content
when you build your output.

Styles
Styles are what you use to give your content the look that you want it to have. Flare uses cascading
stylesheets (or CSS) and the rules around them. CSS isn’t a Flare idea. It’s an international standard for
formatting web content, and it was developed by a group called theWorldWideWebConsortium (orW3C).
You can learn all about theW3C at w3.org.

Now, it would take an eternity to explain CSS here. The important thing for you to know is that’s the basis
of styles in Flare. And even though Flare has a user interface that makes it easy to work with these styles
and you don’t have to be an expert to get started, the difference between a good Flare user and a great Flare
user is often an understanding andmastery of CSS.

The bottom line is that you want to avoid the opposite of styles as much as possible. That's called "local
formatting." For example, you can highlight some text andmake it green and italic right where that content
exists. But if you do that same thing in many places, it takes a lot longer and it's a lot more work to control
the look of that content if you later change your mind. Instead, it's much smarter and better to use a style.

http://w3.org/
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What are You Trying to Accomplish?
This is a question you should try to answer before you begin creating files and content.

What kinds of output do you want to create?

Do you need online output, print output, or both? How many different versions of online and print output do
you need? How will you name your files to keep things consistent and organized?What kinds of snippets
and variables will you need?What kinds of condition tags will you need?Will one author be working on the
project or will multiple people be involved?

In other words, themore planning and preparation you do beforehand, the smoother your journey in Flare
will be.
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Getting Additional Help
You can use any of the following resources for additional help not provided in this manual.

Knowledge Base
You can browse the online Knowledge Base for articles covering common support issues.

http://kb.madcapsoftware.com/

Peer-to-Peer Online Forums
You can visit the online forums to learn from other users or share your own expertise.

http://forums.madcapsoftware.com/

Contact Flare Support
You can contact the Flare support team and get answers to your specific support issues.

http://madcapsoftware.com/support/

http://kb.madcapsoftware.com/
http://forums.madcapsoftware.com/
http://madcapsoftware.com/support/
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2 Creating aNewProject

The first step in developing a project after you launch Flare is to start a project. You can start
a project in one of several ways, such as by importing other projects or files. Following are
the steps for creating a new project using the Start New Project Wizard.

For more information, see theProject Creation PDF Guide. For links to this manual and oth-
ers, see the online Help.
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HOW TO CREATE A NEW PROJECT

1. Do one of the following, depending on the part of the user interface you are using:

Start Page Select the Templates tab. Use the slideshow to find a template that you want to
use as a starting point for your project. When you find one, click it.

Ribbon Select File>New Project.

You can use theOptions dialog to switch between ribbons and the classic tool strip layout. For
more information see the online Help.

Keep inmind that the smaller the application window becomes, themore the options in a rib-
bon shrink. Therefore, youmight only see a small icon instead of text, or youmight see only a
section name displayed with a down arrow to access the options in it. You can hover over
small icons to see tooltips that describe them. You can also enlarge the application window or
click one of the section drop-downs in the ribbon to locate a hidden feature.

Tool Strip Select File>New Project.

Standard Toolbar Click .

To open the Standard toolbar from themenu view, you can select View>Toolbars>Standard.

The Start New Project Wizard opens.

2. In theProject name field, type a name for your project.

3. In the Language field select the language that you want to use for the project.

4. (Optional) If you want to integrate the new Flare project with a source control application, select
Bind to Source Control.

5. Click Next.

6. (Optional) If you have selected the "Bind to Source Control" option, click Bind Project. Then in the
Bind Project dialog, complete the fields, depending on the source control application being used.
When you are finished, click Next.

7. If you used the Start Page to choose a template, it is already selected for you here and you can con-
tinue to the next page of the wizard. If you did not use the Start Page, do the following.

In theSource area, select a file as a starting point for the project. When you first get started, you will
probably want to select New from template, choose a factory template, click Next, and continue
with the rest of the steps below.
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However, if you have legacy files (e.g., Word, FrameMaker, DITA HTMLHelp, RoboHelp) that you
want to use, you can select New from import, click the file type, and complete the fields in the new
wizard that opens. For more information on each of these import wizards and the steps to complete
them, see the online Help, the Import Guide, or theProject Creation Guide.

8. Click Next.

9. From theAvailable Targets field, select the primary target for your project.

10. Click Finish.
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3 Creating Topics

A topic is simply a chunk of information about a particular subject. Topics are themost
important part of a Flare project. Everything else is contained within topics (e.g., cross-ref-
erences, text, images) or points toward topics (e.g., tables of contents, indexes, browse
sequences). The very reason end users open a Help system ormanual is to find information,
a little direction. They find that help within individual topics. At this moment, you are reading
a topic (called "Creating Topics") that was created in Flare and converted to PDF output.

For more information, see the Topics PDF Guide. For links to this manual and others, see
the online Help.
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HOW TO CREATE A NEW TOPIC

1. Do one of the following, depending on the part of the user interface you are using:

(Recommended) Right-Click In the Content Explorer, right-click on a folder and from the con-
text menu select Add Topic.

Tip:When adding a new file to the Content Explorer, the recommendedmethod is to
right-click on the folder in the Content Explorer and use the New menu option. This is
themost efficient way to direct the new file to the folder where you want to store it.
That's because the Add File dialog opens when you add a new content file, and this
method ensures that the folder you want is already selected in that dialog.

Ribbon Select theProject ribbon. In theContent section select New>Topic.

Tool Strip Select Project>Add Topic.

Standard Toolbar Click .

Local Toolbar In the local toolbar of the Content Explorer click .

Keyboard Shortcut Press CTRL+T.

The Add File dialog opens.

2. In the File Type field at the top, make sure Topic is selected.

3. In theSource area select a file as a starting point for the topic. When you first get started, you will
probably want to use a factory template.

4. (Optional) The Folder field is automatically populated with the folder that has focus in the Content
Explorer. If you want to place the file into a folder that you previously created in the Content
Explorer, in the Folder field click and select the subfolder. Otherwise, keep the default location.

5. In the File Name field type a new name for the topic.

Note: Spaces are allowed in the file name. However, if you are publishing output to a UNIX
system, avoiding spaces in the file name is recommended. You can use underscores in
place of spaces.
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6. (Optional) If you want the heading for the topic to use the same text that you provide for the file
name, leave the 1st Heading field blank. Otherwise, enter the text that you want to use for the head-
ing in the topic.

7. (Optional) In the Title field you can give the topic a title for the file. This does not refer to the visual
title (or heading) at the top of the topic. Rather, it refers to the properties title for the topic (s). If you
leave this field blank, the text from the "1st Heading" field will be used for the title.

8. (Optional) If you want the heading for the topic to use the default h1 style, leave theStyle field blank.
Otherwise, select a style to apply to the heading in the topic.

9. (Optional) In theStylesheet field select a stylesheet to associate with the new topic. If you do not
have a stylesheet in your project, this field remains blank. This field is disabled if you have applied a
master stylesheet.

10. Click Add. The topic is added to the Content Explorer and opens in its own page in the XMLEditor.

11. For regular topics, simply click inside the topic page and start typing text or adding any other ele-
ments (e.g., tables, images, cross-references, multimedia) appropriate for the topic. For topics that
contain proxies, you should remove any default text so that the topic contains only the header and
the proxy (or any additional text that you want to include).
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4 Editing Styles in a Regular Stylesheet

You can edit styles contained in a regular stylesheet to quickly change the look of your con-
tent.

A style is a formatting designation that you can use to quickly change the appearance of
your content (such as characters, paragraphs, or tables) in multiple places at once. They
allow you to separate your content from its presentation. The traditional location to store a
regular cascading stylesheet (CSS) in the Content Explorer is in the Resources\Stylesheets
folder. However, you can store it anywhere in the Content Explorer that you like.

There is also a second kind of stylesheet that you can use specifically to format tables. For
the differences between regular stylesheets, table stylesheets, and local properties—and
when you should use one over the other—see the online Help.

For more information, see theStyles PDF Guide. For links to this manual and others, see
the online Help.
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HOW TO EDIT STYLES IN A REGULAR STYLESHEET

1. From the Content Explorer, open the stylesheet that you want to modify.

2. Complete one of the following sets of steps, depending on whether you want to use the Simplified
view or Advanced view in the Stylesheet Editor:

Simplified The Simplified view is often best for newer users. It provides an easier way to
apply properties to styles, with format options available from a toolbar (similar to the way one
would use the Text Format toolbar to change the look of topic content without a style). In some
cases, only themost common property options are available in the Simplified view (e.g., font,
letter/word spacing, paragraph alignment/indentation, autonumbering format, borders, back-
ground). One advantage of the Simplified view is that you can apply a property to multiple
styles at the same time. You can also click a check box to hide the properties in the editor,
allowing you to see only the styles.

Advanced The Advanced view displays style classes and properties in hierarchical tree struc-
tures. For beginners, it is not as quick and easy to use as the Simplified view, but it allows you
to edit more settings than are available in the Simplified view.

Warning: Mediums can be used if you want to use one group of settings for online out-
put types and another group of settings for print-based output types. For example, you
might use the "default" medium for your online outputs and youmight use the "print"
medium for your print outputs.  Make sure the proper medium is selected in the
Stylesheet Editor before you begin (you can do this from theMedium drop-down list). If
you are not using stylesheet mediums for your different outputs or if you want all medi-
ums to have the same settings, just leave themedium set to "default" and
continue. Please note that Flare remembers the last medium that you used when work-
ing in the stylesheet, so it may or may not be the one that you want to use the next time
around.
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IF USING SIMPLIFIED VIEW

a. In the local toolbar, make sure the first button displays (whichmeans that the

Simplified view is currently shown in the editor). If the button displays instead,
then click it.

b. (Optional) You can click in theShow Styles field in the upper-left corner of the Stylesheet
Editor to limit which styles are shown in the editor. For example, if you select Show All
Styles, then all styles will be displayed. If you select Show Paragraph Styles, only paragraph
styles will be displayed. If you select Show Table Styles, only table styles will be displayed.

c. From the grid in the bottom portion of the Stylesheet Editor, select a style.

d. In the local toolbar of the editor, click . The Properties dialog opens.

e. Use the Properties dialog to change values for the style's properties.

f. In the Properties dialog, click OK.

IF USING ADVANCED VIEW

a. In the local toolbar, make sure the first button displays . If the button displays
instead, then click it.

b. (Optional) You can click in theShow Styles drop-down list in the upper-left corner of the
Stylesheet Editor to limit which styles are shown in the editor. For example, if you select Show
All Styles, then all styles will be displayed. If you select Show Paragraph Styles, then only
paragraph styles will be displayed. If you select Show Table Styles, then only table styles will
be displayed.

c. In theStyles section of the editor, select the style that you want to edit.

Tip: If you want to limit the list of styles to only those that you tend to use in your pro-
ject, you can disable the styles that you do not want to see. This does not delete
those styles; it merely hides them from view.
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d. From theShow drop-down list on the upper-right side of the editor, select any of the options
shown to determine which properties are displayed below. This is simply a way to find the
appropriate property as quickly as possible.

Assorted Relevant Properties Displays the property groups that are usedmost often
for the selected style type.

Property Groups Displays all the different groups holding the properties for the selected
style. Property groups are simply a way to organize the properties so that they are easy
for you to find. If you want to see the values for a given property group, expand the group.

Alphabetical List Displays all of the properties in alphabetical order.

Set Properties Displays all properties that have been set for the style.

Set (Locally) Properties Displays properties that have been set for the selected style dir-
ectly in one or more topics. In other words, the global setting for that particular style has
been overruled in some topics within the project.

e. In theProperties section, locate the specific property that you want to change.

The property name is shown in the left column. The right column is used for selecting and enter-
ing values for the property.

f. Click in the value column on the right side. Depending on the type of property, you can either
type the value, select it from a drop-down list, or complete the values in a dialog or popup box.

If you completed values in a popup, click OK at the bottom of the box.

As youmake changes to a property's values, you can see how the changes look in the Pre-
view section at the bottom of the editor.

3. Click to save your work.
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WHY ARE SOME STYLES GRAY?

Whenmaking changes to styles in the Advanced view of the Stylesheet Editor, youmay notice that some
styles are gray. These are called "inherited" styles. That's because they do not yet have explicit settings on
them, so they are inheriting default values from somewhere else. As soon as youmake a change to one of
these styles, it ceases to be an inherited style (or at least the property you set is no longer inheriting from
the default value), and the style name turns from gray to a darker font.
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Also, if you hover over an inherited style, Flare displays the path to the stylesheet from which the style is
inherited.
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5 Determining theOutput Type

The first task in developing output for your project is to determine which type of output is
most appropriate for your needs. Youmight even need to producemultiple outputs and
require more than one output type.

There is a fine line between what is called "online output" and what is called "print-based out-
put." The truth is that topics in virtually any of Flare's online output types can be sent to a
printer, and therefore considered print-based. Similarly, any of the print-based output types
can be viewed electronically, and therefore considered online. The real distinction between
online and print-based outputs has to do with their primary purpose. Online outputs are usu-
ally intended to be viewed on a screen, rather than on a printed page. The idea is to show
only small pieces of content at a time and allow users to jump around to other topics or ele-
ments of the output. On the other hand, print-based output follows amore traditional format
that you would find in an actual book or manual—with the pieces of the output following one
after the other on pages until the end of the book (e.g., title page, table of contents, preface,
chapters, index, appendixes—with page numbers, as well as header or footer content,
shown along the way). Then there is EPUB output, which is intended to be viewed on a
screen, but follows a structure closer to print-based outputs.
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Online Output Options
Following are the online output options in Flare:

DotNet Help This is a Help output format developed by MadCap Software. It was designed to
include the best attributes of Microsoft HTMLHelp andWebHelp, while filling the holes left behind
by those formats. DotNet Help is designed specifically to support Visual Studio developers. It
includes a freely redistributable viewer (MadCapHelp Viewer), as well as components for the Visual
Studio developer. These components can be dropped into your Flare project to facilitate context-
sensitive Help, embedded Help, and features such as automated search string communication
between the application and the DotNet Help documentation.

For more information, see theDotNet Help PDF Guide. For links to this manual and others, see the
online Help.

Eclipse Help This is a Java-based Help system that requires the latest Java Runtime Environment
(JRE) and Java version. Use Eclipse Help to create an Eclipse plug-in for the Eclipse Help Viewer.

For more information, see theEclipse Help PDF Guide. For links to this manual and others, see the
online Help.

HTML5 (Recommended) This is the recommended format for online output. HTML5 output is sim-
ilar to the regularWebHelp format; however, whereas theWebHelp format works with HTML4, this
output type supports the new HTML5 specification developed by theWebHypertext Application
Technology Working Group (WHATWG—http://whatwg.org) and theWorldWideWebConsortium
(W3C—http://w3.org). Therefore, the HTML5 format results in better markup and offers additional
features not found in theWebHelp outputs. HTML5 also lets you use advanced server-based fea-
tures (e.g., searching of non-XHTML files) that are also available withWebHelp Plus. In addition,
HTML5 lets you create traditional Tripane output or Top Navigation output, which gives your output
the appearance of amodern website.

For more information, see theHTML5 PDF Guide. For links to this manual and others, see the online
Help.

Microsoft HTML Help This is an HTML-based Help format that runs onWindows 32-bit platforms
and requires Internet Explorer on the end users' systems. UseMicrosoft HTMLHelp to create Help
forWindows desktop applications.

For more information, see theHTMLHelp PDF Guide. For links to this manual and others, see the
online Help.

http://whatwg.org/
http://w3.org/
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WebHelp Outputs There aremultiple types of WebHelp output available in Flare.

WebHelp This is aWeb-based Help format that can run on almost any browser or platform.
UseWebHelp to create Help for the Internet or an intranet, as well as for desktop applications.

WebHelp AIR This is aWeb-based Help format that is identical to the regularWebHelp output
in most ways. However, WebHelp AIR uses direct integration with Adobe AIR, which is
designed to bringWeb-related content to a desktop environment by takingWeb files and incor-
porating them into a single file to be opened locally, rather than from a server.

WebHelp Mobile This is an output type that lets you deploy Web-based, XHTML output to
mobile devices. WebHelpMobile maintains an easy and intuitive interface that fits on a very
small screen. The Home page inWebHelpMobile output contains navigation links to access
the various panes that you can include: TOC, Index, Glossary, Search, Favorites, Browse
Sequences. 

WebHelp Plus This is aWeb-based Help format that is identical to the regularWebHelp out-
put in most ways. However, WebHelp Plus is designed to work on aWeb server runningWin-
dows 8, Windows 7, Windows Server 2012, Windows Server 2008 R2, Windows Server 2008,
Windows Server 2003, Windows XP, orWindows Vista. It also uses Microsoft Internet Inform-
ation Services (IIS) and ASP.NET. To provide faster search, WebHelp Plus uses Microsoft
Indexing Service orWindows Search. The benefit of publishingWebHelp Plus output is that
you and your users can take advantage of some advanced features, including searching of
non-XHTML content, faster server-side search, and automatic runtimemerging. 

For more information, see theWebHelp Outputs PDF Guide. For links to this manual and others,
see the online Help.
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Print-basedOutput Options
Following are the print-based output options in Flare:

Adobe FrameMaker The output is exported to Adobe FrameMaker in one of the following formats.

BOOK This is FrameMaker's native book (or "document collection") file.

FM This is FrameMaker's native single document file.

PDF In addition to sending output directly to PDF, you can generate a PDF file automatically
when building FrameMaker output. 

Adobe PDF (Recommended) Short for "Portable Document Format," PDF is an open standard
format for electronic documentation exchange invented by Adobe. PDF files are used to represent a
two-dimensional document in an device- and resolution-independent fixed-layout format. This is the
recommended print-based format.

Microsoft Word The output is exported toMicrosoft Word in one of the following file formats.

XML This is the default document format created (if you do not select one of the other formats
in this list).

DOC You can export Word to the standard DOC format.

DOCX This is Microsoft Word's platform-independent, open XML format.

PDF In addition to sending output directly to PDF, you can generate a PDF file automatically
when buildingWord output. Because Flare supports Microsoft Vista andWord 2007, you can
sendWord output to PDF format, even if you do not have the Adobe Distiller installed.

XPS In addition to sending output directly to XPS (as described above), you can generate an
XPS file automatically when buildingWord output. You can do this by installing a free add-in
download fromMicrosoft.

Microsoft XPS Microsoft's XML Paper Specification (XPS) is a document format with amarkup lan-
guage that is a subset of XAML forWindows Presentation Foundation. XPS is an alternative to
Adobe's Portable Document Format (PDF).

XHTML XHTML is a browser-based output type that consolidates project content into an XML file.
It can be viewed online or printed.  

For more information, see thePrinted Output PDF Guide. For links to this manual and others, see the online
Help.
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Other Output Types
Following are a couple of other output options in Flare:

EPUB This is a format for creating reflowable digital books (ebooks). It is developed andmaintained
by the International Digital Publishing Forum (IDPF). EPUB is sort of a hybrid format. The output is
designed to be viewed electronically; in that way, it is like an online format. On the other hand, its
structure is like a book or manual; in that way, it is like a print-based format. In fact, you can follow
many of the same steps for creating EPUB output that you would follow for producing a PDF. For
additional information about this group and the EPUB format, see http://idpf.org/.

DITA Darwin Information Typing Architecture (DITA) file content is supported in Flare. DITA is an
XML-basedmarkup language with its own schema for authoring, producing, and delivering technical
information. It is a standard of the Organization for the Advancement of Structured Information
Standards (OASIS), and it consists of a set of design principles for creating "information-typed" mod-
ules at a topic level and for using that content in various delivery modes.In Flare you can generate
output that produces DITA files. When you build this type of output, a DITA map file is generated,
with multiple DITA files in it. The XHTML tags are converted to DITA elements. In other words,
although it is considered an "output" from the standpoint of the Flare process, the end result is actu-
ally a collection of "source" files, which you can later use in another tool (or import back into Flare) to
produce the final output.

http://idpf.org/
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6 Targets

It is easy to confuse output types with targets, but they are two different concepts. A target
is one instance of an output type. It is the engine that takes all of your files and settings, and
brings them together to produce the end result. When you build your final output, you are
essentially building one or more of the targets in your project.

In Flare you can add targets using any of the available formats, and you canmake as many
copies of an existing target that you want. For example, your project might end up containing
three targets that are all based on the HTML5 output type (in addition to other targets).

For more information, see the Targets PDF Guide. For links to this manual and others, see
the online Help.
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HOW TO ADD TARGETS

1. Do one of the following, depending on the part of the user interface you are using:

Ribbon Select theProject ribbon. In theContent section select New>Target.

Tool Strip Select Project>Add Target.

Right-Click In the Project Organizer, right-click on the Targets folder and from the context
menu select Add Target.

The Add File dialog opens.

2. In the File Type field at the top, make sure Target is selected.

3. In theSource area select a file as a starting point for the target. When you first get started, you will
probably want to use a factory template.

4. (Optional) If you want to place the file into a subfolder that you previously created in the Project
Organizer, in the Folder field click and select the subfolder. Otherwise, keep the default loc-
ation.

5. In the File Name field, type a new name for the target.

6. From theOutput Type field, select one of the available output formats. You can always change the
output type later in the Target Editor.

7. Click Add. The target is added to the Targets folder in the Project Organizer. The Target Editor
opens to the right.

HOW TO MAKE COPIES OF TARGETS

1. Open the Project Organizer.

2. Double-click the Targets folder. The available targets are shown.

3. Click on the target that you want to copy.

4. Press CTRL+C on your keyboard.

5. Press CTRL+V on your keyboard. A copy of the target is added to the Targets folder. The new tar-
get is given the same name as the target you copied, with the words "Copy of" before it.
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HOW TO EDIT TARGETS

1. From the Targets folder in the Project Organizer, open the target that you want to edit.

2. You can use the tabs in the Target Editor to perform various tasks, depending on the output type
associated with the target (i.e., some tasks can be performed only in certain targets).

3. After you have edited settings in the editor, select File>Save.

HOW TO BUILD TARGETS

1. Do one of the following, depending on the part of the user interface you are using:

Ribbon Select theProject ribbon. In theBuild section select Build Primary>Build [name
of target].

Project Toolbar Click the down arrow next to and from themenu select the
name of the target.

To open the Project toolbar from themenu view, select View>Toolbars>Project.

Local Toolbar In the local toolbar of the Target Editor click .

Right-Click In the Project Organizer, open the Targets folder, right-click on a target, and from
the context menu select Build [name of target].

2. (Optional) A row is added to the Builds window pane, showing the progress of the target as it is gen-
erated. If the target generates successfully, the color of the Progress columns changes from light to
dark green, and the Status column displays "Finished." You can then select that row and in the local
toolbar click View Output.

3. (Optional) The log file is generated and saved automatically at the root level of the output folder for
that target, whether or not there are errors or warnings. You can tell if errors or warnings have
occurred by looking at the appropriate columns in the Builds window pane. You can then select that
row and in the local toolbar click Open Build Log.
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IX PDFGuides

The following PDF guides are available for download from the online Help:

Accessibility Guide Key Features Guide

Analyzer Guide Language Support Guide

Autonumbers Guide Movies Guide

Condition Tags Guide Navigation Links Guide

Context-sensitive Help Guide Print-basedOutput Guide

DotNet Help Guide Project Creation Guide

Eclipse Help Guide Pulse Guide

Getting Started Guide QR Codes Guide

Global Project Linking Guide Reports Guide

HTMLHelp Guide Reviews & Contributions Guide

HTML5Guide Search Guide

Images Guide SharePoint Guide

Importing Guide Shortcuts Guide

Index Guide Skins Guide
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Snippets Guide Templates Guide

Source Control Guide: Git Topics Guide

Source Control Guide: Perforce Touring theWorkspaceGuide

Source Control Guide: Subversion Transition From FrameMaker Guide

Source Control Guide: Team Foundation Server Tutorials Guide: Product Foldout 3-Fold Template

Source Control Guide: Visual SourceSafe Tutorials Guide: Top Navigation Adv Template

Styles Guide Tutorials Guide: Tripane and PDF Adv Template

Tables Guide Variables Guide

Tables of Contents Guide WebHelp Outputs Guide

Targets Guide What's New Guide
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