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1 Introduction

Snippets are pre-set chunks of content that you can use in your project over and over. They
are sort of likeminiature topics and can be inserted within topics, or even within other topics.
In snippets you can insert text, tables, images, and whatever else can be included in a nor-
mal topic. 

Themajor benefit of using snippets is that you only have to create your content once, rather
than having to type the same information in each topic where you want to use it. If you need
tomodify the content of a snippet, you only need to change it in one place and the change is
made automatically everywhere that the snippet is added.

Snippets are contained in their own files (using an .flsnp file extension). You can therefore
share them with other authors or use them in other projects. If you insert a snippet that is
stored outside of your project, the file is copied to your project. The traditional location to
store a snippet in the Content Explorer is in the Resources\Snippets folder. However, you
can store it anywhere in the Content Explorer that you like.

This chapter discusses the following:

Text and Block Snippets 6
Condition Tags and Snippet Conditions 6
Snippets and Auto Suggestions 7
Tasks Associated with Snippets 8
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Text and Block Snippets
You can create a text snippet or a block snippet. This is determined by the way you insert the snippet. If
you insert a snippet on a blank line in a topic, it is inserted as a block snippet and takes up all of the room so
that no other content can be added. If you insert a snippet on a line where other content exists, it is inserted
as a text snippet. Therefore, if you want to insert a snippet on a blank line and also type other text before or
after it, you need to type the text first and then insert the snippet afterwards. Also, if you have a snippet con-
tainingmultiple paragraphs and insert it within a line of text, the snippet becomes just one continuous line of
text because it is a text snippet.

When you create a text or block snippet, it displays surrounded by brackets (if you havemarkers turned
on).

Condition Tags and Snippet Conditions
You can apply a condition tag to a snippet so that it is included in some targets but not in other targets.

You can also create snippet conditions. Snippet conditions are condition tags that you can apply to content
within snippets. With snippet conditions, you can separate certain snippet content so that it displays in
some topics or master pages but not in others. This allows you to use one snippet for many purposes,
rather than having to createmultiple snippets. Whereas regular conditions are included or excluded at the
target level, snippet conditions are included or excluded at the topic or master page level. See "Using Snip-
pet Conditions" on page 37.
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Snippets and Auto Suggestions
Flare recognizes when you are typing content that matches existing snippets in your project. This makes it
a very fast and convenient way to single-source your content. 

E X A M P L E

Let's say you work on a team of 15 writers and there are a series of snippets in all of your projects
that begin with the same three words—Formore information…

Perhaps each person knows to start typing those words in certain places. But what if a snippet
already exists with the full content that the writer needs?Without knowing that, a personmight
spend time typing all of the content, andmaybe even create a new snippet for future use. But if Auto
Suggestion is enabled, as soon as a person types a certain number of characters, all matching snip-
pets are shown in the Auto Suggestion popup. Therefore, the writer can quickly find and select the
appropriate snippet.
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Tasks Associated with Snippets
Following are themain tasks involved with using snippets.

Create Snippets From Content If you have already added content in your topic and want to turn
that content into a snippet, you can create a snippet out of that existing content using the Home rib-
bon or Format menu. See "Creating New Snippets" on page 11.

Add SnippetsYou can add a new snippet (without necessarily having any topic open). See "Adding
New Snippets" on page 13.

Note: You can also import an existing snippet from outside your project.

Insert SnippetsAfter you create or add snippets, you can insert them into any topic in your project.
See "Inserting Snippets" on page 17.

Note: You can also create nested snippets (i.e., a snippet within a snippet). To do this,
simply open a snippet and then insert another snippet into it.

Edit SnippetsYou cannot modify the snippet at its location in the topic. When you insert a snippet
into the topic, the content is displayed, but it is held in a separate snippet file. In the topic the snippet
marker is represented by brackets. Tomodify a snippet you need to open it by right-clicking on it and
selectingOpen Link, or you can open it from the Content Explorer. Then you canmake changes to
it in the XMLEditor. See "Editing Snippets" on page 23.

Replace SnippetsAfter you create or add a new snippet to your project, you can insert it into any
of your topics. Later, if you decide that a different snippet is a better fit for the topic, you can select a
new snippet to replace it. See "Replacing Snippets" on page 35.
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Warning: It is recommended that you avoid creating links to snippets.This is primarily due to
the nature of snippets, which are designed to be inserted into multiple files. Let's say you have
a heading style in a snippet and that snippet is then inserted into 12 different topics. In another
topic, youmight decide to create a cross-reference that points to the heading in that snippet.
But which of those 12 topics is it supposed to point to in the output? There is no way for Flare to
know this, so you could end up with some very undesirable results. For this reason, it's a good
idea not to link to any content in a snippet.

Note: Although it is possible to open any Flare files in a third-party editor, it recommended that
you avoid editing these files in certain programs while Flare is running. For example, opening a
stylesheet in Notepad is not an issue. But youmight experience problems if you open a topic or
snippet in Microsoft Word and edit it while Flare is running.
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2 Creating New Snippets

The following steps show you how to create new snippets from existing content.

HOW TO CREATE A NEW SNIPPET FROM EXISTING CONTENT

1. Open the topic.

2. In the XMLEditor highlight the content that you want to turn into a snippet.

3. Do one of the following, depending on the part of the user interface you are using:

Ribbon Select theHome ribbon. In theSnippet section select Create
Snippet.

You can use theOptions dialog to switch between ribbons and the classic tool
strip layout. For more information see the online Help.

Keep inmind that the smaller the application window becomes, themore the
options in a ribbon shrink. Therefore, youmight only see a small icon instead of
text, or youmight see only a section name displayed with a down arrow to
access the options in it. You can hover over small icons to see tooltips that
describe them. You can also enlarge the application window or click one of the
section drop-downs in the ribbon to locate a hidden feature.

Tool Strip Select Format>Create Snippet.

4. In theSnippet File field, type a new name for the snippet.

It is recommended that you leave the project folder selection as "Resources/Snip-
pets" (or select a subfolder that you have created in the Snippets folder). After the
snippet is created, you can see the snippet file in the Content Explorer.
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5. If you want the snippet to replace the highlighted text in the topic, make sure that a check mark is
displayed inReplace Source Content with the New Snippet.

Why would you leave this box unchecked? Let's say you want to create two snippets and they are
going to be very similar. Youmight create the first snippet, make a few changes to the text within
the dialog, and leave this box unchecked. That snippet is created but not inserted into the topic.
Then you can create the second snippet with this box checked. Flare will both create the snippet
and insert it into the topic, replacing the highlighted text.

6. Click Create. The snippet is added to the Content Explorer and opens in the topic page in the XML
Editor. The snippet is surrounded by brackets (if markers are turned on).

7. Click to save your work.

Note: You can also import an existing snippet from outside your project. See "Importing Snippets"
on page 32.
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3 Adding New Snippets

The following steps show you how to add new snippets.

HOW TO ADD A NEW SNIPPET

1. Do one of the following, depending on the part of the user interface you are using:

(Recommended) Right-Click In the Content Explorer, right-click on a folder
and from the context menu select New>Snippet.

Tip:When adding a new file to the Content Explorer, the recom-
mendedmethod is to right-click on the folder in the Content Explorer
and use the New menu option. This is themost efficient way to direct
the new file to the folder where you want to store it. That's because the
Add File dialog opens when you add a new content file, and this
method ensures that the folder you want is already selected in that dia-
log.

Ribbon Select theProject ribbon. In theContent section select
New>Snippet.

Tool Strip Select Project>Add Snippet.

The Add File dialog opens.

2. In the File Type field at the top, make sureSnippet is selected.
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3. In theSource area select one of the following:

New from template This lets you choose either the factory template file or one of your own
customized template files as a starting point. The new file will take on all of the settings con-
tained in the template. If you want to use the factory template provided by Flare, expand the
Factory Templates folder and click on a template file. If you want to use your own customized
template file, expand the appropriate folder and click on a file. For more information about tem-
plates, see the online Help.

New from existing This lets you choose an existing file of the same type as a starting point
for your new file. As with template files, your new file will take on all of the settings contained in
the file you select. To use this option, click the browse button , use the Open File dialog to
find a file, and double-click it.

4. (Optional) The Folder field is automatically populated with the folder that has focus in the Content
Explorer. If you want to place the file into a folder that you previously created in the Content
Explorer, in the Folder field click and select the subfolder. Otherwise, keep the default location.

Note: If you want to place non-topic files in a traditional default folder, youmust first make
sure that folder exists in the Content Explorer. If it does not exist, you can easily add it.

Non-Topic File Type Traditional Default Folder in Content Explorer

Image Resources\Images

Master Page Resources\MasterPages

Multimedia Resources\Multimedia

Page Layout Resources\PageLayouts

Snippet Resources\Snippets

Stylesheet Resources\Stylesheets

Table Stylesheet Resources\TableStyles

5. In the File Name field, type a new name for the snippet.
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6. Click Add. The snippet is added to the Content Explorer and opens in its own page in the XML
Editor with some default text for you.

7. Now simply click inside the snippet page in the XMLEditor and start typing text (replacing the
default text shown) or adding any other elements (e.g., styles, tables, images, hyperlinks, mul-
timedia) appropriate for the snippet.

8. Click to save your work.

Note: You can also import an existing snippet from outside your project. See "Importing Snippets"
on page 32.
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4 Inserting Snippets

After you create or add snippets, you can insert them into a content file (e.g., topic, snippet).
You can do this by using user interface options, which let you search for a snippet, or you
can simply drag an existing snippet from the Content Explorer or File List window pane.
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HOW TO INSERT A SNIPPET

1. Open the content file (e.g., topic, snippet).

2. Place your cursor where you want to insert the snippet.

3. Do one of the following, depending on the part of the user interface you are using:

Ribbon Select the Insert ribbon. In theSingle Source section select Snippet.

You can use theOptions dialog to switch between ribbons and the classic tool strip layout.
For more information see the online Help.

Keep inmind that the smaller the application window becomes, themore the options in a rib-
bon shrink. Therefore, youmight only see a small icon instead of text, or youmight see only a
section name displayed with a down arrow to access the options in it. You can hover over
small icons to see tooltips that describe them. You can also enlarge the application window
or click one of the section drop-downs in the ribbon to locate a hidden feature.

Tool Strip Select Insert>Snippet.

Local Toolbar In the local toolbar at the top of the XMLEditor click .

Keyboard ShortcutPress CTRL+R.

Right-Click Right-click in the editor and select Insert>Snippet. This context menu option is
available only when your cursor is located in certain places in the editor (e.g., not in a drop-
down effect).

The Insert Snippet Link dialog opens.



CHAPTER 4│Snippets Guide 19

4. Navigate to the snippet that you want to insert and select it. By using the buttons in the local toolbar,
you can view all snippet files in a list, view files in their folder structure, and use other options. You
also can click to find and select a snippet file outside of the project. If you want to select a snip-
pet that you recently inserted somewhere in your project, click the down arrow at the bottom of the
dialog select the snippet from the list.
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Shows all of the files in the project in a list in the area below. If you click
the button again, it switches to a folder tree view. In the list, you can click
the File, Type, or Path column headers to sort the list alphabetically by
that column data.

Shows or hides the folders that the files are stored in.

Shows or hides the files. If you click this button when the Show Folders
button is selected, the area splits into two. The folder is shown on the
left side, and the files and subfolders within it are shown on the right.

If the Show Files button is the only one selected, you can click this but-
ton tomove up one folder level.

Lets you filter the kinds of files shown below. Depending on the task you
are performing, this field may already be populated with themost appro-
priate file type(s).

Note: If you select a snippet file outside the project, that file is then copied and placed
inside the project. The image file is stored in the Resources\Snippets folder of the Content
Explorer.
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5. Click OK. The snippet is inserted and is surrounded by brackets (if markers are turned on).

6. Click to save your work.
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HOW TO INSERT A SNIPPET—DRAG AND DROP METHOD

1. Open the Content Explorer or File List window pane.

If necessary, make sure you float and position the window pane or editor so that you can see both it
and XMLEditor at the same time.

2. Click and drag the snippet from the Content Explorer or File List window pane to the location where
you want it in the XMLEditor and drop it.

3. Click to save your work.
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5 Editing Snippets

After you create or add a new snippet to your project, you can insert it into any of your top-
ics. Later, if you decide that the snippet needs to be altered, you can do so easily using the
steps below. When you edit a snippet, the changes are automatically reflected in any topics
where you have inserted the snippet previously.

HOW TO EDIT A SNIPPET

1. Use one of the followingmethods to open the snippet that you want to modify.

Right-click on the snippet in a topic where it is inserted and select Open Link.

OR

Locate the snippet in the Resources\Snippets folder in the Content Explorer and
double-click it.

2. In the XMLEditor make the necessary changes to the snippet, just as you would edit
any other document.

3. Click to save your work.

Note: If you want to change how snippets look when they're inserted in the XML
Editor, you can change theMadCap|snippetBlock or MadCap|snippetText styles
(for block and text snippets, respectively) in the Stylesheet Editor. This does not
affect the output. For more information see the online Help.
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6 Opening Snippets

After you create or add snippets to your project, they are stored in the Content Explorer (Con-
tent\Resources\Snippets). You can open as many existing snippets as you want at one time
andmakemodifications to them. Each snippet displays in its own page of the XMLEditor
and remains accessible as you work. As you openmore snippets or other elements (e.g.,
topics, targets, tables of contents), each page displays in the appropriate editor (e.g., XML
Editor, Target Editor, TOC Editor). By default, themost recently opened page is on the left
side of the editor section in Flare, and the previously opened pages shift to the right. The act-
ive page displays on top of the other pages, and you canmake any page the active one (or
"the one on top") by simply clicking its tab.
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HOW TO OPEN A SNIPPET FROM THE QUICK LAUNCH BAR

TheQuick Launch bar allows you to search for any Flare file or command. It is located in the upper-right
corner of the interface. You can press CTRL+Q on your keyboard tomove focus to the Quick Launch bar
so you can begin typing.

1. In the Quick Launch bar, type a few letters of the name of the file you want to open. Any available
results appear in a drop-down list.

2. From the list, click the name of the file.

HOW TO OPEN A SNIPPET FROM THE CONTEXT MENU

1. Open a topic where the snippet is inserted.

2. Right-click on the snippet and select Open Link.The snippet opens in its own page of the XML
Editor.

HOW TO OPEN A SNIPPET FROM THE CONTENT EXPLORER

1. Open the Content Explorer.

2. Expand theResources folder, and double-click theSnippets subfolder to open it (unless you have
stored these files in a custom folder).
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3. Do one of the following:

Locate and double-click the snippet file (e.g., NameOfSnippet.flsnp) that you want to open.

Locate and click the snippet file (e.g., NameOfSnippet.flsnp) that you want to open. In the
local toolbar, click .

The snippet opens in its own page of the XMLEditor.
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7 Additional Snippet Tasks

In addition to themany features already covered in this guide, there aremany more snippet-
related tasks that you can perform in Flare.

This chapter discusses the following:

Converting Snippets to Text 30
Deleting Snippets 31
Importing Snippets 32
Inserting Page Numbers into Frames 33
Replacing Snippets 35
Using Snippet Conditions 37



30

Converting Snippets to Text
After you create or add a new snippet to your project, youmay decide that you want the snippet to be reg-
ular text instead. Rather than retyping the snippet, you can convert the snippet to text using the steps
below.

HOW TO CONVERT A SNIPPET TO TEXT

1. Open the topic.

2. In the XMLEditor, right-click the snippet that you want to convert to text.

3. From the context menu, select Convert to text. The snippet is converted to text.

4. Click to save your work.
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Deleting Snippets
If necessary, you can delete a snippet that you have added to a topic.

HOW TO DELETE A SNIPPET

1. Open the topic containing the snippet.

2. In the XMLEditor, right-click the snippet that you want to delete.

3. From the context menu, select Delete. The snippet is removed from the topic.

4. Click to save your work.
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Importing Snippets
You can create new snippets (FLSNP files) within your project. But if you already have created snippets in
another project and want to reuse them in your current project, you can import those snippets.

HOW TO IMPORT A SNIPPET

1. Do one of the following, depending on the part of the user interface you are using:

Ribbon Select theProject ribbon. In theContent section select New>Snippet.

Tool Strip Select Project>Add Snippet.

The Add File dialog opens.

2. Select New from existing and click .

3. Find and select the snippet file that you want to import.

4. Click Open. The Source File field now contains the path to the file that you are importing. Also, the
name of the file is displayed in the File Name field.

5. In the Folder field select a location to store the snippet in the project.

6. If you want to give the snippet a different name than that for the imported file, click in the File name
field and replace the text.

7. Click Add. The snippet is added to the Resources\Snippets folder in the Content Explorer and
opens in its own page in the XMLEditor.
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Inserting Page Numbers into Frames
Supported In:

One type of content that you are likely to add to a frame is a page number, which is actually a snippet that
serves as a placeholder for a page number in the output.

HOW TO INSERT A PAGE NUMBER INTO A FRAME

1. Open a page in a page layout.

2. Click on the frame to which you want to add a page number.

Note: You can insert a page number only into header, footer, and decoration frames. You
cannot insert a page number into a body frame (which automatically displays content from
your topics).

3. Do one of the following, depending on the part of the user interface you are using:

Local Toolbar In the local toolbar, click .

Right-ClickRight-click the frame and select Select Frame Text.

The Select Frame Text dialog opens.

4. In the Template Folders section, select a template.

Note: You can click theManage Templates button if you want to open the Template
Manager. This lets youmanage any of your template files (e.g., add new templates, enter
descriptions for templates). For more information see the online Help.
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5. In the Templates section, select one of the page number snippets.

- page -.flsnp Displays a page number surrounded by dashes (e.g., - 53 -).

page (pagecount).flsnp Displays the current page number, followed by the total number of
pages in parentheses.

Page n of N.flsnp Displays the current page number and the total number of pages in the doc-
ument (e.g., Page 13 of 70).

Tip: If you want to change the look of the page number (e.g., remove the dashes or par-
entheses), you can do so easily. To edit the text or content around a page number, con-
tinue inserting the page snippet as it is. After it is added to the frame, click on the frame and
press F2. In the FrameContents window pane, you canmodify it as necessary.

6. Click OK.

7. Click to save your work.
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Replacing Snippets
After you create or add a new snippet to your project, you can insert it into any of your topics. Later, if you
decide that a different snippet is a better fit for the topic, you can select a new snippet to replace it. When
you replace a snippet, it only affects the instance that you selected.

HOW TO REPLACE A SNIPPET

1. Right-click on the snippet where it is inserted and select Select New Snippet. The Insert Snippet
Link dialog opens.

2. Navigate to the snippet that you want to insert and select it. By using the buttons in the local toolbar,
you can view all snippet files in a list, view files in their folder structure, and use other options. You
also can click to find and select a snippet file outside of the project. If you want to select a snip-
pet that you recently inserted somewhere in your project, click the down arrow at the bottom of the
dialog select the snippet from the list.
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Shows all of the files in the project in a list in the area below. If you click
the button again, it switches to a folder tree view. In the list, you can click
the File, Type, or Path column headers to sort the list alphabetically by
that column data.

Shows or hides the folders that the files are stored in.

Shows or hides the files. If you click this button when the Show Folders
button is selected, the area splits into two. The folder is shown on the
left side, and the files and subfolders within it are shown on the right.

If the Show Files button is the only one selected, you can click this but-
ton tomove up one folder level.

Lets you filter the kinds of files shown below. Depending on the task you
are performing, this field may already be populated with themost appro-
priate file type(s).

Note: If you select a snippet file outside the project, that file is then copied and placed
inside the project. The image file is stored in the Resources\Snippets folder of the Content
Explorer.

3. Click OK. The original snippet is replaced by the new snippet.

4. Click to save your work.
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Using Snippet Conditions
Snippet conditions are condition tags that you can apply to content within snippets. With snippet con-
ditions, you can separate certain snippet content so that it displays in some topics or master pages but not
in others. This allows you to use one snippet for many purposes, rather than having to createmultiple snip-
pets. Whereas regular conditions are included or excluded at the target level, snippet conditions are
included or excluded at the topic or master page level.

E X A M P L E

Let's say that you have a table with 15 rows and four columns. Suppose that the table needs to be
included in 40 topics. Rather than copying and pasting the table 40 times, you create one snippet
containing the table and insert it into those 40 topics. However, suppose that in 30 of those topics,
you need to add threemore rows to the table to explain something. In the remaining 10 topics, the
three additional rows are not necessary. Otherwise, the table content is the same in all 40 topics.
What do you do? You have a few options.

The first option is to add a note to the table explaining that the three additional rows are intended
only for some of the topics but not others. However, this might be confusing to your readers.

The second option is to create two separate snippets—one for the 30 topics and another for the 10
topics. However, this means that you need tomaintain identical information in two different places.
And that is no way to single-source your content.

The third option is to create snippet conditions. Here is how youmight do it in this example.

1. Create a condition tag called "Additional Rows."

2. Open the snippet and add the necessary three rows to the table.

3. Using the table row structure bars, apply the new condition tag to the additional three rows.

4. Use the File List window pane (View>File List) to select the 30 topics requiring the addi-
tional rows, and open the Properties dialog.

5. Select theSnippet Conditions tab.

6. Next to the new condition tag, click the Include check box.



38

7. Use the File List window pane to select the 10 topics not requiring the additional rows, and
open the Properties dialog.

8. Select theSnippet Conditions tab.

9. Next to the new condition tag, click theExclude check box.

10. After you save all of your changes and generate the target, you will notice that the three addi-
tional rows are displayed only in the 30 topics where they were included.

HOW TO USE SNIPPET CONDITIONS

1. Create all of the condition tags that you plan to use for separating your snippet content.

Note: Themore variations that you will have in your snippet content, themore condition
tags you will need to create. An average number is four to eight condition tags, but youmay
find that you require fewer or more tags than this for snippet content. It is always preferable
to createmore condition tags than youmay need, rather than to realize later that you have
too few. You can even create a separate condition tag set to be used specifically for hold-
ing your snippet condition tags (while keeping your regular condition tags in other tag sets).

Tip: It is also a good idea to include the word "Snippet" somewhere in the name of a new
snippet condition tag. This way, you can easily identify it, rather than confusing it with the
regular condition tags that you use for other purposes (e.g., online output or printed output
condition tags).

2. Create and open the snippet.
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3. Apply the necessary condition tags to the text or other content in the snippet.

Tip: It is a good idea to click theHide/Show Conditional Indicators button at the bot-
tom of the editor so that you can clearly see where the different tags have been applied in
the snippet.

4. Insert the snippet into the necessary topics, or determine which topics already contain the snippet.

5. After you determine that a particular topic should display only certain tagged content from the inser-
ted snippet, open the Content Explorer and select the topic file.

Note: If there are several topics that you know in advance will include a particular snippet
condition tag, you can open the File List window pane (View>File List) instead and select
all of those files at the same time.

6. In the local toolbar, click . The Properties dialog for the topic opens.

7. Select theSnippet Conditions tab.

8. If you want to exclude a condition tag from the topic, click theExclude check box next to it. If you
want to make sure a condition tag is included in the topic, click the Include check box next to it. The
primary reason for having Include check boxes is to account for possible conflicts.

E X A M P L E

Suppose you have two condition tags—one called "Beginner" and another called
"Advanced." Let's say that you have a snippet containing three paragraphs. You apply the
Advanced tag to the first two paragraphs, and you apply the Beginner tag to the last two para-
graphs.

You have created a topic called "Advanced Set Up." For this topic, you obviously want to
include all snippet content associated with the Advanced tag, but you want to exclude snip-
pet content associated with the Beginner tag.
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By default, Flare will include snippet content associated with both tags, unless you tell it not
to. So you tell Flare to exclude the content associated with the Beginner tag. The problem is
themiddle paragraph from the snippet mentioned above. It is associated with both tags. You
have told Flare to exclude content associated with the Beginner tag, and it will do so, over-
riding the default. But you want to make sure that paragraph is included in the "Advanced Set
Up" topic. That is why you need tomake sure you select the Include check box next to the
Advanced tag.

Warning: If you do not select any check boxes at all, all of the tags will automatically
be included. If you include only some tags and exclude others, any remaining tags
without check marks for either Include or Exclude will automatically be included.
However, if you select Include for any of the tags (even just one) and do not select
Exclude for any tags, all of the other tags that do not have Include check marks will auto-
matically be excluded. If you want to be safe and always know that the correct tags are
included or excluded, you canmake sure that all of the tags have check marks with
either Include or Exclude.

Tip: It is a good idea to create enough snippet condition tags in advance. If sometime later
you realize you need to create additional snippet condition tags, youmay find that you need
to revisit all of the topics where you have already inserted snippets with conditions. Why?
Because by default the snippets containing the new tags may be displayed in all topics
unless you specify otherwise.

9. Click OK.

Note: You can generate a report to see topics in your project that contain snippet conditions.
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IX PDFGuides

The following PDF guides are available for download from the online Help:

Accessibility Guide Key Features Guide

Analyzer Guide Language Support Guide

Autonumbers Guide Movies Guide

Condition Tags Guide Navigation Links Guide

Context-sensitive Help Guide Print-basedOutput Guide

DotNet Help Guide Project Creation Guide

Eclipse Help Guide Pulse Guide

Getting Started Guide QR Codes Guide

Global Project Linking Guide Reports Guide

HTMLHelp Guide Reviews & Contributions Guide

HTML5Guide Search Guide

Images Guide SharePoint Guide

Importing Guide Shortcuts Guide

Index Guide Skins Guide
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Snippets Guide Templates Guide

Source Control Guide: Git Topics Guide

Source Control Guide: Perforce Touring theWorkspaceGuide

Source Control Guide: Subversion Transition From FrameMaker Guide

Source Control Guide: Team Foundation Server Tutorials Guide: Product Foldout 3-Fold Template

Source Control Guide: Visual SourceSafe Tutorials Guide: Top Navigation Adv Template

Styles Guide Tutorials Guide: Tripane and PDF Adv Template

Tables Guide Variables Guide

Tables of Contents Guide WebHelp Outputs Guide

Targets Guide What's New Guide
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