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CHAPTER 1

Introduction
Welcome to Contributor: a single-document authoring tool that is tightly integrated with MadCap
Flare. Contributor is the perfect tool for light content development.

Using Contributor, you can review and edit documents sent to you by
Flare authors. This workflow is for registered users, as opposed to
those using the free annotation-only review mode. See "Review
Workflow" on page 6.

Using Contributor, you can review documents sent to you by Flare
authors. With this workflow, you can add annotations to documents,
but you cannot edit them. See "Review Workflow" on page 6.

You can create original content that can be contributed to MadCap
Flare projects, printed, or saved in formats such as PDF and XHTML.
See "Contribution Workflow" on page 16.

You can create and original content that can be printed, or saved in
formats such as PDF and XHTML, for purposes other than
contributing to a MadCap Flare project. See "Creating New
Documents" on page 22.
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NOTE Contributor's Annotation-Only Mode is free to use after the trial version expires.
You will be able to add and remove text annotations after the trial version expires, but all
other features will be disabled.
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CHAPTER 2

ReviewWorkflow
If you are using a full registered mode of Contributor, you can review and edit documents sent to
you by others.

If you are using the free review mode, you can review documents sent to you by others and add
annotations (comments). However, you cannot edit the documents.

This chapter discusses the following:

Reviewing Documents—Full Registered Mode 7

Reviewing Documents—Free Annotation-Only Mode 10

Regular Document Files vs. Lingo Translation Files 11

What’s Noteworthy? 12

Inserting Annotations 13

Returning Documents to Authors 15
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Reviewing Documents—Full
Registered Mode
1. Open You can open the review package file from your email, or from a link sent to you by the

author. The files in the review package are listed in the Review Packages window pane at
the bottom. Double-click a row to review and edit a particular file.

If the review package contains topics as well as snippet files, you can open the snippets too.
You can open snippets by double-clicking them in the Review Packages window pane.
Another approach is to right-click the snippet where it is inserted in a topic (or in another
snippet) and from the context menu select Open Snippet File.

2. (Optional) Insert Comments You can insert annotations (comments) that are associated
with specific areas of text in the document. These annotations do not become part of the
content within the document, but rather are intended for internal use between you and
others. (Do not select more than one paragraph or click at the very end of paragraphs;
otherwise, the "Insert Annotation" option will not be enabled.) See "Inserting Annotations" on
page 13.

3. Return You can return the review package to the author in various ways. Work with the
author to determine how he or she wants to be notified. If the author is using a built-in email
feature, this might simply entail clicking Return to Sender in the Review Packages window
pane. Otherwise, you might need to manually inform the author via another method (e.g.,
email, chat). See "Returning Documents to Authors" on page 15.
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Reviewing Documents—Free
Annotation-Only Mode
1. Open You can open the review package file (e.g., from your email or a link sent by the

author). The files in the review package are listed in the Review Packages window pane.
Double-click a row to review and edit a particular file.

If the review package contains topics as well as snippet files, you can open the snippets too.
You can open snippets by double-clicking them in the Review Packages window pane.
Another approach is to right-click the snippet where it is inserted in a topic (or in another
snippet) and from the context menu select Open Snippet File.

2. (Optional) Insert Comments You can insert annotations (comments) that are associated
with specific areas of text in the document. These annotations do not become part of the
content within the document, but rather are intended for internal use between you and
others. (Do not select more than one paragraph or click at the very end of paragraphs;
otherwise, the "Insert Annotation" option will not be enabled.) See "Inserting Annotations" on
page 13.

3. Return You can return the review package to the author in various ways. Work with the
author to determine how he or she wants to be notified. If the author is using a built-in email
feature, this might simply entail clicking Return to Sender in the Review Packages window
pane. Otherwise, you might need to manually inform the author via another method (e.g.,
email, chat). See "Returning Documents to Authors" on page 15.
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Regular Document Files vs. Lingo
Translation Files

For MadCap Lingo review package (LIREV) files, the XML Editor works a bit differently than it does
for regular document files from products such as Flare or Word. That's because Lingo is a
translation tool, so only text segments are important, and in particular, the target language
segments. When you open a file from an LIREV package, the editor shows a table containing text
segments from that file in the source and target languages. The status of each segment—which
indicates how closely the target segment matches a translated segment in translation memory—is
also shown.
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You can make changes only to the target segment, as well as insert annotations. In addition, you
can make certain formatting edits to the target segment (e.g., bold, underline, color), but many
other features (e.g., insert image, hyperlink, table) are disabled for Lingo review files.

What’s Noteworthy?
IMPORTANT You cannot use the Internal Text Editor when working with review
packages.
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Inserting Annotations
Supported In:

You can insert an annotation (comment) into a document. These annotations do not become part
of the actual content, but rather are intended for internal use between you and others.

How to Insert an Annotation
1. Open the document or topic.

2. Highlight the content that you want to associate with the annotation, or place your cursor on
it.

NOTE Do not highlight more than one paragraph.

3. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Review > Insert Annotation.

n Right-Click If the track changes feature is enabled, you can right-click and select
Insert Annotation.

A rectangle extends to a sidebar on the right, with a line pointing to the selected
content. This rectangle will hold the annotation text after you type it.

Also, the selected content is shaded, indicating that the annotation refers to that text.
However, the shading will not be displayed in the output; it is for internal use only.
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4. Type your comment in the annotation rectangle.

5. Click to save your work.

NOTE When you insert an annotation, your initials are displayed next to it. The initials are
the first two letters of your login user name. However, you can change the user name and
initials (for use in Contributor) to something else. For more information see the online
Help.
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Returning Documents to Authors
Supported In:

After reviewing documents sent from an author, you can return the documents in various ways.
Work with the author to determine how he or she wants to be notified. If the author is using a built-
in email feature, this might simply entail clicking Return to Sender in the Review Packages
window pane (see below). Otherwise, you might need to manually inform the author via another
method (e.g., email, chat).

NOTE There is more than one way to transfer files between individuals using Flare and
Contributor. For example, you can: (1) use the integrated email feature with Microsoft
Outlook, (2) add files to SharePoint or External Resources where others can access them,
or (3) save files to your computer (File > Save, then Save As or Save To) and then
manually transfer them using some method (e.g., email). If you want to use the integrated
email feature, you must have matching versions of Contributor and Outlook. If you are
using 64-bit Contributor, you need 64-bit Outlook. Likewise, if you are using 32-bit
Contributor, you need 32-bit Outlook.

How to Return Documents to Authors (via Built-
In Email Feature)
The following steps include the integrated Outlook email method. If your systems are not set up for
this feature, you can use one another method (e.g., or save to your computer and manually email).

1. Open the review package containing the documents you reviewed. If you do not see the
Review Packages window pane, select Review > Review Packages.

2. In the local toolbar of the Review Packages window pane, click .

3. In the email message, click Send.
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CHAPTER 3

Contribution Workflow
Following is the basic workflow if you are creating original content to be contributed to a MadCap
Flare project.

1. (Optional) Save Contribution Template A Flare author might email you a contribution
template for you to use when creating new documents. Contribution templates are simply
files with certain settings already in place. They are a quick way to create and edit
documents in a pre-set format that the author wants you to use. You can save a contribution
template and then use it later whenever you need to create new documents to send to a
Flare author. By saving the template file in a folder called "Documents\My
Templates\Contributor" you can easily select it when you create a new document. See
"Saving Contribution Templates" on page 20.
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2. Create You can create new documents from the Contributor interface. See "Creating New
Documents" on page 22.

3. (Optional) Insert Comments You can insert annotations (comments) that are associated
with specific areas of text in the document. These annotations do not become part of the
content in the document, but rather are intended for internal use between you and others.

4. After you finish a document, you can do the following.

n Send You can send a finished document to a Flare author so that it can be
incorporated into a project. See "Sending Documents to Authors" on page 25.

n PDF You can save the document as an Adobe PDF document.
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n XPS You can save the document as a Microsoft XPS document (similar to a PDF
document).

n XHTML You can save the document as an XHTML file (with an .htm extension).

n Print You can print the document directly from the Contributor interface.

NOTE Because documents in Contributor are often used as part of Flare projects, you
may sometimes see them referred to as "topics."
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Saving Contribution Templates
Supported In:

A Flare author might email you a contribution template for you to use when creating new
documents. Contribution templates are simply files with certain settings already in place. They are
a quick way to create and edit documents in a pre-set format that the author wants you to use. You
can save a contribution template and then use it later whenever you need to create new
documents to send to a Flare author. By saving the template file in a folder called "Documents\My
Templates\Contributor" you can easily select it when you create a new document.

How to Save Contribution Templates
1. In the Documents folder on your computer, create a subfolder and name it My Templates.

This subfolder can be used to hold all of the contribution templates that an author sends to
you.

2. In the My Templates folder, create a subfolder and name it Contributor.

3. Open the email message that the Flare author has sent to you, with the contribution template
as an attachment.

4. Double-click the attachment.

5. In the dialog that opens, click Save.

6. Navigate to the Documents\My Templates\Contributor folder and click Save.

NOTE In addition to contribution template files (those with an .mccot extension),
Contributor lets you select other types of files from the template folder as well. This
includes document template files (.mcdoct), XHTML files (.htm), stylesheet files (.css), and
page layout files (.mcpglt).
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NOTE Any templates that you created in the past for X-Edit can still be used in
Contributor, but those files will need to be relocated to the new Contributor folder location
in order to use them when creating new documents.

CHAPTER 3  21



Creating New Documents
Supported In:

You can create new documents (or topics) from the Contributor interface. If a Flare author has sent
you a contribution template that you have saved, you can select that template when creating the
new document.

How to Create a New Document
1. Select File > New.

2. Select a file to use as a basis for your new document, either from a template or from another
existing file.

n Factory Templates If you selected Factory Templates, you can choose from various
templates provided by Contributor.

l Document.mcdoct This template creates a basic document with a header and a
little body text. You will end up with a document that has an .mcdoc extension.
Select this option if you want to create a standalone document, rather than a
contribution topic that will be sent to a Flare author.

l Topic.mccot This template creates a very basic topic file with a header and a little
body text. You will end up with a document that has an .mcco extension. An MCCO
file is the same as an MCDOC file, with the exception that it indicates the file was
created specifically for use as a contribution topic. If you create an MCCO
document, you can quickly email it to Flare authors for incorporation into their
projects.
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l XHTML Document.htm This template creates a very basic document with a header
and a little body text. You will end up with an XHTML document that has an .htm
extension. An HTM file is a good option if you want to post the file on the internet or
an intranet, where others can view it in a browser window.

NOTE You can quickly create a new XHTML document by pressing
CTRL+N on the keyboard.

l Stylesheet.css This template creates a cascading stylesheet (CSS). You will end
up with a file that has a .css extension, and it will open in the Stylesheet Editor. A
CSS file can be used to create elements with formatting. You can then apply the
formatted styles to content in a document to change how it looks.

NOTE If a Flare author has provided you with a contribution template,
chances are that you will use the styles provided by the author, rather than
creating your own stylesheet.

l Page Layout.mcpglt This template creates a page layout file. You will end up with a
file that has an .flpgl extension, and it will open in the Page Layout Editor. A page
layout is an element that you can create in order to determine page specifications
(e.g., size, margins) and to apply certain content (e.g., headers, footers, page
numbers) to your document for print-based output. Page layouts allow for easy
configuration through the use of content frames, a snap-to grid, dragging and
dropping, alignment features, and more.

NOTE If a Flare author has provided you with a contribution template,
chances are that you will use the page layout provided by the author, rather
than creating your own page layout.
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n My Templates If you selected My Templates, you can choose from any templates that
you have saved in your "Documents\My Templates\Contributor" folder. This would
likely include any contribution templates that a Flare author has sent to you. See
"Saving Contribution Templates" on page 20.

NOTE Any templates that you created in the past for X-Edit can still be used
in Contributor, but those files will need to be relocated to the new Contributor
folder location in order to use them when creating new documents.

n New from existing This lets you choose an existing file of the same type—that you've
already created and stored somewhere—as a starting point for your new file. As with
template files, your new file will take on all of the settings contained in the file you
select. To use this option, click the browse button , use the Open File dialog to find a
file, and double-click it.

3. In the Folder field, select a folder for the new document. You can browse for a folder by
clicking the browse button . The Open File dialog, will open, allowing you to find a file.

4. In the File Name field, enter a file name.

5. Click OK.

6. For most document types, add any content, formatting, or annotations as necessary. If you
created a stylesheet or page layout, you can use the respective editors to make changes to
those types of files as well.

7. Click to save your work.
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Sending Documents to Authors
Supported In:

You can send a finished contribution document (MCCO file) to a Flare author so that it can be
incorporated into a larger project. You can do this in various ways. Work with the author to
determine how he or she wants to be notified and receive files. If the author is using a built-in email
feature, this might simply entail clicking a Send button in the Contributor interface (see "How to
Send a New Document to an Author" on the next page).

NOTE There is more than one way to transfer files between individuals using Flare and
Contributor. For example, you can: (1) use the integrated email feature with Microsoft
Outlook, (2) add files to SharePoint or External Resources where others can access them,
or (3) save files to your computer (File > Save, then Save As or Save To) and then
manually transfer them using some method (e.g., email). If you want to use the integrated
email feature, you must have matching versions of Contributor and Outlook. If you are
using 64-bit Contributor, you need 64-bit Outlook. Likewise, if you are using 32-bit
Contributor, you need 32-bit Outlook.
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How to Send a New Document to an Author
The following steps include the integrated Outlook email method. If your systems are not set up for
this feature, you can use one another method (e.g., or save to your computer and manually email).

1. Create or open the MCCO file.

NOTE If you have just created a new document, you must save it before you can
send it.

2. In the local toolbar of the editor click .

3. Complete the email message with the address of the recipient(s) and any message text.
Then send it.
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APPENDIX

PDFs
The following PDFs are available for download from the online Help.

Cheat Sheets
Shortcuts Cheat Sheet

User Guides
Getting Started Guide

Contributor Workflow Guide

Review Workflow Guide

What's New Guide
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