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CHAPTER 1

Introduction
Welcome to MadCap Doc-To-Help—a single-source authoring tool that makes it possible to write in
Microsoft Word once and publish to many different deliverables.

This chapter discusses the following:

Key Benefits 6

Where Do I Begin? 7

Content Reuse and More 8

Getting Additional Help 19
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Key Benefits
Doc-To-Help offers the following:

n Authoring in familiar Word environment

n Access to all Doc-To-Help features without leaving the Word interface

l Doc-To-Help menu under the File menu

l Ribbons in Word to handle Doc-To-Help, project, and target functionality

l Doc-To-Help project panel to easily manage all of your project elements

n Quick and easy creation of online Help, training manuals, user guides, knowledge bases, and
more

n Publishing to multiple outputs, including responsive web, PDF, EPUB, and more

n Professional built-in output themes, with ability to customize your own

n Multi-language support, through integration with MadCap Lingo

n Team authoring features
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Where Do I Begin?
Following are some suggestions to help ease you into the world of Doc-To-Help.

Training
Consider signing up for a training course. It’s well worth your time and will go a long way toward get-
ting you off on the right foot. See http://www.madcapsoftware.com/services/training/.

Website Resources
Use the resources for Doc-To-Help on our website. See http://www.doctohelp.com.

Videos
Videos have been developed to help you become familiar with Doc-To-Help.

See https://www.doctohelp.com/videos/doc-to-help/.

PDF Guides
You can download and read the Doc-To-Help PDF manuals. See "PDFs" on page 47.

Getting Started Tutorial
This self-paced tutorial will show you how easy it is to create a project in Doc-To-Help, as well as
build your output, apply styles, create links, and more. See the online Help or the Getting Started
Tutorial Guide.

Sample Projects
Doc-To-Help includes several real-world sample projects that you can use to learn more about Doc-
To-Help. These projects can be found here on your computer:

C:\Users\[username]\Documents\My Doc-To-Help Projects\Samples

The path may be slightly different depending on your operating system.
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Content Reuse and More
There are all kinds of things you can do in Doc-To-Help. But you don't have to do them all. There are
actually just a few concepts and features that are the most important to grasp. Don't expect to be
an expert at everything right away. Instead, begin by trying to wrap your brain around a few con-
cepts and features that are most important when it comes to learning Doc-To-Help. These con-
cepts and features all tend to revolve around the idea of content reuse (or single-sourcing), which
means that you can take the same content, re-use it, and produce multiple outputs from it.

EXAMPLES

One of the most common ways to single-source a project is to produce one type of
online output (such as NetHelp), as well as multiple print-based outputs (Manual tar-
gets) from the same source Word document.

Another way to take advantage of single-sourcing is to use one set of documents to cre-
ate output for multiple audiences, such as an Administrator version and a Manager ver-
sion.

One more possibility is that you might take the same source content and generate out-
put for different purposes, such as documentation, training, or reference materials.

You might even use a combination of these techniques. For example, you might create
one desktop-based online Help system, a web-based elearning site, a PDF quick start
manual for administrators, a PDF quick start manual for managers, and a PDF ref-
erence manual for co-workers. And it is all created from the same Word source con-
tent.
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What are You Trying to Accomplish?
Following are some important questions you will likely need to answer before you begin creating
files and content:

n What kinds of output do you want to create? Do you need online output, print output, or both?
How many different versions of online and print output do you need? See "Developing Targets"
on page 39.

n How will you name your files to keep things consistent and organized?

n What kinds of variables will you need?

n What kinds of conditions will you need?

n Will one author be working on the project or will multiple people be involved? See the online
Help or the Project Management Guide.

In other words, the more planning and preparation you do beforehand, the smoother your journey in
Doc-To-Help will be.

Automated Single-Sourcing
Whether you start out with just a single Word document or have several Word files, Doc-To-Help
does several things to make it easier to single-source.

n Structure (Documents to Topics) Word documents can be relatively easy to work with, but
they aren't necessarily the most conducive format when it comes to online output. That's
because online output (e.g., a website or online Help system) is typically broken up into sev-
eral somewhat small pages, whereas a Word document is a single presentation of inform-
ation, and sometimes a quite long one at that. To make your Word document more useful for
online output, it is broken up into smaller elements called "topics," which are based on the
heading styles in the document. After you create a Doc-To-Help project and build some out-
put from it, Doc-To-Help automatically creates multiple topics as a result, structuring the con-
tent for online documentation. Heading 1 styles in your Word document automatically
become parent topics, and all of the Heading 2 styles under a Heading 1 style become sub-
topics. Just keep in mind that these topics are not created until you build at least one target in
your project.
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EXAMPLE

The following shows a project containing two Word documents, one that con-
tains the main content and a second being used as a glossary. No targets in this
project have been generated yet. Therefore, no topics exist right now.
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After building a target, notice that the Topics panel is now populated, based on
the heading styles in the Word source document. In this case, multiple topics
were created from the two source documents. It also shows the structure of the
table of contents that will be created in the output.

The Contents window pane in the Doc-To-Help Project panel in Word is also pop-
ulated. If you are working in a source document in Word, you can use the Con-
tents pane in the Doc-To-Help Project panel to quickly view the structure of the
document, jump to locations in the source document, or create links.
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n Navigation Parent topics automatically include "See Also" links to subtopics.

EXAMPLE

The following shows a parent topic containing links to its three subtopics.
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n Links Cross-references (with page numbers in print-based Manual targets) are automatically
converted to hyperlinks in online output. Also, manuals can be set up to include both hyper-
links and page number cross-references. This is useful for both types of end users—those who
prefer to read on screen or print out the manual.

EXAMPLE

Here is how a cross-reference might look in the Word source document:
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When you generate and view the PDF, the link looks like this:

But when you generate and view NetHelp online output, the link looks like this:
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n Drop-Downs and Expanding Text Your text can be flagged so that it appears as drop-down or
expanding text in online output. This text will automatically be included in the print-based out-
put.

EXAMPLE

Here is how a drop-down might look in the Word source document:
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When you generate and view NetHelp online output, the link initially looks like this:

When the drop-down is clicked, it looks like this:
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When you generate and view the PDF, the drop-down looks like this:

n Margin Notes Margin notes included in printed outputs automatically become popups in
online output.

n Front Matter and Back Matter For print-based manuals, Doc-To-Help automatically generates
the title page, table of contents, and index so you don't have to. This occurs if the front matter
and back matter elements are part of the target template that you use. When you open the
target template or generate output, you will see these elements, but when you edit your
source document, you won't see them.
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Getting Additional Help
You can use any of the following resources for additional help not provided in this manual.

Knowledge Base
You can browse the online Knowledge Base for articles covering common support issues.

http://kb.madcapsoftware.com/

Peer-to-Peer Online Forums
You can visit the online forums to learn from other users or share your own expertise.

http://forums.madcapsoftware.com/

Contact Doc-To-Help Support
You can contact the Doc-To-Help support team and get answers to your specific support issues.

http://madcapsoftware.com/support/
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CHAPTER 2

Creating Projects
You can easily create a new project.

This chapter discusses the following:

How to Create a New Project 21

How to Open a Project 25

How to Save a Copy of a Project 26

File Locations 28
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How to Create a New Project
1. In Word, select File > Doc-To-Help. The Open/Create submenu is displayed by default.
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2. Click the New Project button. The New Project Wizard opens.

3. In the Project Name field, type a name for your project.

4. By default, a path to the Documents\My Doc-To-Help Projects folder on your hard drive is
entered in the Location field. (Doc-To-Help creates the My Doc-To-Help Projects folder when
you install the program.) All subfolders and files related to the project will be placed in this
folder as you work on the project. Continue with the next step, unless you want to have your
project files placed in a different folder. If so, do the following:

a. Click . The Browse For Folder dialog opens.

b. Navigate to the folder you want, select it, and click OK.

5. Click Next.

6. (Optional) If you have an older Doc-To-Help project and want to import settings (e.g., attrib-
utes, windows, styles, templates) from it into the new project, click Import settings from this
project. Then click and select that older project.

7. Click Next.

8. Select the language that you want to use for the project.

9. Click Next.
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10. Select a Microsoft Word template to attach to your project. You can always change the tem-
plate later. Also, you can select Add my own set of styles from the drop-down if you want to
select your own template.

11. Click Next.

12. Select a default target (i.e., output type) for your project. You can select and build any target
once your project is created. Your default choice is effective only until you choose another.

13. Click Next.

14. Select one of the following:

n Microsoft Word The new project will include a new Word document.

n Import existing files Select this if you have Word files that you want to import into the new
project.

15. Click Next.

16. Click Finish.

17. If you selected "Microsoft Word" in step 14, the Save New Document As dialog opens. Provide
a name for the new document and click Save.

If you selected "Import existing files" in step 14, the Document Import Wizard opens. Select
either Local or SharePoint (depending on the location of the files to be imported). Then click
Next and complete one of the following sets of steps.

LOCAL

a. Click Add file(s).

b. Find and select the Word files to import, then click Open.

c. Complete any of the other fields as necessary, then click Import.

SHAREPOINT

a. Enter the document's SharePoint URL.

b. (Optional) Select the first check box if you want to specify a custom location for auxiliary
file storage (e.g., linked files such as graphics), then use the field below to choose the loc-
ation.

c. (Optional) If you wish to import the document(s) without retaining their connection to
SharePoint, clear the Retain SharePoint Connection check box.

d. Click Next.
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e. Choose the document(s) you would like to import using the check boxes. The documents
will automatically be copied to the Documents folder in your project by default. You can
change the folder location using the Copy files to field.

f. Click Next.

g. Confirm your choices and click Next. The document(s) will then be imported.

h. Click Finish.
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How to Open a Project
1. In Word, select File > Doc-To-Help. The Open/Create submenu is displayed by default.

2. Click the Open Project button. The Open Doc-To-Help Project dialog opens.

3. Choose your project (.d2h file) and click Open.

NOTE: If you choose a project created in an earlier version of Doc-To-Help, a message box
will inform you that the project will be updated to the current version. Click OK.
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How to Save a Copy of a Project
When you save a copy of your project, Doc-To-Help will append the name of the project folder with
"Copy" unless you rename it.

1. Select File > Doc-To-Help.

2. Click the Common Tasks link under the Project submenu on the Doc-To-Help window.
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3. Click the Save As button. The Save Project As dialog opens.

4. Enter the Project Name; the folder location will update accordingly. If you would like to change
the directory, click .

5. (Optional) If you would like your Target folders to be copied also, select the Copy target
folders check box. If you have renamed the project, or if your Target folders are very large,
you may not want to copy them.

6. Click the Save button.
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File Locations
When you create a new project, Doc-To-Help stores your source documents and templates in the fol-
lowing locations.

Source Document Location
By default, Doc-To-Help will store your projects in the My Doc-To-Help Projects folder. This folder
can be found at C:\Users\[username]\Documents\My Doc-To-Help Projects.

To change the default location for Doc-To-Help projects, use the Options dialog (File > Doc-To-Help
> Common Tasks > Options). Select Files and change the default locations.

Within your Doc-To-Help project folder:

n Word source documents are located by default in the Documents folder.

n Graphics (images, movies, etc.) should be stored in the Media folder.

These locations can be confirmed in the Project Settings dialog (to do this, at the bottom of the Pro-
ject ribbon, click ).

Template Location
Doc-To-Help source and target templates are stored at:

C:\Users\<user name>\AppData\Roaming\Microsoft\Templates.

If you uninstall Doc-To-Help and reinstall a newer version, the templates will remain in that folder.
However, if  one of your customized templates uses the same name as one of Doc-To-Help's default
templates, and there is a newer version of that template in the installation, Doc-To-Help will save
your version of the template to the C:\Program Files (x86)\MadCap Software\MadCap DocToHelp
6\Backup\Templates folder.

The Application Data or App Data folder is a hidden folder. To show hidden folders, open the Folder
Options dialog in your operating system (Control Panel > Folder Options). Click the View tab, under
Advanced Settings > Files and folders > Hidden files and folders, select the Show hidden files and
folders radio button. Click OK.

For more about templates, see "Content and Features" on page 30.
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NOTE: When you create a new project, a glossary document is automatically created. You
can delete this document if you wish. If you’d like to flag a different document as your gloss-
ary, add it to the project and right-click on it in the Documents window pane in Doc-To-Help.
From the menu choose Glossary.
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CHAPTER 3

Content and Features
As soon as you start a project, you can do any number of things with it. Technically, you could build
the final output immediately. However, if it is a new project with a new Word document, building the
output right away would not do your end users much good, since the output does not yet have much
real substance. The project needs content, links, navigation, and all of the other elements necessary
to help your end users. For additional information not discussed in this chapter, see the online Help
or the Documents, Templates, and Content Guide.

This chapter discusses the following:

Source Documents and Content 31

Templates 33
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Source Documents and Content
You can add multiple Microsoft® Word source documents to your project, and within those you can
add many kinds of elements and objects. Some features (e.g., images, lists, tables) are built into
Word and therefore always available, whether the document is part of a Doc-To-Help project or not.
Other features are unique to Doc-To-Help and are available in Word through the Doc-To-Help ribbon,
Target ribbon, Project ribbon, and Doc-To-Help Project panel.

Project Elements and Objects
In addition to the elements and objects that you add within a Word source document, there are
other features (e.g., indexes, groups, related topics, custom tables of contents) that you can add
and manage in the Doc-To-Help Project panel. See the online help or Touring the Workspace Guide
for more information.

Elements and Objects That You Can Add to a Project
Following is a list of elements and objects that you can add to your source documents or within the
Doc-To-Help project. We're not listing the many elements and objects that are built in to Word. For
information about adding those kinds of features, see the online Help provided with Word. Instead,
we are focusing on the elements and objects that are specific to Doc-To-Help.

Some of these features can be used in online output as well as print-based output, whereas some
are for online output only.

n Documents You can add new or existing Word documents to your project.

n ActiveX Controls These controls can be used to provide features in compiled HTML Help sys-
tems (CHM files).

n Conditions A condition is a single-sourcing feature that you can apply to files or to different
areas of your content, so that some information displays in some outputs but not in others. It
is a key feature when it comes to single-sourcing in Doc-To-Help.

n Glossaries A glossary is a list of specialized words with their definitions, accessed in online out-
put or placed at the end of a PDF. When you create a new Doc-To-Help project, a glossary doc-
ument is added automatically. However, you can delete this file or flag a different document
as your glossary. Whenever you like, you can add glossary terms to the file.

n Image Maps You can insert images into your source documents, using the standard options
available in Word. (We recommend using the "Insert and Link" option, and placing images in
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your Media folder.) For online outputs, you can create hotspots from an image that link to top-
ics, keywords, or groups.

n Indexes Index entries are also called "keywords" (or K-links). They will display in your output in
an index.

n Margin Notes Margin notes are used to place text or images in the left margin of a manual,
next to the main body of the text. Margin notes do not appear in online outputs unless you
explicitly link them to the text, where they will appear as popups.

n Multimedia In the Doc-To-Help ribbon in Word, there is an option named "Multimedia" that lets
you insert video files and embed online videos.

n Navigation Links A navigation link is a feature that points to additional information from a spe-
cific area in a topic or document. This can include basic links, cross-references, inline text
effects (expanded, drop-down, popup), expanding/collapsing sections, groups, and related top-
ics.

n Tables You can quickly insert a table into a Word document using the Doc-To-Help Special For-
matting toolbar or ribbon. The table will be pre-formatted with the correct Doc-To-Help styles,
and you can specify borders, indentation, and shading of the heading row.

n Tables of Contents Doc-To-Help automatically creates a table of contents (TOC) for you
based on the structure of your documents. But you can create a custom TOC (you can even
have different TOCs for different targets) if you wish.

n Variables Variables allow you to write content once, and manage it in one place for reuse
across your project. When adding a new text variable (not a rich content variable), you can
now select one of three types: Text, Version, or Date/Time.

NOTE: Doc-To-Help supports DOC, DOCX, DOCM, and RTF files.

NOTE: These features are all available through Microsoft Word.

NOTE: Doc-To-Help styles reside in individual Doc-To-Help templates (such as D2H_NORM.-
dotx), so you should create your files using a predefined Doc-To-Help template and edit it to
your specifications.
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Templates
Word uses template files (DOTX) whenever you create a new Word document. Depending on the
template you use, various styles are already available for you. Doc-To-Help provides predefined tem-
plates to determine how your content will look and work. The name of these templates all begin with
a D2H prefix (e.g., D2H_NOMARGIN.dotx) and contain both Word styles and Doc-To-Help's special
styles, which you apply to content in your Word source documents. Most templates are designed for
print-based outputs, while a couple are available for online outputs.

Doc-To-Help uses two kinds predefined templates to determine how content will look.

n Source Templates These control the look of source documents. Additionally, all of the con-
tent in source templates appears in new documents created from the template, so you can
use custom source templates as a way to provide structure to new documents (e.g., defining
headings, providing sample text).

n Target Templates These control the look of the final output.

These templates contain styles that you apply to your source document. The source styles are inter-
preted by the target template you have chosen so that your output looks and behaves the way you
desire. Styles control your final outputs in multiple ways, and they are a convenient and efficient
way to keep your content looking consistent. Therefore, it is important to use them and avoid apply-
ing local formatting.

You can use the Project ribbon to add and manage the source templates of your Doc-To-Help pro-
ject.

The Target ribbon is used to add and manage the target templates of your Doc-To-Help project.
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CHAPTER 4

Design
There are multiple ways to affect the look of your output. For more information not discussed in this
chapter, see the online Help or the Design Guide.

This chapter discusses the following:

Styles 35

Themes 37

Window Display 38
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Styles
To control the look (and sometimes behavior) of your content, you will use styles associated with
Word and Doc-To-Help. Local formatting (changing the look of content directly on the text) is also
possible, but not recommended. Styles are better because they let you control the look of content in
many places by changing a single style property. There are a few ways to use styles and some
important concepts to know when you are working on a Doc-To-Help project.

If you're used to Microsoft Word, you know that styles can be applied to content to change how it
looks. You can apply Word styles just like you normally would in a document that is not part of a Doc-
To-Help project. However, you should be aware of the following when working in a Word document
that is part of a Doc-To-Help project:

n Doc-To-Help relies on your use of Word's heading styles (e.g., Heading 1, Heading 2) in order
to break your document up into multiple topics. This is important for online outputs. So you
should make sure to apply those styles to headings in your document where you anticipate
new online topics should start.

TIP: If you plan to implement context-sensitive Help, you should standardize on one
(at most two) heading styles that Help button topics will map to. It can be confusing
to the user if multiple styles appear from Help buttons. Make sure to structure inform-
ation so that Help buttons have only one logical mapping. Dialogs that are reused
throughout an application can make this challenging.

n In addition to Word's styles, Doc-To-Help has several special styles that it uses for certain fea-
tures (e.g., drop-downs, popups, conditions). These styles are automatically applied to con-
tent when you use features in the Doc-To-Help ribbon in the Word document. Also, you will see
these styles (which begin with C1H) when you open the Styles window in Word.
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Themes
Doc-To-Help uses themes to style the "skin" that surrounds your content in online output, as well as
the button display and labels, icons, colors, and so much more. Several predefined themes are
included for each online target, and it is easy to create a custom theme to meet your needs and pref-
erences.

You can access themes from the Home ribbon by using the Theme drop-down. Keep in mind that
the theme options (as well as other options on the ribbon) depend on which kind of output type you
choose from the Select Target drop-down (see "Developing Targets" on page 39).
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Custom themes are stored by default on your computer in C:\Users\[username]\Documents\My
Doc-To-Help Projects\Doc-To-Help\Themes. You can change this location using the Doc-To-Help
Options dialog (File > Tools > Options). In the dialog, select Files.

Window Display
The Windows dialog controls the position and—depending on the target—the buttons, caption, back-
ground color, and other characteristics of output windows. Any window options not specified here
will be set using the Theme Designer.

You can open the Windows dialog in Doc-To-Help by selecting Project > Windows.
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CHAPTER 5

Developing Targets
Before you generate output from your project, there are various tasks that you are likely to perform
while developing your targets. To begin with, you need to determine what kind and how many types
of output you want to provide for your end users. For additional information not discussed in this
chapter, see the online Help or the Targets Guide.

This chapter discusses the following:

Output Types 40

Targets 40

Conditions 40

Steps Associated With Targets 41
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Output Types
There are several types of online output (Eclipse Help, EPUB, Microsoft Help 2.0, Microsoft HTML
Help, Microsoft Help Viewer, JavaHelp, NetHelp) and one type of print-based output (Manual) that
you can produce in Doc-To-Help. Each output type has its own set of advantages.

When you first create a Doc-To-Help project, you'll notice that targets based on each output type
are available to you. But you can remove those you don't plan to use and add more targets based on
the output types that you want to publish.

Targets
It is easy to confuse output types with targets, but they are two different (although related) con-
cepts. A target is one instance of an output type. It is the engine that takes all of your files and set-
tings, and brings them together to produce the end result. When you build your final output, you are
essentially building one or more of the targets in your project.

When you create a new Doc-To-Help project, one target of each output type is added to your pro-
ject.

However, any targets added to the project are just a starting point for you. You can rename them to
reflect the nature of your project. For example, if you are writing a Help system for a software pro-
gram called FictionSoftPro, you could rename a target "FictionSoftPro." Also, just because only one
target was added when you first created the project, this does not mean that you are limited to just
that target in your project. You can add asmany new targets as you need, using any of the available
formats. Each target has properties that you adjust to change the way the target behaves, as well
as the way it looks and feels.

Conditions
A condition is a single-sourcing feature that you can apply to files or to different areas of your con-
tent, so that some information displays in some outputs but not in others. Although there are several
settings that are important in each target, conditions are particularly important because they are
central to your ability to single-source output from one set of source content. See the online Help or
the Documents, Templates, and Contents Guide.
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EXAMPLE

Let's say you have two different audiences—beginners and advanced users. The con-
tent in your project is the same in most places for both audiences. However, there are
sections that apply only to the beginners, and other sections that apply only to the
advanced users. You can use one condition to mark the sections for the beginners only,
and you can use another condition to mark the sections for advanced users only. This
lets you create one output for the beginners and another output for the advanced users
without having to create two separate projects.

Steps Associated With Targets
Following are the primary steps when developing targets:

1. Determine Output Type The first task in developing output for your project is to determine
which type of output is most appropriate for your needs. You might even need to produce mul-
tiple outputs and require more than one output type.

2. Create/Delete Targets Every target in a project has a particular output type assigned to it.
You can add multiple targets to a project. For example, your project might end up containing
three targets that are all based on the NetHelp output type and eight that are based on the
Manual output type. While you create new targets, you can also remove targets provided by
Doc-To-Help that you don't plan to use.

3. Edit Target Settings Using the Help Targets dialog, you can apply all kinds of settings to a tar-
get. This includes renaming the target to reflect the nature of your project, setting attributes
(choosing the conditions to include or exclude from the output), and much more. The settings
that are available are different for each output type.

4. Add Transformations Using the Transformation Wizard, you can insert boilerplate content or
code into every topic in your targets. Examples include: headers, footers, or code needed for
technology such as analytics.

5. Select Targets When you want to work with a target, or you are ready to build its output, you
need to select that target.

If your project has target-specific tables of contents, you can select the target you want to
work with by opening the Doc-To-Help Project panel (Project ribbon> Project Panel), then
opening the Contents window pane and selecting a target-specific table of contents from the
drop-down.
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CHAPTER 6

Building Output
By building a target, Doc-To-Help can produce multiple types of outputs: NetHelp (including respons-
ive), HTML Help, EPUB, Eclipse Help, JavaHelp, Manual, Microsoft Help Viewer, and Microsoft Help
2.0.

Target names and other details are customized using the Help Targets dialog.

For additional information not discussed in this chapter, see the online Help or the Targets Guide.

This chapter discusses the following:
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How to Build a Target
1. Save your Word source documents.

2. Select the Doc-To-Help ribbon. In the Project section, click Build. The Doc-To-Help Build panel
opens.

3. From the Active Target drop-down in the local toolbar, select the target you want to build.

NOTE: When you select a target in the local toolbar, it does not affect the active tar-
get in the Doc-To-Help application and it does not affect other Word panels and other
open Word source documents. However, when you start building a target, if you have
other Word source documents open, the Target drop-down in those documents will
synchronize to show the target that is being built.

4. In the local toolbar, click Build or Rebuild.

n Build When you choose the Build button, Doc-To-Help recognizes all the source doc-
uments that have been edited since the last build and makes those changes in the out-
put. This is the quickest way to build a project.

n Rebuild When you choose the Rebuild button, Doc-To-Help deletes all of the content in
the output folder of your target, then builds everything from scratch (not just source
documents). If you make any global changes to your project (e.g., changing project set-
tings, creating variables, glossary entries), you should do a rebuild. A rebuild will always
take longer than a build, especially on large projects. You should always do a rebuild
before reviews and releases.

5. When the target is done building, a dialog asks if you want to view the target. Click Yes to view
it; otherwise click No. You can also view the target by clicking View in the Doc-To-Help Build
panel's local toolbar.

6. (Optional) You can also do any of the following:

n Use the Cancel Build button in the local toolbar to stop a build.

n Click the Open Build Log link on the Build Log tab to view the build log.

n Click the Errors and Unresolved Links tab to view and sort any errors that may have
occurred during the build.
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NOTE: If you are building a target in Word, you will not be able to open Doc-To-Help from
Word until the build is completed.

NOTE: If you remove targets from your project in the Help Targets dialog , you will not see
these targets when viewing Target drop-downs in Word (e.g., in the Contents window pane
or in the Doc-To-Help Build panel).

CHAPTER 6  44



EPUB Output
EPUB output will open in your default reader (such as Calibre) after it is built. To set the default
EPUB reader in Doc-To-Help, go to File > Doc-To-Help > Common Tasks > Options. In the Options dia-
log, select Viewers and choose the EPUB viewer executable.
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Manual Output
When you build a Manual target, you can build a PDF version at the same time. To do so, open the
Help Targets dialog, choose the Manual target, and select the Generate PDF check box. After build-
ing the target, you can then open the Home ribbon and click the View PDF button. Projects will use
Word's built-in PDF converter.

When you view the Word version of your Manual output, the resulting file will have a different Doc-
To-Help ribbon than the source documents. In the target document, the ribbon will contain only the
basic styles and tools necessary to make final adjustments to your manual before printing or con-
version to PDF, such as the Cross-Reference button and the Margin Notes button.

NOTE: When building output, you can schedule builds so that they run on a one-time, daily,
or weekly basis.

NOTE: You can also build targets in batch mode using the command line or using Windows
Services.

NOTE: You can edit Word source documents while building a target. If you choose to edit a
source document that has been shared to SharePoint, it can only be edited locally and all
automatic operations with the SharePoint server are disabled.
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APPENDIX

PDFs
The following PDFs are available for download from the online Help.

On the Doc-To-Help Start Page, click the PDF Guides icon to access them.

Context-sensitive Help Guide Shortcuts Cheat Sheet

Design Guide Targets Guide

Documents, Templates, and Content Guide Touring the Workspace Guide

Getting Started Guide Upgrading Old Projects Guide

Getting Started Tutorial What's New Guide

Project Management Guide
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