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CHAPTER 1

Introduction
MadCap Central is a cloud-based platform that lets you plan, track, and manage the processes, content, and teams that are at the heart of your organization. Following are some of the main benefits
of integrating your Flare projects with Central:
n

Host builds with custom vanity URLs

n

Assign user permissions

n

Use integrated checklists

n

Collaborate with subject matter experts and other authors

n

Create and manage tasks

n

Customize dashboards and widgets

For more complete information about Central, see its online Help:
http://help.madcapsoftware.com/central
Although MadCap Central is located in the cloud, it is integrated with MadCap Flare. This integration
lets you store copies of your projects in Central, continue to work on them locally in Flare, and keep
both sets of copies in sync. You can use Central to quickly build and publish output (and roll back
when necessary) without the need to involve an IT department. You can also send topics and snippets for review on Central, as well as use custom checklists to track your progress in Flare projects.
This chapter discusses the following:
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MadCap Central Window Pane
The MadCap Central window pane in Flare lets you upload (bind) and import projects, as well as
push project changes to Central. Additionally, you can see project properties, log in and out of your
Central account, and launch the Central portal in your browser.
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Tasks Associated with Central
Following are tasks that you can perform from the MadCap Central window pane in Flare:
n

Log In and Log Out If you have an account in Central, you are able to log in and out of your
account from Flare. When you are logged in, you are able to access project properties, upload
(bind) and import projects, and push project changes to the cloud. See "Logging In and Out" on
page 13.

n

Uploading (Binding) Projects You do not have to be a Flare user in order to take advantage of
the various features in MadCap Central. However, if you would like to add a Flare project to a
Central license, you can upload the project from your desktop Flare application. A copy of the
project will therefore reside in the cloud via Central, and you will be able to keep the local and
cloud versions of the project synchronized using integrated source control. You will also be
able to generate and publish Flare targets using Central. See "Uploading (Binding) Projects" on
page 14.

n

Importing Projects If another user uploads a Flare project to your MadCap Central license and
you do not yet have that project on your computer, you can import it. See "Importing Projects
from Central" on page 20.

n

Committing and Synchronizing (Pull, Push) in Single-bound Model If you are working in a
single-bound model, you author content in Flare. When you want to transfer your changes to
Central, you commit files that you’ve changed. This gives you the opportunity to organize your
files into different groups when you add them to Central, and to add a comment to each commit as well. After this, you synchronize (pull, push) your changes with the cloned project on
Central. See "Committing and Synchronizing (Pull, Push) in a Single-bound Model" on page 49.

n

Pushing in Dual-bound ModelIf you are working in a dual-bound model, you author content in
Flare and use your third-party source control tool to synchronize your files with those from
other writers. After this, you use Flare to push those changes to Central. See "Pushing in a
Dual-bound Model" on page 53.

n

Viewing Project Properties If you have access to a project in Central (i.e., you have been
added to the project), you can view its properties in the MadCap Central window pane. This
lets you see relevant information about the project, such as when it was added to Central, the
number of files in the project, and build information. See "Viewing Project Properties" on page
55.
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n

Removing Bindings If you no longer need your project to be bound to Central, you can remove
its binding. Removing the binding from a project does not remove that project from Central;
instead, it simply removes the link between Central and your local project. The project will still
be available locally, but you will no longer be able to upload (push) changes from your local project to the cloned project on Central. See "Removing Bindings" on page 78.

You can also do the following if you want to use MadCap Central for your review process:
n

Send for Review The Central review process lets you send Flare topics and snippets to be
reviewed by subject matter experts (SMEs) or other Flare authors on MadCap Central. After
making edits and adding annotations (comments) to the files in a lightweight editor on Central, the reviewers submit the finished files, sending them back to your inbox in Flare. You can
then accept or reject their changes and accept the file, replacing the original source file.
Because this system uses the cloud, SMEs do not need to download any software to review
your files. Also, multiple reviewers can edit the same file at the same time. See "Sending Files
for Review on Central" on page 62.
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Single-bound Versus Dual-bound
When you upload a Flare project to Central, the files are connected to Central via an integrated
source control system. Your interaction with source control can follow one of two models—singlebound or dual-bound. Single-bound projects are not bound to an additional third-party source control
provider; they only use Central's source control system. Dual-bound projects, on the other hand, are
already bound to another source control provider, and therefore are bound to both the original thirdparty source control provider and to Central.
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Security
Security and privacy are top priorities at MadCap Software, especially when providing customers
with a cloud-based system in Central. We are committed to keeping your files, data, and communications secure. Therefore, in choosing Microsoft® Azure as a partner, we focused on selecting
a security center that understands the importance of privacy and complies with the highest international and industry-specific compliance standards and uptime guarantees. Microsoft Azure regularly undergoes rigorous third-party audits to ensure and verify the highest level of security
controls.
For more information, see the following:
https://www.microsoft.com/en-us/TrustCenter/Security/default.aspx
Also see "Data Centers and Disaster Recovery" on page 85.

NOTE: At this time, you cannot perform source control tasks from the Central interface.
This can be done only from the Flare project.

NOTE: Certain Flare features are not supported when generating output from Central. This
includes limitations on which output formats can be generated and viewed from Central.
See "Flare Features Not Supported in MadCap Central" on page 80.

NOTE: MadCap Central is sold separately from Flare. Please contact MadCap Software
Sales for more information.
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CHAPTER 2

Logging In and Out
If you have an account in Central, you are able to log in and out of your account from Flare. When
you are logged in, you are able to access project properties, upload (bind) and import projects, and
push project changes to the cloud.

LOGGING IN
1. Open the project in MadCap Flare.
2. Select View > MadCap Central. The MadCap Central window pane opens.
3. Enter the same username (i.e., email) and password that you use for logging in to Central.
4. Click Log In.

LOGGING OUT
1. Select View > MadCap Central. The MadCap Central window pane opens.
2. Click

.

NOTE: Logging in or out of Central in Flare does not affect your login status in Central
online. This is beneficial because you do not need to open both the Central website and
Flare if you only need to work in one or the other.
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CHAPTER 3

Uploading (Binding) Projects
You do not have to be a Flare user in order to take advantage of the various features in MadCap Central. However, if you would like to add a Flare project to a Central license, you can upload the project
from your desktop Flare application. A copy of the project will therefore reside in the cloud via Central, and you will be able to keep the local and cloud versions of the project synchronized using integrated source control. You will also be able to generate and publish Flare targets using Central.
For this activity, you must have the following permission setting in Central:

For more information about permissions, see the Central online Help.

NOTE: Before binding a new project to Central, or importing a project that is already
uploaded, you can choose between a couple of transfer protocol options (SSH or HTTPS).
See "Selecting a MadCap Central Transfer Protocol" on page 19.

CHAPTER 3

14

HOW TO UPLOAD (BIND) A PROJECT TO CENTRAL
1. Open the project in MadCap Flare.
2. Select View > MadCap Central. The MadCap Central window pane opens.
3. If you are not yet logged in, enter the same username (i.e., email) and password that you use
for logging into Central, and click Log In.
4. Click

.

TIP: If this button is disabled, try clicking in the window pane first.
5. In the Bind Project dialog, you can complete any of the following fields, then click OK.
n

Select License If you are a member of more than one MadCap Central license, you can
use this field to choose the license where the project will be added.

n

Enter project name This shows the name of the project. You can change the name if
you want, but in most cases you will probably want to keep the same name.

n

Enter project description You can enter a short description, which can then be seen
when anyone views the project profile in Central.
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6. In the success message, click OK. The MadCap Central window pane adjusts, showing properties for the current project.

7. (Optional) In the local toolbar, click

CHAPTER 3

to open Central.
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8. (Optional) In Central, you can click
be shown in the grid. If it isn’t, click

to open the Project page. The uploaded project should
to refresh the page.

NOTE: Binding your project to Central adds an ID to the Flare project file. If your project is dual-bound, be sure you check in the project to your third-party source control
provider after you bind to Central. This will ensure that other users who import the project from source control have the most recent version of the project file (i.e., the one
with the Central ID). The Central ID is necessary for Central to recognize that each
user's local copy of the project is linked to the copy in Central.

NOTE: When you bind a project to Central, a .gitignore text file is automatically created in your local project folder. Advanced users can edit the .gitignore file with a text
editor to control which files or folders can be pushed to your Git repository. You can
also specify which files and folders are ignored by Git, and are not pushed to the repository.
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NOTE: If you intend to build a target that links to an outside Flare project (e.g., for the
purpose of importing files via Global Project Linking, project merging, or multilingual
output), make sure that the other project is also uploaded to Central. Otherwise, the
automated imports or merging will not work.
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Selecting a MadCap Central Transfer
Protocol
If you plan to bind a Flare project to a MadCap Central license, you can choose between a couple of
transfer protocol options when performing the binding. This includes binding new projects or importing existing projects from Central. It does not affect existing projects that are already bound.

HOW TO SELECT A MADCAP CENTRAL TRANSFER PROTOCOL
1. Select File > Options. The Options dialog opens.
2. Select the Source Control tab.
3. Under MadCap Central Transfer Protocol, select one of the following:
n

SSH Also called “Secure Shell,” this is a network protocol that allows you to communicate remotely and securely between computers.

n

HTTPS Hypertext Transfer Protocol Secure (HTTPS) is a more secure version of HTTP,
which is the standard protocol for transferring data over the web.

Some companies might prefer HTTPS, but SSH could be necessary for binding especially
large projects to Central.

4. Click OK.
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CHAPTER 4

Importing Projects from Central
If another user uploads a Flare project to your MadCap Central license and you do not yet have that
project on your computer, you can import it. You can do this from the MadCap Central window pane
in Flare.
In order to import a project, you must be associated with that project in Central. For more information, see the Central online Help.
For this activity, you must have the following permission setting in Central:

For more information about permissions, see the Central online Help.

NOTE: Before binding a new project to Central, or importing a project that is already
uploaded, you can choose between a couple of transfer protocol options (SSH or HTTPS).
See "Selecting a MadCap Central Transfer Protocol" on page 19.
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HOW TO IMPORT A PROJECT FROM CENTRAL
1. Open MadCap Flare.
2. Select View > MadCap Central. The MadCap Central window pane opens.
3. If you are not yet logged in, enter the same username (i.e., email) and password that you use
for logging into Central, and click Log In.
4. Click

.

TIP: If this button is disabled, try clicking in the window pane first.
The Import Project dialog opens.
5. If you are a member of more than one MadCap Central license, click in the My Licenses field
and choose the license where the project is located.
6. From the My Projects field, select the project you want to import.
7. Next to the Destination folder field, click
ted project to be stored on your computer.

and choose the folder where you want the impor-

8. Click OK.
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9. When the import is finished, you can click Open to launch the project in Flare. Otherwise, you
can click Cancel.

IMPORTANT: If you are using a Git/Central dual-binding, you can import projects from Git
(using the Import Project From Source Control Wizard) or from Central. The project will be
the same. However, if you import from Central, you will only be able to push changes to and
pull changes from Central. If you import from Git, you will be able to push changes to and
pull changes from Central as well as your main Git repository. This is because the project in
Central has no connection to the original Git repository, and if you import from Central you
will not have those source control bindings.

NOTE: If your project is already bound to a third-party source control provider other than Git
(i.e., you are working in a dual-bound model as opposed to a single-bound model), the
Import option in the MadCap Central window pane will be disabled. This is because you
should import your project directly from source control using your non-Central binding.
If you already have the project on your machine, you do not need to re-import the project
from source control. Instead, you can get the latest version from source control by using
the Flare Source Control ribbon (see the Flare online Help).
Be sure that you have the latest version of the project because when the project is initially
uploaded to Central, a Central ID is added to the project file. You must have the Central ID
in your local copy of the project file in order for Central to recognize that your copy of the
project is linked to the copy in Central.
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CHAPTER 5

Source Control and MadCap
Central
When you upload a Flare project to Central, the files are connected to Central via an integrated
source control system. Your interaction with source control can follow one of two models—singlebound or dual-bound.
This chapter discusses the following:
Single-bound Projects

24

Dual-bound Projects

27

Committing and Synchronizing (Pull, Push) in a Single-bound Model 49
Pushing in a Dual-bound Model
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Single-bound Projects
If your Flare project is not already bound to an additional third-party source control tool and you
upload the project to Central, you will have only one source control binding. Therefore, you can use
the source control connection between your local Flare project and Central as your primary source
control solution. With this model, you can use the Source Control ribbon in Flare to perform regular
source control tasks such as committing and synchronizing (i.e., pulling and pushing) files.
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HOW TO USE SINGLE-BINDING
1. Open the project in MadCap Flare.
2. Select View > MadCap Central. The MadCap Central window pane opens.
3. If you are not yet logged in, enter the same username (i.e., email) and password that you use
for logging into Central, and click Log In.
4. Upload (bind) your project to Central. See "Uploading (Binding) Projects" on page 14.
5. In Central, assign users to the new project and make sure they have “Import/Pull” and “Push”
permissions. This enables users to import the project using the MadCap Central window
pane. It also allows users to push content to the project. See the Central online Help.
6. Newly assigned users must now import the project from Central using the MadCap Central
window pane in Flare. This allows each user to work on the project locally. See "Importing Projects from Central" on page 20.
7. In Flare, make changes to your files. Then commit those files and synchronize them with the
cloned project on Central. See "Committing and Synchronizing (Pull, Push) in a Single-bound
Model" on page 49.
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Dual-bound Projects
If your Flare project is already bound to an additional third-party source control tool (e.g., Subversion, Team Foundation Server), you will be working in a dual-bound model. With this model, you
continue to use your previous source control binding to do most of your version control work just as
you always have. Then periodically, you will use the MadCap Central window pane in Flare to upload
(or “push”) the latest files from your local copy of the project up to Central. That way, you can be
assured that you are generating output from the most recent version of your Flare project.
With the dual-bound model, you do not use the Source Control ribbon in Flare to perform tasks
related to Central's internal source control connection with the files; instead, use the MadCap Central window pane in Flare. The Source Control ribbon would be used only for your other binding with
a third-party version control tool.
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NOTE: Just because you have a previous third-party binding to a project, this does not
mean you must keep working that way. In other words, you always have the option of
unbinding your Flare project from that third-party source control provider and then working
in a single-bound model instead. But if you desire to continue working with the other thirdparty tool, you can do so by using the dual-bound model.

NOTE: If you are using Git as your third-party source control tool, the dual-bound model
works slightly differently than it does if you are using another source control provider. In this
situation, you will still use the MadCap Central window pane and Source Control ribbon in
Flare to manage your changes. However, you are able to push and pull files from either Central or your Git repository. As a result, your Git repository and your Central repository might
be completely different, and you may encounter conflicts. In this situation, Flare's Conflict
Resolution dialog will open and you can accept or reject the changes. It is recommended
that you establish an internal workflow to dictate the order in which you push and pull from
each repository to prevent conflicts and ensure that your files in Central stay up-to-date.
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HOW TO USE DUAL-BINDING
1. Open the project in MadCap Flare, and make sure your project is already bound to a thirdparty source control provider. See the Flare online Help.
2. Select View > MadCap Central. The MadCap Central window pane opens.
3. If you are not yet logged in, enter the same username (i.e., email) and password that you use
for logging into Central, and click Log In.
4. Upload (bind) your project to Central. See "Uploading (Binding) Projects" on page 14.
Because you are dual-bound, Flare will prompt you to check out your Flare project file before
you can upload the project. This allows Central to add an ID to the project file when you
upload the project. This ID links the project to Central.
5. Check in the Flare project file to your third-party source control provider. This adds the Central
ID in the project file to your source control repository, making it available to other users. See
the Flare online Help.
6. In Central, assign users to the new project and make sure they have “Push” permissions. This
gives the users the ability to push content to the project. See the Central online Help.
7. Newly assigned users must now do one of the following, depending on whether or not they
already have a copy of the Flare project on their local machine:
n

Have a Local Copy Get the latest version of the Flare project file from the third-party
source control provider. See the Flare online Help.

n

Do Not Have a Local Copy Import the project from the third-party source control provider using the Import Project from Source Control Wizard. See the Flare online Help.
NOTE: If your project is already bound to a third-party source control provider
other than Git—i.e., you are working in a dual-bound model as opposed to a
single-bound model—the Import option in the MadCap Central window pane will
be disabled. You will have to import your project directly from source control
using your non-Central binding.
If you already have the project on your machine, you do not need to re-import
the project from source control. Instead, you can get the latest version from
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source control by using the Flare Source Control ribbon (see the Flare online
Help).
Be sure that you have the latest version of the project because when the project is initially uploaded to Central, a Central ID is added to the project file. You
must have the Central ID in your local copy of the project file in order for Central to recognize that your copy of the project is linked to the copy in Central.
Either option will give users the most current version of the project file, with the Central ID.
This links each user's local copy of the project to Central.
8. In Flare, make changes to your files. You should manage all of your file changes using your
third-party source control provider, using the following actions:
n

Check In Check in your changes to source control. See the Flare online Help.

n

Get Latest Get the latest version of your teammates' changes from source control and
add them to your local project. See the Flare online Help.

9. When you are done making changes, push your final changes to Central. To do this, click
in the MadCap Central window pane. See "Pushing in a Dual-bound Model" on page 53.
NOTE: It is possible for multiple people working on a dual-bound project to push files
to Central. However, if you are using a source-control provider other than Git, the
most recently pushed files are the ones that are used in Central. In other words, the
last person to push "wins." To avoid issues, be sure that everyone working on your project has the most recent version of the files before you push. You may even want to
limit users' permissions (see the Central online Help) so only one or two people are
allowed to push files.
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HOW TO USE DUAL-BINDING—GIT
1. Open the project in MadCap Flare.
2. Be sure your project is already bound to Git. See the Flare online Help.
3. Make sure all changes are committed before binding to Central. See the Flare online Help.
4. Select View > MadCap Central. The MadCap Central window pane opens.
5. If you are not yet logged in, enter the same username (i.e., email) and password that you use
for logging into Central, and click Log In.
6. Upload (bind) your project to Central. See "Uploading (Binding) Projects" on page 14.
When you bind the project, an ID is added to the project file. This ID links the project to Central.
7. Push the Flare project file to Git. This adds the Central ID in the project file to your Git repository, making it available to other users. See the Flare online Help.
8. In Central, assign users to the new project and make sure they have “Push” permissions. This
gives the users the ability to push content to the project. See the Central online Help.
9. Newly assigned users must now do one of the following, depending on whether or not they
already have a copy of the Flare project on their local machine:
n

Have a Local Copy Pull the latest version of the Flare project file from Git. See the Flare
online Help.

n

Do Not Have a Local Copy Import the project from Git using the Import Project from
Source Control Wizard. See the Flare online Help.
IMPORTANT: If you are using a Git/Central dual-binding, you can import projects from Git (using the Import Project From Source Control Wizard) or from
Central. The project will be the same. However, if you import from Central, you
will only be able to push changes to and pull changes from Central. If you
import from Git, you will be able to push changes to and pull changes from Central as well as your main Git repository. This is because the project in Central
has no connection to the original Git repository, and if you import from Central
you will not have those source control bindings.
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Either option will give users the most current version of the project file, with the Central ID.
This links each user's local copy of the project to Central.
10. In Flare, make changes to your files. When working in a Git/Central dual-bound situation, you
can make changes to both Central and Git, using the following actions:
n

Push Push your changes to source control. See the Flare online Help.

n

Pull Pull your teammates' changes from Git and add them to your local project. See the
Flare online Help.
NOTE: It does not matter which location (i.e., Git or Central) you push to or pull from
first, as long as you push the files to both Git and Central and that everyone on your
team uses the same workflow.

11. (Optional) If the changes in Git or Central become out-of-sync with each other (i.e., changes
are made in one location but not the other), the Resolve Conflicts dialog opens. If this happens, use the dialog to accept or reject other users' changes. See the Flare online Help.
12. When you are done making changes, push your final changes to Central. To do this, click
in the MadCap Central window pane. See "Pushing in a Dual-bound Model" on page 53.

IMPORTANT: There are several different workflows you can use when working with a
Git/Central dual-binding. The steps above are only one example of how you might perform
this process. Because of the potential for file conflicts, it is essential that you establish a
workflow for using a Git/Central dual-binding, and make sure that all your team members follow the same steps.
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EXAMPLE—TYPIC AL DU AL-BOU ND SITU ATION
Let's say you are working on a team of writers and your project is bound to Microsoft
Team Foundation Server (TFS). Therefore, that is your primary source control provider,
and the source control connection between Flare and Central serves as a secondary
source control provider.
When you first start working with Central, you have to upload (or bind) the project to
Central. To do this, click
in the MadCap Central window pane. Because the project
is bound to TFS, you will have to check out the project file before you can bind the project (Flare will prompt you to do this). Binding the project will establish the connection
between Flare and Central, and creates a copy of the project in Central.
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After you bind the project to Central, an ID is added to the Flare project file. You need to
check in the updated project file so other users on your team can access it. To do this,
click Check In All in the Flare Source Control ribbon.
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If any writers on the team do not already have a local copy of the project, they should
import the project from TFS so they can work on the project locally (they cannot import
from Central because the project's primary source control location is TFS). To import
the project, they will use the Import Project From Source Control Wizard. Importing the
project from TFS will ensure that they have the Central ID in their project, which links
their copy of the project to Central. This is the dual binding. For more information about
importing projects from source control, see the Flare online Help.
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Writers on your team who already have the project locally do not need to re-import.
They simply need to get the latest version of the project by clicking Get Latest All in the
Flare Source Control ribbon. This ensures that they have the Central ID in their project,
linking it to Central.

Now that everyone has the updated project file, you can all work on the project and
make changes using TFS. However, a user with permission also needs to add your
teammates to the project in Central so you can assign them project tasks, or if other
users on the team will be uploading files from Flare to Central (see the Central online
Help).
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As you work on files in Flare, you should check out your files using Flare's Check Out feature on the Flare Source Control ribbon (or using automatic checkouts, if you have this
enabled).

After you are finished making changes, you should check in your changes to TFS. You
can do this by clicking Check In All on the Flare Source Control ribbon. This will upload
your changes to TFS.

Once your changes are checked in, you should make sure that you have the latest version of your teammates' files, as well. To do this, click Get Latest Version All on the
Flare Source Control ribbon. This will download the latest changes of all of the files to
your local version of the project.
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When you and your teammates are finished making changes, you need to synchronize
your local copy of the project with the copy of the project in Central. To do this, click
in the MadCap Central window pane. This will push your local changes up to Central. It is important to remember that the last person who pushes their changes to Central wins, so be sure that everyone has the latest version of the project files before you
push (or even limit some users' permissions so they are not able to push; see the Central online Help) so you do not have out-of-date files in Central.

Once your files are up in Central, you can publish output and manage your project.
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EXAMPLE—GIT/C ENTRAL INTEGRATION
Let's say you are working on a team of writers and your project is bound to Git. Therefore, that is your primary source control provider, and the source control connection
between Flare and Central serves as a secondary source control provider.
When you first start working with Central, you have to upload (or bind) the project to
Central. To do this, click
in the MadCap Central window pane. Binding the project
will establish the connection between Flare and Central, and creates a copy of the project in Central.
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After you bind the project to Central, a Central ID is added to the Flare project file, and
you need to push the updated project file to Git so other users on your team can
access it. To do this, click Push in the Flare Source Control ribbon.

If any writers on the team do not already have a local copy of the project, they should
import the project from Git so they can work on the project locally. Importing the project will ensure that they have the Central ID in their project, which links their copy of
the project to Central. This is the dual binding. Importing from Git (rather than Central)
also ensures that each writer can also push changes to and pull changes from both Git
and Central. To import the project, they will use the Import Project From Source Control Wizard. For more information about importing projects from source control, see
the Flare online Help.
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Writers on your team who already have the project locally do not need to re-import.
They simply need to pull the project from Git by clicking Pull in the Flare Source Control
ribbon. This ensures that they have the Central ID in their project, linking it to Central.

Now that everyone has the updated project file, you can all work on the project and
make changes using Git. However, a user with permission also needs to add your teammates to the project in Central so you can assign them project tasks, or if other users
on the team will be uploading and pulling files from Flare to Central (see the Central
online Help).
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As you work on files in Flare, you can push your changes to and pull changes from
either Git or Central. You can push files by clicking
in the MadCap Central window
pane or by clicking Push in Flare's Source Control ribbon. You can pull files by clicking
Pull in Flare's Source Control ribbon. When using a Git/Central dual-binding, it does not
matter which location you push to or pull from first, as long as you push the files to both
Git and Central and that everyone on your team uses the same workflow.
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It is possible that the files in the main Git repository and the files in Central will become
out-of-sync if changes are made in one repository (i.e., Git or Central) and not made in
the other. If this happens, you will see the Resolve Conflicts dialog. You can use this dialog to accept or reject other users' changes.
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When you and your teammates are finished making changes, you need to synchronize
your local copy of the project with the copy of the project in Central. To do this, click
in the MadCap Central window pane or by clicking Push in Flare's Source Control ribbon, and make sure you are pushing to the MadCap Central remote. This will push your
local changes up to Central.

Once your files are up in Central, you can publish output and manage your project.

IMPORTANT: If your project is dual-bound to MadCap Central and a third-party source control provider, unbinding the project from source control will also remove the binding to Central.
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NOTE: If your project is dual-bound to Git and Central, you can create new branches in Flare
( see the Flare online Help). However, you can only push files from the Master branch to
Central. Single-bound projects do not support branches.

NOTE: If you switch branches in Flare and try to push changes to Central, but the branch
does not have a recognized Central ID associated with it, Flare will prompt you to reload
your project. You will need to copy your changes to the master branch and push your
changes again.

NOTE: If you are using a Git/Central dual-binding, and you encounter conflicts in one repository (i.e., Git or Central), you will likely encounter them in the other location as well. Conflicts in one repository will most likely need to be resolved in the other repository. See the
Flare online Help.
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Committing and Synchronizing (Pull, Push)
in a Single-bound Model
If you are working in a single-bound model (see "Single-bound Projects" on page 24), you author content in Flare. When you want to transfer your changes to Central, there are a couple of things you
must do:
n

Commit To commit a changed file is to record it to the repository. Essentially you are saying,
“I’m ready to transfer this content up to the cloned project on Central.” Committing files gives
you the opportunity to organize them into different groups when you add them to Central. You
can also add a unique comment to each commit.

EXAMPLE
Let’s say you’ve made changes to 23 files in your Flare project. Maybe 17 of the
files are related to Feature A that you are documenting and the other 6 are
related to Feature B.
Suppose your company policy is that you must add a comment each time you
upload changes and provide a summary of what you did. To keep the summary
for Feature A separate from Feature B, you decide to do two commits.
First, you use the Pending Changes window pane to select the 17 changed files
related to Feature A. Then you perform the commit and add a relevant comment.
After this, you select the 6 changed files related to Feature B and perform
another commit with a different comment.
n

Synchronize To synchronize means to pull any changes in the cloned Central project to your
local Flare project. These are changes that other writers have uploaded to Central from their
local projects. Then you push the committed files from your local project up to the project on
Central, where other writers can retrieve them.

For this activity, you must have the following permission settings in Central:

For more information about permissions, see the Central online Help.
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HOW TO COMMIT FILES IN A SINGLE-BOUND PROJECT
1. Open the project in MadCap Flare.
2. Do one of the following, depending on the part of the user interface you are using:
n

Pending Changes Window Pane From the Source Control ribbon, open the Pending
Changes window pane. Select the files in the window pane that you want to commit, and
in the local toolbar click

.

n

Ribbon Select the Source Control ribbon. In the File section select Commit (for selected
files). Alternatively, in the Project section you can click Commit All (for all files in the project).

n

Right-Click If you have the Content Explorer, Project Organizer, Pending Changes window
pane, or File List open, right-click the file you want to commit and select Source Control >
Commit (for selected files) or Source Control > Project > Commit All (for all files in the
project).

The Commit dialog opens. The selected files are listed with check boxes next to them.
3. (Optional) Enter an optional comment tied to the commit. This enables you to keep an audit
trail for a file. The comment can then be viewed from the History dialog, which can be
accessed from the Source Control Explorer, the Source Control ribbon, the File menu, or the
Source Control button

.

4. (Optional) If you want to see all files with pending changes (rather than only those you selected), click

.

5. Make sure to click the check box next to each file you want to commit so that it contains a
check mark.
6. Click Commit.
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HOW TO SYNCHRONIZE FILES IN A SINGLE-BOUND PROJECT
It is possible to use the Pull and Push options in the Flare interface individually to synchronize your
files, but it is more convenient to use the Synchronize option instead. Flare will first pull changes
from the project on Central. After that, it will push changed files from the local project up to Central.
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the Project section select Synchronize.

n

Right-Click If you have the Content Explorer, Project Organizer, Pending Changes window
pane, or File List open, right-click any file and select Source Control > Project > Synchronize.

2. (Optional) If you did not commit your files before starting the synchronize, a dialog asks if you
want to commit your files. Click Yes to continue. See "How to Commit Files in a Single-bound
Project" on the previous page.
NOTE: You must commit all modified files to proceed with the synchronize.
3. In the Select Remote for Synchronize dialog, click OK.
If no conflicts were discovered during the synchronization, you do not need to continue with
the following steps; you are finished.
If conflicts were found (i.e., a remote file is different from the version in your local repository),
the Resolve Conflicts dialog opens. Continue with the following steps.
4. Do one of the following:
n

If you want to accept all of the differences between the remote and local files, thus merging them, click Auto Merge All. If this step is a success, you do not need to continue
with these steps.

n

If you want to review the differences in the files side by side and resolve each conflict
(or if auto-merging is not possible due to conflicts occurring in the same paragraph),
click Resolve. The Resolve Version Conflict dialog opens.

5. From the Resolve Version Conflict dialog you can choose from the following options:
n

Merge changes in merge tool Opens a merging interface, which lets you see exactly what
changes were made and choose which to keep.
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n

Undo my local changes Automatically removes your changes and keeps changes from
other authors.

n

Discard external changes Automatically removes changes from other authors and keeps
your changes.

6. If you selected the option to use the merge tool, the Merge Changes dialog opens. Use this
dialog to view and select changes. You can take actions in the following ways.
n

Click a Change Use the key at the top of the dialog, as well as the color coding on the
local and server sides, to determine if a change has been added (new), deleted, changed,
moved, or is in conflict (difference occur in the same paragraph). For conflicts in the
same paragraph (i.e., areas where a diagonal line is shown), you can click the icon next to
either the local or server change and choose Keep Change. This will copy that change to
the text area at the bottom of the dialog.

n

Type Content If you want to use your changes as well as those from another author, and
even tweak the paragraph a bit more, you can click in the area at the bottom of the dialog
and simply type content.

n

Previous/Next Conflict When you are finished resolving the first conflict, you can use the
"Previous Conflict" and "Next Conflict" buttons at the bottom of the dialog to work on
other conflicts in the file.
NOTE: If you selected "Merge as Text" in the local toolbar and are working in the
code, you can click on text with a hatched background to keep the change in it. After
you click on text with a hatched background, the hatched lines are removed, leaving a
solid color.

7. After all conflicts have been resolved, click OK. A message lets you know that a backup of the
file has been created in case you need to roll back to it. Click OK.
8. Click OK in any remaining dialogs.
9. Because you encountered conflicts, your changes were not pushed up to Central. Therefore,
click the Synchronize option again to complete the process.
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Pushing in a Dual-bound Model
If you are working in a dual-bound model (see "Dual-bound Projects" on page 27), you will author your
content in Flare and then use your third-party source control tool to synchronize your files with
those from other writers. After this, you can use Flare to push those changes to Central.
For this activity, you must have the following permission setting in Central:

For more information about permissions, see the Central online Help.

HOW TO PUSH FILES IN A DUAL-BOUND PROJECT
1. Open the project in MadCap Flare.
2. Get the latest version of the files from your third-party source control provider. For more
information, see the Flare online Help.
3. Select View > MadCap Central. The MadCap Central window pane opens.
4. If you are not yet logged in, enter the same username (i.e., email) and password that you use
for logging into Central, and click Log In.
5. In the local toolbar of the MadCap Central window pane, click

.

A progress dialog shows you the status of the push. If the changes are pushed successfully, a
confirmation will appear.

NOTE: It is possible for multiple people working on a dual-bound project to push files to Central. However, if you are using a source-control provider other than Git, the most recently
pushed files are the ones that are used in Central. In other words, the last person to push
"wins." To avoid issues, be sure that everyone working on your project has the most recent
version of the files before you push. You may even want to limit users' permissions (see the
Central online Help) so only one or two people are allowed to push files.
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NOTE: When you are dual-bound using Git/Central (see "Dual-bound Projects" on page 27),
you can push to both Central and Git. It is possible that the files in the main Git repository
and the files in Central will become out-of-sync if changes are made in one repository (i.e.,
Git or Central) and not made in the other. If this happens, you will see the Flare Conflict Resolution dialog. You can use this dialog to accept or reject other users' changes. For more
information about merging source control files and conflict resolution, see the Flare online
Help.
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CHAPTER 6

Viewing Project Properties
If you have access to a project in Central (i.e., you have been added to the project), you can view its
properties in the MadCap Central window pane. This lets you see relevant information about the project, such as when it was added to Central, the number of files in the project, and build information.

HOW TO VIEW PROJECT PROPERTIES IN FLARE
1. Open the project in MadCap Flare.
2. Open the MadCap Central window pane (View > MadCap Central).
3. If you are not already logged in to Central, log in to your account.
Once you are logged in, the project's properties appear in the MadCap Central window pane.
You can view the following properties:
n

License The name of the license where the project was uploaded.

n

Name The name of the project.

n

Description The project description (if applicable).

n

Created On The date the project was added to Central.

n

Last Modified The last time you pushed changes to the project to Central.

n

Source Project Storage Usage The total size of the project’s source files.

n

Total Project Storage Usage The total size of the project’s files (source plus output).

n

Total Targets The number of targets in the project.

n

Total Live Builds The number of builds for this project that are currently set to “Live” in
Central.
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n

Total Builds The number of builds for this project.

n

Builds Storage Usage The amount of storage in Central used by builds.
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CHAPTER 7

Central Review Process
The Central review process lets you send Flare topics and snippets to be reviewed by subject matter experts (SMEs) or other Flare authors on MadCap Central. After making edits and adding annotations (comments) to the files in a lightweight editor on Central, the reviewers submit the finished
files, sending them back to your inbox in Flare. You can then accept or reject their changes and
accept the file, replacing the original source file.
This chapter discusses the following:
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Sending Files for Review on Central
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Closing Central Review Files
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Accepting or Rejecting Tracked Changes (Central Reviews)
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Accepting Reviewed Files
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Benefits
Benefits of this review workflow include:
n

Cloud Review SMEs do not need to download and install any software. The review takes place
in the cloud.

n

Multi-User Editing Multiple SMEs and authors can make changes and add comments to the
same topic or snippet at the same time.

n

Review-Only Interface A lightweight version of the editor means a streamlined interface. You
will only see options and features that are relevant to the review process.

n

Auto-Save and Tracking Changes in the editor are auto-saved as you work. In addition, all
changes are automatically tracked so that the original author can easily locate edits for
approval or rejection.
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Workflow
Following is how the Flare-Central review process works between the original Flare author and
reviewers. In this workflow, reviewers can be SMEs or other Flare authors.
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1. Original Author—Invite Reviewer to Central License Before you can take advantage of the
review process between Flare and Central, you need to invite SMEs or Flare authors to the
license (if they are not already Central users). See the Central online Help.
2. Reviewer—Set Password When you invite someone to join your Central license, he or she
receives an email. From there, the individual can click a link to set a password in Central.
3. Original Author—Select File(s), Choose Reviewer(s), and Send In Flare, the original author uses
the MadCap Central window pane to log into Central. Then he or she opens the Send Files for
Review Wizard and populates it with topics and/or snippets that need to be reviewed by others. Also, the option Send to MadCap Central must be selected.
On the next page of the wizard, the author chooses reviewers in the Central license. This
might include SMEs, as well as other Flare authors. Anyone selected during this process will
automatically become associated with that Flare project on Central. Also, anyone selected
will become an assigned reviewer for all files chosen in the wizard.
See "Sending Files for Review on Central" on page 62.
4. Reviewer—Open Pending File and Edit/Annotate Anyone involved in the review process for the
selected files (i.e., authors and SMEs) can open the Reviews page in Central to work with
those files.
After opening a topic or snippet, you can edit it or insert annotations as necessary. All
changes are tracked and auto-saved as you work. In addition, other SMEs and authors can
edit a file at the same time, so you will see their changes as well in real time. For details of the
editor interface, see the Central online Help.
5. Reviewer—Submit File A reviewer can return to a file in the Pending pane repeatedly over time
to make changes to it. When the reviewer is finished working on a file and does not need to
make any further edits, he or she clicks the Submit button on the Reviews page. See the Central online Help.
This moves the file to your Submitted pane. If necessary, you can view the file from there and
edit it more. However, once the author closes the review process for the file, it can no longer
be edited in Central.
After all of the reviewers submit the file, the original author receives an email notification (if
the author has enabled those notifications in Central) and the file appears in the “Inbox” view
of the File Reviews window pane in Flare.
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6. Author—Close Review File After all reviewers submit a file in Central, the author can close out
the review process for that file in Flare’s File Reviews window pane. This can be done by
attempting to open the file, in which case you are prompted to close out the review process.
Alternatively, you can select the file (as well as several others) in the File Reviews grid and
click

. See "Closing Central Review Files" on page 68.

After this, the status for the file is changed to “Closed” in the File Reviews window pane. Also,
the file can no longer be edited by anyone in Central, and the file is moved to the Archive pane.
7. Author—Accept/Reject Changes After closing the review process on Central for a file, the
author can open the reviewed file in Flare. Changes can be accepted or rejected as necessary. See "Accepting or Rejecting Tracked Changes (Central Reviews)" on page 72.
8. Author—Accept File When the author is finished accepting or rejecting the changes, he or she
accepts the file back into the Flare project, replacing the old file. This can be done by clicking
in the File Reviews window pane or in the local toolbar. See "Accepting Reviewed Files" on
page 75.
The file is then removed from the Flare inbox.
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Sending Files for Review on Central
Following are steps for sending files to others for review in Central.

HOW TO SEND FILES FOR REVIEW ON CENTRAL
1. If you have not already done so, open the MadCap Central window pane (View > MadCap Central) and log in to Central. See "Logging In and Out" on page 13.
2. Open a topic or snippet.
3. Select the Review ribbon.
4. In the Packages section select Send For Review. The Send Files For Review Wizard opens.
5. (Optional) If you want to add more files to the package file, do the following:
a. Click

.

b. Use the multi-view buttons to find the file(s) you want to add. If you want to add multiple
files, make sure

is selected.

Shows or hides the folders that the files are stored in.
Shows or hides the files. If you click this button when the Show Folders button
is selected, the area splits into two halves. The folder is shown on the left
side, and the files and subfolders within it are shown on the right.
Shows or hides hidden files and folders.
If the Show Files button
is the only one selected, you can click this button
to move up one folder level.
c. Find and select the file(s) you want to add to the review. You can hold the SHIFT key to
select a range, or you can hold the CTRL key to select individual items. When you are finished click Open in the dialog.
TIP: All snippets that are part of a topic will initially be included in the review.
However, in the Files grid you can remove any snippets to exclude them from the
review. You might choose to exclude some (or all) snippets from the review if you
think it will be too confusing and too many files for your reviewers. If you exclude
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snippets, they will still be visible in the topic in Central, but the snippets will be readonly. Therefore, reviewers won’t be able to make edits in the snippets, but in the topic
they can insert annotations (comments) around the snippets in order to provide feedback.
6. Below the Files grid, select Send to MadCap Central.

7. Click Next.
NOTE: If necessary, Flare will also prompt you to commit and synchronize any
changes in your project with Central before you can proceed to the next page of the
wizard.
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8. On the next page of the wizard, select the users on your Central license who you want to
review the file(s). This might include SMEs (individuals who have reviewer-only permission in
Central), as well as other Flare authors. Anyone selected during this process will automatically
become associated with that Flare project on Central. Also, anyone selected will become an
assigned reviewer for all files chosen in the wizard.
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9. Click Send.
After completing the wizard, the files are uploaded and reviewers receive an email notification
with a link to open the Reviews page in Central. (SMEs automatically receive email notifications; however, Flare authors must have the review notifications and email option enabled
in Central to receive emails.) If you are the original author, the files will be listed in your Sent
pane. If you are a reviewer, the files will be listed in your Pending pane. Also, you can use a filter above the panes to view files for all projects, or just for a specific project.

CHAPTER 7

65

CHAPTER 7

66

In addition, the files appear in the “Sent Files” area of File Reviews window pane in Flare. This
means the files are in an “Open” state, pending review. Because this window pane can be used
for reviews in both MadCap Central and Contributor, an icon is used to indicate which system
is being used for a particular file.

NOTE: If you attempt to edit a file that has been sent out for review and is still in an “Open”
state, you will see a warning. You can continue to edit the file, but you may have conflicts
with the version of the file being reviewed. As an alternative to editing the file in Flare, you
can edit it in Central along with your reviewers until it is finished.
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Closing Central Review Files
After all reviewers submit a file in Central, the author can close out the review process for that file in
Flare’s File Reviews window pane.

HOW TO CLOSE THE REVIEW PROCESS FOR FILES
1. Select the Review ribbon.
2. In the Packages section select File Reviews. The File Reviews window pane opens. The files
that need to be closed have a status of “Submitted.”
3. Click in the drop-down field at the top of the window pane, select Inbox. The pane lists all
reviewed files that have not yet been accepted.
NOTE: Technically, you can also select Sent Files in the drop-down and close files
from there. However, these are files that reviewers have not yet finished in Central.
So if you close the review process for these files, they can no longer be edited on Central. You might close the review process for a file from the Sent Files view, for
example, if a particular reviewer leaves the company and is unable to finish editing
the file on Central.
4. (Optional) By default, the Central Field field in the local toolbar is set to My, which means you
will see only files for which you have initiated the review process. You can change the setting
to All if you need to see files initiated by other authors in the Flare project. This option is useful
if the original author is unavailable to close out the review process.
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5. Do one of the following:

CLOSE REVIEW PROCESS FOR A SINGLE FILE
a. Either double-click a file or select the file in the grid and click

in the local toolbar.

b. In the message that displays, click OK.

If you double-clicked the file, it opens to the right.
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CLOSE REVIEW PROCESS FOR A MULTIPLE FILES
a. In the grid, select the files. You can hold the SHIFT key to select a range, or you can hold
the CTRL key to select individual items.
b. In the local toolbar, cclick

.

c. In the message that displays, click OK.
After this, the status for the file is changed to “Closed” in the File Reviews window pane. Also,
the file can no longer be edited by anyone in Central, and the file is moved to the Archive pane.
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Accepting or Rejecting Tracked Changes
(Central Reviews)
After closing the review process on Central for a file, the author can open the reviewed file in Flare.
Changes can be accepted or rejected as necessary.
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HOW TO ACCEPT OR REJECT TRACKED CHANGES
1. From the File Reviews window pane, open the topic or snippet.
2. Make sure you have changes set to be displayed.
3. You can perform any of the following tasks.

ACCEPT ALL CHANGES IN THE FILE
n

Select the Review ribbon. In the Changes section select Accept Change > Accept All
Changes.

ACCEPT SINGLE CHANGE
Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Click on the change you want to accept. Select the Review ribbon. In the
Changes section select Accept Change.

n

Right-Click Right-click on the change you want to accept. From the context menu,
select Accept [Type of Change].

REJECT ALL CHANGES IN THE FILE
n

Select the Review ribbon. In the Changes section select Reject Change > Reject All
Changes.

REJECT SINGLE CHANGE
Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Click on the change you want to reject. Select the Review ribbon. In the
Changes section select Reject Change.

n

Right-Click Right-click on the change you want to reject. From the context menu, select
Reject [Type of Change].

4. Click

to save your work.

NOTE: After reviewing annotations in a file, you can delete them if they are no longer
needed.
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NOTE: When you track changes, every change to the document—along with the user who
performed the change—will be stored in the document’s markup. When a change is accepted or rejected, all markup designating it as a change is removed. When all changes in the
document are resolved, they will not contain any history of changes made and can be considered ready for output.

NOTE: By default, tracked changes are visible only in the editor in MadCap Flare, as well as
in Central or Contributor (depending on the review method you are using). Tracked changes
that have not yet been accepted are not visible when previewing the topic in Flare or when
viewing any output generated from it. You can preserve tracked changes in PDF and Word
output so unaccepted changes will appear in these outputs.
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Accepting Reviewed Files
After an individual returns files that you have sent for review, you can bring those files into your Flare
project. Once the reviewed files (i.e., topics and snippets) are inside your Flare project, you can
close out the review process (if using the Central review process), then view and accept the files.
After accepting a file, it overwrites the original source file in your project. Any edits or annotations
(comments) in the reviewed file therefore become part of the source file.

HOW TO ACCEPT REVIEWED FILES
1. Select the Review ribbon. In the Packages section select File Reviews. The File Reviews window pane opens.
2. Click in the drop-down field at the top of the window pane, select Inbox. All reviewed files that
you have brought into your project, but have not yet been accepted, are listed in the pane.
In the case of Central review files, the status should be “Closed.” If it is not, close out the
review process for the files before continuing.
Also, regardless of the process you use (Central or review packages), make sure you have
accepted or rejected the changes as necessary in the files.
3. In the grid, select the file(s) that you want to accept. You can hold the SHIFT key to select a
range, or you can hold the CTRL key to select individual items.
. A message opens (if there are unresolved changes), indicating
4. In the local toolbar, click
that the unresolved changes will be accepted if the file is accepted. However, if a conflict
exists (e.g., the original file in your project changed since the time you sent it out for review), a
dialog opens to let you know of the issue. You can then take the appropriate action; you can
merge the changes from the files, keep the edits from the reviewer (undoing your changes),
or keep your edits (discarding those from the reviewer).

CHAPTER 7

75

5. Click OK. The reviewed file replaces the source file in the project.
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Also, the file is removed from the File Reviews window pane.
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CHAPTER 8

Removing Bindings
If you no longer need your project to be bound to Central, you can remove its binding. Removing the
binding from a project does not remove that project from Central; instead, it simply removes the link
between Central and your local project. The project will still be available locally, but you will no
longer be able to upload (push) changes from your local project to the cloned project on Central.
For this activity, you must have the following permission setting in Central:

For more information about permissions, see the Central online Help.
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HOW TO REMOVE A BINDING FROM A PROJECT IN CENTRAL
1. Open the project in MadCap Flare.
2. Select View > MadCap Central. The MadCap Central window pane opens.
3. If you are not yet logged in, enter the same username (i.e., email) and password that you use
for logging into Central, and click Log In.
4. Click

.

5. In the confirmation window, click OK.
to open the Project page. The unbound pro6. (Optional) In MadCap Central, you can click
ject is still shown in the grid. However, you can archive it or delete it if you no longer need it. If
you do not archive it or delete it, it will remain in the project list, but you will not be able to push
changes to it. For more information about archiving and deleting projects, see the Central
online Help.

IMPORTANT: You can also remove a project's bindings to Central from the Project Properties dialog (Project > Project Properties). However, doing this will also remove any thirdparty source control bindings to the project.
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CHAPTER 9

Flare Features Not Supported in
MadCap Central
There are certain features in Flare that are not supported when you generate targets from MadCap
Central. These include the following:
This chapter discusses the following:
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Automatically Get Latest Files
If you are working in a dual-bound scenario (see "Dual-bound Projects" on page 27) and you select
the option in the target to automatically get the latest version of files before generating, this option
will not work when you build from MadCap Central. Instead, you must first synchronize your files
with source control in Flare and then push those changes to Central.

Custom Build Log Folder
In the Options dialog, Flare has a feature that lets you choose a custom folder to hold the log file
after generating output. This feature is not supported when building from MadCap Central. Instead,
the log file is stored at the root level of the output folder.

Custom Fonts
If you are using custom fonts in your Flare project, they are not supported when you build output
from MadCap Central.

Custom Output Folder
Flare targets let you choose a custom location for your output folder. However, this is not supported
when building from MadCap Central. You must use the default location.

Date/Time Variables
Target generation occurs on a server with Central, so date/time variables are not supported.
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Global Ignored Warnings
You can tell Flare to ignore certain warnings so that they do not display as such in the Builds window
pane when generating output. This can be done globally for all targets in all projects. You can also
override those global settings for a specific target in a project. However, if you generate output from
Central, global settings to ignore warnings are not supported; instead, you must ignore warnings in
the target.

Linked Mimic Movies and Projects
When building from MadCap Central, external links to Mimic movies/projects will not work.
However, embedded movies in a Flare project are supported.

Pre- and Post-Build Events
If you create pre- or post-build events in your Flare target, they will not function when building from
MadCap Central.

Publishing to Outside Servers
Flare lets you create destination files for the purpose of publishing to external servers. This feature
is not supported when building from MadCap Central. Instead, live builds are always published in
Central.

Some Output Formats (Building)
The following types of output cannot be generated from MadCap Central:
l

Batch targets

l

Adobe FrameMaker
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Some Output Formats (Viewing)
The following types of output can be generated from MadCap Central, but they cannot be viewed
(output files are downloaded to your computer):
l

DITA

l

DotNet Help

l

Eclipse Help

l

EPUB

l

Microsoft HTML Help
NOTE: Due to issues with Microsoft HTML Help, the CHM file that is downloaded will initially be blocked. To unblock the CHM file, remove it from the ZIP file. Then right-click
the CHM file and select Properties. On the General tab in the dialog, select Unblock.

l

Server-based Outputs:
o

HTML5 Plus

o

WebHelp Plus
NOTE: If you want to produce server-based output from MadCap Central, you will need
to download the output from Central after it finishes building. You can then publish the
output to your server.

l

Microsoft Word

l

XHTML Book
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CHAPTER 10

Security and MadCap Central
MadCap Central leverages the security, power, and flexibility of the cloud to mitigate or eliminate
many of the technical hurdles faced by both content creators and information technology professionals. The overhead traditionally associated with managing complex systems can hinder the
ability to create content and deliver content efficiently. The goal of this document is to provide a
high-level overview of the ways that Central addresses these challenges.
Security and privacy are top priorities at MadCap Software, especially when providing customers
with a cloud-based system in Central. We are committed to keeping your files, data, and communications secure. Therefore, in choosing Microsoft® Azure as a partner, we focused on selecting
a security center that understands the importance of privacy and complies with the highest international and industry-specific compliance standards and uptime guarantees. Microsoft Azure regularly undergoes rigorous third-party audits to ensure and verify the highest level of security
controls.
For more information, see the following:
https://www.microsoft.com/en-us/TrustCenter/Security/default.aspx
This chapter discusses the following:
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Data Centers and Disaster Recovery
The infrastructure for MadCap Central is hosted by Microsoft Azure, leveraging secured data centers worldwide. These Azure data centers are ISO27001 certified. For details, see https://www.microsoft.com/en-us/cloud-platform/global-datacenters.
The primary data center is located in Sacramento, California. A secondary read-only data center is
located in Chicago, Illinois. Additional failover web servers located around the world are also available. In the event of a data center outage, MadCap Software engineers can restore your data when
needed, with no interaction needed from the customer.
In addition to data stored in the database, the source control provider (Git) has the ability to failover
in case of an outage. This is essential in handling mission critical data in the event of a catastrophe.

CHAPTER 10

85

Source Control Provider and Data Storage
MadCap Flare projects can be uploaded to Central, thus creating copies of those projects on the
cloud. From the cloud versions of your projects, output files can be generated and published. In addition to Flare source and output files, Central hosts many other types of data, including user and
team information, task details, communications between individuals, and ancillary file attachments.
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When Flare projects are uploaded to a Central license, they are bound by a Git source control connection.
The following objectives are important for this relationship:
n

Easy Access Projects are hosted in the cloud, which means they can be accessed from anywhere.

n

Security Projects are stored securely in the cloud. Communication between your local
desktop and the cloud is over HTTPS (HTTP over SSL). This is an encrypted, secure channel
of communication. Source control data is secured by username and security token.

n

Data Transference Users can synchronize the local and cloud versions of Flare projects after
changes are made to files. In addition, you can retrieve files to a local machine whenever
necessary. Uploaded projects can be imported and generated output files can be downloaded
from Central.
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n

Storage MadCap Central stores user data in different ways depending on the nature of the
data. Some examples of data storage include encrypted SQL databases, source control repositories (GIT), and Azure blob storage.
l

l

l

n

Sensitive data—such as user credentials and company information in the database tier—
are stored using encryption to mitigate unauthorized access to data, and ensure your
information is stored securely.
The methods of storing data follow industry security standards and offer a highly scalable
solution to ever expanding storage management tracking needs.
If you choose to cancel your subscription, hosted data can be wiped at your discretion.

Backups All data is backed up daily. All user data in Central database backups are encrypted,
transmitted remotely, and stored securely. This helps prevent unauthorized access.
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Web Server Hosting and Management
Every MadCap Central subscription includes access to our highly scalable cloud-based build server.
Because MadCap Central is a cloud-based solution, content creators can rapidly generate and publish their content with minimal effort while benefiting from a high level of security, scalability, and
durability, something that would otherwise require skilled IT resources to implement. Published output is hosted on a robust, secure, geographically redundant web application server.
With that in mind, the following are important considerations:
n

Reduced Hosting Costs You can host all of your projects within Central and never worry about
managing or scaling costly web servers. Whether you have a small, single project or several
large projects, you can host and manage all of your content in one place.

n

Automation and Convenience From Central, you generate and publish output with minimal
effort. You also have the ability to quickly roll back published outputs when necessary, with
the click of a button. Builds can be initiated manually or they can be scheduled. All of this can
be done from any device supporting the browser-based interface.

n

Availability and Monitoring Your content is vital to your company, so 24-hour availability of the
web server is crucial, as is constant uptime monitoring. All components of MadCap Central
are monitored 24 hours a day, 7 days a week, 365 days a year using remote monitoring systems. MadCap Software has staff on hand to respond to outages and security breaches.

n

Security Management Data in MadCap Central is secured in the following ways:
l

l

l

l

l

Web services have built-in load balancers to stave off most DOS (Denial-Of-Service)
attacks.
We provide unauthorized access monitoring and incident response. Any breaches in data
security will be reported to affected customers.
User portal and API endpoints (i.e., the connection between Flare and Central) are
secured via user authentication.
All data endpoints are secured using SSL. The user portal, API endpoints, source control
provider (Git), and all backend system communications are all encrypted.
Published builds that are not set to “Live” are secured by user authentication.
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n

Scalability As your content management needs grow, so will your demands for a system that
dynamically scales as well. Over time, the builds that you generate on Central will consume
more and more space. Central offers ease with scalability for your output, which helps to eliminate worries about CPU, memory, and disk-intensive projects.
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Service Level Agreement
The Service Level Agreement (SLA) for hosted output on MadCap Central is 99.97%. This monthly
uptime percentage applies to the total guaranteed availability of your output and the systems (storage and web applications) used to host it. This SLA is guaranteed through Microsoft Azure.
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Application and Browser
Much of the work in MadCap Central (e.g., management of users, teams, tasks, projects, and builds)
requires user interactions to be performed through a browser. In addition to Flare requiring end-toend encryption, all traffic from your web browser to the MadCap Central portal is also secured using
industry standard security practices such as SSL.
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Following are some of the notable features in Central that contribute to a secure, accessible work
experience:
n

Permissions In Central, permissions allow you to dictate which users can see certain information and perform a variety of functions. In addition to basic permissions, there are several
administrator-level rights that can be set, giving you the most flexibility to control how your
data and files are being managed and distributed.

n

Importing Projects If another user uploads a Flare project to your MadCap Central license and
you do not yet have that project on your computer, you can import it. You can do this from the
MadCap Central window pane in Flare.
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n

Downloading Builds

n

Purchasing Seats and Space Built-in widgets inform you when space or user count becomes a
concern.

n

Single-bound and Dual-bound Projects When you upload a Flare project to Central, the files
are connected to Central via an integrated source control system. Your interaction with
source control can follow one of two models—single-bound or dual-bound. Single-bound projects are not bound to an additional third-party source control provider; they only use Central's
source control system. Dual-bound projects, on the other hand, are already bound to another
source control provider, and therefore are bound to both the original third-party source control
provider and to Central.
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APPENDIX

PDFs
The following PDFs are available for download from the online Help.
TUTORIALS

Getting Started Tutorial
Product Foldout Tutorial
Side Navigation Tutorial
Top Navigation Tutorial
Tripane and PDF Tutorial
USER GUIDES

Accessibility Guide

Getting Started Guide

Analysis and Reports Guide

Global Project Linking Guide

Architecture Guide

HTML Help Guide

Autonumbers Guide

HTML5 Guide

Condition Tags Guide

Images Guide

Context-sensitive Help Guide

Importing Guide

DotNet Help Guide

Index Guide

Eclipse Help Guide

Key Features Guide
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Language Support Guide

Source Control Guide: Git

MadCap Central Integration Guide

Source Control Guide: Perforce

Movies Guide

Source Control Guide: Subversion

Navigation Links Guide

Source Control Guide: Team Foundation Server

Plug-In API Guide

Styles Guide

Print-based Output Guide

Tables Guide

Project Creation Guide

Tables of Contents Guide

Pulse Guide

Targets Guide

QR Codes Guide

Templates Guide

Reports Guide

Topics Guide

Reviews & Contributions Guide

Touring the Workspace Guide

Search Guide

Transition From FrameMaker Guide

SharePoint Guide

Variables Guide

Skins Guide

WebHelp Outputs Guide

Snippets Guide

What's New Guide

CHEAT SHEETS

Folders and Files Cheat Sheet
Print Output Cheat Sheet
Shortcuts Cheat Sheet
Structure Bars Cheat Sheet
Styles Cheat Sheet
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