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CHAPTER 1

Introduction
Source control is a process where you store a copy of your project on a server, allowing you to
“check in” and “check out” files and keep your local changes in sync with the server version for the
project, and with changes from other writers. Source control is even useful for single authors
because it provides a means for maintaining a constant backup of all project files.
Flare includes support for every source control tool on the market by virtue of the fact that Flare
uses a wide open architecture. Instead of using proprietary files and databases, all content and project files in Flare are stored as independent XML files. This means that Flare projects are compatible with all source control systems. In addition to this native support for all source control
applications, Flare provides integrated support for several source control applications as well.
This chapter discusses the following:
Is the Source Control Application Inside Flare?

7

Which Source Control Programs are Integrated with Flare?

7

Who is Involved with Source Control?

7

Which Files Can Be Included?

8

MadCap Central and Source Control
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6

Is the Source Control Application Inside
Flare?
No. Flare does not use a proprietary source control system within the application. Instead, Flare
allows you to connect (or "bind") your project to an existing third-party source control application
that is separate from Flare.

Which Source Control Programs are
Integrated with Flare?
Built-in support is available for Microsoft Visual SourceSafe, Microsoft Team Foundation Server, Perforce, Git, and Apache Subversion. In addition, an API allows you to configure your project for integration with other source control tools . You also have the option of manually adding your project files
to any source control tool, rather than using Flare's built-in integration.

Who is Involved with Source Control?
This depends on how you work in your company. Someone (perhaps a network administrator) needs
to set up your source control program (such as Microsoft Visual SourceSafe) and create the necessary database(s) in it. This individual may also set up the "rights" to all persons who have access to
the necessary databases and files. If you are working on a multi-author team, each writer on the
team needs to have a local copy of the Flare project and will be responsible for checking in and
checking out files as necessary.
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Which Files Can Be Included?
The files that can be included in source control depends on whether you are adding them manually
or using the built-in integration.

If Including Files Manually in Your Source Control Client
If you are manually adding files to a source control application (rather than using the built-in Flare
integration), you can transfer any appropriate files in a Flare project. Appropriate files include the following.
n

The main FLPRJ file

n

All files from the Content folder

n

All files from the Project folder, except those in the Project/Users subfolder

n

Files from a specific Output subfolder
You might transfer output files to source control, for example, if you are integrating your Help
into a desktop application, and programmers need access to your output files to build the
application. However, if you do this, make sure you map the source control to the appropriate
output subfolder, and not to the Temporary subfolder or to the main Output folder, which contains the Temporary subfolder.
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If Using the Source Control Integration in the Flare
Interface
If you are using Flare's built-in source control integration, you can transfer the following types of
files.
n

The main FLPRJ file

n

All files from the Content folder

n

All files from the Project folder, except those in the Project/Users subfolder

n

Files from a specific Output subfolder, if using source control publishing

In most workflows, you only need to transfer the content and project files mentioned, and when you
are ready to generate output, you would publish the output files to another location where users can
access them (such as a website or network drive). However, if you want to use Flare to directly publish your output to source control so you can keep a copy of your finished output for future reference, you can also create a source control publishing destination.
NOTE: Microsoft Visual SourceSafe (VSS) does not support source control publishing.
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MadCap Central and Source Control
MadCap Central is a cloud-based platform that lets you plan, track, and manage the processes, content, and teams that are at the heart of your organization. Although MadCap Central is located in
the cloud, it is integrated with MadCap Flare. This integration lets you store copies of your projects
in Central, continue to work on them locally in Flare, and keep both sets of copies in sync. You can
use Central to quickly build and publish output (and roll back when necessary) without the need to
involve an IT department. You can also send topics and snippets for review on Central, as well as
use custom checklists to track your progress in Flare projects. The MadCap Central window pane in
Flare lets you upload (bind) and import projects, as well as push project changes to Central. Additionally, you can see project properties, log in and out of your Central account, and launch the Central portal in your browser.
When you upload a Flare project to Central, the files are connected to Central via an integrated
source control system. Your interaction with source control can follow one of two models—singlebound or dual-bound. For more information see the online Help.
NOTE: MadCap Central is sold separately from Flare. Please contact MadCap Software
Sales for more information.
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CHAPTER 2

About Git
Because Flare uses an open architecture, Flare projects are compatible with all source control systems. In addition to this native support for all source control applications, Flare provides integrated
support with some source control applications.
Please reference the source control topics in this section if you are using Flare's integrated source
control with Git.
You can use the Flare interface to perform various tasks for a project that is bound to Git. Alternatively, you can use a third-party solution, such as GitHub, GitLab, or CloudForge.
This chapter discusses the following:
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Common Source Control Terms

12

Source Control Icons

13

General Workflow (Multi-AuthorTeam)

14

General Workflow (Single Author)

16

Additional Source Control Tasks and Features

18

11

Common Source Control Terms
Following are definitions for some of the common phrases used in Flare's integrated source control
with Git.
n

Bind This means to connect your project to Git. After doing this, you can then take advantage
of all the automated source control tasks (such as commit, revert, pull, push, and so on).

n

Commit This means to record your Flare files to the local Git repository.

n

Revert This means to undo changes you have made to a Flare branch or file. Changes are
reverted to the way they were at the last commit.

n

Synchronize This pulls the files from the remote Git repository and merges them with your
local database, then pushes your local changes back to the remote Git repository.

n

Pull This retrieves commits from the remote Git repository and merges them with the files in
your local database.

n

Push This sends commits from your local database to the remote Git repository.

n

Branch This creates a new path for commits. This lets you create new versions of a file while
keeping the original file unchanged (e.g., for documenting a new feature, testing page layouts,
or rewriting existing information). You can create as many branches as you want.

NOTE: Flare integrates with multiple source control providers to provide built-in source control support. Each of the source control providers built-in to Flare uses different terms. As
such, Flare's source control interface is different depending on which source control provider you use. Please refer to the sections for each source control provider if you need to
see information about the terms used by other built-in systems.
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Source Control Icons
Following are descriptions for the primary icons that you may see next to files when using Git.
Modified
This indicates that the file has been modified. You can commit the file to your local Git
repository when you are ready.
New File (Pending Add)
This indicates that you have a file in your project but have not yet added it to Git. This might
occur, for example, if you create a new topic and do not add the file to source control during the topic creation process. To resolve this, simply right-click on the file and select
Source Control > Add.
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General Workflow (Multi-AuthorTeam)
Following are the basic steps for using Flare's source control integration for a multi-author team.
1. Set Up Git Install Git and set up the local database and any folders where you want to place
the project. You should also set up your remote repository. Also, assign permissions to the
proper individuals. This task may be performed by someone else, such as a network administrator.
2. In Flare, do one of the following, depending on whether you are creating a new Flare project or
using an existing one.
n

Create and Bind New Project Create a new Flare project and simultaneously bind it to an
integrated source control application.
OR

n

Bind Existing Project If you have an existing Flare project on your local machine, bind the
project to Git.
NOTE: Only one person needs to perform this task. Others on the team can import
the project.

3. Import Project Other users on the team can easily import the project from the remote repository. This creates a copy of the Flare project on the user's computer. See "Importing from Git"
on page 29.
4. Pull Files If you need to update the files in your local database, you can pull the most current
files from the remote repository. You will see the Resolve Version Conflict dialog if conflicts
exist.
5. Modify Files When you use Git, there is no need to "check out" a file from source control
before you make changes to it. This is because all of your files are saved in a local Git database, so you can simply edit the file you want to work on. A red check mark is displayed next
to each file that you have modified.
6. Commit Files When you are finished editing files, you can commit them to source control.
Committing a file adds your changes to the local Git database. It is a good idea to periodically
commit files so that you have a backup in source control. When you are ready to add your
local commits to the remote repository, you can push these files to the remote.
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7. Create Branches When you are working in Git, you can create branches. Branches create a
new development area for a file that is separate from the original. You can use branches so
multiple authors can work in individual authoring spaces, or you can use them as a space to
make major changes in your document without affecting the original (e.g., when documenting
a new feature, rewriting large sections of a topic, or making layout changes). Even if others
will not be working on a file, you can still create branches if you want to edit your file and then
refer back to its previous versions.
8. Switch Branches If you have created more than one branch, you can switch to, or select, the
branch you want to work with. When you switch to a new branch, you will see the files associated with that branch, and any new commits will be sent to the selected branch. By default,
the master branch is selected.
9. Publish Branches If you want to push to, pull from, or synchronize using a branch you have created, you must publish the branch. You can still commit to an unpublished branch, but until
you publish, you will not be able to send your commits to source control for backup. It is a
good idea to publish branches unless you are only using a branch for a short period of time.
10. Delete Branches If you no longer need a branch, you can delete it. This also deletes any commits on that branch.
11. Push Files After you make changes in your project, you can commit them to your local database. When you are ready to add your local commits to the remote repository, you can push
these files to the remote.
12. Synchronize Synchronizing files updates the local database with files from the remote repository (pull) and then pushes any local commits to the remote repository. If you have not committed your local project files, you will need to commit them before you can synchronize your
files with the remote. You will see the Resolve Version Conflict dialog if conflicts exist.
13. Add Files When working in a project that is connected to source control, there may be occasions when you have files in your local copy of the project that are not yet part of the source
control copy. For example, when you add a new topic in your local copy of the project, that file
will not be included in the source control copy of the project until you add it.
14. Merging Files There may be times when you need to merge changes from different authors
when synchronizing or pulling files. The merge occurs automatically if there are no conflicting
changes (i.e., changes do not occur in the same location in the file). If there are conflicting
changes, a dialog opens, allowing you to determine how changes are merged.
15. Merging Branches There are times where you may have to merge branches into a common
branch.
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General Workflow (Single Author)
Following are the basic steps for using Flare's Git integration for a single author.
1. Set Up Git Install Git and set up the local database and any folders where you want to place
the project. You should also set up your remote repository. Also, assign permissions to the
proper individuals. This task may be performed by someone else, such as a network administrator.
2. In Flare, do one of the following, depending on whether you are creating a new Flare project or
using an existing one.
n

Create and Bind New Project Create a new Flare project and simultaneously bind it to an
integrated source control application.
OR

n

Bind Existing Project If you have an existing Flare project on your local machine, bind the
project to Git.

3. Pull Files If you need to update the files in your local database, you can pull the most current
files from the remote repository. You will see the Resolve Version Conflict dialog if conflicts
exist.
4. Modify Files When you use Git, there is no need to "check out" a file from source control
before you make changes to it. This is because all of your files are saved in a local Git database, so you can simply edit the file you want to work on. A red check mark is displayed next
to each file that you have modified.
5. Commit Files When you are finished editing files, you can commit them to source control.
Committing a file adds your changes to the local Git database. It is a good idea to periodically
commit files so that you have a backup in source control. When you are ready to add your
local commits to the remote repository, you can push these files to the remote.
6. Create Branches When you are working in Git, you can create branches. Branches create a
new development area for a file that is separate from the original. You can use branches so
multiple authors can work in individual authoring spaces, or you can use them as a space to
make major changes in your document without affecting the original (e.g., when documenting
a new feature, rewriting large sections of a topic, or making layout changes). Even if others
will not be working on a file, you can still create branches if you want to edit your file and then
refer back to its previous versions.
7. Switch Branches If you have created more than one branch, you can switch to, or select, the
branch you want to work with. When you switch to a new branch, you will see the files
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associated with that branch, and any new commits will be sent to the selected branch. By
default, the master branch is selected.
8. Publish Branches If you want to push to, pull from, or synchronize using a branch you have created, you must publish the branch. You can still commit to an unpublished branch, but until
you publish, you will not be able to send your commits to source control for backup. It is a
good idea to publish branches unless you are only using a branch for a short period of time.
9. Delete Branches If you no longer need a branch, you can delete it. This also deletes any commits on that branch.
10. Push Files After you make changes in your project, you can commit them to your local database. When you are ready to add your local commits to the remote repository, you can push
these files to the remote.
11. Synchronize Synchronizing files updates the local database with files from the remote repository (pull) and then pushes any local commits to the remote repository. If you have not committed your local project files, you will need to commit them before you can synchronize your
files with the remote. You will see the Resolve Version Conflict dialog if conflicts exist. See
"Synchronizing Source Control Files" on page 43 and "Merging Source Control Files" on page
46.
12. Add Files When working in a project that is connected to source control, there may be occasions when you have files in your local copy of the project that are not yet part of the source
control copy. For example, when you add a new topic in your local copy of the project, that file
will not be included in the source control copy of the project until you add it.
13. Merging Branches There are times where you may have to merge branches into a common
branch.
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Additional Source Control Tasks and
Features
Following are some additional tasks and features related to source control:
n

API If you are working with a source control application other than those directly supported in
Flare (i.e., Microsoft Team Foundation Server, Perforce, Apache Subversion, Git), you can use
the Microsoft Source Code Control API (SCC API) to integrate that application with your Flare
project.
NOTE: It is not mandatory that you use the SCC API to use a source control application for your Flare project files. It is only necessary if you want to take advantage of
the source control integration features inside Flare. Otherwise, you can manually add
your Flare project files to any source control application.

n

Automatic Status Checks If you are using source control integration in Flare, you can check
for frequent status changes automatically. You can specify the number of minutes and
seconds when you want Flare to ping the source control repository and get status changes for
files that have been checked out, checked in, moved, deleted, etc. The upside of this feature
is that you can ensure that the source control status information is always up to date. The
downside is that you may experience slower performance due to this constant communication over the network.

n

Differences One of the benefits of Flare's integrated source control is that you can view the
history and differences for a particular file.

n

Disable Prompt for Get Latest By default, when you open a project that is bound to source control, a message automatically asks if you want to get the latest version of files. However, you
can disable this prompt in the Options dialog. Therefore, in the future when you open the project you will no longer see the message, and the project will open without replacing any local
files with the latest ones from source control.

n

History You can view the history of a particular source control file.
l

Version Displays a number for each version of the file. The lower the number, the older
the version. The higher the number, the more recent the version.

l

Users Displays the name of the user who has been working on the file.

l

Date Displays the date and time when the action has occurred.
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l

l

l

l

Action Displays the action that has taken place for the file (e.g., modified).
Comment Displays the comment (if any) associated with the file. A comment can be
added to a file when you commit that file to source control. This enables you to maintain
an audit trail for the file's history.
Get Selected Version Retrieves a particular version of a file, thus rolling back to that version of the file. The local version of the file is replaced with the source control version
that you selected.
Show Differences Opens a dialog where you can view the differences between two versions of a file. If you select one row in the History dialog and view the differences, you will
see the content differences between the version that you selected and the version of the
file in your local copy of the Flare project. If you select two files in the History dialog (by
holding down the CTRL key) and view the differences, you will see the content differences between those two versions of the file.

n

Publish to Source Control You can use Flare to directly publish your output to source control,
rather than having to upload it to source control separately. Publishing your output to source
control is beneficial because it you can keep previous versions of your output in source control and access them if necessary.

n

Reverting Branches A revert is a type of commit that undoes a prior commit on your branch.
Reverting becomes necessary if changes have been made that are no longer needed. For
example, if you have committed changes for a feature branch that is no longer going to be
included in a release, then those changes need to be reverted.

n

Unbind You can unbind a project from source control. See "Unbinding a Project from Git" on
page 109.

n

View and Modify Network Settings You can view and change various source control network
settings while working in Flare.

NOTE: Because of the way Git is designed, when you remove files from your project and
commit your changes to the local database, you still need to push your changes to the
remote repository in order for those files to be removed from the remote repository.
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CHAPTER 3

Binding a Project to Git
Use the following steps if you have already created a Flare project and want to bind ("connect") it to
Git. You can also automatically detect existing source control bindings if your project has been previously connected to Git.

HOW TO BIND A PROJECT TO SOURCE CONTROL
1. Select the Project ribbon. In the Properties section select Project Properties. The Project
Properties dialog opens.
2. Select the Source Control tab.
3. Click Bind Project. The Bind Project dialog opens.
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4. From the drop-down, select Git.

5. If you are going to bind to a remote repository, select the Remote Repository box, then enter
the address of the repository in the field. If you want to work locally, you can leave this box
unselected. You can enter an HTTP URL or an SSH URL.
NOTE: You may need to obtain this information from your system administrator.

NOTE: If you use CloudForge Git as your remote repository, it may give you an incorrect URL. If you enter the incorrect URL in when binding your project, you will receive
an error when you push or pull.
To correct this error, change the URL from this format…
https://username@madcapsoftware.git.cloudforge.com/yourproject.git

…to this format…
https://madcapsoftware.git.cloudforge.com/yourproject.git
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Removing the username@ section from the URL allows it to work properly when performing a push or pull.
6. If you want to push to the remote repository when you bind the project, select the Push on
bind check box. This will push the initial project files to the repository when you bind the project.
7. In the Name field, enter your name.
8. In the Email field, enter your email address.
9. From the Save Per drop-down, select how you want to save your files.
n

User Saves the files in your local folder. Select this option if you are working with other
tools (e.g., Tortoise) or if you want to use the same user identity across multiple projects.

n

Project Saves the files locally to your project. Select this option if you want to use different identities for each project.

10. (Optional) In the Comment field, you can enter any internal comments.
11. In the Bind Project dialog, click OK.
12. In the Project Properties dialog, click OK.
13. (Optional) If you entered an HTTP address in Step 7, enter your user name and password in
the Log In dialog. Click OK when you are finished.
14. (Optional) If you entered an SSH URL in Step 7, the Certificate Specification dialog opens. In
the dialog, do the following and click OK when you are finished:
a. In the Public key field, enter your public SSH key, or use
your network.
b. In the Private key field, enter your private SSH key, or use
your network.

to browse for the key on

to browse for the key on

c. If you want Flare to remember your key information so you do not need to enter it again
later, select the check box next to Save certificate information.
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NOTE: SSH keys allow you to establish a secure connection between your computer and your Git source control provider (likewise, using an SSH URL is more
secure than an HTTP URL; you need to use SSH keys if you want to use an
SSH URL). If you do not have a public and private SSH key, your can generate
these keys using your Git source control provider (e.g., Gitlab). Follow the directions provided by your source control provider to add these keys to your Git
account. Once you generate these keys, they are typically found in the
C:\Users\[username]\.ssh folder on your computer.
Public keys typically have a .pub extension. Private keys use the same file name
as the public key, but without the file extension.

EXAMPLE
Use the following as guides when setting up your URLs and keys.
SSH URL
git@gitlabomnibus.mycompany.corp:MyUserName/myproject.git

HTTP URL
http://gitlabomnibus.mycompany.corp/MyUserName/myproject.git

SSH Private Key
mycompanySSHkey_id_rsa

SSH Public Key
mycompanySSHkey_id_rsa.pub
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HOW TO BIND A PROJECT TO SOURCE CONTROL—SOURCE CONTROL EXPLORER
1. Select the View ribbon. In the Explorer section select Source Control Explorer. The Source
Control Explorer opens.
2. From the drop-down or the Home pane, select Settings. The Settings pane opens.
3. Click Bind. The Bind Project dialog opens.
4. From the drop-down, select Git.
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5. If you are going to bind to a remote repository, select the Remote Repository box, then enter
the address of the repository in the field. If you want to work locally, you can leave this box
unselected. You can enter an HTTP URL or an SSH URL.
NOTE: You may need to obtain this information from your system administrator.
6. If you want to push to the remote repository when you bind the project, select the Push on
bind check box. This will push the initial project files to the repository when you bind the project.
7. In the Name field, enter your name.
8. In the Email field, enter your email address.
9. From the Save Per drop-down, select how you want to save your files.
n

User Saves the files in your local folder. Select this option if you are working with other
tools (e.g., Tortoise) or if you want to use the same user identity across multiple projects.

n

Project Saves the files locally to your project. Select this option if you want to use different identities for each project.

10. (Optional) In the Comment field, you can enter any internal comments.
11. In the Bind Project dialog, click OK.
12. In the Project Properties dialog, click OK.
13. (Optional) If you entered an HTTP address in Step 7, enter your user name and password in
the Log In dialog. Click OK when you are finished.
14. (Optional) If you entered an SSH URL in Step 7, the Certificate Specification dialog opens. In
the dialog, do the following and click OK when you are finished:
a. In the Public key field, enter your public SSH key, or use
your network.
b. In the Private key field, enter your private SSH key, or use
your network.

to browse for the key on

to browse for the key on

c. If you want Flare to remember your key information so you do not need to enter it again
later, select the check box next to Save certificate information.
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NOTE: SSH keys allow you to establish a secure connection between your computer and your Git source control provider (likewise, using an SSH URL is more
secure than an HTTP URL; you need to use SSH keys if you want to use an
SSH URL). If you do not have a public and private SSH key, your can generate
these keys using your Git source control provider (e.g., Gitlab). Follow the directions provided by your source control provider to add these keys to your Git
account. Once you generate these keys, they are typically found in the
C:\Users\[username]\.ssh folder on your computer.
Public keys typically have a .pub extension. Private keys use the same file name
as the public key, but without the file extension.

EXAMPLE
Use the following as guides when setting up your URLs and keys.
SSH URL
git@gitlabomnibus.mycompany.corp:MyUserName/myproject.git

HTTP URL
http://gitlabomnibus.mycompany.corp/MyUserName/myproject.git

SSH Private Key
mycompanySSHkey_id_rsa

SSH Public Key
mycompanySSHkey_id_rsa.pub
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AUTOMATICALLY DETECTING PROJECT BINDINGS
You can scan a project when you open it to see if it has any bindings to source control. If a binding is
detected, you can apply the binding and commit the project to source control.
1. Select File > Options. The Options dialog opens.
2. Select the Source Control tab.
3. Select the Bind Detection check box.
4. Select the source control provider(s) you want to scan for bindings.
NOTE: Source control providers are scanned in the following order:
1. Git
2. Subversion
3. Perforce
4. Microsoft Team Foundation Server (TFS)

TIP: Detecting source control bindings may take a considerable amount of time. It is
recommended that you select only the source control providers that you use to speed
up the detection process.

NOTE: You can also bind a new Flare project to source control while creating it.

NOTE: When you bind a project to Flare using Git, a .gitignore text file is automatically created in your local project folder. Advanced users can edit the .gitignore file with a text editor
to control which files or folders can be pushed to your Git repository. You can also specify
which files and folders are ignored by Git, and are not pushed to the repository.

NOTE: If you want to publish your output to source control, you must create a bind destination.
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TIP: If you are having difficulty binding your project, try binding to a brand new directory in
your source control provider. You should also ensure that the directory on your local
machine (and its parent directories) is not already mapped to source control, as this may
cause issues with binding.
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CHAPTER 4

Importing from Git
This chapter focuses on importing a Flare project from source control. You might use this method,
for example, if you are working on a multi-author project and another member of the team has
placed the Flare project in Git. For more information see "Introduction" on page 6.

HOW TO IMPORT A PROJECT FROM SOURCE CONTROL
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select File > New Project > Import Project.

n

Source Control Explorer From the View ribbon, open the Source Control Explorer. From
the drop-down, select the Home pane. Click Import Project.

The Import Project from Source Control Wizard dialog opens.
2. From the drop-down, select Git.
3. In the Remote drop-down, enter the remote repository where the project is located.
NOTE: You may need to obtain this information from your system administrator.
4. In the Name field, enter your name.
5. In the Email field, enter your email address.
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6. From the Save Per drop-down, select how you want to save your files.
n

User Saves the files in your local folder. Select this option if you are working with other
tools (e.g., Tortoise) or if you want to use the same user identity across multiple projects.

n

Project Saves the files locally to your project. Select this option if you want to use different identities for each project.

7. Click Next.
8. Next to the Project file field, click Browse. The Browse Source Control Files dialog opens. (You
may need to log in with your user name and password.)
9. (Optional) If the remote you selected in Step 3 requires an SSH certificate, the Certificate Specification dialog opens. In the dialog, do the following:
a. In the Public key field, enter your public SSH key, or use
your network.
b. In the Private key field, enter your private SSH key, or use
your network.

to browse for the key on

to browse for the key on

c. If you want Flare to remember your key information so you do not need to enter it again
later, select the check box next to Save certificate information.
NOTE: SSH keys allow you to establish a secure connection between your computer and your Git source control provider (likewise, using an SSH URL is more
secure than an HTTP URL; you need to use SSH keys if you want to use an
SSH URL). If you do not have a public and private SSH key, your can generate
these keys using your Git source control provider (e.g., Gitlab). Follow the directions provided by your source control provider to add these keys to your Git
account. Once you generate these keys, they are typically found in the
C:\Users\[username]\.ssh folder on your computer.
Public keys typically have a .pub extension. Private keys use the same file name
as the public key, but without the file extension.
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EXAMPLE
Use the following as guides when setting up your URLs and keys.
SSH URL
git@gitlabomnibus.mycompany.corp:MyUserName/myproject.git

HTTP URL
http://gitlabomnibus.mycompany.corp/MyUserName/myproject.git

SSH Private Key
mycompanySSHkey_id_rsa

SSH Public Key
mycompanySSHkey_id_rsa.pub

10. Find and click on the Flare project file (FLPRJ) that you want to import. (You may need to log
in with your user name and password.)
11. Click OK.
12. Click Next..
13. In the Project name field, the name of the project being imported is displayed. It is recommended that you leave the name as it is, especially if you are working with other authors on
the project. However, you can enter a different project name if you want.
14. In the Project folder field, either accept the default location for the new project or click
browse for and select a folder.

to

15. Click Finish. The project is imported and loaded into Flare.

NOTE: If you want to import a project from source control, you can alternatively open the
project file from another location (e.g., a server location), and then use Flare's bind detection functionality to automatically apply available source control bindings to the project.I
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CHAPTER 5

Committing Source Control
Files
When you are finished editing files, you can commit them to source control. Committing a file adds
your changes to the local Git database. It is a good idea to periodically commit files so that you have
a backup in source control. When you are ready to add your local commits to the remote repository,
you can push these files to the remote.

HOW TO COMMIT FILES TO SOURCE CONTROL
1. Do one of the following, depending on the part of the user interface you are using:
n

Pending Changes Window Pane From the Source Control ribbon, open the Pending
Changes window pane. Select the files in the window pane that you want to commit, and
in the local toolbar click

.

n

Ribbon Select the Source Control ribbon. In the File section select Commit (for selected
files). Alternatively, in the Project section you can click Commit All (for all files in the project).

n

Right-Click If you have the Content Explorer, Project Organizer, Pending Changes window
pane, or File List open, right-click the file you want to commit and select Source Control >
Commit (for selected files) or Source Control > Project > Commit All (for all files in the
project).

The Commit dialog opens. The selected files are listed with check boxes next to them.
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2. (Optional) Enter an optional comment tied to the commit. This enables you to keep an audit
trail for a file. The comment can then be viewed from the History dialog, which can be
accessed from the Source Control Explorer, the Source Control ribbon, the File menu, or the
Source Control button

.

3. (Optional) If you want to see all files with pending changes (rather than only those you selected), click

.

4. Make sure to click the check box next to each file you want to commit so that it contains a
check mark.
5. Click Commit.

HOW TO COMMIT FILES TO SOURCE CONTROL—SOURCE CONTROL EXPLORER
1. Select the View ribbon. In the Explorer section select Source Control Explorer. The Source
Control Explorer opens.
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2. From the drop-down or the Home pane, select Pending Changes.
The Pending Changes pane opens. Files that will be committed are listed under Included
Changes, and files that will not be committed are listed under Excluded Changes. You can
identify modified files because they say [edit] next to the file name.

3. (Optional) In the Comment field, enter an optional comment tied to the commit. This enables
you to keep an audit trail for a file. The comment can then be viewed from the History dialog,
which can be accessed from the Source Control Explorer, the Source Control ribbon, the File
menu, or the Source Control button

.

4. (Optional) If you want to select the files or folders that you include in the commit, right-click a
file or folder and select one of the following options from the context menu.
n

Exclude Excludes the selected file from the commit

n

Exclude Unselected Excludes all unselected files from the commit

n

Include Includes the selected file in the commit

n

Include Unselected Includes all unselected files in the commit

5. Click Commit to commit all of the files in the Included Changes list. The Messages pane
opens and displays a list of files that were committed.
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CHAPTER 6

Pushing Files to a Remote
Repository
After you commit the changes from your project to the local Git repository, you can push them to
the remote Git repository. Performing a push sends all of the files you have committed on your current branch to the remote repository. This is a way to back them up to source control and for other
users to have access the changes you have made.
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PUSHING FILES TO MADCAP CENTRAL
If you are not using MadCap Central, you can simply use the standard method (described below) for
pushing files to a repository. If you are using Central and your project is bound to it (along with a
third-party source control tool), you can use the MadCap Central window pane to push your files (for
more information, see the online Help).

HOW TO PUSH FILES TO A REMOTE REPOSITORY
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the Project section select Push.

n

Right-Click If you have the Content Explorer, Project Organizer, Pending Changes window
pane, or File List open, right-click on any file and select Source Control > Project > Push.

2. (Optional) If you did not commit your files before starting the push, a dialog asks if you want to
commit your files. Click Yes to continue. See "Committing Source Control Files" on page 32.
NOTE: You must commit all modified files to proceed with the push.
3. The Select Remote for Push dialog opens. From the Remote drop-down, select the repository
you want to push to.
4. (Optional) To add or remove a remote repository, click
opens.(Optional)

. The Remote Repositories dialog

HOW TO ADD A REMOTE REPOSITORY
a. In the Remote Repository field, enter the address of the new repository.
NOTE: You may need to obtain this information from your system administrator.
b. In the Alias field, enter a name for the new repository. This is the name that will appear
in the Remote drop-down when you need to select a remote repository.
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NOTE: Repository names cannot include spaces.
c. Click Add to add the new repository to the list of available repositories.

d. Click OK.

HOW TO REMOVE A REMOTE REPOSITORY
a. From the Remote Repository list, select the repository you want to delete.
b. Click Remove. The repository is removed from the list of available repositories.
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c. Click OK.
5. In the Select Remote for Push dialog, click OK. If the Log In dialog opens, complete the User
name and Password fields and click OK.
6. If the local changes are different from those in the remote, you will see an error in the Progress dialog during the push. Perform a pull, then attempt the push again. See "Pulling Files
from a Remote Repository" on page 39.

NOTE: If you use CloudForge Git as your remote repository, it may give you an incorrect
URL. If you enter the incorrect URL in when binding your project, you will receive an error
when you push or pull.
To correct this error, change the URL from this format…
https://username@madcapsoftware.git.cloudforge.com/yourproject.git

…to this format…
https://madcapsoftware.git.cloudforge.com/yourproject.git

Removing the username@ section from the URL allows it to work properly when performing
a push or pull.
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CHAPTER 7

Pulling Files from a Remote
Repository
If you need to update the files in your local database, you can do a pull. When you pull files, Flare
retrieves files from the remote repository and downloads them to your local Git database. This
updates your current branch with the most current version of the file. This is a good way to get
changes that other users have made to a file and pushed to the remote.
When you pull, you will see the Resolve Version Conflict dialog if conflicts exist between the remove
files and the files in your local database.

HOW TO PULL FILES FROM A REMOTE REPOSITORY
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the Project section select Pull.

n

Right-Click If you have the Content Explorer, Project Organizer, Pending Changes window
pane, or File List open, right-click any file and select Source Control > Project > Pull.

2. (Optional) If you did not commit your files before starting the pull, a dialog asks if you want to
commit your files. Click Yes to continue. See "Committing Source Control Files" on page 32.
NOTE: You must commit all modified files to proceed with the pull.
3. The Select Remote for Pull dialog opens. From the Remote drop-down, select the repository
you want to pull from.
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4. (Optional) To add or remove a remote repository, click
opens.

. The Remote Repositories dialog

HOW TO ADD A REMOTE REPOSITORY
a. In the Remote Repository field, enter the address of the new repository.
NOTE: You may need to obtain this information from your system administrator.
b. In the Alias field, enter a name for the new repository. This is the name that will appear
in the Remote drop-down when you need to select a remote repository.

NOTE: Repository names cannot include spaces.
c. Click Add to add the new repository to the list of available repositories.
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d. Click OK.

HOW TO REMOVE A REMOTE REPOSITORY
a. From the Remote Repository list, select the repository you want to delete.
b. Click Remove. The repository is removed from the list of available repositories.
c. Click OK.
5. In the Select Remote for Pull dialog, click OK. If the Log In dialog opens, complete the User
name and Password fields and click OK.
6. If the remote and local files are the same, a message tells you so. Click OK.
If a remote file is different from the version in your local database, the Resolve Conflicts dialog opens. If you want to accept all of the differences between the remote and local files, thus
merging them, click Auto Merge All. If you want to review the differences in the files side by
side and resolve each conflict, click Resolve. For more information about merging files and
resolving conflicts, see "Merging Source Control Files" on page 46.
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NOTE: If you use CloudForge Git as your remote repository, it may give you an incorrect
URL. If you enter the incorrect URL in when binding your project, you will receive an error
when you push or pull.
To correct this error, change the URL from this format…
https://username@madcapsoftware.git.cloudforge.com/yourproject.git

…to this format…
https://madcapsoftware.git.cloudforge.com/yourproject.git

Removing the username@ section from the URL allows it to work properly when performing
a push or pull.
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CHAPTER 8

Synchronizing Source Control
Files
Synchronizing files performs a pull to update the local database with files from the remote repository, and then pushes any local commits to the remote repository. Changes made during a synchronize affect your current branch. You will see the Resolve Version Conflict dialog if conflicts
exist when you synchronize your files.
If a remote file is different from the version in your local database, the Resolve Conflicts dialog
opens. If you want to accept all of the differences between the remote and local files, thus merging
them, click Auto Merge All. If you want to review the differences in the files side by side and resolve
each conflict, click Resolve

HOW TO SYNCHRONIZE FILES
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the Project section select Synchronize.

n

Right-Click If you have the Content Explorer, Project Organizer, Pending Changes window
pane, or File List open, right-click any file and select Source Control > Project > Synchronize.

2. (Optional) If you did not commit your files before starting the synchronize, a dialog asks if you
want to commit your files. Click Yes to continue. See "Committing Source Control Files" on
page 32.
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NOTE: You must commit all modified files to proceed with the synchronize.
3. The Select Remote for Synchronize dialog opens. From the Remote drop-down, select the
repository you want to synchronize with.
4. (Optional) To add or remove a remote repository, click
opens.

. The Remote Repositories dialog

HOW TO ADD A REMOTE REPOSITORY
a. In the Remote Repository field, enter the address of the new repository.
NOTE: You may need to obtain this information from your system administrator.
b. In the Alias field, enter a name for the new repository. This is the name that will appear
in the Remote drop-down when you need to select a remote repository.

NOTE: Repository names cannot include spaces.
c. Click Add to add the new repository to the list of available repositories.
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d. Click OK.

HOW TO REMOVE A REMOTE REPOSITORY
a. From the Remote Repository list, select the repository you want to delete.
b. Click Remove. The repository is removed from the list of available repositories.
c. Click OK.
5. In the Select Remote for Synchronize dialog, click OK. If the Log In dialog opens, complete the
User name and Password fields and click OK.
6. If a remote file is different from the version in your local database, the Resolve Conflicts dialog opens. If you want to accept all of the differences between the remote and local files, thus
merging them, click Auto Merge All. If you want to review the differences in the files side by
side and resolve each conflict, click Resolve For more information about merging files and
resolving conflicts, see "Merging Source Control Files" on page 46.
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CHAPTER 9

Merging Source Control Files
There may be times when you need to merge changes from different authors when synchronizing
or pulling files. The merge occurs automatically if there are no conflicting changes (i.e., changes do
not occur in the same location in the file). If there are conflicting changes, a dialog opens, allowing
you to determine how changes are merged.
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HOW TO MERGE SOURCE CONTROL FILES
1. Synchronize your files with the remote repository. If your local copy of the file is different from
the remote copy (e.g., another author has already pushed the same file to the remote), the
Resolve Conflicts dialog opens. See "Synchronizing Source Control Files" on page 43.
2. Click Auto Merge All. If changes from the other author do not conflict with your changes, this
will merge all changes. A message lets you know that a backup of your local copy has been
made. This allows you to restore that file if you do not want to keep the merged version. You
do not need to complete the rest of the steps below.
However, if your changes conflict with those from another author, a message displays to tell
you. In this case, continue with the next step.
3. Click OK on the conflict message.
4. In the Resolve Conflicts dialog click Resolve. The Resolve Version Conflict dialog opens. From
this dialog, you can choose from the following options.
n

Merge changes for me Automatically merges changes within the same file that are not
part of the same element. If changes have been made to the same element (e.g., the
same <p> tag or <h1> tag), Flare will display a prompt to merge the changes using the
merge tool.

n

Merge changes in merge tool Opens a merging interface, which lets you see exactly what
changes were made and choose which to keep.

n

Undo my local changes Automatically removes your changes and keeps changes from
other authors.

n

Discard external changes Automatically removes changes from other authors and keeps
your changes.

5. If you selected the option to use the merge tool, the Merge Changes dialog opens. Use this
dialog to view and select changes. You can take actions in the following ways.
n

Click a change You can click a change on either the remote or local side. This lets you
select a particular change. Use the key at the top of the merge changes dialog, as well as
the color coding on the local and server sides, to determine if a change has been added
(new), deleted, changed, or moved.
When you select a change, the change you selected will display with a solid colored background, and the conflicting change will display with a striped background. If you select
the other change, the background shading will switch.
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n

Type content If you want to use your changes as well as those from another author, and
even tweak the paragraph a bit more, you can click in the area at the bottom of the dialog
and simply type content.

n

Previous/next conflict When you are finished resolving the first conflict, you can use the
"Previous Conflict" and "Next Conflict" buttons at the bottom of the dialog to work on
other conflicts in the file.
NOTE: If you selected "Merge as Text" in the local toolbar and are working in the
code, you can click on text with a hatched background to keep the change in it. After
you click on text with a hatched background, the hatched lines are removed, leaving a
solid color.

6. After all conflicts have been resolved, a message lets you know that a backup of your local
copy has been made. This allows you to restore that file if you do not want to keep the merged
version. Click OK.
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EXAMPLE—NO C ONFLICTING CHANGES
Let's say two authors—Bob and Jill—are working on the same project, using source control to manage the files.
Bob starts making changes to his local version of the "FAQs" topic.
Jill also starts making changes to her local version of the "FAQs" topic. Jill's changes
are in a different location in the topic than Bob's changes; there are no conflicts. She
finishes before Bob and synchronizes her files.
Bob finishes his changes and tries to synchronize his files. During the pull, Bob is prompted with a dialog, indicating that changes from another author have already been
made.
Bob selects Auto Merge All. The changes from Bob and Jill are now both shown in the
merged topic. When either author pulls the topic again or synchronizes their files, they
will see the new version of the topic.
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EXAMPLE—C ONFLICTING C HANGES
Let's say two authors—Bob and Jill—are working on the same project, using source control to manage the files.
Bob starts making changes to his local version of the "FAQs" topic.
Jill also starts making changes to her local version of the "FAQs" topic. Jill's changes
are in the same paragraph in the topic as Bob's changes; thus, there is a conflict. She
finishes before Bob and synchronizes her files.
Bob finishes his changes and tries to synchronize his files. During the pull, Bob is prompted with a dialog, indicating that changes from another author have already been
made.

Bob selects Auto Merge All. However, he receives another message, stating that his
changes conflict with those of Jill.
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Bob clicks OK. Then in the Resolve Conflicts dialog he clicks Resolve. This opens the
Resolve Version Conflict dialog. From this dialog, Bob can choose from a few different
options.
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Bob selects Merge changes in merge tool. The Merge Changes dialog opens.
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So what action can Bob take at this point for merging the file changes?
Bob can right-click on the icon next to the change on either the local or remote side.
This displays a context menu, which lets Bob either keep or ignore a particular change.

CHAPTER 9

53

Another way of accomplishing the same thing is to left-click on an icon. When you do
this, the change from one side is kept and the change from the other side is ignored. If
you left-click the icon again, the results are toggled; the first change is ignored and the
other is kept.
What if Bob wants to use his changes as well as Jill's, and possibly tweak the paragraph
a bit more? He can click in the area at the bottom of the dialog and simply type content.
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When he is finished resolving the first conflict, Bob can use the "Previous Conflict" and
"Next Conflict" buttons at the bottom of the dialog to work on other conflicts in the file.

After all conflicts have been resolved, Bob clicks OK. The merged topic is now pushed
to source control. When either author pulls the topic again or synchronizes their files,
they will see the new version of the topic.
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CHAPTER 10

Adding Files to Source Control
When working in a project that is connected to a source control application, there may be occasions
when you have local files that are not yet part of the source control repository. For example, when
you add a new topic, that file will not be included in the source control repository until you add it.

HOW TO ADD FILES TO SOURCE CONTROL
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the File section select Add.

n

Right-Click If you have the Content Explorer, Project Organizer, Pending Changes window pane, or File List open, right-click the file you want to add and select Source Control
> Add.

The Commit dialog opens. The selected files are listed with check boxes next to them.
2. (Optional) Enter an optional comment tied to the commit. This enables you to keep an audit
trail for a file. The comment can then be viewed from the History dialog, which can be
accessed from the Source Control Explorer, the Source Control ribbon, the File menu, or the
Source Control button

.

3. (Optional) If you want to see all files with pending changes (rather than only those you selected), click

.

4. Make sure to click the check box next to each file you want to commit so that it contains a
check mark.
5. Click Commit.
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HOW TO ADD FILES TO SOURCE CONTROL—SOURCE CONTROL EXPLORER
1. Select the View ribbon. In the Explorer section select Source Control Explorer. The Source
Control Explorer opens.
2. From the drop-down or the Home pane, select Pending Changes.
The Pending Changes pane opens. Files that will be committed are listed under Included
Changes, and files that will not be committed are listed under Excluded Changes. You can
identify newly added files because they say [add] next to the file name.

3. (Optional) In the Comment field, enter an optional comment tied to the commit. This enables
you to keep an audit trail for a file. The comment can then be viewed from the History dialog,
which can be accessed from the Source Control Explorer, the Source Control ribbon, the File
menu, or the Source Control button
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4. (Optional) If you want to select the files or folders that you include in the commit, right-click a
file or folder and select one of the following options from the context menu.
n

Exclude Excludes the selected file from the commit

n

Exclude Unselected Excludes all unselected files from the commit

n

Include Includes the selected file in the commit

n

Include Unselected Includes all unselected files in the commit

5. Click Commit to commit all of the files in the Included Changes list. The Messages pane
opens and displays a list of files that were committed.
NOTE: Adding files from other areas of the Flare interface (e.g., Pending Changes
window pane, Source Control ribbon) will only add new files. However, if you use the
Source Control Explorer to commit your files, it will commit all of your pending
changes: both new files and modified files. If you do not want to include all of your
files in the commit, you can right-click them and select Exclude. Files you exclude will
not be committed.
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CHAPTER 11

Additional Git Tasks
In addition to the many features already covered in this guide, there are many more tasks related to
source control that you can perform in Flare.
This chapter discusses the following:
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64

Merging Branches

68

Publishing Branches

79

Reverting Branches

84

Switching Branches

87

Deleting Source Control Files

93

Disabling the Get Latest Prompt for Source Control

94

Enabling Source Control Status Checks

95

Modifying Network Settings

96

Publishing to Source Control

99

Reverting Modified Source Control Files

100

Rolling Back to an Earlier Version of a File

101

Setting Color Options for Project File Differences
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Unbinding a Project from Git
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Using an API to Integrate Source Control
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Viewing Differences in Source Control Files
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Viewing Modified Files
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Viewing the History of Source Control Files
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Creating Branches
When you are working in Git, you can create branches. Branches create a new development area
for a file that is separate from the original. You can use branches so multiple authors can work in
individual authoring spaces, or you can use them as a space to make major changes in your document without affecting the original (e.g., when documenting a new feature, rewriting large sections of a topic, or making layout changes). Even if others will not be working on a file, you can still
create branches if you want to edit your file and then refer back to its previous versions.

HOW TO CREATE BRANCHES—BRANCH MANAGEMENT DIALOG
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the Project section select Branch.

n

Right-Click If you have the Content Explorer, Project Organizer, Pending Changes window
pane, or File List open, right-click on any file and select Source Control > Project >
Branch.

The Branch Management dialog opens.
2. Click Create. The Create Branch dialog opens.
3. From the Source Branch drop-down, select the existing branch you want to use to create the
new branch. Your new branch will copy the existing files from the source branch, but commits
you make on the new branch will not affect the source branch.
4. In the Branch Name field, enter a name for your branch. Names cannot include spaces.
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5. (Optional) If you want to switch the branch when you create it, select the Switch to branch
check box.

WARNING: You will not see a confirmation message when switching to a newly created branch. Be sure all of your current changes are committed before creating and
switching to a new branch. If you have uncommitted changes, they will be lost. See
"Committing Source Control Files" on page 32.
6. Click Create. Your new branch is added to the "All branches" list. If you chose to switch to the
branch, you can now begin working on the branch.
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HOW TO CREATE BRANCHES—SOURCE CONTROL EXPLORER
1. Select the View ribbon. In the Explorer section select Source Control Explorer. The Source
Control Explorer opens.
2. From the drop-down or the Home pane, select Branches. The Branches pane opens. In the
pane, you can see your current branch, as well as lists of your published and unpublished
branches.
3. Click Create. The Create Branch dialog opens.
4. From the Source Branch drop-down, select the existing branch you want to use to create the
new branch. Your new branch will copy the existing files from the source branch, but commits
you make on the new branch will not affect the source branch.
5. In the Branch Name field, enter a name for your branch. Names cannot include spaces.
6. (Optional) If you want to switch the branch when you create it, select the Switch to branch
check box.

WARNING: You will not see a confirmation message when switching to a newly created branch. Be sure all of your current changes are committed before creating and
switching to a new branch. If you have uncommitted changes, they will be lost. See
"Committing Source Control Files" on page 32.
7. Click Create. Your new branch is added to the "All branches" list. If you chose to switch to the
branch, you can now begin working on the branch.

CHAPTER 11

63

Deleting Branches
If you no longer need a branch, you can delete it. This also deletes any commits on that branch.
You can delete any branch except the current branch. If you need to delete the current branch, you
will have to switch to a different branch first. See "Switching Branches" on page 87.

HOW TO DELETE BRANCHES—BRANCH MANAGEMENT DIALOG
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the Project section select Branch.

n

Right-Click If you have the Content Explorer, Project Organizer, Pending Changes window
pane, or File List open, right-click on any file and select Source Control > Project >
Branch.

The Branch Management dialog opens.
2. In the All branches list, select the branch you want to delete. You can delete any branch
except the current branch.
NOTE: Your current branch is shown at the bottom of the dialog.
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3. Click Delete.

4. A dialog asks if you want to delete the branch and all of the commits on the branch. Click Yes.
The branch is removed from the list.
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HOW TO DELETE BRANCHES—SOURCE CONTROL EXPLORER
1. Select the View ribbon. In the Explorer section select Source Control Explorer. The Source
Control Explorer opens.
2. From the drop-down or the Home pane, select Branches. The Branches pane opens. In the
pane, you can see your current branch, as well as lists of your published and unpublished
branches.
3. Select the branch you want to delete. You can delete any branch except the current branch.
4. Click Delete Branch.
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5. A dialog asks if you want to delete the branch and all of the commits on the branch. Click Yes.
The branch is removed from the list.
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Merging Branches
There are times where you may have to merge branches into a common branch.

HOW TO MERGE BRANCHES IN GIT
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the Project section, select Merge.

n

Right-Click If you have the Content Explorer or Project Organizer window pane open,
right-click on any file or folder and select Source Control > Project > Merge.

n

Source Control Explorer Click the Merge Branch button.

The Select branch to merge dialog opens.

2. From the drop-down list, select the Git branch you wish to merge into the active branch.
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3. Click OK. A dialog will display the status of the merge in progress.

4. When the merge operation is completed, a dialog will display indicating the merge was a success. Click OK to close the dialog.

EXAMPLE—NO C ONFLICTING CHANGES
Let's say you have two feature branches that are bound in Git source control.
In the first feature branch (e.g., develop-feature1), you are making changes to the "Getting Started" topic. These changes are specific to the first feature being developed.
In the second feature branch (e.g., develop-feature2), you also make changes to the
"Getting Started" topic. These changes are specific to the second feature being
developed, and are being made in a separate part of the topic from the develop-feature1 changes.
After you complete your changes on the second feature branch, you decide you want
to merge your changes from the first feature branch to the second feature branch.
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In the Source Control Explorer, you select the develop-feature2 branch. Then, you click
the Merge Branch button. Finally, from the drop-down list of branches, you select the
develop-feature1 branch.

You click OK to merge. Since the changes took place in different sections of the "Getting Started" topic, the merging of the first feature branch into the second feature
branch is successful.
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EXAMPLE—C ONFLICTING C HANGES
Let's say you have two feature branches that are bound in Git source control.
In the first feature branch, you are making changes to the "Getting Started" topic.
These changes are specific to the first feature being developed.
In the second feature branch, you also make changes to the "Getting Started" topic.
The changes are made to the same paragraph as those you made for the first feature
branch.
In the Source Control Explorer, you select the develop-feature2 branch. Then, you click
the Merge Branch button. Finally, from the drop-down list of branches, you select the
develop-feature1 branch.

You click OK to merge. Since the changes took place in the same paragraph in the "Getting Started" topic, you get a dialog indicating conflicts exist. You then click Yes to
resolve the existing conflicts.
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On the Resolve Conflicts dialog, you click Auto Merge All.

However, the auto merging is not successful. You click OK, then Resolve to fix the
remaining conflicts.
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When the Resolve Version Conflict dialog displays, you choose to Merge changes in
merge tool. This will allow you to view the specific conflict taking place rather than
accepting either the local or the server changes.
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The Merge Changes dialog opens. The left pane is the file version on your local
machine, while the right pane is the server version. The bottom pane displays how the
file will display as you make your changes.

CHAPTER 11

74

As you review the text, you notice the conflict icon next to the "Do This" bullet point.
You decide to keep the server version in the right pane by right-clicking on the conflict
icon and selecting Keep Change.
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Notice that when you keep the changes on the right pane, the conflicting changes in
the left pane are now disabled and outlined in gray.

NOTE: As you resolve conflicts in the merge tool, you can also left-click on the
Conflict icon on either the local or server pane to keep the change. If you leftclick on the icon again, it will toggle the change to be accepted on the opposite
pane of where you are clicking.
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Once you have reviewed all of the conflicts and made your changes, you click OK. At
this point, you need to commit the changes that resolved your conflicts. You then type
in your comment used to resolve the conflict, and click Commit.

When your changes are committed, you can now merge this branch. With the developfeature2 branch selected, you click the Merge Branch button. You then select the
develop-feature1 branch from the drop-down list. You click OK to merge. A confirmation dialog displays when the merge is completed.
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The merge will also be displayed in the Branch History dialog.

NOTE: For more information on how Git branching and merging works, the Git website
provides in-depth workflows and additional details. See https://git-scm.com/book/en/v2/Git-Branching-Basic-Branching-and-Merging.
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Publishing Branches
If you want to push to, pull from, or synchronize using a branch you have created, you must publish
the branch. You can still commit to an unpublished branch, but until you publish, you will not be able
to send your commits to source control for backup. It is a good idea to publish branches unless you
are only using a branch for a short period of time.
You can publish branches in the following ways:
n

Automatic If your current branch is unpublished, pushing, pulling, or synchronizing automatically publishes the branch. See "Pushing Files to a Remote Repository" on page 35,
"Pulling Files from a Remote Repository" on page 39, and "Synchronizing Source Control Files"
on page 43.

n

Manual Select an unpublished branch in the Source Control Explorer and manually publish it.
You can select any branch, even if it is not your current branch.

HOW TO MANUALLY PUBLISH BRANCHES
1. Select the View ribbon. In the Explorer section select Source Control Explorer. The Source
Control Explorer opens.
2. From the drop-down or the Home pane, select Branches.
The Branches pane opens. In the pane, you can see your current branch, as well as lists of
your published and unpublished branches.
3. Select the unpublished branch you want to publish.
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4. Click Publish Branch.

5. (Optional) If you did not commit your files before publishing the branch, a dialog asks if you
want to commit your files. Click Yes to continue. See "Committing Source Control Files" on
page 32.
NOTE: You must commit all modified files before you can publish the branch.
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6. The Select Remote for Publish dialog opens. From the Remote drop-down, select the repository you want to push to.
NOTE: If you have pending changes that you are committing while publishing your
branch, you will see the Select Remote for Push dialog. However, the steps for pushing while publishing a branch are the same. See "Pushing Files to a Remote Repository" on page 35 for additional information.

7. (Optional) To add or remove a remote repository, click
opens.

. The Remote Repositories dialog

HOW TO ADD A REMOTE REPOSITORY
a. In the Remote Repository field, enter the address of the new repository.
NOTE: You may need to obtain this information from your system administrator.
b. In the Alias field, enter a name for the new repository. This is the name that will appear
in the Remote drop-down when you need to select a remote repository.
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NOTE: Repository names cannot include spaces.
c. Click Add to add the new repository to the list of available repositories.

d. Click OK.

HOW TO REMOVE A REMOTE REPOSITORY
a. From the Remote Repository list, select the repository you want to delete.
b. Click Remove. The repository is removed from the list of available repositories.
c. Click OK.
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8. In the Select Remote for Publish dialog, click OK. If the Log In dialog opens, complete the User
name and Password fields and click OK. Your branch is published and added to the Published
Branches list.
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Reverting Branches
A revert is a type of commit that undoes a prior commit on your branch. Reverting becomes necessary if changes have been made that are no longer needed. For example, if you have committed
changes for a feature branch that is no longer going to be included in a release, then those changes
need to be reverted.
In the Source Control ribbon, the Branch History button displays your history of commits on the active Git branch. This dialog displays the history in descending order, with the most recent action displayed on the top line.

The following columns are displayed in the Commit history dialog:
n

Commit Type This indicates the type of changes checked in on the branch. You can view
when a branch was started, when a commit was made, or when a merge occurred.

n

Branches This column displays the branches that are affected by the action taken. If the
changes affect more than one branch then all of the affected branches are displayed in this
column.

n

Commit This alphanumerical code provides the commit number used by Git.
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n

Commit Time This displays the date, followed by the time the commit was made in your Git
branch.

n

Author This displays the name of the author that committed the specific change in the
branch.

n

Comments This column displays the comments made for each commit.

HOW TO REVERT COMMITS IN A GIT BRANCH
1. In the Source Control Explorer, select your branch containing changes that you want to revert.
2. In the Source Control ribbon, click Branch History. The Commit history dialog opens.

3. Select the row that contains the commit you want to back out.
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4. Click Revert.The Accept reverted modifications dialog is displayed.

5. Click Accept.
6. A confirmation message confirms the revert was successful. Click OK to close this dialog.
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Switching Branches
If you have created more than one branch, you can switch to, or select, the branch you want to work
with. When you switch to a new branch, you will see the files associated with that branch, and any
new commits will be sent to the selected branch. By default, the master branch is selected.
You can use branches so multiple authors can work in individual authoring spaces, or you can use
them as a space to make major changes in your document without affecting the original (e.g., when
documenting a new feature, rewriting large sections of a topic, or making layout changes).
Changing branches allows you to save your commits to a new development environment that is separate from the original. When you change branches, you can edit existing files or create new files.
When you commit your changes to the branch, they will not affect the files on your other branches.
There are three ways to switch branches:
n

Submenu Use this method if you already know which branch you want to use.

n

Branch Management Dialog Use this method if you want to perform additional management
tasks before switching to a branch.

n

Source Control Explorer Use this method if you want to pick a branch based on whether it is
published or unpublished.

WARNING: You should commit all of your current changes before switching branches. If
you have uncommitted changes when you switch branches, they will be lost.
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HOW TO SWITCH BRANCHES—SUBMENU
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the Project section, click the arrow under
Branch.

n

Right-Click If you have the Content Explorer, Project Organizer, Pending Changes window
pane, or File List open, right-click on any file and select Source Control > Project > Switch
Branch.

2. From the submenu, select the branch you want to use. If you do not have any pending modifications, your branch switches.

NOTE: Your current branch is marked in the submenu.
3. (Optional) If there are pending modifications on your current branch, a dialog asks if you want
to switch branches and discard your modifications. This is because the changes were made
on the current branch, and do not carry over when you switch branches.
n

Click Yes to switch branches. Your changes will be lost.

n

Click No to cancel the switch. Commit your changes before attempting the switch
again. See "Committing Source Control Files" on page 32.
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HOW TO SWITCH BRANCHES—BRANCH MANAGEMENT DIALOG
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the Project section select Branch.

n

Right-Click If you have the Content Explorer, Project Organizer, Pending Changes window
pane, or File List open, right-click on any file and select Source Control > Project >
Branch.

The Branch Management dialog opens.
2. In the All branches list, select the branch you want to switch to.
NOTE: Your current branch is shown at the bottom of the dialog.
3. Click Switch. If you do not have any pending modifications, your branch switches.
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4. (Optional) If there are pending modifications on your current branch, a dialog asks if you want
to switch branches and discard your modifications.
n

Click Yes to switch branches. Your changes will be lost.

n

Click No to cancel the switch. Click Close in the Branch Management dialog and commit your changes before attempting the switch again. See "Committing Source Control
Files" on page 32.

5. You will see the new branch's name in the Current branch field when the switch is complete.
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HOW TO SWITCH BRANCHES—SOURCE CONTROL EXPLORER
You can also switch branches using the Source Control Explorer. You can view a list of published
and unpublished branches in the Source Control Explorer, so this method is preferable if you want to
pick a branch by its publication status.
1. Select the View ribbon. In the Explorer section select Source Control Explorer. The Source
Control Explorer opens.
2. From the drop-down or the Home pane, select Branches.
The Branches pane opens. In the pane, you can see your current branch, as well as lists of
your published and unpublished branches.
3. Select the branch you want to switch to.
4. Click Select Branch. If you do not have any pending modifications, your branch switches.
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5. (Optional) If there are pending modifications on your current branch, a dialog asks if you want
to switch branches and discard your modifications. This is because the changes were made
on the current branch, and do not carry over when you switch branches.
n

Click Yes to switch branches. Your changes will be lost.

n

Click No to cancel the switch. Commit your changes before attempting the switch
again. See "Committing Source Control Files" on page 32.

6. You will see the new branch's name in the Current branch field when the switch is complete.

CHAPTER 11

92

Deleting Source Control Files
You can delete a topic or file that is bound to source control. This also removes the file from the current Git branch.

HOW TO DELETE A FILE
1. In one of the window panes (e.g., Content Explorer, File List, Project Organizer, Pending
Changes window pane), select the relevant file(s).
2. On your keyboard press DELETE.
3. The Delete dialog opens. Select the bound files you want to delete.
4. Click Delete. The files are removed from your project and from the source control repository.
Files that are deleted from projects bound to Git cannot be undeleted.
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Disabling the Get Latest Prompt for Source
Control
By default, when you open a project that is bound to source control, a message automatically asks if
you want to get the latest version of files. However, you can disable this prompt in the Options dialog. Therefore, in the future when you open the project you will no longer see the message, and the
project will open without replacing any local files with the latest ones from source control.

HOW TO DISABLE THE GET LATEST PROMPT FOR SOURCE CONTROL
1. Select File > Options. The Options dialog opens.
2. Select the Source Control tab.
NOTE: This tab will not be visible if your project is not yet bound to source control.
See "Binding a Project to Git" on page 20.
3. Click the check box Do not prompt to get latest when opening source control bound projects.
4. Click OK.

CHAPTER 11

94

Enabling Source Control Status Checks
If you are using source control integration in Flare, you can check for frequent status changes automatically. You can specify the number of minutes and seconds when you want Flare to ping the
source control repository and get status changes for files that have been committed, synchronized,
moved, deleted, etc. The upside of this feature is that you can ensure that the source control status
information is always up to date. The downside is that you may experience slower performance due
to this constant communication over the network.

HOW TO ENABLE SOURCE CONTROL STATUS CHECKS
1. Select File > Options. The Options dialog opens..
2. Select the Source Control tab.
NOTE: This tab will not be visible if your project is not yet bound to source control.
See "Binding a Project to Git" on page 20.
3. Click the check box Enable background status checks. A check mark in the box indicates that
the feature is enabled.
4. Enter the number of minutes and or seconds between each status update.
5. Click OK.

NOTE: If you elect to disable this feature (disabled is the default setting), you can manually
check for status updates by refreshing the Pending Changes window pane or Source Control Explorer. See "Viewing Modified Files" on page 113.

CHAPTER 11

95

Modifying Network Settings
You can view and change various source control network settings while working in Flare.

HOW TO MODIFY NETWORK SETTINGS
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the Project section select Network Settings.

n

Right-Click If you have the Content Explorer, Project Organizer, Pending Changes window
pane, or File List open, right-click on any file and select Source Control > Project > Network Settings.

n

Source Control Explorer From the View ribbon, open the Source Control Explorer. From
the drop-down, select the Home pane. Click Network Settings.

The Network Settings dialog opens.
2. In the Group field, select the group for which you want to change the settings.
OR
Do one of the following:
n

(Optional) If you want to add a custom group, type its name in the Group field, then click
Add.

n

(Optional) If you want to remove a group, select it from the Group field, then click
Remove.

3. (Optional) If you entered a custom group name, in the Remote Host field, enter the name of
the domain to which the network settings should apply.

CHAPTER 11

96

4. In the grid, make changes to the network settings as necessary. Click
by category, or click

to sort the settings

to sort them alphabetically.

GIT NETWORK SETTINGS
n

n

Cookies
l

Cookie File

l

Save Cookies

HTTP Proxy Options
l

n

Identity
l

n

n

Proxy Host

User Agent

Performance
l

Enable EPSV

l

Max Requests

l

Maximum High Latency Time

l

Min Sessions

l

Minimum Transfer Speed

l

POST Buffer Maximum

SSL Configuration
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SSL CA File

l

SSL CA Path

l

SSL Certificate

l

SSL Key File

l

SSL Password Prompt

l

Try SSL

l

Verify SSL
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NOTE: For more information about each of these settings, refer to:
https://git-scm.com/docs/git-config
5. Click Save.
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Publishing to Source Control
You can use Flare to directly publish your output to source control, rather than having to upload it to
source control separately. Publishing your output to source control is beneficial because it you can
keep previous versions of your output in source control and access them if necessary.
For more information about creating publishing destinations, see the online Help.

HOW TO PUBLISH OUTPUT TO SOURCE CONTROL
1. Create a new source control publishing destination, or select an existing source control publishing destination.
NOTE: When creating a new source control destination, be sure to select Source Control from the Type drop-down.
2. Assign the publishing destination to the target you want to publish.
3. Build and publish your output. Your output files will be published to the source control location
you specified in the destination.

CHAPTER 11

99

Reverting Modified Source Control Files
If you have modified files from source control but do not want to keep your modifications, you can
use the "Revert" option instead of committing the files. While committing the file would save your
changes to source control, reverting a file returns it to its previously committed state and does not
commit any of your new changes to source control. When reverting changes made in Git, you only
revert changes to the file on the branch you are currently editing. If you have a file that resides on
multiple branches, copies of the file on other branches are preserved.

HOW TO REVERT A SOURCE CONTROL FILE
1. In one of the window panes (e.g., Content Explorer, Source Control Explorer, File List, Project
Organizer, Pending Changes window pane), select the relevant file(s).
2. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the File section select Revert (for selected
files). Alternatively, in the Project section you can click Revert All (for all files in the project).

n

Right-Click If you have the Content Explorer, Project Organizer, Pending Changes window
pane, or File List open, right-click the files you want to revert and select Source Control >
Revert (for selected files) or Source Control > Project > Revert All (for all files).

n

Source Control Explorer With the Pending Changes pane open, select the files or folders
that you want to revert, right-click, and select Source Control > Revert. You can also click
Revert to revert all files in the Included Changes section.
NOTE: If you click Revert in the Source Control Explorer, you will not see any additional dialogs and the Revert process completes.

A dialog opens. The selected files are listed with check boxes next to them.
3. (Optional) If you want to see all files with pending changes (rather than only those you selected), click

.

4. Make sure to click the check box next to each appropriate file so that it contains a check
mark.
5. Click Revert.
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Rolling Back to an Earlier Version of a File
One of the benefits of Flare's integrated source control is that you can view the history and differences for a particular file. You can view code and content differences between two source control versions of the same file. This is useful if you need to roll back to an earlier version of a file.
See "Viewing the History of Source Control Files" on page 115 and "Viewing Differences in Source
Control Files" on page 111.

EXAMPLE
Let's say that you have been working on a particular topic for a few days. Each day you
pull the remote commits to your local database, make your changes, and commit and
push the file back to the remote repository at the end of the day. At a certain point, you
determine that you need to "roll back" to an earlier version of the file, using it to replace
the latest version. Therefore, you use this feature to view the highlighted differences
between the current version and an older version of the file. Once you have identified
the older version that you want to use, you can retrieve that version.

HOW TO ROLL BACK TO AN EARLIER VERSION OF A FILE
1. In one of the window panes (e.g., Content Explorer, Source Control Explorer, File List, Project
Organizer, Pending Changes window pane), select the relevant file(s).
OR
Open a file.
2. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the File section select View History.

n

Right-Click If you have the Content Explorer, Project Organizer, Pending Changes window pane, or File List open, right-click the file you want to roll back and select Source
Control > View History.

n

Source Control Explorer With the Pending Changes pane open, right-click the file you
want to roll back and select View History.

The History dialog opens.
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3. (Optional) View the differences between two versions of the file. This may help you decide
which version of the file you want to retrieve. (Another way is to look at the dates for each version in the History dialog.)
To view the differences, follow these steps.
a. Select the first file version from the list.
b. Hold the CTRL key and select the second file version from the list.
c. Click Show Differences. The Differences Editor opens to the right, showing content from
the backup file on the left and the current version of the file on the right.
d. In the local toolbar of the Differences Editor, you can click any of the following to make
adjustments.
n

Options Click this to open the File Differences dialog, which lets you change the colors used to display content differences between the files.

n

Show WYSIWYG Click this to switch from tag view to WYSIWYG (What You See Is
What You Get) view.
EXAMPLE
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n

Ignore Case Click this to ignore changes in case when viewing differences. This
option can be used in "text view" only; it is not available in WYSIWYG view.
EXAMPLE
If a word is not capitalized in the original file but it is capitalized in the
current file, this option does not highlight those differences.
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n

Ignore Whitespace Click this to ignore whitespace when viewing differences.
EXAMPLE
Let's say a paragraph is identical in both files, except for an extra space
that was added within the paragraph in one of those files. If you click
this option, that difference is not highlighted.
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e. When you are finished viewing the differences, close the window pane.
4. In the History dialog, select the version of the file to which you want to roll back.
5. Click Get Selected Version. That file is retrieved from the server and replaces the local copy
of the file in your project.
6. In the History dialog, click Close.
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Setting Color Options for Project File
Differences
If you are using Flare's integrated source control features, you can view differences between files in
various ways. One way is to view file differences between a local version of a Flare project and the
source control version.
When viewing file differences between a local version of a Flare project and the source control version, you can select color options to display the files. Color coding makes it easier to discern where
differences between files occur.
For more information see "Viewing Differences in Source Control Files" on page 111.

EXAMPLE
By default the files that are included only in your local copy are displayed as green in
the Differences Editor, and the files that are included only in source control are displayed in red. You can use this dialog to change the local-only files to blue and the
source control–only files to yellow.

HOW TO SET COLOR OPTIONS FOR PROJECT FILE DIFFERENCES
1. In one of the window panes (e.g., Content Explorer, Source Control Explorer, File List, Project
Organizer, Pending Changes window pane), select the relevant file(s).
OR
Open a file.
2. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the File section select Show Differences.

n

Right-Click If you have the Content Explorer, Project Organizer, Source Control Explorer,
Pending Changes window pane, or File List open, right-click the file you want to view and
select Source Control > Show Differences.

The Differences Editor opens.
3. In the local toolbar of the Differences Editor, click Options. The File Differences dialog opens.
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4. Change the text or background color for any of the difference types. To do this, simply click in
the appropriate Text or Background cell and select Pick Color. In the Color Picker dialog,
choose the new color.
5. Click OK.
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Unbinding a Project from Git
Use the following steps if you have previously connected your Flare project to Git but now wish to
unbind it (i.e., remove the connection).

HOW TO UNBIND A PROJECT FROM SOURCE CONTROL
1. Open the project.
2. Select the Project ribbon. In the Properties section select Project Properties. The Project
Properties dialog opens.
3. Select the Source Control tab.
4. Click Unbind Project.

HOW TO UNBIND A PROJECT FROM SOURCE CONTROL—SOURCE CONTROL
EXPLORER
1. Open the project.
2. Select the View ribbon. In the Explorer section select Source Control Explorer.
The Source Control Explorer opens.
3. From the drop-down or the Home pane, select Settings. The Settings pane opens.
4. Click Unbind. A confirmation dialog appears.
5. Click Yes.

IMPORTANT: If your project is dual-bound to MadCap Central and a third-party source control provider, unbinding the project from source control will also remove the binding to Central.
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Using an API to Integrate Source Control
If you are working with a source control application other than those directly supported in Flare (i.e.,
Microsoft Team Foundation Server, Perforce, Apache Subversion, Git), you can use the Microsoft
Source Code Control API (SCC API) to integrate that application with your Flare project.
The SCC API is an interface specification defined by Microsoft that defines the interface between
an application (in this case, Flare) and a source control provider (e.g., CVS, IBM Rational ClearCase),
providing hooks for a number of common source control operations (such as check out, check in,
get latest, and so on).
Many source control providers adhere to this interface as a standard for source control integration,
including (but not limited to) the following.
n

CVS

n

IBM Rational ClearCase

n

CS-RCS

n

Team Coherence

n

QVCS-Pro

If you are using a source control package that supports the Microsoft SCC API, install the plug-in
that is provided by that tool and follow any included instructions. This plug-in from your source control provider should be installed on the client machine (i.e., the computer that is running Flare). Once
you have done this correctly, you should be able to select that plug-in from the Flare interface
whenever you are asked to select a source control provider (e.g., when binding a project to source
control).

NOTE: It is not mandatory that you use the SCC API to use a source control application for
your Flare project files. It is only necessary if you want to take advantage of the source control integration features inside Flare. Otherwise, you can manually add your Flare project
files to any source control application.
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Viewing Differences in Source Control Files
One of the benefits of Flare's integrated source control is that you can view the history and differences for a particular file.

WAYS TO VIEW DIFFERENCES BETWEEN FILES
You can view differences between files in the following ways:
n

Two Versions of Same Source Control File (History/Roll Back) You can view code and content
differences between two source control versions of the same file. This is useful if you need to
roll back to an earlier version of a file.
EXAMPLE
Let's say that you have been working on a particular topic for a few days. Each day
you pull the remote commits to your local database, make your changes, and commit and push the file back to the remote repository at the end of the day. At a certain point, you determine that you need to "roll back" to an earlier version of the file,
using it to replace the latest version. Therefore, you use this feature to view the
highlighted differences between the current version and an older version of the
file. Once you have identified the older version that you want to use, you can
retrieve that version.

n

Local Versus Source Control Version of a File You can view code and content differences
between the local version of a file and the source control version of that file.
EXAMPLE
Let's say that you modify a procedure topic from source control and then add
some lines of text to your local copy of that topic file. You save your changes.
Later that day, you want to revisit the new content that you wrote, but you cannot
remember exactly which lines of text you added. Therefore, you use this feature to
highlight the text differences between your local version of the file and the version
stored in source control. The new lines of text are highlighted on the side displaying the local version of the file.
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HOW TO VIEW DIFFERENCES BETWEEN TWO VERSIONS OF THE SAME SOURCE
CONTROL FILE
1. In one of the window panes (e.g., Content Explorer, Source Control Explorer, File List, Project
Organizer, Pending Changes window pane), select the relevant file(s).
2. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the File section select View History.

n

Right-Click If you have the Content Explorer, Project Organizer, Source Control Explorer,
Pending Changes window pane, or File List open, right-click the file(s) you want to view
and select Source Control > View History.

The History dialog opens.
3. From the list, select the first file version that you want to compare.
4. Hold the CTRL key and select the second file version from the list.
5. Select Show Differences. The Differences Editor opens.
6. (Optional) In the Differences Editor, use the buttons in the local toolbar to customize the
information shown in the editor.
7. When you are finished viewing the differences, close the window.

HOW TO VIEW DIFFERENCES BETWEEN THE LOCAL VERSION OF A FILE AND THE
SOURCE CONTROL VERSION
1. In one of the window panes (e.g., Content Explorer, Source Control Explorer, File List, Project
Organizer, Pending Changes window pane), select the relevant file(s).
2. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the File section select Show Differences.

n

Right-Click If you have the Content Explorer, Project Organizer, Source Control Explorer,
Pending Changes window pane, or File List open, right-click the file(s) you want to view
and select Source Control > Show Differences.

The Differences Editor opens.
3. (Optional) In the Differences Editor, use the buttons in the local toolbar to customize the
information shown in the editor.
4. When you are finished viewing the differences, close the window.
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Viewing Modified Files
You can use the Pending Changes window pane and Source Control Explorer to view all of the files
that you have modified and need to commit.

HOW TO VIEW FILES THAT YOU HAVE MODIFIED—PENDING CHANGES WINDOW PANE
1. Select the Source Control ribbon. In the Changes section select Pending Changes.
The Pending Changes window pane opens.
2. (Optional) You can use the Filter field to limit the files that are displayed.
n

All Files Displays all files.

n

Topic Files Displays only the topic (HTM and HTML) files.

n

Master Page Files Displays only the master page (FLMSP) files.

n

Page Layout Files Displays only the page layout (FLPGL) files.

n

Snippet Files Displays only the snippet (FLSNP) files.

n

Stylesheet Files Displays only the stylesheet (CSS) files.

n

Image Files Displays only the image files.

n

Multimedia Files Displays only multimedia (audio, video, and 3D model) files.

n

GIF Files Displays only GIF files.

n

JPEG Files Displays only JPG and JPEG files.

n

PNG Files Displays only PNG files.

n

Flash Movie Files Displays only SWF files.

3. (Optional) You can use the following toggle buttons in the local toolbar to limit the files that
are displayed.
This filters the Pending Changes window pane to show or not show files that are out
of date.
This filters the Pending Changes window pane to show or not show files that have
been deleted.
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4. Take note of the Status column. (You may need to use the scroll bar to view this column.)
n

Status Displays the status of the file, such as whether you have modified the file.
l

l

Checked Out This indicates that the file has been modified. You can commit the file
when you are ready.
.Pending Add This indicates that you have a file in your project but have not yet
added it to Git. This might occur, for example, if you create a new topic and do not
add the file to source control during the topic creation process. To resolve this,
simply right-click on the file and select Source Control > Add

HOW TO VIEW FILES THAT YOU HAVE MODIFIED—SOURCE CONTROL EXPLORER
1. Select the View ribbon. In the Explorer section select Source Control Explorer.
The Source Control Explorer opens.
2. From the drop-down or the Home pane, select Pending Changes.
The Pending Changes pane opens. Files that you have changed appear in the Included
Changes or Excluded Changes section (depending on whether you are going to include or
exclude them in your next commit; see "Committing Source Control Files" on page 32). You
will not see other users' changes in the Source Control Explorer.
3. Take note of the file's status. The status is written in brackets next to the file name (e.g., edit,
add).

NOTE: You can click the refresh button
in the local toolbar to make sure you have
the most recent status for each file. Another option is that you can use a feature to
automatically ping the source control repository periodically, thus refreshing this
information frequently. However, you may experience slower performance with this
automatic status update option set.See "Enabling Source Control Status Checks" on
page 95.

CHAPTER 11

114

Viewing the History of Source Control Files
One of the benefits of Flare's integrated source control is that you can view the history for a particular file, including who committed the file and when it was committed. You can also view differences between different versions of the file and roll back to an older version if necessary.
For more information see "Viewing Differences in Source Control Files" on page 111 and "Rolling
Back to an Earlier Version of a File" on page 101.

HOW TO VIEW THE HISTORY OF A SOURCE CONTROL FILE
1. In one of the window panes (e.g., Content Explorer, Source Control Explorer, File List, Project
Organizer, Pending Changes window pane), select the relevant file(s).
OR
Open a file.
2. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the File section select View History.

n

Right-Click If you have the Content Explorer, Project Organizer, Source Control Explorer,
Pending Changes window pane, or File List open, right-click the file you want to view and
select Source Control > View History.

3. The History dialog opens. Following are explanations of the different parts of this dialog.
n

Version Displays a number for each version of the file. The lower the number, the older
the version. The higher the number, the more recent the version.

n

Users Displays the name of the user who has been working on the file.

n

Date Displays the date and time when the action has occurred.

n

Action Displays the action that has taken place for the file (e.g., modified).

n

Comment Displays the comment (if any) associated with the file. A comment can be
added to a file when you commit that file to source control. This enables you to maintain
an audit trail for the file's history.

n

Get Selected Version Retrieves a particular version of a file, thus rolling back to that version of the file. The local version of the file is replaced with the source control version
that you selected.

n

Show Differences Opens a dialog where you can view the differences between two versions of a file. If you select one row in the History dialog and view the differences, you will
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see the content differences between the version that you selected and the version of the
file in your local copy of the Flare project. If you select two files in the History dialog (by
holding down the CTRL key) and view the differences, you will see the content differences between those two versions of the file.
4. In the History dialog, click Close.
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APPENDIX

PDFs
The following PDFs are available for download from the online Help.
TUTORIALS

Getting Started Tutorial
Product Foldout Tutorial
Side Navigation Tutorial
Top Navigation Tutorial
Tripane and PDF Tutorial
USER GUIDES

Accessibility Guide

Getting Started Guide

Analysis and Reports Guide

Global Project Linking Guide

Architecture Guide

HTML Help Guide

Autonumbers Guide

HTML5 Guide

Condition Tags Guide

Images Guide

Context-sensitive Help Guide

Importing Guide

DotNet Help Guide

Index Guide

Eclipse Help Guide

Key Features Guide
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Language Support Guide

Source Control Guide: Git

MadCap Central Integration Guide

Source Control Guide: Perforce

Movies Guide

Source Control Guide: Subversion

Navigation Links Guide

Source Control Guide: Team Foundation Server

Plug-In API Guide

Styles Guide

Print-based Output Guide

Tables Guide

Project Creation Guide

Tables of Contents Guide

Pulse Guide

Targets Guide

QR Codes Guide

Templates Guide

Reports Guide

Topics Guide

Reviews & Contributions Guide

Touring the Workspace Guide

Search Guide

Transition From FrameMaker Guide

SharePoint Guide

Variables Guide

Skins Guide

WebHelp Outputs Guide

Snippets Guide

What's New Guide

CHEAT SHEETS

Folders and Files Cheat Sheet
Print Output Cheat Sheet
Shortcuts Cheat Sheet
Structure Bars Cheat Sheet
Styles Cheat Sheet

APPENDIX

118

