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CHAPTER 1

Creating a Project
Let's start by creating a new project based on the Product Foldout 3-Fold template.

CREATE A NEW PROJECT
1. Select File > New Project. The Start New Project Wizard opens.
2. In the Project name field, name your project My Foldout.
3. (Optional) In the Project folder field, you can enter a location where you want to save your project. By default, projects are saved in your Documents > My Projects folder.

4. Click Next.

CHAPTER 1

5

5. Under Factory Templates, expand the Print folder. Select the Product Foldout 3Fold template.

6. Click Next.
7. Click Finish. The project is created and loaded into Flare.
For more information about using this wizard, see the online Help.
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CHAPTER 2

Creating Page Layouts
Page layouts are used to configure the pages for print-based output and are especially important in
this particular template because of its unique characteristics (e.g., multiple columns, images in the
middle of columns, color and images that bleed off the page). This template comprises only two topics—one for the front of the product foldout and the other for the back of the foldout. Therefore two
page layouts are required—one to be associated with each topic.
When you go through the following steps, you will see that two page layouts already exist in the project, and they're already completely edited. If you want, you can open these files and take a look
around to see what you will be producing in the end. You can also build one of the targets in the project to see how these page layouts are incorporated into the output.
In the following sets of steps, we will create two new page layouts, replicating the look and substance of the existing page layouts.
This chapter discusses the following:
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Front Page Layout

8

Back Page Layout

42
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Front Page Layout
The existing front page layout in the project is simply named "Front." We'll give our new page layout
a slightly different name.

CREATE A PAGE LAYOUT FILE
1. In the Content Explorer, expand the Resources folder, then expand the PageLayouts folder.
Notice the existing two page layouts (Back and Front).
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2. Right-click the PageLayouts folder, and from the context menu select New > Page Layout.

The Add File dialog opens.
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3. Under the Factory Templates, select the Default template, because it is quite simple and
requires fewer changes than other templates.

4. In the File Name field at the bottom of the dialog, type Front2 as the name for the new page
layout.
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5. Click Add. The page layout is added to the Content Explorer, and the Page Layout Editor opens
to the right, displaying the page layout.

6. Before we continue with the rest of the steps for editing the page layout, let's make one quick
change in it.
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7. Click the header frame (the rectangle) at the top of the page layout and press Delete on your
keyboard.

8. Click

to save your work.

For more information about adding page layout files, see the online Help.
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SET PAGE SIZE AND MARGINS
Now that we have created our first page layout, we will start making changes to it. To begin, we will
adjust the page size and margins.

1. In the local toolbar of the Page Layout Editor, click
down arrow).

(click the face of the button, not the

The Page Properties dialog opens.
2. Select the General tab.
3. Click the Page Size drop-down and select (custom).
4. In the Custom Width field, enter 15, and for the unit of measurement select Inch (in).
5. In the Custom Height field, enter 5, and for the unit of measurement select Inch (in).
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6. Keep the Orientation field set to Portrait.
7. In all of the Margins fields, enter 0.

NOTE: You can set some value for the margins on your page if you want. However, in
our template we chose to set them all to 0 and specify the margins on our CSS styles
instead.
8. Click OK.
9. Click

CHAPTER 2

to save your work.
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10. Because the view of the page layout is so large, it is difficult to see what's going on so far.
Therefore, in the local toolbar, click View and select Fit Width. The page layout is zoomed out
so you can see all of it.

For more information about specifying the page size and margins, see the online Help.
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CREATE PANELS—BODY FRAME WITH COLUMNS
Now that we've resized the page layout, we're going to divide it into three equal panels, which will
serve as the natural locations where the printed output can be folded. We will do this by creating
columns in our body frame.
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1. In the Page Layout Editor, double-click the body frame.

The Frame Properties dialog opens.
NOTE: An alternative is to simply click and drag the body frame, and its edges, until
you have it placed just where you want it on the page. However, in this exercise, we'll
use the Frame Properties dialog, because it's easier to get the precise size and position that you see in the template.
2. Select the Frame tab.
3. We want to set the size and position of the body frame so that it fits exactly on top of the
page. So in the Size and Position section, click in the Width field, enter 15, and for the unit of
measurement select Inch (in).
4. In the Height field, enter 5, and for the unit of measurement select Inch (in).
5. In the Padding section, click in the Left field, enter 10, and for the unit of measurement select
Pixel (px).
NOTE: This is optional; you can set it to 0 if you like.

CHAPTER 2

17

6. In the rest of the fields on the tab, enter 0.

7. Select the Columns tab.
8. In the Count field, enter 3.
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9. In the Gap field, enter 0.

10. Click OK.
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11. Click

to save your work. The page layout should now look something like this:

For more information about editing the frame size and columns, see the online Help.
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SET BLEED SIZE
Next, we're going to set the bleed size. The bleed is the area beyond the edge of the page where
printing occurs. Professional printers use the bleed to prevent a final trimmed document from having unprinted areas along the edge of the document.
1. In the local toolbar of the Page Layout Editor, select View > Bleed. Now you can see the bleed
area in the editor.
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2. In the local toolbar of the Page Layout Editor, click
down arrow).

(select the face of the button, not the

The Page Properties dialog opens.
3. Select the Print Marks tab. This lets us set the size of the bleed area.
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4. In all of the fields, enter 0.25 and for the unit of measurement select Inch (in).

NOTE: You can certainly keep the default setting of 0.50 in. We simply changed it in
our template because 0.25 in is the industry standard. The most important thing is to
make sure the bleed area is large enough. Ideally, it should be no less than 0.125 in.
5. Click OK.
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6. Click

to save your work. The page layout should now look something like this:

For more information about the bleed, see the online Help.
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CREATE FOOTER FRAME
In addition to the large body frame that is divided into three columns, we want to add a footer frame,
which will display page numbers and decoration images.
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1. In the Page Layout Editor, double-click the footer frame. You will need to scroll down in the
Page Layout Editor to find it if you started out with the Default page layout and then resized
page according to the previous steps. You will see a small rectangle with the word "footer."
That's the label at the bottom-right of the footer frame; double-click that.

The Frame Properties dialog opens.
NOTE: An alternative is to simply click and drag the footer frame, and its edges, until
you have it placed just where you want it on the page. However, in this exercise, we'll
use the Frame Properties dialog, because it's easier to get the precise size and position that you see in our template.
2. Select the Frame tab.
3. In the Size and Position section, click in the Top field, enter 424, and for the unit of measurement select Pixel (px).
4. Click in the Width field, enter 1440, and for the unit of measurement select Pixel (px).
5. Click in the Height field, enter 44, and for the unit of measurement select Pixel (px).
6. In the Anchors section, click in the Bottom field, enter 12, and for the unit of measurement
select Pixel (px).
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7. In the rest of the fields on the tab, enter 0.
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8. In the lower-right corner of the tab, click the left, right, and bottom arrow so that it looks like
this:

These anchors are useful in case you decide to resize the entire page at some point. When
the page is resized, the footer frame will maintain its same distance from the left, right, and
bottom edges of the page because they are anchored.
9. Select the Alignment tab.
10. Set the Vertical Alignment to Middle.
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NOTE: This is purely optional. You do not need to specify how content is aligned in
the frame. In our template, we decided to align the content in the middle of the frame
vertically.
11. Click OK.
12. The footer frame should now be repositioned and selected on the page.

But we need to bring it up to the top level so that it's easy to work with and so that no content
obscures the decoration images or page numbers that we'll place in the footer. So in the local
toolbar, select Layout > Depth > Float To Top.
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13. Now let's add content to the footer frame. With the frame selected, press F2 on your keyboard.
14. In the dialog asking if you want to insert a page number, click No. The Frame Editor opens at
the bottom of the workspace.
15. Select the Table ribbon.
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16. On the far left of the ribbon, click the face of the Insert Table button.

The Insert Table dialog opens.
17. Select the General tab.
18. In the Number of columns field, enter 3.
19. In the Number of rows field, enter 1.
20. In the Number of header rows and Number of footer rows field, enter 0.
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21. In the AutoFit Behavior section, select Fixed column width, and click the field to the right.
From the upper-right corner of the small popup, you’ll need to select Length first. Then complete the value and unit of measurement fields. Enter 33.333 as the value (an equal percentage for each of the three columns in the table), and choose % as the unit of
measurement. Then click OK in the popup.

22. Click OK.
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23. In the Frame Editor at the bottom of the interface, add content to the first column of the table:
a. In the first table cell insert three circle images, each separated by a space (in our template, the image is named "FooterCircleBlack"). For more about inserting images, see the
online Help.

b. Resize the images you inserted. In the existing page layout, we resized ours to a maximum width of 30px. You can do this by applying a style to the images, or you can rightclick on each image, choose Image Properties, select the Size tab, and edit the Maximum
Size Width. For more about resizing images, see the online Help.
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c. Apply a style to the paragraph in that cell. To do this, click in that cell, select the Table ribbon, and in the Cells section, click Cell Content Style.

Then in the Table Cell Content Style dialog, select p.FrameFooterImagesRight. This is a
style class we created in the template to align the decoration images to the right. We will
cover styles in more detail in a later lesson (see "Creating Styles" on page 89). Click OK.

CHAPTER 2

34

It should now look like this:

24. Add content to the second column of the table:
a. Type the number 2 to represent page 2. In our template, we did not use a page variable—
like we would normally do in a page layout—because we're dealing with columns within a
single page, rather than one page number per page. Besides, the product foldout only has
six panes total, so typing the page numbers is not an issue.
b. Select the Table ribbon, click Cell Content Style, and select p.FrameFooterTextLeft.
Then click OK.
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The number will be bigger and aligned to the left of the table cell.

25. Add content to the third column of the table:
a. Type the number 3 to represent page 3.
b. Select the Table ribbon, click Cell Content Style, and select p.FrameFooterTextRight.
Then click OK.
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This formats the number and aligns it to the right in the cell.

26. Click

to save your work.

27. (Optional) You can close the Frame Contents window pane by clicking the X in the upper-right
corner.
For more information about editing footer frames, see the online Help.
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SET BACKGROUND IMAGE
The front page layout is almost finished, but we want to add a background image to it. Flare allows
you to add one background image to the entire page layout and one background image in each body
frame. We're going to add one image to the background of the page layout in order to use it as a
watermark, appearing behind all of the content added in the topic.

Another thing to keep in mind with page layouts is the dots per inch (DPI) of images. For print-based
output, you ideally want images with high DPI settings. A DPI of 300 is recommended if possible, but
sometimes you need to use an image with a lower DPI so that you can display it at the right size.
The best practice is to start out with a very large image with a high DPI. When it is added to the
Page Layout Editor, it appears to shrink because you've told Flare to display it at 300 DPI (or another
high DPI setting). The larger the DPI, the smaller it's going to be displayed in the Page Layout Editor
and in the output.
1. In the local toolbar of the Page Layout Editor, click
down arrow). The Page Properties dialog opens.

(click the face of the button, not the

2. Select the Background tab.
3. In the Image section, click Browse.
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4. Under the Resources > Images folder, select Image1.eps. Click OK when you are done.

5. In the Repeat field, select No repeat.
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6. In the Position section, click in the X field and enter -200px. This positions the image 200
pixels left horizontally.

NOTE: It's not uncommon to play with different values in the Position fields until you
get the image placed just where you want it.
7. Click OK. Because this image was set in the background of the entire page layout, and the
image is larger than the page, it bleeds beyond the edge of the page. If instead we had set the
image in the background of a frame, it would stop at the edge of that frame.
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8. Click

to save your work. It should now look like this:

For more information about backgrounds in page layouts, see the online Help.
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Back Page Layout
In the Content Explorer, make a copy of the Front2 page layout and name it Back2 .

After that, complete the following sets of steps for the Back2 page layout.
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CREATE PANELS—BODY FRAMES
In the Back2 page layout file, we're going to use two body frames, instead of just one. We're going to
split the second body frame into two columns and set a background color on it.

1. Open the Back2 page layout file.
2. In the Page Layout Editor, you can select View > Fit Width to see the entire layout better.
3. Double-click the body frame. The Frame Properties dialog opens.
4. Select the Frame tab.
5. In the Width field, enter 480, and for the unit of measurement select Pixel (px).
6. In the Height field, enter 480, and for the unit of measurement select Pixel (px).
7. In the Anchors section, click in the Right field, enter 960, and for the unit of measurement
select Pixel (px).
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8. In the rest of the fields on the tab, enter 0.

9. Select the Columns tab.
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10. In the Count field, enter 1.
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11. Click OK.

You'll probably notice that the frame still has a background image from the front page layout.
Don't worry about that right now; we'll fix that in another set of steps.
12. In the Page Layout Editor, click on the body frame and press CTRL+C, then CTRL+V on your
keyboard to make a copy of it.
13. Double-click the new body frame, which should be on top of the first body frame. The Frame
Properties dialog opens.
14. Select the Frame tab.
15. In the Size and Position section, click in the Left field, enter 480, and for the unit of measurement select Pixel (px).
16. In the Width field, enter 10, and for the unit of measurement select Inch (in).
17. In the Height field, enter 5, and for the unit of measurement select Inch (in).
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18. In the Padding section, click in the Left field, enter 10, and for the unit of measurement select
Pixel (px).
NOTE: This is optional; you can set it to 0 if you like.
19. In the rest of the fields on the tab, enter 0.

20. Select the Columns tab.
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21. In the Count field, enter 2.

22. Select the Background tab.
23. In the Color section, select Solid.
24. In the Fill Start field, click the down arrow and select More Colors
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25. In the Color Picker dialog, highlight the number the # field and replace it with 4E4D4E.
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26. In the Color Picker dialog, click OK.

27. In the Frame Properties dialog, click OK.
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28. Click

to save your work. The back page layout should now look like this:

For more information about editing the frame size, columns, and backgrounds, see the online Help.
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CREATE DECORATION FRAME
For the second body frame in the back page layout, we have a background color. Because we anticipate this being printed on white paper, we need to make sure the color extends into the bleed
area.
One solution is to click and drag the body frame so that it extends into the bleed area. But that
means adjusting our styles to prevent topic text from moving into the bleed area.
Instead, we are going to create a decoration frame with the same background color. We will position this decoration frame around (and behind) the second body frame.
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1. In the local toolbar of the Page Layout Editor, click the down arrow next to the New Frame button

and select New Decoration Frame Mode.

2. Click on the page and draw a rectangle. It doesn't matter how big it is or where you draw it.
3. Double-click that frame. The Frame Properties dialog opens.
4. Select the Frame tab.
5. Set the fields as follows:

SIZE AND POSITION
n

Left 480 px

n

Top -0.25 in

n

Width 10.25 in

n

Height 5.50 in
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ANCHORS
n

Right -0.25 in

n

Bottom -0.25 in

PADDING
n

Left 0

n

Right 0

n

Top 0

n

Bottom 0

6. Select the Background tab.
7. In the Color section, select Solid.
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8. In the Fill Start field, click the down arrow and select More Colors
9. In the Color Picker dialog, highlight the number the # field and replace it with 4E4D4E (this
matches the background of the second body frame).
10. In the Color Picker dialog, click OK.
11. In the Frame Properties dialog, click OK.
12. Now we just need to make sure that the decoration frame is behind the body frame. So click
on the decoration frame in the Page Layout Editor.
13. In the local toolbar, select Layout > Depth > Sink To Bottom.
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14. Click

to save your work. The layout should now look like this:

For more information about frames, see the online Help.
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CREATE FOOTER FRAME
Next, we need to make some changes to the footer frame so that it looks good with the dark background.

1. In the Page Layout Editor, select the footer frame and press F2 on your keyboard. The Frame
Editor opens so that we can change the content in the three-column table.
2. In the first column of the table, right-click the circle image on the far right, and in the context
menu select Image Properties.
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3. In the Image Properties dialog, find and select the FooterLogoBlack.eps file.

4. Click OK.
5. Place your cursor in the first cell (not selecting an image).
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6. Select the Table ribbon, click Cell Content Style, and select p.FrameFooterImagesLeft. Then
click OK.

This aligns the images to the left in the cell.

7. In the second column of the table, replace the number 2 with 4 to represent page 4.
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8. Select the Table ribbon, click Cell Content Style, and select p.FrameFooterTextDarkBackgroundLeft. Then click OK.

This formats the number and aligns it to the left in the cell.

9. In the third column of the table, replace the number 3 with 5 to represent page 5.
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10. Select the Table ribbon, click Cell Content Style, and select p.FrameFooterTextDarkBackgroundRight. Then click OK.

This formats the number and aligns it to the right in the cell.

11. Click

to save your work.

12. (Optional) You can close the Frame Contents window pane by clicking the X in the upper-right
corner.
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13. We need to make sure the footer frame is on the top level so that it's easy to work with and so
that no content obscures the decoration images or page numbers. So in the Page Layout
Editor, click on the footer frame (you will need to do this on the left side of the layout, where
the decoration images are shown). Then in the local toolbar, select Layout > Depth > Float To
Top.
14. Click

to save your work. It should now look like this:

For more information about editing footer frames, see the online Help.
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SET BACKGROUND IMAGE
If you've been following the steps up until now—copying the Front page layout and making changes
to it—you should see a background logo image in the back page layout, which we will replace with a
different image of a Flare box.

1. In the local toolbar of the Page Layout Editor, click
arrow). The Page Properties dialog opens.

(the face of the button, not the down

2. Select the Background tab.
3. In the Image section, click Browse.

CHAPTER 2

63

4. In the Insert Image dialog, choose Image3.png, and click OK.

5. In the Repeat field, select No repeat.
6. In the Position section, click in the X field and enter -30px.
7. In the Y field, enter -44px.

8. Click OK.
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to save your work. The back page layout should now be complete, and it should look
9. Click
like this:

For more information about backgrounds in page layouts, see the online Help.

CHAPTER 2

65

CHAPTER 3

Creating Topics
Now that you've created a front and back page layout, you can create a front and back topic to go
with each.

CREATE NEW TOPICS
1. In the Content Explorer, right-click the root Content folder, and from the context menu select
New > Topic.

The Add File dialog opens.
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2. Under the Factory Templates, select the NewTopic.htm template.

3. In the File Name field, type Front2 as the name for the first new topic.
4. Click Add. The topic is added to the Content Explorer, and the XML Editor opens to the right,
displaying the topic.
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5. Follow the same steps above to create another topic, except name the second topic Back2.
Now you have two new topics to go with the existing "Front" and "Back" topics.

Currently, both new topics look rather plain when you open them. But that will soon change
after you associate the topics with the two page layouts that you've already created. Also,
additional content and some styles will help bring the topics together.
For more information about topics, see the online Help.
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CHAPTER 4

Adding Content to Topics
Adding your own content to your topics is relatively simple. But because the output is print-based,
and a bit unique, there are a few things to keep in mind as you work in the XML Editor.
This chapter discusses the following:
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Inserting Variables and Adding Text
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Layout Modes and Style Mediums
The way it is displayed in the XML Editor depends on the layout mode that is selected, as well as the
medium. This is especially important with this template, because you really need to see the approrpriate page layout as you add content. If you are looking at a topic in Web Layout mode, you won't
see this and it will be more difficult to work.

SELECT THE CORRECT LAYOUT MODE
1. If your topic is not already shown in the XML Editor, open the Content Explorer and doubleclick Front2.
Chances are pretty good that your topic will initially be displayed in Web Layout mode with the
default medium, like this:
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2. Click the Layout (Web) drop-down and select Print Layout.

The look of the topic changes to this:

This is the Back page layout (not the one you created, but the original page layout that came
with the template). It is being shown because it is the first page layout listed alphabetically in
the Content Explorer.
But what you really need is the Front2 page layout that you created.
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3. In the local toolbar click the Page Layout drop-down and select Front2.flpgl, and in the flyout
menu select Normal (the name of the only page in that layout).

The display changes, showing the correct page layout:
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Also, notice that the medium selected is print.

This happened automatically when you switched from Web Layout mode to Print Layout
mode. Flare anticipated that you might create both online and print-based output from your
project, and the default medium is typically used for online output while the print medium is
used for print-based output.
4. In the Content Explorer, double-click Back2.htm.
5. If the topic displays in the wrong mode, click the Layout (Web) drop-down and select Print Layout.
The topic displays with the original Back.flpgl page layout. It looks correct, but lets sync it with
the new page layout you created.
6. In the local toolbar click the Page Layout drop-down and select Back2.flpgl, and in the flyout
menu select Normal (the name of the only page in that layout).
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Inserting Variables and Adding Text
In this template, we've created some variables. On the first panel of the foldout, we used them for
the company name and the title. We also used them for company information (e.g., address) on the
back of the foldout. Variables can be useful if you plan to use the same page layout for multiple outputs. For one target you can use the default definitions for the variables, and you can override the
variable definitions for any of the other targets you might generate. For more about variables and
overriding definitions in targets, see the online Help.

INSERT VARIABLES AND TEXT IN THE FRONT TOPIC
1. In the XML Editor, click the Front2.htm topic tab to bring it to the front.

2. In the Front2 topic, delete the heading and paragraph that were added to the topic when you
created it.
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3. With you cursor at the top of the first panel in the topic, click the face of
bar.

in the local tool-

The Variables dialog opens.
4. With the General variable set selected on the left side, choose the CompanyName variable.

5. Click OK. The variable is inserted into the topic.
6. Press Enter to create a new paragraph and click
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again.

75

7. This time select the Title variable.

8. Click OK. The variable is inserted into the topic.
9. Press Enter again to create a new paragraph.
10. In the Content Explorer, double-click Front.htm, the original topic included in the template.
11. If necessary, click the Layout (Web) drop-down in the local toolbar and select Print Layout.
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12. Rather than making you type all of the text in the new topic, we'll just copy and paste it from
the original topic. Highlight all of the text, starting with the first Heading to the last paragraph.

13. Press CTRL+C on your keyboard to copy it.
14. Go back to your Front2.htm topic.
15. Place your cursor on the empty paragraph, and press CTRL+V on your keyboard to paste the
copied text. Notice that the styles associated with the text were also retained, so we won't
need to re-apply the styles to that text.
The topic should look something like this:

16. Click
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INSERT VARIABLES AND TEXT IN THE BACK TOPIC
1. Click the Back2.htm tab to bring it to the front.

2. Delete the heading and paragraph that were added to the topic when you created it.
3. Type the following:
This is the Back Panel
4. Press Enter to create a new paragraph.
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5. In the local toolbar, click the face of

.

The Variables dialog opens.
6. With the General variable set selected on the left side, choose the CompanyName variable.
7. Click OK. The variable is inserted into the topic.
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8. Repeat these these last few steps to insert the StreetAddress and CityStateZip variables in
paragraphs below the first one. Then press Enter after the last variable and type the following:
www.madcapsoftware.com
The top-left part of the topic should look like this when you are finished:

9. We're going to do the same thing that we did with the other topic, copying text from the original back topic. In the Content Explorer, double-click Back.htm.
10. If necessary, click the Layout (Web) drop-down in the local toolbar and select Print Layout.
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11. Highlight all of the text, starting with the first Heading to the end of the example in the third
panel.

12. Press CTRL+C on your keyboard to copy it.
13. Go back to your Back2.htm topic.
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14. After the text www.madcapsoftware.com, press Enter to create a new paragraph. Then press
CTRL+V on your keyboard to paste the copied text. Notice that the styles associated with the
text were also retained, so we won't need to re-apply the styles to that text.
The topic should look something like this:

15. Click
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Inserting and Positioning Images
We've added all of the content into both topics, except for a couple of images. In the page layouts
we set images in the background. In our topics, however, we are going to insert them directly into
the content and then use absolute positioning to drag them where we want.

INSERT AND POSITION AN IMAGE IN THE FRONT TOPIC
1. Open the Front2.htm topic.
2. In the Content Explorer, expand the Resources folder, then expand Images under it.
3. Click the Image2.png file, then drag and drop it at the very beginning of the topic in the XML
Editor.
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4. Hover over the image, and in the lower-right corner of the image, click the resize icon
drag it up and to the left to reduce the size of the image until you like it.
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5. Right-click the image, and from the context menu select Text Wrap > Square.

6. Hover over the middle of the image until the cursor changes to a cross. Then click and drag
the image, dropping it between the second and third panels. You might need to resize the
image again until it is positioned between the text just the way you want.
When you are finished, the topic should look something like this:

7. Click
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INSERT AND POSTITION AN IMAGE IN THE BACK TOPIC
1. Open the Back2.htm topic.
2. In the Content Explorer, click the Image4.png file, then drag and drop it at the very beginning
of the heading in the second panel. We did not drag it to the beginning of the topic this time,
because this topic is using two frames in the page layout, rather than one. And we want to
make sure it is inserted into the second frame.

and drag it
3. (Optional) In the lower-right corner of the image, you can click the resize icon
up and to the left if you want to reduce its size. But this image is smaller, so you may not need
to.
4. Right-click the image, and from the context menu select Text Wrap > Square.
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5. Hover over the middle of the image until the cursor changes to a cross. Then click and drag
the image, dropping it above the heading in the second panel until it is positioned the way you
like.
When you are finished, the topic should look something like this:

6. Click
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MORE INFORMATION
You might find that you require more space to include all of the content that you want. In that case,
you probably want to use one of the other Product Foldout templates that contains more panels
(i.e., 4-Fold, 5-Fold, 6-Fold, 12-Fold).

For more information about the different kinds of content you can add, see the online Help.
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CHAPTER 5

Creating Styles
You are almost finished. The page layouts, topics, and TOC have been created. And you've added all
of the content to the topics. Most of the content is already using the appropriate styles, but there
are a few pieces in the topics that still need to be formatted.
All of the styles you need already existing in the stylesheet in the template. But we're going to show
you how we created a few of the styles so you can see how it is done.
This chapter discusses the following:
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Creating Styles
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Identifying Styles
Before we create new styles, we want to show you how to identify existing styles. If you've ever
looked at a section of content and thought, "I wonder how they got it to look like that," you can easily
find out. It's just a matter of knowing where to look.
1. Open the Back2.htm topic.
2. In the third panel, locate the bulleted list and click in it somewhere.
3. Look to the far left side of the XML Editor and notice the structure bars. If the tag block bars
are not shown to the left of the content, click

at the bottom of the editor.

The structure bars that are related to the list are those with the ul and li labels. The ul structure bar represents the list as a whole, and each li bar represents an item in that list.
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4. Now look above the topic. You should see a span bar. If your span bars are not turned on, click
at the bottom of the editor.
Span bars represent formatting that is done inline. In our list, we have some text at the beginning of each item that is shown in light green. Each of these is using a span style.
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5. Let's investigate the ul and li styles first. Right-click the ul structure bar and select Style Class
> Edit Style Class.

The stylesheet opens and automatically selects the style class. In this case, the style class is
named "ul.DarkBackground."
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6. In the local toolbar, make sure the first button displays

. If the button displays

instead, then click it.

7. In the local toolbar, click
to an alphabetical list.
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8. On the right side of the local toolbar, click the Show drop-down field and select Show: Set Properties. This filters the properties below to only those that have been explicitly set in the
stylesheet for the selected style, as well as any properties explicitly set in an inherited
stylesheet.
As you can see, only two properties were set on this style. One points to a small image that
serves as the bullet. The other property sets the left margin at 60 pixels.

But there is one other style to look at. Notice that the text is very light so that it shows up on
the dark background. This was caused by a generic style class, which is a class that is not
associated with any parent style.
In this example, the class we've looked at is called "ul.DarkBackground." A generic class with
the same name (.DarkBackground) also exists in the stylesheet.
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9. In the list of styles, expand (Generic Classes), and click DarkBackground. The property set for
that class (a light gray color) is shown to the right.

10. Scroll down the list of styles until you find li, and click on it. The properties to the right show
what has been set for the individual list items.

11. Now you know how the list was designed. So let's take a look at the inline formatting that created the light green text at the beginning of the list items. Go back to the Back2.htm topic.
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12. With your cursor still placed in the list, right-click the span bar above the topic, and from the
context menu select Style Class > Edit Style Class.

The stylesheet opens with the relevant style class selected. In this case, it is a class called
"span.Light." And its property settings are shown to the right. You can see that it has a light
green color and the font is bold.

You can use these steps to identify settings for any styles you find in the Front and Back topics.
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Creating Styles
Let's re-create a couple of the style classes that are used in this template. If you look at the original
Front topic, you will see that the first two paragraphs (which have variables) are designed to look differently than a normal paragraph. There is more space above the first paragraph, and the second
paragraph is larger with a green font.
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We are going to create duplicate style classes that we will apply to our front topic.
1. In the upper-left corner of the Stylesheet Editor, click in the drop-down field and select
.
2. On the left side of the Stylesheet Editor, select the p style.
3. In the local toolbar, click Add Selector.

4. In the New Selector dialog, click in the Class Name field and type the following:
ManualTitle1New
5. Click OK. The new class is added under the p style and is selected.
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6. On the right side of the local toolbar, click in the Show drop-down field and select Show: All
Properties. This displays all of the available properties below.

7. Scroll down the list of properties until you find each of the following properties, and give them
the values shown.
n

column-break-before always

n

font-family Century Gothic

n

font-size 9pt

n

margin-bottom 0

n

margin-left 50px

n

padding-top 80px

8. Click

to save your work.

9. In the local toolbar, click Add Selector.
10. In the New Selector dialog, click in the Class Name field and type the following:
ManualTitle2New
11. Click OK. The new class is added under the p style and is selected.
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12. In the list of properties, set the following for the new style class:
n

color #bed230

n

font-family Century Gothic

n

font-size 22pt

n

line-height 0

n

margin-bottom 0

n

margin-left 50px

n

margin-top 0

13. Click

to save your work.

For more information about styles and creating them, see the online Help.
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CHAPTER 6

Applying Styles
Now we are going to apply styles to the remaining content in our topics that need it. In addition to
previously existing styles, we will also apply the two new style clases you created.
This chapter discusses the following:
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Apply Styles to the Front Topic
Most of the work is already done in the front topic, but we need to apply styles to the first two paragraphs, which serve as the cover for the foldout.
1. Select the Home ribbon, and in the Styles section click Style Window. The window pane opens
on the right side of the interface.

2. Open the Front2.htm topic.
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3. Click in the first paragraph, where the "CompanyName" variable is inserted. Do not select the
variable itself, but rather click either right before or after it. Notice that the Styles window populates with all of the styles that you are allowed to select.
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4. In the Styles window pane, scroll down and select ManualTitle1New, the first style class you
created.
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In the topic, the first paragraph is formatted, with extra space above and to the left of it.

5. Click in the second paragraph, just before or after the variable.

CHAPTER 6

105

6. In the Styles window pane, select p.ManualTitle2New, the second style class you created.
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In the topic, the second paragraph is formatted accordingly.

7. Click
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Apply Styles to the Back Topic
In the other topic, we are going to apply styles that previously existed in the stylesheet.
1. Open the Back2.htm topic.
2. Use the same steps above to apply the following styles to the first four paragraphs in the
Back2 topic:
n

This is the Back Panel Apply the p.BackPanel style class.

n

CompanyName Variable Apply the p.CompanyInfo1 style class.

n

StreetAddress Variable Apply the p.CompanyInfo2 style class.

n

CityStateZip Variable Apply the p.CompanyInfo2 style class.

n

www.madcapsoftware.com Apply the p.CompanyInfo2 style class.

CHAPTER 6

108

The first panel in the Back2 topic should look something like this when you are finished:

3. Click

to save your work.

For more information about applying styles, see the online Help.
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CHAPTER 7

Creating a TOC
At this point you've got two page layouts and two topics with similar names. Now we're going to tie
them together so that the Front2 topic uses the Front2 page layout, and the Back2 topic uses the
Back2 page layout. This is accomplished in a table of contents (TOC) file.
It might seem strange to be creating a TOC for a very short product foldout such as this. But remember, for print-based output (which is what you will be creating here), TOC files function as outlines,
not as traditional TOCs.
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CREATE A TOC
1. Open the Project Organizer on the left side of Flare, and expand the TOCs folder. Notice the
file under it called "ProductFoldout." This is a TOC file—or, more accurately, an "outline TOC"—
which was created for the existing Front and Back topics and page layouts. We're going to create another TOC just like this for the Front2 and Back2 files.

2. Right-click the TOCs folder, and from the context menu select Add Table of Contents. The
Add File dialog opens.
3. The only factory TOC template should already be selected, so in the File Name field, type ProductFoldout2 as the name for the new TOC.
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4. Click Add. The TOC is added to the Project Organizer, and the TOC Editor opens to the right,
displaying the TOC.

5. Open the Content Explorer.
6. Click the Front2 topic, then drag and drop it in the TOC Editor, above the two books. When you
see a blue arrow, you will know that it can be dropped.
7. Click the Back2 topic, then drag and drop it in the TOC Editor, below Front2.
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8. Click on each of the books and press Delete on your keyboard to remove them from the
editor.
You can also change the blue text (created by system variables) for each of the TOC entries
to reflect each topic. To do this, click on one of the entries, press F2, then replace the variable
syntax with whatever you like. The TOC should now look something like this:

What you've added to the TOC Editor are not the topics themselves, but rather a link to each
topic. Now we've got to provide a link to the relevant page layouts.
9. In the TOC Editor, double-click the Front2 entry. The Properties dialog opens.
10. Select the Printed Output tab.
11. In the Break Type field, select Page Layout Break.
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12. Click the Page Layout drop-down and select Front2.

13. Click OK.
14. In the TOC Editor, double-click the Back2 entry. The Properties dialog opens.
15. In the Break Type field, select Page Layout Break.
16. Click the Page Layout drop-down and select Back2.

17. Click OK.
18. Click

to save your work.

For more information about creating outline TOCs for print-based output, see the online Help.
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CHAPTER 8

Developing a Target
The project you created already contains two PDF targets. The only difference between them is
that one is set to show crop and registration marks in the output to make it easier when the PDF is
sent to a professional printer.

We are going to create a new PDF target that is not necessarily identical to these existing targets,
but the same in the most important areas.
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CREATE A TARGET
1. In the Project Organizer, right-click the Targets folder, and from the context menu select Add
Target. The Add File dialog opens.
2. The only factory target template should already be selected, so in the File Name field at the
bottom of the dialog, type 3FoldNew.
3. In the Output Type field, select PDF.

4. Click Add. The new target is created and opens in Flare.
5. In the Target Editor, select the General tab.
6. In the Master TOC field, select Product Foldout2, the TOC you created.

7. Select the Advanced tab.
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8. Remove the check marks from the following fields: Generate TOC proxy, Generate index
proxy, and Generate glossary proxy.

9. Select the PDF Options tab.
10. In the Title field, give your foldout a title.
11. In the Author field, enter your name.
12. If you want, you can select Include Crop and Registration Marks.
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13. Select Convert RGB Colors to CMYK.

CHAPTER 8

118

14. Scroll down on the tab, and in the Navigation field, select Page Only.

15. Click

to save your work.

For more information about developing targets and the various fields you can set in the Target
Editor, see the online Help.
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CHAPTER 9

Building and Viewing Output
Now let's build the PDF output and see how it looks.

BUILD AND VIEW OUTPUT
1. In the local toolbar of the Target Editor, click

.

The Builds window pane opens at the bottom of the Flare interface, and the target begins to
generate.
When the build finishes successfully, the Build Progress and Compile Progress cells turn dark
green.
2. Double-click the row to open the PDF and review everything you've done.
For more information about PDF targets and building output, see the online Help.
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APPENDIX

PDFs
The following PDFs are available for download from the online Help.
TUTORIALS

Getting Started Tutorial
Product Foldout Tutorial
Side Navigation Tutorial
Top Navigation Tutorial
Tripane and PDF Tutorial
USER GUIDES

Accessibility Guide

Getting Started Guide

Analysis and Reports Guide

Global Project Linking Guide

Architecture Guide

HTML Help Guide

Autonumbers Guide

HTML5 Guide

Condition Tags Guide

Images Guide

Context-sensitive Help Guide

Importing Guide

DotNet Help Guide

Index Guide

Eclipse Help Guide

Key Features Guide
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Language Support Guide

Source Control Guide: Git

MadCap Central Integration Guide

Source Control Guide: Perforce

Movies Guide

Source Control Guide: Subversion

Navigation Links Guide

Source Control Guide: Team Foundation Server

Plug-In API Guide

Styles Guide

Print-based Output Guide

Tables Guide

Project Creation Guide

Tables of Contents Guide

Pulse Guide

Targets Guide

QR Codes Guide

Templates Guide

Reports Guide

Topics Guide

Reviews & Contributions Guide

Touring the Workspace Guide

Search Guide

Transition From FrameMaker Guide

SharePoint Guide

Variables Guide

Skins Guide

WebHelp Outputs Guide

Snippets Guide

What's New Guide

CHEAT SHEETS

Folders and Files Cheat Sheet
Print Output Cheat Sheet
Shortcuts Cheat Sheet
Structure Bars Cheat Sheet
Styles Cheat Sheet
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