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CHAPTER 1

Introduction
You can import files into Flare in several ways. This includes importing from other Help authoring
projects, popular applications like Word, and many kinds of individual files.
Following are the different ways to import content into Flare:
n

Word You can create a new project or topics by importing Microsoft Word files. See "Importing Word Files" on page 8.

n

FrameMaker You can create a new project or topics by importing Adobe FrameMaker files.
See "Importing FrameMaker Files" on page 33.

n

Doc-To-Help You can create a new project by importing a Doc-To-Help project. See "Importing Doc-To-Help" on page 65.

n

RoboHelp You can create a new project by importing a RoboHelp project. See "Importing a
RoboHelp Project" on page 71.

n

HTML Files You can create a new project or topics by importing HTML files. See "Importing
HTML Files" on page 73.

n

HTML Help Projects You can create a new project by importing an HTML Help project (HHP)
file. See "Importing HTML Help" on page 81.

n

CHM You can create a new project by importing an HTML Help (CHM) file. See "Importing
CHM Files" on page 83.

n

Author-it You can also create a new Flare project by converting Author-it Files. This utility uses
the published XML output from Author-it and converts it to a Flare project, while maintaining
all project and source files. See "Converting Author-it Files" on page 85.

n

DITA You can create a new project or topics by importing DITA files. See "Importing DITA
Files" on page 88.

CHAPTER 1

6

n

Excel You can create a new project or topics by importing Microsoft Excel files. See "Importing Excel Files" on page 96.

n

Individual Files You can import a wide variety of individual files into an existing Flare project.
See "Importing Other Files" on page 106.

n

MadCap Central If another user uploads a Flare project to your MadCap Central license and
you do not yet have that project on your computer, you can import it. You can do this from the
MadCap Central window pane in Flare. See "Importing Projects from Central" on page 125.

n

Source Control You can create a new project by importing one located in source control. See
"Importing a Project from Source Control" on page 128.

n

Global Project Linking You can import content and project files contained in another Flare project, thus allowing you to maintain the information in one location but reuse it in any other project. When you use this feature to import files, you can include or exclude particular types of
files (e.g., topics, snippets, stylesheets, glossaries, targets), specific individual files, or files
that have certain condition tags applied. Simply use the include/exclude methods that work
best for you. For more information about this feature, see the online Help or the Global Project
Linking Guide.
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CHAPTER 2

Importing Word Files
You can import Microsoft Word files in the following ways:
n

Import Into a New Project

n

Import Into an Existing Project (From the Wizard)

n

Import Into an Existing Project (From the Import Editor)

Before you begin, please note that there is a way to control the file names given to new topics that
are created from imported Word documents. To do this, you need to apply "Private" field codes to
the appropriate headings in the Word documents where new topics will be created (see "Specifying
Custom File Names for Word Imports" on page 31). Of course, you also have the option of renaming
the new topic file names after the import process is finished.
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HOW TO IMPORT WORD FILES
1. Do the following, depending on how you are importing your files:

IMPORT INTO A NEW PROJECT
a. Select Project > Import > MS Word Documents.
The Import Microsoft Word Wizard opens.
b. Select Import into a new project.
c. In the Project name field, type a name for the new Flare project that will be created
after you perform the import.
d. In the Project folder field, either accept the default location for the new project or click
to find and select a folder.
e. From the Output Type field, select the primary target for your project.

IMPORT INTO AN EXISTING PROJECT (WIZARD)
a. Select Project > Import > MS Word Documents.
The Import Microsoft Word Wizard opens.
b. Select Import into this project.

IMPORT INTO AN EXISTING PROJECT (IMPORT EDITOR)
Do one of the following:

IF YOU DO NOT YET HAVE A WORD IMPORT FILE
a. Complete the steps for adding an import file. See "Additional Word Tasks" on page 28.
b. Open the file in the Word Import Editor.

IF YOU ALREADY HAVE A WORD IMPORT FILE
a. In the Project Organizer, expand the Imports subfolder.
b. Double-click the appropriate import file. The file opens in the Word Import Editor to the
right.

CHAPTER 2

9

2. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Source Files tab.

3. Click

.

4. In the dialog that opens, find and select the files you want to import. You can hold the SHIFT
key to select a range, or you can hold the CTRL key to select individual items. When you are
finished, click Open.
You can select DOC, DOCX, or RTF files.
NOTE: DOCX is Microsoft Word's platform-independent, open XML format. You must
have Microsoft Word 2007 installed in order to import this file type.
5. You can use the following options as necessary:
This opens the file that is selected in the list.
Link Generated
Files to
Source
Files

This creates a connection between the original files and the files that are created as a result of the import. This is useful if you want to continue editing the
content outside of Flare, instead of editing in the Flare project. Flare recognizes when changes have been made to the source documents and reminds
you to re-import the documents to ensure the Flare project also reflects the
changes. If you use this option, a link icon is added to the top of a linked file in
the Flare interface. This lets you know that you need to edit the source file,
rather than editing this file. If you remove the connection to the source file, this
icon no longer displays on the file. Please note that if you have bound the project to source control, the icons used for source control take precedence over
the link icon.
This removes the selected file(s) from the list.
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This moves the selected file higher in the list (if you have more than one file to
import). The file at the top is used for the name of the content folder holding
the imported topics in Flare. Also, the order determines how the imported files
are arranged in the Flare TOC that is created as a result.
This moves the selected file lower in the list (if you have more than one file to
import).
6. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next. The Word documents are scanned and the next page of the wizard
opens. The paragraph styles used in the Word documents are shown on the left side of
the wizard page ("Used Word Styles").
NOTE: You can skip the rest of the wizard pages by clicking Finish.

n

Import Editor Select the New Topic Styles tab.

7. If you want Flare to split the Word documents into smaller topics based on any of the styles
shown on the left side of the page ("Used Word Styles"), double-click that style to move it to
the right side of the page ("New Topic Styles").
EXAMPLE
If you have a style called "Heading 2" in your Word documents, you might want
new topics to be created whenever Flare finds a Heading 2 style in a document.
So you would double-click Heading 2 and move it to the right side of the page.
8. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Options tab.
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9. You can use the following options as necessary:
n

Add "Topic Continued" links when appropriate Select this option to place a "Topic Continued" link at the bottom of pages when a long topic has been split into multiple ones.

n

Add "Topic Continued From" links when appropriate Select this option to place a "Topic
Continued From" link at the top of continued pages when a long topic has been split into
multiple ones.

n

Cross-Reference Format Use this field to specify the format for the "Topic Continued"
and "Topic Continued From" links. Flare provides a cross-reference format for you—(continued in {title}) or (continued from {title}). With this cross-reference format, the link contains the words "continued in" or "continued from" within parentheses, followed by the
text of the first paragraph in the connected topic. If you do not want the link to use that
particular text, you have a couple of options. First, in Flare, you could manually enter a
heading in each topic that is connected to another topic included in the split. That text
will be used in the link instead (after you update the cross-references in Flare). Another
option is to modify the format by clicking the Edit button.
l

n

Split Long Topics Select this option if you have long sections in your source documents
and want to make sure that they are converted to multiple topics (rather than one very
long topic).
l

n

Edit If you want to modify the cross-reference format provided, click this button,
which opens the Cross-Reference Format dialog.

Threshold Enter the maximum number of characters to be converted to a topic
before a new topic is created. Flare will break the topic at the nearest paragraph to
the threshold value. That way, a new topic will not start in the middle of a sentence
or word, but at the beginning of a paragraph.

Avoid Creating 'Empty' Topics Select this option if you want to ensure that new topics are
not created when large sections are found in the Word documents without any content.
l
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n

Auto-reimport before 'Generate Output' This is also known as "Easy Sync." If you created
a connection between your source files and the Flare project earlier in the wizard, you will
likely make future content changes in the source files. When you make such changes,
the source files need to be re-imported into the project so that they can be included in the
output. You have the option of re-importing the files manually. However, you can also tell
Flare to do this for you automatically, so that you do not have to. Select this option if you
want Flare to automatically re-import files when you attempt to build output.

n

Approximate Filename Length Enter the maximum number of characters to use for naming new topic files that are automatically created after splitting a long topic. The default
is 24.

n

Convert all tables to "Auto-Fit to Contents" Select this option if you want to automatically
set tables to "Auto-Fit to Contents" when they are imported into Flare. This simply
ensures that column widths are not specified on the imported tables.

n

Set first row of each table as a header row Select this option if you want Flare to convert
the first row of every table into a header row. This makes styling tables more efficient. If
you do not select this option, only tables that already have header rows in the Word document will become header rows in Flare. Tables without header rows will be imported just
as they are.
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EXAMPLE
Let's say you have a Word document with two tables.
In the first table, the first row has been set to repeat as a header row.
In the second table, the first row has not been set to repeat as a header
row.
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First, you import the Word document but you do not enable the option to
set the first row of each table as a header row. As a result, the first row in
the first table continues to be a header row, just as it was in the Word document. And the first row in the second table continues to be a regular row,
just as it was in the Word document.
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Next, you import the Word document but you do enable the option to set
the first row of each table as a header row. As a result, the first row of each
table is now a header row.
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n

Create a Page Layout for each section header/footer Select this option if you want Flare
to create new page layouts when you import Word documents that have section breaks,
along with headers or footers. For each new section in the Word document that has a different header or footer than the previous section, Flare creates a unique page layout.
After the import is finished, you can open and edit the page layouts if necessary. You can
then create chapter breaks for your print-based output and assign these page layouts to
the different topics in the output.

n

Automatically set topic title If this option is enabled, the properties setting for the topic
title automatically uses the first heading in the topic. Therefore, if you change the heading text in the future, the topic title changes automatically as well. If this option is disabled, the properties setting for the topic title explicitly uses the first topic heading text
found during the import, and it remains so unless you manually change it later.

n

Convert equations to MathML When importing Microsoft Word files that contain equations, you can convert them from Office Math Markup Language (the format used in
Word) to MathML (the web standard and Flare format). If you disable this option, equations from Word are converted to images.
NOTE: To use this feature, the equation must have been created in Microsoft
Word 2007 or newer. Also, open the Options dialog (File > Options), select the
General tab, and make sure that Import/Export Word Files without MS Office is
disabled.

10. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Stylesheet tab.

11. Use this page to specify whether the imported topics should be associated with a stylesheet
and/or styles from your Word files.
n

Stylesheet If you already have a CSS file that you want to associate with the imported
files, click the Stylesheet button. Then navigate to the stylesheet and select it.

n

Preserve MS Word Styles This retains any style formatting from your Word documents so
that you can continue to use that look and feel in Flare. For example, if you use a style
called "Heading 1" in your source documents and that style is blue, it remains blue after
you finish the import to Flare and the new style is created. Also, selecting this option
affects which mapping styles are available as you continue to make your import
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selections. If you select this option, you can map the Word styles to new Flare styles that
keep the name of the Word style (e.g., Heading 1 becomes h1.Heading 1 in Flare).
n

Don't Preserve MS Word Styles This does not keep the style formatting used in the Word
documents. For example, if you use a style called "Heading 1" in your source documents
and that style is blue, that color (and any other settings for that style) are not kept after
you finish the import to Flare. You will still have styles associated with your content, but it
will not look like it did in the source documents. Also, selecting this option affects which
mapping styles are available as you continue to make your import selections. If you
select this option, you can map the Word styles to new Flare styles that either keep the
name of the Word style (e.g., Heading 1 becomes h1.Heading 1 in Flare) or do not (e.g.,
Heading 1 becomes h1 in Flare).

n

Convert inline formatting to CSS styles This creates new styles based on any local
formatting that exists in the Word documents.
EXAMPLE
If you have applied bold and italic formatting to some text (without using a
style), Flare will create a new style based on that formatting.

TIP: To avoid having several character styles in Flare that you do not want, it is
a good idea to clean up your source documents as much as possible before
importing.
12. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Paragraph Styles tab.

13. Use this page to map paragraph styles from the Word documents to Flare's paragraph styles,
including those from the stylesheet you may have selected. Your Word style will adopt the
name of that style. To map a style, click the style in the MS Word Styles column on the left,
click a style in the Flare Styles section on the far right, and then click the Map button. If you
previously elected not to preserve the Word styles, it is recommended that you map to a
standard CSS parent style—e.g., map your first-level heading style to h1, not to h1.(MS Word
Style).
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The style is added to the Flare Styles column. When you are finished importing the documents
and the new Flare project is loaded, the content that had been associated with the style in the
Word document will now be associated with a new style that you mapped it to.
EXAMPLE—PRESERVE STYLES
Let's say you have a style in your Word source document called "Heading 1" that
is using Arial 14 pt and is red, like this.

Hello
During the process of importing your Word document using the Import Microsoft
Word Wizard, you select the option to preserve your Word styles.
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The next page of the wizard looks something like this:

When you finish importing, the content that was associated with Heading 1 in the
source document is still using Arial 14 pt and is red, just like it was before in Word.
However, the style is now called "h1.Heading 1." In the world of cascading style
sheets (CSS)—which is what Flare uses for controlling the look of content—
you've created a class of the h1 style (h1 is the standard style for first-level headings). But because you wanted to keep the look of the Word style, Flare added it
as a child under its parent, h1.
If you make any future changes in Flare to the h1 style, they will trickle down to
the h1.Heading 1 child (unless the child style has explicit settings that conflict
with the parent). You can also apply style properties directly to the h1.Heading 1
child. So while it is generally a good idea to use standard CSS parent styles (such
as h1) when possible in Flare, the mapping performed in this import process—and
the subsequent creation of a child style—lets you keep the Arial 14 pt red look.

CHAPTER 2

20

EXAMPLE—DO NOT PRESERVE STYLES
Let's say you have a style in your Word source document called "Heading 1" that
is using Arial 14 pt and is red, like this.

Hello
During the process of importing your Word document using the Import Microsoft
Word Wizard, you select the option to not preserve your Word styles.
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The next page of the wizard looks something like this.

When you finish importing, the content that was associated with Heading 1 in the
source document is no longer using Arial 14 pt, red. Instead, it looks something
like this.

Hello
Also, the style is now called "h1." (Keep in mind that, even if you had mapped the
style to "h1.(Word Style) in this case, the formatting would still be removed.)
So although the formatting was not retained, you were able to map to the standard CSS style for first-level headings—h1 .
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14. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Character Styles tab.

15. Use this page to map character styles from the source documents to Flare's character styles,
including those from the stylesheet you may have selected. Your Word style will adopt the
name of that style. This works the same as the feature for mapping paragraph styles, except
it has to do with character-level styles. To map a style, click the style in the MS Word Style
column, click a style in the Flare Styles section, and then click the Map button.
The style is added to the Flare Styles column. When you are finished importing the documents
and the new Flare project is loaded, the content that had been associated with the style in the
Word document will now be associated with a new style that you mapped it to.
16. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Finish. The Accept Imported Documents dialog opens. The files that will be
created as a result of the import are listed on the left. A preview of each file can be seen
to the right when you click the file.

n

Import Editor In the local toolbar click Import (if this is the first time importing files) or
Reimport (if files have been imported previously). The Accept Imported Documents dialog opens. The files that will be created as a result of the import are listed on the left. A
preview of each file can be seen to the right when you click the file.

17. When you are finished previewing the files to be created, click Accept.
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HOW WORD FEATURES ARE TREATED WHEN IMPORTED
The following table shows some Word features how what happens to them when you import documents into Flare.
Word Feature

Result After Import

Artwork and Special Effects

If you apply certain special effects or artwork (e.g.,
arrows) to images in Word and then import them
into Flare, those effects will not be retained. For
example, a rotated image will return to its straight,
original state. However, there are some workarounds that may allow you to keep the effects or
artwork. One solution is to apply another effect such
as a shadow or 3-D to the image in Word (e.g., add a
shadow to a rotated image that you want to keep).
This forces Word to save the image as an entirely
new image with the effects. Another possible solution is to save the Word document as a web page,
manually copy that HTM file into the Flare folder,
and then open it within Flare. As for text floating
around images, this effect is not supported in Flare.
When you import from Word, the text is added below
the image.

Image Alt Text and Description

If you have an image in a Word document that contains alt text or a description, both are brought in to
Flare. After the Word document is imported, you can
open the topic containing the image, right-click on
the image, and select Image Properties. In the
Image Properties dialog, the description for the
image is shown in the Screen Tip field, and the alt
text is shown in the Alternate Text field.
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Word Feature
Linked and Embedded Images—File Names

Linked Images

Result After Import
Image file names are treated in the following ways
for linked and embedded images:
n

Linked Images If you have inserted a picture
as a linked image in a Word document, the file
name for the image is preserved when imported into Flare. The image file is stored by
default at the root of the Resources/Images
subfolder in the Content Explorer.

n

Embedded Images If you have inserted a picture as an embedded image in a Word document, the file name for the image is based on
the topic name when imported into Flare. The
image file is stored by default in the
Resources/Images/[Word Document Name]
subfolder in the Content Explorer.

When you insert an image in Word, one of the
options is to insert it as a linked image.
NOTE: If you received a Word document
with linked images from another person—
rather than creating the document yourself—you need to also get the images themselves from that individual. Then you need
to re-link the images in the document. Otherwise, Word (and therefore also Flare) will not
be able to find them.
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Word Feature
Videos

Result After Import
If you import a Word document that contains a direct link to a video, it is now brought into the Flare project. Previously, Flare did not support videos in Word
documents.
This only works for direct video links. For example, if
you have Word 2013, you can look for and insert
videos from Bing or YouTube. These are direct link
videos that are supported. But those from video
embed codes are not supported.

NOTE: Flare supports Microsoft Word 2003 and newer versions.

NOTE: When you import Word files, a stylesheet (at least a generic one) will always be created and initially be applied at the project level, whether you choose to preserve Word styles
or not. When a master stylesheet is applied at either the target or project level, you cannot
associate stylesheets at the topic level (unless you remove the master stylesheet association at the project and/or target level).
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NOTE: If you import Microsoft Word documents containing embedded images into a project, Flare places copies of those image files in subfolders within the Resources > Images
folder. This is done in order to avoid naming conflicts with embedded images from other
Word documents that you might import. The subfolders are named after the Word documents being imported.

NOTE: A link icon displays on tabs in the XML Editor next to file names that are imported
from and linked to another file or Flare project. However, if you are also using the built-in
source control technology, the source control icons have a higher precedence and will
therefore be displayed instead.
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Additional Word Tasks
Following are some other Word-related tasks that you can perform in Flare when it comes to importing.
n

Add Word Import File See "Adding an MS Word Import File" below.

n

Open Word Import File See "Opening an MS Word Import File" on page 30.

n

Specify Custom File Names See "Specifying Custom File Names for Word Imports" on page 31.

Adding an MS Word Import File
The following steps show you how to add an MS Word import file, which is used to import Word documents into a project.

HOW TO ADD AN MS WORD IMPORT FILE TO A PROJECT
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Project ribbon. In the Content section select New > Import File > Add
MS Word Import File.

n

Right-Click In the Project Organizer, right-click on the Imports folder and from the context
menu select Add MS Word Import File.

The Add File dialog opens.
2. In the File Type field at the top, make sure MS Word Import File is selected.
3. In the Source area select one of the following:
n

New from template Choose either the factory template file or one of your own customized template files as a starting point. The new file will take on all of the settings contained in the template. If you want to use the factory template provided by Flare, expand
the Factory Templates folder and click on a template file. If you want to use your own customized template file, expand the appropriate folder and click on a file. For more information about templates, see the online Help.

n

New from existing Choose an existing file of the same type as a starting point for your
new file. As with template files, your new file will take on all of the settings contained in
the file you select. To use this option, click the browse button
, use the Open File dialog to find a file, and double-click it.
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4. (Optional) If you want to place the file into a subfolder previously created in the Content
Explorer or Project Organizer, in the Folder field click
and select the subfolder. Otherwise,
keep the default location.
5. In the File Name field, type a new name for the import file.
6. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click
and select the conditions you
want to apply. Click OK.
7. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the dialog. Next to the File Tags field, click
and select the file tags you want to apply. Click OK.
8. Click Add. The import file is added to the Imports folder in the Project Organizer. The Word
Import Editor opens to the right.

NOTE: Flare supports Microsoft Word 2003 and newer versions.
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Opening an MS Word Import File
The following steps show you how to open an MS Word import file that you have added to a project.
You can then use this file to create topics by importing Word documents into the project. See
"Importing Word Files" on page 8.

HOW TO OPEN AN MS WORD IMPORT FILE FROM THE QUICK LAUNCH BAR
The Quick Launch bar allows you to search for any Flare file or command. It is located in the upperright corner of the interface. You can press CTRL+Q on your keyboard to move focus to the Quick
Launch bar so you can begin typing.

1. In the Quick Launch bar, type a few letters of the name of the file you want to open. Any available results appear in a drop-down list.
2. From the list, click the name of the file.

HOW TO OPEN AN MS WORD IMPORT FILE FROM THE PROJECT ORGANIZER
1. Open the Project Organizer.
2. Double-click the Imports folder. The MS Word import files in your project are displayed.
3. Double-click the import file that you want to open. The Word Import Editor opens to the right.

NOTE: Flare supports Microsoft Word 2003 and newer versions.
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Specifying Custom File Names for Word Imports
If you import Microsoft Word documents, you can split those documents into multiple topics based
on the styles in them. For example, you might decide to create a new topic at each "Heading 1" style
in the Word document. You can also control the file names given to the new topics that are created
from the imported Word documents. To do this, you need to apply "Private" field codes to the appropriate headings in the Word documents where new topics will be created. The following format
should be used when applying the field: PRIVATE:MADCAP:FILENAME:<custom filename>.

HOW TO SPECIFY CUSTOM FILE NAMES FOR WORD IMPORTS
The following steps are based on Microsoft Word 2003 and 2007. For more details on creating Private fields in Microsoft Word in other versions, please refer to the documentation provided with that
application.
1. Open the Word document.
2. Place your cursor on a heading where you want to start a new topic in Flare.
3. Do one of the following.
n

For Word 2003 Select Insert > Field.
OR

n

For Word 2007 Select Insert > Quick Parts > Field.

The Field dialog opens.
4. In the Field name section, scroll down and select Private.
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5. In the Field codes section, enter the code using the following format:
PRIVATE:MADCAP:FILENAME:<custom filename>.
EXAMPLE
Let's say that you have a place in a Word document that is using the "Heading 1"
style and contains the text "All About Rabbits." You want a new topic to be created at that point when you import the document. However, you also want to
make sure that the file name for that new topic is simply "Rabbits." Therefore,
you open the Word document and apply a Private field on that heading, using the
following format:
PRIVATE:MADCAP:FILENAME:Rabbits
When you import the Word document, you select to split new topics on certain
styles, including the "Heading 1" style. After the import is finished, one of the topics created is named "Rabbits.htm."
6. Click OK.
7. Save the Word document.
8. In Flare, go through the process for importing the Word document. When you arrive at the
"New Topic Styles" page in the Import Microsoft Word Wizard or the "New Topic Styles" tab in
the Word Import Editor, make sure you select the style(s) where you inserted Private fields in
the Word document.
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CHAPTER 3

Importing FrameMaker Files
You can import Adobe FrameMaker files in the following ways:
n

Import Into a New Project

n

Import Into an Existing Project (From the Wizard)

n

Import Into an Existing Project (From the Import Editor)
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HOW TO IMPORT FRAMEMAKER FILES
1. Do the following, depending on how you are importing your files:

IMPORT INTO A NEW PROJECT
a. Select Project > Import > FrameMaker Documents.
The Import FrameMaker Documents Wizard opens.
b. Select Import into a new project.
c. In the Project name field, type a name for the new Flare project that will be created
after you perform the import.
d. In the Project folder field, either accept the default location for the new project or click
to find and select a folder.
e. From the Output Type field, select the primary target for your project.

IMPORT INTO AN EXISTING PROJECT (WIZARD)
a. Select Project > Import > FrameMaker Documents.
The Import FrameMaker Documents Wizard opens.
b. Select Import into this project.
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IMPORT INTO AN EXISTING PROJECT (IMPORT EDITOR)
Do one of the following:

IF YOU DO NOT YET HAVE A FRAMEMAKER IMPORT FILE
a. Complete the steps for adding an import file. See "Additional FrameMaker Tasks" on
page 53.
b. Open the file in the Frame Import Editor.

IF YOU ALREADY HAVE A FRAMEMAKER IMPORT FILE
a. In the Project Organizer, expand the Imports subfolder.
b. Double-click the appropriate import file. The file opens in the Frame Import Editor to the
right.
2. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Source Files tab.

3. Click

.

4. In the dialog that opens, find and select the files you want to import. You can hold the SHIFT
key to select a range, or you can hold the CTRL key to select individual items. When you are
finished, click Open.
You can select BOOK, FM, or MIF files.
TIP: When possible, it is recommended that you select a Adobe FrameMaker BOOK
file for import and let Flare locate and import all the associated document files within
the Adobe FrameMaker book.

CHAPTER 3

35

5. You can use the following options as necessary:
This opens the file that is selected in the list.
Link Generated
Files to
Source
Files

This creates a connection between the original files and the files that are created as a result of the import. This is useful if you want to continue editing the
content outside of Flare, instead of editing in the Flare project. Flare recognizes when changes have been made to the source documents and reminds
you to re-import the documents to ensure the Flare project also reflects the
changes. If you use this option, a link icon is added to the top of a linked file in
the Flare interface. This lets you know that you need to edit the source file,
rather than editing this file. If you remove the connection to the source file, this
icon no longer displays on the file. Please note that if you have bound the project to source control, the icons used for source control take precedence over
the link icon.
This removes the selected file(s) from the list.
This moves the selected file higher in the list (if you have more than one file to
import). The file at the top is used for the name of the content folder holding
the imported topics in Flare. Also, the order determines how the imported files
are arranged in the Flare TOC that is created as a result.
This moves the selected file lower in the list (if you have more than one file to
import).

6. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next. The FrameMaker documents are scanned and the next page of the
wizard opens. The paragraph styles used in the FrameMaker documents are shown on
the left side of the wizard page ("Used FrameMaker Styles").
NOTE: You can skip the rest of the wizard pages by clicking Finish.

n
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Import Editor Select the New Topic Styles tab.
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7. If you want Flare to split the FrameMaker documents into smaller topics based on any of the
styles shown on the left side of the page ("Used FrameMaker Styles"), double-click that style
to move it to the right side of the page ("New Topic Styles").
EXAMPLE
If you have a style called "Heading 2" in your FrameMaker documents, you might
want new topics to be created whenever Flare finds a Heading 2 style in a document. So you would double-click Heading 2 and move it to the right side of the
page.
8. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Options tab.

9. You can use the following options as necessary:
n

Add "Topic Continued" links when appropriate Select this option to place a "Topic Continued" link at the bottom of pages when a long topic has been split into multiple ones.

n

Add "Topic Continued From" links when appropriate Select this option to place a "Topic
Continued From" link at the top of continued pages when a long topic has been split into
multiple ones.

n

Cross-Reference Format Use this field to specify the format for the "Topic Continued"
and "Topic Continued From" links. Flare provides a cross-reference format for you—(continued in {title}) or (continued from {title}). With this cross-reference format, the link contains the words "continued in" or "continued from" within parentheses, followed by the
text of the first paragraph in the connected topic. If you do not want the link to use that
particular text, you have a couple of options. First, in Flare, you could manually enter a
heading in each topic that is connected to another topic included in the split. That text
will be used in the link instead (after you update the cross-references in Flare). Another
option is to modify the format by clicking the Edit button.
l
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Edit If you want to modify the cross-reference format provided, click this button,
which opens the Cross-Reference Format dialog.
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n

Split Long Topics Select this option if you have long sections in your source documents
and want to make sure that they are converted to multiple topics (rather than one very
long topic).
l

n

Avoid Creating 'Empty' Topics Select this option if you want to ensure that new topics are
not created when large sections are found in the FrameMaker documents without any
content.
l

n

Threshold Enter the maximum number of characters to be converted to a topic
before a new topic is created. Flare will break the topic at the nearest paragraph to
the threshold value. That way, a new topic will not start in the middle of a sentence
or word, but at the beginning of a paragraph.

Threshold Enter the maximum number of empty character spaces allowed in a
topic. If this number is exceeded, Flare will not create a new topic from that empty
space.

Anchored Frames With Images You can use this area to specify how Flare should handle
anchored frames that contain images as well as other content (e.g., text callouts).
l

l
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Generate Images Without Callouts If the anchored frame contains an image along
with callout text, the original image is imported without the callout text. You might
select this option if you have resized the image in FrameMaker. With this option,
the imported image is likely to be of a higher quality than it would be otherwise. You
can then add a callout to the image once it is inside Flare.
Generate Images With Callouts If the anchored frame contains an image along
with callout text, Flare creates a PROPS (i.e., properties) file along with the image
file when that document is imported. This means that you can open those image
files in MadCap Capture to edit those callouts after the import process is completed.
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EXAMPLE
If you import anchored frame images and tell Flare not to include the
callouts, your imported image files will look something like this in Windows Explorer.

On the other hand, if you import the same images and tell Flare to
include the callouts, it will look something like this in Windows
Explorer.

NOTE: Some FrameMaker elements—such as arcs and nested frames—
are not supported with this option.

l
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Generate Flattened Images If the anchored frame contains an image along with
callout text, a new flattened image will be created as a result. The callout is
included, but you cannot edit it.
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n

Preserve Image Size This option affects how the size of imported images are handled.
l

l

Option Selected The original image is imported. However, the <img> tag is modified
in the imported file to closely reflect the height and width of the image in the
FrameMaker document. This is done regardless of whether you are importing
linked or embedded images from FrameMaker documents.
Option NOT Selected The <img> tag is not modified in the imported file. Instead,
the image is referenced at 100% of its original value.

n

Auto-reimport before 'Generate Output' This is also known as "Easy Sync." If you created
a connection between your source files and the Flare project earlier in the wizard, you will
likely make future content changes in the source files. When you make such changes,
the source files need to be re-imported into the project so that they can be included in the
output. You have the option of re-importing the files manually. However, you can also tell
Flare to do this for you automatically, so that you do not have to. Select this option if you
want Flare to automatically re-import files when you attempt to build output.

n

Approximate Filename Length Enter the maximum number of characters to use for naming new topic files that are automatically created after splitting a long topic. The default
is 24.

n

Enable 'Passthrough' Markers Select this check box to include a check mark if you have
created passthrough markers in your FrameMaker source documents.A passthrough
marker is a special marker that you can insert into your FrameMaker source content
when you have information or code that you plan to import to Flare and want left alone
(or "passed through," leaving it exactly as you have authored it, rather than processing it).
A passthrough marker can be just about anything, as long as supports it in the XHTML
code.You can specify how the marker content should be treated when the FrameMaker
document is imported. The first option is that you can import the marker content as regular text (which is the default setting). The second option is that you can import the
marker content as an XML fragment (e.g., the first part of a bold tag—<b>—but not the
second part). The third option is that you can import the marker content as a complete
XML tag. You might use a passthrough marker for various reasons, such as for importing
a marker as XHTML or JavaScript code.
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EXAMPLE
Let's say you plan to import some FrameMaker documents to Flare and
you have locations in those documents where you want to link to CHM
files. The problem is that FrameMaker does not allow you to create links to
CHM files in such a way that those links can then be imported into another
software application.
Therefore, you create a passthrough marker in the FrameMaker document, providing the beginning "href" tag and path to the CHM file. Like
this:

Then you create a second passthrough marker, providing the end tag for
the link. Like this:

When you import the FrameMaker document(s), you can specify that the
passthrough markers should be imported as XML fragments. In Flare, the
link to the CHM file will look and work as it should.

CHAPTER 3

41

n

Passthrough Marker Format After you enable passthrough markers, click the down arrow
in this field and select the type of format that you want to use for the import.
l

l

l

text The marker content will be imported as regular text (default setting).
fragment The marker content is imported as an XML fragment (e.g., the first part
of a bold tag—<b>—but not the second part). If you select this option, you will probably need a second marker in the FrameMaker document to complete the XML
tag.
xml The marker content is imported as a complete XML tag.

n

Convert equations to MathML Select this option to convert MathFullForm equations (the
FrameMaker-specific format) to MathML (the web standard and Flare format). If you disable this option, equations from FrameMaker are converted to images.

n

Convert Table Styles If you have tables in your FrameMaker documents that you have
formatted in a certain way, select this check box if you want to create matching table
styles as a result of the import. In the Flare project, the new table styles will be named
after the format named applied to the table in FrameMaker (e.g., "Format_A.css,"
"Format_B.css," and so on). You can rename these table stylesheets in Flare after the
import finishes. Even if you do not use this mapping feature, the table formatting still
comes across when you import the documents. The only difference is that table
stylesheets make it easier to maintain the formatting of your tables within Flare.

n

Reimport Table Styles This option displays only if you are working in the Import Editor,
rather than the wizard. This option is useful after you have already imported FrameMaker
documents and converted the formatting in your tables into at least one table stylesheet
in Flare. You can use this option to determine whether tables should be imported again as
table styles when you re-import. You might want to keep this check box selected for
some re-imports, but other times you might want to deselect it when re-importing.
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EXAMPLE
Let’s say you want the formatted tables in your FrameMaker documents to
be converted to table styles when you perform the initial import into a Flare
project. Therefore, in the import wizard, you turn on the "Convert Table
Styles" option. As a result, let's say that Flare creates a new table style and
calls it "FormatA.css."
After the initial import, you realize you want the tables to look a little different. Therefore, in the Flare project, you modify the properties of the
FormatA.css table stylesheet.
Awhile later, let's say you want to re-import the FrameMaker documents.
The problem is that you've already changed the table stylesheet in Flare.
You probably want to keep the tweaked table style so that you don’t have
to modify it again after the import.
This is where the new "re-import" option comes into play. It determines
whether or not a second new table stylesheet will be created, based on the
old look from the tables in the FrameMaker documents.
Here's one scenario. Let's say that before you re-imported the
FrameMaker documents, you selected the "Reimport Table Styles" option
in the Frame Import Editor. And during the import when you were prompted, you selected not to overwrite the existing FormatA.css table
stylesheet. In that case, Flare keeps your tweaked stylesheet in the project, but it also creates another table stylesheet called "FormatA1.css" that
has the old look and feel. All of the re-imported content now links to the
FormatA1.css stylesheet instead of FormatA.css.
Here's a different scenario. Let's say that you perform the same steps
described above, except this time you deselected the "Reimport Table
Styles" option in the Frame Import Editor. In that case, the second
FormatA1.css file is not created. The imported content is linked to the
FormatA.css table stylesheet that you previously modified, since it already
exists in the project.
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10. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Stylesheet tab.

11. Use this page to specify whether the imported topics should be associated with a stylesheet
and/or styles from your FrameMaker files.
n

Stylesheet If you already have a CSS file that you want to associate with the imported
files, click the Stylesheet button. Then navigate to the stylesheet and select it.

n

Preserve FrameMaker Styles This retains any style formatting from your FrameMaker
documents so that you can continue to use that look and feel in Flare. For example, if you
use a style called "Heading 1" in your source documents and that style is blue, it remains
blue after you finish the import to Flare and the new style is created. Also, selecting this
option affects which mapping styles are available as you continue to make your import
selections. If you select this option, you can map the FrameMaker styles to new Flare
styles that keep the name of the FrameMaker style (e.g., Heading 1 becomes h1.Heading
1 in Flare).

n

Don't Preserve FrameMaker Styles This does not keep the style formatting used in the
FrameMaker documents. For example, if you use a style called "Heading 1" in your source
documents and that style is blue, that color (and any other settings for that style) are not
kept after you finish the import to Flare. You will still have styles associated with your content, but it will not look like it did in the source documents. Also, selecting this option
affects which mapping styles are available as you continue to make your import selections. If you select this option, you can map the FrameMaker styles to new Flare styles
that either keep the name of the FrameMaker style (e.g., Heading 1 becomes h1.Heading
1 in Flare) or do not (e.g., Heading 1 becomes h1 in Flare).
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Conversion Styles This opens the Import Styles Editor, which lets you specify how to convert each property of the FrameMaker styles. If you do not enter a property value, the
value from the FrameMaker document is used. If you enter a property value, it overrides
the value from the FrameMaker document. This button is used only if you have selected
"Preserve FrameMaker Styles."

n

EXAMPLE
You might use this button, for example, if you need to change a cross-reference format coming from FrameMaker into something more meaningful
in Flare. There are some cross-reference building blocks in FrameMaker
that do not have an equivalent in Flare. In cases such as these, the formats
are preserved after conversion to Flare. However, the formats may therefore appear to be broken, but they are preserved to let you know that there
was some formatting in a cross-reference style that Flare did not understand; you can then make changes to the cross-reference style in the
stylesheet. Therefore, if you already know ahead of time that you have a
cross-reference style that will need to be modified for use in Flare, you can
use the Conversion Styles button and change the cross-reference format
to something that Flare understands.
12. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Paragraph Styles tab.
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13. Use this page to map paragraph styles from the FrameMaker documents to Flare's paragraph
styles, including those from the stylesheet you may have selected. Your FrameMaker style
will adopt the name of that style. To map a style, click the style in the FrameMaker Styles
column on the left, click a style in the Flare Styles section on the far right, and then click the
Map button. If you previously elected not to preserve the FrameMaker styles, it is recommended that you map to a standard CSS parent style—e.g., map your first-level heading style
to h1, not to h1.(FrameMaker Style).
The style is added to the Flare Styles column. When you are finished importing the documents
and the new Flare project is loaded, the content that had been associated with the style in the
FrameMaker document will now be associated with a new style that you mapped it to.
EXAMPLE—PRESERVE STYLES
Let's say you have a style in your FrameMaker source document called "Heading1" that is using Arial 14 pt and is red, like this.

Hello
During the process of importing your FrameMaker document using the Import
FrameMaker Wizard, you select the option to preserve your FrameMaker styles.

CHAPTER 3

46

The next page of the wizard looks something like this:

When you finish importing, the content that was associated with Heading1 in the
source document is still using Arial 14 pt and is red, just like it was before in
FrameMaker. However, the style is now called "h1.Heading1." In the world of cascading style sheets (CSS)—which is what Flare uses for controlling the look of
content—you've created a class of the h1 style (h1 is the standard style for firstlevel headings). But because you wanted to keep the look of the FrameMaker
style, Flare added it as a child under its parent, h1.
If you make any future changes in Flare to the h1 style, they will trickle down to
the h1.Heading1 child (unless the child style has explicit settings that conflict
with the parent). You can also apply style properties directly to the h1.Heading1
child. So while it is generally a good idea to use standard CSS parent styles (such
as h1) when possible in Flare, the mapping performed in this import process—and
the subsequent creation of a child style—lets you keep the Arial 14 pt red look.
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EXAMPLE—DO NOT PRESERVE STYLES
Let's say you have a style in your FrameMaker source document called "Heading1" that is using Arial 14 pt and is red, like this.

Hello
During the process of importing your FrameMaker document using the Import
FrameMaker Wizard, you select the option to not preserve your FrameMaker
styles.

CHAPTER 3

48

The next page of the wizard looks something like this.

When you finish importing, the content that was associated with Heading1 in the
source document is no longer using Arial 14 pt, red. Instead, it looks something
like this.

Hello
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Also, the style is now called "h1." (Keep in mind that, even if you had mapped the
style to "h1.(FrameMaker Style) in this case, the formatting would still be
removed.)
So although the formatting was not retained, you were able to map to the standard CSS style for first-level headings—h1 .
14. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Character Styles tab.

15. Use this page to map character styles from the source documents to Flare's character styles,
including those from the stylesheet you may have selected. Your FrameMaker style will adopt
the name of that style. This works the same as the feature for mapping paragraph styles,
except it has to do with character-level styles. To map a style, click the style in the
FrameMaker Style column, click a style in the Flare Styles section, and then click the Map button.
The style is added to the Flare Styles column. When you are finished importing the documents
and the new Flare project is loaded, the content that had been associated with the style in the
FrameMaker document will now be associated with a new style that you mapped it to.
16. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Cross-Reference Styles tab.
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17. Use this page to map cross-reference (x-ref) styles from the FrameMaker documents to
Flare's cross-reference styles, including those from the stylesheet you may have selected. In
this way, you can have your FrameMaker style take on the appearance of the Flare style that
you map it to. To map a style, click the style in the FrameMaker Style column on the left, click
a style in the Flare Styles section on the far right, and then click the Map button.
The style is added to the Flare Style column. When you are finished importing the documents
and the new Flare project is loaded, the content that had been associated with the
FrameMaker style in the FrameMaker document will now be associated with a new style that
has the appearance of the style that you mapped it to.
What happens if you do not map a style? In the case of cross-reference styles, they are automatically added as style classes under the MadCap|xref style. For example, let's say you
import a style called "PageOnly" from your source document and do not map it to anything. In
that case, it will be called "MadCap|xref.PageOnly" in the resulting project.
18. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Finish. The Accept Imported Documents dialog opens. The files that will be
created as a result of the import are listed on the left. A preview of each file can be seen
to the right when you click the file.

n

Import Editor In the local toolbar click Import (if this is the first time importing files) or
Reimport (if files have been imported previously). The Accept Imported Documents dialog opens. The files that will be created as a result of the import are listed on the left. A
preview of each file can be seen to the right when you click the file.

19. When you are finished previewing the files to be created, click Accept.

NOTE: You must have FrameMaker installed on your computer in order to import
FrameMaker files.

NOTE: For each master page used in your FrameMaker documents, a corresponding page
layout is automatically created in your Flare project. You can use the page layouts to configure pages for print-based output. You can then create chapter breaks for your printbased output and assign these page layouts to the different topics in the output.

NOTE: Flare supports FrameMaker 7.0 and newer versions.

CHAPTER 3

51

NOTE: A link icon displays on tabs in the XML Editor next to file names that are imported
from and linked to another file or Flare project. However, if you are also using the built-in
source control technology, the source control icons have a higher precedence and will
therefore be displayed instead.
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Additional FrameMaker Tasks
Following are some other FrameMaker-related tasks that you can perform in Flare when it comes to
importing.
n

Add FrameMaker Import File See "Adding a FrameMaker Import File" below.

n

Open FrameMaker Import file See "Opening a FrameMaker Import File" on page 55.

n

Create Drop-Down Effects See "Creating Drop-Down Effects in FrameMaker Source Documents" on page 56.

n

Create Hyperlinks See "Creating Hyperlinks in FrameMaker Source Documents" on page 57.

n

Create Passthrough Markers See "Creating Passthrough Markers in FrameMaker Source
Documents" on page 58.

n

Create Topic Alias Markers See "Creating Topic Alias Markers in FrameMaker for CSH" on
page 61.

n

Specify Custom File Names See "Specifying Custom File Names for FrameMaker Imports" on
page 63.

Adding a FrameMaker Import File
The following steps show you how to add a FrameMaker import file, which is used to import
FrameMaker documents into a project.

HOW TO ADD A FRAMEMAKER IMPORT FILE TO A PROJECT
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Project ribbon. In the Content section select New > Import File > Add
FrameMaker Import File.

n

Right-Click In the Project Organizer, right-click on the Imports folder and from the context
menu select Add FrameMaker Import File.

The Add File dialog opens.
2. In the File Type field at the top, make sure FrameMaker Import File is selected.
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3. In the Source area select one of the following:
n

New from template Choose either the factory template file or one of your own customized template files as a starting point. The new file will take on all of the settings contained in the template. If you want to use the factory template provided by Flare, expand
the Factory Templates folder and click on a template file. If you want to use your own customized template file, expand the appropriate folder and click on a file. For more information about templates, see the online Help.

n

New from existing Choose an existing file of the same type as a starting point for your
new file. As with template files, your new file will take on all of the settings contained in
the file you select. To use this option, click the browse button
, use the Open File dialog to find a file, and double-click it.

4. (Optional) If you want to place the file into a subfolder previously created in the Content
Explorer or Project Organizer, in the Folder field click
and select the subfolder. Otherwise,
keep the default location.
5. In the File Name field, type a new name for the import file.
6. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click
and select the conditions you
want to apply. Click OK.
7. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the dialog. Next to the File Tags field, click
and select the file tags you want to apply. Click OK.
8. Click Add. The import file is added to the Imports folder in the Project Organizer. The Frame
Import Editor opens to the right.
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Opening a FrameMaker Import File
The following steps show you how to open a FrameMaker import file that you have added to a project. You can then use this file to import FrameMaker documents into the project. See "Importing
FrameMaker Files" on page 33.

HOW TO OPEN A FRAMEMAKER IMPORT FILE FROM THE QUICK LAUNCH BAR
The Quick Launch bar allows you to search for any Flare file or command. It is located in the upperright corner of the interface. You can press CTRL+Q on your keyboard to move focus to the Quick
Launch bar so you can begin typing.

1. In the Quick Launch bar, type a few letters of the name of the file you want to open. Any available results appear in a drop-down list.
2. From the list, click the name of the file.

HOW TO OPEN A FRAMEMAKER IMPORT FILE FROM THE PROJECT ORGANIZER
1. Open the Project Organizer.
2. Double-click the Imports folder. The FrameMaker import files in your project are displayed.
3. Double-click the import file that you want to open. The Frame Import Editor opens to the right.

NOTE: Flare supports FrameMaker 7.0 and newer versions.
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Creating Drop-Down Effects in FrameMaker Source
Documents
The following steps show you how to create a new drop-down effect in a FrameMaker source document (if you plan to import that document into Flare). After you import the document, the dropdown effect will automatically be created in the XML Editor.

HOW TO CREATE A DROP-DOWN EFFECT IN A FRAMEMAKER SOURCE DOCUMENT
The following steps may vary in different versions of FrameMaker.
1. Open the FrameMaker document.
2. In FrameMaker, create the two drop-down paragraph styles that are required for producing
this effect. This is a one-time step in the document. Afterwards, you can simply select the
newly created styles when specifying drop-down text. To create the two styles, do the following.
a. In FrameMaker, select Format > Paragraphs > Designer. The Paragraph Designer opens.
b. From the Commands field, click the down arrow and select New Format. The New
Format dialog opens.
c. In the Tag field, type PullDownButton.
d. Make sure that the Store in Catalog check box has a check mark.
e. Make sure that the Apply to Selection check box does NOT have a check mark in it
(unless you want the style to immediately be applied to the paragraph where your cursor
is placed).
f. Click Create.
g. Follow these same steps to create a paragraph style called PullDownBody.
h. Close the Paragraph Designer.
3. In the FrameMaker document, place your cursor in the paragraph that you want to serve as
the drop-down hotspot in the online output (i.e., when the user clicks that hotspot, the text
below that is identified as the drop-down body will be shown or hidden).
4. From the styles drop-down menu or from the paragraph catalog, select PullDownButton.
5. Highlight the paragraph(s) that you want to serve as the drop-down body in the online output.
6. From the styles drop-down menu or from the paragraph catalog, select PullDownBody.
7. Save the FrameMaker document.
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Creating Hyperlinks in FrameMaker Source Documents
If you are importing Adobe FrameMaker documents and you have created hyperlinks by using "Specify Named Destination" and "Jump to Named Destination" markers, Flare will automatically convert
them to links in your project. Following are steps for creating these hyperlinks in Adobe
FrameMaker. For more information, please refer to the documentation provided with Adobe
FrameMaker.

HOW TO CREATE A HYPERLINK IN A FRAMEMAKER SOURCE DOCUMENT
The following steps may vary in different versions of FrameMaker.
1. Open the Adobe FrameMaker document.
2. In Adobe FrameMaker, place your cursor at the spot to be used as the destination for a link.
This might be a heading that will become a new topic when you import the document. When a
user clicks on the hyperlink (created below), this is the content that will be displayed to end
users.
3. Select Special > Hypertext. The Hypertext dialog opens.
4. From the Command field, select Specify Named Destination.The text "newlink" is added to the
area below.
5. After the text "newlink," type a name to identify the destination (perhaps the name of the heading).
6. Click New Hypertext Marker.
7. Locate the area that you want to serve as the hyperlink. Prepare the area to become a hyperlink, according to the documentation provided with Adobe FrameMaker.
8. Place your cursor in the prepared hypertext area.
9. From the Command field of the Hypertext dialog, select Jump to Named Destination. The text
"gotolink" is added to the text area below.
10. After the text "gotolink," type the name that you gave to the destination marker.
11. Click New Hypertext Marker.
12. Close the Hypertext dialog.
13. Save the Adobe FrameMaker document.
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Creating Passthrough Markers in FrameMaker Source
Documents
A passthrough marker is a special marker that you can insert into your FrameMaker source content
when you have information or code that you plan to import to Flare and want left alone (or "passed
through," leaving it exactly as you have authored it, rather than processing it). A passthrough marker
can be just about anything, as long as supports it in the XHTML code.
You can specify how the marker content should be treated when the FrameMaker document is
imported. The first option is that you can import the marker content as regular text (which is the
default setting). The second option is that you can import the marker content as an XML fragment
(e.g., the first part of a bold tag—<b>—but not the second part). The third option is that you can
import the marker content as a complete XML tag.
You might use a passthrough marker for various reasons, such as for importing a marker as XHTML
or JavaScript code.

EXAMPLE
Let's say you plan to import some FrameMaker documents to Flare and you have locations in those documents where you want to link to CHM files. The problem is that
FrameMaker does not allow you to create links to CHM files in such a way that those
links can then be imported into another software application.
Therefore, you create a passthrough marker in the FrameMaker document, providing
the beginning "href" tag and path to the CHM file. Like this:
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Then you create a second passthrough marker, providing the end tag for the link. Like
this:

When you import the FrameMaker document(s), you can specify that the passthrough
markers should be imported as XML fragments. In Flare, the link to the CHM file will
look and work as it should.

HOW TO CREATE A PASSTHROUGH MARKER IN A FRAMEMAKER SOURCE DOCUMENT
Following are steps for creating these markers inAdobe FrameMaker. For more information, please
refer to the documentation provided with Adobe FrameMaker.
The following steps may vary in different versions of FrameMaker.
1. Open the FrameMaker document.
2. In FrameMaker, create the passthrough marker type that is required for this feature. This is a
one-time step in the document. Afterwards, you can simply select the newly created marker
type when applying it to content. To create the passthrough marker type, do the following.
a. In FrameMaker, select Special > Marker. The Marker dialog opens.
b. From the Marker Type field, click the down arrow and select Edit. The Edit Custom
Marker Type dialog opens.
c. In the field, replace the existing text and type PassThrough.
d. Click Add.
e. Click Done.

CHAPTER 3

59

3. In the FrameMaker document, place your cursor at the location where you want to insert a
passthrough marker.
4. If it is not already displayed, open the Marker dialog (Special > Marker).
5. If the passthrough marker type is not already displayed in the dialog, click the Marker Type
down arrow and select PassThrough.
6. In the Marker Text field, enter the text and/or code that you want to be included in the
marker.
7. Click New Marker.
8. Save the FrameMaker document.
9. In Flare, go through the process for importing the FrameMaker document. When you arrive at
the "Options" page in the Import FrameMaker Wizard or the "Options" tab in the Frame Import
Editor, make sure Enable 'Passthrough' Markers is selected. Then from the Passthrough
Marker Format field, select one of the options:
n

text The marker content will be imported as regular text (default setting).

n

fragment The marker content is imported as an XML fragment (e.g., the first part of a
bold tag—<b>—but not the second part). If you select this option, you will probably need a
second marker in the FrameMaker document to complete the XML tag.

n

xml The marker content is imported as a complete XML tag.
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Creating Topic Alias Markers in FrameMaker for CSH
A topic alias marker is a special marker that you can insert into your FrameMaker source content
wherever you want a new context-sensitive Help (CSH) identifier to be created in Flare (after you
import the FrameMaker document). After the developer "hooks" the CSH identifier with the appropriate user interface element in the application, that imported FrameMaker content will display
when a user opens the CSH in the application's user interface.
You can use these markers as an alternative to creating the identifiers in Flare. For more information see the online Help.
Following are steps for creating these markers in Adobe FrameMaker. For more information, please
refer to the documentation provided with FrameMaker.

HOW TO CREATE A TOPIC ALIAS MARKER FOR CONTEXT-SENSITIVE HELP
The following steps may vary in different versions of FrameMaker.
1. Open the FrameMaker document.
2. In FrameMaker, create the topic alias marker type that is required for this feature. This is a
one-time step in the document. Afterwards, you can simply select the newly created marker
type when applying it to content. To create the topic alias marker type, do the following:
a. In FrameMaker, select Special > Marker. The Marker dialog opens.
b. From the Marker Type field, click the down arrow and select Edit. The Edit Custom
Marker Type dialog opens.
c. In the field, replace the existing text and type TopicAlias.
d. Click Add.
e. Click Done.
3. In the FrameMaker document, place your cursor at the location where you want to insert a
topic alias marker.
Usually you will place the cursor at the beginning of a heading that you want to be the start of
a new online topic in Flare.
4. If it is not already displayed, open the Marker dialog (Special > Marker).
5. If the topic alias marker type is not already displayed in the dialog, click the Marker Type down
arrow and select TopicAlias.
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6. In the Marker Text field, enter the text to be used as the topic ID.
You might simply type the same text that occurs in the paragraph heading. That way, it will be
easily identified by both you and the developer. When typing the topic ID, make sure you use
underscores between words, because spaces are not allowed (e.g., Properties_Dialog).
7. Click New Marker.
8. Close the Marker dialog.
9. Save the FrameMaker document.
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Specifying Custom File Names for FrameMaker Imports
If you import Adobe FrameMaker documents, you can split those documents into multiple topics
based on the styles in them. For example, you might decide to create a new topic at each "Heading
1" style in the FrameMaker document. You can also control the file names given to the new topics
that are created from the imported Imported documents. To do this, you need to insert a custom
"Filename" marker at the appropriate headings in the FrameMaker documents where new topics will
be created.

HOW TO SPECIFY CUSTOM FILE NAMES FOR FRAMEMAKER IMPORTS
Following are steps for creating these markers in Adobe FrameMaker. For more information, please
refer to the documentation provided with FrameMaker. The following steps may vary in different
versions of FrameMaker.
1. Open the FrameMaker document.
2. In FrameMaker, create the filename marker type that is required for this feature. This is a
one-time step in the document. Afterwards, you can simply select the newly created marker
type when applying it to content. To create the filename marker type, do the following:
a. In FrameMaker, select Special > Marker. The Marker dialog opens.
b. From the Marker Type field, click the down arrow and select Edit. The Edit Custom
Marker Type dialog opens.
c. In the field, replace the existing text and type Filename.
d. Click Add.
e. Click Done.
3. In the FrameMaker document, place your cursor at the heading where you want to create a
new file during the import.
4. If it is not already displayed, open the Marker dialog (Special > Marker).
5. If the filename marker type is not already displayed in the dialog, click the Marker Type down
arrow and select Filename.

CHAPTER 3

63

6. In the Marker Text field, enter the name you want to assign to the file (without the file extension).
EXAMPLE
Let's say that you have a place in a FrameMaker document that is using the
Heading 1 style and contains the text "All About Rabbits." You want a new topic to
be created at that point when you import the document. However, you also want
to make sure that the file name for that new topic is simply "Rabbits." Therefore,
you open the FrameMaker document and insert a filename marker at that heading, using the text "Rabbits" for the marker.
When you import the FrameMaker document, you select to split new topics on
certain styles, including the Heading 1 style. After the import is finished, one of
the topics created is named "Rabbits.htm."
7. Click New Marker.
8. Save the FrameMaker document.
9. In Flare, import the FrameMaker document. When you arrive at the "New Topic Styles" page in
the Import FrameMaker Wizard or the "New Topic Styles" tab in the FrameMaker Import
Editor, select the style(s) where you inserted filename markers in the FrameMaker document.
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CHAPTER 4

Importing Doc-To-Help
You can create a project by importing a Doc-To-Help project.

HOW TO IMPORT A DOC-TO-HELP PROJECT
1. Select File > New Project > Doc-To-Help Project.
2. In the dialog that opens, browse for and double-click the Doc-To-Help project file (D2H file) to
be imported. The Import Project Wizard opens.
3. Click Next.
NOTE: If you want to import Doc-To-Help projects to a 64-bit version of Flare, you will
need to download Microsoft Access Database Engine 2010 x64 edition. If you do not
already have this add-in, Flare will prompt you to install it from the Microsoft Download Center.
4. In the Project name field, type a name for the new Flare project that will be created after you
import the Doc-To-Help project.
5. In the Project folder field, either accept the default location for the new project or click
browse for and select a folder.

to

6. Click Next.
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7. If you convert Word source documents to HTML5 source files in Doc-To-Help, and then build a
target, stylesheets are created as a result and saved in the output folder. You can save those
stylesheets in a different folder and then use this page of the wizard to point to them, bringing
them into Flare in one merged CSS file.

TO SAVE DOC-TO-HELP STYLESHEETS AND SELECT THEM WHEN IMPORTING TO
FLARE
a. Make a backup copy of your Doc-To-Help project.
b. Open your Doc-To-Help project that contains Word source files.
c. Select or create a NetHelp target and build the output.
d. Open the project output folder and browse to [Project Name]\NetHelp\LinksExt.
NOTE: The LinksExt folder might contain several stylesheets (separate ones for
each topic), because each time a Word topic uses a style not already used in a
previous topic, Doc-To-Help creates a new stylesheet to account for it. It might
look something like this:

e. Move the LinksExt folder to a new location outside of the NetHelp parent folder, because
this folder will be overwritten when you generate output again. Then rename the folder to
whatever you want your imported stylesheet to be named.
f. In your Doc-To-Help project, click Convert Multiple Documents to HTML5 and proceed
with the wizard to convert all files.
g. Word closes the project when there are no DOC or DOCX files in the project. Therefore, in
Windows navigate to your Program Files\MadCap Software\DocToHelp folder and
double-click the DocToHelp EXE file. Then build a target to update links.
h. In Flare, import your Doc-To-Help project, and on the "Select CSS folders…" page of the
wizard, click
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i. In the dialog that opens, locate and select the folder that you moved and renamed earlier
in this process. Then finish importing the project. If the folder contains multiple
stylesheets, Flare merges them into one CSS file.
8. Click Next.
9. Select an option for how to import links. You can import links as cross-references or as hyperlinks.
10. Select a language for the project.
11. Click Finish.

DOC-TO-HELP FEATURES AND FLARE EQUIVALENTS
The following table shows many of the Doc-To-Help features and their equivalents in Flare. For a
few of these features, the settings are not imported from Doc-To-Help to Flare.
Doc-To-Help
Feature

Flare
Feature

Attributes

Conditions

Bookmarks

Bookmarks

Carousel Widgets

Slideshows

CodeHighlighter
Widgets

Div Tags

Collapsible Sections

Togglers

Comments

Annotations

CSS

Stylesheet

Gallery Widgets

Slideshows
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Notes/Limitations
Doc-To-Help allows conditions on platforms (e.g., all Word targets). However, Flare does not support that feature; therefore
conditions on platforms are not imported.
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Doc-To-Help
Feature
Glossaries

Flare
Feature

Notes/Limitations

Glossaries
and Proxies

Glossary terms are added to a Flare glossary file. Glossary topics
are changed to include Flare's Glossary proxy.
Flare does not support images and text formatting in glossaries,
so those elements are not included in the import.

Groups

Concepts
and
Concept
Links (Alinks)

Groups are similar to Flare's concepts, which can be used for a
couple of things, including the creation of concept links (also
called "See Also links" or "A-links"). When you import a Doc-ToHelp project, groups are converted to concepts in a couple of different ways, depending on how they are created in Doc-To-Help:
n

If you insert a group in Doc-To-Help by dragging the topic
from the Topics pane to the Groups pane, Flare converts
the group to a concept and adds it at the very top of the
topic.

n

If you insert a group in Doc-To-Help from the ribbon, you
are adding it inline, as well as adding it to the Groups pane.
Flare converts the group to a concept and adds it inline as
well as at the very top of the topic. This means that when
you have an A-link, that group might be listed twice in the
output. Therefore, you may need to clean up your topics,
removing the excess concepts.

If you already have a group link in Doc-To-Help, it is imported as a
concept link in Flare.
Inline Text:
Expanded, Drop
down, Pop Up

Expanding
Text
Drop-Down
Text
Text
Popups
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Doc-To-Help
Feature
Keywords

Flare
Feature
Index Keywords

Notes/Limitations
Keywords are similar to Flare's index keywords, which can be
used for a couple of things, including the creation of keyword
links (also called "K-links"). When you import a Doc-To-Help project, keywords are converted to index keywords in a couple of different ways, depending on how they are created in Doc-To-Help:
n

If you insert a keyword in Doc-To-Help by dragging the
topic from the Topics pane to the Index pane, Flare converts the keyword to an index keyword and adds it at the
very top of the topic.

n

If you insert a keyword in Doc-To-Help from the ribbon, you
are adding it inline, as well as adding it to the Index pane.
Flare converts the keyword to an index keyword and adds it
inline as well as at the very top of the topic. This means
that when you have a K-link, that index keyword might be
listed twice in the output. Therefore, you may need to
clean up your topics, removing the excess index keywords.

If you already have an index link in Doc-To-Help, it is imported as
a keyword link in Flare.
Lightbox Widgets

Slideshows

Link Tags

Bookmarks

Note Widgets

Div Tags

Plain Text Variables

Variables

Related Topics

Related Topics Links

Rich Content
Variables

Snippets

Tabs Widgets

Div Tags
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Flare does not support conditioned multiple variable definitions.
Those definitions are imported as multiple variable definitions.
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Doc-To-Help
Feature

Flare
Feature

Notes/Limitations

Targets

Targets

Flare does not import any target settings.

Themes

Skins

Flare does not import any theme settings to skins.

TOCs

TOCs

If a TOC is not customized, it is not imported. An auto-generated
TOC is not in the database when you import, so it is not considered customized. However, you can make a simple change in
a TOC (e.g., move a TOC topic up and then down, not actually
changing it). The TOC will then be considered customized and
will import correctly.

Topic Contents
Widgets

Mini-TOC
Proxies

Although topic contents widgets in Doc-To-Help are similar to
Flare's mini-TOC proxies, they are not identical. Therefore, you
may see some discrepancies after the import conversion.
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CHAPTER 5

Importing a RoboHelp Project
You can create a project by importing a RoboHelp project.

HOW TO IMPORT A ROBOHELP PROJECT
1. Select File > New Project > RoboHelp Project.
2. In the dialog that opens, browse for and double-click the RoboHelp project file (MPJ or XPJ
file) to be imported. The Import Project Wizard opens.
3. In the Project name field, type a name for the new Flare project that will be created after you
import the RoboHelp project.
4. In the Project folder field, either accept the default location for the new project or click
browse for and select a folder.

to

5. Click Next.
6. (Optional) Select Convert all topics at once if you want Flare to immediately convert all of your
topic files to XHTML.
If you remove the check mark from the box, Flare imports the topic files as they are. When
you try to open an imported topic in Flare, a message asks if you want to convert it to XML.
Also, if this option is not selected, Flare will not import index keywords from the source files.
7. (Optional) Select Convert inline formatting to CSS styles if you want Flare to create new
styles based on any "local" formatting that exists in the RoboHelp project files.
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EXAMPLE
If you have applied bold and italic formatting to some text (without using a style),
Flare will create a new style based on that formatting.
8. Click Next.
9. Select a language for the project.
10. Click Finish. A message tells you that the project was converted successfully and will be
opened.
11. Click OK.
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CHAPTER 6

Importing HTML Files
You can import XHTML and HTML files (automatically converting them to XHTML) in the following
ways:
n

Import Into a New Project

n

Import Into an Existing Project (From the Wizard)

n

Import Into an Existing Project (From the Import Editor)
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HOW TO IMPORT HTML FILES
1. Do the following, depending on how you are importing your files:

IMPORT INTO A NEW PROJECT
a. Select Project > Import > HTML File Set.
The Import HTML Files Wizard opens.
b. Select Import into a new project.
c. In the Project name field, type a name for the new Flare project that will be created
after you perform the import.
d. In the Project folder field, either accept the default location for the new project or click
to find and select a folder.
e. From the Output Type field, select the primary target for your project.

IMPORT INTO AN EXISTING PROJECT (WIZARD)
a. Select Project > Import > HTML File Set.
The Import HTML Files Wizard opens.
b. Select Import into this project.

IMPORT INTO AN EXISTING PROJECT (IMPORT EDITOR)
Do one of the following:

IF YOU DO NOT YET HAVE AN HTML IMPORT FILE
a. Complete the steps for adding an import file. See "Additional HTML Tasks" on page 78.
b. Open the file in the HTML Import Editor.

IF YOU ALREADY HAVE AN HTML IMPORT FILE
a. In the Project Organizer, expand the Imports subfolder.
b. Double-click the appropriate import file. The file opens in the HTML Import Editor to the
right.
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2. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Source Files tab.

3. Click one of the following:
In the dialog that opens, find and select the files you want to import. You can hold the SHIFT key
to select a range, or you can hold the CTRL key to select individual items. When you are finished, click Open.
In the dialog that opens, find and select a folder containing HTML files you want to import. When
you select a folder to import, the wizard imports all files within that folder that have an .htm,
.html, or .xhtml extension. If you later re-import HTML files into the project, Flare checks to see
if any of the files in the source folder have changed. It also determines whether files have been
deleted or added, and it updates the source files list accordingly. When you are finished, click
Open.

4. You can use the following options as necessary:
This opens the file that is selected in the list.
This opens the HTML to XHTML Conversion dialog, which lets you see how the
selected file looks in HTML and how it will look after its conversion to XHTML.
Link Generated
Files to
Source
Files

This creates a connection between the original files and the files that are created as a result of the import. This is useful if you want to continue editing the
content outside of Flare, instead of editing in the Flare project. Flare recognizes when changes have been made to the source documents and reminds
you to re-import the documents to ensure the Flare project also reflects the
changes. If you use this option, a link icon is added to the top of a linked file in
the Flare interface. This lets you know that you need to edit the source file,
rather than editing this file. If you remove the connection to the source file, this
icon no longer displays on the file. Please note that if you have bound the project to source control, the icons used for source control take precedence over
the link icon.
This removes the selected file(s) from the list.
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This moves the selected file higher in the list (if you have more than one file to
import). The file at the top is used for the name of the content folder holding
the imported topics in Flare. Also, the order determines how the imported files
are arranged in the Flare TOC that is created as a result.
This moves the selected file lower in the list (if you have more than one file to
import).
5. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Options tab.

6. Click Next.
7. You can use the following options as necessary:
n

Import linked HTML files Select this option if you want to automatically bring in other files
that are linked to those you selected on the previous page. For example, if you import
Doc1.htm, which contains a hyperlink to Doc2.htm, this option imports Doc2.htm as well.

n

Import resources Select this option if you want to include any supporting resource files
(e.g., stylesheets, images, multimedia files) in the import. Then select one of the following:
l

l

n

Keep existing structure The supporting resources files will be copied into folders with
the same names and hierarchy as those used in the source.
To project resources folder The supporting files will be placed in the Resources
folder in your Flare project.

Auto-reimport before 'Generate Output' This is also known as "Easy Sync." If you created
a connection between your source files and the Flare project earlier in the wizard, you will
likely make future content changes in the source files. When you make such changes,
the source files need to be re-imported into the project so that they can be included in the
output. You have the option of re-importing the files manually. However, you can also tell
Flare to do this for you automatically, so that you do not have to. Select this option if you
want Flare to automatically re-import files when you attempt to build output.
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8. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Finish. The Accept Imported Documents dialog opens. The files that will be
created as a result of the import are listed on the left. A preview of each file can be seen
to the right when you click the file.

n

Import Editor In the local toolbar click Import (if this is the first time importing files) or
Reimport (if files have been imported previously). The Accept Imported Documents dialog opens. The files that will be created as a result of the import are listed on the left. A
preview of each file can be seen to the right when you click the file.

9. When you are finished previewing the files to be created, click Accept.

NOTE: A link icon displays on tabs in the XML Editor next to file names that are imported
from and linked to another file or Flare project. However, if you are also using the built-in
source control technology, the source control icons have a higher precedence and will
therefore be displayed instead.
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Additional HTML Tasks
Following are some other HTML file-related tasks that you can perform in Flare when it comes to
importing.
n

Add HTML Import File See "Adding an HTML Import File" below.

n

Open HTML Import File See "Opening an HTML Import File" on page 80.

Adding an HTML Import File
The following steps show you how to add an HTML import file, which is used to import HTML files
into a project.

HOW TO ADD AN HTML IMPORT FILE TO A PROJECT
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Project ribbon. In the Content section select New > Import File > Add
HTML Import File.

n

Right-Click In the Project Organizer, right-click on the Imports folder and from the context
menu select Add HTML Import File.

The Add File dialog opens.
2. In the File Type field at the top, make sure HTML Import File is selected.
3. In the Source area select one of the following:
n

New from template Choose either the factory template file or one of your own customized template files as a starting point. The new file will take on all of the settings contained in the template. If you want to use the factory template provided by Flare, expand
the Factory Templates folder and click on a template file. If you want to use your own customized template file, expand the appropriate folder and click on a file. For more information about templates, see the online Help.

n

New from existing Choose an existing file of the same type as a starting point for your
new file. As with template files, your new file will take on all of the settings contained in
the file you select. To use this option, click the browse button
, use the Open File dialog to find a file, and double-click it.
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4. (Optional) If you want to place the file into a subfolder previously created in the Content
Explorer or Project Organizer, in the Folder field click
and select the subfolder. Otherwise,
keep the default location.
5. In the File Name field, type a new name for the import file.
6. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click
and select the conditions you
want to apply. Click OK.
7. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the dialog. Next to the File Tags field, click
and select the file tags you want to apply. Click OK.
8. Click Add. The import file is added to the Imports folder in the Project Organizer. The HTML
Import Editor opens to the right.
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Opening an HTML Import File
The following steps show you how to open an HTML import file that you have added to a project.
You can then use this file to import HTML files into the project. See "Importing HTML Files" on page
73.

HOW TO OPEN AN HTML IMPORT FILE FROM THE QUICK LAUNCH BAR
The Quick Launch bar allows you to search for any Flare file or command. It is located in the upperright corner of the interface. You can press CTRL+Q on your keyboard to move focus to the Quick
Launch bar so you can begin typing.

1. In the Quick Launch bar, type a few letters of the name of the file you want to open. Any available results appear in a drop-down list.
2. From the list, click the name of the file.

HOW TO OPEN AN HTML IMPORT FILE FROM THE PROJECT ORGANIZER
1. Open the Project Organizer.
2. Double-click the Imports folder. The HTML import files in your project are displayed.
3. Double-click the import file that you want to open. The HTML Import Editor opens to the right.
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CHAPTER 7

Importing HTML Help
You can create a project by importing an HTML Help project (HHP file).

HOW TO IMPORT AN HTML HELP PROJECT (HHP)
1. Select File > Import Project > HTML Help Project (HHP).
2. In the dialog that opens, browse for and double-click the HTML Help file (HHP file) to be imported. The Import Project Wizard opens.
3. In the Project name field, type a name for the new Flare project that will be created after you
import the HTML Help project.
4. In the Project folder field, either accept the default location for the new project or click
browse for and select a folder.

to

5. Click Next.
6. (Optional) Select Convert all topics at once if you want Flare to immediately convert all of your
topic files to XHTML.
If you remove the check mark from the box, Flare imports the topic files as they are. When
you try to open an imported topic in Flare, a message asks if you want to convert it to XHTML.
Also, if this option is not selected, Flare will not import index keywords from the source files.
7. (Optional) Select Convert inline formatting to CSS styles if you want Flare to create new
styles based on any "local" formatting that exists in the HTML Help project files.
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EXAMPLE
If you have applied bold and italic formatting to some text (without using a style),
Flare will create a new style based on that formatting.
8. Click Next.
9. Select a language for the project.
10. Click Finish. A message tells you that the project was converted successfully and will be
opened.
11. Click OK.
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CHAPTER 8

Importing CHM Files
You can create a project by importing an HTML Help (CHM) file.

HOW TO IMPORT AN HTML HELP (CHM) FILE
1. Select File > New Project > HTML Help File (CHM).
2. In the dialog that opens, browse for and double-click the CHM file to be imported. The Import
Project Wizard opens.
3. Click Next.
4. In the Project name field, type a name for the new Flare project that will be created after you
import the CHM file.
5. In the Project folder field, either accept the default location for the new project or click
find and select a folder.

to

6. Click Next.
7. (Optional) Select Convert all topics at once if you want Flare to immediately convert all of your
topic files to XHTML.
If you remove the check mark from the box, Flare imports the topic files as they are. When
you try to open an imported topic in Flare, a message asks if you want to convert it to XHTML.
Also, if this option is not selected, Flare will not import index keywords from the source files.
8. (Optional) Select Convert inline formatting to CSS styles if you want Flare to create new
styles based on any "local" formatting that exists in the HTML Help file.
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EXAMPLE
If you have applied bold and italic formatting to some text (without using a style),
Flare will create a new style based on that formatting.
9. Click Next.
10. Select a language for the project.
11. Click Finish. A message tells you that the project was converted successfully and will be
opened.
12. Click OK.

CHAPTER 8

84

CHAPTER 9

Converting Author-it Files
MadCap Software has created an Author-it ® Converter, which lets you create a new Flare project
based on Author-it Files. This utility uses the published XML output from Author-it and converts it to
a Flare project, while maintaining all project and source files.

SYSTEM REQUIREMENTS
n

MadCap Flare 10 or newer

n

Microsoft .Net 4.5.1 (installed with the software if needed)

n

Microsoft Visual C++ Redistributables (installed with the software if needed)

n

Minimum 2048 MB memory (RAM)

n

Minimum 150 MB available hard drive space (additional space depending on size of XML files
to be converted)

n

Microsoft Windows 7 or newer, 32- or 64-bit, including all required updates
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HOW TO DOWNLOAD AND INSTALL THE AUTHOR-IT CONVERTER
1. Click the following to download and save the installation file locally:
Download Author-it Converter Utility
2. Unzip the archive:
a. Right-click AuthorItConverterSetup.exe and choose Properties.
b. Verify the EXE file is not being blocked (located on the General tab). This often happens
with network and Windows security.
n

If the option to unblock the EXE is available, check the option and click OK.

n

If no option to unblock exists, the above steps are not needed.

3. Run AuthorItConverterSetup.exe with elevated privileges (Run as Administrator).
4. Follow the prompts to install the utility.

HOW TO USE THE AUTHOR-IT CONVERTER
1. From the MadCap Software program group, launch Author-it to Flare Converter.
2. Select the location and the Author-it XML file by clicking the browse button […].
3. Select a location where the Flare project should be saved by clicking the browse button […].
4. Select Content Path Options and choose one of the following:
n

Author-it Keeps the existing folder structure outlined in the XML

n

Flat Puts all topics at the root level under the Content folder

n

Condensed Removes all empty folders from the XML structure; maintains only folders
with topics in the Content Explorer

5. Click Convert. The utility begins. A log report will be sent to the Flare project folder for
troubleshooting purposes.
6. When the conversion process is complete, click Yes to open the folder.
7. Double-click the project.flprj file to open the project in Flare.
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HOW ELEMENTS ARE CONVERTED FROM AUTHOR-IT TO FLARE
Certain elements from Author-it converted to their closest counterparts in Flare. The following table
describes this.
Author-it Element

Flare Element

Notes

Context IDs

Context IDs

Context IDs and values are converted to alias and header files.

Embedded topics

Converted to snippets

These are placed in Resources
folder in Flare.

Glossaries

Glossaries

Images

Images

Index keywords

Index keywords

Styles

Styles

Table of contents of Author-it
books

Converted to topics

Variables

Variables

These are placed in Resources
folder in Flare.

Stylesheets are placed in
Resources folder in Flare.

Variables and all permutations
are converted.
Variables embedded in variables are not supported in Flare
at this time. In this case, each
definition is added as a permutation of the variable.

NOTE: The XML files from Author-it are from the Publish option in the Author-it software.

NOTE: Topics without headings will be named "Topic####.htm" where the # is the Object
ID of the topic in the XML.
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CHAPTER 10

Importing DITA Files
Darwin Information Typing Architecture (DITA) file content is supported in Flare. DITA is an XMLbased markup language with its own schema for authoring, producing, and delivering technical
information. It is a standard of the Organization for the Advancement of Structured Information
Standards (OASIS), and it consists of a set of design principles for creating "information-typed" modules at a topic level and for using that content in various delivery modes.
You can import DITA files in the following ways:
n

Import Into a New Project

n

Import Into an Existing Project (From the Wizard)

n

Import Into an Existing Project (From the Import Editor)
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HOW TO IMPORT DITA FILES
1. Do the following, depending on how you are importing your files:

IMPORT INTO A NEW PROJECT
a. Select Project > Import > DITA Document Set.
The Import DITA Wizard opens.
b. Select Import into a new project.
c. In the Project name field, type a name for the new Flare project that will be created
after you perform the import.
d. In the Project folder field, either accept the default location for the new project or click
to find and select a folder.
e. From the Output Type field, select the primary target for your project.

IMPORT INTO AN EXISTING PROJECT (WIZARD)
a. Select Project > Import > DITA Document Set.
The Import DITA Wizard opens.
b. Select Import into this project.

IMPORT INTO AN EXISTING PROJECT (IMPORT EDITOR)
Do one of the following:

IF YOU DO NOT YET HAVE A DITA IMPORT FILE
a. Complete the steps for adding an import file. See "Additional DITA Tasks" on page 93.
b. Open the file in the DITA Import Editor.

IF YOU ALREADY HAVE A DITA IMPORT FILE
a. In the Project Organizer, expand the Imports subfolder.
b. Double-click the appropriate import file. The file opens in the DITA Import Editor to the
right.

CHAPTER 10

89

2. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Source Files tab.

3. Click

.

4. In the dialog that opens, find and select the files you want to import. You can hold the SHIFT
key to select a range, or you can hold the CTRL key to select individual items. When you are
finished, click Open.
You can select DITA or DITAMAP files.
NOTE: You cannot select multiple DITAMAP files from different folders during the
same import process. You must first import the DITAMAP file(s) from one folder.
Then in the project that is created as a result, you can import the DITAMAP file(s)
from a second folder.
5. You can use the following options as necessary:
This opens the file that is selected in the list.
Link Generated
Files to
Source
Files

This creates a connection between the original files and the files that are created as a result of the import. This is useful if you want to continue editing the
content outside of Flare, instead of editing in the Flare project. Flare recognizes when changes have been made to the source documents and reminds
you to re-import the documents to ensure the Flare project also reflects the
changes. If you use this option, a link icon is added to the top of a linked file in
the Flare interface. This lets you know that you need to edit the source file,
rather than editing this file. If you remove the connection to the source file, this
icon no longer displays on the file. Please note that if you have bound the project to source control, the icons used for source control take precedence over
the link icon.
This removes the selected file(s) from the list.
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This moves the selected file higher in the list (if you have more than one file to
import). The file at the top is used for the name of the content folder holding
the imported topics in Flare. Also, the order determines how the imported files
are arranged in the Flare TOC that is created as a result.
This moves the selected file lower in the list (if you have more than one file to
import).
6. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Options tab.

7. You can use the following options as necessary:
n

Import all Content files to one folder Select this option if you want all of the imported
DITA file content to be placed in just one folder in the Content Explorer.

n

Auto-reimport before 'Generate Output' This is also known as "Easy Sync." If you created
a connection between your source files and the Flare project earlier in the wizard, you will
likely make future content changes in the source files. When you make such changes,
the source files need to be re-imported into the project so that they can be included in the
output. You have the option of re-importing the files manually. However, you can also tell
Flare to do this for you automatically, so that you do not have to. Select this option if you
want Flare to automatically re-import files when you attempt to build output.

n

Preserve ID attributes for elements Every element inside a DITA file has an ID. This ID is
not needed in Flare. However, if you intend to send your output back out to DITA at any
point, you can select this option to make sure the ID is preserved.

8. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Stylesheet tab.
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9. Use this page to specify whether the imported topics should be associated with a stylesheet
and/or styles from your DITA files.
Conversion Styles This opens the DITA Import Styles Editor, which lets you specify how to
convert each property of the DITA elements. If you do not enter a property value, the
value from the DITA file is used. If you enter a property value, it overrides the value from
the DITA file. You can also use the dialog to import and export styles.

n

NOTE: When you import content from DITA files, there is a one-to-one conversion that occurs. For each DITA element in your file, a style class is created in
Flare. For example, let's say you have a paragraph-level DITA element called "topictitle," after you import the file, a style class called "h1.topictitle" might be created in Flare. Or if you have a character-level DITA element called "cmdname,"
after you import the file, a style class called "span.cmdname" might be created
as a result in Flare. If necessary, you can later edit those style classes in Flare. If
you generate DITA output from your project, the style classes are converted
back to DITA elements.
Stylesheet If you already have a CSS file that you want to associate with the imported
files, click the Stylesheet button. Then navigate to the stylesheet and select it.

n

10. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Finish. The Accept Imported Documents dialog opens. The files that will be
created as a result of the import are listed on the left. A preview of each file can be seen
to the right when you click the file.

n

Import Editor In the local toolbar click Import (if this is the first time importing files) or
Reimport (if files have been imported previously). The Accept Imported Documents dialog opens. The files that will be created as a result of the import are listed on the left. A
preview of each file can be seen to the right when you click the file.

11. When you are finished previewing the files to be created, click Accept.

NOTE: A link icon displays on tabs in the XML Editor next to file names that are imported
from and linked to another file or Flare project. However, if you are also using the built-in
source control technology, the source control icons have a higher precedence and will
therefore be displayed instead.
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Additional DITA Tasks
Following are some other DITA-related tasks that you can perform in Flare when it comes to importing.
n

Add DITA Import File See "Adding a DITA Import File" below.

n

Open DITA Import File See "Opening a DITA Import File" on page 95.

Adding a DITA Import File
The following steps show you how to add a DITA import file, which is used to import DITA file content into a project.

HOW TO ADD A DITA IMPORT FILE TO A PROJECT
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Project ribbon. In the Content section select New > Import File > Add
DITA Import File.

n

Right-Click In the Project Organizer, right-click on the Imports folder and from the context
menu select Add DITA Import File.

The Add File dialog opens.
2. In the File Type field at the top, make sure DITA Import File is selected.
3. In the Source area select one of the following:
n

New from template Choose either the factory template file or one of your own customized template files as a starting point. The new file will take on all of the settings contained in the template. If you want to use the factory template provided by Flare, expand
the Factory Templates folder and click on a template file. If you want to use your own customized template file, expand the appropriate folder and click on a file. For more information about templates, see the online Help.

n

New from existing Choose an existing file of the same type as a starting point for your
new file. As with template files, your new file will take on all of the settings contained in
the file you select. To use this option, click the browse button
, use the Open File dialog to find a file, and double-click it.
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4. (Optional) If you want to place the file into a subfolder previously created in the Content
Explorer or Project Organizer, in the Folder field click
and select the subfolder. Otherwise,
keep the default location.
5. In the File Name field, type a new name for the import file.
6. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click
and select the conditions you
want to apply. Click OK.
7. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the dialog. Next to the File Tags field, click
and select the file tags you want to apply. Click OK.
8. Click Add. The import file is added to the Imports folder in the Project Organizer.
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Opening a DITA Import File
The following steps show you how to open a DITA import file that you have added to a project. You
can then use this file to import DITA file content into the project. See "Importing DITA Files" on page
88.

HOW TO OPEN A DITA IMPORT FILE FROM THE QUICK LAUNCH BAR
The Quick Launch bar allows you to search for any Flare file or command. It is located in the upperright corner of the interface. You can press CTRL+Q on your keyboard to move focus to the Quick
Launch bar so you can begin typing.

1. In the Quick Launch bar, type a few letters of the name of the file you want to open. Any available results appear in a drop-down list.
2. From the list, click the name of the file.

HOW TO OPEN A DITA IMPORT FILE FROM THE PROJECT ORGANIZER
1. Open the Project Organizer.
2. Double-click the Imports folder. The DITA import files in your project are displayed.
3. Double-click the import file that you want to open. The DITA Import Editor opens to the right.
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CHAPTER 11

Importing Excel Files
You can import Microsoft Excel files into Flare projects. They can be imported into existing projects
or when creating a new project. The spreadsheet content will be added to tables in Flare when the
import is finished.

HOW TO IMPORT EXCEL FILES
1. Do the following, depending on how you are importing your files:

IMPORT INTO A NEW PROJECT
a. Select Project > Import > MS Excel Workbooks.
The Import Microsoft Excel Wizard opens.
b. Select Import into a new project.
c. In the Project name field, type a name for the new Flare project that will be created
after you perform the import.
d. In the Project folder field, either accept the default location for the new project or click
to find and select a folder.
e. From the Output Type field, select the primary target for your project.

IMPORT INTO AN EXISTING PROJECT (WIZARD)
a. Select Project > Import > MS Excel Workbooks.
The Import Microsoft Word Wizard opens.
b. Select Import into this project.
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2. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Source Files tab.

3. Click

.

4. In the dialog that opens, find and select the files you want to import. You can hold the SHIFT
key to select a range, or you can hold the CTRL key to select individual items. When you are
finished, click Open.
You can select XLS, XLSX, or CSV files.
5. You can use the following options as necessary:
This opens the file that is selected in the list.
Link Generated
Files to
Source
Files

This creates a connection between the original files and the files that are created as a result of the import. This is useful if you want to continue editing the
content outside of Flare, instead of editing in the Flare project. Flare recognizes when changes have been made to the source documents and reminds
you to re-import the documents to ensure the Flare project also reflects the
changes. If you use this option, a link icon is added to the top of a linked file in
the Flare interface. This lets you know that you need to edit the source file,
rather than editing this file. If you remove the connection to the source file, this
icon no longer displays on the file. Please note that if you have bound the project to source control, the icons used for source control take precedence over
the link icon.
This removes the selected file(s) from the list.
This moves the selected file higher in the list (if you have more than one file to
import). The file at the top is used for the name of the content folder holding
the imported topics in Flare. Also, the order determines how the imported files
are arranged in the Flare TOC that is created as a result.
This moves the selected file lower in the list (if you have more than one file to
import).

CHAPTER 11

97

6. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Options tab.

7. You can use the following options as necessary:
n

Import Worksheets as Select the type of Flare file where you want your spreadsheets to
be imported.
l

l

Topics Flare will convert your content and place worksheets into topics. Title text on
a worksheet tab will become a heading in the Flare topic.
Snippets Flare will convert your content and place each worksheet into a separate
snippet.

If you selected “Snippets” above, you can also choose from the following options:
l

l

Include tab titles as headings Any title text on your worksheet tabs will become headings in the Flare snippets.
Create a topic with snippets Flare will create a topic and place the snippets within it.
Otherwise, only the snippets will be created.

n

Organize worksheets into different folders per workbook Select this option if you are
importing multiple workbooks and want the resulting files to be stored in separate folders
in Flare. If you do not select this option when importing multiple workbooks, the files will
all be placed in the same folder in Flare.

n

Import hidden rows/columns This includes any hidden rows and columns in the import.
Otherwise, they will not be part of the imported content.

n

Use first row as column header Select this option if you want Flare to convert the first
row of every spreadsheet into column headers in the Flare tables. If you do not select this
option, the first row will be treated like all the other rows.
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n

Import equations based on settings When importing Excel files that contain equations,
you can select this option to convert them to MathML (the web standard) or images. If
you disable this option, equations from Excel are not converted to Flare.
NOTE: The conversion of equations to MathML versus images depends on
whether you have Excel installed:
l

If Excel is Installed Equations will be imported as MathML.

l

If Excel is not Installed Equations will be imported as PNG images.

NOTE: There is an option in Excel that must be enabled in order for equations to
be imported into Flare. In Excel, select an equation that you’ve inserted, open the
Design ribbon, and in the Tools section, click the small option in the lower-right.
Then in the dialog, select Copy MathML to the clipboard as plain text.

NOTE: If you choose to convert equations to MathML, they are automatically
stored in snippets in Flare. Otherwise, equations will be converted to images. A
snippet or image displaying an equation is automatically placed below the worksheet (in the topic or snippet where the worksheet was converted to a table).
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NOTE: To use this feature, the equation must have been created in Microsoft
Excel 2010 or newer.
Import charts as Any charts in your spreadsheets will be imported as images. Use this
field to select the type of image format to be used.

n

NOTE: An image displaying an imported chart is automatically placed below the
worksheet (in the topic or snippet where the worksheet was converted to a
table).

n

Split topics or snippets by maximum rows You can select this option if you have spreadsheets with a lot of rows and want to divide them into multiple topics or snippets (rather
than one very long topic or snippet). After enabling this option, enter the number of rows
that you want to allow in each topic or snippet before a new topic or snippet is created.

n

Auto-reimport before 'Generate Output' This is also known as "Easy Sync." If you created
a connection between your source files and the Flare project earlier in the wizard, you will
likely make future content changes in the source files. When you make such changes,
the source files need to be re-imported into the project so that they can be included in the
output. You have the option of re-importing the files manually. However, you can also tell
Flare to do this for you automatically, so that you do not have to. Select this option if you
want Flare to automatically re-import files when you attempt to build output.

8. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Styles tab.

9. Use this page to specify how you want the formatting of the Excel files to be treated upon
import. Whether the imported files should retain their look and feel from Excel, or if you want
to associate them with a table stylesheet that you’ve already created in Flare.
n

Preserve MS Excel Styles This retains any formatting from your spreadsheets so that
you can continue to use that look and feel in Flare.
If you have Excel installed, all styles (factory and custom) and local formatting are
retained in Flare. If you do not have Excel installed, only custom styles and local format-
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ting are preserved; factory styles are not retained. Also, if you are using more than one
table style in a worksheet, only one of them will be retained in Flare.
n

Don't Preserve MS Excel Styles This does not keep the formatting used in the Excel
spreadsheets. You can click
in the field below this if you want to associate the
imported spreadsheets with a table stylesheet that you’ve already created in Flare. If
you do not choose a table stylesheet, the files will be imported with plain text.

10. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Filters tab.

11. You can use this page to exclude certain worksheets, or even specific rows and columns,
from the import. By default, all workbooks, worksheets, rows, and columns are selected for
import. You can click the corresponding check boxes to remove check marks, which excludes
items from the import. If you click on a particular worksheet, the area to the right displays the
rows and columns within it. You can then remove check marks for any rows or columns that
you want to exclude.
NOTE: If your worksheets have any hidden rows or columns that you did not include
in the import, you may see that those rows or columns are skipped on this page. For
example, you might see columns A, B, C, and E (where D is hidden).
12. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Finish. The Accept Imported Documents dialog opens. The files that will be
created as a result of the import are listed on the left. A preview of each file can be seen
to the right when you click the file.

n

Import Editor In the local toolbar click Import (if this is the first time importing files) or
Reimport (if files have been imported previously). The Accept Imported Documents dialog opens. The files that will be created as a result of the import are listed on the left. A
preview of each file can be seen to the right when you click the file.

13. When you are finished previewing the files to be created, click Accept.

NOTE: There is a limit of 256 columns per worksheet that can be imported from Excel into
Flare.
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NOTE: Flare supports Microsoft Excel 2010 and newer versions. However, if you have an
older version of Excel, you can open the Options dialog (File > Options), select the General
tab, and choose Import Excel Files Without MS Office.

NOTE: A link icon displays on tabs in the XML Editor next to file names that are imported
from and linked to another file or Flare project. However, if you are also using the built-in
source control technology, the source control icons have a higher precedence and will
therefore be displayed instead.
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Additional Excel Tasks
Following are some other Excel-related tasks that you can perform in Flare when it comes to importing.
n

Add Excel Import File See "Adding an Excel Import File" below.

n

Open Excel Import File See "Opening an Excel Import File" on page 105.

Adding an Excel Import File
The following steps show you how to add an Excel import file, which is used to import Excel files into
a project.

HOW TO ADD AN EXCEL IMPORT FILE TO A PROJECT
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Project ribbon. In the Content section select New > Import File > Add
MS Excel Import File.

n

Right-Click In the Project Organizer, right-click on the Imports folder and from the context
menu select Add MS Excel Import File.

The Add File dialog opens.
2. In the File Type field at the top, make sure MS Excel Import File is selected.
3. In the Source area select one of the following:
n

New from template Choose either the factory template file or one of your own customized template files as a starting point. The new file will take on all of the settings contained in the template. If you want to use the factory template provided by Flare, expand
the Factory Templates folder and click on a template file. If you want to use your own customized template file, expand the appropriate folder and click on a file. For more information about templates, see the online Help.

n

New from existing Choose an existing file of the same type as a starting point for your
new file. As with template files, your new file will take on all of the settings contained in
the file you select. To use this option, click the browse button
, use the Open File dialog to find a file, and double-click it.
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4. (Optional) If you want to place the file into a subfolder previously created in the Content
Explorer or Project Organizer, in the Folder field click
and select the subfolder. Otherwise,
keep the default location.
5. In the File Name field, type a new name for the import file.
6. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click
and select the conditions you
want to apply. Click OK.
7. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the dialog. Next to the File Tags field, click
and select the file tags you want to apply. Click OK.
8. Click Add. The import file is added to the Imports folder in the Project Organizer.
After you add the new import file, you can import Excel files into the project. See "Importing Excel
Files" on page 96.
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Opening an Excel Import File
The following steps show you how to open an Excel import file that you have added to a project. You
can then use this file to import Excel files into the project. See "Importing Excel Files" on page 96.

HOW TO OPEN AN EXCEL IMPORT FILE FROM THE QUICK LAUNCH BAR
The Quick Launch bar allows you to search for any Flare file or command. It is located in the upperright corner of the interface. You can press CTRL+Q on your keyboard to move focus to the Quick
Launch bar so you can begin typing.

1. In the Quick Launch bar, type a few letters of the name of the file you want to open. Any available results appear in a drop-down list.
2. From the list, click the name of the file.

HOW TO OPEN AN EXCEL IMPORT FILE FROM THE PROJECT ORGANIZER
1. Open the Project Organizer.
2. Double-click the Imports folder. The Excel import files in your project are displayed.
3. Double-click the import file that you want to open. The Excel Import Editor opens to the right.
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CHAPTER 12

Importing Other Files
You can import a wide variety of individual files into a Flare project.
This chapter discusses the following:
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Importing Alias Files
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Importing Browse Sequences
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Importing Alias Files
Not only can you add new alias files to Flare, but you can also import existing alias files (FLALI files).

HOW TO IMPORT AN ALIAS FILE
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Project ribbon. In the Content section select New > Advanced > Alias
File.

n

Right-Click In the Project Organizer, right-click on the Advanced folder and from the context menu select Add Alias File.

The Add File dialog opens.
2. In the File Type field at the top, make sure Alias File is selected.
3. Select New from existing and click

.

4. Find and select the FLALI file that you want to import.
5. Click Open. The Source File field now contains the path to the file that you are importing. Also,
the name of the file is displayed in the File Name field.
6. If you want to give the alias file a different name than that for the imported file, click in the File
name field and replace the text.
7. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click
and select the conditions you
want to apply. Click OK.
8. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the dialog. Next to the File Tags field, click
and select the file tags you want to apply. Click OK.
9. Click Add. The alias file is added and opens in the Alias Editor.
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Importing Browse Sequences
Not only can you add a new browse sequences, but you can also import an existing browse
sequence (FLBRS file).

HOW TO IMPORT A BROWSE SEQUENCE
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Project ribbon. In the Content section select New > Advanced >
Browse Sequence.

n

Right-Click In the Project Organizer, right-click on the Advanced folder and from the context menu select Add Browse Sequence.

The Add File dialog opens.
2. In the File Type field at the top, make sure Browse Sequence is selected.
3. Select New from existing and click

.

4. Find and select the FLBRS file that you want to import.
5. Click Open. The Source File field now contains the path to the file that you are importing. Also,
the name of the file is displayed in the File Name field.
6. If you want to give the browse sequence a different name than that for the imported file, click
in the File name field and replace the text.
7. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click
and select the conditions you
want to apply. Click OK.
8. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the dialog. Next to the File Tags field, click
and select the file tags you want to apply. Click OK.
9. Click Add. The browse sequence is added and opens in the Browse Sequence Editor.
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Importing Condition Tag Sets
Not only can you add a new condition tag set, but you can also import an existing condition tag set
(FLCTS file).

HOW TO IMPORT A CONDITION TAG SET
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Project ribbon. In the Content section select New > Condition Tag Set.

n

Right-Click In the Project Organizer, right-click on the Conditional Text folder and from
the context menu select Add Condition Tag Set.

The Add File dialog opens.
2. In the File Type field at the top, make sure Condition Tag Set is selected.
3. Select New from existing and click

.

4. Find and select the FLCTS file that you want to import.
5. Click Open. The Source File field now contains the path to the file that you are importing. Also,
the name of the file is displayed in the File Name field.
6. If you want to give the condition tag set a different name than that for the imported file, click
in the File name field and replace the text.
7. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click
and select the conditions you
want to apply. Click OK.
8. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the dialog. Next to the File Tags field, click
and select the file tags you want to apply. Click OK.
9. Click Add. The condition tag set is added and opens in the Condition Tag Set Editor.
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Importing Destinations
Not only can you add a new destination, but you can also import an existing destination (FLDES file).

HOW TO IMPORT A DESTINATION
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Project ribbon. In the Content section select New > Destination.

n

Right-Click In the Project Organizer, right-click on the Destinations folder and from the
context menu select Add Destination.

The Add File dialog opens.
2. Select New from existing and click

.

3. Find and select the FLDES file that you want to import.
4. Click Open. The Source File field now contains the path to the file that you are importing. Also,
the name of the file is displayed in the File Name field.
5. If you want to give the destination a different name than that for the imported file, click in the
File name field and replace the text.
6. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click
and select the conditions you
want to apply. Click OK.
7. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the dialog. Next to the File Tags field, click
and select the file tags you want to apply. Click OK.
8. Click Add. The destination is added and opens in the Destination Editor.
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Importing Glossaries
Not only can you add a new glossary, but you can also import an existing glossary (FLGLO file).

HOW TO IMPORT A GLOSSARY
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Project ribbon. In the Content section select New > Glossary.

n

Right-Click In the Project Organizer, right-click on the Glossaries folder and from the context menu select Add Glossary.

The Add File dialog opens.
2. Select New from existing and click

.

3. Find and select the FLGLO file that you want to import.
4. Click Open. The Source File field now contains the path to the file that you are importing. Also,
the name of the file is displayed in the File Name field.
5. If you want to give the glossary a different name than that for the imported file, click in the File
name field and replace the text.
6. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click
and select the conditions you
want to apply. Click OK.
7. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the dialog. Next to the File Tags field, click
and select the file tags you want to apply. Click OK.
8. Click Add. The glossary is added and opens in the Glossary Editor.
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Importing Header Files
Not only can you add new header files to Flare, but you can also import existing header files (e.g.,
files with .h or .hh extensions).

HOW TO IMPORT A HEADER FILE
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Project ribbon. In the Content section select New > Advanced >
Header File.

n

Right-Click In the Project Organizer, right-click on the Advanced folder and from the context menu select Add Header File.

The Add File dialog opens.
2. In the File Type field at the top, make sure Header File is selected.
3. Select New from existing and click

.

4. Find and select the header file that you want to import.
5. Click Open. The Source File field now contains the path to the file that you are importing. Also,
the name of the file is displayed in the File Name field.
6. If you want to give the header file a different name than that for the imported file, click in the
File name field and replace the text.
7. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click
and select the conditions you
want to apply. Click OK.
8. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the dialog. Next to the File Tags field, click
and select the file tags you want to apply. Click OK.
9. Click Add. The header file is added.
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Importing Page Layouts
You can import individual page layout (FLPGL) files (such as those from another Flare project or
those sent to you by a contributor).

HOW TO IMPORT A PAGE LAYOUT
1. Select the Project ribbon. In the Content section select New > Page Layout.
The Add File dialog opens.
2. Select New from existing and click

.

3. In the Open dialog, navigate to the FLPGL file that you want to import. Then select it and click
Open. The Source File field now contains the path to the file that you are importing. Also, the
name of the file is displayed in the File Name field.
4. In the File name field, type a new name for the page layout.
5. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click
and select the conditions you
want to apply. Click OK.
6. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the dialog. Next to the File Tags field, click
and select the file tags you want to apply. Click OK.
7. Click Add. The page layout is added to the Resources\PageLayouts subfolder in the Content
Explorer. The Page Layout Editor opens, displaying the page layout.
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Importing Search Filter Sets
Not only can you add new search filter sets, but you can also import an existing search filter set
(FLSFS file).

HOW TO IMPORT A SEARCH FILTER SET
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Project ribbon. In the Content section select New > Advanced > Search
Filter Set.

n

Right-Click In the Project Organizer, right-click on the Advanced folder and from the context menu select Add Search Filter Set.

The Add File dialog opens.
2. Select New from existing and click

.

3. Find and select the FLSFS file that you want to import.
4. Click Open. The Source File field now contains the path to the file that you are importing. Also,
the name of the file is displayed in the File Name field.
5. If you want to give the search filter set a different name than that for the imported file, click in
the File name field and replace the text.
6. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click
and select the conditions you
want to apply. Click OK.
7. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the dialog. Next to the File Tags field, click
and select the file tags you want to apply. Click OK.
8. Click Add. The search filter set is added and opens in the Search Filter Set Editor.
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Importing Skins
Not only can you add a new skin, but you can also import an existing skin (FLSKN file).

HOW TO IMPORT A SKIN
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Project ribbon. In the Content section select New > Skin.

n

Right-Click In the Project Organizer, right-click on the Skins folder and from the context
menu select Add Skin.

The Add File dialog opens.
2. Select New from existing and click

.

3. Find and select the FLSKN file that you want to import.
4. Click Open. The Source File field now contains the path to the file that you are importing. Also,
the name of the file is displayed in the File Name field.
5. If you want to give the skin a different name than that for the imported file, click in the File
name field and replace the text.
6. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click
and select the conditions you
want to apply. Click OK.
7. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the dialog. Next to the File Tags field, click
and select the file tags you want to apply. Click OK.
8. Click Add. The skin is added and opens in the Skin Editor.

NOTE: You can download a variety of free skins with different looks from the MadCap Software website. Simply go to http://madcapsoftware.com/downloads/flareskingallery.aspx.
After downloading the skin, you can import it into your project.
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Importing Snippets
You can create new snippets (FLSNP files) within your project. But if you already have created snippets in another project and want to reuse them in your current project, you can import those snippets.

HOW TO IMPORT A SNIPPET
1. Select the Project ribbon. In the Content section select New > Snippet.
The Add File dialog opens.
2. Select New from existing and click

.

3. Find and select the snippet file that you want to import.
4. Click Open. The Source File field now contains the path to the file that you are importing. Also,
the name of the file is displayed in the File Name field.
5. In the Folder field select a location to store the snippet in the project.
6. If you want to give the snippet a different name than that for the imported file, click in the File
name field and replace the text.
7. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click
and select the conditions you
want to apply. Click OK.
8. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the dialog. Next to the File Tags field, click
and select the file tags you want to apply. Click OK.
9. Click Add. The snippet is added to the Resources\Snippets folder in the Content Explorer and
opens in its own page in the XML Editor.
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Importing Stylesheets
If you already have a stylesheet (CSS file) somewhere else and want to reuse it in your current project, you can import that stylesheet.

HOW TO IMPORT A STYLESHEET
1. Select the Project ribbon. In the Content section select New > Stylesheet. The Add File dialog
opens.
2. Select New from existing and click

.

3. Find and select the stylesheet file that you want to import.
4. Click Open. The Source File field now contains the path to the file that you are importing. Also,
the name of the file is displayed in the File Name field.
5. Leave the selection in the Folder field as Resources/Stylesheets.
6. If you want to give the stylesheet a different name than that for the imported file, click in the
File name field and replace the text.
7. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click
and select the conditions you
want to apply. Click OK.
8. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the dialog. Next to the File Tags field, click
and select the file tags you want to apply. Click OK.
9. Click Add. The stylesheet is added to the Resources\Stylesheets folder in the Content
Explorer and opens in the Stylesheet Editor.

NOTE: You can also import individual styles from another stylesheet. See "Importing Styles"
on the next page.
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Importing Styles
You can manually create new styles in a stylesheet. Another option is to import existing styles from
another stylesheet.

HOW TO IMPORT A STYLE
1. From the Content Explorer, open the stylesheet that you want to modify.
2. In the local toolbar, click the Options button and select Import Styles.
3. Do one of the following, depending on the stylesheet containing the style you want to import.

SELECT A STYLESHEET FROM ONE OF THE AVAILABLE FOLDERS
a. In the Library Folders section, select one of the folders.
n

Factory Stylesheets Holds stylesheets that are provided by Flare. This folder
includes a stylesheet called "SearchHighlight," which provides styles that let you control the look of terms that are highlighted in searches performed by users.

n

My Templates Holds your own stylesheets that you store in your Documents\My
Templates\Stylesheets folder.
NOTE: Depending on your operating system, the folder may be called "My
Documents" instead of "Documents."

n

Project Stylesheets Holds stylesheets added to your project.

b. In the Styles section to the right, select a stylesheet contained in the folder.

SELECT A STYLESHEET NOT FOUND IN ONE THE AVAILABLE FOLDERS
a. Click the Browse button.
b. In the dialog, find and double-click the stylesheet.
4. (Optional) In the [Show Styles] drop-down list, you can make a selection to filter which types
of styles to show in the area below.
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5. (Optional) In the [Medium] drop-down list, you can select a specific medium. This determines
the medium to which the styles are imported in your current stylesheet. If you select "default,"
the imported style properties will be applied to all of the mediums in the other stylesheet. If
you select a custom medium, the imported style properties will be imported to that medium in
the other stylesheet.
6. Click the Import check box next to each style that you want to import.
7. Click OK. The styles are added to the current stylesheet.

NOTE: You can also import entire stylesheets into your project. See "Importing Stylesheets"
on page 117.
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Importing Tables of Contents
Not only can you add a new table of contents (TOC), but you can also import an existing TOC
(FLTOC file).

HOW TO IMPORT A TOC
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Project ribbon. In the Content section select New > Table of Contents.

n

Right-Click In the Project Organizer, right-click on the TOCs folder and from the context
menu select Add Table of Contents.

The Add File dialog opens.
2. Select New from existing and click

.

3. Find and select the FLTOC file that you want to import.
4. Click Open. The Source File field now contains the path to the file that you are importing. Also,
the name of the file is displayed in the File Name field.
5. If you want to give the TOC a different name than that for the imported file, click in the File
name field and replace the text.
6. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click
and select the conditions you
want to apply. Click OK.
7. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the dialog. Next to the File Tags field, click
and select the file tags you want to apply. Click OK.
8. Click Add. The TOC is added and opens in the TOC Editor.
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Importing Targets
Not only can you add a new target, but you can also import an existing target (FLTAR file).

HOW TO IMPORT A TARGET
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Project ribbon. In the Content section select New > Target.

n

Right-Click In the Project Organizer, right-click on the Targets folder and from the context
menu select Add Target.

The Add File dialog opens.
2. Select New from existing and click

.

3. Find and select the FLTAR file that you want to import.
4. Click Open. The Source File field now contains the path to the file that you are importing. Also,
the name of the file is displayed in the File Name field.
5. If you want to give the target a different name than that for the imported file, click in the File
name field and replace the text.
6. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click
and select the conditions you
want to apply. Click OK.
7. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the dialog. Next to the File Tags field, click
and select the file tags you want to apply. Click OK.
8. Click Add. The target is added and opens in the Target Editor.

CHAPTER 12

121

Importing Topics
You can import individual XHTML files (such as those from another Flare project).

HOW TO IMPORT A TOPIC
1. Do one of the following, depending on the part of the user interface you are using:
n

(Recommended) Right-Click In the Content Explorer, right-click on a folder and from the
context menu select Add Topic.
TIP: When adding a new file to the Content Explorer, the recommended method
is to right-click on the folder in the Content Explorer and use the New menu
option. This is the most efficient way to direct the new file to the folder where
you want to store it. That's because the Add File dialog opens when you add a
new content file, and this method ensures that the folder you want is already
selected in that dialog.

n

Ribbon Select the Project ribbon. In the Content section select New > Topic.

n

Local Toolbar In the local toolbar of the Content Explorer click

n

Keyboard Shortcut Press CTRL+T.

.

The Add File dialog opens.
2. Select New from existing and click

.

3. In the Open dialog, navigate to the XHTML file that you want to import. Then select it and click
Open. The Source File field now contains the path to the file that you are importing. Also, the
name of the file is displayed in the File Name field.
4. (Optional) The Folder field is automatically populated with the folder that has focus in the Content Explorer. If you want to place the file into a folder that you previously created in the Content Explorer, in the Folder field click
and select the subfolder. Otherwise, keep the
default location.
5. (Optional) If you want to give the topic a different name than that for the imported file, click in
the File name field and enter the text.
6. (Optional) If you want the heading for the topic to use the same text that you provide for the
file name, leave the 1st Heading field blank. Otherwise, enter the text that you want to use for
the heading in the topic.

CHAPTER 12

122

7. (Optional) If you want the heading for the topic to use the default h1 style, leave the Style field
blank. Otherwise, select a style to apply to the heading in the topic.
8. (Optional) In the Stylesheet field, select a stylesheet to apply to the new topic. If you do not
have a stylesheet in your project, this field remains blank.
9. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click
and select the conditions you
want to apply. Click OK.
10. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the dialog. Next to the File Tags field, click
and select the file tags you want to apply. Click OK.
11. Click Add. The topic is added and opens in the XML Editor.
12. Now simply click inside the topic page in the XML Editor and start typing text or adding any
other elements (e.g., tables, images, cross-references, multimedia) appropriate for the topic.
It is also likely that you will want to apply formatting styles to the topic at this point.

NOTE: You can also import plain HTML files, automatically converting them to XHTML
files. See "Importing HTML Files" on page 73.
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Importing Variable Sets
Not only can you add a new variable set, but you can also import an existing variable set (FLVAR
file).

HOW TO IMPORT A VARIABLE SET
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Project ribbon. In the Content section select New > Variable Set.

n

Right-Click In the Project Organizer, right-click on the Variables folder and from the context menu select Add Variable Set.

The Add File dialog opens.
2. Select New from existing and click

.

3. Find and select the FLVAR file that you want to import.
4. Click Open. The Source File field now contains the path to the file that you are importing. Also,
the name of the file is displayed in the File Name field.
5. (Optional) If you want to place the file into a subfolder previously created in the Content
Explorer or Project Organizer, in the Folder field click
and select the subfolder. Otherwise,
keep the default location.
6. If you want to give the variable set a different name than that for the imported file, click in the
File name field and replace the text.
7. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click
and select the conditions you
want to apply. Click OK.
8. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the dialog. Next to the File Tags field, click
and select the file tags you want to apply. Click OK.
9. Click Add. The variable set is added and opens in the Variable Set Editor.
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CHAPTER 13

Importing Projects from Central
If another user uploads a Flare project to your MadCap Central license and you do not yet have that
project on your computer, you can import it.
In order to import a project, you must be associated with that project in Central. For more information, see the Central online Help.
For this activity, you must have the following permission setting in Central:

For more information about permissions, see the Central online Help.

NOTE: Before binding a new project to Central, or importing a project that is already
uploaded, you can choose between a couple of transfer protocol options (SSH or HTTPS).
See the Flare online Help for more information.

NOTE: If your project is already bound to a third-party source control provider other than Git
(i.e., you are working in a dual-bound model as opposed to a single-bound model), the
Import option in the MadCap Central window pane will be disabled. This is because you
should import your project directly from source control using your non-Central binding.
If you already have the project on your machine, you do not need to re-import the project
from source control. Instead, you can get the latest version from source control by using
the Flare Source Control ribbon.
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Be sure that you have the latest version of the project because when the project is initially
uploaded to Central, a Central ID is added to the project file. You must have the Central ID
in your local copy of the project file in order for Central to recognize that your copy of the
project is linked to the copy in Central.

IMPORTANT: If you are using a Git/Central dual-binding, you can import projects from Git
(using the Import Project From Source Control Wizard) or from Central. The project will be
the same. However, if you import from Central, you will only be able to push changes to and
pull changes from Central. If you import from Git, you will be able to push changes to and
pull changes from Central as well as your main Git repository. This is because the project in
Central has no connection to the original Git repository, and if you import from Central you
will not have those source control bindings.
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HOW TO IMPORT A PROJECT FROM CENTRAL
1. Open MadCap Flare.
2. Select View > MadCap Central. The MadCap Central window pane opens.
3. If you are not yet logged in, enter the same user name (i.e., email) and password that you use
for logging into Central, and click Log In.
4. Click

.

TIP: If this button is disabled, try clicking in the window pane first.
The Import Project dialog opens.
5. If you are a member of more than one MadCap Central license, click in the My Licenses field
and choose the license where the project is located.
6. From the My Projects field, select the project you want to import.
7. Next to the Destination folder field, click
ted project to be stored on your computer.

and choose the folder where you want the impor-

8. Click OK.
9. When the import is finished, you can click Open to launch the project in Flare. Otherwise, you
can click Cancel.
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CHAPTER 14

Importing a Project from
Source Control
This chapter focuses on importing a Flare project from source control. You might use this method,
for example, if you are working on a multi-author project and another member of the team has
placed the Flare project in source control.
You can import projects from source control in the following ways:
n

Apache Subversion "Importing from Subversion" on the next page

n

Git "Importing from Git" on page 131

n

Microsoft Team Foundation Server "Importing from Microsoft TFS" on page 134

n

Microsoft Visual Team Services "Importing from Microsoft Visual Studio Team Services" on
page 136

n

Perforce "Importing from Perforce" on page 139
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Importing from Subversion
This chapter focuses on importing a Flare project from source control. You might use this method,
for example, if you are working on a multi-author project and another member of the team has
placed the Flare project in Apache Subversion.

HOW TO IMPORT A PROJECT FROM SOURCE CONTROL
1. Do one of the following, depending on the part of the user interface you are using:
n

.Ribbon Select File > New Project > Import Project.

n

Source Control Explorer From the View ribbon, open the Source Control Explorer. From
the drop-down, select the Home pane. Click Import Project.

The Import Project from Source Control Wizard dialog opens.
2. From the drop-down, select Subversion.
3. In the Server field, enter the name of the computer or server IP address.
4. Click Next.
5. Next to the Project file field, click Browse. The Browse Source Control Files dialog opens. (You
may need to log in with your user name and password.)
6. Find and click on the Flare project file (FLPRJ) that you want to import. (You may need to log
in with your user name and password.)
7. Click OK.
8. Click Next.
9. In the Project name field, the name of the project being imported is displayed. It is recommended that you leave the name as it is, especially if you are working with other authors on
the project. However, you can enter a different project name if you want.
10. In the Project folder field, either accept the default location for the new project or click
browse for and select a folder.

to

11. Click Finish. The project is imported and loaded into Flare.
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NOTE: If you want to import a project from source control, you can alternatively open the
project file from another location (e.g., a server location), and then use Flare's bind detection functionality to automatically apply available source control bindings to the project.
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Importing from Git
This chapter focuses on importing a Flare project from source control. You might use this method,
for example, if you are working on a multi-author project and another member of the team has
placed the Flare project in Git.

HOW TO IMPORT A PROJECT FROM SOURCE CONTROL
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select File > New Project > Import Project.

n

Source Control Explorer From the View ribbon, open the Source Control Explorer. From
the drop-down, select the Home pane. Click Import Project.

The Import Project from Source Control Wizard dialog opens.
2. From the drop-down, select Git.
3. In the Remote drop-down, enter the remote repository where the project is located.
NOTE: You may need to obtain this information from your system administrator.
4. In the Name field, enter your name.
5. In the Email field, enter your email address.
6. From the Save Per drop-down, select how you want to save your files.
n

User Saves the files in your local folder. Select this option if you are working with other
tools (e.g., Tortoise) or if you want to use the same user identity across multiple projects.

n

Project Saves the files locally to your project. Select this option if you want to use different identities for each project.

7. Click Next.
8. Next to the Project file field, click Browse. The Browse Source Control Files dialog opens. (You
may need to log in with your user name and password.)
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9. (Optional) If the remote you selected in Step 3 requires an SSH certificate, the Certificate Specification dialog opens. In the dialog, do the following:
a. In the Public key field, enter your public SSH key, or use
your network.
b. In the Private key field, enter your private SSH key, or use
your network.

to browse for the key on

to browse for the key on

c. If you want Flare to remember your key information so you do not need to enter it again
later, select the check box next to Save certificate information.
NOTE: SSH keys allow you to establish a secure connection between your computer and your Git source control provider (likewise, using an SSH URL is more
secure than an HTTP URL; you need to use SSH keys if you want to use an
SSH URL). If you do not have a public and private SSH key, your can generate
these keys using your Git source control provider (e.g., Gitlab). Follow the directions provided by your source control provider to add these keys to your Git
account. Once you generate these keys, they are typically found in the
C:\Users\[username]\.ssh folder on your computer.
Public keys typically have a .pub extension. Private keys use the same file name
as the public key, but without the file extension.
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EXAMPLE
Use the following as guides when setting up your URLs and keys.
SSH URL
git@gitlabomnibus.mycompany.corp:MyUserName/myproject.git

HTTP URL
http://gitlabomnibus.mycompany.corp/MyUserName/myproject.git

SSH Private Key
mycompanySSHkey_id_rsa

SSH Public Key
mycompanySSHkey_id_rsa.pub

10. Find and click on the Flare project file (FLPRJ) that you want to import. (You may need to log
in with your user name and password.)
11. Click OK.
12. Click Next..
13. In the Project name field, the name of the project being imported is displayed. It is recommended that you leave the name as it is, especially if you are working with other authors on
the project. However, you can enter a different project name if you want.
14. In the Project folder field, either accept the default location for the new project or click
browse for and select a folder.

to

15. Click Finish. The project is imported and loaded into Flare.

NOTE: If you want to import a project from source control, you can alternatively open the
project file from another location (e.g., a server location), and then use Flare's bind detection functionality to automatically apply available source control bindings to the project.I
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Importing from Microsoft TFS
This chapter focuses on importing a Flare project from source control. You might use this method,
for example, if you are working on a multi-author project and another member of the team has
placed the Flare project in Microsoft Team Foundation Server.

HOW TO IMPORT A PROJECT FROM SOURCE CONTROL
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select File > New Project > Import Project.

n

Source Control Explorer From the View ribbon, open the Source Control Explorer. From
the drop-down, select the Home pane. Click Import Project.

The Import Project from Source Control Wizard dialog opens.
2. From the drop-down, select Microsoft Team Foundation Server.
3. In the Server field, enter the name of the computer or the IP address of the server. You can
also click
to select a "Team Project Collection." If you click this button, the Select Team
Foundation Server Project Collection dialog opens, and you can do the following.
a. To add a server, click

. The Add Team Foundation Server dialog opens.

b. Enter the name or URL of the server.
c. Enter the path and port number.
d. Select the protocol (HTTP or HTTPS).
NOTE: You may need to obtain this information from your system administrator.
Click OK in the dialogs until you return to the main wizard page.

NOTE: If you run into issues in this dialog, chances are your user permissions do not
have access to all of the collections on the TFS server. Please try to enter in the
server/collection path manually.

4. Next to the Team Project field, click
and Password fields.

. If the Log In dialog opens, complete the User name

5. Click on the Team Foundation project.
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6. Click Next.
7. Next to the Project file field, click Browse. The Browse Source Control Files dialog opens.
8. Find and click on the Flare project file (FLPRJ) that you want to import. (You may need to log
in with your user name and password.)
9. Click OK.
10. Click Next.
11. In the Project name field, the name of the project being imported is displayed. It is recommended that you leave the name as it is, especially if you are working with other authors on
the project. However, you can enter a different project name if you want.
12. In the Project folder field, either accept the default location for the new project or click
browse for and select a folder.

to

13. Click Finish. The project is imported and loaded into Flare.

NOTE: If you want to import a project from source control, you can alternatively open the
project file from another location (e.g., a server location), and then use Flare's bind detection functionality to automatically apply available source control bindings to the project.
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Importing from Microsoft Visual Studio
Team Services
Flare includes Microsoft Team Foundation Server support for Microsoft Visual Studio Team Services (VSTS). If you manage your source control projects with Microsoft's online version of Visual
Studio, you can import these projects to Flare.
Use the following steps if you have already created a Flare project and want to import it to Flare
from Microsoft VSTS.

HOW TO IMPORT A PROJECT FROM SOURCE CONTROL
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select File > New Project > Import Project.

n

Source Control Explorer From the View ribbon, open the Source Control Explorer. From
the drop-down, select the Home pane. Click Import Project.

The Import Project from Source Control Wizard dialog opens.
2. From the drop-down, select Microsoft Team Foundation Server.
3. In the Server field, enter the URL of the project's "Default Collection."
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NOTE: When binding to a VSTS project using TFS, you must manually enter the
URL in the Server field. You can only browse for a server location when binding to a
local project using TFS.

NOTE: You may need to obtain this information from your system administrator.
Click OK in the dialogs until you return to the main wizard page.

NOTE: If you run into issues in this dialog, chances are your user permissions do not
have access to all of the collections on the TFS server. Please try to enter in the
server/collection path manually.

. You may need to log in to Microsoft VSTS. If the Log
4. Next to the Team Project field, click
In dialog opens, complete the User name and Password fields.
The Browse Team Foundation Server dialog appears.
NOTE: When you use Visual Studio Team Services with Flare, you will be prompted to
log in to Visual Studio Team Services via a dialog in Flare. Your login credentials are
stored in a cookie in the Internet Explorer Temporary Internet Files folder:
C:\Users\[username]\AppData\Local\Microsoft\Windows\INetCache
When this cookie expires, you will logged out of Visual Studio Team Services, and
Flare will prompt you to log in again.
5. Click on the Team Foundation project.
6. Click OK.
7. Click Next.
8. Next to the Project file field, click Browse. The Browse Source Control Files dialog opens.
9. Find and click on the Flare project file (FLPRJ) that you want to import. (You may need to log
in with your user name and password.)
10. Click OK.
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11. Click Next.
12. In the Project name field, the name of the project being imported is displayed. It is recommended that you leave the name as it is, especially if you are working with other authors on
the project. However, you can enter a different project name if you want.
13. In the Project folder field, either accept the default location for the new project or click
browse for and select a folder.

to

14. Click Finish. The project is imported and loaded into Flare.
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Importing from Perforce
This chapter focuses on importing a Flare project from source control. You might use this method,
for example, if you are working on a multi-author project and another member of the team has
placed the Flare project in Perforce.

HOW TO IMPORT A PROJECT FROM SOURCE CONTROL
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select File > New Project > Import Project.

n

Source Control Explorer From the View ribbon, open the Source Control Explorer. From
the drop-down, select the Home pane. Click Import Project.

The Import Project from Source Control Wizard dialog opens.
2. From the drop-down, select Perforce.
3. In the Server field, enter the server address.
4. Next to the User field, click

. The Select User dialog opens.

5. Select a user and click OK. (Users are set up separately in Perforce.)
6. Next to the Location field, click Browse. The Browse Depots and Streams dialog opens.
7. Select a depot or stream (i.e., the name of your Flare project).
8. Click OK.
9. Click Next.
10. Next to the Project file field, click Browse. The Browse Source Control Files dialog opens. (You
may need to log in with your user name and password.)
11. Find and click on the Flare project file (FLPRJ) that you want to import. (You may need to log
in with your user name and password.)
12. Click OK.
13. Click Next.
14. In the Project name field, the name of the project being imported is displayed. It is recommended that you leave the name as it is, especially if you are working with other authors on
the project. However, you can enter a different project name if you want.
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15. In the Project folder field, either accept the default location for the new project or click
browse for and select a folder.

to

16. Click Finish. The project is imported and loaded into Flare.

NOTE: If you want to import a project from source control, you can alternatively open the
project file from another location (e.g., a server location), and then use Flare's bind detection functionality to automatically apply available source control bindings to the project.
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CHAPTER 15

Additional Importing Tasks
In addition to the many features already covered in this guide, there are other import-related tasks
that you can perform in Flare.
This chapter discusses the following:
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Disabling Auto-Sync of Import Files

144

Overwriting Imported Documents
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Adding Project Import Files
The Import Flare Project Wizard guides you through the steps for importing Flare files from another
project. When you use this wizard, an import file is created automatically and placed in the Imports
folder in the Project Organizer.
However, as an alternative to using the Import Flare Project Wizard, you can add an import project
file manually. After you create this file, it will be stored in the Imports folder in the Project Organizer.
If you want to manually re-import files from the project in the future, you can open this file (with an
.flimpfl extension). Your settings are saved in the file, and you can simply initiate a re-import.

HOW TO ADD A PROJECT IMPORT FILE MANUALLY
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Project ribbon. In the Content section select New > Import File > Flare
Project Import File.

n

Right-Click In the Project Organizer, right-click on the Imports folder and from the context
menu select Add Flare Project Import File.

2. In the File Type field at the top, make sure Flare Import File is selected.
3. In the Source area select one of the following:
n

New from template Choose either the factory template file or one of your own customized template files as a starting point. The new file will take on all of the settings contained in the template. If you want to use the factory template provided by Flare, expand
the Factory Templates folder and click on a template file. If you want to use your own customized template file, expand the appropriate folder and click on a file. For more information about templates, see the online Help.

n

New from existing Choose an existing file of the same type as a starting point for your
new file. As with template files, your new file will take on all of the settings contained in
the file you select. To use this option, click the browse button
, use the Open File dialog to find a file, and double-click it.

4. (Optional) If you want to place the file into a subfolder previously created in the Content
Explorer or Project Organizer, in the Folder field click
and select the subfolder. Otherwise,
keep the default location.
5. In the File Name field, type a new name for the import file.
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6. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click
and select the conditions you
want to apply. Click OK.
7. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the dialog. Next to the File Tags field, click
and select the file tags you want to apply. Click OK.
8. Click Add. The import file is added to the Project Organizer. The Project Import Editor opens
to the right.
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Disabling Auto-Sync of Import Files
Let's say you have imported Microsoft Word, Adobe FrameMaker, Microsoft Excel, or Flare files
from another project, and when doing so, you selected the "Easy Sync" option to automatically reimport the files when you generate output. If you want to override that Easy Sync setting for a specific target, you can do so by using the steps below. Therefore, if you want to re-import any of the
files, you will need to do so manually. See "Importing Word Files" on page 8, "Importing FrameMaker
Files" on page 33, and "Importing Excel Files" on page 96.
You might decide to use this option, for example, if you are testing the generation of output and do
not want to wait the extra time for the files to be imported. After you finish your testing, you can
deselect this option to return to the automatic imports of the files.

HOW TO DISABLE AUTO-SYNC OF IMPORT FILES
1. Open the target.
2. In the Target Editor, select the General tab.
3. Select the check box labeled Disable auto-sync of all import files.
4. Click
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Overwriting Imported Documents
If you have imported Microsoft Word or Adobe FrameMaker documents and maintained a link with
the source documents, you receive a warning when you try to save changes in the imported document. One of the options that you can select is to save the document and ignore the warning. In
this case, the local file remains linked to the source file, even though it is different. When you
attempt to re-import that file from the source, you are given the opportunity to overwrite the local
file.

HOW TO OVERWRITE IMPORTED DOCUMENTS
1. From the Imports folder in the Project Organizer, open an import file, and attempt to re-import
a file that you have changed locally. The Confirm Overwrite Documents dialog opens.
2. Click the Overwrite check box next to any files that you want to overwrite with the source file.
You can use the options at the bottom of the dialog to quickly select multiple files.
n

Select All Use this button to automatically add check marks next to all files in the list.

n

Clear All Use this button to automatically remove check marks from all files in the list.

n

Check Selected Use this button to automatically add check marks next to all files in the
list that are selected (i.e., you have highlighted them). You can hold the SHIFT key to
select a range, or you can hold the CTRL key to select individual items.

n

Clear Selected Use this button to automatically remove check marks from all files in the
list that are selected (i.e., you have highlighted them). You can hold the SHIFT key to
select a range, or you can hold the CTRL key to select individual items.

3. Click OK.
4. In the dialog that opens, click either Yes or Yes All to replace the files.
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APPENDIX

PDFs
The following PDFs are available for download from the online Help.
TUTORIALS

Getting Started Tutorial
Product Foldout Tutorial
Side Navigation Tutorial
Top Navigation Tutorial
USER GUIDES

Accessibility Guide

HTML Help Guide

Analysis and Reports Guide

HTML5 Guide

Architecture Guide

Images Guide

Autonumbers Guide

Importing Guide

Condition Tags Guide

Index Guide

Context-sensitive Help Guide

Key Features Guide

Eclipse Help Guide

Language Support Guide

Getting Started Guide

MadCap Central Integration Guide

Global Project Linking Guide

Master Pages Guide
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Micro Content Guide

Source Control Guide: Git

Movies Guide

Source Control Guide: Perforce

Navigation Links Guide

Source Control Guide: Subversion

Plug-In API Guide

Source Control Guide: Team Foundation Server

Print-based Output Guide

Styles Guide

Project Creation Guide

Tables Guide

Pulse Guide

Tables of Contents Guide

QR Codes Guide

Targets Guide

Reports Guide

Templates Guide

Reviews & Contributions Guide

Topics Guide

Search Guide

Touring the Workspace Guide

SharePoint Guide

Transition From FrameMaker Guide

Skins Guide

Variables Guide

Snippets Guide

What's New Guide

CHEAT SHEETS

Folders and Files Cheat Sheet
Print Output Cheat Sheet
Shortcuts Cheat Sheet
Structure Bars Cheat Sheet
Styles Cheat Sheet
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