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CHAPTER 1

Introduction
You can embed Flash, Windows Media, Quicktime, and HTML5 files, as well as videos from your
YouTube or Vimeo account. In addition, you can insert links to movies created in MadCap Mimic.
These elements are supported in online outputs, but in many cases they are also supported in
PDF output (when viewing the PDF in electronic format). For more information about which elements or file types are supported in which output type, see "Multimedia Features and File Types Supported Per Output Format" on page 9.
This chapter discusses the following:
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Flash, HTML5, QuickTime, and Windows Media Movies

6

YouTube and Vimeo

7
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8

Multimedia Features and File Types Supported Per Output Format

9
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Flash, HTML5, QuickTime, and Windows
Media Movies
You can insert Flash, Windows Media, HTML5, or QuickTime movies directly into your Flare topics or
snippets. See "Inserting Movies" on page 19.
There are three ways to insert Flash, Windows Media, QuickTime, and HTML5 movies:
n

Embedded You can use the Insert > Multimedia option. When you use this option, the movie
is embedded into the topic or snippet. In addition, you can specify advanced settings, such
as whether to include controls with the movie (e.g., Play, Pause), whether to automatically
start the movie when it displays, and audio levels. The options available depend on the type
of movie you are inserting. Also, keep in mind that some movie formats may be supported in
some outputs but not in others.

n

Linked You can use the Insert > Hyperlink option. When you use this option, the user must
click the text link in order to open the movie. Also, you can choose to display the movie in
another window.

n

Drag and Drop You can insert embedded movie files by dragging and dropping the movie file
from the Content Explorer or File List window pane to the XML Editor. However, with this
method, you can specify any necessary advanced settings only after the movie file is inserted (to do this, right-click on the inserted movie and select Edit Multimedia).

NOTE: When you insert a movie from outside your project (using the Insert > Multimedia
option), a copy of the file is added to your project. The file is stored by default in the
Resources\Multimedia folder of the Content Explorer.
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YouTube and Vimeo
If you store movies on YouTube or Vimeo, or if you use third-party movies from these providers in
your content, you can add these videos to web-based outputs.
There are two ways to insert YouTube and Vimeo movies:
n

Embedded You can use the Insert > Multimedia option. When you use this option, the movie
is embedded into the topic or snippet. In addition, you can specify advanced settings, such
as whether to automatically start the movie when it displays, and what kind of information to
display on the movie (e.g., movie title, player branding). The options available depend on the
type of movie you are inserting.

n

Linked You can use the Insert > Hyperlink option. When you use this option, the user must
click the text link in order to open the movie. When you insert a YouTube or Vimeo link in
your output, it will send you to the host's website to play the movie.

NOTE: When you insert a YouTube or Vimeo movie (using the Insert > Multimedia option),
these movies are not stored in your Resources > Multimedia folder like other movie types,
because Flare references them from the web.
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Mimic Movie Links
If you have MadCap Mimic installed, you can create videos to be displayed in the output format of
your choice—HTML5, Mimic Movie Format (MMF), Microsoft Silverlight, or Adobe Flash.
After creating a Mimic movie, you can insert a link to it. The movie will open and play in the appropriate window (e.g., movies generated in MMF are viewed in the MadCap Movie Viewer). After you
insert a movie link, a small movie frame icon
displays next to it. You can insert movie links into
topics, tables of contents, or browse sequences. For more information see "Mimic Movie Links in
Topics" on page 37, "Mimic Movie Links in TOCs" on page 41, and "Mimic Movie Links in Browse
Sequences" on page 44.
For more information not provided here—such as details on the different movie output formats—see
the MadCap Mimic online Help.
NOTE: When you insert a Mimic movie link, the appropriate movie files are not copied to
your project's content files. Instead, they are automatically copied to the output files when
you generate the target.
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Multimedia Features and File Types Supported Per Output
Format
Following are multimedia features supported in each output type:

3D Models
(U3D)
Audio/Video
ASF
ASX
AU
AVI4
M4V4
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MID
MIDI
MP3
MP4 4
MPA
MPE
MPEG
MPG
OGG4
OGV4
OPUS
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SWF
WAV
WEBM4
WMA
WMV
MadCap Mimic Movie Links
Flash
(SWF)
Format
HTML5
Format
(Depending on
Browser)4
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Mimic
Movie
Format
Silverlight
Format
Vimeo
Embedded
Videos
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YouTube
Embedded
Videos
1EPUB

support for each element or file type depends on if a particular reader supports it.

2PDF support for 3D

Models requires Adobe Reader 7.0+.

3For this

output, the 3D Model opens in a separate window.

4To view

HTML5 movie output, end users must have a newer browser that supports these types of videos.

5This

file format does not work in Internet Explorer.

6If you generate

Microsoft HTML Help, YouTube videos are rendered smaller than in other outputs and Vimeo Advanced settings are not supported.

However, you can make it work by adding the default meta tag to your target: <meta http-equiv="X-UA-Compatible" content="IE=Edge" />.
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WARNING: Due to issues with Windows Media, these files will not work in the compiled output if the link from the topic to the media file has ../ at the beginning. For example, let's say
you have a topic at the root level of the Content Explorer and another topic that is in a folder
you created. Suppose that each of these topics contains a link to a Windows Media file that
is stored (by default) in the Resources/Multimedia folder in the Content Explorer. The file
will work in the first topic but not in the second. The solution is to move either the topic or
the multimedia file to fix the link. Therefore, you might decide to move the multimedia file
into the folder where the topic is stored. Alternatively, you might move all topics that use
multimedia into one folder. Then, you might place all multimedia files in that same folder or
a subfolder within it.

NOTE: When a PDF is opened, there is initially a blank area where the multimedia item was
inserted. Also, a security message is shown, prompting the user to allow the video to load
once or always.
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After clicking one of these options, the video loads.
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CHAPTER 2

Adding Multimedia Files
You can add many types of multimedia files to your project, which can then be inserted into topics
or snippets.
The following steps show you how to add a multimedia file to your project, without inserting it into a
topic (or snippet). But if you follow the steps for inserting movies into topics or snippets (see "Inserting Movies" on page 19), the multimedia file is automatically added to the project as well.
The traditional location to store a multimedia file in the Content Explorer is in the Resources\Multimedia folder. However, you can store it anywhere in the Content Explorer that you like.
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HOW TO ADD A MULTIMEDIA FILE TO A PROJECT
1. Do one of the following, depending on the part of the user interface you are using:
n

(Recommended) Right-Click In the Content Explorer, right-click on a folder and from the
context menu select New > Multimedia.
TIP: When adding a new file to the Content Explorer, the recommended method
is to right-click on the folder in the Content Explorer and use the New menu
option. This is the most efficient way to direct the new file to the folder where
you want to store it. That's because the Add File dialog opens when you add a
new content file, and this method ensures that the folder you want is already
selected in that dialog.

n

Ribbon Select the Project ribbon. In the Content section select New > Add Multimedia.

The Add File dialog opens.
2. Click the File Type field at the top of the dialog and select Multimedia.
3. In the Source area select one of the following:
n

New from template Choose either the factory template file or one of your own customized template files as a starting point. The new file will take on all of the settings contained in the template. If you want to use the factory template provided by Flare, expand
the Factory Templates folder and click on a template file. If you want to use your own customized template file, expand the appropriate folder and click on a file. For more information about templates, see the online Help.

n

New from existing Choose an existing file of the same type as a starting point for your
new file. As with template files, your new file will take on all of the settings contained in
the file you select. To use this option, click the browse button
, use the Open File dialog to find a file, and double-click it.

Most of the time you will probably use the "New from existing" option to import a multimedia
file from outside your project.
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4. (Optional) The Folder field is automatically populated with the folder that has focus in the Content Explorer. If you want to place the file into a folder that you previously created in the Content Explorer, in the Folder field click
and select the subfolder. Otherwise, keep the
default location.
NOTE: If you want to place non-topic files in a traditional default folder, you must first
make sure that folder exists in the Content Explorer. If it does not exist, you can easily
add it.

Non-Topic File Type

Recommended Default Folder in Content Explorer

Image

Resources > Images

Master Page

Resources > MasterPages

Micro Content

Resources > MicroContent

Multimedia

Resources > Multimedia

Page Layout

Resources > PageLayouts

Snippet

Resources > Snippets

Stylesheet

Resources > Stylesheets

Table Stylesheet

Resources > TableStyles

5. In the File Name field, you can type a new name for the multimedia file.
6. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click
and select the conditions you
want to apply. Click OK.
7. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the dialog. Next to the File Tags field, click
and select the file tags you want to apply. Click OK.
8. Click Add. The multimedia file is added to the Content Explorer.
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CHAPTER 3

Inserting Movies
You can insert Flash, Windows Media, QuickTime, or HTML5 movies directly into your Flare topics or
snippets. You can also insert YouTube and Vimeo movies from the web directly into your topics and
snippets.

INSERTING FLASH, WINDOWS MEDIA, QUICKTIME AND HTML5 MOVIES
There are three ways to insert Flash, Windows Media, QuickTime, and HTML5 movies:
n

Embedded You can use the Insert > Multimedia option. When you use this option, the movie is
embedded into the topic or snippet. In addition, you can specify advanced settings, such as
whether to include controls with the movie (e.g., Play, Pause), whether to automatically start
the movie when it displays, and audio levels. The options available depend on the type of
movie you are inserting. Also, keep in mind that some movie formats may be supported in
some outputs but not in others.

n

Linked You can use the Insert > Hyperlink option. When you use this option, the user must
click the text link in order to open the movie. Also, you can choose to display the movie in
another window.

n

Drag and Drop You can insert embedded movie files by dragging and dropping the movie file
from the Content Explorer or File List window pane to the XML Editor. However, with this
method, you can specify any necessary advanced settings only after the movie file is inserted
(to do this, right-click on the inserted movie and select Edit Multimedia).
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INSERTING YOUTUBE AND VIMEO MOVIES
There are two ways to insert YouTube and Vimeo movies:
n

Embedded You can use the Insert > Multimedia option. When you use this option, the movie is
embedded into the topic or snippet. In addition, you can specify advanced settings, such as
whether to automatically start the movie when it displays, and what kind of information to display on the movie (e.g., movie title, player branding). The options available depend on the type
of movie you are inserting.

n

Linked You can use the Insert > Hyperlink option. When you use this option, the user must
click the text link in order to open the movie. When you insert a YouTube or Vimeo link in your
output, it will send you to the host's website to play the movie.
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HOW TO INSERT AN EMBEDDED MOVIE
1. Open the content file (e.g., topic, snippet).
2. In the XML Editor, place your cursor where you want to insert the movie.
3. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Insert ribbon. In the Multimedia section select the drop-down arrow on
the Multimedia button and choose either Flash Movie, Windows Media Player, Quicktime
Movie, HTML5 Movie, or YouTube/Vimeo.

n

Right-Click Depending on where your cursor is located in the XML Editor, you can also
right-click and from the context menu select Insert > Multimedia.

The Insert Multimedia dialog opens.
4. Select the General tab.
5. Select a movie file to insert. You can do this in various ways.

SELECTING A FILE IN THE PROJECT
a. To select a movie file already in the project, select Multimedia in project.
b. In the area below, find and choose the file. Use the buttons in the local toolbar to view all
files in a list, view files in their folder structure, etc.
Button

Description
Shows all of the files in the project in a list in the area below. If you
click the button again, it switches to a folder tree view. In the list,
you can click the File, Type, or Path column headers to sort the list
alphabetically by that column data.
Shows or hides the folders that the files are stored in.
Shows or hides the files. If you click this button when the Show
Folders button
is selected, the area splits into two. The folder
is shown on the left side, and the files and subfolders within it are
shown on the right.
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Button

Description
If the Show Files button
is the only one selected, you can
click this button to move up one folder level.
Lets you filter the kinds of files shown below. Depending on the
task you are performing, this field may already be populated with
the most appropriate file type(s).

. If you want to select a
c. (Optional) To select a movie file outside of the project, click
movie file that you recently inserted somewhere in your project, click the down arrow in
the field next to
and select the file from the list.

NOTE: If you select a movie file outside the project, that file is then copied and
placed inside the project. The movie file is stored in the Resources\Multimedia
folder of the Content Explorer.
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SELECTING A YOUTUBE OR VIMEO FILE FROM THE WEB
a. To select a movie file on the web, select Multimedia from Web.
b. In the field, enter the location of the movie file you want to use in your project.
EXAMPLE
In the following example, we are linking to a YouTube video.

NOTE: You can only add YouTube and Vimeo files from the web.

NOTE: When you insert a YouTube or Vimeo movie (using the Insert > Multimedia
option), these movies are not stored in your Resources > Multimedia folder like other
movie types, because Flare references them from the web.
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NOTE: You can set YouTube videos to have a specific start time. For example, you
might want the video to begin playing not from its beginning, but rather 1 minute and
30 seconds into the movie. To do this, add the time you want the video to start to the
end of the URL using the format t=(time in minutes and seconds). For example:
https://youtu.be/SI6PHhxHNNA?t=1m30s
The easiest way to do this is to open the video in YouTube, click the Share button,
enter the start time, and copy the URL given.

6. (Optional) If you want to apply a specific style class to the movie, you can select it from the
Style Class field.
EXAMPLE
Let's say that you have created in your stylesheet a class of the object style
called "BigMargin" (i.e., object.BigMargin) and you have set the margin for all
sides of that class to 1 inch. Rather than using the default parent object style
when you insert the movie, you select object.BigMargin from the Style Class
drop-down. As a result, 1 inch of space is added around the movie in the output.
7. (Optional) In the Screen Tip field, you can type a phrase that will appear when the end user
hovers over the movie link in the output. If you want to insert a variable, you can click
. The
variable will appear as syntax in the field, but in the output the variable definition will be
shown.
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8. (Optional) Select the Advanced tab and complete the options as necessary. The options
shown depend on the type of movie file you are inserting.

FLASH OPTIONS
n

Quality Select the quality of the video, from "Low" up to "Best."
l

l

l

l

l

l

n

Low Favors playback speed over appearance and never uses anti-aliasing.
Auto Low Emphasizes speed at first but improves appearance whenever possible.
Playback begins with anti-aliasing turned off. If the Flash Player detects that the processor can handle it, anti-aliasing is turned on.
Auto High Emphasizes playback speed and appearance equally at first but sacrifices
appearance for playback speed if necessary. Playback begins with anti-aliasing
turned on. If the actual frame rate drops below the specified frame rate, anti-aliasing
is turned off to improve playback speed. Use this setting to emulate the View >
Antialias setting in Flash.
Medium Applies some anti-aliasing and does not smooth bitmaps. It produces a better quality than the Low setting, but lower quality than the High setting.
High Favors appearance over playback speed and always applies anti-aliasing. If the
movie does not contain animation, bitmaps are smoothed; if the movie has animation, bitmaps are not smoothed.
Best Provides the best display quality and does not consider playback speed. All output is anti-aliased and all bitmaps are smoothed.

Scale When you insert an embedded movie, a square container represents the area
where the video will be displayed. Just like a regular image, you can resize the container
either by using the settings on the Size tab or by clicking the clicking and dragging the
icon
in the lower-right corner of the container. The settings in this field determine
how the video is displayed in the area represented by the square container.
l

l

CHAPTER 3

Default (Show All) Makes the entire movie visible in the specified area without distortion, while maintaining the original aspect ratio of the movie. Borders may appear
on two sides of the movie.
No border Scales the movie to fill the specified area, without distortion but possibly
with some cropping, while maintaining the original aspect ratio of the movie.
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l

Exact fit Makes the entire movie visible in the specified area without trying to preserve the original aspect ratio. Distortion may occur.

n

Alignment Select where you want the video to be displayed within the container area
(e.g., Left, Right, Bottom, Bottom Right).

n

Auto Play Select this option if you want the video to automatically begin playing when the
topic displays. Otherwise, the user must click the Play button to start the movie.

n

Loop Select this option if you want the movie to play repeatedly.

n

Show Menu Select this option if you want to display the full menu, allowing the user a variety of options to enhance or control playback. If you do not select this option, the menu
contains only the Settings option and the About Flash option.

n

Enable SWLiveConnect Select this option to specify whether the browser should start
Java when loading the Flash Player for the first time.

WINDOWS MEDIA OPTIONS
n

Player Controls Select an option for displaying the player controls (e.g., Play, Pause,
Volume).
l

Full Displays all of the available player controls.

l

None Does not display any player controls.

l

Mini Displays only some of the player controls (Play, Pause, Stop, Mute, Volume).

l

Invisible Hides the movie entirely, while still playing the audio. If you select this
option, you might want to resize the container square in your topic so that it does not
take up so much space in the output. The user will simply see blank space where the
container exists.

n

Auto Start Select this option if you want the video to automatically begin playing when
the topic displays. Otherwise, the user must click the Play button to start the movie.

n

Full Screen Select this option to display the movie using the entire screen.

n

Stretch to Fit Select this option to automatically resize the movie so that it exactly
matches the size of the container area.

n

Play Count Enter the number of times you want the video to repeat.

n

Audio Select options for the sound (mute, volume level, balance).
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QUICKTIME AND HTML5 OPTIONS
n

Scale When you insert an embedded movie, a square container represents the area
where the video will be displayed. Just like a regular image, you can resize the container
either by using the settings on the Size tab or by clicking and dragging the icon
in the
lower-right corner of the container. The settings in this field determine how the video is
displayed in the area represented by the square container.
l

l

l

To Fit Automatically resizes the movie so that it exactly matches the size of the container area.
Aspect Automatically resizes the movie so that it exactly matches the size of the
container area. However, the image is not stretched, but rather kept in its original proportion. For example, the width of the movie might be increased to match the width
of the container area, but extra empty space might be shown above and below the
movie in order to compensate for the height of the container area.
Value Enter the value that you want to increase the display of the movie. If you
select 2, the movie will be twice as large as 1, and so on.

n

Show Controls Select this option to show the player controls (e.g., Play, Pause).

n

Auto Play Select this option if you want the video to automatically begin playing when the
topic displays. Otherwise, the user must click the Play button to start the movie.

n

Loop Select this option if you want the movie to play repeatedly.

n

Audio Select the volume level for the movie.
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YOUTUBE OPTIONS
n

Auto Hide Select this option if you want to hide the video's title and player controls bar
when the movie begins playing.

n

Auto Play Select this option if you want the video to automatically begin playing when the
topic displays. Otherwise, the user must click the Play button to start the movie.

n

Full Screen Select this option if you want to allow users to play the video in full-screen
mode.

n

Show Related Videos Select this option if you want to show similar, suggested videos
when the movie stops playing.

n

Annotations Select this option if you want to show annotations from the video owner
when viewing the movie.
l

On Enables annotations from the video owner.

l

Off Disables annotations from the video owner.

n

Modest Branding Select this option if you want to remove the YouTube branding from the
player controls.

n

Show Info Select this option if you want to show the title bar on the top of the video.

n

Progress Bar Color Select the color you want to use for the player's progress bar.

n

n

l

White Displays a white progress bar.

l

Red Displays a red progress bar.

Controls Select the display option for the player controls (i.e., play, pause, full-screen, settings).
l

On (Always) Displays player controls at all times.

l

On (Only during playback) Displays player controls only during video playback.

l

Off Disables player controls.

Theme Select a color theme for the player controls.
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Light Displays a light gray player control bar.

l

Dark Displays a black player control bar.
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NOTE: Some advanced features may not work in all web browsers.

NOTE: Setting the Progress Bar option to White overrides the Modest Branding
option, so you will always see the YouTube logo when you play your videos.

NOTE: If you disable the player controls, users will only be able to play and pause the
video. They will not be able to adjust the volume, view or adjust the progress bar,
change video settings, or open the video in full-screen mode.

VIMEO OPTIONS
n

Auto Pause Select this option if you want the video to automatically pause when another
Vimeo video in the topic is played. Otherwise, the user must click the Pause button to
pause the movie.

n

Auto Play Select this option if you want the video to automatically begin playing when the
topic displays. Otherwise, the user must click the Play button to start the movie.

n

Loop Select this option if you want the movie to play repeatedly.

n

Byline Select this option if you want to display the video owner's name on the movie.

n

Portrait Select this option if you want display the video owner's portrait on the movie.

n

Title Select this option if you want display the title on the video.

n

Controls Color If you want change the color of the player controls, click
a color.

and select

NOTE: Some advanced features may not work in all web browsers.
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NOTE: Vimeo's advanced features are not available in Microsoft HTML Help and
Eclipse Help outputs. However, you can make it work in Microsoft HTML Help by
adding the default meta tag to your target:
<meta http-equiv="X-UA-Compatible" content="IE=Edge" />

NOTE: If the owner of the video is a Vimeo Pro or Vimeo Plus member, some of these
settings may be overridden by that member's preferences. For example, an owner of
a video may not allow you to remove the title and byline, so you will still see this information on the video even if you chose not to display it in the Flare output.

NOTE: You cannot remove the Vimeo Staff Picks badge from a video.
9. (Optional) Select the Size tab and complete the options as necessary to resize the container
area where the movie will be displayed. As an alternative, you can click and drag the icon
in the lower-right corner of the container.

TO SET A PRECISE WIDTH AND/OR HEIGHT
n

In the Width and/or Height field of the Size section, provide the settings. First you need to
select Length in the top drop-down list. You can then enter a value in the lower-left area
and choose from several different units of measurement (points, pixels, centimeters,
etc.) in the lower-right area.

TO SET THE MINIMUM WIDTH AND/OR HEIGHT
If the original object is smaller than the minimum width or height that is set, it will be enlarged
so that it reaches the minimum value. If the original object is larger than the minimum width
or height, it will not be resized.
n

In the Width and/or Height field of the Minimum Size section, provide the settings. First
you need to select Length in the top drop-down list. You can then enter a value in the
lower-left area and choose from several different units of measurement (points, pixels,
centimeters, etc.) in the lower-right area.
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TO SET THE MAXIMUM WIDTH AND/OR HEIGHT
If the original object is larger than the maximum width or height that is set, it will be reduced in
size so that it is no greater than the maximum value. If the original object is smaller than the
maximum width or height, it will not be resized.
n

In the Width and/or Height field of the Maximum Size section, provide the settings. First
you need to select Length in the top drop-down list. You can then enter a value in the
lower-left area and choose from several different units of measurement (points, pixels,
centimeters, etc.) in the lower-right area.
NOTE: When resizing objects, you can ensure the aspect ratio is maintained. For
example, if you want certain objects to be resized so that each is exactly 3 inches
high, you can make sure the width of each object is adjusted accordingly to stay in
proportion. To do this, first set the height at 3 inches. You would not set the width
property at all. In the same way, if you were to specify an exact width, you could maintain the aspect ratio by not setting the height.

NOTE: By default, YouTube and Vimeo videos are displayed at 560 pixels by 315
pixels. In Microsoft HTML Help output, YouTube videos display slightly smaller than
this, with black padding around the video. However, you can remove the black padding by adding the default meta tag to your target:
<meta http-equiv="X-UA-Compatible" content="IE=Edge" />
10. (Optional) Select the Position tab and complete the options as necessary to determine how
the movie is positioned in the topic. You can select a Float and a Clear setting. You can also
set the Vertical Alignment of the object.

FLOAT
Use this field to specify where to place the element on the page.
n

None Does not place the element in a specific location.

n

Left Positions the element on the left side of the page frame, allowing you to type text to
the right of the element.
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n

Right Positions the element on the right side of the page frame, allowing you to type text
to the left of the element.

n

Center of Column Positions the element in the center of the column on the page.

n

Outside Left Margin Positions the element beyond the left margin of the topic text.

n

Outside Right Margin Positions the element beyond the right margin of the topic text.

n

Outside Frame Positions the element outside of the page frame.

n

Outside Frame, Top Align Positions the element outside of the page frame, as well as
aligning it with the top of the frame.

n

Left of Frame Positions the element to the left of the page frame.

n

Right of Frame Positions the element to the right of the page frame.

n

Center of Frame Positions the element both vertically and horizontally in the middle of
the page frame.

CLEAR
Use this field to position an element so that it is "clear" of an adjacent element. For example,
let's say you have already inserted an element and applied the float left property to it. If you
then insert another element immediately after the first element, you want to make sure that
the second element doesn't rest next to the first one. Instead, you want the second element
to be placed completely below the first one. Therefore, you can apply a clear property to the
second element.
n

None Does not apply the clear property to the element.

n

Left Side The element will be placed below the bottom outer edge of a previous element
that is floating left.

n

Right Side The element will be placed below the bottom outer edge of a previous element
that is floating right.

n

Both Sides The element will be placed below the previous one, whether floating left or
right.
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VERTICAL ALIGNMENT
Use this field to adjust where the item is positioned vertically.
n

Baseline The baseline of the box will be aligned with the baseline of the parent box.

n

Text Top The top of the box will be aligned with the top of the parent element's font.

n

Text Bottom The bottom of the box will be aligned with the bottom of the line box.

n

Top The top of the box will be aligned with the top of the line box.

n

Middle The vertical midpoint of the box will be aligned with the baseline of the parent box,
plus half the x-height of the parent.

n

Bottom The bottom of the box will be aligned with the bottom of the line box.

11. (Optional) Select the Borders & Margins tab if you want to specify margins, padding, or borders around the movie.

MARGIN
Click in any of the individual fields (Left, Right, Top, Bottom) to specify the settings for the margins around the object. If you click the down arrow to the right of all the fields, the settings will
be applied to all of the margin fields.

PADDING
Click in any of the individual fields (Left, Right, Top, Bottom) to specify the settings for the padding. This adds extra space between an image's border and the image itself. This adds extra
space between a text box's border and the text within it. In the left side of the field, enter a
number for the amount of padding. In the right side of the field, select a unit of measurement
(e.g., point, pixel, centimeter) for the number you entered. If you click the down arrow to the
right of all the fields, the settings will be applied to all of the padding fields. When you click that
down arrow, a small popup displays.

BORDERS
a. Click in any of the individual fields (Left, Right, Top, Bottom) to specify the settings for the
border. If you click the down arrow to the right of all the fields, the settings will be applied
to all of the border fields.
When you click that down arrow or in one of the individual fields, a small popup displays.
b. Use the lower-left area of the popup to enter a number for the border thickness.
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c. Use the lower-middle area to select a unit of measurement (e.g., point, pixel, centimeter)
for the number you entered.
d. Use the upper-right area to select a color for the border.
e. Use the lower-right area to select a line type (e.g., solid, double, dashed) for the border.
f. Click OK.

12. (Optional) Select the Background tab if you want to add background settings to a movie interface. This includes the ability to specify a color, an image, and a repeating pattern for the
background image.

SET A COLOR FOR THE BACKGROUND
n

In the Color field, click the down arrow and select a color from the popup. For advanced
color options, select More Colors and use the fields in the Color Picker dialog.

ADD AN IMAGE TO THE BACKGROUND
a. Next to the Image field, click the Browse button. The Insert Image dialog opens.
b. Select an image file to insert and click OK.
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c. If you want the background image to repeat, select one of the options from the Repeat
field. You can also set the image position horizontally and vertically by using the X and Y
fields.
13. Click OK. The movie is added to the topic, represented by a gray square or rectangle, which is
the area where the video will be shown in the output.
14. Click

to save your work.

HOW TO INSERT A MOVIE LINK
1. Select the Project ribbon. In the Content section select New > Multimedia.
See "Adding Multimedia Files" on page 16.
2. Open the content file (e.g., topic, snippet).
3. In the XML Editor, highlight the text that you want to use as the link (or "hotspot") to the movie.
4. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Insert ribbon. In the Links section, select Hyperlink.

n

Local Toolbar In the local toolbar of the XML Editor, click

.

The Insert Hyperlink dialog opens.
5. From the Link to field select File in Project.
6. Navigate to the movie that you want to link to and select it.
7. (Optional) The Link text field displays the text that you highlighted in the topic, which will be
used as the hyperlink. Leave the text as it is, unless you decide you would like to change it. If
you want to change the link text, type the new text in the field. It will replace the previously
selected text in the topic.
8. (Optional) In the Screen Tip field, you can type a phrase that will appear when the end user
hovers over the hyperlink in the output. If you want to insert a variable, you can click
. The
variable will appear as syntax in the field, but in the output the variable definition will be
shown.
9. (Optional) Next to the Style Class field, click the Select button. This opens the Select Class dialog, which lets you apply one of the defined hyperlink styles from your stylesheet to the link.
You can change the appearance of the link in the Stylesheet Editor. After you select a style
class in the dialog, click OK. The Style Class field displays the selected style. (If you do not specify a style class, Flare uses the parent "a" style.)
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10. (Optional) In the Target Frame field, click the drop-down arrow to select the way the linked
destination will open (e.g., in another window, in a popup).
n

Page Default The destination file opens in the same window as the output window.

n

Parent Frame The destination file opens in the parent frame of the current topic while hiding that topic.

n

New Window The destination file opens in a new browser window.

n

Same Frame The destination file opens in the same window frame as the current topic.

n

Top Frame The destination file opens in the same output window, removing all other
framesets. You might use this option, for example, if the destination topic has its own
frameset.

n

Popup Window The destination file opens in a popup box on top of the current topic.

11. Click OK. The hyperlink is added to the topic.
12. Click

to save your work.

HOW TO INSERT A MOVIE—DRAG AND DROP METHOD
1. Open the Content Explorer or File List window pane.
If necessary, make sure you float and position the window pane or editor so that you can see
both it and XML Editor at the same time.
2. Click and drag the movie file from the Content Explorer or File List window pane to the location where you want it in the XML Editor and drop it.
3. Click

to save your work.

NOTE: For information on which multimedia file types are supported in which outputs, see
"Introduction" on page 5.

NOTE: You can also insert a link to a MadCap Mimic movie file (if you have Mimic installed).
This lets you insert videos generated with any of the following output types: Mimic Movie
Format (MMF), Microsoft Silverlight, or Adobe Flash. MMF offers several advantages (such
as quicker compilation and smaller files). For more information see "Mimic Movie Links in
Topics" on page 37.
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CHAPTER 4

Mimic Movie Links in Topics
If you have used Mimic to produce a movie, you can use this feature to create a link in a topic to the
movie's output. When you are finished, a link to the finished movie is inserted into the topic. When a
user clicks the link in the output, the movie plays.
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HOW TO INSERT A MIMIC MOVIE LINK INTO A TOPIC
1. Open the content file (e.g., topic, snippet).
2. In the XML Editor, place your cursor where you want to insert the link.
3. Select the Insert ribbon. In the Multimedia section select Multimedia > Mimic Movie.
4. In the dialog that opens, find and select an individual Mimic movie or a movie collection that
you want to link to. You can select any of the following types of files.
n

MIMOV This is an individual Mimic movie file (whether part of a collection or standalone). When you want to work on an individual movie, you open this file.

n

MIPRJ This is the main Mimic collection file, which contains one or more movie (MIMOV)
files. It is not required that you create a collection in Mimic; it is simply an option that you
can use if you want to create a movie collection, as opposed to a standalone movie.
Neither the MIPRJ nor the MIMOV files are finalized movies. They are merely the files
that are used to generate the finalized movies. When you want to work on a movie collection, you open the MIPRJ file.

n

MCMOVIE This is an output file that is created when you generate a movie (whether the
movie is part of a collection or standalone). A Mimic collection can contain several
movies. When you generate the finalized movies in Mimic, an MCMOVIE file is created for
each movie in the collection (e.g., myfirstmovie.mcmovie, mysecondmovie.mcmovie).
The output plays in the MadCap Movie Viewer.

n

MCMV This is an optional output file that lets you view the movie(s) in the MadCap Movie
Viewer, rather than in a browser window.

n

MCMOVIESYS This is an output file that is created when you generate a movie collection. The file is named after your collection (e.g., mycollection.mcmoviesys) and can
be used as an entry point to view the movie collection. The output plays in the MadCap
Movie Viewer.

5. Click Open.The Edit Mimic Movie dialog opens.
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6. Change the options in the dialog as necessary.
n

File Displays the path to the movie or collection file after you select it.
Lets you find and select a different movie or collection file.

n
n

Format You can use this drop-down to select the type of output to be generated.

IF YOU HAVE MIMIC 8 OR NEWER
l

l

(default) If you build a Microsoft HTML Help, WebHelp, HTML5, or WebHelp Plus target, the movie uses the HTML5 movie format.
HTML5 The movie is generated in the HTML5 movie format.

IF YOU HAVE MIMIC 7 OR OLDER
l

l

l

l

MadCap Movie Player The movie is generated in MMF and displays in the MadCap
Movie Viewer.
Adobe Flash The movie is generated in a Flash SWF file.
Adobe Flash (Embed) The movie is generated in a Flash SWF file and is embedded in
your output.

l

Microsoft Silverlight The movie is generated in the Microsoft Silverlight format.

l

HTML5 The movie is generated in the HTML5 movie format.

l

n

(default) The most appropriate movie format is used, based on the Flare output type
that you generate. If you build a Microsoft HTML Help, WebHelp, HTML5, or
WebHelp Plus target, the movie uses the HTML5 movie format. If you want to override these settings, select one of the specific movie types below.

HTML5 (Embed) The movie is generated in the HTML5 movie format and is embedded in your output.

Style Class Select the kind of style class to be used for the link to affect the way it looks
and behaves. You can select the main hyperlink style (a) or a class of that style.
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n

Link Text Displays the text that you highlighted in the topic, which will be used as the
movie link. Leave the text as it is, unless you decide you would like to change it. If you
want to change the link text, type the new text in the field. It will replace the previously
selected text in the topic. If you do not provide link text, the file name for the movie or collection will be used.

n

Screen Tip Type a phrase that will appear when the end user hovers over the movie link in
the output.

7. Click OK. The movie link is added to the topic with a small movie frame icon
to it.
8. Click

displayed next

to save your work.

NOTE: If instead you want to insert a movie directly into a topic (rather than a link), see
"Inserting Movies" on page 19.

NOTE: You do not need to add the Mimic movie files to your Flare project. When you generate the target(s) in Flare, the movie output file(s) will automatically be copied to the target output file or folder.

NOTE: For information on which multimedia file types are supported in which outputs, see
"Introduction" on page 5.

CHAPTER 4

40

CHAPTER 5

Mimic Movie Links in TOCs
If you have used Mimic to produce a movie, you can use this feature to create a link in a table of contents entry to the movie's output.
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HOW TO INSERT A MOVIE LINK INTO A TOC
1. Open the TOC where you want to insert the movie link.
2. In the TOC Editor, double-click the TOC entry that you want to link to the movie. The Properties dialog opens.
3. Select the General tab.
4. Select Mimic Movie or Movie Collection as. The Open dialog opens.
5. Find and select an individual Mimic movie or a movie collection to which you want to link the
entry. You can select any of the following types of files.
n

MIMOV This is an individual Mimic movie file (whether part of a collection or standalone). When you want to work on an individual movie, you open this file.

n

MIPRJ This is the main Mimic collection file, which contains one or more movie (MIMOV)
files. It is not required that you create a collection in Mimic; it is simply an option that you
can use if you want to create a movie collection, as opposed to a standalone movie.
Neither the MIPRJ nor the MIMOV files are finalized movies. They are merely the files
that are used to generate the finalized movies. When you want to work on a movie collection, you open the MIPRJ file.

n

MCMOVIE This is an output file that is created when you generate a movie (whether the
movie is part of a collection or standalone). A Mimic collection can contain several
movies. When you generate the finalized movies in Mimic, an MCMOVIE file is created for
each movie in the collection (e.g., myfirstmovie.mcmovie, mysecondmovie.mcmovie).
The output plays in the MadCap Movie Viewer.

n

MCMV This is an optional output file that lets you view the movie(s) in the MadCap Movie
Viewer, rather than in a browser window.

n

MCMOVIESYS This is an output file that is created when you generate a movie collection. The file is named after your collection (e.g., mycollection.mcmoviesys) and can
be used as an entry point to view the movie collection. The output plays in the MadCap
Movie Viewer.

6. Click Open.
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7. (Optional) You can click in the drop-down field to the right and specify an output format.

IF YOU HAVE MIMIC 8 OR NEWER
n

(default) If you build a Microsoft HTML Help, WebHelp, HTML5, or WebHelp Plus target,
the movie uses the HTML5 movie format.

n

HTML5 The movie is generated in the HTML5 movie format.

IF YOU HAVE MIMIC 7 OR OLDER
n

(default) The most appropriate movie format is used, based on the Flare output type that
you generate. If you build a Microsoft HTML Help, WebHelp, HTML5, or WebHelp Plus target, the movie uses the HTML5 movie format. If you want to override these settings,
select one of the specific movie types below.

n

MadCap Movie Player The movie is generated in MMF and displays in the MadCap Movie
Viewer.

n

Adobe Flash The movie is generated in a Flash SWF file.

n

Microsoft Silverlight The movie is generated in the Microsoft Silverlight format.

n

HTML5 The movie is generated in the HTML5 movie format.

8. Click OK in the Properties dialog. The movie link is added to the TOC entry.
9. Click

to save your work.

NOTE: You do not need to add the Mimic movie files to your Flare project. When you generate the target(s) in Flare, the movie output file(s) will automatically be copied to the target output file or folder.
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CHAPTER 6

Mimic Movie Links in Browse
Sequences
If you have used Mimic to produce a movie, you can use this feature to create a link in a browse
sequence entry to the movie's output.
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HOW TO INSERT A MOVIE LINK INTO A BROWSE SEQUENCE
1. Open the browse sequence where you want to insert the movie link.
2. In the Browse Sequence Editor, double-click the browse sequence entry that you want to link
to the movie. The Properties dialog opens.
3. Select the General tab.
4. Select Mimic Movie or Movie Collection as. The Open dialog opens.
5. Find and select an individual Mimic movie or a movie collection to which you want to link the
entry. You can select any of the following types of files.
n

MIMOV This is an individual Mimic movie file (whether part of a collection or standalone). When you want to work on an individual movie, you open this file.

n

MIPRJ This is the main Mimic collection file, which contains one or more movie (MIMOV)
files. It is not required that you create a collection in Mimic; it is simply an option that you
can use if you want to create a movie collection, as opposed to a standalone movie.
Neither the MIPRJ nor the MIMOV files are finalized movies. They are merely the files
that are used to generate the finalized movies. When you want to work on a movie collection, you open the MIPRJ file.

n

MCMOVIE This is an output file that is created when you generate a movie (whether the
movie is part of a collection or standalone). A Mimic collection can contain several
movies. When you generate the finalized movies in Mimic, an MCMOVIE file is created for
each movie in the collection (e.g., myfirstmovie.mcmovie, mysecondmovie.mcmovie).
The output plays in the MadCap Movie Viewer.

n

MCMV This is an optional output file that lets you view the movie(s) in the MadCap Movie
Viewer, rather than in a browser window.

n

MCMOVIESYS This is an output file that is created when you generate a movie collection. The file is named after your collection (e.g., mycollection.mcmoviesys) and can
be used as an entry point to view the movie collection. The output plays in the MadCap
Movie Viewer.

6. Click Open.
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7. (Optional) You can click in the drop-down field to the right and specify an output format.

IF YOU HAVE MIMIC 8 OR NEWER
n

(default) If you build a Microsoft HTML Help, WebHelp, HTML5, or WebHelp Plus target,
the movie uses the HTML5 movie format.

n

HTML5 The movie is generated in the HTML5 movie format.

IF YOU HAVE MIMIC 7 OR OLDER
n

(default) The most appropriate movie format is used, based on the Flare output type that
you generate. If you build a Microsoft HTML Help, WebHelp, HTML5, or WebHelp Plus target, the movie uses the HTML5 movie format. If you want to override these settings,
select one of the specific movie types below.

n

MadCap Movie Player The movie is generated in MMF and displays in the MadCap Movie
Viewer.

n

Adobe Flash The movie is generated in a Flash SWF file.

n

Microsoft Silverlight The movie is generated in the Microsoft Silverlight format.

n

HTML5 The movie is generated in the HTML5 movie format.

8. Click OK in the Properties dialog. The movie link is added to the browse sequence entry.
9. Click

to save your work.

NOTE: You do not need to add the Mimic movie files to your Flare project. When you generate the target(s) in Flare, the movie output file(s) will automatically be copied to the target output file or folder.

NOTE: For information on which multimedia file types are supported in which outputs, see
"Introduction" on page 5.
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CHAPTER 7

Editing Movies
You can edit movies in a variety of ways, depending on how you inserted the movie and what you
want to edit. You can do any of the following.
n

Edit Flash, Windows Media, Quicktime, WebM, YouTube, or Vimeo Movie Properties If you
have inserted an embedded Flash, Windows Media, Quicktime, WebM, YouTube, or Vimeo
movie, you can edit the properties for it.

n

Edit Mimic Movies If you have inserted a link to a MadCap Mimic movie, you can open the
movie in Mimic, where you can make enhancements and changes to it.

n

Edit Mimic Movie Link Properties If you have inserted a link to a MadCap Mimic movie, you
can edit the properties of the link.
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HOW TO EDIT FLASH, WINDOWS MEDIA, QUICKTIME, WEBM, YOUTUBE, OR VIMEO
MOVIE PROPERTIES
1. Open the content file (e.g., topic, snippet).
2. In the XML Editor, right-click the square or rectangle representing the area where the movie
will play.
3. From the context menu, select Edit Multimedia. The Edit Multimedia dialog opens.
4. Change the options on the tabs in the dialog as necessary.

GENERAL TAB
n

You can select a different movie file. You can do this in various ways.

SELECTING A FILE IN THE PROJECT
1. To select a movie file already in the project, select Multimedia in project.
2. Find and choose the file in the Select File area. Use the buttons in the local toolbar to view all files in a list, view files in their folder structure, etc.
Button

Description
Shows all of the files in the project in a list in the area
below. If you click the button again, it switches to a folder
tree view. In the list, you can click the File, Type, or Path
column headers to sort the list alphabetically by that
column data.
Shows or hides the folders that the files are stored in.
Shows or hides the files. If you click this button when the
Show Folders button
is selected, the area splits into
two. The folder is shown on the left side, and the files and
subfolders within it are shown on the right.
If the Show Files button
is the only one selected, you
can click this button to move up one folder level.
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Button

Description
Lets you filter the kinds of files shown below. Depending
on the task you are performing, this field may already be
populated with the most appropriate file type(s).

. If you want to
3. (Optional) To select a movie file outside of the project, click
select a movie file that you recently inserted somewhere in your project, click the
down arrow in the field next to
and select the file from the list.

NOTE: If you select a movie file outside the project, that file is then
copied and placed inside the project. The movie file is stored in the
Resources > Multimedia folder of the Content Explorer.

SELECTING A FILE FROM THE WEB
1. To select a movie file on the web, select Multimedia from Web.
2. In the field, enter the location of the movie file you want to use in your project.
NOTE: You can only add YouTube and Vimeo files from the web.

NOTE: When you insert a YouTube or Vimeo movie (using the Insert > Multimedia option), these movies are not stored in your Resources > Multimedia
folder like other movie types, because Flare references them from the web.
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NOTE: You can set YouTube videos to have a specific start time. For example,
you might want the video to begin playing not from its beginning, but rather 1
minute and 30 seconds into the movie. To do this, add the time you want the
video to start to the end of the URL using the format t=(time in minutes and
seconds). For example:
https://youtu.be/SI6PHhxHNNA?t=1m30s
The easiest way to do this is to open the video in YouTube, click the Share button, enter the start time, and copy the URL given.

n

If you want to apply a specific style class to the movie, you can select it from the Style
Class field.
EXAMPLE
Let's say that you have created in your stylesheet a class of the object style
called "BigMargin" (i.e., object.BigMargin) and you have set the margin for all
sides of that class to 1 inch. Rather than using the default parent object
style when you insert the movie, you select object.BigMargin from the Style
Class drop-down. As a result, 1 inch of space is added around the movie in
the output.

n

In the Screen Tip field you can type a phrase that will appear when the end user hovers
over the movie link in the output.
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ADVANCED TAB
The options shown on this tab depend on the type of movie file you are inserting (Flash, Windows Media, QuickTime, WebM, YouTube, Vimeo).

FLASH OPTIONS
n

Quality Select the quality of the video, from "Low" up to "Best."
l

l

l

l

l

l

n

Low Favors playback speed over appearance and never uses anti-aliasing.
Auto Low Emphasizes speed at first but improves appearance whenever possible.
Playback begins with anti-aliasing turned off. If the Flash Player detects that the
processor can handle it, anti-aliasing is turned on.
Auto High Emphasizes playback speed and appearance equally at first but sacrifices appearance for playback speed if necessary. Playback begins with anti-aliasing turned on. If the actual frame rate drops below the specified frame rate, antialiasing is turned off to improve playback speed. Use this setting to emulate the
View > Antialias setting in Flash.
Medium Applies some anti-aliasing and does not smooth bitmaps. It produces a better quality than the Low setting, but lower quality than the High setting.
High Favors appearance over playback speed and always applies anti-aliasing. If
the movie does not contain animation, bitmaps are smoothed; if the movie has
animation, bitmaps are not smoothed.
Best Provides the best display quality and does not consider playback speed. All output is anti-aliased and all bitmaps are smoothed.

Scale When you insert an embedded movie, a square container represents the area
where the video will be displayed. Just like a regular image, you can resize the container
either by using the settings on the Size tab or by clicking the clicking and dragging the
icon
in the lower-right corner of the container. The settings in this field determine
how the video is displayed in the area represented by the square container.
l
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Default (Show All) Makes the entire movie visible in the specified area without distortion, while maintaining the original aspect ratio of the movie. Borders may
appear on two sides of the movie.
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l

l

No border Scales the movie to fill the specified area, without distortion but possibly
with some cropping, while maintaining the original aspect ratio of the movie.
Exact fit Makes the entire movie visible in the specified area without trying to preserve the original aspect ratio. Distortion may occur.

n

Alignment Select where you want the video to be displayed within the container area
(e.g., Left, Right, Bottom, Bottom Right).

n

Auto play Select this option if you want the video to automatically begin playing when
the topic displays. Otherwise, the user must click the Play button to start the movie.

n

Loop Select this option if you want the movie to play repeatedly.

n

Show menu Select this option if you want to display the full menu, allowing the user a
variety of options to enhance or control playback. If you do not select this option, the
menu contains only the Settings option and the About Flash option.

n

Enable SWLiveConnect Select this option to specify whether the browser should start
Java when loading the Flash Player for the first time.

WINDOWS MEDIA OPTIONS
n

Player Controls Select an option for displaying the player controls (e.g., Play, Volume).
l

Full Displays all of the available player controls.

l

None Does not display any player controls.

l

Mini Displays only some of the player controls (Play, Pause, Stop, Mute, Volume).

l

Invisible Hides the movie entirely, while still playing the audio. If you select this
option, you might want to resize the container square in your topic so that it does
not take up so much space in the output. The user will simply see blank space
where the container exists.

n

Auto start Select this option if you want the video to automatically begin playing when
the topic displays. Otherwise, the user must click the Play button to start the movie.

n

Full screen Select this option to display the movie using the entire screen.

n

Stretch to fit Select this option to automatically resize the movie so that it exactly
matches the size of the container area.

n

Play count Enter the number of times you want the video to repeat.

n

Audio Select options for the sound (mute, volume level, balance).
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QUICKTIME OPTIONS
n

Scale When you insert an embedded movie, a square container represents the area
where the video will be displayed. Just like a regular image, you can resize the container
either by using the settings on the Size tab or by clicking and dragging the icon
in
the lower-right corner of the container. The settings in this field determine how the
video is displayed in the area represented by the square container.
l

l

l

To Fit Automatically resizes the movie so that it exactly matches the size of the
container area.
Aspect Automatically resizes the movie so that it exactly matches the size of the
container area. However, the image is not stretched, but rather kept in its original
proportion. For example, the width of the movie might be increased to match the
width of the container area, but extra empty space might be shown above and
below the movie in order to compensate for the height of the container area.
Value Enter the value that you want to increase the display of the movie. If you
select 2, the movie will be twice as large as 1, and so on.

n

Show controls Select this option to show the player controls (e.g., Play, Pause).

n

Auto play Select this option if you want the video to automatically begin playing when
the topic displays. Otherwise, the user must click the Play button to start the movie.

n

Loop Select this option if you want the movie to play repeatedly.

n

Audio Select the volume level for the movie.

WEBM OPTIONS
n

Show controls Select this option to show the player controls (e.g., Play, Pause).

n

Auto play Select this option if you want the video to automatically begin playing when
the topic displays. Otherwise, the user must click the Play button to start the movie.

n

Loop Select this option if you want the movie to play repeatedly.

n

Mute Select this option if you want the audio control in the output to initially be set to
mute when the movie is loaded.
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YOUTUBE OPTIONS
n

Auto Hide Select this option if you want to hide the video's title and player controls bar
when the video begins playing.

n

Auto Play Select this option if you want the video to automatically begin playing when
the topic displays. Otherwise, the user must click the Play button to start the movie.

n

Full Screen Select this option if you want to allow users play the video in full-screen
mode.

n

Show Related Videos Select this option if you want to show similar, suggested videos
when the video stops playing.

n

Annotations Select this option if you want to show annotations from the video owner
when viewing the video.
l

l

On Enables annotations from the video owner (i.e., notes about that pop up or display during the video).
Off Disables annotations from the video owner.

n

Modest Branding Select this option if you want to remove the YouTube branding from
the player controls.

n

Show Info Select this option if you want to show the title bar on the top of the video.

n

Progress Bar Color Select the color you want to use for the player's progress bar.

n

n

l

White Displays a white progress bar.

l

Red Displays a red progress bar.

Controls Select the display option for the player controls.
l

Always on Displays player controls at all times.

l

On during playback Displays player controls only during video playback.

l

Off Disables player controls.

Theme Select a color theme for the player controls.
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l

Light Displays a light gray player control bar.

l

Dark Displays a black player control bar.
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NOTE: Some advanced features may not work in all web browsers.

NOTE: Setting the Progress Bar option to White overrides the Modest Branding
option, so you will always see the YouTube logo when you play your videos.

NOTE: If you disable the player controls, users will only be able to play and pause
the video. They will not be able to adjust the volume, view or adjust the progress bar,
change video settings, or open the video in full-screen mode.

VIMEO OPTIONS
n

Auto Pause Select this option if you want the video to automatically pause when
another Vimeo video in the topic is played. Otherwise, the user must click the Pause button to pause the movie.

n

Auto Play Select this option if you want the video to automatically begin playing when
the topic displays. Otherwise, the user must click the Play button to start the movie.

n

Loop Select this option if you want the movie to play repeatedly.

n

Byline Select this option if you want display the video owner's name on the video.

n

Portrait Select this option if you want display the video owner's portrait on the video.

n

Title Select this option if you want display the title on the video.

n

Controls Color If you want change the color of the player controls, click
a color.

and select

NOTE: Some advanced features may not work in all web browsers.
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NOTE: Vimeo's advanced features are not available in Microsoft HTML Help and
Eclipse Help outputs. However, you can make it work in Microsoft HTML Help by
adding the default meta tag to your target:
<meta http-equiv="X-UA-Compatible" content="IE=Edge" />

NOTE: If the owner of the video is a Vimeo Pro or Vimeo Plus member, some of
these settings may be overridden by that member's preferences. For example, an
owner of a video may not allow you to remove the title and byline, so you will still see
this information on the video even if you chose not to display it in the Flare output.

NOTE: You cannot remove the Vimeo Staff Picks badge from a video.

SIZE TAB
Complete the options as necessary to resize the container area where the movie will be displayed. As an alternative, you can click and drag the icon
container.

in the lower-right corner of the

TO SET A PRECISE WIDTH AND/OR HEIGHT
n

In the Width and/or Height field of the Size section, provide the settings. First you need
to select Length in the top drop-down list. You can then enter a value in the lower-left
area and choose from several different units of measurement (points, pixels, centimeters, etc.) in the lower-right area.
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TO SET THE MINIMUM WIDTH AND/OR HEIGHT
If the original object is smaller than the minimum width or height that is set, it will be
enlarged so that it reaches the minimum value. If the original object is larger than the minimum width or height, it will not be resized.
n

In the Width and/or Height field of the Minimum Size section, provide the settings. First
you need to select Length in the top drop-down list. You can then enter a value in the
lower-left area and choose from several different units of measurement (points, pixels,
centimeters, etc.) in the lower-right area.

TO SET THE MAXIMUM WIDTH AND/OR HEIGHT
If the original object is larger than the maximum width or height that is set, it will be reduced
in size so that it is no greater than the maximum value. If the original object is smaller than
the maximum width or height, it will not be resized.
n

In the Width and/or Height field of the Maximum Size section, provide the settings. First
you need to select Length in the top drop-down list. You can then enter a value in the
lower-left area and choose from several different units of measurement (points, pixels,
centimeters, etc.) in the lower-right area.
NOTE: When resizing objects, you can ensure the aspect ratio is maintained. For
example, if you want certain objects to be resized so that each is exactly 3 inches
high, you can make sure the width of each object is adjusted accordingly to stay in
proportion. To do this, first set the height at 3 inches. You would not set the width
property at all. In the same way, if you were to specify an exact width, you could
maintain the aspect ratio by not setting the height.

NOTE: By default, YouTube and Vimeo videos are displayed at 560 pixels by 315
pixels. In Microsoft HTML Help outputs, YouTube videos display slightly smaller than
this, with black padding around the video. However, you can remove the black padding by adding the default meta tag to your target:
<meta http-equiv="X-UA-Compatible" content="IE=Edge" />
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POSITION TAB
Complete the options as necessary to determine how the movie is positioned in the topic. You
can select a Float and a Clear setting. You can also set the Vertical Alignment of the object.

FLOAT
Use this field to specify where to place the element on the page.
n

None Does not place the element in a specific location.

n

Left Positions the element on the left side of the page frame, allowing you to type text
to the right of the element.

n

Right Positions the element on the right side of the page frame, allowing you to type text
to the left of the element.

n

Center of Column Positions the element in the center of the column on the page.

n

Outside Left Margin Positions the element beyond the left margin of the topic text.

n

Outside Right Margin Positions the element beyond the right margin of the topic text.

n

Outside Frame Positions the element outside of the page frame.

n

Outside Frame, Top Align Positions the element outside of the page frame, as well as
aligning it with the top of the frame.

n

Left of Frame Positions the element to the left of the page frame.

n

Right of Frame Positions the element to the right of the page frame.

n

Center of Frame Positions the element both vertically and horizontally in the middle of
the page frame.
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CLEAR
Use this field to position an element so that it is "clear" of an adjacent element. For example,
let's say you have already inserted an element and applied the float left property to it. If you
then insert another element immediately after the first element, you want to make sure that
the second element doesn't rest next to the first one. Instead, you want the second element
to be placed completely below the first one. Therefore, you can apply a clear property to the
second element.
n

None Does not apply the clear property to the element.

n

Left Side The element will be placed below the bottom outer edge of a previous element that is floating left.

n

Right Side The element will be placed below the bottom outer edge of a previous element that is floating right.

n

Both Sides The element will be placed below the previous one, whether floating left or
right.

VERTICAL ALIGNMENT
Use this field to adjust where the item is positioned vertically.
n

Baseline The baseline of the box will be aligned with the baseline of the parent box.

n

Text Top The top of the box will be aligned with the top of the parent element's font.

n

Text Bottom he bottom of the box will be aligned with the bottom of the line box.

n

Top The top of the box will be aligned with the top of the line box.

n

Middle The vertical midpoint of the box will be aligned with the baseline of the parent
box, plus half the x-height of the parent.

n

Bottom The bottom of the box will be aligned with the bottom of the line box.
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BORDERS & MARGINS TAB
Following are settings in the Borders & Margins tab.

MARGIN
Click in any of the individual fields (Left, Right, Top, Bottom) to specify the settings for the
margins around the object. If you click the down arrow to the right of all the fields, the settings will be applied to all of the margin fields.

PADDING
Click in any of the individual fields (Left, Right, Top, Bottom) to specify the settings for the
padding. In the left side of the field, enter a number for the amount of padding. In the right
side of the field, select a unit of measurement (e.g., point, pixel, centimeter) for the number
you entered. If you click the down arrow to the right of all the fields, the settings will be
applied to all of the padding fields. When you click that down arrow, a small popup displays.

BORDERS
a. Click in any of the individual fields (Left, Right, Top, Bottom) to specify the settings for
the border. If you click the down arrow to the right of all the fields, the settings will be
applied to all of the border fields. When you click that down arrow or in one of the individual fields, a small popup displays.
b. Use the lower-left area of the popup to enter a number for the border thickness.
c. Use the lower-middle area to select a unit of measurement (e.g., point, pixel, centimeter) for the number you entered.
d. Use the upper-right area to select a color for the border.
e. Use the lower-right area to select a line type (e.g., solid, double, dashed) for the border.
f. Click OK.
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BACKGROUND TAB
Complete the options as necessary to determine how the background will be displayed in the
topic.

SET A COLOR FOR THE BACKGROUND
n

In the Color field, click the down arrow and select a color from the popup. For advanced
color options, select More Colors and use the fields in the Color Picker dialog.

ADD AN IMAGE TO THE BACKGROUND
a. Next to the Image field, click the Browse button.
The Insert Image dialog opens.
b. Select an image file to insert and click OK.
c. If you want the background image to repeat, select one of the options from the Repeat
field. You can also set the image position horizontally and vertically by using the X and Y
fields.
5. Click OK.
6. Click
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HOW TO EDIT A MIMIC MOVIE
1. Open the content file (e.g., topic, snippet).
2. In the XML Editor, right-click the movie link.
3. In the context menu, select Edit Linked Movie. The movie or collection opens in MadCap
Mimic.
See Mimic's online Help for information about editing movies in that application.
If your movie link in Flare is directed to the movie or collection file, there is nothing else you
need to do in Flare. The next time you build your output, the movie(s) will automatically be generated with the changes that you made.
If your movie link in Flare is directed to the generated output for the movie or collection, make
sure you re-generate the movie or collection output in Mimic after you make your changes.
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HOW TO EDIT MIMIC MOVIE LINK PROPERTIES
1. Open the content file (e.g., topic, snippet).
2. In the XML Editor, right-click the movie link.
3. From the context menu, select Edit Movie Link. The Edit Mimic Movie dialog opens.
4. Change the options in the dialog as necessary.
n

File Displays the path to the movie or collection file after you select it.
Lets you find and select a different movie or collection file.

n
n

Format You can use this drop-down to select the type of output to be generated.

IF YOU HAVE MIMIC 8 OR NEWER
l

l

l

(default) If you build a Microsoft HTML Help, WebHelp, HTML5, or WebHelp Plus target, the movie uses the HTML5 movie format.
HTML5 The movie is generated in the HTML5 movie format.
HTML5 (Embed) The movie is generated in the HTML5 movie format and is embedded in your output.

IF YOU HAVE MIMIC 7 OR OLDER
l

l

l

l

MadCap Movie Player The movie is generated in MMF and displays in the MadCap
Movie Viewer.
Adobe Flash The movie is generated in a Flash SWF file.
Adobe Flash (Embed) The movie is generated in a Flash SWF file and is embedded in
your output.

l

Microsoft Silverlight The movie is generated in the Microsoft Silverlight format.

l

HTML5 The movie is generated in the HTML5 movie format.

l
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(default) The most appropriate movie format is used, based on the Flare output type
that you generate. If you build a Microsoft HTML Help, WebHelp, HTML5, or
WebHelp Plus target, the movie uses the HTML5 movie format. If you want to override these settings, select one of the specific movie types below.

HTML5 (Embed) The movie is generated in the HTML5 movie format and is embedded in your output.
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n

Style Class Select the kind of style class to be used for the link to affect the way it looks
and behaves. You can select the main hyperlink style (a) or a class of that style.

n

Link Text Displays the text that you highlighted in the topic, which will be used as the
movie link. Leave the text as it is, unless you decide you would like to change it. If you
want to change the link text, type the new text in the field. It will replace the previously
selected text in the topic. If you do not provide link text, the file name for the movie or collection will be used.

n

Screen Tip Type a phrase that will appear when the end user hovers over the movie link in
the output.

5. Click OK. The movie link is changed in the topic. You can change the appearance of the link by
modifying the style in the Stylesheet Editor.
6. Click

to save your work.

NOTE: You can also edit Mimic movie links that have been inserted into TOCs or browse
sequences. To do this, simply open the Properties dialog for the TOC or the Properties dialog for the browse sequence and make changes from there.

NOTE: For information on which multimedia file types are supported in which outputs, see
"Introduction" on page 5.
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CHAPTER 8

Additional Movie Tasks
In addition to the many features already covered in this guide, there are other movie-related tasks
that you can perform in Flare.
This chapter discusses the following:
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Previewing Movies
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Launching MadCap Mimic
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Deleting Movies from Topics

67

Deleting Movie Files from the Project
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Previewing Movies
If you have inserted a link to a MadCap Mimic movie in a content file, you can easily preview the
movie to see how it looks.

HOW TO PREVIEW A MOVIE
1. Open the content file (e.g., topic, snippet).
2. In the XML Editor, right-click inside the hyperlink and from the context menu select Preview
Movie. The movie opens in the appropriate viewer.

Launching MadCap Mimic
Mimic is MadCap's movie-making and editing tool, which is tightly integrated with Flare. If you have
Mimic installed on your computer, you can use it to do any of the following from within Flare.
n

Insert movie links into topics If you have used Mimic to produce a movie, you can use this feature to create a link in a topic to the movie's output. See "Mimic Movie Links in Topics" on
page 37.

n

Insert movie links into TOCs If you have used Mimic to produce a movie, you can use this feature to create a link in a table of contents entry to the movie's output. See "Mimic Movie Links
in TOCs" on page 41.

n

Insert movie links into browse sequences If you have used Mimic to produce a movie, you can
use this feature to create a link in a browse sequence entry to the movie's output. See "Mimic
Movie Links in Browse Sequences" on page 44.

n

Edit movies You can open a movie linked in Flare. The movie opens in Mimic, where you can
make changes to it. See "Editing Movies" on page 47.

n

Launch MadCap Mimic You can simply open the Mimic application from Flare.

HOW TO LAUNCH MADCAP MIMIC
n

Select Tools > MadCap > MadCap Mimic.
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Deleting Movies from Topics
Use the following steps to delete a movie that you previously inserted into a topic.

HOW TO DELETE A MOVIE FROM A TOPIC
1. Open the content file (e.g., topic, snippet).
2. In the XML Editor, right-click the movie.
3. From the context menu, click Delete.
4. Click

to save your work.

Deleting Movie Files from the Project
Use the following steps to remove a movie (SWF) file from a project. Movie files are added to the
project automatically when you insert a movie into a topic.

HOW TO DELETE A MOVIE FILE FROM A PROJECT
1. Open the Content Explorer.
2. Expand the Resources folder, and double-click the Images folder to open it (unless you have
stored these files in a custom folder).
3. Locate and select the SWF file that you want to delete.
4. On your keyboard press DELETE.
5. You may be asked if you are certain you want to send the file to the recycle bin. If so, click
Yes.
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APPENDIX

PDFs
The following PDFs are available for download from the online Help.
TUTORIALS

Getting Started Tutorial
Product Foldout Tutorial
Side Navigation Tutorial
Top Navigation Tutorial
USER GUIDES

Accessibility Guide

HTML Help Guide

Analysis and Reports Guide

HTML5 Guide

Architecture Guide

Images Guide

Autonumbers Guide

Importing Guide

Condition Tags Guide

Index Guide

Context-sensitive Help Guide

Key Features Guide

Eclipse Help Guide

Language Support Guide

Getting Started Guide

MadCap Central Integration Guide

Global Project Linking Guide

Master Pages Guide
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Micro Content Guide

Source Control Guide: Git

Movies Guide

Source Control Guide: Perforce

Navigation Links Guide

Source Control Guide: Subversion

Plug-In API Guide

Source Control Guide: Team Foundation Server

Print-based Output Guide

Styles Guide

Project Creation Guide

Tables Guide

Pulse Guide

Tables of Contents Guide

QR Codes Guide

Targets Guide

Reports Guide

Templates Guide

Reviews & Contributions Guide

Topics Guide

Search Guide

Touring the Workspace Guide

SharePoint Guide

Transition From FrameMaker Guide

Skins Guide

Variables Guide

Snippets Guide

What's New Guide

CHEAT SHEETS

Folders and Files Cheat Sheet
Print Output Cheat Sheet
Shortcuts Cheat Sheet
Structure Bars Cheat Sheet
Styles Cheat Sheet
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