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CHAPTER 1

Starting Projects
The first step in developing a project after you launch Flare is to start a project.
This chapter discusses the following:
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Ways to Start Projects
You can start a project in several ways:
n

Create a New Project—Standard Method Use the Start New Project Wizard to create a new
project, basing it on a factory template or one that you have created. See "Creating a New Project" on page 8.

n

Import Microsoft Word Create a project by importing Microsoft Word documents. In addition,
after you create a project (using any method), you can create new topics in that project by
importing Word documents. See "Importing Word Files" on page 18.

n

Import Microsoft Excel Create a project by importing Microsoft Excel files. In addition, after
you create a project (using any method), you can create new topics in that project by importing Excel files. See "Importing Excel Files" on page 36.

n

Import Adobe FrameMaker Create a project by importing Adobe FrameMaker documents.
Because you can import the source FrameMaker BOOK and FM files (rather than just MIF
files), Flare has full access to FrameMaker variables, conditionals, autonumbering, and so on.
This means that those features are converted to Flare seamlessly. In addition, after you create a project (using any method), you can create new topics in that project by importing
FrameMaker documents. See "Importing FrameMaker Files" on page 43.

n

Import RoboHelp Project Create a new project by importing a RoboHelp project (MPJ or XPJ
file). See "Importing a RoboHelp Project" on page 62.

n

Import HTML Help Project (HHP) Create a new project by importing an HTML Help project
(HHP file). See "Importing HTML Help" on page 63.

n

Import HTML Help File (CHM) Create a new project by importing an HTML Help file (CHM
file). See "Importing CHM Files" on page 64.

n

Import DITA Content Create a project by importing DITA file content. When you do this, the
DITA elements are converted to HTML tags (and if you later generate DITA output, they are
then converted back to DITA elements). In addition, after you create a project (using any
method), you can create new topics in that project by importing DITA file content. See
"Importing DITA Files" on page 65.

n

Import HTML File Set Create a project by importing XHTML and HTML files (automatically
converting them to XHTML). See "Importing HTML Files" on page 70.

n

Import Doc-To-Help Project Create a project by importing a MadCap Doc-To-Help project.
See "Importing Doc-To-Help" on page 74.
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n

Import From Source Control Import a Flare project that has been added to a source control
application, such as Microsoft Team Foundation Server, Perforce, Git, or Apache Subversion.
See "Importing a Project from Source Control" on page 80.

n

Open a Project Start a project by opening an existing one. See "Opening a Project" on page
155.
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Creating a New Project
The first step in developing a project after you launch Flare is to start a project. You can start a project in one of several ways, such as by importing other projects or files. Following are the steps for
creating a new project using the Start New Project Wizard.

HOW TO CREATE A NEW PROJECT
1. Do one of the following, depending on the part of the user interface you are using:
n

Start Page Click New Project.

n

Ribbon Select File > New Project.

The Start New Project Wizard opens.
2. In the Project name field, type a name for your project.
3. By default, a path to the Documents\My Projects folder on your hard drive is entered in the
Project folder field. (Flare creates the My Projects folder when you install the program.) All
subfolders and files related to the project will be placed in this folder as you work on the project. Continue with the next step, unless you want to have your project files placed in a different folder. If so, do the following.
a. Click

. The Browse For Folder dialog opens.

b. Navigate to the folder you want, select it, and click OK.
TIP: If you think you may have several folders and subfolders with content in your project, you might consider placing your project closer to your root C: drive, or perhaps
within that drive itself. This will help shorten the paths to files, which might help prevent certain issues from arising where paths are too long.

TIP: It is recommended that you always store your project locally, rather than on a
network. Of course, there may be times when you need to place a copy of your project on a network (e.g., to use source control, or to make a copy available to a coworker). But performance and speed should be significantly better if you work on a
local copy of the project rather than working on it from a remote server.
4. In the Language field select the language that you want to use for the project.
5. (Optional) If you want to integrate the new Flare project with a source control application
(such as Microsoft Team Foundation Server), select Bind to Source Control.
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6. Click Next.
7. (Optional) If you have selected the "Bind to Source Control" option, click Bind Project. Then in
the Bind Project dialog, complete the fields, depending on the source control application being
used. When you are finished, click Next.

IF USING GIT
a. From the drop-down, select Git.

b. If you are going to bind to a remote repository, select the Remote Repository box, then
enter the address of the repository in the field. If you want to work locally, you can leave
this box unselected. You can enter an HTTP URL or an SSH URL.
NOTE: You may need to obtain this information from your system administrator.
c. If you want to push to the remote repository when you bind the project, select the Push
on bind check box. This will push the initial project files to the repository when you bind
the project.
d. In the Name field, enter your name.
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e. In the Email field, enter your email address.
f. From the Save Per drop-down, select how you want to save your files.
n

User Saves the files in your local folder. Select this option if you are working with
other tools (e.g., Tortoise) or if you want to use the same user identity across multiple projects.

n

Project Saves the files locally to your project. Select this option if you want to use
different identities for each project.

g. (Optional) In the Comment field, you can enter any internal comments.
h. In the Bind Project dialog, click OK.
i. (Optional) If you entered an HTTP address in Step b, enter your user name and password in the Log In dialog. Click OK when you are finished.
j. (Optional) If you entered an SSH URL in Step b, the Certificate Specification dialog
opens. In the dialog, do the following and click OK when you are finished:
i. In the Public key field, enter your public SSH key, or use
on your network.
ii. In the Private key field, enter your private SSH key, or use
on your network.

to browse for the key

to browse for the key

iii. If you want Flare to remember your key information so you do not need to enter it
again later, select the check box next to Save certificate information.
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NOTE: SSH keys allow you to establish a secure connection between your
computer and your Git source control provider (likewise, using an SSH URL
is more secure than an HTTP URL; you need to use SSH keys if you want to
use an SSH URL). If you do not have a public and private SSH key, your can
generate these keys using your Git source control provider (e.g., Gitlab).
Follow the directions provided by your source control provider to add these
keys to your Git account. Once you generate these keys, they are typically
found in the C:\Users\[username]\.ssh folder on your computer.
Public keys typically have a .pub extension. Private keys use the same file
name as the public key, but without the file extension.

EXAMPLE
Use the following as guides when setting up your URLs and keys.
SSH URL
git@gitlabomnibus.mycompany.corp:MyUserName/myproject.git

HTTP URL
http://gitlabomnibus.mycompany.corp/MyUserName/myproject.git

SSH Private Key
mycompanySSHkey_id_rsa

SSH Public Key
mycompanySSHkey_id_rsa.pub
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IF USING TEAM FOUNDATION SERVER
a. From the drop-down, select Microsoft Team Foundation Server.
b. In the Server field, enter the name of the computer or the IP address of the server. You
can also click
to select a "Team Project Collection." If you click this button, the
Select Team Foundation Server Project Collection dialog opens, and you can do the following.
i. To add a server, click

. The Add Team Foundation Server dialog opens.

ii. Enter the name or URL of the server.
iii. Enter the path and port number.
iv. Select the protocol (HTTP or HTTPS).
NOTE: If you are binding a Visual Studio Team Services repository to TFS, in the
Server field, enter the URL of the project's "Default Collection."

NOTE: You may need to obtain this information from your system administrator.
Click OK in the dialogs until you return to the main wizard page.

NOTE: Be sure to specify the path deeper than the server name. For example:
.../tfs/DefaultCollection

or
.../tfs/SourceCollection

If you do not know this information, contact your system administrator.
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NOTE: If you run into issues in this dialog, chances are your user permissions do
not have access to all of the collections on the TFS server or Visual Studio Team
Services. Please try to enter in the server/collection path manually.

c. Next to the Project Path field, click
opens.

. The Browse Source Control Folders dialog

d. Click on the Team Foundation Server folder to which you want to bind the Flare project.
e. Click OK.
f. (Optional) In the Comment field, you can enter any internal comments.
g. (Optional) If you want the files in the project to be checked out when you are finished,
click Keep files checked out.
h. In the Bind Project dialog, click OK.
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IF USING SUBVERSION
a. From the drop-down, select Subversion.
b. In the Server field, enter the IP address.
c. Next to the Project Path field, click
opens.

. The Browse Source Control Folders dialog

d. Click on the Subversion folder to which you want to bind the Flare project.
e. Click OK.
f. (Optional) In the Comment field, you can enter any internal comments.
g. In the Bind Project dialog, click OK.
h. If the Log In dialog opens, complete the User name and Password fields and click OK.
Copies of the Flare files are created and added to the folder you specified.
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IF USING PERFORCE
a. From the drop-down, select Perforce.
b. In the Server field, enter the server address.
c. Next to the User field, click

. The Select User dialog opens.

d. Select a user and click OK. (Users are set up separately in Perforce.)
e. From the Type drop-down, select whether you want to bind to a stream or a depot. A
depot contains multiple streams.

IF YOU ARE BINDING TO A STREAM
i. Next to the Stream field, click New.
If the Log In dialog opens, complete the User name and Password fields and
click OK.
The New Perforce Stream dialog opens.
ii. From the Stream Type drop-down, select the type of stream you want to use.
Most streams are mainline streams.
iii. Next to the Streams Depot field, click Browse.
The Browse Depots dialog opens.
iv. Select a depot. This is essentially a folder or directory in Perforce that contains
multiple streams, one of which will be your Flare files.
v. Click OK.
vi. (Optional) In the New Perforce Stream dialog, you can complete any of the
other fields as necessary. For information about these fields, please refer to the
documentation provided with Perforce.
vii. Click OK.

CHAPTER 1

15

IF YOU ARE BINDING TO A DEPOT
i. Next to the Depot field, click New, or select an existing depot using the dropdown arrow.
If you clicked New, the New Depot dialog opens.
ii. In the Name field, enter a name for the depot.
iii. (Optional) In the Description field, enter a description for the depot.
iv. Click OK.
v. Next to the Path field, click

.

If the Log In dialog opens, complete the User name and Password fields and
click OK.
Select the location where you want to bind the project.
vi. Select the location where you want to bind the project.
vii. Click OK.
f. (Optional) In the Comment field, you can enter any internal comments.
g. (Optional) If you want the files in the project to be checked out when you are finished,
click Keep files checked out.
h. In the Bind Project dialog, click OK.
NOTE: If you have elected to bind the project to source control but do not complete
the source control fields, the Finish button in the wizard is disabled.
8. In the Source area select one of the following:

NEW FROM TEMPLATE
Choose either the factory template file or one of your own customized template files as a
starting point. The new file will take on all of the settings contained in the template. If you
want to use the factory template provided by Flare, expand the Factory Templates folder and
click on a template file. If you want to use your own customized template file, expand the
appropriate folder and click on a file. For more information about templates, see the online
Help.
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NEW FROM EXISTING
Choose an existing file of the same type as a starting point for your new file. As with template
files, your new file will take on all of the settings contained in the file you select. To use this
option, click the browse button
, use the Open File dialog to find a file, and double-click it.

NEW FROM IMPORT
Choose legacy files (e.g., Word, Excel, FrameMaker, HTML, DITA, HTML Help, RoboHelp) to
import. If you select this option and click Next, a list of import options is displayed. You can
select the file type, click Next again, and complete the options in the new wizard that opens,
instead of completing the rest of the steps below. For more information on each of these
import wizards and the steps to complete them, see any of the following.
l

"Importing Word Files" on the next page

l

"Importing Excel Files" on page 36

l

"Importing FrameMaker Files" on page 43

l

"Importing a RoboHelp Project" on page 62

l

"Importing HTML Help" on page 63

l

"Importing CHM Files" on page 64

l

"Importing DITA Files" on page 65

l

"Importing HTML Files" on page 70

l

"Importing Doc-To-Help" on page 74

9. Click Next.
10. From the Available Targets field, select the primary target for your project.
11. Click Finish.
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Importing Word Files
You can import Microsoft Word files in the following ways:
n

Import Into a New Project

n

Import Into an Existing Project (From the Wizard)

n

Import Into an Existing Project (From the Import Editor)

HOW TO IMPORT WORD FILES
1. Do the following, depending on how you are importing your files:

IMPORT INTO A NEW PROJECT
a. Select Project > Import > MS Word Documents.
The Import Microsoft Word Wizard opens.
b. Select Import into a new project.
c. In the Project name field, type a name for the new Flare project that will be created
after you perform the import.
d. In the Project folder field, either accept the default location for the new project or click
to find and select a folder.
e. From the Output Type field, select the primary target for your project.

IMPORT INTO AN EXISTING PROJECT (WIZARD)
a. Select Project > Import > MS Word Documents.
The Import Microsoft Word Wizard opens.
b. Select Import into this project.

IMPORT INTO AN EXISTING PROJECT (IMPORT EDITOR)
Do one of the following:

IF YOU DO NOT YET HAVE A WORD IMPORT FILE
a. Complete the steps for adding an import file.
b. Open the file in the Word Import Editor.
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IF YOU ALREADY HAVE A WORD IMPORT FILE
a. In the Project Organizer, expand the Imports subfolder.
b. Double-click the appropriate import file. The file opens in the Word Import Editor to the
right.
2. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Source Files tab.

3. Click

.

4. In the dialog that opens, find and select the files you want to import. You can hold the SHIFT
key to select a range, or you can hold the CTRL key to select individual items. When you are
finished, click Open.
You can select DOC, DOCX, or RTF files.
NOTE: DOCX is Microsoft Word's platform-independent, open XML format. You must
have Microsoft Word 2007 installed in order to import this file type.
5. You can use the following options as necessary:
This opens the file that is selected in the list.
Link Generated
Files to
Source
Files
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This creates a connection between the original files and the files that are created as a result of the import. This is useful if you want to continue editing the
content outside of Flare, instead of editing in the Flare project. Flare recognizes when changes have been made to the source documents and reminds
you to re-import the documents to ensure the Flare project also reflects the
changes. If you use this option, a link icon is added to the top of a linked file in
the Flare interface. This lets you know that you need to edit the source file,
rather than editing this file. If you remove the connection to the source file, this
icon no longer displays on the file. Please note that if you have bound the project to source control, the icons used for source control take precedence over
the link icon.
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This removes the selected file(s) from the list.
This moves the selected file higher in the list (if you have more than one file to
import). The file at the top is used for the name of the content folder holding
the imported topics in Flare. Also, the order determines how the imported files
are arranged in the Flare TOC that is created as a result.
This moves the selected file lower in the list (if you have more than one file to
import).
6. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next. The Word documents are scanned and the next page of the wizard
opens. The paragraph styles used in the Word documents are shown on the left side of
the wizard page ("Used Word Styles").
NOTE: You can skip the rest of the wizard pages by clicking Finish.

n

Import Editor Select the New Topic Styles tab.

7. If you want Flare to split the Word documents into smaller topics based on any of the styles
shown on the left side of the page ("Used Word Styles"), double-click that style to move it to
the right side of the page ("New Topic Styles").
EXAMPLE
If you have a style called "Heading 2" in your Word documents, you might want
new topics to be created whenever Flare finds a Heading 2 style in a document.
So you would double-click Heading 2 and move it to the right side of the page.
8. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Options tab.
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9. You can use the following options as necessary:
n

Add "Topic Continued" links when appropriate Select this option to place a "Topic Continued" link at the bottom of pages when a long topic has been split into multiple ones.

n

Add "Topic Continued From" links when appropriate Select this option to place a "Topic
Continued From" link at the top of continued pages when a long topic has been split into
multiple ones.

n

Cross-Reference Format Use this field to specify the format for the "Topic Continued"
and "Topic Continued From" links. Flare provides a cross-reference format for you—(continued in {title}) or (continued from {title}). With this cross-reference format, the link contains the words "continued in" or "continued from" within parentheses, followed by the
text of the first paragraph in the connected topic. If you do not want the link to use that
particular text, you have a couple of options. First, in Flare, you could manually enter a
heading in each topic that is connected to another topic included in the split. That text
will be used in the link instead (after you update the cross-references in Flare). Another
option is to modify the format by clicking the Edit button.
l

n

Split Long Topics Select this option if you have long sections in your source documents
and want to make sure that they are converted to multiple topics (rather than one very
long topic).
l

n

Edit If you want to modify the cross-reference format provided, click this button,
which opens the Cross-Reference Format dialog.

Threshold Enter the maximum number of characters to be converted to a topic
before a new topic is created. Flare will break the topic at the nearest paragraph to
the threshold value. That way, a new topic will not start in the middle of a sentence
or word, but at the beginning of a paragraph.

Avoid Creating 'Empty' Topics Select this option if you want to ensure that new topics are
not created when large sections are found in the Word documents without any content.
l
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Threshold Enter the maximum number of empty character spaces allowed in a
topic. If this number is exceeded, Flare will not create a new topic from that empty
space.
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n

Auto-reimport before 'Generate Output' This is also known as "Easy Sync." If you created
a connection between your source files and the Flare project earlier in the wizard, you will
likely make future content changes in the source files. When you make such changes,
the source files need to be re-imported into the project so that they can be included in the
output. You have the option of re-importing the files manually. However, you can also tell
Flare to do this for you automatically, so that you do not have to. Select this option if you
want Flare to automatically re-import files when you attempt to build output.

n

Approximate Filename Length Enter the maximum number of characters to use for naming new topic files that are automatically created after splitting a long topic. The default
is 24.

n

Convert all tables to "Auto-Fit to Contents" Select this option if you want to automatically
set tables to "Auto-Fit to Contents" when they are imported into Flare. This simply
ensures that column widths are not specified on the imported tables.

n

Set first row of each table as a header row Select this option if you want Flare to convert
the first row of every table into a header row. This makes styling tables more efficient. If
you do not select this option, only tables that already have header rows in the Word document will become header rows in Flare. Tables without header rows will be imported just
as they are.
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EXAMPLE
Let's say you have a Word document with two tables.
In the first table, the first row has been set to repeat as a header row.
In the second table, the first row has not been set to repeat as a header
row.
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First, you import the Word document but you do not enable the option to
set the first row of each table as a header row. As a result, the first row in
the first table continues to be a header row, just as it was in the Word document. And the first row in the second table continues to be a regular row,
just as it was in the Word document.
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Next, you import the Word document but you do enable the option to set
the first row of each table as a header row. As a result, the first row of each
table is now a header row.
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n

Create a Page Layout for each section header/footer Select this option if you want Flare
to create new page layouts when you import Word documents that have section breaks,
along with headers or footers. For each new section in the Word document that has a different header or footer than the previous section, Flare creates a unique page layout.
After the import is finished, you can open and edit the page layouts if necessary. You can
then create chapter breaks for your print-based output and assign these page layouts to
the different topics in the output.

n

Automatically set topic title If this option is enabled, the properties setting for the topic
title automatically uses the first heading in the topic. Therefore, if you change the heading text in the future, the topic title changes automatically as well. If this option is disabled, the properties setting for the topic title explicitly uses the first topic heading text
found during the import, and it remains so unless you manually change it later.

n

Convert equations to MathML When importing Microsoft Word files that contain equations, you can convert them from Office Math Markup Language (the format used in
Word) to MathML (the web standard and Flare format). If you disable this option, equations from Word are converted to images.
NOTE: To use this feature, the equation must have been created in Microsoft
Word 2007 or newer. Also, open the Options dialog (File > Options), select the
General tab, and make sure that Import/Export Word Files without MS Office is
disabled.

10. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Stylesheet tab.

11. Use this page to specify whether the imported topics should be associated with a stylesheet
and/or styles from your Word files.
n

Stylesheet If you already have a CSS file that you want to associate with the imported
files, click the Stylesheet button. Then navigate to the stylesheet and select it.
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n

Preserve MS Word Styles This retains any style formatting from your Word documents so
that you can continue to use that look and feel in Flare. For example, if you use a style
called "Heading 1" in your source documents and that style is blue, it remains blue after
you finish the import to Flare and the new style is created. Also, selecting this option
affects which mapping styles are available as you continue to make your import selections. If you select this option, you can map the Word styles to new Flare styles that keep
the name of the Word style (e.g., Heading 1 becomes h1.Heading 1 in Flare).

n

Don't Preserve MS Word Styles This does not keep the style formatting used in the Word
documents. For example, if you use a style called "Heading 1" in your source documents
and that style is blue, that color (and any other settings for that style) are not kept after
you finish the import to Flare. You will still have styles associated with your content, but it
will not look like it did in the source documents. Also, selecting this option affects which
mapping styles are available as you continue to make your import selections. If you
select this option, you can map the Word styles to new Flare styles that either keep the
name of the Word style (e.g., Heading 1 becomes h1.Heading 1 in Flare) or do not (e.g.,
Heading 1 becomes h1 in Flare).

n

Convert inline formatting to CSS styles This creates new styles based on any local
formatting that exists in the Word documents.
EXAMPLE
If you have applied bold and italic formatting to some text (without using a
style), Flare will create a new style based on that formatting.

TIP: To avoid having several character styles in Flare that you do not want, it is
a good idea to clean up your source documents as much as possible before
importing.
12. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Paragraph Styles tab.
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13. Use this page to map paragraph styles from the Word documents to Flare's paragraph styles,
including those from the stylesheet you may have selected. Your Word style will adopt the
name of that style. To map a style, click the style in the MS Word Styles column on the left,
click a style in the Flare Styles section on the far right, and then click the Map button. If you
previously elected not to preserve the Word styles, it is recommended that you map to a
standard CSS parent style—e.g., map your first-level heading style to h1, not to h1.(MS Word
Style).
The style is added to the Flare Styles column. When you are finished importing the documents
and the new Flare project is loaded, the content that had been associated with the style in the
Word document will now be associated with a new style that you mapped it to.
EXAMPLE—PRESERVE STYLES
Let's say you have a style in your Word source document called "Heading 1" that
is using Arial 14 pt and is red, like this.

Hello
During the process of importing your Word document using the Import Microsoft
Word Wizard, you select the option to preserve your Word styles.
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The next page of the wizard looks something like this:

When you finish importing, the content that was associated with Heading 1 in the
source document is still using Arial 14 pt and is red, just like it was before in Word.
However, the style is now called "h1.Heading 1." In the world of cascading style
sheets (CSS)—which is what Flare uses for controlling the look of content—
you've created a class of the h1 style (h1 is the standard style for first-level headings). But because you wanted to keep the look of the Word style, Flare added it
as a child under its parent, h1.
If you make any future changes in Flare to the h1 style, they will trickle down to
the h1.Heading 1 child (unless the child style has explicit settings that conflict
with the parent). You can also apply style properties directly to the h1.Heading 1
child. So while it is generally a good idea to use standard CSS parent styles (such
as h1) when possible in Flare, the mapping performed in this import process—and
the subsequent creation of a child style—lets you keep the Arial 14 pt red look.
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EXAMPLE—DO NOT PRESERVE STYLES
Let's say you have a style in your Word source document called "Heading 1" that
is using Arial 14 pt and is red, like this.

Hello
During the process of importing your Word document using the Import Microsoft
Word Wizard, you select the option to not preserve your Word styles.
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The next page of the wizard looks something like this.

When you finish importing, the content that was associated with Heading 1 in the
source document is no longer using Arial 14 pt, red. Instead, it looks something
like this.

Hello
Also, the style is now called "h1." (Keep in mind that, even if you had mapped the
style to "h1.(Word Style) in this case, the formatting would still be removed.)
So although the formatting was not retained, you were able to map to the standard CSS style for first-level headings—h1 .
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14. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Character Styles tab.

15. Use this page to map character styles from the source documents to Flare's character styles,
including those from the stylesheet you may have selected. Your Word style will adopt the
name of that style. This works the same as the feature for mapping paragraph styles, except
it has to do with character-level styles. To map a style, click the style in the MS Word Style
column, click a style in the Flare Styles section, and then click the Map button.
The style is added to the Flare Styles column. When you are finished importing the documents
and the new Flare project is loaded, the content that had been associated with the style in the
Word document will now be associated with a new style that you mapped it to.
16. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Finish. The Accept Imported Documents dialog opens. The files that will be
created as a result of the import are listed on the left. A preview of each file can be seen
to the right when you click the file.

n

Import Editor In the local toolbar click Import (if this is the first time importing files) or
Reimport (if files have been imported previously). The Accept Imported Documents dialog opens. The files that will be created as a result of the import are listed on the left. A
preview of each file can be seen to the right when you click the file.

17. When you are finished previewing the files to be created, click Accept.
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HOW WORD FEATURES ARE TREATED WHEN IMPORTED
The following table shows some Word features how what happens to them when you import documents into Flare.
Word Feature

Result After Import

Artwork and Special Effects

If you apply certain special effects or artwork (e.g.,
arrows) to images in Word and then import them
into Flare, those effects will not be retained. For
example, a rotated image will return to its straight,
original state. However, there are some workarounds that may allow you to keep the effects or
artwork. One solution is to apply another effect such
as a shadow or 3-D to the image in Word (e.g., add a
shadow to a rotated image that you want to keep).
This forces Word to save the image as an entirely
new image with the effects. Another possible solution is to save the Word document as a web page,
manually copy that HTM file into the Flare folder,
and then open it within Flare. As for text floating
around images, this effect is not supported in Flare.
When you import from Word, the text is added below
the image.

Image Alt Text and Description

If you have an image in a Word document that contains alt text or a description, both are brought in to
Flare. After the Word document is imported, you can
open the topic containing the image, right-click on
the image, and select Image Properties. In the
Image Properties dialog, the description for the
image is shown in the Screen Tip field, and the alt
text is shown in the Alternate Text field.
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Word Feature
Linked and Embedded Images—File Names

Linked Images

Result After Import
Image file names are treated in the following ways
for linked and embedded images:
n

Linked Images If you have inserted a picture
as a linked image in a Word document, the file
name for the image is preserved when imported into Flare. The image file is stored by
default at the root of the Resources/Images
subfolder in the Content Explorer.

n

Embedded Images If you have inserted a picture as an embedded image in a Word document, the file name for the image is based on
the topic name when imported into Flare. The
image file is stored by default in the
Resources/Images/[Word Document Name]
subfolder in the Content Explorer.

When you insert an image in Word, one of the
options is to insert it as a linked image.
NOTE: If you received a Word document
with linked images from another person—
rather than creating the document yourself—you need to also get the images themselves from that individual. Then you need
to re-link the images in the document. Otherwise, Word (and therefore also Flare) will not
be able to find them.
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Word Feature
Videos

Result After Import
If you import a Word document that contains a direct link to a video, it is now brought into the Flare project. Previously, Flare did not support videos in Word
documents.
This only works for direct video links. For example, if
you have Word 2013, you can look for and insert
videos from Bing or YouTube. These are direct link
videos that are supported. But those from video
embed codes are not supported.

NOTE: Flare supports Microsoft Word 2003 and newer versions.

NOTE: When you import Word files, a stylesheet (at least a generic one) will always be created and initially be applied at the project level, whether you choose to preserve Word styles
or not. When a master stylesheet is applied at either the target or project level, you cannot
associate stylesheets at the topic level (unless you remove the master stylesheet association at the project and/or target level).
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Importing Excel Files
You can import Microsoft Excel files into Flare projects. They can be imported into existing projects
or when creating a new project. The spreadsheet content will be added to tables in Flare when the
import is finished.

HOW TO IMPORT EXCEL FILES
1. Do the following, depending on how you are importing your files:

IMPORT INTO A NEW PROJECT
a. Select Project > Import > MS Excel Workbooks.
The Import Microsoft Excel Wizard opens.
b. Select Import into a new project.
c. In the Project name field, type a name for the new Flare project that will be created
after you perform the import.
d. In the Project folder field, either accept the default location for the new project or click
to find and select a folder.
e. From the Output Type field, select the primary target for your project.

IMPORT INTO AN EXISTING PROJECT (WIZARD)
a. Select Project > Import > MS Excel Workbooks.
The Import Microsoft Word Wizard opens.
b. Select Import into this project.
2. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Source Files tab.

3. Click
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4. In the dialog that opens, find and select the files you want to import. You can hold the SHIFT
key to select a range, or you can hold the CTRL key to select individual items. When you are
finished, click Open.
You can select XLS, XLSX, or CSV files.
5. You can use the following options as necessary:
This opens the file that is selected in the list.
Link Generated
Files to
Source
Files

This creates a connection between the original files and the files that are created as a result of the import. This is useful if you want to continue editing the
content outside of Flare, instead of editing in the Flare project. Flare recognizes when changes have been made to the source documents and reminds
you to re-import the documents to ensure the Flare project also reflects the
changes. If you use this option, a link icon is added to the top of a linked file in
the Flare interface. This lets you know that you need to edit the source file,
rather than editing this file. If you remove the connection to the source file, this
icon no longer displays on the file. Please note that if you have bound the project to source control, the icons used for source control take precedence over
the link icon.
This removes the selected file(s) from the list.
This moves the selected file higher in the list (if you have more than one file to
import). The file at the top is used for the name of the content folder holding
the imported topics in Flare. Also, the order determines how the imported files
are arranged in the Flare TOC that is created as a result.
This moves the selected file lower in the list (if you have more than one file to
import).

6. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Options tab.
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7. You can use the following options as necessary:
n

Import Worksheets as Select the type of Flare file where you want your spreadsheets to
be imported.
l

l

Topics Flare will convert your content and place worksheets into topics. Title text on
a worksheet tab will become a heading in the Flare topic.
Snippets Flare will convert your content and place each worksheet into a separate
snippet.

If you selected “Snippets” above, you can also choose from the following options:
l

l

Include tab titles as headings Any title text on your worksheet tabs will become headings in the Flare snippets.
Create a topic with snippets Flare will create a topic and place the snippets within it.
Otherwise, only the snippets will be created.

n

Organize worksheets into different folders per workbook Select this option if you are
importing multiple workbooks and want the resulting files to be stored in separate folders
in Flare. If you do not select this option when importing multiple workbooks, the files will
all be placed in the same folder in Flare.

n

Import hidden rows/columns This includes any hidden rows and columns in the import.
Otherwise, they will not be part of the imported content.

n

Use first row as column header Select this option if you want Flare to convert the first
row of every spreadsheet into column headers in the Flare tables. If you do not select this
option, the first row will be treated like all the other rows.
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n

Import equations based on settings When importing Excel files that contain equations,
you can select this option to convert them to MathML (the web standard) or images. If
you disable this option, equations from Excel are not converted to Flare.
NOTE: The conversion of equations to MathML versus images depends on
whether you have Excel installed:
l

If Excel is Installed Equations will be imported as MathML.

l

If Excel is not Installed Equations will be imported as PNG images.

NOTE: There is an option in Excel that must be enabled in order for equations to
be imported into Flare. In Excel, select an equation that you’ve inserted, open the
Design ribbon, and in the Tools section, click the small option in the lower-right.
Then in the dialog, select Copy MathML to the clipboard as plain text.

NOTE: If you choose to convert equations to MathML, they are automatically
stored in snippets in Flare. Otherwise, equations will be converted to images. A
snippet or image displaying an equation is automatically placed below the worksheet (in the topic or snippet where the worksheet was converted to a table).
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NOTE: To use this feature, the equation must have been created in Microsoft
Excel 2010 or newer.
Import charts as Any charts in your spreadsheets will be imported as images. Use this
field to select the type of image format to be used.

n

NOTE: An image displaying an imported chart is automatically placed below the
worksheet (in the topic or snippet where the worksheet was converted to a
table).

n

Split topics or snippets by maximum rows You can select this option if you have spreadsheets with a lot of rows and want to divide them into multiple topics or snippets (rather
than one very long topic or snippet). After enabling this option, enter the number of rows
that you want to allow in each topic or snippet before a new topic or snippet is created.

n

Auto-reimport before 'Generate Output' This is also known as "Easy Sync." If you created
a connection between your source files and the Flare project earlier in the wizard, you will
likely make future content changes in the source files. When you make such changes,
the source files need to be re-imported into the project so that they can be included in the
output. You have the option of re-importing the files manually. However, you can also tell
Flare to do this for you automatically, so that you do not have to. Select this option if you
want Flare to automatically re-import files when you attempt to build output.

8. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Styles tab.

9. Use this page to specify how you want the formatting of the Excel files to be treated upon
import. Whether the imported files should retain their look and feel from Excel, or if you want
to associate them with a table stylesheet that you’ve already created in Flare.
n

Preserve MS Excel Styles This retains any formatting from your spreadsheets so that
you can continue to use that look and feel in Flare.
If you have Excel installed, all styles (factory and custom) and local formatting are
retained in Flare. If you do not have Excel installed, only custom styles and local format-
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ting are preserved; factory styles are not retained. Also, if you are using more than one
table style in a worksheet, only one of them will be retained in Flare.
n

Don't Preserve MS Excel Styles This does not keep the formatting used in the Excel
spreadsheets. You can click
in the field below this if you want to associate the
imported spreadsheets with a table stylesheet that you’ve already created in Flare. If
you do not choose a table stylesheet, the files will be imported with plain text.

10. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Filters tab.

11. You can use this page to exclude certain worksheets, or even specific rows and columns,
from the import. By default, all workbooks, worksheets, rows, and columns are selected for
import. You can click the corresponding check boxes to remove check marks, which excludes
items from the import. If you click on a particular worksheet, the area to the right displays the
rows and columns within it. You can then remove check marks for any rows or columns that
you want to exclude.
NOTE: If your worksheets have any hidden rows or columns that you did not include
in the import, you may see that those rows or columns are skipped on this page. For
example, you might see columns A, B, C, and E (where D is hidden).
12. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Finish. The Accept Imported Documents dialog opens. The files that will be
created as a result of the import are listed on the left. A preview of each file can be seen
to the right when you click the file.

n

Import Editor In the local toolbar click Import (if this is the first time importing files) or
Reimport (if files have been imported previously). The Accept Imported Documents dialog opens. The files that will be created as a result of the import are listed on the left. A
preview of each file can be seen to the right when you click the file.

13. When you are finished previewing the files to be created, click Accept.

NOTE: There is a limit of 256 columns per worksheet that can be imported from Excel into
Flare.
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NOTE: Flare supports Microsoft Excel 2010 and newer versions. However, if you have an
older version of Excel, you can open the Options dialog (File > Options), select the General
tab, and choose Import Excel Files Without MS Office.

CHAPTER 1

42

Importing FrameMaker Files
You can import Adobe FrameMaker files in the following ways:
n

Import Into a New Project

n

Import Into an Existing Project (From the Wizard)

n

Import Into an Existing Project (From the Import Editor)

NOTE: Before diving in to the import process, it is recommended that you first download
and review the Transition from FrameMaker Guide. This guide provides tips for making sure
the FrameMaker import process goes as smoothly as possible. See "PDFs" on page 160.

HOW TO IMPORT FRAMEMAKER FILES
1. Do the following, depending on how you are importing your files:

IMPORT INTO A NEW PROJECT
a. Select Project > Import > FrameMaker Documents.
The Import FrameMaker Documents Wizard opens.
b. Select Import into a new project.
c. In the Project name field, type a name for the new Flare project that will be created
after you perform the import.
d. In the Project folder field, either accept the default location for the new project or click
to find and select a folder.
e. From the Output Type field, select the primary target for your project.

IMPORT INTO AN EXISTING PROJECT (WIZARD)
a. Select Project > Import > FrameMaker Documents.
The Import FrameMaker Documents Wizard opens.
b. Select Import into this project.
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IMPORT INTO AN EXISTING PROJECT (IMPORT EDITOR)
Do one of the following:

IF YOU DO NOT YET HAVE A FRAMEMAKER IMPORT FILE
a. Complete the steps for adding an import file.
b. Open the file in the Frame Import Editor.

IF YOU ALREADY HAVE A FRAMEMAKER IMPORT FILE
a. In the Project Organizer, expand the Imports subfolder.
b. Double-click the appropriate import file. The file opens in the Frame Import Editor to the
right.
2. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Source Files tab.

3. Click

.

4. In the dialog that opens, find and select the files you want to import. You can hold the SHIFT
key to select a range, or you can hold the CTRL key to select individual items. When you are
finished, click Open.
You can select BOOK, FM, or MIF files.
TIP: When possible, it is recommended that you select a Adobe FrameMaker BOOK
file for import and let Flare locate and import all the associated document files within
the Adobe FrameMaker book.
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5. You can use the following options as necessary:
This opens the file that is selected in the list.
Link Generated
Files to
Source
Files

This creates a connection between the original files and the files that are created as a result of the import. This is useful if you want to continue editing the
content outside of Flare, instead of editing in the Flare project. Flare recognizes when changes have been made to the source documents and reminds
you to re-import the documents to ensure the Flare project also reflects the
changes. If you use this option, a link icon is added to the top of a linked file in
the Flare interface. This lets you know that you need to edit the source file,
rather than editing this file. If you remove the connection to the source file, this
icon no longer displays on the file. Please note that if you have bound the project to source control, the icons used for source control take precedence over
the link icon.
This removes the selected file(s) from the list.
This moves the selected file higher in the list (if you have more than one file to
import). The file at the top is used for the name of the content folder holding
the imported topics in Flare. Also, the order determines how the imported files
are arranged in the Flare TOC that is created as a result.
This moves the selected file lower in the list (if you have more than one file to
import).

6. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next. The FrameMaker documents are scanned and the next page of the
wizard opens. The paragraph styles used in the FrameMaker documents are shown on
the left side of the wizard page ("Used FrameMaker Styles").
NOTE: You can skip the rest of the wizard pages by clicking Finish.

n

CHAPTER 1

Import Editor Select the New Topic Styles tab.
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7. If you want Flare to split the FrameMaker documents into smaller topics based on any of the
styles shown on the left side of the page ("Used FrameMaker Styles"), double-click that style
to move it to the right side of the page ("New Topic Styles").
EXAMPLE
If you have a style called "Heading 2" in your FrameMaker documents, you might
want new topics to be created whenever Flare finds a Heading 2 style in a document. So you would double-click Heading 2 and move it to the right side of the
page.
8. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Options tab.

9. You can use the following options as necessary:
n

Add "Topic Continued" links when appropriate Select this option to place a "Topic Continued" link at the bottom of pages when a long topic has been split into multiple ones.

n

Add "Topic Continued From" links when appropriate Select this option to place a "Topic
Continued From" link at the top of continued pages when a long topic has been split into
multiple ones.

n

Cross-Reference Format Use this field to specify the format for the "Topic Continued"
and "Topic Continued From" links. Flare provides a cross-reference format for you—(continued in {title}) or (continued from {title}). With this cross-reference format, the link contains the words "continued in" or "continued from" within parentheses, followed by the
text of the first paragraph in the connected topic. If you do not want the link to use that
particular text, you have a couple of options. First, in Flare, you could manually enter a
heading in each topic that is connected to another topic included in the split. That text
will be used in the link instead (after you update the cross-references in Flare). Another
option is to modify the format by clicking the Edit button.
l
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Edit If you want to modify the cross-reference format provided, click this button,
which opens the Cross-Reference Format dialog.
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n

Split Long Topics Select this option if you have long sections in your source documents
and want to make sure that they are converted to multiple topics (rather than one very
long topic).
l

n

Avoid Creating 'Empty' Topics Select this option if you want to ensure that new topics are
not created when large sections are found in the FrameMaker documents without any
content.
l

n

Threshold Enter the maximum number of characters to be converted to a topic
before a new topic is created. Flare will break the topic at the nearest paragraph to
the threshold value. That way, a new topic will not start in the middle of a sentence
or word, but at the beginning of a paragraph.

Threshold Enter the maximum number of empty character spaces allowed in a
topic. If this number is exceeded, Flare will not create a new topic from that empty
space.

Anchored Frames With Images You can use this area to specify how Flare should handle
anchored frames that contain images as well as other content (e.g., text callouts).
l

l
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Generate Images Without Callouts If the anchored frame contains an image along
with callout text, the original image is imported without the callout text. You might
select this option if you have resized the image in FrameMaker. With this option,
the imported image is likely to be of a higher quality than it would be otherwise. You
can then add a callout to the image once it is inside Flare.
Generate Images With Callouts If the anchored frame contains an image along
with callout text, Flare creates a PROPS (i.e., properties) file along with the image
file when that document is imported. This means that you can open those image
files in MadCap Capture to edit those callouts after the import process is completed.
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EXAMPLE
If you import anchored frame images and tell Flare not to include the
callouts, your imported image files will look something like this in Windows Explorer.

On the other hand, if you import the same images and tell Flare to
include the callouts, it will look something like this in Windows
Explorer.

NOTE: Some FrameMaker elements—such as arcs and nested frames—
are not supported with this option.

l
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Generate Flattened Images If the anchored frame contains an image along with
callout text, a new flattened image will be created as a result. The callout is
included, but you cannot edit it.
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n

Preserve Image Size This option affects how the size of imported images are handled.
l

l

Option Selected The original image is imported. However, the <img> tag is modified
in the imported file to closely reflect the height and width of the image in the
FrameMaker document. This is done regardless of whether you are importing
linked or embedded images from FrameMaker documents.
Option NOT Selected The <img> tag is not modified in the imported file. Instead,
the image is referenced at 100% of its original value.

n

Auto-reimport before 'Generate Output' This is also known as "Easy Sync." If you created
a connection between your source files and the Flare project earlier in the wizard, you will
likely make future content changes in the source files. When you make such changes,
the source files need to be re-imported into the project so that they can be included in the
output. You have the option of re-importing the files manually. However, you can also tell
Flare to do this for you automatically, so that you do not have to. Select this option if you
want Flare to automatically re-import files when you attempt to build output.

n

Approximate Filename Length Enter the maximum number of characters to use for naming new topic files that are automatically created after splitting a long topic. The default
is 24.

n

Enable 'Passthrough' Markers Select this check box to include a check mark if you have
created passthrough markers in your FrameMaker source documents.A passthrough
marker is a special marker that you can insert into your FrameMaker source content
when you have information or code that you plan to import to Flare and want left alone
(or "passed through," leaving it exactly as you have authored it, rather than processing it).
A passthrough marker can be just about anything, as long as supports it in the XHTML
code.You can specify how the marker content should be treated when the FrameMaker
document is imported. The first option is that you can import the marker content as regular text (which is the default setting). The second option is that you can import the
marker content as an XML fragment (e.g., the first part of a bold tag—<b>—but not the
second part). The third option is that you can import the marker content as a complete
XML tag. You might use a passthrough marker for various reasons, such as for importing
a marker as XHTML or JavaScript code.
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EXAMPLE
Let's say you plan to import some FrameMaker documents to Flare and
you have locations in those documents where you want to link to CHM
files. The problem is that FrameMaker does not allow you to create links to
CHM files in such a way that those links can then be imported into another
software application.
Therefore, you create a passthrough marker in the FrameMaker document, providing the beginning "href" tag and path to the CHM file. Like
this:

Then you create a second passthrough marker, providing the end tag for
the link. Like this:

When you import the FrameMaker document(s), you can specify that the
passthrough markers should be imported as XML fragments. In Flare, the
link to the CHM file will look and work as it should.

CHAPTER 1

50

n

Passthrough Marker Format After you enable passthrough markers, click the down arrow
in this field and select the type of format that you want to use for the import.
l

l

l

text The marker content will be imported as regular text (default setting).
fragment The marker content is imported as an XML fragment (e.g., the first part
of a bold tag—<b>—but not the second part). If you select this option, you will probably need a second marker in the FrameMaker document to complete the XML
tag.
xml The marker content is imported as a complete XML tag.

n

Convert equations to MathML Select this option to convert MathFullForm equations (the
FrameMaker-specific format) to MathML (the web standard and Flare format). If you disable this option, equations from FrameMaker are converted to images.

n

Convert Table Styles If you have tables in your FrameMaker documents that you have
formatted in a certain way, select this check box if you want to create matching table
styles as a result of the import. In the Flare project, the new table styles will be named
after the format named applied to the table in FrameMaker (e.g., "Format_A.css,"
"Format_B.css," and so on). You can rename these table stylesheets in Flare after the
import finishes. Even if you do not use this mapping feature, the table formatting still
comes across when you import the documents. The only difference is that table
stylesheets make it easier to maintain the formatting of your tables within Flare.

n

Reimport Table Styles This option displays only if you are working in the Import Editor,
rather than the wizard. This option is useful after you have already imported FrameMaker
documents and converted the formatting in your tables into at least one table stylesheet
in Flare. You can use this option to determine whether tables should be imported again as
table styles when you re-import. You might want to keep this check box selected for
some re-imports, but other times you might want to deselect it when re-importing.
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EXAMPLE
Let’s say you want the formatted tables in your FrameMaker documents to
be converted to table styles when you perform the initial import into a Flare
project. Therefore, in the import wizard, you turn on the "Convert Table
Styles" option. As a result, let's say that Flare creates a new table style and
calls it "FormatA.css."
After the initial import, you realize you want the tables to look a little different. Therefore, in the Flare project, you modify the properties of the
FormatA.css table stylesheet.
Awhile later, let's say you want to re-import the FrameMaker documents.
The problem is that you've already changed the table stylesheet in Flare.
You probably want to keep the tweaked table style so that you don’t have
to modify it again after the import.
This is where the new "re-import" option comes into play. It determines
whether or not a second new table stylesheet will be created, based on the
old look from the tables in the FrameMaker documents.
Here's one scenario. Let's say that before you re-imported the
FrameMaker documents, you selected the "Reimport Table Styles" option
in the Frame Import Editor. And during the import when you were prompted, you selected not to overwrite the existing FormatA.css table
stylesheet. In that case, Flare keeps your tweaked stylesheet in the project, but it also creates another table stylesheet called "FormatA1.css" that
has the old look and feel. All of the re-imported content now links to the
FormatA1.css stylesheet instead of FormatA.css.
Here's a different scenario. Let's say that you perform the same steps
described above, except this time you deselected the "Reimport Table
Styles" option in the Frame Import Editor. In that case, the second
FormatA1.css file is not created. The imported content is linked to the
FormatA.css table stylesheet that you previously modified, since it already
exists in the project.
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10. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Stylesheet tab.

11. Use this page to specify whether the imported topics should be associated with a stylesheet
and/or styles from your FrameMaker files.
n

Stylesheet If you already have a CSS file that you want to associate with the imported
files, click the Stylesheet button. Then navigate to the stylesheet and select it.

n

Preserve FrameMaker Styles This retains any style formatting from your FrameMaker
documents so that you can continue to use that look and feel in Flare. For example, if you
use a style called "Heading 1" in your source documents and that style is blue, it remains
blue after you finish the import to Flare and the new style is created. Also, selecting this
option affects which mapping styles are available as you continue to make your import
selections. If you select this option, you can map the FrameMaker styles to new Flare
styles that keep the name of the FrameMaker style (e.g., Heading 1 becomes h1.Heading
1 in Flare).

n

Don't Preserve FrameMaker Styles This does not keep the style formatting used in the
FrameMaker documents. For example, if you use a style called "Heading 1" in your source
documents and that style is blue, that color (and any other settings for that style) are not
kept after you finish the import to Flare. You will still have styles associated with your content, but it will not look like it did in the source documents. Also, selecting this option
affects which mapping styles are available as you continue to make your import selections. If you select this option, you can map the FrameMaker styles to new Flare styles
that either keep the name of the FrameMaker style (e.g., Heading 1 becomes h1.Heading
1 in Flare) or do not (e.g., Heading 1 becomes h1 in Flare).

n

Conversion Styles This opens the Import Styles Editor, which lets you specify how to convert each property of the FrameMaker styles. If you do not enter a property value, the
value from the FrameMaker document is used. If you enter a property value, it overrides
the value from the FrameMaker document. This button is used only if you have selected
"Preserve FrameMaker Styles."
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EXAMPLE
You might use this button, for example, if you need to change a cross-reference format coming from FrameMaker into something more meaningful
in Flare. There are some cross-reference building blocks in FrameMaker
that do not have an equivalent in Flare. In cases such as these, the formats
are preserved after conversion to Flare. However, the formats may therefore appear to be broken, but they are preserved to let you know that there
was some formatting in a cross-reference style that Flare did not understand; you can then make changes to the cross-reference style in the
stylesheet. Therefore, if you already know ahead of time that you have a
cross-reference style that will need to be modified for use in Flare, you can
use the Conversion Styles button and change the cross-reference format
to something that Flare understands.
12. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Paragraph Styles tab.

13. Use this page to map paragraph styles from the FrameMaker documents to Flare's paragraph
styles, including those from the stylesheet you may have selected. Your FrameMaker style
will adopt the name of that style. To map a style, click the style in the FrameMaker Styles
column on the left, click a style in the Flare Styles section on the far right, and then click the
Map button. If you previously elected not to preserve the FrameMaker styles, it is recommended that you map to a standard CSS parent style—e.g., map your first-level heading style
to h1, not to h1.(FrameMaker Style).
The style is added to the Flare Styles column. When you are finished importing the documents
and the new Flare project is loaded, the content that had been associated with the style in the
FrameMaker document will now be associated with a new style that you mapped it to.
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EXAMPLE—PRESERVE STYLES
Let's say you have a style in your FrameMaker source document called "Heading1" that is using Arial 14 pt and is red, like this.

Hello
During the process of importing your FrameMaker document using the Import
FrameMaker Wizard, you select the option to preserve your FrameMaker styles.
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The next page of the wizard looks something like this:

When you finish importing, the content that was associated with Heading1 in the
source document is still using Arial 14 pt and is red, just like it was before in
FrameMaker. However, the style is now called "h1.Heading1." In the world of cascading style sheets (CSS)—which is what Flare uses for controlling the look of
content—you've created a class of the h1 style (h1 is the standard style for firstlevel headings). But because you wanted to keep the look of the FrameMaker
style, Flare added it as a child under its parent, h1.
If you make any future changes in Flare to the h1 style, they will trickle down to
the h1.Heading1 child (unless the child style has explicit settings that conflict
with the parent). You can also apply style properties directly to the h1.Heading1
child. So while it is generally a good idea to use standard CSS parent styles (such
as h1) when possible in Flare, the mapping performed in this import process—and
the subsequent creation of a child style—lets you keep the Arial 14 pt red look.
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EXAMPLE—DO NOT PRESERVE STYLES
Let's say you have a style in your FrameMaker source document called "Heading1" that is using Arial 14 pt and is red, like this.

Hello
During the process of importing your FrameMaker document using the Import
FrameMaker Wizard, you select the option to not preserve your FrameMaker
styles.
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The next page of the wizard looks something like this.

When you finish importing, the content that was associated with Heading1 in the
source document is no longer using Arial 14 pt, red. Instead, it looks something
like this.

Hello
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Also, the style is now called "h1." (Keep in mind that, even if you had mapped the
style to "h1.(FrameMaker Style) in this case, the formatting would still be
removed.)
So although the formatting was not retained, you were able to map to the standard CSS style for first-level headings—h1 .
14. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Character Styles tab.

15. Use this page to map character styles from the source documents to Flare's character styles,
including those from the stylesheet you may have selected. Your FrameMaker style will adopt
the name of that style. This works the same as the feature for mapping paragraph styles,
except it has to do with character-level styles. To map a style, click the style in the
FrameMaker Style column, click a style in the Flare Styles section, and then click the Map button.
The style is added to the Flare Styles column. When you are finished importing the documents
and the new Flare project is loaded, the content that had been associated with the style in the
FrameMaker document will now be associated with a new style that you mapped it to.
16. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Cross-Reference Styles tab.

CHAPTER 1

59

17. Use this page to map cross-reference (x-ref) styles from the FrameMaker documents to
Flare's cross-reference styles, including those from the stylesheet you may have selected. In
this way, you can have your FrameMaker style take on the appearance of the Flare style that
you map it to. To map a style, click the style in the FrameMaker Style column on the left, click
a style in the Flare Styles section on the far right, and then click the Map button.
The style is added to the Flare Style column. When you are finished importing the documents
and the new Flare project is loaded, the content that had been associated with the
FrameMaker style in the FrameMaker document will now be associated with a new style that
has the appearance of the style that you mapped it to.
What happens if you do not map a style? In the case of cross-reference styles, they are automatically added as style classes under the MadCap|xref style. For example, let's say you
import a style called "PageOnly" from your source document and do not map it to anything. In
that case, it will be called "MadCap|xref.PageOnly" in the resulting project.
18. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Finish. The Accept Imported Documents dialog opens. The files that will be
created as a result of the import are listed on the left. A preview of each file can be seen
to the right when you click the file.

n

Import Editor In the local toolbar click Import (if this is the first time importing files) or
Reimport (if files have been imported previously). The Accept Imported Documents dialog opens. The files that will be created as a result of the import are listed on the left. A
preview of each file can be seen to the right when you click the file.

19. When you are finished previewing the files to be created, click Accept.

NOTE: You must have FrameMaker installed on your computer in order to import
FrameMaker files.

NOTE: For each master page used in your FrameMaker documents, a corresponding page
layout is automatically created in your Flare project. You can use the page layouts to configure pages for print-based output. You can then create chapter breaks for your printbased output and assign these page layouts to the different topics in the output.
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NOTE: Flare supports FrameMaker 7.0 and newer versions.

NOTE: A link icon displays on tabs in the XML Editor next to file names that are imported
from and linked to another file or Flare project. However, if you are also using the built-in
source control technology, the source control icons have a higher precedence and will
therefore be displayed instead.
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Importing a RoboHelp Project
Following are the steps for creating a project by importing a RoboHelp project.

HOW TO IMPORT A ROBOHELP PROJECT
1. Select File > New Project > RoboHelp Project.
2. In the dialog that opens, browse for and double-click the RoboHelp project file (MPJ or XPJ
file) to be imported. The Import Project Wizard opens.
3. In the Project name field, type a name for the new Flare project that will be created after you
import the RoboHelp project.
4. In the Project folder field, either accept the default location for the new project or click
browse for and select a folder.

to

5. Click Next.
6. (Optional) Select Convert all topics at once if you want Flare to immediately convert all of your
topic files to XHTML.
If you remove the check mark from the box, Flare imports the topic files as they are. When
you try to open an imported topic in Flare, a message asks if you want to convert it to XML.
Also, if this option is not selected, Flare will not import index keywords from the source files.
7. (Optional) Select Convert inline formatting to CSS styles if you want Flare to create new
styles based on any "local" formatting that exists in the RoboHelp project files.
EXAMPLE
If you have applied bold and italic formatting to some text (without using a style),
Flare will create a new style based on that formatting.
8. Click Next.
9. Select a language for the project.
10. Click Finish. A message tells you that the project was converted successfully and will be
opened.
11. Click OK.
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Importing HTML Help
Following are the steps for creating a project by importing an HTML Help project (HHP file).

HOW TO IMPORT AN HTML HELP PROJECT (HHP)
1. Select File > New Project > HTML Help Project (HHP).
2. In the dialog that opens, browse for and double-click the HTML Help file (HHP file) to be imported. The Import Project Wizard opens.
3. In the Project name field, type a name for the new Flare project that will be created after you
import the HTML Help project.
4. In the Project folder field, either accept the default location for the new project or click
browse for and select a folder.

to

5. Click Next.
6. (Optional) Select Convert all topics at once if you want Flare to immediately convert all of your
topic files to XHTML.
If you remove the check mark from the box, Flare imports the topic files as they are. When
you try to open an imported topic in Flare, a message asks if you want to convert it to XHTML.
Also, if this option is not selected, Flare will not import index keywords from the source files.
7. (Optional) Select Convert inline formatting to CSS styles if you want Flare to create new
styles based on any "local" formatting that exists in the HTML Help project files.
EXAMPLE
If you have applied bold and italic formatting to some text (without using a style),
Flare will create a new style based on that formatting.
8. Click Next.
9. Select a language for the project.
10. Click Finish. A message tells you that the project was converted successfully and will be
opened.
11. Click OK.
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Importing CHM Files
Following are the steps for creating a project by importing an HTML Help (CHM) file.

HOW TO IMPORT AN HTML HELP (CHM) FILE
1. Select File > New Project > HTML Help File (CHM).
2. In the dialog that opens, browse for and double-click the CHM file to be imported. The Import
Project Wizard opens.
3. Click Next.
4. In the Project name field, type a name for the new Flare project that will be created after you
import the CHM file.
5. In the Project folder field, either accept the default location for the new project or click
find and select a folder.

to

6. Click Next.
7. (Optional) Select Convert all topics at once if you want Flare to immediately convert all of your
topic files to XHTML.
If you remove the check mark from the box, Flare imports the topic files as they are. When
you try to open an imported topic in Flare, a message asks if you want to convert it to XHTML.
Also, if this option is not selected, Flare will not import index keywords from the source files.
8. (Optional) Select Convert inline formatting to CSS styles if you want Flare to create new
styles based on any "local" formatting that exists in the HTML Help file.
EXAMPLE
If you have applied bold and italic formatting to some text (without using a style),
Flare will create a new style based on that formatting.
9. Click Next.
10. Select a language for the project.
11. Click Finish. A message tells you that the project was converted successfully and will be
opened.
12. Click OK.
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Importing DITA Files
Darwin Information Typing Architecture (DITA) file content is supported in Flare. DITA is an XMLbased markup language with its own schema for authoring, producing, and delivering technical
information. It is a standard of the Organization for the Advancement of Structured Information
Standards (OASIS), and it consists of a set of design principles for creating "information-typed" modules at a topic level and for using that content in various delivery modes.
You can import DITA files in the following ways:
n

Import Into a New Project

n

Import Into an Existing Project (From the Wizard)

n

Import Into an Existing Project (From the Import Editor)

HOW TO IMPORT DITA FILES
1. Do the following, depending on how you are importing your files:

IMPORT INTO A NEW PROJECT
a. Select Project > Import > DITA Document Set.
The Import DITA Wizard opens.
b. Select Import into a new project.
c. In the Project name field, type a name for the new Flare project that will be created
after you perform the import.
d. In the Project folder field, either accept the default location for the new project or click
to find and select a folder.
e. From the Output Type field, select the primary target for your project.

IMPORT INTO AN EXISTING PROJECT (WIZARD)
a. Select Project > Import > DITA Document Set.
The Import DITA Wizard opens.
b. Select Import into this project.
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IMPORT INTO AN EXISTING PROJECT (IMPORT EDITOR)
Do one of the following:

IF YOU DO NOT YET HAVE A DITA IMPORT FILE
a. Complete the steps for adding an import file.
b. Open the file in the DITA Import Editor.

IF YOU ALREADY HAVE A DITA IMPORT FILE
a. In the Project Organizer, expand the Imports subfolder.
b. Double-click the appropriate import file. The file opens in the DITA Import Editor to the
right.
2. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Source Files tab.

3. Click

.

4. In the dialog that opens, find and select the files you want to import. You can hold the SHIFT
key to select a range, or you can hold the CTRL key to select individual items. When you are
finished, click Open.
You can select DITA or DITAMAP files.
NOTE: You cannot select multiple DITAMAP files from different folders during the
same import process. You must first import the DITAMAP file(s) from one folder.
Then in the project that is created as a result, you can import the DITAMAP file(s)
from a second folder.
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5. You can use the following options as necessary:
This opens the file that is selected in the list.
Link Generated
Files to
Source
Files

This creates a connection between the original files and the files that are created as a result of the import. This is useful if you want to continue editing the
content outside of Flare, instead of editing in the Flare project. Flare recognizes when changes have been made to the source documents and reminds
you to re-import the documents to ensure the Flare project also reflects the
changes. If you use this option, a link icon is added to the top of a linked file in
the Flare interface. This lets you know that you need to edit the source file,
rather than editing this file. If you remove the connection to the source file, this
icon no longer displays on the file. Please note that if you have bound the project to source control, the icons used for source control take precedence over
the link icon.
This removes the selected file(s) from the list.
This moves the selected file higher in the list (if you have more than one file to
import). The file at the top is used for the name of the content folder holding
the imported topics in Flare. Also, the order determines how the imported files
are arranged in the Flare TOC that is created as a result.
This moves the selected file lower in the list (if you have more than one file to
import).

6. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Options tab.
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7. You can use the following options as necessary:
n

Import all Content files to one folder Select this option if you want all of the imported
DITA file content to be placed in just one folder in the Content Explorer.

n

Auto-reimport before 'Generate Output' This is also known as "Easy Sync." If you created
a connection between your source files and the Flare project earlier in the wizard, you will
likely make future content changes in the source files. When you make such changes,
the source files need to be re-imported into the project so that they can be included in the
output. You have the option of re-importing the files manually. However, you can also tell
Flare to do this for you automatically, so that you do not have to. Select this option if you
want Flare to automatically re-import files when you attempt to build output.

n

Preserve ID attributes for elements Every element inside a DITA file has an ID. This ID is
not needed in Flare. However, if you intend to send your output back out to DITA at any
point, you can select this option to make sure the ID is preserved.

8. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Stylesheet tab.
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9. Use this page to specify whether the imported topics should be associated with a stylesheet
and/or styles from your DITA files.
Conversion Styles This opens the DITA Import Styles Editor, which lets you specify how to
convert each property of the DITA elements. If you do not enter a property value, the
value from the DITA file is used. If you enter a property value, it overrides the value from
the DITA file. You can also use the dialog to import and export styles.

n

NOTE: When you import content from DITA files, there is a one-to-one conversion that occurs. For each DITA element in your file, a style class is created in
Flare. For example, let's say you have a paragraph-level DITA element called "topictitle," after you import the file, a style class called "h1.topictitle" might be created in Flare. Or if you have a character-level DITA element called "cmdname,"
after you import the file, a style class called "span.cmdname" might be created
as a result in Flare. If necessary, you can later edit those style classes in Flare. If
you generate DITA output from your project, the style classes are converted
back to DITA elements.
Stylesheet If you already have a CSS file that you want to associate with the imported
files, click the Stylesheet button. Then navigate to the stylesheet and select it.

n

10. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Finish. The Accept Imported Documents dialog opens. The files that will be
created as a result of the import are listed on the left. A preview of each file can be seen
to the right when you click the file.

n

Import Editor In the local toolbar click Import (if this is the first time importing files) or
Reimport (if files have been imported previously). The Accept Imported Documents dialog opens. The files that will be created as a result of the import are listed on the left. A
preview of each file can be seen to the right when you click the file.

11. When you are finished previewing the files to be created, click Accept.
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Importing HTML Files
You can import XHTML and HTML files (automatically converting them to XHTML) in the following
ways:
n

Import Into a New Project

n

Import Into an Existing Project (From the Wizard)

n

Import Into an Existing Project (From the Import Editor)

HOW TO IMPORT HTML FILES
1. Do the following, depending on how you are importing your files:

IMPORT INTO A NEW PROJECT
a. Select Project > Import > HTML File Set.
The Import HTML Files Wizard opens.
b. Select Import into a new project.
c. In the Project name field, type a name for the new Flare project that will be created
after you perform the import.
d. In the Project folder field, either accept the default location for the new project or click
to find and select a folder.
e. From the Output Type field, select the primary target for your project.

IMPORT INTO AN EXISTING PROJECT (WIZARD)
a. Select Project > Import > HTML File Set.
The Import HTML Files Wizard opens.
b. Select Import into this project.
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IMPORT INTO AN EXISTING PROJECT (IMPORT EDITOR)
Do one of the following:

IF YOU DO NOT YET HAVE AN HTML IMPORT FILE
a. Complete the steps for adding an import file.
b. Open the file in the HTML Import Editor.

IF YOU ALREADY HAVE AN HTML IMPORT FILE
a. In the Project Organizer, expand the Imports subfolder.
b. Double-click the appropriate import file. The file opens in the HTML Import Editor to the
right.
2. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Source Files tab.

3. Click one of the following:
In the dialog that opens, find and select the files you want to import. You can hold the SHIFT key
to select a range, or you can hold the CTRL key to select individual items. When you are finished, click Open.
In the dialog that opens, find and select a folder containing HTML files you want to import. When
you select a folder to import, the wizard imports all files within that folder that have an .htm,
.html, or .xhtml extension. If you later re-import HTML files into the project, Flare checks to see
if any of the files in the source folder have changed. It also determines whether files have been
deleted or added, and it updates the source files list accordingly. When you are finished, click
Open.
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4. You can use the following options as necessary:
This opens the file that is selected in the list.
This opens the HTML to XHTML Conversion dialog, which lets you see how the
selected file looks in HTML and how it will look after its conversion to XHTML.
Link Generated
Files to
Source
Files

This creates a connection between the original files and the files that are created as a result of the import. This is useful if you want to continue editing the
content outside of Flare, instead of editing in the Flare project. Flare recognizes when changes have been made to the source documents and reminds
you to re-import the documents to ensure the Flare project also reflects the
changes. If you use this option, a link icon is added to the top of a linked file in
the Flare interface. This lets you know that you need to edit the source file,
rather than editing this file. If you remove the connection to the source file, this
icon no longer displays on the file. Please note that if you have bound the project to source control, the icons used for source control take precedence over
the link icon.
This removes the selected file(s) from the list.
This moves the selected file higher in the list (if you have more than one file to
import). The file at the top is used for the name of the content folder holding
the imported topics in Flare. Also, the order determines how the imported files
are arranged in the Flare TOC that is created as a result.
This moves the selected file lower in the list (if you have more than one file to
import).

5. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Next.

n

Import Editor Select the Options tab.

6. Click Next.

CHAPTER 1

72

7. You can use the following options as necessary:
n

Import linked HTML files Select this option if you want to automatically bring in other files
that are linked to those you selected on the previous page. For example, if you import
Doc1.htm, which contains a hyperlink to Doc2.htm, this option imports Doc2.htm as well.

n

Import resources Select this option if you want to include any supporting resource files
(e.g., stylesheets, images, multimedia files) in the import. Then select one of the following:
l

l

Keep existing structure The supporting resources files will be copied into folders with
the same names and hierarchy as those used in the source.
To project resources folder The supporting files will be placed in the Resources
folder in your Flare project.

Auto-reimport before 'Generate Output' This is also known as "Easy Sync." If you created
a connection between your source files and the Flare project earlier in the wizard, you will
likely make future content changes in the source files. When you make such changes,
the source files need to be re-imported into the project so that they can be included in the
output. You have the option of re-importing the files manually. However, you can also tell
Flare to do this for you automatically, so that you do not have to. Select this option if you
want Flare to automatically re-import files when you attempt to build output.

n

8. Do one of the following, depending on the part of the interface you are using:
n

Wizard Click Finish. The Accept Imported Documents dialog opens. The files that will be
created as a result of the import are listed on the left. A preview of each file can be seen
to the right when you click the file.

n

Import Editor In the local toolbar click Import (if this is the first time importing files) or
Reimport (if files have been imported previously). The Accept Imported Documents dialog opens. The files that will be created as a result of the import are listed on the left. A
preview of each file can be seen to the right when you click the file.

9. When you are finished previewing the files to be created, click Accept.
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Importing Doc-To-Help
Following are the steps for creating a project by importing a Doc-To-Help project.

BEFORE YOU BEGIN
Here are some important things to keep in mind when importing Doc-To-Help projects:
n

You will need to build a target in your Doc-To-Help project before importing to Flare to ensure
that all links have been updated. Flare's import process uses the Doc-To-Help database, which
only updates links when Doc-To-Help projects are built.

n

Flare will only convert HTML5 source documents from Doc-To-Help. Therefore, you will need
to use the Doc-To-Help converter to convert all Word source documents. This includes any
rich content variables authored in Word. See the online documentation for Doc-To-Help.
NOTE: Keep in mind that once all documents in the project have been converted to
HTML5, the project has to be managed directly within the Doc-To-Help application
(C:\Program Files (x86)\MadCap Software\DocToHelp\DocToHelp.exe).

n

If a Doc-To-Help source document is a multiple topic type, upon import it will be split into Flare
topics by heading levels h1 through h5. All documents converted from Word to HTML5 are
multiple topic types. The splitting is used to preserve the look of the online output with each
heading level showing as a new page in the online TOC. To avoid this behavior, you can convert your multiple topics into single topics in Doc-To-Help before importing into Flare.

n

Auto-generated TOCs are not in the database when they are imported. The TOC must be modified in order to be imported from Doc-To-Help to Flare. Even a simple change (e.g. moving a
TOC topic up and then down to the same position) is considered a customization. This customization of the TOC will ensure that is imported from Doc-To-Help to Flare.

HOW TO IMPORT A DOC-TO-HELP PROJECT
1. Select File > New Project > Doc-To-Help Project.
2. In the dialog that opens, browse for and double-click the Doc-To-Help project file (D2H file) to
be imported. The Import Project Wizard opens.
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3. Click Next.
NOTE: If you want to import Doc-To-Help projects to a 64-bit version of Flare, you will
need to download Microsoft Access Database Engine 2010 x64 edition. If you do not
already have this add-in, Flare will prompt you to install it from the Microsoft Download Center.
4. In the Project name field, type a name for the new Flare project that will be created after you
import the Doc-To-Help project.
5. In the Project folder field, either accept the default location for the new project or click
browse for and select a folder.

to

6. Click Next.
7. If you convert Word source documents to HTML5 source files in Doc-To-Help, and then build a
target, stylesheets are created as a result and saved in the output folder. You can save those
stylesheets in a different folder and then use this page of the wizard to point to them, bringing
them into Flare in one merged CSS file.

HOW TO SAVE DOC-TO-HELP STYLESHEETS AND SELECT THEM WHEN
IMPORTING TO FLARE
a. Make a backup copy of your Doc-To-Help project.
b. Open your Doc-To-Help project that contains Word source files.
c. Select or create a NetHelp target and build the output.
d. Open the project output folder and browse to [Project Name]\NetHelp\LinksExt.
NOTE: The LinksExt folder might contain several stylesheets (separate ones for
each topic), because each time a Word topic uses a style not already used in a
previous topic, Doc-To-Help creates a new stylesheet to account for it. It might
look something like this:
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e. Move the LinksExt folder to a new location outside of the NetHelp parent folder, because
this folder will be overwritten when you generate output again. Then rename the folder to
whatever you want your imported stylesheet to be named.
f. In your Doc-To-Help project, click Convert Multiple Documents to HTML5 and proceed
with the wizard to convert all files.
g. Word closes the project when there are no DOC or DOCX files in the project. Therefore, in
Windows navigate to your Program Files\MadCap Software\DocToHelp folder and
double-click the DocToHelp EXE file. Then build a target to update links.
h. In Flare, import your Doc-To-Help project, and on the "Select CSS folders…" page of the
wizard, click

.

i. In the dialog that opens, locate and select the folder that you moved and renamed earlier
in this process. Then finish importing the project. If the folder contains multiple
stylesheets, Flare merges them into one CSS file.
8. Click Next.
9. Select an option for how to import links. You can import links as cross-references or as hyperlinks.
10. Select a language for the project.
11. Click Finish.

DOC-TO-HELP FEATURES AND FLARE EQUIVALENTS
The following table shows many of the Doc-To-Help features and their equivalents in Flare. For a
few of these features, the settings are not imported from Doc-To-Help to Flare.
Doc-To-Help
Feature

Flare
Feature

Attributes

Conditions

Bookmarks

Bookmarks

Carousel Widgets

Slideshows
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Notes/Limitations
Doc-To-Help allows conditions on platforms (e.g., all Word targets). However, Flare does not support that feature; therefore
conditions on platforms are not imported.
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Doc-To-Help
Feature

Flare
Feature

CodeHighlighter
Widgets

Div Tags

Collapsible Sections

Togglers

Comments

Annotations

CSS

Stylesheet

Gallery Widgets

Slideshows

Glossaries

Glossaries
and Proxies

Notes/Limitations

Glossary terms are added to a Flare glossary file. Glossary topics
are changed to include Flare's Glossary proxy.
Flare does not support images and text formatting in glossaries,
so those elements are not included in the import.

Groups

Concepts
and
Concept
Links (Alinks)

Groups are similar to Flare's concepts, which can be used for a
couple of things, including the creation of concept links (also
called "See Also links" or "A-links"). When you import a Doc-ToHelp project, groups are converted to concepts in a couple of different ways, depending on how they are created in Doc-To-Help:
n

If you insert a group in Doc-To-Help by dragging the topic
from the Topics pane to the Groups pane, Flare converts
the group to a concept and adds it at the very top of the
topic.

n

If you insert a group in Doc-To-Help from the ribbon, you
are adding it inline, as well as adding it to the Groups pane.
Flare converts the group to a concept and adds it inline as
well as at the very top of the topic. This means that when
you have an A-link, that group might be listed twice in the
output. Therefore, you may need to clean up your topics,
removing the excess concepts.

If you already have a group link in Doc-To-Help, it is imported as a
concept link in Flare.
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Doc-To-Help
Feature
Inline Text:
Expanded, Drop
down, Pop Up

Flare
Feature

Notes/Limitations

Expanding
Text
Drop-Down
Text
Text
Popups

Keywords

Index Keywords

Keywords are similar to Flare's index keywords, which can be
used for a couple of things, including the creation of keyword
links (also called "K-links"). When you import a Doc-To-Help project, keywords are converted to index keywords in a couple of different ways, depending on how they are created in Doc-To-Help:
n

If you insert a keyword in Doc-To-Help by dragging the
topic from the Topics pane to the Index pane, Flare converts the keyword to an index keyword and adds it at the
very top of the topic.

n

If you insert a keyword in Doc-To-Help from the ribbon, you
are adding it inline, as well as adding it to the Index pane.
Flare converts the keyword to an index keyword and adds it
inline as well as at the very top of the topic. This means
that when you have a K-link, that index keyword might be
listed twice in the output. Therefore, you may need to
clean up your topics, removing the excess index keywords.

If you already have an index link in Doc-To-Help, it is imported as
a keyword link in Flare.
Lightbox Widgets

Slideshows

Link Tags

Bookmarks

Note Widgets

Div Tags

Plain Text Variables

Variables
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Flare does not support conditioned multiple variable definitions.
Those definitions are imported as multiple variable definitions.
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Doc-To-Help
Feature

Flare
Feature

Related Topics

Related Topics Links

Rich Content
Variables

Snippets

Tabs Widgets

Div Tags

Targets

Targets

Flare does not import any target settings.

Themes

Skins

Flare does not import any theme settings to skins.

TOCs

TOCs

If a TOC is not customized, it is not imported. An auto-generated
TOC is not in the database when you import, so it is not considered customized. However, you can make a simple change in
a TOC (e.g., move a TOC topic up and then down, not actually
changing it). The TOC will then be considered customized and
will import correctly.

Topic Contents
Widgets

Mini-TOC
Proxies

Although topic contents widgets in Doc-To-Help are similar to
Flare's mini-TOC proxies, they are not identical. Therefore, you
may see some discrepancies after the import conversion.
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Importing a Project from Source Control
You can import projects from source control in the following ways:
n

Apache Subversion "Importing from Subversion" on the next page

n

Git "Importing from Git" on page 83

n

Microsoft Team Foundation Server "Importing from Microsoft TFS" on page 86

n

Microsoft Visual Team Services "Importing from Microsoft Visual Studio Team Services" on
page 88

n

Perforce "Importing from Perforce" on page 91
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Importing from Subversion
This section focuses on importing a Flare project from source control. You might use this method,
for example, if you are working on a multi-author project and another member of the team has
placed the Flare project in Apache Subversion.
Following are the steps for importing a project from Subversion.

HOW TO IMPORT A PROJECT FROM SOURCE CONTROL
1. Do one of the following, depending on the part of the user interface you are using:
n

.Ribbon Select File > New Project > Import Project.

n

Source Control Explorer From the View ribbon, open the Source Control Explorer. From
the drop-down, select the Home pane. Click Import Project.

The Import Project from Source Control Wizard dialog opens.
2. From the drop-down, select Subversion.
3. In the Server field, enter the name of the computer or server IP address.
4. Click Next.
5. Next to the Project file field, click Browse. The Browse Source Control Files dialog opens. (You
may need to log in with your user name and password.)
6. Find and click on the Flare project file (FLPRJ) that you want to import. (You may need to log
in with your user name and password.)
7. Click OK.
8. Click Next.
9. In the Project name field, the name of the project being imported is displayed. It is recommended that you leave the name as it is, especially if you are working with other authors on
the project. However, you can enter a different project name if you want.
10. In the Project folder field, either accept the default location for the new project or click
browse for and select a folder.

to

11. Click Finish. The project is imported and loaded into Flare.
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NOTE: If you want to import a project from source control, you can alternatively open the
project file from another location (e.g., a server location), and then use Flare's bind detection functionality to automatically apply available source control bindings to the project.
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Importing from Git
Following are the steps for importing a project from Git.

HOW TO IMPORT A PROJECT FROM SOURCE CONTROL
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select File > New Project > Import Project.

n

Source Control Explorer From the View ribbon, open the Source Control Explorer. From
the drop-down, select the Home pane. Click Import Project.

The Import Project from Source Control Wizard dialog opens.
2. From the drop-down, select Git.
3. In the Remote drop-down, enter the remote repository where the project is located.
NOTE: You may need to obtain this information from your system administrator.
4. In the Name field, enter your name.
5. In the Email field, enter your email address.
6. From the Save Per drop-down, select how you want to save your files.
n

User Saves the files in your local folder. Select this option if you are working with other
tools (e.g., Tortoise) or if you want to use the same user identity across multiple projects.

n

Project Saves the files locally to your project. Select this option if you want to use different identities for each project.

7. Click Next.
8. Next to the Project file field, click Browse. The Browse Source Control Files dialog opens. (You
may need to log in with your user name and password.)
9. (Optional) If the remote you selected in Step 3 requires an SSH certificate, the Certificate Specification dialog opens. In the dialog, do the following:
a. In the Public key field, enter your public SSH key, or use
your network.
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b. In the Private key field, enter your private SSH key, or use
your network.

to browse for the key on

c. If you want Flare to remember your key information so you do not need to enter it again
later, select the check box next to Save certificate information.
NOTE: SSH keys allow you to establish a secure connection between your computer and your Git source control provider (likewise, using an SSH URL is more
secure than an HTTP URL; you need to use SSH keys if you want to use an
SSH URL). If you do not have a public and private SSH key, your can generate
these keys using your Git source control provider (e.g., Gitlab). Follow the directions provided by your source control provider to add these keys to your Git
account. Once you generate these keys, they are typically found in the
C:\Users\[username]\.ssh folder on your computer.
Public keys typically have a .pub extension. Private keys use the same file name
as the public key, but without the file extension.

EXAMPLE
Use the following as guides when setting up your URLs and keys.
SSH URL
git@gitlabomnibus.mycompany.corp:MyUserName/myproject.git

HTTP URL
http://gitlabomnibus.mycompany.corp/MyUserName/myproject.git

SSH Private Key
mycompanySSHkey_id_rsa

SSH Public Key
mycompanySSHkey_id_rsa.pub

10. Find and click on the Flare project file (FLPRJ) that you want to import. (You may need to log
in with your user name and password.)
11. Click OK.
12. Click Next..
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13. In the Project name field, the name of the project being imported is displayed. It is recommended that you leave the name as it is, especially if you are working with other authors on
the project. However, you can enter a different project name if you want.
14. In the Project folder field, either accept the default location for the new project or click
browse for and select a folder.

to

15. Click Finish. The project is imported and loaded into Flare.

NOTE: If you want to import a project from source control, you can alternatively open the
project file from another location (e.g., a server location), and then use Flare's bind detection functionality to automatically apply available source control bindings to the project.I
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Importing from Microsoft TFS
Following are the steps for importing a project from Microsoft Team Foundation Server.

HOW TO IMPORT A PROJECT FROM SOURCE CONTROL
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select File > New Project > Import Project.

n

Source Control Explorer From the View ribbon, open the Source Control Explorer. From
the drop-down, select the Home pane. Click Import Project.

The Import Project from Source Control Wizard dialog opens.
2. From the drop-down, select Microsoft Team Foundation Server.
3. In the Server field, enter the name of the computer or the IP address of the server. You can
also click
to select a "Team Project Collection." If you click this button, the Select Team
Foundation Server Project Collection dialog opens, and you can do the following.
a. To add a server, click

. The Add Team Foundation Server dialog opens.

b. Enter the name or URL of the server.
c. Enter the path and port number.
d. Select the protocol (HTTP or HTTPS).
NOTE: You may need to obtain this information from your system administrator.
Click OK in the dialogs until you return to the main wizard page.

NOTE: If you run into issues in this dialog, chances are your user permissions do not
have access to all of the collections on the TFS server. Please try to enter in the
server/collection path manually.

4. Next to the Team Project field, click
and Password fields.

. If the Log In dialog opens, complete the User name

5. Click on the Team Foundation project.
6. Click Next.
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7. Next to the Project file field, click Browse. The Browse Source Control Files dialog opens.
8. Find and click on the Flare project file (FLPRJ) that you want to import. (You may need to log
in with your user name and password.)
9. Click OK.
10. Click Next.
11. In the Project name field, the name of the project being imported is displayed. It is recommended that you leave the name as it is, especially if you are working with other authors on
the project. However, you can enter a different project name if you want.
12. In the Project folder field, either accept the default location for the new project or click
browse for and select a folder.

to

13. Click Finish. The project is imported and loaded into Flare.

NOTE: If you want to import a project from source control, you can alternatively open the
project file from another location (e.g., a server location), and then use Flare's bind detection functionality to automatically apply available source control bindings to the project.
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Importing from Microsoft Visual Studio Team Services
Following are the steps for importing a project from Microsoft Visual Team Services (VSTS).

HOW TO IMPORT A PROJECT FROM SOURCE CONTROL
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select File > New Project > Import Project.

n

Source Control Explorer From the View ribbon, open the Source Control Explorer. From
the drop-down, select the Home pane. Click Import Project.

The Import Project from Source Control Wizard dialog opens.
2. From the drop-down, select Microsoft Team Foundation Server.
3. In the Server field, enter the URL of the project's "Default Collection."

NOTE: When binding to a VSTS project using TFS, you must manually enter the
URL in the Server field. You can only browse for a server location when binding to a
local project using TFS.

CHAPTER 1

88

NOTE: You may need to obtain this information from your system administrator.
Click OK in the dialogs until you return to the main wizard page.

NOTE: If you run into issues in this dialog, chances are your user permissions do not
have access to all of the collections on the TFS server. Please try to enter in the
server/collection path manually.

. You may need to log in to Microsoft VSTS. If the Log
4. Next to the Team Project field, click
In dialog opens, complete the User name and Password fields.
The Browse Team Foundation Server dialog appears.
NOTE: When you use Visual Studio Team Services with Flare, you will be prompted to
log in to Visual Studio Team Services via a dialog in Flare. Your login credentials are
stored in a cookie in the Internet Explorer Temporary Internet Files folder:
C:\Users\[username]\AppData\Local\Microsoft\Windows\INetCache
When this cookie expires, you will logged out of Visual Studio Team Services, and
Flare will prompt you to log in again.
5. Click on the Team Foundation project.
6. Click OK.
7. Click Next.
8. Next to the Project file field, click Browse. The Browse Source Control Files dialog opens.
9. Find and click on the Flare project file (FLPRJ) that you want to import. (You may need to log
in with your user name and password.)
10. Click OK.
11. Click Next.
12. In the Project name field, the name of the project being imported is displayed. It is recommended that you leave the name as it is, especially if you are working with other authors on
the project. However, you can enter a different project name if you want.
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13. In the Project folder field, either accept the default location for the new project or click
browse for and select a folder.

to

14. Click Finish. The project is imported and loaded into Flare.
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Importing from Perforce
Following are the steps for importing a project from Perforce.

HOW TO IMPORT A PROJECT FROM SOURCE CONTROL
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select File > New Project > Import Project.

n

Source Control Explorer From the View ribbon, open the Source Control Explorer. From
the drop-down, select the Home pane. Click Import Project.

The Import Project from Source Control Wizard dialog opens.
2. From the drop-down, select Perforce.
3. In the Server field, enter the server address.
4. Next to the User field, click

. The Select User dialog opens.

5. Select a user and click OK. (Users are set up separately in Perforce.)
6. Next to the Location field, click Browse. The Browse Depots and Streams dialog opens.
7. Select a depot or stream (i.e., the name of your Flare project).
8. Click OK.
9. Click Next.
10. Next to the Project file field, click Browse. The Browse Source Control Files dialog opens. (You
may need to log in with your user name and password.)
11. Find and click on the Flare project file (FLPRJ) that you want to import. (You may need to log
in with your user name and password.)
12. Click OK.
13. Click Next.
14. In the Project name field, the name of the project being imported is displayed. It is recommended that you leave the name as it is, especially if you are working with other authors on
the project. However, you can enter a different project name if you want.
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15. In the Project folder field, either accept the default location for the new project or click
browse for and select a folder.

to

16. Click Finish. The project is imported and loaded into Flare.

NOTE: If you want to import a project from source control, you can alternatively open the
project file from another location (e.g., a server location), and then use Flare's bind detection functionality to automatically apply available source control bindings to the project.
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Converting Author-it Files
MadCap Software has created an Author-it ® Converter, which lets you create a new Flare project
based on Author-it Files. This utility uses the published XML output from Author-it and converts it to
a Flare project, while maintaining all project and source files.

SYSTEM REQUIREMENTS
n

MadCap Flare 10 or newer

n

Microsoft .Net 4.5.1 (installed with the software if needed)

n

Microsoft Visual C++ Redistributables (installed with the software if needed)

n

Minimum 2048 MB memory (RAM)

n

Minimum 150 MB available hard drive space (additional space depending on size of XML files
to be converted)

n

Microsoft Windows 7 or newer, 32- or 64-bit, including all required updates

HOW TO DOWNLOAD AND INSTALL THE AUTHOR-IT CONVERTER
1. Click the following to download and save the installation file locally:
Download Author-it Converter Utility
2. Unzip the archive:
a. Right-click AuthorItConverterSetup.exe and choose Properties.
b. Verify the EXE file is not being blocked (located on the General tab). This often happens
with network and Windows security.
n

If the option to unblock the EXE is available, check the option and click OK.

n

If no option to unblock exists, the above steps are not needed.

3. Run AuthorItConverterSetup.exe with elevated privileges (Run as Administrator).
4. Follow the prompts to install the utility.
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HOW TO USE THE AUTHOR-IT CONVERTER
1. From the MadCap Software program group, launch Author-it to Flare Converter.
2. Select the location and the Author-it XML file by clicking the browse button […].
3. Select a location where the Flare project should be saved by clicking the browse button […].
4. Select Content Path Options and choose one of the following:
n

Author-it Keeps the existing folder structure outlined in the XML

n

Flat Puts all topics at the root level under the Content folder

n

Condensed Removes all empty folders from the XML structure; maintains only folders
with topics in the Content Explorer

5. Click Convert. The utility begins. A log report will be sent to the Flare project folder for
troubleshooting purposes.
6. When the conversion process is complete, click Yes to open the folder.
7. Double-click the project.flprj file to open the project in Flare.

HOW ELEMENTS ARE CONVERTED FROM AUTHOR-IT TO FLARE
Certain elements from Author-it converted to their closest counterparts in Flare. The following table
describes this.
Author-it Element

Flare Element

Notes

Context IDs

Context IDs

Context IDs and values are converted to alias and header files.

Embedded topics

Converted to snippets

These are placed in Resources
folder in Flare.

Glossaries

Glossaries

Images

Images

Index keywords

Index keywords

Styles

Styles
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These are placed in Resources
folder in Flare.

Stylesheets are placed in
Resources folder in Flare.
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Author-it Element

Flare Element

Table of contents of Author-it
books

Converted to topics

Variables

Variables

Notes

Variables and all permutations
are converted.
Variables embedded in variables are not supported in Flare
at this time. In this case, each
definition is added as a permutation of the variable.

NOTE: The XML files from Author-it are from the Publish option in the Author-it software.

NOTE: Topics without headings will be named "Topic####.htm" where the # is the Object
ID of the topic in the XML.
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CHAPTER 2

Merging Projects
Supported In:

In Flare you can merge projects in many ways.
This chapter discusses the following:
Linking to CHM Files

97

Runtime Merging Flare Projects Using Targets

98

Runtime Merging Output from Flare WebHelp Projects

102

Runtime Merging Output from HTML Help Projects (CHM Files)

109

Runtime Merging Server-based HTML5 Output

113

Runtime Merging Output Using WebHelp Plus

122

Displaying Merged Navigation in HTML Help Child Outputs

130

NOTE: Flare's HTML5 Side and Top Navigation skins do not support runtime project merging.
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Linking to CHM Files
You can include a CHM file in the TOC in your project so that it can be opened in your output.
If you do this when generating Microsoft HTML Help, the linked CHM will be merged with the TOC in
the project.
If you do this when generating one of the web-based outputs (HTML5, WebHelp, WebHelp Plus), the
user will be able to download the CHM.
Regardless of the type of online output you are generating, you can find the steps for linking to a
CHM file in the following topic: "Runtime Merging Output from HTML Help Projects (CHM Files)" on
page 109.

NOTE: Links to CHM files can be configured in two ways. First, links can point to the CHM
file in general. Second, they can point to a specific topic within the CHM. The first method is
supported in all of the online outputs mentioned above. The second method is supported
only in Microsoft HTML Help output.
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Runtime Merging Flare Projects Using
Targets
Use this merging method if you have access to all of the Flare project files to be merged. You can
merge projects together by linking targets with the same output type (e.g., linking Microsoft HTML
Help to Microsoft HTML Help, linking WebHelp to WebHelp).

HOW TO MERGE MULTIPLE FLARE PROJECTS AT RUNTIME
1. Open the TOC in the Flare project that will serve as the master project.
NOTE: You can also merge projects by linking them from a browse sequence, as well
as from a TOC. If you want to do this, simply follow these same steps after opening
your browse sequence.
2. In the TOC Editor, select the TOC entry or book where you want to link the output from
another Flare project. (The TOC of the linked project will be inserted at that spot in the "master" TOC.)
3. In the local toolbar of the TOC Editor, click

. The Properties dialog opens.

4. Select the General tab.
5. Click Select Flare Project and Target. The Link to Flare Project and Target dialog opens.
6. Do one of the following:
n

Click Browse for Project. Then click Project File and find/select a Flare project to which
you want to link.
OR

n

Click Select Recent Project. Then select a recently opened Flare project from the list on
the right.

7. From the Select Target field, choose a specific target in the Flare project. Make sure you
select a target that uses the same output type (e.g., Microsoft HTML Help or WebHelp) as the
target that you will build in the current project.
8. Click OK.
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9. (Optional) If you want the merged TOC to replace the entry that you selected, do the following.
a. Select the Advanced tab.
b. Click the check box labeled When merging, replace node with merged TOC.
For example, you might have a TOC in your parent project that looks like this:

If you select the option in this step to replace the node, the merged TOC would look like this in
the output:
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And if you do not select this option, your merged TOC would look like this:

10. In the Properties dialog, click OK.
11. Build the output for the target in your master project. The output files for the projects are
merged. When you open the TOC in the output, you will see the integrated TOC from the
linked project.

NOTE: There are occasions when projects cannot be merged because the file name is the
same in two or more of the linked projects (e.g., multiple WebHelp projects all named
"MyWebProject.mcwebhelp" or multiple Microsoft HTML Help projects all named "MyHtmlHelp.chm"). The way to solve this dilemma is to make sure each linked project has a different output file name. To do this: (1) open the target, (2) select the General tab in the
Target Editor, and (3) enter a unique name in the Output File field.

NOTE: If you are working with HTML Help and import a RoboHelp project that has been
merged with other CHM files, the linked CHM files are placed in a special subfolder in the
Content Explorer (Resources > CHMSupport).
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NOTE: If you have previously merged Flare projects with WebHelp outputs and then decide
to generate WebHelp Plus output from the master project instead, you must make sure that
the child projects linked to the master contain at least one WebHelp Plus target each. Even
if you keep the link from the master project to a WebHelp target in the child, the child project must also have a WebHelp Plus target.

NOTE: If you merge projects, synonym files will remain separate in each project. For
example, if you create synonyms in Project A but not in project B, only the topics from Project A will use the synonyms when users perform searches in the output.

NOTE: You can merge HTML Help so that the navigation (table of contents, index, search)
for each CHM file is displayed, regardless of which CHM file you open (parent or child). This
can be done in a couple of ways, depending on whether you have access to all of the Flare
projects or to the CHM files only.

NOTE: Flare's HTML5 Side and Top Navigation skins do not support runtime project merging.
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Runtime Merging Output from Flare
WebHelp Projects
Supported In:

Use this merging method if you are developing HTML5, WebHelp, or WebHelp Plus and you want to
merge the output files from your parent project with the web output files from an external Flare project. This method is useful, for example, if another author is working on the external web project to
which you are linking and you only have access to the output files (not the project files).
Before your master project can be merged with an external Help system, the output folders and files
for the external (or "child") project need to be copied to a folder called "Subsystems" in the same location where the master project is being published. The child's target folder containing these output
files also needs to be included at this location.

EXAMPLE
For example, if the master project's output files are being published to C:\MyHelpSystem\Master\Master.mcwebhelp, the output folders and files for the child project
should be copied to the folder C:\MyHelpSystem\Master\webSubsystems (e.g.,
C:\MyHelpSystem\Master\Subsystems\AnotherHelpSystem\AnotherHelpSystem.mcwebhelp). In
this example, "AnotherHelpSystem" is the target folder that you generated, which holds
the output folders and files, and "AnotherHelpSystem.mcwebhelp" is the main output
file for the child project that was created. Not only does the main .mcwebhelp output
file need to be included in this folder, but also the ancillary output folders and files (e.g.,
Content, Data, Skin).
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You can merge WebHelp outputs using an automatic or manual method.

HOW TO MERGE OUTPUT FROM WEB PROJECTS (AUTOMATIC METHOD)
1. Generate the output for the child project.
2. Open the TOC in the Flare project that will serve as the parent project.
NOTE: You can also merge projects by linking them from a browse sequence, as well
as from a TOC. If you want to do this, simply follow these same steps after opening
your browse sequence.
3. In the TOC Editor, select the TOC entry or book where you want to link the output from the
child WebHelp project. (The TOC of the linked project will be inserted at that spot in the parent
TOC.)
4. In the local toolbar of the TOC Editor, click

. The Properties dialog opens.

5. Click Enter External Help System. The Link to Help System dialog opens.
6. Click Browse.
7. In the Files of type field, click the down arrow and select MadCap Web Help Files (*.mcwebhelp). Then find and select the MCWEBHELP output file to which you want to link.
8. Click OK.
The full path to the file is displayed in the field.
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9. (Optional) If you want the merged TOC to replace the entry that you selected, do the following:
a. Select the Advanced tab.
b. Click the check box labeled When merging, replace node with merged TOC.
For example, you might have a TOC in your master project that looks like this:

If you select the option in this step to replace the node, the merged TOC would look like this in
the output:
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And if you do not select this option, your merged TOC would look like this:

10. In the Properties dialog, click OK.
11. Build the output for the WebHelp target in your "master" project.
Flare automatically creates the Subsystems folder for you. It also copies the target folder and
.mcwebhelp file (along with the ancillary output files and folders) to the appropriate
destination. When you open the TOC in the output, you will see the integrated TOC from the
linked project.
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HOW TO MERGE OUTPUT FROM WEB PROJECTS (MANUAL METHOD)
1. Generate the output for the child project.
2. Open the TOC in the Flare project that will serve as the parent project.
3. In the TOC Editor, select the TOC entry or book where you want to link the output from the
child WebHelp project. (The TOC of the linked project will be inserted at that spot in the parent
TOC.)
4. In the local toolbar of the TOC Editor, click

. The Properties dialog opens.

5. Click Enter External Help System. The Link to Help System dialog opens.
6. Type the name of the child target and main output file (e.g., AnotherHelpSystem/AnotherHelpSystem.mcwebhelp).
7. Click OK.
8. (Optional) If you want the merged TOC to replace the entry that you selected, do the following:
a. Select the Advanced tab.
b. Click the check box labeled When merging, replace node with merged TOC.
For example, you might have a TOC in your master project that looks like this:
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If you select the option in this step to replace the node, the merged TOC would look like this in
the output:

And if you do not select this option, your merged TOC would look like this:

9. In the Properties dialog, click OK.
10. Build the output for the WebHelp target in your "master" project.
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11. In the master Flare project, right-click on the target and select Open Output Folder. Within
that folder, manually create another folder and name it Subsystems.
12. In the child Flare project, select Project > Open Output Folder (if using the ribbon view) or Build
> Open Output Folder (if using the menu view).
13. Copy the target folder to be merged with the master project.
14. Paste the target folder within the Subsystems folder that you created in the master output
folder.

NOTE: There are occasions when projects cannot be merged because the file name is the
same in two or more of the linked projects (e.g., multiple WebHelp projects all named
"MyWebProject.mcwebhelp" or multiple Microsoft HTML Help projects all named "MyHtmlHelp.chm"). The way to solve this dilemma is to make sure each linked project has a different output file name. To do this: (1) open the target, (2) select the General tab in the
Target Editor, and (3) enter a unique name in the Output File field.

NOTE: If you plan to use Mark of the Web (MOTW) and are merging output from multiple
Flare WebHelp projects, make sure you enable MOTW in all of the subprojects to be
included in the merge. Otherwise, the output will not load smoothly into the browser window
for the user. For more information about MOTW, see Microsoft's MSDN website.

NOTE: If you have previously merged Flare projects with WebHelp outputs and then decide
to generate WebHelp Plus output from the master project instead, you must make sure that
the child projects linked to the master contain at least one WebHelp Plus target each. Even
if you keep the link from the master project to a WebHelp target in the child, the child project must also have a WebHelp Plus target.

NOTE: If you merge projects, synonym files will remain separate in each project. For
example, if you create synonyms in Project A but not in project B, only the topics from Project A will use the synonyms when users perform searches in the output.
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Runtime Merging Output from HTML Help
Projects (CHM Files)
Use this merging method if you are developing Microsoft HTML Help (a CHM file) and you want to
merge your output with another CHM file. This method is useful, for example, if another author is
working on the external Microsoft HTML Help project to which you are linking and you only have
access to the other CHM file (not the project files).
You can merge your output with another CHM file that you have already brought into your project
(perhaps via the external resources feature), or you can select a CHM file located elsewhere, in
which case a copy of it is added to your project.

HOW TO MERGE OUTPUT FROM HTML PROJECTS
1. Open the TOC in the Flare project that will serve as the parent project.
NOTE: You can also merge projects by linking them from a browse sequence, as well
as from a TOC. If you want to do this, simply follow these same steps after opening
your browse sequence.
2. Do one of the following:
n

In the TOC Editor, select the TOC entry or book where you want to link the output from
the child HTML Help project. (The TOC of the linked CHM file will be inserted at that spot
in the parent TOC.)
OR

n

If the CHM file already exists somewhere in your project, you can open the Content
Explorer and drag the CHM file to the location in the "master" TOC where you want to
place it. If you use this method, the link will not point to any particular topic in the CHM
file. Also, if you use this method, you do not need to complete the rest of the steps below.

3. In the local toolbar of the TOC Editor, click

. The Properties dialog opens.

4. On the General tab, click Select HTML Help. The Link to HTML Help dialog opens.
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5. Do one of the following:
n

If the child CHM file is already in your project Select Project Files and then use the area
below to navigate to the file that you want to link to and select it. By using the buttons in
the local toolbar, you can view all files in a list, view files in their folder structure, and use
other options.
Shows or hides the folders that the files are stored in.
Shows or hides the files. If you click this button when the Show Folders button
is selected, the area splits into two. The folder is shown on the left side, and
the files and subfolders within it are shown on the right.

n

If the child CHM file is not yet in your project Select Import Existing. In the dialog that
opens, find and double-click the child CHM file. Then from the drop-down—which displays
"(root folder)" by default, you can select a specific content folder in your project to place
the child CHM file.

6. (Optional) If you want to point to a specific topic in the child CHM file, in the Topic field click
. In the dialog that opens, find and double-click the topic that you want to link to.
If you use this option, only the specified topic will be included in the TOC, as opposed to the
entire TOC of the child CHM. However, even though just one topic will be included in the
merged TOC, the other topics in it will still be included in the output and you can get to them
through other means (e.g., clicking hyperlinks).
7. Click OK in the Link to HTML Help dialog.
8. If you imported a child CHM file, the Copy to Project dialog opens. You can select Keep file
synchronized (create mapping). This creates a link (map) between the original file and the
copy being added to your project. Then click OK in the Copy to Project dialog.
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9. (Optional) If you want the merged TOC to replace the entry that you selected, do the following.
a. Select the Advanced tab.
b. Click the check box labeled When merging, replace node with merged TOC.
For example, you might have a TOC in your parent project that looks like this:

If you select the option in this step to replace the node, the merged TOC would look like this in
the output:

And if you do not select this option, your merged TOC would look like this:
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10. In the Properties dialog, click OK.

NOTE: There are occasions when projects cannot be merged because the file name is the
same in two or more of the linked projects (e.g., multiple WebHelp projects all named
"MyWebProject.mcwebhelp" or multiple Microsoft HTML Help projects all named "MyHtmlHelp.chm"). The way to solve this dilemma is to make sure each linked project has a different output file name. To do this: (1) open the target, (2) select the General tab in the
Target Editor, and (3) enter a unique name in the Output File field.

NOTE: If you are working with HTML Help and import a RoboHelp project that has been
merged with other CHM files, the linked CHM files are placed in a special subfolder in the
Content Explorer (Resources > CHMSupport).

NOTE: You can also link to CHM files from the TOC in all web-based outputs (HTML5,
WebHelp, WebHelp Plus). However, linking to a specific topic within the CHM is not supported in these outputs.

NOTE: You can merge HTML Help so that the navigation (table of contents, index, search)
for each CHM file is displayed, regardless of which CHM file you open (parent or child). This
can be done in a couple of ways, depending on whether you have access to all of the Flare
projects or to the CHM files only.
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Runtime Merging Server-based HTML5
Output
This is an easy way to merge the output from multiple HTML5 server-based Flare targets into one
Help system. These targets can be originated from the same Flare project or from different Flare
projects. You simply place the output files in the correct location on the server (i.e., within your master project's AutoMerge folder). Flare then automatically merges the output from all of the targets
when users access the Help. From the end user's perspective, the results are seamless, appearing
as one large Help system. All of the TOCs, browse sequences, indexes, glossaries, and search capabilities for the projects are merged.
The following information is necessary only for server-based output. If you do not require serverbased HTML5 output, see "Runtime Merging Flare Projects Using Targets" on page 98 instead.

HOW TO MERGE SERVER-BASED HTML5 OUTPUT AT RUNTIME
1. Enable HTML5 Server-based Output If you want to take advantage of the advanced serverside features of HTML5 (i.e., automatic runtime project merging, server-side search, searching of non-XHTML files), you must enable HTML5 server-based output. This includes performing the following tasks: (1) installing Microsoft Internet Information Services (IIS) and
ASP.NET, (2) setting up the HTML5 target and generating/publishing, (3) configuring IIS on
the production server, (4) starting Microsoft Indexing Service or Microsoft Windows Search
(depending on the operating system), and (5) enabling HTML5 search. For more information
see the online Help.
2. Determine Master Output Decide which of your project outputs will serve as the "master."
This is the main output that users will open. All other outputs will be accessed from that output, although it will appear as one large Help system to end users.
3. (Optional) Specify TOC and/or Browse Sequence Locations for AutomergeBy default, the
TOCs and browse sequences from the secondary outputs will be appended at the end of the
master output's TOC and browse sequence. However, if you want them to be appended somewhere within the master output's TOC or browse sequence, you can specify the exact location. See "Specifying the Automerge Location in a TOC for HTML5" on page 118 and
"Specifying the Automerge Location in a Browse Sequence for HTML5" on page 116.
4. (Optional) Specify Order of Merged Outputs When you automerge HTML5 outputs, the secondary outputs are merged to the master project's table of contents (TOC) and/or browse
sequence in alphabetical order. However, you can override this default configuration and
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merge the secondary outputs in any order that you like. See "Specifying the Order of
Automerged HTML5 Outputs" on page 120.
5. Generate Outputs Build the output for each of the targets to be included in the automerge.
You must use HTML5 for all of the targets.
6. Publish Output to Server Publish the output for the master project to the web server running
Microsoft IIS. The output files for the secondary targets need to be published to the
"AutoMerge" subfolder located in the master target's main output folder (e.g.,
http://www.xyzincorporated.com/help systems/MyTargetName/AutoMerge).
When readers open the online output, they will see all of the HTML5 outputs merged into one
Help system. They can easily navigate and use the index and search across all of the output
files.

NOTE: If you are testing HTML5 server-based output on your local machine, you need view
the output at least one time. When you view HTML5 output on your local computer, you
need to create a special folder called "MCPreview" within your "C:\Inetpub\wwwroot" folder.
Place a copy of your HTML5 output files in it. This enables you to test the advanced features of HTML5 on your local machine. When testing the automerge feature on your computer, you need to place the secondary ("child") outputs in the AutoMerge subfolder at this
location (as opposed to the output folder that was generated where your Flare project is located).

NOTE: If you are testing HTML5 server-based output on your local machine, you may need
to wait a few minutes after viewing the output for the Indexing Service to fully scan your
files. Otherwise, you may not immediately see the effects of the scan (e.g., searches of
non-XHTML files, incorporation of merged output files) in the output. If you avoid performing other tasks during this period, the scanning of the files will be completed more
quickly.

NOTE: If you want to test HTML5 server-based output on your local computer, the
advanced search features of HTML5 are not operable.
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NOTE: Flare's HTML5 Side and Top Navigation skins do not support runtime project merging.
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Specifying the Automerge Location in a Browse Sequence
for HTML5
You can determine where other Flare project outputs are merged relative to your "master" project's
browse sequence if you are generating HTML5 server-based output and you are publishing the files
to a web server running Microsoft IIS.
By default, the other HTML5 server-based outputs will be merged at the end of your master project's browse sequence. However, you can use the following steps to select one of the available
options to override this placement.

HOW TO SPECIFY THE AUTOMERGE LOCATION IN A BROWSE SEQUENCE
1. Open the browse sequence in the Flare project that will serve as the "master" project.
2. Do one of the following:
n

If you want to merge the other outputs in relation to one of the existing entries in the
browse sequence (e.g., before it, after it), select that entry (whether it is an individual
item or a book).
OR

n

If you want to merge the other outputs at the location of an entry that is not linked to any
other file, and you want to provide a label to indicate the location of the merge, create a
new browse sequence item. To do this:
a. Place your cursor in the browse sequence where you want to add the new item.
b. Click

.

c. Press F2.
d. Replace the default text with new text.
e. Press Enter.
f. If necessary, use the arrow buttons in the local toolbar to position the new entry in
the browse sequence.
3. In the local toolbar of the Browse Sequence Editor, click

. The Properties dialog opens.

4. Select the Advanced tab.

CHAPTER 2

116

5. In the Server-based Automerge field, select one of the following:
n

Before The automerge will occur immediately before the selected browse sequence
entry.

n

After The automerge will occur immediately after the selected browse sequence entry.

n

First Child The automerge will occur at the first location directly after the selected
browse sequence book (i.e., before any other entries within the book). If you use this
option on a simple browse sequence entry instead of a book, the entry will automatically
become a book once the outputs are automerged.

n

Last Child The automerge will occur at the last location after the selected browse
sequence book (after the last entry within the book). If you use this option on a simple
browse sequence entry instead of a book, the entry will automatically become a book
once the outputs are automerged.

n

Replace The automerge will occur at the location of the browse sequence entry where
you have specified this option. It would replace any links that might otherwise be applied
to that entry. You might use this option, for example, if you want to create a new entry in
the master browse sequence so that you can add a label at the point where the
automerge occurs.

6. In the Properties dialog, click OK.
7. Click
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Specifying the Automerge Location in a TOC for HTML5
You can determine where other Flare project outputs are merged relative to your "master" project's
TOC if you are generating HTML5 server-based output and you are publishing the files to a web
server running Microsoft IIS.
By default, the other HTML5 server-based outputs will be merged at the end of your master project's TOC. However, you can use the following steps to select one of the available options to override this placement.

HOW TO SPECIFY THE AUTOMERGE LOCATION IN A TOC
1. Open the TOC in the Flare project that will serve as the parent project.
2. Do one of the following:
n

If you want to merge the other outputs in relation to one of the existing entries in the TOC
(e.g., before it, after it), select that entry (whether it is an individual item or a book).
OR

n

If you want to merge the other outputs at the location of an entry that is not linked to any
other file, and you want to provide a label to indicate the location of the merge, create a
new TOC item. To do this:
a. Place your cursor in the TOC where you want to add the new item.
b. Click

.

c. Press F2.
d. Replace the default text with new text.
e. Press Enter.
f. If necessary, use the arrow buttons in the local toolbar to position the new entry in
the TOC.
3. In the local toolbar of the TOC Editor, click

. The Properties dialog opens.

4. Select the Advanced tab.
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5. In the Server-based Automerge field, select one of the following:
n

Before The automerge will occur immediately before the selected TOC entry.

n

After The automerge will occur immediately after the selected TOC entry.

n

First Child The automerge will occur at the first location directly after the selected TOC
book (i.e., before any other entries within the book). If you use this option on a simple
TOC entry instead of a book, the entry will automatically become a book once the outputs
are automerged.

n

Last Child The automerge will occur at the last location after the selected TOC book
(after the last entry within the book). If you use this option on a simple TOC entry instead
of a book, the entry will automatically become a book once the outputs are automerged.

n

Replace The automerge will occur at the location of the TOC entry where you have specified this option. It would replace any links that might otherwise be applied to that entry.
You might use this option, for example, if you want to create a new entry in the master
TOC so that you can add a label at the point where the automerge occurs.

6. In the Properties dialog, click OK.
7. Click
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Specifying the Order of Automerged HTML5 Outputs
When you automerge HTML5 outputs, the secondary outputs are merged to the master project's
table of contents (TOC) and/or browse sequence in alphabetical order. However, you can override
this default configuration and merge the secondary outputs in any order that you like. See "Runtime
Merging Server-based HTML5 Output" on page 113.

EXAMPLE
Let’s say you have a master project with a target named "Main" and three smaller projects with targets named "First Child," "Second Child," and "Third Child," respectively. If
you place the three smaller project outputs in the AutoMerge subfolder where "Main" is
published, their TOCs will be appended to the master project's TOC in the following
order:
1. First Child
2. Second Child
3. Third Child
But what if you want "Third Child" to be appended first? You can use the steps in this
topic to position it above the other targets. Therefore, the result would be:
1. Third Child
2. First Child
3. Second Child
Now let's say that you add two more targets (called "Final Child" and "Another Child") to
the AutoMerge folder. If you do not adjust your custom order, Flare will automerge
these outputs in alphabetical order at the end of your custom order. Therefore, the
final result would be:
1. Third Child
2. First Child
3. Second Child
4. Another Child
5. Final Child
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HOW TO SPECIFY THE ORDER OF AUTOMERGED OUTPUTS
1. Create an XML file and name it SortOrder.xml. You can do this by opening an editor such as
Notepad. When you save the file, type the xml file extension at the end of the name.
2. Enter the following code into the blank file.
<?xml version="1.0" encoding="utf-8"?>
<SortOrder>
<Item>ProjectA</Item>
<Item>ProjectB</Item>
<Item>ProjectC</Item>
</SortOrder>
3. Replace "ProjectA," "ProjectB," and "ProjectC" with the names of your own child targets. You
can add or remove line items as necessary.
If you were to use the example at the top of this topic, you would enter the following.
<?xml version="1.0" encoding="utf-8"?>
<SortOrder>
<Item>Third Child</Item>
<Item>First Child</Item>
<Item>Second Child</Item>
</SortOrder>
4. Save the file.
5. Copy and paste the SortOrder.xml file into the AutoMerge directory of your published HTML5
output. This file sits beside the child output folders that you are using for the automerge.
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Runtime Merging Output Using WebHelp
Plus
This is an easy way to merge the output from multiple WebHelp Plus Flare targets into one Help system. These targets can be originated from the same Flare project or from different Flare projects.
You simply place the output files in the correct location on the server (i.e., within your master project's AutoMerge folder). Flare then automatically merges the output from all of the targets when
users access the Help. From the end user's perspective, the results are seamless, appearing as one
large Help system. All of the TOCs, browse sequences, indexes, glossaries, and search capabilities
for the projects are merged.

HOW TO MERGE OUTPUT AT RUNTIME USING WEBHELP PLUS
1. Enable WebHelp Plus Output If you want to take advantage of the advanced server-side features of WebHelp Plus (i.e., automatic runtime project merging, faster search, server-side
search, searching of non-XHTML files), you must enable WebHelp Plus output. This includes
performing the following tasks: (1) installing Microsoft Internet Information Services (IIS) and
ASP.NET, (2) setting up the WebHelp Plus target and generating/publishing, (3) configuring IIS
on the production server, (4) starting Microsoft Indexing Service or Microsoft Windows
Search (depending on the operating system), and (5) enabling WebHelp Plus search. For more
information see the online Help.
2. Determine Master Output Decide which of your project outputs will serve as the "master."
This is the main output that users will open. All other outputs will be accessed from that output, although it will appear as one large Help system to end users.
3. (Optional) Specify TOC and/or Browse Sequence Locations for AutomergeBy default, the
TOCs and browse sequences from the secondary outputs will be appended at the end of the
master output's TOC and browse sequence. However, if you want them to be appended somewhere within the master output's TOC or browse sequence, you can specify the exact location. See "Specifying the Automerge Location in a TOC for WebHelp Plus" on page 126 and
"Specifying the Automerge Location in a Browse Sequence for WebHelp Plus" on page 124.
4. (Optional) Specify Order of Merged Outputs When you automerge WebHelp Plus outputs, the
secondary outputs are merged to the master project's table of contents (TOC) and/or browse
sequence in alphabetical order. However, you can override this default configuration and
merge the secondary outputs in any order that you like. See "Specifying the Order of
Automerged WebHelp Plus Outputs" on page 128.
5. Generate Outputs Build the output for each of the targets to be included in the automerge.
You must use WebHelp Plus for all of the targets.
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6. Publish Output to Server Publish the output for the master project to the web server running
Microsoft IIS. The output files for the secondary targets need to be published to the
"AutoMerge" subfolder located in the master target's main output folder (e.g.,
http://www.xyzincorporated.com/help systems/MyTargetName/AutoMerge).
When readers open the online output, they will see all of the WebHelp Plus outputs merged
into one Help system. They can easily navigate and use the index and search across all of the
output files.

NOTE: If you are testing WebHelp Plus output on your local machine, you need view the output at least one time. When you view WebHelp Plus output on your local computer, Flare creates a special folder called "MCPreview" within your "C:\Inetpub\wwwroot" folder, and it
places a copy of your WebHelp Plus output files in it. This enables you to test the advanced
features of WebHelp Plus on your local machine. When testing the automerge feature on
your computer, you need to place the secondary ("child") outputs in the AutoMerge subfolder at this location (as opposed to the output folder that was generated where your Flare
project is located).

NOTE: If you are testing WebHelp Plus output on your local machine, you may need to wait
a few minutes after viewing the output for the Indexing Service to fully scan your files.
Otherwise, you may not immediately see the effects of the scan (e.g., searches of nonXHTML files, incorporation of merged output files) in the output. If you avoid performing
other tasks during this period, the scanning of the files will be completed more quickly.

NOTE: If you want to test WebHelp Plus on your local computer, the advanced search features of WebHelp Plus are not operable.
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Specifying the Automerge Location in a Browse Sequence
for WebHelp Plus
You can determine where other Flare project outputs are merged relative to your "master" project's
browse sequence if you are generating WebHelp Plus output and you are publishing the files to a
web server running Microsoft IIS.
By default, the other WebHelp Plus outputs will be merged at the end of your master project's
browse sequence. However, you can use the following steps to select one of the available options to
override this placement.

HOW TO SPECIFY THE AUTOMERGE LOCATION IN A BROWSE SEQUENCE
1. Open the browse sequence in the Flare project that will serve as the "master" project.
2. Do one of the following:
n

If you want to merge the other outputs in relation to one of the existing entries in the
browse sequence (e.g., before it, after it), select that entry (whether it is an individual
item or a book).
OR

n

If you want to merge the other outputs at the location of an entry that is not linked to any
other file, and you want to provide a label to indicate the location of the merge, create a
new browse sequence item. To do this:
a. Place your cursor in the browse sequence where you want to add the new item.
b. Click

.

c. Press F2.
d. Replace the default text with new text.
e. Press Enter.
f. If necessary, use the arrow buttons in the local toolbar to position the new entry in
the browse sequence.
3. In the local toolbar of the Browse Sequence Editor, click

. The Properties dialog opens.

4. Select the Advanced tab.
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5. In the Server-based Automerge field, select one of the following:
n

Before The automerge will occur immediately before the selected browse sequence
entry.

n

After The automerge will occur immediately after the selected browse sequence entry.

n

First Child The automerge will occur at the first location directly after the selected
browse sequence book (i.e., before any other entries within the book). If you use this
option on a simple browse sequence entry instead of a book, the entry will automatically
become a book once the outputs are automerged.

n

Last Child The automerge will occur at the last location after the selected browse
sequence book (after the last entry within the book). If you use this option on a simple
browse sequence entry instead of a book, the entry will automatically become a book
once the outputs are automerged.

n

Replace The automerge will occur at the location of the browse sequence entry where
you have specified this option. It would replace any links that might otherwise be applied
to that entry. You might use this option, for example, if you want to create a new entry in
the master browse sequence so that you can add a label at the point where the
automerge occurs.

6. In the Properties dialog, click OK.
7. Click
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Specifying the Automerge Location in a TOC for WebHelp
Plus
You can determine where other Flare project outputs are merged relative to your "master" project's
TOC if you are generating WebHelp Plus output and you are publishing the files to a web server running Microsoft IIS.
By default, the other WebHelp Plus outputs will be merged at the end of your master project's TOC.
However, you can use the following steps to select one of the available options to override this placement.

HOW TO SPECIFY THE AUTOMERGE LOCATION IN A TOC
1. Open the TOC in the Flare project that will serve as the parent project.
2. Do one of the following:
n

If you want to merge the other outputs in relation to one of the existing entries in the TOC
(e.g., before it, after it), select that entry (whether it is an individual item or a book).
OR

n

If you want to merge the other outputs at the location of an entry that is not linked to any
other file, and you want to provide a label to indicate the location of the merge, create a
new TOC item. To do this:
a. Place your cursor in the TOC where you want to add the new item.
b. Click

.

c. Press F2.
d. Replace the default text with new text.
e. Press Enter.
f. If necessary, use the arrow buttons in the local toolbar to position the new entry in
the TOC.
3. In the local toolbar of the TOC Editor, click

. The Properties dialog opens.

4. Select the Advanced tab.
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5. In the Server-based Automerge field, select one of the following:
n

Before The automerge will occur immediately before the selected TOC entry.

n

After The automerge will occur immediately after the selected TOC entry.

n

First Child The automerge will occur at the first location directly after the selected TOC
book (i.e., before any other entries within the book). If you use this option on a simple
TOC entry instead of a book, the entry will automatically become a book once the outputs
are automerged.

n

Last Child The automerge will occur at the last location after the selected TOC book
(after the last entry within the book). If you use this option on a simple TOC entry instead
of a book, the entry will automatically become a book once the outputs are automerged.

n

Replace The automerge will occur at the location of the TOC entry where you have specified this option. It would replace any links that might otherwise be applied to that entry.
You might use this option, for example, if you want to create a new entry in the master
TOC so that you can add a label at the point where the automerge occurs.

6. In the Properties dialog, click OK.
7. Click
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Specifying the Order of Automerged WebHelp Plus Outputs
When you automerge WebHelp Plus outputs, the secondary outputs are merged to the master project's table of contents (TOC) and/or browse sequence in alphabetical order. However, you can override this default configuration and merge the secondary outputs in any order that you like. See
"Runtime Merging Output Using WebHelp Plus" on page 122.

EXAMPLE
Let’s say you have a master project with a target named "Main" and three smaller projects with targets named "First Child," "Second Child," and "Third Child," respectively. If
you place the three smaller project outputs in the AutoMerge subfolder where "Main" is
published, their TOCs will be appended to the master project's TOC in the following
order:
1. First Child
2. Second Child
3. Third Child
But what if you want "Third Child" to be appended first? You can use the steps in this
topic to position it above the other targets. Therefore, the result would be:
1. Third Child
2. First Child
3. Second Child
Now let's say that you add two more targets (called "Final Child" and "Another Child") to
the AutoMerge folder. If you do not adjust your custom order, Flare will automerge
these outputs in alphabetical order at the end of your custom order. Therefore, the
final result would be:
1. Third Child
2. First Child
3. Second Child
4. Another Child
5. Final Child
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HOW TO SPECIFY THE ORDER OF AUTOMERGED OUTPUTS
1. Create an XML file and name it SortOrder.xml. You can do this by opening an editor such as
Notepad. When you save the file, type the xml file extension at the end of the name.
2. Enter the following code into the blank file.
<?xml version="1.0" encoding="utf-8"?>
<SortOrder>
<Item>ProjectA</Item>
<Item>ProjectB</Item>
<Item>ProjectC</Item>
</SortOrder>
3. Replace "ProjectA," "ProjectB," and "ProjectC" with the names of your own child targets. You
can add or remove line items as necessary.
If you were to use the example at the top of this topic, you would enter the following.
<?xml version="1.0" encoding="utf-8"?>
<SortOrder>
<Item>Third Child</Item>
<Item>First Child</Item>
<Item>Second Child</Item>
</SortOrder>
4. Save the file.
5. Copy and paste the SortOrder.xml file into the AutoMerge directory of your published
WebHelp Plus output. This file sits beside the child output folders that you are using for the
automerge.
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Displaying Merged Navigation in HTML Help
Child Outputs
You can merge HTML Help so that the navigation (table of contents, index, search) for each CHM
file is displayed, regardless of which CHM file you open (parent or child). This can be done in a
couple of ways, depending on whether you have access to all of the Flare projects or to the CHM
files only.

HOW TO DISPLAY MERGED NAVIGATION IN HTML HELP—ACCESS TO ALL FLARE
PROJECTS
1. Open the target to be used as the parent CHM.
2. On the Advanced tab of the Target Editor, select Display merged navigation in HTML Help.
3. Click

to save your work.

4. Follow the steps for merging based on HTML Help targets. See "Runtime Merging Flare Projects Using Targets" on page 98.
5. Generate the parent HTML Help target.
The parent CHM file and all child CHM files are located in the same output folder, and when
you open any of those CHM files, you can see the navigation for any of the other outputs.
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HOW TO DISPLAY MERGED NAVIGATION IN HTML HELP—ACCESS TO CHM FILES
ONLY
Use this method if you do not have access to all of the Flare projects, but you do know the names of
the other CHM files that will be created. This method is more of a manual setup and is useful if you
are part of a team where different authors have access to different Flare projects that need to be
merged. This method also lets you add or remove child CHM files without needing to recompile the
parent project.
1. The author for each project (parent and child) places a simple TXT file named merge.txt in the
same folder where the Flare project file (.flprj) is located. This TXT file can be created with
Notepad and should simply list the names of all CHM files to be included in the merged output
(one on each line), with the name of the parent CHM appearing first.
EXAMPLE
MyParent.chm
MyFirstChild.chm
MySecondChild.chm
MyThirdChild.chm
2. The author for each child project generates his output and provides the author of the parent
project with the CHM file(s).
3. The author for the parent project brings the child CHM files into the parent project and follows
the steps for merging based on CHM files. See "Runtime Merging Output from HTML Help Projects (CHM Files)" on page 109.
4. The author for the parent project generates the main HTML Help target.
The parent CHM file and all child CHM files are located in the same output folder, and when
you open any of those CHM files, you can see the navigation for any of the other outputs.
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CHAPTER 3

Exporting Projects
You can export projects, thus creating copies of them.
This chapter discusses the following:
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Adding an Export Project File
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Exporting Projects
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Exporting Projects Using the Command Line
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Adding an Export Project File
The following steps show you how to add an export project file, which is used to export projects.

HOW TO ADD AN EXPORT PROJECT FILE
1. Select the Project ribbon. In the Content section select New > Add Export Project File. The
Add File dialog opens.
2. In the File Type field at the top, make sure Export Project File is selected.
3. In the Source area select one of the following:
n

New from template Choose either the factory template file or one of your own customized template files as a starting point. The new file will take on all of the settings contained in the template. If you want to use the factory template provided by Flare, expand
the Factory Templates folder and click on a template file. If you want to use your own customized template file, expand the appropriate folder and click on a file. For more information about templates, see the online Help.

n

New from existing Choose an existing file of the same type as a starting point for your
new file. As with template files, your new file will take on all of the settings contained in
the file you select. To use this option, click the browse button
, use the Open File dialog to find a file, and double-click it.

4. In the File Name field, type a new name for the export file.
5. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click
and select the conditions you
want to apply. Click OK.
6. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the dialog. Next to the File Tags field, click
and select the file tags you want to apply. Click OK.
7. Click Add. The export file is added to the Exports folder in the Project Organizer. The Export
Project File Editor opens to the right.
After you add the new export file, you can export the project or part of it. See "Exporting Projects" on
the next page.
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Exporting Projects
You can export an entire Flare project, or parts of one, to another location. One reason you might
want to use this feature is to quickly and easily archive projects, especially if you have an extremely
large Flare project and need to archive only parts of it. Another use for this feature is translation. If
you only need a portion of a master project to be translated, you don't want to send the translator all
of the files, but rather a smaller version of the project containing only the files requiring translation.

You can export a project using the Export Project Wizard to guide you. Alternatively, you can add an
export file to your project and use the Export Project File Editor (see the online Help).
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HOW TO EXPORT A PROJECT USING THE EXPORT PROJECT WIZARD
1. Open a project.
2. Select the Project ribbon. In the Save section select Export Project. The Export Project Wizard
opens.
3. In the New Project Name field, enter a name for the exported project.
4. (Optional) The New Project Path field is automatically populated with the default location
(Documents\My Project Exports). If you want to export the project to a different location,
click
and select the folder you want.

NOTE: Depending on your operating system, the folder may be called "My Documents" instead of "Documents."

NOTE: If you select Project Template below in step 6, this area is grayed out because
the project files will automatically be placed in your templates folder.
5. In the Export From drop-down, select one of the following:
n

Entire Project This option makes a copy of the entire project, including all folders, subfolders, and files.

n

Using Target This option uses the same workflow as that used for generating a target.
When you select a particular target, the same files and content that would be included in
generated output are included in the exported project.

n

Using Conditions This option exports only files and content affected by condition tags
that you tell Flare to include or exclude.

n

Using File Tags This option exports only files affected by file tags that you tell Flare to
include or exclude. This method can be especially useful for translation purposes, exporting only files that are marked with a certain file tag status (e.g., Ready for Translation).

n

Select Files This option exports only specific files that you select. You can choose any
files stored in the source project's Content Explorer and Project Organizer.
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If you have a master TOC, page layout, or stylesheet set in the Project Properties dialog and
include those files in an export, the settings in the Project Properties dialog will be preserved.
If you do not include those files in an export, default files are added to the exported project to
allow it to work, and the settings in the Project Properties dialog are set to default.
EXAMPLE
You can open the Project Properties dialog from the Project ribbon.

Let's say the Defaults tab looks like this:

Notice that the fields point to specific files.
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Suppose you export this project and include the TOC and styles files in the
export, but you do not include the page layout file. In that case, the Project Properties dialog will look like this in the exported project:

NOTE: If Flare detects any missing files (e.g., stylesheet, master page, target) that
are necessary in order to properly open the exported project, default files are added.
For example, if no target file is added directly as a result of your selection, an HTML5
target is added by default.
6. In the Output drop-down, select one of the following:
n

Zip File This option packages the project files into a single zip file with an .flprjzip extension and places it in a location that you select. The default location is Documents\My Project Exports.

n

Project Files This option simply exports the project files to a location that you select. The
default location is Documents\My Project Exports.

n

Project Template This option exports the project files to your templates folder (e.g., Documents\My Templates\Projects). By being placed in this location, the project files become
available as a template selection when you create a new project.

7. (Optional) Select Save settings if you want to retain your settings for future re-exports. The
export project file (.flexp) is stored in the Exports folder in the Project Organizer. When you
open this export file, the Export Project File Editor opens. This editor lets you change any of
your settings (if necessary) and export the project again (see the set of steps below for exporting a project using the Export Project File Editor).
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8. Click Next.
9. If you are exporting based on a target, click in the Target drop-down field and select the appropriate target from the source project.
10. (Optional) You can select one or both of the following:
n

Convert variables to text Select this option if you want all relevant variables to be converted to text.

n

Convert snippets to text Select this option if you want all relevant snippets to be converted to text.

11. Do the following, depending on the type of export you selected in step 5:

ENTIRE PROJECT
Skip to step 12.

USING TARGET
Skip to step 12.

USING CONDITIONS
a. Click Next.
b. Use either the Basic or Advanced section to tell Flare which condition tags to include and
which to exclude from the export.
By default when you open this page, the Basic option is selected. You can click Advanced
to switch to that mode if you are experienced at writing expressions by hand.While the
Basic section is easier for most people to use, it is also more limited in the type of expressions it can create.
With the Basic method, all of your work is done on the top half of the user interface, by
just clicking check boxes. On the other hand, with the Advanced method, most of your
work is done on the bottom portion of the user interface.
For details and examples on using each of these methods, see the online Help.
NOTE: In order for this method to work, make sure you have already applied the
appropriate condition tags to files and content in the project.
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NOTE: If you are an experienced user and want to use the Advanced mode, you
might find it helpful to begin with the Basic mode to create the initial expression
and then switch to Advanced when you are ready.

NOTE: The Finish button is not enabled until you create at least one condition
expression on this page.

USING FILE TAGS
a. Click Next.
b. In the Tag Type field, you can select a specific file tag set or choose to display all file tags
to the right.
c. Use either the Basic or Advanced section to tell Flare which file tags to include (e.g.,
Ready for Translation) and which to exclude from the export.
By default when you open this page, the Basic option is selected. You can click Advanced
to switch to that mode if you are experienced at writing expressions by hand.While the
Basic section is easier for most people to use, it is also more limited in the type of expressions it can create.
With the Basic method, all of your work is done on the top half of the user interface, by
just clicking check boxes. On the other hand, with the Advanced method, most of your
work is done on the bottom portion of the user interface.
The process for creating file tag expressions is essentially the same as that for condition
tag expressions.
NOTE: In order for this method to work, make sure you have already associated
the appropriate file tags with files in the project.
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NOTE: If you are an experienced user and want to use the Advanced mode, you
might find it helpful to begin with the Basic mode to create the initial expression
and then switch to Advanced when you are ready.

NOTE: The Finish button is not enabled until you create at least one file tag
expression on this page.

SELECT FILES
a. Click Next.
b. Make sure a check mark is next to each content folder or file that you want to include in
the exported project. By default, all of the boxes are checked, but you can click in any of
the boxes to remove the check marks if necessary. You can expand folders and subfolders to see files within them.

c. Click Next.
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d. Make sure a check mark is next to each project folder or file that you want to include in
the exported project. By default, all of the boxes are checked, but you can click in any of
the boxes to remove the check marks if necessary. You can expand folders and subfolders to see files within them.
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12. Complete one of the following sets of steps, depending on the type of output method you
selected in step 6:

PROJECT FILES
n

Click Finish. The project is exported, and Windows opens to the location, showing you the
files.

PROJECT TEMPLATE
a. Click Next.
b. On the next page of the template, select the template folder where you want to export
the files. You can click Manage Templates if you need to add or change template folders.
c. In the Template Name field, enter a new name for the template.
d. Click Finish. The project is exported, and Windows opens to the location, showing you the
files.

ZIP FILES
n

Click Finish. The project is exported, and Windows opens to the location, showing you the
zipped file.
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EXAMPLE—ARC HIVE
Let's say you have a large Flare project, from which you create single-sourced output
for four products. Furthermore, let's say that the documentation for each of those
products consists of several targets in the Flare project (e.g., some online, some printbased outputs).
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In order to keep the output separate and organized throughout the Flare project, you
use condition tags, both on content and on the files themselves (e.g., topics, images,
stylesheet).
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Your manager says that each time you finish documentation for a particular product,
you must save just those files in a repository. So let's say one day you finish the documentation for Product 1, which you've designed to produce output from three targets
(one output for the Web, and two outputs for PDFs).

Your large Flare project holds the finished documentation for Product 1, but it also
holds the documentation for Products 2, 3, and 4, which are in different stages of progress. You want to archive only the documentation that is specific to Product 1, so you
decide to export the relevant files from the large Flare project to a smaller one.
But how do you do this? One option is to export to a smaller project based on condition
tags, which you have used to organize all of the content and files in the project.
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So from the Project ribbon you click Export Project. On the first page of the wizard, you
click in the Export From drop-down and select Using Conditions.
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You can then tell Flare which conditions to include and which to exclude. In this case,
you tell Flare to include all of the condition tags that have to do with Product 1 and its
targets, and you exclude all of the condition tags that have to do exclusively with the
other products and their targets.

After clicking Finish, the relevant files and content are exported to a new, smaller Flare
project.
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EXAMPLE—TRANSLATION
Let's say you have a Flare project with seven targets you need to translate the content
associated one of those targets from English to French. You could send your entire
Flare project to the translator, but that would mean the translator would be getting files
associated with all seven targets, not just the one requiring translation. So you decide
to export only the portion of the Flare project that needs to be translated.
First, from the Project ribbon you click Export Project. On the first page of the wizard,
you click in the Export From drop-down and select Using Target.
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On the next page of the wizard, you select the target whose files you want to export. In
this case, let's say the target in question is named "Product1_Web Output." In addition,
you tell Flare to convert your variables and snippets to text so that they become part of
the topics, rather than separate files.

After clicking Finish, the relevant files and content are exported to a new, smaller Flare
project. Only the files and content necessary to produce the Product1_Web Output target are included in the export. Therefore, the translator receives only the files requiring
translation.

NOTE: As an alternative to exporting projects in the Flare user interface, you can use madbuild to export projects from the command line. Using this method, you do not need to have
Flare open, and you can schedule exports for specific days and times. See "Exporting Projects Using the Command Line" on the next page.

NOTE: There is also a less robust, but quicker feature for zipping projects. See "Zipping Projects" on page 158.
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Exporting Projects Using the Command Line
As an alternative to exporting projects in the Flare user interface, you can use madbuild to export
projects from the command line. Using this method, you do not need to have Flare open, and you
can schedule exports for specific days and times.

HOW TO USE THE COMMAND LINE TO EXPORT A PROJECT
1. Add an export project file in the Project Organizer. It will be placed in an Exports folder. See
"Adding an Export Project File" on page 133.
2. Complete the fields in the Export Project File Editor. You need to do this so that Flare knows
where to export the project, which parts of it to export, and so on. These fields need to be completed only once. After that, you can export the project anytime you want and these same
rules will be used. For more information on each field and option in the Export Project File
Editor, see "Exporting Projects" on page 134.
3. Do one of the following, depending on whether you want to create a batch file for later use or
to export immediately using the command line.
n

To Create a Batch File (Recommended) Open Notepad. For example, in Windows 7, you
can open it by clicking the Start button and selecting All Programs > Accessories > Notepad.
OR

n

To Generate Immediately From the Command Line Open your command prompt. For
example, in Windows 7, you can open it by clicking the Start button and then selecting All
Programs > Accessories > Command Prompt.

4. Type the path to the Flare.app folder where you installed Flare, and press Enter.
EXAMPLE
If you installed Flare at C:\Program Files (this is just an example; your files might
be installed in a different folder, such as Program Files x86), you might type the
following and press Enter on your keyboard:
cd\Program Files\MadCap Software\MadCap Flare
V15\Flare.app
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5. Type the following and press Enter on your keyboard (entering the path to your project, and
the export file within it, in place of the section in angle brackets):
madbuild -export [project path] -settings [export project file
name]
Make sure you add the .flexp file extension at the end of the export project file name.
NOTE: If there are spaces anywhere in your path or project name, you need to use
quotation marks around it.

TIP: If you are using the command prompt (as opposed to a Notepad file) and you
have an operating system that supports dragging, you can drag a file from the Windows location to the Command Prompt window. This will add the path of the file
within quotation marks for you.

EXAMPLE—NO SPAC ES
You have a Flare project called "FictionSoftPro" that you have stored in a folder of
the same name at the root level of the C: drive. Within that project you've created
an export file named "MyExportFile." In that case, you can type this:
madbuild -export c:\FictionSoftPro\FictionSoftPro.flprj settings MyExportFile.flexp

EXAMPLE—SPACES
You have a project called "FictionSoftPro" that you have stored in a folder named
"My Projects" (with a space) at the root level of the C: drive. Within that project
you've created an export file named "My Export File" (with spaces). In that case,
you can type this:
madbuild -export "c:\My Projects\FictionSoftPro\
FictionSoftPro.flprj" -settings "My Export File.flexp"
If you are using the command prompt window, the project is exported immediately.
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If you are creating a batch file in Notepad, it might look something like this:

6. If you are creating a batch file, save the Notepad file to any location you like on your computer. When you do this, type .bat as the extension at the end of the file name (e.g.,
MyBatchFile.bat). At any time you like, you can export the project simply by double-clicking
the batch file. You can also use a tool to schedule the batch file to run.
For example, complete the following steps if using the Windows 7 Task Scheduler utility.
a. In Windows, click the Start button.
b. Select All Programs > Accessories > System Tools > Task Scheduler.
c. Click Action > Create Basic Task.
d. In the Create Basic Task Wizard, give the task a name and click Next.
e. Using the next couple of pages of the wizard, choose when you wan the batch to run
(e.g., daily, starting at 2 a.m.). Click Next until you get to the Action page.
f. Click Start a program, and click Next.
g. Click Browse. Then find and double-click the batch file you created.
h. Click Next.
i. Click Finish.
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ERROR CODES
If you export a project using the command line, the following error codes may be seen if problems
occur during an export process:
n

3001 The entered export project file does not exist.

n

3002 There was an error parsing the entered export project file.

n

3003 Export failed.

n

3004 Export destination name not set in the export file

n

3005 Export destination path not set in the export file

n

3006 Template name not set in the export file

n

3007 Template path not set in the export file

n

3008 Target path not set in export file (when exporting using target)

n

3009 Target path not found (when exporting using target)

n

3010 Conditional expression not set (when exporting using conditional expression)

n

3011 File Tag expression not set (when exporting using file tag expression)

n

3012 No files selected (when exporting using manual selection)
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CHAPTER 4

Other Project Tasks
In addition to creating and merging projects, there are several other project-related tasks that you
might perform.
This chapter discusses the following:
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Closing Projects
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Deleting Projects
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Zipping Projects
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Opening a Project
There are multiple ways to open an existing project. You can use interface options or drag files from
Windows Explorer.

HOW TO OPEN A PROJECT USING INTERFACE OPTIONS
Do one of the following, depending on the part of the user interface you are using:
n

Start Page On the left side of the Start Page, click Open. You can also click a recently opened
project. If you do not see the Start Page, select View > Start Page.

n

Ribbon Select File > Open. The Open dialog displays. The Flare project file extension (.flprj)
appears in the File Type field. In the Open dialog navigate to the project you want, select it,
and click Open.

n

Keyboard Shortcut Press CTRL+O. The Open dialog displays. The Flare project file extension
(.flprj) appears in the File Type field. In the Open dialog navigate to the project you want,
select it, and click Open.

HOW TO OPEN A PROJECT BY DRAGGING A FILE FROM WINDOWS EXPLORER
1. Open Windows and navigate to a folder containing a project file.
2. Launch Flare.
3. Drag the project file from Windows to the application window and drop it on the title bar in
Flare.
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Closing Projects
When you are finished working on a project, you can either close the project or close Flare altogether. If you close just the project, Flare remains open, which lets you start another project if you
want. Select File > Close > Close Project.
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Deleting Projects
To delete a project completely, you must use Windows Explorer. This operation cannot be done
from Flare.
You can also remove projects from displaying as recent projects in Flare. This does not delete the
project, but simply removes it from those shortcut locations.

HOW TO DELETE A PROJECT THROUGH WINDOWS
1. In Windows Explorer, browse to the location where you have stored the project (e.g., C:\Documents and settings\Projects\My Project).
2. Delete the folder holding the project files.

HOW TO REMOVE A PROJECT FROM RECENT PROJECTS IN FLARE
1. Select File > Manage Recent Projects.
The Recent Projects dialog opens.
2. Highlight the project and click Remove.
3. Click OK.

NOTE: Projects that you have pinned in the Start Page are not removed from it when you
manage your recent projects, removing them all. If you want to remove a pinned project
from the Start Page, you need to unpin it in order for it to be removed. Just click the pin button to the right of the project.
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Zipping Projects
If you want to send your project to another location or person, you can package (zip) the project into
a single file that is much smaller than the entire project in its normal state. The zipped project can
then be easily unzipped by anyone who also uses Flare, retuning the project to its normal state so
that it can be edited. Zipping a project is also a great way to create and store a backup of your project.
There are two methods you can use—(1) zipping only or (2) zipping and emailing. The first method
lets you zip the project and place the compressed file where you want on your computer. The
second method lets you zip the project and immediately attach it to an email so that you can send it
to someone. This topic deals with the first method. Also see "Flare compresses the project and
places it into a single file with an.flprjzip extension. The file is attached to an email message, ready
for you to send to others." on the next page.

HOW TO ZIP A PROJECT
1. Open a project.
2. Select the Project ribbon. In the Save section select Zip Project. The Create Package dialog
opens.
3. (Optional) You can click in the Package File field and rename the zipped file at the end of the
path. By default, the zipped file is named after your project.
4. (Optional) You can click the Browse button and navigate to another folder to store the zipped
file. By default, Flare specifies that the zipped file should be placed in your "Documents"
folder, but you can use the Browse button to change that.
5. Click Create. Flare compresses the project and places it into a single file with an .flprjzip extension.
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HOW TO ZIP AND EMAIL A PROJECT
1. Open a project.
2. Select the Project ribbon. In the Save section select Zip Project > Zip and Email Project.
Flare compresses the project and places it into a single file with an.flprjzip extension. The file
is attached to an email message, ready for you to send to others.
When individuals receive the email, the can unzip the file by double-clicking it (if they also
have Flare installed).

NOTE: Alternatively, you can use a more robust export feature, with additional options, to
zip a project (or parts of one). See "Exporting Projects" on page 134.
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APPENDIX

PDFs
The following PDFs are available for download from the online Help.
TUTORIALS

Getting Started Tutorial
Product Foldout Tutorial
Side Navigation Tutorial
Top Navigation Tutorial
USER GUIDES

Accessibility Guide

HTML Help Guide

Analysis and Reports Guide

HTML5 Guide

Architecture Guide

Images Guide

Autonumbers Guide

Importing Guide

Condition Tags Guide

Index Guide

Context-sensitive Help Guide

Key Features Guide

Eclipse Help Guide

Language Support Guide

Getting Started Guide

MadCap Central Integration Guide

Global Project Linking Guide

Master Pages Guide
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Micro Content Guide

Source Control Guide: Git

Movies Guide

Source Control Guide: Perforce

Navigation Links Guide

Source Control Guide: Subversion

Plug-In API Guide

Source Control Guide: Team Foundation Server

Print-based Output Guide

Styles Guide

Project Creation Guide

Tables Guide

Pulse Guide

Tables of Contents Guide

QR Codes Guide

Targets Guide

Reports Guide

Templates Guide

Reviews & Contributions Guide

Topics Guide

Search Guide

Touring the Workspace Guide

SharePoint Guide

Transition From FrameMaker Guide

Skins Guide

Variables Guide

Snippets Guide

What's New Guide

CHEAT SHEETS

Folders and Files Cheat Sheet
Print Output Cheat Sheet
Shortcuts Cheat Sheet
Structure Bars Cheat Sheet
Styles Cheat Sheet
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