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CHAPTER 1

Introduction
Source control is a process where you store a copy of your project on a server, allowing you to synchronize your local changes with the server version of the project, and with changes from other
writers. Source control is even useful for single authors because it provides a means for maintaining
a constant backup of all project files.
Flare includes support for every source control tool on the market by virtue of the fact that Flare
uses a wide open architecture. Instead of using proprietary files and databases, all content and project files in Flare are stored as independent XML files. This means that Flare projects are compatible with all source control systems. In addition to this native support for all source control
applications, Flare provides integrated support for several source control applications as well.
This chapter discusses the following:
Is the Source Control Application Inside Flare?

7

Which Source Control Programs are Integrated with Flare?

7

Who is Involved with Source Control?

7

Which Files Can Be Included?

8

MadCap Central and Source Control
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6

Is the Source Control Application Inside
Flare?
No. Flare does not use a proprietary source control system within the application. Instead, Flare
allows you to connect (or "bind") your project to an existing third-party source control application
that is separate from Flare.

Which Source Control Programs are
Integrated with Flare?
Built-in support is available for Microsoft Team Foundation Server, Perforce, Git, and Apache Subversion. You also have the option of manually adding your project files to any source control tool,
rather than using Flare's built-in integration.

Who is Involved with Source Control?
This depends on how you work in your company. Someone (perhaps a network administrator) needs
to set up your source control program and create the necessary database(s) in it. This individual
may also set up the "rights" to all persons who have access to the necessary databases and files. If
you are working on a multi-author team, each writer on the team needs to have a local copy of the
Flare project and will be responsible for checking in and checking out files as necessary.
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Which Files Can Be Included?
The files that can be included in source control depends on whether you are adding them manually
or using the built-in integration.

If Including Files Manually in Your Source Control Client
If you are manually adding files to a source control application (rather than using the built-in Flare
integration), you can transfer any appropriate files in a Flare project. Appropriate files include the following.
n

The main FLPRJ file

n

All files from the Content folder

n

All files from the Project folder, except those in the Project > Users subfolder

n

Files from a specific Output subfolder
You might transfer output files to source control, for example, if you are integrating your Help
into a desktop application, and programmers need access to your output files to build the
application. However, if you do this, make sure you map the source control to the appropriate
output subfolder, and not to the Temporary subfolder or to the main Output folder, which contains the Temporary subfolder.
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If Using the Source Control Integration in the Flare
Interface
If you are using Flare's built-in source control integration, you can transfer the following types of
files.
n

The main FLPRJ file

n

All files from the Content folder

n

All files from the Project folder, except those in the Project > Users subfolder

n

Files from a specific Output subfolder, if using source control publishing

In most workflows, you only need to transfer the content and project files mentioned, and when you
are ready to generate output, you would publish the output files to another location where users can
access them (such as a website or network drive). However, if you want to use Flare to directly publish your output to source control so you can keep a copy of your finished output for future reference, you can also create a source control publishing destination.
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MadCap Central and Source Control
MadCap Central is a cloud-based platform that lets you plan, track, and manage the processes, content, and teams that are at the heart of your organization. MadCap Central's integration with
MadCap Flare lets you store copies of your projects in Central, continue to work on them locally in
Flare, and keep both sets of copies in sync. You can use Central to quickly build and publish output
(and roll back when necessary) without the need to involve an IT department. You can also send topics and snippets for review on Central, as well as use custom checklists to track your progress in
Flare projects. The MadCap Central window pane in Flare lets you upload (bind) and import projects,
as well as push project changes to Central. Additionally, you can see project properties, log in and
out of your Central account, and launch the Central portal in your browser.
When you upload a Flare project to Central, the files are connected to Central via an integrated
source control system. Your interaction with source control can follow one of two models—singlebound or dual-bound. For more information see the online Help.
NOTE: MadCap Central is sold separately from Flare. Please contact MadCap Software
Sales for more information.
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CHAPTER 2

About Perforce
Because Flare uses an open architecture, Flare projects are compatible with all source control systems. In addition to this native support for all source control applications, Flare provides integrated
support with some source control applications.
Please reference the source control topics in this section if you are using Flare's integrated source
control with Perforce.
This chapter discusses the following:
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Common Source Control Terms
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Source Control Icons

13

General Workflow (Multi-Author Team)

15

General Workflow (Single Author)

17

Additional Source Control Tasks and Features

18
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Common Source Control Terms
n

Bind This means to connect your project to Perforce. After doing this, you can then take
advantage of all the automated source control tasks (such as submit, revert, lock, unlock, and
so on).

n

Submit This means to send changes made to your open Flare files to the server, or depot.

n

Check Out This means to copy the latest source control files to your local Flare project and
remove the "Read Only" designation from them so that you can edit the files.

n

Get Latest Version This means to copy the latest source control files to your local project
without necessarily checking out the files. This means that the "Read Only" designation will
remain associated with the files until you check them out.

n

Revert This means to undo changes you have made to a Flare file. Changes are reverted to
the way they were at the last submit.

n

Lock This means to prevent other users from submitting changes to an opened Flare file in
source control.

n

Unlock This means to remove an existing lock from an open Flare file so other users can submit changes to the file.

NOTE: Flare integrates with multiple source control providers to provide built-in source control support. Each of the source control providers built-in to Flare uses different terms. As
such, Flare's source control interface is different depending on which source control provider you use. Please refer to the sections for each source control provider if you need to
see information about the terms used by other built-in systems.
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Source Control Icons
Following are descriptions for the primary icons that you may see next to files when using source
control.
Checked Out
This indicates that the file has been checked out from source control. You can submit the
file when you are ready (if you are the user who has checked it out).
New File (Pending Add)
This indicates that you have a file in your project but have not yet added it to Perforce. This
might occur, for example, if you create a new topic and do not add the file to source control
during the topic creation process. To resolve this, simply right-click on the file and select
Source Control > Add.
Not Checked Out
This indicates that the file is added to source control but is not currently checked out,
which means that it contains a "Read Only" designation in its properties. In order to edit the
file, you must check it out from source control.
Locked by Another User
This indicates that another user has locked the file. You will often see this icon in conjunction with the icon, indicating that another user is both using the file and has locked
the file. You can still make changes to this file even if another user has locked it, but you
cannot submit them until the lock is removed.
Locked by You
This indicates that you have locked the file. You will often see this icon in conjunction with
the icon, indicating that you have both locked and checked out the file. Other users can
make changes to this file even if you have locked it.
Checked Out to Other User
This indicates that the file is currently checked out by another user. You will often see this
icon in conjunction with the icon, indicating that another user is both using the file and
has locked the file.
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Out of Date
This indicates that the file is not current (i.e., the local copy of the file is older than the
source control copy). This might happen, for example, if another user checks out the file,
makes changes to it, and submits it to source control. If this occurs, you can check the file
out or get the latest version of the file from source control.
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General Workflow (Multi-Author Team)
Following are the basic steps for using Flare's source control integration for a multi-author team.
1. Set Up Perforce Install Perforce and set up the database and any folders where you want to
place the project. Also, assign permissions to the proper individuals. This task may be performed by someone else, such as a network administrator.
2. In Flare, do one of the following, depending on whether you are creating a new Flare project or
using an existing one.
n

Create and Bind New Project Create a new Flare project and simultaneously bind it to an
integrated source control application.
OR

n

Bind Existing Project If you have an existing Flare project on your local machine, bind the
project to the source control application.
NOTE: Only one of the authors needs to perform this task. The other authors on the
team can follow Step 3 below.

3. Import Project Other users on the team can easily import the project from source control.
This creates a copy of the Flare project on the author's computer.
4. Get Latest Version After you bind a Flare project to a source control application, you can get
the latest version of any of the source control files. When you do this, you are copying the
most current files stored in the source control application to your local Flare project without
necessarily checking out the files. This means that the "Read Only" designation will remain
associated with the files until you check them out. When working with other authors, it is a
good idea to do this frequently (e.g., at the beginning of each day) in order to ensure you have
the latest changes that those authors have made, and that they have the latest changes
you've made.
5. Check Out Files When you need to work on any of the Flare project files, you can check them
out. Checking out files means to copy the latest source control files to your local Flare project
and remove the "Read Only" designation from them so that you can edit the files. A red check
mark is displayed next to each file that is checked out.
6. Lock/Unlock Files When you are working, you may want to lock the files you have modified.
Locking a file does not prevent other users from modifying the file. However, no one else can
submit a file that you have locked until you remove the lock.
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7. Submit Files When you are finished editing files, you can submit them to source control. Submitting a file overwrites the old copy of the file in the source control database with the new
one from your local machine. So even if others will not be working on that file, it is a good idea
to periodically submit files so that you have a backup in source control.
8. Merging There may be times when you need to merge changes from different authors when
checking in a file. The merge occurs automatically if there are no conflicting changes (i.e.,
changes do not occur in the same location). If there are conflicting changes, a dialog opens,
allowing you to determine how changes are merged.
9. Add Files When working in a project that is connected to source control, there may be occasions when you have files in your local copy of the project that are not yet part of the source
control copy. For example, when you add a new topic in your local copy of the project, that file
will not be included in the source control copy of the project until you add it.
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General Workflow (Single Author)
Following are the basic steps for using Flare's Perforce integration for a single author.
1. Set Up Perforce Install Perforce and set up the database and any folders where you want to
place the project. Also, assign permissions to the proper individuals. This task may be performed by someone else, such as a network administrator.
2. In Flare, do one of the following, depending on whether you are creating a new Flare project or
using an existing one.
n

Create and Bind New Project Create a new Flare project and simultaneously bind it to an
integrated source control application.
OR

n

Bind Existing Project If you have an existing Flare project on your local machine, bind the
project to the source control application.

3. Check Out Files When you need to work on any of the Flare project files, you can check them
out. Checking out files means to copy the latest source control files to your local Flare project
and remove the "Read Only" designation from them so that you can edit the files. A red check
mark is displayed next to each file that is checked out.
4. Submit Files When you are finished editing files, you can submit them to source control. Submitting a file overwrites the old copy of the file in the source control database with the new
one from your local machine. So even if others will not be working on that file, it is a good idea
to periodically submit files so that you have a backup in source control.
5. Add Files When working in a project that is connected to source control, there may be occasions when you have files in your local copy of the project that are not yet part of the source
control copy. For example, when you add a new topic in your local copy of the project, that file
will not be included in the source control copy of the project until you add it. See "Adding Files
to Source Control" on page 51.
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Additional Source Control Tasks and
Features
Following are some additional tasks and features related to source control.
n

Automatic Status Checks If you are using source control integration in Flare, you can check
for frequent status changes automatically. You can specify the number of minutes and
seconds when you want Flare to ping the source control repository and get status changes for
files that have been checked out, checked in, moved, deleted, etc. The upside of this feature
is that you can ensure that the source control status information is always up to date. The
downside is that you may experience slower performance due to this constant communication over the network.

n

Differences You can view differences between files in various ways. For more information see

n

Disable Prompt for Get Latest By default, when you open a project that is bound to source control, a message automatically asks if you want to get the latest version of files. However, you
can disable this prompt in the Options dialog (File > Options).

n

Disconnect from Source Control There may be times that you need to disconnect from
source control to work offline. You can disconnect from source control and reconnect at any
time.

n

History You can view the history of a particular source control file.
l

Version Displays a number for each version of the file. The lower the number, the older
the version. The higher the number, the more recent the version.

l

Users Displays the name of the user who has been working on the file.

l

Date Displays the date and time when the action has occurred.

l

Action Displays the action that has taken place for the file (e.g., submit).

l

l

Comment Displays the comment (if any) associated with the file. A comment can be
added to a file when you submit that file to source control. This enables you to maintain
an audit trail for the file's history.
Get Selected Version Performs a "get" of a particular version of a file, thus rolling back to
that version of the file. The local version of the file is replaced with the source control version that you selected.
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l

Show Differences Opens a dialog that lets you view the differences between two versions of a file. If you select one row in the History dialog and view the differences, you will
see the content differences between the version that you selected and the version of the
file in your local copy of the Flare project. If you select two files in the History dialog (by
holding down the CTRL key) and view the differences, you will see the content differences between those two versions of the file.

n

Locks You can lock files so that other users cannot submit those same files when you have
them checked out. You might use this feature to prevent conflicting changes from occurring
and having to merge files as a result. You can set files to be locked automatically when you
check out files. This can be done from the Source Control tab in the Options dialog (File >
Options). Another option is to manually set files to be locked whenever you check out files.
This can be done from the Check Out dialog.

n

Publish to Source Control You can use Flare to directly publish your output to source control,
rather than having to upload it to source control separately. Publishing your output to source
control is beneficial because it you can keep previous versions of your output in source control and access them if necessary.

n

Unbind You can unbind a project from source control.

n

View Checked-Out Files You can use the Pending Changes window pane and the Source Control Explorer to view all of the files that you have checked out and need to submit. You can use
the File List window pane and Pending Changes window pane to view files that are checked
out by other users.

NOTE: When you remove files from your project and submit your changes, you still need to
perform a "get latest" in order for those files to be removed from the client.
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CHAPTER 3

Binding a Project to Perforce
Use the following steps if you have already created a Flare project and want to bind ("connect") it to
Perforce. You can also automatically detect existing source control bindings if your project has
been previously connected to Perforce.
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HOW TO BIND A PROJECT TO SOURCE CONTROL
1. Open the project.
2. Select the Project ribbon. In the Properties section select Project Properties. The Project
Properties dialog opens.
3. Select the Source Control tab.
4. Click Bind Project. The Bind Project dialog opens.
5. From the drop-down, select Perforce.
6. In the Server field, enter the server address.
7. Next to the User field, click

. The Select User dialog opens.

8. Select a user and click OK. (Users are set up separately in Perforce.)
9. From the Type drop-down, select whether you want to bind to a stream or a depot. A depot
contains multiple streams.

IF YOU ARE BINDING TO A STREAM
a. Next to the Stream field, click New.
If the Log In dialog opens, complete the User name and Password fields and click OK.
The New Perforce Stream dialog opens.
b. From the Stream Type drop-down, select the type of stream you want to use. Most
streams are mainline streams.
c. Next to the Streams Depot field, click Browse.
The Browse Depots dialog opens.
d. Select a depot. This is essentially a folder or directory in Perforce that contains multiple
streams, one of which will be your Flare files.
e. Click OK.
f. (Optional) In the New Perforce Stream dialog, you can complete any of the other fields
as necessary. For information about these fields, please refer to the documentation
provided with Perforce.
g. Click OK.
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IF YOU ARE BINDING TO A DEPOT
a. Next to the Depot field, click New, or select an existing depot using the drop-down
arrow.
If you clicked New, the New Depot dialog opens.
b. In the Name field, enter a name for the depot.
c. (Optional) In the Description field, enter a description for the depot.
d. Click OK.
e. Next to the Path field, click

.

If the Log In dialog opens, complete the User name and Password fields and click OK.
The Browse Source Control Folders dialog opens.
f. Select the location where you want to bind the project.
g. Click OK.
10. (Optional) In the Comment field, you can enter any internal comments.
11. (Optional) If you want the files in the project to be checked out when you are finished, click
Keep files checked out.
12. In the Bind Project dialog, click OK.
13. If the Log In dialog opens, complete the User name and Password fields and click OK. Copies
of the Flare files are created and added to the folder you specified.
14. In the Project Properties dialog, click OK. The project is connected to Perforce, and you can
now submit files and check them out as necessary.
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HOW TO BIND A PROJECT TO SOURCE CONTROL—SOURCE CONTROL EXPLORER
1. Open the project.
2. Select the View ribbon. In the Explorer section select Source Control Explorer. The Source
Control Explorer opens.
3. From the drop-down or the Home pane, select Settings. The Settings pane opens.
4. Click Bind. The Bind Project dialog opens.
5. From the drop-down, select Perforce.
6. In the Server field, enter the server address.
7. Next to the User field, click

. The Select User dialog opens.

8. Select a user and click OK. (Users are set up separately in Perforce.)
9. From the Type drop-down, select whether you want to bind to a stream or a depot. A depot
contains multiple streams.

IF YOU ARE BINDING TO A STREAM
a. Next to the Stream field, click New.
If the Log In dialog opens, complete the User name and Password fields and click OK.
The New Perforce Stream dialog opens.
b. From the Stream Type drop-down, select the type of stream you want to use. Most
streams are mainline streams.
c. Next to the Streams Depot field, click Browse.
The Browse Depots dialog opens.
d. Select a depot. This is essentially a folder or directory in Perforce that contains multiple
streams, one of which will be your Flare files.
e. Click OK.
f. (Optional) In the New Perforce Stream dialog, you can complete any of the other fields
as necessary. For information about these fields, please refer to the documentation
provided with Perforce.
g. Click OK.
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IF YOU ARE BINDING TO A DEPOT
a. Next to the Depot field, click New, or select an existing depot using the drop-down
arrow.
If you clicked New, the New Depot dialog opens.
b. In the Name field, enter a name for the depot.
c. (Optional) In the Description field, enter a description for the depot.
d. Click OK.
e. Next to the Path field, click

.

If the Log In dialog opens, complete the User name and Password fields and click OK.
The Browse Source Control Folders dialog opens.
f. Select the location where you want to bind the project.
g. Click OK.
10. (Optional) In the Comment field, you can enter any internal comments.
11. (Optional) If you want the files in the project to be checked out when you are finished, click
Keep files checked out.
12. In the Bind Project dialog, click OK.
13. If the Log In dialog opens, complete the User name and Password fields and click OK. Copies
of the Flare files are created and added to the folder you specified. The project is connected
to Perforce, and you can now submit files and check them out as necessary.
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AUTOMATICALLY DETECTING EXISTING PROJECT BINDINGS
You can scan a project when you open it to see if it has any bindings to source control. If a binding is
detected, you can apply the binding and submit the project to source control.
1. Select File > Options. The Options dialog opens.
2. Select the Source Control tab.
3. Select the Bind Detection check box.
4. Select the source control provider(s) you want to scan for bindings.
NOTE: Source control providers are scanned in the following order:
1. Git
2. Subversion
3. Perforce

TIP: Detecting source control bindings may take a considerable amount of time. It is
recommended that you select only the source control providers that you use to speed
up the detection process.

NOTE: You can also bind a new Flare project to source control while creating it.

NOTE: If you want to publish your output to source control, you must create a bind destination.

TIP: If you are having difficulty binding your project, try binding to a brand new directory in
your source control provider. You should also ensure that the directory on your local
machine (and its parent directories) is not already mapped to source control, as this may
cause issues with binding.
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CHAPTER 4

Importing from Perforce
This chapter focuses on importing a Flare project from source control. You might use this method,
for example, if you are working on a multi-author project and another member of the team has
placed the Flare project in Perforce. For more information see "Introduction" on page 6.
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HOW TO IMPORT A PROJECT FROM SOURCE CONTROL
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select File > New Project > Import Project.

n

Source Control Explorer From the View ribbon, open the Source Control Explorer. From
the drop-down, select the Home pane. Click Import Project.

The Import Project from Source Control Wizard dialog opens.
2. From the drop-down, select Perforce.
3. In the Server field, enter the server address.
4. Next to the User field, click

. The Select User dialog opens.

5. Select a user and click OK. (Users are set up separately in Perforce.)
6. Next to the Location field, click Browse. The Browse Depots and Streams dialog opens.
7. Select a depot or stream (i.e., the name of your Flare project).
8. Click OK.
9. Click Next.
10. Next to the Project file field, click Browse. The Browse Source Control Files dialog opens. (You
may need to log in with your user name and password.)
11. Find and click on the Flare project file (FLPRJ) that you want to import. (You may need to log
in with your user name and password.)
12. Click OK.
13. Click Next.
14. In the Project name field, the name of the project being imported is displayed. It is recommended that you leave the name as it is, especially if you are working with other authors on
the project. However, you can enter a different project name if you want.
15. In the Project folder field, either accept the default location for the new project or click
browse for and select a folder.

to

16. Click Finish. The project is imported and loaded into Flare.

CHAPTER 4

27

NOTE: If you want to import a project from source control, you can alternatively open the
project file from another location (e.g., a server location), and then use Flare's bind detection functionality to automatically apply available source control bindings to the project.
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CHAPTER 5

Getting the Latest Version of
Source Control Files
After you bind a Flare project to a source control application, you can get the latest version of any of
the source control files. When you do this, you are copying the most current files stored in the
source control application to your local Flare project without necessarily checking out the files. This
means that the "Read Only" designation will remain associated with the files until you check them
out.
Following are steps for getting the latest version of all files in a project automatically, as well as
steps for getting the latest version of files manually.
This chapter discusses the following:
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Manual Get
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Automatic Get
You might use this option if you are working with a team of authors and want to make sure that you
include the latest changes from other writers in the output (without having to manually get those
files).
With this option:
n

You will not be prompted before the "get" is performed.

n

Flare will not get the latest copy of the files in the Targets folder, because that would conflict
with the generation of the output.

n

Conflicts with files will not cause local files to be overwritten. Therefore, if your local files are
writable or already checked out, those files will be kept, rather than overwritten with the source
control files.

HOW TO GET THE LATEST VERSION OF SOURCE CONTROL FILES AUTOMATICALLY
1. Open the target.
2. In the Target Editor, select the General tab.
3. Select the check box labeled Automatically get latest version of all files before generating the
target.
4. Click

to save your work.

5. Build the target.

CHAPTER 5

30

Manual Get
You can manually get the latest version of all of the files in the Flare project or specific files only.

HOW TO GET THE LATEST VERSION OF SOURCE CONTROL FILES MANUALLY
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the File section select Get Latest Version (for
selected files). Alternatively, in the Project section you can click Get Latest Version All
(for all files in the project).

n

Right-Click If you have the Content Explorer, Project Organizer, Pending Changes window
pane, or File List open, right-click the file you want to get and select Source Control > Get
Latest Version.

n

Source Control Explorer With the Pending Changes pane open, right-click the file you
want to update and select Get Latest Version.

2. If the local and server files are the same, a message tells you so. Click OK.
If the local file is different from the file on the server, the Resolve Conflicts dialog opens. If you
want to accept all of the differences between the local and server files, thus merging them,
click Auto Merge All. If you want to review the differences in the files side by side and resolve
each conflict, click Resolve
If the local file is different from the file on the server, the Resolve Conflicts dialog opens. If you
want to accept all of the differences between the local and server files, thus merging them,
click Auto Merge All. If you want to review the differences in the files side by side and resolve
each conflict, click Resolve For more information about merging files and resolving conflicts,
see "Merging Source Control Files" on page 41.
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NOTE: By default, when you open a project that is bound to source control, a message automatically asks if you want to get the latest version of files. However, you can disable this
prompt in the Source Control tab of the Options dialog (File > Options). See "Disabling the
Get Latest Prompt for Source Control" on page 57.

NOTE: If you update your read-only files with read-only files and you do not perform a check
out, the files will appear to be checked in without actually updating the server-side version.

CHAPTER 5

32

CHAPTER 6

Checking Out Source Control
Files
When you need to work on any of the Flare project files, you can check them out. Checking out files
means to copy the latest source control files to your local Flare project and remove the "Read Only"
designation from them so that you can edit the files. A red check mark is displayed next to each file
that is checked out.
You can check files out automatically or manually.

CHAPTER 6

33

HOW TO CHECK OUT FILES FROM SOURCE CONTROL AUTOMATICALLY
1. Select File > Options. The Options dialog opens.
2. Select the Source Control tab.
NOTE: This tab will not be visible if your project is not yet bound to source control.
See "Binding a Project to Perforce" on page 20.
3. Click the check box Automatically check file out from source control when saving file
changes. A check mark in the box indicates that the feature is enabled.
4. (Optional) If you want files that are automatically checked out to be locked as well, select
Lock files when automatically checking out.
Locking files means that other users cannot submit those same files when you have them
checked out. You might use this feature to prevent conflicting changes from occurring and
having to merge files as a result.
5. Click OK.
Whenever you open a file that is not checked out, make changes, and save, not only will your
changes be saved but the file will automatically be checked out to you.

HOW TO CHECK OUT FILES FROM SOURCE CONTROL MANUALLY
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the File section select Check Out (for selected files). Alternatively, in the Project section you can click Check Out All (for all files in
the project).

n

Right-Click If you have the Content Explorer, Project Organizer, Pending Changes window
pane, or File List open, right-click the file you want to check out and select Source Control
> Check Out (for selected files) or Source Control > Project > Check Out All (for all files in
the project).

The Check Out dialog opens. The selected files are listed with check boxes next to them.
2. Make sure to click the check box next to each file you want to check in so that it contains a
check mark.
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3. (Optional) If you want the files to be locked as well, select Lock files.
Locking files means that other users cannot submit those same files when you have them
checked out. You might use this feature to prevent conflicting changes from occurring and
having to merge files as a result.
4. Click Check Out.
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CHAPTER 7

Submitting Source Control Files
When you are finished editing files, you can submit them to source control. Submitting a file overwrites the old copy of the file in the source control database with the new one from your local
machine. So even if others will not be working on that file, it is a good idea to periodically submit files
so that you have a backup in source control.
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HOW TO SUBMIT FILES TO SOURCE CONTROL
1. Do one of the following, depending on the part of the user interface you are using:
n

Pending Changes Window Pane From the Source Control ribbon, open the Pending
Changes window pane. Select the files in the window pane that you want to submit, and
in the local toolbar click

.

n

Ribbon Select the Source Control ribbon. In the File section select Submit (for selected
files). Alternatively, in the Project section you can click Submit All (for all files in the project).

n

Right-Click If you have the Content Explorer, Project Organizer, Pending Changes window
pane, or File List open, right-click the file you want to submit and select Source Control >
Submit (for selected files) or Source Control > Project > Submit All (for all files in the project).

The Submit dialog opens. The selected files are listed with check boxes next to them.
2. (Optional) In the Comment field, enter an optional comment tied to the submit. This enables
you to keep an audit trail for a file. The comment can then be viewed from the History dialog,
which can be accessed from the Source Control Explorer, the Source Control ribbon, the File
menu, or the Source Control button
.
3. (Optional) If you want to see all files with pending changes (rather than only those you selected), click

.

4. Make sure to click the check box next to each file you want to check in so that it contains a
check mark.
5. If you want to keep the files checked out of source control, select Keep Checked Out. Doing
this will overwrite the source control copies of the files so that they have the latest changes,
but it allows you to continue working on the files. This is a useful option if you are the only
author working on the files in question.
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6. Click Submit.
If no other users have also made changes to the file and submitted it while you were working
on it, your version of the file is submitted.
However, if that is not the case, the Resolve Version Conflict dialog opens to let you know that
another user has already submitted the file with changes. You can merge the files automatically if there are no conflicting changes (i.e., changes do not occur in the same location
in the file). If there are conflicting changes, you can use the Merge Changes dialog to determine how changes are merged. See "Merging Source Control Files" on page 41.
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HOW TO SUBMIT FILES TO SOURCE CONTROL—SOURCE CONTROL EXPLORER
1. Select the View ribbon. In the Explorer section select Source Control Explorer. The Source
Control Explorer opens.
2. From the drop-down or the Home pane, select Pending Changes.
The Pending Changes pane opens. Files that will be committed are listed under Included
Changes, and files that will not be committed are listed under Excluded Changes. You can
identify modified files because they say [edit] next to the file name.

NOTE: When you check out a file in source control, you may sometimes see a SKL file
alongside the XLF and original files. This skeleton file is a placeholder file. Be sure to
submit all three associated files together. Submitting just the SKL file may result in
errors.
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3. (Optional) In the Comment field, enter an optional comment tied to the submit. This enables
you to keep an audit trail for a file. The comment can then be viewed from the History dialog,
which can be accessed from the Source Control Explorer, the Source Control ribbon, the File
menu, or the Source Control button
..
4. (Optional) If you want to select the files or folders that you include in the submit, right-click a
file or folder and select one of the following options from the context menu.
n

Exclude Excludes the selected file from the submit

n

Exclude Unselected Excludes all unselected files from the submit

n

Include Includes the selected file in the submit

n

Include Unselected Includes all unselected files in the submit

5. Click Submit to submit all of the files in the Included Changes list. The Messages pane opens
and displays a list of files that were submitted.
If no other users have also made changes to the file and submitted it while you were working
on it, your version of the file is submitted.
However, if that is not the case, the Resolve Version Conflict dialog opens to let you know that
another user has already submitted the file with changes. You can merge the files automatically if there are no conflicting changes (i.e., changes do not occur in the same location
in the file). If there are conflicting changes, you can use the Merge Changes dialog to determine how changes are merged. See "Merging Source Control Files" on page 41.
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CHAPTER 8

Merging Source Control Files
There may be times when you need to merge changes from different authors when checking in a
file. The merge occurs automatically if there are no conflicting changes (i.e., changes do not occur
in the same location in the file). If there are conflicting changes, a dialog opens, allowing you to
determine how changes are merged.
If you selected the option to use the merge tool, the Merge Changes dialog opens. Use this dialog to
view and select changes. You can take actions in the following ways.
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HOW TO MERGE SOURCE CONTROL FILES
1. Go through the process of getting the latest version of files from source control or submitting
files. See "Getting the Latest Version of Source Control Files" on page 29 and "Submitting
Source Control Files" on page 36. If your local copy of the file is different from the server copy
(e.g., another author has already submitted the same file), the Resolve Conflicts dialog opens.
2. Click Auto Merge All. If changes from the other author do not conflict with your changes, this
will merge all changes. A message lets you know that a backup of your local copy has been
made. This allows you to restore that file if you do not want to keep the merged version. You
do not need to complete the rest of the steps below.
However, if your changes conflict with those from another author, a message displays to tell
you. In this case, continue with the next step.
3. Click OK on the conflict message.
4. In the Resolve Conflicts dialog click Resolve. The Resolve Version Conflict dialog opens. From
this dialog, you can choose from the following options.
n

Merge changes for me Automatically merges changes within the same file that are not
part of the same element. If changes have been made to the same element (e.g., the
same <p> tag or <h1> tag), Flare will display a prompt to merge the changes using the
merge tool.

n

Merge changes in merge tool Opens a merging interface, which lets you see exactly what
changes were made and choose which to keep.

n

Undo my local changes Automatically removes your changes and keeps changes from
other authors.

n

Discard external changes Automatically removes changes from other authors and keeps
your changes.
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5. If you selected the option to use the merge tool, the Merge Changes dialog opens. Use this
dialog to view and select changes. You can take actions in the following ways.
n

Click a change You can click a change on either the remote or local side. This lets you
select a particular change. Use the key at the top of the merge changes dialog, as well as
the color coding on the local and server sides, to determine if a change has been added
(new), deleted, changed, or moved.
When you select a change, the change you selected will display with a solid colored background, and the conflicting change will display with a striped background. If you select
the other change, the background shading will switch.

n

Type content If you want to use your changes as well as those from another author, and
even tweak the paragraph a bit more, you can click in the area at the bottom of the dialog
and simply type content.

n

Previous/next conflict When you are finished resolving the first conflict, you can use the
"Previous Conflict" and "Next Conflict" buttons at the bottom of the dialog to work on
other conflicts in the file.
NOTE: If you selected "Merge as Text" in the local toolbar and are working in the
code, you can click on text with a hatched background to keep the change in it. After
you click on text with a hatched background, the hatched lines are removed, leaving a
solid color.

6. After all conflicts have been resolved, a message lets you know that a backup of your local
copy has been made. This allows you to restore that file if you do not want to keep the merged
version. Click OK.
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EXAMPLE—AU TO MERGING
Let's say two authors —Bob and Jill—are working on the same project, using source control to manage the files.
Bob checks out the "FAQs" topic and starts making changes to it.
Jill also checks out the "FAQs" topic and makes some changes to it. Jill's changes are in
a different location in the topic than Bob's changes; there are no conflicts. She finishes
before Bob and submits the file to source control.
Bob finishes his changes and tries to submit the file. Before the file can be submitted,
Bob is prompted with a dialog, indicating that changes from another author have
already been submitted.
Bob selects Auto Merge All. The changes from Bob and Jill are now both shown in the
merged topic.
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EXAMPLE—C ONFLICTING C HANGES
Let's say two authors—Bob and Jill—are working on the same project, using source control to manage the files.
Bob checks out the "FAQs" topic and starts making changes to it.
Jill also checks out the "FAQs" topic and makes some changes to it. Jill's changes are in
the same paragraph in the topic as Bob's changes; thus, there is a conflict. She finishes
before Bob and commits the file to source control.
Bob finishes his changes and tries to submit the file. Before the file can be submitted,
Bob is prompted with a dialog, indicating that changes from another author have
already been submitted.
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Bob selects Auto Merge All. However, he receives another message, stating that his
changes conflict with those of Jill.

Bob clicks OK. Then in the Resolve Conflicts dialog he clicks Resolve. This opens the
Resolve Version Conflict dialog. From this dialog, Bob can choose from a few different
options.
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Bob selects Merge changes in merge tool. The Merge Changes dialog opens.
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So what action can Bob take at this point for merging the file changes?
Bob can right-click on the icon next to the change on either the local or server side.
This displays a context menu, which lets Bob either keep or ignore a particular change.
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Another way of accomplishing the same thing is to left-click on an icon. When you do
this, the change from one side is kept and the change from the other side is ignored. If
you left-click the icon again, the results are toggled; the first change is ignored and the
other is kept.
What if Bob wants to use his changes as well as Jill's, and possibly tweak the paragraph
a bit more? He can click in the area at the bottom of the dialog and simply type content.
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When he is finished resolving the first conflict, Bob can use the "Previous Conflict" and
"Next Conflict" buttons at the bottom of the dialog to work on other conflicts in the file.

After all conflicts have been resolved, Bob clicks OK. The merged topic is now submitted to source control.
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CHAPTER 9

Adding Files to Source Control
When working in a project that is connected to source control, there may be occasions when you
have files in your local copy of the project that are not yet part of the source control copy. For
example, when you add a new topic in your local copy of the project, that file will not be included in
the source control copy of the project until you add it.
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HOW TO ADD FILES TO SOURCE CONTROL
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the File section select Add.

n

Right-Click If you have the Content Explorer, Project Organizer, Pending Changes window pane, or File List open, right-click the file you want to add and select Source Control
> Add.

The Submit dialog opens. The selected files are listed with check boxes next to them.
2. (Optional) Enter an optional comment tied to the submit. This enables you to keep an audit
trail for a file. The comment can then be viewed from the History dialog, which can be
accessed from the Source Control Explorer, the Source Control ribbon, the File menu, or the
Source Control button
.
3. (Optional) If you want to see all files with pending changes (rather than only those you selected), click

.

4. Make sure to click the check box next to each file you want to check in so that it contains a
check mark.
5. If you want to automatically check the files out of source control, select Keep Checked Out.
6. Click Submit.
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HOW TO ADD FILES TO SOURCE CONTROL—SOURCE CONTROL EXPLORER
1. Select the View ribbon. In the Explorer section select Source Control Explorer. The Source
Control Explorer opens.
2. From the drop-down or the Home pane, select Pending Changes.
The Pending Changes pane opens. Files that will be submitted are listed under Included
Changes, and files that will not be submitted are listed under Excluded Changes. You can
identify newly added files because they say [add] next to the file name.

3. (Optional) Enter an optional comment tied to the submit. This enables you to keep an audit
trail for a file. The comment can then be viewed from the History dialog, which can be
accessed from the Source Control Explorer, the Source Control ribbon, the File menu, or the
Source Control button
.
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4. (Optional) If you want to select the files or folders that you include in the submit, right-click a
file or folder and select one of the following options from the context menu.
n

Exclude Excludes the selected file from the submit

n

Exclude Unselected Excludes all unselected files from the submit

n

Include Includes the selected file in the submit

n

Include Unselected Includes all unselected files in the submit

5. Click Submit to submit all of the files in the Included Changes list. The Messages pane opens
and displays a list of files that were submitted.
NOTE: Adding files from other areas of the Flare interface (e.g., Pending Changes
window pane, Source Control ribbon) will only add new files. However, if you use the
Source Control Explorer to submit your files, it will submit all of your pending changes:
both new files and modified files. If you do not want to include all of your files in the
submit, you can right-click them and select Exclude. Files you exclude will not be submitted.
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CHAPTER 10

Additional Perforce Tasks
In addition to the many features already covered in this guide, there are many more tasks related to
source control that you can perform in Flare.
This chapter discusses the following:
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Deleting Source Control Files
You can delete a topic or file that is bound to source control. This also removes the file from Perforce.

HOW TO DELETE A FILE
1. In one of the window panes (e.g., Content Explorer, File List, Project Organizer, Pending
Changes window pane), select the relevant file(s).
2. On your keyboard press DELETE.
3. The Delete dialog opens. Select the bound files you want to delete.
4. Click Delete. The files are removed from your project and from the source control repository.
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Disabling the Get Latest Prompt for Source
Control
By default, when you open a project that is bound to source control, a message automatically asks if
you want to get the latest version of files. However, you can disable this prompt in the Source Control tab of the Options dialog (File > Options). Therefore, in the future when you open the project you
will no longer see the message, and the project will open without replacing any local files with the
latest ones from source control.

HOW TO DISABLE THE GET LATEST PROMPT FOR SOURCE CONTROL
1. Select File > Options. The Options dialog opens.
2. Select the Source Control tab.
NOTE: This tab will not be visible if your project is not yet bound to source control.
See "Binding a Project to Perforce" on page 20.
3. Click the check box Do not prompt to get latest when opening source control bound projects.
4. Click OK.
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Disconnecting from Source Control
There may be times that you need to disconnect from source control to work offline. You can disconnect from Perforce and reconnect at any time.
Disconnecting from source control is beneficial because it allows you to modify files when you
would otherwise not have access to the source control system (e.g., you are out of the office with
your laptop or you do not want to access source control over VPN). It also provides a fallback offline
status in the event that the network is disconnected while you are working, so you are able to continue working on the files you have checked out until the network connection is restored.

HOW TO DISCONNECT FROM PERFORCE
When you want to work offline, you can disconnect from source control.
1. Check out the files you will need to work on while disconnected. See "Checking Out Source
Control Files" on page 33.
2. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the Project section select Disconnect.

n

Right-Click If you have the Content Explorer, Project Organizer, Pending Changes window
pane, or File List open, right-click on any file and select Source Control > Project > Disconnect.

3. A confirmation dialog appears. Click Yes. You will be disconnected from source control.

NOTE: When you disconnect from source control, you are not able to see the source control status of files or access source control functions.

NOTE: If you attempt to modify a file that is not checked out, you will receive an error when
you try to save the file. To avoid this, be sure you have all necessary files checked out
before disconnecting from source control.
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NOTE: If you make a change to a file’s properties (e.g., delete, rename) while disconnected
from source control, your changes may not be preserved when you reconnect to the network. To prevent errors, it is recommended that you do not make these kinds of changes
until you reconnect to source control.

HOW TO RECONNECT TO PERFORCE
When you are finished working offline, you can reconnect to source control.
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the Project section select Reconnect.
Right-Click If you have the Content Explorer, Project Organizer, Pending Changes window
pane, or File List open, right-click on any file and select Source Control > Project > Disconnect.

2. Submit the files you previously checked out. See "Submitting Source Control Files" on page
36.

NOTE: Your current network connection status is indicated in the lower right corner of the
Flare interface. If you are connected you will see
; if you are disconnected you
will see
.
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Enabling Source Control Status Checks
If you are using source control integration in Flare, you can check for frequent status changes automatically. You can specify the number of minutes and seconds when you want Flare to ping the
source control repository and get status changes for files that have been checked out, submitted,
moved, deleted, etc. The upside of this feature is that you can ensure that the source control status
information is always up to date. The downside is that you may experience slower performance due
to this constant communication over the network.

HOW TO ENABLE SOURCE CONTROL STATUS CHECKS
1. Select File > Options. The Options dialog opens.
2. Select the Source Control tab.
NOTE: This tab will not be visible if your project is not yet bound to source control.
See "Binding a Project to Perforce" on page 20.
3. Click the check box Enable background status checks. A check mark in the box indicates that
the feature is enabled.
4. Enter the number of minutes and or seconds between each status update.
5. Click OK.

NOTE: If you elect to disable this feature (disabled is the default setting), you can manually
check for status updates by refreshing the Pending Changes window pane or Source Control Explorer. See "Viewing Files that are Checked Out" on page 77.
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Locking a File
When you are working, you may want to lock the files you have modified. Locking a file does not prevent other users from modifying the file. However, no one else can submit a file that you have
locked until you remove the lock.

HOW TO LOCK A FILE
1. In one of the window panes (e.g., Content Explorer, Source Control Explorer, File List, Project
Organizer, Pending Changes window pane), select the relevant file(s).
OR
Open a file.
2. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the File section select Lock.

n

Right-Click If you have the Content Explorer, Project Organizer, Pending Changes window pane, or File List open, right-click the files you want to lock and select Source Control > Lock.

n

Source Control Explorer Right-click the files you want to lock and select Lock.

The Lock dialog opens. The selected files are listed with check boxes next to them.
3. Make sure to select the check box next to each file you want to lock so it contains a check
mark.
4. Click Lock.

NOTE: You cannot lock files with Pending Add or Checked In status.
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Publishing to Source Control
You can use Flare to directly publish your output to source control, rather than having to upload it to
source control separately. Publishing your output to source control is beneficial because it you can
keep previous versions of your output in source control and access them if necessary.
For more information about creating publishing destinations, see the online Help.

HOW TO PUBLISH OUTPUT TO SOURCE CONTROL
1. Create a new source control publishing destination, or select an existing source control publishing destination.
NOTE: When creating a new source control destination, be sure to select Source Control from the Type drop-down.
2. Assign the publishing destination to the target you want to publish.
3. Build and publish your output. Your output files will be published to the source control location
you specified in the destination.
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Reverting a Checkout of Source Control
Files
If you have files checked out from source control but do not want them checked out anymore, you
can use the "Revert" option instead of submitting the files. While submitting the file would save your
changes to source control, reverting a checkout returns the files to their previously submitted state
and does not submit any of your changes to source control.

HOW TO REVERT A SOURCE CONTROL FILE
1. In one of the window panes (e.g., Content Explorer, Source Control Explorer, File List, Project
Organizer, Pending Changes window pane), select the relevant file(s).
2. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the File section select Revert (for selected
files). Alternatively, in the Project section you can click Revert All (for all files in the project).

n

Right-Click If you have the Content Explorer, Project Organizer, Pending Changes window
pane, or File List open, right-click the files you want to revert and select Source Control >
Revert (for selected files) or Source Control > Project > Revert All (for all files).

n

Source Control Explorer With the Pending Changes pane open, select the files or folders
that you want to revert, right-click, and select Source Control > Revert. You can also click
Revert to revert all files in the Included Changes section.
NOTE: If you click Revert in the Source Control Explorer, you will not see any additional dialogs and the Revert process completes.

The Undo Check Out dialog opens. The selected files are listed.
3. (Optional) If you want to see all files with pending changes (rather than only those you selected), click

.

4. Make sure to click the check box next to each file you want to check in so that it contains a
check mark.
5. Click Undo Check Out.
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Rolling Back to an Earlier Version of a File
One of the benefits of Flare's integrated source control is that you can view the history and differences for a particular file. You can view code and content differences between two source control versions of the same file. This is useful if you need to roll back to an earlier version of a file.
See "Viewing the History of Source Control Files" on page 82 and "Viewing Differences in Source
Control Files" on page 75.

EXAMPLE
Let's say that you have been working on a particular topic for a few days. Each day you
check out the latest version of that topic file from source control, make your changes,
and submit the file back to source control at the end of the day. At a certain point, you
determine that you need to "roll back" to an earlier version of the file, using it to replace
the latest version. Therefore, you use this feature to view the highlighted differences
between the current version and an older version of the file. Once you have identified
the older version that you want to use, you can perform a "get" of that version.

HOW TO ROLL BACK TO AN EARLIER VERSION OF A FILE
1. In one of the window panes (e.g., Content Explorer, Source Control Explorer, File List, Project
Organizer, Pending Changes window pane), select the relevant file(s).
OR
Open a file.
2. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the File section select View History.

n

Right-Click If you have the Content Explorer, Project Organizer, Pending Changes window pane, or File List open, right-click the file you want to roll back and select Source
Control > View History.

n

Source Control Explorer With the Pending Changes pane open, right-click the file you
want to roll back and select View History.

The History dialog opens.
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3. (Optional) View the differences between two versions of the file. This may help you decide
which version of the file you want to retrieve. (Another way is to look at the dates for each version in the History dialog.)
To view the differences, follow these steps.
a. Select the first file version from the list.
b. Hold the CTRL key and select the second file version from the list.
c. Click Show Differences. The Differences Editor opens to the right, showing content from
the backup file on the left and the current version of the file on the right.
d. In the local toolbar of the Differences Editor, you can click any of the following to make
adjustments.
n

Options Click this to open the File Differences dialog, which lets you change the colors used to display content differences between the files.

n

Show WYSIWYG Click this to switch from tag view to WYSIWYG (What You See Is
What You Get) view.
EXAMPLE
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n

Ignore Case Click this to ignore changes in case when viewing differences. This
option can be used in "text view" only; it is not available in WYSIWYG view.
EXAMPLE
If a word is not capitalized in the original file but it is capitalized in the
current file, this option does not highlight those differences.
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n

Ignore Whitespace Click this to ignore whitespace when viewing differences.
EXAMPLE
Let's say a paragraph is identical in both files, except for an extra space
that was added within the paragraph in one of those files. If you click
this option, that difference is not highlighted.
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e. When you are finished viewing the differences, close the window pane.
4. In the History dialog, select the version of the file to which you want to roll back.
5. Click Get Selected Version. That file is downloaded from source control and replaces the local
copy of the file in your project.
6. In the History dialog, click Close.

CHAPTER 10

69

Setting Color Options for Project File
Differences
If you are using Flare's integrated source control features, you can view differences between files in
various ways. One way is to view file differences between a local version of a Flare project and the
source control version.
When viewing file differences between a local version of a Flare project and the source control version, you can select color options to display the files. Color coding makes it easier to discern where
differences between files occur.
For more information see "Viewing Differences in Source Control Files" on page 75 and "About Perforce" on page 11.

EXAMPLE
By default the files that are included only in your local copy are displayed as green in
the Differences Editor, and the files that are included only in source control are displayed in red. You can use this dialog to change the local-only files to blue and the
source control–only files to yellow.

HOW TO SET COLOR OPTIONS FOR PROJECT FILE DIFFERENCES
1. In one of the window panes (e.g., Content Explorer, Source Control Explorer, File List, Project
Organizer, Pending Changes window pane), select the relevant file(s).
OR
Open a file.
2. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the File section select Show Differences.

n

Right-Click If you have the Content Explorer, Project Organizer, Source Control Explorer,
Pending Changes window pane, or File List open, right-click the file you want to view and
select Source Control > Show Differences.

The Differences Editor opens.
3. In the local toolbar of the Differences Editor, click Options. The File Differences dialog opens.
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4. Change the text or background color for any of the difference types. To do this, simply click in
the appropriate Text or Background cell and select Pick Color. In the Color Picker dialog,
choose the new color.
5. Click OK.
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Unbinding a Project from Perforce
Use the following steps if you have previously connected your Flare project to Perforce but now
wish to unbind it (i.e., remove the connection).

HOW TO UNBIND A PROJECT FROM SOURCE CONTROL
1. Open the project.
2. Select the Project ribbon. In the Properties section select Project Properties. The Project
Properties dialog opens.
3. Select the Source Control tab.
4. Click Unbind Project.

HOW TO UNBIND A PROJECT FROM SOURCE CONTROL—SOURCE CONTROL
EXPLORER
1. Open the project.
2. Select the View ribbon. In the Explorer section select Source Control Explorer.
The Source Control Explorer opens.
3. From the drop-down or the Home pane, select Settings. The Settings pane opens.
4. Click Unbind. A confirmation dialog appears.
5. Click Yes.

IMPORTANT: If your project is dual-bound to MadCap Central and a third-party source control provider, unbinding the project from source control will also remove the binding to Central.
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Undeleting Source Control Files
If you have a file marked as "Deleted" but then want to add it to source control, you can undelete the
file, which then allows you to do this. You might encounter this situation if you rename a file and
then create a new file with that name, or if you rename a file to the name of a previously deleted file.

NOTE: You can only undelete files from Microsoft Team Foundation Server and Perforce.
When you delete files from other source control providers, they are removed from the
source control repository.

HOW TO UNDELETE A SOURCE CONTROL FILE
1. In one of the window panes (e.g., Content Explorer, Project Organizer, Pending Changes window pane), select the relevant file(s).
2. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the File section select Undelete.

n

Right-Click If you have the Content Explorer, Project Organizer, or Pending Changes window pane open, right-click the file you want to undelete and select Source Control >
Undelete.

3. The Undelete dialog opens. Select the files you want to undelete.
4. Click OK.
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Unlocking a File
If you have locked a file, you should unlock it when you are done modifying it. Other users can
modify the file while you have it locked, but they cannot submit a locked file until you unlock it. To
help prevent file conflicts and make sure that everyone on your team has the most current version
of the file, you should unlock and submit the file when you are finished working on it.
See "Locking a File" on page 61 for more information on locking files.

HOW TO UNLOCK A FILE
1. In one of the window panes (e.g., Content Explorer, Source Control Explorer, File List, Project
Organizer, Pending Changes window pane), select the relevant file(s).
OR
Open a file.
2. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the File section select Unlock.

n

Right-Click If you have the Content Explorer, Project Organizer, Pending Changes window pane, or File List open, right-click the files you want to unlock and select Source
Control > Unlock.

n

Source Control Explorer Right-click the files you want to unlock and select Unlock.

The Unlock dialog opens. The selected files are listed with check boxes next to them.
3. Make sure to click the check box next to each file you want to check in so that it contains a
check mark.
4. Click Unlock.
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Viewing Differences in Source Control Files
WAYS TO VIEW DIFFERENCES BETWEEN FILES
You can view differences between files in the following ways:
n

Two Versions of Same Source Control File (History/Roll Back) You can view code and content
differences between two source control versions of the same file. This is useful if you need to
roll back to an earlier version of a file.
EXAMPLE
Let's say that you have been working on a particular file for a few days. Each day
you check out the latest version of that file from source control, make your
changes, and check the file back in to source control at the end of the day. At a
certain point, you determine that you need to "roll back" to an earlier version of the
file, using it to replace the latest version. Therefore, you use this feature to view
the highlighted differences between the current version and an older version of
the file. Once you have identified the older version that you want to use, you can
perform a "get" of that version.

n

Local Versus Source Control Version of a File You can view code and content differences
between the local version of a file and the source control version of that file.
EXAMPLE
Let's say that you check out a procedure topic from source control and then add
some lines of text to your local copy of that topic file. You save your changes.
Later that day, you want to revisit the new content that you wrote, but you cannot
remember exactly which lines of text you added. Therefore, you use this feature to
highlight the text differences between your local version of the file and the version
stored in the source control application. The new lines of text are highlighted on
the side displaying the local version of the file.
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HOW TO VIEW DIFFERENCES BETWEEN TWO VERSIONS OF THE SAME SOURCE
CONTROL FILE
1. In one of the window panes (e.g., Content Explorer, Source Control Explorer, File List, Project
Organizer, Pending Changes window pane), select the relevant file(s).
2. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the File section select View History.

n

Right-Click If you have the Content Explorer, Project Organizer, Source Control Explorer,
Pending Changes window pane, or File List open, right-click the file(s) you want to view
and select Source Control > View History.

The History dialog opens.
3. From the list, select the first file version that you want to compare.
4. Hold the CTRL key and select the second file version from the list.
5. Select Show Differences.The Differences Editor opens.
6. (Optional) In the Differences Editor, use the buttons in the local toolbar to customize the
information shown in the editor.
7. When you are finished viewing the differences, close the window.

HOW TO VIEW DIFFERENCES BETWEEN THE LOCAL VERSION OF A FILE AND THE
SOURCE CONTROL VERSION
1. In one of the window panes (e.g., Content Explorer, Source Control Explorer, File List, Project
Organizer, Pending Changes window pane), select the relevant file(s).
2. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the File section select Show Differences.

n

Right-Click If you have the Content Explorer, Project Organizer, Source Control Explorer,
Pending Changes window pane, or File List open, right-click the file(s) you want to view
and select Source Control > Show Differences.

The Differences Editor opens.
3. (Optional) In the Differences Editor, use the buttons in the local toolbar to customize the
information shown in the editor.
4. When you are finished viewing the differences, close the window.
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Viewing Files that are Checked Out
You can use the Pending Changes window pane and the Source Control Explorer to view all of the
files that you have checked out and need to submit. You can use the File List window pane and
Pending Changes window pane to view files that are checked out by other users.

HOW TO VIEW FILES THAT YOU AND OTHERS HAVE CHECKED OUT—PENDING
CHANGES WINDOW PANE
1. Select the Source Control ribbon. In the Changes section select Pending Changes.
The Pending Changes window pane opens.
2. (Optional) You can use the Filter field to limit the files that are displayed.
n

All Files Displays all files.

n

Topic Files Displays only the topic (HTM and HTML) files.

n

Master Page Files Displays only the master page (FLMSP) files.

n

Page Layout Files Displays only the page layout (FLPGL) files.

n

Snippet Files Displays only the snippet (FLSNP) files.

n

Micro Content Files Displays only the master page (FLMCO) files.

n

Stylesheet Files Displays only the stylesheet (CSS) files.

n

Image Files Displays only the image files.

n

Multimedia Files Displays only multimedia (audio, video, and 3D model) files.

n

GIF Files Displays only GIF files.

n

JPEG Files Displays only JPG and JPEG files.

n

PNG Files Displays only PNG files.

n

Flash Movie Files Displays only SWF files.
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3. (Optional) You can use the following toggle buttons in the local toolbar to limit the files that
are displayed.
This filters the Pending Changes window pane to show or not show files that other
users have checked out.
This filters the Pending Changes window pane to show or not show files that are out
of date.
This filters the Pending Changes window pane to show or not show files that have
been deleted.
This filters the Pending Changes window pane to show or not show files that are
locked.
4. Take note of the Status and User columns. (You may need to use the scroll bar to view these
columns.)
n

Status Displays the status of the file, such as whether you have it checked out. You can
also see if another user has a file checked out.
l

l

l

l
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Checked Out This indicates that the file has been checked out from source control.
You can submit the file when you are ready (if you are the user who has checked it
out).
Pending Add This indicates that you have a file in your project but have not yet added
it to Perforce. This might occur, for example, if you create a new topic and do not
add the file to source control during the topic creation process. To resolve this,
simply right-click on the file and select Source Control > Add
Out of Date This indicates that the file is not current (i.e., the local copy of the file is
older than the source control copy). This might happen if another user checks out
the file, makes changes to it, and checks it back in to source control. If this occurs,
you can check the file out or get the latest version of the file from source control.
Locked This indicates that a file has been locked by you or another user.
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NOTE: You can click the refresh button
in the local toolbar to make sure you
have the most recent status for each file. Another option is that you can use a
feature to automatically ping the source control repository periodically, thus
refreshing this information frequently. However, you may experience slower performance with this automatic status update option set. See "Enabling Source
Control Status Checks" on page 60.

n

User Displays the user name. If you see the name of another user in this column, it
means that the file is checked out by that user through source control.
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HOW TO VIEW FILES THAT ARE CHECKED OUT BY OTHERS—FILE LIST WINDOW PANE
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the View ribbon. In the Explorer section select File List.

n

Keyboard Shortcut Press CTRL+SHIFT+J.

The File List window pane opens.
2. (Optional) You can use the Filter field to limit the files that are displayed.
n

All Files Displays all files.

n

Topic Files Displays only the topic (HTM and HTML) files.

n

Master Page Files Displays only the master page (FLMSP) files.

n

Page Layout Files Displays only the page layout (FLPGL) files.

n

Snippet Files Displays only the snippet (FLSNP) files.

n

Micro Content Files Displays only the master page (FLMCO) files.

n

Stylesheet Files Displays only the stylesheet (CSS) files.

n

Image Files Displays only the image files.

n

Multimedia Files Displays only multimedia (audio, video, and 3D model) files.

n

GIF Files Displays only GIF files.

n

JPEG Files Displays only JPG and JPEG files.

n

PNG Files Displays only PNG files.

n

Flash Movie Files Displays only SWF files.
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3. Take note of the Status and User columns. (You may need to use the scroll bar to view these
columns.)
n

Status Displays the status of the file, such as whether you have it checked out. You can
also see if another user has a file checked out.

NOTE: You can click the refresh button
in the local toolbar to make sure you
have the most recent status for each file. Another option is that you can use a
feature to automatically ping the source control repository periodically, thus
refreshing this information frequently. However, you may experience slower performance with this automatic status update option set. See "Enabling Source
Control Status Checks" on page 60.

n

User Displays the user name. If you see the name of another user in this column, it
means that the file is checked out by that user through source control.

HOW TO VIEW FILES THAT YOU HAVE CHECKED OUT—SOURCE CONTROL EXPLORER
1. Select the View ribbon. In the Explorer section select Source Control Explorer.
The Source Control Explorer opens.
2. From the drop-down or the Home pane, select Pending Changes.
The Pending Changes pane opens. Files that you have changed appear in the Included
Changes or Excluded Changes section (depending on whether you are going to include or
exclude them in your next submit; see "Submitting Source Control Files" on page 36).
3. Take note of the file's status. The status is written in brackets next to the file name (e.g., edit,
add).

NOTE: You can click the refresh button
in the local toolbar to make sure you have
the most recent status for each file. Another option is that you can use a feature to
automatically ping the source control repository periodically, thus refreshing this
information frequently. However, you may experience slower performance with this
automatic status update option set. See "Enabling Source Control Status Checks" on
page 60.
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Viewing the History of Source Control Files
One of the benefits of Flare's integrated source control is that you can view the history for a particular file, including who submitted the file and when it was submitted. You can also view differences between different versions of the file and roll back to an older version if necessary.
For more information see "Viewing Differences in Source Control Files" on page 75 and "Rolling Back
to an Earlier Version of a File" on page 64.

HOW TO VIEW THE HISTORY OF A SOURCE CONTROL FILE
1. In one of the window panes (e.g., Content Explorer, Source Control Explorer, File List, Project
Organizer, Pending Changes window pane), select the relevant file(s).
OR
Open a file.
2. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Source Control ribbon. In the File section select View History.

n

Right-Click If you have the Content Explorer, Project Organizer, Source Control Explorer,
Pending Changes window pane, or File List open, right-click the file(s) you want to view
and select Source Control > View History.Right-Click If you have the Source Control
Explorer or File List open, right-click the file(s) you want to view and select Source Control > View History.

3. The History dialog opens. The following are explanations of the different parts of this dialog.
n

Version Displays a number for each version of the file. The lower the number, the older
the version. The higher the number, the more recent the version.

n

Users Displays the name of the user who has been working on the file.

n

Date Displays the date and time when the action has occurred.

n

Action Displays the action that has taken place for the file (e.g., submit).

n

Comment Displays the comment (if any) associated with the file. A comment can be
added to a file when you submit that file to source control. This enables you to maintain
an audit trail for the file's history.

n

Get Selected Version Performs a "get" of a particular version of a file, thus rolling back to
that version of the file. The local version of the file is replaced with the source control version that you selected.
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n

Show Differences Opens a dialog that lets you view the differences between two versions of a file. If you select one row in the History dialog and view the differences, you will
see the content differences between the version that you selected and the version of the
file in your local copy of the Flare project. If you select two files in the History dialog (by
holding down the CTRL key) and view the differences, you will see the content differences between those two versions of the file.

4. In the History dialog, click Close.
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APPENDIX

PDFs
The following PDFs are available for download from the online Help.
TUTORIALS

Getting Started Tutorial
Product Foldout Tutorial
Side Navigation Tutorial
Top Navigation Tutorial
USER GUIDES

Accessibility Guide

HTML Help Guide

Analysis and Reports Guide

HTML5 Guide

Architecture Guide

Images Guide

Autonumbers Guide

Importing Guide

Condition Tags Guide

Index Guide

Context-sensitive Help Guide

Key Features Guide

Eclipse Help Guide

Language Support Guide

Getting Started Guide

MadCap Central Integration Guide

Global Project Linking Guide

Master Pages Guide
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Micro Content Guide

Source Control Guide: Git

Movies Guide

Source Control Guide: Perforce

Navigation Links Guide

Source Control Guide: Subversion

Plug-In API Guide

Source Control Guide: Team Foundation Server

Print-based Output Guide

Styles Guide

Project Creation Guide

Tables Guide

Pulse Guide

Tables of Contents Guide

QR Codes Guide

Targets Guide

Reports Guide

Templates Guide

Reviews & Contributions Guide

Topics Guide

Search Guide

Touring the Workspace Guide

SharePoint Guide

Transition From FrameMaker Guide

Skins Guide

Variables Guide

Snippets Guide

What's New Guide

CHEAT SHEETS

Folders and Files Cheat Sheet
Print Output Cheat Sheet
Shortcuts Cheat Sheet
Structure Bars Cheat Sheet
Styles Cheat Sheet
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