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CHAPTER 1

Introduction
When you create a project and add content (e.g., topics, snippets, stylesheets) or project-related elements (e.g., tables of contents, targets, skins) to it, you can use templates. A template is simply an
existing file or element of the same type that you are creating. By basing your addition on a template, you are giving yourself a head start because the template already contains some settings or
formatting for you.
In most cases, Flare provides you with one or more templates (called "factory templates"), so you do
not need to worry about coming up with your own. However, if you want, you can create your own
templates and use them when you create new projects or add new elements to a project. Templates can be especially useful when you are working on a team.
This chapter discusses the following:
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Example
The following example shows one way that you might make use of templates.

EXAMPLE
Let's say that you want to add a new target to a project. You already know that you
want your target to share most of the same settings as other targets that you've created in the past, with a few minor exceptions. So when you add the target, you can
base it on a target template that already contains all of the settings that are shared by
your many targets. That way, you do not have to specify all of those settings manually
in your new target. After the target is inserted into the project, you can adjust the new
target as necessary.

CHAPTER 1

6

Steps for Using Templates
Following are the main steps for using templates.
1. Create Template Folders The first step in using custom templates is to create a template
folder, by selecting a folder that already exists. The template folder is simply the place where
you will store your template files. You can have as many template folders as you need in order
to hold all of your template files. In addition to selecting a folder on your local drive, you can
also select a folder on a network, even on a SharePoint server (if you have previously connected to one). When you save a file (e.g., topic, page layout) as a new template and select a
template folder, the appropriate template subfolder is added to that folder (e.g., topic templates are stored in a subfolder called "Content"; page layout templates are stored in a subfolder called "PageLayouts"). As a result, those files become accessible as templates when
you create new features in Flare. Selecting a folder on a network is a great way to share template files with other Flare users. See "Creating Template Folders" on page 21.
2. Create Templates After creating a template folder, you can add one or more template files to
it. See "Creating Templates" on page 22.
What if the file being used as a template has links to other files (e.g., stylesheet, images)?
Flare does not remove those links. Therefore, you need to make sure those ancillary files are
also imported into the project. Depending on the type of file (e.g., an image), you might need
to make sure it is placed in the same location(s) relative to the file in question.
3. Select Templates Whenever you create new projects or add new elements (e.g., topics, page
layouts, targets) to a project, you select the factory or custom template that you want to use.
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EXAMPLE
Let's say you are working with a team of 10 other writers, and you want to create a
topic called "Welcome" that all authors should use in their projects. The template topic
will contain some standard text and headings. In addition, the topic links to a
stylesheet, which automatically gives the topic the appropriate look and feel. The idea
is the authors will create a "Welcome" topic in each of their projects, adding more content to that topic as needed; all "Welcome" topics should be consistent and look the
same in all projects.
To accomplish this, you first open a Flare project and create the topic. It might look
something like this:
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Now you need to make sure that you have a template folder ready to hold the new template file. Therefore, you select the Tools ribbon. In the Templates section you click
Manage Templates. This opens the Template Manager.
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In the dialog that opens, you find and select the folder where you want to store the template file.
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After closing the Template Manager, you make sure your new topic is still open. Then
you select File > Save > Save As Template. In the dialog that opens, you select the new
template folder and click OK.
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Now let's say that Karen, one of the other authors, wants to create a "Welcome" topic
for a new project she is working on. In her Flare project, she selects Project > New >
Topic. In the dialog that opens, she selects the template file you created, chooses a location (in the following example, the root folder), and provides a name for the new file.
Then she clicks Add.
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The new topic is added to the Karen's project. In order for her topic to look just like your
topic, she needs to add the same stylesheet file to her project. This can be done by
simply importing that file or maybe through Global Project Linking.
Once Karen brings the stylesheet file into her project, she can associate it at the project, target, or topic level. Let's say she sets it at the project level (in the Project Properties dialog, which is opened by selecting Project > Project Properties). After doing
this, her topic will look just like yours, and she can begin adding content to it.
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Managing Templates
In addition to the main steps for using templates, you can manage templates in the Template Manager dialog. This dialog can be opened from the Tools ribbon or menu, by clicking the Manage Templates button
that can be found in a variety of template-related dialogs (such as the Save As
Template dialog). The Template Manager lets you do the following.
n

Add template files

n

Create template folders

n

Open templates to edit them

n

Delete templates

n

Edit template descriptions.

See "Managing Templates" on page 29.
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Contribution Templates
Authors, developers, or other individuals in your company can use MadCap Contributor to create
new documents and files, which can be incorporated into your Flare project. These documents can
also be exported to PDF output.
In order to accommodate and assist the contribution process, you can create contribution templates for other individuals to use. These templates are topic files that can be crafted to already
have certain pieces in place (e.g., text, formatting, locked regions) and make certain ancillary files
available (e.g., variables, condition tags, stylesheets) to the contributor. After using the template to
create a new document in Contributor, the contributor can send it to you, and you can then make
the document part of your project. For more information, see the online Help and the Reviews and
Contributions Guide.
Following are basic tasks that you may perform when using contribution templates.
n

"Creating and Sending Contribution Templates" on page 32

n

"Sending Contribution Templates" on page 35

n

"Viewing Contribution Templates" on page 36
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Exporting Projects to Templates
When exporting a project, you can select an option that saves those files to your templates folder
(e.g., Documents\My Templates\Projects). By being placed in this location, the project files
become available as a template selection when you create a new project.For more information, see
the online Help and the Project Creation Guide.

FLARE'S FACTORY PROJECT TEMPLATES
You can choose from Flare's many factory project templates when creating a new project.
Flare's factory templates are organized into the following folders:
n

Online These templates were designed for online output only.

n

Online & Print These templates were designed to generate both online and print-based outputs from the same content.

n

Print These templates were designed for print-based output only.

n

Tutorials This folder contains a template that is intended to be used with the Getting Started
Tutorial, which guides you in the creation and development of a project.

ONLINE TEMPLATES
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Template
Knowledge
Base

Side Navigation

Top Navigation

Tripane

Characteristics
n

Contains starter topics and other files designed for an online knowledge base
in HTML5 format. If you intend to use Flare to generate an online knowledge
base, this project demonstrates one approach you may consider.

n

Includes responsive output, which means the content display changes automatically depending on the width of the screen.

n

Contains starter topics and other files intended for online HTML5 output that
looks like a modern website with navigation on the side (left or right).

n

Offers a frameless, modern alternative to the more traditional tripane format.

n

Includes responsive output, which means the content display changes automatically depending on the width of the screen.

n

Contains starter topics and other files intended for online HTML5 output that
looks like a modern website with navigation on the top.

n

Offers a frameless, modern alternative to the more traditional tripane format.

n

Includes responsive output, which means the content display changes automatically depending on the width of the screen.

n

Contains starter topics and other files intended for online HTML5 output in a
traditional tripane format (navigation pane, toolbar pane, content pane).

n

Includes responsive output, which means the content display changes automatically depending on the width of the screen.

ONLINE AND PRINT TEMPLATES

CHAPTER 1

17

Template
Side Navigation
and PDF

Top Navigation
and PDF

Tripane
and PDF

Characteristics
n

Contains starter topics and other files intended for both online and print-based
output.

n

The online HTML5 output looks like a modern website with navigation on the
side (left or right). Offers a frameless, modern alternative to the more traditional tripane format. Includes responsive output, which means the content
display changes automatically depending on the width of the screen.

n

The PDF output is a user guide that includes auto-generation of a TOC, glossary, and index.

n

Contains starter topics and other files intended for both online and print-based
output.

n

The online HTML5 output looks like a modern website with navigation on the
top. Offers a frameless, modern alternative to the more traditional tripane
format. Includes responsive output, which means the content display changes
automatically depending on the width of the screen.

n

The PDF output is a user guide that includes auto-generation of a TOC, glossary, and index.

n

Contains starter topics and other files intended for both online and print-based
output.

n

The online HTML5 output uses a traditional tripane format (navigation pane,
toolbar pane, content pane). Includes responsive output, which means the content display changes automatically depending on the width of the screen.

n

The PDF output is a user guide that includes auto-generation of a TOC, glossary, and index.

PRINT TEMPLATES
Template
Brochure
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Characteristics
n

Contains two topics and two page layouts designed to create a brochure
with three panes.
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Template

Characteristics

Policies and Procedures

Product Foldout

User Guide

n

Contains starter topics and other files designed to produce a policies
and procedures manual in PDF format.

n

Includes content and variables that you can re-use.

n

Includes auto-generation of a TOC and index.

n

Contains two topics and two page layouts designed to create a fourpane PDF product foldout.

n

Ideal for brief product instructions.

n

Contains starter topics and other files designed to produce a user guide
in PDF format.

n

Includes auto-generation of a TOC, glossary, and index.

TUTORIAL TEMPLATE
Template
San
Diego
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Characteristics
n

Designed to be used alongside self-paced Getting Started tutorial.

n

Tutorial gives you hands-on experience in Flare, guiding you in the basic steps
for creating, developing, and building output.

n

End result is a PDF guide and online HTML5 output with top navigation like a
modern website, instead of the more traditional tripane format.
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DOWNLOADING ADDITIONAL PROJECT TEMPLATES
If you want to use one of the many other templates available from the MadCap Software website
(including older ones that once were available in this wizard), you can click a new link to browse the
templates and download them.

After downloading a project template, you can unzip it and save it to a location on your computer.
Then, next to New from existing, click
and select that project’s main .flprj file.
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CHAPTER 2

Creating Template Folders
The first step in using custom templates is to create a template folder, simply by selecting a folder
that already exists. The template folder is simply the place where you will store your template files.
You can have as many template folders as you need in order to hold all of your template files.
In addition to selecting a folder on your local drive, you can also select a folder on a network, even on
a SharePoint server (if you have previously connected to one). When you save a file (e.g., topic,
page layout) as a new template and select a template folder, the appropriate template subfolder is
added to that folder (e.g., topic templates are stored in a subfolder called "Content"; page layout
templates are stored in a subfolder called "PageLayouts"). As a result, those files become accessible as templates when you create new features in Flare. Selecting a folder on a network is a great
way to share template files with other Flare users.

HOW TO CREATE A TEMPLATE FOLDER
1. Select the Tools ribbon. In the Templates section select Manage Templates. The Template
Manager opens.
2. Click

.

3. In the Select dialog, find and select the folder where you want to store template files.
4. After you have selected the folder, click OK.
5. In the Template Manager, click Close.
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CHAPTER 3

Creating Templates
After creating a template folder, you can add one or more template files to it. A template is simply
an existing file or element of the same type that you are creating (e.g., a project, topic file, target
file, snippet file).
You can create templates of entire projects or individual files within a project. There are two ways
to create a template from an individual file: (1) with the file open and (2) from the Template Manager.
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HOW TO CREATE A TEMPLATE OF AN ENTIRE PROJECT
1. Create a project, adding all of the content, elements, and settings that you want to be part of
the project.
2. Select the Project ribbon. In the Save section select Save Project As Template. The Save Project As Template Wizard opens.
3. In the Template Folder section, select the folder where you want to store the template files.
4. The Template Name field, enter a name for the new template.

5. Click Next.
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6. On the next page of the wizard, make sure a check mark is next to each content folder or file
that you want to include in the project template. By default, all of the boxes are checked, but
you can click in any of the boxes to remove the check marks if necessary.

7. Click Next.
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8. On the next page of the wizard, make sure a check mark is next to each project folder or file
that you want to include in the project template. By default, all of the boxes are checked, but
you can click in any of the boxes to remove the check marks if necessary.

9. Click Finish.
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HOW TO CREATE A FILE TEMPLATE—WITH THE FILE OPEN
1. In Flare create the element (e.g., topic, target, skin, master page ) that you want to use as a
template.
2. Add content or settings to the element as you normally would. When you use the template to
create more elements in the future, those new elements will start out with the same content
or settings as your template file.
3. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select File > Save > Save As Template.

n

Tool Strip Select File > Save As Template.

The Save As Template dialog opens.
4. In the Template Folder section, select the folder where you want to store the template file.
5. The Template Name field, enter a name for the new template.

6. Click OK.
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HOW TO CREATE A FILE TEMPLATE—FROM THE TEMPLATE MANAGER
1. In Flare create the element (e.g., topic, target, skin, master page) that you want to use as a
template.
2. Add content or settings to the element as you normally would. When you use the template to
create more elements in the future, those new elements will start out with the same content
or settings as your template file.
3. Click

to save your work.

4. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Tools ribbon. In the Templates section select Manage Templates.

n

Tool Strip Select Tools > Manage Templates.

The Template Manager opens.
5. In the built-in tree, find and select the folder where you want to store the template file.
6. Click

.

7. In the dialog that opens, find and double-click the file that you want to add as a template.
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8. In the Save As Template dialog click OK.
9. In the Template Manager dialog click Close.
After you create a template, you can select it whenever you create a new element of the same type
(e.g., you can select a topic template when creating a new topic).
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CHAPTER 4

Managing Templates
You can manage your template files from within the Template Manager dialog. This dialog can be
opened from the Tools ribbon or menu, by clicking the Manage Templates button
that can be
found in a variety of template-related dialogs (such as the Save As Template dialog).
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Following are the primary tasks that can be accomplished in the Template Manager dialog.
n

Add Template Files You can add files to any of your existing template folders. Therefore,
those files become available as templates when you create new features in Flare. See "Creating Templates" on page 22. To add a template file in the Template Manager, select the folder
where you want it to be stored and then click

n

.

Create Template Folders You can find and select an existing folder on your local drive or on a
network, even on a SharePoint server (if you have previously connected to one). When you
save a file (e.g., topic, page layout) as a new template and select a template folder, the appropriate template subfolder is added to that folder (e.g., topic templates are stored in a subfolder called "Content"; page layout templates are stored in a subfolder called "PageLayouts").
As a result, those files become accessible as templates when you create new features in
Flare. This is a great way to share template files with other Flare users on your network. See
"Creating Template Folders" on page 21. To create a template folder in the Template Manager, click

.

n

Open/Edit Template Files If you want to open a template file to make changes to it, you can
double-click it in the Template Manager. You can also right-click the file and select
Open.When you open a template file, it opens in the appropriate editor, just as a regular file
would open. However, the following message displays at the top of the editor to let you know
that the file you are modifying is a template file that is not located in the current project:

n

Delete Template Folders and Files If you no longer want certain template folders or files, you
can select it in the Template Manager and press Delete.

n

Edit Template Descriptions Many template files can include a template description, which is
shown when you work in the Template Manager or if you select the template when creating a
feature in Flare. In the Template Manager, you can edit the description for any XML template
files, except XHTML files. For example, you can edit descriptions for target, skin, TOC, and destination template files, but you cannot edit descriptions for topics, snippets, stylesheets,
images, and multimedia files. You might find this feature useful if you are working with a team
of writers and need a good description of each template; therefore, each author will easily
know the purpose of the template. To create or edit the description for a template in the Template Manager, first select the template file in the built-in tree and then click
description for the template and click OK.
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CHAPTER 5

Contribution Templates
In order to accommodate and assist the contribution process, you can create contribution templates for other individuals to use. These templates are topic files that can be crafted to already
have certain pieces in place (e.g., text, formatting, locked regions) and make certain ancillary files
available (e.g., variables, condition tags, stylesheets) to the contributor. After using the template to
create a new document in Contributor, the contributor can send it to you, and you can then make
the document part of your project.
This chapter discusses the following:
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Creating and Sending Contribution Templates
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Sending Contribution Templates

35

Viewing Contribution Templates
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Creating and Sending Contribution
Templates
Following are steps for creating and sending a contribution template.

HOW TO CREATE AND SEND CONTRIBUTION TEMPLATES
1. Create a topic or open an existing one, and add any content that you want to be part of the
ready-made template for contributors (e.g., text, images).
2. (Optional) If there are parts of the topic that you do not want contributors to modify, apply
locks to those areas. For more information see the online Help.
3. Select File > Save > Save As Contribution Template.
The Save Topic as Contribution Template Wizard opens.
4. In the Template Name field, enter a name for the new template.
and select a location to store a copy of the new template file, which uses
5. (Optional) Click
an .mccot extension.
The default location is Documents/My Contribution Templates. This is the location used if
you do not select one.
NOTE: Depending on your operating system, the folder may be called "My Documents" instead of "Documents."
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6. Click Next. All of the content support folders and files are shown, and those that are relevant
to the topic are already selected. For example, if the topic has an image and a table using a
special table stylsheet, those files are selected in the wizard so that they can be included in
the template package. If those support files were not included, the contributor would not be
able to see the topic in the same way that you are able to. You can also click other check
boxes to include additional files if you like. However, you cannot add other topic files.
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7. Click Next. This is just like the previous page, except it shows project folders and files, with relevant ones already selected. You can click other check boxes to include additional files if you
like.

8. Click Finish. The Template Created dialog opens.
9. If you want to immediately send the new template to a contributor, click Yes. A new email
message is automatically created with the template file attached.
10. Send the email.
After contributors make changes to the file and return it, you can double-click on the MCCO file that
they send, bring it into your project, and accept it, thus making it part of your project.
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Sending Contribution Templates
Use the following steps to send a contribution template that you have already created. If you have
not yet created the template, see "Creating and Sending Contribution Templates" on page 32.

HOW TO SEND CONTRIBUTION TEMPLATES
1. Select the View ribbon. In the Resources section select Contributions.
The Contributions window pane opens.
2. Click in the drop-down field at the top of the window pane, select Templates. All contribution
templates that you have created are listed in the pane.
3. Click on the template that you want to send.
4. In the local toolbar click

. The Send Contribution Template dialog opens.

5. (Optional) You can click in the Message area and edit the default text that will be shown in the
main body of the email sent to the contributors.
6. If you do not have an email address in the list, click
in the New Address Book Entry dialog and click Add.

. Complete the fields

7. Once an email address is added to the list, click the Send check box next to the addresses
that you want to include in the email.
8. Click Send.
9. Send the email.
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Viewing Contribution Templates
You can quickly see a list of all contribution templates that you have created. From the list, you can
open any of the templates or send them to contributors so that they can use them when creating
documents in Contributor.

HOW TO VIEW CONTRIBUTION TEMPLATES
1. Select the View ribbon. In the Resources section select Contributions.
The Contributions window pane opens.
2. Click in the drop-down field at the top of the window pane, select Templates. All contribution
templates that you have created and saved in the Contribution Templates folder are listed in
the pane. See "Contribution Templates" on page 31.
From the Contributions window pane, you can select a template in the list and click any of the following buttons in the local toolbar to take action on it
Refreshes the window pane so that the latest information is shown.
Deletes the selection.
Opens the contribution template (MCCOT file) in the Topic Template Editor.
Opens the Send Contribution Template dialog, which lets you send the template to
your contributors. See "Sending Contribution Templates" on the previous page.
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APPENDIX

PDFs
The following PDFs are available for download from the online Help.
TUTORIALS

Getting Started Tutorial
Product Foldout Tutorial
Side Navigation Tutorial
Top Navigation Tutorial
USER GUIDES

Accessibility Guide

HTML Help Guide

Analysis and Reports Guide

HTML5 Guide

Architecture Guide

Images Guide

Autonumbers Guide

Importing Guide

Condition Tags Guide

Index Guide

Context-sensitive Help Guide

Key Features Guide

Eclipse Help Guide

Language Support Guide

Getting Started Guide

MadCap Central Integration Guide

Global Project Linking Guide

Master Pages Guide
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Micro Content Guide

Source Control Guide: Git

Movies Guide

Source Control Guide: Perforce

Navigation Links Guide

Source Control Guide: Subversion

Plug-In API Guide

Source Control Guide: Team Foundation Server

Print-based Output Guide

Styles Guide

Project Creation Guide

Tables Guide

Pulse Guide

Tables of Contents Guide

QR Codes Guide

Targets Guide

Reports Guide

Templates Guide

Reviews & Contributions Guide

Topics Guide

Search Guide

Touring the Workspace Guide

SharePoint Guide

Transition From FrameMaker Guide

Skins Guide

Variables Guide

Snippets Guide

What's New Guide

CHEAT SHEETS

Folders and Files Cheat Sheet
Print Output Cheat Sheet
Shortcuts Cheat Sheet
Structure Bars Cheat Sheet
Styles Cheat Sheet

APPENDIX

38

