Plug-In API
CONTENTS

CHAPTER 1
Introduction .............................................................................................................. 4

CHAPTER 2
Interfaces and Enumerations .............................................................................. 11
   IPlugin Interface ................................................................................................. 12
   IHost Interface ................................................................................................... 13

CHAPTER 3
Examples ............................................................................................................ 31
   Context Menu Example ....................................................................................... 32
   Controlled Language Example ............................................................................ 33
   Ribbon Example .................................................................................................. 37
   Search and Change Text Style Example ............................................................ 40
   Toolbar Example ................................................................................................. 41

APPENDIX
PDFs ......................................................................................................................... 43
Introduction

The MadCap Software plug-in API lets you integrate Flare with DLLs that you produce. For example, you might want to add customized ribbons, menus, or toolbar buttons to Flare.

Most of the information provided regarding the plug-in API is intended for developers or those who are quite familiar with APIs and DLLs.

WHAT YOU NEED

Here is what you need before you begin:

- Latest build of MadCap Flare
- B3.PluginAPIKit.dll
- Visual Studio 2010 or later
HOW TO CREATE A PLUG-IN

1. In Visual Studio, create a new Class Library project.
2. In the new project dialog, select .Net Framework 4.0.
3. Add a library reference to the B3.PluginAPIKit.dll assembly.
4. Implement the IPlugin interface. See "IPlugin Interface" on page 12.

⭐ EXAMPLE

Following is a basic example where the function of the plugin is to simply show a message box whenever the plugin is activated or deactivated.

```csharp
using System;
using System.Windows.Forms;
using B3.PluginAPIKit;
namespace DemoPlugin
{
    public class DemoPlugin : IPlugin
    {
        private IHost mHost;
        private bool mActivated;
        public bool IsActivated
        {
            get { return mActivated; }
        }
        public string GetVersion()
        {
            return "1.0";
        }
        public string GetAuthor()
        {
            return "Bob Smith";
        }
        public string GetDescription()
        {
            return "Displays a message box.";
        }
    }
}
```
```csharp
public string GetName()
{
    return "DemoPlugin";
}
public void Initialize(IHost host)
{
    mHost = host;
}
public void Execute()
{
    mActivated = true;
    MessageBox.Show(GetName() + " activated!");
}
public void Stop()
{
    MessageBox.Show(GetName() + " deactivated!");
mHost.Dispose();
mActivated = false;
}
```
HOW TO INTEGRATE A PLUGIN INTO FLARE

Flare monitors the Plugins folder under its root application directory. Any valid plug-in detected inside the Plugins folder will be listed on the Plugins tab of the Options dialog in Flare.

1. Make sure Flare is not open.

2. In Windows navigate to the Flare.app\Plugins folder where you have installed Flare (e.g., C:\Program Files\MadCap Software\MadCap Flare15\Flare.app\Plugins).

3. Within the Plugins directory, create a new folder named after your plugin. For the example above, the plugin directory is named “DemoPlugin.”

4. Add your built plug-in assemblies and resource files into that directory. The directory hierarchy should look as follows:

```
Flare.App
    Plugins
        DemoPlugin
            Plugin Assemblies + Resource Files
```
HOW TO ENABLE THE PLUG-IN WITHIN FLARE

1. Launch Flare.
2. Select File > Options. The Options dialog opens.
3. Select the Plugins tab. You should see a row that represents your DLL.
4. Click Enable.

**NOTE** You can also use the Plugins tab in the Options dialog (File > Options) to disable a plugin.

5. Restart Flare.
INTERFACES AND ENUMERATIONS

For more details on the interfaces and enumerations with the plug-in API, see the following:

- "IPlugin Interface" on page 12
- "IHost Interface" on page 13
  - "IEditorContext Interface" on page 14
    - "IDocument Interface" on page 15
    - "ISelection Interface" on page 18
    - "EditorView Enumeration" on page 19
  - "INavContext Interface" on page 20
    - "ICustomToolBar Interface" on page 21
    - "IToolStripMenuItem Interface" on page 22
    - "IRibbon Interface" on page 23
    - "IRibbonControlData Interface" on page 24
    - "IRibbonMenuData Interface" on page 25
    - "IRibbonTab Interface" on page 25
    - "IRibbonGroup Interface" on page 26
    - "IRibbonComboBox Interface" on page 28
    - "IRibbonMenu Interface" on page 29
    - "RibbonIconSize Enumeration" on page 30

EXAMPLES

For examples of creating and working with the plug-in API, see the following:

- "ContextMenu Example" on page 32
- "Controlled Language Example" on page 33
- "Ribbon Example" on page 37
- "Search and Change Text Style Example" on page 40
- "Toolbar Example" on page 41
BEST PRACTICES/GUIDELINES

Following are some best practices and guidelines to keep in mind as you work with the plug-in API.

TARGET FRAMEWORK

- Currently, the Flare API framework only supports libraries targeted to .NET Framework 4.0.

INITIALIZATION

- `IPlugin.Initialize(IHost)` should only be used to set the instance of `IHost` passed in to a class variable.
- Calls to obtain the editor or navigation context should be done in `IPlugin.Execute()`.

CLEANING UP

- Events should be properly detached.
- Changes made to the UI should be reverted back to its original state (e.g., ribbon, context menus, tool strip).
- `IHost.Dispose()` should be called in `IPlugin.Stop()`. This will dispose of most of the menu bar items and ribbon items added.
- The `IPlugin.IsActivated` property should be set to `false`.

REFERENCES

- The working directory is the base application directory. If you are passing in a URL to any of the interface methods, relative paths are relative to the “Plugins” directory. For example, "DemoPlugin/Icons/Filter.png" maps to:
  
  C:/<Flare Install Path>/Flare.app/Plugins/DemoPlugin/Icons/Filter.png.
CHAPTER 2

Interfaces and Enumerations

There are several interfaces and enumerations involved with the plug-in API.

This chapter discusses the following:

IPlugin Interface .................................................................12
IHost Interface ...............................................................13
IPlugin Interface

The IPlugin interface represents the plug-in. For the plug-in assembly to be considered valid, it must implement the IPlugin interface.

PROPERTIES

- bool IsActivated Gets a value indicating whether the plug-in is activated or not.

METHODS

- void Execute() Activates the plug-in. This method is called when users click Enable on the Plugins tab of the Options dialog (File > Options).
- string GetAuthor() Returns the author of the plug-in.
- string GetDescription() Returns the description of the plug-in.
- string GetName() Returns the name of the plug-in.
- string GetVersion() Returns the version of the plug-in.
- void Initialize(IHost) Initializes the plug-in. An instance of IHost is passed in as a parameter, which gives users access to Flare components. See "IHost Interface" on the next page.
- void Stop() Deactivates the plug-in. This method is called when users click Disable on the Plugins tab of the Options dialog (File > Options).
IHost Interface

The IHost interface represents the host application. An instance of IHost is be passed in as a parameter to the Initialize() method in the IPlugin interface. See "IPlugin Interface" on the previous page.

METHODS

- `string GetCompany()` Returns the name of the company.
- `IEditorContext GetEditorContext()` Returns the active IEditorContext object. See "IEditorContext Interface" on the next page.
- `string GetName()` Returns the name of the active application.
- `INavContext GetNavContext()` Returns the active INavContext object. See "INavContext Interface" on page 20.
- `void Dispose()` Cleans up the instance of IHost after usage. This must be called whenever the plug-in is disabled.
IEditorContext Interface

An instance of IEditorContext is returned using the GetEditorContext() method in the IHost interface (see "IHost Interface" on the previous page). IEditorContext gives access to opened Flare documents in the editor.

EVENTS

- **DocumentSwitched** Occurs when the active document changes.

METHODS

- **IDocument GetActiveDocument()** Returns the currently active IDocument. See "IDocument Interface" on the next page.
- **IEnumerable<IDocument> GetDocuments()** Returns a System.Collections.IEnumerable containing all the IDocument(s) currently open. See "IDocument Interface" on the next page.
- **IDocument OpenDocument(string)** Opens the given file path and returns the associated IDocument. See "IDocument Interface" on the next page.
- **IDocument OpenDocument(string, EditorView)** Opens the given file path in the EditorView passed in and returns the associated IDocument. See "EditorView Enumeration" on page 19 and "IDocument Interface" on the next page.
**IDocument Interface**

The IDocument interface provides access to components associated with an editor document.

**PROPERTIES**

- **EditorView CurrentEditorView** Gets the current EditorView in focus. See "EditorView Enumeration" on page 19.
- **bool EnableLocks** Gets and sets whether locks are enabled in the current document.
- **ISelection Selection** Gets the ISelection of the currently selected text. See "ISelection Interface" on page 18.
- **bool ShowChanges** Gets and sets whether changes are shown in the current document.
- **bool ShowLocks** Gets and sets whether locks are shown in the current document.

**EVENTS**

- **CheckingIn** Occurs when the editor document checks in to source control.
- **Closing** Occurs when the editor document is closing.
- **CurrentEditorViewChanged** Occurs when the editor view switches focus.
- **EnableLocksChanged** Occurs when the editor document EnableLocks property changes.
- **KeyDown** Occurs when a key is pressed down while the editor document has focus.
- **KeyUp** Occurs when a key is released while the editor document has focus.
- **MouseClick** Occurs when the editor document is clicked by the mouse.
- **MouseDoubleClick** Occurs when the editor document is double-clicked by the mouse.
- **MouseHover** Occurs when the editor document is hovered over by the mouse.
- **MouseMove** Occurs when the mouse moves over the editor document.
- **OnContentChanged** Occurs when content is changed in the editor document.
- **PreviewKeyDown** Occurs before the KeyDown event when a key is pressed while the document has focus.
- **Printing** Occurs when the Print or Print Preview command is invoked before the document prints.
- **Saved** Occurs when the editor document saves.
- **SavedAs** Occurs when the editor document runs the "Save As" command.
- **Saving** Occurs before the editor document saves.
- **Savings** Occurs before the editor document runs the "Save As" command.
- **ShowChangesChanged** Occurs when the editor document ShowChanges property changes.
- **ShowLocksChanged** Occurs when the editor document ShowLocks property changes.

**METHODS**

- `bool ApplyStylesheet(string)` Adds the referenced CSS stylesheet to the working list of styles. Paths may be absolute or relative.
- `void Close()` Closes the document.
- `void EndOperation()` Ends the current operation.
- `int GetCursorPosition()` Returns the linear position of the insertion point. The initial position starts from 0.
- `string GetDocumentText()` Returns the document text.
- `string GetDocumentXml()` Returns the xml of the document as text.
- `string GetSourceUrl()` Returns the url of the editor document.
- `List<ToolStripItem> GetUserPendingContextMenuItems()` Returns the list of `System.Windows.Forms.ToolStripItems` that are pending to be added to the context menu.
- `void InsertDocumentNode(XmlNode, XmlNode, int, bool)` Inserts a new `System.Xml.XmlNode` as a child under the referenced parent node in the DOM. The last boolean parameter determines whether this operation will be reflected in the Flare Track Change system.
- `void LookupVariableValue(string, string)` Returns the value of the given variable set and name.
- `void RemoveDocumentNode(XmlNode, bool)` Removes an existing `System.Xml.XmlNode` from the DOM. The last boolean parameter determines whether this operation will be reflected in the Flare Track Change system.
- `bool RemoveStylesheet(string)` Removes the referenced CSS stylesheet to the working list of styles. Paths may be absolute or relative.
- `void ReplaceDocumentNode(XmlNode, XmlNode, bool)` Replaces an existing `System.Xml.XmlNode` with a new node in the DOM. The last boolean parameter determines whether this operation will be reflected in the Flare Track Change system.
- `bool Save()` Saves the current document. Returns bool indicating success of the operation.
- `void Select(string)` Selects the first instance of text matching the search string after the current position of the insertion point.
- `void Select(XmlNode)` Selects the matching `System.Xml XmlNode`.
- `void SetCursorPosition(int)` Sets the position of the insertion point to the specified value.
- `void StartOperation(string)` Starts a new operation. All changes within a StartOperation and EndOperation call will be bundled into one undoable operation in Flare's undo/redo stack.
- `void UpdateView()` Refreshes the document.
ISelection Interface

The ISelection interface provides functionality to edit the document selection.

PROPERTIES

- **bool IsBold** Gets the value indicating whether the selection is bold.
- **bool IsItalic** Gets the value indicating whether the selection is italic.
- **bool IsUnderlined** Gets the value indicating whether the selection is underlined.
- **bool TrackChange** Gets and sets the value indicating if ISelection operations are tracked.

METHODS

- **bool Bold()** Bolds the selection.
- **bool ChangeBackColor(Color)** Changes the background of the selection to the specified `System.Drawing.Color`.
- **bool ChangeFontFamily(string)** Changes the font family of the selection to the specified value.
- **bool ChangeFontSize(float)** Changes the font size of the selection to the specified value.
- **bool ChangeForeColor(Color)** Changes the foreground color of the selection to the specified `System.Drawing.Color`.
- **bool FormatStyle(string)** Changes the span style of the selection to the specified CSS class and/or ID.
- **Color GetBackColor()** Returns the `System.Drawing.Color` of the background.
- **string GetFontFamily()** Returns the font family of the selection.
- **float GetFontSize()** Returns the font size of the selection.
- **Color GetForeColor()** Returns the `System.Drawing.Color` of the foreground.
- **string GetStyle()** Returns the CSS class and/or ID of the selection.
- **string GetText()** Returns the selected text.
- **IList<XmlNode> GetXmlNodeList()** Returns a list of `System.Xml.XmlNode(s)` that the selection is a part of.
- **bool Italicize()** Italicizes the selection.
- `bool RemoveFormatStyle(string)` Removes the specified span style/class of the selection. If the specified argument is null, all inline formatting is removed from the selection.

- `bool ReplaceText(string)` Replaces the selected text with the specified text.

- `void SetSelectionLength(int)` Sets the length of the selection to the specified value.

- `bool Underline()` Underlines the selection.

EditorView Enumeration

The `EditorView` enum defines constants, which indicate the type of editor views.

MEMBERS

- Text Text Editor view.

- Xml Xml Editor view.
INavContext Interface

An instance of INavContext is returned using the GetNavContext() method in the IHost interface (see "IHost Interface" on page 13). INavContext gives access to the navigational user interface components of Flare.

METHODS

- **Form GetParentForm()** Returns the parent `System.Windows.Form`. To be used as a reference control for child windows.

- **ICustomToolBar CreateCustomToolBar(string)** Creates an instance of ICustomToolBar. See "ICustomToolBar Interface" on the next page.

- **IToolStripMenuItem CreateToolStripMenu(string, string)** Creates an instance of IToolStripMenuItem to be added to the Tool Strip menu. See "IToolStripMenuItem Interface" on page 22.

- **IRibbon GetRibbon()** Returns the current IRibbon object. See "IRibbon Interface" on page 23.
ICustomToolBar Interface

The ICustomToolBar interface lets you build a custom toolbar to be added to the Tool Strip user interface in Flare.

METHODS

- **Button** `AddButton(string, ICommand, object, string, RibbonIconSize, string, string, string)` Adds a button to the toolbar. Returns an instance of `System.Windows.Controls.Button`.
- **IRibbonComboBox** `AddComboBox(string, ICommand, object, string, RibbonIconSize, string, string, string)` Adds a combo box to the toolbar. Returns an instance of `IRibbonComboBox`. See "IRibbonComboBox Interface" on page 28.
- **IRibbonComboBox** `AddComboBox(IRibbonMenuData)` Adds a combo box to the toolbar. Returns an instance of `IRibbonComboBox`. See "IRibbonComboBox Interface" on page 28.
- **IRibbonMenu** `AddMenuButton(string, string, RibbonIconSize, string, string, string)` Adds a menu button to the toolbar. Returns an instance of `IRibbonMenu`. See "IRibbonMenu Interface" on page 29.
- **IRibbonMenu** `AddMenuButton(IRibbonMenuData)` Adds a menu button to the toolbar. Returns an instance of `IRibbonMenu`. See "IRibbonMenu Interface" on page 29.
- **void** `AddSeparator()` Adds a separator to the toolbar.
- **IRibbonMenu** `AddSplitMenuButton(string, ICommand, object, string, RibbonIconSize, string, string, string)` Adds a split menu button to the toolbar. Returns an instance of `IRibbonMenu`. See "IRibbonMenu Interface" on page 29.
- **IRibbonMenu** `AddSplitMenuButton(IRibbonMenuData)` Adds a split menu button to the toolbar. Returns an instance of `IRibbonMenu`. See "IRibbonMenu Interface" on page 29.

**NOTE** The custom toolbar is only visible when the Flare interface is in "Tool Strip" mode.
IToolStripMenuItem Interface

The IToolStripMenuItem interface lets you build a custom Tool Strip menu to be added to Flare’s Tool Strip user interface.

METHODS

- IToolStripMenuStrip AddMenuItem(string, ICommand, object, string, RibbonIconSize, string, string) Adds a menu item to the menu. Returns an instance of IToolStripMenuItem.

- IToolStripMenuStrip AddMenuItem(IRibbonMenuData) Adds a menu item to the menu. Returns an instance of IToolStripMenuItem.

- void AddSeparator() Adds a separator to the menu.
IRibbon Interface

The I.Ribbon interface provides the starting point to add custom elements to the application ribbon user interface.

PROPERTIES

- `bool IsCollapsed` Gets the value indicating whether the ribbon is collapsed.

METHODS

- `IRibbonTab AddNewRibbonTab(string, string)` Adds a new tab to the ribbon. Returns an instance of IRibbonTab. See "IRibbonTab Interface" on page 25.
IRibbonControlData Interface

The IIRibbonControlData interface gives users an object template for data binding to ribbon controls.

PROPERTIES

- bool CanAddToQuickAccessToolBarDirectly Gets and sets a value that indicates whether this control can be added directly to the Quick Access toolbar.
- ICommand Command Gets and sets the command to execute.
- string Font Gets and sets the font.
- bool IsChecked Gets and sets a value that indicates whether this control is checked.
- string KeyTip Gets and sets the key tip value.
- string Label Gets and sets the label.
- string MenuLabel Gets and sets the menu label.
- ImageSource LargeImage Gets and sets the large image (32x32).
- bool ShouldExecuteCommand Gets and sets the value indicating whether the command should be executed.
- ImageSource SmallImage Gets and sets the small image (16x16).
- string ToolTipDescription Gets and sets the tool tip description.
- string ToolTipFooterDescription Gets and sets the tool tip footer description.
- Uri ToolTipFooterImage Gets and sets the tool tip footer image.
- string ToolTipFooterTitle Gets and sets the tool tip footer title.
- Uri ToolTipImage Gets and sets the tool tip image.
- string ToolTipTitle Gets and sets the tool tip title.
- object Value Gets and sets the value.
IRibbonMenuData Interface

The IRibbonMenuData interface gives you an object template for data binding to menu-type Ribbon controls. It inherits from IRibbonControlData. See "IRibbonControlData Interface" on the previous page.

PROPERTIES

- ObservableCollection<IRibbonControlData> ControlDataCollection Gets the collection of IRibbonControlData used to generate the content of the control. See "IRibbonControlData Interface" on the previous page.

IRibbonTab Interface

The IRibbonTab interface represents a tab in IRibbon. See "IRibbon Interface" on page 23.

METHODS

IRibbonGroup Interface

The I RibbonGroup interface represents a group of controls that appear in IRibbonTab. See "IRibbonTab Interface" on the previous page.

METHODS

- **Button** AddRibbonButton(string, ICommand, object, string, RibbonIconSize, string, string, string) Adds a ribbon button to the ribbon group. Returns an instance of System.Windows.Controls.Button.


- **CheckBox** AddRibbonCheckBox(string, ICommand, object, string, string, string) Adds a ribbon check box to the ribbon group. Returns an instance of System.Windows.Controls.CheckBox.

- **CheckBox** AddRibbonCheckBox(IRibbonControlData) Adds a ribbon check box to the ribbon group. Returns an instance of System.Windows.Controls.CheckBox.

- **IRibbonComboBox** AddRibbonCombobox(string, ICommand, object, string, RibbonIconSize, string, string, string) Adds a ribbon combo box to the ribbon group. Returns an instance of IRibbonComboBox. See "IRibbonComboBox Interface" on page 28.

- **IRibbonComboBox** AddRibbonCombobox(IRibbonMenuData) Adds a ribbon combo box to the ribbon group. Returns an instance of IRibbonComboBox. See "IRibbonComboBox Interface" on page 28.

- **IRibbonMenu** AddRibbonMenuButton(string, string, RibbonIconSize, string, string, string) Adds a ribbon menu button to the ribbon group. Returns an instance of IRibbonMenu. See "IRibbonMenu Interface" on page 29.

- **IRibbonMenu** AddRibbonMenuButton(IRibbonMenuData) Adds a ribbon menu button to the ribbon group. Returns an instance of IRibbonMenu. See "IRibbonMenu Interface" on page 29.

- **IRibbonMenu** AddRibbonSplitMenuButton(string, ICommand, object, string, RibbonIconSize, string, string, string) Adds a ribbon split menu button to the ribbon group. Returns an instance of IRibbonMenu. See "IRibbonMenu Interface" on page 29.

- **IRibbonMenu** AddRibbonSplitMenuButton(IRibbonMenuData) Adds a ribbon split menu button to the ribbon group. Returns an instance of IRibbonMenu. See "IRibbonMenu Interface" on page 29.


IRibbonComboBox Interface

The IRibbonComboBox represents a combo box on IRibbonTab. See "IRibbonTab Interface" on page 25.

METHODS

- **void AddComboboxItem(string)** Adds a combo box item with the specified value to the combo box control.
- **string GetComboboxValue()** Gets the current value of the combo box control.
- **void SetComboboxValue(string)** Sets the current value of the combo box control to the specified string.
IRibbonMenu Interface

The I RibbonMenu interface represents a menu on IRibbonTab. See "IRibbonTab Interface" on page 25.

METHODS

- void AddMenuItem(string, ICommand, object, string) Adds a menu item for ribbon menu-type controls.
- void AddSeparator() Adds a separator to the ribbon menu-type control.
RibbonIconSize Enumeration

The RibbonIconSize enum defines constants, which indicate the size of a ribbon icon image.

MEMBERS

- **Collapsed** The image is not visible.
- **Small** The image size is 16x16 pixels at 96 DPI.
- **Large** The image size is 32x32 pixels at 96 DPI.
Examples

When creating and working with the plug-in API, reviewing examples might be of use to you. This chapter discusses the following:

- Context Menu Example ................................................................. 32
- Controlled Language Example .................................................. 33
- Ribbon Example ......................................................................... 37
- Search and Change Text Style Example ...................................... 40
- Toolbar Example ......................................................................... 41
Context Menu Example

Following is an example of how to add and properly remove a context menu item for a given instance of IDocument. See "IDocument Interface" on page 15.

```csharp
// EXAMPLE

public void AddContextMenuItem(IDocument doc)
{
    if (doc != null)
    {
        List<System.Windows.Forms.ToolStripItem> cms =
            doc.GetUserPendingContextMenuItems();
        cms.Add(new System.Windows.Forms.ToolStripMenuItem("Editor Plugin Item");
    }
}

public void RemoveContextMenuItem(IDocument doc)
{
    if (doc != null)
    {
        List<System.Windows.Forms.ToolStripItem> cms =
            mCurrentDocument.GetUserPendingContextMenuItems();
        cms.Clear();
    }
}
```

NOTE If you have multiple documents with custom context menu items, you need to manually clear their context "toolstripitem" lists.
Controlled Language Example

One of the most common uses for the Flare plug-in API is to implement controlled language with Simplified Technical English (STE). This lets you validate the language and terminology used in your Flare content, ensuring the use of standardized vocabulary and style, while improving consistency, eliminating ambiguity, and reducing complexity. This also means you can ensure compliance with corporate terminology and style guide rules.

Two STE solutions that can be integrated with Flare come from Acrolinx (acrolinx.com) and Tedopres (tedopres.com).
EXAMPLE

Let’s say you use Tedopres HyperSTE, which is one of the leading software solutions for STE. You want to integrate HyperSTE with your Flare project so that you can take advantage of controlled language when you write topics and snippets. You might do the following to set it all up and use it.

REGISTER HYPERSTE AND ENABLE THE PLUG-IN

1. Install HyperSTE and launch it.
   a. Select HyperSTE for MadCap Flare.
   b. Don't launch the license server.
   c. Click Finish.
2. Open a Flare project and select File > Options. The Options dialog opens.
3. Select the Plugins tab.
4. Click Enable.
5. Select the HyperSTE ribbon and click Check Document.

6. When you check a document for the first time, the HyperSTE plugin looks for your associated license. If you don't have a license already, you'll need to request one from Tedopres. To request a trial license of HyperSTE, contact STE@tedopres.com.

7. When a license file is returned, save it on your machine.

8. From the HyperSTE ribbon, click Check Document.

9. When the licensing UI launches, select I have a license. This launches the HyperSTE configuration wizard.

10. Click Next and set up HyperSTE, filling out the information as needed.


12. Select a dictionary file (acquired from Tedopres).
USE HYPERSTE TO CHECK A CONTENT FILE IN FLARE

1. Open a project in Flare.
2. Open the topic you want to validate.
3. From the HyperSTE ribbon, click Check Document.
4. Click on highlighted words throughout the topic. Notice the HyperSTE window explaining the terms and usage.

You can also use the other features shown in the HyperSTE ribbon in Flare.
Ribbon Example

To add a ribbon tab for your plug-in, you need to use the INavContext interface. See "INavContext Interface" on page 20.

From it, you may call GetRibbon() to retrieve an IRibbon instance. With the IRibbon instance, you may add a new ribbon tab.

```csharp
private void CreatePluginRibbon()
{
    IRibbon ribbon = mNavigationContext.GetRibbon();
    IRibbonTab tab = ribbon.AddNewRibbonTab("PluginTab", "p");
    IRibbonGroup group = tab.AddNewRibbonGroup("PluginGroup");
    Button searchAndHighlightButton = group.AddRibbonButton(PluginViewModel.SearchHighlight);
    IRibbonComboBox comboMenu = group.AddRibbonCombobox(PluginViewModel.Fonts);
}
```
Sample code for the PluginViewModel:

```csharp
public static class PluginViewModel
{
    private static RibbonControlData _searchHighlight;
    private static RibbonMenuData _fonts;
    public static RibbonControlData SearchHighlight
    {
        get
        {
            if (_searchHighlight == null)
            {
                _searchHighlight = new RibbonControlData()
                {
                    Label = "Search and Highlight",
                    Command = new ButtonCommand(),
                    KeyTip = "S"
                };
            }
            return _searchHighlight;
        }
    }
}
```
```csharp
public static RibbonMenuData Fonts
{
    get
    {
        if (_fonts == null)
        {
            BitmapImage image = new BitmapImage(new Uri
            ("C:/TFS/Trunk/ObjectApplications/Debug/Flare.app/
            Plugins/NavigationPlugin/Icons/EditDocument.png"));
            _fonts = new RibbonMenuData()
            {
                Label = "My Fonts",
                LargeImage = image
            };
            _fonts.ControlDataCollection.Add(new
            RibbonControlData()
            {
                Label = "Arial"
            });
            _fonts.ControlDataCollection.Add(new
            RibbonControlData()
            {
                Label = "Helvetica"
            });
            _fonts.ControlDataCollection.Add(new
            RibbonControlData()
            {
                Label = "Times New Roman"
            });
            return _fonts;
        }
    }
}
```

**NOTE** The ribbon tab is only visible when the Flare interface is in “Ribbon” mode.
Search and Change Text Style Example

Following is a basic example where IEditorContext is used to search for a input string and change the style of it throughout the document. See "IEditorContext Interface" on page 14.

```
private void SearchAndChangeStyle(string searchString)
{
    IDocument currentDocument = mEditorContext.GetActiveDocument();
    if (currentDocument != null)
    {
        string text = currentDocument.GetDocumentText();
        int occurrences = Regex.Matches(text, searchString).Count;
        for (int i = 0; i < occurrences; i++)
        {
            currentDocument.Select(searchString);
            currentDocument.Selection.ChangeBackColor(Color.Yellow);
            currentDocument.Selection.ChangeForeColor(Color.Red);
            currentDocument.Selection.ChangeFontFamily("Comic Sans MS");
        }
    }
}
```
Toolbar Example

To add a custom toolbar, you need to use the INavContext interface. See "INavContext Interface" on page 20.

EXAMPLE

Here is an example assuming your class instance of INavContext is named "mNav."

```csharp
private void CreateCustomBar()
{
    ICustomToolBar toolBar = mNav.CreateCustomToolBar("My ToolBar");
    toolBar.AddButton("My Button", new ButtonCommand());
    toolBar.AddSeparator();
    toolBar.AddMenuButton(MyViewModel.MenuData);
}
```

ButtonCommand and MyViewModel are defined as follows:

```csharp
public class ButtonCommand : ICommand
{
    public bool CanExecute(object parameter)
    {
        return true;
    }
    public void Execute(object parameter)
    {
        MessageBox.Show("I got pressed!");
    }
}
```
public static class RibbonViewModel
{
    private static RibbonMenuData _menuData;
    public static RibbonMenuData MenuData
    {
        get
        {
            if (_menuData == null)
            {
                BitmapImage image = new BitmapImage(new Uri("<ICON PATH>"));
                _menuData = new RibbonMenuData()
                {
                    Label = "My Menu",
                    SmallImage = image,
                    KeyTip = "D"
                };
                _menuData.ControlDataCollection.Add(new RibbonControlData()
                {
                    MenuLabel = "item1"
                });
                _menuData.ControlDataCollection.Add(new RibbonControlData()
                {
                    MenuLabel = "item2"
                });
            }
            return _menuData;
        }
    }
}

NOTE The custom toolbar is only visible when the Flare interface is in "Tool Strip" mode.
The following PDFs are available for download from the online Help.

**TUTORIALS**
- Getting Started Tutorial
- Product Foldout Tutorial
- Side Navigation Tutorial
- Top Navigation Tutorial

**USER GUIDES**
- Accessibility Guide
- Analysis and Reports Guide
- Architecture Guide
- Autonumbers Guide
- Condition Tags Guide
- Context-Sensitive Help Guide
- Eclipse Help Guide
- Getting Started Guide
- Global Project Linking Guide
- HTML Help Guide
- HTML5 Guide
- Images Guide
- Import Guide
- Indexing Guide
- Key Features Guide
- Language Support Guide
- MadCap Central Integration Guide
- Master Pages Guide
Micro Content Guide
Movies Guide
Navigation Links Guide
Plug-In API Guide
Print-Based Output Guide
Project Creation Guide
QR Codes Guide
Reports Guide
Reviews & Contributions Guide
Search Guide
SharePoint Guide
Skins Guide
Snippets Guide
Source Control Guide: Perforce
Source Control Guide: Subversion
Source Control Guide: Team Foundation Server
Styles Guide
Tables Guide
Tables of Contents Guide
Targets Guide
Templates Guide
Topics Guide
Touring the Workspace Guide
Transition From FrameMaker Guide
Variables Guide
What's New Guide

CHEAT SHEETS

Folders and Files Cheat Sheet
Print-Based Output Cheat Sheet
Shortcuts Cheat Sheet
Structure Bars Cheat Sheet
Styles Cheat Sheet