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CHAPTER 1

Introduction
Microsoft Team Foundation Server (TFS) (or Azure DevOps) is a source control tool that integrates
with Flare. You can use the Flare interface to perform various source control tasks for a project that
is bound to TFS.

General Information

n "Common Source Control Terms" on page 8

n "Source Control Icons" on page 9

n "Bind Detection, Disabling Providers, and Unbinding Providers—TFS" on page 11

Process

1. Setting Up TFS (Done Outside of Flare)

2. "Binding a Project" on page 15

3. (Other Team Members) "Importing From Source Control" on page 21

4. "Getting the Latest Version" on page 23

5. "Checking Out Source Control Files" on page 27

6. "Checking In Source Control Files" on page 29

7. "Merging Source Control Files" on page 32
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NOTE Because of the way Team Foundation Server is designed, when you remove files
from your project and check in your changes, you still need to perform a "get latest" in order
for those files to be removed from the client.

NOTE If you unpack a zipped project that is bound to source control, the files in the
unpacked project become editable.
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CHAPTER 2

General Information for Team
Foundation Server
There are various pieces of general information you should know if you plan to use this feature.

This chapter discusses the following:

Common Source Control Terms 8

Source Control Icons 9

Bind Detection, Disabling Providers, and Unbinding Providers—TFS 11
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Common Source Control Terms
Following are definitions for some of the common phrases used in Flare's integrated source control
with Microsoft Team Foundation Server.

n Bind This means to connect your project to Microsoft Team Foundation Server. After doing
this, you can then take advantage of all the automated source control tasks (such as check in,
check out, and so on).

n Check In This means to copy your local Flare files to Microsoft Team Foundation Server,
overwriting the copies stored in Microsoft Team Foundation Server. This enables other
authors on your team to access and edit the latest files.

n Check Out This means to copy the latest source control files to your local Flare project and
remove the "Read Only" designation from them so that you can edit the files.

n Get Latest Version This means to copy the latest source control files to your local project
without necessarily checking out the files. This means that the "Read Only" designation will
remain associated with the files until you check them out.

NOTE Flare integrates with multiple source control providers to provide built-in source
control support. Each of the source control providers built-in to Flare uses different terms.
As such, Flare's source control interface is different depending on which source control
provider you use. Please refer to the sections for each source control provider if you need
to see information about the terms used by other built-in systems.
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Source Control Icons
Following are descriptions for the primary icons that you may see next to files when using source
control.

Checked Out

This indicates that the file has been checked out from source control. When your
changes are done, you can check in the file.

You may see this icon in conjunction with the icon, indicating that you have
checked out and locked the file.

New File (Pending Add)

This indicates that you have a file in your project but have not yet added it to the
integrated source control application. This might occur, for example, if you create a
new topic and do not add the file to source control during the topic creation process.
To resolve this, simply right-click on the file and select Source Control > Add.

Not Checked Out

This indicates that the file is added to source control but is not currently checked out,
which means that it contains a "Read Only" designation in its properties. In order to
edit the file, you must check it out from source control.

Locked by Another User

This indicates that another user has locked the file. You cannot check in the file while
it is locked by another user.

Locked by You

This indicates that you have locked the file. You can lock a file when you check it out.
Other users cannot check in the file while it is locked.
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Checked Out By Other User

This indicates that the file is currently checked out to another user.

You may see this icon in conjunction with the icon, indicating that another user has
checked out and locked the file.

Out of Date

This indicates that the file is not current (i.e., the local copy of the file is older than the
source control copy). This might happen if another user checks out the file, makes
changes to it, and checks it back in to source control. If this occurs, you can check the
file out or get the latest version of the file from source control.

Deleted

This indicates that the file is deleted from source control, but you still have a copy of
the file on your local machine. If necessary, you can add the file to source control.
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Bind Detection, Disabling Providers,
and Unbinding Providers—TFS

Flare has options for bind detection, disabling providers, and unbinding providers. Although these
are separate features, they are all somewhat related. This information is especially important if you
are using an external tool to bind and manage your source control tasks.

Bind Detection
Flare's bind detection settings are found on the Source Control tab of the Options dialog.

CHAPTER 2  11



Bind detection scans your project when you load it to see if the project has been previously bound
to source control. If a binding is detected, you then have the option of applying the binding and
committing the project to source control. Depending on the provider you are using, Flare may
search the file system and its artifacts, as well as contact and query servers, to find potential
source control bindings.

When you open a Flare project that hasn't been bound to source control before, the bind detection
option is disabled for Perforce Helix Core, Subversion, and Team Foundation Server. It is enabled by
default for Git and MadCap Central (which uses Git). If you bind a project to source control using
the Flare interface, the option is then automatically enabled.

NOTE You can use bind detection as an alternative to importing a Flare project. If you have
received a Flare project file (e.g., by copying it from a server, by opening it from a network
location), you can simply open the file and Flare will search for and apply existing source
control bindings.

NOTE Source control providers are scanned in the following order:

1. Git

2. Subversion

3. Perforce Helix Core

TIP Detecting source control bindings may take a considerable amount of time. It is
recommended that you select only the source control providers that you use to speed up
the detection process.
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Disabling Providers
By default, when a project is bound to source control, the provider (Git, Perforce Helix Core,
Subversion, or Team Foundation Server) is enabled. This means that the source control interface
elements in Flare are visible, and you can use them to perform various tasks (e.g., commits,
synchronize changes).

Disabling a provider means that the source control interface elements are no longer shown. This
does not mean you cannot use source control. As long as the provider is still bound to the project,
you can perform source control tasks in a third-party tool outside of Flare.

For more details and steps, see "Disabling a Team Foundation Server Provider" on page 52.

Unbinding Providers
When you unbind a provider, it means you are removing the connection altogether between the
Flare project and the local repository.

You can unbind a provider via the Project Properties dialog or the Settings view in the Source
Control Explorer. Click the Unbind Provider button.

For more details and steps, See "Unbinding a Team Foundation Server Provider" on page 69.
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CHAPTER 3

Process for Team Foundation
Server
Certain tasks must be completed in order when using this feature.

1. Setting Up TFS (Done Outside of Flare)

2. "Binding a Project" on the next page

3. (Other Team Members) "Importing From Source Control" on page 21

4. "Getting the Latest Version" on page 23

5. "Checking Out Source Control Files" on page 27

6. "Checking In Source Control Files" on page 29

7. "Merging Source Control Files" on page 32
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Binding a Project
Use the following steps if you have already created a Flare project and want to bind ("connect") it to
Microsoft Team Foundation Server (or Azure DevOps). You can also automatically detect existing
source control bindings if your project has been previously connected to TFS.

NOTE The following steps show how to bind a project using the Flare interface. It is also
possible to bind a project outside of Flare (e.g., using Git Bash). If you decide to do this, you
should be aware of some additional aspects of source control, such as bind detection and
disabling providers.
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How to Bind a Project Using the Project
Properties Dialog

1. Open the project.

2. Select Project > Project Properties. The Project Properties dialog opens.

3. Select the Source Control tab.

4. Click Bind Project. The Bind Project dialog opens.

5. From the drop-down, select Microsoft Team Foundation Server.

6. In the Server field, enter the name of the computer or the IP address of the server. You can
also click to select a "Team Project Collection." If you click this button, the Select Team
Foundation Server Project Collection dialog opens, and you can do the following.

a. To add a server, click .

b. Enter the name or URL of the server.

c. Enter the path and port number.

d. Select the protocol (HTTP or HTTPS).

NOTE You may need to obtain this information from your system administrator.
Click OK in the dialogs until you return to the main wizard page.
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NOTE Be sure to specify the path deeper than the server name. For example:

.../tfs/DefaultCollection

or

.../tfs/SourceCollection

If you do not know this information, contact your system administrator.

NOTE If you run into issues in this dialog, chances are your user permissions do not
have access to all of the collections on the TFS server. Please try to enter in the
server/collection path manually.

7. Next to the Project Path field, click .

8. Click on the Team Foundation Server folder to which you want to bind the Flare project.

9. Click OK.

10. (Optional) In the Comment field, you can enter any internal comments.

11. (Optional) If you want the files in the project to be checked out when you are finished, click
Keep files checked out.

12. In the Bind Project dialog, click OK.

13. If the Log In dialog opens, complete the User name and Password fields and click OK. Copies
of the Flare files are created and added to the folder you specified.

14. In the Project Properties dialog, click OK. The project is connected to Team Foundation
Server, and you can now check files in and out as necessary.
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How to Bind a Project Using the Explorer
1. Open the project.

2. Select View > Source Control Explorer. The Source Control Explorer opens.

3. From the drop-down or the Home pane, select Settings. The Settings pane opens.

4. Click Bind. The Bind Project dialog opens.

5. From the drop-down, select Microsoft Team Foundation Server.

6. In the Server field, enter the name of the computer or the IP address of the server. You can
also click to select a "Team Project Collection." If you click this button, the Select Team
Foundation Server Project Collection dialog opens, and you can do the following.

a. To add a server, click .

b. Enter the name or URL of the server.

c. Enter the path and port number.

d. Select the protocol (HTTP or HTTPS).

NOTE You may need to obtain this information from your system administrator.
Click OK in the dialogs until you return to the main wizard page.

NOTE Be sure to specify the path deeper than the server name. For example:

.../tfs/DefaultCollection

If you do not know this information, contact your system administrator.

NOTE If you run into issues in this dialog, chances are your user permissions do not
have access to all of the collections on the TFS server. Please try to enter in the
server/collection path manually.

7. Next to the Project Path field, click .

8. Click on the Team Foundation Server folder to which you want to bind the Flare project.

9. Click OK.
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10. (Optional) In the Comment field, you can enter any internal comments.

11. (Optional) If you want the files in the project to be checked out when you are finished, click
Keep files checked out.

12. In the Bind Project dialog, click OK.

13. If the Log In dialog opens, complete the User name and Password fields and click OK. Copies
of the Flare files are created and added to the folder you specified. The project is connected
to Team Foundation Server, and you can now check files in and out as necessary.
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What’s Noteworthy?
TIP If you are having difficulty binding your project, try binding to a brand new directory in
your source control provider. You should also ensure that the directory on your local
machine (and its parent directories) is not already mapped to source control, as this may
cause issues with binding.

NOTE You can also bind a new Flare project to source control while creating it.

NOTE If you want to publish your output to source control, you must create a bind
destination.
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Importing From Source Control
This chapter focuses on importing a Flare project from source control. You might use this method,
for example, if you are working on a multi-author project and another member of the team has
placed the Flare project in Microsoft Team Foundation Server.

How to Import a Project From Team Foundation
Server

1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select File > New Project > Import Project.

n Source Control Explorer From the View ribbon, open the Source Control Explorer. From
the drop-down, select the Home pane. Click Import Project.

The Import Project from Source Control Wizard dialog opens.

2. From the drop-down, select Microsoft Team Foundation Server.

3. In the Server field, enter the name of the computer or the IP address of the server. You can
also click to select a "Team Project Collection." If you click this button, the Select Team
Foundation Server Project Collection dialog opens, and you can do the following.

a. To add a server, click . The Add Team Foundation Server dialog opens.

b. Enter the name or URL of the server.

c. Enter the path and port number.

d. Select the protocol (HTTP or HTTPS).

NOTE You may need to obtain this information from your system administrator.
Click OK in the dialogs until you return to the main wizard page.

NOTE If you run into issues in this dialog, chances are your user permissions do not
have access to all of the collections on the TFS server. Please try to enter in the
server/collection path manually.
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4. Next to the Team Project field, click . If the Log In dialog opens, complete the User name
and Password fields.

5. Click on the Team Foundation project.

6. Click Next.

7. Next to the Project file field, click Browse. The Browse Source Control Files dialog opens.

8. Find and click on the Flare project file (FLPRJ) that you want to import. (You may need to log
in with your user name and password.)

9. Click OK.

10. Click Next.

11. In the Project name field, the name of the project being imported is displayed. It is
recommended that you leave the name as it is, especially if you are working with other
authors on the project. However, you can enter a different project name if you want.

12. In the Project folder field, either accept the default location for the new project or click to
browse for and select a folder.

13. Click Finish. The project is imported and loaded into Flare

NOTE When a project is dual bound to Central and a non-Git third-party provider, keep the
following in mind if you (i.e., the second user) want to access this setup. After importing the
project from Perforce Helix Core, Subversion, or Team Foundation Server, you will have to
re-bind the project to Central. In Flare’s MadCap Central window pane, click to upload (or
bind) the project to Central. In the Bind Project dialog, it is important to enter the exact
name of the project as it currently exists on Central. When you click OK, a message
displays asking if you want to bind to the existing project. Select Yes. This re-establishes
the existing Flare/Central connection; note that it does not create a new binding.

NOTE If you want to import a project from source control, you can alternatively open the
project file from another location (e.g., a server location), and then use Flare's bind
detection functionality to automatically apply available source control bindings to the
project.

CHAPTER 3  22



Getting the Latest Version
After you bind a Flare project to a source control application, you can get the latest version of any of
the source control files. When you do this, you are copying the most current files stored in the
source control application to your local Flare project without necessarily checking out the files. This
means that the "Read Only" designation will remain associated with the files until you check them
out.

Following are steps for getting the latest version of all files in a project automatically, as well as
steps for getting the latest version of files manually.
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Automatic Get
You might use this option if you are working with a team of authors and want to make sure that you
include the latest changes from other writers in the output (without having to manually get those
files).

With this option:

n You will not be prompted before the "get" is performed.

n Flare will not get the latest copy of the files in the Targets folder, because that would conflict
with the generation of the output.

n Conflicts with files will not cause local files to be overwritten. Therefore, if your local files are
writable or already checked out, those files will be kept, rather than overwritten with the
source control files.

How to Get the Latest Version of Source Control Files
Automatically

1. Open the target.

2. In the Target Editor, select the General tab.

3. Select the check box labeled Automatically get latest version of all files before generating the
target.

4. Click to save your work.

5. Build the target.

NOTE The "automatic get" feature is not supported if you are building output using the
command line, as opposed to the Flare interface.
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Manual Get
You can manually get the latest version of all of the files in the Flare project or specific files only.

How to Get the Latest Version of Source Control Files
Manually

1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Source Control > Get Latest Version (for selected files) or Source Control
> Get Latest Version All (for all files in the project).

n Right-Click If you have the Content Explorer, Project Organizer, Pending Changes
window pane, or File List open, right-click the file you want to get and select Source
Control > Get Latest Version.

n Source Control Explorer With the Pending Changes pane open, right-click the file you
want to update and select Get Latest Version.

2. If the local and server files are the same, a message tells you so. Click OK.

If the local file is different from the file on the server, the Resolve Conflicts dialog opens. If
you want to accept all of the differences between the local and server files, thus merging
them, click Auto Merge All. If you want to review the differences in the files side by side and
resolve each conflict, click Resolve. For more information about merging files and resolving
conflicts, see "Merging Source Control Files" on page 32.
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What’s Noteworthy?

NOTE By default, when you open a project that is bound to source control, a message
automatically asks if you want to get the latest version of files. However, you can disable
this prompt in the Options dialog (File > Options). See "Disabling the Get Latest Prompt for
Source Control" on page 51.

NOTE If you update your read-only files with read-only files and you do not perform a check
out, the files will appear to be submitted without actually updating the server-side version.
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Checking Out Source Control Files
When you need to work on any of the Flare project files, you can check them out. Checking out files
means to copy the latest source control files to your local Flare project and remove the "Read Only"
designation from them so that you can edit the files. A red check mark is displayed next to each file
that is checked out.

You can check files out automatically or manually.

How to Check Out Files From Source Control
Automatically

1. Select File > Options. The Options dialog opens.

2. Select the Source Control tab.

NOTE This tab will not be visible if your project is not yet bound to source control.
See "Binding a Project" on page 15.

3. Click the check box Automatically check file out from source control when saving file
changes. A check mark in the box indicates that the feature is enabled.

4. (Optional) If you want files that are automatically checked out to be locked as well, select
Lock files when automatically checking out.

Locking files means that other users cannot check in those same files when you have them
checked out. You might use this feature to prevent conflicting changes from occurring and
having to merge files as a result.

5. Click OK.

Whenever you open a file that is not checked out, make changes, and save, not only will your
changes be saved but the file will automatically be checked out to you.
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How to Check Out Files From Source Control
Manually

1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Source Control > Check Out (for selected files) or Source Control > Check
Out All (for all files in the project).

n Right-Click If you have the Content Explorer, Project Organizer, Pending Changes
window pane, or File List open, right-click the file you want to check out and select
Source Control > Check Out (for selected files) or Source Control > Project > Check Out
All (for all files in the project).

The Check Out dialog opens. The selected files are listed with check boxes next to them.

2. Make sure to click the check box next to each file you want to check out so that it contains a
check mark.

3. (Optional) If you want the files to be locked as well, select Lock files.

Locking files means that other users cannot check in those same files when you have them
checked out. You might use this feature to prevent conflicting changes from occurring and
having to merge files as a result.

4. Click Check Out.
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Checking In Source Control Files
When you are finished editing files, you can check them in to source control. Checking in a file
overwrites the old copy of the file in the database with the new one from your local machine. Even if
others are not working on a file, it is a good idea to periodically check in files for a backup in source
control.
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How to Check In Files to Source Control
1. Do one of the following, depending on the part of the user interface you are using:

n Pending Changes Window Pane From the Source Control ribbon, open the Pending
Changes window pane. Select the files in the window pane that you want to check in,
and in the local toolbar click .

n RibbonSelect Source Control > Check In (for selected files) or Source Control > Check In
All (for all files in the project).

n Right-Click If you have the Content Explorer, Project Organizer, Pending Changes
window pane, or File List open, right-click the file you want to check in and select
Source Control > Check In (for selected files) or Source Control > Project > Check In All
(for all files in the project).

The Check In dialog opens. The selected files are listed with check boxes next to them.

2. (Optional) Enter an optional comment tied to the check-in. This enables you to keep an audit
trail for a file. The comment can then be viewed from the History dialog, which can be
accessed from the Source Control Explorer, the Source Control ribbon, the File menu, or the
Source Control button .

3. (Optional) If you want to see all files with pending changes (rather than only those you
selected), click .

4. Make sure to click the check box next to each file you want to check in so that it contains a
check mark.

5. If you want to keep the files checked out of source control, select Keep Checked Out. Doing
this will overwrite the source control copies of the files so that they have the latest changes,
but it lets you continue working on the files. This is a useful option if you are the only author
working on the files in question.

6. Click Check In.

If no other users have also made changes to the file and checked it in while you were working
on it, your version of the file is checked in.

However, if that is not the case, the Resolve Version Conflict dialog opens to let you know
that another user has already checked in the file with changes. You can merge the files
automatically if there are no conflicting changes (i.e., changes do not occur in the same
location in the file). If there are conflicting changes, you can use the Merge Changes dialog to
determine how changes are merged. See "Merging Source Control Files" on page 32.
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How to Check In Files to Source Control Using
the Explorer

1. Select View > Source Control Explorer. The Source Control Explorer opens.

2. From the drop-down or the Home pane, select Pending Changes.

The Pending Changes pane opens. Files that will be checked in are listed under Included
Changes, and files that will not be checked in are listed under Excluded Changes. You can
identify changed files because they say [edit] next to the file name.

3. (Optional) In the Comment field, enter an optional comment tied to the check-in. This enables
you to keep an audit trail for a file. The comment can then be viewed from the History dialog,
which can be accessed from the Source Control Explorer, the Source Control ribbon, the File
menu, or the Source Control button .

4. (Optional) If you want to select the files or folders that you include in the check-in, right-click a
file or folder and select one of the following options from the context menu.

n Exclude Excludes the selected file from the check-in

n Exclude Unselected Excludes all unselected files from the check-in

n Include Includes the selected file in the check-in

n Include Unselected Includes all unselected files in the check-in

5. Click Check In Included to check in all of the files in the Included Changes list.

If no other users have also made changes to the file and checked it in while you were working
on it, your version of the file is checked in. The Messages pane opens and displays a list of
files that were checked in.

However, if that is not the case, the Resolve Version Conflict dialog opens to let you know
that another user has already checked in the file with changes. You can merge the files
automatically if there are no conflicting changes (i.e., changes do not occur in the same
location in the file). If there are conflicting changes, you can use the Merge Changes dialog to
determine how changes are merged. See "Merging Source Control Files" on the next page.
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Merging Source Control Files
There may be times when you need to merge changes from different authors when checking in a
file. The merge occurs automatically if there are no conflicting changes (i.e., changes do not occur
in the same location in the file). If there are conflicting changes, a dialog opens, allowing you to
determine how changes are merged.

How to Merge Source Control Files
1. Go through the process of getting the latest version of files from source control or checking

in files. See "Getting the Latest Version" on page 23 and "Checking In Source Control Files" on
page 29. If your local copy of the file is different from the server copy (e.g., another author
has already checked in the same file), the Resolve Conflicts dialog opens.

2. Click Auto Merge All. If changes from the other author do not conflict with your changes, this
will merge all changes. A message lets you know that a backup of your local copy has been
made. This lets you restore that file if you do not want to keep the merged version.You do not
need to complete the rest of the steps below.

However, if your changes conflict with those from another author, a message displays to tell
you. In this case, continue with the next step.

3. Click OK on the conflict message.

4. In the Resolve Conflicts dialog click Resolve. The Resolve Version Conflict dialog opens.
From this dialog, you can choose from the following options.

n Merge changes for me Automatically merges changes within the same file that are not
part of the same element. If changes have been made to the same element (e.g., the
same <p> tag or <h1> tag), Flare will display a prompt to merge the changes using the
merge tool.

n Merge changes in merge tool Opens a merging interface, which lets you see exactly
what changes were made and choose which to keep.

n Undo my local changes Automatically removes your changes and keeps changes from
other authors.

n Discard external changes Automatically removes changes from other authors and
keeps your changes.
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5. If you selected the option to use the merge tool, the Merge Changes dialog opens. Use this
dialog to view and select changes. You can take actions in the following ways.

n Click a change You can click a change on either the remote or local side. This lets you
select a particular change. Use the key at the top of the merge changes dialog, as well
as the color coding on the local and server sides, to determine if a change has been
added (new), deleted, changed, or moved.

When you select a change, the change you selected will display with a solid colored
background, and the conflicting change will display with a striped background. If you
select the other change, the background shading will switch.

n Type content If you want to use your changes as well as those from another author,
and even tweak the paragraph a bit more, you can click in the area at the bottom of the
dialog and simply type content.

n Previous/next conflict When you are finished resolving the first conflict, you can use
the "Previous Conflict" and "Next Conflict" buttons at the bottom of the dialog to work
on other conflicts in the file.

NOTE If you selected "Merge as Text" in the local toolbar and are working in the code,
you can click on text with a hatched background to keep the change in it. After you
click on text with a hatched background, the hatched lines are removed, leaving a
solid color.

6. After all conflicts have been resolved, a message lets you know that a backup of your local
copy has been made. This lets you restore that file if you do not want to keep the merged
version. Click OK.
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EXAMPLE — No Conflicting Changes

Two authors—Bob and Jill—are working on the same project, using source control to
manage the files.

Bob checks out the "FAQs" topic and starts making changes to it.

Jill also checks out the "FAQs" topic and makes some changes to it. Jill's changes are in a
different location in the topic than Bob's changes; there are no conflicts. She finishes
before Bob and checks the file in to source control.

Bob finishes his changes and tries to check in the file. Before the file can be checked in, Bob
is prompted with a dialog, indicating that changes from another author have already been
checked in.

Bob selects Auto Merge All. The changes from Bob and Jill are now both shown in the
merged topic.
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EXAMPLE — Conflicting Changes

Two authors—Bob and Jill—are working on the same project, using source control to
manage the files.

Bob checks out the "FAQs" topic and starts making changes to it.

Jill also checks out the "FAQs" topic and makes some changes to it. Jill's changes are in
the same paragraph in the topic as Bob's changes; thus, there is a conflict. She finishes
before Bob and checks the file in to source control.

Bob finishes his changes and tries to check in the file. Before the file can be checked in, Bob
is prompted with a dialog, indicating that changes from another author have already been
checked in.
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Bob selects Auto Merge All. However, he receives another message, stating that his
changes conflict with those of Jill.

Bob clicks OK. Then in the Resolve Conflicts dialog he clicks Resolve. This opens the
Resolve Version Conflict dialog. From this dialog, Bob can choose from a few different
options.

CHAPTER 3  36



Bob selects Merge changes in merge tool. The Merge Changes dialog opens.
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So what action can Bob take at this point for merging the file changes?

Bob can right-click on the icon next to the change on either the local or server side. This
displays a context menu, which lets Bob either keep or ignore a particular change.
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Another way of accomplishing the same thing is to left-click on an icon. When you do this,
the change from one side is kept and the change from the other side is ignored. If you left-
click the icon again, the results are toggled; the first change is ignored and the other is kept.

What if Bob wants to use his changes as well as Jill's, and possibly tweak the paragraph a
bit more? He can click in the area at the bottom of the dialog and simply type content.
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When he is finished resolving the first conflict, Bob can use the "Previous Conflict" and
"Next Conflict" buttons at the bottom of the dialog to work on other conflicts in the file.

After all conflicts have been resolved, Bob clicks OK. The merged topic is now checked in to
source control.
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CHAPTER 4

Other Activities for Team
Foundation Server
In addition to the many features already covered in this guide, there are many more tasks related to
source control that you can perform in Flare.

This chapter discusses the following:

Adding Files to Source Control 43

Binding a Project to Microsoft Visual Studio Team Services 45

Deleting Source Control Files 50

Disabling the Get Latest Prompt for Source Control 51

Disabling a Team Foundation Server Provider 52

Disconnecting From Source Control 54

Enabling Source Control Status Checks 56

Importing From Microsoft Visual Studio Team Services 57

Publishing to Source Control 60

Rolling Back to an Earlier Version of a File 61

Setting Color Options for Project File Differences 67

Unbinding a Team Foundation Server Provider 69

Undeleting Source Control Files 71

Undoing a Checkout of Source Control Files 76

Viewing Differences in Source Control Files 77
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Viewing Files That are Checked Out 82

Viewing the History of Source Control Files 88
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Adding Files to Source Control
When working in a project that is connected to source control, there may be occasions when you
have files in your local copy of the project that are not yet part of the source control copy. For
example, when you add a new topic in your local copy of the project, that file will not be included in
the source control copy of the project until you add it.

How to Add Files to Source Control
1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Source Control > Add.

n Right-Click If you have the Content Explorer, Project Organizer, Pending Changes
window pane, or File List open, right-click the file you want to add and select Source
Control > Add.

The Check In dialog opens. The selected files are listed with check boxes next to them.

2. (Optional) Enter an optional comment tied to the check-in. This enables you to keep an audit
trail for a file. The comment can then be viewed from the History dialog, which can be
accessed from the Source Control Explorer, the Source Control ribbon, the File menu, or the
Source Control button .

3. (Optional) If you want to see all files with pending changes (rather than only those you
selected), click .

4. Make sure to click the check box next to each file you want to check in so that it contains a
check mark.

5. If you want to automatically check the files out of source control, select Keep Checked Out.

6. Click Check In.
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How to Add Files to Source Control Using the
Explorer

1. Select View > Source Control Explorer. The Source Control Explorer opens.

2. From the drop-down or the Home pane, select Pending Changes.

The Pending Changes pane opens. Files that will be checked in are listed under Included
Changes, and files that will not be checked in are listed under Excluded Changes. You can
identify newly added files because they say [add] next to the file name.

3. (Optional) In the Comment field, enter an optional comment tied to the check-in. This enables
you to keep an audit trail for a file. The comment can then be viewed from the History dialog,
which can be accessed from the Source Control Explorer, the Source Control ribbon, the File
menu, or the Source Control button .

4. (Optional) If you want to select the files or folders that you include in the check-in, right-click a
file or folder and select one of the following options from the context menu.

n Exclude Excludes the selected file from the check-in

n Exclude Unselected Excludes all unselected files from the check-in

n Include Includes the selected file in the check-in

n Include Unselected Includes all unselected files in the check-in

5. Click Check In Included to check in all of the files in the Included Changes list. The Messages
pane opens and displays a list of files that were checked in.

NOTE Adding files from other areas of the Flare interface (e.g., Pending Changes
window pane, Source Control ribbon) will only add new files. However, if you use the
Source Control Explorer to check in your files, it will check in all of your pending
changes: both new files and modified files. If you do not want to include all of your
files in the check in, you can right-click them and select Exclude. Files you exclude
will not be checked in.
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Binding a Project to Microsoft Visual
Studio Team Services

Flare includes Microsoft Team Foundation Server support for Microsoft Visual Studio Team
Services (VSTS). This is also known as Visual Studio Online, as well as Microsoft DevOps on Azure.
If you manage your source control projects with Microsoft's online version of Visual Studio, you can
bind your projects to Flare and perform check-ins and check-outs of files.

Use the following steps if you have already created a Flare project and want to bind ("connect") it to
the Microsoft VSTS repository using Microsoft Team Foundation Server.

How to Bind a Project to Source Control
1. Open the project.

2. Select Project > Project Properties. The Project Properties dialog opens.

3. Select the Source Control tab.

4. Click Bind Project. The Bind Project dialog opens.

5. From the drop-down, select Microsoft Team Foundation Server.

6. In the Server field, enter the URL of the project's "Default Collection."

NOTE When binding to VSTS project using TFS, you must manually enter the URL in
the Server field. You can only browse for a server location when binding to a local
project using TFS.

NOTE You may need to obtain this information from your system administrator.
Click OK in the dialogs until you return to the main wizard page.
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NOTE If you run into issues in this dialog, chances are your user permissions do not
have access to all of the collections on VSTS. Please try to enter in the
server/collection path manually.

7. Next to the Project Path field, click . You may need to log in to Microsoft VSTS. If the Log In
dialog opens, complete the User name and Password fields.

The Browse Source Control Folders dialog opens.

8. Click on the Team Foundation Server folder to which you want to bind the Flare project.

9. Click OK.

10. (Optional) In the Comment field, you can enter any internal comments.

11. (Optional) If you want the files in the project to be checked out when you are finished, click
Keep files checked out.

12. In the Bind Project dialog, click OK.

13. If the Log In dialog opens, complete the User name and Password fields and click OK. Copies
of the Flare files are created and added to the folder you specified.

14. In the Project Properties dialog, click OK. The project is connected to Team Foundation
Server, and you can now check files in and out as necessary.

CHAPTER 4  46



How to Bind a Project to Source Control Using
the Explorer

1. Open the project.

2. Select View > Source Control Explorer. The Source Control Explorer opens.

3. From the drop-down or the Home pane, select Settings. The Settings pane opens.

4. Click Bind. The Bind Project dialog opens.

5. From the drop-down, select Microsoft Team Foundation Server.

6. In the Server field, the URL of the project's "Default Collection."

NOTE When binding to VSTS project using TFS, you must manually enter the URL in
the Server field. You can only browse for a server location when binding to a local
project using TFS.

NOTE You may need to obtain this information from your system administrator.
Click OK in the dialogs until you return to the main wizard page.

NOTE If you run into issues in this dialog, chances are your user permissions do not
have access to all of the collections on VSTS. Please try to enter in the
server/collection path manually.
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7. Next to the Project Path field, click . You may need to log in to Microsoft VSTS. If the Log In
dialog opens, complete the User name and Password fields.

The Browse Source Control Folders dialog opens.

8. Click on the Team Foundation Server folder to which you want to bind the Flare project.

9. Click OK.

10. (Optional) In the Comment field, you can enter any internal comments.

11. (Optional) If you want the files in the project to be checked out when you are finished, click
Keep files checked out.

12. In the Bind Project dialog, click OK.
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13. If the Log In dialog opens, complete the User name and Password fields and click OK. Copies
of the Flare files are created and added to the folder you specified.The project is connected to
Team Foundation Server, and you can now check files in and out as necessary.

NOTE When you use Visual Studio Team Services with Flare, you will be prompted to
log in to Visual Studio Team Services via a dialog in Flare. Your login credentials are
stored in a cookie in the Internet Explorer Temporary Internet Files folder:

C:\Users\[username]\AppData\Local\Microsoft\Windows\INetCache

When this cookie expires, you will logged out of Visual Studio Team Services, and
Flare will prompt you to log in again.
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Deleting Source Control Files
You can delete a topic or file that is bound to source control. This also removes the file from Team
Foundation Server.

How to Delete a File
1. In one of the window panes (e.g., Content Explorer, File List, Project Organizer, Pending

Changes window pane), select the relevant file(s).

2. On your keyboard press DELETE.

3. The Delete dialog opens. Select the bound files you want to delete.

4. Click Delete.

5. Check in your changes in order for the deletions to be reflected in remote projects. See
"Checking In Source Control Files" on page 29.
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Disabling the Get Latest Prompt for
Source Control

By default, when you open a project that is bound to source control, a message automatically asks
if you want to get the latest version of files. However, you can disable this prompt in the Options
dialog. Therefore, in the future when you open the project you will no longer see the message, and
the project will open without replacing any local files with the latest ones from source control.

How to Disable the Get Latest Prompt for
Source Control

1. Select File > Options. The Options dialog opens.

2. Select the Source Control tab.

NOTE This tab will not be visible if your project is not yet bound to source control.
See "Binding a Project" on page 15.

3. Click the check box Do not prompt to get latest when opening source control bound projects.

4. Click OK.
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Disabling a Team Foundation Server
Provider

By default, when a project is bound to source control, the provider (Git, Perforce Helix Core,
Subversion, or Team Foundation Server) is enabled. This means that the source control interface
elements in Flare are visible, and you can use them to perform various tasks (e.g., commits,
synchronize changes).

Disabling a provider means that the source control interface elements are no longer shown. This
does not mean you cannot use source control. As long as the provider is still bound to the project,
you can perform source control tasks in a third-party tool outside of Flare.

How to Disable a Provider
Use this method if you want to disable a provider in just one project, rather than many projects.

1. Do one of the following, depending on the part of the user interface you are using:

n Project Properties Select Project > Project Properties.

n Source Control Explorer Select View > Source Control Explorer. Then, in the window
pane, click Settings.

2. Click Enabled to remove the check mark.

3. If you used the Project Properties dialog, click OK.

NOTE If you disable a Git provider, the local repository will continue to track your changes
in case you later decide to enable the provider once again.

If you disable one of the other providers (Perforce Helix Core, Subversion, Team Foundation
Server), your changes after that point will not be tracked. Therefore, if you later enable the
provider again, it will not have recorded any changes made since the time that you disabled
it.

NOTE When you disable a provider, that information is written to the registry on your
computer.
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NOTE If you disable a provider, but then perform one of the following actions in the Flare
interface, the provider will automatically become enabled once again.

n Bind an existing project

n Bind a new project

n Bind a project to Central (either as secondary or primary provider)

n Import a project from source control

n Import a project from Central

NOTE Having a provider enabled in Flare does not interfere with your workflow if you are
performing source control actions exclusively outside of Flare. Even if a provider is enabled
in the project and the source control user interface elements are visible, this does not mean
Flare is automatically performing any source control actions with your files. It simply
means Flare is recognizing the binding, so it reflects your activities (e.g., the Pending
Changes window is populated when you make edits in topics). However, if you prefer not to
see any of this in Flare, you can disable the provider.
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Disconnecting From Source Control
There may be times that you need to disconnect from source control to work offline. You can
disconnect from Microsoft Team Foundation Server and reconnect at any time.

Disconnecting from source control is beneficial because it lets you modify files when you would
otherwise not have access to the source control system (e.g., you are out of the office with your
laptop or you do not want to access source control over VPN). It also provides a fallback offline
status in the event that the network is disconnected while you are working, so you are able to
continue working on the files you have checked out until the network connection is restored.

How to Disconnect From TFS
When you want to work offline, you can disconnect from source control.

1. Check out the files you will need to work on while disconnected. See "Checking Out Source
Control Files" on page 27.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Source Control > Disconnect.

n Right-Click If you have the Content Explorer, Project Organizer, Pending Changes
window pane, or File List open, right-click on any file and select Source Control >
Project > Disconnect.

3. A confirmation dialog appears. Click Yes. You will be disconnected from source control.

NOTE When you disconnect from source control, you are not able to see the source control
status of files or access source control functions.

NOTE If you attempt to modify a file that is not checked out, you will receive an error when
you try to save the file. To avoid this, be sure you have all necessary files checked out
before disconnecting from source control.
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NOTE If you make a change to a file’s properties (e.g., delete, rename) while disconnected
from source control, your changes may not be preserved when you reconnect to the
network. To prevent errors, it is recommended that you do not make these kinds of
changes until you reconnect to source control.

How to Reconnect to TFS
When you are finished working offline, you can reconnect to source control.

1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Source Control > Reconnect.

n Right-Click If you have the Content Explorer, Project Organizer, Pending Changes
window pane, or File List open, right-click on any file and select Source Control >
Project > Reconnect.

2. Check in the files you previously checked out. See "Checking In Source Control Files" on page
29.

What’s Noteworthy?

NOTE Your current network connection status is indicated in the lower right corner of the
Flare interface. If you are connected you will see ; if you are disconnected you
will see .
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Enabling Source Control Status
Checks

If you are using source control integration in Flare, you can check for frequent status changes
automatically. You can specify the number of minutes and seconds when you want Flare to ping
the source control repository and get status changes for files that have been checked out, checked
in, moved, deleted, etc. The upside of this feature is that you can ensure that the source control
status information is always up to date. The downside is that you may experience slower
performance due to this constant communication over the network.

How to Enable Source Control Status Checks
1. Select File > Options. The Options dialog opens.

2. Select the Source Control tab.

NOTE This tab will not be visible if your project is not yet bound to source control.
See "Binding a Project" on page 15.

3. Click the check box Enable background status checks. A check mark in the box indicates that
the feature is enabled.

4. Enter the number of minutes and or seconds between each status update.

5. Click OK.

NOTE If you elect to disable this feature (disabled is the default setting), you can manually
check for status updates by refreshing the Pending Changes window pane or Source
Control Explorer. See "Viewing Files That are Checked Out" on page 82.
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Importing From Microsoft Visual
Studio Team Services

Flare includes Microsoft Team Foundation Server support for Microsoft Visual Studio Team
Services (VSTS). If you manage your source control projects with Microsoft's online version of
Visual Studio, you can import these projects to Flare.

Use the following steps if you have already created a Flare project and want to import it to Flare
from Microsoft VSTS.

How to Import a Project From Microsoft Visual
Studio Team Services

1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select File > New Project > Import Project.

n Source Control Explorer From the View ribbon, open the Source Control Explorer. From
the drop-down, select the Home pane. Click Import Project.

The Import Project from Source Control Wizard dialog opens.

2. From the drop-down, select Microsoft Team Foundation Server.

3. In the Server field, enter the URL of the project's "Default Collection."
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NOTE When binding to a VSTS project using TFS, you must manually enter the
URL in the Server field. You can only browse for a server location when binding to a
local project using TFS.

NOTE You may need to obtain this information from your system administrator.
Click OK in the dialogs until you return to the main wizard page.

NOTE If you run into issues in this dialog, chances are your user permissions do not
have access to all of the collections on the TFS server. Please try to enter in the
server/collection path manually.

4. Next to the Team Project field, click . You may need to log in to Microsoft VSTS. If the Log
In dialog opens, complete the User name and Password fields.

The Browse Team Foundation Server dialog appears.

NOTE When you use Visual Studio Team Services with Flare, you will be prompted to
log in to Visual Studio Team Services via a dialog in Flare. Your login credentials are
stored in a cookie in the Internet Explorer Temporary Internet Files folder:

C:\Users\[username]\AppData\Local\Microsoft\Windows\INetCache

When this cookie expires, you will logged out of Visual Studio Team Services, and
Flare will prompt you to log in again.
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5. Click on the Team Foundation project.

6. Click OK.

7. Click Next.

8. Next to the Project file field, click Browse. The Browse Source Control Files dialog opens.

9. Find and click on the Flare project file (FLPRJ) that you want to import. (You may need to log
in with your user name and password.)

10. Click OK.

11. Click Next.

12. In the Project name field, the name of the project being imported is displayed. It is
recommended that you leave the name as it is, especially if you are working with other
authors on the project. However, you can enter a different project name if you want.

13. In the Project folder field, either accept the default location for the new project or click to
browse for and select a folder.

14. Click Finish. The project is imported and loaded into Flare.
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Publishing to Source Control
You can use Flare to directly publish your output to source control, rather than having to upload it to
source control separately. Publishing your output to source control is beneficial because it you can
keep previous versions of your output in source control and access them if necessary.

For more information about creating publishing destinations, see the online Help.

How to Publish Output to Source Control
1. Create a new source control publishing destination, or select an existing source control

publishing destination.

NOTE When creating a new source control destination, be sure to select Source
Control from the Type drop-down.

2. Assign the publishing destination to the target you want to publish.

3. Build and publish your output. Your output files will be published to the source control
location you specified in the destination.
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Rolling Back to an Earlier Version of a
File

One of the benefits of Flare's integrated source control is that you can view the history and
differences for a particular file. You can view code and content differences between two source
control versions of the same file. This is useful if you need to roll back to an earlier version of a file.

EXAMPLE You have been working on a particular file for a few days. Each day you check
out the latest version of that file from source control, make your changes, and check the file
back in to source control at the end of the day. At a certain point, you determine that you
need to "roll back" to an earlier version of the file, using it to replace the latest version.
Therefore, you use this feature to view the highlighted differences between the current
version and an older version of the file. Once you have identified the older version that you
want to use, you can perform a "get" of that version.

How to Roll Back to an Earlier Version of a File
1. In one of the window panes (e.g., Content Explorer, Source Control Explorer, File List, Project

Organizer, Pending Changes window pane), select the relevant file(s).

OR

Open a file.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Source Control > View History.

n Right-Click If you have the Content Explorer, Project Organizer, Pending Changes
window pane, or File List open, right-click the file you want to roll back and select
Source Control > View History.

n Source Control Explorer With the Pending Changes pane open, right-click the file you
want to roll back and select View History.

The History dialog opens.
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3. (Optional) View the differences between two versions of the file. This may help you decide
which version of the file you want to retrieve. (Another way is to look at the dates for each
version in the History dialog.)

To view the differences, follow these steps.

a. Select the first file version from the list.

b. Hold the CTRL key and select the second file version from the list.

c. Click Show Differences. The Differences Editor opens to the right, showing content
from the backup file on the left and the current version of the file on the right.

d. In the local toolbar of the Differences Editor, you can click any of the following to make
adjustments.

n Options Click this to open the File Differences dialog, which lets you change the
colors used to display content differences between the files.

n Show WYSIWYG Click this to switch from tag view to WYSIWYG (What You See Is
What You Get) view.
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n Ignore Case Click this to ignore changes in case when viewing differences. This
option can be used in "text view" only; it is not available in WYSIWYG view.

EXAMPLE If a word is not capitalized in the original file but it is
capitalized in the current file, this option does not highlight those
differences.
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n Ignore Whitespace Click this to ignore whitespace when viewing differences.

EXAMPLE A paragraph is identical in both files, except for an extra
space that was added within the paragraph in one of those files. If you
click this option, that difference is not highlighted.
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e. When you are finished viewing the differences, close the window pane.

4. In the History dialog, select the version of the file to which you want to roll back.

5. Click Get Selected Version. That file is downloaded from source control and replaces the local
copy of the file in your project.

6. In the History dialog, click Close.
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Setting Color Options for Project File
Differences

If you are using Flare's integrated source control features, you can view differences between files in
various ways. One way is to view file differences between a local version of a Flare project and the
source control version.

When viewing file differences between a local version of a Flare project and the source control
version, you can select color options to display the files. Color coding makes it easier to discern
where differences between files occur.

EXAMPLE By default the files that are included only in your local copy are displayed as
green in the Differences Editor, and the files that are included only in source control are
displayed in red. You can use this dialog to change the local-only files to blue and the
source control–only files to yellow.
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How to Set Color Options for Project File
Differences

1. In one of the window panes (e.g., Content Explorer, Source Control Explorer, File List, Project
Organizer, Pending Changes window pane), select the relevant file(s).

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Source Control > Show Differences.

n Right-Click If you have the Content Explorer, Project Organizer, Source Control Explorer,
Pending Changes window pane, or File List open, right-click the file you want to view
and select Source Control > Show Differences.

The Differences Editor opens.

3. In the local toolbar of the Differences Editor, click Options. The File Differences dialog opens.

4. Change the text or background color for any of the difference types. To do this, simply click in
the appropriate Text or Background cell and select Pick Color. In the Color Picker dialog,
choose the new color.

5. Click OK.
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Unbinding a Team Foundation Server
Provider

When you unbind a provider, it means you are removing the connection altogether between the
Flare project and the local repository.

How to Unbind Using the Project Properties
Dialog

1. Open the project.

2. Select Project > Project Properties.

3. Select the Source Control tab.

4. Click Unbind Provider. (If your project is dual-bound, you will also see a section for the other
binding.)

5. Click OK.

How to Unbind Using the Source Control
Explorer

1. Open the project.

2. Select View > Source Control Explorer.

3. From the drop-down or the Home pane, select Settings. The Settings pane opens.

4. Click Unbind Provider. (If your project is dual-bound, you will also see a section for the other
binding.)

5. Click Yes.
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What’s Noteworthy?

NOTE You can also disable a provider, which retains the binding but hides source control
elements from the user interface.

NOTE If you are using a dual-bound setup where you are bound to MadCap Central and a
third-party provider, you might decide at some point to move to a single-bound
configuration, removing one of the bindings but leaving the other.
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Undeleting Source Control Files
If you have a file marked as "Deleted" but then want to add it to source control, you can undelete the
file, which then lets you do this. You might encounter this situation if you rename a file and then
create a new file with that name, or if you rename a file to the name of a previously deleted file.

NOTE You can only undelete files from Microsoft Team Foundation Server and Perforce
Helix Core. When you delete files from other source control providers, they are removed
from the source control repository.

How to Undelete a Source Control File
1. In one of the window panes (e.g., Content Explorer, Project Organizer, Pending Changes

window pane), select the relevant file(s).

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Source Control > Undelete.

n Right-Click If you have the Content Explorer, Project Organizer, or Pending Changes
window pane open, right-click the file you want to undelete and select Source Control >
Undelete.

3. The Undelete dialog opens. Select the files you want to undelete.

4. Click OK.
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EXAMPLE You open the Content Explorer and delete one of the topics. Then you create a
topic with the same name in the same folder. That new topic has a "Deleted" status and
must be undeleted before it is added to source control.
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In order to add the new file to source control, you need to remove the "Deleted" status.
Therefore, you right-click on the file, select Source Control, and choose Undelete.
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Undoing a Checkout of Source Control
Files

If you have files checked out from source control but do not want them checked out anymore, you
can use the "Undo Check Out" option instead of checking in the files. While checking in the file
would save your changes to source control, undoing a checkout returns the files to their previous
state and does not check in any of your changes to source control.

How to Undo a Checkout of Source Control Files
1. In one of the window panes (e.g., Content Explorer, Source Control Explorer, File List, Project

Organizer, Pending Changes window pane), select the relevant file(s).

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Source Control > Undo Check Out (for selected files) or Source control >
Undo Check Out All (for all files in the project).

n Right-Click If you have the Content Explorer, Project Organizer, Pending Changes
window pane, or File List open, right-click the files you want to undo and select Source
Control > Undo Check Out (for selected files) or Source Control > Project > Undo Check
Out All (for all files in the project).

The Undo Check Out dialog opens. The selected files are listed with check boxes next to
them.

3. (Optional) If you want to see all files with pending changes (rather than only those you
selected), click .

4. Make sure to click the check box next to each appropriate file so that it contains a check
mark.

5. Click Undo Check Out.
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Viewing Differences in Source Control
Files

One of the benefits of Flare's integrated source control is that you can view the history and
differences for a particular file.

Ways to View Differences Between Files
You can view differences between files in the following ways:

n Two Versions of Same Source Control File (History/Roll Back) You can view code and content
differences between two source control versions of the same file. This is useful if you need to
roll back to an earlier version of a file.

EXAMPLE You have been working on a particular file for a few days. Each day you
check out the latest version of that file from source control, make your changes, and
check the file back in to source control at the end of the day. At a certain point, you
determine that you need to "roll back" to an earlier version of the file, using it to
replace the latest version. Therefore, you use this feature to view the highlighted
differences between the current version and an older version of the file. Once you
have identified the older version that you want to use, you can perform a "get" of that
version.

CHAPTER 4  77



n Local Versus Source Control Version of a File You can view code and content differences
between the local version of a file and the source control version of that file.

EXAMPLE You check out a procedure topic from source control and then add some
lines of text to your local copy of that topic file. You save your changes. Later that
day, you want to revisit the new content that you wrote, but you cannot remember
exactly which lines of text you added. Therefore, you use this feature to highlight the
text differences between your local checked-out version of the file and the version
stored in the source control application. The new lines of text are highlighted on the
side displaying the local version of the file.

n Local Versus Source Control Version of All Files in a Folder You can view file differences
between the local version of the files in a folder and the source control version. Most likely,
you will use this to view all of the differences between the local files and source control files
in either your Content Explorer or Project Organizer.

EXAMPLE You are working on a large Flare project. During the course of the day, you
edit several topics in the project. At the end of the day, you check in most of your
files, but forget to check in a few of them. Later, you realize that you missed a few
files, and now those files are out-of-date. Therefore, you use this feature to see the
file-level differences between your local copy of the Content Explorer root folder and
the source control copy. The differences are color coded, so you can easily identify
the files in question. (By default, the files that are included only in your local copy are
green, and the files that are included only in source control are red.) You can then
right-click on the files that were added only to the local copy, and you can select to
add them to source control.
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How to View Differences Between Two Versions
of the Same Source Control File

1. In one of the window panes (e.g., Content Explorer, Source Control Explorer, File List, Project
Organizer, Pending Changes window pane), select the relevant file(s).

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Source Control > View History.

n Right-Click If you have the Content Explorer, Project Organizer, Source Control Explorer,
Pending Changes window pane, or File List open, right-click the file(s) you want to view
and select Source Control > View History.

The History dialog opens.

3. From the list, select the first file version that you want to compare.

4. Hold the CTRL key and select the second file version from the list.

5. Select Show Differences.The Differences Editor opens.

6. (Optional) In the Differences Editor, use the buttons in the local toolbar to customize the
information shown in the editor.

7. When you are finished viewing the differences, close the window.
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How to View Differences Between the Local
Version of a File and the Source Control Version

1. In one of the window panes (e.g., Content Explorer, Source Control Explorer, File List, Project
Organizer, Pending Changes window pane), select the relevant file(s).

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Source Control > Show Differences.

n Right-Click If you have the Content Explorer, Project Organizer, Source Control Explorer,
Pending Changes window pane, or File List open, right-click the file(s) you want to view
and select Source Control > Show Differences.

The Differences Editor opens.

3. (Optional) In the Differences Editor, use the buttons in the local toolbar to customize the
information shown in the editor.

4. When you are finished viewing the differences, close the window.
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How to View Differences Between the Local
Version of All Files in a Folder and the Source
Control Version

1. In the Content Explorer or Project Organizer, select the relevant folder.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Source Control > Show Differences.

n Right-Click Right-click the folder you want to view and select Source Control > Show
Differences.

The Differences Options dialog opens.

3. (Optional) Use this dialog to specify the type of information that you want to see in the
Differences Editor. (You can also choose these options from the local toolbar of the
Differences Editor.)

n Show files that are only in the Left folder Displays the files on the left side of the
Differences Editor. The left side is used to show the local copies of your project files.

n Show files that are only in the Right folder Displays the files on the right side of the
Differences Editor. The right side is used to show the source control copies of your
project files.

n Show files that are different in both folders Displays the files where differences occur
between the local copy and source control copy of the project. For example, the left
side might display files that you have created in your local copy but have not yet been
added to source control.

n Show files that are the same in both folders Displays the files that are the same in the
local copy as they are in the source control copy.

n Recursive Displays files recursively. In other words, if you have files contained within
folders, selecting this button will ensure that you see all of the files, not just the folders.

4. Click OK. The Differences Editor opens.

5. (Optional) In the Differences Editor, use the buttons in the local toolbar to customize the
information shown in the editor.
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Viewing Files That are Checked Out
You can use the Pending Changes window pane and the Source Control Explorer to view all of the
files that you have checked out and need to check in. You can use the File List window pane and
Pending Changes window pane to view files that are checked out by other users.

How to View Files That You and Others Have
Checked Out—Pending Changes Window Pane

1. Select Source Control > Pending Changes. The Pending Changes window pane opens.

2. (Optional) You can use the Filter field to limit the files that are displayed.

n All Files Displays all files.

n Topic Files Displays only the topic (HTM and HTML) files.

n Template Page Files Displays only the template page (FLMSP) files.

n Page Layout Files Displays only the page layout (FLPGL) files.

n Snippet Files Displays only the snippet (FLSNP) files.

n Micro Content Files Displays only the micro content (FLMCO) files.

n Stylesheet Files Displays only the stylesheet (CSS) files.

n Image Files Displays only the image files.

n Multimedia Files Displays only multimedia (audio, video, and 3D model) files.

n GIF Files Displays only GIF files.

n JPEG Files Displays only JPG and JPEG files.

n PNG Files Displays only PNG files.

n Flash Movie Files Displays only SWF files.
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3. (Optional) You can use the following toggle buttons in the local toolbar to limit the files that
are displayed.

This filters the Pending Changes window pane to show or not show files that
other users have checked out.

This filters the Pending Changes window pane to show or not show files that
are out of date.

This filters the Pending Changes window pane to show or not show files that
have been deleted.

This filters the Pending Changes window pane to show or not show files that
are locked.

4. Take note of the Status and User columns. (You may need to use the scroll bar to view these
columns.)

n Status Displays the status of the file, such as whether you have it checked out. You can
also see if another user has a file checked out.

l Checked Out This indicates that the file has been checked out from source control.
When your changes are done, you can check in the file.

l Pending Add This indicates that you have a file in your project but have not yet
added it to the integrated source control application. This might occur, for example,
if you create a new topic and do not add the file to source control during the topic
creation process. To resolve this, simply right-click on the file and select Source
Control > Add.

l Out of Date This indicates that the file is not current (i.e., the local copy of the file is
older than the source control copy). This might happen if another user checks out
the file, makes changes to it, and checks it back in to source control. If this occurs,
you can check the file out or get the latest version of the file from source control.
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NOTE You can click the refresh button in the local toolbar to make sure you
have the most recent status for each file. Another option is that you can use a
feature to automatically ping the source control repository periodically, thus
refreshing this information frequently. However, you may experience slower
performance with this automatic status update option set. See "Enabling
Source Control Status Checks" on page 56.

n User Displays the user name. If you see the name of another user in this column, it
means that the file is checked out by that user through source control.
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How to View Files That Others Have Checked
Out—File List Window Pane

1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select View > File List.

n Keyboard Shortcut Press CTRL+SHIFT+J.

The File List window pane opens.

2. (Optional) You can use the Filter field to limit the files that are displayed.

n All Files Displays all files.

n Topic Files Displays only the topic (HTM and HTML) files.

n Template Page Files Displays only the template page (FLMSP) files.

n Page Layout Files Displays only the page layout (FLPGL) files.

n Snippet Files Displays only the snippet (FLSNP) files.

n Micro Content Files Displays only the micro content (FLMCO) files.

n Stylesheet Files Displays only the stylesheet (CSS) files.

n Image Files Displays only the image files.

n Multimedia Files Displays only multimedia (audio, video, and 3D model) files.

n GIF Files Displays only GIF files.

n JPEG Files Displays only JPG and JPEG files.

n PNG Files Displays only PNG files.

n Flash Movie Files Displays only SWF files.
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3. Take note of the Status and User columns. (You may need to use the scroll bar to view these
columns.)

n Status Displays the status of the file, such as whether you have it checked out. You can
also see if another user has a file checked out.

NOTE You can click the refresh button in the local toolbar to make sure you
have the most recent status for each file. Another option is that you can use a
feature to automatically ping the source control repository periodically, thus
refreshing this information frequently. However, you may experience slower
performance with this automatic status update option set. See "Enabling
Source Control Status Checks" on page 56.

n User Displays the user name. If you see the name of another user in this column, it
means that the file is checked out by that user through source control.
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How to View Files That You Have Checked Out—
Source Control Explorer

1. Select View > Source Control Explorer. The Source Control Explorer opens.

2. From the drop-down or the Home pane, select Pending Changes.

The Pending Changes pane opens. Files that you have changed appear in the Included
Changes or Excluded Changes section (depending on whether you are going to include or
exclude them in your next check-in; see "Checking In Source Control Files" on page 29).

3. Take note of the file's status. The status is written in brackets next to the file name (e.g., edit,
add).

NOTE You can click the refresh navigation button in the Source Control Explorer
to make sure you have the most recent status for each file. Another option is that you
can use a feature to automatically ping the source control repository periodically,
thus refreshing this information frequently. However, you may experience slower
performance with this automatic status update option set. See "Enabling Source
Control Status Checks" on page 56.
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Viewing the History of Source Control
Files

One of the benefits of Flare's integrated source control is that you can view the history for a
particular file, including who checked in the file and when it was checked in. You can also view
differences between different versions of the file and roll back to an older version if necessary.

How to View the History of a Source Control File
1. In one of the window panes (e.g., Content Explorer, Source Control Explorer, File List, Project

Organizer, Pending Changes window pane), select the relevant file(s).

OR

Open a file.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Source Control > View History.

n Right-Click If you have the Content Explorer, Project Organizer, Source Control Explorer,
Pending Changes window pane, or File List open, right-click the file you want to view
and select Source Control > View History.

3. The History dialog opens. The following are explanations of the different parts of this dialog.

n Version Displays a number for each version of the file. The lower the number, the older
the version. The higher the number, the more recent the version.

n User Displays the name of the user who has been working on the file.

n Date Displays the date and time when the action has occurred.

n Action Displays the action that has taken place for the file (e.g., check in).

n Comment Displays the comment (if any) associated with the file. A comment can be
added to a file when you check that file in to source control. This enables you to
maintain an audit trail for the file's history.

n Get Selected Version Performs a "get" of a particular version of a file, thus rolling back
to that version of the file. The local version of the file is replaced with the source control
version that you selected.
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n Show Differences Opens a dialog that lets you view the differences between two
versions of a file. If you select one row in the History dialog and view the differences,
you will see the content differences between the version that you selected and the
version of the file in your local copy of the Flare project. If you select two files in the
History dialog (by holding down the CTRL key) and view the differences, you will see the
content differences between those two versions of the file.

4. In the History dialog, click Close.
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APPENDIX

PDFs
The following PDFs are available for download from the online Help.

Tutorials
Getting Started Tutorial

Autonumbers Tutorial

Back-to-Top Button Tutorial

Context-Sensitive Help Tutorial

Custom Toolbar Tutorial

eLearning Tutorial—Basic

eLearning Tutorial—Advanced

Image Tooltips Tutorial

Lists Tutorial

Meta Tags Tutorial

Micro Content Tutorial—Basic

Micro Content Tutorial—Advanced

Responsive Output Tutorial

Single-Sourcing Tutorial

Snippet Conditions Tutorial

Styles Tutorials

Tables Tutorial

Word Import Tutorial
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Cheat Sheets
Context-Sensitive Help Cheat Sheet

Folders and Files Cheat Sheet

Learning & Development Cheat Sheet

Lists Cheat Sheet

Micro Content Cheat Sheet

Print-Based Output Cheat Sheet

Search Cheat Sheet

Shortcuts Cheat Sheet

Structure Bars Cheat Sheet

Styles Cheat Sheet
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User Guides
Accessibility Guide

Analysis and Reports Guide

Architecture Guide

Autonumbers Guide

Branding Guide

Condition Tags Guide

Context-Sensitive Help Guide

Eclipse Help Guide

eLearning Guide

Getting Started Guide

Global Project Linking Guide

HTML5 Guide

Images Guide

Import Guide

Indexing Guide

Key Features Guide

Lists Guide

MadCap Central Integration
Guide

Meta Tags Guide

Micro Content Guide

Navigation Links Guide

Plug-In API Guide

Print-Based Output Guide

Project Creation Guide

QR Codes Guide

Reviews & Contributions With
Contributor Guide

Scripting Guide

Search Guide

SharePoint Guide

Skins Guide

Snippets Guide

Source Control Guide: Git

Source Control Guide:
Perforce Helix Core

Source Control Guide:
Subversion

Source Control Guide: Team
Foundation Server

Styles Guide

Tables Guide

Tables of Contents Guide

Targets Guide

Template Pages Guide

Templates Guide

Topics Guide

Touring the Workspace Guide

Transition From FrameMaker
Guide

Translation and Localization
Guide

Variables Guide

Videos Guide

What's New Guide
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