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CHAPTER 1

Welcome
Approximate Time: 30 minutes

Welcome to the Flare Tables Tutorial.

n Tutorial Goal Learning how to create and manage tables.

n Key Concepts Inserting tables in different ways, creating and applying table styles, and
working with captions.
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CHAPTER 2

Creating a Project From a
Template
To start, let's create a new project based on Flare's Austin template.
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How to Create a New Project From a
Template
1. Select File > New Project. The Start New Project Wizard opens.

2. In the Project name field, give your project any name you want.

3. (Optional) In the Project folder field, you can enter a location where you want to save your
project. By default, projects are saved in your Documents > My Projects folder.

4. Click Next.

5. Under Factory Templates, expand the Tutorials folder. Select the Austin template.

6. Click Next.

7. For branding, keep the default settings. (This is where you could customize your project's
look with branding, such as colors and logo.) Click Next.

8. Click Finish. The project is created and loaded into Flare.
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CHAPTER 3

Inserting Tables
There are multiple ways to create a table. Let's use two different methods to add a new table to a
topic.
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How to Insert a Table Using the Drop-
Down Grid

First, let's use the quick-access table grid found in the Table ribbon. This is the easiest and fastest
way to insert a table.

1. From the Content Explorer, open the Famous-Austin-Folks.htm topic.

2. After the first paragraph, press ENTER to create a new empty paragraph.

3. Select Table > Insert Table (down arrow).

4. Hover over the grid to choose four columns and five rows. When you do this, the squares
change color to indicate how many rows and columns will be included in the table. Once the
correct number of columns and rows are selected, click the mouse.
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The table looks very plain because it has no properties or stylesheet associated with it.

5. From the list below, copy Lance Armstrong (even though, you know, that thing about the Tour
de France), and paste that text in the first cell of the first column.

6. Copy Stone Cold Steve Austin and paste it in the second cell of the first column.

You could continue copying and pasting until all the names are in the table, but there is an
easier and quicker way to do the same thing, which you will see in the next set of steps.

7. In the upper-left of the interface, click repeatedly until all of your changes are undone.
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How to Insert a Table Using the Dialog
If you use the Insert Table dialog instead of the drop-down table grid, you can apply various settings
(including headers, footers, and styles) at the same time the table is added to the topic. You can
use this method to insert an empty table, just as you did in the previous set of steps, but you can
also use it to populate the table immediately with existing text. That's what you will do now.

1. Select the entire bulleted list in the topic.

2. Select Table > Insert Table (the face of the button, not the drop-down).
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3. In the dialog, set the Number of columns to 4. Notice that the "Number of rows" field
automatically sets to 5 so that it has room for all of the list items that you selected.
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4. Set the other fields in the dialog as follows.
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NOTE In the AutoFit to window field, the way to remove a value—so that it is "(not
set)"—is to click the down arrow, then in the popup click the down arrow next to the
Length field and choose (default).

5. Click OK. The table is created and populated with all of the names. It also has a design, which
is from the table stylesheet that you selected.
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How to Make Adjustments to a Table
Let's make some changes to the table, adding text, moving text around, and adding/removing rows
and columns.

1. Type Names in the first header cell, and More Names in the second cell.

2. Select the cells containing names in the second column, and press CTRL+C on your keyboard
to copy them.
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3. Right-click the tr structure bar representing the bottom row of the table, and from the context
menu select Paste (Below). If the tag block bars are not shown to the left of the content, click

at the bottom of the editor.
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Flare adds the text in new rows.

4. Repeat this for the text in the third and fourth columns. This adds even more rows to the
bottom of the table.
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5. Click in any name cell in the first column (not the header cell), and select Table > Sort Rows >
Ascending.
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The table is sorted alphabetically according to the first names in the first column.
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6. In the first column, select the cells from Lyndon Johnson to Willie Nelson, and press CTRL+X
on your keyboard to cut them.
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7. In the second column, select the first 10 cells and press CTRL+V on your keyboard to paste.
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You should now have all of the names in the first 10 cells of the first and second columns.
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8. Choose the rest of the rows at the bottom of the table, and select Table > Delete Table >
Rows.
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9. Right-click the structure bar representing the third column, and from the context menu select
Delete. If the span block bars are not shown at the top of the content, click at the bottom
of the editor.

10. Repeat this to remove the fourth column.

11. Click to save your work.

CHAPTER 3  24



CHAPTER 4

Creating Table Stylesheets
You've already used an existing table stylesheet when you inserted the table in your topic. Let's
create another one so that there is a choice in designs whenever inserting new tables.

A table stylesheet is a CSS file, like a regular stylesheet. You might use table stylesheets, regular
stylesheets, or branding stylesheets to control the look of your tables. Table stylesheets are just
handy because they let you do things, such as create column or row patterns, which would be quite
hard to do in a regular stylesheet.
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How to Create a Table Stylesheet
1. In the Content Explorer, expand the Resources folder. Then, right-click the TableStyles

subfolder, and from the context menu select New > Table Style.

2. Select the Columns.css factory template, and name it Alternate-Column-Color.

3. Click Add. The table stylesheet is added to the Content Explorer and opens in its own page in
the Table Style Editor.

4. Make sure the General tab is selected, and scroll down (if necessary) to the Cell Padding field.

CHAPTER 4  26



5. To the right of that field, click the down arrow, in the popup enter 5 px, and click OK. This adds
the value to each side of the cells.
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6. Select the Columns tab. Notice that it has two rows in the grid at the top. By having more than
one row in the grid, you can create patterns in the table. In this case, the stylesheet is already
set up to have two alternative column patterns.
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7. With the first row selected, click the down arrow to the right of the Background Color field and
select More Colors.
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8. In the dialog set the value to #F5CDBF (which is the hex number of a color). Then click OK.
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9. In the Column Styles area at the top of the editor, click . This adds another row (pattern)
and automatically selects it.

10. Follow the same steps as above to set its background color to #ADD8E6. Notice the design
created by the three patterns in the preview.

11. Click to save your work.
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CHAPTER 5

Applying Table Stylesheets
Now that you have a new table stylesheet, you can use it when inserting a new table, or you can
apply it to an existing table. Let's do the latter.
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How to Apply a Table Stylesheet
1. Open the Famous-Austin-Folks.htm topic.

2. Right-click the table structure bar to the left of the table, and from the context menu select
Table Style > Alternate-Column-Color.css.
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3. From the Table ribbon, click Columns to the Right four times. Notice the new design.

4. In the Quick Access toolbar in the upper-left of the interface, click four times to remove
the extra columns.
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5. Right-click the table structure bar to the left of the table. Select Table Style, and from the
menu select Reset Table Style.

6. Click off the table and notice that it is now plain, with no table stylesheet applied.
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7. Right-click the table structure bar again, and apply the Alternate-Row-Color.css table
stylesheet again. Now you're back where you started.

8. Click to save your work.
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CHAPTER 6

Controlling Styles for Table
Content
There are multiple ways to control the look of content in tables. In this lesson, let's take a look at
using cell content styles, as well as employing advanced selectors in a stylesheet.

This chapter discusses the following:

How to Adjust Styles in a Regular Stylesheet 38

How to Apply a Cell Content Style 42

How to Use an Advanced Selector to Control Table Cell Content 46
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How to Adjust Styles in a Regular
Stylesheet

Before we use a cell content style in a table, let's make some simple adjustments in a regular
stylesheet. Doing this will help us more clearly see what happens when you work inside a table.

1. In the Content Explorer, expand Resources > Stylesheets. Then double-click Styles.css.
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2. On the left side of the local toolbar in the Stylesheet Editor, select Table Styles.

3. Select the td style, and set the font-size property to 10pt.
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4. Change the filter to show Paragraph Styles, and set the p style to a font-size of 18pt.

5. Click to save your work.

6. Open the Famous-Austin-Folks.htm topic.
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7. Place your cursor at the end of Ben Crenshaw and press ENTER. Notice the much larger font
size. This happened because each cell of a table uses the <td> tag initially to hold content,
and the stylesheet is set to display that content at 10 pt. However, each cell can have only
one <td> tag, so as soon as you press ENTER, Flare puts the content inside <p> tags, which
are nested within the <td> tag. And because you set the p style at 18 pt, the text is much
larger than the text in the rest of the table, where there are not yet <p> tags.

8. Click to undo your changes.
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How to Apply a Cell Content Style
One way to get around the dilemma from the previous set of steps is to use a cell content style for
your tables.

1. Go back to the Styles.css stylesheet.

2. On the left side of the Stylesheet Editor, expand the p style, and under it select the table-text
class. Then set the color property to blue.

3. Click to save your work.

4. From the Content Explorer, expand TableStyles and double-click Alternate-Column-Color.css.

5. In the TableStyle Editor, select the Rows tab. Notice that this stylesheet only has one row
pattern (i.e., one row in the grid at the top of the editor), which means you only have to set the
cell content style once. If you had more row patterns, you would need to set the style on each
of them.
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6. Scroll down in the field portion of the editor to the Cell Content Style field. In the Tag field
select p, and in the Class field select table-text.

NOTE If you were to open the Alternate-Row-Color.css table stylesheet, you would
see that the same cell content style has already been set for both of the row patterns.

7. Click to save your work.

8. Go back to the Famous-Austin-Folks.htm topic.
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9. Insert a new table in the topic, associating the Alternate-Column-Color.css stylesheet with it
when you do. Then once the table is inserted, type some text in the cells. Notice that each cell
of the regular rows already has the p.table-text class in it, and the font is therefore blue.

10. Click repeatedly until the new table is removed.
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11. Notice that the existing table still has text without the blue color. You can update an existing
table to use that cell content style. First, select all of the regular body cells in the table.

12. In the Table ribbon, click Cell Content Style.

13. Scroll down in the dialog and select p.table-text. Then click OK.

14. Click off the table and notice that all of the cell text is blue, even if you press ENTER after one
of the names and type more text.

CHAPTER 6  45



How to Use an Advanced Selector to
Control Table Cell Content
1. In the Famous-Austin-Folks.htm topic, click repeatedly until the blue text is removed from

the table.

2. Open the Alternate-Column-Color.css and Alternate-Row-Color.css stylesheets, and on the
Rows tab remove the values in the Cell Content Style fields (i.e., you can delete the class from
the second field and set the first field to (default)). Remember, in the Alternate-Row-Color.css
stylesheet, you need to do this for each of the row patterns on that tab (i.e., select the first
row pattern and remove the cell content style, then select the second row and remove the cell
content style from it as well).

3. Click to save all files.
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4. Open the Styles.css stylesheet.

5. On the left side of the Stylesheet Editor, filter for Table Styles.

6. Select the td style. Then set the color to green and the font-size to 12pt.

This will automatically use those values in all regular body cells of your tables. But what
happens if you press ENTER at the end of text, creating <p> tags withing the <td> tag? That's
what we'll take care of next by creating an advanced selector.

7. In the local toolbar of the Stylesheet Editor, click Add Selector.

8. In the dialog, click in the HTML Element field and enter td (if it isn't already there). Then click
the Advanced Options down arrow to show more fields.
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9. In the Advanced Selector field, add a space after td, then type p.

This is a special style where you are telling Flare that when it finds a <p> tag within a <td> tag,
you want it to look a certain way.

10. Click OK.
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11. Filter the Stylesheet Editor to show All Styles, and at the top of the list of styles, expand
(Complex Selectors).

12. Under (Complex Selectors), scroll down and select td p. Then set its color to green and its
font-size to 12pt.

13. Click to save your work.

CHAPTER 6  49



14. Go back to the Famous-Austin-Folks.htm topic, and notice that the table text is now green
and 12 pt. Click after any of the names and press ENTER to create <p> tags and type more
content. That text looks the same—green and 12 pt.

15. Click to save your work.

NOTE For most projects, using an advanced selector in a regular stylesheet is probably the
best method to control the look of table cell content. Just use it with caution because it will
affect all paragraph tags in all tables. If you want to have a different default look for
paragraph content depending on the table, it might be better to use the cell content style.
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CHAPTER 7

Creating Table Captions
You can add captions to your tables quite easily. Then, you can use your stylesheet to control how
those captions look , including applying autonumbering to them.

This chapter discusses the following:

How to Add a Caption in the Table Properties 52

How to Use Styles to Control the Look of Table Captions 54
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How to Add a Caption in the Table
Properties
1. Open the Famous-Austin-Folks.htm topic.

2. Right-click anywhere inside the table and from the context menu select Table Properties.

3. On the General tab of the dialog, click in the Table Caption Text field and enter My Table
Caption.

Leave the other fields in the Table Caption area as they are. To learn more about those fields,
see the online Help.
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4. Click OK. The caption is added above the table.

5. Click to save your work.
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How to Use Styles to Control the Look
of Table Captions
1. Open the Styles.css stylesheet.

2. On the left side of the editor, filter the styles to show Table Styles. Then select caption.

3. Let's give our table captions a larger font, aligned left, with more space between them and the
start of the tables. First, expand the Font property group (if you are using the group view in
the Stylesheet Editor), and set the font-size to 14pt.
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4. In the Block group, set the text-align property to left.

5. In the Box group, set the padding-bottom property to 12px.

CHAPTER 7  55



6. Now let's add an autonumber to the style so that captions are incremented when you have
multiple tables. Scroll down and expand the AutoNumber group. Then to the right of mc-
autonumber-format, click .

7. Copy the following format, and paste it into the field at the top of the dialog. Add a couple of
spaces at the end of the format (i.e., after {/b}).

T: {b}TABLE {n+}:{/b}
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NOTE In this example, "T" at the beginning of the format is arbitrary. You can use any
letter you want.

8. Click OK.

9. Click to save your work.

10. Go back to the Famous-Austin-Folks.htm topic. Notice the changes to the caption.

11. Right-click the table structure bar to the left of the table, and from the context menu select
Copy.

12. Then right-click the table structure bar again, and this time select Paste After.
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13. Click the floating paste icon at the bottom-right of the second table, and in the menu make
sure Don't Merge Tables is selected.

NOTE If the horizontal scroll bar obstructs the icon when you hover over it, clicking
at the very top of the icon should open the menu. Another option is to temporarily
add a paragraph at the bottom of the topic under the second table so that the scroll
bar doesn't get in the way. Then copy and paste the table again.

14. Click anywhere on the caption at the top of the second table. Then press the up arrow key on
your keyboard to move the cursor between the tables, and press ENTER.

15. Type Here is some text, just to add some content between the tables.

16. Notice that the second table caption still says TABLE 1. That's because the editor needs to be
refreshed to see the correct autonumber. Press F5.

Now it says TABLE 2, while the caption above the first table says TABLE 1.

17. Click to save your work.
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NOTE You can make more extensive autonumber changes to table captions, such as
having a different autonumber format for online vs. print output, or adding chapter
numbers. For more details about how this can be done, see the Autonumbers Tutorial. That
tutorial explores captions on images, but you can apply the same concepts to table
captions.
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APPENDIX

PDFs
The following PDFs are available for download from the online Help.

Tutorials
Getting Started Tutorial

Autonumbers Tutorial

Back-to-Top Button Tutorial

Context-Sensitive Help Tutorial

Custom Toolbar Tutorial

eLearning Tutorial—Basic

eLearning Tutorial—Advanced

Image Tooltips Tutorial

Lists Tutorial

Meta Tags Tutorial

Micro Content Tutorial—Basic

Micro Content Tutorial—Advanced

Responsive Output Tutorial

Single-Sourcing Tutorial

Snippet Conditions Tutorial

Styles Tutorials

Tables Tutorial

Word Import Tutorial
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Cheat Sheets
Context-Sensitive Help Cheat Sheet

Folders and Files Cheat Sheet

Learning & Development Cheat Sheet

Lists Cheat Sheet

Micro Content Cheat Sheet

Print-Based Output Cheat Sheet

Search Cheat Sheet

Shortcuts Cheat Sheet

Structure Bars Cheat Sheet

Styles Cheat Sheet
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User Guides
Accessibility Guide

Analysis and Reports Guide

Architecture Guide

Autonumbers Guide

Branding Guide

Condition Tags Guide

Context-Sensitive Help Guide

Eclipse Help Guide

eLearning Guide

Getting Started Guide

Global Project Linking Guide

HTML5 Guide

Images Guide

Import Guide

Indexing Guide

Key Features Guide

Lists Guide

MadCap Central Integration
Guide

Meta Tags Guide

Micro Content Guide

Navigation Links Guide

Plug-In API Guide

Print-Based Output Guide

Project Creation Guide

QR Codes Guide

Reviews & Contributions With
Contributor Guide

Scripting Guide

Search Guide

SharePoint Guide

Skins Guide

Snippets Guide

Source Control Guide: Git

Source Control Guide:
Perforce Helix Core

Source Control Guide:
Subversion

Source Control Guide: Team
Foundation Server

Styles Guide

Tables Guide

Tables of Contents Guide

Targets Guide

Template Pages Guide

Templates Guide

Topics Guide

Touring the Workspace Guide

Transition From FrameMaker
Guide

Translation and Localization
Guide

Variables Guide

Videos Guide

What's New Guide
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