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CHAPTER 1

Introduction
You can incorporate different types of video files (i.e., YouTube, Vimeo, Windows Media, QuickTime,
HTML5) into your Flare project. In addition, you can insert links to movies created in MadCap
Mimic.

Main Activities

n "Inserting Movies" on page 12

n "Mimic Movie Links in Content Files" on page 29

n "Mimic Movie Links in TOCs" on page 32

n "Mimic Movie Links in Browse Sequences" on page 34

n "Editing Videos" on page 36

Other Activities

n "Previewing Videos" on page 55

n "Deleting Video Files From the Project" on page 55

n "Deleting Videos From Topics" on page 56

n "Launching MadCap Mimic" on page 56
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Multimedia Features and File Types Supported

HTML5 PDF Word
Clean
XHTML

Eclipse
Help EPUB1

HTML
Help

3D Models (U3D)

Audio/Video

ASF

ASX

AU

AVI4
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HTML5 PDF Word
Clean
XHTML

Eclipse
Help EPUB1

HTML
Help

M4V4

MID

MIDI

MP3

MP44

MPA

MPE

MPEG

MPG
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HTML5 PDF Word
Clean
XHTML

Eclipse
Help EPUB1

HTML
Help

OGG4

OGV4

OPUS

SWF

WAV

WEBM4

WMA

WMV
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HTML5 PDF Word
Clean
XHTML

Eclipse
Help EPUB1

HTML
Help

Web Videos

Vimeo Embedded Videos

YouTube Embedded Videos

MadCap Mimic Movie Links

Flash (SWF) Format

HTML5 Format (Depending on
Browser)5

Mimic Movie Format
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HTML5 PDF Word
Clean
XHTML

Eclipse
Help EPUB1

HTML
Help

Silverlight Format

1EPUB support for each element or file type depends on if a particular reader supports it.

2PDF support for 3D Models requires Adobe Reader 7.0+.

3For this output, the 3D Model opens in a separate window.

4If you generate Microsoft HTML Help, YouTube videos are rendered smaller than in other outputs and Vimeo Advanced
settings are not supported.

5To view HTML5 movie output, end users must have a newer browser that supports these types of videos.
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CHAPTER 2

Main Activities for Videos
Some activities are particularly common and important when it comes to this feature.

This chapter discusses the following:

Inserting Movies 12

Mimic Movie Links in Content Files 29

Mimic Movie Links in TOCs 32

Mimic Movie Links in Browse Sequences 34

Editing Videos 36
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Inserting Movies
You can insert Flash, Windows Media, QuickTime, or HTML5 videos directly into your Flare content
files. You can also insert YouTube and Vimeo videos from the web.

Inserting Flash, Windows Media, QuickTime, and
HTML5 Movies
Options:

n Embedded You can use Insert > Multimedia to embed the video in the content file. In addition,
you can specify advanced settings, such as whether to include controls with the movie (e.g.,
Play, Pause), whether to automatically start the movie when it displays, and audio levels. The
options available depend on the type of movie you are inserting. Also, keep in mind that some
movie formats may be supported in some outputs but not in others.

n Linked You can use Insert > Hyperlink. When you use this option, the user must click the text
link in order to open the movie. Also, you can choose to display the movie in another window.

n Drag and Drop You can insert embedded movie files by dragging and dropping the movie file
from the Content Explorer or File List window pane into the XML Editor. However, with this
method, you can specify any necessary advanced settings only after the movie file is inserted
(to do this, right-click on the inserted movie and select Edit Multimedia).

Inserting YouTube and Vimeo Movies
Options:

n Embedded You can use Insert > Multimedia to embed the video in the content file. In addition,
you can specify advanced settings, such as whether to automatically start the movie when it
displays, and what kind of information to display on the movie (e.g., movie title, player
branding). The options available depend on the type of movie you are inserting.

n Linked You can use Insert > Hyperlink. When you use this option, the user must click the text
link in order to open the movie. When you insert a YouTube or Vimeo link in your output, it will
send you to the host's website to play the movie.
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How to Insert an Embedded Movie
1. In the XML Editor, place your cursor where you want to insert the movie.

2. Select Insert > Multimedia, then choose either Flash Movie, Windows Media Player, Quicktime
Movie, HTML5 Movie, or YouTube/Vimeo.

3. Select the General tab.

4. Select a movie file to insert. You can do this in various ways.

SELECTING A FILE IN THE PROJECT

a. To select a movie file already in the project, select Multimedia in project.

b. Find and choose the file. Use the buttons in the local toolbar to view all files in a list,
view files in their folder structure, etc.

Shows all of the files in the project in a list below. Click the
button again to switch to a folder tree view. You can click
the File, Type, or Path column headers to sort the list
alphabetically by that column data.

Shows or hides the folders that the files are stored in.

Shows or hides the files. If you click this button when the
Show Folders button is selected, the area splits into
two. The folder is shown on the left side, and the files and
subfolders within it are shown on the right.

If the Show Files button is the only one selected, you
can click this button to move up one folder level.

Lets you filter the kinds of files shown below. Depending
on the task you are performing, this field may already be
populated with the most appropriate file type(s).
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c. (Optional) To select a movie file outside of the project, click . To select a movie file
that you recently inserted somewhere in your project, click the down arrow in the field
next to and select the file from the list.

NOTE If you select a movie file outside the project, that file is then copied and
placed inside the project. The movie file is stored in the Resources >
Multimedia folder of the Content Explorer.

SELECTING A YOUTUBE OR VIMEO FILE FROM THE WEB

a. To select a movie file on the web, select Multimedia from Web.

b. In the field, enter the location of the movie file you want to use in your project.

EXAMPLE In the following example, we are linking to a YouTube video.

NOTE You can only add YouTube and Vimeo files from the web.
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NOTE When you insert a YouTube or Vimeo movie (using the Insert > Multimedia
option), these movies are not stored in your Resources > Multimedia folder like other
movie types, because Flare references them from the web.

NOTE You can set YouTube videos to have a specific start time. For example, you
might want the video to begin playing not from its beginning, but rather 1 minute and
30 seconds into the movie. To do this, add the time you want the video to start to the
end of the URL using the format t=(time in minutes and seconds). For example:

https://youtu.be/SI6PHhxHNNA?t=1m30s

The easiest way to do this is to open the video in YouTube, click the Share button,
enter the start time, and copy the URL given.

5. (Optional) If you want to apply a specific style class to the movie, you can select it from the
Style Class field.

EXAMPLE You have created in your stylesheet a class of the object style called
"BigMargin" (i.e., object.BigMargin) and you have set the margin for all sides of that
class to 1 inch. Rather than using the default parent object style when you insert the
movie, you select object.BigMargin from the Style Class drop-down. As a result, 1
inch of space is added around the movie in the output.
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6. (Optional) In the Screen Tip field, you can type a phrase that will appear when the end user
hovers over the movie link in the output.

If you want to insert a variable in a field, you can click . The variable will appear as syntax in
the field, but in the output the variable definition will be shown.

7. (Optional) In the Alternate Text field, you can type alternate text to display when the movie is
not available, such as when a disabled individual is using a screen reader.

8. (Optional) Select the Advanced tab and complete the options as necessary. The options
shown depend on the type of movie file you are inserting.

FLASH OPTIONS
n Quality Select the quality of the video, from "Low" up to "Best."

l Low Favors playback speed over appearance and never uses anti-aliasing.

l Auto Low Emphasizes speed at first but improves appearance whenever possible.
Playback begins with anti-aliasing turned off. If the Flash Player detects that the
processor can handle it, anti-aliasing is turned on.

l Auto High Emphasizes playback speed and appearance equally at first but sacrifices
appearance for playback speed if necessary. Playback begins with anti-aliasing
turned on. If the actual frame rate drops below the specified frame rate, anti-aliasing
is turned off to improve playback speed. Use this setting to emulate the View >
Antialias setting in Flash.

l Medium Applies some anti-aliasing and does not smooth bitmaps. It produces a
better quality than the Low setting, but lower quality than the High setting.

l High Favors appearance over playback speed and always applies anti-aliasing. If the
movie does not contain animation, bitmaps are smoothed; if the movie has
animation, bitmaps are not smoothed.

l Best Provides the best display quality and does not consider playback speed. All
output is anti-aliased and all bitmaps are smoothed.

n Scale When you insert an embedded movie, a square container represents the area
where the video will be displayed. Just like a regular image, you can resize the
container either by using the settings on the Size tab or by clicking the clicking and
dragging the icon in the lower-right corner of the container. The settings in this field
determine how the video is displayed in the area represented by the square container.
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l Default (Show All) Makes the entire movie visible in the specified area without
distortion, while maintaining the original aspect ratio of the movie. Borders may
appear on two sides of the movie.

l No border Scales the movie to fill the specified area, without distortion but possibly
with some cropping, while maintaining the original aspect ratio of the movie.

l Exact fit Makes the entire movie visible in the specified area without trying to
preserve the original aspect ratio. Distortion may occur.

n Alignment Select where you want the video to be displayed within the container area
(e.g., Left, Right, Bottom, Bottom Right).

n Auto Play Select this option if you want the video to automatically begin playing when
the topic displays. Otherwise, the user must click the Play button to start the movie.

n Loop Select this option if you want the movie to play repeatedly.

n Show Menu Select this option if you want to display the full menu, allowing the user a
variety of options to enhance or control playback. If you do not select this option, the
menu contains only the Settings option and the About Flash option.

n Enable SWLiveConnect Select this option to specify whether the browser should start
Java when loading the Flash Player for the first time.

WINDOWS MEDIA OPTIONS
n Player Controls Select an option for displaying the player controls (e.g., Play, Pause,

Volume).

l Full Displays all of the available player controls.

l None Does not display any player controls.

l Mini Displays only some of the player controls (Play, Pause, Stop, Mute, Volume).

l Invisible Hides the movie entirely, while still playing the audio. If you select this
option, you might want to resize the container square in your topic so that it does
not take up so much space in the output. The user will simply see blank space where
the container exists.

n Auto Start Select this option if you want the video to automatically begin playing when
the topic displays. Otherwise, the user must click the Play button to start the movie.

n Full Screen Select this option to display the movie using the entire screen.
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n Stretch to Fit Select this option to automatically resize the movie so that it exactly
matches the size of the container area.

n Play Count Enter the number of times you want the video to repeat.

n Audio Select options for the sound (mute, volume level, balance).

QUICKTIME AND HTML5 OPTIONS
n Scale When you insert an embedded movie, a square container represents the area

where the video will be displayed. Just like a regular image, you can resize the
container either by using the settings on the Size tab or by clicking and dragging the
icon in the lower-right corner of the container. The settings in this field determine
how the video is displayed in the area represented by the square container.

l To Fit Automatically resizes the movie so that it exactly matches the size of the
container area.

l Aspect Automatically resizes the movie so that it exactly matches the size of the
container area. However, the image is not stretched, but rather kept in its original
proportion. For example, the width of the movie might be increased to match the
width of the container area, but extra empty space might be shown above and below
the movie in order to compensate for the height of the container area.

l Value Enter the value that you want to increase the display of the movie. If you
select 2, the movie will be twice as large as 1, and so on.

n Show Controls Select this option to show the player controls (e.g., Play, Pause). 

n Auto Play Select this option if you want the video to automatically begin playing when
the topic displays. Otherwise, the user must click the Play button to start the movie.

n Loop Select this option if you want the movie to play repeatedly.

n Audio Select the volume level for the movie.
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YOUTUBE OPTIONS
n Auto Hide Select this option if you want to hide the video's title and player controls bar

when the movie begins playing.

n Auto Play Select this option if you want the video to automatically begin playing when
the topic displays. Otherwise, the user must click the Play button to start the movie.

n Full Screen Select this option if you want to allow users to play the video in full-screen
mode.

n Show Related Videos Select this option if you want to show similar, suggested videos
when the movie stops playing.

n Annotations Select this option if you want to show annotations from the video owner
when viewing the movie.

l On Enables annotations from the video owner.

l Off Disables annotations from the video owner.

n Modest Branding Select this option if you want to remove the YouTube branding from
the player controls.

n Show Info Select this option if you want to show the title bar on the top of the video.

n Progress Bar Color Select the color you want to use for the player's progress bar.

l White Displays a white progress bar.

l Red Displays a red progress bar.

n Controls Select the display option for the player controls (i.e., play, pause, full-screen,
settings).

l On (Always) Displays player controls at all times.

l On (Only during playback) Displays player controls only during video playback.

l Off Disables player controls.

n Theme Select a color theme for the player controls.

l Light Displays a light gray player control bar.

l Dark Displays a black player control bar.

NOTE Some advanced features may not work in all web browsers.
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NOTE Setting the Progress Bar option to White overrides the Modest Branding
option, so you will always see the YouTube logo when you play your videos.

NOTE If you disable the player controls, users will only be able to play and
pause the video. They will not be able to adjust the volume, view or adjust the
progress bar, change video settings, or open the video in full-screen mode.

VIMEO OPTIONS

l Auto Pause Select this option if you want the video to automatically pause when
another Vimeo video in the topic is played. Otherwise, the user must click the Pause
button to pause the movie.

l Auto Play Select this option if you want the video to automatically begin playing
when the topic displays. Otherwise, the user must click the Play button to start the
movie.

l Loop Select this option if you want the movie to play repeatedly.

l Byline Select this option if you want to display the video owner's name on the movie.

l Portrait Select this option if you want display the video owner's portrait on the
movie.

l Title Select this option if you want display the title on the video.

l Controls Color If you want change the color of the player controls, click and
select a color.

NOTE Some advanced features may not work in all web browsers.
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NOTE Vimeo's advanced features are not available in Microsoft HTML Help and
Eclipse Help outputs.

NOTE If the owner of the video is a Vimeo Pro or Vimeo Plus member, some of these
settings may be overridden by that member's preferences. For example, an owner of
a video may not allow you to remove the title and byline, so you will still see this
information on the video even if you chose not to display it in the Flare output.

NOTE You cannot remove the Vimeo Staff Picks badge from a video.

9. (Optional) Select the Size tab and complete the options as necessary to resize the container
area where the movie will be displayed. As an alternative, you can click and drag the icon
in the lower-right corner of the container.

TO SET A PRECISE WIDTH AND/OR HEIGHT

In the Width and/or Height field of the Size section, provide the settings. First you need to
select Length in the top drop-down list. You can then enter a value in the lower-left area and
choose from several different units of measurement (points, pixels, centimeters, etc.) in the
lower-right area.

TO SET THE MINIMUM WIDTH AND/OR HEIGHT

If the original object is smaller than the minimum width or height that is set, it will be enlarged
so that it reaches the minimum value. If the original object is larger than the minimum width
or height, it will not be resized.

In the Width and/or Height field of the Minimum Size section, provide the settings. First you
need to select Length in the top drop-down list. You can then enter a value in the lower-left
area and choose from several different units of measurement (points, pixels, centimeters,
etc.) in the lower-right area.

CHAPTER 2  21



TO SET THE MAXIMUM WIDTH AND/OR HEIGHT

If the original object is larger than the maximum width or height that is set, it will be reduced
in size so that it is no greater than the maximum value. If the original object is smaller than
the maximum width or height, it will not be resized.

In the Width and/or Height field of the Maximum Size section, provide the settings. First you
need to select Length in the top drop-down list. You can then enter a value in the lower-left
area and choose from several different units of measurement (points, pixels, centimeters,
etc.) in the lower-right area.

NOTE When resizing objects, you can ensure the aspect ratio is maintained. For
example, if you want certain objects to be resized so that each is exactly 3 inches
high, you can make sure the width of each object is adjusted accordingly to stay in
proportion. To do this, first set the height at 3 inches. You would not set the width
property at all. In the same way, if you were to specify an exact width, you could
maintain the aspect ratio by not setting the height.
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10. (Optional) Select the Position tab and complete the options as necessary to determine how
the movie is positioned in the topic.

FLOAT

Use this field to specify where to place the element on the page.

n None Does not place the element in a specific location.

n Left Positions the element on the left side of the page frame, allowing you to type text
to the right of the element.

n Right Positions the element on the right side of the page frame, allowing you to type
text to the left of the element.

n Center of Column Positions the element in the center of the column on the page.

n Outside Left Margin Positions the element beyond the left margin of the topic text.

n Outside Right Margin Positions the element beyond the right margin of the topic text.

n Outside Frame Positions the element outside of the page frame.

n Outside Frame, Top Align Positions the element outside of the page frame, as well as
aligning it with the top of the frame.

n Left of Frame Positions the element to the left of the page frame.

n Right of Frame Positions the element to the right of the page frame.

n Center of Frame Positions the element both vertically and horizontally in the middle of
the page frame.
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CLEAR

Use this field to position an element so that it is "clear" of an adjacent element. For example,
let's say you have already inserted an element and applied the float left property to it. If you
then insert another element immediately after the first element, you want to make sure that
the second element doesn't rest next to the first one. Instead, you want the second element
to be placed completely below the first one. Therefore, you can apply a clear property to the
second element.

n None Does not apply the clear property to the element.

n Left Side The element will be placed below the bottom outer edge of a previous
element that is floating left.

n Right Side The element will be placed below the bottom outer edge of a previous
element that is floating right.

n Both Sides The element will be placed below the previous one, whether floating left or
right.

VERTICAL ALIGNMENT

Use this field to adjust where the item is positioned vertically.

n Baseline The baseline of the box will be aligned with the baseline of the parent box.

n Text Top The top of the box will be aligned with the top of the parent element's font.

n Text Bottom The bottom of the box will be aligned with the bottom of the line box.

n Top The top of the box will be aligned with the top of the line box.

n Middle The vertical midpoint of the box will be aligned with the baseline of the parent
box, plus half the x-height of the parent.

n Bottom The bottom of the box will be aligned with the bottom of the line box.
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11. (Optional) Select the Borders & Margins tab if you want to specify margins, padding, or
borders around the movie.

MARGIN

Click in any of the individual fields (Left, Right, Top, Bottom) to specify the settings for the
margins around the object. If you click the down arrow to the right of all the fields, the
settings will be applied to all of the margin fields.

PADDING

Click in any of the individual fields (Left, Right, Top, Bottom) to specify the settings for the
padding. In the left side of the field, enter a number for the amount of padding. In the right
side of the field, select a unit of measurement (e.g., point, pixel, centimeter) for the number
you entered. If you click the down arrow to the right of all the fields, the settings will be
applied to all of the padding fields. When you click that down arrow, a small popup displays.

BORDERS

a. Click in any of the individual fields (Left, Right, Top, Bottom) to specify the settings for
the border. If you click the down arrow to the right of all the fields, the settings will be
applied to all of the border fields.

When you click that down arrow or in one of the individual fields, a small popup
displays.

b. Use the lower-left area of the popup to enter a number for the border thickness.

c. Use the lower-middle area to select a unit of measurement (e.g., point, pixel,
centimeter) for the number you entered.

d. Use the upper-right area to select a color for the border.

e. Use the lower-right area to select a line type (e.g., solid, double, dashed) for the border.

f. Click OK.
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12. (Optional) Select the Background tab if you want to add background settings to a movie
interface.

TO SET A COLOR FOR THE BACKGROUND

In the Color field, click the down arrow and select a color from the popup. For advanced color
options, select More Colors and use the fields in the Color Picker dialog.

TO ADD AN IMAGE TO THE BACKGROUND

a. Next to the Image field, click the Browse button. The Insert Image dialog opens.

b. Select an image file to insert and click OK.

c. If you want the background image to repeat, select one of the options from the Repeat
field. You can also set the image position horizontally and vertically by using the X and
Y fields.

13. Click OK. The movie is added to the topic, represented by a gray square or rectangle, which is
the area where the video will be shown in the output.

14. Click to save your work.
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How to Insert a Movie Link
1. If necessary, add the multimedia file(s) to the project.

2. In the XML Editor, highlight the text that you want to use as the link (or "hotspot") to the
movie.

3. Select Insert > Hyperlink, or in the local toolbar click . .

4. From the Link to field select File in Project.

5. Navigate to the movie that you want to link to and select it.

6. (Optional) The Link text field displays the text that you highlighted in the topic, which will be
used as the hyperlink. Leave the text as it is, unless you decide you would like to change it.

7. (Optional) In the Screen Tip field, you can type a phrase that will appear when the end user
hovers over the hyperlink in the output.

If you want to insert a variable in a field, you can click . The variable will appear as syntax in
the field, but in the output the variable definition will be shown.

8. (Optional) In the Alternate Text field you can type alternate text to display when the image is
not available, such as when a disabled individual is using a screen reader.

9. (Optional) Next to the Style Class field, click the Select button. This opens the Select Class
dialog, which lets you apply one of the defined hyperlink styles from your stylesheet to the
link. After you select a style class in the dialog, click OK. The Style Class field displays the
selected style. (If you do not specify a style class, Flare uses the parent "a" style.)

10. (Optional) In the Target Frame field, click the drop-down arrow to select the way the linked
destination will open (e.g., in another window, in a popup).

n Page Default The destination file opens in the same window as the output window.

n Parent Frame The destination file opens in the parent frame of the current topic while
hiding that topic.

n New Window The destination file opens in a new browser window.

n Same Frame The destination file opens in the same window frame as the current topic.

n Top Frame The destination file opens in the same output window, removing all other
framesets. You might use this option, for example, if the destination topic has its own
frameset.

n Popup Window The destination file opens in a popup box on top of the current topic.
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11. Click OK.

12. Click to save your work.

How to Insert a Movie—Drag-and-Drop Method
1. Open the Content Explorer or File List window pane.

If necessary, make sure you float and position the window pane or editor so that you can see
both it and XML Editor at the same time.

2. Click and drag the movie file from the Content Explorer or File List window pane to the
location where you want it in the XML Editor and drop it.

3. Click to save your work.

What’s Noteworthy?

NOTE You can also insert a link to a MadCap Mimic movie file (if you have Mimic installed).
This lets you insert videos generated with any of the following output types: Mimic Movie
Format (MMF), Microsoft Silverlight, or Adobe Flash. MMF offers several advantages (such
as quicker compilation and smaller files). For more information see "Mimic Movie Links in
Content Files" on the next page.
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Mimic Movie Links in Content Files
If you have used Mimic to produce a movie, you can use this feature to create a link in a topic to the
movie's output. When you are finished, a link to the finished movie is inserted into the topic. When a
user clicks the link in the output, the movie plays.

How to Insert a Mimic Movie Link in a Content
File

1. Open the content file.

2. In the XML Editor, place your cursor where you want to insert the link.

3. Select Insert > Multimedia > Mimic Movie.

4. In the dialog that opens, find and select an individual Mimic movie or a movie collection that
you want to link to. You can select any of the following types of files.

n MIMOV This is an individual Mimic movie file (whether part of a collection or
standalone). When you want to work on an individual movie, you open this file.

n MIPRJ This is the main Mimic collection file, which contains one or more movie
(MIMOV) files. It is not required that you create a collection in Mimic; it is simply an
option that you can use if you want to create a movie collection, as opposed to a
standalone movie. Neither the MIPRJ nor the MIMOV files are finalized movies. They
are merely the files that are used to generate the finalized movies. When you want to
work on a movie collection, you open the MIPRJ file.

n MCMOVIE This is an output file that is created when you generate a movie (whether the
movie is part of a collection or standalone). A Mimic collection can contain several
movies. When you generate the finalized movies in Mimic, an MCMOVIE file is created
for each movie in the collection (e.g., myfirstmovie.mcmovie,
mysecondmovie.mcmovie). The output plays in the MadCap Movie Viewer.

n MCMV This is an optional output file that lets you view the movie(s) in the MadCap
Movie Viewer, rather than in a browser window.

n MCMOVIESYS This is an output file that is created when you generate a movie
collection. The file is named after your collection (e.g., mycollection.mcmoviesys) and
can be used as an entry point to view the movie collection. The output plays in the
MadCap Movie Viewer.

5. Click Open.The Edit Mimic Movie dialog opens.
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6. Change the options in the dialog as necessary.

n File Displays the path to the movie or collection file after you select it.

n Lets you find and select a different movie or collection file.

n Format You can use this drop-down to select the type of output to be generated.

IF YOU HAVE MIMIC 8 OR NEWER

l (default) If you build a Microsoft HTML Help, WebHelp, HTML5, or WebHelp Plus
target, the movie uses the HTML5 movie format.

l HTML5 The movie is generated in the HTML5 movie format.

IF YOU HAVE MIMIC 7 OR OLDER

l (default) The most appropriate movie format is used, based on the Flare output type
that you generate. If you build a Microsoft HTML Help, WebHelp, HTML5, or
WebHelp Plus target, the movie uses the HTML5 movie format. If you want to
override these settings, select one of the specific movie types below.

l MadCap Movie Player The movie is generated in MMF and displays in the MadCap
Movie Viewer.

l Adobe Flash The movie is generated in a Flash SWF file.

l Adobe Flash (Embed) The movie is generated in a Flash SWF file and is embedded
in your output.

l Microsoft Silverlight The movie is generated in the Microsoft Silverlight format.

l HTML5 The movie is generated in the HTML5 movie format.

l HTML5 (Embed) The movie is generated in the HTML5 movie format and is
embedded in your output.

n Style Class Select the kind of style class to be used for the link to affect the way it looks
and behaves. You can select the main hyperlink style (a) or a class of that style.
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n Link Text Displays the text that you highlighted in the topic, which will be used as the
movie link. Leave the text as it is, unless you decide you would like to change it. If you
want to change the link text, type the new text in the field. It will replace the previously
selected text in the topic. If you do not provide link text, the file name for the movie or
collection will be used.

n Screen Tip Type a phrase that will appear when the end user hovers over the movie link
in the output.

7. Click OK. The movie link is added to the topic with a small movie frame icon displayed
next to it.

8. Click to save your work.

NOTE If instead you want to insert a movie directly into a topic (rather than a link), see
"Inserting Movies" on page 12.

NOTE You do not need to add the Mimic movie files to your Flare project. When you
generate the target(s) in Flare, the movie output file(s) will automatically be copied to the
target output file or folder.
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Mimic Movie Links in TOCs
If you have used Mimic to produce a movie, you can use this feature to create a link in a table of
contents entry to the movie's output.

How to Insert a Movie Link Into a TOC
1. Open the TOC where you want to insert the movie link.

2. In the TOC Editor, double-click the TOC entry that you want to link to the movie. The
Properties dialog opens.

3. Select the General tab.

4. Select Mimic Movie or Movie Collection as. The Open dialog opens.

5. Find and select an individual Mimic movie or a movie collection to which you want to link the
entry. You can select any of the following types of files.

n MIMOV This is an individual Mimic movie file (whether part of a collection or
standalone). When you want to work on an individual movie, you open this file.

n MIPRJ This is the main Mimic collection file, which contains one or more movie
(MIMOV) files. It is not required that you create a collection in Mimic; it is simply an
option that you can use if you want to create a movie collection, as opposed to a
standalone movie. Neither the MIPRJ nor the MIMOV files are finalized movies. They
are merely the files that are used to generate the finalized movies. When you want to
work on a movie collection, you open the MIPRJ file.

n MCMOVIE This is an output file that is created when you generate a movie (whether the
movie is part of a collection or standalone). A Mimic collection can contain several
movies. When you generate the finalized movies in Mimic, an MCMOVIE file is created
for each movie in the collection (e.g., myfirstmovie.mcmovie,
mysecondmovie.mcmovie). The output plays in the MadCap Movie Viewer.

n MCMV This is an optional output file that lets you view the movie(s) in the MadCap
Movie Viewer, rather than in a browser window.

n MCMOVIESYS This is an output file that is created when you generate a movie
collection. The file is named after your collection (e.g., mycollection.mcmoviesys) and
can be used as an entry point to view the movie collection. The output plays in the
MadCap Movie Viewer.

6. Click Open.
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7. (Optional) You can click in the drop-down field to the right and specify an output format.

IF YOU HAVE MIMIC 8 OR NEWER
n (default) If you build a Microsoft HTML Help, WebHelp, HTML5, or WebHelp Plus target,

the movie uses the HTML5 movie format.

n HTML5 The movie is generated in the HTML5 movie format.

IF YOU HAVE MIMIC 7 OR OLDER
n (default) The most appropriate movie format is used, based on the Flare output type

that you generate. If you build a Microsoft HTML Help, WebHelp, HTML5, or WebHelp
Plus target, the movie uses the HTML5 movie format. If you want to override these
settings, select one of the specific movie types below.

n MadCap Movie Player The movie is generated in MMF and displays in the MadCap
Movie Viewer.

n Adobe Flash The movie is generated in a Flash SWF file.

n Microsoft Silverlight The movie is generated in the Microsoft Silverlight format.

n HTML5 The movie is generated in the HTML5 movie format.

8. Click OK in the Properties dialog. The movie link is added to the TOC entry.

9. Click to save your work.

NOTE You do not need to add the Mimic movie files to your Flare project. When you
generate the target(s) in Flare, the movie output file(s) will automatically be copied to the
target output file or folder.
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Mimic Movie Links in Browse
Sequences

If you have used Mimic to produce a movie, you can use this feature to create a link in a browse
sequence entry to the movie's output.

How to Insert a Movie Link Into a Browse
Sequence

1. Open the browse sequence where you want to insert the movie link.

2. In the Browse Sequence Editor, double-click the browse sequence entry that you want to link
to the movie. The Properties dialog opens.

3. Select the General tab.

4. Select Mimic Movie or Movie Collection as. The Open dialog opens.

5. Find and select an individual Mimic movie or a movie collection to which you want to link the
entry. You can select any of the following types of files.

n MIMOV This is an individual Mimic movie file (whether part of a collection or
standalone). When you want to work on an individual movie, you open this file.

n MIPRJ This is the main Mimic collection file, which contains one or more movie
(MIMOV) files. It is not required that you create a collection in Mimic; it is simply an
option that you can use if you want to create a movie collection, as opposed to a
standalone movie. Neither the MIPRJ nor the MIMOV files are finalized movies. They
are merely the files that are used to generate the finalized movies. When you want to
work on a movie collection, you open the MIPRJ file.

n MCMOVIE This is an output file that is created when you generate a movie (whether the
movie is part of a collection or standalone). A Mimic collection can contain several
movies. When you generate the finalized movies in Mimic, an MCMOVIE file is created
for each movie in the collection (e.g., myfirstmovie.mcmovie,
mysecondmovie.mcmovie). The output plays in the MadCap Movie Viewer.

n MCMV This is an optional output file that lets you view the movie(s) in the MadCap
Movie Viewer, rather than in a browser window.
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n MCMOVIESYS This is an output file that is created when you generate a movie
collection. The file is named after your collection (e.g., mycollection.mcmoviesys) and
can be used as an entry point to view the movie collection. The output plays in the
MadCap Movie Viewer.

6. Click Open.

7. (Optional) You can click in the drop-down field to the right and specify an output format.

IF YOU HAVE MIMIC 8 OR NEWER
n (default) If you build a Microsoft HTML Help, WebHelp, HTML5, or WebHelp Plus target,

the movie uses the HTML5 movie format.

n HTML5 The movie is generated in the HTML5 movie format.

IF YOU HAVE MIMIC 7 OR OLDER
n (default) The most appropriate movie format is used, based on the Flare output type

that you generate. If you build a Microsoft HTML Help, WebHelp, HTML5, or WebHelp
Plus target, the movie uses the HTML5 movie format. If you want to override these
settings, select one of the specific movie types below.

n MadCap Movie Player The movie is generated in MMF and displays in the MadCap
Movie Viewer.

n Adobe Flash The movie is generated in a Flash SWF file.

n Microsoft Silverlight The movie is generated in the Microsoft Silverlight format.

n HTML5 The movie is generated in the HTML5 movie format.

8. Click OK in the Properties dialog. The movie link is added to the browse sequence entry.

9. Click to save your work.

NOTE You do not need to add the Mimic movie files to your Flare project. When you
generate the target(s) in Flare, the movie output file(s) will automatically be copied to the
target output file or folder.
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Editing Videos
You can edit videos in a variety of ways, depending on how you inserted the movie and what you
want to edit.

How to Edit Flash, Windows Media, QuickTime,
WebM, YouTube, or Vimeo Video Properties

1. Open the content file.

2. In the XML Editor, right-click the square or rectangle representing the area where the movie
will play.

3. From the context menu, select Edit Multimedia. The Edit Multimedia dialog opens.

4. Change the options on the tabs in the dialog as necessary.

GENERAL TAB
n You can select a different movie file. You can do this in various ways.

TO SELECT A FILE IN THE PROJECT

a. To select a movie file already in the project, select Multimedia in project.

b. Find and choose the file in the Select File area. Use the buttons in the local
toolbar to view all files in a list, view files in their folder structure, etc.

Shows all of the files in the project in a list below.
Click the button again to switch to a folder tree view.
You can click the File, Type, or Path column headers
to sort the list alphabetically by that column data.

Shows or hides the folders that the files are stored
in.
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Shows or hides the files. If you click this button
when the Show Folders button is selected, the
area splits into two. The folder is shown on the left
side, and the files and subfolders within it are shown
on the right.

If the Show Files button is the only one
selected, you can click this button to move up one
folder level.

Lets you filter the kinds of files shown below.
Depending on the task you are performing, this field
may already be populated with the most appropriate
file type(s).

c. (Optional) To select a movie file outside of the project, click . If you want to
select a movie file that you recently inserted somewhere in your project, click the
down arrow in the field next to and select the file from the list.

NOTE If you select a movie file outside the project, that file is then
copied and placed inside the project. The movie file is stored in the
Resources > Multimedia folder of the Content Explorer.
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TO SELECT A FILE FROM THE WEB

a. To select a movie file on the web, select Multimedia from Web.

b. In the field, enter the location of the movie file you want to use in your project.

NOTE You can only add YouTube and Vimeo files from the web.

NOTE When you insert a YouTube or Vimeo movie (using the Insert >
Multimedia option), these movies are not stored in your Resources >
Multimedia folder like other movie types, because Flare references them from
the web.

NOTE You can set YouTube videos to have a specific start time. For example,
you might want the video to begin playing not from its beginning, but rather 1
minute and 30 seconds into the movie. To do this, add the time you want the
video to start to the end of the URL using the format t=(time in minutes and
seconds). For example:

https://youtu.be/SI6PHhxHNNA?t=1m30s

The easiest way to do this is to open the video in YouTube, click the Share
button, enter the start time, and copy the URL given.
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n If you want to apply a specific style class to the movie, you can select it from the Style
Class field.

EXAMPLE You have created in your stylesheet a class of the object style
called "BigMargin" (i.e., object.BigMargin) and you have set the margin for all
sides of that class to 1 inch. Rather than using the default parent object style
when you insert the movie, you select object.BigMargin from the Style Class
drop-down. As a result, 1 inch of space is added around the movie in the
output.

n In the Screen Tip field you can type a phrase that will appear when the end user hovers
over the movie link in the output.

ADVANCED TAB

The options shown on this tab depend on the type of movie file you are inserting (Flash,
Windows Media, QuickTime, WebM, YouTube, Vimeo).

FLASH OPTIONS
n Quality Select the quality of the video, from "Low" up to "Best."

l Low Favors playback speed over appearance and never uses anti-aliasing.

l Auto Low Emphasizes speed at first but improves appearance whenever possible.
Playback begins with anti-aliasing turned off. If the Flash Player detects that the
processor can handle it, anti-aliasing is turned on.

l Auto High Emphasizes playback speed and appearance equally at first but sacrifices
appearance for playback speed if necessary. Playback begins with anti-aliasing
turned on. If the actual frame rate drops below the specified frame rate, anti-aliasing
is turned off to improve playback speed. Use this setting to emulate the View >
Antialias setting in Flash.

l Medium Applies some anti-aliasing and does not smooth bitmaps. It produces a
better quality than the Low setting, but lower quality than the High setting.

l High Favors appearance over playback speed and always applies anti-aliasing. If the
movie does not contain animation, bitmaps are smoothed; if the movie has
animation, bitmaps are not smoothed.
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l Best Provides the best display quality and does not consider playback speed. All
output is anti-aliased and all bitmaps are smoothed.

n Scale When you insert an embedded movie, a square container represents the area
where the video will be displayed. Just like a regular image, you can resize the
container either by using the settings on the Size tab or by clicking the clicking and
dragging the icon in the lower-right corner of the container. The settings in this field
determine how the video is displayed in the area represented by the square container.

l Default (Show All) Makes the entire movie visible in the specified area without
distortion, while maintaining the original aspect ratio of the movie. Borders may
appear on two sides of the movie.

l No border Scales the movie to fill the specified area, without distortion but possibly
with some cropping, while maintaining the original aspect ratio of the movie.

l Exact fit Makes the entire movie visible in the specified area without trying to
preserve the original aspect ratio. Distortion may occur.

n Alignment Select where you want the video to be displayed within the container area
(e.g., Left, Right, Bottom, Bottom Right).

n Auto play Select this option if you want the video to automatically begin playing when
the topic displays. Otherwise, the user must click the Play button to start the movie.

n Loop Select this option if you want the movie to play repeatedly.

n Show menu Select this option if you want to display the full menu, allowing the user a
variety of options to enhance or control playback. If you do not select this option, the
menu contains only the Settings option and the About Flash option.

n Enable SWLiveConnect Select this option to specify whether the browser should start
Java when loading the Flash Player for the first time.

WINDOWS MEDIA OPTIONS
n Player Controls Select an option for displaying the player controls (e.g., Play, Volume).

l Full Displays all of the available player controls.

l None Does not display any player controls.

l Mini Displays only some of the player controls (Play, Pause, Stop, Mute, Volume).
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l Invisible Hides the movie entirely, while still playing the audio. If you select this
option, you might want to resize the container square in your topic so that it does
not take up so much space in the output. The user will simply see blank space where
the container exists.

n Auto start Select this option if you want the video to automatically begin playing when
the topic displays. Otherwise, the user must click the Play button to start the movie.

n Full screen Select this option to display the movie using the entire screen.

n Stretch to fit Select this option to automatically resize the movie so that it exactly
matches the size of the container area.

n Play count Enter the number of times you want the video to repeat.

n Audio Select options for the sound (mute, volume level, balance).
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QUICKTIME OPTIONS
n Scale When you insert an embedded movie, a square container represents the area

where the video will be displayed. Just like a regular image, you can resize the
container either by using the settings on the Size tab or by clicking and dragging the
icon in the lower-right corner of the container. The settings in this field determine
how the video is displayed in the area represented by the square container.

l To Fit Automatically resizes the movie so that it exactly matches the size of the
container area.

l Aspect Automatically resizes the movie so that it exactly matches the size of the
container area. However, the image is not stretched, but rather kept in its original
proportion. For example, the width of the movie might be increased to match the
width of the container area, but extra empty space might be shown above and below
the movie in order to compensate for the height of the container area.

l Value Enter the value that you want to increase the display of the movie. If you
select 2, the movie will be twice as large as 1, and so on.

n Show controls Select this option to show the player controls (e.g., Play, Pause).

n Auto play Select this option if you want the video to automatically begin playing when
the topic displays. Otherwise, the user must click the Play button to start the movie.

n Loop Select this option if you want the movie to play repeatedly.

n Audio Select the volume level for the movie.

WEBM OPTIONS
n Show controls Select this option to show the player controls (e.g., Play, Pause). 

n Auto play Select this option if you want the video to automatically begin playing when
the topic displays. Otherwise, the user must click the Play button to start the movie.

n Loop Select this option if you want the movie to play repeatedly.

n Mute Select this option if you want the audio control in the output to initially be set to
mute when the movie is loaded.
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YOUTUBE OPTIONS
n Auto Hide Select this option if you want to hide the video's title and player controls bar

when the video begins playing.

n Auto Play Select this option if you want the video to automatically begin playing when
the topic displays. Otherwise, the user must click the Play button to start the movie.

n Full Screen Select this option if you want to allow users play the video in full-screen
mode.

n Show Related Videos Select this option if you want to show similar, suggested videos
when the video stops playing.

n Annotations Select this option if you want to show annotations from the video owner
when viewing the video.

l On Enables annotations from the video owner (i.e., notes about that pop up or
display during the video).

l Off Disables annotations from the video owner.

n Modest Branding Select this option if you want to remove the YouTube branding from
the player controls.

n Show Info Select this option if you want to show the title bar on the top of the video.

n Progress Bar Color Select the color you want to use for the player's progress bar.

l White Displays a white progress bar.

l Red Displays a red progress bar.

n Controls Select the display option for the player controls.

l Always on Displays player controls at all times.

l On during playback Displays player controls only during video playback.

l Off Disables player controls.

n Theme Select a color theme for the player controls.

l Light Displays a light gray player control bar.

l Dark Displays a black player control bar.

CHAPTER 2  43



NOTE Some advanced features may not work in all web browsers.

NOTE Setting the Progress Bar option to White overrides the Modest Branding
option, so you will always see the YouTube logo when you play your videos.

NOTE If you disable the player controls, users will only be able to play and pause the
video. They will not be able to adjust the volume, view or adjust the progress bar,
change video settings, or open the video in full-screen mode.

VIMEO OPTIONS
n Auto Pause Select this option if you want the video to automatically pause when

another Vimeo video in the topic is played. Otherwise, the user must click the Pause
button to pause the movie.

n Auto Play Select this option if you want the video to automatically begin playing when
the topic displays. Otherwise, the user must click the Play button to start the movie.

n Loop Select this option if you want the movie to play repeatedly.

n Byline Select this option if you want display the video owner's name on the video.

n Portrait Select this option if you want display the video owner's portrait on the video.

n Title Select this option if you want display the title on the video.

n Controls Color If you want change the color of the player controls, click and select
a color.

NOTE Some advanced features may not work in all web browsers.

NOTE Vimeo's advanced features are not available in Microsoft HTML Help and
Eclipse Help outputs.
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NOTE If the owner of the video is a Vimeo Pro or Vimeo Plus member, some of these
settings may be overridden by that member's preferences. For example, an owner of
a video may not allow you to remove the title and byline, so you will still see this
information on the video even if you chose not to display it in the Flare output.

NOTE You cannot remove the Vimeo Staff Picks badge from a video.

SIZE TAB

Complete the options as necessary to resize the container area where the movie will be
displayed. As an alternative, you can click and drag the icon in the lower-right corner of the
container.

TO SET A PRECISE WIDTH AND/OR HEIGHT

In the Width and/or Height field of the Size section, provide the settings. First you need to
select Length in the top drop-down list. You can then enter a value in the lower-left area and
choose from several different units of measurement (points, pixels, centimeters, etc.) in the
lower-right area.
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TO SET THE MINIMUM WIDTH AND/OR HEIGHT

If the original object is smaller than the minimum width or height that is set, it will be enlarged
so that it reaches the minimum value. If the original object is larger than the minimum width
or height, it will not be resized.

In the Width and/or Height field of the Minimum Size section, provide the settings. First you
need to select Length in the top drop-down list. You can then enter a value in the lower-left
area and choose from several different units of measurement (points, pixels, centimeters,
etc.) in the lower-right area.

TO SET THE MAXIMUM WIDTH AND/OR HEIGHT

If the original object is larger than the maximum width or height that is set, it will be reduced
in size so that it is no greater than the maximum value. If the original object is smaller than
the maximum width or height, it will not be resized.

In the Width and/or Height field of the Maximum Size section, provide the settings. First you
need to select Length in the top drop-down list. You can then enter a value in the lower-left
area and choose from several different units of measurement (points, pixels, centimeters,
etc.) in the lower-right area.

NOTE When resizing objects, you can ensure the aspect ratio is maintained. For
example, if you want certain objects to be resized so that each is exactly 3 inches
high, you can make sure the width of each object is adjusted accordingly to stay in
proportion. To do this, first set the height at 3 inches. You would not set the width
property at all. In the same way, if you were to specify an exact width, you could
maintain the aspect ratio by not setting the height.
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POSITION TAB

Complete the options as necessary to determine how the movie is positioned in the topic.
You can select a Float and a Clear setting. You can also set the Vertical Alignment of the
object.

FLOAT

Use this field to specify where to place the element on the page.

n None Does not place the element in a specific location.

n Left Positions the element on the left side of the page frame, allowing you to type text
to the right of the element.

n Right Positions the element on the right side of the page frame, allowing you to type
text to the left of the element.

n Center of Column Positions the element in the center of the column on the page.

n Outside Left Margin Positions the element beyond the left margin of the topic text.

n Outside Right Margin Positions the element beyond the right margin of the topic text.

n Outside Frame Positions the element outside of the page frame.

n Outside Frame, Top Align Positions the element outside of the page frame, as well as
aligning it with the top of the frame.

n Left of Frame Positions the element to the left of the page frame.

n Right of Frame Positions the element to the right of the page frame.

n Center of Frame Positions the element both vertically and horizontally in the middle of
the page frame.
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CLEAR

Use this field to position an element so that it is "clear" of an adjacent element. For example,
let's say you have already inserted an element and applied the float left property to it. If you
then insert another element immediately after the first element, you want to make sure that
the second element doesn't rest next to the first one. Instead, you want the second element
to be placed completely below the first one. Therefore, you can apply a clear property to the
second element.

n None Does not apply the clear property to the element.

n Left Side The element will be placed below the bottom outer edge of a previous
element that is floating left.

n Right Side The element will be placed below the bottom outer edge of a previous
element that is floating right.

n Both Sides The element will be placed below the previous one, whether floating left or
right.

VERTICAL ALIGNMENT

Use this field to adjust where the item is positioned vertically.

n Baseline The baseline of the box will be aligned with the baseline of the parent box.

n Text Top The top of the box will be aligned with the top of the parent element's font.

n Text Bottom he bottom of the box will be aligned with the bottom of the line box.

n Top The top of the box will be aligned with the top of the line box.

n Middle The vertical midpoint of the box will be aligned with the baseline of the parent
box, plus half the x-height of the parent.

n Bottom The bottom of the box will be aligned with the bottom of the line box.
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BORDERS & MARGINS TAB

Following are settings in the Borders & Margins tab.

MARGIN

Click in any of the individual fields (Left, Right, Top, Bottom) to specify the settings for the
margins around the object. If you click the down arrow to the right of all the fields, the
settings will be applied to all of the margin fields.

PADDING

Click in any of the individual fields (Left, Right, Top, Bottom) to specify the settings for the
padding. In the left side of the field, enter a number for the amount of padding. In the right
side of the field, select a unit of measurement (e.g., point, pixel, centimeter) for the number
you entered. If you click the down arrow to the right of all the fields, the settings will be
applied to all of the padding fields. When you click that down arrow, a small popup displays.

BORDERS

a. Click in any of the individual fields (Left, Right, Top, Bottom) to specify the settings for
the border. If you click the down arrow to the right of all the fields, the settings will be
applied to all of the border fields. When you click that down arrow or in one of the
individual fields, a small popup displays.

b. Use the lower-left area of the popup to enter a number for the border thickness.

c. Use the lower-middle area to select a unit of measurement (e.g., point, pixel,
centimeter) for the number you entered.

d. Use the upper-right area to select a color for the border.

e. Use the lower-right area to select a line type (e.g., solid, double, dashed) for the border.

f. Click OK.
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BACKGROUND TAB

Complete the options as necessary to determine how the background will be displayed in the
topic.

TO SET A COLOR FOR THE BACKGROUND

In the Color field, click the down arrow and select a color from the popup. For advanced color
options, select More Colors and use the fields in the Color Picker dialog.
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TO ADD AN IMAGE TO THE BACKGROUND

a. Next to the Image field, click the Browse button.

The Insert Image dialog opens.

b. Select an image file to insert and click OK.

c. If you want the background image to repeat, select one of the options from the Repeat
field. You can also set the image position horizontally and vertically by using the X and
Y fields.

5. Click OK.

6. Click to save your work.

How to Edit a Mimic Movie
1. Open the content file.

2. In the XML Editor, right-click the movie link.

3. In the context menu, select Edit Linked Movie. The movie or collection opens in MadCap
Mimic.

See Mimic's online Help for information about editing movies in that application.

If your movie link in Flare is directed to the movie or collection file, there is nothing else you
need to do in Flare. The next time you build your output, the movie(s) will automatically be
generated with the changes that you made.

If your movie link in Flare is directed to the generated output for the movie or collection, make
sure you re-generate the movie or collection output in Mimic after you make your changes.
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How to Edit Mimic Movie Link Properties
1. Open the content file.

2. In the XML Editor, right-click the movie link.

3. From the context menu, select Edit Movie Link. The Edit Mimic Movie dialog opens.

4. Change the options in the dialog as necessary.

n File Displays the path to the movie or collection file after you select it.

n Lets you find and select a different movie or collection file.

n Format You can use this drop-down to select the type of output to be generated.

IF YOU HAVE MIMIC 8 OR NEWER

l (default) If you build a Microsoft HTML Help, WebHelp, HTML5, or WebHelp Plus
target, the movie uses the HTML5 movie format.

l HTML5 The movie is generated in the HTML5 movie format.

l HTML5 (Embed) The movie is generated in the HTML5 movie format and is
embedded in your output.

IF YOU HAVE MIMIC 7 OR OLDER

l (default) The most appropriate movie format is used, based on the Flare output type
that you generate. If you build a Microsoft HTML Help, WebHelp, HTML5, or
WebHelp Plus target, the movie uses the HTML5 movie format. If you want to
override these settings, select one of the specific movie types below.

l MadCap Movie Player The movie is generated in MMF and displays in the MadCap
Movie Viewer.

l Adobe Flash The movie is generated in a Flash SWF file.

l Adobe Flash (Embed) The movie is generated in a Flash SWF file and is embedded
in your output.

l Microsoft Silverlight The movie is generated in the Microsoft Silverlight format.

l HTML5 The movie is generated in the HTML5 movie format.

l HTML5 (Embed) The movie is generated in the HTML5 movie format and is
embedded in your output.
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n Style Class Select the kind of style class to be used for the link to affect the way it looks
and behaves. You can select the main hyperlink style (a) or a class of that style.

n Link Text Displays the text that you highlighted in the topic, which will be used as the
movie link. Leave the text as it is, unless you decide you would like to change it. If you
want to change the link text, type the new text in the field. It will replace the previously
selected text in the topic. If you do not provide link text, the file name for the movie or
collection will be used.

n Screen Tip Type a phrase that will appear when the end user hovers over the movie link
in the output.

5. Click OK. The movie link is changed in the topic. You can change the appearance of the link
by modifying the style in the Stylesheet Editor.

6. Click to save your work.

What’s Noteworthy?

NOTE You can also edit Mimic movie links that have been inserted into TOCs or browse
sequences. To do this, simply open the Properties dialog for the TOC or the Properties
dialog for the browse sequence and make changes from there.
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CHAPTER 3

Other Activities for Videos
In addition to the main activities, there are some other tasks you might perform regarding this
feature.

This chapter discusses the following:

Previewing Videos 55

Deleting Video Files From the Project 55

Deleting Videos From Topics 56

Launching MadCap Mimic 56
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Previewing Videos
If you have inserted a link to a MadCap Mimic movie in a content file, you can easily preview the
video to see how it looks.

1. Open the content file.

2. In the XML Editor, right-click inside the hyperlink and from the context menu select Preview
Movie. The movie opens in the appropriate viewer.

Deleting Video Files From the Project
Use the following steps to remove a video (SWF) file from a project. Video files are added to the
project automatically when you insert a movie into a topic.

1. Open the Content Explorer.

2. Expand the Resources folder, and double-click the Images folder to open it (unless you have
stored these files in a custom folder).

3. Locate and select the SWF file that you want to delete.

4. On your keyboard press DELETE.

5. You may be asked if you are certain you want to send the file to the recycle bin. If so, click
Yes.
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Deleting Videos From Topics
Use the following steps to delete a video that you previously inserted into a topic.

1. Open the content file.

2. In the XML Editor, right-click the video.

3. From the context menu, click Delete.

4. Click to save your work.

Launching MadCap Mimic
Mimic is MadCap's movie-making and editing tool, which is tightly integrated with Flare.

Select Tools > MadCap > MadCap Mimic.
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APPENDIX

PDFs
The following PDFs are available for download from the online Help.

Tutorials
Getting Started Tutorial

Autonumbers Tutorial

Back-to-Top Button Tutorial

Context-Sensitive Help Tutorial

Custom Toolbar Tutorial

eLearning Tutorial—Basic

eLearning Tutorial—Advanced

Image Tooltips Tutorial

Lists Tutorial

Meta Tags Tutorial

Micro Content Tutorial—Basic

Micro Content Tutorial—Advanced

Responsive Output Tutorial

Single-Sourcing Tutorial

Snippet Conditions Tutorial

Styles Tutorials

Tables Tutorial

Word Import Tutorial
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Cheat Sheets
Context-Sensitive Help Cheat Sheet

Folders and Files Cheat Sheet

Learning & Development Cheat Sheet

Lists Cheat Sheet

Micro Content Cheat Sheet

Print-Based Output Cheat Sheet

Search Cheat Sheet

Shortcuts Cheat Sheet

Structure Bars Cheat Sheet

Styles Cheat Sheet
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User Guides
Accessibility Guide

Analysis and Reports Guide

Architecture Guide

Autonumbers Guide

Branding Guide

Condition Tags Guide

Context-Sensitive Help Guide

Eclipse Help Guide

eLearning Guide

Getting Started Guide

Global Project Linking Guide

HTML5 Guide

Images Guide

Import Guide

Indexing Guide

Key Features Guide

Lists Guide

MadCap Central Integration
Guide

Meta Tags Guide

Micro Content Guide

Navigation Links Guide

Plug-In API Guide

Print-Based Output Guide

Project Creation Guide

QR Codes Guide

Reviews & Contributions With
Contributor Guide

Scripting Guide

Search Guide

SharePoint Guide

Skins Guide

Snippets Guide

Source Control Guide: Git

Source Control Guide:
Perforce Helix Core

Source Control Guide:
Subversion

Source Control Guide: Team
Foundation Server

Styles Guide

Tables Guide

Tables of Contents Guide

Targets Guide

Template Pages Guide

Templates Guide

Topics Guide

Touring the Workspace Guide

Transition From FrameMaker
Guide

Translation and Localization
Guide

Variables Guide

Videos Guide

What's New Guide
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