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CHAPTER 1

Introduction
Supported In:

A template page lets you automatically apply certain content—such as breadcrumbs, menus,
toolbars, search bars, mini-TOCs, or footer text—to multiple topics in the output. A template page is
primarily used in online outputs, but it can be used in Word output as well. For Word output, a
template page lets you determine page specifications (such as size or orientation) and to apply
certain content (e.g., header text or page numbers) to many topics in a manual. For print-based
outputs other than Word, page layouts are used instead of template pages.

Page layouts are similar to template pages, but are more flexible and easier to use. The general rule
is that page layouts are recommended for print-based output, and template pages continue to be
the best method for automatically adding headers, footers, breadcrumbs, and more in multiple
topics for online output. Another difference between page layouts and template pages is that page
layouts can be used for Adobe PDF, Microsoft Word or Microsoft PowerPoint, whereas template
pages can be used only for Microsoft Word when creating print-based output.
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Like all other files in Flare, a template page is an XML file. It has an .flmsp extension. The traditional
location to store it in the Content Explorer is in the Resources > TemplatePages folder. However,
you can store it anywhere in the Content Explorer that you like.
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General Information

n "Page Layouts or Template Pages for Print Output?" on page 10

n "Print Template Pages" on page 11

n "Proxies and Template Pages" on page 23

Process

1. "Adding a Template Page File to a Project" on page 25

2. "Opening Template Pages" on page 28

3. "Creating Template Pages" on page 30

4. "Associating Template Pages With Targets" on page 32

5. "Associating Template Pages With Topics" on page 33

Other Activities

n "Custom Date/Time Variables in Template Pages" on page 40

n "Deleting Template Pages" on page 43

n "Disabling the Use of Template Pages" on page 44
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EXAMPLE You want every topic in your Help system to include a footer with contact
information about your company. Rather than having to type this content or insert a snippet
in every topic, you can create a template page and enter the footer in just that one location.
Then you associate the template page with any of the targets in your project. The footer is
automatically included at the bottom of every topic when you build and view any of those
associated targets.
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CHAPTER 2

General Information for
Template Pages
There are various pieces of general information you should know if you plan to use this feature.

This chapter discusses the following:

Page Layouts or Template Pages for Print Output? 10

Print Template Pages 11

Proxies and Template Pages 23
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Page Layouts or Template Pages for
Print Output?

For print-based output, there are two ways to set the configuration (e.g., page size, margins,
headers, footers) for pages in the output: page layouts and template pages.
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Print Template Pages
Supported In:

Print template pages are used to determine the look and content of pages in your printed output (if
you are generating Word output). If necessary, you can use different print template pages for
different purposes (e.g., title page, TOC, chapters, index).

NOTE You can use page layouts as an alternative to template pages. Page layouts are
similar to template pages, but are more flexible and easier to use. The general rule is that
page layouts are recommended for print-based output, and template pages continue to be
the best method for automatically adding headers, footers, breadcrumbs, and more in
multiple topics for online output. Another difference between page layouts and template
pages is that page layouts can be used for Adobe PDF, Microsoft Word or Microsoft
PowerPoint, whereas template pages can be used only for Microsoft Word when creating
print-based output.
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Print Template Page Considerations
If you are creating template pages for use in print-based output, keep the following in mind.

What is Included in a Print Template Page?
A print template page uses a Body proxy as a placeholder for content in your project, as well as
page header and footer proxies for page numbers. When you generate the output, a Body proxy is
replaced with your topic content. Body proxies can also be used to hold information about the size,
orientation, and margins for the printed pages.

In addition to proxies, you can add a wide range of content to template pages, similar to the way
you would add content to a regular topic. For example, you can add text or variables above or below
a Body proxy to be used as header or footer content for the printed output.

How Many Print Template Pages Do I Need?
That depends on your situation. You might need only one template page, or you might need multiple
template pages.

If the page settings and header/footer information on all of the pages of your document are
consistent, you may be able to use just one print template page. It is possible to have one print
template page with multiple body proxies on it. You might do this if you want different page settings
(e.g., margins, page number settings) for first, even, and odd pages of a manual. In other words,
each proxy can have a different page configuration. You can also add other content (e.g., text,
images, Heading variables, Running Head variables) above or below the Body proxy on a template
page, and you can designate each of these sets of content to show up specifically on a first, even,
or odd page.

However, you might not want to use just one template page for an entire document. Why? Because
you might have some sections of your manual where you do not want any headers or footers at all
(e.g., title page). Or you might want some sections of the manual to use one set of header or footer
content and other sections to use different header or footer content.
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Adding Page Header and Footer Proxies
The Page Header and Page Footer proxies let you insert content or automatic page numbering
(specifically designated for the first page, even pages, or odd pages) in a template page. Use the
Page Header proxy to insert content and page numbering above the body, and use the Page Footer
proxy to insert content and page numbering below the body. When you insert one of these proxies,
a page number placeholder is added automatically. You can delete it if you do not want to include a
page number in that location, or you can realign it (to the left, right or, center). If you want to specify
a starting page number or change the format (e.g., alpha, Roman, uppercase, lowercase), you can
do so by editing the Body proxy and changing the settings in the Printer Page Properties dialog. 
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How to Add Page Header and Footer Proxies
1. From the Content Explorer, open the template page.

2. Place your cursor at the location in the template page where you want to add a proxy.

3. Select Insert > Page Header or Insert > Page Footer. Depending on the type of proxy you
select, either the Page Header dialog or Page Footer dialog opens.

4. In the dialog, click the down arrow in the Stylesheet class field and make a selection. Select
either Odd Page, Even Page, or First Page (depending on whether you want that particular
header or footer content to be displayed on the odd pages, even pages, or first page of the
printed output).

NOTE If you want a page footer or header to always display on certain page types by
default, you can specify this in your stylesheet (using the mc-feader-type property).
Therefore, that page type will always be used as the default setting, unless you
override it at the spot where you have inserted the proxy.

NOTE You do not need to limit yourself to one page header or one page footer per
template page. If necessary, you can add three page headers (one for first pages, one
for odd pages, and one for even pages), and you can add three page footers (one for
first pages, one for odd pages, and one for even pages). This way, you only need to
use one template page to specify what header content is to be used on which pages
of the printed output.

5. Click OK.

The proxy is added to the template page. A holder for page numbering is automatically
added. However, this does not mean that you must use page numbering for that header or
footer. You can delete the page numbering holder if you want. It also does not mean that you
cannot add anything else to the header or footer. You can add any content that you want to
that header or footer by doing the following.

a. Place your cursor inside a particular page header or Page Footer proxy.

b. Type or insert the content as you normally would in a regular topic.
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TO SEE IF CURSOR IS WITHIN A PAGE HEADER OR FOOTER PROXY

If the tag block bars are not shown to the left of the content, click at the bottom of the
editor.

The tag bar to the left of the proxy will display the label (or at least the first part) for a
"MadCap|pageHeader" or "MadCap|pageFooter."
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TO SEE WHICH PAGE(S) WILL DISPLAY PAGE HEADER OR FOOTER CONTENT

To determine whether the page header or page footer will be displayed on odd pages, even
pages, or the first page of the printed output, right-click the structure bar to the left of the
proxy. Then from the context menu, select Style Class. The appropriate page designation will
have a check mark next to it.

6. Click to save your work.
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Editing the Page Type for Page Footers and
Headers
When you add page footer and header proxies for Microsoft Word output, you can specify which
types of pages (all, even pages, first page, odd pages) should display the footers or headers. This
can be done at the time you insert the proxy, but you can also use the following steps to set the
page type on a style. Therefore, that page type will always be used as the default setting, unless you
override it at the spot where you have inserted the proxy.

How to Edit the Page Type for Page Footers and
Headers

1. From the Content Explorer, open the stylesheet that you want to modify.

2. In the local toolbar, make sure the first button displays . If the button displays
instead, then click it.

3. In the upper-left corner of the editor, click in the drop-down field and select
.

4. In the Styles section on the left of the editor, find and select either MadCap|pageFooter or
MadCap|pageHeader (or a style class you have created within either style).

5. From the Show drop-down list on the upper-right side of the editor, select .
This displays only the properties that have been set for that particular selector.

6. From the Properties section, expand the Unclassified property group.

7. To the right of mc-feader-type click and select one of these options:

n all Displays the footer or header on all pages in the output.

n even Displays the footer or header only on even pages in the output.

n first Displays the footer or header only on the first page of each section.

n odd Displays the footer or header only on the odd pages in the output.

8. Click to save your work.
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Inserting Heading Variables Into Template
Pages
In addition to any type of regular content (e.g., text, images) and page numbers, you can insert
Heading variables or Running Head variables into template pages.

How to Insert a Heading Variable Into a Template Page
1. From the Content Explorer, open the template page.

2. Place your cursor inside a particular page header or page footer proxy.

3. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Insert > Variable.

n Local Toolbar Click .

n Keyboard Shortcut On your keyboard press CTRL+SHIFT+V.

The Variables dialog opens, with the variable set(s) on the left and the variables associated
with the selected set on the right.

4. Select the Heading variable set.

5. Select the variable you want to add:

n AnyLevel Automatically displays the text in the first heading on a page that uses any of
the h1 through h6 styles.

n Level1 Automatically displays the first text on a page that uses the mc-heading-level
style property set at 1. By default, the h1 style has the mc-heading-level set to 1 (that's
why it's called a first-level heading), but you can change it, and you can set the mc-
heading-level to 1 for other styles if you want.
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EXAMPLE You are using the keep the mc-heading-level set to 1 for the h1
style. Furthermore, you use the h1 style only for your chapter titles at the
beginning of each chapter. If you insert the Heading.Level1 variable into the
heading frames in the page layout that you are using for chapters, the
appropriate chapter title will display automatically at the top of each chapter in
the output.

n Level2 Automatically displays the first text on a page that uses the mc-heading-level
style property set at 2. By default, the h2 style has the mc-heading-level set to 2 (that's
why it's called a second-level heading), but you can change it, and you can set the mc-
heading-level to 2 other styles if you want.

n Level3 Automatically displays the first text on a page that uses the mc-heading-level
style property set at 3. By default, the h3 style has the mc-heading-level set to 3 (that's
why it's called a third-level heading), but you can change it, and you can set the mc-
heading-level to 3 for other styles if you want.

n Level4 Automatically displays the first text on a page that uses the mc-heading-level
style property set at 4. By default, the h4 style has the mc-heading-level set to 4 (that's
why it's called a fourth-level heading), but you can change it, and you can set the mc-
heading-level to 4 for other styles if you want.

n Level5 Automatically displays the first text on a page that uses the mc-heading-level
style property set at 5. By default, the h5 style has the mc-heading-level set to 5 (that's
why it's called a fifth-level heading), but you can change it, and you can set the mc-
heading-level to 5 for other styles if you want.

n Level6 Automatically displays the first text on a page that uses the mc-heading-level
style property set at 6. By default, the h6 style has the mc-heading-level set to 6 (that's
why it's called a sixth-level heading), but you can change it, and you can set the mc-
heading-level to 6 for other styles if you want.

NOTE The glossary and index variable options are available only in Adobe PDF
output.
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6. Click OK. The variable is added to the template page.

7. Click to save your work.

Inserting Running Head Variables Into Template
Pages
In addition to any type of regular content (e.g., text, images) and page numbers, you can insert
Heading variables or Running Head variables into template pages.
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How to Insert a Running Head Variable Into a Template
Page

1. Add a variable set to the project, selecting the Running HF template.

2. From the Content Explorer, open the template page.

3. Place your cursor where you want to insert a Running head variable (i.e., in a page header or
Page Footer proxy).

4. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Insert > Variable.

n Local Toolbar Click .

n Keyboard Shortcut On your keyboard press CTRL+SHIFT+V.

The Variables dialog opens, with the variable set(s) on the left and the variables associated
with the selected set on the right.

5. On the left side of the dialog, select the Running Head variable set that you created.

6. On the right side of the dialog, select the variable you want to insert. Unless you edit the
variable definitions to change the style classes within them, each variable is associated with
one of the six heading styles (h1-h6). When you insert a Running Head variable into a
template page, Flare inserts the text from the first occurrence of the specified style on that
page. If it doesn't find text using that style, it uses the text from the previous occurrence of
that style.

EXAMPLE If you want the header in chapters to display content that is using the h1
style (perhaps you are using this style to display the chapter title for your output),
select the Running H/F 1 variable. The header will then display the first h1 content
that it finds in the document (e.g., "My First Chapter Title"). When the next occurrence
of the h1 style appears on another page, the heading changes to display that text
(e.g., "My Second Chapter Title"), and so on.

7. Click OK. The Running Head variable is added to the template page.

8. Click to save your work.
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Proxies and Template Pages
You can add a proxy to a template page to let Flare know you want to include a certain type of
content in the template page. A proxy acts as a placeholder for auto-generated content or content
that you have created elsewhere. When you build output, the content takes the place of that proxy.
Proxies can be added to regular topics, as well as to template pages. The difference is that a proxy
added to a topic will display that information in the output only once (wherever the topic occurs),
but if a proxy is added to a template page, the content will show up everywhere that the template
page has been applied. Proxies are quite often used for print-based outputs, especially to create
navigation-like elements, such as TOCs, indexes, and glossaries. However, proxies can be used in
online output as well. They can be especially useful if you are creating HTML5 Top Navigation
output, where the traditional Tripane format is replaced by a more modern design that relies heavily
on proxies.
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CHAPTER 3

Process for Template Pages
Certain tasks must be completed in order when using this feature.

This chapter discusses the following:

Adding a Template Page File to a Project 25

Opening Template Pages 28

Creating Template Pages 30

Associating Template Pages With Targets 32

Associating Template Pages With Topics 33
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Adding a Template Page File to a
Project

You can add as many template pages to a project as you want. A template page lets you apply
consistent content to topics and is contained in a file with an .flmsp extension. The traditional
location to store a template page in the Content Explorer is in the Resources > TemplatePages
folder. However, you can store it anywhere in the Content Explorer that you like.

How to Add a Template Page File to a Project
1. Do one of the following, depending on the part of the user interface you are using:

n (Recommended) Right-Click In the Content Explorer, right-click a folder and from the
context menu select New > Template Page.

TIP When adding a new file to the Content Explorer, the recommended method
is to right-click on the folder in the Content Explorer and use the New menu
option. This is the most efficient way to direct the new file to the folder where
you want to store it. That's because the Add File dialog opens when you add a
new content file, and this method ensures that the folder you want is already
selected in that dialog.

n Ribbon Select Project > New > Add Template Page.

The Add File dialog opens.

2. In the File Type field at the top, make sure Template Page is selected.

3. In the Source area, choose to create the new file based on a template or an existing file.

n New From Template Choose either a factory template file or one of your own custom
template files as a starting point. The new file will take on all of the settings contained
in the template. If you want to use the factory template provided by Flare, expand the
Factory Templates folder and click on a template file. If you want to use your own
custom template file, expand the appropriate folder and click on a file. For more
information about templates, see the online Help.
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n New From Existing Choose an existing file of the same type as a starting point for your
new file. As with template files, your new file will take on all of the settings contained in
the file you select. To use this option, click , use the Open File dialog to find a file, and
double-click it.

4. (Optional) The Folder field is automatically populated with the folder that has focus in the
Content Explorer. If you want to place the file into a folder that you previously created in the
Content Explorer, in the Folder field click and select the subfolder. Otherwise, keep the
default location.

Non-Topic File Type Recommended Default Folder in Content Explorer

Branding Resources > Branding

Image Resources > Images

Micro Content Resources > MicroContent

Multimedia Resources > Multimedia

Page Layout Resources > PageLayouts

Snippet Resources > Snippets

Stylesheet Resources > Stylesheets

Table Stylesheet Resources > TableStyles

Template Page Resources > TemplatePages

5. In the File name field, type a new name for the template page.

6. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click and select the conditions you
want to apply. Click OK.
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7. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the
dialog. Next to the File Tags field, click and select the file tags you want to apply. Click OK.

8. Click Add. The template page file is added. The XML Editor opens to the right, with the new
template page shown.
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Opening Template Pages
The recommended location to store a template page in the Content Explorer is in the Resources >
TemplatePages folder. However, you can store it anywhere in the Content Explorer that you like. At
any time, you can open a template page and make modifications to it. The template page displays
in its own page of the XML Editor and remains accessible as you work.

How to Open a Template Page From the Quick
Launch Bar
The Quick Launch bar lets you search for any Flare file or command. It is located in the upper-right
corner of the interface. You can press CTRL+Q on your keyboard to move focus to the Quick
Launch bar so you can begin typing.

1. In the Quick Launch bar, type a few letters of the name of the file you want to open. Any
available results appear in a drop-down list.

2. From the list, click the name of the file.
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How to Open a Template Page From the
Content Explorer

1. Open the Content Explorer.

2. Expand the Resources, and double-click the TemplatePages subfolder to open it (unless you
have stored these files in a custom folder).

3. Do one of the following:

n Locate and double-click the template page file (NameOfTemplatePage.flmsp) that you
want to open.

n Locate and click the template page file (NameOfTemplatePage.flmsp) that you want to
open. In the local toolbar, click .

The template page opens in its own page of the XML Editor.
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Creating Template Pages
After adding template page files to a project, you can create template pages for use in both online
and Word output to apply certain content to multiple topics.

How to Add a Proxy to a Template Page
Depending on the template page template that you select, you might already have one or more
types of proxies in your template page. Some of these proxies are used primarily for online output
(e.g., Breadcrumbs, Menu, Search Bar), some are used for printed output (e.g., Glossary, Index, TOC,
Page Header, Page Footer), and some may be used for both online and printed output (e.g., Body,
Mini-TOC). Some proxies are typically added to topics, whereas others are usually inserted into
template pages, and some (e.g., Mini-TOC proxies) are often used in either.

1. From the Content Explorer, open the template page.

2. Place your cursor at the location in the template page where you want to add a proxy. The
horizontal cursor blinks. Use the up and down arrow keys on your keyboard to navigate
between proxies. Then press ENTER.

3. Select Insert > Proxy > Insert [Type of Proxy]. Depending on the type of proxy you select, one
of several types of dialogs opens.

4. In the dialog, complete the available options, if necessary. Some options (e.g., Stylesheet
class) are optional. Click OK. The proxy is added to the template page.

5. Click to save your work.

NOTE In some cases, you do not need to make any other changes to the template page;
the content for the proxies will be included automatically in the output as long as you
associate the template page with a target, or associate template pages with TOC entries (if
producing print-based output). However, you can add content above or below any of the
proxies.
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How to Remove a Proxy from a Template Page
1. From the Content Explorer, open the template page.

2. Right-click the proxy bar that you want to delete. In the menu, select Delete. The proxy is
removed from the template page.

3. Click to save your work.

How to Add a Template Page Header or Footer
If you want your topics to include a header or footer, you need to add content above the Body proxy
(for headers) or below the body (for footers). Use the arrow keys on your keyboard to move the
cursor above or below the Body proxy, then press ENTER and type the content.

For specific steps about headers and footers for printed output, see "Print Template Pages" on page
11.

1. From the Content Explorer, open the template page.

2. Click somewhere in the template page. The horizontal cursor blinks.

3. Press ENTER and add the content for the header or footer. If you want to add content in a
different area, press the up or down arrow on your keyboard until the horizontal cursor blinks
where you want it, then press ENTER and add content.

4. Click to save your work.
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Associating Template Pages With
Targets

If you want a template page to be applied to all topics in the output, you would associate that
template page with the target that you are building. This is useful, for example, if you want the
template page to include breadcrumbs, a mini-TOC, header content, or footer content for your
online outputs.

How to Associate a Template Page With a
Target

1. Open the target.

2. In the Target Editor, click the Advanced tab.

3. Click the drop-down arrow in the Template Page field, and select the template page that you
want to associate with the target.

4. Click to save your work.

NOTE If you want most topics to use a particular template page, but some other topics to
use a different one, you can associate the first template page with the target. Then you can
associate the other template page with the remaining topics. See "Associating Template
Pages With Topics" on the next page.
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Associating Template Pages With
Topics

You can associate a template page with individual topics, which is beneficial if you want some
topics to use one template page and other topics to use a different template page.

How to Associate a Template Page With Topics
via the Properties Dialog (Recommended)

1. Do one of the following, depending on whether you want to associate a template page with a
single topic or multiple topics:

n Single Topic If you want to associate a template page with a single topic, right-click the
topic file in the Content Explorer and choose Properties. The Properties dialog opens.

n Multiple Topics If you want to associate a template page with many topics, do this:

a. Select View > File List.

b. (Optional) From the Filter drop-down list in the local toolbar, you can select Topic
Files to limit the results in the grid to topics only.

c. Select the files to which you want to apply a stylesheet. You can hold the SHIFT
key to select a range, or you can hold the CTRL key to select individual items.

d. In the local toolbar, click . The Properties dialog opens.

2. Click the Topic Properties tab.

3. Click the Template Page field and select a template page.

4. Click OK.
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EXAMPLE You have a template page called "Primary," which you want most of your online
topics to use. This template page is set up so that in the output most topics will display
breadcrumbs and a search bar at the top of each page, a menu on the side, and some
copyright text at the bottom.
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But you also have a secondary template page called "Special." This template page includes
the same things as the Primary template page, but you also have your company logo under
the copyright text. You want 8 specific topics to use the Special template page.
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To accomplish this, you associate the Primary template page with the target (see
"Associating Template Pages With Targets" on page 32). But for the other topics, you can
open the Properties dialog and choose the Special template page.
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How to Associate a Template Page With Topics
via the mc-template-page Property

1. Create the template pages that you need.

2. Open your stylesheet (in the Advanced view) and select the html style on the left side of the
editor.

3. Create a new class. When you are finished it will be placed under the html style.

4. Select your new class on the left side of the editor.

5. In the upper-right corner of the Stylesheet Editor, click the Show field and select Show:
Assorted Relevant Properties.

6. To the right of the mc-template-page property, click , then select the template page to be
associated with it.

NOTE If you are working in Group View, this property can be found under
Unclassified.

7. Click to save your work.

8. Open a topic that you want to associate with that template page.

9. Make sure the structure bars are turned on.

10. To the left of the topic content, right-click the html bar.

11. In the context menu, select Style Class and choose the html style class that you want to
apply.

NOTE You will not see any styles from this list until you create a class for the html
style in the Stylesheet Editor.
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CHAPTER 4

Other Activities for Template
Pages
In addition to the main activities, there are some other tasks you might perform regarding this
feature.

This chapter discusses the following:

Adding Copyright Text to Topics 39

Custom Date/Time Variables in Template Pages 40

Deleting Template Pages 43

Disabling the Use of Template Pages 44
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Adding Copyright Text to Topics
A template page is the perfect way to add copyright information to many, or all, topics.

How to Add Copyright Text to Topics
1. Open a template page.

2. Click the body proxy and then use your arrow keys to move the cursor above or below the
proxy, depending on whether you want the copyright text at the top or bottom of topics.

3. In a new paragraph, enter your copyright text. You also might want to insert variables (e.g.,
company name, year format).

4. Click to save your work.
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Custom Date/Time Variables in
Template Pages

In addition to any type of regular content (e.g., text, images) and page numbers, you can also insert
custom date/time variables into template pages. This lets you display the date and time on each
page of your output. These variables update as if they are part of the topic, so you do not need to
add a variable to each individual topic in your output.

How to Insert a Custom Date/Time Variable Into
a Template Page

1. From the Content Explorer, open the template page.

2. Place your cursor in the template page where you want to insert a custom date/time variable.
If you insert it above the Topic Body proxy, the date and time are shown in the header (above
the topic content). If you insert it below the Topic Body proxy, the date and time are shown in
the footer (below the topic content).

3. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Insert > Variable.

n Local Toolbar Click .

n Keyboard Shortcut On your keyboard press CTRL+SHIFT+V.

The Variables dialog opens, with the variable set(s) on the left and the variables associated
with the selected set on the right.

4. On the left side of the dialog, select the variable set that you created.
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5. On the right side of the dialog, select the custom/date time variable that you want to insert.
When you insert a custom date/time variable into a template page, Flare will insert the
appropriate date and time (based on your variable's update settings) into the topic as if it
were part of the topic itself.

EXAMPLE You want each topic in your online output to display the time the file was
saved so your users know exactly when your Help topics were updated. You create a
custom date/time variable that updates each time a file is saved.
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Then add it to the footer area of the template page.

When you build your online output, each topic shows the date and time that it was
last saved at the bottom of the output.

6. Click OK. The custom date/time variable is added to the template page.

7. Click to save your work.

NOTE Custom date/time variables are not supported in page layouts.
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Deleting Template Pages
If necessary, you can delete a template page that you have created.

How to Delete a Template Page
1. Open the Content Explorer.

2. Expand the Resources folder, and double-click the TemplatePages subfolder to open it
(unless you have stored these files in a custom folder).

3. Click the template page that you want to delete.

4. On your keyboard press DELETE.

5. When asked if you are sure you want to delete the template page, click Yes.

NOTE You can also disassociate template pages from targets. That way, you do not need
to delete the template page. In that case, the template page would still exist in the project
(in case you decide to use it again in the future), but it does not show up in any of the
outputs. For more information see "Associating Template Pages With Targets" on page 32,
and remove the template page from the target.
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Disabling the Use of Template Pages
You might have used template pages in earlier versions of Flare when creating Word output, but
then decide to use the newer page layouts instead. You can manually remove all links to template
pages in your target and table of contents. However, another alternative is to automatically disable
the use of template pages in your project. By using this feature, Flare will ignore all links to template
pages when you generate the Word target. It will instead use links that you provide to any page
layouts.

How to Disable the Use of Template Pages
1. Open the target.

2. In the Target Editor, select the MS Word Options tab.

3. Click the check box next to Disable Template Pages for MS Word output.

4. Click to save your work.
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APPENDIX

PDFs
The following PDFs are available for download from the online Help.

Tutorials
Autonumbers Tutorial

Back-to-Top Button Tutorial

Context-Sensitive Help Tutorial

Custom Toolbar Tutorial

eLearning Tutorial—Basic

eLearning Tutorial—Advanced

Getting Started Tutorial

Image Tooltips Tutorial

Lists Tutorial

Meta Tags Tutorial

Micro Content Tutorial—Basic

Micro Content Tutorial—Advanced

Responsive Output Tutorial

Single-Sourcing Tutorial

Snippet Conditions Tutorial

Styles Tutorials

Tables Tutorial

Word Import Tutorial
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Cheat Sheets
Context-Sensitive Help Cheat Sheet

Folders and Files Cheat Sheet

Learning & Development Cheat Sheet

Lists Cheat Sheet

Micro Content Cheat Sheet

Print-Based Output Cheat Sheet

Search Cheat Sheet

Shortcuts Cheat Sheet

Structure Bars Cheat Sheet

Styles Cheat Sheet
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User Guides
Accessibility Guide

Analysis and Reports Guide

Architecture Guide

Autonumbers Guide

Branding Guide

Condition Tags Guide

Context-Sensitive Help Guide

Eclipse Help Guide

eLearning Guide

Getting Started Guide

Global Project Linking Guide

HTML5 Guide

Images Guide

Import Guide

Indexing Guide

Key Features Guide

Lists Guide

MadCap Central Integration
Guide

Meta Tags Guide

Micro Content Guide

Navigation Links Guide

Plug-In API Guide

Print-Based Output Guide

Project Creation Guide

QR Codes Guide

Reviews & Contributions With
Contributor Guide

Scripting Guide

Search Guide

SharePoint Guide

Skins Guide

Snippets Guide

Source Control Guide: Git

Source Control Guide:
Perforce Helix Core

Source Control Guide:
Subversion

Source Control Guide: Team
Foundation Server

Styles Guide

Tables Guide

Tables of Contents Guide

Targets Guide

Template Pages Guide

Templates Guide

Topics Guide

Touring the Workspace Guide

Transition From FrameMaker
Guide

Translation and Localization
Guide

Variables Guide

Videos Guide

What's New Guide
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