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CHAPTER 1

Introduction
Flare 2024 r2 release notes can be found here.

Following are the new features available in Flare 2024 r2.

For more information about each feature discussed in this manual, open the online Help and refer
to the "What's New" topic. Links are provided in some feature descriptions, taking you to topics that
contain additional information and steps.

"PowerPoint Output" on page 5

n Support for a new target output type: Microsoft PowerPoint

n Ability to single-source project content and generate PowerPoint slides for online or
print presentations

n Share content with other teams that use the PowerPoint tool

"Upcoming Deprecated Features" on page 31

n List of features that will be deprecated

n Recommended replacements for deprecated features
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CHAPTER 2

PowerPoint Output
Flare supports Microsoft PowerPoint output for slideshow presentations. This format is ideal for
single-sourcing content (e.g., text, images, lists, tables) in your project and creating PowerPoint
(PPTX) output. The content packaged for PowerPoint is your deliverable for printed distribution or
online presentations. You do not need to edit slides in PowerPoint, but you can if necessary.

The PowerPoint output type is a hybrid format. Although it has elements of a print-based output, it
is commonly shared and viewed digitally (e.g., you intend to create an online presentation).

When you create PowerPoint output from a new or an existing project, the main thing you need s a
PowerPoint target. The output will display with basic styles already in place, but the format might
be insufficient. With a little more effort, you can make your PowerPoint presentation shine by
adding and styling content, arranging a TOC, adding a PowerPoint page layout, and specifying
target options.
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EXAMPLE You are using Flare to make training material. This works great for creating
eLearning courses in PDF or online formats, but you also need a slideshow presentation to
deliver the content in front of an audience. You would like to single-source the content and
export the material into a PowerPoint presentation. Flare’s PowerPoint target output type
eliminates the task of copying and pasting content from your project into PowerPoint
slides. PowerPoint output lets you format slides and maintain larger slide decks, as well as
share content across your organization.

This chapter discusses the following:

Adding Content for PowerPoint 7

Adding a Page Layout for PowerPoint 9

Adding and Editing a Target for PowerPoint 20

Building and Viewing a PowerPoint Target 24

Post-Processing in PowerPoint 25

Supported Features in PowerPoint Output 27

What’s Noteworthy? 30
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Adding Content for PowerPoint
Similar to other types of output, there are a number of ways to create, organize, and design a
project for PowerPoint slides. The following points serve as a guideline to help you get started.

n Create content for the presentation You can reuse content from existing topics or you can
create content in new topics for PowerPoint output.

You can se features such as lists, images, snippets, QR codes, cross-references, etc.

Use stylesheets to add or edit styles and customize the look and feel of the content for your
presentation. You can use the default stylesheet or create a new one.

If your presentation includes tables, you can use existing table styles (or create a new table
stylesheet) to format the way they look and behave.
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NOTE When creating content for a PowerPoint presentation, each "topic" typically
equates to a "slide." If a topic is long (i.e., it runs beyond the frame of the slide) it will
extend into multiple slides. This can happen depending on a myriad of reasons such
as text overflow, font size, spacing between lines, etc. A couple ways to control your
content is with reorganizing the topic or with page breaks. You can manually insert
page breaks or you can set page breaks on styles.

NOTE Each element will likely be converted to its own editing box in PowerPoint.

n Add topics to a TOC outline You can add topics to an existing TOC or create a new TOC file if
you want. This file serves as an outline for the topics in the PowerPoint output. Simply drag
and drop topics from the Content Explorer to the TOC Editor, or use buttons in the local
toolbar of the TOC.
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Adding a Page Layout for PowerPoint
To add basic formatting to your PowerPoint output, use a factory page layout template. It is
recommended to use either Landscape4x3.flpgl r Landscape16x9.flpgl for PowerPoint. Of those
two choices, the slide size differs (i.e., displaying with a standard 4:3 or widescreen 16:9 aspect
ratio). The templates include andscape page orientation, and a default body frame size, but do not
include headers or footers. hese two page layout templates improve the initial output appearance
and workflow between Flare and PowerPoint.

How to Add a Page Layout
1. Do one of the following, depending on the part of the user interface you are using:

n (Recommended) Right-Click In the Content Explorer, right-click a folder and from the
context menu select New > Page Layout.

n Ribbon Select Project > New > Page Layout.

The Add File dialog opens.

TIP If your project does not include a folder for page layouts under the Content
Explorer's Resources folder, it might be a good idea to create a new folder called
PageLayouts.

2. In the File Type field at the top, make sure Page Layout is selected.

3. In the Source area, under New from template, expand Factory Templates (if not already), and
select the landscape template that will best fit the needs of your presentation (i.e.,
Landscape4x3.flpgl, or Landscape16x9.flpgl).

NOTE You can create other page layout templates for PowerPoint output. For
example, most slide decks employ the landscape format with a standard (4:3) or
widescreen (16:9) slide size, but you can create a presentation using the portrait
format instead. Whatever the case, you can customize the page layout according to
your intended design.
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4. (Optional) The Folder field is automatically populated with the folder that has focus in the
Content Explorer. If you want to place the file into a folder that you previously created in the
Content Explorer, in the Folder field click and select the subfolder. Otherwise, keep the
default location.

5. In the File Name field, type a new name for the page layout.

6. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click and select the conditions you
want to apply. Click OK.

7. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the
dialog. Next to the File Tags field, click and select the file tags you want to apply. Click OK.

8. Click Add. The page layout is added to the Content Explorer. The Page Layout Editor opens to
the right, displaying the page layout.

TIP Once you have a page layout template in your project that you want to use for
PowerPoint you might want to build and view the output. It is likely that you will want to
make page layout adjustments. Before you build it, you must first tie the page layout with
the PowerPoint target, so Flare knows what layout to use. Do this in the Target Editor by
selecting the General tab, and then a Primary Page Layout.
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EXAMPLE For a regional conference about birds, you have created a project using Flare
and have added content to it. Knowing that you need to generate PowerPoint output, you
plan for each topic to be a “slide” and use cascading stylesheets to design the content. Up
until now, you have viewed your progress by building HTML5 output, but now you want to
build and see it in PowerPoint.

First, add a page layout for PowerPoint. In the Content Explorer, right-click on a folder and
from the context menu select New > Page Layout.
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Then, in the Add File dialog, select a template, provide a name, and click Add. Note that 4x3
and 16x9 in the names of the two landscape template choices, efers to the aspect ratio of
the slide.

The page layout is added to the designated folder in the Content Explorer.
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Modifying a Layout in the Page Layout Editor
The advantage of using a factory page layout specifically for PowerPoint output is that a working
template is set up for you. However, you can adjust properties such as page type, page size, page
orientation, and body frame.

To edit the page properties, double-click the page in the Page Layout Editor and select Properties.

The landscape page layout templates include one page (i.e., a Normal page type) by default.
Although you can generate PowerPoint output with a single page type in the page layout, you can
add more pages. For example, you might want to add a First page for an introduction, or include a
page with a different set of margins applied.

Right-click the small page graphic in the Page Layout Editor, and select an item from the context
menu (e.g., Add Page > First Page).
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If your PowerPoint output design includes multiple page types (e.g., a First page, and a Normal
page), you need to account for this using the TOC Editor's Printed Output options. For example, you
might have a cover page or introduction using one page type, and then another page type starting
with the next page. These options dictate how a page behaves in the output.

From each relevant topic in the TOC, select to display its properties. Select the appropriate Break
Type, Page Layout, and Page Type.
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EXAMPLE When you add a page layout for PowerPoint to the project, a working template
is set up for you. Once you build your target, you might realize you want to change page
layout properties for customization.

View the page layout in the Page Layout Editor. In this case, it displays with default
properties. No adjustments have been made to it yet.

You want to add a template page for the first slide in your presentation. Right-click the
small page graphic, and select Add Page > First Page. You can keep the default page
properties or update them if you have a special need.
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Notice another page type displays in the editor. Save the file.

From the TOC, locate the first slide (or welcome topic), right-click and select Properties.
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In the Printed Output tab select the appropriate Break Type (e.g., Chapter Break, Page
Layout Break), Page Layout (e.g., Widescreen.flpgl), and Page Type (First). Click OK.

Locate the second slide, and select the Break Type (e.g., Chapter Break, Page Layout
Break), Page Layout (e.g., Widescreen.flpgl), and Page Type (e.g., Normal). Click OK.
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Then, for the third slide, confirm that the Break Type defaults to None. Any topics that
occur after this slide will inherit its settings. Click OK.

Rebuild the PowerPoint output type. Notice how the page layout adjustments affected the
format of the presentation.

CHAPTER 2  18



NOTE If you are not using a PowerPoint page layout where landscape mode is already set
in the template), the output can default to a portrait page orientation. You can change the
orientation using the Page Layout Editor.

NOTE Do not mix and match landscape and portrait page orientations for PowerPoint
output—use one or the other. Otherwise, problems with formatting can occur. he more
common use case is to use landscape.

NOTE There is an order of precedence with the three levels where you can specify a page
layout. Specific entries in an outline TOC have the highest precedence, followed by page
layouts at the target level, followed by page layouts at the project level. If you have a page
layout set at the project or target level and it does not seem to be working the way you think
it should, you might check to see if you have any page layouts set on specific TOC entries
that are overriding the target- or project-level setting.

NOTE There is a limitation when setting gradient options for a PowerPoint page layout
template. The gradient color will always start from left to right—regardless of which setting
is selected. These settings are in Page Properties, with the Background tab in focus.
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Adding and Editing a Target for
PowerPoint

At a minimum, you must have a PowerPoint target. If you do not have one for PowerPoint output,
select to add a new target to your project.

How to Add a PowerPoint Target
1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Project > New > Add Target.

n Right-Click In the Project Organizer, right-click on the Targets folder and from the
context menu select Add Target.

The Add File dialog opens.

2. In the File Type field at the top, make sure Target is selected.

3. In the Source area, under New from template, expand Factory Templates (if not already), and
select the default template (e.g., MyTarget).

4. (Optional) If you want to place the file into a subfolder reviously created in the Content
Explorer or Project Organizer, in the Folder field click and select the subfolder. Otherwise,
keep the default location.

5. In he File Name field, type a new name for the target.

6. From the Output Type field, select PowerPoint.

7. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click and select the conditions you
want to apply. Click OK.

8. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the
dialog. Next to the File Tags field, click and select the file tags you want to apply. Click OK.

9. Click Add. The target is added to the Targets folder in the Project Organizer. The Target Editor
opens to the right.
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How to Edit PowerPoint Options
If you are sending output to Microsoft PowerPoint, you can access PowerPoint options in the
Target Editor. These options let you specify document properties and other options for the output.

1. Open a target that is using the PowerPoint format.

2. Select the PowerPoint Options tab.

3. Enter information as necessary. This includes metadata such as the document title, author,
subject, keywords, etc. In the PowerPoint application, you can view the document properties
information in File > Properties.

NOTE If you want to insert a variable in a field, you can click . The variable will
appear as syntax in the field, but in the output the variable definition will be shown.
The variable button displays after you click a field.
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4. Associate a page layout with the PowerPoint output so Flare knows there is a specific layout
to use. Set the layout in the Target Editor if you are not setting it in the TOC, or if you are using
more than one page layout in the project.

NOTE You can set the page layout at the TOC, target, or project level. For example, if
you are using a page layout template with multiple pages types, you might want to
set a page layout at a TOC node level. But if you plan to use the same page type for
the entire slide show, then setting it at the target level might be better.

a. In the Target Editor, select the General tab.

b. From the Primary Page Layout drop-down, select the page layout that you want to use
for topics in the target. (You can also et a TOC and stylesheet files for the PowerPoint
target.)

NOTE The Target Editor > General tab > Output Type drop-down defaults to
PowerPoint when interacting with a PowerPoint target.
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NOTE The Target Editor includes many other options to consider for your
PowerPoint output. For example, the Advanced tab has options for auto-generating
proxies and handling text effects.

5. Click to save your work.
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Building and Viewing a PowerPoint
Target

When you have content, a PowerPoint page layout, and PowerPoint target in place for your project,
you can build the output.

You can quickly build PowerPoint output from the PowerPoint target if you select Build. When it is
complete, select View Output (or double-click the build row) from the Builds window pane. f he
PowerPoint application is installed, the output opens in PowerPoint. The output files are placed in
the Project's Output folder (e.g., C:\Project\Output\[name]\PPTX).

If no files have been identified for the page layout, TOC, or stylesheets n the Target Editor, he
project builds with default target options.
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Post-Processing in PowerPoint
The main point of the PowerPoint output type is that it puts content n a packaged form for
PowerPoint. When you use Flare as your authoring source, the generated content is your deliverable
for PowerPoint. There is no need to finalize the slide deck by customizing or cleaning up output.

It is possible, however, to make changes in the PowerPoint application if absolutely necessary. For
example, you might want to draw on slides, add themes, slide transitions, and slide animations.

WARNING If you edit content in the PowerPoint application, those changes will not be in
your source project in Flare. Anytime you rebuild the output using Flare, the fixes you made
in PowerPoint will not be evident in the output. You will have to manually make those
changes again. (You cannot import those changes back into Flare from PowerPoint.)

As a best practice, edit in Flare so the changes are available and saved in your source files.

CHAPTER 2  25



TIP View your output in PowerPoint's reading or full-screen slide show mode to review your
presentation. For example, you might want to verify links that you have included re
working. You can test links in PowerPoint's normal mode but it is difficult to find the
clickable spot. In full-screen (presentation mode) the links are quicker to review because
the boundaries are clearer.
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Supported Features in PowerPoint
Output

Many features commonly used in Flare are supported in PowerPoint output (e.g., text, images, lists,
tables), but some are not.

PowerPoint supports the following features, but with special behavior n the output.

Feature Special Behavior in PowerPoint Output

Branding CSS variables display in PPTX output, but the branding stylesheet must
be specified at the target or project level.

Drop-Down Text The text displays expanded like other print-based outputs.

eLearning Question
Sections

PPTX output is not interactive, but it displays multiple choice and
multiple response question types. In the Target Editor's Advanced tab,
you can select to show the correct answers in the output.

Equations An equation is exported as an image.

Expanding Text The text displays expanded like other print-based outputs. In the Target
Editor's Advanced tab, you can select how you want the ext to be
converted (e.g., as footnotes, inline, or remove the body).

FAQ Proxy FAQ content displays as expanded text in a topic. You can use a
custom FAQ skin component with your FAQ content.

Glossary Proxy A glossary generates in PPTX output if specified in the Target Editor's
Advanced tab.

Headers (and
Footers)

Headers and footers do not directly convert into PowerPoint headers
and footers, but the content from headers and footers defined by the
page layout converts to a text box.
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Feature Special Behavior in PowerPoint Output

Horizontal Rules An inserted horizontal rule displays like other print-based outputs (e.g.,
as a ine in PPTX output).

Images Images are embedded in PPTX output.

A background image is supported with properties: repeat and no-
repeat. It does not support repeat horizontally or vertically.

Index Proxy An index generates in PPTX output if specified in the Target Editor's
Advanced tab. (Index terms need to be included in your project.)

Links Links are functional both to external sites and to other slides. (Cross-
references only point to a slide, not to another location on the slide.)

Micro Content Micro content associated with search results, such as featured
snippets, Knowledge panel, and Promotion or Knowledge roxies do not
display in PPTX output. However, micro content using the FAQ proxy
does display in PPTX output.

Multimedia Most audio and video formats play in the output. Some player controls
are not supported in the output.

Page Layout When setting gradient options for a PowerPoint page layout template,
the gradient always starts from left to right, regardless of which setting
is selected.

The PowerPoint page layout defaults to a solid border (or column
divider) even if another option is selected.

QR Codes A QR code is exported as an image.
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Feature Special Behavior in PowerPoint Output

Tables Tables that include rounded corners display as squared corners in
PPTX output.

Text Formatting Text wrapping around a floating image does not display as such in
PPTX output.

Text layout limitations might occur when floated, inline in combination
with a block in the same parent.

Text Popups Text popups display as expanded text. In the Target Editor's Advanced
tab, you can select how you want the ext to be converted (e.g., as
footnotes, inline, or remove the body).

TOC Proxy A TOC generates in PPTX output if specified in the Target Editor's
Advanced tab.

Togglers The text displays expanded like other print-based outputs.
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What’s Noteworthy?
TIP The PPTX file is in essence a ZIP file. You can rename the .PPTX extension to .ZIP and
extract it. All the embedded files (XML files included in the single-packaged PPTX file) will
display in organized folders and files.

NOTE You must have the PowerPoint application to view the output, but you do not need it
installed to build the output.

NOTE The PPTX file is the same as the older PPT, but the appended X stands for XML
support. The Open XML format manages multimedia, text, images, etc., that can be
included in a presentation, and it stores data in folders that are zipped together rather than
in one binary file.
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CHAPTER 3

Upcoming Deprecated Features
Following are features that will be removed in a future release of MadCap Flare, alongside features
that we recommend as replacements.

Deprecated Features Recommended Replacements

DITA Output Clean XHTML Output or HTML5 Output

Feedback Central Analytics

Pulse Central Analytics

Toolstrip Ribbons

WebHelp and WebHelp Plus HTML5 Output

To provide feedback on these deprecated lists, please send an email to:

supportplanrep@madcapsoftware.com.
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APPENDIX

PDFs
The following PDFs are available for download from the online Help.

Tutorials
Autonumbers Tutorial

Back-to-Top Button Tutorial

Context-Sensitive Help Tutorial

Custom Toolbar Tutorial

eLearning Tutorial—Basic

eLearning Tutorial—Advanced

Getting Started Tutorial

Image Tooltips Tutorial

Lists Tutorial

Meta Tags Tutorial

Micro Content Tutorial—Basic

Micro Content Tutorial—Advanced

Responsive Output Tutorial

Single-Sourcing Tutorial

Snippet Conditions Tutorial

Styles Tutorials

Tables Tutorial

Word Import Tutorial
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Cheat Sheets
Context-Sensitive Help Cheat Sheet

Folders and Files Cheat Sheet

Learning & Development Cheat Sheet

Lists Cheat Sheet

Micro Content Cheat Sheet

Print-Based Output Cheat Sheet

Search Cheat Sheet

Shortcuts Cheat Sheet

Structure Bars Cheat Sheet

Styles Cheat Sheet
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User Guides
Accessibility Guide

Analysis and Reports Guide

Architecture Guide

Autonumbers Guide

Branding Guide

Condition Tags Guide

Context-Sensitive Help Guide

Eclipse Help Guide

eLearning Guide

Getting Started Guide

Global Project Linking Guide

HTML5 Guide

Images Guide

Import Guide

Indexing Guide

Key Features Guide

Lists Guide

MadCap Central Integration
Guide

Meta Tags Guide

Micro Content Guide

Navigation Links Guide

Plug-In API Guide

Print-Based Output Guide

Project Creation Guide

QR Codes Guide

Reviews & Contributions With
Contributor Guide

Scripting Guide

Search Guide

SharePoint Guide

Skins Guide

Snippets Guide

Source Control Guide: Git

Source Control Guide:
Perforce Helix Core

Source Control Guide:
Subversion

Source Control Guide: Team
Foundation Server

Styles Guide

Tables Guide

Tables of Contents Guide

Targets Guide

Template Pages Guide

Templates Guide

Topics Guide

Touring the Workspace Guide

Transition From FrameMaker
Guide

Translation and Localization
Guide

Variables Guide

Videos Guide

What's New Guide
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