
USER GUIDE

MADCAP FLARE DESKTOP 2025

Analysis and Reports



Copyright © 2025 MadCap Software. All rights reserved.

Information in this document is subject to change without notice. The software described in this document is furnished
under a license agreement or nondisclosure agreement. The software may be used or copied only in accordance with the
terms of those agreements. No part of this publication may be reproduced, stored in a retrieval system, or transmitted in
any form or any means electronic or mechanical, including photocopying and recording for any purpose other than the
purchaser's personal use without the written permission of MadCap Software.

MadCap Software
1660 17th Street, Suite 201
Denver, Colorado 80202
858-320-0387
www.madcapsoftware.com

THIS PDF WAS CREATED USING MADCAP FLARE.



CONTENTS

CHAPTER 1

Introduction 5
Analysis on Source Files 6
Analysis on Output Files 9

CHAPTER 2

Analysis Ribbon 12
Enabling Analysis Scans 13
Analysis Summary 15
Viewing Issues for Specific Files 23
Validating XML Files 27
Links Analysis 28
Suggestions 42
Undefined Items 81
Used Items 108
More Analysis Scans 124

CHAPTER 3

Reports 155
Adding Report Files 156
Generating Reports 157
Opening Reports 160

CONTENTS iii



Saving Reports 161
Viewing the Word Count 162
Exporting File Data to a CSV File 164

CHAPTER 4

Text Analysis 166
How to Run a Text Analysis 166

CHAPTER 5

Flare Online Analytics 171
Permission Required? 173
Types of Analytics Information 174
Host Output Anywhere 180
Creating and Editing Analytics Keys 181
Associating Analytics Keys With Targets 182
Managing Analytics Keys 183
Downloading Analytics 184

CHAPTER 6

Content Services Portal 185
How to Access the Production Content Services Portal 186
How to Access the Local Content Services Portal 187
Managing Search Indexes 188
Importing Data From an Upgrade 194

APPENDIX

PDFs 195
Tutorials 195
Cheat Sheets 196
User Guides 197

CONTENTS iv



CHAPTER 1

Introduction
You can use various tools to analyze project source files for issues, and view user activity on
output.

This chapter discusses the following:

Analysis on Source Files 6

Analysis on Output Files 9
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Analysis on Source Files
No setup is needed for analysis of source files. You simply run scans on your project.

Analysis Ribbon
From the Analysis ribbon in Flare Desktop, you can scan files and run reports to discover a wide
variety of information. This includes broken links or bookmarks, files with changes, topics not in a
table of contents (TOC), used meta tags, and more. See "Analysis Ribbon" on page 12.
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Reports
From the Reports folder in the Project Organizer, you can generate custom reports based on
information contained in your project. In addition, you can design the look and feel of reports, save
them for future access, and open them in a browser window (where you can print them). See
"Reports" on page 155.
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Text Analysis
From the Tools ribbon in Flare Desktop, you can run text analysis on content files for readability,
average sentence length, and more.
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Analysis on Output Files
By collecting information about how people are using your output, you can more effectively make
decisions to improve the content.

MadCap Flare Online Analytics
If you have a MadCap Flare Online license, you can view analytics on published HTML5 output. This
includes search phrases used, search phrases with no results, topics viewed, context-sensitive Help
calls, and demographic statistics (browsers and operating systems). See "Flare Online Analytics" on
page 171.

The process is quite simple. You create an analytics key in a couple of steps, associating it with a
target. Then after building and publishing your output, you use the Analytics page in Flare Online to
view user activity on the output as it occurs.

Analytics works on projects located in Flare Online, or you can host output on your own servers. If
you host the output outside of Flare Online, you still need to use Flare Online with a key to view the
analytics data. Also, the server where the output is hosted must be able to communicate with Flare
Online (e.g., not be behind a firewall).
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MadCap Content Services
The Content Services Portal is used to manage search indexes on your Elasticsearch output. You
can review and manage search indexes by topic, micro content, user searches, and global
searches. See "Content Services Portal" on page 185.
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Google Analytics
You might decide to use Google Analytics (or another third-party tool) for reporting activity on your
output. If you have a Google Analytics account, you can obtain a tracking code, which you can then
add to your template page(s) in a Flare project. After publishing the output, you can use the Google
Analytics website to see various reports about your output. For more information, please refer to
the Google Analytics website.

Syndicate Analytics
If you publish output files to a Xyleme Syndicate destination, you can use the analytics that are
built-in to the application. Since Syndicate was designed primarily for learning and development
(although it also hosts technical documentation), its analytics centers on tracking user interactions
with content. It can track how users consume content such as individual topics or videos. For
eLearning it can manage millions of records in its built-in learning record store (LRS). See the
Syndicate documentation.

NOTE If you are interested in learning more about Syndicate, contact MadCap Sales. They
can provide information about the product, demos, review purchase options, and set up
Syndicate accounts.
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CHAPTER 2

Analysis Ribbon
From the Analysis ribbon in Flare Desktop, you can scan files and run reports to discover a wide
variety of information. This includes broken links or bookmarks, files with changes, topics not in a
table of contents (TOC), used meta tags, and more.

This chapter discusses the following:

Enabling Analysis Scans 13

Analysis Summary 15

Viewing Issues for Specific Files 23

Validating XML Files 27

Links Analysis 28

Suggestions 42

Undefined Items 81

Used Items 108

More Analysis Scans 124
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Enabling Analysis Scans
You can enable or disable the collection of different types of information when the analysis engine
scans a project for possible issues and problems. Also, by disabling scans, you may find that your
system performance is improved somewhat. In addition to disabling scans, you can limit the
number of results returned.

How to Enable Analysis Scans
1. Select File > Options. The Options dialog opens.

2. Select the Project Analysis tab.

3. Enable or disable any of the following:

n Collect Segments Select this check box if you want Flare Desktop to collect segments
of text while scanning your project. Segment collection lets you view information about
your project such as frequent segments found and index keyword suggestions.

n Collect Variable Prospects Select this check box if you want Flare Desktop to look for
text that you might want to convert to variables.

n Collect Snippet Prospects Select this check box if you want Flare Desktop to look for
text that you might want to convert to snippets.

n Collect Local Style Prospects Select this check box if you want Flare Desktop to look for
places where you have applied local formatting and might want to apply styles to those
areas instead.

n Collect Embedded Stylesheet Prospects Select this check box if you want Flare
Desktop to look for style information (embedded styles in <style> elements) in your
topic files. Disabling this scan limits the results found in the style reports.

NOTE You should select this option if you have imported topics that have
embedded styles. Otherwise, it is not usually necessary to select this option.

n Collect Accessibility Prospects Select this check box if you want Flare Desktop to look
for text where you might want to add web accessibility features (e.g., captions,
alternate text).
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n Collect Markup Prospects Select this check box if you want Flare Desktop to look for a
variety of XHTML markup issues in your content (e.g., extra spaces, empty attributes).
You can open the affected files and clean up the markup in them. You may be able to
fix some issues in the XML Editor, but other issues may require you to open the behind-
the-scenes code in the Internal Text Editor.

NOTE In order for these options to be effective, you must set the options before
opening your project. If you have your project open and a scan is in process, setting
these options will not improve your system performance.

4. You can click in the Search Limits field to limit the number of results returned from some
reports. You can limit the search results to 100, 500, 1000, or 5000. If All is selected, there are
no limitations for the search results. You might want to use this feature to improve
performance.

When a limit is selected, it is applied to the following window panes and reports:

n Index Keyword Suggestions

n New Style Suggestions

n Replace Local Style Suggestions

n Undefined Styles

5. Click OK.
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Analysis Summary
The Analysis Summary window pane displays current issues for the project that you are analyzing.
Issues might be critical problems (e.g., broken links) or simply information that can be used for
improving the project (e.g., new style suggestions). After the analysis tool finishes scanning your
project and displays the current issues, you can double-click on a row to the open the appropriate
window pane and take action.
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Option Description

Scans your project so that the latest current issues are displayed in the
Summary window pane and the most recent information is shown in other
window panes in the application.

Opens the advanced scan options dialog, which lets you enable or disable the
collection of different types of information when your project is scanned for
possible issues and problems. Also, by disabling scans, you may find that your
system performance is improved somewhat. See "Enabling Analysis Scans" on
page 13.

Exports all the data in the window pane to a CSV file.

Exports selected data in the window pane to a CSV file.

Project Displays the name and path of the project that you are scanning.

Last Scan
Date

Displays the most recent date and time that your project was scanned.

Status Displays the status of a scan on your project (e.g., "Scanning," "Up-To-Date").
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Option Description

Summary This section displays any current issues that the project analysis module has
found after scanning your project. From the Summary window pane, you can
double-click any of the issue rows. Doing this opens the appropriate window
pane in the interface so that you can see more information about the reported
issues and take action (e.g., fix broken links).

n Category Displays the group into which the issue fits. For example, if
there is a broken link, the category is "Link." If the analysis is suggesting
that you create a snippet from specific content, the category is
"Suggestion."

n Issue Displays the exact kind of issue found.

n Count Displays the number of places where the issue is found.

n Status Displays the status of the issue. In other words, a cell may display
"Loading…" if the analysis tool is still scanning for the issue.
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Viewing Current Issues
After opening a Flare project, the project can be scanned for possible issues by opening the
Summary window pane. From the Summary window pane, you can double-click any of the issue
rows. Doing this opens the appropriate window pane in the interface so that you can see more
information about the reported issues and take action (e.g., fix broken links).

How to View Current Issues
1. After opening a project, select the Analysis ribbon. In the Dynamic Reports section, click the

Summary button. When you do this, the Summary window pane opens automatically, listing
any issues in your project. You can also perform a manual scan of the project by clicking
in the local toolbar of the Summary window pane.

This window pane displays the kind of issue that has been uncovered. It might be a "critical"
issue displayed in a red font (such as a broken link or undefined style) that you should fix as
soon as possible. Otherwise, it might be an "informative" issue (such as a suggestion for a
new style), which might be a good change to consider, but not necessarily urgent.
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2. Double-click any row to open the appropriate window pane to deal with the issue.

For example, if you double-click the broken links row, the Broken Links window pane opens. If
you double-click the new style suggestions row, the New Style Suggestions window pane
opens.

Following are the main activities when dealing with current issues. For more information and
steps about each of these, see the Help system or the relevant PDF guide (e.g. Styles Guide
for any style-related issues).

LINKS
n Absolute links—viewing and fixing

n Broken bookmarks—viewing and fixing

n Broken links—viewing and fixing

n External links—viewing and checking

n Incoming and outgoing links—viewing

n Named destinations—viewing

n Topics not linked—viewing

SNIPPETS
n Suggestions—viewing and converting

n Files with snippet conditions—viewing

VARIABLES
n Suggestions—viewing and converting

n Undefined variables—viewing and fixing

n Unused variables—viewing

n Used variables—viewing and renaming
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SEGMENTS
n Frequent segments—viewing, customizing, and converting to snippets or variables

n Similar segments—viewing

n Topics for a selected item—viewing

STYLES
n Duplicate styles—viewing

n Local style suggestions—viewing and replacing

n New style suggestions—viewing and converting

n Undefined styles—viewing and fixing

n Unused styles—viewing

TOCS
n Duplicate items in TOC—viewing

n Topics not in TOC—viewing

INDEXES
n Links—viewing and renaming

n Suggestions—viewing and adding

n Topics not indexed—viewing

n Used index keywords—viewing and renaming

CONDITION TAGS
n Undefined condition tags—viewing and fixing

n Unused condition tags—viewing

n Used condition tags—viewing and renaming

CHAPTER 2  20



FILE TAGS
n Undefined file tags—viewing and fixing

n Unused file tags—viewing

n Used file tags—viewing and renaming

OTHER FEATURES
n Annotations and tracked changes—viewing

n Concepts (used)—viewing and renaming

n Concepts within concept links—viewing and renaming

n Content files (unused)—viewing

n Cross-reference suggestions—viewing and converting

n CSH IDs (unused)—viewing

n Empty content folders—viewing

n Glossary term links (undefined)—viewing and fixing

n Images (unused)—viewing

n Language tags (used)—viewing

n Markup suggestions—viewing

n Non-XML topics—viewing and converting

n Topics not linked by map ID—viewing

n Writing suggestions—viewing
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Viewing Database Errors
You can view miscellaneous errors that may occur regarding the database in the Analyzer folder of
your project. These happen when your project contains data not compatible with the database. If a
file is listed in this pane, it will not be included in any analysis or suggestions. If your project
contains database errors, please contact MadCap Software's technical support team for help.

How to View Database Errors
1. On the Analysis ribbon, click Summary.

2. Find the row where Database Errors are listed under the Issue column. Double-click on the
row to view the errors.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n File Displays the name of the file.

n Folder Displays the folder where the file is found.

n Description Displays a description of the error. When contacting MadCap technical
support, you should provide the information in this column.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

NOTE You can also include this information in reports that you create.
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Viewing Issues for Specific Files
The File Issues Viewer displays any issues associated with specific topics in the Flare project you
are analyzing. You can also view issues associated with specific targets in the Flare project.
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How to View Issues for Specific Files
1. Open a project.

2. Do one of the following:

TO ADD MANY FILES TO THE FILE ISSUES VIEWER

a. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Analysis > File List.

n Keyboard Shortcut Press CTRL+SHIFT+J.

The File List window pane opens.

b. In the File List window pane select the files you want to view. You can hold the SHIFT
key to select a range, or you can hold the CTRL key to select individual items.

c. Once the files are selected, do one of the following.

n Local Toolbar Click .

n Right-Click Right-click any of the selected files and from the context menu, select
Send to File Issues Viewer.

The File Issues window pane opens with all the selected files listed in the Files field.

TO ADD ONE FILE AT A TIME TO THE FILE ISSUES VIEWER

a. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Analysis > File Issues.

n Local Toolbar Click .

The File Issues Viewer window pane opens.

b. Do one of the following:

n Local Toolbar Click .

n Right-Click Right-click in the list area at the top of the Viewer and select Add.
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NOTE Files cannot be added or removed unless the By Target field is specified
as “(Selected Files)”.

c. In the dialog that opens, find and select the content file(s) you want to add to the
Viewer. Then click Open. You can use the buttons in the local toolbar to view all files in
a list, view files in their folder structure, etc.

Option Description

Shows or hides the folders that the files are stored in.

Shows or hides the files. If you click this button when the Show
Folders button is selected, the area splits into two halves. The
folder is shown on the left side, and the files and subfolders within it
are shown on the right.

Shows or hides hidden files and folders.

If the Show Files button is the only one selected, you can click this
button to move up one folder level.

The bottom of the Viewer shows the types of issues found for the file(s) in the viewer, and
how many.

3. Double-click any row at the bottom of the Viewer to open the appropriate window pane to
deal with the issue.

CHAPTER 2  25



How to View Issues for Specific Targets
1. Open a project.

2. On the Analysis ribbon, click the File Issues button.

The File Issues Viewer opens.

3. From the By Target field, select the target for which you want to view issues.

The bottom of the Viewer shows the types of issues found for the file(s) in the target, and
how many.

4. Double-click any row at the bottom of the Viewer to open the appropriate window pane to
deal with the issue.

NOTE Files cannot be added or removed unless the By Target field is specified as
“(Selected Files)”.
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Validating XML Files
If you are unable to open a file, it is possible that the file has invalid XML code (e.g., unclosed tags,
starting tag is uppercase with a lowercase end tag). When you have files with invalid XML, they are
added to the non-XML Topics window pane. Files such as these can be fixed by validating the file in
Flare Desktop.

How to Validate XML Files
1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select View > File List.

n Keyboard Shortcut Press CTRL+SHIFT+J.

2. Right-click on a file with invalid XML and select Validate XML.

The XML Validator dialog opens. The left side shows the markup for the original file, and the
right side shows the markup for the file after the invalid XML has been fixed. You can switch
to the WYSIWYG view by clicking Show Source Code to remove the check mark.

3. (Optional) You can click Create Backup File if you want to keep a copy of the original file in
your Backups window pane.

4. Click Save.
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Links Analysis
In the Analysis ribbon, the Links drop-down button provides several options to view potential issues
in your Flare project.

Viewing Broken Links
You can view a list of files in your project where a broken link is located, including which file it is
trying to find, the link text, the link tag, and other information. Also, you can open the file where the
broken link is located. The broken link is highlighted so that you can easily fix it. 

How to View and Fix Broken Links
1. From the Analysis ribbon, click the Summary button.

2. If you see a row indicating broken links in red, double-click it.

3. In the grid listing all broken links, double-click one.

4. In the file that opens, the broken link is highlighted.

5. Edit the broken link or remove it.

6. Click to save your work.
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How to Fix Links Directly in the Broken Links Window
Pane

1. In the Broken Links window pane, click the row that you want to correct, then click . The Fix
Broken Links dialog opens.

2. In the Fix Broken Links dialog, do one of the following.

n Click or right-click a file and from the context menu, select Select file for linking. This
option opens a dialog, from which you can select a new link.

n Click or right-click a file and from the context menu, select Scan for Potential Links.
This option scans the project for potential matches to the broken link. When this option
is selected, the Search for Similar Files dialog opens, which lists the similar files that
the analysis tool has found. You can then select a file from that list.

The name of the file you select to fix the broken link will be displayed in the File field at the
bottom of the Fix Broken Links dialog.

3. Click Apply.
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Viewing Broken Bookmarks
You can view a list of files with broken bookmarks, including the bookmark destination that the link
is trying to find, the link text, the link tag, and other information. Also, you can open the file where
the broken link is located so that you can fix it. 

How to View and Fix Broken Bookmarks
1. Open a content file (e.g., topic).

2. Select Analysis > Links > Broken Bookmarks.

The Broken Bookmarks window pane opens. The area at the bottom of the window pane
displays all files that contain bookmark links to the open file that are broken.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n File Displays the name of the file where the broken link occurs.

n Folder Displays the folder where the file is found.

n Link Displays the link that is broken (e.g., the path and name of the topic in question).

n Type Displays the type of broken link (e.g., missing file).

n Link Text Displays the text in the source topic that is being used as the link.

n Link Tag Displays the style used for the link. For example, if a regular text hyperlink is
used, you will see "a" in this column.

n Extension Displays the file extension that the link is not finding (e.g., .htm, .jpg).

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

5. Double-click the row that you want to correct. The file opens in the appropriate editor or
dialog. For example, if the link appears in a topic, the XML Editor opens with the broken link
highlighted.

6. Redirect the link as necessary (e.g., right-click on the link and select Edit Hyperlink or Edit
Cross-Reference).
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Viewing External Links
You can view a list of files in your Flare project containing links to external files. For example, if you
have a text hyperlink to a website, the file name where the link exists is displayed. By clicking the
"Check" button, you can verify that all external links point to valid destinations. You can either
double-click on the specific row, or right-click on the row and select Open. This lets you fix any
problems with external links.

How to View External Links
1. Open a project.

2. Select Analysis > Links > External Links.

The External Links window pane opens, listing all of the occurrences of external links in the
project.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Link Displays the external link.

n Status Displays the status of the external link. After you click the "Check" button, this
cell provides a message indicating whether the external link is valid or not.

n File Displays the name of the file where the external link occurs.

n Folder Displays the folder where the file is found.

n Link Text Displays the text in the source topic that is being used as the link.

n Link Tag Displays the style used for the link. For example, if a regular text hyperlink is
used, you will see "a" in this column.

n Extension Displays the extension of the file where the link is pointing (e.g., htm).

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.
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How to Check and Fix External Links
1. In the External Links window pane, select the rows that you want to validate. You can hold the

SHIFT key to select a range, or you can hold the CTRL key to select individual items.

2. Click the Check button. If a particular external link does not point to a valid destination, the
Status cell displays a message indicating so.

3. If the external link is not valid, you can remove it or fix it in the source file. You can either
double-click on the specific row, or right-click on the row and select Open.

4. Remove or redirect the link as necessary (e.g., right-click on the link and select Unbind or Edit
Hyperlink).
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Viewing Absolute Links
You can view a list of files in your Flare project containing absolute links to other files. An absolute
link contains the full path to the target file. For example, let's say you have a text hyperlink that
points to a file in your project like this: file://C:\MyProject\Content\MyFile.htm. (You can view this
link format in the file's true code, which can be seen by using the Internal Text Editor in the source
Flare project.) Because users do not have access to your local C: drive, they will not be able to use
the link successfully in the output. Instead, the link should be relative to the file in your project, with
dots and slashes that represent each folder level away from the current file (e.g., ..\..\MyFile.htm).
You do not need to create this path manually; instead, it is automatically created when you properly
insert a link by using the interface. The Absolute Links window pane lets you find absolute links so
that you turn them into relative links (by re-inserting the link). You can either double-click on the
specific row, or right-click on the row and select Open. The link is highlighted so that you can easily
fix it.
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How to View Absolute Links
1. Open a project.

2. Do one of the following:

n Ribbon Select Analysis > Links > Absolute Links.

n Analysis Window Pane Double-click the row that mentions absolute links.

The Absolute Links window pane opens, listing all of the occurrences of absolute links in the
project.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Link Displays the link that is absolute (e.g., the path and name of the topic).

n File Displays the name of the file where the absolute link occurs.

n Folder Displays the name of the folder in the Content Explorer, which contains the file
where the absolute link occurs.

n Link Text Displays the text in the source topic that is being used as the link.

n Link Tag Displays the style used for the link. For example, if a regular text hyperlink is
used, you will see "a" in this column.

n Extension Displays the extension of the file where the link is pointing (e.g., htm).

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

How to Fix Absolute Links
1. You can either double-click on the specific row, or right-click on the row and select Open.

2. Redirect the link as necessary (e.g., right-click on the link and select Edit Hyperlink).
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Viewing Named Destinations
Named destinations are used to point to a specific place in a PDF. You can view the named
destinations in your project by opening the Named Destinations window pane. In this window pane,
you also have the option to either rename or delete them.

How to View Named Destinations
1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Analysis > Links > Named Destinations.

n Analysis Summary Window Pane Double-click the row that mentions named
destinations.

The Named Destinations window pane opens, listing all of the occurrences of named
destinations in the project.

2. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Name Displays the name of the named destination.

n File Displays the name of the file.

n Name Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

3. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.
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How to Rename Named Destinations
1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Analysis > Links > Named Destinations.

n Analysis Summary Window Pane Double-click the row that mentions named
destinations.

The Named Destinations window pane opens, listing all of the occurrences of named
destinations in the project.

2. In the Named Destinations window pane, do one of the following, depending on which part of
the user interface you are using:

n Local Toolbar Select a named destination and click Rename.

n Keyboard Shortcut Select a named destination and press F2 on the keyboard.

n Right-Click Right-click the named destination and from the context menu, select
Rename.

n Double-Click Double-click the named destination to open the topic in which it is located,
then right-click the named destination marker in the topic and from the context menu,
select Edit Named Destination.

The Rename Named Destinations dialog opens.

3. In the dialog, enter a new name for the named destination.

4. Click OK.

CHAPTER 2  36



How to Delete Named Destinations
1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Analysis > Links > Named Destinations.

n Analysis Summary Window Pane Double-click the row that mentions named
destinations.

The Named Destinations window pane opens, listing all of the occurrences of named
destinations in the project.

3. In the Named Destinations window pane, do one of the following:

n Local Toolbar Select a named destination and click in the local toolbar.

n Keyboard Shortcut Select a named destination and press DEL on the keyboard.

n Right-Click Right-click the named destination and from the context menu, select Delete.

n Double-Click Double-click the named destination to open the topic in which it is located,
then right-click the named destination marker in the topic and from the context menu,
select Delete.

A message will appear asking you to confirm the deletion.

4. Click OK.
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Viewing Index Keyword Links
You can view a list of all index keywords used in index links throughout your project. You can also
quickly rename index keywords associated with the links.

For more information about index keywords and how they are used in projects, see the Index Guide
or the Help system.

How to View Index Keywords Used in Index Links
1. Open a project.

2. Select Analysis > Links > Index Keyword Links.

The Index Keyword Links window pane opens, listing all of the index keywords used within
index links throughout the project.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Keyword Displays the index keyword used in an index link in the file.

n File Displays the path and name of the file where the index keyword link is inserted.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.
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How to Rename Index Keyword Links
1. In the window pane, select all keywords that you want to rename. If you want to select all

rows click . You can hold the SHIFT key to select a range, or you can hold the CTRL key to
select individual items.

NOTE All keywords that you select will be renamed to the same keyword that you
provide in the following steps.

2. In the local toolbar, click the Rename button. The Rename Index Keyword Link(s) dialog
opens.

3. In the New index keyword link name field, enter a new index keyword.

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected
keywords are renamed.

NOTE If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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Viewing Concepts in Links
You can view a list of all concepts that have been used in concept links throughout your project.
You can also quickly rename concepts associated with the links.

For more information about concepts and how they are used in projects, see the Help system for
more information.

How to View Concepts Used in Concept Links
1. Open a project.

2. Select the Analysis ribbon. In the Dynamic Reports section, select Links > Concept Links. The
Concept Links window pane opens, listing all of the concepts used within concept links
throughout the project.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Concept Displays the concept used in a concept link in the file.

n File Displays the path and name of the file where the concept link is inserted.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.
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How to Rename Concepts Used in Concept Links
1. In the window pane, select all concepts that you want to rename. If you want to select all

rows click . You can hold the SHIFT key to select a range, or you can hold the CTRL key to
select individual items.

NOTE All concepts that you select will be renamed to the same concept that you
provide in the following steps.

2. In the local toolbar, click the Rename button. The Rename Concept Link(s) dialog opens.

3. In the New concept link name field, enter a new concept.

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected
concepts are renamed.

NOTE If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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Suggestions
In the Analysis ribbon, the Suggestions drop-down button provides several options.

Viewing Index Keyword Suggestions
You can view a list of topics containing text that matches existing index keywords in your project.
You can then quickly add the same index keywords to those topics.

EXAMPLE You have opened Topic A and inserted "Chair" as an index keyword. The word
"Chair" may also occur in the text of Topic B. If you have not yet inserted the word "Chair" as
an index keyword in Topic B, it will show up when you view index keyword suggestions.
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How to View Index Keyword Suggestions
1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Analysis > Suggestions > Index Keyword Suggestions.

n Summary Window Pane Double-click the row that mentions index keyword
suggestions.

The Index Keyword Suggestions window pane opens.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Keyword Displays the index keyword text found in the topic that matches an existing
keyword.

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.
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How to Convert Suggestions to Index Keywords
Do one of the following, depending on whether you want to convert multiple suggestions to index
keywords simultaneously, or if you want to convert only one index keyword suggestion at a time.

To Convert Multiple Suggestions Simultaneously

1. In the window pane, select all suggestions that you want to convert. If you want to select all
rows click . You can hold the SHIFT key to select a range, or you can hold the CTRL key to
select individual items.

2. In the local toolbar, click the Apply button.

3. In the message that opens, click OK. Another message lets you know how many files were
changed.

4. Click OK. All of the selected suggestions are converted to index keywords.

NOTE If you want to undo the conversions, you can use the Backups window pane
(View > Backups).

To Convert One Suggestion at a Time

1. In the Index Keyword Suggestions window pane, select the row that you want to convert to an
index keyword.

2. You can either double-click on the specific row, or right-click on the row and select Open. The
file opens in the application with the suggested content highlighted.

3. Insert the index keyword. See the Help system for more information about inserting index
keywords.
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Viewing Snippet Suggestions
You can view content that matches existing snippets in your project, and you can quickly convert
these occurrences to snippets. You can also double-click a row to open the topic in question, with
the potential snippet content highlighted.

How to View Snippet Suggestions
1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Analysis > Suggestions > Snippet Suggestions.

n Analysis Summary Window Pane Double-click the row that mentions snippet
suggestions.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Suggestion Displays the suggestion that the analysis is making to you (i.e., "Replace
with Snippet").

n Snippet Path Displays the location in your project's Content Explorer where the snippet
is found, as well as the name of the snippet (e.g.,
Resources/Snippets/NewSnippet.flsnp).

n File Displays the path and name of the file where the content in question is found.

n Folder Displays the folder where the file is found.

n Xml Text Displays the exact XML tag structure of the content in question.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.
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How to Convert Suggestions to Snippets
Do one of the following, depending on whether you want to convert multiple suggestions to a
snippet simultaneously, or if you want to convert only one snippet suggestion at a time.

To Convert Multiple Suggestions Simultaneously

1. In the window pane, select all suggestions that you want to convert. If you want to select all
rows click . You can hold the SHIFT key to select a range, or you can hold the CTRL key to
select individual items.

2. In the local toolbar, click the Apply button.

3. In the message that opens, click OK. Another message lets you know how many files were
changed.

4. Click OK. All of the selected suggestions are converted to snippets.

NOTE If you want to undo the conversions, you can use the Backups window pane
(View > Backups).

To Convert One Suggestion at a Time

1. In the Snippet Suggestions window pane, select the row that you want to convert to a snippet.

2. You can either double-click on the specific row, or right-click on the row and select Open. The
file opens with the suggested content highlighted.

3. In Flare Desktop, insert the snippet (e.g., select Insert > Snippet).

CHAPTER 2  46



What’s Noteworthy?

NOTE Keep in mind that in order for content to be found and included in the Snippet
Suggestions window pane, it must match the tag of the existing snippet exactly. For
example, let's say that your snippet is a paragraph within a div tag. If you simply type the
same text as the snippet on a simple paragraph in a topic, that content will not be found as
a snippet suggestion. However, if you were to place that paragraph within a div tag in the
topic, then it would be found as a snippet suggestion.

NOTE You can also include this information in reports that you create.
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Viewing Variable Suggestions
You can view regular text that matches existing variables in your project, and then quickly convert
these occurrences to variables. You can also double-click a row to open the topic in question, with
the potential variable text highlighted.

How to View Variable Suggestions
1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Analysis > Suggestions > Variable Suggestions.

n Analysis Summary Window Pane Double-click the row that mentions variable
suggestions.

The Variable Suggestions window pane opens, listing all of the variable suggestions for the
project.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Suggestion Displays the suggestion that Flare Desktop is making to you (i.e., "Replace
with Variable").

n Type Displays the name of the variable set and the name of the variable (e.g.,
Primary.CompanyName).

n Context Displays the context of the variable in question. In other words, it displays
words that are found before the variable tag.

n File Displays the path and name of the file where the content in question is found.

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.
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How to Convert Suggestions to Variables
Do one of the following, depending on whether you want to convert multiple suggestions to a
variable simultaneously, or if you want to convert only one suggestion at a time.

To Convert Multiple Suggestions Simultaneously

1. In the window pane, select all suggestions that you want to convert. If you want to select all
rows click . You can hold the SHIFT key to select a range, or you can hold the CTRL key to
select individual items.

2. In the local toolbar, click the Apply button.

3. In the message that opens, click OK. Another message lets you know how many files were
changed.

4. Click OK. All of the selected suggestions are converted to variables.

NOTE If you want to undo the conversions, you can use the Backups window pane
(View > Backups).

To Convert One Suggestion at a Time

1. In the Variable Suggestions window pane, select the row that you want to convert to a
variable.

2. You can either double-click on the specific row, or right-click on the row and select Open. The
file opens with the suggested content highlighted.

3. In Flare Desktop, insert the variable (e.g., select Insert > Variable).
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Viewing New Style Suggestions
You can view the places in a project containing local formatting. The analysis tool suggests that
you convert these instances to new styles. You can use the Create New Style dialog to do just that.
You can also double-click a row to open the file where the formatted content exists.

Local formatting is a way to change the look and feel of content directly so that the changes are
applied only to that specific content (as opposed to applying the changes throughout your project
via the use of styles). Many tools are provided in Flare Desktop for editing and formatting topics
directly in the XML Editor, without having to know XML at all. Simply open the topic that you want to
format, and use the tool that suits your needs best. For example, if you want certain text to be bold,
you can highlight the text and click the Bold button in the Text Format toolbar. This direct
approach to formatting topics (sometimes called "inline" formatting) can be very attractive because
it is quick and easy. However, it is recommended that you use style classes instead of local
formatting whenever possible. Although local formatting is very convenient in the short-term, using
style classes is much more efficient and can save you a great deal of time in the long-term.

How to View New Style Suggestions
1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Analysis > Suggestions > New Style Suggestions.

n Analysis Window Pane Double-click the row that mentions new style suggestions.

The New Style Suggestions window pane opens, listing all of the new style suggestions for
the project.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Selector Displays the parent tag(s) where the formatting is found in the topic (e.g., p,
div, ul, li).

n Properties Displays the formatting already set on the tag (including the local formatting
that you may have applied to the content).

n File Displays the name of the file.

n Folder Displays the folder where the file is found.
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4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

How to Convert Suggestions to New Styles
1. In the New Style Suggestions window pane, select the row that you want to convert to a new

style.

2. In the local toolbar, click the Create Style button. The Create New Style dialog opens.

3. In the Stylesheet field, select the stylesheet where you want to create the new style.

4. In the Class field, type a name for the new style class.

EXAMPLE If you have selected a row based on the p style and you type
YellowBackground in this field, a new class called p.YellowBackground will be
created.

5. Click OK.

6. If a message displays, stating that the backups folder is not empty, click OK to empty the
folder and continue.

7. Another message lets you know how many files were changed. Click OK.

NOTE If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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Viewing Local Style Suggestions
You can view the places in your project where you have used local formatting. The analysis tool
suggests that you replace these instances of formatting with existing styles in your stylesheet that
match the formatting that you have applied manually. This is different from a new style suggestion
in the following way: With a new style suggestion, the properties in the tag do not match an existing
style exactly; therefore, the analysis suggests that you create a new style. On the other hand, if you
make formatting changes that happen to result in an exact match to all of the properties in an
existing style, the analysis suggests that you replace the formatting with that style (rather than
creating a new style).

How to View Local Style Replacement Suggestions
1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Analysis > Suggestions > Replace Local Style Suggestions.

n Analysis Summary Window Pane Double-click the row that mentions local style
replacement suggestions.

The Replace Local Style Suggestions window pane opens.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Selector Displays the base tag(s) where the formatting is found in the topic (e.g., p, div,
ul, li), followed by a period and the name of the style class that is suggested for you to
use.

n Properties Displays the formatting properties already set on the tag, which matches the
formatting properties that you have applied manually.

n File Displays the path and name of the file where the formatting is found.

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.
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How to Replace Local Formatting With Existing Styles
1. In the window pane, select all suggestions that you want to convert. If you want to select all

rows click . You can hold the SHIFT key to select a range, or you can hold the CTRL key to
select individual items.

2. In the local toolbar, click the Apply button.

3. In the message that opens, click OK. Another message lets you know how many files were
changed.

4. Click OK. All of the selected suggestions are converted to styles.

NOTE If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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Viewing Accessibility Suggestions
Using the Accessibility Suggestions window pane, you can view places in your project where you
can make accessibility improvements for web-based and PDF outputs in Flare Desktop. This
includes the ability to identify tables that are missing certain elements and finding objects—such as
images, equations, and QR codes—that are missing alternate text. You can use the Accessibility
Suggestions Search Properties dialog to customize which types of issues to display in the window
pane.

How to View Accessibility Suggestions
1. Make sure accessibility suggestions are enabled:

a. Select File > Options.

b. Select the Project Analysis tab.

c. Ensure that Collect Accessibility Prospects is enabled.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Analysis > Suggestions > Accessibility Suggestions.

n Summary Window Pane If you have the Summary window pane in view, double-click
the row that mentions accessibility suggestions.

The Accessibility Suggestions window pane opens.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Tag Displays the tag where the issue occurs (e.g., img, table, qrCode, equation).

n Issue Displays the issue with the tag (e.g., needs alternate text, caption, summary,
header elements).

n Context Displays the context of the issue in question. For example, if the issue is that a
tag is missing alternate text, this shows the name and path of the image.

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.
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4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

What’s Next?
When you see issues listed in the Accessibility Suggestions window pane, you can use the Apply
Accessibility Suggestions Wizard to take action on issues that have to do with missing alternate
text. See the Help system.
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Customizing Accessibility Suggestions Shown
You can use the Accessibility Suggestions Search Properties dialog to customize which types of
accessibility issues to look for when analyzing Flare projects. Based on your selections in this
dialog, the Accessibility Suggestions window pane updates accordingly.

How to Customize the Accessibility Suggestions Shown in the Window
Pane

1. Open the Accessibility Suggestions window pane. See "Viewing Accessibility Suggestions" on
page 54.

2. In the local toolbar of the Accessibility Suggestions window pane, click Search Properties.
The Accessibility Suggestions Search Properties dialog opens.

3. Select any of the options in the dialog.

n Images without alt text

n Equations without alt text

n QR Codes without alt text

n Tables missing both a caption and summary

n Form elements without labels

n Frame elements missing title and name

n Tables missing header elements

n Table captions that are not the first table element

n Server-side image maps

4. Click OK.
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Viewing and Applying Markup Suggestions
The Markup Suggestions window pane lets you see a list of files where the XHTML markup (code)
can be improved (e.g., empty tags, CDATA tags, empty attributes, excessive spaces). When the
analysis tool finds markup issues, there are a couple of ways that you can "clean them up." First,
you can click the Apply button in the local toolbar to automatically apply the suggestions to the
selected files. Alternatively, you can double-click a row to open that file and work on the issues
manually. You may be able to fix some issues for a specific file in the XML Editor. Other issues may
require you to open the behind-the-scenes code in the Internal Text Editor.

How to View Markup Suggestions
1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Analysis > Suggestions > Markup Suggestions.

n Summary Window Pane Double-click the row that mentions markup suggestions.

The Markup Suggestions window pane opens.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Suggestion Displays the suggestion to resolve the issue (e.g., "Remove empty
attribute," "Make single space").

n Context Displays the context of the issue in question, along with a tag if applicable for
the suggestion (e.g., img, p, h1, li). For example, if the issue is that a tag has an empty
attribute, this shows the tag and name of the attribute within it.

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.
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How to Apply Markup Suggestions Automatically
1. View the markup suggestions.

2. In the Markup Suggestions window pane, select all issues that you want to resolve. If you
want to select all rows click . You can hold the SHIFT key to select a range, or you can hold
the CTRL key to select individual items.

3. In the local toolbar, click the Apply button.

4. A message asks if you want to apply the selected suggestions. Click OK.

5. If your Backups folder is not empty, a message asks if you want to empty it and continue. If
so, click OK.

6. Click OK once more.

NOTE If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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How to Resolve Markup Issues Manually
1. View the markup suggestions.

2. You can open any file in the list to view or modify it in an editor. You can either double-click on
the specific row, or right-click on the row and select Open.

3. If necessary, you can open the file in the Internal Text Editor to work directly in the markup.

What’s Noteworthy?

NOTE You can customize the suggestions that are shown in the Markup Suggestions
window pane. See "Customizing Markup Suggestions Shown" on the next page.
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Customizing Markup Suggestions Shown
You can use the Markup Suggestions Search Properties dialog to customize which types of markup
issues to look for when analyzing Flare projects. The Markup Suggestions window pane is then
updated based on your selections in this dialog.

How to Customize the Markup Suggestions Shown in the Window
Pane

1. View the markup suggestions. See "Viewing and Applying Markup Suggestions" on page 57.

2. In the local toolbar of the Markup Suggestions window pane, click Search Properties. The
Markup Suggestions Search Properties dialog opens.

3. Select any of the options in the dialog.

n CDATA tags

n Empty tags

n Line breaks

n Underscores in topic title

n Untagged text in topic body

n Empty attributes

n Tags with only spaces

n Non-breaking spaces

n Multiple spaces

4. Click OK.
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Viewing Cross-Reference Suggestions
The Cross-Reference Suggestions window pane displays links in a project that you might want to
convert to cross-references. This window pane also provides you with the option to convert the
selected links to cross-references.

For example, if you have regular text hyperlinks (<a> tags), you might want to convert them,
because cross-references change dynamically and are therefore usually preferred over text
hyperlinks.

How to View Cross-Reference Suggestions
1. Open a project.

2. Select Analysis > Suggestions > Cross-Reference Suggestions.

The Cross-Reference Suggestions window pane opens.

3. Double-click a file to open it in the XML Editor. The file opens and highlights the cross-
reference suggestion.

How to Convert Cross-Reference Suggestions
1. Open a project.

2. Select Analysis > Suggestions > Cross-Reference Suggestions.

The Cross-Reference Suggestions window pane opens.

3. Do one of the following:

n Click the Convert to Cross-References button in the local toolbar.

OR

n Right-click any file in the Cross-References Suggestions window pane and from the
context menu, select Convert to Cross-References.

The Convert to Cross-Reference dialog opens.

4. In the Convert to Cross-References dialog, you can make selections from the following
options.

CHAPTER 2  61



TARGET OPTIONS

In the Target Option field, select one of the following to indicate how you want the destination
file to open when the link is clicked.

n Link Target This uses the target that is set in the original link.

n Target Frame This enables the Target Frame field (immediately below), which you can
use to select one of the following target frame options.

l Page Default The destination file opens in the same window as the output window.

l Parent Frame The destination file opens in the parent frame of the current topic
while hiding that topic.

l New Window The destination file opens in a new browser window.

l Same Frame The destination file opens in the same window frame as the current
topic.

l Top Frame The destination file opens in the same output window, removing all other
framesets. You might use this option, for example, if the destination topic has its
own frameset.

l Popup Window The destination file opens in a popup box on top of the current topic.
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SCREEN TIP OPTIONS

In the Screen Tip Option field, select one of the following to add a screen tip to the link. This is
useful when it comes to accessibility.

n Link Alt Text This uses the screen tip text that is set in the original link.

n Screen Tip This uses the screen tip text that you enter in the Screen Tip field
(immediately below).
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CROSS-REFERENCE STYLE CLASS

In the XRef Class field, you can set the cross-reference's style class and format . The style
class is previewed to the right.

n Edit You can click Edit to change the selected cross-reference style class. This opens
the Edit Cross-Reference Style Class Dialog.

n New You can click New to create a new cross-reference style. This opens the New
Cross-Reference Style Class Dialog.

5. Click OK. A message indicates how many files have been updated.
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How to Include Cross-Reference Suggestions in a
Report

1. Open a report.

2. In the Report Editor, click the General tab.

3. In the Tables field, scroll down to the Links section.

4. Click the Cross-Reference Suggestions check box.

5. Click Generate. The generated report will include cross-reference suggestions.
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Viewing Writing Suggestions
You can view places in your project where you can make writing improvements based on industry-
wide standards. For example, the analysis tool can locate files where an h1 or h2 heading has only
one subheading (i.e., an h1 heading with only one h2 heading under it, or an h2 heading with only
one h3 heading under it). It is recommended that you have more than one subheading under a
parent heading. Therefore, occurrences such as these are raised as concerns. The analysis tool can
also locate files where a heading level has been skipped (e.g., an h1 heading is followed by an h3
heading, rather than h2), as well as any files where consecutive headings exist (e.g., an h1 heading
is followed by an h2 heading, with no other content between them). You can use the Writing
Suggestions Search Properties dialog to customize which types of suggestions to display in the
window pane.
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How to View Writing Suggestions
1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Analysis > Suggestions > Writing Suggestions.

n Summary Window Pane Double-click the row that mentions writing suggestions.

The Writing Suggestions window opens.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Suggestion Displays the issue (e.g., "H1s with single child," "Skipped heading").
Following are the types of issues that might be found, depending on your selections in
the Writing Suggestions Search Properties dialog.

l Heading 1s with only one child heading Locates files where an h1 heading has only
one h2 heading under it. For more information about styles (including h1 through h6
heading styles), see the Help system.

l Heading 2s with only one child heading Locates files where an h2 heading has only
one h3 heading under it.

l Heading 3s with only one child heading Locates files where an h3 heading has only
one h4 heading under it.

l Heading 4s with only one child heading Locates files where an h4 heading has only
one h5 heading under it.

l Heading 5s with only one child heading Locates files where an h5 heading has only
one h6 heading under it.

l Skipped headings Locates files where a heading level has been skipped (e.g., an h1
heading is followed by an h3 heading, rather than h2).

l Consecutive headings Locates files where one heading is followed immediately by
another heading with no other content in between.

n Tag Displays the tag where the issue occurs.

n File Displays the name of the file.

n Folder Displays the folder where the file is found.
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4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.
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Customizing Writing Suggestions Shown
If you want to limit or expand the list of the writing suggestions that are displayed, you can easily do
so by selecting various options.

How to Customize the Writing Suggestions Shown in the Window Pane

1. View the writing suggestions by selecting the Analysis ribbon. Then click Suggestions >
Writing Suggestions.

2. In the local toolbar of the Writing Suggestions window pane, click Search Properties. The
Writing Suggestions Search Properties dialog opens.

3. Select any of the options in the dialog.

n Heading 1s with only one child heading Locates files where an h1 heading has only one
h2 heading under it. For more information about styles (including h1 through h6
heading styles), see the Help system.

n Heading 2s with only one child heading Locates files where an h2 heading has only one
h3 heading under it.

n Heading 3s with only one child heading Locates files where an h3 heading has only one
h4 heading under it.

n Heading 4s with only one child heading Locates files where an h4 heading has only one
h5 heading under it.

n Heading 5s with only one child heading Locates files where an h5 heading has only one
h6 heading under it.

n Skipped headings Locates files where a heading level has been skipped (e.g., an h1
heading is followed by an h3 heading, rather than h2).

n Consecutive headings Locates files where one heading is followed immediately by
another heading with no other content in between.

4. Click OK.
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Frequent Segments
Flare Desktop lets you view lists of segments that occur frequently throughout your project. Why is
this important? It's important because by viewing repeated information in your project, you can
convert that text to reusable content (snippets or variables), thereby taking advantage of single-
sourcing.

Viewing Frequent Segments
You can view a list of segments that occur frequently in your project. You can see the segment text,
the number of occurrences of each segment, and the number of words and characters in each
segment.

How to View Frequent Segments

1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Analysis > Suggestions > Frequent Segments.

n Summary Window Pane If you have the Analysis window pane open, double-click the
row that mentions frequent segments.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Segment Displays the segment that occurs multiple times throughout your project.

n Count Displays the number of times a particular segment occurs throughout your
project.

n Word Count Displays the number of words contained in a particular segment.

n Character Count Displays the number of characters contained in a particular segment.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.
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NOTE You can use the Segment Topics window pane to view the topics where a particular
segment is located. See "Viewing Segments for Topics" on page 80.
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Converting Frequent Segments to Snippets
You can view a list of segments that occur frequently in your project. You can see the segment text,
the number of occurrences of each segment, and the number of words and characters in each
segment. If you notice that certain segments are repeated numerous times in your project, you can
easily convert them to snippets. See the Help system for more information on snippets.

How to Convert a Frequent Segment to a Snippet

1. Open the Frequent Segments window pane. See "Viewing Frequent Segments" on page 70.

2. Select the segment that you want to convert to a snippet.

3. In the local toolbar, click the Create drop-down button and select Create Snippet. The Create
Snippet dialog opens.

4. In the Snippet File field, type a new name for the snippet.

It is recommended that you leave the project folder selection as "Resources/Snippets" (or
select a subfolder that you have created in the Snippets folder). After the snippet is created,
you can see the snippet file in the Content Explorer.

5. Click Create. The snippet is created and added to the Flare project that you are analyzing.

6. Open the Snippet Suggestions window pane.

7. Do one of the following, depending on whether you want to convert multiple suggestions
simultaneously, or if you want to convert only one snippet suggestion at a time.
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TO CONVERT MULTIPLE SUGGESTIONS SIMULTANEOUSLY

a. In the window pane, select all suggestions that you want to convert. If you want to
select all rows click . You can hold the SHIFT key to select a range, or you can hold
the CTRL key to select individual items.

b. In the local toolbar, click the Apply button.

c. In the message that opens, click OK. Another message lets you know how many files
were changed.

d. Click OK. All of the selected suggestions are converted to snippets.

NOTE If you want to undo the conversions, you can use the Backups window
pane (View > Backups).

TO CONVERT ONE SUGGESTION AT A TIME

a. In the Snippet Suggestions window pane, select the row that you want to convert to a
snippet.

b. You can either double-click on the specific row, or right-click on the row and select
Open. The file opens with the suggested content highlighted.

c. In Flare Desktop, insert the snippet (e.g., select Insert > Snippet).
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Converting Frequent Segments to Variables
You can view a list of segments that occur frequently in your project. You can see the segment text,
the number of occurrences of each segment, and the number of words and characters in each
segment. If you notice that certain segments are repeated numerous times in your project, you can
easily convert them to variables. See the Variables Guide or the Help system for more information.

How to Convert a Frequent Segment to a Variable

1. Open the Frequent Segments window pane.

2. Select the segment that you want to convert to a variable.

3. In the local toolbar, click the Create drop-down button and select Create Variable. The Create
Variable dialog opens.

4. In the Variable Name field, type a new name for the variable.

5. Click in the Variable Set field and select an existing variable set.

6. Click Create. The variable is created and added to the Flare project that you are analyzing.

7. Open the Variable Suggestions window pane.

8. Do one of the following, depending on whether you want to convert multiple suggestions to a
variable simultaneously, or if you want to convert only one variable suggestion at a time.
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TO CONVERT MULTIPLE SUGGESTIONS SIMULTANEOUSLY

a. In the window pane, select all suggestions that you want to convert. If you want to
select all rows click . You can hold the SHIFT key to select a range, or you can hold
the CTRL key to select individual items.

b. In the local toolbar, click the Apply button.

c. In the message that opens, click OK. Another message lets you know how many files
were changed.

d. Click OK. All of the selected suggestions are converted to variables.

NOTE If you want to undo the conversions, you can use the Backups window
pane (View > Backups).

TO CONVERT ONE SUGGESTION AT A TIME

a. In the Variable Suggestions window pane, select the row that you want to convert to a
variable.

b. You can either double-click on the specific row, or right-click on the row and select
Open. The file opens with the suggested content highlighted.

c. In Flare Desktop, insert the variable (e.g., select Insert > Variable).
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Customizing Frequent Segments Shown
If you want to limit or expand the list of frequent segments that are displayed, you can easily do so
by setting the minimum and maximum word counts, as well as the minimum number of
occurrences.

How to Customize Which Segments are Shown in the Window Pane

1. View the frequent segments. See "Viewing Frequent Segments" on page 70.

2. In the local toolbar of the Frequent Segments window pane, click Search Properties.The
Frequent Segment Search Properties dialog opens.

3. Adjust any of the fields in the dialog.

n Min Word Count Use this field to set the minimum number of words that must be
contained in a segment in order for it to be displayed in the Frequent Segments window
pane.

n Max Word Count Use this field to set the maximum number of words that can be
contained in a segment in order for it to be displayed in the Frequent Segments window
pane. The highest number you can enter is 30. If you want to convert content
containing more than 30 words to snippets, you can use Flare Desktop to find multiple
instances of partial content. Then you need to open Flare Desktop and manually
replace the large chunks of content with snippets.

n Min Segment Count Use this field to set the minimum number of times that a segment
must occur throughout a project in order for it to be displayed in the Frequent
Segments window pane.

4. Click OK.
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Viewing Similar Segments
You can view a list of segments of text in your project that are similar, but not identical, to each
other. You may want to modify similar segments so that they become identical to each other, or
even convert them to snippets. You can also use the "Start Search" button to limit or expand the list
of similar segments that are displayed.

The Similar Segments window pane displays similar segments in pairs. In other words, one row
displays a segment of text in one column, with a similar segment in the next column. If you double-
click the row, the file containing the first segment opens. In the row directly beneath the first, the
same segments are shown, only in reverse order. If you double-click that row, the file containing the
other segment opens.
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How to View Similar Segments
1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Analysis > Suggestions > Similar Segments.

n Summary Window Pane Double-click the row that mentions similar segments.

The Similar Segments window pane opens.

3. In the local toolbar, click the Start Search button. (Even if you do not want to change the
search properties, you need to click this button to initiate a new search for similar segments.)
The Similar Segments Search Properties dialog opens.

4. You can modify any of the search property settings to limit or expand the list of similar
segments shown in the list.

n Min Word Count Use this field to set the minimum number of words that must be
contained in a segment in order for it to be displayed in the Similar Segments window
pane. The highest number you can enter is 1000.

n Max Word Count Use this field to set the maximum number of words that can be
contained in a segment in order for it to be displayed in the Similar Segments window
pane. The highest number you can enter is 1000.

n Max "Edit Distance" Use this field to set the maximum amount of difference that can
exist between segments in order for them to be displayed in the Similar Segments
window. The value has to do with the number of characters that are different between
the two segments. The smaller the number, the more alike the segments are. The larger
the number, the greater the difference that exists between the segments. You can
modify this value to limit or increase the number of segments displayed in the window.
The highest number you can enter is 1000.

5. Click OK. The window pane populates with similar segments found in the project.

6. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Pair Index Displays the number that identifies a pair of segments. Segments are always
compared in pairs. The first row displays the "primary" segment (in the "Segment 1"
column), and it displays a segment that is similar to it in the "Segment2" column. In the
other row, the segments are reversed, with the second segment displayed in the
"Segment1" column.
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n Segment1 Displays the "primary" segment in the row. If you double-click the row, the
topic containing the segment in the "Segment1" column opens.

n Segment2 Displays the secondary segment (i.e., the segment that is similar to the one
displayed in the "Segment1" column).

n Edit Distance Displays the numerical value that indicates how much difference exists
between the segments (see the "Max Edit Distance" option mentioned above).

n File Displays the file where the segment of text is found.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

7. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

NOTE You can use the Segment Topics window pane to view the topics where a particular
segment is located. See "Viewing Segments for Topics" on the next page.

CHAPTER 2  79



Viewing Segments for Topics
You can view a list of topics associated with a segment (as selected in the Frequent Segments
window pane or Similar Segments window pane). This is a quick way to open a file where a
particular segment exists.

How to View Segments for Topics
1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using and the
type of segments.

FREQUENT SEGMENTS

Select Analysis > Suggestions > Frequent Segments. The Frequent Segments window pane
opens, displaying segments that occur a certain number of times throughout your project.

SIMILAR SEGMENTS

Select Analysis > Suggestions > Similar Segments. The Similar Segments window pane
opens, displaying segments that are similar in your project. (You need to click the Start
Search button in the local toolbar to initiate a search of similar segments.)

3. In the window pane, select a row. Then, click the button in the local toolbar to open the
Segment Topics window pane. It lists all of the topics where the frequent segment is found.

4. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n File Displays the name of the file where the segment occurs.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

n Extension Displays the extension of the file (e.g., .htm).

5. You can open any file in the list to view or modify it in an editor. You can either double-click on
the specific row, or right-click on the row and select Open.
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Undefined Items
In the Analysis ribbon, the Undefined Items drop-down button provides several options.

Viewing Undefined Glossary Term Links
You can view a list of files where glossary term links are inserted, but those glossary terms do not
appear in any of your glossary files. This might occur, for example, if you have created a new term
in a glossary and then inserted that term into a topic as a glossary term link. Later, you remove that
term from the glossary. You now have a glossary term link in a topic, but the term no longer exists
in the glossary. Therefore, a problem exists. You need to either remove the glossary term link from
the content, or you need to add the term to the glossary again. From the Undefined Glossary Term
Links window pane, you can quickly unbind or rename multiple glossary term link occurrences in a
single batch, add a new glossary term, or map the undefined term to an existing glossary term.
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How to View Undefined Glossary Term Links
1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Analysis > Undefined Items > Undefined Glossary Term Links.

n Analysis Summary Window Pane Double-click the row that mentions undefined
glossary term links.

The Undefined Glossary Term Links window pane opens.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Term Displays the term that is used in a glossary term link in the file.

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.
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How to Fix Undefined Glossary Term Links
There are a few basic ways to fix an undefined glossary term link: (1) You can rename the glossary
term; (2) you can unbind the glossary term link; (3) you can remove the glossary term link from the
file; (4) you can add the same glossary term to the glossary file; (5) you can replace an undefined
glossary term with an existing glossary term; and (6) you can create a new glossary term.

To Rename Glossary Terms in a File

1. In the window pane, select all glossary term link occurrences that you want to rename. If you
want to select all rows click . You can hold the SHIFT key to select a range, or you can hold
the CTRL key to select individual items.

NOTE All glossary term occurrences that you select will be renamed to the same
glossary term that you provide in the following steps.

2. In the local toolbar, click the Rename button.

3. In the New glossary term link name field, enter a new glossary term.

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected glossary
term link occurrences are renamed.

NOTE If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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To Unbind Glossary Term Links in a File

1. In the window pane, select all glossary term link occurrences that you want to unbind. If you
want to select all rows click . You can hold the SHIFT key to select a range, or you can hold
the CTRL key to select individual items.

NOTE The links for all glossary term occurrences that you select will be removed.

2. In the local toolbar, click the Unbind button.

3. Click OK.

4. A message lets you know how many files were changed. Click OK. The links for all of the
selected glossary term link occurrences are removed.

NOTE If you want to undo the conversions, you can use the Backups window pane
(View > Backups).

To Remove Glossary Terms From a File

1. You can either double-click on the specific row, or right-click on the row and select Open.

2. On your keyboard press DELETE. Add regular text if necessary.

3. Click to save your work.

CHAPTER 2  84



To Add Matching Terms to a Glossary

1. In the Undefined Glossary Term Links window pane, select the row that you want to correct.
You can either double-click on the specific row, or right-click on the row and select Open. The
file opens in the XML Editor of the application, with the glossary term link highlighted.

2. Open the glossary and add a matching glossary term.

To Replace an Undefined Glossary TermWith an Existing Term

1. In the window pane, select all glossary term link occurrences that you want to replace. If you
want to select all rows click . You can hold the SHIFT key to select a range, or you can hold
the CTRL key to select individual items.

2. Do one of the following, depending on the part of the user interface you are using:

n Local Toolbar Click .

n Right-Click Right-click on the glossary term you want to replace and from the context
menu select Create Glossary Term Link.

The Create Glossary Link dialog opens.

3. On the right side of the dialog, select the existing glossary term you want to link to the
undefined term.

4. Click OK. The undefined glossary terms are replaced with the term you selected.
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To Create a Glossary Term

1. In the window pane, select the glossary term link occurrences that you want to add to the
project.

2. Do one of the following, depending on the part of the user interface you are using:

n Local Toolbar Click .

n Right-Click Right-click on the glossary term you want to replace and from the context
menu select Create Glossary Term Link.

The Create Glossary Link dialog opens.

3. Click Add New Term.

The Create Glossary Term dialog opens.

4. Enter a new term and definition, which will be added to the glossary when you are finished.

5. (Optional) You can also use the Insert Variable button , if you want to add a variable to the
definition.

6. (Optional) If you want to sort a glossary entry using a different term, in the Sort As field, enter
the term you want to use for sorting. "Sort As" terms appear in the Sort As column of the
glossary.

TIP Use a "Sort As" term if you want to sort a glossary term as something else. This
can be useful when a term begins with a symbol (e.g., place <html> in the "h" section,
instead of at the top of the glossary), or if you are using character sets that need to
be sorted phonetically.

7. Click OK.

8. In the Create Glossary Link dialog, click OK. The undefined glossary terms are replaced with
the new glossary term.
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Viewing Undefined Variables
You can view a list of all files where you have variables inserted in the content, but those variables
have not been defined. This might occur, for example, if you have inserted a variable in a topic and
then later change the name of the variable or variable set. The old variable or set name is still used
at the location where it was previously inserted in the topic; therefore, a problem exists. From the
Undefined Variables window pane, you can open the topic in question and fix the undefined
variable. You can also quickly rename or remove multiple variables in a single batch, add the
undefined variable to the project, or map the undefined variable to an existing variable.

How to View Undefined Variables
1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Analysis > Undefined Items > Undefined Variables.

n Analysis Summary Window Pane Double-click the row that mentions undefined
variables.

The Undefined Variables window pane opens.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Variable Displays the name of the variable set and the variable within it. The variable set
is listed first, followed by a period and then the name of the variable (e.g.,
Primary.CompanyName).

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

n Tag Displays the tag being used by the variable.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.
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How to Fix Undefined Variables
There are a few ways to fix an undefined variable: (1) You can rename the variable or variable set so
that it matches what you have used in the topic; (2) you can re-insert the variable in the topic so that
it uses an existing variable set/variable name, (3) you can add the undefined variable to the project
as a new variable; and (4) you can map the undefined variable to an existing variable.

To Rename Variables

1. In the window pane, select all variable occurrences that you want to rename. If you want to
select all rows click . You can hold the SHIFT key to select a range, or you can hold the
CTRL key to select individual items.

NOTE All variable occurrences that you select will be renamed to the same variable
that you provide in the following steps.

2. In the local toolbar, click the Rename button. The Rename Variable(s) dialog opens.

3. In the New variable name field, enter a new variable. Type the name of the variable set,
followed by a period, then the name of the variable (e.g., MyVariableSet.MyVariableName).

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected variable
occurrences are renamed.

NOTE If you want to undo the conversions, you can use the Backups window pane
(View > Backups).

To Re-insert Variables

1. You can either double-click on the specific row, or right-click on the row and select Open.

2. Re-insert the variable in the topic, selecting an existing name from a variable set. See the
Variables Guide or the Help system for more information about inserting variables.
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To Add a Variable

1. In the window pane, select all variable occurrences that you want to add to the project. If you
want to select all rows click . You can hold the SHIFT key to select a range, or you can hold
the CTRL key to select individual items.

2. Do one of the following, depending on the part of the user interface you are using:

n Local Toolbar Click .

n Right-Click Right-click on the variable you want to add and from the context menu
select Add Variable.

The Variable Set Editor opens, with the new variable(s) displayed.

NOTE When you create a new variable, one of two things will happen:

a. If the Variable Set file specified for the undefined variable exists in the project,
Flare Desktop will add the new variable to the existing Variable Set file.

b. If the Variable Set file specified for the undefined variable does not exist in the
project, Flare Desktop will create a brand new Variable Set file in the project
and add the variable to that file.

3. (Optional) In the Variable Set Editor, edit the variable's properties (e.g., name, definition,
comment).

4. Click to save your work.
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To Map to a Variable

1. In the window pane, select all variable occurrences that you want to map to an existing
variable. If you want to select all rows click . You can hold the SHIFT key to select a range,
or you can hold the CTRL key to select individual items.

2. Do one of the following, depending on the part of the user interface you are using:

n Local Toolbar Click .

n Right-Click Right-click on the variable you want to add and from the context menu
select Map to Existing Variable.

3. In the Variables dialog, select the existing variable in the project to overwrite the current
undefined variable reference.

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected variable
occurrences are overwritten with the new variable.

NOTE If you want to undo the conversions, you can use the Backups window pane
(View > Backups).

6. Click to save your work.

What’s Noteworthy?

NOTE Another way to replace a variable in many places throughout a project is to use the
Find and Replace in Files feature in Flare Desktop. For example, let's say that you originally
inserted a variable named "Company" (from the "Primary" variable set) in a lot of places in
your project. Later, you renamed the variable "Branch." You can perform a find and replace
throughout your entire project. In the "Find" field, you can enter Primary.Company, and in
the "Replace with" field, you can enter Primary.Branch. Also, make sure you select the
"Find in source code" option in the Find and Replace in Files window pane. After replacing
this text throughout your project, that variable will no longer be considered "undefined".

CHAPTER 2  90



Viewing Undefined Conditions
You can view a list of all files where you have condition tags in the content, but those condition tags
have not been defined. This might occur, for example, if you have applied a condition tag in a topic
and then later change the name of the tag or condition tag set. The old tag or set name is still used
at the location where it was previously applied in the topic. Therefore, a problem exists. From the
Undefined Condition Tags window pane, you can open the file in question and fix the undefined
condition tag. You can also quickly rename or remove multiple condition tag occurrences in a single
batch, add the undefined tag to the project, or map the undefined tag to an existing condition tag.

How to View Conditions
1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Analysis > Undefined Items > Undefined Condition Tags.

n Summary Window Pane Double-click the row that mentions undefined condition tags.

The Undefined Condition Tags window pane opens, displaying a list of undefined condition
tags.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Condition Tag Displays the name of the condition tag set and the tag within it. The
condition tag set is listed first, followed by a period and then the name of the condition
tag (e.g., Primary.Print).

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

n Tag Displays the tag being used by the condition tag.

n Exclude ActionDisplays the kind of "exclude" action tied to the condition tag. In most
cases, the exclude action is "remove." However, in some instances, this action might be
"unbind." For example, you might have the unbind action for a condition tag if you have
applied the tag to a hyperlink and want the link to be removed from the text in some
outputs, but you still want the text to be shown in those outputs.
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4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

How to Fix Undefined Conditions
There are a few different ways to fix an undefined condition tag: (1) You can rename the condition
tag or condition tag set so that it matches what you have used in the topic; (2) you can reapply the
condition tag in the topic so that it uses an existing condition tag set/condition tag; (3) you can add
the undefined condition tag to the project as a new condition tag; (4) you can map the undefined
condition tag to an existing condition tag; and (5) you can delete references in content files (e.g.,
topics, snippets) to the condition.

To Rename Conditions

1. In the window pane, select all condition tag occurrences that you want to rename. If you want
to select all rows click . You can hold the SHIFT key to select a range, or you can hold the
CTRL key to select individual items.

NOTE All condition tag occurrences that you select will be renamed to the same
condition tag that you provide in the following steps.

2. In the local toolbar, click the Rename button. The Rename Condition Tag(s) dialog opens.

3. In the New condition tag name field, enter a new condition tag. Type the name of the
condition tag set, followed by a period, then the name of the condition tag (e.g.,
Primary.Print).

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected
condition tag occurrences are renamed.

NOTE If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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To Reapply Conditions

1. You can either double-click on the specific row, or right-click on the row and select Open.

2. Reapply the condition tag to the content, selecting an existing name from a condition tag set.
See the Condition Tags Guide or the Help system for more information.

To Add a Condition

1. In the window pane, select all condition tag occurrences that you want to add to the project. If
you want to select all rows click . You can hold the SHIFT key to select a range, or you can
hold the CTRL key to select individual items.

2. Do one of the following, depending on the part of the user interface you are using:

n Local Toolbar Click .

n Right-Click Right-click on the condition tag you want to add and from the context menu
select Add New Condition Tag.

The Condition Tag Set Editor opens, with the new condition tag(s) displayed.

NOTE When you create a new condition tag, one of two things will happen:

a. If the Condition Tag Set file specified exists in the project, Flare Desktop will
add the new condition tag to the existing file.

b. If the Condition Tag Set file specified does not exist in the project, Flare
Desktop will create a brand new Condition Tag Set file and add the new
condition tag to that file.

3. (Optional) In the Condition Tag Set Editor, edit the condition tag's properties (e.g., name,
color, comment).

4. Click to save your work.
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To Map a Condition

1. In the window pane, select all condition tag occurrences that you want to map to an existing
condition tag. If you want to select all rows click . You can hold the SHIFT key to select a
range, or you can hold the CTRL key to select individual items.

2. Do one of the following, depending on the part of the user interface you are using:

n Local Toolbar Click .

n Right-Click Right-click on the condition tag you want to add and from the context menu
select Map to Existing Condition Tag.

The Condition Tags dialog opens.

3. In the dialog, select the existing condition tag in the project to overwrite the current undefined
condition tag reference.

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected
condition tag occurrences are overwritten with the new condition tag.

NOTE If you want to undo the conversions, you can use the Backups window pane
(View > Backups).

6. Click to save your work.

To Delete References to a Condition

1. In the window pane, select all condition tag occurrences whose references you want to
delete. If you want to select all rows click . You can hold the SHIFT key to select a range, or
you can hold the CTRL key to select individual items.

2. Do one of the following, depending on the part of the user interface you are using:

n Local Toolbar Click .

n Right-Click Right-click on the condition tag and from the context menu select Delete.

3. Click OK.
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NOTE This activity deletes the references to the undefined condition only. It does not
affect your content file(s) in any other way.

NOTE Another way to apply a different condition tag to many places throughout a project
is to use the Find and Replace in Files feature in Flare Desktop. For example, let's say that
you originally applied a condition tag named "Print" (from the "Primary" condition tag set) to
a lot of content in your project. Later, you renamed the condition tag "PDF." You can
perform a find and replace in your entire project. In the "Find" field, you can enter
Primary.Print, and in the "Replace with" field, you can enter Primary.PDF. Also, make
sure you select the "Find in source code" option in the Find and Replace in Files window
pane. After replacing this text throughout your project, that condition tag will no longer be
considered "undefined" in Flare Desktop.
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Viewing Undefined File Tags
You can view a list of all files that are associated with file tags, but those file tags have not been
defined. This might occur, for example, if you have associated a file tag with a topic and then later
change the name of the tag or file tag set. The old tag or set name is still used for the topic.
Therefore, a problem exists. From the Undefined File Tags window pane, you can open the file in
question and fix the undefined tag. You can also quickly rename or remove multiple file tag
occurrences in a single batch.
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How to View Undefined File Tags
1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Analysis > Undefined Items > Undefined File Tags.

n Summary Window Pane Double-click the row that mentions undefined file tags.

The Undefined File Tags window pane opens, displaying a list of undefined file tags.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n File Tag Displays the name of the file tag set and the tag within it. The file tag set is
listed first, followed by a period and then the name of the file tag (e.g.,
AuthorTagSet.Bob).

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.
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How to Fix Undefined File Tags
There are a couple of basic ways to fix an undefined file tag. First, you can rename the file tag or file
tag set so that it matches what you have associated with the file. Otherwise, you can re-associate
the file tag with the file so that it uses an existing file tag or file tag set.

To Rename File Tags

1. In the window pane, select all file tag occurrences that you want to rename. If you want to
select all rows click . You can hold the SHIFT key to select a range, or you can hold the
CTRL key to select individual items.

NOTE All file tag occurrences that you select will be renamed to the same file tag
that you provide in the following steps.

2. In the local toolbar, click the Rename button. The Rename File Tag(s) dialog opens.

3. In the New file tag name field, enter a new file tag name. Type the name of the file tag set,
followed by a period, then the name of the file tag (e.g., AuthorTagSet.Bob).

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected file tag
occurrences are renamed.

NOTE If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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To Re-associate File Tags

1. Open the Flare project that contains the file.

2. In the Content Explorer or Project Organizer, right-click on the file and select Properties.

3. Select the File Tags tab.

4. Select the appropriate file tag set and file tag.

5. Click OK.

What’s Noteworthy?

NOTE Another way to associate a different file tag to many places throughout a project is
to use the Find and Replace in Files feature in Flare Desktop. For example, let's say that you
originally associated a file tag named "Completed" (from the "Status" file tag set) with a lot
of files in your project. Later, you renamed the file tag "Finished." You can perform a find
and replace in your entire project. In the "Find" field, you can enter Status.Completed,
and in the "Replace with" field, you can enter Status.Finished. Also, make sure you
select the "Find in source code" option in the Find and Replace in Files window pane. After
replacing this text throughout your project, that file tag will no longer be considered
"undefined" in Flare Desktop. See the Help system for more information.
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Viewing Undefined Meta Tags
You can view a list of all files with meta tags applied to them, but those meta tags have not been
defined. This might occur, for example, if you have applied a meta tag to a file and then later change
the name of the tag or meta tag set in the Text Editor.

How to View Undefined Meta Tags
1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Analysis > Undefined Items > Undefined Meta Tags.

n Summary Window Pane Double-click the row that mentions undefined meta tags.

The Undefined Meta Tags window pane opens.

2. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

3. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.
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How to Fix Undefined File Tags
There are a couple of basic ways to fix an undefined meta tag. First, you can rename the meta tag
so that it matches what you have associated with the file. Otherwise, you can re-associate the meta
tag with the file so that it uses an existing meta tag or meta tag set.

To Rename Meta Tags

1. In the window pane, select all file tag occurrences that you want to rename. If you want to
select all rows click . You can hold the SHIFT key to select a range, or you can hold the
CTRL key to select individual items.

NOTE All meta tag occurrences that you select will be renamed to the same meta
tag that you provide in the following steps.

2. In the local toolbar, click the Rename button.

3. In the New meta tag name field, enter a meta tag name that already exists in the meta tag
set.

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected meta
tag occurrences are renamed.

NOTE If you want to undo the conversions, you can use the Backups window pane
(View > Backups).

CHAPTER 2  101



To Re-associate Meta Tags

1. In the Content Explorer, right-click the file and select Properties.

2. Select the Meta Tags tab.

3. Select the appropriate meta tag set and meta tag.

4. Click OK.

What’s Noteworthy?

NOTE Another way to associate a different meta tag to many places throughout a project
is to use the Find and Replace in Files feature in Flare Desktop. For example, let's say that
you originally associated values from a meta tag named "Authors" with a lot of files in your
project. Later, you renamed the meta tag "Writers." If this results in undefined meta tags for
some reason, you can perform a find and replace in your entire project. In the "Find" field,
you can enter <meta name="Authors", and in the "Replace with" field, you can enter
<meta name="Writers". Also, make sure you select the "Find in source code" option in
the Find and Replace in Files window pane. After replacing this text throughout your
project, that meta tag will no longer be considered "undefined" in Flare Desktop. See the
Help system for more information.
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Viewing Undefined Styles
You can view a list of all files where you have style classes applied to content, but those styles have
not been defined. This might occur, for example, if you have created a new style class and applied it
to a paragraph in a topic. Later, you remove that style class from the stylesheet. Therefore, you now
have a style in a topic that is no longer defined in the stylesheet. You need to either apply a
different, existing style class to that content, or you need to add the style class to the stylesheet
again. You can also quickly rename or remove multiple style occurrences in a single batch, add the
undefined style to the project, or map the undefined style to an existing style.

How to View Undefined Styles
1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Analysis > Undefined Items > Undefined Styles.

n Analysis Summary Window Pane Double-click the row that mentions undefined styles.

The Undefined Styles window pane opens.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Tag Displays the parent tag for the class.

n Style Displays the child style class that is applied to content in the file.

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.
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How to Fix Undefined Styles
There are a few basic ways to fix an undefined style: (1) You can rename the style; (2) you can
remove the style from the content; (3) you can apply a different style class to the affected content;
(4) you can add a new style to the stylesheet; and (5) you can map the undefined style to an existing
style.

To Rename Style Classes

1. In the window pane, select all style class occurrences that you want to rename. If you want to
select all rows click . You can hold the SHIFT key to select a range, or you can hold the
CTRL key to select individual items.

NOTE All style class occurrences that you select will be renamed to the same style
that you provide in the following steps.

2. In the local toolbar, click the Rename button. The Rename Style(s) dialog opens.

3. In the New style name field, enter a new style class.

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected style
class occurrences are renamed.

NOTE If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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To Remove Style Classes

1. In the window pane, select all style class occurrences that you want to delete. If you want to
select all rows click . You can hold the SHIFT key to select a range, or you can hold the
CTRL key to select individual items.

2. In the local toolbar, click .

3. Click OK.

4. A message lets you know how many files were changed. Click OK. All of the selected style
class occurrences are removed.

NOTE If you want to undo the conversions, you can use the Backups window pane
(View > Backups).

To Apply Different Style Classes

1. You can either double-click on the specific row, or right-click on the row and select Open.

2. Select Home, click the down arrow in the field displaying styles, and choose a new style class.
See the Styles Guide or the Help system for more information about styles and how to apply
them.

3. Click to save your work.
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To Add a Style

1. In the window pane, select the style that you want to add to the project.

2. Do one of the following, depending on the part of the user interface you are using:

n Local Toolbar Click .

n Right-Click Right-click on the condition tag you want to add and from the context menu
select Add New Style.

The Create Style dialog opens.

3. On the left side of the dialog, select one of the following:

n Class Select this if you want to create a simple class (e.g., a special paragraph intended
to serve as a tip or note).

n ID In CSS, an identifier (ID) is similar to a class, except that IDs are unique. An element
in your stylesheet can have only one ID on it, whereas it can have multiple classes. And
each page of your output can have only one element with a particular ID. For many
authors, using an ID may not be important, but for others—such as those making use of
JavaScript—IDs can be very useful.

4. In the field after your selection, type a name for the new style class or ID, without using
spaces.

5. On the right side of the dialog, select the stylesheet to which you want to add the new style.

6. The property values already applied to the selected content are shown. If you do not want to
include certain property values in the new selector, click the check box next to the value (in
the Include column) to remove the check mark.

7. If you want the new style to immediately be applied to the content selected in the topic, select
Create style and update the source element. If you do not want the new style to immediately
be applied to the content selected in the topic, select Create style without updating the
source element.

8. Click OK. The style is added to the currently linked stylesheet.

9. Click to save your work.
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To Map to a Style

1. In the window pane, select the style that you want to map to an existing style.

2. Do one of the following, depending on the part of the user interface you are using:

n Local Toolbar Click .

n Right-Click Right-click on the condition tag you want to add and from the context menu
select Map to Existing Style.

The Select Class or ID dialog opens.

3. In the dialog, select the existing style class or ID in the project to overwrite the current
undefined style.

4. Click OK. All of the selected style occurrences are overwritten with the new style.

5. Click to save your work.
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Used Items
In the Analysis ribbon, the Used Items drop-down button provides several options.

Viewing Used Conditions
You can view a list of all condition tags that have been applied in files throughout your project. The
list shows not only the condition tags, but each file where they have been used. You can also
quickly rename or remove multiple condition tag occurrences in a single batch.

For more information about condition tags and how they are used in projects, see the Condition
Tags Guide or the Help system.

How to View Used Conditions
1. Open a project.

2. Select Analysis > Used Items > Used Condition Tags.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Condition Tag Displays the name of the condition tag set and the tag within it. The
condition tag set is listed first, followed by a period and then the name of the condition
tag (e.g., Primary.Print).

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

n Tag Displays the tag being used by the condition tagvariable.

n Exclude Action Displays the kind of "exclude" action tied to the condition tag. In most
cases, the exclude action is "remove." However, in some instances, this action might be
"unbind." For example, you might have the unbind action for a condition tag if you have
applied the tag to a hyperlink and want the link to be removed from the text in some
outputs, but you still want the text to be shown in those outputs.
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4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

NOTE You can open any file in the list to view or modify it in an editor. You can either
double-click on the specific row, or right-click on the row and select Open.

How to Rename Conditions
1. In the window pane, select all of the condition tags that you want to rename. If you want to

select all rows click . You can hold the SHIFT key to select a range, or you can hold the
CTRL key to select individual items.

NOTE All condition tags that you select will be renamed to the same condition tag
that you provide in the following steps.

2. In the local toolbar, click the Rename button. The Rename Condition tag(s) dialog opens.

3. In the New condition tag name field, enter a new name.

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected
condition tags are renamed.

NOTE If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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Viewing Used File Tags
You can view a list of all file tags used in your project. The list shows the tag type and the file that it
is associated with. You can quickly rename or remove multiple file tag occurrences in a single
batch.

For more information about file tags and how they are used in projects, see the Flare Desktop Help
system.
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How to View Used File Tags
1. Open a project.

2. Select Analysis > Used Items > Used File Tags.

The Used File Tags window pane opens, listing all of the file tags used throughout the project.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n File Tag Displays the name of the file tag set and the tag within it. The file tag set is
listed first, followed by a period and then the name of the file tag (e.g.,
AuthorTagSet.Bob).

n Type Displays the type of file tag (e.g., Status, Author). It also indicates if a file tag is
undefined. In that case, use the Undefined File Tags window pane to fix the problem.

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

NOTE You can open any file in the list to view or modify it in an editor. You can either
double-click on the specific row, or right-click on the row and select Open.
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How to Rename File Tag Occurrences
1. In the window pane, select all file tag occurrences that you want to rename. If you want to

select all rows click . You can hold the SHIFT key to select a range, or you can hold the
CTRL key to select individual items.

NOTE All file tag occurrences that you select will be renamed to the same file tag
that you provide in the following steps.

2. In the local toolbar, click the Rename button. The Rename File Tag(s) dialog opens.

3. In the New file tag name field, enter a new file tag name. Type the name of the file tag set,
followed by a period, then the name of the file tag (e.g., AuthorTagSet.Bob).

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected file tag
occurrences are renamed.

NOTE If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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Viewing Used Language Tags
You can view a list showing each file where a language tag is found, the content tag to which it has
been applied (e.g., html, span), and the language used.

How to View Used Language Tags
1. Open a project.

2. Select the Analysis ribbon. In the Dynamic Reports section, select Used Items > Used
Language Tags.

The Used Language Tags window pane opens, listing all of the language tags used
throughout the project.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Language Displays the abbreviation for the language in the tag. For example, the
abbreviation for English is "en"; the abbreviation for German is "de"; and the
abbreviation for Italian is "it."

n Tag Displays the tag for the content where the language tag is applied. For example, if
the language is applied to a topic file, the tag is html. If the language is applied to
selected text within a paragraph, the tag is span.

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.
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NOTE You can open any file in the list to view or modify it in an editor. You can either
double-click on the specific row, or right-click on the row and select Open.

NOTE You can also include this information in reports that you create.
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Viewing and Renaming Used Meta Tags
You can view a list of all meta tags that have been applied to files throughout your project. The list
shows not only the meta tags, but each file where they have been used, and the values (i.e.,
content) of each. You can also quickly rename or remove multiple meta tag occurrences in a single
batch.

How to View Used Meta Tags
1. In the Analysis ribbon, select Used Items > Used Meta Tags.

2. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Meta Tag Displays the name of the meta tag.

n Meta Tag Set Displays the name of the meta tag set file (if any) where the meta tag was
found.

n Content Displays the value for the meta tag.

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

3. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

4. You can click a column heading to reorganize the grid according to that value. For example, if
you want to see the meta tag values grouped together, click the Content column heading.

NOTE You can open any file in the list to view or modify it in an editor. You can either
double-click on the specific row, or right-click on the row and select Open.
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How to Rename Meta Tag Occurrences
1. In the window pane, select all file tag occurrences that you want to rename. If you want to

select all rows click . You can hold the SHIFT key to select a range, or you can hold the
CTRL key to select individual items.

NOTE All meta tag occurrences that you select will be renamed to the same meta
tag that you provide in the following steps.

2. In the local toolbar, click the Rename button.

3. In the New meta tag name field, enter a meta tag name that already exists in the meta tag
set.

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected meta
tag occurrences are renamed.

NOTE If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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Viewing Used Variables
You can view a list of variables that have been inserted in your project. The list shows not only the
variables, but each topic where they have been used. You can also quickly rename or remove
multiple variable occurrences in a single batch.

How to View Used Variables
1. Open a project.

2. Select Analysis > Used Items > Used Variables.

The Used Variables window pane opens, listing all of the variables used throughout the
project, including snippet variables.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Variable Displays the name of the variable set and the variable within it. The variable set
is listed first, followed by a period and then the name of the variable (e.g.,
Primary.CompanyName).

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

n Tag Displays the tag being used by the variable.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

NOTE You can open any file in the list to view or modify it in an editor. You can either
double-click on the specific row, or right-click on the row and select Open.
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How to Rename Variable Occurrences
1. In the window pane, select all variable occurrences that you want to rename. If you want to

select all rows click . You can hold the SHIFT key to select a range, or you can hold the
CTRL key to select individual items.

NOTE All variable occurrences that you select will be renamed to the same variable
that you provide in the following steps.

2. In the local toolbar, click the Rename button. The Rename Variable(s) dialog opens.

3. In the New variable name field, enter a new variable. Type the name of the variable set,
followed by a period, then the name of the variable (e.g., MyVariableSet.MyVariableName).

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected variable
occurrences are renamed.

NOTE If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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Viewing Used Index Keywords
You can view a list of all index keywords used throughout your project. You can also quickly rename
multiple keyword occurrences in a single batch.

For more information about index keywords and how they are used in projects, see the Index Guide
or the Help system.

How to View Used Index Keywords
1. Open a project.

2. Select Analysis > Used Items > Used Index Keywords.

The Used Index Keywords window pane opens, listing all of the index keywords used
throughout the project.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Keyword Displays the index keyword used in the file.

n File Displays the path and name of the file where the index keyword is inserted.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.
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How to Rename Index Keywords
1. In the window pane, select all keywords that you want to rename. If you want to select all

rows click . You can hold the SHIFT key to select a range, or you can hold the CTRL key to
select individual items.

NOTE All keywords that you select will be renamed to the same keyword that you
provide in the following steps.

2. In the local toolbar, click the Rename button. The Rename Index Keyword(s) dialog opens.

3. In the New index keyword name field, enter a new index keyword.

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected
keywords are renamed.

NOTE If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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Viewing Used Concepts
You can view a list of all concepts used in your project. You can also quickly rename multiple
concept occurrences in a single batch.

For more information about concepts and how they are used in projects, see the Help system for
more information.

How to View Used Concepts
1. Open a project.

2. Select the Analysis ribbon. In the Dynamic Reports section, select Used Items > Used
Concepts. The Used Concepts window pane opens, listing all of the concepts used
throughout the project.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Concept Displays the concept used in the file.

n File Displays the path and name of the file where the concept is inserted.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.
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How to Rename Concepts
1. In the window pane, select all concepts that you want to rename. If you want to select all

rows click . You can hold the SHIFT key to select a range, or you can hold the CTRL key to
select individual items.

NOTE All concepts that you select will be renamed to the same concept that you
provide in the following steps.

2. In the local toolbar, click the Rename button. The Rename Concept(s) dialog opens.

3. In the New concept name field, enter a new concept.

4. Click OK.

5. A message lets you know how many files were changed. Click OK. All of the selected
concepts are renamed.

NOTE If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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Viewing Used Bookmark Links
You can view a list showing each file where a link to a bookmark is found, including the name of the
bookmark, the kind of link used, and the path of the link. You can also double-click a row to open the
file where the bookmark link is inserted.

How to View Used Bookmark Links
1. Open a project.

2. Select Analysis > Used Items > Used Bookmarks.

The Used Bookmarks window pane opens, listing all of the bookmark links used throughout
the project.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Bookmark Displays the name of the bookmark.

n Link Tag Displays the tag where the bookmark link is used.

n Link Displays the link path.

n File Displays the name of the file.

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

NOTE You can open any file in the list to view or modify it in an editor. You can either
double-click on the specific row, or right-click on the row and select Open.

NOTE You can also include this information in reports that you create.
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More Analysis Scans
In the Analysis ribbon, the More Reports drop-down button provides several report options.

Viewing Files With Annotations
You can view a list of all files where annotations (internal comments) have been inserted. You can
also double-click a row to open the topic in question.

How to View Files With Annotations
1. Select Analysis > More Reports > Files With Annotations.

The Files With Annotations window pane opens. The area at the bottom of the window pane
displays all topics in your project where annotations have been inserted.

2. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

n Text Displays the annotation text.

n Initials Displays the initials of the individual who inserted the annotation.

n Creator Displays the user name of the individual who create the annotation.

n Editor Displays the user name of the individual who last edited the annotation.

n Create Date Displays the date and time when the annotation was created.

n Edit Date Displays the date and time when the annotation was last edited.

3. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.
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NOTE You can open any file in the list to view or modify it in an editor. You can either
double-click on the specific row, or right-click on the row and select Open.
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Viewing Files With Changes
You can view a list of files with tracked changes (and annotations). You can then open the file
where the changes are located and deal with them appropriately (e.g., accept or reject changes).

How to View Files With Changes
1. Select Analysis > More Reports > Files With Changes.

The Files With Changes window pane opens. The area at the bottom of the window pane
displays all topics in your project where tracked changes have been made.

2. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

n Change Displays the type of change that was made.

n Initials Displays the initials of the individual who made the change.

n Creator Displays the user name of the individual who made the change.

n Timestamp Displays the date and time when the change was made.

3. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

4. You can double-click any file in the list to accept or reject the changes.
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Viewing Topics Not Indexed
You can view a list of all topics where you have not yet inserted index keywords. Therefore, no
references to those topics will be found in the generated index. You can also double-click a row to
open the topic in question. 

How to View Topics Not Indexed
1. Select Analysis > More Reports > Topics Not In Index.

The Topics Not In Index window pane opens. The area at the bottom of the window pane
displays all topics where you have not yet inserted index keywords.

2. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

3. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

NOTE You can open any file in the list to view or modify it in an editor. You can either
double-click on the specific row, or right-click on the row and select Open.

CHAPTER 2  127



Viewing Topics Not in a TOC
You can view a list of all topics that have been created in the project, but they have not yet been
linked to any items in a TOC. A drop-down filter lets you select a specific TOC to analyze, or you can
select "Any TOC" to analyze all TOCs in a project. 

How to View Topics Not Added to the TOC
1. Select Analysis > More Reports > Topics Not In Selected TOC.

The Topics Not In Selected TOC window pane opens. The area at the bottom of the window
pane displays all topics that have not yet been added to a TOC.

2. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

3. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

4. (Optional) You can drag topics from the Topics Not In Selected TOC window pane into an
open TOC by selecting a TOC from the Filter field in the Topics Not in Selected TOC window
pane, then dragging topics from the pane into the TOC. You may need to float and position
the TOC so you can see both it and the Topics Not in Selected TOC window pane.

NOTE You can open any file in the list to view or modify it in an editor. You can either
double-click on the specific row, or right-click on the row and select Open.
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Viewing Topics Not Linked by a Map ID
You can view a list of all topics that are not linked to context-sensitive Help (CSH) map IDs. You can
also double-click a row to open the topic in question.

How to View Topics Not Linked by a Map ID
1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Analysis > More Reports > Topics Not Linked By Map ID.

n Summary Window Pane Double-click the row that mentions these items.

The Topics Not Linked By Map ID window pane opens.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.
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Viewing Duplicate Items in a TOC
You can view a list of all files in your project that have been added more than once to a TOC using
the Duplicate TOC Items window pane.

How to View Duplicate Items in the TOC
1. Open a project.

2. Select Analysis > More Reports > Duplicate TOC Items. The Duplicate TOC Items window
pane opens, displaying all files that have been added more than once to a TOC.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

n TOC Displays the name of the TOC where the multiple links to the file are found.

n Count Displays the count.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

NOTE You can open any file in the list to view or modify it in an editor. You can either
double-click on the specific row, or right-click on the row and select Open.
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Viewing Duplicate Meta Tags
You can view a list of all meta tags that have been applied to files throughout your project and
whose values are defined two or more times in the same file. However, the same meta tag name is
allowed in different meta tag sets.

How to View Duplicate Meta Tags
1. Select Analysis > More Reports > Duplicate Meta Tags. The Duplicate Meta Tags window

pane opens.

2. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

3. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

4. You can quickly remove multiple meta tag occurrences in a single batch. Select the rows you
want to affect, and click the "Delete" button.

NOTE You can open any file in the list to view or modify it in an editor. You can either
double-click on the specific row, or right-click on the row and select Open.
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Viewing Duplicate Styles
You can view a list of all styles in your project where the same properties have been set. For
example, let's say you have a style called "p.tip" and another style called "p.note." If you have
specified the same settings for each of these styles (e.g., red font, 12 pt), with no other properties
set, these styles will be included in the Duplicate Styles window pane. Groups or pairs of duplicate
styles are displayed in alternating shaded rows (e.g., the rows for the first pair of duplicate styles
are not shaded, the rows for the next group are shaded, the rows for the next group are not shaded,
and so on). If you encounter duplicate styles, you may want to modify the settings for one or both
styles, or you can remove one of the style classes from the stylesheet.

How to View Duplicate Styles
1. Open a project.

2. Select Analysis > More Reports > Duplicate Style Formats. The Duplicate Style Formats
window pane opens, displaying all topics in your project where there are duplicate styles.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Pair Index Displays a number to represent the group of duplicate styles. The first group
of duplicate styles has an index of 1. The next group of duplicate styles has an index of
2. The next group has an index of 3, and so on.

n Selector Displays the style name.

n Declarations Displays the properties that have been set for the style. For all styles in an
"index pair," these properties are identical.

n Medium Displays the medium to which the style properties are applied. If this cell is
blank, the style properties are simply used in the default medium. For more information
about style medium types, please see the Help system.

n File Displays the name of the file.

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.
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NOTE You can open any file in the list to view or modify it in the Stylesheet Editor. You can
either double-click on the specific row, or right-click on the row and select Open.

NOTE Duplicate styles are displayed only if they are based on the same tag. For example, if
you have identical properties set for the styles "p.tip" and "p.note," they will be included in
the window pane (because they are both based on the p style). However, if you have
identical properties set for the styles "p.tip" and "h4.note," they will not be included in the
window pane (because one is based on the p style, whereas the other is based on the h4
style).
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Viewing Topics Not Linked
You can view a list of all topics that are not linked from anywhere else in the project. Let's say you
were to create a text hyperlink to this topic from another topic, or perhaps link to the topic from a
table of contents. In that case, the topic would no longer be displayed in the Topics Not Linked
window pane. You can double-click a row to open the topic in question. You can also add condition
tags to the topic.

How to View Topics Not Linked
1. Select Analysis > More Reports > Unused Items.

The Unused Items window pane opens, which lets you view various unused elements in the
project (such as bookmarks, condition tags, content files, CSH IDs, images, variables, styles,
file tags, meta tags, and topics not linked).

2. Click the drop-down field at the top of the window pane and select Topics Not Linked. The
unlinked topics in the project are listed.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Condition Tag Displays the name of the condition tag not being used.

n File Displays the name of the topic or file that is not linked.

n Title Displays the properties title of the file (if any).

n Folder  Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

5. If you want to remove any unlinked topics from Flare Desktop, as well as from the project
being analyzed, select the topic in the list and click in the local toolbar.
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6. (Optional) You can add condition tags to the topics not linked.To add condition tags, do the
following.

a. Select Topics Not Linked from the drop-down menu in the Unused Items window pane.

b. Do one of the following.

n Right-click the unlinked topic and from the context menu, select Properties.

n Right-click the unlinked topic and press CTRL+SHIFT+P on the keyboard.

The Properties dialog opens.

c. In the Properties dialog, click the Conditional Text tab.

d. Select condition tags, then click OK.

NOTE You can open any file in the list to view or modify it in an editor. You can either
double-click on the specific row, or right-click on the row and select Open.
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Viewing Unused Content Files
You can view a list of the content files (e.g., topics, images, multimedia, page layouts, template
pages, snippets) within your project that are not being used. For example, if an image file is added
to your project but not yet inserted into any topic, it is considered an unused file. Also, if you have
created a topic, but no other files link to that topic (or if no index keywords or concepts have been
inserted into it), the topic is considered unused. You can quickly delete any of the files that you do
not plan to use. You can also add condition tags to the content files.

How to View Unused Content Files
1. Select Analysis > More Reports > Unused Items.

The Unused Items window pane opens, which lets you view various unused elements in the
project (such as bookmarks, condition tags, content files, CSH IDs, images, variables, styles,
file tags, meta tags, and topics not linked).

2. Click the drop-down field at the top of the window pane and select Unused Content Files. The
unused content files in the project are listed.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Condition Tag Displays the conditions applied to the unused content files.

n File Displays the name of the content file not being used.

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

5. If you want to remove any unused content files from Flare Desktop, as well as from the
project being analyzed, select the content file in the list and click in the local toolbar.
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6. (Optional) You can add condition tags to the unused content files.To add condition tags, do
the following.

a. Select Unused Content Files from the drop-down menu in the Unused Items window
pane.

b. Do one of the following.

n Right-click the content file and from the context menu, select Properties.

n Right-click the content file and press CTRL+SHIFT+P on the keyboard.

The Properties dialog opens.

c. In the Properties dialog, click the Conditional Text tab.

d. Select condition tags, then click OK.

NOTE You can open any file in the list to view or modify it in an editor. You can either
double-click on the specific row, or right-click on the row and select Open.
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Viewing Unused Images
You can view a list of all images that have been created in your project but have not yet been used
in any topics or other files. You can quickly delete any of the images that you do not plan to use.
You can also add condition tags to the images. For more information about images, see the Images
Guide or the Help system.

How to View Unused Images
1. Select Analysis > More Reports > Unused Items.

The Unused Items window pane opens, which lets you view various unused elements in the
project (such as bookmarks, condition tags, content files, CSH IDs, images, variables, styles,
file tags, meta tags, and topics not linked).

2. Click the drop-down field at the top of the window pane and select Unused Images. The
unused images in the project are listed.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Condition Tag Displays the condition tag for the image not being used.

n File Displays the name of the image file not being used.

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

5. If you want to remove any unused images from Flare Desktop, as well as from the project
being analyzed, select the image in the list and click in the local toolbar.
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6. (Optional) You can add condition tags to the unused images. To add condition tags, do the
following.

a. Select Unused Images from the drop-down menu in the Unused Items window pane.

b. Do one of the following:

n Click the button in the local toolbar.

n Right-click the image and from the context menu, select Properties.

n Right-click the image and press CTRL+SHIFT+P on the keyboard.

The Properties dialog opens.

c. In the Properties dialog, click the Conditional Text tab.

d. Select condition tags, then click OK.

NOTE You can open the image file for any picture in the list to view it in the Image Viewer.
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Viewing Unused Variables
You can view a list of all variables that have been created in your project but have not yet been used
in any topics or other files. You can quickly delete any of the variables that you do not plan to use.

How to View Unused Variables
1. Select Analysis > More Reports > Unused Items.

The Unused Items window pane opens, which lets you view various unused elements in the
project (such as bookmarks, condition tags, content files, CSH IDs, images, variables, styles,
file tags, meta tags, and topics not linked).

2. Click the drop-down field at the top of the window pane and select Unused Variables. The
unused variables in the project are listed.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Variable Displays the name of the variable not being used.

n File Displays the name of the variable set where the variable is located.

n Definition Displays the text associated with the variable.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

5. If you want to remove any unused variables from Flare Desktop, as well as from the project
being analyzed, select the variable in the list and click in the local toolbar.

NOTE You can open the set file for any variable in the list to view or modify it in the
Variable Set Editor.
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Viewing Unused Conditions
You can view a list of all condition tags that have been created in your project but have not yet been
used in any topics or other files. You can quickly delete any of the condition tags that you do not
plan to use. For more information about condition tags and how they are used in projects, see the
Condition Tags Guide or the Help system.

How to View Unused Conditions
1. Select Analysis > More Reports > Unused Items.

The Unused Items window pane opens, which lets you view various unused elements in the
project (such as bookmarks, condition tags, content files, CSH IDs, images, variables, styles,
file tags, meta tags, and topics not linked).

2. Click the drop-down field at the top of the window pane and select Unused Condition Tags.
The unused condition tags in the project are listed.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Condition Tag Displays the name of the condition tag not being used.

n File Displays the name of the condition tag set file where the condition tag is located.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

5. If you want to remove any unused condition tags from Flare Desktop, as well as from the
project being analyzed, select the condition tag in the list and click in the local toolbar.

NOTE You can open the set file for any condition tag in the list to view or modify it in the
Condition Tag Set Editor.
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Viewing Unused CSH IDs
You can view a list of all context-sensitive Help (CSH) identifiers that have been created in your
project but have not yet been assigned. You can double-click a row to open the Flare header file. For
more information, see the CSH Guide or the Help system.

How to View Unused CSH IDs
1. Select Analysis > More Reports > Unused Items.

The Unused Items window pane opens, which lets you view various unused elements in the
project (such as bookmarks, condition tags, content files, CSH IDs, images, variables, styles,
file tags, meta tags, and topics not linked).

2. Click the drop-down field at the top of the window pane and select Unused CSH IDs. The
unused CSH IDs in the project are listed.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n CSH ID Displays the CSH identifier that is not being used.

n File Displays the alias file where the CSH ID is located. You can use the alias file to
assign the unused CSH ID to a topic or micro content phrase, unless you prefer to
delete the CSH ID.

n Definition Displays the unique numerical value associated with the CSH ID.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

5. If you want to remove any unused CSH IDs from Flare Desktop, as well as from the project
being analyzed, select the CSH ID in the list and click in the local toolbar.

NOTE You can open the alias file for any CSH ID in the list to view or modify it in the Alias
Editor.
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Viewing Unused File Tags
You can view a list of all file tags that have been created in your project but have not yet been used
in any files. You can quickly delete any of the file tags that you do not plan to use.

For more information about file tags and how they are used in projects, see the Flare Desktop Help
system.

How to View Unused File Tags
1. Select Analysis > More Reports > Unused Items.

The Unused Items window pane opens, which lets you view various unused elements in the
project (such as bookmarks, condition tags, content files, CSH IDs, images, variables, styles,
file tags, meta tags, and topics not linked).

2. Click the drop-down field at the top of the window pane and select Unused File Tags. The
unused file tags in the project are listed.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n File Tag Displays the name of the file tag not being used.

n Type Displays the type of file tag (e.g., Status, Author).

n File Displays the name of the file.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

5. If you want to remove any unused file tags from Flare Desktop, as well as from the project
being analyzed, select the file tag in the list and click in the local toolbar.

NOTE You can open the set file for any file tag in the list to view it in the File Tag Set Editor.
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Viewing Unused Meta Tags
You can view a list of all meta tags that have been created in your project but have not yet been
used in any files. By "unused," we mean that the meta tag was created but no values were set for it
in any file.

You can quickly delete any of the meta tags that you do not plan to use.

How to View Unused Meta Tags
1. Select Analysis > More Reports > Unused Items.

The Unused Items window pane opens, which lets you view various unused elements in the
project (such as bookmarks, condition tags, content files, CSH IDs, images, variables, styles,
file tags, meta tags, and topics not linked).

2. Click the drop-down field at the top of the window pane and select Unused Meta Tags. The
unused meta tags in the project are listed.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

5. If you want to remove any unused meta tags from the project being analyzed, select the meta
tag in the list and click in the local toolbar.

CHAPTER 2  144



Viewing Unused Styles
You can view a list of styles in your project that have not yet been applied to content in any files. If
you do not use a particular style class, you can remove it from the stylesheet. You can also use the
"disable" feature to hide styles that you do not want to be displayed in the stylesheet; you can
access this feature from the Options drop-down button in the local toolbar of the Stylesheet Editor.

How to View Unused Styles
1. Select Analysis > More Reports > Unused Items.

The Unused Items window pane opens, which lets you view various unused elements in the
project (such as bookmarks, condition tags, content files, CSH IDs, images, variables, styles,
file tags, meta tags, and topics not linked).

2. Click the drop-down field at the top of the window pane and select Unused Styles. The
unused styles in the project are listed.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Selector Displays the name of the parent style, followed by a period and the name of
the class under that style (e.g., p.tip).

n Declarations Displays any property settings that you have set for the style class.

n File Displays the name of the file.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

5. If you want to remove any unused styles from Flare Desktop, as well as from the project
being analyzed, select the style in the list and click in the local toolbar.

NOTE You can open the stylesheet for any style in the list to view or modify it in the
Stylesheet Editor.
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Viewing Empty Content Folders
You can scan for empty content folders in a project with the Unused Items window pane. Empty
content folders are those that have been created, but do not contain files of any type. You can
quickly delete any empty content folders in the Unused Items window pane.

How to View Empty Content Folders
1. Select Analysis > More Reports > Unused Items.

The Unused Items window pane opens, which lets you view various unused elements in the
project (such as bookmarks, condition tags, content files, CSH IDs, images, variables, styles,
file tags, meta tags, and topics not linked).

2. Click the drop-down field at the top of the window pane and select Empty Content Folders.
The empty content folders in the project are listed.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Folder Displays the name of the empty content folder.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

5. If you want to remove any empty content folders from Flare Desktop, as well as from the
project being analyzed, select the empty content folder in the list and click in the local
toolbar.
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Viewing Unused Bookmarks
You can view a list of all bookmarks that have been inserted in content files, but there are no links in
that file or any others pointing to that bookmark. You can quickly delete any of the bookmarks that
you do not plan to use. You can also double-click a row to open the file where the bookmark is
inserted. For more information about bookmarks and how they are used in projects, see the
Navigation Links Guide or the Help system.

How to View Unused Bookmarks
1. Select Analysis > More Reports > Unused Items.

The Unused Items window pane opens, which lets you view various unused elements in the
project (such as bookmarks, condition tags, content files, CSH IDs, images, variables, styles,
file tags, meta tags, and topics not linked).

2. Click the drop-down field at the top of the window pane and select Unused Bookmarks. The
unused bookmarks in the project are listed.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Bookmark Displays the name of the bookmark.

n File Displays the name of the file.

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

5. If you want to remove any unused bookmarks from Flare Desktop, as well as from the project
being analyzed, select the bookmark in the list and click in the local toolbar.

NOTE You can open any file in the list to view or modify it in an editor. You can either
double-click on the specific row, or right-click on the row and select Open.
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Viewing Non-XML Topics
You can view a list of non-XML files (e.g., HTML files) that have been added to your project. You can
also convert those HTML files to XHTML files in a single batch.

EXAMPLE You have many HTML files that you want to add to your Flare project. So you
copy and paste them into the Windows folder where your project is stored (i.e., within the
Content folder). If you were to try to open each of those files within the Flare project, a
dialog would open, directing you to convert each HTML file to an XHTML file (one at a
time). However, if you have hundreds of these files, you may not want to take the time to
convert each one individually. So instead, you open the Non-XML Topics window so that
you can view a list of all of the non-XML files in the project. Then you can quickly convert
the entire list of HTML files to XHTML files.
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How to View Non-XML Topics
1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Analysis > More Reports > Non-XML Topics.

n Analysis Summary Window Pane Double-click the row that mentions these items.

The Non-XML Topics window pane opens, listing all non-XML files in the project.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n Apply Displays a check box next to the files. If you decide to convert the non-XML file to
XML, you need to make sure the check box is selected. If you do not want to convert the
file, but you do want to convert other files in the list, you can click the check box to
remove the check mark.

n File Displays the name of the non-XML file.

n Title Displays the title of the non-XML topic (if any).

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

CHAPTER 2  149



How to Convert Non-XML Topics
1. In the window pane, select all files that you want to convert. If you want to select all rows

click . You can hold the SHIFT key to select a range, or you can hold the CTRL key to select
individual items.

2. In the local toolbar, click the Convert Topics button.

3. In the message that opens, click OK. If you selected a single topic row only, the HTML to
XHTML Conversion dialog opens. Click Convert.

4. If you selected multiple topic rows, another message lets you know how many files were
changed. Click OK. All of the selected files are converted to XHTML files.

NOTE If you want to undo the conversions, you can use the Backups window pane
(View > Backups).
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Viewing Files With Snippet Conditions
You can view a list of all files where snippet conditions have been applied. You can also double-click
a row to open the file in question.

How to View Topics With Snippet Conditions
1. Open a project.

2. Select the Analysis ribbon. In the Dynamic Reports section select More Reports > Files With
Snippet Conditions.

The Files With Snippet Conditions window pane opens, displaying all files in your project
where snippet conditions have been applied.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n File Displays the name of the file.

n Location Displays the location of the snippet condition (e.g., topic, snippet block).

n Folder Displays the folder where the file is found.

n Expression Displays the condition expression used.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

NOTE You can open any file in the list to view or modify it in an editor. You can either
double-click on the specific row, or right-click on the row and select Open.
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Viewing Files Without File Tags
You can view a list of all content files in the project that do not have file tags. Then you can open
the properties for a file and associate one or more file tags with it.

For more information about file tags and how they are used in projects, see the Flare Desktop Help
system.

How to View Without File Tags
1. Open a project.

2. Do one of the following:

n Ribbon Select Analysis > More Reports > Files Without File Tags.

n Summary Window Pane Double-click the row that mentions files without file tags.

The Files Without File Tags window pane opens, listing all content files that do not have file
tags associated with them.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

5. You can open a file and associate file tags with it. You can either double-click on the specific
row, or right-click on the row and select Open.

6. Once the file is open, select File > Properties. In the Properties dialog, you can use the File
Tags tab to associate file tags.

CHAPTER 2  152



Viewing Invalid Meta Values
You can view a list of all files containing meta tags that have invalid values. For example, an invalid
meta tag might occur if you remove a meta tag's list item from the meta tag set file. In a case such
as this, you can resolve the issue by adding the list item back to the meta tag set, or re-associating
the files with a different value.

How to View Invalid Meta Values
1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Analysis > More Reports > Invalid Meta Values.

n Summary Window Pane Double-click the row that mentions invalid meta values.

The Invalid Meta Values window pane opens.

2. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

3. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

NOTE You can open any file in the list to view or modify it in an editor. You can either
double-click on the specific row, or right-click on the row and select Open.
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Viewing Topics Without Concepts
You can view a list of all topics in the project that do not have concepts inserted. You can then open
a topic and insert concepts into it.

For more information about concepts and how they are used in projects, see the Help system.

How to View Topics Without Concepts
1. Open a project.

2. Do one of the following:

n Ribbon Select Analysis > More Reports > Topics Without Concepts.

n Summary Window Pane Double-click the row that mentions topics without concepts.

The Topics Without Concepts window pane opens, listing all topics that do not have concepts
inserted into them.

3. To see more of the information in the window pane, drag the divider bar to make the pane
wider.

n File Displays the name of the file.

n Title Displays the properties title of the file (if any).

n Folder Displays the folder where the file is found.

4. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.
You can also click View All in the local toolbar to see all results on a single page. Keep in mind
that the more items you have in the project, the longer it will take to load this view.

NOTE You can open a file and insert concepts into it. You can either double-click on the
specific row, or right-click on the row and select Open.

CHAPTER 2  154



CHAPTER 3

Reports
From the Reports folder in the Project Organizer, you can generate custom reports based on
information contained in your project. In addition, you can design the look and feel of reports, save
them for future access, and open them in a browser window (where you can print them). 

This chapter discusses the following:

Adding Report Files 156

Generating Reports 157

Opening Reports 160

Saving Reports 161

Viewing the Word Count 162

Exporting File Data to a CSV File 164
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Adding Report Files
The first step in using analysis reports is to add a report file, which is stored in the Reports folder in
the Project Organizer.

How to Add a Report File
1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Project > New > Add Report File.

n Right-Click In the Project Organizer, right-click on the Reports folder and from the
context menu select Add Report File.

The Add File dialog opens.

2. In the File Type field at the top, make sure Report is selected.

3. In the Source area, choose to create the new file based on a template or an existing file.

n New From Template Choose either a factory template file or one of your own custom
template files as a starting point. The new file will take on all of the settings contained
in the template. If you want to use the factory template provided by Flare Desktop,
expand the Factory Templates folder and click on a template file. If you want to use
your own custom template file, expand the appropriate folder and click on a file. For
more information about templates, see the Help system.

n New From Existing Choose an existing file of the same type as a starting point for your
new file. As with template files, your new file will take on all of the settings contained in
the file you select. To use this option, click , use the Open File dialog to find a file, and
double-click it.

4. (Optional) If you want to place the file into a subfolder previously created in the Content
Explorer or Project Organizer, in the Folder field click and select the subfolder. Otherwise,
keep the default location.

5. In the File Name field, type a new name for the report file.

6. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the
dialog. Next to the File Tags field, click and select the file tags you want to apply. Click OK.

7. Click Add. The report file is added to the Project Organizer. The Report Editor opens.
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Generating Reports
You can create a report based on the information captured while your project is being analyzed.
When doing this, you can provide a name for the report and select the types of information that you
want to include in it. Another option is to immediately print the report after it is generated. You can
also design the look and feel of the report, and then compile it so that it displays the selected data
in the format you provide.

How to Generate a Report
1. Add or open a report file. The Report Editor opens. See "Adding Report Files" on the previous

page.

2. Select the General tab.

3. In the Title field, enter a title for the report you want to generate.

4. In the Tables section, click in the check boxes next to any information that you want to
include in the report. Some items appear in multiple categories. Click the appropriate Select
All check box to choose all items in a category.

CHAPTER 3  157



5. (Optional) Select Skip empty reports if you want to see only reports that contain information.

EXAMPLE You are generating a report and have selected ten different types of
information to include. Perhaps one of those types of information—"Unused
Condition Tags"—will not return any results because all of your condition tags have
been used somewhere. However, the other nine types of information do have data to
report.

If you select the "skip" option, the generated report will include nine sections, one for
each type of information containing data. You will not see a section in the generated
report for "unused condition tags."

If you do not select the "skip" option, you will see ten sections in the generated result.
Nine of those sections will show data, and the tenth (for "unused condition tags") will
simply mention that no data exists.

6. (Optional) Select Print report after generation if you want to print a report immediately after
you generate it. If this option is selected, the Print dialog opens as soon as a report is finished
generating.

7. (Optional) If you want to modify the look of the report, use the following steps.

a. Select the Styles tab.

b. Select the style item that you want to modify (e.g., ReportEntry, ReportHeading,
ReportText). You can select a basic style node, or you can expand the node and select
an option under it.

n ReportEntry This affects the individual lines of data in a report, displaying the
information you selected when generating the report. You can add borders,
padding, and margins to those entries. Depending on the depth of the information
in the report, the data may display on one of three levels. You can expand the
style item and use the Level1, Level2, and Level 3 options to specify settings for
each level.
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n ReportGroup This affects the chunks or groups of data in a report, displaying the
information you selected when generating the report. You can add borders,
padding, and margins to those entries.

n ReportHeading This affects the individual headings that display in the report,
based on the types of information that you selected when generating the report.
For example, if you select four different types of data for the report (e.g., Absolute
Links, Broken Links, External Links, Snippet Suggestions), you will see a different
heading for each of those. You can change the heading label, as well as font,
border, padding, and margin settings.

n ReportPrefix This affects the prefix text that is displayed before the individual
lines of data in a report so that you know what you are looking at in an entry (e.g.,
File, Condition Tag, Link, Bookmark). You can change the font settings for those
prefixes. Depending on the depth of the information in the report, the data may
display on one of three levels. You can expand the style item and use the Level1,
Level2, and Level 3 options to specify settings for each level.

n ReportSection This affects the entire section where a type of information is
displayed in a report. For example, if you selected to view absolute links and
external links in a report, you can modify the section for each, to change the look
of the area where the heading and individual entries are shown. You can add
borders, padding, and margins to those sections. You can also specify that a
page break should be inserted before or after the heading in a report.

n ReportText This affects the text of the individual lines of data in a report. You can
change the font settings for the text. Depending on the depth of the information
in the report, the data may display on one of three levels. You can expand the
style item and use the Level1, Level2, and Level 3 options to specify settings for
each level.

c. Select the Property Groups or Alphabetical List option to display the properties for the
style item.

d. In the Properties section, set the values for the properties that you want modify.

8. Click to save your work.

9. Select the General tab.

10. In the Report section, click the Generate button. The report is generated and displays below. If
you change the options and click Generate again, the report will be replaced with a new one.
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Opening Reports
You can easily open a report file, which contains settings used for generating reports. Each report
file can contain many generated reports in its archives. After generating a report, you can open it in
a browser window. From the browser window, you can print the report.

How to Open a Report File in the Interface
1. Open the Project Organizer.

2. Double-click the Reports folder.

3. Double-click the report file that you want to open. The Report Editor opens, with the previous
settings still in place. You can re-generate a report with those settings or use the Archive tab
to open a report that you have saved previously.

How to Open a Generated Report in a Browser
Window

1. Generate a report. See "Generating Reports" on page 157.

2. In the Report Editor, do one of the following.

n Select the General tab. Click the Open in Browser button.

n If you have previously saved a generated report in the archive, select the Archive tab.
Select the report and click the Open in Browser button.

After opening a report in a browser window, you can print it.
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Saving Reports
You can archive a generated report, which saves a copy of the report in the Project\Reports folder
where your project is located. Each report file can contain many generated reports in its archives.

How to Save a Report
1. Generate a report.

2. In the Report Editor, select the General tab.

3. Click the Add to Archive button. The Archive Report dialog opens. By default, the name of the
report file is displayed, followed by the current date.

4. Leave the report name as it is, or enter a new name.

5. Click OK.

If you later want to open the saved report, use the Archive tab in the Report Editor.
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Viewing the Word Count
You can look in the lower-left of the XML Editor to see the word count for the open content file. Also,
you can generate reports to see the word count for files in different ways.

XML Editor
If you select content, that number of words is shown along with the total word count for the file
(e.g., 7/60 = 7 out of 60 words are selected).
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Reports
After you add and open a report, select any of the following in the Report Editor, then generate the
report.

n Content Files > File Word Count Shows word count for each content file in project

n Project > Statistics Shows total words combined for all content files in project (along with
other statistics, such as total number of topics and images)

n Target > Word Count Shows total words combined for all content files in target, based on
associated TOC
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Exporting File Data to a CSV File
You can export data from the File List window pane, most windows related to analysis functions,
and TOC Editor to a comma-separated value (CSV) file. This can be quite useful since there are
several columns of data in the window pane. CSV files are typically used to transfer large amounts
of spreadsheet or database information from one program to another.

How to Export File Data to a CSV File
1. Open the File List window pane, window related to the analysis tool, or the TOC Editor.

2. If you opened the TOC Editor, make sure Grid View is shown, as opposed to Tree View.
Otherwise, the export buttons will not be enabled.

3. If you want to export only some of the data, select the rows that you want to include. You can
hold the SHIFT key to select a range, or you can hold the CTRL key to select individual items.
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4. Do one of the following, depending on the part of the user interface you are using:

n Local Toolbar To export all data, click . To export only selected rows, click .

OR

n Right-Click Right-click in the window pane and from the context menu, select either
Export to CSV or Export selection to CSV.

The Save As dialog opens.

5. In the Save As dialog, select a destination and file name for the CSV file. The "Save as type"
field will be pre-populated with the CSV file type.

6. Click Save.
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CHAPTER 4

Text Analysis
From the Tools ribbon in Flare Desktop, you can run text analysis on content files for readability,
average sentence length, and more.

How to Run a Text Analysis
1. Open the content file.

2. Select Tools > Text Analysis.

3. Select any of the options to include in the analysis.

n Readability scores This lets you know how easy or hard it is to read your documents.
Scores are based on “The Flesch Reading Ease” and “Flesch-Kincaid Grade Level” tests.
For Reading Ease, a higher score indicates that the text is easier to read and a lower
score means it is harder to read. The Flesch-Kincaid Grade Level is based on grade
levels in the United States educational system (e.g., a score of 6 means a 6th grade
reading level).

For more information about these tests, see:

https://readable.io/content/the-flesch-reading-ease-and-flesch-kincaid-
grade-level/

n Average sentence length This lets you know how many words are in the average
sentence.
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n Punctuation density per sentence This lets you know the average number of
punctuation marks in each sentence.

n Number of unique words This provides you with a basic vocabulary count. It lets you
know how many words are used in the document(s), but it does not count any word
more than once.

n Analyze text in Select which document(s) you want to include in the analysis:

l current document Flare Desktop analyzes the active file only.

l pick a file A dialog opens that lets you choose any topic, snippet, template page, or
micro content file.

l documents in the same folder Flare Desktop analyzes all files located in the same
folder as the current one.

l all open documents Flare Desktop analyzes all files that are currently open in the
project.

l pick a folder A dialog opens that lets you choose any folder in your project. Flare
Desktop will then analyze the files within that folder.

l whole project Flare Desktop analyzes every file in the project.

n Compare text in This lets you perform a side-by-side comparison of the document(s)
originally selected above with other documents. Choose the second document (or
group of documents) to include in the comparison.

When the selected analysis option is part of the group being compared (e.g., whole
project, documents in same folder), results are not included for those files. Results are
included only for the other documents being compared.

4. Click Analyze. Results are shown in the space below.

Colored bars are used to indicate whether an area has a good (green), average (yellow), or
poor (red) score. Remember that reading ease and grade level results are the opposite of one
another. That is why you would see a high reading ease score with green bar but a high grade
level score with a red bar; that’s because you want to see high scores with reading ease, but
low scores are preferable for grade level.
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EXAMPLE You have a folder in your project containing three topics: Basic Steps, Getting
Started, and What’s New.

You want to analyze these topics for their readability scores. If you analyze the topics one
at a time, you’ll see that the Basic Steps topic has the following results
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The Getting Started topic has these results:

And the results for the What’s New topic look like this:
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Then you decide you want to compare the results for the Basic Steps topic next to the other
two. So in the Compare text in field, you select (documents in the same folder) and run the
analysis. The results look like this:

The results on the left are for the Basic Steps topic. The comparison results on the right are
a composite of the Getting Started and What’s New topics.

Although the Basic Steps topic is included in the same folder as the other two, it doesn’t
make sense to include that topic in the second set of results, because that is the topic you
are comparing the others to.
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CHAPTER 5

Flare Online Analytics
If you have a MadCap Flare Online license, you can view analytics on published HTML5 output. This
includes search phrases used, search phrases with no results, topics viewed, context-sensitive Help
calls, and demographic statistics (browsers and operating systems).
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NOTE If the project is not bound to Flare Online, you can view the analytics information on
any Flare Online license where you are using the analytics key. However, if the project is
bound to Flare Online, you can view its analytics only on the Flare Online license where the
project is uploaded.

This chapter discusses the following:

Permission Required? 173

Types of Analytics Information 174

Host Output Anywhere 180

Creating and Editing Analytics Keys 181

Associating Analytics Keys With Targets 182

Managing Analytics Keys 183

Downloading Analytics 184
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Permission Required?
To create and manage keys, you must have the following permission setting in Flare Online:

However, all users on the license can view analytics data, regardless of their permission settings.

For more information about permissions, see the documentation for Flare Online.
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Types of Analytics Information
By using Flare Online Analytics, you can obtain various types of information about your output.

Search

Phrases
Shows all search queries made to the output, including whether a search term returned any micro
content results. This is useful because it indicates the kind of documentation most often sought by
users, as well as whether you should create new micro content to match certain search terms.
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Phrases With No Results
Shows all search phrases that didn't produce any results. This is useful because it indicates if you
need to produce new documentation to provide results for users, or perhaps create synonyms that
will show results for existing documentation.
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Content

Topics
Shows all topics in the output that have been viewed at least once. This is useful because it
indicates the topics where you might want to focus much of your attention.
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Context-Sensitive Help Calls
Shows context-sensitive Help identifiers that have been invoked at least once in the output. This is
useful because it indicates which areas of your product’s interface are most active, and perhaps even
unclear to users.
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Demographics

Browser Statistics
Shows which browsers are being used to view your online output. The graph shows a broad view of
the browsers, and the grid breaks down the information into specific browser versions. This is
useful because it indicates which browsers you should focus on supporting.
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Operating System Statistics
Shows which operating systems are being used to view your online output. This is useful because it
indicates which operating systems you should focus on supporting. It might even be used to
determine whether your company’s software needs to continue supporting certain operating
systems.

NOTE The graph at the top is limited to the first 10 items. The grid below shows all items.

NOTE For more information about using the Analytics page—including downloading and
filtering data—see the documentation for Flare Online.
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Host Output Anywhere
Analytics works on projects located in Flare Online, or you can host output on your own servers. If
you host the output outside of Flare Online, you still need to use Flare Online with a key to view the
analytics data. Also, the server where the output is hosted must be able to communicate with Flare
Online (e.g., not be behind a firewall).
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Creating and Editing Analytics Keys
Analytics keys are associated with Flare HTML5 targets. You can create and edit these keys either
in Flare Desktop or in Flare Online. To do this, you must have the permission in Flare Online to
“Manage Output Analytics Keys” (see the documentation for Flare Online).

How to Create or Edit an Analytics Key in Flare
Desktop

1. Open an HTML5 target.

2. Select the Analytics tab.

3. From the Provider field, select Flare Online.

4. If you are not yet logged in to Flare Online, click Login. Then complete the fields in the dialog
and click OK.

5. From the Flare Online License field, choose your license.

6. Next to the Key field, click Create.

If you already have a key that you want to edit, select it from the drop-down, then click Edit.

7. Enter a name for the key and an optional description, then click OK.

8. Click to save your work.

What’s Next?
If your new analytics key is not already associated with a target, you need to open the target and
select it.
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Associating Analytics Keys With
Targets

If you create a key in Flare Desktop, it will become associated with your HTML5 target as you do
this. But if you create the key in Flare Online, you need to then open the target and associate that
key with it.

How to Associate an Analytics Key With a
Target

1. Open an HTML5 target.

2. Select the Analytics tab.

3. From the Provider field, select Flare Online.

4. If you are not yet logged in to Flare Online, click Login. Then complete the fields in the dialog
and click OK.

5. From the Flare Online License field, choose your license.

6. At the bottom of the Key area, click the drop-down and select the name of the key.

7. Click to save your work.

8. Build output for the target and publish it to see the analytics results.
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Managing Analytics Keys
You can click Manage Keys in the Flare target.

This opens the Analytics page in Flare Online. From here, you can create and edit keys, as well as
delete any that you no longer need.
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Downloading Analytics
In the toolbar of the Analytics page, you can click to download the data to a comma-separated
value (CSV) file.
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CHAPTER 6

Content Services Portal
The Content Services Portal is used to manage search indexes on your Elasticsearch output. You
can review and manage search indexes by topic, micro content, user searches, and global
searches.

This chapter discusses the following:

How to Access the Production Content Services Portal 186

How to Access the Local Content Services Portal 187

Managing Search Indexes 188

Importing Data From an Upgrade 194
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How to Access the Production
Content Services Portal

Installation and configuration of the Content Services Portal results in a URL for the portal. To
access Content Services on the production server, you can enter the URL into a web browser. For
example, the URL to use from another computer to access this portal is http://[name of server]/
[MyPortal].
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How to Access the Local Content
Services Portal

The following steps describe how to open the local version of Content Services. You might want to
do this to test the portal locally.

1. Open a project.

2. Open an HTML5 target that has been built using Elasticsearch as the search engine.

3. Click the Search tab.

4. After all of the settings have been configured for Elasticsearch, click the Launch Content
Services button.
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Managing Search Indexes
The All Targets window displays all HTML5 targets using Elasticsearch. You can access search
data by an individual target. Each of the columns on this window can be sorted in ascending or
descending order by clicking on the column name.

When you click an individual target, the Summary window is displayed for it. This window shows
the total number of searches done, number of files that can be searched, and users that have
searched on the individual target. The bottom half of this window displays the settings you
configured for your Elasticsearch output.
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If you click the red Topics button in the top left corner, the Topics window displays the total number
of files searched on this target. You can enter a string in the search field to filter the list of files
displayed.
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When you click the purple box in the portal, the Micro Content window displays all of the phrases
and the corresponding content that responds to each phrase. Each box in this window contains the
phrase, the date the micro content was created, and its corresponding response.
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Clicking the blue button displays the number of user searches for the specific target. This window
displays the search criteria from each individual search, the date of the search, along with the
IP address of the user who conducted the search. Each of the columns can be sorted in ascending
or descending order by clicking on the column name. You have the option to delete individual
search criteria, or delete all of the individual user searches for your target.
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The Global Searches window is displayed when you click the green button labeled Global Searches
anywhere in the portal. The Global Searches window shows each search criteria, the last time that
criteria was searched, along with the number of times that particular search string has been
searched for your Elasticsearch output. The number displayed in the Search Count field increments
higher when a specific string is searched by different IP addresses. So if the same IP address has
searched a certain search string multiple times, the search count number does not increment
higher for that particular IP address. Each of these columns can be sorted in ascending or
descending order by clicking on the column name.
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Importing Data From an Upgrade
If you are upgrading Elasticsearch from 5.6 to 7.10.2, you will see a large Import Data button in the
portal after you open a target.

NOTE If you have do not yet have data for Elasticsearch 7.10.2, you should see the large
Import Data button. This button will go away after your first import. There is also a smaller
import button at the top of the portal.
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APPENDIX

PDFs
The following PDFs are available for download from the Help system.

Tutorials
Autonumbers Tutorial

Back-to-Top Button Tutorial

Context-Sensitive Help Tutorial

Custom Toolbar Tutorial

eLearning Tutorial—Basic

eLearning Tutorial—Advanced

Getting Started Tutorial

Image Tooltips Tutorial

Lists Tutorial

Meta Tags Tutorial

Micro Content Tutorial—Basic

Micro Content Tutorial—Advanced

Responsive Output Tutorial

Single-Sourcing Tutorial

Snippet Conditions Tutorial

Styles Tutorials

Tables Tutorial

Word Import Tutorial
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Cheat Sheets
Context-Sensitive Help Cheat Sheet

Folders and Files Cheat Sheet

Learning & Development Cheat Sheet

Lists Cheat Sheet

Micro Content Cheat Sheet

Print-Based Output Cheat Sheet

Search Cheat Sheet

Shortcuts Cheat Sheet

Structure Bars Cheat Sheet

Styles Cheat Sheet
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User Guides
Accessibility Guide

Analysis and Reports Guide

Architecture Guide

Autonumbers Guide

Branding Guide

Condition Tags Guide

Context-Sensitive Help Guide

Eclipse Help Guide

eLearning Guide

Getting Started Guide

Global Project Linking Guide

HTML5 Guide

Images Guide

Import Guide

Indexing Guide

Key Features Guide

Lists Guide

MadCap Flare Online
Integration Guide

Meta Tags Guide

Micro Content Guide

Navigation Links Guide

Plug-In API Guide

Print-Based Output Guide

Project Creation Guide

QR Codes Guide

Reviews & Contributions With
Contributor Guide

Scripting Guide

Search Guide

SharePoint Guide

Skins Guide

Snippets Guide

Source Control Guide: Git

Source Control Guide:
Perforce Helix Core

Source Control Guide:
Subversion

Source Control Guide: Team
Foundation Server

Styles Guide

Tables Guide

Tables of Contents Guide

Targets Guide

Template Pages Guide

Templates Guide

Topics Guide

Touring the Workspace Guide

Transition From FrameMaker
Guide

Translation and Localization
Guide

Variables Guide

Videos Guide

What's New Guide
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