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CHAPTER 1

Introduction
A snippet is a chunk of formatted content that is heavily used in single-sourcing. Snippets can
include text, tables, images, and whatever else can be included in a normal topic. You can insert
snippets into one or more topics throughout your project, thus allowing you to reuse content that is
maintained in one place. You can even insert them into other snippets, creating nested snippets.
Snippets are not usually intended for single words or very short phrases that change frequently. In
those cases, you probably want to use variables instead.

General Information

n "Benefits of Snippets" on page 8

n "Snippet Files" on page 8

n "Text and Block Snippets" on page 9

n "Snippets and Auto Suggestions" on page 10

Main Activities

n "Creating Snippets" on page 12

n "Adding Snippet Files" on page 14

n "Inserting Snippets" on page 17

n "Opening Snippets" on page 23

n "Editing Snippets" on page 25

n "Using Snippet Conditions" on page 26
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Other Activities

n "Replacing Snippets" on page 39

n "Converting Snippets to Text" on page 41

n "Inserting Page Numbers into Frames" on page 42

n "Importing Snippets" on page 44

n "Pinning Snippets" on page 45

n "Deleting Snippets" on page 54

WARNING It is recommended that you avoid creating links to snippets. This is primarily
due to the nature of snippets, which are designed to be inserted into multiple files. Let's say
you have a heading style in a snippet and that snippet is then inserted into 12 different
topics. In another topic, you might decide to create a cross-reference that points to the
heading in that snippet. But which of those 12 topics is it supposed to point to in the
output? There is no way for Flare Desktop to know this, so you could end up with some very
undesirable results. For this reason, it's a good idea not to link to any content in a snippet.

NOTE Although it is possible to open any Flare files in a third-party editor, it is
recommended that you avoid editing these files in certain programs while Flare Desktop is
running. For example, opening a stylesheet in Notepad++ is not an issue. But you might
experience problems if you open a topic or snippet in Microsoft Word and edit it while Flare
Desktop is running.
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CHAPTER 2

General Information for
Snippets
There are various pieces of general information you should know if you plan to use this feature.

This chapter discusses the following:

Benefits of Snippets 8

Snippet Files 8

Text and Block Snippets 9

Block Snippet 9

Snippets and Auto Suggestions 10
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Benefits of Snippets
The major benefit of using snippets is that you only have to create your content once, rather than
having to type the same information in each topic (or in another snippet) where you want to use it.
If you need to modify the content of a snippet, you only need to change it in one place and the
change is made automatically in every file where the snippet has been inserted.

Snippet Files
Snippets are contained in their own files (using an .flsnp file extension). You can therefore share
them with other authors or use them in other projects. If you insert a snippet that is stored outside
of your project, the file is copied to your project. The recommended location to store a snippet in
the Content Explorer is in the Resources > Snippets folder. However, you can store it anywhere in
the Content Explorer that you like.
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Text and Block Snippets
There are two types of snippets: text and block. This is determined by the way you insert the
snippet.

n Text Snippet If you insert a snippet on a line where other content exists (i.e., inline), it is
inserted as a text snippet. Therefore, if you want to insert a snippet on a blank line and also
type other text before or after it, you need to type the text first and then insert the snippet
afterward.

n
Block Snippet If you insert a snippet on a blank line in a topic, it is inserted as a block snippet
and takes up all of the room so that no other content can be added in front of it or behind it.
(The exception to this is if you have created a snippet containing only a <body> tag and no
block tags, such as <p>; in that case, the snippet inserted on an empty line becomes a text
snippet.)

When a snippet has multiple "blocks" of content (e.g., paragraphs, lists, images), it is best to insert it
as a block snippet on an empty line, because it doesn't work well when inserted as a text snippet
(i.e., inline with other content). Conversely, a snippet containing a single line of content (e.g., one
sentence, one paragraph) can be inserted as a block snippet on an empty line, or as a text snippet
inline with other content.

When you create a text or block snippet, it displays surrounded by brackets (if you have markers
turned on).
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Snippets and Auto Suggestions
Flare Desktop recognizes when you are typing content that matches existing snippets in your
project. This makes it a very fast and convenient way to single-source your content. 

EXAMPLE You work on a team of 15 writers and there are a series of snippets in all of your
projects that begin with the same three words—For more information…

Perhaps each person knows to start typing those words in certain places. But what if a
snippet already exists with the full content that the writer needs? Without knowing that, a
person might spend time typing all of the content, and maybe even create a new snippet for
future use. But if Auto Suggestion is enabled, as soon as a person types a certain number
of characters, all matching snippets are shown in the Auto Suggestion popup. Therefore,
the writer can quickly find and select the appropriate snippet.
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CHAPTER 3

Main Activities for Snippets
Some activities are particularly common and important when it comes to this feature.

This chapter discusses the following:

Creating Snippets 12

Adding Snippet Files 14

Inserting Snippets 17

Opening Snippets 23

Editing Snippets 25

Using Snippet Conditions 26
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Creating Snippets
If you have already typed content in your topic and want to turn that content into a snippet, you can
create a snippet out of that existing content using the Home ribbon or Format menu. You can then
insert the snippet into other topics where you want it to appear.

How to Create a Snippet From Existing Content
1. In the XML Editor select the content you want to turn into a snippet.

2. In the Home ribbon, select Create Snippet.

3. Give the snippet a name and choose a folder location to store it.

It is recommended that you leave the project folder selection as "Resources/Snippets" (or
select a subfolder that you have created in the Snippets folder). After the snippet is created,
you can see the snippet file in the Content Explorer.

4. If you want the snippet to replace the highlighted content, select Replace Source Content with
the New Snippet.

Why would you leave this box unchecked? Let's say you want to create two snippets and they
are going to be very similar. You might create the first snippet, make a few changes to the
text within the dialog, and leave this box unchecked. That snippet is created but not inserted
into the topic. Then you can create the second snippet with this box checked. Flare Desktop
will both create the snippet and insert it into the topic, replacing the highlighted text.

5. Click Create. In the XML Editor, the snippet is surrounded by brackets (if markers are turned
on).

6. Click to save your work.
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WARNING You can create snippets for entire question sections and reuse them. However,
use caution when doing so, because each question has its own question ID associated with
it, and you do not want the ID to end up inside the snippet. The question ID is necessary for
eLearning tracking. For more information see the Help system.

NOTE You can also add a new snippet file or import an existing snippet from outside your
project. See "Adding Snippet Files" on the next page and "Importing Snippets" on page 44.
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Adding Snippet Files
You can add a new snippet (without necessarily having any topic open) and then insert the snippet
into the topics where you want it to appear.

How to Add a Snippet File
1. Do one of the following, depending on the part of the user interface you are using:

n (Recommended) Right-Click In the Content Explorer, right-click on a folder and from the
context menu select New > Snippet.

TIP When adding a new file to the Content Explorer, the recommended method
is to right-click on the folder in the Content Explorer and use the New menu
option. This is the most efficient way to direct the new file to the folder where
you want to store it. That's because the Add File dialog opens when you add a
new content file, and this method ensures that the folder you want is already
selected in that dialog.

n Ribbon Select Project > New > Snippet.

The Add File dialog opens.

2. In the File Type field at the top, make sure Snippet is selected.

3. In the Source area, choose to create the new file based on a template or an existing file.

n New From Template Choose either a factory template file or one of your own custom
template files as a starting point. The new file will take on all of the settings contained
in the template. If you want to use the factory template provided by Flare Desktop,
expand the Factory Templates folder and click on a template file. If you want to use
your own custom template file, expand the appropriate folder and click on a file. For
more information about templates, see the Help system.

n New From Existing Choose an existing file of the same type as a starting point for your
new file. As with template files, your new file will take on all of the settings contained in
the file you select. To use this option, click , use the Open File dialog to find a file, and
double-click it.
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4. (Optional) The Folder field is automatically populated with the folder that has focus in the
Content Explorer. If you want to place the file into a folder that you previously created in the
Content Explorer, in the Folder field click and select the subfolder. Otherwise, keep the
default location.

NOTE If you want to place non-topic files in a recommended folder, first make sure
that folder exists in the Content Explorer. If it does not exist, you can easily add it.

Non-Topic File Type Recommended Default Folder in Content Explorer

Branding Resources > Branding

Image Resources > Images

Micro Content Resources > MicroContent

Multimedia Resources > Multimedia

Page Layout Resources > PageLayouts

Snippet Resources > Snippets

Stylesheet Resources > Stylesheets

Table Stylesheet Resources > TableStyles

Template Page Resources > TemplatePages

5. In the File Name field, type a new name for the snippet.

6. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click and select the conditions you
want to apply. Click OK.
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7. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the
dialog. Next to the File Tags field, click and select the file tags you want to apply. Click OK.

8. Click Add. The snippet is added to the Content Explorer and opens in its own page in the XML
Editor with some default text for you.

9. Now simply click inside the snippet page in the XML Editor and start typing text (replacing the
default text shown) or adding any other elements (e.g., styles, tables, images, hyperlinks,
multimedia) appropriate for the snippet.

10. Click to save your work.
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Inserting Snippets
After you create or add snippets, you can insert them into a content file (e.g., topic, snippet). You
can do this by using user interface options, which let you search for a snippet, or you can simply
drag an existing snippet from the Content Explorer or File List window pane.

How to Insert a Snippet—Insert Snippet Link
Dialog

1. Open the content file.

2. Place your cursor where you want to insert the snippet.

3. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Insert > Snippet.

n Local Toolbar Click the face of the button.

OR

Click the down arrow next to , then select More Snippets.

n Keyboard Shortcut Press CTRL+R.

n Right-Click Right-click in the editor and select Insert > Snippet. This context menu
option is available only when your cursor is located in certain places in the editor (e.g.,
not in a drop-down effect).

The Insert Snippet Link dialog opens.

4. Navigate to the snippet that you want to insert and select it. By using the buttons in the local
toolbar, you can view all snippet files in a list, view files in their folder structure, and use other
options. If you want to add one of your 20 most recently used snippets to the project, you can
select a snippet from the Recently Used Snippets group. If you want to add one of your
pinned—or favorite—snippets to the project, you can select a snippet from the Pinned
Snippets group. You also can click to find and select a snippet file outside of the project.

CHAPTER 3  17



CHAPTER 3  18



Option Description

Shows all of the files in the project in a list below. Click the
button again to switch to a folder tree view. You can click the
File, Type, or Path column headers to sort the list alphabetically
by that column data.

Shows or hides the folders that the files are stored in.

Shows or hides the files. If you click this button when the Show
Folders button is selected, the area splits into two. The folder
is shown on the left side, and the files and subfolders within it
are shown on the right.

If the Show Files button is the only one selected, you can
click this button to move up one folder level.

Lets you filter the kinds of files shown below. Depending on the
task you are performing, this field may already be populated with
the most appropriate file type(s).

NOTE If you select a snippet file outside the project, that file is then copied and
placed inside the project. The image file is stored in the Resources\Snippets folder of
the Content Explorer.
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5. Click OK. The snippet is inserted and is surrounded by brackets (if markers are turned on).

6. Click to save your work.
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How to Insert a Snippet—Drag-and-Drop
1. Open the Content Explorer or File List window pane.

If necessary, make sure you float and position the window pane or editor so that you can see
both it and XML Editor at the same time.

2. Click and drag the snippet from the Content Explorer or File List window pane to the location
where you want it in the XML Editor and drop it.

3. Click to save your work.

How to Insert a Snippet—Local Toolbar
1. Open the content file.

2. Place your cursor where you want to insert the snippet.

3. In the local toolbar at the top of the XML Editor click the down arrow next to . This
expands the Insert Snippet drop-down, where you can see your pinned snippets and the 20
most recently used snippets.

4. Navigate to the snippet that you want to insert and select it.

5. Click to save your work.
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What’s Noteworthy?

NOTE If you need to insert a snippet that does not appear in the Pinned Snippets or
Recently Used Snippets groups, you can select More Snippets to open the Insert Snippet
Link dialog.

NOTE Snippets must appear in the Recently Used Snippets group before they can be
pinned. If the snippet you want to pin does not appear in the Recently Used Snippets group,
you can add it to a content file by dragging it from the Content Explorer or using the Insert
Snippet Link dialog.

NOTE The Recently Used Snippets and Pinned Snippets groups show the relative path
location of each snippet. Hover over any snippet to see its full file path.

NOTE You can expand or collapse the Recently Used Snippets and Pinned Snippets groups
by clicking the arrows next to each group name.

NOTE If you have the snippet feature in Auto Suggestions enabled, you can quickly insert
snippets into content files when you begin typing matching text.

NOTE If you want to change how snippets look when they're inserted in the XML Editor, you
can change the MadCap|snippetBlock or MadCap|snippetText styles (for block and text
snippets, respectively) in the Stylesheet Editor. This does not affect the output. For more
information see the Help system.
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Opening Snippets
After you create or add snippets to your project, they are stored in the Content Explorer (Content >
Resources > Snippets). You can open as many existing snippets as you want at one time and make
modifications to them. Each snippet displays in its own page of the XML Editor and remains
accessible as you work. As you open more snippets or other elements (e.g., topics, targets, tables
of contents), each page displays in the appropriate editor (e.g., XML Editor, Target Editor, TOC
Editor). By default, the most recently opened page is on the left side of the editor section in Flare
Desktop, and the previously opened pages shift to the right. The active page displays on top of the
other pages, and you can make any page the active one (or "the one on top") by simply clicking its
tab.

How to Open a Snippet From the Quick Launch
Bar
The Quick Launch bar lets you search for any Flare Desktop file or command. It is located in the
upper-right corner of the interface. You can press CTRL+Q on your keyboard to move focus to the
Quick Launch bar so you can begin typing.

1. In the Quick Launch bar, type a few letters of the name of the file you want to open. Any
available results appear in a drop-down list.

2. From the list, click the name of the file.
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How to Open a Snippet From the Context Menu
1. Open a topic where the snippet is inserted.

2. Right-click on the snippet and select Open Snippet File.The snippet opens in its own page of
the XML Editor.

How to Open a Snippet From the Content
Explorer

1. Open the Content Explorer.

2. Expand the Resources folder, and double-click the Snippets subfolder to open it (unless you
have stored these files in a custom folder).

3. Do one of the following:

n Locate and double-click the snippet file (e.g., NameOfSnippet.flsnp) that you want to
open.

n Locate and click the snippet file (e.g., NameOfSnippet.flsnp) that you want to open. In
the local toolbar, click .

The snippet opens in its own page of the XML Editor.
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Editing Snippets
After you create or add a new snippet to your project, you can insert it into any of your topics. Later,
if you decide that the snippet needs to be altered, you can do so easily using the steps below. When
you edit a snippet, the changes are automatically reflected in any topics where you have inserted
the snippet previously.

How to Edit a Snippet
1. Use one of the following methods to open the snippet that you want to modify.

n Right-click on the snippet in a topic where it is inserted and select Open Snippet File.

n Locate the snippet in the Resources > Snippets folder in the Content Explorer and
double-click it.

2. In the XML Editor make the necessary changes to the snippet, just as you would edit any
other document.

3. Click to save your work.

NOTE If you want to change how snippets look when they're inserted in the XML Editor, you
can change the MadCap|snippetBlock or MadCap|snippetText styles (for block and text
snippets, respectively) in the Stylesheet Editor. This does not affect the output. For more
information see the Help system.
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Using Snippet Conditions
Snippet conditions are just regular condition tags that you can apply to content within snippets and
then include or exclude them at the snippet or topic level (rather than at the target level). They are
especially useful when the majority of the snippet content is identical everywhere the snippet is
used, but there are some small differences in some places. This lets you use one snippet for many
purposes, rather than having to create multiple snippets to account for the small exceptions.

How to Use Snippet Conditions
1. Create all of the condition tags that you plan to use for separating your snippet content.

TIP You might want to include the word "Snippet" somewhere in the name of a new
snippet condition tag (e.g., Snippet1, Snippet2). This way, you can easily identify it,
rather than confusing it with the rest of the condition tags that you use for other
purposes (e.g., online output or printed output condition tags).

NOTE The more variations that you have in your snippet content, the more condition
tags you will need to create. An average number is four to eight condition tags, but
you may find that you require fewer or more tags than this for snippet content. It is
always preferable to create more condition tags than you may need, rather than to
realize later that you have too few. You can even create a separate condition tag set
to be used specifically for holding your snippet condition tags, while keeping the rest
of your condition tags in other tag sets.

2. Create and open the snippet.

3. Apply the necessary condition tags to the text or other content in the snippet.

TIP It is a good idea to click the Hide/Show Conditional Indicators button at the
bottom of the editor so that you can clearly see where the different tags have been
applied in the snippet.
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4. Do one of the following.

TO APPLY SNIPPET CONDITIONS AT THE SNIPPET LEVEL

This method is recommended in most cases. It allows you more flexibility and tends to be
easier to maintain topics as time goes by. Snippet conditions at the snippet level override
snippet conditions applied at the topic level.

a. Insert the snippet into the topic, or determine which topic already contains the snippet.

b. In the topic, right-click the snippet, and from the context menu, select Snippet
Conditions. The Snippet Conditions dialog opens.

c. If you want to exclude a condition tag from the snippet, select its row to highlight it.
Then click the Exclude option to the right. If you want to include a condition in the
snippet, select its row to highlight it, then click the Include option to the right.

d. Click OK.

e. (Optional) Repeat steps b-d for any other instances of the snippet in the topic.

f. Click to save your work.

TO APPLY SNIPPET CONDITIONS AT THE TOPIC LEVEL

This method is good if you have snippet conditions set throughout a topic and you want to
include and exclude the same conditions for the entire topic. Otherwise, it is recommended
that you apply snippet conditions at the snippet level.

a. Insert the snippet into the topics, or determine which topics already contain the
snippet.

b. After you determine that a particular topic should display only certain tagged content
from the inserted snippet, open the Content Explorer and select the topic file.

NOTE If there are several topics that you know in advance will include a
particular snippet condition tag, you can open the File List window pane (View
> File List) instead and select all of those files at the same time.

c. In the local toolbar, click . The Properties dialog for the topic opens.

d. Click the Snippet Conditions tab.
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e. If you want to exclude a condition tag from the topic, select its row to highlight it. Then
click the Exclude option to the right. If you want to include a condition in the topic,
select its row to highlight it, then click the Include option to the right.

f. Click OK.

EXAMPLE — Snippet Level

You are writing a user guide. There is a three-step process that users need to repeat very
frequently, so you create a snippet for those steps. However, there occasionally is a fourth
step in the process, where users can optionally select an extra check box before
completing the process. You sometimes need to include this process multiple times in the
same topic, so you create a snippet for the four-step process, and apply a condition to the
optional step.
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You add your snippet to the topic...
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...and then exclude the snippet condition on the second instance of the snippet. By doing
this, you won’t see the optional step in that instance of the snippet.
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Later, if you need to edit the content, you only have one snippet to edit.
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EXAMPLE — Topic Level

You have a table with 15 rows and four columns. Suppose the table needs to be included in
40 topics. Rather than copying and pasting the table 40 times, you create one snippet
containing the table and insert it into those 40 topics. However, let’s say that in 30 of those
topics, you need to add three more rows to the table to explain something. In the remaining
10 topics, the three additional rows are not necessary. Otherwise, the table content is the
same in all 40 topics. What do you do? You have a few options.

The first option is to add a note to the table explaining that the three additional rows are
intended only for some of the topics but not others. However, this might be confusing to
your readers.

The second option is to create two separate snippets—one for the 30 topics and another
for the 10 topics. However, this means that you need to maintain identical information in
two different places. And that is no way to single-source your content.

The third option is to create snippet conditions. Here is how you might do it in this example:

1. Create a condition tag.

2. Open the snippet and add the necessary three rows to the table.

3. Using the table row structure bars, apply the new condition tag to the additional three
rows.

4. Use the File List window pane (View > File List) to select the 30 topics requiring the
additional rows, and open the Properties dialog.

5. Select the Snippet Conditions tab.

6. Highlight the new condition tag, and select the Include option to the right.

7. Use the File List window pane to select the 10 topics not requiring the additional
rows, and open the Properties dialog.

8. Select the Snippet Conditions tab.

9. Highlight the new condition tag, and select the Exclude option to the right.

10. After you save all of your changes and generate the target, you will notice that the
three additional rows are displayed only in the 30 topics where they were included.
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EXAMPLE — Snippet Level Overriding Topic Level

You are working in a topic that has several snippet conditions set at the topic level. When
you insert an existing snippet into your topic, you notice that some of the text in the snippet
is excluded using the condition tag Snippet1. However, the Snippet1 condition tag is also
excluded at the topic level in the topic you are working on, so that text does not appear in
the XML Editor or your output.
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Snippet conditions on individual snippets override those at the topic level. So in the topic
you right-click the snippet and choose Snippet Conditions.
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In the Snippet Conditions dialog, you set the conditions on this snippet to include Snippet1.
While Snippet1 will still be excluded at the topic level, in this particular snippet, you will be
able to see the text that is marked with that tag.
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What’s Noteworthy?

WARNING The condition feature is an inclusive system. If you do not select any options, all
of the tags will automatically be included, as indicated by the gray text in the Action cell. If
you include only some tags and exclude others, any remaining tags without options
specifically set will automatically be included. However, if you select Include for any of the
tags (even just one) and do not select Exclude for any tags, all of the other tags that do not
have the Include option set explicitly will automatically be excluded. If you have not
explicitly set an option for a condition tag, make sure you look at the gray text in the Action
cell to know what will happen for that tag in the output.
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TIP If you are using snippet conditions, you may want to enable snippet condition
indicators from the Show tags drop-down in the XML Editor. This command enables or
disables a marker that overlays snippets that have snippet conditions applied to them.

If you enable this indicator, you will see it on snippets if you have snippet conditions
enabled at either the topic level or the snippet level.

NOTE Remember that snippet conditions only apply to a particular instance of a snippet. If
you add new snippet conditions to an existing snippet, be sure to use the Link Viewer to
check that the content in other instances of the snippet is still visible (or hidden) the way
you want it to be.

NOTE You can generate a report to see topics in your project that contain snippet
conditions at the topic or snippet level.
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CHAPTER 4

Other Activities for Snippets
In addition to the main activities, there are some other tasks you might perform regarding this
feature.

This chapter discusses the following:

Replacing Snippets 39

Converting Snippets to Text 41

Inserting Page Numbers into Frames 42

Importing Snippets 44

Pinning Snippets 45

Deleting Snippets 54
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Replacing Snippets
After you create or add a new snippet to your project, you can insert it into any of your topics. Later,
if you decide that a different snippet is a better fit for the topic, you can select a new snippet to
replace it. When you replace a snippet, it only affects the instance that you selected.

How to Replace a Snippet
1. Right-click on the snippet where it is inserted and select Select New Snippet. The Insert

Snippet Link dialog opens.

2. Navigate to the snippet that you want to insert and select it. By using the buttons in the local
toolbar, you can view all snippet files in a list, view files in their folder structure, and use other
options. If you want to add one of your 20 most recently used snippets to the project, you can
select a snippet from the Recently Used Snippets group. If you want to add one of your
pinned—or favorite—snippets to the project, you can select a snippet from the Pinned
Snippets group. You also can click to find and select a snippet file outside of the project.
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Option Description

Shows all of the files in the project in a list below. Click the
button again to switch to a folder tree view. You can click the
File, Type, or Path column headers to sort the list alphabetically
by that column data.

Shows or hides the folders that the files are stored in.

Shows or hides the files. If you click this button when the Show
Folders button is selected, the area splits into two. The folder
is shown on the left side, and the files and subfolders within it
are shown on the right.

If the Show Files button is the only one selected, you can
click this button to move up one folder level.

Lets you filter the kinds of files shown below. Depending on the
task you are performing, this field may already be populated with
the most appropriate file type(s).

NOTE If you select a snippet file outside the project, that file is then copied and
placed inside the project. The image file is stored in the Resources\Snippets folder of
the Content Explorer.

3. Click OK. The original snippet is replaced by the new snippet.

4. Click to save your work.
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Converting Snippets to Text
After you create or add a new snippet to your project, you may decide that you want the snippet to
be regular text instead. Rather than retyping the snippet, you can convert the snippet to text using
the steps below.

How to Convert a Snippet to Text
1. Open the topic.

2. In the XML Editor, right-click the snippet that you want to convert to text.

3. From the context menu, select Convert to text. The snippet is converted to text.

4. Click to save your work.
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Inserting Page Numbers into Frames
Supported In:

One type of content that you are likely to add to a frame is a page number, which is actually a
snippet that serves as a placeholder for a page number in the output.

How to Insert a Page Number Into a Frame
1. Open a page in a page layout.

2. Click on the header, footer, or decoration frame to which you want to add a page number.

NOTE You cannot insert a page number into a body frame (which automatically
displays content from your topics).

3. In the local toolbar, click , or right-click the frame and select Select Frame Text.

4. In the Templates section, select one of the page number snippets.

n - page -.flsnp Displays a page number surrounded by dashes (e.g., - 53 -).

n page (pagecount).flsnp Displays the current page number, followed by the total number
of pages in parentheses.

n Page n of N.flsnp Displays the current page number and the total number of pages in
the document (e.g., Page 13 of 70).

TIP You can change the look of the page number (e.g., remove the dashes or
parentheses). To edit the text or content around a page number, continue inserting
the page snippet as it is. After it is added to the frame, click on the frame and press
F2. In the Frame Contents window pane, modify it as necessary.
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5. Click OK.

6. Click to save your work.
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Importing Snippets
You can create new snippets (FLSNP files) within your project. But if you already have created
snippets in another project and want to reuse them in your current project, you can import those
snippets.

How to Import a Snippet
1. Select Project > New > Snippet.

The Add File dialog opens.

2. Select New from existing and click .

3. Find and select the snippet file that you want to import.

4. Click Open. The Source File field now contains the path to the file that you are importing. Also,
the name of the file is displayed in the File Name field.

5. In the Folder field select a location to store the snippet in the project.

6. If you want to give the snippet a different name than that for the imported file, click in the File
name field and replace the text.

7. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click and select the conditions you
want to apply. Click OK.

8. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the
dialog. Next to the File Tags field, click and select the file tags you want to apply. Click OK.

9. Click Add. The snippet is added to the Resources\Snippets folder in the Content Explorer and
opens in its own page in the XML Editor.
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Pinning Snippets
You can pin your favorite snippets so you can easily find them again later. Pinned snippets appear
in a group that you can expand or collapse. This is a way to limit the list of snippets to those that
you use the most.

You can pin any snippet that appears in the Recently Used Snippets group. This group lists your 20
most recently used snippets.

How to Pin a Snippet—Insert Snippet Link Dialog
1. Open the content file.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Insert > Snippet.

n Local Toolbar In the local toolbar at the top of the XML Editor click the face of the
button.

OR

In the local toolbar at the top of the XML Editor click the down arrow next to , then
select More Snippets.

n Keyboard Shortcut Press CTRL+R.

n Right-Click Right-click in the editor and select Insert > Snippet. This context menu
option is available only when your cursor is located in certain places in the editor (e.g.,
not in a drop-down effect).

The Insert Snippet Link dialog opens.

3. From the Recently Used Snippets group, select the snippet you want to pin. A pin appears
to the right of the snippet.

NOTE Snippets must appear in the Recently Used Snippets group before they can be
pinned. If the snippet you want to pin does not appear in the Recently Used Snippets
group, you can add it to a content file by dragging it from the Content Explorer or
using the Insert Snippet Link dialog.
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4. To pin the snippet, click . The pin changes to to show that the snippet has been pinned
to the list. Pinned snippets are added to the Pinned Snippets group in alphabetical order.
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5. To unpin the snippet, click the pin again and it will be moved back to the bottom of the
Recently Used Snippets group.
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6. Click OK.
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How to Pin a Snippet—Local Toolbar
1. Open the content file.

2. In the local toolbar at the top of the XML Editor click the down arrow next to . This
expands the Insert Snippet drop-down.

3. From the Recently Used Snippets group, select the snippet you want to pin. A pin appears
to the right of the snippet.

NOTE Snippets must appear in the Recently Used Snippets group before they can be
pinned. If the snippet you want to pin does not appear in the Recently Used Snippets
group, you can add it to a content file by dragging it from the Content Explorer or
using the Insert Snippet Link dialog.

4. To pin the snippet, click . The pin changes to to show that the snippet has been pinned
to the list. Pinned snippets are added to the Pinned Snippets group.
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5. To unpin the snippet, click the pin again and it will be moved back to the bottom of the
Recently Used Snippets group.
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EXAMPLE Four snippets have been added to the Pinned Snippets group. Other recently
used snippets can still be seen in the Recently Used Snippets group; you can add any of
these snippets to the Pinned Snippets group at any time.

What’s Noteworthy?

NOTE The Recently Used Snippets and Pinned Snippets groups show the relative path
location of each snippet. Hover over any snippet to see its full file path.

NOTE You can expand or collapse the Recently Used Snippets and Pinned Snippets groups
by clicking the arrows next to each group name.
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Deleting Snippets
If necessary, you can delete a snippet that you have added to a topic.

How to Delete a Snippet
1. Open the topic containing the snippet.

2. In the XML Editor, right-click the snippet that you want to delete.

3. From the context menu, select Delete. The snippet is removed from the topic.

4. Click to save your work.
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APPENDIX

PDFs
The following PDFs are available for download from the Help system.

Tutorials
Autonumbers Tutorial

Back-to-Top Button Tutorial

Context-Sensitive Help Tutorial

Custom Toolbar Tutorial

eLearning Tutorial—Basic

eLearning Tutorial—Advanced

Getting Started Tutorial

Image Tooltips Tutorial

Lists Tutorial

Meta Tags Tutorial

Micro Content Tutorial—Basic

Micro Content Tutorial—Advanced

Responsive Output Tutorial

Single-Sourcing Tutorial

Snippet Conditions Tutorial

Styles Tutorials

Tables Tutorial

Word Import Tutorial
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Cheat Sheets
Context-Sensitive Help Cheat Sheet

Folders and Files Cheat Sheet

Learning & Development Cheat Sheet

Lists Cheat Sheet

Micro Content Cheat Sheet

Print-Based Output Cheat Sheet

Search Cheat Sheet

Shortcuts Cheat Sheet

Structure Bars Cheat Sheet

Styles Cheat Sheet
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User Guides
Accessibility Guide

Analysis and Reports Guide

Architecture Guide

Autonumbers Guide

Branding Guide

Condition Tags Guide

Context-Sensitive Help Guide

Eclipse Help Guide

eLearning Guide

Getting Started Guide

Global Project Linking Guide

HTML5 Guide

Images Guide

Import Guide

Indexing Guide

Key Features Guide

Lists Guide

MadCap Flare Online
Integration Guide

Meta Tags Guide

Micro Content Guide

Navigation Links Guide

Plug-In API Guide

Print-Based Output Guide

Project Creation Guide

QR Codes Guide

Reviews & Contributions With
Contributor Guide

Scripting Guide

Search Guide

SharePoint Guide

Skins Guide

Snippets Guide

Source Control Guide: Git

Source Control Guide:
Perforce Helix Core

Source Control Guide:
Subversion

Source Control Guide: Team
Foundation Server

Styles Guide

Tables Guide

Tables of Contents Guide

Targets Guide

Template Pages Guide

Templates Guide

Topics Guide

Touring the Workspace Guide

Transition From FrameMaker
Guide

Translation and Localization
Guide

Variables Guide

Videos Guide

What's New Guide
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