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CHAPTER 1

Introduction
You can use the Flare Desktop interface to perform various source control tasks for a project that is
bound to Subversion.

General Information

n "Common Source Control Terms" on page 7

n "Source Control Icons" on page 8

n "Bind Detection, Disabling Providers, and Unbinding Providers—Subversion" on page 10

Process

1. Install and Set Up Subversion (done outside of Flare Desktop)

2. "Binding a Project to Subversion" on page 14

3. (Other Team Members) "Importing From Source Control" on page 17

4. "Updating Source Control Files" on page 19

5. "Committing Source Control Files" on page 22

6. "Merging Source Control Files" on page 26
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CHAPTER 2

General Information for
Subversion
There are various pieces of general information you should know if you plan to use this feature.

This chapter discusses the following:

Common Source Control Terms 7

Source Control Icons 8

Bind Detection, Disabling Providers, and Unbinding Providers—
Subversion 10
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Common Source Control Terms
Following are definitions for some of the common phrases used in Flare Desktop's integrated
source control with Subversion.

n Bind This means to connect your project to Apache Subversion. After doing this, you can take
advantage of all the automated source control tasks (such as commit, revert, update, and so
on).

n Commit This means to send changes from your working copy of a Flare Desktop file to the
Subversion repository, on a server.

n Revert This means to undo changes you have made to a Flare Desktop file. Changes are
reverted to the way they were at the last commit.

n Update This means to update your working copy of a Flare Desktop file with changes from
the repository.

n Lock This means to prevent other users from committing changes to a Flare Desktop file in
the repository.

n Unlock This means to remove an existing lock from a Flare Desktop file in the repository so
other users can commit changes to the file.

NOTE Flare Desktop integrates with multiple source control providers to provide built-in
source control support. Each of the source control providers built-in to Flare Desktop uses
different terms. As such, Flare Desktop's source control interface is different depending on
which source control provider you use. Please refer to the sections for each source control
provider if you need to see information about the terms used by other built-in systems.
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Source Control Icons
Following are descriptions for the primary icons that you may see next to files when using
Subversion.

Icon Description

Modified

This indicates that the file has been modified. You can commit the file when you are
ready (if you are the user who has modified it, or if you have stolen the lock on the file
from another user).

New File (Add)

This indicates that you have a file in your project but have not yet added it to
Subversion. This might occur, for example, if you create a new topic and do not add
the file to source control during the topic creation process. To resolve this, simply
right-click on the file and select Source Control > Add.

Locked by Another User

This indicates that another user has locked the file. You will often see this icon in
conjunction with the icon, indicating that another user is using the file and has
locked the file. You can make changes to this file even if another user has locked it.

If you need to commit the file in while another user is working on it, you can steal
their lock. To do this, right-click on the file and select Source Control > Lock. In the
Lock dialog, select Steal the lock, then click Lock.

Locked by You

This indicates that you have locked the file. You will often see this icon in conjunction
with the icon, indicating that you have both locked and modified the file. Other
users can make changes to this file even if you have locked it, but they cannot
commit it unless they steal the lock from you first.
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Icon Description

In Use by Other User

This indicates that the file is currently being modified by another user. You will often
see this icon in conjunction with the icon, indicating that another user is using the
file and has locked it.

Renamed

This indicates that a file has been renamed, but not modified in any other way. If you
make any additional changes to the file, such as editing the text or adding a condition
tag, the renamed icon is replaced by a icon.

Out of Date

This indicates that the file is not current (i.e., the local copy of the file is older than the
source control copy). This might happen, for example, if another user modifies the
file and commits it to source control. If this occurs, you can modify the file or update
the file from source control.
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Bind Detection, Disabling Providers,
and Unbinding Providers—Subversion

Flare Desktop has options for bind detection, disabling providers, and unbinding providers.
Although these are separate features, they are all somewhat related. This information is especially
important if you are using an external tool to bind and manage your source control tasks.

Bind Detection
Flare Desktop's bind detection settings are found on the Source Control tab of the Options dialog.
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Bind detection scans your project when you load it to see if the project has been previously bound
to source control. If a binding is detected, you then have the option of applying the binding and
committing the project to source control. Depending on the provider you are using, Flare Desktop
may search the file system and its artifacts, as well as contact and query servers, to find potential
source control bindings.

When you open a Flare Desktop project that hasn't been bound to source control before, the bind
detection option is disabled for Perforce Helix Core, Subversion, and Team Foundation Server. It is
enabled by default for Git and MadCap Flare Online (which uses Git). If you bind a project to source
control using the Flare Desktop interface, the option is then automatically enabled.

NOTE You can use bind detection as an alternative to importing a Flare Desktop project. If
you have received a Flare Desktop project file (e.g., by copying it from a server, by opening
it from a network location), you can simply open the file and Flare Desktop will search for
and apply existing source control bindings.

NOTE Source control providers are scanned in the following order:

1. Git

2. Subversion

3. Perforce Helix Core

TIP Detecting source control bindings may take a considerable amount of time. It is
recommended that you select only the source control providers that you use to speed up
the detection process.
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Disabling Providers
By default, when a project is bound to source control, the provider (Git, Perforce Helix Core,
Subversion, or Team Foundation Server) is enabled. This means that the source control interface
elements in Flare Desktop are visible, and you can use them to perform various tasks (e.g.,
commits, synchronize changes).

Disabling a provider means that the source control interface elements are no longer shown. This
does not mean you cannot use source control. As long as the provider is still bound to the project,
you can perform source control tasks in a third-party tool outside of Flare Desktop.

For more details and steps, see "Disabling a Subversion Provider" on page 41.

Unbinding Providers
When you unbind a provider, it means you are removing the connection altogether between the
Flare Desktop project and the local repository.

You can unbind a provider via the Project Properties dialog or the Settings view in the Source
Control Explorer. Click the Unbind Provider button.

For more details and steps, See "Unbinding a Subversion Provider" on page 62.
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CHAPTER 3

Process for Subversion
Certain tasks must be completed in order when using this feature.

This chapter discusses the following:

Binding a Project to Subversion 14

Importing From Source Control 17

Updating Source Control Files 19

Committing Source Control Files 22

Merging Source Control Files 26
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Binding a Project to Subversion
Use the following steps if you have already created a Flare Desktop project and want to bind
("connect") it to Subversion. You can also automatically detect existing source control bindings if
your project has been previously connected to Subversion.

NOTE The following steps show how to bind a project using the Flare Desktop interface. It
is also possible to bind a project outside of Flare Desktop (e.g., using Git Bash). If you
decide to do this, you should be aware of some additional aspects of source control, such
as bind detection and disabling providers.

How to Bind a Project Using the Project
Properties Dialog

1. Open the project.

2. Select Project > Project Properties. The Project Properties dialog opens.

3. Select the Source Control tab.

4. Click Bind Project. The Bind Project dialog opens.

5. From the drop-down, select Subversion.

6. In the Server field, enter the IP address.

7. Next to the Project Path field, click .

8. Click on the Subversion folder to which you want to bind the Flare Desktop project.

9. Click OK.

10. (Optional) In the Comment field, you can enter any internal comments.

11. In the Bind Project dialog, click OK.

12. If the Log In dialog opens, complete the User name and Password fields and click OK. Copies
of the Flare Desktop files are created and added to the folder you specified.

13. In the Project Properties dialog, click OK. The project is connected to Subversion, and you can
now commit files as necessary.
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How to Bind a Project Using the Explorer
1. Open the project.

2. Select View > Source Control Explorer. The Source Control Explorer opens.

3. From the drop-down or the Home pane, select Settings. The Settings pane opens.

4. Click Bind. The Bind Project dialog opens.

5. From the drop-down, select Subversion.

6. In the Server field, enter the IP address.

7. Next to the Project Path field, click .

8. Click on the Subversion folder to which you want to bind the Flare Desktop project.

9. Click OK.

10. (Optional) In the Comment field, you can enter any internal comments.

11. In the Bind Project dialog, click OK.

12. If the Log In dialog opens, complete the User name and Password fields and click OK. Copies
of the Flare Desktop files are created and added to the folder you specified. The project is
connected to Subversion, and you can now commit files as necessary.
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What’s Noteworthy?
TIP If you are having difficulty binding your project, try binding to a brand new directory in
your source control provider. You should also ensure that the directory on your local
machine (and its parent directories) is not already mapped to source control, as this may
cause issues with binding.

NOTE You can also bind a new Flare project to source control while creating it.

NOTE If you want to publish your output to source control, you must create a bind
destination.
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Importing From Source Control
This chapter focuses on importing a Flare Desktop project from source control. You might use this
method, for example, if you are working on a multi-author project and another member of the team
has placed the Flare Desktop project in Apache Subversion.

How to Import a Project From Subversion
1. Select File > New Project > Import Project. The Import Project from Source Control Wizard

dialog opens.

2. From the drop-down, select Subversion.

3. In the Server field, enter the name of the computer or server IP address.

4. Click Next.

5. Next to the Project file field, click Browse. The Browse Source Control Files dialog opens.
(You may need to log in with your user name and password.)

6. Find and click on the Flare Desktop project file (FLPRJ) that you want to import. (You may
need to log in with your user name and password.)

7. Click OK.

8. Click Next.

9. In the Project name field, the name of the project being imported is displayed. It is
recommended that you leave the name as it is, especially if you are working with other
authors on the project. However, you can enter a different project name if you want.

10. In the Project folder field, either accept the default location for the new project or click to
browse for and select a folder.

11. Click Finish. The project is imported and loaded into Flare Desktop.
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NOTE When a project is dual bound to Flare Online and a non-Git third-party provider, keep
the following in mind if you (i.e., the second user) want to access this setup. After importing
the project from Perforce Helix Core, Subversion, or Team Foundation Server, you will have
to re-bind the project to Flare Online. In the MadCap Flare Online window pane in Flare
Desktop, click to upload (or bind) the project to Flare Online. In the Bind Project dialog, it is
important to enter the exact name of the project as it currently exists in Flare Online. When
you click OK, a message displays asking if you want to bind to the existing project. Select
Yes. This re-establishes the existing Flare Desktop-Flare Online connection; note that it
does not create a new binding.

NOTE If you want to import a project from source control, you can alternatively open the
project file from another location (e.g., a server location), and then use Flare Desktop's bind
detection functionality to automatically apply available source control bindings to the
project.
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Updating Source Control Files
After you bind a Flare Desktop project to Subversion, you can update any of the source control files.
When you do this, you are copying the most current files stored in Subversion to your local Flare
Desktop project.

Following are steps for getting the latest version of all files in a project automatically, as well as
steps for getting the latest version of files manually.

Automatic Update
You might use this option if you are working with a team of authors and want to make sure that you
include the latest changes from other writers in the output (without having to manually update
those files).

With this option:

n You will not be prompted before the update is performed.

n Flare Desktop will not get the latest copy of the files in the Targets folder, because that would
conflict with the generation of the output.

n Conflicts with files will not cause local files to be overwritten. Therefore, if your local files
have been modified, those files will be kept, rather than overwritten with the source control
files.
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How to Update Source Control Files Automatically
1. Open the target.

2. In the Target Editor, select the General tab.

3. Select the check box labeled Automatically get latest version of all files before generating the
target.

4. Click to save your work.

5. Build the target.

NOTE The "automatic get" feature is not supported if you are building output using the
command line, as opposed to the Flare Desktop interface.
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Manual Update
You can manually update all of the files in the Flare project or specific files only.

How to Update Source Control Files Manually
1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Source Control > Update (for selected files) or Source Control > Update
All (for all files in the project).

n Right-Click If you have the Content Explorer, Project Organizer, Pending Changes
window pane, File List open, right-click the file you want to update and select Source
Control > Get Latest Version.

n Source Control Explorer With the Pending Changes pane open, right-click the file you
want to update and select Get Latest Version.

2. If the local and server files are the same, a message tells you so. Click OK.

If the local file is different from the file on the server, the Resolve Conflicts dialog opens. If
you want to accept all of the differences between the local and server files, thus merging
them, click Auto Merge All. If you want to review the differences in the files side by side and
resolve each conflict, click Resolve. For more information about merging files and resolving
conflicts, see "Merging Source Control Files" on page 26.

NOTE By default, when you open a project that is bound to source control, a message
automatically asks if you want to update files. However, you can disable this prompt in the
Options dialog (File > Options). See "Disabling the Get Latest Prompt for Source Control" on
page 40.
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Committing Source Control Files
When you are finished editing files, you can commit them to source control. Committing a file
overwrites the old copy of the file in the source control database with the new one from your local
machine. So even if others will not be working on that file, it is a good idea to periodically commit
files so that you have a backup in source control.

However, if that is not the case, the Resolve Version Conflict dialog opens to let you know that
another user has already committed the file with changes. You can merge the files automatically if
there are no conflicting changes (i.e., changes do not occur in the same location in the file). If there
are conflicting changes, you can use the Merge Changes dialog to determine how changes are
merged.
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How to Commit Files to Source Control
1. Do one of the following, depending on the part of the user interface you are using:

n Pending Changes Window Pane From the Source Control ribbon, open the Pending
Changes window pane. Select the files in the window pane that you want to commit,
and in the local toolbar click .

n Ribbon Select Source Control > Commit (for selected files) or Source Control > Commit
All (for all files in the project).

n Right-Click If you have the Content Explorer, Project Organizer, Pending Changes
window pane, or File List open, right-click the file you want to commit and select Source
Control > Commit (for selected files) or Source Control > Project > Commit All (for all
files in the project).

2. (Optional) Enter a comment tied to the commit. This enables you to keep an audit trail for a
file. The comment can then be viewed from the History dialog, which can be accessed from
the Source Control Explorer, the Source Control ribbon, the File menu, or the Source Control
button .

3. (Optional) If you want to see all files with pending changes (rather than only those you
selected), click .

4. Make sure to click the check box next to each file you want to check in so that it contains a
check mark.

5. If you have files locked and you want to keep them locked, select Keep locks. Doing this will
overwrite the source control copies of the files so that they have the latest changes, but it lets
you keep the file locked so others will know you are working on it.

6. Click Commit.

If no other users have also made changes to the file and committed in while you were
working on it, your version of the file is committed.

However, if that is not the case, the Resolve Version Conflict dialog opens to let you know
that another user has already committed the file with changes. You can merge the files
automatically if there are no conflicting changes (i.e., changes do not occur in the same
location in the file). If there are conflicting changes, you can use the Merge Changes dialog to
determine how changes are merged. See "Merging Source Control Files" on page 26.
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How to Commit Files to Source Control Using
the Explorer

1. Select View > Source Control Explorer. The Source Control Explorer opens.

2. From the drop-down or the Home pane, select Pending Changes.

The Pending Changes pane opens. Files that will be committed are listed under Included
Changes, and files that will not be committed are listed under Excluded Changes. You can
identify modified files because they say [modified] next to the file name.

3. (Optional) In the Comment field, enter a comment tied to the commit. This enables you to
keep an audit trail for a file. The comment can then be viewed from the History dialog, which
can be accessed from the Source Control Explorer, the Source Control ribbon, the File menu,
or the Source Control button .

4. (Optional) If you want to select the files or folders that you include in the commit, right-click a
file or folder and select one of the following options from the context menu.

n Exclude Excludes the selected file from the commit

n Exclude Unselected Excludes all unselected files from the commit

n Include Includes the selected file in the commit

n Include Unselected Includes all unselected files in the commit

5. Click Commit Included to commit all of the files in the Included Changes list. The Messages
pane opens and displays a list of files that were committed.

If no other users have also made changes to the file and committed in while you were
working on it, your version of the file is committed.

However, if that is not the case, the Resolve Version Conflict dialog opens to let you know
that another user has already committed the file with changes. You can merge the files
automatically if there are no conflicting changes (i.e., changes do not occur in the same
location in the file). If there are conflicting changes, you can use the Merge Changes dialog to
determine how changes are merged. See "Merging Source Control Files" on page 26.
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What’s Noteworthy?

NOTE Subversion will automatically lock a modified file when saving changes (if it is not
already locked) if you selected the option to automatically check out files from source
control when saving them. Because there is not a "checked out" status for Subversion files,
these files will be marked as modified and can be committed.
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Merging Source Control Files
There may be times when you need to merge changes from different authors when committing a
file. The merge occurs automatically if there are no conflicting changes (i.e., changes do not occur
in the same location in the file). If there are conflicting changes, a dialog opens, allowing you to
determine how changes are merged.

How to Merge Source Control Files
1. Go through the process of updating files from source control or committing files. See

"Updating Source Control Files" on page 19 and "Committing Source Control Files" on page
22. If your local copy of the file is different from the server copy (e.g., another author has
already committed the same file), the Resolve Conflicts dialog opens.

2. Click Auto Merge All. If changes from the other author do not conflict with your changes, this
will merge all changes. A message lets you know that a backup of your local copy has been
made. This lets you restore that file if you do not want to keep the merged version. You do not
need to complete the rest of the steps below.

However, if your changes conflict with those from another author, a message displays to tell
you. In this case, continue with the next step.

3. Click OK on the conflict message.

4. In the Resolve Conflicts dialog click Resolve. The Resolve Version Conflict dialog opens.
From this dialog, you can choose from the following options.

n Merge changes for me Automatically merges changes within the same file that are not
part of the same element. If changes have been made to the same element (e.g., the
same <p> tag or <h1> tag), Flare Desktop will display a prompt to merge the changes
using the merge tool.

n Merge changes in merge tool Opens a merging interface, which lets you see exactly
what changes were made and choose which to keep.

n Undo my local changes Automatically removes your changes and keeps changes from
other authors.

n Discard external changes Automatically removes changes from other authors and
keeps your changes.
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5. If you selected the option to use the merge tool, the Merge Changes dialog opens. Use this
dialog to view and select changes. You can take actions in the following ways.

n Click a change You can click a change on either the remote or local side. This lets you
select a particular change. Use the key at the top of the merge changes dialog, as well
as the color coding on the local and server sides, to determine if a change has been
added (new), deleted, changed, or moved.When you select a change, the change you
selected will display with a solid colored background, and the conflicting change will
display with a striped background. If you select the other change, the background
shading will switch.

n Type content If you want to use your changes as well as those from another author,
and even tweak the paragraph a bit more, you can click in the area at the bottom of the
dialog and simply type content.

n Previous/next conflict When you are finished resolving the first conflict, you can use
the "Previous Conflict" and "Next Conflict" buttons at the bottom of the dialog to work
on other conflicts in the file.

NOTE If you selected "Merge as Text" in the local toolbar and are working in the code,
you can click on text with a hatched background to keep the change in it. After you
click on text with a hatched background, the hatched lines are removed, leaving a
solid color.

6. After all conflicts have been resolved, a message lets you know that a backup of your local
copy has been made. This lets you restore that file if you do not want to keep the merged
version. Click OK.
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EXAMPLE — Auto Merging

Let's say two authors —Bob and Jill—are working on the same project, using source control
to manage the files.

Bob checks out the "FAQs" topic and starts making changes to it.

Jill also checks out the "FAQs" topic and makes some changes to it. Jill's changes are in a
different location in the topic than Bob's changes; there are no conflicts. She finishes
before Bob and submits the file to source control.

Bob finishes his changes and tries to submit the file. Before the file can be submitted, Bob
is prompted with a dialog, indicating that changes from another author have already been
submitted.

Bob selects Auto Merge All. The changes from Bob and Jill are now both shown in the
merged topic.
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EXAMPLE — Conflicting Changes

Two authors—Bob and Jill—are working on the same project, using source control to
manage the files.

Bob starts making changes to the "FAQs" topic.

Jill also makes some changes to the "FAQs" topic. Jill's changes are in the same paragraph
in the topic as Bob's changes; thus, there is a conflict. She finishes before Bob and
commits the file to source control.

Bob finishes his changes and tries to commit the file. Before the file can be committed, Bob
is prompted with a dialog, indicating that changes from another author have already been
committed.
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Bob selects Auto Merge All. However, he receives another message, stating that his
changes conflict with those of Jill.

Bob clicks OK. Then in the Resolve Conflicts dialog he clicks Resolve. This opens the
Resolve Version Conflict dialog. From this dialog, Bob can choose from a few different
options.
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Bob selects Merge changes in merge tool. The Merge Changes dialog opens.
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So what action can Bob take at this point for merging the file changes?

Bob can right-click on the icon next to the change on either the local or server side. This
displays a context menu, which lets Bob either keep or ignore a particular change.
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Another way of accomplishing the same thing is to left-click on an icon. When you do this,
the change from one side is kept and the change from the other side is ignored. If you left-
click the icon again, the results are toggled; the first change is ignored and the other is kept.

What if Bob wants to use his changes as well as Jill's, and possibly tweak the paragraph a
bit more? He can click in the area at the bottom of the dialog and simply type content.

CHAPTER 3  33



When he is finished resolving the first conflict, Bob can use the "Previous Conflict" and
"Next Conflict" buttons at the bottom of the dialog to work on other conflicts in the file.

After all conflicts have been resolved, Bob clicks OK. The merged topic is now committed
to source control.
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CHAPTER 4

Other Activities for Subversion
In addition to the main activities, there are some other tasks you might perform regarding this
feature.

This chapter discusses the following:

Adding Files to Source Control 37

Deleting Source Control Files 39

Disabling the Get Latest Prompt for Source Control 40

Disabling a Subversion Provider 41

Disconnecting From Source Control 43

Enabling Source Control Status Checks 46

Locking a File 47

Modifying Network Settings 49

Publishing to Source Control 52

Reverting Modified Source Control Files 53

Rolling Back to an Earlier Version of a File 54

Setting Color Options for Project File Differences 60

Unbinding a Subversion Provider 62

Unlocking a File 64

Viewing Differences in Source Control Files 65

Viewing the History of Source Control Files 70
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Viewing Modified Files 72
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Adding Files to Source Control
When working in a project that is connected to source control, there may be occasions when you
have files in your local copy of the project that are not yet part of the source control copy. For
example, when you add a new topic in your local copy of the project, that file will not be included in
the source control copy of the project until you add it.

How to Add Files to Source Control
1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Source Control > Add.

n Right-Click If you have the Content Explorer, Project Organizer, Pending Changes
window pane, or File List open, right-click the file you want to add and select Source
Control > Add.

2. (Optional) Enter a comment tied to the commit. This enables you to keep an audit trail for a
file. The comment can then be viewed from the History dialog, which can be accessed from
the Source Control Explorer, the Source Control ribbon, the File menu, or the Source Control
button .

3. (Optional) If you want to see all files with pending changes (rather than only those you
selected), click ..

4. Make sure to click the check box next to each file you want to check in so that it contains a
check mark.

5. Click Commit.
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How to Add Files to Source Control Using the
Explorer

1. Select View > Source Control Explorer. The Source Control Explorer opens.

2. From the drop-down or the Home pane, select Pending Changes.

The Pending Changes pane opens. Files that will be submitted are listed under Included
Changes, and files that will not be submitted are listed under Excluded Changes. You can
identify newly added files because they say [add] next to the file name.

3. (Optional) In the Comment field, enter a comment tied to the commit. This enables you to
keep an audit trail for a file. The comment can then be viewed from the History dialog, which
can be accessed from the Source Control Explorer, the Source Control ribbon, the File menu,
or the Source Control button .

4. (Optional) If you want to select the files or folders that you include in the commit, right-click a
file or folder and select one of the following options from the context menu.

n Exclude Excludes the selected file from the commit

n Exclude Unselected Excludes all unselected files from the commit

n Include Includes the selected file in the commit

n Include Unselected Includes all unselected files in the commit

5. Click Commit Included to commit all of the files in the Included Changes list. The Messages
pane opens and displays a list of files that were committed.

NOTE Adding files from other areas of the Flare Desktop interface (e.g., Pending
Changes window pane, Source Control ribbon) will only add new files. However, if you
use the Source Control Explorer to submit your files, it will submit all of your pending
changes: both new files and modified files. If you do not want to include all of your
files in the submit, you can right-click them and select Exclude. Files you exclude will
not be submitted.
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Deleting Source Control Files
You can delete a topic or file that is bound to source control. This also removes the file from
Subversion.

How to Delete a File
1. In one of the window panes (e.g., Content Explorer, File List, Project Organizer, Pending

Changes window pane), select the relevant file(s).

2. On your keyboard press DELETE.

3. The Delete dialog opens. Select the bound files you want to delete.

4. Click Delete. The files are removed from your project and from the source control repository.
Files that are deleted from projects bound to Subversion cannot be undeleted.

CHAPTER 4  39



Disabling the Get Latest Prompt for
Source Control

By default, when you open a project that is bound to source control, a message automatically asks
if you want to get the latest version of files. However, you can disable this prompt in the Source
Control tab of the Options dialog (File > Options). Therefore, in the future when you open the project
you will no longer see the message, and the project will open without replacing any local files with
the latest ones from source control.

How to Disable the Get Latest Prompt for
Source Control

1. Select File > Options. The Options dialog opens.

2. Select the Source Control tab.

NOTE This tab will not be visible if your project is not yet bound to source control.
See "Binding a Project to Subversion" on page 14.

3. Click the check box Do not prompt to get latest when opening source control bound projects..

4. Click OK.
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Disabling a Subversion Provider
By default, when a project is bound to source control, the provider (Git, Perforce Helix Core,
Subversion, or Team Foundation Server) is enabled. This means that the source control interface
elements in Flare Desktop are visible, and you can use them to perform various tasks (e.g.,
commits, synchronize changes).

Disabling a provider means that the source control interface elements are no longer shown. This
does not mean you cannot use source control. As long as the provider is still bound to the project,
you can perform source control tasks in a third-party tool outside of Flare Desktop.

How to Disable a Provider
Use this method if you want to disable a provider in just one project, rather than many projects.

1. Do one of the following, depending on the part of the user interface you are using:

n Project Properties Select Project > Project Properties.

n Source Control Explorer Select View > Source Control Explorer. Then, in the window
pane, click Settings.

2. Click Enabled to remove the check mark.

3. If you used the Project Properties dialog, click OK.

NOTE If you disable a Git provider, the local repository will continue to track your changes
in case you later decide to enable the provider once again.

If you disable one of the other providers (Perforce Helix Core, Subversion, Team Foundation
Server), your changes after that point will not be tracked. Therefore, if you later enable the
provider again, it will not have recorded any changes made since the time that you disabled
it.

NOTE When you disable a provider, that information is written to the registry on your
computer.
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NOTE If you disable a provider, but then perform one of the following actions in the Flare
Desktop interface, the provider will automatically become enabled once again.

n Bind an existing project

n Bind a new project

n Bind a project to Flare Online (either as secondary or primary provider)

n Import a project from source control

n Import a project from Flare Online

NOTE Having a provider enabled in Flare Desktop does not interfere with your workflow if
you are performing source control actions exclusively outside of Flare Desktop. Even if a
provider is enabled in the project and the source control user interface elements are visible,
this does not mean Flare Desktop is automatically performing any source control actions
with your files. It simply means Flare Desktop is recognizing the binding, so it reflects your
activities (e.g., the Pending Changes window is populated when you make edits in topics).
However, if you prefer not to see any of this in Flare Desktop, you can disable the provider.
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Disconnecting From Source Control
There may be times that you need to disconnect from source control to work offline. You can
disconnect from Apache Subversion and reconnect at any time.

Disconnecting from source control is beneficial because it lets you modify files when you would
otherwise not have access to the source control system (e.g., you are out of the office with your
laptop or you do not want to access source control over VPN). It also provides a fallback offline
status in the event that the network is disconnected while you are working, so you are able to
continue working on the files you have checked out until the network connection is restored.
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How to Disconnect From Subversion
When you want to work offline, you can disconnect from source control.

1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Source Control > Disconnect.

n Right-Click If you have the Content Explorer, Project Organizer, Pending Changes
window pane, or File List open, right-click on any file and select Source Control >
Project > Disconnect.

2. A confirmation dialog appears. Click Yes. You will be disconnected from source control.

NOTE Because Subversion does not have a "checked out” status, disconnecting from
source control lets you work as if your project is unbound. You do not need to check out
files before disconnecting.

NOTE When you disconnect from source control, you are not able to see the source control
status of files or access source control functions.

NOTE If you make a change to a file’s properties (e.g., delete, rename) while disconnected
from source control, your changes may not be preserved when you reconnect to the
network. To prevent errors, it is recommended that you do not make these kinds of
changes until you reconnect to source control.
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How to Reconnect to Subversion
When you are finished working offline, you can reconnect to source control.

1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Source Control > Reconnect.

n Right-Click If you have the Content Explorer, Project Organizer, Pending Changes
window pane, or File List open, right-click on any file and select Source Control >
Project > Reconnect.

2. Commit the files you modified. See "Committing Source Control Files" on page 22.

What’s Noteworthy?

NOTE Your current network connection status is indicated in the lower right corner of the
Flare Desktop interface. If you are connected you will see ; if you are
disconnected you will see .
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Enabling Source Control Status
Checks

If you are using source control integration in Flare Desktop, you can check for frequent status
changes automatically. You can specify the number of minutes and seconds when you want Flare
Desktop to ping the source control repository and get status changes for files that have been
committed, moved, deleted, etc. The upside of this feature is that you can ensure that the source
control status information is always up to date. The downside is that you may experience slower
performance due to this constant communication over the network.

How to Enable Source Control Status Checks
1. Select File > Options. The Options dialog opens.

2. Select the Source Control tab.

NOTE This tab will not be visible if your project is not yet bound to source control.T
See "Binding a Project to Subversion" on page 14.

3. Click the check box Enable background status checks. A check mark in the box indicates that
the feature is enabled.

4. Enter the number of minutes and or seconds between each status update.

5. Click OK.

NOTE If you elect to disable this feature (disabled is the default setting), you can manually
check for status updates by refreshing the Pending Changes window pane or Source
Control Explorer. See "Viewing Modified Files" on page 72.

CHAPTER 4  46



Locking a File
When you are working, you may want to lock the files you have modified. Locking a file does not
prevent other users from modifying the file. However, no one else can commit a file that you have
locked unless they steal the lock from you or until you remove the lock. See "Unlocking a File" on
page 64.

You can steal a lock from another user if you need to commit the locked file while they are working
on it. Likewise, another user can steal a lock on a file you have locked.

How to Lock a File
1. In one of the window panes (e.g., Content Explorer, Source Control Explorer, File List, Project

Organizer, Pending Changes window pane), select the relevant file(s).

OR

Open a file.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Source Control > Lock.

n Right-Click If you have the Content Explorer, Project Organizer, Pending Changes
window pane, or File List open, right-click the files you want to lock and select Source
Control > Lock.

n Source Control Explorer Right-click the files you want to lock and select Lock.

The Lock dialog opens. The selected files are listed with check boxes next to them.

3. (Optional) In the Comment field, enter an optional comment tied to the submit. This enables
you to keep an audit trail for a file. The comment can then be viewed from the History dialog,
which can be accessed from the Source Control Explorer, the Source Control ribbon, the File
menu, or the Source Control button .

4. (Optional) If you want to steal another user's lock so you can commit the file while they are
working on it, select Steal the Lock. This will give you the lock so you can commit the file.

5. Make sure to select the check box next to each file you want to lock so it contains a check
mark.

6. Click Lock..
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NOTE You cannot lock files with Add or Rename status.

NOTE Subversion will automatically lock a modified file when saving changes (if it is not
already locked) if you selected the option to automatically check out files from source
control when saving them. Because there is not a "checked out" status for Subversion files,
these files will be marked as modified and can be committed.
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Modifying Network Settings
You can view and change various source control network settings while working in Flare Desktop.

How to Modify Network Settings
1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Source Control > Network Settings.

n Right-Click If you have the Content Explorer, Project Organizer, Pending Changes
window pane, or File List open, right-click on any file and select Source Control >
Project > Network Settings.

n Source Control Explorer From the View ribbon, open the Source Control Explorer. From
the drop-down, select the Home Page view. Click Network Settings.

The Network Settings dialog opens.

2. In the Group field, select the group for which you want to change the settings.

OR

Do one of the following:

n (Optional) If you want to add a custom group, type its name in the Group field, then
click Add.

n (Optional) If you want to remove a group, select it from the Group field, then click
Remove.

3. (Optional) If you entered a custom group name, in the Remote Host/Pattern field, enter the
name of the domain to which the network settings should apply.

NOTE If you are using Subversion, you can enter wildcards in this field.
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4. In the grid, make changes to the network settings as necessary. Click to sort the settings
by category, or click to sort them alphabetically.

SUBVERSION NETWORK SETTINGS
n Advanced

l Chunk Requests

l HTTP Bulk Update

l HTTP Compression

l Maximum Connections

n Caching Options

l Store Authentication Info

l Store Passwords

l Store Plaintext Passwords

l Store Plaintext SLL Client Cert Passphrase

l Store SSL Client Cert Passphrase

n Global Options

l Default User Name

n HTTP Proxy Options

l Proxy Host

l Proxy Host Port

l Proxy Password

l Proxy Timeout

l Proxy User Name

l Site Exceptions
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n SSL Options

l SSL Authority Files

l SSL Client Certificate File

l SSL Client Certificate Password

l SSL Trust Default CAs

NOTE For more information about each of these settings, refer to:

http://svnbook.red-bean.com/en/1.7/svn.advanced.confarea.html

5. Click Save.
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Publishing to Source Control
You can use Flare Desktop to directly publish your output to source control, rather than having to
upload it to source control separately. Publishing your output to source control is beneficial
because it you can keep previous versions of your output in source control and access them if
necessary.

For more information about creating publishing destinations, see the Help system.

How to Publish Output to Source Control
1. Create a new source control publishing destination, or select an existing source control

publishing destination.

NOTE When creating a new source control destination, be sure to select Source
Control from the Type drop-down.

2. Assign the publishing destination to the target you want to publish.

3. Build and publish your output. Your output files will be published to the source control
location you specified in the destination.
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Reverting Modified Source Control
Files

If you have modified files from source control but do not want to keep your modifications, use the
"Revert" option instead of committing the files. While committing the file would save changes to
source control, reverting a file returns it to its previously committed state and does not commit any
of your new changes to source control.

How to Revert a Source Control File
1. In one of the window panes (e.g., Content Explorer, Source Control Explorer, File List, Project

Organizer, Pending Changes window pane), select the relevant file(s).

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Source Control > Revert (for selected files) or Source Control > Revert All
(for all files in the project).

n Right-Click If you have the Content Explorer, Project Organizer, Pending Changes
window pane, or File List open, right-click the files you want to revert and select Source
Control > Revert (for selected files) or Source Control > Project > Revert All (for all files
in the project).

The Revert dialog opens. The selected files are listed with check boxes next to them.

3. (Optional) If you want to see all files with pending changes (rather than only those you
selected), click .

4. Make sure to click the check box next to each appropriate file so that it contains a check
mark.

5. Click Revert.
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Rolling Back to an Earlier Version of a
File

One of the benefits of Flare Desktop's integrated source control is that you can view the history and
differences for a particular file. You can view code and content differences between two source
control versions of the same file. This is useful if you need to roll back to an earlier version of a file.

See "Viewing Differences in Source Control Files" on page 65 and "Viewing the History of Source
Control Files" on page 70.

EXAMPLE You have been working on a particular topic for a few days. Each day you
modify that topic file, make your changes, and commit the file back to the server at the end
of the day. At a certain point, you determine that you need to "roll back" to an earlier version
of the file, using it to replace the latest version. Therefore, you use this feature to view the
highlighted differences between the current version and an older version of the file. Once
you have identified the older version that you want to use, you can retrieve that version.

How to Roll Back to an Earlier Version of a File
1. In one of the window panes (e.g., Content Explorer, Source Control Explorer, File List, Project

Organizer, Pending Changes window pane), select the relevant file(s).

OR

Open a file.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Source Control > View History.

n Right-Click If you have the Content Explorer, Project Organizer, Pending Changes
window pane, or File List open, right-click the file you want to roll back and select
Source Control > View History.

n Source Control Explorer With the Pending Changes pane open, right-click the file you
want to roll back and select View History.

The History dialog opens.
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3. (Optional) View the differences between two versions of the file. This may help you decide
which version of the file you want to retrieve. (Another way is to look at the dates for each
version in the History dialog.)

To view the differences, follow these steps.

a. Select the first file version from the list.

b. Hold the CTRL key and select the second file version from the list.

c. Click Show Differences. The Differences Editor opens to the right, showing content
from the backup file on the left and the current version of the file on the right.

d. In the local toolbar of the Differences Editor, you can click any of the following to make
adjustments.

n Options Click this to open the File Differences dialog, which lets you change the
colors used to display content differences between the files.

n Show WYSIWYG Click this to switch from tag view to WYSIWYG (What You See Is
What You Get) view.
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n Ignore Case Click this to ignore changes in case when viewing differences. This
option can be used in "text view" only; it is not available in WYSIWYG view.

EXAMPLE If a word is not capitalized in the original file but it is
capitalized in the current file, this option does not highlight those
differences.

CHAPTER 4  56



CHAPTER 4  57



n Ignore Whitespace Click this to ignore whitespace when viewing differences.

EXAMPLE A paragraph is identical in both files, except for an extra
space that was added within the paragraph in one of those files. If you
click this option, that difference is not highlighted.
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e. When you are finished viewing the differences, close the window pane.

4. In the History dialog, select the version of the file to which you want to roll back.

5. Click Get Selected Version. That file is retrieved from the server and replaces the local copy of
the file in your project.

6. In the History dialog, click Close.
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Setting Color Options for Project File
Differences

If you are using Flare Desktop's integrated source control features, you can view differences
between files in various ways. One way is to view file differences between a local version of a Flare
project and the source control version.

When viewing file differences between a local version of a Flare project and the source control
version, you can select color options to display the files. Color coding makes it easier to discern
where differences between files occur.

For more information see "Viewing Differences in Source Control Files" on page 65.

EXAMPLE By default the files that are included only in your local copy are displayed as
green in the Differences Editor, and the files that are included only in source control are
displayed in red. You can use this dialog to change the local-only files to blue and the
source control–only files to yellow.
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How to Set Color Options for Project File
Differences

1. In one of the window panes (e.g., Content Explorer, Source Control Explorer, File List, Project
Organizer, Pending Changes window pane), select the relevant file(s).

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Source Control > Show Differences.

n Right-Click If you have the Content Explorer, Project Organizer, Source Control Explorer,
Pending Changes window pane, or File List open, right-click the file you want to view
and select Source Control > Show Differences.

The Differences Editor opens.

3. In the local toolbar of the Differences Editor, click Options. The File Differences dialog opens.

4. Change the text or background color for any of the difference types. To do this, simply click in
the appropriate Text or Background cell and select Pick Color. In the Color Picker dialog,
choose the new color.

5. Click OK.
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Unbinding a Subversion Provider
When you unbind a provider, it means you are removing the connection altogether between the
Flare Desktop project and the local repository.

How to Unbind Using the Project Properties
Dialog

1. Open the project.

2. Select Project > Project Properties.

3. Select the Source Control tab.

4. Click Unbind Provider. (If your project is dual-bound, you will also see a section for the other
binding.)

5. Click OK.

How to Unbind Using the Source Control
Explorer

1. Open the project.

2. Select View > Source Control Explorer.

3. From the drop-down or the Home pane, select Settings. The Settings pane opens.

4. Click Unbind Provider. (If your project is dual-bound, you will also see a section for the other
binding.)

5. Click Yes.
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What’s Noteworthy?

NOTE You can also disable a provider, which retains the binding but hides source control
elements from the user interface.

NOTE If you are using a dual-bound setup where you are bound to MadCap Flare Online
and a third-party provider, you might decide at some point to move to a single-bound
configuration, removing one of the bindings but leaving the other.
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Unlocking a File
If you have locked a file, you should unlock it when you are done modifying it. Other users can
modify the file while you have it locked, but they cannot commit a locked file until you unlock the file
or unless they steal the lock from you. To help prevent file conflicts and make sure that everyone on
your team has the most current version of the file, you should unlock and commit the file when you
are finished working on it.

See "Locking a File" on page 47 for more information on locking files and stealing locks.

How to Unlock a File
1. In one of the window panes (e.g., Content Explorer, Source Control Explorer, File List, Project

Organizer, Pending Changes window pane), select the relevant file(s).

OR

Open a file.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Source Control > Unlock.

n Right-Click If you have the Content Explorer, Project Organizer, Pending Changes
window pane, or File List open, right-click the files you want to unlock and select Source
Control > Unlock.

n Source Control Explorer Right-click the files you want to unlock and select Unlock.

The Unlock dialog opens. The selected files are listed with check boxes next to them.

3. Make sure to select the check box next to each file you want to unlock so it contains a check
mark.

4. Click Unlock.
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Viewing Differences in Source Control
Files

One of the benefits of Flare Desktop's integrated source control is that you can view the history and
differences for a particular file.

Ways to View Differences Between Files
You can view differences between files in the following ways:

n Two Versions of Same Source Control File (History/Roll Back) You can view code and content
differences between two source control versions of the same file. This is useful if you need to
roll back to an earlier version of a file. See "Rolling Back to an Earlier Version of a File" on page
54 and "Updating Source Control Files" on page 19.

EXAMPLE You have been working on a particular topic for a few days. Each day you
modify that topic file, make your changes, and commit the file back to the server at
the end of the day. At a certain point, you determine that you need to "roll back" to an
earlier version of the file, using it to replace the latest version. Therefore, you use this
feature to view the highlighted differences between the current version and an older
version of the file. Once you have identified the older version that you want to use,
you can retrieve that version.
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n Local Versus Source Control Version of a File You can view code and content differences
between the local version of a file and the source control version of that file.

EXAMPLE You modify a procedure topic from source control and then add some
lines of text to your local copy of that topic file. You save your changes. Later that
day, you want to revisit the new content that you wrote, but you cannot remember
exactly which lines of text you added. Therefore, you use this feature to highlight the
text differences between your local version of the file and the version stored in the
source control application. The new lines of text are highlighted on the side
displaying the local version of the file.

n Local Versus Source Control Version of All Files in a Folder You can view file differences
between the local version of the files in a folder and the source control version. Most likely,
you will use this to view all of the difference between the local files and source control files in
either your Content Explorer or Project Organizer.

EXAMPLE You are working on a large Flare project. During the course of the day, you
edit several topics in the project. At the end of the day, you commit most of your files,
but forget to commit a few files. Afterward, you realize that you missed a few files,
and now those files are out-of-date. Therefore, you use this feature to see the file-
level differences between your local copy of the Content Explorer root folder and the
source control copy. The differences are color coded, so you can easily identify the
files in question. (By default, the files that are included only in your local copy are
green, and the files that are included only in source control are red.) You can then
right-click on the files that were added only to the local copy, and you can select to
add them to source control.
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How to View Differences Between Two Versions
of the Same Source Control File

1. In one of the window panes (e.g., Content Explorer, Source Control Explorer, File List, Project
Organizer, Pending Changes window pane), select the relevant file(s).

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Source Control > View History.

n Right-Click If you have the Content Explorer, Project Organizer, Source Control Explorer,
Pending Changes window pane, or File List open, right-click the file(s) you want to view
and select Source Control > View History.

The History dialog opens.

3. From the list, select the first file version that you want to compare.

4. Hold the CTRL key and select the second file version from the list.

5. Select Show Differences.The Differences Editor opens.

6. (Optional) In the Differences Editor, use the buttons in the local toolbar to customize the
information shown in the editor.

7. When you are finished viewing the differences, close the window.
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How to View Differences Between the Local
Version of a File and the Source Control Version

1. In one of the window panes (e.g., Content Explorer, Source Control Explorer, File List, Project
Organizer, Pending Changes window pane), select the relevant file(s).

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Source Control > Show Differences.

n Right-Click If you have the Content Explorer, Project Organizer, Source Control Explorer,
Pending Changes window pane, or File List open, right-click the file(s) you want to view
and select Source Control > Show Differences.

The Differences Editor opens.

3. (Optional) In the Differences Editor, use the buttons in the local toolbar to customize the
information shown in the editor.

4. When you are finished viewing the differences, close the window.
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How to View Differences Between the Local
Version of All Files in a Folder and the Source
Control Version

1. In the Content Explorer or Project Organizer, select the relevant folder.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Source Control > Show Differences.

n Right-Click Right-click the folder you want to view and select Source Control > Show
Differences.

The Differences Options dialog opens.

3. (Optional) Use this dialog to specify the type of information that you want to see in the
Differences Editor. (You can also choose these options from the local toolbar of the
Differences Editor.)

n Show files that are only in the Left folder Displays the files on the left side of the
Differences Editor. The left side is used to show the local copies of your project files.

n Show files that are only in the Right folder Displays the files on the right side of the
Differences Editor. The right side is used to show the source control copies of your
project files.

n Show files that are different in both folders Displays the files where differences occur
between the local copy and source control copy of the project. For example, the left
side might display files that you have created in your local copy but have not yet been
added to source control.

n Show files that are the same in both folders Displays the files that are the same in the
local copy as they are in the source control copy.

n Recursive Displays files recursively. In other words, if you have files contained within
folders, selecting this button will ensure that you see all of the files, not just the folders.

4. Click OK. The Differences Editor opens.

5. (Optional) In the Differences Editor, use the buttons in the local toolbar to customize the
information shown in the editor.
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Viewing the History of Source Control
Files

One of the benefits of Flare Desktop's integrated source control is that you can view the history for
a particular file, including who committed the file and when it was committed. You can also view
differences between different versions of the file and roll back to an older version if necessary.

For more information see "Viewing Differences in Source Control Files" on page 65 and "Rolling
Back to an Earlier Version of a File" on page 54.

How to View the History of a Source Control File
1. In one of the window panes (e.g., Content Explorer, Source Control Explorer, File List, Project

Organizer, Pending Changes window pane), select the relevant file(s).

OR

Open a file.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Source Control > View History.

n Right-Click If you have the Content Explorer, Project Organizer, Source Control Explorer,
Pending Changes window pane, or File List open, right-click the file you want to view
and select Source Control > View History.

3. The History dialog opens. The following are explanations of the different parts of this dialog.

n Version Displays a number for each version of the file. The lower the number, the older
the version. The higher the number, the more recent the version.

n Users Displays the name of the user who has been working on the file.

n Date Displays the date and time when the action has occurred.

n Action Displays the action that has taken place for the file (e.g., commit).

n Comment Displays the comment (if any) associated with the file. A comment can be
added to a file when you commit that file to source control. This enables you to
maintain an audit trail for the file's history.
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n Get Selected Version Retrieves a particular version of a file, thus rolling back to that
version of the file. The local version of the file is replaced with the source control
version that you selected.

n Show Differences Opens a dialog that lets you view the differences between two
versions of a file. If you select one row in the History dialog and view the differences,
you will see the content differences between the version that you selected and the
version of the file in your local copy of the Flare Desktop project. If you select two files
in the History dialog (by holding down the CTRL key) and view the differences, you will
see the content differences between those two versions of the file.

4. In the History dialog, click Close.
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Viewing Modified Files
You can use the Pending Changes window pane and the Source Control Explorer to view all of the
files that you have modified and need to commit. You can use the File List window pane and
Pending Changes window pane to view files that have been modified by other users.

How to View Files That You and Others Have
Modified—Pending Changes Window Pane

1. Select Source Control > Pending Changes. The Pending Changes window pane opens.

2. (Optional) You can use the Filter field to limit the files that are displayed.

n All Files Displays all files.

n Topic Files Displays only the topic (HTM and HTML) files.

n Template Page Files Displays only the template page (FLMSP) files.

n Page Layout Files Displays only the page layout (FLPGL) files.

n Snippet Files Displays only the snippet (FLSNP) files.

n Micro Content Files Displays only the micro content (FLMCO) files.

n Stylesheet Files Displays only the stylesheet (CSS) files.

n Image Files Displays only the image files.

n Multimedia Files Displays only multimedia (audio, video, and 3D model) files.

n GIF Files Displays only GIF files.

n JPEG Files Displays only JPG and JPEG files.

n PNG Files Displays only PNG files.

n Flash Movie Files Displays only SWF files.
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3. (Optional) You can use the following toggle buttons in the local toolbar to limit the files that
are displayed.

Option Description

This filters the Pending Changes window pane to show or not show files that
other users have modified.

This filters the Pending Changes window pane to show or not show files that
are out of date.

This filters the Pending Changes window pane to show or not show files that
have been deleted.

This filters the Pending Changes window pane to show or not show files that
are locked.

4. Take note of the Status and User columns. (You may need to use the scroll bar to view these
columns.)

n Status Displays the status of the file, such as whether you have modified it. You can
also see if another user has modified or locked a file.

l Modified This indicates that the file has been modified. You can commit the file
when you are ready (if you are the user who has modified it, or if you have stolen the
lock on the file from another user).

l Add This indicates that you have a file in your project but have not yet added it to
Subversion. This might occur, for example, if you create a new topic and do not add
the file to source control during the topic creation process. To resolve this, simply
right-click on the file and select Source Control > Add.

l Out of Date This indicates that the file is not current (i.e., the local copy of the file is
older than the source control copy). This might happen, for example, if another user
modifies the file and commits it to source control. If this occurs, you can modify the
file or update the file from source control.

l Locked This indicates that the file has been locked by you or another user. Any user
can modify the file even if it has been locked. However, a user cannot commit a file
that another user has locked unless they steal the lock first.
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l Renamed This indicates that a file has been renamed, but not modified in any other
way.

NOTE You can click the refresh button in the local toolbar to make sure you
have the most recent status for each file. Another option is that you can use a
feature to automatically ping the source control repository periodically, thus
refreshing this information frequently. However, you may experience slower
performance with this automatic status update option set. See "Enabling
Source Control Status Checks" on page 46.

n User Displays the user name. If you see the name of another user in this column, it
means that the file has been modified by that user.
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How to View Files That Others Have Modified—
File List Window Pane

1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select View > File List.

n Keyboard Shortcut Press CTRL+SHIFT+J.

The File List window pane opens.

2. (Optional) You can use the Filter field to limit the files that are displayed.

n All Files Displays all files.

n Topic Files Displays only the topic (HTM and HTML) files.

n Template Page Files Displays only the template page (FLMSP) files.

n Page Layout Files Displays only the page layout (FLPGL) files.

n Snippet Files Displays only the snippet (FLSNP) files.

n Micro Content Files Displays only the micro content (FLMCO) files.

n Stylesheet Files Displays only the stylesheet (CSS) files.

n Image Files Displays only the image files.

n Multimedia Files Displays only multimedia (audio, video, and 3D model) files.

n GIF Files Displays only GIF files.

n JPEG Files Displays only JPG and JPEG files.

n PNG Files Displays only PNG files.

n Flash Movie Files Displays only SWF files.
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3. Take note of the Status and User columns. (You may need to use the scroll bar to view these
columns.)

n Status Displays the status of the file, such as whether you have modified it. You can
also see if another user has modified or locked a file.

NOTE You can click the refresh button in the local toolbar to make sure you
have the most recent status for each file. Another option is that you can use a
feature to automatically ping the source control repository periodically, thus
refreshing this information frequently. However, you may experience slower
performance with this automatic status update option set. See "Enabling
Source Control Status Checks" on page 46.

n User Displays the user name. If you see the name of another user in this column, it
means that the file has been modified by that user.
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How to View Files That You Have Modified—
Source Control Explorer

1. Select View > Source Control Explorer. The Source Control Explorer opens.

2. From the drop-down or the Home pane, select Pending Changes.

The Pending Changes pane opens. Files that you have changed appear in the Included
Changes or Excluded Changes section (depending on whether you are going to include or
exclude them in your next commit; see "Committing Source Control Files" on page 22). You
will not see other users' changes in the Source Control Explorer.

3. Take note of the file's status. The status is written in brackets next to the file name (e.g.,
modified, add).

NOTE You can click the refresh navigation button in the Source Control Explorer
to make sure you have the most recent status for each file. Another option is that you
can use a feature to automatically ping the source control repository periodically,
thus refreshing this information frequently. However, you may experience slower
performance with this automatic status update option set. See "Enabling Source
Control Status Checks" on page 46.
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APPENDIX

PDFs
The following PDFs are available for download from the Help system.

Tutorials
Autonumbers Tutorial

Back-to-Top Button Tutorial

Context-Sensitive Help Tutorial

Custom Toolbar Tutorial

eLearning Tutorial—Basic

eLearning Tutorial—Advanced

Getting Started Tutorial

Image Tooltips Tutorial

Lists Tutorial

Meta Tags Tutorial

Micro Content Tutorial—Basic

Micro Content Tutorial—Advanced

Responsive Output Tutorial

Single-Sourcing Tutorial

Snippet Conditions Tutorial

Styles Tutorials

Tables Tutorial

Word Import Tutorial
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Cheat Sheets
Context-Sensitive Help Cheat Sheet

Folders and Files Cheat Sheet

Learning & Development Cheat Sheet

Lists Cheat Sheet

Micro Content Cheat Sheet

Print-Based Output Cheat Sheet

Search Cheat Sheet

Shortcuts Cheat Sheet

Structure Bars Cheat Sheet

Styles Cheat Sheet
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User Guides
Accessibility Guide

Analysis and Reports Guide

Architecture Guide

Autonumbers Guide

Branding Guide

Condition Tags Guide

Context-Sensitive Help Guide

Eclipse Help Guide

eLearning Guide

Getting Started Guide

Global Project Linking Guide

HTML5 Guide

Images Guide

Import Guide

Indexing Guide

Key Features Guide

Lists Guide

MadCap Flare Online
Integration Guide

Meta Tags Guide

Micro Content Guide

Navigation Links Guide

Plug-In API Guide

Print-Based Output Guide

Project Creation Guide

QR Codes Guide

Reviews & Contributions With
Contributor Guide

Scripting Guide

Search Guide

SharePoint Guide

Skins Guide

Snippets Guide

Source Control Guide: Git

Source Control Guide:
Perforce Helix Core

Source Control Guide:
Subversion

Source Control Guide: Team
Foundation Server

Styles Guide

Tables Guide

Tables of Contents Guide

Targets Guide

Template Pages Guide

Templates Guide

Topics Guide

Touring the Workspace Guide

Transition From FrameMaker
Guide

Translation and Localization
Guide

Variables Guide

Videos Guide

What's New Guide

APPENDIX  80


	CHAPTER 1
	Introduction

	CHAPTER 2
	General Information for Subversion
	Common Source Control Terms
	Source Control Icons
	Bind Detection, Disabling Providers, and Unbinding Providers—Subversion


	CHAPTER 3
	Process for Subversion
	Binding a Project to Subversion
	Importing From Source Control
	Updating Source Control Files
	Committing Source Control Files
	Merging Source Control Files


	CHAPTER 4
	Other Activities for Subversion
	Adding Files to Source Control
	Deleting Source Control Files
	Disabling the Get Latest Prompt for Source Control
	Disabling a Subversion Provider
	Disconnecting From Source Control
	Enabling Source Control Status Checks
	Locking a File
	Modifying Network Settings
	Publishing to Source Control
	Reverting Modified Source Control Files
	Rolling Back to an Earlier Version of a File
	Setting Color Options for Project File Differences
	Unbinding a Subversion Provider
	Unlocking a File
	Viewing Differences in Source Control Files
	Viewing the History of Source Control Files
	Viewing Modified Files


	APPENDIX
	PDFs
	Tutorials
	Cheat Sheets
	User Guides



