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CHAPTER 1

Introduction
You can import common file types, such as DITA or HTML. Also, you can import files from other
applications, such as Word or FrameMaker, or even other Flare projects.
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Files From Other Applications

n "Converting Author-it Files" on page 201

n "Importing CHM Files" on page 188

n "Importing Confluence Files" on page 81

n "Importing DITA Files" on page 193

n "Importing a Doc-To-Help Project" on page 180

n "Importing Excel Files" on page 60

n "How to Import FrameMaker Files" on page 146

n "Importing HTML Files" on page 72

n "Importing an HTML Help Project" on page 190

n "Importing Markdown Files" on page 98

n "Importing a RoboHelp Project" on page 178

n "Importing Word Files" on page 21

Files From Other Flare Projects

n "Importing a Project From Source Control" on page 9

n "Global Project Linking—Importing From Other Projects" on page 208

n "Importing Projects From Flare Online" on page 216
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CHAPTER 2

Importing a Project From
Source Control
This chapter focuses on importing a Flare project from source control. You might use this method,
for example, if you are working on a multi-author project and another member of the team has
placed the Flare project in source control.

This chapter discusses the following:

How to Import a Project From Subversion 10

How to Import a Project From Git 11

How to Import a Project From Team Foundation Server 14

How to Import a Project From Microsoft Visual Studio Team
Services 16

How to Import a Project From Perforce Helix Core 18
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How to Import a Project From
Subversion
1. Select File > New Project > Import Project. The Import Project from Source Control Wizard

dialog opens.

2. From the drop-down, select Subversion.

3. In the Server field, enter the name of the computer or server IP address.

4. Click Next.

5. Next to the Project file field, click Browse. The Browse Source Control Files dialog opens.
(You may need to log in with your user name and password.)

6. Find and click on the Flare Desktop project file (FLPRJ) that you want to import. (You may
need to log in with your user name and password.)

7. Click OK.

8. Click Next.

9. In the Project name field, the name of the project being imported is displayed. It is
recommended that you leave the name as it is, especially if you are working with other
authors on the project. However, you can enter a different project name if you want.

10. In the Project folder field, either accept the default location for the new project or click to
browse for and select a folder.

11. Click Finish. The project is imported and loaded into Flare Desktop.

NOTE When a project is dual bound to Flare Online and a non-Git third-party provider, keep
the following in mind if you (i.e., the second user) want to access this setup. After importing
the project from Perforce Helix Core, Subversion, or Team Foundation Server, you will have
to re-bind the project to Flare Online. In the MadCap Flare Online window pane in Flare
Desktop, click to upload (or bind) the project to Flare Online. In the Bind Project dialog, it is
important to enter the exact name of the project as it currently exists in Flare Online. When
you click OK, a message displays asking if you want to bind to the existing project. Select
Yes. This re-establishes the existing Flare Desktop-Flare Online connection; note that it
does not create a new binding.
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How to Import a Project From Git
1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select File > New Project > Import Project.

n Source Control Explorer From the View ribbon, open the Source Control Explorer. From
the drop-down, select the Home pane. Click Import Project.

The Import Project from Source Control Wizard dialog opens.

2. From the drop-down, select Git.

3. In the Remote drop-down, enter the remote repository where the project is located.

NOTE You may need to obtain this information from your system administrator.

4. In the Name field, enter your name.

5. In the Email field, enter your email address.

6. From the Save Per drop-down, select how you want to save your files.

n User Saves the files in your local folder. Select this option if you are working with other
tools (e.g., Tortoise) or if you want to use the same user identity across multiple
projects.

n Project Saves the files locally to your project. Select this option if you want to use
different identities for each project.

7. Click Next.

8. Next to the Project file field, click Browse. The Browse Source Control Files dialog opens.
(You may need to log in with your user name and password.)
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9. (Optional) If the remote you selected in Step 3 requires an SSH certificate, the Certificate
Specification dialog opens. In the dialog, do the following:

a. In the Public key field, enter your public SSH key, or use to browse for the key on
your network.

b. In the Private key field, enter your private SSH key, or use to browse for the key on
your network.

c. If you want Flare Desktop to remember your key information so you do not need to
enter it again later, select the check box next to Save certificate information.

NOTE SSH keys allow you to establish a secure connection between your
computer and your Git source control provider (likewise, using an SSH URL is
more secure than an HTTP URL; you need to use SSH keys if you want to use
an SSH URL). If you do not have a public and private SSH key, your can
generate these keys using your Git source control provider (e.g., Gitlab). Follow
the directions provided by your source control provider to add these keys to
your Git account. Once you generate these keys, they are typically found in the
C:\Users\[username]\.ssh folder on your computer.

Public keys typically have a .pub extension. Private keys use the same file
name as the public key, but without the file extension.

EXAMPLE Use the following as guides when setting up your URLs and keys.

SSH URL

git@gitlabomnibus.mycompany.corp:MyUserName/myproject.git

HTTP URL

http://gitlabomnibus.mycompany.corp/MyUserName/myproject.git
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SSH Private Key

mycompanySSHkey_id_rsa

SSH Public Key

mycompanySSHkey_id_rsa.pub

10. Find and click the Flare project file (FLPRJ) that you want to import. (You may need to log in
with your user name and password.)

11. Click OK.

12. Click Next..

13. In the Project name field, the name of the project being imported is displayed. It is
recommended that you leave the name as it is, especially if you are working with other
authors on the project. However, you can enter a different project name if you want.

14. In the Project folder field, either accept the default location for the new project or click to
browse for and select a folder.

15. Click Finish. The project is imported and loaded into Flare Desktop.
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How to Import a Project From Team
Foundation Server
1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select File > New Project > Import Project.

n Source Control Explorer From the View ribbon, open the Source Control Explorer. From
the drop-down, select the Home pane. Click Import Project.

The Import Project from Source Control Wizard dialog opens.

2. From the drop-down, select Microsoft Team Foundation Server.

3. In the Server field, enter the name of the computer or the IP address of the server. You can
also click to select a "Team Project Collection." If you click this button, the Select Team
Foundation Server Project Collection dialog opens, and you can do the following.

a. To add a server, click . The Add Team Foundation Server dialog opens.

b. Enter the name or URL of the server.

c. Enter the path and port number.

d. Select the protocol (HTTP or HTTPS).

NOTE You may need to obtain this information from your system administrator.
Click OK in the dialogs until you return to the main wizard page.

NOTE If you run into issues in this dialog, chances are your user permissions do not
have access to all of the collections on the TFS server. Please try to enter in the
server/collection path manually.

4. Next to the Team Project field, click . If the Log In dialog opens, complete the User name
and Password fields.

5. Click on the Team Foundation project.

6. Click Next.

7. Next to the Project file field, click Browse. The Browse Source Control Files dialog opens.
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8. Find and click on the Flare project file (FLPRJ) that you want to import. (You may need to log
in with your user name and password.)

9. Click OK.

10. Click Next.

11. In the Project name field, the name of the project being imported is displayed. It is
recommended that you leave the name as it is, especially if you are working with other
authors on the project. However, you can enter a different project name if you want.

12. In the Project folder field, either accept the default location for the new project or click to
browse for and select a folder.

13. Click Finish. The project is imported and loaded into Flare Desktop

NOTE When a project is dual bound to Flare Online and a non-Git third-party provider, keep
the following in mind if you (i.e., the second user) want to access this setup. After importing
the project from Perforce Helix Core, Subversion, or Team Foundation Server, you will have
to re-bind the project to Flare Online. In the MadCap Flare Online window pane in Flare
Desktop, click to upload (or bind) the project to Flare Online. In the Bind Project dialog, it is
important to enter the exact name of the project as it currently exists in Flare Online. When
you click OK, a message displays asking if you want to bind to the existing project. Select
Yes. This re-establishes the existing Flare Desktop-Flare Online connection; note that it
does not create a new binding.
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How to Import a Project From
Microsoft Visual Studio Team
Services
1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select File > New Project > Import Project.

n Source Control Explorer From the View ribbon, open the Source Control Explorer. From
the drop-down, select the Home pane. Click Import Project.

The Import Project from Source Control Wizard dialog opens.

2. From the drop-down, select Microsoft Team Foundation Server.

3. In the Server field, enter the URL of the project's "Default Collection."

NOTE When binding to a VSTS project using TFS, you must manually enter the
URL in the Server field. You can only browse for a server location when binding to a
local project using TFS.

NOTE You may need to obtain this information from your system administrator.
Click OK in the dialogs until you return to the main wizard page.
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NOTE If you run into issues in this dialog, chances are your user permissions do not
have access to all of the collections on the TFS server. Please try to enter in the
server/collection path manually.

4. Next to the Team Project field, click . You may need to log in to Microsoft VSTS. If the Log
In dialog opens, complete the User name and Password fields.

The Browse Team Foundation Server dialog appears.

NOTE When you use Visual Studio Team Services with Flare Desktop, you will be
prompted to log in to Visual Studio Team Services via a dialog in Flare Desktop. Your
login credentials are stored in a cookie in the Internet Explorer Temporary Internet
Files folder:

C:\Users\[username]\AppData\Local\Microsoft\Windows\INetCache

When this cookie expires, you will logged out of Visual Studio Team Services, and
Flare Desktop will prompt you to log in again.

5. Click on the Team Foundation project.

6. Click OK.

7. Click Next.

8. Next to the Project file field, click Browse. The Browse Source Control Files dialog opens.

9. Find and click on the Flare project file (FLPRJ) that you want to import. (You may need to log
in with your user name and password.)

10. Click OK.

11. Click Next.

12. In the Project name field, the name of the project being imported is displayed. It is
recommended that you leave the name as it is, especially if you are working with other
authors on the project. However, you can enter a different project name if you want.

13. In the Project folder field, either accept the default location for the new project or click to
browse for and select a folder.

14. Click Finish. The project is imported and loaded into Flare Desktop.
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How to Import a Project From
Perforce Helix Core
1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select File > New Project > Import Project.

n Source Control Explorer From the View ribbon, open the Source Control Explorer. From
the drop-down, select the Home pane. Click Import Project.

The Import Project from Source Control Wizard dialog opens.

2. From the drop-down, select Perforce Helix Core.

3. In the Server field, enter the server address.

4. Next to the User field, click .

5. Select a user and click OK. (Users are set up separately in Perforce Helix Core.)

6. Next to the Location field, click Browse. The Browse Depots and Streams dialog opens.

7. Select a depot or stream (i.e., the name of your Flare Desktop project).

8. Click OK.

9. Click Next.

10. Next to the Project file field, click Browse. The Browse Source Control Files dialog opens.
(You may need to log in with your user name and password.)

11. Find and click on the Flare Desktop project file (FLPRJ) that you want to import. (You may
need to log in with your user name and password.)

12. Click OK.

13. Click Next.

14. In the Project name field, the name of the project being imported is displayed. It is
recommended that you leave the name as it is, especially if you are working with other
authors on the project. However, you can enter a different project name if you want.

15. In the Project folder field, either accept the default location for the new project or click to
browse for and select a folder.

16. Click Finish. The project is imported and loaded into Flare Desktop.
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NOTE When a project is dual bound to Flare Online and a non-Git third-party provider, keep
the following in mind if you (i.e., the second user) want to access this setup. After importing
the project from Perforce Helix Core, Subversion, or Team Foundation Server, you will have
to re-bind the project to Flare Online. In the MadCap Flare Online window pane in Flare
Desktop, click to upload (or bind) the project to Flare Online. In the Bind Project dialog, it is
important to enter the exact name of the project as it currently exists in Flare Online. When
you click OK, a message displays asking if you want to bind to the existing project. Select
Yes. This re-establishes the existing Flare Desktop-Flare Online connection; note that it
does not create a new binding.
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CHAPTER 3

Importing Word
There are various tasks you can perform when importing Word documents.

This chapter discusses the following:

Importing Word Files 21

Adding a Word Import File 50

Enabling Import/Export Without Word Installed 52

Opening a Word Import File 53

Specifying Custom File Names for Word Imports 55

Disabling Auto-Sync of Import Files 57

Overwriting Imported Documents 58
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Importing Word Files
You can import Microsoft Word files into a new project or an existing one.

Specifying Custom File Names for Word Imports
Before you begin, please note you can control the file names given to new topics that are created
from imported Word documents. To do this, apply “Private” field codes to the appropriate headings
in the Word documents where new topics will be created (see "Specifying Custom File Names for
Word Imports" on page 55). You also have the option of renaming the new topic file names after the
import process is finished.
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How to Import Word Documents
The following steps describe how to import Word files using the Import Word Wizard. However, you
also have the option of adding a Word import file (see "Adding a Word Import File" on page 50) and
then using the Word Import Editor (see "Word Import Editor—Import and Re-Import" on page 45).

1. Select Project > Import > MS Word Documents.

2. In the wizard, choose either Import into a new project (and complete the fields below) or
Import into this project. However, if you do not have a project currently open, the file(s) will
automatically be imported into a new project.

n Project name Type a name for the new Flare project that will be created after you
perform the import.

n Project folder Accept the default location for the new project or click to find and
select a folder.

n Output type Select the primary target for your project.

3. Click Add file to choose Word documents. You can also select other options as necessary.

Option Description

This removes the selected file(s) from the list.

This moves the selected file or folder lower in the list (if you
have more than one to import).

This moves the selected file or folder higher in the list (if you
have more than one to import). The file at the top is used for
the name of the Flare TOC that is created as a result of the
import. Also, the order determines how the imported files are
arranged in the TOC as topics.

This opens the file that is selected in the list.
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NOTE DOCX is Microsoft Word's platform-independent, open XML format. You must
have Microsoft Word 2007 or later installed in order to import this file type. You also
must have Word installed on your computer, as opposed to using the feature on the
Options dialog (File > Options) to import without Microsoft Office.

4. (Optional) On the left, select Styles. You can use this page for various style settings.

ASSOCIATE A STYLESHEET

This is purely optional. You can choose an existing stylesheet by clicking . After doing this,
styles from that stylesheet become available in the mapping drop-down fields below, so that
you can map Word styles to those from the stylesheet you chose.
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STYLE MAPPING
n Discard MS Word styles By default, styles from the Word documents are mapped in

such a way that their names are retained and appended to Flare styles. However, you
can click this button, which will map to the Flare style but not keep the Word style name
or its formatting.

n Restore defaults If you change your mind, you can click this button, which will once
again retain the Word style names.

EXAMPLE In your Word document, second-level headings use the “Heading 2”
style. But in Flare Desktop, it is named “h2.” So when the Word style is mapped
to the Flare style, the resulting name will be “h2.Heading2.”
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If you click Discard MS Word styles, the mapping remains in place, but now the
resulting name will be “h2” and any formatting from Word for that style is not
retained.
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If you click Restore defaults, the mapping will once again result in the name
“h2.Heading2” and its formatting will be retained.
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n Paragraph/Character You can expand these sections to see the styles found in the
Word document(s).
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In these sections, you can map a paragraph or character style from the Word document
(s) to another style. Click the drop-down in a cell to select a style. Flare styles are listed
in the top part of the drop-down menu, while Word styles are listed on the bottom.
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If you want to specify that new topics should start with certain paragraph styles, simply
click the check box next to that style. The h1 style is selected by default (most authors
start new topics on heading styles), but you can choose any paragraph-level styles that
you like.
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PREVIEW

When you select a style row in either the Paragraph or Character section, a preview is shown
at the bottom so you can see how it looks. The design of the original Word style is shown on
the left, and the look of the mapped style is shown on the right.
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5. (Optional) On the left, select Advanced Options. You can use this page to set various options.

STYLES
n Create new stylesheet This creates a new stylesheet based on the settings you choose.

If you disable this option, the styles resulting from the import will be added to the
project’s primary stylesheet.
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NOTE If you choose to create a stylesheet when importing Word documents
into a new project, that stylesheet will be automatically selected in the project
properties. If you then open the Word Import Editor, deselect the option to
create a new stylesheet, and reimport the documents, that stylesheet will
continue to exist in the project.

n [Inline formatting]

l Keep inline formatting This retains inline formatting found in the Word documents.
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l Convert inline formatting to CSS styles This converts inline styles found in the Word
documents to styles in the Flare project.

l Remove inline formatting This removes any inline formatting found in the Word
documents, displaying it as regular text instead.
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TOPICS
n Automatically set topic title If this option is enabled, the properties setting for the topic

title automatically uses the first heading in the topic. Therefore, if you change the
heading text in the future, the topic title changes automatically as well. If this option is
disabled, the properties setting for the topic title explicitly uses the first topic heading
text found during the import, and it remains so unless you manually change it later.

n Avoid empty topics threshold Select this option if you want to ensure that new topics
are not created when large sections are found in the Word documents without any
content. Enter the maximum number of empty character spaces allowed in a topic. If
this number is exceeded, Flare Desktop will not create a new topic from that empty
space.

n Split long topics threshold Select this option if you have long sections in your source
documents and want to make sure that they are converted to multiple topics (rather
than one very long topic). Enter the maximum number of characters to be converted to
a topic before a new topic is created. Flare Desktop will break the topic at the nearest
paragraph to the threshold value. That way, a new topic will not start in the middle of a
sentence or word, but at the beginning of a paragraph.

n Add continued links Select this option to place a "Topic Continued" link at the bottom of
pages when a long topic has been split into multiple ones.

n Add continued from links Select this option to place a "Topic Continued From" link at
the top of continued pages when a long topic has been split into multiple ones.

l (continued in/from {title}) Use these fields to specify the format for the "(continued
in)" and "(continued from)" links. Flare Desktop provides a cross-reference format
for you—(continued in {title}) or (continued from {title}). With this cross-reference
format, the link contains the words "continued in" or "continued from" within
parentheses, followed by the text of the first paragraph in the connected topic. If you
do not want the link to use that particular text, you have a couple of options. First, in
Flare Desktop, you could manually enter a heading in each topic that is connected to
another topic included in the split. That text will be used in the link instead (after you
update the cross-references in Flare Desktop). Another option is to modify the
format by clicking the Edit button.

n Approximate filename length Enter the maximum number of characters to use for
naming topic files. The default is 24.
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TABLES
n Convert all tables to "auto-fit to contents" Select this option if you want to automatically

set tables to "Auto-Fit to Contents" when they are imported into Flare Desktop. This
ensures that column widths are not specified on the imported tables.

n Set first row of each table as a header row Select this option if you want Flare Desktop
to convert the first row of every table into a header row. This makes styling tables more
efficient. If you do not select this option, only tables that already have header rows in
the Word document will become header rows in Flare Desktop. Tables without header
rows will be imported just as they are.

EXAMPLE You have a Word document with two tables.

In the first table, the first row has been set to repeat as a header row.

In the second table, the first row has not been set to repeat as a header row.
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First, you import the Word document but you do not enable the option to set the
first row of each table as a header row. As a result, the first row in the first table
continues to be a header row, just as it was in the Word document. And the first
row in the second table continues to be a regular row, just as it was in the Word
document.
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Next, you import the Word document but you do enable the option to set the
first row of each table as a header row. As a result, the first row of each table is
now a header row.
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n [Table styles]

l Create CSS table styles as regular stylesheet This finds table formatting in the Word
documents and creates styles accordingly in the regular stylesheet in Flare Desktop.

l Convert table styles to Flare table styles This finds table formatting in the Word
documents and creates a special table stylesheets accordingly in Flare Desktop.
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NOTE To use this feature, the table must have been created in Microsoft
Word 2007 or later. Also, open the Options dialog (File > Options), select the
General tab, and make sure that Import/Export Word Files without MS Office
is disabled.

l Apply a selected table stylesheet to all imported tables This lets you select an
existing Flare table stylesheet and apply it to all imported tables.

l Remove all table styles This removes styling from all tables found in the Word
documents. You can keep them as plain tables in Flare Desktop or apply styles to
them later.
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LISTS

Use standard list style type This will use standard bullets (e.g., square, disc) and numbering
(e.g., decimal), whether they were used in the Word documents or not.

If this is not enabled, lists are imported with the characters or symbols used for the lists in
the Word documents. However, these are contained within span tags in the Flare topics. This
allows you to keep special elements, (e.g., Wingdings) that you might have used in Word for
custom lists.

EXAMPLE You have a Word document with lists, and it looks like this:
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If the option to use standard list style types is enabled, the topic in Flare Desktop will
look like this:
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If the option is disabled, the topic will look like this:

EQUATIONS

Convert equations to MathML When importing Microsoft Word files that contain equations,
you can convert them from Office Math Markup Language (the format used in Word) to
MathML (the web standard and Flare format). If you disable this option, equations from Word
are converted to images.

NOTE To use this feature, the equation must have been created in Microsoft Word
2007 or later. Also, open the Options dialog (File > Options), select the General tab,
and make sure that Import/Export Word Files without MS Office is disabled.
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PAGE LAYOUTS

Create a page layout for each section header/footer Select this option if you want Flare
Desktop to create new page layouts when you import Word documents that have section
breaks, along with headers or footers. For each new section in the Word document that has a
different header or footer than the previous section, Flare Desktop creates a unique page
layout. After the import is finished, you can open and edit the page layouts if necessary. You
can then create chapter breaks for your print-based output and assign these page layouts to
the different topics in the output.

PAGE BREAKS
n Preserve and create new topics on page breaks This keeps any page breaks found in

the Word documents.

n Preserve and convert to MadCap page breaks This keeps any page breaks found in the
Word documents, but it will convert them to the special page break tags
(MadCap|pageBreak) used by Flare Desktop. This page break element displays as a
gray bar in the XML Editor, but it is not shown in the output; a page break simply occurs
at that spot.

n Ignore page breaks This will not keep any page breaks found in the Word documents.
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REIMPORT
n Link generated files to source files Enable this if you want to continue editing in Word

and reimport as needed. Deselect it if you want to edit the imported files in Flare
Desktop going forward, severing the connection to the source files.

n Auto-reimport before generate output If you selected “Link generated files to source
files,” you will likely make future content changes in the source files. When you make
such changes, the source files need to be reimported into the project so that they can
be included in the output. You have the option of reimporting the files manually.
However, you can use this option instead and let Flare Desktop reimport the files
automatically when you attempt to build output.

6. Click Finish, then Accept.
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Word Import Editor—Import and Re-Import
If you add a Word import file (see "Adding a Word Import File" on page 50) or if you have previously
imported Word files using the wizard, a file is added to the Imports folder in the Project Organizer.

When you double-click this file, it opens in the Word Import Editor. This editor contains most of the
same fields and options as the Import Word Wizard.
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After completing or changing any of these fields, you can click Reimport in the toolbar.
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How Word Features are Treated When Imported
The following table shows some Word features how what happens to them when you import
documents into Flare Desktop.

Word Feature Result After Import

Artwork and
Special Effects

If you apply certain special effects or artwork (e.g., arrows) to images in
Word and then import them into Flare Desktop, those effects will not be
retained. For example, a rotated image will return to its straight, original
state. However, there are some workarounds that may allow you to keep the
effects or artwork. One solution is to apply another effect such as a shadow
or 3-D to the image in Word (e.g., add a shadow to a rotated image that you
want to keep). This forces Word to save the image as an entirely new image
with the effects. Another possible solution is to save the Word document as
a web page, manually copy that HTM file into the Flare folder, and then open
it within Flare Desktop. As for text floating around images, this effect is not
supported in Flare Desktop. When you import from Word, the text is added
below the image.

File Names Image file names are treated in the following ways for linked and embedded
images:

n
Linked Images If you have inserted a picture as a linked image in a
Word document, the file name for the image is preserved when
imported into Flare Desktop. The image file is stored by default at the
root of the Resources > Images subfolder in the Content Explorer.

n
Embedded Images If you have inserted a picture as an embedded
image in a Word document, the file name for the image is based on
the topic name when imported into Flare Desktop. The image file is
stored by default in the Resources > Images > [Word Document Name]
subfolder in the Content Explorer.
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Word Feature Result After Import

Image Alt Text
and Description

If you have an image in a Word document that contains alt text or a
description, both are brought in to Flare Desktop. After the Word document
is imported, you can open the topic containing the image, right-click on the
image, and select Image Properties. In the Image Properties dialog, the
description for the image is shown in the Screen Tip field, and the alt text is
shown in the Alternate Text field.

Linked Images When you insert an image in Word, one of the options is to insert it as a
linked image.

NOTE If you received a Word document with linked images from
another person—rather than creating the document yourself—you
need to also get the images themselves from that individual. Then
you need to re-link the images in the document. Otherwise, Word
(and therefore also Flare Desktop) will not be able to find them.

Videos If you import a Word document that contains a direct link to a video, it is
brought into the Flare project.

This only works for direct video links. For example, if you have Word 2013,
you can look for and insert videos from Bing or YouTube. These are direct
link videos that are supported. But those from video embed codes are not
supported.
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NOTE Flare Desktop supports Microsoft Word 2003 and newer versions.

NOTE A link icon displays on tabs in the XML Editor next to file names that are imported
from and linked to another file or Flare project. However, if you are also using the built-in
source control technology, the source control icons have a higher precedence and will
therefore be displayed instead.
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Adding a Word Import File
The following steps show you how to add an MS Word import file, which is used to import Word
documents into a project. If you go through the Import MS Word Documents Wizard (Project >
Import > MS Word Documents), this file is created automatically and added to the Imports folder in
the Project Organizer; you do not need to do this separately.

How to Add a Word Import File to a Project
1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Project > New > Import File > Add MS Word Import File.

n Right-Click In the Project Organizer, right-click on the Imports folder and from the
context menu select Add MS Word Import File.

The Add File dialog opens.

2. In the File Type field at the top, make sure MS Word Import File is selected.

3. In the Source area, choose to create the new file based on a template or an existing file.

n New From Template Choose either a factory template file or one of your own custom
template files as a starting point. The new file will take on all of the settings contained
in the template. If you want to use the factory template provided by Flare Desktop,
expand the Factory Templates folder and click on a template file. If you want to use
your own custom template file, expand the appropriate folder and click on a file. For
more information about templates, see the Help system.

n New From Existing Choose an existing file of the same type as a starting point for your
new file. As with template files, your new file will take on all of the settings contained in
the file you select. To use this option, click , use the Open File dialog to find a file, and
double-click it.

4. (Optional) If you want to place the file into a subfolder previously created in the Content
Explorer or Project Organizer, in the Folder field click and select the subfolder. Otherwise,
keep the default location.

5. In the File Name field, type a new name for the import file.

6. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click and select the conditions you
want to apply. Click OK.
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7. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the
dialog. Next to the File Tags field, click and select the file tags you want to apply. Click OK.

8. Click Add. The import file is added to the Imports folder in the Project Organizer. The Word
Import Editor opens to the right.

NOTE Flare Desktop supports Microsoft Word 2003 and newer versions.
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Enabling Import/Export Without Word
Installed

Flare Desktop supports the import and export of Microsoft Word documents without the need to
have Word installed locally. For example, a user of Microsoft Office 365 (a subscription-based
software solution) would not have Microsoft Word installed locally (via Microsoft Office). However,
Flare Desktop lets Office 365 users build Word output, or import Word files in the DOCX, DOC, or
RTF format, even if they do not have Microsoft Word installed on the same machine.

It is still recommended that you work with Word installed locally, which is a more robust process.
However, if you are an Office 365 user without a local installation of Word, you can use the
following steps to enable this feature. (This option is disabled by default.)

How to Enable the Import/Export Process
Without Word Installed

1. Select File > Options.

2. Select the General tab.

3. Select Import/Export Word Files Without MS Office.

4. Click OK.
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Opening a Word Import File
The following steps show you how to open an MS Word import file that you have added to a project.
You can then use this file to create topics by importing Word documents into the project. See
"Importing Word Files" on page 21.

How to Open a Word Import File From the Quick
Launch Bar
The Quick Launch bar lets you search for any Flare Desktop file or command. It is located in the
upper-right corner of the interface. You can press CTRL+Q on your keyboard to move focus to the
Quick Launch bar so you can begin typing.

1. In the Quick Launch bar, type a few letters of the name of the file you want to open. Any
available results appear in a drop-down list.

2. From the list, click the name of the file.
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How to Open a Word Import File From the
Project Organizer

1. Open the Project Organizer.

2. Double-click the Imports folder. The MS Word import files in your project are displayed.

3. Double-click the import file that you want to open. The Word Import Editor opens to the right.

What’s Noteworthy?

NOTE Flare Desktop supports Microsoft Word 2003 and newer versions.
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Specifying Custom File Names for
Word Imports

If you import Microsoft Word documents, you can split those documents into multiple topics based
on the styles in them. For example, you might decide to create a new topic at each "Heading 1" style
in the Word document. You can also control the file names given to the new topics that are created
from the imported Word documents. To do this, you need to apply "Private" field codes to the
appropriate headings in the Word documents where new topics will be created. The following
format should be used when applying the field: PRIVATE:MADCAP:FILENAME:<custom filename>.

How to Specify Custom File Names for Word
Imports
The following steps are based on Microsoft Word 2003 and 2007. For more details on creating
Private fields in Microsoft Word in other versions, please refer to the documentation provided with
that application.

1. Open the Word document.

2. Place your cursor on a heading where you want to start a new topic in Flare Desktop.

3. Do one of the following:

n For Word 2003 Select Insert > Field.

n For Word 2007 Select Insert > Quick Parts > Field.

The Field dialog opens.

4. In the Field name section, scroll down and select Private.
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5. In the Field codes section, enter the code using the following format:
PRIVATE:MADCAP:FILENAME:<custom filename>.

EXAMPLE You have a place in a Word document that is using the "Heading 1" style
and contains the text "All About Rabbits." You want a new topic to be created at that
point when you import the document. However, you also want to make sure that the
file name for that new topic is simply "Rabbits." Therefore, you open the Word
document and apply a Private field on that heading, using the following format:

PRIVATE:MADCAP:FILENAME:Rabbits

When you import the Word document, you select to split new topics on certain styles,
including the "Heading 1" style. After the import is finished, one of the topics created
is named "Rabbits.htm."

6. Click OK.

7. Save the Word document.

8. In Flare Desktop, go through the process for importing the Word document. When you arrive
at the "New Topic Styles" page in the Import Microsoft Word Wizard or the "New Topic Styles"
tab in the Word Import Editor, make sure you select the style(s) where you inserted Private
fields in the Word document.

CHAPTER 3  56



Disabling Auto-Sync of Import Files
Let's say you have imported Microsoft Word, Adobe FrameMaker, Microsoft Excel, or Flare files
from another project, and when doing so, you selected the "Easy Sync" option to automatically
reimport the files when you generate output. If you want to override that Easy Sync setting for a
specific target, you can do so by using the steps below. Therefore, if you want to reimport any of
the files, you will need to do so manually. See "Importing Word Files" on page 21, "How to Import
FrameMaker Files" on page 146, and "Importing Excel Files" on page 60.

You might decide to use this option, for example, if you are testing the generation of output and do
not want to wait the extra time for the files to be imported. After you finish your testing, you can
deselect this option to return to the automatic imports of the files.

How to Disable Auto-Sync of Import Files
1. Open the target.

2. In the Target Editor, select the General tab.

3. Select the check box labeled Disable auto-sync of all import files.

4. Click to save your work.
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Overwriting Imported Documents
If you have imported Microsoft Word or Adobe FrameMaker documents and maintained a link with
the source documents, you receive a warning when you try to save changes in the imported
document. One of the options that you can select is to save the document and ignore the warning.
In this case, the local file remains linked to the source file, even though it is different. When you
attempt to reimport that file from the source, you are given the opportunity to overwrite the local
file.

How to Overwrite Imported Documents
1. From the Imports folder in the Project Organizer, open an import file, and attempt to reimport

a file that you have changed locally. The Confirm Overwrite Documents dialog opens.

2. Click the Overwrite check box next to any files that you want to overwrite with the source file.
You can use the options at the bottom of the dialog to quickly select multiple files.

n Select All Use this button to automatically add check marks next to all files in the list.

n Clear All Use this button to automatically remove check marks from all files in the list.

n Check Selected Use this button to automatically add check marks next to all files in the
list that are selected (i.e., you have highlighted them). You can hold the SHIFT key to
select a range, or you can hold the CTRL key to select individual items.

n Clear Selected Use this button to automatically remove check marks from all files in the
list that are selected (i.e., you have highlighted them). You can hold the SHIFT key to
select a range, or you can hold the CTRL key to select individual items.

3. Click OK.

4. In the dialog that opens, click either Yes or Yes All to replace the files.
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CHAPTER 4

Importing Excel
There are various tasks involved with importing Excel files.

This chapter discusses the following:

Importing Excel Files 60

Adding an Excel Import File 67

Opening an Excel Import File 69
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Importing Excel Files
You can import Microsoft Excel files into Flare projects. They can be imported into existing projects
or when creating a new project. The spreadsheet content will be added to tables in Flare Desktop
when the import is finished.

How to Import Excel Files
1. Select Project > Import > MS Excel Workbooks.

2. In the wizard, choose either Import into a new project (and complete the fields below) or
Import into this project. However, if you do not have a project currently open, the file(s) will
automatically be imported into a new project.

n Project name Type a name for the new Flare project that will be created after you
perform the import.

n Project folder Accept the default location for the new project or click to find and
select a folder.

n Output type Select the primary target for your project.
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3. Click Next.

4. Click to choose Excel files. You can select XLS, XLSX, or CSV files. When finished, click
Next. (You can also select other options as necessary.)

Option Description

This opens the file that is selected in the list.

Link
Generated
Files to
Source Files

This creates a connection between the original files and the files that are
created as a result of the import. This is useful if you want to continue
editing the content outside of Flare Desktop, instead of editing in the
Flare project. Flare Desktop recognizes when changes have been made
to the source documents and reminds you to reimport the documents to
ensure the Flare project also reflects the changes. If you use this option,
a link icon is added to the top of a linked file in the Flare Desktop
interface. This lets you know that you need to edit the source file, rather
than editing this file. If you remove the connection to the source file, this
icon no longer displays on the file. Please note that if you have bound the
project to source control, the icons used for source control take
precedence over the link icon.

This removes the selected file(s) from the list.

This moves the selected file higher in the list (if you have more than one
file to import). The file at the top is used for the name of the content
folder holding the imported topics in Flare Desktop. Also, the order
determines how the imported files are arranged in the Flare TOC that is
created as a result.

This moves the selected file lower in the list (if you have more than one
file to import).
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5. Select from various options as necessary, then click Next.

n Import Worksheets as Select the type of Flare file where you want your spreadsheets
to be imported.

l Topics Flare Desktop will convert your content and place worksheets into topics.
Title text on a worksheet tab will become a heading in the Flare topic.

l Snippets Flare Desktop will convert your content and place each worksheet into a
separate snippet.

If you selected “Snippets” above, you can also choose from the following options:

l Include tab titles as headings Any title text on your worksheet tabs will become
headings in the Flare snippets.

l Create a topic with snippets Flare Desktop will create a topic and place the snippets
within it. Otherwise, only the snippets will be created.

n Organize worksheets into different folders per workbook Select this option if you are
importing multiple workbooks and want the resulting files to be stored in separate
folders in Flare Desktop. If you do not select this option when importing multiple
workbooks, the files will all be placed in the same folder in Flare Desktop.

n Import hidden rows/columns This includes any hidden rows and columns in the import.
Otherwise, they will not be part of the imported content.

n Use first row as column header Select this option if you want Flare Desktop to convert
the first row of every spreadsheet into column headers in the Flare tables. If you do not
select this option, the first row will be treated like all the other rows.

n Import equations based on settings When importing Excel files that contain equations,
you can select this option to convert them to MathML (the web standard) or images. If
you disable this option, equations from Excel are not converted to Flare Desktop.

NOTE The conversion of equations to MathML versus images depends on
whether you have Excel installed:

l If Excel is Installed Equations will be imported as MathML.

l If Excel is not Installed Equations will be imported as PNG images.
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NOTE There is an option in Excel that must be enabled in order for equations
to be imported into Flare Desktop. In Excel, select an equation that you’ve
inserted, open the Design ribbon, and in the Tools section, click the small
option in the lower-right. Then in the dialog, select Copy MathML to the
clipboard as plain text.

NOTE If you choose to convert equations to MathML, they are automatically
stored in snippets in Flare Desktop. Otherwise, equations will be converted to
images. A snippet or image displaying an equation is automatically placed
below the worksheet (in the topic or snippet where the worksheet was
converted to a table).

NOTE To use this feature, the equation must have been created in Microsoft
Excel 2010 or newer.

n Import charts as Any charts in your spreadsheets will be imported as images. Use this
field to select the type of image format to be used.

NOTE An image displaying an imported chart is automatically placed below
the worksheet (in the topic or snippet where the worksheet was converted to a
table).

n Split topics or snippets by maximum rows You can select this option if you have
spreadsheets with a lot of rows and want to divide them into multiple topics or snippets
(rather than one very long topic or snippet). After enabling this option, enter the number
of rows that you want to allow in each topic or snippet before a new topic or snippet is
created.

n Auto-reimport before 'Generate Output' If you selected “Link Generated Files to Source
Files” earlier in the wizard, you will likely make future content changes in the source
files. When you make such changes, the source files need to be reimported into the
project so that they can be included in the output. You have the option of reimporting
the files manually. However, you can also tell Flare Desktop to do this for you
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automatically, so that you do not have to. Select this option if you want Flare Desktop
to automatically reimport files when you attempt to build output.

6. Use the next page to specify how you want the formatting of the Excel files to be treated upon
import. Choose whether the imported files should retain their look and feel from Excel, or if
you want to associate them with a table stylesheet that you’ve already created in Flare
Desktop. When finished, click Next.

n Preserve MS Excel Styles This retains any formatting from your spreadsheets so that
you can continue to use that look and feel in Flare Desktop.

If you have Excel installed, all styles (factory and custom) and local formatting are
retained in Flare Desktop. If you do not have Excel installed, only custom styles and
local formatting are preserved; factory styles are not retained. Also, if you are using
more than one table style in a worksheet, only one of them will be retained in Flare
Desktop.

n Don't Preserve MS Excel Styles This does not keep the formatting used in the Excel
spreadsheets. You can click in the field below this if you want to associate the
imported spreadsheets with a table stylesheet that you’ve already created in Flare
Desktop. If you do not choose a table stylesheet, the files will be imported with plain
text.

7. You can use this page to exclude certain worksheets, or even specific rows and columns,
from the import. By default, all workbooks, worksheets, rows, and columns are selected for
import. You can click the corresponding check boxes to remove check marks, which excludes
items from the import. If you click on a particular worksheet, the area to the right displays the
rows and columns within it. You can then remove check marks for any rows or columns that
you want to exclude.

NOTE If your worksheets have any hidden rows or columns that you did not include
in the import, you may see that those rows or columns are skipped on this page. For
example, you might see columns A, B, C, and E (where D is hidden).

8. Click Finish. The Accept Imported Documents dialog opens. The files that will be created as a
result of the import are listed on the left. A preview of each file can be seen to the right when
you click the file.

9. When you are finished previewing the files to be created, click Accept.
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Excel Import Editor—Import and Re-Import
If you add an Excel import file (see "Adding an Excel Import File" on page 67) or if you have
previously imported Excel files using the wizard, a file is added to the Imports folder in the Project
Organizer.

When you double-click this file, it opens in the Excel Import Editor. This editor contains most of the
same fields and options as the Import Microsoft Excel Wizard.
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After completing or changing any of these fields, you can click Reimport in the toolbar.

What’s Noteworthy?

NOTE There is a limit of 256 columns per worksheet that can be imported from Excel into
Flare Desktop.

NOTE Flare Desktop supports Microsoft Excel 2010 and newer versions. However, if you
have an older version of Excel, you can open the Options dialog (File > Options), select the
General tab, and choose Import Excel Files Without MS Office.

NOTE A link icon displays on tabs in the XML Editor next to file names that are imported
from and linked to another file or Flare project. However, if you are also using the built-in
source control technology, the source control icons have a higher precedence and will
therefore be displayed instead.
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Adding an Excel Import File
The following steps show you how to add an Excel import file, which is used to import Excel files
into a project. If you go through the Import Microsoft Excel Wizard (Project > Import > MS Excel
Workbooks), this file is created automatically and added to the Imports folder in the Project
Organizer; you do not need to do this separately.
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How to Add an Excel Import File to a Project
1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Project > New > Import File > Add MS Excel Import File.

n Right-Click In the Project Organizer, right-click on the Imports folder and from the
context menu select Add MS Excel Import File.

The Add File dialog opens.

2. In the File Type field at the top, make sure MS Excel Import File is selected.

3. In the Source area, choose to create the new file based on a template or an existing file.

n New From Template Choose either a factory template file or one of your own custom
template files as a starting point. The new file will take on all of the settings contained
in the template. If you want to use the factory template provided by Flare Desktop,
expand the Factory Templates folder and click on a template file. If you want to use
your own custom template file, expand the appropriate folder and click on a file. For
more information about templates, see the Help system.

n New From Existing Choose an existing file of the same type as a starting point for your
new file. As with template files, your new file will take on all of the settings contained in
the file you select. To use this option, click , use the Open File dialog to find a file, and
double-click it.

4. (Optional) If you want to place the file into a subfolder previously created in the Content
Explorer or Project Organizer, in the Folder field click and select the subfolder. Otherwise,
keep the default location.

5. In the File Name field, type a new name for the import file.

6. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click and select the conditions you
want to apply. Click OK.

7. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the
dialog. Next to the File Tags field, click and select the file tags you want to apply. Click OK.

8. Click Add. The import file is added to the Imports folder in the Project Organizer.
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Opening an Excel Import File
The following steps show you how to open an Excel import file that you have added to a project.
You can then use this file to import Excel files into the project. See "Importing Excel Files" on page
60.

How to Open an Excel Import File From the
Quick Launch Bar
The Quick Launch bar lets you search for any Flare Desktop file or command. It is located in the
upper-right corner of the interface. You can press CTRL+Q on your keyboard to move focus to the
Quick Launch bar so you can begin typing.

1. In the Quick Launch bar, type a few letters of the name of the file you want to open. Any
available results appear in a drop-down list.

2. From the list, click the name of the file.
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How to Open an Excel Import File From the
Project Organizer

1. Open the Project Organizer.

2. Double-click the Imports folder. The Excel import files in your project are displayed.

3. Double-click the import file that you want to open. The Excel Import Editor opens to the right.
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CHAPTER 5

Importing HTML
There are various tasks involved with importing HTML files.

This chapter discusses the following:

Importing HTML Files 72

Adding an HTML Import File 76

Opening an HTML Import File 78

CHAPTER 5  71



Importing HTML Files
You can import XHTML and HTML files (automatically converting them to XHTML).

How to Import HTML Files
1. Select Project > Import > HTML File Set.

2. In the wizard, choose either Import into a new project (and complete the fields below) or
Import into this project. However, if you do not have a project currently open, the file(s) will
automatically be imported into a new project.

n Project name Type a name for the new Flare project that will be created after you
perform the import.

n Project folder Accept the default location for the new project or click to find and
select a folder.

n Output type Select the primary target for your project.

3. Click Next.

4. Click to choose HTML files. You can also click to find and select a folder containing
HTML files you want to import. When you select a folder to import, the wizard imports all files
within that folder that have an .htm, .html, or .xhtml extension. If you later reimport
HTML files into the project, Flare Desktop checks to see if any of the files in the source folder
have changed. It also determines whether files have been deleted or added, and it updates
the source files list accordingly. When you are finished, click Open.
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5. (Optional) You can use the other options on the page if necessary.

Option Description

This opens the file that is selected in the list.

This opens the HTML to XHTML Conversion dialog, which lets you see
how the selected file looks in HTML and how it will look after its
conversion to XHTML.

Link
Generated
Files to
Source Files

This creates a connection between the original files and the files that are
created as a result of the import. This is useful if you want to continue
editing the content outside of Flare Desktop, instead of editing in the
Flare project. Flare Desktop recognizes when changes have been made
to the source documents and reminds you to reimport the documents to
ensure the Flare project also reflects the changes. If you use this option,
a link icon is added to the top of a linked file in the Flare Desktop
interface. This lets you know that you need to edit the source file, rather
than editing this file. If you remove the connection to the source file, this
icon no longer displays on the file. Please note that if you have bound the
project to source control, the icons used for source control take
precedence over the link icon.

This removes the selected file(s) from the list.

This moves the selected file higher in the list (if you have more than one
file to import). The file at the top is used for the name of the content
folder holding the imported topics in Flare Desktop. Also, the order
determines how the imported files are arranged in the Flare TOC that is
created as a result.

This moves the selected file lower in the list (if you have more than one
file to import).

6. Click Next.
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7. (Optional) You can use more import options as necessary.

n Import linked HTML files Select this option if you want to automatically bring in other
files that are linked to those you selected on the previous page. For example, if you
import Doc1.htm, which contains a hyperlink to Doc2.htm, this option imports
Doc2.htm as well.

n Import resources Select this option if you want to include any supporting resource files
(e.g., stylesheets, images, multimedia files) in the import. Then select one of the
following:

l Keep existing structure The supporting resources files will be copied into folders
with the same names and hierarchy as those used in the source.

l To project resources folder The supporting files will be placed in the Resources
folder in your Flare project.

n Auto-reimport before 'Generate Output' If you selected “Link Generated Files to Source
Files” earlier in the wizard, you will likely make future content changes in the source
files. When you make such changes, the source files need to be reimported into the
project so that they can be included in the output. You have the option of reimporting
the files manually. However, you can also tell Flare Desktop to do this for you
automatically, so that you do not have to. Select this option if you want Flare Desktop
to automatically reimport files when you attempt to build output.

8. Click Finish. The Accept Imported Documents dialog opens. The files that will be created as a
result of the import are listed on the left. A preview of each file can be seen to the right when
you click the file.

9. When you are finished previewing the files to be created, click Accept.
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Import Editor—Import and Re-Import
If you add an HTML import file (see "Adding an HTML Import File" on the next page) or if you have
previously imported HTML files using the wizard, a file is added to the Imports folder in the Project
Organizer.

When you double-click this file, it opens in the Import Editor. This editor contains most of the same
fields and options as the Import HTML Files Wizard.

After completing or changing any of these fields, you can click Reimport in the toolbar.

What’s Noteworthy?

NOTE A link icon displays on tabs in the XML Editor next to file names that are imported
from and linked to another file or Flare project. However, if you are also using the built-in
source control technology, the source control icons have a higher precedence and will
therefore be displayed instead.
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Adding an HTML Import File
The following steps show you how to add an HTML import file, which is used to import HTML files
into a project. If you go through the Import HTML Files Wizard (Project > Import > HTML File Set),
this file is created automatically and added to the Imports folder in the Project Organizer; you do
not need to do this separately.
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How to Add an HTML Import File to a Project
1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Project > New > Import File > Add HTML Import File.

n Right-Click In the Project Organizer, right-click on the Imports folder and from the
context menu select Add HTML Import File.

The Add File dialog opens.

2. In the File Type field at the top, make sure HTML Import File is selected.

3. In the Source area, choose to create the new file based on a template or an existing file.

n New From Template Choose either a factory template file or one of your own custom
template files as a starting point. The new file will take on all of the settings contained
in the template. If you want to use the factory template provided by Flare Desktop,
expand the Factory Templates folder and click on a template file. If you want to use
your own custom template file, expand the appropriate folder and click on a file. For
more information about templates, see the Help system.

n New From Existing Choose an existing file of the same type as a starting point for your
new file. As with template files, your new file will take on all of the settings contained in
the file you select. To use this option, click , use the Open File dialog to find a file, and
double-click it.

4. (Optional) If you want to place the file into a subfolder previously created in the Content
Explorer or Project Organizer, in the Folder field click and select the subfolder. Otherwise,
keep the default location.

5. In the File Name field, type a new name for the import file.

6. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click and select the conditions you
want to apply. Click OK.

7. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the
dialog. Next to the File Tags field, click and select the file tags you want to apply. Click OK.

8. Click Add. The import file is added to the Imports folder in the Project Organizer. The HTML
Import Editor opens to the right.
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Opening an HTML Import File
The following steps show you how to open an HTML import file that you have added to a project.
You can then use this file to import HTML files into the project. See "Importing HTML Files" on page
72.

How to Open an HTML Import File From the
Quick Launch Bar
The Quick Launch bar lets you search for any Flare Desktop file or command. It is located in the
upper-right corner of the interface. You can press CTRL+Q on your keyboard to move focus to the
Quick Launch bar so you can begin typing.

1. In the Quick Launch bar, type a few letters of the name of the file you want to open. Any
available results appear in a drop-down list.

2. From the list, click the name of the file.
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How to Open an HTML Import File From the
Project Organizer

1. Open the Project Organizer.

2. Double-click the Imports folder. The HTML import files in your project are displayed.

3. Double-click the import file that you want to open. The HTML Import Editor opens to the right.
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CHAPTER 6

Importing Confluence
There are various tasks involved with importing Confluence files.

This chapter discusses the following:

Importing Confluence Files 81

Adding a Confluence Import File 93

Opening a Confluence Import File 95
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Importing Confluence Files
If you have an Atlassian Confluence account, you can import pages (HTM and resource files) into
Flare projects. You can import these files into a new Flare project or an existing one. Flare Desktop
supports both the cloud and local versions of Confluence.

How to Import Confluence Pages
1. Select Project > Import > Confluence Pages.

2. In the wizard, choose either Import into a new project (and complete the fields below) or
Import into this project. However, if you do not have a project currently open, the file(s) will
automatically be imported into a new project.

PROJECT FIELDS
n Project name Type a name for the new Flare project that will be created after you

perform the import.

n Project folder Accept the default location for the new project or click to find and
select a folder.

n Output type Select the primary target for your project.

3. Complete the Confluence Server, Username, and Password fields. Then click Submit. The
Workspace Selection page should open automatically.

4. From the drop-down, select the space from which you want to import.
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5. In the tree, select the pages to be imported. If you click on an item, a preview for it displays to
the right.

6. (Optional) On the left, select Advanced Options and choose options as necessary.

TOPICS
n Import linked pages Select this if you want to automatically bring in other files that are

linked to those you selected from the tree. For example, if you choose to import a page
called “Beer,” which contains a link to a page called “Food,” this option imports both
pages.

n Remove inline formatting Select this if you do not want to keep any inline formatting in
the pages. If you do not select this option, the formatting will be retained. However,
keep in mind that styles, rather than inline (local) formatting, is recommended in Flare
projects.

n Remove style classes Select this if you want to remove any style classes that
Confluence might have added to elements (such as tables and images). Otherwise, you
might have some undefined styles after the pages are imported into Flare Desktop.
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RESOURCES
n Import resources Select this option if you want to include any supporting resource files

(e.g., images, multimedia) in the import. In Flare Desktop, these will be added to the
Resources folder in the Content Explorer, and they will link to the appropriate topics.

REIMPORT
n Link generated files to source files Select this option if you want to continue editing in

Confluence and reimport as needed. Deselect it if you want to edit the imported files in
Flare Desktop going forward.

7. Click Finish and Accept.
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Confluence Import Editor—Import and Re-Import
If you add a Confluence import file (see "Adding a Confluence Import File" on page 93) or if you have
previously imported Confluence files using the wizard, a file is added to the Imports folder in the
Project Organizer.
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When you double-click this file, it opens in the Confluence Import Editor. This editor contains most
of the same fields and options as the Import Confluence Wizard.

After completing or changing any of these fields, you can click Import or Reimport in the toolbar.

CHAPTER 6  85



How Elements are Converted From Confluence
to Flare
Certain elements from Confluence are converted to their closest counterparts in Flare. The
following table describes this.

Confluence Flare Desktop

Paragraph Styles

Article title H1

Heading 1 through Heading 6 H1 through H6

Preformatted Text surrounded by <pre> tags

Quote Text surrounded by <blockquote> tags

Character Styles

Bold Text surrounded by <strong> tags

Font color Text surrounded by <span> tags

Italic Text surrounded by <em> tags

Monospace Text surrounded by <code> tags

Strikethrough Text surrounded by <s> tags

Subscript Text surrounded by <sub> tags
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Confluence Flare Desktop

Superscript Text surrounded by <sup> tags

Underline Text surrounded by <u> tags

Lists

Bulleted list Bullet list

Numbered list Numbered list

Task list Bullet list

Alignment

Center Center

Left Left

Indent Indent

Outdent Outdent

Right Right

Content

Date Text
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Confluence Flare Desktop

Emoticon SVG image

Gallery Table containing images

Horizontal rule Horizontal rule

Info Text surrounded by <div> tags

Link Link

Markup Text

Status Text surrounded by <div> tags

Symbol Symbol

Table of contents Links in bulleted list

Task list Bulleted list

User mention Link

Other Macros

Blog post Text surrounded by <div> tags

Change history Links in table
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Confluence Flare Desktop

Content by label Text surrounded by <div> tags

Content by user Links in table

Content report table Text in table

Contributor Link

Contributor summary Text and links in table

Create from template Link

Except include Text

Favorite pages Text and links

Include pages Text

Labels list Links

Microsoft Office Excel File added to Content Explorer

Microsoft Office PowerPoint File added to Content Explorer

Microsoft Office Word File added to Content Explorer

Multimedia Multimedia file with image as placeholder
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Confluence Flare Desktop

PDF File added to Content Explorer

Popular labels Links in bulleted list

Recently updated Links and text

Recently updated dashboard Links

Related labels Text

Space attachments Links and text in table

Space details Text

Spaces list Links in table

Status Text

Task report Text and links in table

User profile Links

Formatting

Code block Text surrounded by <div> tags

Column Text surrounded by <div> tags
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Confluence Flare Desktop

Expand Text surrounded by <div> tags

Info Text surrounded by <div> tags

No format Text surrounded by <div> tags

Note Text surrounded by <div> tags

Panel Text surrounded by <div> tags

Section Text surrounded by <div> tags

Tip Text surrounded by <div> tags

Warning Text surrounded by <div> tags

Navigation

Children display Link

Livesearch Search bar in output

Page index Link in table

Search results Text and links

Table of content zone Text
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Confluence Flare Desktop

Table of contents Links

Reporting

Global reports Links and text in table

Page properties Text

Page properties report Text in table

Popular labels Links

What’s Noteworthy?

NOTE If you import a GIF image using the GIPHY integration in Confluence, the file will be
imported without an extension and will resemble a folder in the Content Explorer.

NOTE A link icon displays on tabs in the XML Editor next to file names that are imported
from and linked to another file or Flare project. However, if you are also using the built-in
source control technology, the source control icons have a higher precedence and will
therefore be displayed instead.
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Adding a Confluence Import File
The following steps show you how to add a Confluence import file, which is used to import
Confluence pages into a project. If you go through the Import Confluence Wizard (Project > Import >
Confluence Pages), this file is created automatically and added to the Imports folder in the Project
Organizer; you do not need to do this separately.

How to Add a Confluence Import File to a
Project

1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Project > New > Import File > Add Confluence Import File.

n Right-Click In the Project Organizer, right-click on the Imports folder and from the
context menu select Add Confluence Import File.

The Add File dialog opens.

2. In the File Type field at the top, make sure Confluence Import File is selected.

3. In the Source area, choose to create the new file based on a template or an existing file.

n New From Template Choose either a factory template file or one of your own custom
template files as a starting point. The new file will take on all of the settings contained
in the template. If you want to use the factory template provided by Flare Desktop,
expand the Factory Templates folder and click on a template file. If you want to use
your own custom template file, expand the appropriate folder and click on a file. For
more information about templates, see the Help system.

n New From Existing Choose an existing file of the same type as a starting point for your
new file. As with template files, your new file will take on all of the settings contained in
the file you select. To use this option, click , use the Open File dialog to find a file, and
double-click it.

4. (Optional) If you want to place the file into a subfolder previously created in the Content
Explorer or Project Organizer, in the Folder field click and select the subfolder. Otherwise,
keep the default location.

5. In the File Name field, type a new name for the import file.
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6. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click and select the conditions you
want to apply. Click OK.

7. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the
dialog. Next to the File Tags field, click and select the file tags you want to apply. Click OK.

8. Click Add. The import file is added to the Imports folder in the Project Organizer. The
Confluence Import Editor opens to the right.
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Opening a Confluence Import File
The following steps show you how to open a Confluence import file that you have added to a
project. You can then use this file to import Confluence files into the project.

How to Open a Confluence Import File From the
Quick Launch Bar
The Quick Launch bar lets you search for any Flare Desktop file or command. It is located in the
upper-right corner of the interface. You can press CTRL+Q on your keyboard to move focus to the
Quick Launch bar so you can begin typing.

1. In the Quick Launch bar, type a few letters of the name of the file you want to open. Any
available results appear in a drop-down list.

2. From the list, click the name of the file.
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How to Open a Confluence Import File From the
Project Organizer

1. Open the Project Organizer.

2. Double-click the Imports folder. The Confluence import files in your project are displayed.

3. Double-click the import file that you want to open. The Confluence Import Editor opens to the
right.
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CHAPTER 7

Importing Markdown
There are various tasks you can perform when importing Markdown documents.

This chapter discusses the following:

Importing Markdown Files 98

Adding a Markdown Import File 114

Opening a Markdown Import File 116
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Importing Markdown Files
Markdown is a markup language using plain formatting syntax. You can import Markdown (.md)
files into Flare projects. This might be necessary, for example, if software developers or subject
matter experts write content in Markdown and you want to include that information in your Flare
project.

Flavors
There are multiple variations, or "flavors," of Markdown.

n CommonMark This is a standardized syntax of Markdown, and Flare Desktop supports this
flavor entirely.

n Other Flavors A variety of other Markdown implementations have been created over the years
to support additional features beyond the most common HTML elements. Flare Desktop may
import extra markup from those flavors, but some might not be fully supported.
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Markdown Syntax and Flare Results
Depending on the Markdown flavor, various syntax and tags will be converted in Flare in different
ways. The following resources are helpful to understand Markdown's basic and extended syntax:

n Basic Syntax

https://www.markdownguide.org/basic-syntax/

n Extended Syntax

https://www.markdownguide.org/extended-syntax/

Usually the conversion is straightforward because there is an obvious HTML counterpart.

EXAMPLES

Markdown Syntax HTML Result in Flare

## My Second-Level Heading <h2>My Second-Level Heading</h2>

I am **really** serious! <p>I am <strong>really</strong>
serious!</p>

- First thing

- Second thing

- Third thing

<ul>

<li>First thing</li>

<li>Second thing</li>

<li>Third thing</li>

</ul>
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NOTE If you add regular HTML into Markdown files, it will be imported properly into Flare
Desktop as HTML.
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Custom Tags
Flare Desktop is able to import custom tags that you add to Markdown files.

EXAMPLE A person writes the following in a Markdown document.

After this document is imported into Flare Desktop, it will look as follows. Notice the
structure bar at the top indicates the custom code tag name when you click inside the
content below.

NOTE At this time, MadCap-specific tags (e.g., markup for a drop-down effect) cannot be
imported from Markdown into Flare Desktop.
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How to Import Markdown Documents
The following steps describe how to import Markdown files using the Import Markdown Wizard.
However, you also have the option of adding a Markdown import file (see "Adding a Markdown
Import File" on page 114) and then using the Markdown Import Editor (see "Markdown Import
Editor—Import and Re-Import" on page 112).

1. Select Project > Import > Markdown Documents.

2. In the wizard, choose either Import into a new project (and complete the fields below) or
Import into this project. However, if you do not have a project currently open, the file(s) will
automatically be imported into a new project.

n Project name Type a name for the new Flare project that will be created after you
perform the import.

n Project folder Click to find and select a folder.

n Output type Select the primary target for your project.

3. Click Add file to choose Markdown documents. You can also select other options as
necessary.

Option Description

This removes the selected file(s) from the list.

This lets you choose a folder, so that all files in that folder are
added for the import.

This moves the selected file or folder lower in the list (if you
have more than one to import).
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Option Description

This moves the selected file or folder higher in the list (if you
have more than one to import). The file at the top is used for
the name of the Flare TOC that is created as a result of the
import. Also, the order determines how the imported files are
arranged in the TOC as topics.

This opens the file that is selected in the list.

4. (Optional) On the left, select Styles. You can use this page for various style settings.

ASSOCIATE A STYLESHEET

This is purely optional. You can choose an existing stylesheet (such as one in the Flare
project you are importing files into) by clicking . After doing this, styles from that stylesheet
become available in the mapping drop-down fields below, so that you can map Markdown
tags to those from the stylesheet you chose.
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STYLE MAPPING
n Restore defaults If you make mapping selections in the fields below but then change

your mind, you can click this button, which will return the default settings.

n [Drop-Downs] You can expand these sections to see the styles found in the Markdown
document(s).

l Block These are styles that take up the entire space in a line (e.g., paragraphs,
headings)

l List These are styles that are used to create bulleted and numbered lists.

l Definition List These are styles that are used to create definition lists, which are
typically groups of terms and definitions.

l Inline These are character-level styles that are applied only to certain words within a
block (e.g., hyperlinks, bold text).
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SELECTING STYLES

In these drop-down sections, you can map a style from the Markdown document(s) to
another style.

Flare Desktop automatically populates the "Map to" column with the recommended
style. For example, if Heading 1 is found in the Markdown document, the recommended
style to map to is h1 in Flare Desktop. Therefore, you often don't need to choose a
different style. However, sometimes you might want something different. If you want to
map the style to something other than what is recommended, click the drop-down in a
cell to select a style.

EXAMPLE — Code Blocks

You have a code block in the Markdown document, Flare Desktop initially maps
it to the MadCap:codeSnippet style.
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If you leave this setting, the content will be brought in to Flare Desktop like this:

However, you might want to map code blocks to the "pre" style instead.
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In that case, the content will be imported like this:

SPECIFYING NEW TOPICS

If you want to specify that new topics should start with certain styles, expand the Block
section and click the check box next to that style. The h1 style is selected by default
(most authors start new topics on heading styles), but you can choose any block styles
that you like.
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PREVIEW

When you select a style row, a preview is shown at the bottom so you can see how it looks.

5. (Optional) On the left, select Advanced Options. You can use this page to set various options.

STYLES
n Create new stylesheet This creates a new stylesheet based on the settings you choose.

If you disable this option, the styles resulting from the import will be added to the
project’s primary stylesheet.

NOTE If you choose to create a stylesheet when importing Markdown
documents into a new project, that stylesheet will be automatically selected in
the project properties. If you then open the Markdown Import Editor, deselect
the option to create a new stylesheet, and reimport the documents, that
stylesheet will continue to exist in the project.
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TOPICS
n Convert all simple lists to paragraph lists If you leave this option disabled, bulleted and

numbered lists will be imported so that each item in the list just has an <li> tag. If you
enable this option, <p> tags will be added within each <li> tag. However, you can add
<p> tags later manually for list items where you want them. The benefit of having <p>
tags within list items is that you can easily add paragraphs or other content within that
item before the next bullet or number is shown.

NOTE Markdown supports both simple and paragraph lists. Although you can
import simple lists as paragraph lists using this option, the reverse is not true.
If you have paragraph lists in Markdown, they will not be converted to simple
lists if you deselect the option. Those will just be imported as paragraph lists
regardless of the option setting.

n Convert all definition lists to definition paragraph lists If you leave this option disabled,
definition lists will be imported so that each item in the list just has a <dd> or <dt> tag.
If you enable this option, <p> tags will be added within each <dd> or <dt> tag. However,
you can add <p> tags later manually for definition or term items where you want them.
Most authors tend to create definition lists without <p> tags, but you can add them if
you want.

n Approximate filename length Enter the maximum number of characters to use for
naming topic files. The default is 24.
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RESOURCES
n Resources If the Markdown files have links to other files, such as images, you can

select this option to include those files in the import. However, the files need to be
located on your computer in order to be imported.

l To project resources folder Select this to automatically import any extra files to the
Resources folder in your project.

l To folder Select this if you want to import the extra files into a specific folder, such
as a subfolder under Resources, or even in a different folder in the Content Explorer.
Then use the field below to choose the folder.

TABLES
n Leave table styles as is This imports tables in a plain format with no styling.

n Apply a selected table stylesheet to all imported tables This lets you select an existing
Flare table stylesheet and apply it to all imported tables. That way, the imported tables
will automatically have the look and feel associated with that table stylesheet.

REIMPORT
n Link generated files to source files Enable this if you want to continue editing in

Markdown and reimport as needed. Deselect it if you want to edit the imported files in
Flare Desktop going forward, severing the connection to the source files.

n Auto-reimport before generate output If you selected “Link generated files to source
files,” you will likely make future content changes in the source files. When you make
such changes, the source files need to be reimported into the project so that they can
be included in the output. You have the option of reimporting the files manually.
However, you can use this option instead and let Flare Desktop reimport the files
automatically when you attempt to build output.

6. Click Finish, then Accept.
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Markdown Import Editor—Import and Re-Import
If you add a Markdown import file (see "Adding a Markdown Import File" on page 114) or if you have
previously imported Markdown files using the wizard, a file is added to the Imports folder in the
Project Organizer.

When you double-click this file, it opens in the Markdown Import Editor. This editor contains most
of the same fields and options as the Import Markdown Wizard.
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After completing or changing any of these fields, you can click Reimport in the toolbar.

NOTE A link icon displays on tabs in the XML Editor next to file names that are imported
from and linked to another file or Flare project. However, if you are also using the built-in
source control technology, the source control icons have a higher precedence and will
therefore be displayed instead.
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Adding a Markdown Import File
The following steps show you how to add a Markdown import file, which is used to import
Markdown documents into a project. If you go through the Import Markdown Wizard (Project >
Import > Markdown Documents), this file is created automatically and added to the Imports folder
in the Project Organizer; you do not need to do this separately.

How to Add a Markdown Import File to a Project
1. Open a project.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Project > New > Import File > Add Markdown Import File.

n Right-Click In the Project Organizer, right-click on the Imports folder and from the
context menu select Add Markdown Import File.

The Add File dialog opens.

3. In the File Type field at the top, make sure Markdown Import File is selected.

4. In the Source area, choose to create the new file based on a template or an existing file.

n New From Template Choose either a factory template file or one of your own custom
template files as a starting point. The new file will take on all of the settings contained
in the template. If you want to use the factory template provided by Flare Desktop,
expand the Factory Templates folder and click on a template file. If you want to use
your own custom template file, expand the appropriate folder and click on a file. For
more information about templates, see the Help system.

n New From Existing Choose an existing file of the same type as a starting point for your
new file. As with template files, your new file will take on all of the settings contained in
the file you select. To use this option, click , use the Open File dialog to find a file, and
double-click it.

5. (Optional) If you want to place the file into a subfolder previously created in the Content
Explorer or Project Organizer, in the Folder field click and select the subfolder. Otherwise,
keep the default location.

6. In the File Name field, type a new name for the import file.
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7. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click and select the conditions you
want to apply. Click OK.

8. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the
dialog. Next to the File Tags field, click and select the file tags you want to apply. Click OK.

9. Click Add. The import file is added to the Imports folder in the Project Organizer. The
Markdown Import Editor opens to the right.

NOTE Flare Desktop fully supports CommonMark for Markdown imports. Results of
importing other Markdown flavors may vary.
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Opening a Markdown Import File
The following steps show you how to open a Markdown import file that you have added to a
project. You can then use this file to create topics by importing Markdown documents into the
project. See "Importing Markdown Files" on page 98.

How to Open a Markdown Import File From the
Quick Launch Bar
The Quick Launch bar lets you search for any Flare Desktop file or command. It is located in the
upper-right corner of the interface. You can press CTRL+Q on your keyboard to move focus to the
Quick Launch bar so you can begin typing.

1. In the Quick Launch bar, type a few letters of the name of the file you want to open. Any
available results appear in a drop-down list.

2. From the list, click the name of the file.
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How to Open a Markdown Import File From the
Project Organizer

1. Open the Project Organizer.

2. Double-click the Imports folder. The Markdown import files in your project are displayed.

3. Double-click the import file that you want to open. The Markdown Import Editor opens to the
right.

What’s Noteworthy?

NOTE Flare Desktop fully supports CommonMark for Markdown imports. Results of
importing other Markdown flavors may vary.
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CHAPTER 8

Importing FrameMaker
When importing and moving from Adobe FrameMaker to Flare Desktop, you should do some
planning before you start to get the best results.

This chapter discusses the following:

General Information for FrameMaker 119

How to Import FrameMaker Files 146

Other Activities and Information for FrameMaker 161
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General Information for FrameMaker
There are various pieces of general information you should know if you plan to use this feature.

Flare Desktop and FrameMaker
Flare Desktop is different than Adobe FrameMaker, not just because it's a different product, but
because Flare Desktop thinks about content differently than FrameMaker.

In FrameMaker, you use a book with files to define your content. The smallest chunk of information
is typically the file, or chapter. You assemble a group of files into a book, which is your deliverable.
You can use Flare Desktop the same way, in that you can open a topic and write a 50-page Chapter
4, but the real power of Flare Desktop will be missed.

In Flare Desktop, you don't work initially with chapters; rather, you work with topics. Similar to
FrameMaker, you assemble the topics into the deliverable, but you will have many more topics than
you had chapters in FrameMaker.

Topics are the unit of content that you should be working with in Flare Desktop. They are usually 2
to 4 pages of text, including any graphics. In most cases, topics will probably map to the headings
(Heading 1, Heading 2, and so on) in your FrameMaker files.

Not all the information in every heading section should be a topic, though. For example, the
information in your heading level 4s may not be able to stand on their own—this information may
need the context of the information in the heading level 3 above it to make sense to the reader.

There are no hard and fast rules about the size of the chunks of information and how to break it up.
In general, a topic should be able to stand on its own. This is where knowing the structure of your
FrameMaker files is going to help you a lot.
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Before You Import
The import process will require less work overall if you prepare your files before you start. Just to
be safe, make a backup of all FrameMaker files first.

Special Markers
If you are used to importing your FrameMaker documents into Quadralay WebWorks, you may have
used special markers in FrameMaker when doing so. You can continue doing the same for
importing into Flare Desktop. All special markers supported by WebWorks are also supported by
Flare Desktop. The following are some of the more common types of markers.

n Filename This marker lets you control the file names given to the new topics that are created
from the imported documents. It is highly recommended that you use this marker. See
"Specifying Custom File Names for FrameMaker Imports" on page 166.

EXAMPLE You have a place in a FrameMaker document that is using the Heading 1
style and contains the text "All About Rabbits." You want a new topic to be created at
that point when you import the document. However, you also want to make sure that
the file name for that new topic is simply "Rabbits." Therefore, you open the
FrameMaker document and insert a filename marker at that heading, using the text
"Rabbits" for the marker.

When you import the FrameMaker document, you select to split new topics on
certain styles, including the Heading 1 style. After the import is finished, one of the
topics created is named "Rabbits.htm."

n Hyperlink If you are importing Adobe FrameMaker documents and you have created
hyperlinks by using "Specify Named Destination" and "Jump to Named Destination" markers,
Flare Desktop will automatically convert them to links in your project. See "Creating
Hyperlinks in FrameMaker Source Documents" on page 170.

n Topic Alias A topic alias marker is a special marker that you can insert into your FrameMaker
source content wherever you want a new context-sensitive Help (CSH) identifier to be created
in Flare Desktop (after you import the FrameMaker document). After the developer "hooks"
the CSH identifier with the appropriate user interface element in the application, that
imported FrameMaker content will display when a user opens the CSH in the application's
user interface. See "Creating Topic Alias Markers in FrameMaker for CSH" on page 176.
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Cleanly Formatted FrameMaker Files With No Style
Overrides
The more your FrameMaker files consistently use defined styles, the more smoothly the import
process will be. Use character, paragraph, and table formats consistently and with no manual
overrides.

Character Tags

If you hand-bolded text throughout your book, but the bold isn't a character style, it may be worth
your while to create a Bold character style and apply it to all instances of hand-bolded text.

Paragraph Tags—Numbered Lists

FrameMaker requires you to create two distinct paragraph tags to handle numbered lists. Because
Flare Desktop uses standard HTML code for ordered lists and list items, content developers
frequently choose not to take the extra steps to create distinct paragraph styles to handle list
numbering. Because FrameMaker handles list numbering using paragraph tags, Flare Desktop
converts those tags to the to the standard p style during the import. You then apply the desired
ordered list and list item tags to the existing numbered steps in Flare Desktop.
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EXAMPLE In FrameMaker, you must create two distinct paragraph tags to handle
automatic list numbering—one tag to apply to the first step in the list and another tag to
apply to the remaining steps.

Because Flare Desktop uses standard HTML code (where an ordered list starts with the
<ol> tag and each list item starts with the <li> tag), there is no need to create distinct
paragraph styles to handle list numbering. You simply apply the desired numbered list
format using the quick list drop-down menu shown below.
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Once the list numbering is set, you don't need worry about it again. The example below
shows you a simple numbered list in the Flare Desktop XML Editor:

The Flare Desktop Text Editor lets you see how ordered lists and list items are formatted in
HTML:

If you want to map numbered lists from FrameMaker to a paragraph style in Flare Desktop, the
option is available. Before importing your FrameMaker document into Flare Desktop, create
comparable p styles in the Flare Desktop stylesheet and ensure that those styles are set to use the
appropriate mc-auto-number-format command.

Create This Style in
Flare Desktop

mc-auto-number-
format To Map It to This FrameMaker Paragraph Tag

p.Step1 {n=1} Step1 (or your equivalent)
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Create This Style in
Flare Desktop

mc-auto-number-
format To Map It to This FrameMaker Paragraph Tag

p.StepNext {n+} StepNext (or your equivalent)

The next step is to import your FrameMaker document into Flare Desktop. During the import
process, you can map your FrameMaker paragraph tags to the corresponding tags in Flare
Desktop.

NOTE The import process does not support mapping numbered lists from FrameMaker to
CSS list item li styles.

Logically Structured FrameMaker Files
The more logically you structure the information in your FrameMaker files, the easier the
information will be to work with in Flare Desktop.

EXAMPLE The information tagged Heading 1 should all share the same kind of
information.

Let's say you have the following:

H1: Opening Files

H3: Editing Files

H2: Saving Files

H4: Printing Files

H3: Archiving Files

These are probably all first-level headings and should be moved to be at the same level.
You can do this in FrameMaker or you can use an outlining FrameMaker utility called
Enhance, available at http://www.sandybrook.com.
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Consistently Use and Apply Paragraph, Character, and
Table Formats
Over time, it's easy for FrameMaker files to include many formats, some used and some not. It's
also easy to have several formats that look identical and serve the same purpose. This can cause
confusion after importing into Flare Desktop.

You should delete the unused formats in your FrameMaker files. You can do this manually, or use
tools like the following to help.

To Delete Use This Tool Available From

Unused Character
Formats

Character Tools http://www.siliconprairiesoftware.com/

Unused Paragraph
Formats

Paragraph Tools http://www.siliconprairiesoftware.com/

Unused Table
Formats

Table Tools http://www.siliconprairiesoftware.com/

Make sure you understand how your files were designed. It's possible that you or someone else
tagged different kinds of information with tags that look identical. You may not want to undo this.

If you have a lot of identical formats in your FrameMaker files and they serve no purpose, you
should consolidate these.

To help you identify identical tags, it might be useful to list all tag settings. Table tools, Character
Tools, and Paragraph Tools, listed above, will create these lists.

After you identify the formats you want to change, you can go to the following website and get
FindChangeSpecial:

http://www.frameexpert.com/plugins/findchangespecial/index.htm

You can find and change format names in FrameMaker, so this tool is not essential, but it makes
the process faster.

After the import process, you may still need to clean up the formats in Flare Desktop. If so, you
should utilize Flare Desktop's analysis tool. It can show you unused styles, identical styles, and
other issues in your stylesheets. You can delete, rename, and modify your imported files based on
the analysis.
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All Cross-References and Referenced Files Need
Targets
To import your files, Flare Desktop (and FrameMaker) should be able to find all the files used. In
FrameMaker, this is pretty easy—generate/update your book so it finds all the files the book. Even if
you're only going to import one file from a book, this lets FrameMaker know where everything is and
how to find it.

If FrameMaker reports it cannot find files or cross-references, sort this out before you start your
import in Flare Desktop.

Update TOCs
If you are importing a book file that has a book-level table of contents (TOC), the TOC is used to
create a Flare TOC. This saves you a lot of time and effort in re-creating your FrameMaker TOC.

Before you start the import in Flare Desktop, make sure the FrameMaker book-level TOC includes
the headings you want in the eventual Flare TOC. After you import into Flare Desktop, you can add
topics to the Flare TOC, but making sure the FrameMaker TOC is correct saves you work after the
import.

Distiller Settings for Importing Graphics
Selecting the right import options in Flare Desktop is half the process in getting graphics that look
good. The other half is selecting the correct Adobe Distiller options.

Why the correct Distiller options? Because Flare Desktop uses Distiller to convert graphics from
FrameMaker. This ensures the best quality graphics when you import into Flare Desktop. Therefore,
it’s important to get the settings right in Distiller before you start the import process.

Open Distiller on your computer, find the Images settings, and set all Downsampling to Off or None.
This prevents the Distiller from reducing the number of pixels in your graphics, making the resulting
graphic look much cleaner. The following example shows Distiller 8 but the same settings can be
found in other versions of Distiller. For more information about Distiller, please refer to its
documentation.
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When you’re done, save the Distiller settings as a .joboptions file. When you return to the Distiller
interface, make sure you select the .joboption file that you just created.

When you close Distiller, it automatically uses the settings last selected when it was closed. So
make sure you select the .joboption file that you created before you close it.
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As You Import
All of your file preparation is going to pay off in the import process. This section assumes you've
followed the best practices in the previous Quick Start topics ("Flare Desktop and FrameMaker" on
page 119 and "Before You Import" on page 120). You should have clean FrameMaker files that can
locate all linked files.

Pay Attention and Be Patient
If you rush into opening the Import FrameMaker Wizard, specify a FrameMaker file, and click Finish,
you're likely to hate the results.

The import process requires that you make decisions about what you want, based on what you
have. Because the structure of the information in FrameMaker files can vary wildly, pay attention to
the decisions you're being asked to make and take the time to make them.

Try It Several Ways
Because Flare Desktop offers you a lot of options on import, you may be uncertain what you need
to select and why. At the end of the import process, we show you a preview of what your files look
like. Take the time to scroll through the results and look at what happened.

If what you see is not what you wanted, click Cancel and try other options. Rinse and repeat until
what you see in the preview looks like what you want. We provide the preview so you can make an
informed decision about your content before you bring it into Flare Desktop. Use that option and
don't be afraid to cancel many times if needed to get what you want.

Slice Your Information Into Reasonable Chunks
The New Topics Styles page in the Import FrameMaker Wizard is one of the most important places
to stop and think when you are importing FrameMaker files into Flare Desktop.

What you're doing is telling Flare Desktop that you want your FrameMaker files chopped into topics,
based on the paragraph formats you move to the right side of the screen. This is where the logically
structured documents that you prepared will pay off.
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EXAMPLE In the example below, Flare Desktop will make topics out of sections that start
with BookTitle, ChapterTitle, Heading1, and Heading2. No other formats will be used to
create topics.

At the end of the import process, carefully review the topics to see if the formats you selected are
the information chunks you want. If they are too large or too small, cancel and select other formats
to see if you like those better.
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Use Special Settings When Importing Graphics
Technical manuals typically use many graphics. It’s important these come through the conversion
process as clean as possible, and you can use special settings on the Options page of the Import
FrameMaker Wizard to help things along.

When you import, you have a few options for graphics. What you select depends on what you want
to do and how your FrameMaker files are set up. The result also depends on settings in the Adobe
Distiller. See "Distiller Settings for Importing Graphics" on page 126.

n If your document contains graphics with callouts, you can select one of three options to
determine how the images are imported.

l Generate Images Without Callouts If the anchored frame contains an image along with
callout text, the original image is imported without the callout text. You might select this
option if you have resized the image in FrameMaker. With this option, the imported
image is likely to be of a higher quality than it would be otherwise. You can then add a
callout to the image once it is inside Flare Desktop.

l Generate Images With Callouts If the anchored frame contains an image along with
callout text, Flare Desktop creates a PROPS (i.e., properties) file along with the image file
when that document is imported. This means that you can open those image files in
MadCap Capture to edit those callouts after the import process is completed.
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EXAMPLE If you import anchored frame images and tell Flare Desktop not to
include the callouts, your imported image files will look something like this in
Windows Explorer.

On the other hand, if you import the same images and tell Flare Desktop to
include the callouts, it will look something like this in Windows Explorer.

NOTE Some FrameMaker elements—such as arcs and nested frames—are not
supported with this option.

l Generate Flattened Images If the anchored frame contains an image along with callout
text, a new flattened image will be created as a result. The callout is included, but you
cannot edit it.

n To get the best resolution in the graphics after the import, clear the Preserve Image Size
check box. If you select this option, the original image is imported. However, the <img> tag is
modified in the imported file to closely reflect the height and width of the image in the
FrameMaker document. If you do not select this option, the <img> tag is not modified in the
imported file. Instead, the image is referenced at 100% of its original value. You might then
need to manually resize the image in Flare Desktop. But this will give you the cleanest looking
graphic because it wasn’t reduced in size in the import process. For more information about
resizing your graphics in Flare Desktop, see the Help system.
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Like so many options when you import, review the graphics in the Preview before you commit to the
import. Make sure the graphics look the way you want. If not, click Cancel and change the options.
Also understand that some cleanup may be required, so factor that into your time estimates.
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Preserve FrameMaker Styles
If you have a robustly styled FrameMaker file that you like, and this is your first FrameMaker import,
you probably want to preserve FrameMaker styles on import.

This serves two functions: (1) It makes your Flare documents look very similar to your FrameMaker
documents, and (2) it creates a template that you can easily reuse in future projects. While it may
be some work up front, it results in less work down the line—always a good practice.

NOTE If you select this import option, you will get a lot of "child" formats in your eventual
stylesheet. The names look like h1.Heading1 or h2.Heading2, where the part after the
period comes from the style names in your FrameMaker files. These formats inherit some
or all of their formatting from the parent (h1, h2, and so on) style.

Define Your Styles If You are Not Using an Existing
Stylesheet
If you opted to preserve FrameMaker styles, you can edit the styles to look as you want them before
you finish the import. Click the Conversion Styles button if you want to change the formats.
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You do not have to make the changes to the formats here—you can always do it after you import
using the Stylesheet Editor, but it will seem easier to do it now. Your content will come through
looking more like you expect.
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Map and Create Cross-Reference Formats
Most technical material includes a lot of cross-references. This is a great practice because it helps
the reader know where related information is in the manual. Flare Desktop has a fairly robust cross-
reference feature set.

You have two ways of managing cross-references: standard mapping and preservation styles
conversion.

Using the Standard Mapping During Import

This is in the Import FrameMaker Wizard, on the Cross-References page. This setting overrides any
other settings you may use. The downside to using this area is that you have little control over the
exact cross-reference structure. It’s best if your cross-references are heading and page style
references. You can always change them later.
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Using the Frame Styles Conversion Settings

On the Stylesheet page of the Import FrameMaker Wizard, you can click the Conversion Styles
button if you are preserving FrameMaker styles. This opens the Import Styles Editor, which you can
use to change the cross-reference formats in your FrameMaker files, mapping them to exactly what
you want in Flare Desktop. This is a better method if you have a lot of unique cross-reference
formats, such as Step # or other references.

When you expand the Cross-Reference node, you see the cross-reference formats in your
FrameMaker document(s). You can specify how these look when they come through the
conversion.
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Conversion Table

The following table will help you understand how and what you are converting.

Command Description Similar to FrameMaker’s Format

{b} Start bold text Managed in Character formats

{/b} End bold text Managed in Character formats

{bg} Start new background color None

{/bg} End background color None

{color} Start new text color Managed in Character formats

{/color} End text color Managed in Character formats

{default} Reset all font changes [default]

{ext} File extension None

{family} Start new font family None

{/family} End font family None

{file} File name, including extension [fullfilename]

{filename} File name, without extension [filename]
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Command Description Similar to FrameMaker’s Format

{h1} Text of first heading 1 paragraph in
topic

None, although the running
header/footer system variable
comes close

{h2} Text of first heading 2 paragraph in
topic

None, although the running
header/footer system variable
comes close

{h3} Text of first heading 3 paragraph in
topic

None, although the running
header/footer system variable
comes close

{h4} Text of first heading 4 paragraph in
topic

None, although the running
header/footer system variable
comes close

{h5} Text of first heading 5 paragraph in
topic

None, although the running
header/footer system variable
comes close

{h6} Text of first heading 6 paragraph in
topic

None, although the running
header/footer system variable
comes close

{i} Start italic text Managed in Character formats

{/i} End italic text Managed in Character formats

{page} Page number [pagenumonly]

{pagecount} Page count
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Command Description Similar to FrameMaker’s Format

{pageref} Context-sensitive page reference
automatically adjusts from a page
number to "above," "below," "next,"
or "previous."

None

{paranum} The autonumber text of
bookmarked paragraph The
bookmark is automatically added
to the heading when you insert the
cross-reference.

[paranum]

{paranumonly} The autonumber only of
bookmarked paragraph The
bookmark is automatically added
to the heading when you insert the
cross-reference.

[paranumonly]

{paratext} Text of bookmarked paragraph The
bookmark is automatically added
to the heading when you insert the
cross-reference.

[paratext]

{paraxml} Text and markup of bookmarked
paragraph The bookmark is
automatically added to the heading
when you insert the cross-
reference.

None

{path} File path None

{size} Start new font size Managed in Character formats
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Command Description Similar to FrameMaker’s Format

{/size} End font size Managed in Character formats

{sub} Start subscript text Managed in Character formats

{/sub} End subscript text Managed in Character formats

{sup} Start superscript text Managed in Character formats

{/sup} End superscript text Managed in Character formats

{title} Title of document None

{u} Start underlined text Managed in Character formats

{/u} End underlined text Managed in Character formats

{url} File path, URL syntax None, but HTML marker is close

Remember, when you import cross-references, they show the page number from FrameMaker. Until
you put the topics together into a TOC and create a target in Flare Desktop, the topics know nothing
about pages and page numbering, except within a single topic.
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Map All Your FrameMaker Styles to Those in Your
Stylesheet
When you reach the import pages for mapping your existing FrameMaker styles to Flare styles,
make sure you map all of them. You can map paragraph styles, character styles, and cross-
reference styles.

Unmapped paragraph styles come through as p.whateverthestylenamewas, unmapped character
styles come through as span.whateverthestylenamewas, and unmapped cross-reference styles
come through as MadCap|xref.whateverthenamewas. This may result in lots of formats you did not
actually want in the stylesheet and can take a lot to clean up. It is better to control the mapping up
front and reduce the cleanup afterwards.

EXAMPLE You might have a paragraph style called "ChapterTitle." When you import this
style, you might want it to be mapped to an h1 style in Flare Desktop. Therefore, if you map
it to h1, the result will be a style called h1.ChapterTitle. If you do not map it, the result will
be a style called p.ChapterTitle.
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After You Import
After you clean up your source files and import into Flare Desktop, you may need to clean up or re-
create certain elements.

Set Up Your Page Layouts
Master pages from FrameMaker are not converted in Flare Desktop. You need to re-create them as
page layouts. The good news is that page layouts are more flexible than master pages in
FrameMaker. For example, FrameMaker master pages do not allow different sized pages in the
same file.

Flare Desktop lets you have many pages defined in page layouts, and they can be different sizes.
For example, this lets you have an 8 x 11 page layout that includes an 11 x 14 page, which allows
for the fold-out schematic that you need in the middle of a chapter.

You can also have multiple sets of page layouts, something that FrameMaker does not allow. This
lets you define one set of page layouts for the 8 x 11 PDF book that you put on your website for
customers to download. You can also define 7 x 9 page layouts for the book you will send to the
printer that needs to fit in the product box.

Reference Pages
There are no equivalents to reference pages in Flare Desktop. The formatting and other tasks you
are used to performing are done in the Stylesheet Editor, the Page Layout Editor, or both.
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Organize Your Files
After you import, any graphics in your FrameMaker files are put in the same folder as your
converted FrameMaker files. This looks messy and probably isn't what you wanted. You can easily
fix this.

In the Content Explorer, click the Show Files button .

After you click the Show Files button, a two-pane view opens. You can expand your folders or create
a new folder by clicking the New Folder button .

CHAPTER 8  143



On the right side, select one or more files you want to move. Drag them to the folder on the left
where you want to store them. The Resources\Images folder is the default location for new images
that you create in Flare Desktop, so you may want to drag all of your graphic files to that folder (you
may need to manually create the "Images" subfolder first). All of the standard Windows multi-select
options are available.

You are prompted to update links when the files are moved. Make sure you click Update so that
Flare Desktop knows where these files have been moved to and how to find them.

Move and Resize Your Graphics
Your graphics came through but, as with any conversion, there will be some tweaking to get them
placed exactly where you want them, especially if your graphics were in the left margins in
FrameMaker.

There are no anchored frames in Flare Desktop. To select a graphic, right-click it and choose Select.
You can also right-click the image and select Image Properties to format and position the graphic
the way you want it; you can also right-click and use the Text Wrap context menu and position
images absolutely by dragging them around. For more information see the topics "Using Floats for
Positioning Elements" and "Using Absolute Positioining on Elements" in the Help system.
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Reuse Your Stylesheet in the Next Project
The next time you need to import another FrameMaker project, all the time and work you put into
perfecting your stylesheet will pay off.

During your next import process, browse and select the stylesheet you already like. This reduces all
the effort in defining and mapping styles. All you have to do is map styles and account for any new
FrameMaker formats not mapped or created in your stylesheet.

Reuse Your Import File
When you finish importing FrameMaker documents, an import file is created and stored in the
Project Organizer in Flare Desktop. This file contains all of the settings ("rules") that you entered in
the Import FrameMaker Wizard when you imported the documents. If you need to reimport the files,
you can simply open this file so that you don't have to redo all of your settings. You can also make
copies of this file and tweak it for importing other FrameMaker books and files (i.e., remove
selected files from the Source Files list and add other files that you want to import with the same
rules).

What’s Next?
Now that you've completed the first step (creating a project), you can add more topics, create
snippets, develop tables of contents, edit targets, and work your way through all of the other steps
that are part of producing online and/or print-based output.
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How to Import FrameMaker Files
1. Select Project > Import > FrameMaker Documents.

2. Select Import into a new project or Import into this project (if you already have a project
open). If it is a new project, enter a project name, and select a folder location (if different from
the default) and primary output type. Then click Next.

3. Click .

4. Find and select the files you want to import. You can hold the SHIFT key to select a range, or
you can hold the CTRL key to select individual items. When you are finished, click Open.

You can select BOOK, FM, or MIF files.

TIP When possible, it is recommended that you select a Adobe FrameMaker BOOK
file for import and let Flare Desktop locate and import all the associated document
files within the Adobe FrameMaker book.

5. (Optional) Use other options on the page as necessary. Then click Next.

Option Description

This opens the file that is selected in the list.

Link
Generated
Files to
Source Files

This creates a connection between the original files and the files that are
created as a result of the import. This is useful if you want to continue
editing the content outside of Flare Desktop, instead of editing in the
Flare project. Flare Desktop recognizes when changes have been made
to the source documents and reminds you to reimport the documents to
ensure the Flare project also reflects the changes. If you use this option,
a link icon is added to the top of a linked file in the Flare Desktop
interface. This lets you know that you need to edit the source file, rather
than editing this file. If you remove the connection to the source file, this
icon no longer displays on the file. Please note that if you have bound the
project to source control, the icons used for source control take
precedence over the link icon.
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Option Description

This removes the selected file(s) from the list.

This moves the selected file higher in the list (if you have more than one
file to import). The file at the top is used for the name of the content
folder holding the imported topics in Flare Desktop. Also, the order
determines how the imported files are arranged in the Flare TOC that is
created as a result.

This moves the selected file lower in the list (if you have more than one
file to import).

6. (Optional) Split the FrameMaker documents into smaller topics during the import based on
styles. Double-click any of the styles on the left, moving them to the right. Then Click Next.

EXAMPLE If you have a style called "Heading 2" in your FrameMaker documents, you
might want new topics to be created whenever Flare Desktop finds a Heading 2 style
in a document. So you would double-click Heading 2 and move it to the right side of
the page.

7. (Optional) Use any options to further customize the import. Then click Next.

n Add "Topic Continued" links when appropriate Select this option to place a "Topic
Continued" link at the bottom of pages when a long topic has been split into multiple
ones.

n Add "Topic Continued From" links when appropriate Select this option to place a "Topic
Continued From" link at the top of continued pages when a long topic has been split
into multiple ones.

n Cross-Reference Format Use this field to specify the format for the "Topic Continued"
and "Topic Continued From" links. Flare Desktop provides a cross-reference format for
you—(continued in {title}) or (continued from {title}). With this cross-reference format,
the link contains the words "continued in" or "continued from" within parentheses,
followed by the text of the first paragraph in the connected topic. If you do not want the
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link to use that particular text, you have a couple of options. First, in Flare Desktop, you
could manually enter a heading in each topic that is connected to another topic
included in the split. That text will be used in the link instead (after you update the
cross-references in Flare Desktop). Another option is to modify the format by clicking
the Edit button.

l Edit If you want to modify the cross-reference format provided, click this button,
which opens the Cross-Reference Format dialog.

n Split Long Topics Select this option if you have long sections in your source
documents and want to make sure that they are converted to multiple topics (rather
than one very long topic).

l Threshold Enter the maximum number of characters to be converted to a topic
before a new topic is created. Flare Desktop will break the topic at the nearest
paragraph to the threshold value. That way, a new topic will not start in the middle of
a sentence or word, but at the beginning of a paragraph.

n Avoid Creating 'Empty' Topics Select this option if you want to ensure that new topics
are not created when large sections are found in the FrameMaker documents without
any content.

l Threshold Enter the maximum number of empty character spaces allowed in a
topic. If this number is exceeded, Flare Desktop will not create a new topic from that
empty space.

n Anchored Frames With Images You can use this area to specify how Flare Desktop
should handle anchored frames that contain images as well as other content (e.g., text
callouts).

l Generate Images Without Callouts If the anchored frame contains an image along
with callout text, the original image is imported without the callout text. You might
select this option if you have resized the image in FrameMaker. With this option, the
imported image is likely to be of a higher quality than it would be otherwise. You can
then add a callout to the image once it is inside Flare Desktop.

l Generate Images With Callouts If the anchored frame contains an image along with
callout text, Flare Desktop creates a PROPS (i.e., properties) file along with the
image file when that document is imported. This means that you can open those
image files in MadCap Capture to edit those callouts after the import process is
completed.
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EXAMPLE If you import anchored frame images and tell Flare Desktop not
to include the callouts, your imported image files will look something like
this in Windows Explorer.

On the other hand, if you import the same images and tell Flare Desktop to
include the callouts, it will look something like this in Windows Explorer.

NOTE Some FrameMaker elements—such as arcs and nested frames—are
not supported with this option.

l Generate Flattened Images If the anchored frame contains an image along with
callout text, a new flattened image will be created as a result. The callout is included,
but you cannot edit it.
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n Preserve Image Size This option affects how the size of imported images are handled.

l Option Selected The original image is imported. However, the <img> tag is modified
in the imported file to closely reflect the height and width of the image in the
FrameMaker document. This is done regardless of whether you are importing linked
or embedded images from FrameMaker documents.

l Option NOT Selected The <img> tag is not modified in the imported file. Instead, the
image is referenced at 100% of its original value.

n Auto-reimport before 'Generate Output' If you selected “Link Generated Files to Source
Files” earlier in the wizard, you will likely make future content changes in the source
files. When you make such changes, the source files need to be reimported into the
project so that they can be included in the output. You have the option of reimporting
the files manually. However, you can also tell Flare Desktop to do this for you
automatically, so that you do not have to. Select this option if you want Flare Desktop
to automatically reimport files when you attempt to build output.

n Approximate Filename Length Enter the maximum number of characters to use for
naming new topic files that are automatically created after splitting a long topic. The
default is 24.

n Enable 'Passthrough' Markers Select this check box to include a check mark if you have
created passthrough markers in your FrameMaker source documents.A passthrough
marker is a special marker that you can insert into your FrameMaker source content
when you have information or code that you plan to import to Flare Desktop and want
left alone (or "passed through," leaving it exactly as you have authored it, rather than
processing it). A passthrough marker can be just about anything, as long as supports it
in the XHTML code.You can specify how the marker content should be treated when
the FrameMaker document is imported. The first option is that you can import the
marker content as regular text (which is the default setting). The second option is that
you can import the marker content as an XML fragment (e.g., the first part of a bold
tag—<b>—but not the second part). The third option is that you can import the marker
content as a complete XML tag.  You might use a passthrough marker for various
reasons, such as for importing a marker as XHTML or JavaScript code.
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EXAMPLE You plan to import some FrameMaker documents to Flare Desktop
and you have locations in those documents where you want to link to CHM
files. The problem is that FrameMaker does not allow you to create links to
CHM files in such a way that those links can then be imported into another
software application.

Therefore, you create a passthrough marker in the FrameMaker document,
providing the beginning "href" tag and path to the CHM file. Like this:

Then you create a second passthrough marker, providing the end tag for the
link. Like this:

When you import the FrameMaker document(s), you can specify that the
passthrough markers should be imported as XML fragments. In Flare Desktop,
the link to the CHM file will look and work as it should.
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n Passthrough Marker Format After you enable passthrough markers, click the down
arrow in this field and select the type of format that you want to use for the import.

l text The marker content will be imported as regular text (default setting).

l fragment The marker content is imported as an XML fragment (e.g., the first part of
a bold tag—<b>—but not the second part). If you select this option, you will probably
need a second marker in the FrameMaker document to complete the XML tag.

l xml The marker content is imported as a complete XML tag.

n Convert equations to MathML Select this option to convert MathFullForm equations
(the FrameMaker-specific format) to MathML (the web standard and Flare format). If
you disable this option, equations from FrameMaker are converted to images.

n Convert Table Styles If you have tables in your FrameMaker documents that you have
formatted in a certain way, select this check box if you want to create matching table
styles as a result of the import. In the Flare project, the new table styles will be named
after the format named applied to the table in FrameMaker (e.g., "Format_A.css,"
"Format_B.css," and so on). You can rename these table stylesheets in Flare Desktop
after the import finishes. Even if you do not use this mapping feature, the table
formatting still comes across when you import the documents. The only difference is
that table stylesheets make it easier to maintain the formatting of your tables within
Flare Desktop.

n Reimport Table Styles This option displays only if you are working in the Import Editor,
rather than the wizard. This option is useful after you have already imported
FrameMaker documents and converted the formatting in your tables into at least one
table stylesheet in Flare Desktop. You can use this option to determine whether tables
should be imported again as table styles when you reimport. You might want to keep
this check box selected for some reimports, but other times you might want to deselect
it when reimporting.
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EXAMPLE You want the formatted tables in your FrameMaker documents to
be converted to table styles when you perform the initial import into a Flare
project. Therefore, in the import wizard, you turn on the "Convert Table Styles"
option. As a result, let's say that Flare Desktop creates a new table style and
calls it "FormatA.css."

After the initial import, you realize you want the tables to look a little different.
Therefore, in the Flare project, you modify the properties of the FormatA.css
table stylesheet.

Awhile later, let's say you want to reimport the FrameMaker documents. The
problem is that you've already changed the table stylesheet in Flare Desktop.
You probably want to keep the tweaked table style so that you don’t have to
modify it again after the import.

This is where the new "reimport" option comes into play. It determines whether
or not a second new table stylesheet will be created, based on the old look
from the tables in the FrameMaker documents.

Here's one scenario. Let's say that before you reimported the FrameMaker
documents, you selected the "Reimport Table Styles" option in the Frame
Import Editor. And during the import when you were prompted, you selected
not to overwrite the existing FormatA.css table stylesheet. In that case, Flare
Desktop keeps your tweaked stylesheet in the project, but it also creates
another table stylesheet called "FormatA1.css" that has the old look and feel.
All of the reimported content now links to the FormatA1.css stylesheet instead
of FormatA.css.

Here's a different scenario. Let's say that you perform the same steps
described above, except this time you deselected the "Reimport Table Styles"
option in the Frame Import Editor. In that case, the second FormatA1.css file is
not created. The imported content is linked to the FormatA.css table stylesheet
that you previously modified, since it already exists in the project.
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8. (Optional) Specify whether the imported topics should be associated with a stylesheet and/or
styles from your FrameMaker files. Then click Next.

n Stylesheet If you already have a CSS file that you want to associate with the imported
files, click the Stylesheet button. Then navigate to the stylesheet and select it.

n Preserve FrameMaker Styles This retains any style formatting from your FrameMaker
documents so that you can continue to use that look and feel in Flare Desktop. For
example, if you use a style called "Heading 1" in your source documents and that style
is blue, it remains blue after you finish the import to Flare Desktop and the new style is
created. Also, selecting this option affects which mapping styles are available as you
continue to make your import selections. If you select this option, you can map the
FrameMaker styles to new Flare styles that keep the name of the FrameMaker style
(e.g., Heading 1 becomes h1.Heading 1 in Flare Desktop).

n Don't Preserve FrameMaker Styles This does not keep the style formatting used in the
FrameMaker documents. For example, if you use a style called "Heading 1" in your
source documents and that style is blue, that color (and any other settings for that
style) are not kept after you finish the import to Flare Desktop. You will still have styles
associated with your content, but it will not look like it did in the source documents.
Also, selecting this option affects which mapping styles are available as you continue
to make your import selections. If you select this option, you can map the FrameMaker
styles to new Flare styles that either keep the name of the FrameMaker style (e.g.,
Heading 1 becomes h1.Heading 1 in Flare Desktop) or do not (e.g., Heading 1 becomes
h1 in Flare Desktop).
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n Conversion Styles This opens the Import Styles Editor, which lets you specify how to
convert each property of the FrameMaker styles. If you do not enter a property value,
the value from the FrameMaker document is used. If you enter a property value, it
overrides the value from the FrameMaker document. This button is used only if you
have selected "Preserve FrameMaker Styles."

EXAMPLE You might use this button, for example, if you need to change a
cross-reference format coming from FrameMaker into something more
meaningful in Flare Desktop. There are some cross-reference building blocks in
FrameMaker that do not have an equivalent in Flare Desktop. In cases such as
these, the formats are preserved after conversion to Flare Desktop. However,
the formats may therefore appear to be broken, but they are preserved to let
you know that there was some formatting in a cross-reference style that Flare
Desktop did not understand; you can then make changes to the cross-
reference style in the stylesheet. Therefore, if you already know ahead of time
that you have a cross-reference style that will need to be modified for use in
Flare Desktop, you can use the Conversion Styles button and change the cross-
reference format to something that Flare Desktop understands.

9. (Optional) Map paragraph styles from the FrameMaker documents to Flare's paragraph
styles. Then click Next.

Your FrameMaker style will adopt the name of that style. To map a style, click the style in the
FrameMaker Styles column on the left, click a style in the Flare Styles section on the far right,
and then click the Map button. If you previously elected not to preserve the FrameMaker
styles, it is recommended that you map to a standard CSS parent style—e.g., map your first-
level heading style to h1, not to h1.(FrameMaker Style).

The style is added to the Flare Styles column. When you are finished importing the
documents and the new Flare project is loaded, the content that had been associated with
the style in the FrameMaker document will now be associated with a new style that you
mapped it to.
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EXAMPLE — Preserve Styles

Let's say you have a style in your FrameMaker source document called "Heading1"
that is using Arial 14 pt and is red, like this.

Hello
During the process of importing your FrameMaker document using the Import
FrameMaker Wizard, you select the option to preserve your FrameMaker styles.

The next page of the wizard looks something like this:
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When you finish importing, the content that was associated with Heading1 in the
source document is still using Arial 14 pt and is red, just like it was before in
FrameMaker. However, the style is now called "h1.Heading1." In the world of
cascading style sheets (CSS)—which is what Flare Desktop uses for controlling the
look of content—you've created a class of the h1 style (h1 is the standard style for
first-level headings). But because you wanted to keep the look of the FrameMaker
style, Flare Desktop added it as a child under its parent, h1.

If you make any future changes in Flare Desktop to the h1 style, they will trickle down
to the h1.Heading1 child (unless the child style has explicit settings that conflict with
the parent). You can also apply style properties directly to the h1.Heading1 child. So
while it is generally a good idea to use standard CSS parent styles (such as h1) when
possible in Flare Desktop, the mapping performed in this import process—and the
subsequent creation of a child style—lets you keep the Arial 14 pt red look.
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EXAMPLE — Do Not Preserve Styles

Let's say you have a style in your FrameMaker source document called "Heading1"
that is using Arial 14 pt and is red, like this.

Hello
During the process of importing your FrameMaker document using the Import
FrameMaker Wizard, you select the option to not preserve your FrameMaker styles.

The next page of the wizard looks something like this.
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When you finish importing, the content that was associated with Heading1 in the
source document is no longer using Arial 14 pt, red. Instead, it looks something like
this.

Hello
Also, the style is now called "h1." (Keep in mind that, even if you had mapped the style
to "h1.(FrameMaker Style) in this case, the formatting would still be removed.)

So although the formatting was not retained, you were able to map to the standard
CSS style for first-level headings—h1 .

10. (Optional) Map character styles from the source documents to Flare's character styles. Then
click Next.

Your FrameMaker style will adopt the name of that style. This works the same as the feature
for mapping paragraph styles, except it has to do with character-level styles. To map a style,
click the style in the Framemaker Style column, click a style in the Flare Styles section, and
then click the Map button.

The style is added to the Flare Styles column. When you are finished importing the
documents and the new Flare project is loaded, the content that had been associated with
the style in the FrameMaker document will now be associated with a new style that you
mapped it to.
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11. (Optional) Map cross-reference (x-ref) styles from the FrameMaker documents to Flare's
cross-reference styles. Then click Finish.

In this way, you can have your FrameMaker style take on the appearance of the Flare style
that you map it to. To map a style, click the style in the FrameMaker Style column on the left,
click a style in the Flare Styles section on the far right, and then click the Map button.

The style is added to the Flare Style column. When you are finished importing the documents
and the new Flare project is loaded, the content that had been associated with the
FrameMaker style in the FrameMaker document will now be associated with a new style that
has the appearance of the style that you mapped it to.

What happens if you do not map a style? In the case of cross-reference styles, they are
automatically added as style classes under the MadCap|xref style. For example, let's say you
import a style called "PageOnly" from your source document and do not map it to anything. In
that case, it will be called "MadCap|xref.PageOnly" in the resulting project.

12. When you are finished previewing the files to be created, click Accept.

NOTE For each template page used in your FrameMaker documents, a corresponding
page layout is automatically created in your Flare project. You can use the page layouts to
configure pages for print-based output. You can then create chapter breaks for your print-
based output and assign these page layouts to the different topics in the output.

NOTE Flare Desktop supports FrameMaker 7.0 and newer versions.

NOTE A link icon displays on tabs in the XML Editor next to file names that are imported
from and linked to another file or Flare project. However, if you are also using the built-in
source control technology, the source control icons have a higher precedence and will
therefore be displayed instead.
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Other Activities and Information for
FrameMaker

In addition to the main activities, there are some other tasks you might perform regarding this
feature.

Adding a FrameMaker Import File
The following steps show you how to add a FrameMaker import file, which is used to import
FrameMaker documents into a project. If you go through the Import FrameMaker Documents
Wizard (Project > Import > FrameMaker Documents), this file is created automatically and added to
the Imports folder in the Project Organizer; you do not need to do this separately.
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How to Add a FrameMaker Import File to a Project
1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Project > New > Import File > Add FrameMaker Import File.

n Right-Click In the Project Organizer, right-click on the Imports folder and from the
context menu select Add FrameMaker Import File.

The Add File dialog opens.

2. In the File Type field at the top, make sure FrameMaker Import File is selected.

3. In the Source area, choose to create the new file based on a template or an existing file.

n New From Template Choose either a factory template file or one of your own custom
template files as a starting point. The new file will take on all of the settings contained
in the template. If you want to use the factory template provided by Flare Desktop,
expand the Factory Templates folder and click on a template file. If you want to use
your own custom template file, expand the appropriate folder and click on a file. For
more information about templates, see the Help system.

n New From Existing Choose an existing file of the same type as a starting point for your
new file. As with template files, your new file will take on all of the settings contained in
the file you select. To use this option, click , use the Open File dialog to find a file, and
double-click it.

4. (Optional) If you want to place the file into a subfolder previously created in the Content
Explorer or Project Organizer, in the Folder field click and select the subfolder. Otherwise,
keep the default location.

5. In the File Name field, type a new name for the import file.

6. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click and select the conditions you
want to apply. Click OK.

7. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the
dialog. Next to the File Tags field, click and select the file tags you want to apply. Click OK.

8. Click Add. The import file is added to the Imports folder in the Project Organizer. The Frame
Import Editor opens to the right.
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Opening a FrameMaker Import File
The following steps show you how to open a FrameMaker import file that you have added to a
project. You can then use this file to import FrameMaker documents into the project.

How to Open a FrameMaker Import File From the Quick
Launch Bar
The Quick Launch bar lets you search for any Flare Desktop file or command. It is located in the
upper-right corner of the interface. You can press CTRL+Q on your keyboard to move focus to the
Quick Launch bar so you can begin typing.

1. In the Quick Launch bar, type a few letters of the name of the file you want to open. Any
available results appear in a drop-down list.

2. From the list, click the name of the file.
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How to Open a FrameMaker Import File From the
Project Organizer

1. Open the Project Organizer.

2. Double-click the Imports folder. The FrameMaker import files in your project are displayed.

3. Double-click the import file that you want to open. The Frame Import Editor opens to the right.

What’s Noteworthy?

NOTE Flare Desktop supports FrameMaker 7.0 and newer versions.

Anchored Frames With Images in FrameMaker
Imports
When you import FrameMaker documents, you can specify how Flare Desktop should handle
anchored frames that contain images as well as other content (e.g., text callouts).

n Generate Images Without Callouts If the anchored frame contains an image along with
callout text, the original image is imported without the callout text. You might select this
option if you have resized the image in FrameMaker. With this option, the imported image is
likely to be of a higher quality than it would be otherwise. You can then add a callout to the
image once it is inside Flare Desktop.

n Generate Images With Callouts If the anchored frame contains an image along with callout
text, Flare Desktop creates a PROPS (i.e., properties) file along with the image file when that
document is imported. This means that you can open those image files in MadCap Capture to
edit those callouts after the import process is completed.
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EXAMPLE If you import anchored frame images and tell Flare Desktop not to include
the callouts, your imported image files will look something like this in Windows
Explorer.

On the other hand, if you import the same images and tell Flare Desktop to include
the callouts, it will look something like this in Windows Explorer.

NOTE Some FrameMaker elements—such as arcs and nested frames—are not
supported with this option.

n Generate Flattened Images If the anchored frame contains an image along with callout text, a
new flattened image will be created as a result. The callout is included, but you cannot edit it.
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Specifying Custom File Names for FrameMaker
Imports
If you import Adobe FrameMaker documents, you can split those documents into multiple topics
based on the styles in them. For example, you might decide to create a new topic at each "Heading
1" style in the FrameMaker document. You can also control the file names given to the new topics
that are created from the imported Imported documents. To do this, you need to insert a custom
"Filename" marker at the appropriate headings in the FrameMaker documents where new topics
will be created.

How to Specify Custom File Names for FrameMaker
Imports
Following are steps for creating these markers in Adobe FrameMaker. For more information, please
refer to the documentation provided with FrameMaker. The following steps may vary in different
versions of FrameMaker.

1. Open the FrameMaker document.

2. In FrameMaker, create the filename marker type that is required for this feature. This is a one-
time step in the document. Afterwards, you can simply select the newly created marker type
when applying it to content. To create the filename marker type, do the following:

a. In FrameMaker, select Special > Marker. The Marker dialog opens.

b. From the Marker Type field, click the down arrow and select Edit. The Edit Custom
Marker Type dialog opens.

c. In the field, replace the existing text and type Filename.

d. Click Add.

e. Click Done.

3. In the FrameMaker document, place your cursor at the heading where you want to create a
new file during the import.

4. If it is not already displayed, open the Marker dialog (Special > Marker).

5. If the filename marker type is not already displayed in the dialog, click the Marker Type down
arrow and select Filename.
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6. In the Marker Text field, enter the name you want to assign to the file (without the file
extension).

EXAMPLE You have a place in a FrameMaker document that is using the Heading 1
style and contains the text "All About Rabbits." You want a new topic to be created at
that point when you import the document. However, you also want to make sure that
the file name for that new topic is simply "Rabbits." Therefore, you open the
FrameMaker document and insert a filename marker at that heading, using the text
"Rabbits" for the marker.

When you import the FrameMaker document, you select to split new topics on
certain styles, including the Heading 1 style. After the import is finished, one of the
topics created is named "Rabbits.htm."

7. Click New Marker.

8. Save the FrameMaker document.

9. In Flare Desktop, import the FrameMaker document. When you arrive at the "New Topic
Styles" page in the Import FrameMaker Wizard or the "New Topic Styles" tab in the
FrameMaker Import Editor, select the style(s) where you inserted filename markers in the
FrameMaker document.
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Creating Drop-Down Effects in FrameMaker
Source Documents
The following steps show you how to create a new drop-down effect in a FrameMaker source
document (if you plan to import that document into Flare Desktop). After you import the document,
the drop-down effect will automatically be created in the XML Editor.
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How to Create a Drop-Down Effect in a FrameMaker
Source Document
The following steps may vary in different versions of FrameMaker.

1. Open the FrameMaker document.

2. In FrameMaker, create the two drop-down paragraph styles that are required for producing
this effect. This is a one-time step in the document. Afterwards, you can simply select the
newly created styles when specifying drop-down text. To create the two styles, do the
following.

a. In FrameMaker, select Format > Paragraphs > Designer. The Paragraph Designer
opens.

b. From the Commands field, click the down arrow and select New Format. The New
Format dialog opens.

c. In the Tag field, type PullDownButton.

d. Make sure that the Store in Catalog check box has a check mark.

e. Make sure that the Apply to Selection check box does NOT have a check mark in it
(unless you want the style to immediately be applied to the paragraph where your
cursor is placed).

f. Click Create.

g. Follow these same steps to create a paragraph style called PullDownBody.

h. Close the Paragraph Designer.

3. In the FrameMaker document, place your cursor in the paragraph that you want to serve as
the drop-down hotspot in the online output (i.e., when the user clicks that hotspot, the text
below that is identified as the drop-down body will be shown or hidden).

4. From the styles drop-down menu or from the paragraph catalog, select PullDownButton.

5. Highlight the paragraph(s) that you want to serve as the drop-down body in the online output.

6. From the styles drop-down menu or from the paragraph catalog, select PullDownBody.

7. Save the FrameMaker document.
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Creating Hyperlinks in FrameMaker Source
Documents
If you are importing Adobe FrameMaker documents and you have created hyperlinks by using
"Specify Named Destination" and "Jump to Named Destination" markers, Flare Desktop will
automatically convert them to links in your project. Following are steps for creating these
hyperlinks in Adobe FrameMaker. For more information, please refer to the documentation
provided with Adobe FrameMaker.

CHAPTER 8  170



How to Create a Hyperlink in a FrameMaker Source
Document
The following steps may vary in different versions of FrameMaker.

1. Open the Adobe FrameMaker document.

2. In Adobe FrameMaker, place your cursor at the spot to be used as the destination for a link.
This might be a heading that will become a new topic when you import the document. When a
user clicks on the hyperlink (created below), this is the content that will be displayed to end
users.

3. Select Special > Hypertext. The Hypertext dialog opens.

4. From the Command field, select Specify Named Destination.The text "newlink" is added to the
area below.

5. After the text "newlink," type a name to identify the destination (perhaps the name of the
heading).

6. Click New Hypertext Marker.

7. Locate the area that you want to serve as the hyperlink. Prepare the area to become a
hyperlink, according to the documentation provided with Adobe FrameMaker.

8. Place your cursor in the prepared hypertext area.

9. From the Command field of the Hypertext dialog, select Jump to Named Destination. The text
"gotolink" is added to the text area below.

10. After the text "gotolink," type the name that you gave to the destination marker.

11. Click New Hypertext Marker.

12. Close the Hypertext dialog.

13. Save the Adobe FrameMaker document.
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Creating Passthrough Markers in FrameMaker
Source Documents
A passthrough marker is a special marker that you can insert into your FrameMaker source content
when you have information or code that you plan to import to Flare Desktop and want left alone (or
"passed through," leaving it exactly as you have authored it, rather than processing it). A
passthrough marker can be just about anything, as long as supports it in the XHTML code.

You can specify how the marker content should be treated when the FrameMaker document is
imported. The first option is that you can import the marker content as regular text (which is the
default setting). The second option is that you can import the marker content as an XML fragment
(e.g., the first part of a bold tag—<b>—but not the second part). The third option is that you can
import the marker content as a complete XML tag.

You might use a passthrough marker for various reasons, such as for importing a marker as
XHTML or JavaScript code.
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EXAMPLE You plan to import some FrameMaker documents to Flare Desktop and you
have locations in those documents where you want to link to CHM files. The problem is that
FrameMaker does not allow you to create links to CHM files in such a way that those links
can then be imported into another software application.

Therefore, you create a passthrough marker in the FrameMaker document, providing the
beginning "href" tag and path to the CHM file. Like this:

Then you create a second passthrough marker, providing the end tag for the link. Like this:

When you import the FrameMaker document(s), you can specify that the passthrough
markers should be imported as XML fragments. In Flare Desktop, the link to the CHM file
will look and work as it should.
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How to Create a Passthrough Marker
Following are steps for creating these markers inAdobe FrameMaker. For more information, please
refer to the documentation provided with Adobe FrameMaker.

The following steps may vary in different versions of FrameMaker.

1. Open the FrameMaker document.

2. In FrameMaker, create the passthrough marker type that is required for this feature. This is a
one-time step in the document. Afterward, you can simply select the newly created marker
type when applying it to content. To create the passthrough marker type, do the following.

a. In FrameMaker, select Special > Marker. The Marker dialog opens.

b. From the Marker Type field, click the down arrow and select Edit. The Edit Custom
Marker Type dialog opens.

c. In the field, replace the existing text and type PassThrough.

d. Click Add.

e. Click Done.

3. In the FrameMaker document, place your cursor at the location where you want to insert a
passthrough marker.

4. If it is not already displayed, open the Marker dialog (Special > Marker).

5. If the passthrough marker type is not already displayed in the dialog, click the Marker Type
down arrow and select PassThrough.

6. In the Marker Text field, enter the text and/or code that you want to be included in the marker.

7. Click New Marker.

8. Save the FrameMaker document.
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9. In Flare Desktop, go through the process for importing the FrameMaker document. When you
arrive at the "Options" page in the Import FrameMaker Wizard or the "Options" tab in the
Frame Import Editor, make sure Enable 'Passthrough' Markers is selected. Then from the
Passthrough Marker Format field, select one of the options:

n text The marker content will be imported as regular text (default setting).

n fragment The marker content is imported as an XML fragment (e.g., the first part of a
bold tag—<b>—but not the second part). If you select this option, you will probably need
a second marker in the FrameMaker document to complete the XML tag.

n xml The marker content is imported as a complete XML tag.
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Creating Topic Alias Markers in FrameMaker for
CSH
A topic alias marker is a special marker that you can insert into your FrameMaker source content
wherever you want a new context-sensitive Help (CSH) identifier to be created in Flare Desktop
(after you import the FrameMaker document). After the developer "hooks" the CSH identifier with
the appropriate user interface element in the application, that imported FrameMaker content will
display when a user opens the CSH in the application's user interface.

You can use these markers as an alternative to creating the identifiers in Flare Desktop. For more
information see the Help system.

Following are steps for creating these markers in Adobe FrameMaker. For more information, please
refer to the documentation provided with FrameMaker.

How to Create a Topic Alias Marker for Context-
Sensitive Help
The following steps may vary in different versions of FrameMaker.

1. Open the FrameMaker document.

2. In FrameMaker, create the topic alias marker type that is required for this feature. This is a
one-time step in the document. Afterward, you can simply select the newly created marker
type when applying it to content. To create the topic alias marker type, do the following:

a. In FrameMaker, select Special > Marker. The Marker dialog opens.

b. From the Marker Type field, click the down arrow and select Edit. The Edit Custom
Marker Type dialog opens.

c. In the field, replace the existing text and type TopicAlias.

d. Click Add.

e. Click Done.

3. In the FrameMaker document, place your cursor at the location where you want to insert a
topic alias marker.

Usually you will place the cursor at the beginning of a heading that you want to be the start of
a new online topic in Flare Desktop.

4. If it is not already displayed, open the Marker dialog (Special > Marker).
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5. If the topic alias marker type is not already displayed in the dialog, click the Marker Type
down arrow and select TopicAlias.

6. In the Marker Text field, enter the text to be used as the topic ID.

You might simply type the same text that occurs in the paragraph heading. That way, it will be
easily identified by both you and the developer. When typing the topic ID, make sure you use
underscores between words, because spaces are not allowed (e.g., Properties_Dialog).

7. Click New Marker.

8. Close the Marker dialog.

9. Save the FrameMaker document.
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CHAPTER 9

Importing a RoboHelp Project
You can create a project by importing a RoboHelp project.

How to Import a RoboHelp Project
1. Select File > New Project > RoboHelp Project.

2. In the dialog that opens, browse for and double-click the RoboHelp project file (MPJ or XPJ
file) to be imported. The Import Project Wizard opens.

3. In the Project name field, type a name for the new Flare project that will be created after you
import the RoboHelp project.

4. In the Project folder field, either accept the default location for the new project or click to
browse for and select a folder.

5. Click Next.

6. (Optional) Select Convert all topics at once if you want Flare Desktop to immediately convert
all of your topic files to XHTML.

If you remove the check mark from the box, Flare Desktop imports the topic files as they are.
When you try to open an imported topic in Flare Desktop, a message asks if you want to
convert it to XML. Also, if this option is not selected, Flare Desktop will not import index
keywords from the source files.
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7. (Optional) Select Convert inline formatting to CSS styles if you want Flare Desktop to create
new styles based on any "local" formatting that exists in the RoboHelp project files.

EXAMPLE If you have applied bold and italic formatting to some text (without using
a style), Flare Desktop will create a new style based on that formatting.

8. Click Next.

9. Select a language for the project.

10. Click Finish. A message tells you that the project was converted successfully and will be
opened.

11. Click OK.
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CHAPTER 10

Importing a Doc-To-Help
Project
You can create a project by importing a Doc-To-Help project.

This chapter discusses the following:

How to Import a Doc-To-Help Project 181

Doc-To-Help Features and Flare Equivalents 183
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How to Import a Doc-To-Help Project
1. Select File > New Project > Doc-To-Help Project.

2. In the dialog that opens, browse for and double-click the Doc-To-Help project file (D2H file) to
be imported. The Import Project Wizard opens.

3. Click Next.

NOTE If you want to import Doc-To-Help projects to a 64-bit version of Flare
Desktop, you will need to download Microsoft Access Database Engine 2010 x64
edition. If you do not already have this add-in, Flare Desktop will prompt you to install
it from the Microsoft Download Center.

4. In the Project name field, type a name for the new Flare project that will be created after you
import the Doc-To-Help project.

5. In the Project folder field, either accept the default location for the new project or click to
browse for and select a folder.

6. Click Next.

7. If you convert Word source documents to HTML5 source files in Doc-To-Help, and then build
a target, stylesheets are created as a result and saved in the output folder. You can save
those stylesheets in a different folder and then use this page of the wizard to point to them,
bringing them into Flare Desktop in one merged CSS file.

TO SAVE DOC-TO-HELP STYLESHEETS AND SELECT THEM WHEN IMPORTING
TO FLARE DESKTOP

a. Make a backup copy of your Doc-To-Help project.

b. Open your Doc-To-Help project that contains Word source files.

c. Select or create a NetHelp target and build the output.
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d. Open the project output folder and browse to [Project Name]\NetHelp\LinksExt.

NOTE The LinksExt folder might contain several stylesheets (separate ones for
each topic), because each time a Word topic uses a style not already used in a
previous topic, Doc-To-Help creates a new stylesheet to account for it. It might
look something like this:

e. Move the LinksExt folder to a new location outside of the NetHelp parent folder,
because this folder will be overwritten when you generate output again. Then rename
the folder to whatever you want your imported stylesheet to be named.

f. In your Doc-To-Help project, click Convert Multiple Documents to HTML5 and proceed
with the wizard to convert all files.

g. Word closes the project when there are no DOC or DOCX files in the project. Therefore,
in Windows navigate to your Program Files\MadCap Software\DocToHelp folder and
double-click the DocToHelp EXE file. Then build a target to update links.

h. In Flare Desktop, import your Doc-To-Help project, and on the "Select CSS folders…"
page of the wizard, click .

i. In the dialog that opens, locate and select the folder that you moved and renamed
earlier in this process. Then finish importing the project. If the folder contains multiple
stylesheets, Flare Desktop merges them into one CSS file.

8. Click Next.

9. Select an option for how to import links. You can import links as cross-references or as
hyperlinks.

10. Select a language for the project.

11. Click Finish.
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Doc-To-Help Features and Flare
Equivalents

The following table shows many of the Doc-To-Help features and their equivalents in Flare. For a
few of these features, the settings are not imported from Doc-To-Help to Flare Desktop.

Doc-To-Help
Feature Flare Feature Notes/Limitations

Attributes Conditions Doc-To-Help allows conditions on platforms (e.g.,
all Word targets). However, Flare Desktop does not
support that feature; therefore conditions on
platforms are not imported.

Bookmarks Bookmarks

Carousel Widgets Slideshows

CodeHighlighter
Widgets

Div Tags

Collapsible
Sections

Togglers

Comments Annotations

CSS Stylesheet

Gallery Widgets Slideshows
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Doc-To-Help
Feature Flare Feature Notes/Limitations

Glossaries Glossaries and
Proxies

Glossary terms are added to a Flare glossary file.
Glossary topics are changed to include Flare
Desktop's Glossary proxy.

Flare Desktop does not support images and text
formatting in glossaries, so those elements are not
included in the import.

Groups Concepts and
Concept Links (A-
links)

Groups are similar to Flare's concepts, which can
be used for a couple of things, including the
creation of concept links (also called "See Also
links" or "A-links"). When you import a Doc-To-Help
project, groups are converted to concepts in a
couple of different ways, depending on how they
are created in Doc-To-Help:

n If you insert a group in Doc-To-Help by
dragging the topic from the Topics pane to
the Groups pane, Flare Desktop converts the
group to a concept and adds it at the very top
of the topic.

n If you insert a group in Doc-To-Help from the
ribbon, you are adding it inline, as well as
adding it to the Groups pane. Flare Desktop
converts the group to a concept and adds it
inline as well as at the very top of the topic.
This means that when you have an A-link, that
group might be listed twice in the output.
Therefore, you may need to clean up your
topics, removing the excess concepts.

If you already have a group link in Doc-To-Help, it is
imported as a concept link in Flare Desktop.
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Doc-To-Help
Feature Flare Feature Notes/Limitations

Inline Text:
Expanded, Drop
down, Pop Up

Expanding Text

Drop-Down Text

Text Popups

Keywords Index Keywords Keywords are similar to Flare's index keywords,
which can be used for a couple of things, including
the creation of keyword links (also called "K-links").
When you import a Doc-To-Help project, keywords
are converted to index keywords in a couple of
different ways, depending on how they are created
in Doc-To-Help:

n If you insert a keyword in Doc-To-Help by
dragging the topic from the Topics pane to
the Index pane, Flare Desktop converts the
keyword to an index keyword and adds it at
the very top of the topic.

n If you insert a keyword in Doc-To-Help from
the ribbon, you are adding it inline, as well as
adding it to the Index pane. Flare Desktop
converts the keyword to an index keyword
and adds it inline as well as at the very top of
the topic. This means that when you have a
K-link, that index keyword might be listed
twice in the output. Therefore, you may need
to clean up your topics, removing the excess
index keywords.

If you already have an index link in Doc-To-Help, it is
imported as a keyword link in Flare Desktop.

Lightbox Widgets Slideshows
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Doc-To-Help
Feature Flare Feature Notes/Limitations

Link Tags Bookmarks

Note Widgets Div Tags

Plain Text
Variables

Variables Flare Desktop does not support conditioned
multiple variable definitions. Those definitions are
imported as multiple variable definitions.

Related Topics Related Topics
Links

Rich Content
Variables

Snippets

Tabs Widgets Div Tags

Targets Targets Flare Desktop does not import any target settings.

Themes Skins Flare Desktop does not import any theme settings
to skins.

TOCs TOCs If a TOC is not customized, it is not imported. An
auto-generated TOC is not in the database when
you import, so it is not considered customized.
However, you can make a simple change in a TOC
(e.g., move a TOC topic up and then down, not
actually changing it). The TOC will then be
considered customized and will import correctly.
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Doc-To-Help
Feature Flare Feature Notes/Limitations

Topic Contents
Widgets

Mini-TOC Proxies Although topic contents widgets in Doc-To-Help are
similar to Flare Desktop's mini-TOC proxies, they
are not identical. Therefore, you may see some
discrepancies after the import conversion.
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CHAPTER 11

Importing CHM Files
You can create a project by importing an HTML Help (CHM) file.

How to Import an HTML Help (CHM)
File
1. Select File > New Project > HTML Help File (CHM).

2. In the dialog that opens, browse for and double-click the CHM file to be imported, then click
Next.

3. In the Project name field, type a name for the new Flare project that will be created after you
import the CHM file.

4. In the Project folder field, either accept the default location for the new project or click to
find and select a folder. Then click Next.

5. (Optional) Select Convert all topics at once if you want Flare Desktop to immediately convert
all of your topic files to XHTML.

If you remove the check mark from the box, Flare Desktop imports the topic files as they are.
When you try to open an imported topic in Flare Desktop, a message asks if you want to
convert it to XHTML. Also, if this option is not selected, Flare Desktop will not import index
keywords from the source files.
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6. (Optional) Select Convert inline formatting to CSS styles if you want Flare Desktop to create
new styles based on any "local" formatting that exists in the HTML Help file. Then click Next.

EXAMPLE If you have applied bold and italic formatting to some text (without using
a style), Flare Desktop will create a new style based on that formatting.

NOTE This may result in dozens of new style classes being generated in your
project.

7. Select a language for the project.

8. Click Finish.

9. Click OK.
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CHAPTER 12

Importing an HTML Help
Project
You can create a project by importing an HTML Help project (HHP file).

How to Import an HTML Help Project
1. Select File > New Project > HTML Help Project (HHP).

2. In the dialog that opens, browse for and double-click the HTML Help file (HHP file) to be
imported. The Import Project Wizard opens.

3. In the Project name field, type a name for the new Flare project that will be created after you
import the HTML Help project.

4. In the Project folder field, either accept the default location for the new project or click to
browse for and select a folder.

5. Click Next.

6. (Optional) Select Convert all topics at once if you want Flare Desktop to immediately convert
all of your topic files to XHTML.

If you remove the check mark from the box, Flare Desktop imports the topic files as they are.
When you try to open an imported topic in Flare Desktop, a message asks if you want to
convert it to XHTML. Also, if this option is not selected, Flare Desktop will not import index
keywords from the source files.
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7. (Optional) Select Convert inline formatting to CSS styles if you want Flare Desktop to create
new styles based on any "local" formatting that exists in the HTML Help project files.

EXAMPLE If you have applied bold and italic formatting to some text (without using
a style), Flare Desktop will create a new style based on that formatting.

8. Click Next.

9. Select a language for the project.

10. Click Finish. A message tells you that the project was converted successfully and will be
opened.

11. Click OK.
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CHAPTER 13

Importing DITA
There are various tasks involved with importing DITA files.

This chapter discusses the following:

Importing DITA Files 193

Adding a DITA Import File 198

Opening a DITA Import File 200
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Importing DITA Files
Darwin Information Typing Architecture (DITA) file content is supported in Flare Desktop. DITA is an
XML-based markup language with its own schema for authoring, producing, and delivering
technical information. It is a standard of the Organization for the Advancement of Structured
Information Standards (OASIS), and it consists of a set of design principles for creating
"information-typed" modules at a topic level and for using that content in various delivery modes.

You can import DITA files in the a few ways.

How to Import DITA Files
1. Do the following, depending on how you are importing your files:

TO IMPORT INTO A NEW PROJECT

a. Select Project > Import > DITA Document Set.

The Import DITA Wizard opens.

b. Select Import into a new project.

c. In the Project name field, type a name for the new Flare project that will be created after
you perform the import.

d. In the Project folder field, either accept the default location for the new project or click
to find and select a folder.

e. From the Output Type field, select the primary target for your project.

TO IMPORT INTO AN EXISTING PROJECT (WIZARD)

a. Select Project > Import > DITA Document Set.

The Import DITA Wizard opens.

b. Select Import into this project.
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TO IMPORT INTO AN EXISTING PROJECT (IMPORT EDITOR)

Do one of the following:

IF YOU DO NOT YET HAVE A DITA IMPORT FILE

a. Complete the steps for adding an import file. See "Adding a DITA Import File" on page
198.

b. Open the file in the DITA Import Editor.

IF YOU ALREADY HAVE A DITA IMPORT FILE

a. In the Project Organizer, expand the Imports subfolder.

b. Double-click the appropriate import file. The file opens in the DITA Import Editor to the
right.

2. Do one of the following, depending on the part of the interface you are using:

n Wizard Click Next.

n Import Editor Select the Source Files tab.

3. Click .

4. Find and select the files you want to import. You can hold the SHIFT key to select a range, or
you can hold the CTRL key to select individual items. When you are finished, click Open.

You can select DITA or DITAMAP files.

NOTE You cannot select multiple DITAMAP files from different folders during the
same import process. You must first import the DITAMAP file(s) from one folder.
Then in the project that is created as a result, you can import the DITAMAP file(s)
from a second folder.
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5. You can use the following options as necessary.

Option Description

This opens the file that is selected in the list.

Link
Generated
Files to
Source Files

This creates a connection between the original files and the files that are
created as a result of the import. This is useful if you want to continue
editing the content outside of Flare Desktop, instead of editing in the
Flare project. Flare Desktop recognizes when changes have been made
to the source documents and reminds you to reimport the documents to
ensure the Flare project also reflects the changes. If you use this option,
a link icon is added to the top of a linked file in the Flare Desktop
interface. This lets you know that you need to edit the source file, rather
than editing this file. If you remove the connection to the source file, this
icon no longer displays on the file. Please note that if you have bound the
project to source control, the icons used for source control take
precedence over the link icon.

This removes the selected file(s) from the list.

This moves the selected file higher in the list (if you have more than one
file to import). The file at the top is used for the name of the content
folder holding the imported topics in Flare Desktop. Also, the order
determines how the imported files are arranged in the Flare TOC that is
created as a result.

This moves the selected file lower in the list (if you have more than one
file to import).

6. Do one of the following, depending on the part of the interface you are using:

n Wizard Click Next.

n Import Editor Select the Options tab.
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7. You can use the following options as necessary.

n Import all Content files to one folder Select this option if you want all of the imported
DITA file content to be placed in just one folder in the Content Explorer.

n Auto-reimport before 'Generate Output' If you selected “Link Generated Files to Source
Files” earlier in the wizard, you will likely make future content changes in the source
files. When you make such changes, the source files need to be reimported into the
project so that they can be included in the output. You have the option of reimporting
the files manually. However, you can also tell Flare Desktop to do this for you
automatically, so that you do not have to. Select this option if you want Flare Desktop
to automatically reimport files when you attempt to build output.

n Preserve ID attributes for elements Every element inside a DITA file has an ID. This ID is
not needed in Flare Desktop. However, if you intend to send your output back out to
DITA at any point, you can select this option to make sure the ID is preserved.

8. Do one of the following, depending on the part of the interface you are using:

n Wizard Click Next.

n Import Editor Select the Stylesheet tab.
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9. Use this page to specify whether the imported topics should be associated with a stylesheet
and/or styles from your DITA files.

n Conversion Styles This opens the DITA Import Styles Editor, which lets you specify how
to convert each property of the DITA elements. If you do not enter a property value, the
value from the DITA file is used. If you enter a property value, it overrides the value from
the DITA file. You can also use the dialog to import and export styles.

NOTE When you import content from DITA files, there is a one-to-one
conversion that occurs. For each DITA element in your file, a style class is
created in Flare Desktop. For example, let's say you have a paragraph-level
DITA element called "topictitle," after you import the file, a style class called
"h1.topictitle" might be created in Flare Desktop. Or if you have a character-
level DITA element called "cmdname," after you import the file, a style class
called "span.cmdname" might be created as a result in Flare Desktop. If
necessary, you can later edit those style classes in Flare Desktop. If you
generate DITA output from your project, the style classes are converted back to
DITA elements.

n Stylesheet If you already have a CSS file that you want to associate with the imported
files, click the Stylesheet button. Then navigate to the stylesheet and select it.

10. Do one of the following, depending on the part of the interface you are using:

n Wizard Click Finish. The Accept Imported Documents dialog opens. The files that will
be created as a result of the import are listed on the left. A preview of each file can be
seen to the right when you click the file.

n Import Editor In the local toolbar click Import (if this is the first time importing files) or
Reimport (if files have been imported previously). The Accept Imported Documents
dialog opens. The files that will be created as a result of the import are listed on the left.
A preview of each file can be seen to the right when you click the file.

11. When you are finished previewing the files to be created, click Accept.

NOTE A link icon displays on tabs in the XML Editor next to file names that are imported
from and linked to another file or Flare project. However, if you are also using the built-in
source control technology, the source control icons have a higher precedence and will
therefore be displayed instead.
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Adding a DITA Import File
The following steps show you how to add a DITA import file, which is used to import DITA file
content into a project. If you go through the Import DITA Wizard (Project > Import > DITA Document
Set), this file is created automatically and added to the Imports folder in the Project Organizer; you
do not need to do this separately.
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How to Add a DITA Import File to a Project
1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Project > New > Import File > Add DITA Import File.

n Right-Click In the Project Organizer, right-click on the Imports folder and from the
context menu select Add DITA Import File.

The Add File dialog opens.

2. In the File Type field at the top, make sure DITA Import File is selected.

3. In the Source area, choose to create the new file based on a template or an existing file.

n New From Template Choose either a factory template file or one of your own custom
template files as a starting point. The new file will take on all of the settings contained
in the template. If you want to use the factory template provided by Flare Desktop,
expand the Factory Templates folder and click on a template file. If you want to use
your own custom template file, expand the appropriate folder and click on a file. For
more information about templates, see the Help system.

n New From Existing Choose an existing file of the same type as a starting point for your
new file. As with template files, your new file will take on all of the settings contained in
the file you select. To use this option, click , use the Open File dialog to find a file, and
double-click it.

4. (Optional) If you want to place the file into a subfolder previously created in the Content
Explorer or Project Organizer, in the Folder field click and select the subfolder. Otherwise,
keep the default location.

5. In the File Name field, type a new name for the import file.

6. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the
bottom of the dialog. Next to the Condition Tags field, click and select the conditions you
want to apply. Click OK.

7. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the
dialog. Next to the File Tags field, click and select the file tags you want to apply. Click OK.

8. Click Add. The import file is added to the Imports folder in the Project Organizer.
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Opening a DITA Import File
The following steps show you how to open a DITA import file that you have added to a project. You
can then use this file to import DITA file content into the project. See "Importing DITA Files" on page
193.

How to Open a DITA Import File From the Quick
Launch Bar
The Quick Launch bar lets you search for any Flare Desktop file or command. It is located in the
upper-right corner of the interface. You can press CTRL+Q on your keyboard to move focus to the
Quick Launch bar so you can begin typing.

1. In the Quick Launch bar, type a few letters of the name of the file you want to open. Any
available results appear in a drop-down list.

2. From the list, click the name of the file.

How to Open a DITA Import File From the
Project Organizer

1. Open the Project Organizer.

2. Double-click the Imports folder. The DITA import files in your project are displayed.

3. Double-click the import file that you want to open. The DITA Import Editor opens to the right.

CHAPTER 13  200



CHAPTER 14

Converting Author-it Files
MadCap Software has an Author-it® Converter, which lets you create a new Flare project based on
Author-it Files. This utility uses the published XML output from Author-it and converts it to a Flare
project, while maintaining all project and source files.

This chapter discusses the following:

System Requirements 202

How to Download and Install the Author-it Converter 203

How to Use the Author-it Converter 204

How Elements are Converted From Author-it to Flare 205

What’s Noteworthy? 207
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System Requirements
n MadCap Flare Desktop 10 or newer

n Microsoft .Net 4.5.1 (installed with the software if needed)

n Microsoft Visual C++ Redistributables (installed with the software if needed)

n Minimum 2048 MB memory (RAM)

n Minimum 150 MB available hard drive space (additional space depending on size of XML files
to be converted)

n Microsoft Windows 7 or newer, 32- or 64-bit, including all required updates
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How to Download and Install the
Author-it Converter
1. Click the following to download and save the installation file locally:

Download Author-it Converter Utility

2. Unzip the archive:

a. Right-click AuthorItConverterSetup.exe and choose Properties.

b. Verify the EXE file is not being blocked (located on the General tab). This often happens
with network and Windows security.

n If the option to unblock the EXE is available, check the option and click OK.

n If no option to unblock exists, the above steps are not needed.

3. Run AuthorItConverterSetup.exe with elevated privileges (Run as Administrator).

4. Follow the prompts to install the utility.
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How to Use the Author-it Converter
1. From the MadCap Software program group, launch Author-it to Flare Converter.

2. Select the location and the Author-it XML file by clicking the browse button […].

3. Select a location where the Flare project should be saved by clicking the browse button […].

4. Select Content Path Options and choose one of the following:

n Author-it Keeps the existing folder structure outlined in the XML

n Flat Puts all topics at the root level under the Content folder

n Condensed Removes all empty folders from the XML structure; maintains only folders
with topics in the Content Explorer

5. Click Convert. The utility begins. A log report will be sent to the Flare project folder for
troubleshooting purposes.

6. When the conversion process is complete, click Yes to open the folder.

7. Double-click the project.flprj file to open the project in Flare Desktop.
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How Elements are Converted From
Author-it to Flare

Certain elements from Author-it are converted to their closest counterparts in Flare. The following
table describes this.

Author-it Element Flare Element Notes

Context IDs Context IDs Context IDs and values are
converted to alias and header
files.

Embedded topics Converted to snippets These are placed in
Resources folder in Flare
Desktop.

Glossaries Glossaries

Images Images These are placed in
Resources folder in Flare
Desktop.

Index keywords Index keywords

Styles Styles Stylesheets are placed in
Resources folder in Flare
Desktop.

Table of contents of Author-it
books

Converted to topics
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Author-it Element Flare Element Notes

Variables Variables Variables and all
permutations are converted.

Variables embedded in
variables are not supported in
Flare Desktop at this time. In
this case, each definition is
added as a permutation of the
variable.
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What’s Noteworthy?
NOTE The XML files from Author-it are from the Publish option in the Author-it software.

NOTE Topics without headings will be named "Topic####.htm" where the # is the Object ID
of the topic in the XML.
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CHAPTER 15

Global Project Linking—
Importing From Other Projects
You can import files from another Flare project using Global Project Linking.

How to Import Files Using the Import
Flare Project Wizard

The Import Flare Project Wizard guides you through the steps for importing Flare files from another
project. When you use this wizard, an import file is created automatically and placed in the Imports
folder in the Project Organizer.

1. Select Project > Import > Flare Project. The Import Flare Project Wizard opens.

2. Next to the Project file field click .

3. In the dialog find and double-click the Flare project file (.flprj extension) from which you will
be importing files.

4. (Optional) If you want future changes to the files in the source project to be reimported
automatically, click the Auto-reimport before "Generate Output" check box. If you select this
"Easy Sync" option, the changes to the source files will be reimported automatically when you
generate output. If you do not select this option, you can reimport future changes from the
other project manually.

CHAPTER 15  208



5. (Optional) If you want outdated files (e.g., files that have been deleted, renamed, or moved in
the parent project) to be deleted from the child project automatically, click the Delete stale
files check box.

EXAMPLE You import a group of files from a parent project into a child project.
Later, you delete some of the files from the parent project. Selecting this option will
remove the stale files from the child project automatically when you reimport files.
The stale files will be deleted when you reimport either manually (by clicking
Reimport in the Project Import Editor) or automatically when you generate output (if
you have selected Auto-reimport before "Generate Output" in the Project Import
Editor).

WARNING If you do not use this option, you must remember to delete the stale files
in the child project manually. Otherwise, the files in the parent and child projects will
not match.

6. (Optional) You can select Delete unreferenced files. This means that any files that were
previously imported—but are not specified to be included (either under the Include Files or
Import Conditions filters) in the reimport—will be marked for deletion in the Accept Imported
Documents dialog and removed from the child project upon confirmation.
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EXAMPLE Previously you had the Project Import Editor set up like this, where you
are importing three topic files from a parent project:

Later, after you've made lots of changes to the parent project, you open the child
project again to import the latest files into it. However, you decide you no longer want
to import the Welcome.htm topic into the child project (although it still exists in the
parent project). So in the Project Import Editor, you remove it from the Include Files
field. You also click Delete unreferenced files.
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When you tell Flare Desktop to reimport, the Accept Imported Documents dialog
opens, showing the following:

After you click Accept in that dialog, the changed files are replaced and Welcome.htm
is removed from the child project.

If you had not selected the "Delete unreferenced files" check box, the two changed
files would still have been imported, but the old Welcome.htm topic would still remain
in the child project.

This feature is slightly different from "Delete stale files." When you tell Flare Desktop to delete
stale files, you automatically sync the parent project with the child project when you've
removed files in the parent. So in the example above, the Welcome.htm file would
automatically be removed from the child project if you had also removed it from the parent
project.

7. Click Next.

8. Use the Include Files and Exclude Files fields to select the type of files to be included in the
import or excluded from it. Click the down arrow next to the appropriate field and select the
type of files. Completing the Include Files field is mandatory. Completing the Exclude Files
field is optional.

If you want to import all of the files from the global project, select All Files (*.*).

NOTE You are not limited to importing all files of a single file type. The following
steps explain how to add more than one file type to the field, as well as how to select
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specific files to be imported while excluding others.

9. (Optional) If you want to add more file types to one of the fields, click the Edit button under
the appropriate field and use the following steps.

a. In the Import File Filter dialog click Add. The Import File Filter Designer dialog opens.

b. Select the file type that you want to add. You can also use standard wildcards (text
between asterisks) to enter patterns directly into the Pattern field (or into the Include
Files or Exclude Files fields).

EXAMPLE You want to import only topic files that contain the word "Interface"
in the file name. Rather than selecting to import all topic files and then later
systematically deselecting the ones you do not really want in the import (via
the Accept Imported Documents dialog), you can enter the following:

*Interface*.htm;*Interface*.html

Or maybe you want to import only files that have an extension starting with "fl,"
such as TOC files (.fltoc) and snippet files (.flsnp). In order to do this, you could
enter *.fl* in the field, like the following:

*.fl*

c. Click OK.

d. In the Import File Filter dialog, click OK.

10. (Optional) Let's say that the files you are importing contain links to other files. If you want
Flare Desktop to automatically import those files as well, click Auto-include linked files. Not
only will the immediate linked files be included, but any linked files from those files as well,
and so on. It is a "domino" effect until no more linked files are found.

11. (Optional) In addition to specifying certain files or file types to include or exclude from the
import, you can go a level deeper through the use of condition tags. If you have applied
condition tags to files in your project, you can use the Import Conditions field to tell Flare
Desktop to include or exclude certain files, depending on the condition tags that are applied
to them at the file level. Simply click the Edit button to choose the conditions. In the
Conditional Text dialog for this feature, you can use the Basic or Advanced mode for creating
condition tag expressions. For more information about condition tags, see the Help system.
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12. (Optional) If you use the "Import Conditions" option, you may want to make sure that files
without condition tags in the source project are not included in the import. If that is the case,
click Auto-Exclude Non-Tagged Files.

13. Click Finish. The Accept Imported Documents dialog opens. The files in the source project
are listed (depending on whether the file types were included or excluded from the import in
the previous steps).

14. (Optional) The Accept Imported Documents dialog provides you with one last look at the files
to be imported, allowing you to make sure everything is correct and letting you change your
mind on any of the files. If you recognize files in the dialog that should not be imported, you
can click the check boxes next to the files you want to exclude (removing the check marks).

You can use the Select All and Clear All buttons as necessary. For example, if you only want
to include a very small number of the files listed, you can click the Clear All button and then
manually click the check boxes next to the files you want to include (this is quicker than
individually deselecting each file that you want to exclude).

NOTE If the current project already contains a file with the same name, the Status
cell may be highlighted in green or red. Green shading indicates that the source file is
newer. Red shading indicates that the local (or current) file is newer. If the file is
identical in both projects, the check box is deselected by default.

TIP You might find it useful to click on the column headings in the Accept Imported
Documents dialog. Doing this reorganizes the contents in alphabetical order of the
column that you click. For example, by clicking the Status column, you can easily
group together all of the files that have red or green backgrounds (i.e., files that are
newer in the local project or newer in the source project). This can be especially
useful when reimporting project files.

15. Click Accept. If the current project already contains files with the same names, you may be
asked if you want to replace the local copies. Select Yes if you do.
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NOTE When you manually import files from the parent project, you will see the Accept
Imported Documents dialog. This dialog lets you manually check or uncheck the files to be
imported or excluded from the import. It is sort of a last chance to take a look at the files
and make changes (include or exclude) before the actual import takes place. It also
remembers whether you have checked or unchecked certain files during previous imports.
However, when you use the "auto-reimport before generate output" feature, the import
takes place automatically, so you do not see the Accept Imported Documents dialog. This
means that all files will be imported automatically based on the criteria you provide,
regardless of whether you have previously deselected a file during a manual import. This is
one reason it is recommended you use conditions during Global Project Linking; with
conditions, you are more assured of importing the correct files during an automatic import.

For example, let's say you have four topics—TopicA, TopicB, TopicC, and TopicD—and you
have not conditioned any of them before importing. In your project import file, you specify
that all topic files should be imported. You then perform the import. The Accept Imported
Documents dialog opens, listing all four of your topics with check marks next to each one.
However, you decide that you really do not want to import TopicD, so you remove the check
mark next to it. After completing the manual import, TopicA, TopicB, and TopicC are
imported, but TopicD is not. Later, let's say you have made changes to your files and need
to reimport. After you click Reimport, you again see the Accept Imported Documents
dialog. Again, check marks are automatically shown next to TopicA, TopicB, and TopicC.
However, Flare Desktop remembered that you removed the check mark next to TopicD
previously, so the check mark remains absent from it. You finish the reimport and
everything goes according to plan.

Now let's say that after a few manual reimports, you decide to use the "auto-reimport"
feature. Therefore, in your import file, you click the check box next to Auto-reimport before
"Generate Output" and save. When you build the output, which topics are imported? The
answer is TopicA, TopicB, TopicC, and TopicD.

In this example, one of the best ways to use the auto-reimport feature and be assured that
the correct topics are included and excluded is to use condition tags at the file level.
Therefore, in your source project, you create one condition tag (let's say you name it
"YesImport") and you apply it to TopicA, TopicB, and TopicC. Then you create a second
condition tag (let's say you name it "NoImport") and apply it to TopicD. Then in the child
project, you open your import file. You click the Edit button next to Import Conditions, and
within the dialog that opens you tell Flare Desktop to include the "YesImport" condition and
exclude the "NoImport" condition. Now, the next time you build the output, which topics are
imported? The answer is TopicA, TopicB, and TopicC.
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NOTE A link icon displays on tabs in the XML Editor next to file names that are imported
from and linked to another file or Flare project. However, if you are also using the built-in
source control technology, the source control icons have a higher precedence and will
therefore be displayed instead.

NOTE The Imported Files tab in the Import Editor displays the files that have been
imported previously.

NOTE In the Project Import Editor, the Removed Links tab displays any files that were
previously imported, but the link to the source project has since been removed. For
example, let's say that you have imported several files from a source project. After awhile,
you open one of those files in the project where the files were imported. You make a few
changes and attempt to save it. Because Flare Desktop sees that a connection exists
between the file and the source project, it prompts you with some options. One of the
options is to continue to save your changes and remove the link from the source project.
This means that future changes to the file need to be made in the current project, rather
than in the source project. When you remove a link to a file in this way, that file is added to
the Removed Links tab.
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CHAPTER 16

Importing Projects From Flare
Online
If another user uploads a project locally from Flare Desktop to your MadCap Flare Online license
and you do not yet have that project on your computer, you can import it.

In order to import a project, you must be associated with that project in Flare Online. For more
information, see the documentation for Flare Online.

IMPORTANT If you are using a Git-Flare Online dual-binding, you can import projects from
Git (using the Import Project From Source Control Wizard) or from Flare Online. The project
will be the same. However, if you import from Flare Online, you will only be able to push
changes to and pull changes from Flare Online. If you import from Git, you will be able to
push changes to and pull changes from Flare Online as well as your main Git repository.
This is because the project in Flare Online has no connection to the original Git repository,
and if you import from Flare Online you will not have those source control bindings.
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NOTE If your project is already bound to a third-party source control provider other than Git
(i.e., you are working in a dual-bound model as opposed to a single-bound model), the
Import option in the Flare Online window pane will be disabled. This is because you should
import your project directly from source control using your non-Flare Online binding.

If you already have the project on your machine, you do not need to reimport the project
from source control. Instead, you can get the latest version from source control by using
the Flare Desktop Source Control ribbon.

Be sure that you have the latest version of the project.

NOTE When a project is dual bound to Flare Online and a non-Git third-party provider, keep
the following in mind if you (i.e., the second user) want to access this setup. After importing
the project from Perforce Helix Core, Subversion, or Team Foundation Server, you will have
to re-bind the project to Flare Online. In the MadCap Flare Online window pane in Flare
Desktop, click to upload (or bind) the project to Flare Online. In the Bind Project dialog, it is
important to enter the exact name of the project as it currently exists in Flare Online. When
you click OK, a message displays asking if you want to bind to the existing project. Select
Yes. This re-establishes the existing Flare Desktop-Flare Online connection; note that it
does not create a new binding.

This chapter discusses the following:

Permission Required? 218

How to Import a Project from Flare Online 219
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Permission Required?
For this activity, you must have the following permission setting in Flare Online:

For more information about permissions, see the documentation for Flare Online.
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How to Import a Project from Flare
Online
1. Select View > Flare Online. The Flare Online window pane opens.

2. Be sure to log in if you aren't already.

3. Click .

TIP If this button is disabled, try clicking in the window pane first.

The Import Project dialog opens.

4. From the My Projects field, select the project you want to import.

5. Next to the Destination folder field, click and choose the folder where you want the
imported project to be stored on your computer.

6. Click OK.

7. When the import is finished, you can click Open to launch the project in Flare Desktop.
Otherwise, you can click Cancel.
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CHAPTER 17

Removing Import Links
When using importing some kinds of files (e.g., Word, HTML), you can use an option to keep the
generated (i.e., imported) files linked to the source files. This means you would continue editing the
source files and re-import when necessary.

When using Global Project Linking, a similar link connection occurs automatically (without any such
option to select).

If you decide you want to break the links so that you can edit the imported files and no longer re-
import them, complete the following steps.

This chapter discusses the following:

How to Remove the Link for a Single Imported File 221

How to Remove Links for All Files (Most Kinds of Imports) 222

How to Remove Links for All Files (Global Project Linking) 223
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How to Remove the Link for a Single
Imported File
1. In Flare Desktop, open a file (e.g., topic) that has been imported.

2. Make edits to the file and click . (For Global Project Linking files, you do not save at this
point.)

3. In the dialog that opens, do one of the following:

MOST KINDS OF IMPORT FILES

a. Select Save the document and remove the link.

b. Click Continue.

GLOBAL PROJECT LINKING

a. Select Remove the link and continue the operation.

b. Click OK twice.

c. Click to save your work.

If you open the import file from the Project Organizer, you will see that the file has been
added to the "Removed Links" tab.
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How to Remove Links for All Files
(Most Kinds of Imports)
1. In Flare Desktop, open the Project Organizer, expand the Imports folder, and open the import

file.

2. Disable the option Link generated files to source files. The location of this option in the editor
depends on the type of files imported.

3. Click to save your work.

4. In the toolbar click Reimport.

5. Click Accept.
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How to Remove Links for All Files
(Global Project Linking)
1. In Flare Desktop, open the Project Organizer, expand the Imports folder.

2. Delete the import file.
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APPENDIX

PDFs
The following PDFs are available for download from the Help system.

Tutorials
Autonumbers Tutorial

Back-to-Top Button Tutorial

Context-Sensitive Help Tutorial

Custom Toolbar Tutorial

eLearning Tutorial—Basic

eLearning Tutorial—Advanced

Getting Started Tutorial

Image Tooltips Tutorial

Lists Tutorial

Meta Tags Tutorial

Micro Content Tutorial—Basic

Micro Content Tutorial—Advanced

Responsive Output Tutorial

Single-Sourcing Tutorial

Snippet Conditions Tutorial

Styles Tutorials

Tables Tutorial

Word Import Tutorial
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Cheat Sheets
Context-Sensitive Help Cheat Sheet

Folders and Files Cheat Sheet

Learning & Development Cheat Sheet

Lists Cheat Sheet

Micro Content Cheat Sheet

Print-Based Output Cheat Sheet

Search Cheat Sheet

Shortcuts Cheat Sheet

Structure Bars Cheat Sheet

Styles Cheat Sheet
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User Guides
Accessibility Guide

Analysis and Reports Guide

Architecture Guide

Autonumbers Guide

Branding Guide

Condition Tags Guide

Context-Sensitive Help Guide

Eclipse Help Guide

eLearning Guide

Flare Online Integration
Guide

Getting Started Guide

Global Project Linking Guide

HTML5 Guide

Images Guide

Import Guide

Indexing Guide

Key Features Guide

Lists Guide

Meta Tags Guide

Micro Content Guide

Navigation Links Guide

Plug-In API Guide

Print-Based Output Guide

Project Creation Guide

QR Codes Guide

Reviews & Contributions With
Contributor Guide

Scripting Guide

Search Guide

SharePoint Guide

Skins Guide

Snippets Guide

Source Control Guide: Git

Source Control Guide:
Perforce Helix Core

Source Control Guide:
Subversion

Source Control Guide: Team
Foundation Server

Styles Guide

Tables Guide

Tables of Contents Guide

Targets Guide

Template Pages Guide

Templates Guide

Topics Guide

Touring the Workspace Guide

Transition From FrameMaker
Guide

Translation and Localization
Guide

Variables Guide

Videos Guide

What's New Guide
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