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CHAPTER 1

Introduction
Flare Desktop supports integration with Microsoft SharePoint, including SharePoint Online (or
SharePoint 365). From Flare Desktop you can access, edit, and synchronize SharePoint files.

SharePoint is like a scaled-down version of a source control tool, with the ability to check out and
check in files. Many organizations use a source control tool to manage files that are part of
products and will be shipped to customers, while using SharePoint mostly for internal files to be
shared among colleagues.
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Process

1. "Connecting to a SharePoint Server" on page 8

2. "Checking Out SharePoint Files" on page 9

3. "Opening SharePoint Files" on page 12

4. "Checking In SharePoint Files" on page 15

5. "Copying and Mapping Files" on page 17

6. "Managing Mappings of Files" on page 20

7. "Synchronizing SharePoint Files" on page 23

EXAMPLE You need several people—such as subject matter experts, managers, or peers—
to review your topics. You can always email review packages to those individuals, but an
alternative is to upload the review package to a SharePoint server. Each reviewer can check
out the package, make their comments, and check the file back in. You can then bring the
review package back into your project, integrating the updated topics into your project.

NOTE Due to limitations with Microsoft, you might experience an error when publishing
output to a SharePoint server. If this occurs, please consult your SharePoint administrator.
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CHAPTER 2

Connecting to a SharePoint
Server
From the SharePoint Explorer in Flare Desktop, you can connect to a specific SharePoint server.
You can then use that window pane to access the files on that server.

How to Connect to a SharePoint
Server
1. Select View > SharePoint Explorer.

2. In the local toolbar click . The Connect to SharePoint Server dialog opens.

3. Enter the path to the SharePoint server.

4. Click to validate the server.

5. Click OK. The SharePoint Explorer is populated with files from the server.
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CHAPTER 3

Checking Out SharePoint Files
You can check out SharePoint files from the Flare Desktop interface. Checking out a file simply
means to activate a "flag" on the SharePoint site indicating that you want to access the file and
prevent others from editing it and conflicting with your changes.

This chapter discusses the following:

How to Check Out SharePoint Files 10

How to Undo a Check-Out of SharePoint Files 11
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How to Check Out SharePoint Files
1. Select View > SharePoint Explorer.

2. Locate the file(s) that you want to check out. You can use the "multi-view" to do this.

Option Description

Shows or hides the folders that the files are stored in.

Shows or hides the files. If you click this button when the "Show Folders"
button is selected, the area splits into two halves. The folder is shown on the
left side, and the files and subfolders within it are shown on the right.

Collapses the folders.

If the "Show Files" button is the only one selected, you can click this button
to move up one folder level.

3. Select the file(s) that you want to check out. If the window pane is split into two halves, you
can select the appropriate folder on the left side and select the files on the right side. You can
hold the SHIFT key to select a range, or you can hold the CTRL key to select individual items.

4. Right-click the file(s) and from the context menu select Check Out.

5. In the dialog that opens, click Check Out.

NOTE By default there is a check mark next to all files that were selected. If
necessary, you can click any check box to remove the check mark, which means that
file will not be checked out when you are finished.
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How to Undo a Check-Out of
SharePoint Files
1. Select View > SharePoint Explorer.

2. Locate the file(s). You can use the "multi-view" to do this.

Option Description

Shows or hides the folders that the files are stored in.

Shows or hides the files. If you click this button when the "Show Folders"
button is selected, the area splits into two halves. The folder is shown on the
left side, and the files and subfolders within it are shown on the right.

Collapses the folders.

If the "Show Files" button is the only one selected, you can click this button
to move up one folder level.

3. Select the file(s). If the window pane is split into two halves, you can select the appropriate
folder on the left side and select the files on the right side. You can hold the SHIFT key to
select a range, or you can hold the CTRL key to select individual items.

4. Right-click the file(s) and from the context menu select Undo Check Out.

5. In the dialog that opens, click Undo Check Out.
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CHAPTER 4

Opening SharePoint Files
After connecting to a SharePoint server, you can open files to edit them.

One option is that you can open the actual SharePoint files that exist on the server (if you decide, for
example, to use the check-out/check-in features). See "Checking Out SharePoint Files" on page 9
and "Checking In SharePoint Files" on page 15.

Another option is to open copies of those files in your project (if you decide to use file mappings
and synchronization). See "Copying and Mapping Files" on page 17 and "Synchronizing SharePoint
Files" on page 23.

This chapter discusses the following:

How to Open a File Existing on the SharePoint Server 13

How to Open a Copy of a SharePoint File in a Project 14
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How to Open a File Existing on the
SharePoint Server
1. Select View > SharePoint Explorer.

2. Locate the file that you want to open. You can use the "multi-view" to do this.

Option Description

Shows or hides the folders that the files are stored in.

Shows or hides the files. If you click this button when the "Show Folders"
button is selected, the area splits into two halves. The folder is shown on the
left side, and the files and subfolders within it are shown on the right.

Collapses the folders.

If the "Show Files" button is the only one selected, you can click this button
to move up one folder level.

3. Do one of the following:

n Double-click the file.

n Right-click the file and select Open.

n Click on the file, and in the local toolbar click .

If it is a file type not supported in Flare Desktop, you will be directed to open the file in its
default application.
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How to Open a Copy of a SharePoint
File in a Project
1. Open the Content Explorer.

2. All copies of SharePoint files that you added to your project will be located somewhere in the
Content folder (in the root itself or under subfolders where you may have placed files when
copying them to Flare Desktop). Locate the file that you want to open. You can use the "multi-
view" to do this.

Option Description

Shows or hides the folders that the files are stored in.

Shows or hides the files. If you click this button when the "Show Folders"
button is selected, the area splits into two halves. The folder is shown on the
left side, and the files and subfolders within it are shown on the right.

Expands the folders.

Collapses the folders.

If the "Show Files" button is the only one selected, you can click this button
to move up one folder level.

3. Do one of the following:

n Double-click the file.

OR

n Right-click the file and select Open.

OR

n Click on the file, and in the local toolbar click .

If it is a file type not supported in Flare Desktop, you will be directed to open the file in its
default application.
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CHAPTER 5

Checking In SharePoint Files
When you are finished working on a SharePoint file that you checked out, you can check it back in
so that others can edit it.

How to Check In SharePoint Files
1. Select View > SharePoint Explorer.

2. Locate the file(s) that you want to check in. You can use the "multi-view" to do this.

Option Description

Shows or hides the folders that the files are stored in.

Shows or hides the files. If you click this button when the "Show Folders"
button is selected, the area splits into two halves. The folder is shown on the
left side, and the files and subfolders within it are shown on the right.

Collapses the folders.

If the "Show Files" button is the only one selected, you can click this button
to move up one folder level.
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3. Select the file(s) that you want to check in. If the window pane is split into two halves, you can
select the appropriate folder on the left side and select the files on the right side. You can
hold the SHIFT key to select a range, or you can hold the CTRL key to select individual items.

4. Right-click the file(s) and from the context menu select Check In.

5. Click Check In.

NOTE By default there is a check mark next to all files that were selected. If
necessary, you can click any check box to remove the check mark, which means that
file will not be checked in when you are finished.
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CHAPTER 6

Copying and Mapping Files
After you connect to a SharePoint server, you can copy any of the SharePoint files to your project,
mapping them to the source files at the same time.

This is a different process than that of importing files, which you can do elsewhere in Flare
Desktop. Files that are brought into a project using a traditional import process can be connected
to the source file, but only in one direction (i.e., files can be updated from the source to the imported
file in the project). On the other hand, files that are copied from the SharePoint Explorer can be
connected via mappings to the source files in two directions (i.e., files can be updated from the
source to the copied file or from the copied file to the source).
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How to Copy and Map SharePoint
Files
1. Select View > SharePoint Explorer. The SharePoint Explorer opens.

2. Locate the file that you want to add to the project. You can use the "multi-view" to do this.

Option Description

Shows or hides the folders that the files are stored in.

Shows or hides the files. If you click this button when the "Show Folders"
button is selected, the area splits into two halves. The folder is shown on the
left side, and the files and subfolders within it are shown on the right.

Collapses the folders.

If the "Show Files" button is the only one selected, you can click this button
to move up one folder level.

3. Right-click on the file and from the context menu select Copy to Project.

4. In the dialog that opens, find and select the location in your project that you want to add the
file. Again, you can use the multi-view buttons to navigate to folders in your project.

5. Click OK.

6. In the Copy to Project dialog select Keep file synchronized (create mapping).
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7. Click OK. The file is added to the project, as you can see by opening the Content Explorer. If
you selected to map the file, a small icon is shown next to it.
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CHAPTER 7

Managing Mappings of Files
If you copy SharePoint files to your project, you can create mappings (connections) between the
copies of those files that you bring into your project and the source files on the SharePoint server.
You can do this at the point that you copy those files into your project (see "Copying and Mapping
Files" on page 17). You can also manage these mappings whenever necessary through the Map
Files and Folders dialog. This involves the ability to create, change, or remove mappings.
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How to Manage Mappings of
SharePoint Files
1. Select Project > Manage Mappings.

2. Use the Map Files and Folders dialog to do any of the following.

TO CREATE OR CHANGE A MAPPING

a. If you are creating a new mapping, in the blank row click in the Project Path cell. If you
are changing an existing mapping, in the appropriate populated row click in the Project
Path cell.

b. In that cell click .

c. In the dialog that opens, find and double-click the copy of the file located in your
project.

d. Click in the External Path cell.

e. In that cell click .

f. In the dialog that opens, find and double-click the source file located outside of your
project.

TO REMOVE A MAPPING

a. Click on the icon on the far left side of the row you want to delete. This highlights the
entire row.

b. At the bottom of the dialog click Remove.

3. Click OK.
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CHAPTER 8

Other Activities for SharePoint
In addition to the main activities, there are some other tasks you might perform regarding this
feature.

This chapter discusses the following:

Synchronizing SharePoint Files 23

Merging Mapped Files 24

Setting Color Options for Mapped File Differences 28
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Synchronizing SharePoint Files
After you map project files to source files located on a SharePoint server, you can synchronize
them to ensure that each file contains the same content. This process lets you import content from
SharePoint files, export content from mapped files in the project to SharePoint, or keep the most
recently modified content.

How to Synchronize SharePoint Files
1. Select Project > Synchronize Files.

The Synchronize Files dialog opens. By default only files that are out of sync are listed.
However, you can click to also show files that are already synchronized, and you can click

to refresh the list.

2. From the drop-down field at the top, select any of the following options.

n Synchronize Files This imports external source files into the project, overwriting the
copies (if the external files have been modified most recently). And it also exports
copies of files in the project, overwriting external source files (if the copies in the
project have been modified most recently).

n Import Files For all out-of-sync files, this imports external source files into the project,
overwriting the copies (regardless of which files have been modified most recently).

n Export Files For all out-of-sync files, this exports copies of files in the project,
overwriting external source files (regardless of which files have been modified most
recently).

3. Make sure there is a check mark next to each pair of files that you want to synchronize and
click Synchronize.

4. In the message that displays, click OK.

NOTE In the list of files, you can click to see more details, such as the modified date and
file size.
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Merging Mapped Files
If you attempt to synchronize files and Flare Desktop detects a conflict (i.e., a mapped file has been
modified both locally and in its mapped location), a dialog opens so that you can take the
appropriate action.

In the Synchronize Files dialog, you can tell if a conflict exists because a warning icon will display
next to the files in question.

How to Merge Mapped Files
1. Go through the process of synchronizing external or SharePoint files. See "Synchronizing

SharePoint Files" on the previous page. After you click the Synchronize button, the Resolve
Conflicts dialog opens if a conflict exists.

2. Click Auto Merge All.

If changes in the files do not conflict with each other (i.e., if the changes occur in different
parts of the files so that they will not affect one another), this will merge all changes. A
message lets you know that a backup of your local copy has been made. This lets you restore
that file if you do not want to keep the merged version You do not need to complete the rest
of the steps below.

However, if your the changes in the files do conflict with each other (i.e., they occur in the
same places in the files), a message displays to tell you. In this case, continue with the next
step.

NOTE This option is not available if you are synchronizing a file that is not native to
Flare.

3. Click OK on the conflict message.

4. In the Resolve Conflicts dialog click Resolve. The Resolve Conflict dialog opens. From this
dialog, you can choose from the following options:

n Merge changes in merge tool Opens a merging interface, which lets you see exactly
what changes were made and choose which to keep.
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NOTE This option is not available if you are synchronizing a file that is not
native to Flare.

n Undo my local changes Automatically removes changes in the local file in your project
and keeps changes from the file in the mapped location.

n Discard external changes Automatically removes changes from the file in the mapped
location and keeps changes in the local file in your project.

5. If you selected the first option, the Merge Changes dialog opens. Use this dialog to view and
select changes. You can take actions in the following ways:

n Right-click icon You can right-click on the icon next to a change on either the local or
external side. This displays a context menu, which lets you either keep or ignore a
particular change.

n Left-click icon You can left-click on the icon next to a change on either the local or
external side. When you do this, the change from one side is kept and the change from
the other side is ignored. If you left-click the icon again, the results are toggled; the first
change is ignored and the other is kept.

n Type content If you want to use the local changes as well as those from the external
file, and even tweak the paragraph a bit more, you can click in the area at the bottom of
the dialog and simply type content.

n Previous/next conflict When you are finished resolving the first conflict, you can use
the "Previous Conflict" and "Next Conflict" buttons at the bottom of the dialog to work
on other conflicts in the file.

6. (Optional) If you want to change the colors associated with the changes, you can click
Options.

7. (Optional) By default the files are shown in a WYSIWYG (What You See Is What You Get)
view. But you can click Merge as Text to work in the markup instead.

8. After all conflicts have been resolved, a message lets you know that a backup of your local
copy has been made. This lets you restore that file if you do not want to keep the merged
version. Click OK.

9. Click OK in the other dialogs that open.
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Icons for File Differences
Following are descriptions of the various basic icons you might see in the Merge Changes dialog
when merging files.

Icon Description

Changed Content This indicates that the content has changed but there is no
conflict. Therefore, no action is needed.

Changed Tag This is the same as the "Changed Content" icon, except the content has
not changed, just a tag, such as a style or span.

New Content This indicates that there is new content, but there is no conflict with
your changes. Therefore, no action is needed.

Deleted This indicates that content was deleted, but there is no conflict with your
changes. Therefore, no action is needed.
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Following are descriptions of conflict icons.

Icon Description

Changed Content—Conflict This indicates that the content has changed and a
conflict exists. Therefore, user action is required. This icon appears in both the left
and right panes of the Merge Changes dialog at the spot of the conflict. You must
click on one of the icons to "Accept" that particular change.

Conflict Change—Accepted This indicates that a change with a conflict has been
accepted after clicking on . The bottom pane of the Merge Changes dialog
updates to show the accepted content.

Conflict Change—Not Accepted This indicates that a change with a conflict will not
be accepted. When you accept a conflict change and that side of the Merge Changes
dialog displays , the opposite pane where the conflict exists will display .

Changed Tag—Conflict This indicates that the tag has changed and a conflict exists.
Therefore, user action is required. This icon appears in both the left and right panes
of the Merge Changes dialog at the spot of the conflict. You must click on one of the
icons to "Accept" that particular change.

Conflict Tag—Accepted This indicates that a change with a conflict in a tag has been
accepted after clicking on . The bottom pane of the Merge Changes dialog
updates to show the accepted content.

Conflict Tag—Not Accepted This indicates that a change with a conflict in a tag will
not be accepted. When you accept a conflict change and that side of the Merge
Changes dialog displays , the opposite pane where the conflict exists will display

.
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Setting Color Options for Mapped File
Differences

If you need to merge mapped files, you can view differences between the files. When viewing file
differences between a local copy of a file and the original file located elsewhere, you can select
color options to display the files. Color coding makes it easier to discern where differences between
files occur.

How to Set Color Options for Mapped File
Differences

1. Go through the process of merging mapped files.

2. In the local toolbar of the Merge Changes dialog, click Options. The File Differences dialog
opens.

3. Change the text or background color for any of the difference types. To do this, simply click in
the appropriate Text or Background cell and select Pick Color. In the Color Picker dialog,
choose the new color.

4. Click OK.
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APPENDIX

PDFs
The following PDFs are available for download from the Help system.

Tutorials
Autonumbers Tutorial

Back-to-Top Button Tutorial

Context-Sensitive Help Tutorial

Custom Toolbar Tutorial

eLearning Tutorial—Basic

eLearning Tutorial—Advanced

Getting Started Tutorial

Image Tooltips Tutorial

Lists Tutorial

Meta Tags Tutorial

Micro Content Tutorial—Basic

Micro Content Tutorial—Advanced

Responsive Output Tutorial

Single-Sourcing Tutorial

Snippet Conditions Tutorial

Styles Tutorials

Tables Tutorial

Word Import Tutorial
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Cheat Sheets
Context-Sensitive Help Cheat Sheet

Folders and Files Cheat Sheet

Learning & Development Cheat Sheet

Lists Cheat Sheet

Micro Content Cheat Sheet

Print-Based Output Cheat Sheet

Search Cheat Sheet

Shortcuts Cheat Sheet

Structure Bars Cheat Sheet

Styles Cheat Sheet
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User Guides
Accessibility Guide

Analysis and Reports Guide

Architecture Guide

Autonumbers Guide

Branding Guide

Condition Tags Guide

Context-Sensitive Help Guide

Eclipse Help Guide

eLearning Guide

Flare Online Integration
Guide

Getting Started Guide

Global Project Linking Guide

HTML5 Guide

Images Guide

Import Guide

Indexing Guide

Key Features Guide

Lists Guide

Meta Tags Guide

Micro Content Guide

Navigation Links Guide

Plug-In API Guide

Print-Based Output Guide

Project Creation Guide

QR Codes Guide

Reviews & Contributions With
Contributor Guide

Scripting Guide

Search Guide

SharePoint Guide

Skins Guide

Snippets Guide

Source Control Guide: Git

Source Control Guide:
Perforce Helix Core

Source Control Guide:
Subversion

Source Control Guide: Team
Foundation Server

Styles Guide

Tables Guide

Tables of Contents Guide

Targets Guide

Template Pages Guide

Templates Guide

Topics Guide

Touring the Workspace Guide

Transition From FrameMaker
Guide

Translation and Localization
Guide

Variables Guide

Videos Guide

What's New Guide
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