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CHAPTER 1

Introduction
A template is an existing project or file that serves as the basis for a new one, providing preset
content, settings, or formatting.

In most cases, Flare Desktop provides you with one or more templates (called "factory templates"),
so you do not need to worry about coming up with your own. However, if you want, you can create
your own templates and use them when you create new projects or add new elements to a project.
Templates can be especially useful when you are working on a team.

General Information

n "Contribution Templates" on page 12

n "Flare's Factory Project Templates" on page 12

Process

1. "Creating Template Folders" on page 20

2. "Creating Templates" on page 21

3. "Managing Templates" on page 27

4. Select a template when creating a new project or file.
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EXAMPLE You are working with a team of 10 other writers, and you want to create a topic
called "Welcome" that all authors should use in their projects. The template topic will
contain some standard text and headings. In addition, the topic links to a stylesheet, which
automatically gives the topic the appropriate look and feel. The idea is the authors will
create a "Welcome" topic in each of their projects, adding more content to that topic as
needed; all "Welcome" topics should be consistent and look the same in all projects.

To accomplish this, you first open a Flare project and create the topic. It might look
something like this:
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Now you need to make sure that you have a template folder ready to hold the new template
file. Therefore, you select the Tools ribbon. In the Templates section you click Manage
Templates. This opens the Template Manager.
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In the dialog that opens, you find and select the folder where you want to store the template
file.
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After closing the Template Manager, you make sure your new topic is still open. Then you
select File > Save > Save As Template. In the dialog that opens, you select the new template
folder and click OK.
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Now let's say that Karen, one of the other authors, wants to create a "Welcome" topic for a
new project she is working on. In her Flare project, she selects Project > New > Topic. In the
dialog that opens, she selects the template file you created, chooses a location (in the
following example, the root folder), and provides a name for the new file. Then she clicks
Add.
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The new topic is added to the Karen's project. In order for her topic to look just like your
topic, she needs to add the same stylesheet file to her project. This can be done by simply
importing that file or maybe through Global Project Linking.

Once Karen brings the stylesheet file into her project, she can associate it at the project,
target, or topic level. Let's say she sets it at the project level (in the Project Properties
dialog, which is opened by selecting Project > Project Properties). After doing this, her topic
will look just like yours, and she can begin adding content to it.
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CHAPTER 2

General Information for
Templates
There are various pieces of general information you should know if you plan to use this feature.

This chapter discusses the following:

Contribution Templates 12

Flare's Factory Project Templates 12
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Contribution Templates
Authors, developers, or other individuals in your company can use MadCap Contributor to create
new documents and files, which can be incorporated into your Flare project.

For more information, see the Help system and the Reviews and Contributions Guide.

Flare's Factory Project Templates
You can choose from Flare Desktop's many factory project templates when creating a new project.

Flare's factory templates are organized into the following folders:

n Online These templates were designed for online output only (although you can always add
print-based outputs later).

n Online & Print These templates were designed to generate both online and print-based
outputs from the same content.

n Print These templates were designed for print-based output only (although you can always
add online outputs later).

n Tutorials This folder contains templates intended to be used with various Flare Tutorials.
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Online Templates
Template Characteristics

eLearning
n Contains starter topics and other files designed for an eLearning

course in HTML5 format. You can quickly generate a course with
simple knowledge checks, another with a gradable quiz, or a
combination.

n Lets you integrate course output with an external learning
management system (LMS) for tracking results; supports SCORM
and xAPI.

n Includes responsive output, which means the content display
changes automatically depending on the width of the screen.

Knowledge Base
n Contains starter topics and other files designed for an online

knowledge base in HTML5 format. If you intend to use Flare Desktop
to generate an online knowledge base, this project demonstrates
one approach you may consider.

n Includes responsive output, which means the content display
changes automatically depending on the width of the screen.

Side Navigation
n Contains starter topics and other files intended for online HTML5

output that looks like a modern website with navigation on the side
(left or right).

n Offers a frameless, modern alternative to the more traditional tripane
format.

n Includes responsive output, which means the content display
changes automatically depending on the width of the screen.
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Template Characteristics

Top Navigation
n Contains starter topics and other files intended for online HTML5

output that looks like a modern website with navigation on the top.

n Offers a frameless, modern alternative to the more traditional tripane
format.

n Includes responsive output, which means the content display
changes automatically depending on the width of the screen.

Tripane
n Contains starter topics and other files intended for online HTML5

output in a traditional tripane format (navigation pane, toolbar pane,
content pane).

n Includes responsive output, which means the content display
changes automatically depending on the width of the screen.

Online and Print Templates
Template Characteristics

eLearning and
PDF

n Contains starter topics and other files designed for an eLearning
course in HTML5 format. You can quickly generate a course with
simple knowledge checks, another with a gradable quiz, or a
combination.

n Lets you integrate course output with an external learning
management system (LMS) for tracking results; supports SCORM
and xAPI.

n Online HTML5 output allows for interactivity in learning blocks (e.g.,
selecting answers, viewing feedback and test results). Includes
responsive output, which means the content display changes
automatically depending on the width of the screen.

n PDF output allows for distribution of a print version of the course,
with a one-click option to show or hide answers in the output.
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Template Characteristics

Side Navigation
and PDF

n Contains starter topics and other files intended for both online and
print-based output.

n Online HTML5 output looks like a modern website with navigation on
the side (left or right). Offers a frameless, modern alternative to the
more traditional tripane format. Includes responsive output, which
means the content display changes automatically depending on the
width of the screen.

n PDF output is a user guide that includes auto-generation of a TOC,
glossary, and index.

Top Navigation
and PDF

n Contains starter topics and other files intended for both online and
print-based output.

n Online HTML5 output looks like a modern website with navigation on
the top. Offers a frameless, modern alternative to the more
traditional tripane format. Includes responsive output, which means
the content display changes automatically depending on the width of
the screen.

n PDF output is a user guide that includes auto-generation of a TOC,
glossary, and index.

Tripane and PDF
n Contains starter topics and other files intended for both online and

print-based output.

n Online HTML5 output uses a traditional tripane format (navigation
pane, toolbar pane, content pane). Includes responsive output, which
means the content display changes automatically depending on the
width of the screen.

n PDF output is a user guide that includes auto-generation of a TOC,
glossary, and index.
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Print Templates
Template Characteristics

Brochure
n Contains two topics and two page layouts designed to create a

brochure with three panes.

Policies and
Procedures

n Contains starter topics and other files designed to produce a
policies and procedures manual in PDF format.

n Includes content and variables that you can re-use.

n Includes auto-generation of a TOC and index.

Product Foldout
n Contains two topics and two page layouts designed to create a four-

pane PDF product foldout.

n Ideal for brief product instructions.

User Guide
n Contains starter topics and other files designed to produce a user

guide in PDF format.

n
Includes auto-generation of a TOC, glossary, and index.

Tutorial Templates
Template Characteristics

Austin
n Designed to be used alongside various feature tutorials.

n Tutorials help you in the creation of Flare Desktop features, such as
micro content, context-sensitive Help, snippet conditions, and more.
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Template Characteristics

San Diego
n Designed to be used alongside self-paced Getting Started tutorial.

n This tutorial gives you hands-on experience in Flare Desktop, guiding
you in the basic steps for creating, developing, and building output.

n End result is a PDF guide and online HTML5 output with top
navigation like a modern website, instead of the more traditional
tripane format.
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Downloading Additional Project Templates
If you want to use one of the many other templates available from the MadCap Software website
(including older ones that once were available in this wizard), you can click a new link to browse the
templates and download them.

After downloading a project template, you can unzip it and save it to a location on your computer.
Then, next to New from existing, click and select that project’s main .flprj file.
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CHAPTER 3

Process for Templates
Certain tasks must be completed in order when using this feature.

This chapter discusses the following:

Creating Template Folders 20

Creating Templates 21

Managing Templates 27

Changing Project Templates 29
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Creating Template Folders
The first step in using custom templates is to create a template folder, simply by selecting a folder
that already exists. The template folder is simply the place where you will store your template files.
You can have as many template folders as you need in order to hold all of your template files.

In addition to selecting a folder on your local drive, you can also select a folder on a network, even
on a SharePoint server (if you have previously connected to one). When you save a file (e.g., topic,
page layout) as a new template and select a template folder, the appropriate template subfolder is
added to that folder (e.g., topic templates are stored in a subfolder called "Content"; page layout
templates are stored in a subfolder called "PageLayouts"). As a result, those files become
accessible as templates when you create new features in Flare Desktop. Selecting a folder on a
network is a great way to share template files with other Flare Desktop users.

How to Create a Template Folder
1. Select Tools > Manage Templates. The Template Manager opens.

2. Click .

3. In the Select dialog, find and select the folder where you want to store template files.

4. After you have selected the folder, click OK.

5. In the Template Manager, click Close.
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Creating Templates
After creating a template folder, you can add one or more template files to it. A template is simply
an existing file or element of the same type that you are creating (e.g., a project, topic file, target file,
snippet file).

You can create templates of entire projects or individual files within a project. There are two ways
to create a template from an individual file: (1) with the file open and (2) from the Template
Manager.

How to Create a Template of an Entire Project
1. Create a project, adding all of the content, elements, and settings that you want to be part of

the project.

2. Select Project > Save Project As Template.

3. In the Template Folder section, select the folder where you want to store the template files.

4. The Template Name field, enter a name for the new template.

5. Click Next.
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6. On the next page of the wizard, make sure a check mark is next to each content folder or file
that you want to include in the project template. By default, all of the boxes are checked, but
you can click in any of the boxes to remove the check marks if necessary.

7. Click Next.
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8. On the next page of the wizard, make sure a check mark is next to each project folder or file
that you want to include in the project template. By default, all of the boxes are checked, but
you can click in any of the boxes to remove the check marks if necessary.

9. Click Finish.
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How to Create a File Template—File Open
1. In Flare Desktop create the element (e.g., topic, target, skin, template page ) that you want to

use as a template.

2. Add content or settings to the element as you normally would. When you use the template to
create more elements in the future, those new elements will start out with the same content
or settings as your template file.

3. Select File > Save > Save As Template.

4. In the Template Folder section, select the folder where you want to store the template file.

5. The Template Name field, enter a name for the new template.

6. Click OK.
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How to Create a File Template—Template
Manager

1. In Flare Desktop create the element (e.g., topic, target, skin, template page) that you want to
use as a template.

2. Add content or settings to the element as you normally would. When you use the template to
create more elements in the future, those new elements will start out with the same content
or settings as your template file.

3. Click to save your work.

4. Select Tools > Manage Templates.

5. In the built-in tree, find and select the folder where you want to store the template file.

6. Click .

7. In the dialog that opens, find and double-click the file that you want to add as a template.

8. In the Save As Template dialog click OK.

9. In the Template Manager dialog click Close.
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What’s Next?
After you create a template, you can select it whenever you create a new element of the same type
(e.g., you can select a topic template when creating a new topic).
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Managing Templates
You can manage your template files from within the Template Manager dialog. This dialog can be
opened from the Tools ribbon or menu, by clicking the Manage Templates button that can be
found in a variety of template-related dialogs (such as the Save As Template dialog).

Adding Template Files
You can add files to any of your existing template folders. Therefore, those files become available
as templates when you create new features in Flare Desktop. See "Creating Templates" on page 21.

To add a template file in the Template Manager, select the folder where you want it to be stored and
then click .
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Creating Template Folders
You can find and select an existing folder on your local drive or on a network, even on a SharePoint
server (if you have previously connected to one). When you save a file (e.g., topic, page layout) as a
new template and select a template folder, the appropriate template subfolder is added to that
folder (e.g., topic templates are stored in a subfolder called "Content"; page layout templates are
stored in a subfolder called "PageLayouts"). As a result, those files become accessible as templates
when you create new features in Flare Desktop. This is a great way to share template files with
other Flare Desktop users on your network. See "Creating Template Folders" on page 20.

To create a template folder in the Template Manager, click .

Opening and Editing Template Files
If you want to open a template file to make changes to it, you can double-click it in the Template
Manager. You can also right-click the file and select Open.When you open a template file, it opens in
the appropriate editor, just as a regular file would open. However, the following message displays at
the top of the editor to let you know that the file you are modifying is a template file that is not
located in the current project:

Editing Template Descriptions
Many template files can include a template description, which is shown when you work in the
Template Manager or if you select the template when creating a feature in Flare Desktop. In the
Template Manager, you can edit the description for any XML template files, except XHTML files. For
example, you can edit descriptions for target, skin, TOC, and destination template files, but you
cannot edit descriptions for topics, snippets, stylesheets, images, and multimedia files. You might
find this feature useful if you are working with a team of writers and need a good description of
each template; therefore, each author will easily know the purpose of the template. To create or edit
the description for a template in the Template Manager, first select the template file in the built-in
tree and then click . Then type a description for the template and click OK.

CHAPTER 3  28



Changing Project Templates
You might already have a Flare project but decide you want to use the look from a different
template. For example, maybe you initially selected a template that is shown in Flare Desktop's
Start New Project Wizard, but then you later find a template on the MadCap Software website that
you like better. There isn't a feature dedicated to make a change like this, with built-in mapping, etc.
However, you can use a combination of some Flare Desktop features to make it work. The following
explains how to change templates using Flare Desktop's Global Project Linking and exporting
features.
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How to Change Project Templates
1. Download the template you want to use, or create a new, small project based on a template.

2. Open that new project in Flare Desktop (if you downloaded a project template, you can
double-click the Flare zip file to unpack and open it), and add a Flare project import file
(Project > New > Import File > Add Flare Project Import File).

NOTE Alternatively, you can add the project import file to your original project and
import files from the new template project into that. In that case, you would probably
want to import mainly design-related files (e.g., stylesheets, template pages, skins).
However, there will probably be less work afterward if you import mostly content files
from the original project into the new template project, then export or name it.

3. In the Project Import Editor, select the source project and use the fields to choose the files
you want to import. If you are importing from the original project into the new template
project, you probably want to limit your selections to non-design files (e.g., choose files such
as topics, snippets, images, and variables), although in some cases you might decide to keep
some design files (e.g., stylesheet, page layouts). When finished, save your work, click Import,
then Accept.

4. Delete any of the topics and other files that were part of the template project and you do not
plan on using (e.g., topics, images, TOC). Also, in the Project Organizer, expand the Imports
folder and delete the import file (unless you plan on re-importing some more files).

5. Generate and view output and see what kinds of manual changes you might need to make.
For example, if you imported your original stylesheet, you might need to link it to the one(s) in
the new project, or you might need to re-apply some styles to some content.

6. You probably want to rename the new project. An easy way to do this is to select Project >
Export Project, which gives you an opportunity to rename the project and select a location for
it.
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APPENDIX

PDFs
The following PDFs are available for download from the Help system.

Tutorials
Autonumbers Tutorial

Back-to-Top Button Tutorial

Context-Sensitive Help Tutorial

Custom Toolbar Tutorial

eLearning Tutorial—Basic

eLearning Tutorial—Advanced

Getting Started Tutorial

Image Tooltips Tutorial

Lists Tutorial

Meta Tags Tutorial

Micro Content Tutorial—Basic

Micro Content Tutorial—Advanced

Responsive Output Tutorial

Single-Sourcing Tutorial

Snippet Conditions Tutorial

Styles Tutorials

Tables Tutorial

Word Import Tutorial
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Cheat Sheets
Context-Sensitive Help Cheat Sheet

Folders and Files Cheat Sheet

Learning & Development Cheat Sheet

Lists Cheat Sheet

Micro Content Cheat Sheet

Print-Based Output Cheat Sheet

Search Cheat Sheet

Shortcuts Cheat Sheet

Structure Bars Cheat Sheet

Styles Cheat Sheet

APPENDIX  32



User Guides
Accessibility Guide

Analysis and Reports Guide

Architecture Guide

Autonumbers Guide

Branding Guide

Condition Tags Guide

Context-Sensitive Help Guide

Eclipse Help Guide

eLearning Guide

Flare Online Integration
Guide

Getting Started Guide

Global Project Linking Guide

HTML5 Guide

Images Guide

Import Guide

Indexing Guide

Key Features Guide

Lists Guide

Meta Tags Guide

Micro Content Guide

Navigation Links Guide

Plug-In API Guide

Print-Based Output Guide

Project Creation Guide

QR Codes Guide

Reviews & Contributions With
Contributor Guide

Scripting Guide

Search Guide

SharePoint Guide

Skins Guide

Snippets Guide

Source Control Guide: Git

Source Control Guide:
Perforce Helix Core

Source Control Guide:
Subversion

Source Control Guide: Team
Foundation Server

Styles Guide

Tables Guide

Tables of Contents Guide

Targets Guide

Template Pages Guide

Templates Guide

Topics Guide

Touring the Workspace Guide

Transition From FrameMaker
Guide

Translation and Localization
Guide

Variables Guide

Videos Guide

What's New Guide
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