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CHAPTER 1

Introduction
Lingo's Translation Editor lets you work in Translation (or grid) mode, with the source content in one
column and the target language in the next column. For some types of files—such as Flare topics,
snippets, and master pages; Microsoft Excel, PowerPoint, and Word documents; DITA files; HTML
files; and XML files—you can also switch to Live Preview mode, which lets you view content in its
intended context. A suggestions area at the bottom of the Translation Editor lets you quickly select
and insert matching translations from your translation memory (TM) database.
This chapter discusses the following:
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7

Steps for Translating Files
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Types of Content
In Lingo you can translate many types of files in the Translation Editor, including the following:
n

Adobe FrameMaker files (FM, MIF, and BOOK)

n

Adobe InDesign files (IDML)

n

DITA files (DITA, DITAMAP, XML)

n

Doc-To-Help projects (D2H)

n

HTM and HTML documents

n

JSON files

n

MadCap Capture image files (BMP, GIF, JPG, JPEG, PNG, TIF, TIFF)

n

MadCap Contributor files (MCDOC)

n

MadCap Flare package files (FLPRJZIP)

n

MadCap Flare projects (FLPRJ)

n

MadCap Lingo bundles (ZIP)

n

MadCap Mimic movies and collections (MIMOV, MIPRJ)

n

Microsoft .NET Resource files (RESX)

n

Microsoft Excel documents (XLS, XLSX)

n

Microsoft PowerPoint documents (PPT, PPTX)

n

Microsoft Word documents (DOC, DOCX)

n

Properties files (.properties)

n

Rich text files (RTF)

n

SDL Trados newer files (SDLXLIFF)

n

SDL Trados older files (TTX)

n

SQL files

n

SVG files

n

TXT files

n

Wordfast files (TXML)
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n

XLIFF 1.2 files (XLF)

n

XML files

NOTE: If you are using the grid view (as opposed to the folder structure view) in the File List
window pane, you can use the Filter field to see only specific types of files in the list (e.g.,
snippets), or you can select All Files to show all translation file types in the same list.
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Steps for Translating Files
Although you do not need to use TM when translating files, it is recommended that you do so. Therefore, before following the steps below, make sure you have performed the necessary setup tasks for
TM. See "Translation Memory" on page 56.

HOW TO TRANSLATE FILES
1. (Optional) Before you start translating text, you may want to select Home > Translate project
with TM. This scans your translation memory to find 100% matches for untranslated segments and applies those translations accordingly. See "Applying Translation Memory Suggestions" on page 94.
2. From the File List window pane, open the file you want to translate.
The file segments are shown in the Translation Editor. The source text is shown in the left
column. The right column, which is initially empty by default, is where you enter the translation.
NOTE: You can customize the way the Translation Editor and Translation Memory
Editor display translation segments. You can display the source and target segments
next to each other, or with the source segment above the target segment. You can
also adjust the editor font size, which resizes translation segments, translation suggestions, and segment notes based on your desired font size.
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3. Click in a target cell (the right column) of a segment row. The cell may remain empty until you
type in it, or the cell may become immediately filled with a perfectly matching translation
from TM.
NOTE: If you change the fuzzy matches percentage in the Options dialog, a segment
doesn't necessarily have to have a 100% match to be automatically filled in when you
click on it. For example, you can change the option so that segments with a 95%
match are considered exact.
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NOTE: If you prefer to use the old behavior from previous versions of Lingo (i.e., automatically display a copy of source segments even if no match is found in TM), you
can select a check box on the Translation Memory tab of the Options dialog (File >
Options).

4. Do one of the following:
n

Type your translation.
OR

n
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If the TM Suggestions tab below shows a match for the segment that you want to use,
double-click it. The target cell becomes filled with that translation. You can keep the
translation as it is, or you can click in the cell and adjust it.
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5. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Home ribbon. In the Translation section select one of the Confirm buttons.

n

Keyboard Shortcut Press Enter.
OR
Press CTRL+SHIFT+Down Arrow or CTRL+SHIFT+Up Arrow on your keyboard (to move
to the next or previous untranslated segment, respectively).

n

Right-Click Right-click in the cell and from the context menu select Confirm.

The translation is confirmed and focus moves to the next appropriate cell. After a segment is
translated and confirmed, the Status cell becomes gray and a check mark is shown in it. Also,
if you are using TM, the translation is automatically uploaded to the database.
6. Click
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to save your work.
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Translation Features
When translating files in Lingo, you have access to numerous features.
This chapter discusses the following:
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Filter
A segment filter at the top of the Translation Editor lets you limit the segments shown in the editor.
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USING THE FILTER
To use the filter, type text in the Source Filter and/or Target Filter field to search for content in
either. Then either press Enter on your keyboard or click
ing your search are shown.

. As a result, only the segments match-

EXAMPLE
Let's say you have the following segments in the Translation Editor:
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You want to limit the segments shown to only those where the name "Jack" appears in
the source segments. So you type Jack in the Source Filter field and click
ult, only a few segments are now shown.
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. As a res-
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Then let's say you want to further limit the segments so that, of those shown, only
those with "Jill" on the target side are included. Therefore, you type Jill in the Target
Filter field and click
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. Now the list of segments is further reduced.
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REGULAR EXPRESSIONS AND CASE-SENSITIVE TEXT
You can also select options to use regular expressions or to make the search case-sensitive.
EXAMPLE—REGU LAR EXPRESSION
Let's say you want to limit the results to only segments where the source sentences
begins with the letter w. First, you enter ^w in the Source Filter field. This is a regular
expression that looks for lines that begin with w.
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Then you click
and select Regular Expression. This enables Lingo to use the expression you just typed.

Finally, you press Enter on your keyboard and the list is shortened.
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EXAMPLE—C ASE-SENSITIVE
Let's say you have the following segments in the Translation Editor:
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You want to limit the segments shown to only those that contain the word "song" in the
source. So you type song in the Source Filter field and click
segments are now shown.
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. As a result, only a few
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However, let's say you want to limit the results to only the segments where the word is
lowercase. So you click

After you click
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and select Case Sensitive.

again, only one segment is found where song is found in lowercase.
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CLEARING THE FILTER AND RESETTING THE EDITOR
When you want to clear the search fields and show all of the segments again, you can click

.

EXAMPLE
Let's say you have used the filter fields so that the Translation Editor shows only a
single segment in the file.
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Now you want to clear the filter fields and return to the original view showing all of the
segments in the file. To do this, you simply click
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Translation Memory
At the bottom of the editor is the TM Suggestions tab. If matching content has already been translated and uploaded to the translation memory (TM) database, it displays in the suggestions area
with the following information:
n

% Match Displays a numerical ranking for the match. For example, if 100 is displayed, the content matches 100%; if 85 is displayed, the content matches 85%; and so on.

n

Source Displays the word(s) in the source language.

n

Translation Displays the translated word(s) in the target language.

n

Source TM Displays the name of the TM database containing the translation match.

For more information, see "Translation Memory" on page 56.
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Machine Translation
Machine translation (MT) is translation of text by a computer or translation program, such as
Google Cloud Translation. A great benefit of MT is that it allows translators to translate a large
amount of content quickly using an automated translation system, and then make any necessary
updates to the translation on a case-by-case basis (e.g., using a termbase to replace certain words,
fixing translations that are not accurate in context). Then, the translator can add the target segments to an installed TM, improving the speed for future translations as well. See "Machine Translation" on page 144.

Termbases
A termbase is a concept-oriented database that makes translation work easier and quicker by letting you create, manage, and reuse multilingual terminology from a single storage area. This system
automatically displays previously translated words from your termbase during the translation process, thus improving the reliability of translations. For more information, see the online Help or the
Termbase Guide PDF.
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Notes for Segments
For each segment in the Translation Editor, you can enter a note. For example, you might want to
add a note to remind yourself to do additional research about a term, or to tell a reviewer why a particular translation was used.
A Note column on the right side of the segment row and a tab at the bottom of the editor are available for this purpose.
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To add a note, open the Segment Notes tab at the bottom of the editor. You can do this in one of the
following ways:
n

Click the Segment Notes tab.

n

Click the Note icon

n

Right-click in the segment and in the context menu select Add Note.

for that segment.

In the Segment Notes tab, type in either the Source Note or Target Note area. If you want to create
a new paragraph, press CTRL+Enter. After you enter a note, the icon changes in the Note column.
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NOTE: When translating .properties files, only the value is translatable. The entire value pair
is added to the segment as a segment note for your reference.

NOTE: You can translate metadata tags in PDF and EPUB targets. The metadata type is
added to the segment as a segment note for your reference.
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NOTE: When you import a Doc-To-Help project file into Lingo, additional project information
(e.g., variables, keywords, topic titles) is imported as part of the D2H file. Open the D2H file
in Lingo to translate these segments. A translation note is created for each segment so you
can see what kind of data is contained in the segment. Click
on the Segment Notes tab.

to see the translation note

NOTE: Segment notes travel with the project. Therefore, if you create a new Lingo project
based on the same source files, the same notes will not automatically be associated with
those segments because it is a new project.

NOTE: When you import a review package from Contributor, any annotations from the
reviewer are added to the segment as segment notes. For more information, see the Lingo
online Help.
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Adding Numbers from Source Segments
This option that lets you automatically copy a number from the source to the target cell. This helps
ensure that you do not accidentally retype an incorrect number during the translation.
You can add numbers from the source in the following ways:
n

Context Menu You can right-click in the segment and select Add Next Number.

n

Keyboard Shortcut You can press CTRL+, (comma) on your keyboard to add numbers to the
target in order.

n

Translate Ribbon From the Translate ribbon you can click Add Next Number.
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Right-Click/Keyboard Shortcut Options
Several options are available from the context menu when you right-click a segment in the Translation Editor.

You can also use keyboard shortcuts for these options.
n

Synonyms Lets you select words matched through the thesaurus.
NOTE: If there are no matches for a word in the thesaurus, the Synonyms option is
not displayed in the context menu.

n

Cut (CTRL+X) Cuts the selection and sends it to the clipboard.

n

Copy (CTRL+C) Copies the selection and sends it to the clipboard.
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n

Paste (CTRL+V) Pastes the selection from the clipboard to the place where the cursor is inserted.

n

Confirm (Enter) Confirms the translation, adds it to TM (if applicable), and moves focus to the
next segment. You can also press Enter on your keyboard to do this.

n

Split Segment (CTRL+T) Breaks the segment at the point where the cursor is placed, so that
the one segment becomes two.

n

Join Segments (CTRL+SHIFT+K) Merges the selected segments into a single segment.

n

Add Note Opens the Segment Notes tab at the bottom of the Translation Editor. This lets you
type a note related to the selected segment (for the source and/or the target). When you are
done, the Note icon to the right of the segment changes to reflect the fact that a note exists.

n

Clear Target Segment (CTRL+Delete) Removes all content from the target cell.

n

Copy Source to Target (CTRL+K) Copies all of the text, as well as the formatting or tags, from
the source to the target cell.

n

Add Next Tag (CTRL+N) Copies each tag in order from the source to the target cell.

n

Add Next Number (CTRL+,) Adds each number in order from the source to the target cell.

n

Add New Term Lets you add a term in the segment to a termbase.

n

Thesaurus (SHIFT+F7) Lets you view and select words related to those in an open translation
file.

You can edit shortcuts from the Options dialog.
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Live Preview Mode
When you translate text, the segments are shown in a grid format (i.e., Translation mode). If you
want to see the content in its original context (in paragraphs), click the toggle button
in the local
toolbar. This button lets you open Live Preview mode for certain file types (i.e., Microsoft Word,
Excel, PowerPoint, MadCap Flare, Capture images with callouts). Live Preview mode displays next
to the Translation Editor and updates in real time as you make changes in the Translation Editor. To
toggle the location of the Live Preview pane, click
horizontally or vertically.

. This toggles the Live Preview pane to display

EXAMPLE—WORD
When you first open a Word file in Lingo, it may look something like this, with text segments in a grid.
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After you click , the file looks just like it would in Word. You can still see the Translation Editor and make changes, which appear in the preview area as you make them.
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EXAMPLE—EXC EL
When you first open an Excel file in Lingo, it may look something like this, with text segments in a grid.
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After you click , the file looks just like it would in Excel. You can still see the Translation Editor and make changes, which appear in the preview area as you make them.
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EXAMPLE—POWERPOINT
When you first open a PowerPoint file in Lingo, it may look something like this, with text
segments in a grid.
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After you click , the file looks just like it would in PowerPoint. You can still see the
Translation Editor and make changes, which appear in the preview area as you make
them.
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If the PowerPoint document has multiple pages, and most do, select a different segment in the Translation Editor to view the slide.
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EXAMPLE—FLARE PROJECT WITH CAPTU RE IMAGE WITH CALLOU TS
This is an example of an untranslated Flare project, viewed in Live Preview mode.
Notice that the callout is part of the preview. This is because the callout is part of the
image, not part of the text for the topic file.
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When you open the image file, you can translate the callout separately.

NOTE: The Word preview feature supports DOC and DOCX files.

NOTE: The PowerPoint preview feature supports only PPTX files, not PPT files.
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Inline Formatting and Tags
Lingo lets you control formatting and other elements in segments so that the translation matches
the source in terms of more than just text. This is done through inline formatting styles and tags.
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INLINE FORMATTING
If the source document contains inline formatting that Lingo is able to read (e.g., bold, italic, underlined text), that formatting is displayed in the source cell in the Translation Editor. You need to apply
the same formatting to the appropriate text in the target cell.
You can apply inline formatting to the target segment in the following ways:
n

Inline Style(s) Field You can highlight the applicable text in the target segment. Then in the
local toolbar, click the Inline style(s) field and select the available formatting. This field displays only the formatting found in the source cell.
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n

Keyboard Shortcuts For much inline formatting (e.g., bold, italic, underline, superscript, subscript and any combination of these), you can use Microsoft Word shortcuts (e.g., CTRL+I for
italic, CTRL+B for bold). For font size, color, or background color, you must use the Inline style
(s) field as described above.
In addition, you can use a keyboard shortcut to access the Inline style(s) field. After highlighting the applicable text in the target segment, you can press CTRL+W to open the Inline
style(s) field. You can then use your keyboard to select the formatting.
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TAGS
Tags are shown for elements and formatting that Lingo is not able to read. For example, you might
see miscellaneous tags when you import a Word document. Also, Flare project elements such as
bookmarks, variables, conditional text indicators, or index keywords are represented by tags. It is
not important that you know the purpose of each tag. As the translator, your job is to make sure the
same tags in the source segment are added to the target segment and placed next to the appropriate words.
You can add tags in the following ways:
n

Context Menu You can right-click in the segment and select Add Next Tag.

n

Drag and Drop You can click on tags in the source cell and drag them to the target cell.

n

Home Ribbon From the Home ribbon you can click Add Next Tag.

n

Keyboard Shortcut You can press CTRL+N on your keyboard to add tags to the target in order.

EXAMPLE
The segment below includes a condition tag.

Lingo places yellow conditional text tags on either side of the text that were marked
with a condition tag indicator in the source document. You can hover over the tags to
see information about the condition that is applied to the text.

When the translator translates the segments, he can drag the yellow tags into the target segments, so the translation will also include the condition tag. Later, when the
translator exports the document back to Flare, the condition tag will appear in the finished project.
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ERROR AND WARNING ICONS
If the source segment contains formatting or tags, you might see an error or warning icon in the
Status column. You can hover over the icon for additional information about the error or warning.
This warning icon means that the source segment contains formatting or tags, but that you
have not yet added them to the target segment. If you see this icon, you can still save, export,
or preview the file (when applicable). In addition, you can confirm the translated segment as
completed.
This error icon means that you have incomplete tags in the target segment. In other words,
some tags require a beginning and ending tag, and if you have only one of those, Lingo identifies it as invalid and gives you the error. If you see this icon, you cannot save, export, or preview the file (when applicable).

EXAMPLE
The following example shows segments with inline formatting and a tag, as well as the
error icon:
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NOTE: If you want all formatting to be displayed as tags in the Translation Editor and Translation Memory Editor (as in previous versions), you can select a check box in the Options dialog. You may need to close and re-open files in the project to see the change.

NOTE: If you are not sure what a tag means, you can click the toggle button
in the local
toolbar of the editor to switch to Preview mode to see the content in its intended context.

NOTE: Unflattened snippets and variables appear as tags in a segment. You can translate
these items by opening the snippet or variable file in from the File List. See "Content Flattening" on page 186.
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NOTE: If a concept or index tag appears at the beginning or end of a segment, it is not displayed in the Translation Editor. This makes segments look cleaner in the Translation Editor,
and prevents translators from needing to move tags that are not related to the segment.
Additionally, these tags are not displayed in Live Preview mode. Index and concept
keywords are still displayed if they appear between two words. You can translate any index
and concept tags in a project when you open the index keyword or concept keyword file
from the File List window pane.
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NOTE: Tags (e.g., spans) are removed from a segment if they wrap the entire translation
unit. The exception to this is condition tags, which are not removed if they span the entire
unit (this is because condition tags can affect translation status).
Similarly, unflattened snippets, conrefs, and variables will be removed from the Translation
Editor if they span the entire translation unit (e.g., a snippet that makes up an entire segment).
This content will be added back into the project when you export it. Be sure to translate the
content in the associated content file in the File List so it will be translated in the finished
project.

NOTE: When you import and export Translation Memory eXchange (TMX) files, the formatting and tag data are included. See "Importing TMX Files" on page 116 and "Exporting Translation Memory Files" on page 118.

CHAPTER 2

50

Setting the Translated Status of Files
You can set the translation status (e.g., Untranslated, In Progress, Completed, Reviewed, Approved)
of a particular file. This is an optional task. Its purpose is to help you keep track of your work. The
status that you select affects the Status column in the File List window pane.
In addition to setting the status manually, it can be set automatically when certain actions are performed. For example, if you begin translating segments in a file, the status automatically changes to
"In Progress." Also, let's say you bundle a project and send it to a translator. When you do this, the
status of all files in the bundle automatically changes to "Sent for Translation." If the translator completely translates a file in that project and returns it to you, and then you merge the bundle back into
the project, that file status automatically changes to "Completed."
You can manually set the translation status from one of the following locations.
n

Translation Editor Local Toolbar This is the quickest way to set the status for a single file.

n

Properties Dialog (Accessed From the File List Window Pane) This is best if you want to set
the same status for multiple files.

HOW TO SET THE FILE STATUS FROM THE TRANSLATION EDITOR
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the View ribbon. In the Pane section select File List.

n

Keyboard Shortcut Press CTRL+R.

The File List window pane opens.
2. Double-click a file to open it in the Translation Editor.
3. In the local toolbar of the Translation Editor, click the status drop-down field
and select a status.
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HOW TO SET THE FILE STATUS FROM THE PROPERTIES DIALOG (VIA THE FILE LIST
WINDOW PANE)
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the View ribbon. In the Pane section select File List.

n

Keyboard Shortcut Press CTRL+R.

The File List window pane opens.
2. From the list, select one or more files. You can hold the SHIFT key to select a range, or you
can hold the CTRL key to select individual items.
3. In the local toolbar, click

. The Properties dialog opens.

4. Select the Translation tab.
5. In the Translation Status section, select one of the options.
6. Click OK.

NOTE: If a Flare project or Contributor document contains file tags, you may see them in
the Lingo project, and some of these file tags may pertain to file status. However, whereas
the statuses described above have to do solely with the translation status of files, the file
tags from the author probably have to do with the overall creation of each file (e.g., produce
first draft, send for review, send to translator). The author may ask you to edit these file
tags when you complete the translation of each file. Therefore, you can right-click on files,
select Properties, choose the File Tags tab, and adjust the status.

NOTE: If you are working with a multilingual project, you can change the active target language in the Project Properties dialog (File > Project Properties). This will change the language of the files shown in the File List window pane.
The translation status displayed in the File List is shown for the active target language (for
example, a file might be translated in Spanish, untranslated in French, and already sent for
review in German).
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Sending Translated Content for Review
You can send translated content to individuals for review. For example, you might use this feature if
you are an author who has received files back from a translator and you want to send them to a
third party (who does not have access to Lingo) to ensure the translations are correct. When you
use this feature, you can export translations as a MadCap Contributor review package.
Before you send a Contributor review package to a reviewer, be sure the reviewer has the latest version of Contributor installed. Reviewers do not need to purchase a license to use Contributor review
Lingo files; instead, they can use Contributor's free review mode to review Lingo files.

HOW TO SEND TRANSLATED CONTENT FOR REVIEW
1. Select File > Review. The Save Review Package dialog opens.
2. (Optional) If you are working with a multilingual project, you can use the Filter by language
drop-down to filter the project files. You can filter by all languages and by individual languages.
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NOTE: You will only see this option if you are working with a multilingual project.
3. The files that can be exported and sent for review are on the left side of the dialog. Select the
file(s) that you want to send for review. You can hold the SHIFT key to select a range, or you
can hold the CTRL key to select individual items.
4. Click

. The selected files are moved to the right side of the dialog. If you want to move any

items back to the left, you can select them on the right side and click

.

5. Click Finish.
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6. A dialog opens where you can select a location to save the MadCap Lingo Review Package
(LIREV file). Navigate to the location where you want to save the file, enter a name for the file
in the File name field, and then click Save.
When the process is completed, a confirmation dialog asks if you want to open the folder
where you saved the file. Click OK to see the file location or click Cancel to return to Lingo.
7. Email the appropriate file(s) to individuals for review.

NOTE: You cannot add or remove languages to a project while files are being reviewed. You
must import the completed review package before you can add or remove languages.

NOTE: If you filtered your project using target or condition filters, the Save Review Package
dialog reflects the filters you applied. You can only send files for review if they are part of
your current project. See "Dynamic Filtering" on page 205.

After you send the review package for review, the reviewer opens it in MadCap Contributor, makes
changes and/or comments, and returns it to you. You can then import the package back into your
project. For more information, see the Lingo online Help.
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CHAPTER 3

Translation Memory
A translation memory (TM) system is a database that consists of content in a source language next
to the translated content in one or more target languages. The great benefit of a TM system is that
it remembers what you have already translated in previous projects and uses it to provide suggestions for future translation work. You can connect your Lingo project to one or more TM databases.
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This chapter discusses the following:
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Translation Memory Features
Features of TM in Lingo include the following:

Local or Server Translation Memory
You must have SQL installed to take advantage of server TM and termbases in Lingo. SQLite and
SQL Express are the types of SQL supported. See "Creating a Translation Memory Database" on
page 69.

SQLITE (LOCAL)
SQLite is a self-contained relational database system that is in the public domain. In Lingo, SQLite
is intended for local TM databases and termbases, not those that reside on an external server.
SQLite is easier and faster, just not quite as robust as SQL Express.
SQLite is automatically installed during the process of installing Lingo. For more information about
this database system, see www.sqlite.org.
By default, the location for SQLite databases is in “Documents\Lingo Translation Memories” on
your computer. However, you can choose a different location if you like.

SQL SERVER EXPRESS (SERVER)
SQL Server Express is designed to be used on a server with Lingo. To download and install the
latest version of SQL Server Express, go to http://www.microsoft.com/downloads/.
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Multiple Translation Memory Databases Per Project
You can connect multiple TM databases to your project. See "Choosing a Translation Memory Database" on page 73.
EXAMPLE
Let's say you are creating a new project and have already created a few TM databases
previously. In the Start New Project wizard, you might see something like this:
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Rank Translation Memory Databases
You can rank TM databases. This lets you select the order in which you want to apply segments
when translating or pre-translating a project. Lingo will also prioritize higher-ranked TMs when showing suggestions in the TM Suggestions pane. See " " on page 134.
EXAMPLE
You can rank each enabled TM.
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The results from the highest-ranked TM are given priority on the TM Suggestions tab.

Suggestions Based on Previous Translations
TM remembers the translation work that you have uploaded and uses it to make suggestions when
you translate content in the future.
NOTE: Using the Options dialog (File > Options or Tools > Options) you can adjust the percentages for matches to change the behavior of the interface. This lets you determine how
closely translations must match text in order to be shown in the interface and/or be used
automatically. You can also specify how to handle exact matches, whether they are automatically accepted or not when TM is applied. See "Setting Match Options for Suggestions"
on page 124 and "Accepting Exact Matches on Applying Translation Memory" on page 127.
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Statuses and Matches
When you are working in the Translation Editor, you will notice that various statuses may be used for
each segment in a document. These often relate to how closely a segment matches a previously
translated segment in TM. Different colors and percentages are used to indicate a segment's
status. See "Statuses and Matches" on page 83.

Updating Segments with Context (101%) Matches
There is a check box in the Options dialog related to 101% matches in translation memory (TM). It is
labeled "Update segments with context matches." This option dictates what you see in the Translation Editor when you confirm multiple translations of segments that have 101% matches. See
"Updating Segments with 101% Matches" on page 128.

Updating Translations with Identical Sources
There is a check box in the Options dialog that lets you dictate what happens when you have multiple identical source terms and you begin translating, confirming, and uploading them to translation
memory (TM). After segments are confirmed, what happens to those that are not yet translated?
Are translations for those segments updated accordingly? That's what this check box lets you control. See " " on page 131.

Translation Memory eXchange
The purpose of Translation Memory eXchange (TMX) is to allow easier transmission of TM data
between tools and/or translation vendors with no loss of critical data during the process. See "Translation Memory eXchange" on page 115.

Edit Translation Memory Databases
You can open your TM database and edit it. From the Translation Memory Editor, you can delete
items, make corrections, add new segments, and import/export TMX files. See "Editing a Translation Memory Database" on page 99.

View Metadata and Clean Up Databases
When editing a TM database, you can view metadata for each translation unit. These additional
details for each translation help you identify each segment. Some of this information is gathered
from the project details you enter when you initially create the project (e.g., the client and domain),
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and some is gathered as you edit the TM segment (e.g., the time the segment was last modified
and the user who last changed it). You can view the metadata for each segment, and you can filter
the entire translation memory to only display segments that have specific metadata.
Translation memory cleanup lets you use TM metadata to find and replace within a TM segment or
delete TM segments. You can use metadata to search within the TM and locate specific segments,
such as those created by a certain user or those pertaining to a specific client. You can also use
translation memory cleanup to remove duplicate segments in your translation memory.
See "Translation Memory Metadata" on page 106 and "Cleaning Up the Translation Memory" on
page 110.

Pre-Translate Files
You can automatically apply matching translations from a TM database, and if there are spots
where you do not have matches, you can choose to have Lingo fill in those segments with matches
from a machine translation provider. See "Applying Translation Memory Suggestions" on page 94.
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EXAMPLE
Let’s say you have performed a great deal of translation work for a particular client.
Once in a while, the source files from that client contain identical segments to those
you have already translated in previous projects, and you have uploaded those translations to TM. One day, this client sends you some source files for a new translation project, and these source files include 73 segments that you have already translated for
them in the past. During the process of creating the new Lingo project, you select the
TM database containing those translations and you click Pre-translate. When Lingo finishes creating the new project, it automatically applies matching translations to all 73
of those segments.

EXAMPLE
Let’s say you are translating a project using a TM that has been passed along to you
from a former colleague. It was assembled using translations from lots of other projects, and you're not sure exactly how accurate it will be, but you want to make a first
pass through your project to see what matches there are.
You build a new project and add the TM, then tell Lingo to pre-translate the project
using matches from the TM only. When it finishes, you have a few solid matches and a
lot of fuzzy matches. However, you also have quite a few empty segments.
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You decide to rebuild the project and add an MT provider as a backup for the pre-translation option, because you know it will fill in the gaps where you are missing translations. You also know it will provide machine translated suggestions in the
TM Suggestions area for all your segments, so you can refer to these when updating
your fuzzy translations later.
When the new project finishes, you have translations for most of your segments. Now
you can review the MT suggestions and make any necessary adjustments, and then
add new translations where needed. When you're done, you can add all the completed
translations to the existing TM so you'll have a better database to work with in the
future.

NOTE: Lingo will use your existing fuzzy match settings to fill in matches using the TM. In
the Options dialog (File > Options or Tools > Options), you can change the percentage for
fuzzy matches to be filled in. See "Setting Match Options for Suggestions" on page 124.

NOTE: In the Options dialog, you can select a check box labeled "Accept Exact Matches
upon applying TM." This option automatically confirms matching segments that are applied
at the project or file level. See "Accepting Exact Matches on Applying Translation Memory"
on page 127.
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NOTE: If you apply TM to a project with multiple TM databases selected, Lingo applies
matching translations from the highest-ranked database. If no databases are ranked, Lingo
applies matching translations from the first database selected.

NOTE: If you apply TM and a segment has multiple exact or context matches, Lingo applies
the match from the highest-ranked TM database. If no databases are ranked or there are
multiple matches in the same database, Lingo applies the first match it finds in the TM database.
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Steps for Using Translation Memory
Following are the general steps for using TM:
1. Install SQL In order to use features such as translation memory, you need to have SQLite or
SQL Express Server. SQLite is automatically installed during the process of installing Lingo,
but you must install SQL Express Server separately if you want to use that.
2. Create TM Database Before you can take advantage of translation memory, you need to create at least one database. See "Creating a Translation Memory Database" on page 69.
3. Choose TM Database You need to choose which TM databases you want to use for a particular project. You can choose one or more databases per project. See "Choosing a Translation Memory Database" on page 73.
4. Upload TM Content for Suggestions When you translate text in a project, your work can be
uploaded to a TM database. This enables Lingo to make suggestions while you translate text
in the future. If your project is already associated with a TM database, translations are
uploaded automatically whenever you finish translating and confirming a text segment.
5. Translate With TM Suggestions You can apply TM suggestions to a segment when you are
translating files. You can do this manually for each segment you come across that has a
match, or you can automatically apply matching translations across the entire project or a
single file. See "Applying Translation Memory Suggestions" on page 94.

IMPORTANT: If you are using source control, do not include your local termbase (.litdb3)
and translation memory (.db) files in your project folder. These files do not function correctly when used with source control, and can cause conflicts. Instead, you should use a
server termbase or translation memory. This will allow other users to have access to the
terms in the database while avoiding possible conficts.
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NOTE: If you are having difficulty connecting to a remote Lingo database, it may be due to
the security setting of SQL. To view a remote server, you must have administrator rights on
that server. You can add users to a local machine as administrators or add users in SQL
Management Studio. To do this in Management Studio: (1) open SQL Server Management
Studio (for more information see msdn.microsoft.com); (2) expand the server and then
expand Security; you’ll probably have a login called "BUILTIN\Administrators," which will
have "sysadmin" rights; in that case, any admin of your machine will have sysadmin rights
because they’re part of that group; and (3) add anyone to this who will need to access your
server.

NOTE: If your database is not displaying when you are setting up TM, your SQL browser service may not be enabled. To enable this service: (1) open SQL Server Management Studio
(for more information see msdn.microsoft.com), (2) open the SQL Server Configuration
Manager, (3) open the SQL Server Browser and go to the Service tab, (4) change the Start
Mode to Automatic, and (5) click Apply, and (6) start your SQL Server Browser.

NOTE: When would you use a termbase, and when would you use TM? The two are related,
but not the same thing. TM is used for quickly applying previously translated segments.
Termbases are really an extra tool for making sure you are using the correct term in a translation (i.e., context). That's why termbases let you provide additional info about each term.
Also, TM is necessary in order to use a termbase and apply its suggestions, but a termbase
is not necessary in order to use TM.
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Creating a Translation Memory Database
Before you can take advantage of translation memory, you need to create at least one
database. You can create a local TM database (using SQLite), which is stored locally on your computer. Alternatively, you can create a server TM database (using SQL Express), which can be stored
on an external server.

HOW TO CREATE A TRANSLATION MEMORY DATABASE
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Resources ribbon. In the Translation Memory section, select Create
TM.

n

Start New Project Wizard On the second page of the wizard, select Create TM.

2. From the submenu, select one of the following:
n

Local Select this option if you want to use SQLite for a local TM database. This option
opens a simple dialog that lets you give the new database a name and choose where to
store it. By default, the location for SQLite databases is in Documents\Lingo Translation
Memories on your computer. However, you can choose a different location if you like.

n

Server Select this option if you want to use SQL Server Express for a TM database to be
stored on a server. This opens a dialog with fields for the name, server, and security
information related to the database.
NOTE: If you do not already have SQL Server Express installed and you try to
install a server termbase or server translation memory, Lingo will prompt you to
install SQL Server Express 2012. This version of SQL Server Express is supported
on Windows 7, Windows Server 2008 R2, and Windows Server 2008 Service Pack
2,. However, it is not supported on Windows 8. If necessary, you can manually
install another version of SQL.
To download and install the latest version of SQL Server Express, go to:
http://www.microsoft.com/downloads/
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NOTE: In order to create a server translation memory or termbase, you must
have both db_datareader and db_datawriter roles , or you must have the dbcreator role. This is set in your SQL management tool.
In the following user mapping image, the user has both db_datareader and db_
datawriter selected:
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In the following server role image, the user has dbcreator selected:

For a server TM, in the Name of new database field, type a name for the TM database. Next to
the Database server field, click
. The Connect to SQL Server dialog opens, displaying a list
of usable servers after Lingo scans your network. In the Connection timeout field, you can
adjust the number of seconds to allow a connection to the server to be successful. In the
Authentication section, you can use Windows Integrated Security (the default), or you can
enter a specific user name and password for the server (if necessary). If you elect to use Windows Integrated Security, leave the user name and password fields blank. Otherwise, if your
server requires specific credentials, enter them in the fields provided.
3. After completing the fields in the appropriate dialog, click OK.
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Adding a Translation Memory Database
You can add as many translation memories (TMs) as you need. For example, you might use one TM
for Client A, a different TM for Client B, and yet another for Client C. When you add a TM, it can be
used in any of your Lingo projects.
Adding a TM is different from creating one. While creating a TM generates a new, empty database,
adding a TM takes one that already exists on your computer, network, or server and adds it to the
list of available TMs in Lingo. This is useful if you had removed a TM from the list of available databases, but you need to use it again.

HOW TO ADD A TM
1. Select the Resources ribbon. In the Translation Memory section, select Choose TM.
The Manage Translation Memory dialog opens.
2. Click

.

3. From the submenu, select one of the following:
n

Local Select this option if you want to select a TM that resides on your computer or network. Next to the Select existing Translation Memory field, click Browse. A dialog opens
where you can locate the TM. Click Open.

n

Server Select this option if you want to use a TM that resides on your SQL Server. This
opens a dialog with fields for the name, server, and security information related to the
database.

For a server TM, locate the TM you want to use on the server. Next to the Translation memory
server field, click Browse. The Select Database dialog opens, displaying a list of usable servers
after Lingo scans your network. On the right side of the dialog, available databases display.
Select the database you want to use, then click OK. The name of the database appears in the
Translation memory name field. In the Authentication section, you can use Windows Integrated Security (the default), or you can enter a specific user name and password for the
server (if necessary). If you elect to use Windows Integrated Security, leave the user name
and password fields blank. Otherwise, if your server requires specific credentials, enter them
in the fields provided. If you want to create a new server TM instead of using an existing TM,
click Create New Server TM. See "Creating a Translation Memory Database" on page 69.
4. After completing the fields in the appropriate dialog, click OK.
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Choosing a Translation Memory Database
You need to choose which TM databases you want to use for a particular project. You can choose
one or more databases per project.

HOW TO CHOOSE A TM DATABASE
1. Make sure you have created at least one TM database. See "Creating a Translation Memory
Database" on page 69.
2. Select the Resources ribbon. In the Translation Memory section, select Choose TM.
The Manage Translation Memory dialog opens.
3. Next to each TM in the grid that you want to associate with the project, click Use.
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You can also use the dialog to do any of the following:

ADD/REMOVE TM DATABASES TO/FROM GRID
If you have additional TM databases that are not shown in the grid, you can add them. Click
Add and from the drop-down select one of the following:
n

Local Select this option if you want to use SQLite for a local TM database. This option
opens a simple dialog that lets you give the new database a name and choose where to
store it. By default, the location for SQLite databases is in Documents\Lingo Translation
Memories on your computer. However, you can choose a different location if you like.

n

Server Select this option if you want to use SQL Server Express for a TM database to be
stored on a server. This opens a dialog with fields for the name, server, and security
information related to the database.
NOTE: If you do not already have SQL Server Express installed and you try to
install a server termbase or server translation memory, Lingo will prompt you to
install SQL Server Express 2012. This version of SQL Server Express is supported
on Windows 7, Windows Server 2008 R2, and Windows Server 2008 Service Pack
2,. However, it is not supported on Windows 8. If necessary, you can manually
install another version of SQL.
To download and install the latest version of SQL Server Express, go to:
http://www.microsoft.com/downloads/
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NOTE: In order to create a server translation memory or termbase, you must
have both db_datareader and db_datawriter roles , or you must have the dbcreator role. This is set in your SQL management tool.
In the following user mapping image, the user has both db_datareader and db_
datawriter selected:
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In the following server role image, the user has dbcreator selected:

In addition, you can remove TM databases from the grid if you do not want to see them. This
does not delete the databases altogether; it simply removes them from the interface. To
remove a TM database, select the row in the grid and click Remove.
EXAMPLE
The following shows how you might add or remove TM databases:
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CREATE NEW TM DATABASES
You can also create new TM databases. This is different from the option to add databases.
Adding a database simply makes sure a TM that already exists is shown in the grid so you can
select it. On the other hand, creating a database builds a brand new database, adds it to the
grid, and automatically selects the Use check box so that it will be associated with the project.
To create a new TM database, click Create and select Local or Server, depending on whether
you want to create a SQLite or SQL Express database, respectively. Then complete the fields
in the appropriate dialog. See "Creating a Translation Memory Database" on page 69.
EXAMPLE
Let's say you are creating a new Lingo project and you already have one local TM
database that you plan to use.

However, you want to create an additional local database to use in the project.
So you select Create and select Local.
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The New Local Translation Memory Database dialog opens. You give the database a name and keep the default location where it will be stored.
When you are finished, the new database is shown in the grid and the Use check
box is automatically selected.
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RANK TRANSLATION MEMORY DATABASES
You can apply a rank to your TM databases or change their existing ranks. Higher-ranked
TM databases will take priority in translation suggestions and are used first when applying a
TM to the entire project. Select a rank for the database in the Rank column.
See " " on page 134.

NOTE: You can only rank enabled TMs. The Rank drop-down is disabled if a TM is not
selected for the project.
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DELETE TM DATABASE
You can delete a TM database by selecting the row and clicking Delete. This not only removes
the TM from the grid, but it deletes it entirely.

IMPORT TMX FILES
If you already have a Translation Memory eXchange (TMX) file containing translations, you
can import it into any of the TM databases shown in the grid. To do this, select the database
in the grid, then click Import. Complete the fields in the dialog and click Start Import. See
"Importing TMX Files" on page 116.
EXAMPLE
Let's say you are creating a new project and you have created a new TM database. The new database is obviously empty. However, you have a TMX file with
lots of translations, and you want the new database to have these translations.
So with the database selected in the grid, you click Import.

Finally, you would use the dialog that opens to find and select the TMX file to
import.

EXPORT TMX FILES
If you have a termbase file in Lingo, you can export it into a Translation Memory eXchange
(TMX) file to share with others or to save for later. To do this, select the database in the grid,
then click Export. Complete the fields in the dialog and click Start Export. See "Exporting
Translation Memory Files" on page 118.
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SPECIFY ACCESS—READ & WRITE VERSUS READ ONLY
In the grid listing TM databases, there is a drop-down field to specify the access rights for
each database. There are options for Read & Write, as well as for Read Only. By default all
databases are set to Read & Write, which means they can be altered once they are loaded
into the Lingo project. However, you can change any of the databases to Read Only access if
you want. In order to switch to Read Only access, the Use check box must first be selected for
that database.
EXAMPLE
Let's say you are connecting your new Lingo project to four different TM databases, like this:

You want to receive translation suggestions from all of the databases. However,
when you confirm new translations and upload them to TM, let's say you only
want to upload them to the database called "Local1." Therefore, even though the
Lingo project will be connected to all four databases, three of them should be set
as Read Only, and Local1 should be set to Read & Write.
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NOTE: You can only specify access rights for enabled TMs. The Access drop-down is
disabled if a TM is not selected for the project.
4. Click OK.

NOTE: You can also choose a TM when creating a new project.
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Statuses and Matches
When you are working in the Translation Editor, you will notice that various statuses may be used for
each segment in a document. These often relate to how closely a segment matches a previously
translated segment in TM. Different colors and percentages are used to indicate a segment's
status.

Name

Context
Match

Default
Color

Definition

This is a segment that exactly matches a
translation in TM, where its context (the segment before or after) is also an exact match.
A context match gives you an additional level
of confidence in the matching translation and
therefore displays it as a 101% match. Context matches can be especially useful for
those who translate files with recurring sentences and paragraphs (e.g., legal documents) and want to make sure the same
section is translated just as they did it in
another file.
As soon as you accept a translated segment,
it is considered a context (101%) match,
because Lingo not only adds it to TM, but it
also immediately saves the context separately.

Percentage
Shown in
Status
Column

Percentage
Shown in
TM Suggestions Tab

101% if segment was
added to
TM before
project was
created

101%

Original percentage
(e.g., 0%,
81%, 100%)
if segment
was added
to TM after
project was
created

The contexts of the segments are also imported or exported when you import or export
TMX files.
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Name

Exact
Match

Default
Color

Definition

This is a segment that exactly matches a
translation in TM, without regard to its context.

Percentage
Shown in
Status
Column

Percentage
Shown in
TM Suggestions Tab

100%

100% before
you accept
segment
100% or
101% after
you accept
segment

Repetition

This is an identical segment to a previous one
in the same file, where a translation for the
segment has already been uploaded to TM.

100%

100% before
you accept
segment
101% after
you accept
segment

Context
Repetition
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This is a segment that is a combination of a
context match and a repetition. It functions
just like a regular repetition, except the match
in TM also has context (i.e., the segment
before or after it is also an exact match).

101%

101%
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Percentage
Shown in
Status
Column

Percentage
Shown in
TM Suggestions Tab

This is a segment that matches a translation
in TM, but it is less than an exact match. In
the Options dialog, the default setting is to
show matches in the Translation Editor if they
are at least 50%, but you can increase or
decrease this percentage.

Initially 0%,
then less
than 100%
(e.g., 73%)
once you
select it for
that segment

Less than
100% (e.g.,
73%) before
you accept
segment

Confirmed

This is a segment where a translation has
been entered and confirmed, thus sending
that translation to TM if necessary.

Original percentage
(e.g., 101%,
100%, 73%,
0%)

101% (and
perhaps
other
matches)

Machine
Translated

This is a segment that was supplied by a
machine translation provider. Machine translated segments do not register as TM suggestions, and therefore do not show a
percentage match in the Status column.

0%

0%

Name

Fuzzy
Match

Default
Color

Definition

101% (and
perhaps
other
matches
less than
100%) after
you accept
segment

However, if you accept the machine translated suggestion, it is confirmed and added to
the TM. If you use the suggestion again
later—as a TM suggestion and not as an MT
suggestion—it will show a TM status and percentage (e.g. context match, exact match).
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EXAMPLE—C ONTEXT MATCHES
The following shows some context matches where the translated segments were
added to TM before the project was created:
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The following shows a context match where the translated segment was added to TM
after the project was created:
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EXAMPLE—EXAC T MATCHES
The following shows two segments in a file that have exact matches in TM:
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EXAMPLE—REPETITIONS
The following shows a segment that is a repetition of an identical segment in the same
file:
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EXAMPLE—C ONTEXT REPETITIONS
The following shows two segments in a file that are context repetitions of other segments in the same file:
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EXAMPLE—FU ZZY MATCHES
The following shows a segment in a file that does not match the translated segment
exactly. It is a fuzzy (or partial) match:
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EXAMPLE—C ONFIRMED SEGMENTS
The following shows some segments in a file that have been confirmed:
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EXAMPLE—MAC HINE TRANSLATED SEGMENTS
The following shows some segments in a file that were generated using machine translation.

NOTE: Formatting and punctuation differences might cause an exact text match to result
in something less than 101% or 100% (e.g., because some words in the segment are in bold,
it might be considered a 95% match instead).

NOTE: You can change the color for any of the statuses via the Options dialog. See
"Changing Segment Status Colors" on page 123.
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Applying Translation Memory Suggestions
You can automatically apply matching translations from a Translation Memory (TM) database to
segments in a project. In other words, the target cell in the Translation Editor will be populated with
the translation. This does not mean the translation is completed. You still need to confirm each one.
You can apply TM suggestions at the project, file, or segment level.

HOW TO APPLY TRANSLATION MEMORY TO A PROJECT—WHEN CREATING IT
1. Begin the process of creating a project.
2. On the third page of the wizard, select the TM.
3. From the Pre-translate options drop-down, select Pre-translate with TM. This automatically
applies TM suggestions to the segments in the project.

CHAPTER 3

94

EXAMPLE
Let’s say you have performed a great deal of translation work for a particular client. Once in a while, the source files from that client contain identical segments
to those you have already translated in previous projects, and you have uploaded
those translations to TM. One day, this client sends you some source files for a
new translation project, and these source files include 73 segments that you
have already translated for them in the past. During the process of creating the
new Lingo project, you select the TM database containing those translations and
you click Pre-translate. When Lingo finishes creating the new project, it automatically applies matching translations to all 73 of those segments.
4. Finish the steps for creating the project.
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HOW TO APPLY TRANSLATION MEMORY TO A PROJECT—AFTER IT IS CREATED
1. Open the project.
2. Select the Home ribbon. In the Utilize TM section select Translate project with TM.
A message lets you know if segments were applied, and how many.
3. Click OK.

HOW TO APPLY TRANSLATION MEMORY TO A FILE
1. Open the file in the Translation Editor.
2. In the local toolbar click
many.

. A message lets you know if segments were applied, and how

3. Click OK.

CHAPTER 3

96

HOW TO APPLY TRANSLATION MEMORY TO A SEGMENT
n

In the Translation Editor, click in the empty target cell. The matching suggestion is applied
immediately to that cell.

NOTE: By default, TM suggestions are applied in the current target language, but you can
apply them in all target languages. You can change your language settings in the Project
Properties dialog.
If you choose to pre-translate your project during project creation, TM suggestions are
applied to the whole project across all languages, regardless of the setting in the Project
Properties dialog.

NOTE: To confirm a segment, click in that Target cell and press Enter.

NOTE: Lingo will use your existing fuzzy match settings to fill in matches using the TM. In
the Options dialog (File > Options or Tools > Options), you can change the percentage for
fuzzy matches to be filled in. See "Setting Match Options for Suggestions" on page 124.

NOTE: Be aware that TM rankings take priority over fuzzy match percentages. If you set a
minimum match percentage and you ranked your TMs, a segment in the highest-ranked
TM will take priority over a segment in the lower-ranked TM, even if the higher-ranked segment has a lower fuzzy match percentage. See "Ranking Translation Memories" on page
135.

NOTE: In the Options dialog, you can select a check box labeled "Accept Exact Matches
upon applying TM." This option automatically confirms matching segments that are applied
at the project or file level. See "Accepting Exact Matches on Applying Translation Memory"
on page 127.
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NOTE: If you apply TM to a project with multiple TM databases selected, Lingo applies
matching translations from the highest-ranked database. If no databases are ranked, Lingo
applies matching translations from the first database selected.

NOTE: If you apply TM and a segment has multiple exact or context matches, Lingo applies
the match from the highest-ranked TM database. If no databases are ranked or there are
multiple matches in the same database, Lingo applies the first match it finds in the TM database.

NOTE: If you translate a segment in Lingo and then update the source for that segment,
the source content may no longer match the translation provided by the TM or machine
translation. If this happens, the TM Source column displays "Xliff Alternate," to indicate that
a previous translation is stored in the XLIFF file.
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Editing a Translation Memory Database
You can open your database and edit it in various ways.
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HOW TO EDIT A TRANSLATION MEMORY DATABASE
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Resources ribbon. In the Translation Memory section select Edit TM
and choose the database.

n

Translation Editor In the TM Suggestions area at the bottom of the editor, right-click on
the segment and from the context menu select Edit Text.

The Translation Memory Editor opens.
2. You can do any of the following:

ADD A SEGMENT
a. In the local toolbar, click

. A new row is added to the bottom of the editor.

b. Click on the row to select it.
c. In the text fields at the bottom of the editor, enter the text for the source language on the
left, and enter the text for the target language on the right.
d. Press Enter on your keyboard.
e. Click

to save your work.

EDIT A SEGMENT
a. Select the row that you want to edit.
b. In the cells on the left, edit the text for the source language. In the cells on the right, edit
the text for the target language.
c. Press Enter on your keyboard.
d. Click

CHAPTER 3

to save your work.

100

DELETE A SEGMENT
a. Do one of the following:
n

Select the row and click

.

n

Select the row and press Delete on your keyboard.

n

Right-click the row and select Delete Row from the context menu.

A line appears through the middle of the text.
b. Click

to save your work.

NOTE: You can also delete TM segments from the Suggestions area at the bottom of
the Translation Editor. Simply right-click on the segment to be deleted from TM and
select Delete from the context menu.

SEARCH FOR A TERM
n
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FILTER THE TRANSLATION MEMORY USING METADATA
a. In the local toolbar of the editor, click

. The Metadata Filter dialog opens.

b. In the dialog, select the metadata you want to use to filter the TM. You can filter by creator, project, client, domain, document, last modifier, date created, and date modified.
You can also sort the results.

c. Click OK.
d. To reset your filters and see the entire TM, in the local toolbar, click
ation, see "Translation Memory Metadata" on page 106.
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CLEAN UP THE TRANSLATION MEMORY USING METADATA
a. In the local toolbar of the editor, click

.

b. From the drop-down, select one of the following options:
n

TM—Find and Replace Use metadata to find and replace words within the TM

n

TM—Delete Use metadata to search for segments you want to delete from the TM

n

TM—Cleanup Use metadata to remove duplicate segments in the TM

c. In the dialog that opens, select the metadata you want to use to filter the TM to complete
the clean up. For more information, see "Creating a Translation Memory Database" on
page 69.

FILTER LANGUAGES
a. In the local toolbar click in the Language drop-down field.
b. Select any of the available options to display the segments for certain languages.

IMPORT A TRANSLATION MEMORY EXCHANGE (TMX) FILE
a. In the local toolbar, click
b. Click

. The Import TMX File dialog opens.

.

c. In the dialog that opens, navigate to the TMX file that you want to import, and doubleclick it.
d. (Optional) By default, the current database is shown in the Translation Memory field. If
you are working with other databases and want to use a different one instead, select it
from this field.
You might use this field, for example, if you forgot to change to the database you want
before starting the import process.
e. Click Start Import.
A message lets you know the results of the import. For more information see "Importing
TMX Files" on page 116.
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EXPORT SEGMENTS TO A TMX FILE
a. In the local toolbar, click

. The Export to TMX Dialog opens.

b. Next to the TMX File field, click

.

c. In the dialog that opens, navigate to the folder where you want to export the file. Also in
the File name field, enter a name for the new TMX file. Then click Save.
d. In the Languages to export field, all of the languages involved in your translation memory
database are listed, showing both the source and target languages. Select the languages
that you want to include in the exported TMX file.
e. In the Source language field, select the language(s) that you want to be available as the
source in the exported TMX file. You can select an individual language or you can select
"Any," which allows tools to use translations in any direction in the TMX file.
f. Click Start Export. A message lets you know the results of the export. For more information see "Exporting Translation Memory Files" on page 118.

USE THE THESAURUS
n

Right-click a word, and from the context menu select Thesaurus.

3. If a certain number of items have been found, page navigation buttons in the local toolbar
may be enabled. You can use these buttons to go to additional pages to display more items.

NOTE: You can spell check the Translation Memory Editor using manual spell check.

NOTE: The Find and Replace window pane is disabled when the focus is on the Translation
Memory Editor. However, you can use the Quick Find and Quick Replace widgets to find and
replace terms in the TM. For more information, see the Lingo online Help.

NOTE: You can change the font size and segment display options for the Translation
Memory Editor using the Options dialog. For more information, see the Lingo online Help.
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NOTE: If you are not seeing segments in the editor that you expect to see, try clearing the
Search field. You might also need to select different languages from the local toolbar.
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Translation Memory Metadata
Translation memory (TM) metadata adds additional details to each translation in the TM to help you
identify each segment. Some of this information is gathered from the project details you enter
when you initially create the project (e.g., the client and domain), and some is gathered as you edit
the TM segment (e.g., the time the segment was last modified and the user who last changed it).
You can view the metadata for each segment, and you can filter the entire TM to only display segments that have specific metadata.
You can also clean up your TM using find and replace, or by deleting segments that match your
search criteria. You can also use TM cleanup to remove duplicate segments in your TM. See "Cleaning Up the Translation Memory" on page 110.

HOW TO VIEW TRANSLATION MEMORY METADATA FOR A SPECIFIC SEGMENT
You can view TM metadata so you know details about who created or modified a TM segment, what
project it is in, the language of the source or target segment, and more. TM metadata is an easy
way to know more about your segments, and it can also be used to filter and clean up your projects.
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Resources ribbon. In the Translation Memory section select Edit TM
and choose the database.

n

Translation Editor In the TM Suggestions area at the bottom of the editor, right-click on
the segment and from the context menu select Edit Text.

The Translation Memory Editor opens.
2. In the editor, in the Metadata column next to the segment for which you want to view
metadata, click

.

The Metadata Viewer dialog opens.
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3. View the metadata for the TM segment. You can see metadata for both the source and target segment, as well as information about who created the original translation and when they
created it.

4. Click OK.
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HOW TO FILTER THE TRANSLATION MEMORY
You can use metadata to filter your TM to show segments that have specific metadata. This can
help you find certain segments, and is especially useful if you have a very large TM.
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Resources ribbon. In the Translation Memory section select Edit TM
and choose the database.

n

Translation Editor In the TM Suggestions area at the bottom of the editor, right-click on
the segment and from the context menu select Edit Text.

The Translation Memory Editor opens.
2. In the local toolbar of the editor, click

.

The Metadata Filter dialog opens.
3. In the dialog, select the metadata you want to use to filter the TM. You can filter by creator,
project, client, domain, document, last modifier, date created, and date modified. You can
also sort the results.

CHAPTER 3

108

EXAMPLE
Let's say you want to filter your TM to show all the TM segments by a certain
translator that are also part of a specific project. Your TM looks like this before it
is filtered:

But after you filter it using creator and project metadata filters, it looks like this:

4. Click OK.
5. To reset your filters and see the entire TM, in the local toolbar, click
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Cleaning Up the Translation Memory
Translation memory (TM) cleanup lets you use TM metadata to search within the database and locate specific segments, such as those created by a certain user or those pertaining to a specific client. Using this information, you can then clean up your TM using find and replace, or by deleting
segments that match your search criteria. You can also use TM cleanup to remove duplicate segments in your TM.
TM cleanup is especially beneficial if you have a very large database. If you have made edits over
time to your TM, it may have duplicate segments that you are unaware of. Also, if you have imported several TMX files into your TM, there may be outdated information that needs to be updated
with new terminology or removed altogether. TM cleanup is an easy way for you to manage your
database within Lingo.
You can view TM metadata in the Translation Memory Editor. See "Translation Memory Metadata"
on page 106.

HOW TO FIND AND REPLACE CONTENT IN THE TRANSLATION MEMORY
You can find and replace content in your TM. This is useful if you need to make a global update to
your TM and do not want to search through your TM database manually. You can find and replace in
the source or target segment, which is also helpful if a client changes her terminology and you need
to change your existing translation to reflect their new language.
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Resources ribbon. In the Translation Memory section, select Edit TM
and choose the database.

n

Translation Editor In the TM Suggestions area at the bottom of the editor, right-click on
the segment and from the context menu select Edit Text.

The Translation Memory Editor opens.
2. In the local toolbar of the editor, click

. From the drop-down, select TM—Find and Replace.

The TM Cleanup: Find and Replace dialog opens.

CHAPTER 3

110

3. In the dialog, enter the word you want to find in the TM, and the word you want to replace it
with. Then use the drop-downs to filter the segments in the TM so you only replace words in
the appropriate location. You can filter by creator, project, client, domain, document, last modifier, date created, and date modified. You can also sort the results.
EXAMPLE
Let's say your client changed her terminology and you need to make a global
change to a word in your documentation. You decide to search for words in a specific project for a specific client.
Enter the word you want to find, the word you want to replace it with, and set
your filters.

When the filter processes, the word is replaced in your translation memory.

4. Click OK.

CHAPTER 3

111

NOTE: Making changes using Find and Replace updates the word you are searching
for, but it does not update the corresponding translation or source word. Remember
to make any necessary changes to the corresponding source or target segment as
well, so your translations are accurate.
For example, if your client changes the word "airplane" to "bus," and you make this
change in the source segment but forget to update the target segment, the TM will
not know that the word is incorrect and will show this as a match in future translations.

NOTE: Any changes you make to the TM only affect future translations. They do not
replace any previous translations you have done.
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HOW TO DELETE ENTRIES IN THE TRANSLATION MEMORY
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Resources ribbon. In the Translation Memory section select Edit TM
and choose the database.

n

Translation Editor In the TM Suggestions area at the bottom of the editor, right-click on
the segment and from the context menu select Edit Text.

The Translation Memory Editor opens.
2. In the local toolbar of the editor, click

. From the drop-down, select TM—Delete.

The TM Cleanup: Delete dialog opens.
3. In the dialog, select the metadata you want to use to delete entries from the TM. You can filter by creator, project, client, domain, document, last modifier, date created, and date modified. You can also sort the results. When deleting TM segments, you can also sort by
language.

4. Click OK to permanently delete these entries from the TM.
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HOW TO CLEAN UP DUPLICATE TRANSLATION MEMORY ENTRIES
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Resources ribbon. In the Translation Memory section select Edit TM
and choose the database.

n

Translation Editor In the TM Suggestions area at the bottom of the editor, right-click on
the segment and from the context menu select Edit Text.

The Translation Memory Editor opens.
2. In the local toolbar of the editor, click

. From the drop-down, select TM—Cleanup.

3. A confirmation window opens asking if you want to remove duplicates. This will permanently
remove repeated segments from the TM database. If you want to proceed, click OK.
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Translation Memory eXchange
The purpose of Translation Memory eXchange (TMX) is to allow easier transmission of translation
memory data between tools and/or translation vendors with little or no loss of critical data during
the process.
In Lingo, you can import TMX files from tools such as Trados and memoQ. This lets you leverage all
prior translations, whether or not they occurred in the same project or document. By importing a
TMX file into Lingo, all of your past translation work will become available as suggestions when you
are localizing content in Lingo. Then, when you have finished translating content in Lingo, you can
export the TMX files so that they can be used again in the other tools.
See "Importing TMX Files" on the next page and "Exporting Translation Memory Files" on page 118.
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Importing TMX Files
You can import files from tools such as Trados and memoQ. This lets you leverage all prior translations, whether or not they occurred in the same project or document.

HOW TO IMPORT A TRANSLATION MEMORY
1. Select Resources > Import TMX.
2. Next to the TMX File field, click

.

3. Navigate to the TMX file that you want to import, and double-click it.
4. (Optional) If you want to be informed of matching segments, click Check TMX for repeated
segments.
If this option is selected, you will be informed if alternative or duplicate segments are found in
your TM. Duplicate segments are not reimported.

EXAMPLE
Let's say you have the text "This is a car." In your TM database, you already have
this translated, using the word "coche" for "car." In the TMX file you are importing,
the translation is much the same, except the word "carro" is used. Therefore,
Lingo informs you that an alternative translation has been found.
On the other hand, if the translation in the TMX file also uses the word "coche" in
the translation, Lingo informs you that a duplicate translation has been found.
If you do not select the option to check for repeated segments, the import process is faster.
However, you are not informed of duplicate or alternate translations. Whether you select the
option or not, the translations in the TMX file are added to the TM database.
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5. (Optional) You can select Import alternate tag segmentation segments if necessary.
EXAMPLE
Let’s say you are importing a TMX file that was previously used for a third-party
translation tool. That tool might have treated the <strong> tag differently than
Lingo, so after you import the TMX file you might discover that some match results are not what you expect. By selecting this new option, Lingo will consolidate
those tags, which will produce better match results.
6. (Optional) By default, the current database is shown in the Translation Memory field. If you
are working with other databases and want to use a different one instead, select it from this
field.
7. Click Start Import.

CHAPTER 3

117

Exporting Translation Memory Files
When you have finished translating content in Lingo, you can export a file. After exporting a TMX
file, it can be used in other tools such as Trados and memoQ.

HOW TO EXPORT A TRANSLATION MEMORY
1. Select Resources > Export to TMX.
2. Next to the TMX File field, click

.

3. Navigate to the folder where you want to export the file. Also in the File name field, enter a
name for the new TMX file. Then click Save.
4. In the Languages to export field, select the language(s) to include in the exported TMX file.
5. In the Source language field, select the language(s) to be available as the source in the exported TMX file. You can select an individual language or you can select "Any," which allows tools
to use translations in any direction in the TMX file.
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EXAMPLE
Let's say that the "Languages to export" field shows English-to-Danish and English-to-German translations. Like this:
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If you select "English" in the Source Language field to the right, the tool using the
exported TMX file will be able to use the translations going from English to Danish or English to German.
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If you select "Any" in the Source Language field to the right, the tool using the
exported TMX file will be able to use the translations going from English to Danish, English to German, Danish to English, and German to English.

6. Click Start Export.
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Other Translation Memory Tasks
In addition to the features already discussed, there are a few other tasks related to translation
memory that you may need to do:
n

Changing Segment Status Colors (page 123)

n

Setting Match Options for Suggestions (page 124)

n

Accepting Exact Matches on Applying TM (page 127)

n

Updating Context Matches (page 128)

n

Updating Translations With an Identical Source (page 131)

n

Ranking a Translation Memory Database (page 134)

n

Removing a Translation Memory (page 141)

n

Deleting a Translation Memory (page 142)
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Changing Segment Status Colors
You can change the color for any of the statuses via the Options dialog.

HOW TO CHANGE SEGMENT STATUS COLORS
1. Select File > Options.
The Options dialog opens.
2. Select the Translation Memory tab.
3. In the Status Colors section, click on the colored rectangle you want to change. The Color
Picker dialog opens.
4. Select a new color.
5. Click OK.
6. If you want to return to the factory color settings for each status, click Reset to Default
Colors.
7. In the Options dialog click OK.
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Setting Match Options for Suggestions
Properties are available for specifying matching behavior for translation suggestions. This includes
minimum matches and fuzzy matches.

MINIMUM MATCHES
With this feature, only translations with a rank greater than or equal to a specified percentage will be
displayed as suggestions in the interface.

HOW TO SET A MINIMUM MATCH PERCENTAGE
1. Select File > Options.
2. Select the Translation Memory tab.
3. Enter a percentage in the field labeled Retrieve suggestions with minimum match of.
4. Click OK.

EXAMPLE
Let's say that you set this percentage to 50%. When using translation suggestions, you
might have one translation in your database that matches the current string exactly
(100%), another translation that matches it 75%, and a third translation that matches it
only 30%. In this case, only the first two translations will be available for you to select in
the interface.
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FUZZY MATCHES
With this feature, you can specify the percentage at which you can insert matching translations
automatically. By default, this percentage is set at 100%, meaning you can use automatic inserts
only when text strings match existing translations exactly. However, you can reduce this percentage if you wish. Any matching translation that falls below that specified percentage is considered "fuzzy," because it does not match the string closely enough to warrant an automatic insert.

HOW TO SET A FUZZY MATCH PERCENTAGE
1. Select File > Options.
2. Select the Translation Memory tab.
3. Enter a percentage in the field labeled Fill-in fuzzy matches of at least.
4. Click OK.

EXAMPLE
Let's say that you open a topic to translate the text in it. In the suggestions area at the
bottom of the Translation Editor, a few matching translations from your TM database
are shown. Perhaps two of the translations match segments exactly (100%) and there
are other partial matches that are below 100%. Perhaps one of those is a 98% match.
All of the partial matches, including the one at 98%, are considered "fuzzy."
When you first opened the Translation Editor, a message displayed. It might say something like this: "2 segments had matches of at least 100% and there were 3 other partial
matches. Do you want to use the top matches automatically?" If you select Yes, the
two translations that match text 100% will replace the corresponding strings in the
topic automatically. If you want to use any of the partial matches, you must do so
manually.
Now suppose you want to be able to automatically use matching translations if they
match 97% of the string text. Therefore, you set the fuzzy matching option to 97%. If
you then return to the same topic, this time the message will say the following: "3 segments had matches of at least 97% and there were 2 other partial matches. Do you
want to use the top matches automatically?" If you select Yes, both of the 100%
matches are automatically used, as is the 98% match (because it is no longer considered a "fuzzy match").
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NOTE: Be aware that TM rankings take priority over fuzzy match percentages. If you set a
minimum match percentage and you ranked your TMs, a segment in the highest-ranked
TM will take priority over a segment in the lower-ranked TM, even if the higher-ranked segment has a lower fuzzy match percentage. See "Ranking Translation Memories" on page
135.
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Accepting Exact Matches on Applying Translation Memory
When you apply translation memory (TM) suggestions , you can control how exact matches are
handled, whether they are automatically accepted or not. This is done by selecting a check box in
the Options dialog.

HOW TO ACCEPT EXACT MATCHES ON APPLYING TRANSLATION MEMORY
1. Select File > Options.
2. Select the Translation Memory tab.
3. Select Accept Exact Matches upon applying TM.
If this option is selected and you apply translation memory (TM), 100% or 101% matches are
automatically populated in the target cells and accepted. Therefore, the Status column for
those segments in the Translation Editor is displayed with a gray background and check mark.
If this option is not selected and you apply TM, 100% or 101% matches are simply populated in
the target cells; they are not yet confirmed. This lets you review those segments before manually accepting the matching translations.
4. Click OK.

NOTE: If you apply TM to a project with multiple TM databases selected, Lingo applies
matching translations from the highest-ranked database. If no databases are ranked, Lingo
applies matching translations from the first database selected.

NOTE: If you apply TM and a segment has multiple exact or context matches, Lingo applies
the match from the highest-ranked TM database. If no databases are ranked or there are
multiple matches in the same database, Lingo applies the first match it finds in the TM database.
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Updating Segments with 101% Matches
There is a check box in the Options dialog related to 101% matches in translation memory (TM). It is
labeled "Update segments with context matches." This option dictates what you see in the Translation Editor when you confirm multiple translations of segments that have 101% matches.

HOW TO UPDATE TRANSLATIONS WITH 101% MATCHES
1. Select File > Options.
2. Select the Translation Memory tab.
3. Select Update segments with context matches.

4. Click OK.
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EXAMPLE
Let's say you have a source file with the term "Car." Now suppose this term and has
already been translated to "Carro" in Spanish and added to the TM. When you click in a
segment with the term "Car," Lingo shows that it has a 101% match.
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If you change the translation to "Coche," confirm it, click back in that cell, and look
down at the TM Suggestions area, you will see both the old translation (Carro) and the
new one (Coche) as 101% matches.
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This is the default behavior, which is what happens when the check box in the Options
dialog is not selected.
If you select the check box in the Options dialog, create a new project, and follow the
same steps, you would see only one 101% match, the new one (Coche).
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Updating Translations with an Identical Source
There is a check box in the Options dialog that lets you dictate what happens when you have multiple identical source terms and you begin translating, confirming, and uploading them to translation
memory (TM). After segments are confirmed, what happens to those that are not yet translated?
Are translations for those segments updated accordingly? That's what this check box lets you control.

HOW TO UPDATE TRANSLATIONS WITH AN IDENTICAL SOURCE
1. Select File > Options.
2. Select the Translation Memory tab.
3. Select Update translations with identical source.

4. Click OK.
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EXAMPLE
Let's say you have a file with the term "Car" appearing three times.

Suppose you translate the first "Car" term as "Carro" and confirm it. The second and
third instances are marked as repetitions and the Carro translation is copied to them.

CHAPTER 3

133

If you change the translation for the second "Car" term to "Coche" and confirm it, the
third "Car" term remains as "Carro."

This is the default behavior, with the option not selected.
If this option is selected and you change the translation of the second "Car" term to
"Coche," all three of the rows will show that translation.
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Ranking Translation Memories
If you use multiple translation memories (TMs), you can assign them rankings to specify which database should take priority in translation suggestions. You can set these priority rankings when creating a new project or by using the Manage Translation Memory dialog (Resources > Choose TM).
The results from the highest-ranked database take priority when you translate or pretranslate an
entire project with a TM. If there are multiple identical source segments, Lingo will use the segment
from the highest-ranked TM. Suggestions from the highest-ranked TM will appear first on the
TM Suggestions tab in the Translation Editor.
Be aware that rankings take priority over fuzzy match percentages. If you set a minimum match percentage and ranked your TMs, a segment in the highest-ranked TM will take priority over a segment
in the lower-ranked TM, even if the higher-ranked segment has a lower fuzzy match percentage.
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HOW TO RANK A TM DATABASE
1. Make sure you have created at least one TM database. See "Creating a Translation Memory
Database" on page 69.
2. Select the Resources ribbon. In the Translation Memory section select Choose TM.
The Manage Translation Memory dialog opens.
3. Next to each TM in the grid that you want to associate with the project, click Use.

4. From the Rank drop-down, select a numeric ranking for each enabled TM, where 1 is the preferred TM. You do not have to select a value; unranked TMs will take lowest priority.
NOTE: You can only rank enabled TMs. The Rank drop-down is disabled if a TM is not
selected for the project.

NOTE: You cannot assign the same rank to more than one TM.
5. Click OK.
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EXAMPLE
You can rank each enabled TM.
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The results from the highest-ranked TM are given priority on the TM Suggestions tab.
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EXAMPLE
Let's say you have two TMs: a local TM and a server TM. They contain several similar
target segments. When selecting your TMs, you give the server TM a rank of 1 and the
local TM a rank of 2. You also have the fuzzy match percentage set to 50%. You decide
to pretranslate your project.
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Later, you are looking through your project and see a match that isn't completely accurate. The TM Suggestions tab shows you that it the match is from the server TM, and it
has a fuzzy match percentage of 50%. The TM Suggestions tab also shows a 101%
match from the local TM, which has a lower ranking.
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The match from the server TM was applied because it had a ranking of 1, and priority
over the server TM. If you want the segment with the higher match percentage to
always take priority, you can disable fuzzy matches (so only 100% or 101% matches will
be applied), or you can disable rankings. You can also manually select a match from
the TM Suggestions tab.

If you disable fuzzy matches, and there is a 100% or 101% match in both TMs, the
higher ranked TM will still take priority.
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Removing a Translation Memory
If you are no longer using a translation memory (TM) for a particular project, you can remove it,
which simply hides that database from the list of available TMs in your project. If instead you want
to delete a TM database permanently, see " " below.

HOW TO REMOVE A TM
1. Select the Resources ribbon. In the Translation Memory section, select Choose TM.
2. Select the TM that you want to remove.
3. Click Remove.
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Deleting a Translation Memory
If you no longer need a translation memory (TM) or the data in the TM, you can delete it.

WARNING: Be careful when deleting a TM. Deleting a TM permanently removes it from the
list and deletes all data from it.
If you want to keep the data in your TM, you should remove the TM, which only removes it
from the list instead of deleting it permanently. You can add the TM—and its data—back to
Lingo later if you need to use it again.

HOW TO DELETE A TM
1. Select the Resources ribbon. In the Translation Memory section, select Choose TM.
The Manage Translation Memory dialog opens.
2. Select the TM that you want to delete.
3. Click Delete.
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CHAPTER 4

Machine Translation
Machine translation (MT) is translation of text by a computer or translation program, such as
Google Cloud Translation. A great benefit of MT is that it allows translators to translate a large
amount of content quickly using an automated translation system, and then make any necessary
updates to the translation on a case-by-case basis (e.g., using a termbase to replace certain words,
fixing translations that are not accurate in context). Then, the translator can add the target segments to an installed translation memory (TM), improving the speed for future translations as well.
This chapter discusses the following:
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Steps for Using Machine Translation

150

Setting Machine Translation Options

151

Choosing a Machine Translation Provider

153

Translating Projects with Machine Translation

155
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Machine Translation Features
Features of machine translation in Lingo include the following:

CHOOSE FROM MULTIPLE MACHINE TRANSLATION PROVIDERS
You can choose from MT services to provide translation suggestions for your source segments. You
can also quickly translate your entire project using any single MT provider. Lingo currently supports
MT from Google Cloud Translation, Microsoft Translator, MyMemory, and DeepL. See "Choosing a
Machine Translation Provider" on page 153.

MACHINE TRANSLATE ENTIRE PROJECTS
MT lets you quickly translate a project using translation suggestions from an MT provider. Once you
have selected an MT provider, you can translate an entire project using MT. See "Translating Projects with Machine Translation" on page 155.
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PRE-TRANSLATE FILES
You can automatically apply matching translations from a TM database, and if there are spots
where you do not have matches, you can choose to have Lingo fill in those segments with matches
from a machine translation provider. See "Applying Translation Memory Suggestions" on page 94.
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EXAMPLE
Let’s say you are translating a project using a TM that has been passed along to you
from a former colleague. It was assembled using translations from lots of other projects, and you're not sure exactly how accurate it will be, but you want to make a first
pass through your project to see what matches there are.
You build a new project and add the TM, then tell Lingo to pre-translate the project
using matches from the TM only. When it finishes, you have a few solid matches and a
lot of fuzzy matches. However, you also have quite a few empty segments.
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You decide to rebuild the project and add an MT provider as a backup for the pre-translation option, because you know it will fill in the gaps where you are missing translations. You also know it will provide machine translated suggestions in the
TM Suggestions area for all your segments, so you can refer to these when updating
your fuzzy translations later.
When the new project finishes, you have translations for most of your segments. Now
you can review the MT suggestions and make any necessary adjustments, and then
add new translations where needed. When you're done, you can add all the completed
translations to the existing TM so you'll have a better database to work with in the
future.

MACHINE TRANSLATION SUGGESTIONS
If you do not want to translate the entire project using an MT or pre-translation, you can choose to
run MT in the background so you will see suggestions from the MT provider alongside suggestions
from your existing TM in the TM Suggestions area. You then can select any suggestion for a target
segment by selecting the segment and double-clicking the suggestion you want to use.
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FUTURE SUGGESTIONS BASED ON ACCEPTED MACHINE TRANSLATIONS
When a translation suggestion is initially accepted from the MT provider, the Status field displays a
0% match. This is because Lingo is not making the direct suggestion. But if you are using a TM in
your project (as recommended), and you accept a translation suggestion from the MT provider,
Lingo adds the segment to your TM as a 100% match. Because some MT providers charge a fee
based on the number of characters translated, this can save you money in the long run, since you
will not need to retranslate the file using the MT. If you need to retranslate the file, or if you translate
a file with similar segments using your TM, your TM will provide translation suggestions based on
your accepted translations.

CONCORDANCE SEARCHING
If you are using MT, you can use the concordance to search any of the suggestions your MT provider has returned. After you have enabled the MT for concordance searches, you can enter any
word in the concordance search window pane, and if it appears in an MT suggestion, the translation
will appear in the window pane. This lets you check for consistency in your project even if you do not
have a translation memory installed.
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Steps for Using Machine Translation
Following are general steps for using MT:
1. Obtain MT Provider Credentials Lingo supports MT from Google Cloud Translation, Microsoft
Translator, My Memory, and DeepL. To use any of these translation services, visit the provider's website and obtain credentials for translation use.
2. Enter MT Provider Credentials Before you can take advantage of MT in Lingo, enter your credentials for the MT providers you want to use. See "Setting Machine Translation Options" on
the next page.
3. Choose MT Provider(s) Select the provider you want to use to supply suggestions for your project. This enables you to see MT suggestions in the TM Suggestions pane and to translate the
entire project. See "Choosing a Machine Translation Provider" on page 153.
NOTE: You can select multiple providers if you want to see suggestions from more
than one MT service. However, if you want to translate your entire project at once,
you must choose a single provider from the Machine Translation Providers dialog.
See "Translating Projects with Machine Translation" on page 155.
4. Translate with MT You can apply MT suggestions to a segment when you are translating files,
or you can translate your entire project at once. You can do this manually for each segment
you come across that has a match, or you can automatically apply translations across the
entire project. See "Translating Projects with Machine Translation" on page 155.

NOTE: For a current list of supported languages for an MT, refer to the provider website.
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Setting Machine Translation Options
Before you can use machine translation (MT) to translate a project or provide suggestions for segments, you must provide authentication credentials for the MT provider(s) you want to use. You can
do this from Lingo's Options dialog.

HOW TO SET MACHINE TRANSLATION OPTIONS
1. Select File > Options.
2. Click the Machine Translation tab.
3. From the Select Machine Translation Provider drop-down, select an MT service. In the Settings area, enter your authentication credentials. Each provider requires different credentials.
n

Google Cloud Translation Enter your API Key.

n

Microsoft Translator Enter your API Key.
(Optional) In the Category field, you can also provide a category that you have previously set up in your Microsoft MT account.

n

MyMemory Enter your Key.

n

DeepL Enter your Authentication Key.

For information about MT provider usage and credentials, please visit each provider's website.
4. (Optional) Click Test Connection to verify that your credentials are correct.
5. (Optional) If you want to save previously used MT results in an XLIFF file, select Cache MT results as XLIFF alternates. This prevents the MT from looking for new translations for previously
translated segments. If the source segment is modified, the MT will look for a new translation
for the updated segment. If this option is disabled, the MT will look for new translations
whenever you click a target segment or translate the project with the MT.
6. (Optional) If you want MT suggestions to show up when you are doing a concordance search,
select Use MT in concordance searching. In the Concordance Search window pane, you can
tell whether a suggestion comes from translation memory (TM) or MT by hovering over a segment.
7. Click OK.
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NOTE: By default, MT suggestions are applied in the current target language, but you can
apply them in all target languages. You can change your language settings in the Project
Properties dialog.
If you choose to pre-translate your project during project creation, MT suggestions are
applied to the whole project across all languages, regardless of the setting in the Project
Properties dialog.
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Choosing a Machine Translation Provider
You can choose from multiple machine translation (MT) services to provide translation suggestions
for your source segments. You can also quickly translate your entire project using any single MT provider. Lingo currently supports MT from Google Cloud Translation, Microsoft Translator,
MyMemory, and DeepL. See "Machine Translation" on page 144.

HOW TO CHOOSE A MACHINE TRANSLATION PROVIDER
1. Select Resources > Choose MT.
2. Select the provider(s) you want to use for MT.

NOTE: You can select multiple providers if you want to see suggestions from more
than one MT service. However, if you want to translate your entire project at once,
you must choose a single provider from the Machine Translation Providers dialog.
See "Translating Projects with Machine Translation" on page 155.
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3. (Optional) If you have not yet entered credentials for the MT provider in the Options dialog
(see "Setting Machine Translation Options" on page 151), an additional dialog opens where
you can provide your authentication information.

TO APPLY MACHINE TRANSLATION SETTINGS
a. From the Select Machine Translation Provider drop-down, select an MT service. Then in
the Settings area, enter your authentication credentials. Each provider requires different
credentials.
n

Google Cloud Translation Enter your API Key.

n

Microsoft Translator Enter your API Key.
(Optional) In the Category field, you can also provide a category that you have previously set up in your Microsoft MT account.

n

MyMemory Enter your Key.

n

DeepL Enter your Authentication Key.

For information about MT provider usage and credentials, please visit each provider's
website.
b. (Optional) Click Test Connection to verify that your credentials are correct.
c. (Optional) If you want to save previously used MT results in an XLIFF file, select Cache
MT results as XLIFF alternates. This prevents the MT from looking for new translations
for previously translated segments. If the source segment is modified, the MT will look
for a new translation for the updated segment. If this option is disabled, the MT will look
for new translations whenever you click a target segment or translate the project with
the MT.
d. (Optional) If you want MT suggestions to show up when you are doing a concordance
search, select Use MT in concordance searching. In the Concordance Search window
pane, you can tell whether a suggestion comes from translation memory (TM) or MT by
hovering over a segment.
e. Click OK.
4. Click OK.

NOTE: For a current list of supported languages for an MT, refer to the provider website.
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Translating Projects with Machine
Translation
After you have selected a machine translation provider for your project, you can automatically apply
machine translation (MT) suggestions to segments in a project. In other words, the target cell in the
Translation Editor will be populated with the translation from your machine translation provider. This
does not mean the translation is completed. You still need to confirm each one.
You can apply MT suggestions at the project or segment level.
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HOW TO APPLY MT SUGGESTIONS TO AN ENTIRE PROJECT—DURING PROCESS OF
CREATING PROJECT
1. Begin the process of creating a project.
2. On the third page of the wizard, select the translation memory.
3. From the Select Machine Translation Providers drop-down, select the provider you want to
use. You can only select one provider when applying MT suggestions to the entire project.
You may have to click off of the drop-down after making your selection.
If you have not yet entered credentials for the machine translation provider in the Options dialog (see "Setting Machine Translation Options" on page 151), an additional dialog opens where
you can provide your authentication information.
4. From the Pre-translate options drop-down, select Pre-translate with TM then MT. This will
apply matches from the translation memory to segments in the project, then apply machine
translation to any segments that are not translated.
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EXAMPLE
Let’s say you are translating a project using a TM that has been passed along to
you from a former colleague. It was assembled using translations from lots of
other projects, and you're not sure exactly how accurate it will be, but you want
to make a first pass through your project to see what matches there are.
You build a new project and add the TM, then tell Lingo to pre-translate the project using matches from the TM only. When it finishes, you have a few solid
matches and a lot of fuzzy matches. However, you also have quite a few empty
segments.
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You decide to rebuild the project and add an MT provider as a backup for the pretranslation option, because you know it will fill in the gaps where you are missing
translations. You also know it will provide machine translated suggestions in the
TM Suggestions area for all your segments, so you can refer to these when
updating your fuzzy translations later.
When the new project finishes, you have translations for most of your segments.
Now you can review the MT suggestions and make any necessary adjustments,
and then add new translations where needed. When you're done, you can add all
the completed translations to the existing TM so you'll have a better database to
work with in the future.

5. Finish the steps for creating the project.

HOW TO APPLY MT SUGGESTIONS TO AN ENTIRE PROJECT—AFTER THE PROJECT IS
CREATED
1. Open the project.
2. Select the Resources ribbon. In the Machine Translation section, select Machine Translate
Project.
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HOW TO APPLY MT SUGGESTIONS TO INDIVIDUAL SEGMENTS
1. In the Translation Editor, click in an empty target cell.
2. In the TM Suggestions window pane, review the suggestions. If you selected multiple
machine translation providers, you may see more than one machine translation option.
3. Double-click the suggestion you want to apply. The matching suggestion is applied immediately to that cell.

NOTE: To confirm a segment, click in that target cell and press Enter. This also adds the
MT suggestion to your selected translation memory.

NOTE: You can select multiple providers if you want to see suggestions from more than
one MT service. However, if you want to translate your entire project at once, you must
choose a single provider from the Machine Translation Providers dialog.

NOTE: Machine translation is only applied to files if the status is set to In Progress or
Untranslated. If you have files marked with other statuses (e.g., Sent for Translation, Completed) and you run machine translation, segments in these files will not be affected.

NOTE: If you translate a segment in Lingo and then update the source for that segment,
the source content may no longer match the translation provided by the TM or machine
translation. If this happens, the TM Source column displays "Xliff Alternate," to indicate that
a previous translation is stored in the XLIFF file.
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CHAPTER 5

Concordance
Lingo lets you use a concordance to perform advanced searches in one or more translation
memory (TM) databases. You can also search suggestions from machine translation (MT) providers. This means you can search for words you've already translated to maintain consistency. The
concordance searches the TM and suggestions from MT; in contrast, the search filter in the Translation Editor looks only in the current file.
This chapter discusses the following:
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Concordance Search Window Pane
To use the concordance, first open the Concordance Search window pane (View > Concordance
Search).
By default, the window pane opens on the right side of the interface. It contains search fields as well
as some advanced options for further refining your search. The search results are displayed at the
bottom of the window pane.
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Search Fields
There are two search fields in the Concordance Search window pane. Each of these fields has a
drop-down that lets you select either the source or target, depending on what you want to be the
focus of the search—the original language or the translation language.
The primary reason for having two fields has to do with the equal and not-equal buttons in each
field. This lets you look for segments that contain a particular word or phrase (equal sign is used),
but to exclude segments that have another word or phrase, thus narrowing the search results.
EXAMPLE
Let's say you are translating the nursery rhyme Humpty Dumpty from English to Spanish, and you already have some translations in TM. If you want to find all segments in
the source language that contain the word "Humpty," you would select Source in the
first field, enter the word Humpty and click Search. The equal sign is left in its original
state.
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Now suppose you want to refine your search so that it excludes all source segments
that contain the word "wall." So in the second field, you select Source, click the equal
button so that it changes to "not equal," enter the word wall, and click Search. The
search results now show fewer segments, because one of the segments in the previous search contained the word "wall."

You can use the Reset button to clear the search fields, returning them to the default settings.

Advanced Options
If you want to make an even more detailed search, you an expand the Advanced Options area and
use any of the following:
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Field

Description

Regular
Expression

Regular expressions (also referred to as regex or regexp) are similar to wildcards in
that they let you find matching strings of text. However, they are more powerful than
wildcards.To use regular expressions in the Concordance Search window pane,
expand Advanced Options and select Regular Expression. Then enter the regular
expression in the second search field.
EXAMPLES
Following are some examples of regular expressions:
Expression

Description

[a-z]

Matches any lowercase letter

[A-Z]

Matches any uppercase letter

\d

Matches any decimal digit

\D

Matches any non-digit

\s

Matches any white-space character

{…}

Explicit quantifier
For example, a{3} finds "aaa"

|

Alternation
For example, gray|grey finds "gray" or "grey"

(…)

Logical grouping

?

0 or 1 of previous expression; forces minimal matching
when expression might match several strings within a
search string
For example, reg(ular expressions?|ex(p|es?) finds "regular expression," "regular expressions," regex, regexp, or
"regexes"

For more examples and information about regular expressions, see the
following:
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Field

Description

http://www.regular-expressions.info/
http://regexlib.com/CheatSheet.aspx

IMPORTANT: You can only use regular expressions in the second search
field with reference to whatever is in the first search field. The reason for
this is that the TM databases don't support regular expressions, so what
you're actually doing is filtering the results of the first search field.

NOTE: Lingo supports only .NET Framework regular expressions. For more
information, see http://msdn.microsoft.com/en-us/library/hs600312.aspx.

Case Sens- If you want Lingo to respect uppercase and lowercase characters in your conitive
cordance search, expand Advanced Options and select Case Sensitive. Case-sensitive searches can only be used with =, not with ≠.
TMs to
search
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Searching Machine Translated Suggestions
If you are using MT, you can use the concordance to search any of the suggestions your MT provider has returned. The process for searching remains the same, but you must first allow the MT to
be used in concordance searching.

HOW TO ENABLE THE MT IN CONCORDANCE SEARCHES
1. Select File > Options. The Options dialog opens.
2. Click the Machine Translation tab.
3. If you have not already done so, enter your authentication credentials for the MT provider(s)
you want to use.
4. To enable to the MT in concordance searches, select Use MT in concordance searching.
5. Click OK.
After you have enabled the MT for concordance searches, you can enter any word in the concordance search window pane, and if it appears in a machine translated suggestion, the translation
will appear in the window pane.
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CHAPTER 6

Bundles
You can bundle your Lingo project, exporting it to a ZIP or LIPRJZIP (Lingo Project Bundle) file. This
feature allows content developers to work with translators who must use a tool other than Lingo
(e.g., Trados, memoQ) to perform the actual translation work. With this process, Lingo helps to prepare your files before you send them to the translator.
This chapter discusses the following:
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Why Is Bundling Necessary?
So what is the benefit of using Lingo as a "middle man" in this translation effort? Why not just use
Word, Flare, or another tool for the documentation and then send those files directly to the translator? You can certainly send a translator raw files and bypass Lingo altogether, but this only works
well if your translator is very familiar with those kinds of files. And it is highly unlikely that your translator is an expert at Flare and understands all of the different types of files that make up a Flare project. Therefore, the best solution is usually one where the translator uses Lingo for the translation
work or when you (the content developer) use bundling in Lingo to manage the translator's work on
your end, incorporating the translated files back into Flare (or whatever tool you are using).
n

Ensure That All Files are Translated One of the best reasons to use bundling is that Lingo tells
you exactly what files need to be translated so that you do not accidentally miss some. This
might not be necessary when translating a simple Word document. But if you have a Flare project that requires translation, there are likely many different types of files that are easy to forget about—files such as skins, glossaries, search filter sets, and many more. If you translate
the Flare project in Lingo, the File List window pane shows exactly what needs to be translated, so there is no guessing. But if you try to translate that same Flare project in a third-party
tool, it can be extremely difficult to determine which files require translation.

n

Generate More Accurate Estimates Another good reason to use bundling is the statistics feature in Lingo. The statistics report lets you see exactly what has been translated and what still
requires translation.
This can positively affect a translator's estimates. For example, if you hire someone to translate a Flare project, the initial estimates given by the translator might be too low because several files may have been accidentally missed. After discovering the extra files, the translator
needs to adjust the estimates.
In addition, you can use the report to see how many matches were found in translation
memory (TM) for the segments. This is important because it is much less expensive for translators to use existing translations in a TM database than to produce new translations.

n

Avoid Rework When translating files, it's important for the translator to keep the folder structure that you have in place. Otherwise, the result could be lots of broken links and missing
information. With a Lingo bundle, you can be assured that the folder structure is maintained
throughout the process.

By using bundling in Lingo, you can avoid these issues. The translator will receive all of the files
requiring translation work, and only those files. This allows the translator to give you a more accurate estimate for the necessary work, and for you to see the statistics yourself. When you receive the
files back from the translator, you can use Lingo to verify that everything was translated and nothing
was left behind.
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Steps for Using Bundling
Bundling is different than most of the other features in Lingo because the individual using this feature in Lingo is typically the content developer, rather than a translator. The following steps show
how it works:
1. Create Lingo Project (Author) The author creates a Lingo project based on the project or files
that require translation.
2. (Optional) Create/Import Translation Memory (Author) You can create a new translation
memory (TM) database for the project and import a Translation Memory eXchange (TMX) file
from the translator. Your translator's quote should take into account previous translations
from the TMX file (which makes translation work less expensive than translating brand new
segments). You can view statistics (Step 6 below) on the project to see how many translations from the TMX file match segments in your source documents. See "Translation
Memory" on page 56, "Creating a Translation Memory Database" on page 69, and "Importing
TMX Files" on page 116.
3. Prepare and Send Bundle (Author) In Lingo, the author bundles the necessary files in the project. You can bundle all files or only selected files. To do this, open the File List window pane,
select the appropriate files, and click the Prepare Translation Bundle button . Then send the
bundle—which is either a ZIP file (if the translator will be using a third-party tool) or an
LIPRJZIP file (if the translator will be using Lingo). This bundle file consists of the content files
requiring translation, and can also consist of translation memory databases or termbases. For
more information see the online Help.
4. Translate Content, Send ZIP or LIPRJZIP File (Translator) Using a third-party tool or Lingo, the
translator performs the translation work, puts the completed files into a ZIP or LIPRJZIP file,
and sends it back to the author. For more information see the online Help.
NOTE: Translators must return a bundle in the same file format as the original bundle
they received. If you sent the translator a Lingo project file (*.LIPRJZIP), you should
receive an LIPRJZIP file back from the translator. Likewise, if you sent the translator
a ZIP file, should receive a ZIP file back.
5. Merge Completed Bundle (Author) The author reintegrates the translator's work with the
Lingo project (by clicking the Merge Completed Bundle button
pane). For more information see the online Help.
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6. Ensure Completeness (Author) There are a few ways that the author can ensure completeness of the translations. For more information see the online Help.
n

Statistics You can select File > Compute Statistics. This displays a statistics report
showing detailed information for the project and each file. Using this report, the content
developer can see exactly how many words and segments were translated.

n

Reports In addition to running a statistics report, you can also run quality assurance
(QA) reports to find any discrepancies between the source and target segments in your
project. To do this, you can select File > Project QA, then select the type of QA report
you want to run. Using these reports, the content developer can find errors the translator may have missed, such as formatting or punctuation inaccuracies, misuse of the
termbase, or repeated segments.

n

Status The File List window pane lists each content file and various information for
each. One of the columns in this window pane is named "Status." This column displays
the translation status of each file (e.g., Untranslated, In Progress, Completed,
Reviewed, Approved). The translation status can be set manually, or when certain
actions are performed, the status is set automatically. After a translator returns a
bundle and you merge it back into a Lingo project, the status of each file is updated,
depending on the situation. If the translator only partially translates a file, the status
changes to "In Progress." If the translator finishes translating all segments in a file, the
status changes to "Completed." If the translator returns the file untouched, the status
remains "Untranslated."

n

Review You can export translated content to a MadCap Contributor review archive file
(LIREV) and send it to a third party for review.

7. Export Translated Projects (Author) After ensuring that everything is completely translated,
the author exports the Lingo project to the necessary file(s) (e.g., a new Flare project, a new
Word document).
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EXAMPLE
Bob is a technical writer for a small company that does not have in-house translators.
He uses MadCap Flare to create his English documentation and then sends that project to an outside vendor to translate the content into Spanish. The translation company uses SDL Trados, so when the translator looks at the Flare files, he's not sure
which files need to be translated, how long it will take, or what it will cost. Bob also
doesn't know how much translation work is involved.
Therefore, Bob's company buys Lingo. Using Lingo, Bob creates a new project based
on his Flare documentation and installs a TM database. In Lingo he bundles the files
requiring translation and emails that ZIP file to the translator.
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Using SDL Trados, the translator imports the ZIP file and translates the content. The
translator puts the translated files back into a ZIP file—just like the one received—and
returns it to Bob.
Bob receives the email and saves the ZIP file to a folder on his computer. In his Lingo
project, Bob opens the File List window pane, selects the "Merge Completed Bundle"
option, and browses for the ZIP file received from the translator. Lingo takes the
bundle, extracts the files, and merges them into the Lingo project.
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Bob then selects File > Compute Statistics, which displays a report reflecting detailed
information about the translated files. The report is designed to warn Bob of any files
that the translator may have missed, and possibly consistency problems.
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In addition, Bob can look in the File List window pane to see the translation status of all
of the files.

If necessary, Bob can inform the translator of any files that were not translated and
request a new, updated ZIP file from the translator. After all of his files have been successfully translated, Bob exports the Lingo project to a new Flare project. So now he
has two Flare projects—the original English project, and the new Spanish project.
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NOTE: You cannot merge a bundle back into your project unless the files within it are
named the same as the files in the original bundle. Additionally, the bundle must have the
same folder structure as the original bundle (i.e., files must reside in the same relative locations and folders cannot have been renamed).
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Preparing Translation Bundles
If you are working with a translator who is using a third-party tool—such as Trados or memoQ—you
first need to package your Lingo project in order to separate the necessary files for the translator.
You can then send the bundle (which is a ZIP file or LIPRJZIP file) to the translator. This file consists
of the content files requiring translation.

HOW TO PREPARE A BUNDLE
1. Select View > File List.
NOTE: You can also create bundles from the TOC View window pane.
2. Select the files to be included in the bundle. You can hold the SHIFT key to select a range, or
you can hold the CTRL key to select individual items. Selecting multiple files can be done only
if you are in grid view.
3. In the local toolbar click the Create Bundle button

.

4. In the Bundle Settings area, select the file type for the bundle and the project files to include
with the bundle.
n

Lingo Project Bundle Packages the bundle as an LIPRJZIP file to send to a translator
who also uses Lingo.

n

XLIFF Files Bundle Packages the bundle as a ZIP file to send to a translator who uses
another third-party tool, such as SDL Trados or memoQ.

n

Language (Optional) Select the target language for the files in the bundle. You can
select an individual language or all languages.
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NOTE: You will only see this option if you are working with a multilingual project.

NOTE: If you need to send multiple languages to the translator, you can send
each language as individual bundles, or you can select All languages to send all
of the files in one bundle.

NOTE: You cannot add or remove languages to a project while a bundle is out
for translation. You must import the returned bundle before you can add or
remove languages. See "Bundles" on page 168.

n
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n

Include Project Termbases Includes the project's termbases with the bundle.
EXAMPLE
Let's say you are bundling a large Lingo project for translation. The project
is already partially translated, but you are using a new translator to finish
the project. By including the connected translation memories and termbases with the bundle, the new translator can use the previous translator's
completed work (using the translation memory), as well as any standards
for commonly used terms that you may have established with the previous
translator (using the termbase). This saves you time because you won't
need to review these things with the new translator, and it saves you
money because the new translator will not need to retranslate segments
that have already been completed.

5. (Optional) In the Bundle Files area, you can use the filters to search for additional files to
include with the bundle. You can filter by file type, translation status, and difference status.
Any project files not yet included in the bundle and that match your selected filters display in
the Project Files grid. Any files currently included in the bundle display in the Output Files grid.
NOTE: The filters available in your bundle depend on the files available in your project. For example, if you do not have any new files in your project, you will not see the
New difference status filter. If you add new files to the project, the New filter
becomes available.

NOTE: If you have already filtered your project using target or condition filters, the
available files reflect the filters you applied. You can only bundle files that are part of
your current project. See "Dynamic Filtering" on page 205.
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EXAMPLE
Let's say you have already sent your project to your translator to begin translating content. After a few weeks, you need to make a major, unexpected change
to a section of the documentation that you have already sent for translation.
Rather than sending the whole project to the translator again, you can use the
project files filters to send only the changed files to the translator.
After updating your project in Lingo, create a new bundle and use the project files
filter to locate files with a difference status of Different. Any files you changed
display in the Project Files grid. Select the files to include them in the bundle.

6. Click OK. The project is scanned and computed statistics for the project are shown (if you
have TM installed, as recommended).
7. Click Close. A Windows subfolder (within your project folder) named "Exporting" opens. This
subfolder holds a ZIP file or LIPRJZIP file, depending on the bundle settings you chose. This
file contains the files that your translator needs to work with.

CHAPTER 6

180

8. Send the ZIP file or LIPRJZIP file (via email, FTP, etc.) to the translator.
IMPORTANT: If you need to make changes to your bundle before you send it to the
translator, you should not remove files from the ZIP or LIPRJZIP file, as this could
cause problems merging the bundle back into Lingo later. Instead, it is recommended
that you create a new bundle and send the corrected bundle to the translator.
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Merging Completed Bundles
After the translator returns the completed ZIP or LIPRJZIP file, you can merge its contents into your
original Lingo project.

HOW TO MERGE A COMPLETED BUNDLE
1. Save the returned ZIP or LIPRJZIP file to a location on your computer.
2. In Lingo select View > File List.
NOTE: You can also merge bundles from the TOC View window pane.

3. In the local toolbar click the Merge Completed Bundle button

.

4. In the dialog find and double-click the ZIP or LIPRJZIP file that the translator returned. You
may need to select the appropriate file type from the file type drop-down. Click Open. The
updated files are merged with your project.
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NOTE: If you sent a multilingual bundle to the translator, when you merge the bundle, the
files will automatically merge into the appropriate language in your project.

NOTE: Translators must return a bundle in the same file format as the original bundle they
received. If you sent the translator a Lingo project file (*.LIPRJZIP), you should receive an
LIPRJZIP file back from the translator. Likewise, if you sent the translator a ZIP file, should
receive a ZIP file back.
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CHAPTER 7

Additional Features
In addition to the key features in Lingo, the following are also available:
n

Filters When working with translations in Lingo, you can create different kinds of filters to control what content is translated in your Lingo project. You can create filters for file types, targets, or conditions. You can also flatten snippets, variables, or DITA content references to
determine what content is translated within a segment. See "Filters" on page 186.

n

Language Skins When you create your Lingo project, you have the option to add a language
skin to your project. This generates a language skin file (LanguageSkin.fllng) containing several terms used in different Flare skins (e.g., "Table of Contents," "Glossary," "Home"). Translators can open the language skin file to translate these terms. This is especially useful if
there are custom terms in the Flare skin and they need to be translated to match the custom
interface. See "Creating Language Skins" on page 270.

n

Mapping Fonts If you are translating a project into multiple languages, you may need to use
different fonts for each language. For example, if you translate a document into French,
Chinese, and Arabic, each language uses different character sets. Using fonts appropriate for
the language's character set ensures that the characters display correctly when viewed in the
output. You can use Lingo's font mapping feature to locate the fonts already used in the
source Flare project and replace them with fonts that are supported by each target language.
The mapped fonts will be used when the project is exported back to Flare. See "Mapping
Fonts" on page 273.

n

Replacing Images in Batches You can replace an image in Lingo instead of deleting and
adding the image manually. You can also create a batch that lets you replace many images at
the same time, without needing to retranslate their callouts. See "Batch Replacing Images" on
page 278.
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n

Replacing Skin Images If you are translating a Flare project that has a skin with an image, you
can replace the image in Lingo. You can replace logos in HTML5 skins, and you can replace
the About box in Mobile and WebHelp skins. See "Replacing Skin Images" on page 286.

n

Segmentation Rules and Split/JoinSometimes you may have segments in the Translation
Editor that you need to join together or split apart. You can do this in a couple of ways in
Lingo—automatically by using segmentation rules or manually by using the split and join features. See "Segmentation Rules" on page 287 and "About Split/Join" on page 309.

n

Sorting Indexes and Glossaries There may be times that you want to create a custom sort
order for your Flare index or glossary. You can do this by adding a "Sort As" term to the index
or glossary term. Custom sort orders are especially important when translating a Flare project
because terms in each translated language may have different spellings or pronunciations
that are not automatically picked up by Flare. Because of this, you may need to specify how
the index or glossary should sort a term, so the term is identified correctly when the Lingo project is exported back to Flare. See "Sorting Indexes and Glossaries" on page 313.
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Filters
When working with translations in Lingo, you can create different kinds of filters to control what content is translated in your Lingo project. You can create filters for file types, targets, or conditions.
You can also flatten snippets, variables, or DITA content references to determine what content is
translated within a segment.
n

"Content Flattening" below

n

"Dynamic Filtering" on page 205

n

"File Type Filters" on page 225

Content Flattening
Replacing content nodes with text is referred to as "flattening." You can flatten snippets and variables in Flare projects, and content references (conrefs) in DITA projects.
If the content is flattened, you can edit the translation to make it more appropriate for the segment
where it appears.
Similarly, you may have multiple versions of content based on the document you are writing. This is
often the case if you have content that needs to be translated differently for different audiences.
You can flatten content when creating a new project, or you can update an existing project's flattening settings in the Project Properties dialog. The settings are the same in both locations. Settings are updated dynamically, so you do not need to update the project to apply the settings.
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HOW TO FLATTEN DITA CONTENT REFERENCES
You can flatten conrefs. This means that conref content will be included as text in the segment in
Lingo. Translating a conref as part of the segment allows translators to account for context, rather
than translating each conref individually. This also makes sure that you have the most accurate
translations in the translation memory.
Flattened conrefs appear as normal text in the Translation Editor, while unflattened conrefs appear
as tags. Translators can move these tags to their correct location in the target segment.
1. Do one of the following, depending on the type of project you are using:
n

New Project Select File > New Project. The Start New Project Wizard opens. Proceed
through the wizard until you get to the Select DITA project settings page (the location of
this page in the wizard varies slightly depending on your project creation method).

n

Existing Project Select File > Project Properties. The Project Properties dialog opens.
Select the DITA Settings tab.

2. At the bottom of the dialog, select the check box next to Flatten conref nodes to plain text.
This will flatten all conrefs.
3. In the Project Properties dialog, click OK.
OR
In the Start New Project Wizard, click Next or Finish.
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EXAMPLE
You use content references throughout your DITA project. You know that your existing
translation memory (TM) already includes some of the segments in your project, but
the segments in your TM do not use content references; instead, the text is written as
part of the segment. Because of this, you decide to flatten the content references in
your entire project. This way, when you send the project to your translator, she will get
the most accurate matches from your existing TM. This will also let her account for
context in the segment when translating the content references.

NOTE: As a best practice, you should always translate conrefs in the associated DITA file,
even if you have flattened them and translated them in the segment. Lingo will use the
translation from these files for instances of the conref that are not included in the segment
(e.g., conrefs that are removed from the Translation Editor).

NOTE: You can flatten both inline and block conrefs. Flattening block conrefs may add additional tags to the segment in order to preserve the formatting found in the block of content.
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HOW TO FLATTEN SNIPPETS
You can flatten sub-segment snippets (i.e., snippets that are part of a segment, as opposed to their
own tag). This means that snippet content will be included as text in the segment in Lingo. Translating a snippet as part of the segment allows translators to account for context, rather than translating each snippet individually. This also makes sure that you have the most accurate translations
in the translation memory.
Flattened snippets appear as normal text in the Translation Editor, while unflattened snippets
appear as tags. Translators can move these tags to their correct location in the target segment.
1. Do one of the following, depending on the type of project you are using:
n

New Project Select File > New Project. The Start New Project Wizard opens. Proceed
through the wizard until you get to the Select Flare project settings page (the location
of this page in the wizard varies slightly depending on your project creation method).

n

Existing Project Select File > Project Properties. The Project Properties dialog opens.
Select the Flare Settings tab.

2. At the bottom of the dialog, select the check box next to Convert sub-segment snippets to
text. This will flatten all inline snippets.
3. In the Project Properties dialog, click OK.
OR
In the Start New Project Wizard, click Next or Finish.
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EXAMPLE
There are several short snippets in your Lingo project. Sometimes they appear as part
of a segment. Other snippets appear as their own segments.
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If you do not flatten the snippets...
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...the content in Lingo looks as follows. Because the snippets are unflattened, you see
tags where the snippets appear in the segments. You can drag each tag into the target
segment. Snippets that are part of their own segment do not appear as tags in the
Translation Editor.

You can translate all of the snippets in the snippet files, which are found in the File List
window pane.
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If you do flatten your snippets...
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...the content in Lingo looks as follows. Content from each snippet appears in the
Translation Editor as text.

NOTE: As a best practice, you should always translate snippet content in the snippet files,
even if you have flattened them and translated them in the segment. Lingo will use the
translation from these files if it finds instances of the snippet that are not included in the
segment (e.g., snippet tags that are removed from the Translation Editor).

NOTE: You can flatten both inline and block snippets. Flattening block snippets may add
additional tags to the segment in order to preserve the formatting found in the block of content.
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HOW TO FLATTEN VARIABLES
Variable flattening works differently from snippet and conref flattening. Unlike snippets and conrefs,
you can select the variables you want to flatten. You can flatten variables from a specific variable
set, and you can select certain variables in a set. This gives the translator greater flexibility when
translating, because some variables (like a company name) may never need to be translated, but
others may always need to be translated.
Flattened variables appear as normal text in the Translation Editor, while unflattened variables
appear as tags. Translators can move these tags to their correct location in the target segment.
1. Do one of the following, depending on the type of project you are using:
n

New Project Select File > New Project. The Start New Project Wizard opens. Proceed
through the wizard until you get to the Select Flare project settings page (the location
of this page in the wizard varies slightly depending on your project creation method).

n

Existing Project Select File > Project Properties. The Project Properties dialog opens.
Select the Flare Settings tab.

2. In the Select variables to flatten area, select the variable set you want to flatten from the left
side of the grid. The variables in that variable set appear on the right side of the grid. By
default, all of the variables in the set are selected.
3. (Optional) If you only want to flatten some of the variables in a set, on the right side of the grid,
remove the check marks next to the variables you do not want to flatten.
NOTE: If you want to flatten variable definitions for a specific target, you can optionally filter by target by selecting a target from the Filter by target drop-down. You can
then translate the target-specific variables in the target file in your Lingo project. See
"Dynamic Filtering" on page 205.
4. (Optional) Repeat steps 2-3 for additional variable sets.
5. In the Project Properties dialog, click OK.
OR
In the Start New Project Wizard, click Next or Finish.
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You might use this feature if a variable definition has different meanings in the translation language,
depending on the context (e.g., "cash" versus "currency" in German). If you do not flatten variables,
you can only translate the variable with a single term, and it will be used everywhere in the project
that the variable is inserted. On the other hand, if you do flatten variables, you will then be able to
translate each term separately when it appears in the Translation Editor.
EXAMPLE
If you do not flatten variables, you will see something like this.

If you do flatten variables, you will see something like this.

CHAPTER 7

196

If the Flare author created a target override for a variable (i.e., one Flare target will use a particular
variable definition while another target will use a different one), you can create a target filter in addition to flattening variables. This lets you filter the entire Lingo project to the target whose variable
definition you want to use when flattening the variables. You can then translate the target-specific
definition in the target file in Lingo.
You can flatten variables and apply target overrides to both new and existing projects.
To add them to a new project, apply the settings in the Start New Project Wizard.
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To add them to an existing project, select File > Project Properties, then apply the new settings from
the Flare Settings tab.
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EXAMPLE
You are a Flare author writing a short manual for a company that has two internal
teams: Red and Blue. One of the variables in your project is a target-specific
"Team" variable with two definitions: "Red" and "Blue."
You need your manual translated into Spanish. When creating your Lingo project, you
filter the Flare project by target so you only see the appropriate topics and variables for
each team.
The first document you produce is the one for the Blue team. To do this, you filter by
the "Blue" target when creating the Lingo project. You do not flatten the variables for
this project.
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The variable definition for "Blue" that was specified in your Flare project is included in
the Lingo project. When finished, you bundle the project and send it to your translator.
Because you did not flatten the variables in the project, your translator will translate the
variable in the target file (because it is target-specific).
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When translating segments, he simply moves the "Blue" tag in the source segment to
the target segment. He does not need to translate the variable each time he encounters it in a topic.

When you create the Lingo project for the Red team, you decide to flatten the "Red" variable. Unlike "Blue," which does not take on a different gender depending on the words it
modifies, "Red" might be masculine or feminine. You know that you may need to
change the variable slightly to use correct gender agreement.
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To do this, you update the project's settings on the Flare Settings tab of the Project
Properties dialog (File > Project Properties). You choose to filter by the Red target. You
also select the "Team" variable (which has the "Red" definition in this target) from the
Select variables to flatten area at the top of the tab.

CHAPTER 7

202

When finished, you bundle the project and send it to your translator.
By flattening the variable, your translator can translate it directly in the segment and
make changes based on the context of the sentence.

The variable also appears in the target file, because Lingo will use this translation if the
variable is used elsewhere in the project.

NOTE: If you filter by target, target-specific variables can be translated in the target file
from the File List. Default variable definitions are translated in the variable set file (they are
not considered target-specific, even if selected for a target).
All other variables (and variables in projects not filtered by target) can be translated in the
variables file.
As a best practice, you should translate variables in the variable set or target file, even if you
have flattened them and translated them in the segment. Lingo will use the translation from
these files for instances of the variable that are not included in the segment (e.g., variable
tags that are removed from the Translation Editor).
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NOTE: If you update the flattening settings for an existing project, the translation status of
changed segments is set to Untranslated. You also have the option to completely clear any
existing translations for these segments.
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Dynamic Filtering
You can use dynamic filters to control the content that appears in your Lingo project. These filters
are based on settings in a Flare project or DITA file, such as target settings or conditional attributes.
You can set filters when creating a new project, or you can update an existing project's filtering settings in the Project Properties dialog. The settings are the same in both locations. These settings
are updated whenever you change them—dynamically—so you do not need to update the entire project to apply new filter settings.
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HOW TO FILTER OUT CONDITION TAGS
You can filter Flare projects to exclude one or more conditions. You can also select conditions
based on the entire condition set, or you can pick the specific conditions in the set that you want to
filter by. The resulting Lingo project will include all of the translatable files that are not marked with
the selected conditions. Additionally, because Lingo supports block-level, inline, glossary, snippet,
and CSS conditions, content within a file or segment that is marked with an excluded condition tag
will also be excluded from a filtered Lingo project.
If you use condition tags to filter your Lingo project, the filtered content and files will be used
throughout your Lingo project when running reports, creating bundles, viewing glossary terms, and
performing other tasks. For example, if you pull a report, you will only see data from the filtered content. If you make a bundle, you will only be able to select from files that are included in the project.
1. Do one of the following, depending on the type of project you are using:
n

New Project Select File > New Project. The Start New Project Wizard opens. Proceed
through the wizard until you get to the Select Flare project settings page (the location
of this page in the wizard varies slightly depending on your project creation method).

n

Existing Project Select File > Project Properties. The Project Properties dialog opens.
Select the Flare Settings tab.

2. Select Filter out condition.
3. Click Select conditions. The Select Conditions dialog opens.
4. From the left side of the grid, select the condition set you want to exclude . The tags in that
condition set appear on the right side of the grid. By default, all of the tags in the set are selected.
5. (Optional) If you only want to exclude some of the tags in a condition set, on the right side of
the grid, deselect the boxes next to the condition tags you do not want to exclude from the
project.
6. Click OK.
7. In the Project Properties dialog, click OK.
OR
In the Start New Project Wizard, click Next or Finish.
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EXAMPLE
You are an author with a very large Flare project, but you only need to send specific
files to your translator. Rather than exporting your entire project to Lingo and then
searching for the individual files that you need to export for translation, you instead
mark the files and folders you do not need to translate with a "Do Not
Translate" condition tag as you create each item in Flare.
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In Lingo, you filter the project to exclude the condition tag, creating a new Lingo project
that only includes the files you need to send to your translator.
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When you open the File List window pane in a Lingo project, it looks like this:

Because you applied the "Do Not Translate" condition throughout your project, you see
only a handful of topics and images. You also see a few project files, such as your glossary, variables file, and TOCs.

CHAPTER 7

209

EXAMPLE
The content author filtered her Flare project to exclude a "Do Not Translate" condition
tag. Of the nine lines in the original topic (including the heading), four were marked with
a "Do Not Translate" condition tag.

When you view the topic in the Translation Editor in Lingo, only five segments appear.
This is because four lines were excluded when the project was created. Additionally,
you see blue condition tag indicators in some segments where individual words were
conditioned out and excluded from a segment.
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EXAMPLE
You use expanding text throughout your Flare project. You do not want your expanding
headers to appear in your printed outputs, so you create a style class in your stylesheet
named “OnlineOnly” that has a condition called “ScreenOnly” condition tag applied to it.
After this, you set this style class on your expanding headers.
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Later, you need to send one of your printed outputs for translation. When you create a
Lingo project, you can exclude the “ScreenOnly” condition tag from the project.
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This way, the expanding headers in your online outputs are not included in the content
you send to your translator.

NOTE: Although you can filter out condition tags, Lingo does not explicitly include the condition tags that you have not excluded. For example, if you have condition tags A and B in
your project, and you filter out A, you will see content marked with tag B in the project.
However, if there is content marked with both tags in your project, it will also be excluded.
This is because Lingo excludes anything marked with the A tag, even if the B tag was not
also excluded.
If you need to exclude some content and include other content, you can do this by filtering
your project using a Flare target with your desired condition filters. Filtering by a Flare target
respects both include and exclude condition tag filters.

NOTE: Conditions that "unbind" rather than "exclude" content will not be excluded when you
filter out a condition in Lingo. If you notice that content has not been removed but you think
that it should be, check to be sure that the condition is not marked as an "unbind" condition
in Flare.
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HOW TO FILTER BY DITA ATTRIBUTES
You can filter DITA files to include one or more conditional attributes. The resulting Lingo project will
include all of the translatable files that are marked with the selected attributes (while excluding
those that are not selected). Additionally, because Lingo supports block-level and inline attributes,
content within a segment that is marked with an excluded attribute will also be excluded from a
filtered Lingo project.
If you use conditional attributes to filter your Lingo project, the filtered content and files will be used
throughout your project when running reports, creating bundles, and performing other tasks. For
example, if you pull a report, you will only see data from the filtered content. If you make a bundle,
you will only be able to select from files that are included in the project.
1. Do one of the following, depending on the type of project you are using:
n

New Project Select File > New Project. The Start New Project Wizard opens. Proceed
through the wizard until you get to the Select DITA project settings page (the location of
this page in the wizard varies slightly depending on your project creation method).

n

Existing Project Select File > Project Properties. The Project Properties dialog opens.
Select the DITA Settings tab.

2. In the Select conditional attributes to include section, use the drop-downs to select the attributes you want to include in your DITA project.
n

Props Filter to include the selected property attribute.

n

Platform Filter to include the selected platform attribute.

n

Product Filter to include the selected product attribute.

n

Audience Filter to include the selected audience attribute.

n

Other props Filter to include any other defined otherprops attribute.
NOTE: If you select All in any of the drop-downs, Lingo will include all available values
for that attribute. In other words, no values are excluded from that attribute.

3. In the Project Properties dialog, click OK.
OR
In the Start New Project Wizard, click Next or Finish.
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EXAMPLE
Your DITA files include information for Mac, Windows, and Linux operating systems. In
your DITA files, you used the platform attribute to mark the content applicable to each
of these operating systems. Additionally, you used the audience attribute to mark content for expert and novice users.
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When creating your Lingo project, you have the option to filter your content by either
the platform or audience attributes. You could also filter the content using both attributes.
You need to translate all of the content that is applicable to all of your users who use
Windows. You select the windows platform attribute to include this attribute type
(excluding Mac and Linux) and leave the audience attribute set to All (including both
expert and novice users).
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Your project looks like this in Lingo:
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You then use Lingo to create a bundle and send the Windows files to your translator.
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You also need to translate content for expert Linux users, but this content goes to a different translator. You open the Project Properties dialog and adjust the filter settings
so the platform attribute is set to linux (excluding Mac and Windows) and the audience
attribute is set to expert (excluding novice users).

Your project dynamically updates, and now it looks like this in Lingo:

Because your project now displays only the expert-level Linux files, you can create a
bundle with these files and send them to the other translator.

NOTE: For more detailed information about DITA, please refer to:
www.oasis-open.org/committees/dita/
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HOW TO FILTER BY A TARGET
You can filter your Flare projects by one or more targets. The resulting project will include all of the
translatable files that are part of the selected target(s), such as topics, images, skins, and variables.
A good reason to use target filters is if you need to maintain different translations for different targets. Additionally, you could filter to a specific target and use variable flattening if you need use different definitions of a variable in different targets.
1. Do one of the following, depending on the type of project you are using:
n

New Project Select File > New Project. The Start New Project Wizard opens. Proceed
through the wizard until you get to the Select Flare project settings page (the location
of this page in the wizard varies slightly depending on your project creation method).

n

Existing Project Select File > Project Properties. The Project Properties dialog opens.
Select the Flare Settings tab.

2. Select Filter by target.
3. From the drop-down, select the target(s) whose files you want to include in the Lingo project.
After clicking the appropriate check boxes, click elsewhere on the page to close the dropdown.
Any files that are not part of the selected target(s) will not be shown in the File List.
NOTE: If you want to replace variable definitions for a specific target, you can optionally select variables from the Select variables to flatten grid. You can then translate
the target-specific variables in the target file in your Lingo project. See "Dynamic Filtering" on page 205.
4. In the Project Properties dialog, click OK.
OR
In the Start New Project Wizard, click Next or Finish.
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EXAMPLE
You create your glossary in Flare with the intent of using the same glossary file for multiple outputs. To do this, you apply condition tags to each term that indicate which
terms belong in which output. Some terms are used in multiple targets, others are used
in single targets.
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Later, when you need to send a specific target to your translator, you can filter your
new Lingo project by the target you need to produce.
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When you do this, the condition text rules set in the Flare target are applied to the Lingo
project. Because you applied condition tags to your glossary as well as to your topics,
when your translator opens the glossary file in your Lingo project, she will only see the
terms that need to be translated for that output.
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She will also only see the terms for that output when she opens the Project Properties
dialog and views the Sort Order information for the glossary.

NOTE: If you are creating Lingo projects from both Flare and DITA source files, be aware
that DITA conditional filters are include filters, while Flare conditional filters are exclude filters.

NOTE: If you update the filter settings for an existing project, the translation status of
changed segments is set to Untranslated. You also have the option to completely clear any
existing translations for these segments.

NOTE: You cannot filter a Flare project by both target and conditions. If you select one filter, the other will be disabled.

NOTE: If you need to create a filter for the content in individual files or for files in a folder,
you can use file type filters. See "File Type Filters" on the next page.
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File Type Filters
When creating a project in Lingo, you can use a filter to translate only specific content in a folder or
in certain file types. Filters allow you to set restrictions on the content in a file or folder that is available for translation. Filters are available for Word, Excel, text, XML, and JSON files. You can also add
filters to unsupported file types using a text file type filter. Filters are also available for folders, so
you can choose the file types in the folder that you want to translate.
Once you create a filter, you can save it to reuse it later, and you can apply it to all other files of the
same type in the project.

IMPORTANT: Creating file type filters is recommended for advanced Lingo users. This feature requires an understanding of advanced topics such as regular expressions, XML, and
segmentation rules.
Additionally, it is recommended that you are familiar with the file(s) you are importing prior
to adding a filter. Some file type filters require you to select the specific content that you
want to import (e.g., sheet labels, headers and footers, comments).
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EXAMPLES
This shows how to access a file type filter:
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This shows how to access a folder filter:

NOTE: If you wish to create a new file filter in an open project, select Tools > File Filters. In
the File Filters dialog, select the File type from the drop-down list. Then, follow the remaining steps for that file type to create the filter.
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HOW TO CREATE A FILTER FOR FOLDERS
When you create a Lingo project, you can create a project from a folder. You can filter the file types
in the folder so only some files are included in the translation project. You can also create additional
filters for any files that may be in the folder so only certain parts of the file are imported for translation.
NOTE: If you want to translate an entire Flare, Mimic, or Doc-To-Help project, you must
select the project file using the Add File button, rather than selecting the folder where the
project is located.

NOTE: If you want to translate a Doc-To-Help project, you must import the entire .d2h project file.
The .d2h project file is required for XML and Word files in a Doc-To-Help project to be imported correctly. Because of this, importing individual XML files from a project is not supported,
and importing individual Word files from a project is not recommended.

1. Begin the process of creating a new Lingo project, and on the second page of the wizard,
select the folder containing files to be translated.
2. If you want to create file type filters for the files within the folder, from the Filter drop-down
select Customize Folder. The File Types Filters dialog opens.
3. In the Translate column, select the file types you want to import. You can click the Select All
check box to add all the file types at once.
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4. From the Filter drop-down, select the filter you want to use for each translatable file type.
NOTE: You cannot select a filter for file types that cannot be translated, such as
image files.
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5. If you want to create a new filter, from the Filter drop-down, select Create New.
NOTE: Applying a text file type filter to unsupported file types lets you translate the
files as if they were text files. If you have unsupported file types in your folder and you
do not apply a text file type filter to these files, they will be discarded upon project creation.
6. Click OK.

CHAPTER 7

230

HOW TO CREATE A FILTER FOR WORD DOCUMENTS
1. Begin the process of creating a new Lingo project, and on the second page of the wizard,
select the file(s) to be translated.
2. From the Filter drop-down, select Create New.
3. Enter a name for your filter and click OK. The File Filters dialog opens.
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4. (Optional) You can do one of the following before saving your current filter:
n

Import a Filter Click Import. In the dialog that opens, locate the filter you want to import,
then click Open.

n

Export a Filter Click Export. In the dialog that opens, select the location you want to
export the current filter, then click Save.

n

Select a Filter From the Filter drop-down, select an existing filter.

n

Create a New Filter Click

n

Delete a Filter Select a filter from the Filter drop-down, then click

.
.

NOTE: If you delete a filter, it will be removed from all translation projects
where it is currently in use.
5. In the Segmentation area, select an option for how to import soft breaks and tabs into the
translation project:
n

Insert tag Select this option to keep soft breaks or tabs together with the rest of the segment. Lingo adds a tag where the soft break or tab appears in the segment.
EXAMPLE
The two segments pictured below include a soft break and a tab, respectively. The Word file type filter in Lingo has been set to add a tag when there
is a tab or a soft break, but it will not split the segment. When translating
the segment, you can drag the tag into the target segment where it needs
to appear.
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n

Insert tag and create new segment Select this option to create a new segment
wherever there is a soft break or a tab in your project.
EXAMPLE
The two segments pictured below include a soft break and a tab, respectively. The Word file type filter in Lingo has been set to add a tag when there
is a tab or a soft break, and it will also create a new segment at the location
where the tab or soft break appears. When translating the segment, you
can drag the tag into the target segment where it needs to appear.
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6. In the Content area, select the check boxes for the content you want to include in the translation project:
n

Include hidden text Select this option to include hidden text in the Lingo project so it can
be translated.
EXAMPLE
The segment below includes hidden text. Lingo places a tag where the hidden text appears in the original Word document, so the location of the text
is clearly visible in the Translation Editor. However, in this example, the
Lingo file type filter is set so hidden text is not included for translation.
When translating the segment, you can drag the tag into the target segment where it needs to appear.

In the segment below, the filter has been changed so hidden text is
included. Notice that the word "HIDDEN" is now visible. Lingo also places a
tag on either side of the hidden text so the text is clearly visible in the Translation Editor. You can drag the yellow tags onto the target segment to
mark the hidden text in the target segment.
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n

Include comments Select this option to include comments as separate segments in the
Lingo project so they can be translated. If you do not select this option, comments will
not be included.
EXAMPLE
The segment below includes a comment. Lingo places a tag on either side
of the phrase that was marked with a comment in the original Word document, so the location of the comment is clearly visible in the Translation
Editor. However, in this example, the Lingo file type filter is set so the comment itself is not included for translation.

In the segment below, the filter has been changed so the comment itself is
included. Notice that the comment is visible in a second segment. This lets
you translate the comment separately. You can also still see the comment
tag in the first segment that indicates where the comment was marked in
the original Word document. When translating the sentence, you can drag
the yellow tag onto the phrase that needs the comment in the target segment. Later, when you export the document, the comment will appear in
the finished project, attached to the appropriate location in the document.
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n

Include index Select this option to include index entries as separate line items in the
Lingo project so they can be translated. If you do not select this option, index entries will
not be included.
EXAMPLE
The segment below includes words that are marked as index entries. Lingo
places a tag next to the text that was marked with a keyword in the original
Word document, so the location of the index keywords are clearly visible in
the Translation Editor. When translating the segment, you can drag the tag
into the target segment where it needs to appear. However, in this
example, the Lingo file type filter is set so the index entry itself is not
included for translation.

In the segment below, the filter has been changed so the index entries
itself are included. Notice that each word in the index is visible, so three
additional segments follow the original segment. This lets you translate
each index entry separately. You can also still see the keyword tags in the
first segment that indicates where the keywords were marked in the original Word document.
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n

Include footnotes/endnotes Select this option to include footnotes or endnotes as separate segments in the Lingo project so they can be translated. If you do not select this
option, footnotes or endnotes will not be included.
EXAMPLE
The segment below includes a footnote. Lingo places a tag next to the sentence that was marked with a footnote in the original Word document, so
the location of the footnote is clearly visible in the Translation Editor. When
translating the segment, you can drag the tag into the target segment
where it needs to appear. However, in this example, the Lingo file type filter
is set so the footnote itself is not included for translation.

In the segment below, the filter has been changed so the footnote is
included as a separate segment. This lets you translate the footnote separately. You can also still see the footnote tag in the first segment that
indicates where the footnote was marked in the original Word document.
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7. In the Styles/Markup area, select the check box if you want to include minor formatting
changes in your translation project.
EXAMPLE
The segment below includes a text effect, and also includes bold formatting.
However, in this example, the Lingo file type filter is set so the text effect is not
visible in Lingo. You can only see the bold formatting.

In the segment below, the filter has been changed so the text effect is visible.
Lingo places a tag next to the word that was marked with a text effect in the original Word document, so the location of the effect is clearly visible in the Translation Editor. When translating the sentence, you can drag the yellow tag onto the
word that needs the text effect in the target segment. Later, when you export
the document, the text effect will appear in the finished project.

8. Click OK.
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HOW TO CREATE A FILTER FOR EXCEL DOCUMENTS
1. Begin the process of creating a new Lingo project, and on the second page of the wizard,
select the file(s) to be translated.
2. From the Filter drop-down, select Create New.
3. Enter a name for your filter and click OK. The File Filters dialog opens.
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4. (Optional) You can do one of the following before saving your current filter:
n

Import a Filter Click Import. In the dialog that opens, locate the filter you want to import,
then click Open.

n

Export a Filter Click Export. In the dialog that opens, select the location you want to
export the current filter, then click Save.

n

Select a Filter From the Filter drop-down, select an existing filter.

n

Create a New Filter Click

n

Delete a Filter Select a filter from the Filter drop-down, then click

.
.

NOTE: If you delete a filter, it will be removed from all translation projects
where it is currently in use.
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5. In the Direction area, select an option for how to import the contents of the Excel file:
n

Top Down and Left to Right Select this option if you want Lingo to import cells by
column (i.e., starting in Column A and working down the column, then moving to
Column B).
EXAMPLE
You want to import this Excel document into Lingo.
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If you import it using the Top Down and Left to Right direction filter, it will
look like this:
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n

Left to Right and Top Down Select this option if you want Lingo to import cells by row
(i.e., starting in Row 1 and working across the row, then moving to Row 2).
EXAMPLE
You want to import this Excel document into Lingo.
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If you import it using the Left to Right and Top Down direction filter, it will
look like this:
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n

Choose 2 columns as Source and Target Select this option if you want to choose the
columns that Lingo should associate with the source and target segments.
l

l

Source Column Enter the name of the column you want to import as source segments.
Target Column Enter the name of the column that you want to use for target segments when the finished translations are exported back to Excel.
IMPORTANT: When you enter target translations in Lingo and export them
back into Excel, the translations will overwrite any data that may already exist in
that column. It is recommended that you select an empty column for translated target segments to avoid accidental data loss.

IMPORTANT: When you apply a filter to an Excel workbook, Lingo applies the
filter to all of the sheets in the workbook. This is especially important when
exporting to a specific target column because Lingo will export each worksheet's data to the specified column. To avoid accidental data loss, be sure that
your target column is not being used in any of your worksheets.
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EXAMPLE
You have an Excel file that you use for glossary terms. You want to import
this file into Lingo and translate the terms into Spanish, and then export the
translations back to the original Excel so you can save them.
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If you import the worksheet using the Choose 2 columns as Source and
Target direction filter, you can select the columns you want to import as
the source segments (Column B) and associate with the target translations (Column D). It will look like this in Lingo:
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When you export the finished translation back to Excel, it will look like this.

6. Select the check boxes for the content you want to include in the translation project:
n

Import sheet labels Select this option if you want to import the name of each worksheet
(i.e., the tabs at the bottom of the Excel page) as its own segment.

n

Import header and footer Select this option if you want to include the worksheet's headers and footers as translatable segments.

n

Import hidden rows and columns Select this option if you want to include data in hidden
rows and columns. If this option is not selected, data in hidden rows and columns will
not be available for translation.

n

Include hidden worksheet Select this option to include hidden worksheets when importing an Excel document. If this option is not selected, hidden worksheets will not be available for translation.
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n

Include cells containing formulas Select this option to import cells that contain formulas.
EXAMPLE
The segment below includes a formula.

Lingo imports the formula so you can translate relevant words (in this
case, "duck"). This ensures that the formula will function correctly when
the translation is exported back to Excel.

NOTE: This option is not available if you are running a trial version of Lingo.
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n

Include cell comments Select this option to import any reviewer comments as a separate segment.
EXAMPLE
The segment below includes a comment.

Lingo places formatting tags on either side of the phrase that was marked
as a comment in the original Excel document, so the location of the original
formatting is clearly visible in the Translation Editor. When translating the
comment, you can drag the yellow tags onto the target segment and apply
the formatting to the appropriate phrases. Later, when you export the document, the comment will appear in the finished project with the correct
formatting.

7. Click OK.

NOTE: If you import a cell that contains multiple lines of content separated by a line break
(ALT+Enter), these line breaks are not segmented in Lingo.
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HOW TO CREATE A FILTER FOR TEXT FILES
1. Begin the process of creating a new Lingo project, and on the second page of the wizard,
select the file(s) to be translated.
2. From the Filter drop-down, select Create New.
3. Enter a name for your filter and click OK. The File Filters dialog opens.
4. (Optional) You can do one of the following before saving your current filter:
n

Import a Filter Click Import. In the dialog that opens, locate the filter you want to import,
then click Open.

n

Export a Filter Click Export. In the dialog that opens, select the location you want to
export the current filter, then click Save.

n

Select a Filter From the Filter drop-down, select an existing filter.

n

Create a New Filter Click

n

Delete a Filter Select a filter from the Filter drop-down, then click

.
.

NOTE: If you delete a filter, it will be removed from all translation projects
where it is currently in use.
5. In the Segment/Note field, enter a regular expression to identify the text you want to translate. By default, the first logical grouping is extracted as translatable text. If you enter a
second grouping, it is extracted as a segment note.
IMPORTANT: Text filters created in Lingo 9.x or older used separate fields for segments and notes. In Lingo 10 or newer, these regular expressions are combined into a
single field.
If you have a text filter that was created in Lingo 9.x or older, and you edit it in Lingo
10 or newer, the segment regular expression will be preserved. However, the notes
regular expression is not preserved. You will need to manually update your text filter
to include this logical grouping in the Segment/Note field.
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6. (Optional) If your segments need to be translated so the first logical grouping is extracted as a
segment note, and the second grouping is extracted as translatable text, select Use first
logical grouping as note.
7. (Optional) If you want Lingo to interpret the regular expression as a single-line regular expression, select the Single line regular expression box. This changes the behavior of the period (.)
language element so that it matches every character, instead of matching every character
except for the newline character \n. By default, Lingo interprets regular expressions as multiline regular expressions.
EXAMPLE
Let's say you have a text file that looks like this:

You want to include everything on the left side of the text file (between the quotation marks) as a note in your translatable file, and everything on the right side
of the text file (after the equal sign) as the segment for translation.
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To accomplish this, you would create a filter using regular expressions that look
like this:

Because the notes are on the left side of the file, you are sure to select the Use
logical grouping as note box.
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When you create the project, it will look like this:

8. Click OK.
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HOW TO CREATE A FILTER FOR XML DOCUMENTS
1. Begin the process of creating a new Lingo project, and on the second page of the wizard,
select the file(s) to be translated.
2. From the Filter drop-down, select Create New.
3. Enter a name for your filter and click OK. The File Filters dialog opens.
4. (Optional) You can do one of the following before saving your current filter:
n

Import a Filter Click Import. In the dialog that opens, locate the filter you want to import,
then click Open.

n

Export a Filter Click Export. In the dialog that opens, select the location you want to
export the current filter, then click Save.

n

Select a Filter From the Filter drop-down, select an existing filter.

n

Create a New Filter Click

n

Delete a Filter Select a filter from the Filter drop-down, then click

.
.

NOTE: If you delete a filter, it will be removed from all translation projects
where it is currently in use.
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5. (Optional) If you want to associate a DTD or XML schema with the XML file, click
dialog that opens, locate the schema or DTD file you want to use, then click Open.
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6. In the Candidate Tags section, select the tags from XML file that you want to translate. If a
tag can be translated, it will be checked in the Translatable column. If you do not want to
translate a tag, remove the check mark from this column.
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EXAMPLE
You might want to translate tags that are words, but tags that consist of all numbers might not be good candidates for translation. Suppose you have an XML file
that includes tags named “price” and “pub_date,” which are used to display numbers only. So you create a new filter called “No Numbers” and you remove the
check mark from the Translatable column for these tags.

Therefore, those tags will not be included in the project.
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7. In the Add Tag field, enter any additional tags you want to add to the XML file. These tags do
not need to be in the XML file at this time, but if you know that they may be in the file in the
future, you can add them here. Enter a name for the tag, then click
want to remove a tag, select it from the list, then click

to add the tag. If you

.

8. In the Candidate Attributes section, select the attributes from XML file that you want to translate.
NOTE: If a tag does not have any attributes, nothing displays in this section. If you do
not see any attributes in the Candidate Attributes section, try selecting a different
tag.
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9. If you want to translate an attribute, select the check box in the Translatable column. If you
do not want to translate an attribute, remove the check mark from this column.
10. In the Add Attribute field, enter any additional attributes you want to associate with a tag.
These attributes do not need to be in the XML file at this time, but if you know that they may
be in the file in the future, you can add them here. Enter the name for the attribute, then click
to add the attribute. If you want to remove an attribute, select it from the list, then click
.
11. (Optional) When you are adding a filter to an XML file, you can place restrictions on the attributes in the file to tell Lingo when to include or exclude an element for translation. You can also
remove restrictions if you no longer need them.
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TO ADD A RESTRICTION TO AN XML ATTRIBUTE
a. Click Restriction. The Attribute Restriction dialog opens.
b. Select the restriction you want to apply. You can include or exclude the element if the
attribute value is listed.
c. In the Add Attribute Value field, enter any additional attribute values you want to add.
These tags do not need to be in the XML file at this time, but if you know that they may
be in the file in the future, you can add them here. Enter the name for the attribute
value, then click
list, then click

to add the value. If you want to remove a value, select it from the
.

d. Click OK. The restriction appears in the File Filters dialog.
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TO REMOVE A RESTRICTION FROM AN XML ATTRIBUTE
a. In the Candidate Attributes area of the File Filters dialog, select the attribute with a
restriction.
b. Click Restriction. The Attribute Restriction dialog opens.
c. Click Clear Restriction.
12. Click OK.
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HOW TO CREATE A FILTER FOR JSON FILES
1. Begin the process of creating a new Lingo project, and on the second page of the wizard,
select the file(s) to be translated.
2. Click the Filter drop-down, and select Create New.
3. Enter a name for your filter and click OK. The File Filters dialog opens.
4. (Optional) You can do one of the following before saving your current filter:
n

Import a Filter Click Import. In the dialog that opens, locate the filter you want to import,
then click Open.

n

Export a Filter Click Export. In the dialog that opens, select the location you want to
export the current filter, then click Save.

n

Select a Filter From the Filter drop-down, select an existing filter.

n

Create a New Filter Click

n

Delete a Filter Select a filter from the Filter drop-down, then click

.
.

NOTE: If you delete a filter, it will be removed from all translation projects
where it is currently in use.
5. Select the tags from the JSON file that you want to translate. If a tag can be translated, it will
be checked in the Translatable column. If you do not want to translate a tag, remove the
check mark from this column.
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6. (Optional) Enter any additional tags you want to add to the JSON file, and click
7. (Optional) Select any tags you want to remove, and click

.

.

8. Click OK.
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HOW TO CREATE A FILTER FOR UNRECOGNIZED FILE TYPES
If you add a file type that Lingo does not recognize, you will see a warning image next to the file filter
drop-down. To resolve this, you can add a text file type filter to the file. This will treat the file type as
a text file and allow you to translate the file.
If you do not add a file type filter to the file, it will be discarded when you create the Lingo project.
1. Begin the process of creating a new Lingo project, and on the second page of the wizard,
select the file(s) to be translated.
2. From the Filter drop-down, select Create New.
3. Enter a name for your filter and click OK. The File Filters dialog opens.
4. (Optional) You can do one of the following before saving your current filter:
n

Import a Filter Click Import. In the dialog that opens, locate the filter you want to import,
then click Open.

n

Export a Filter Click Export. In the dialog that opens, select the location you want to
export the current filter, then click Save.

n

Select a Filter From the Filter drop-down, select an existing filter.

n

Create a New Filter Click

n

Delete a Filter Select a filter from the Filter drop-down, then click

.
.

NOTE: If you delete a filter, it will be removed from all translation projects
where it is currently in use.
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5. In the Segment/Note field, enter a regular expression to identify the text you want to translate. By default, the first logical grouping is extracted as translatable text. If you enter a
second grouping, it is extracted as a segment note.
IMPORTANT: Text filters created in Lingo 9.x or older used separate fields for segments and notes. In Lingo 10 or newer, these regular expressions are combined into a
single field.
If you have a text filter that was created in Lingo 9.x or older, and you edit it in Lingo
10 or newer, the segment regular expression will be preserved. However, the notes
regular expression is not preserved. You will need to manually update your text filter
to include this logical grouping in the Segment/Note field.
6. (Optional) If your segments need to be translated so the first logical grouping is extracted as a
segment note, and the second grouping is extracted as translatable text, select Use first
logical grouping as note.
7. (Optional) If you want Lingo to interpret the regular expression as a single-line regular expression, select the Single line regular expression box. This changes the behavior of the period (.)
language element so that it matches every character, instead of matching every character
except for the newline character \n. By default, Lingo interprets regular expressions as multiline regular expressions.
8. Click OK.
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EXAMPLE
You need to translate an ODF file. However, Lingo does not recognize this file type.
When you add the file to your project, you see a yellow warning icon.

To resolve this error, select the Filter drop-down and select Create New.
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The File Filters dialog opens, and you can create a new text file filter using regular
expressions.

When you select the new text file filter from the drop-down, the error is resolved.
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The file is imported for translation.

HOW TO EDIT AND UPDATE A FILE FILTER
You can edit a file filter after you apply it to a project. When you update the project, the new filter settings will be applied.
1. Select Tools > File Filters. The File Filters dialog opens.
2. From the Filters drop-down, select the filter you want to edit.
3. Edit the filter as desired.
4. Click OK.
5. Select File > Update Project. This will reload your project and apply the updated filter.

WARNING: Changing a filter that is already in use may cause corruption when exporting
translations.
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Creating Language Skins
When you create your Lingo project, you have the option to add a language skin to your project. This
generates a language skin file (LanguageSkin.fllng) containing several terms used in different Flare
skins (e.g., "Table of Contents," "Glossary," "Home"). Translators can open the language skin file to
translate these terms. This is especially useful if there are custom terms in the Flare skin and they
need to be translated to match the custom interface.
When you export the project back to Flare, the language skin can be seen by opening the Project
Organizer, then selecting the Advanced folder. Additional changes can be made to the language
skin in Flare, if necessary. When the output is generated, the translations in the language skin
replace Flare's default translations for interface elements.

HOW TO CREATE A LANGUAGE SKIN
1. Select File > New Project. The Start New Project Wizard opens.
2. Proceed through the wizard until you get to the Select Flare project settings page (the location of this page in the wizard varies slightly depending on your project creation method).
3. At the bottom of the dialog, select the check box next to Create language skin.
4. Click Next (to continue the wizard) or Finish. A language skin project is added to your project.

NOTE: You can only add language skins to a project if there are not language skins already
in the source Flare project. If the source Flare project already includes one or more language skins, they will be added to the Lingo project and can be translated.
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NOTE: If your project's target language has an available spell check dictionary, some translations will be pre-populated when you create your language skin. The available translations
vary depending on the language you are using. Languages with an available spell check dictionary are displayed in bold when you select a language during project creation.
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NOTE: When translating language skin segments, the interface element value is added to
the segment as a segment note for your reference.

NOTE: For additional information about using language skins in Flare, please see the Flare
online Help.
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Mapping Fonts
If you are translating a project into multiple languages, you may need to use different fonts for each
language. For example, if you translate a document into French, Chinese, and Arabic, each language
uses different character sets. Using fonts appropriate for the language's character set ensures that
the characters display correctly when viewed in the output. You can use Lingo's font mapping feature to locate the fonts already used in the source Flare project and replace them with fonts that are
supported by each target language. The mapped fonts will be used when the project is exported
back to Flare.
You can create, edit, and delete font maps from the Manage Font Maps dialog.
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EXAMPLE
You are translating a Flare project that was originally written in English. You need to
translate it into French and Arabic. You know that each of these documents will use different fonts in the final output, so you use Lingo to create a font map.
First you scan your project files for fonts. The files are currently using Arial, Calibri, and
Cambria. This is fine for French, which does not need to display a special character set,
and therefore does not need a special font. However, you need to use a different font
for Arabic in order to support the language's character set. You switch the language to
Arabic and map each of the fonts in your project to B Fantezy, which is an Arabic font.
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When the author exports the Arabic project back to Flare, the output uses B Fantezy
and all of the characters are supported.

HOW TO CREATE A FONT MAP
1. Select Resources > Manage Font Mapping.
The Manage Font Maps dialog opens.
2. Click

. The Create New Font Map dialog opens.

3. In the field, enter a name for the font map.
4. Click OK.
5. In the Font Map Files dialog, click OK to close the dialog, or edit the new font map to assign
font mappings.
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HOW TO EDIT A FONT MAP
1. Select Resources > Manage Font Mapping.
The Manage Font Maps dialog opens.
2. Select the font map you want to edit.
3. Click

. The Modifying Font Map dialog opens.

4. From the Language drop-down, select the target language for which you want to map fonts.
NOTE: You can only select target languages currently associated with the project.
5. In the File grid, select the files that you want to scan for fonts.
NOTE: Lingo scans the following file types for fonts:
n

Master pages (.flmsp)

n

Page layouts (.flpgl)

n

Snippets (.flsnp)

n

Stylesheets and table stylesheets (.css)

n

Topics (.htm)

6. Click Discover Fonts. Lingo scans the file(s) you selected. Located fonts appear in the Original
column of the grid at the bottom of the dialog.
7. From the Replace drop-downs next to each Original font, do one of the following:
n

Choose a New Font Select a named font if you want to use a different font for the selected target language.

n

Keep the Original Font Select (none) if you want to keep the original font.

8. (Optional) Repeat steps 4-7 for each additional target language.
9. Click OK.
10. (Optional) If you want to use this font map in your project, select the check box in the In Use
column. You can use one font map per project.
11. Click OK.
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HOW TO DELETE A FONT MAP
1. Select Resources > Manage Font Mapping.
The Manage Font Maps dialog opens.
2. Select the font map you want to delete.
3. Click

.

4. When asked if you are sure you want to delete the font map, click OK.
WARNING: Deleting a font map is permanent. Deleted font maps are removed from
all Lingo projects.
5. In the Font Map Files dialog, click OK.
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Batch Replacing Images
You can replace an image in Lingo instead of deleting and adding the image manually. You can also
create a batch that lets you replace many images at the same time, without needing to retranslate
their callouts.
If you are working in a multilingual project, you can replace the original images with different images
for each language in your project. This is very useful if you need to localize images for different languages or countries.

EXAMPLE
You are translating documentation for a company whose products are used in both
English- and Spanish-speaking countries. You need to localize the images in the documentation so the text on the images is appropriate for the language used in the documentation. To do this, you can use the Batch Image Replace dialog to sync the
images from the English source project with the localized Spanish images.
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To do this, you create a folder with the localized Spanish images. After you click the
button in the Batch Replace Images dialog, you select the Spanish Images folder.
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Any images that have identical file names to those in the original Images folder are
automatically replaced with your localized Spanish images.
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HOW TO REPLACE IMAGES
1. (Optional) In the File List, select the image file(s) you want to replace.
2. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select Home > Batch Replace Images.

n

Local Toolbar In the local toolbar of the File List, click

.

The Batch Replace Images dialog opens. If you selected image files, they appear on the left
side of the grid. If you did not select any files from the File List, the grid is blank. Otherwise, the
grid will show the files you selected in the File List.
3. (Optional) If you are working in a multilingual project, select a language from the drop-down
on the right side of the grid. The current target language is selected by default.
4. (Optional) If you want to replace images in a batch, next to the Folder to Replace field, click
. In the dialog that opens, find and select the folder containing the images that you want
to replace. Click Select Folder.
NOTE: You can only select folders within your Lingo project.
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5. Replace the original images with new images. You can sync the original images to images in a
replacement folder, or you can replace individual images.

TO SYNC THE ORIGINAL IMAGES TO A REPLACEMENT FOLDER
a. On the right side of the grid, click the Sync button

next to the current language.

b. In the dialog that opens, find and select the folder containing the images you want to
sync for the current language. Click Select Folder.
c. If the images in the replacement folder have the same names as the images in the original folder, the replacement images will automatically be linked to the original images.
A confirmation dialog appears notifying you how many replacement links were set. Click
OK. In the Batch Replace Images dialog, the replacement images appear on the right
side of the grid.
NOTE: If Lingo cannot find a replacement image that matches the original
image's exact name or file type extension, no replacement will be selected. If
this occurs, you can replace these images individually.
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TO REPLACE INDIVIDUAL IMAGES
a. On the right side of the grid, click the link next to the image file you want to replace. If
you have not added a replacement image yet, the link will look like an ellipsis; if you have
already added a replacement image, the link will display the image's file name.
NOTE: If you previously localized an image and then reopened the Batch Image
Replacement dialog (or changed languages using the drop-down language
menu), the replacement link next to the original image will say "localized." This
alerts you that you have already replaced that image with a new image.
However, you can still click the link and replace the image with a new image.
b. In the dialog that opens, find and select the replacement image you want to use.
Click Open. In the Batch Replace Images dialog, the replacement image appears on the
right side of the grid.
NOTE: When you replace individual images, you can only select the same type
of image being replaced.

c. Continue replacing images as needed.
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6. (Optional) To preview an original or replacement image, select it in the grid. A preview of the
image and its file path appear in the lower-left corner of the dialog.
7. (Optional) If you want to undo a localization, you can reset the link. To do this, select the cell
(s) you want to reset, then click Reset selected cells.
TIP: Hold down SHIFT or CTRL to select multiple cells.

WARNING: Resetting cells is permanent. As a best practice, you should only click
Reset selected cells if you have made a serious error and cannot correct it manually.
8. (Optional) Repeat steps 4-7 for the other languages in your project.
9. Click OK.

NOTE: If there are not any images in your project, batch image replacement is disabled.

NOTE: Callouts from the original image are transferred to the replacement image and can
be translated in Lingo. However, if your replacement image also contains callouts, these callouts will be flattened during the replacement process, and will no longer be editable. As a
best practice, choose replacement images that do not include callouts.

NOTE: When performing a batch replacement, you can replace images in subfolders. To
sync correctly, the subfolders must have the same names in the original folder and the
replacement folder. Folders with different names will not sync.

NOTE: If you have localized images and you update your Lingo project, a confirmation dialog will ask you if you want to replace the localized images with the images from the source
project.
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NOTE: If you are translating a MadCap Mimic movie, you can replace frame background
images. However, image objects are not replaceable.
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Replacing Skin Images
If you are translating a Flare project that has a skin with an image, you can replace the image in
Lingo. You can replace logos in HTML5 skins, and you can replace the About box in Mobile and
WebHelp skins.

HOW TO REPLACE THE SKIN IMAGE
1. From the File List window pane, open the skin for which you need to replace an image.
2. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select the Resources ribbon. In the Skin Resources section, select Replace Skin
Images.

n

Local Toolbar In the local toolbar of the Translation Editor, click

.

The Replace Skin Images dialog opens.
3. From the Select skin file drop-down, select the skin file in which you want to replace the logo.
The image in the skin file appears.
4. Click Browse beneath the logo.
In the dialog that opens, select a new image file.
5. Click Open. The new image appears in the preview area.
6. (Optional) If you want to replace logos in a different skin, select a new skin from the Select
skin file drop-down.
7. Click OK.

NOTE: If you need to localize the images in your skins, you can select a different target language for the project from the Project Properties dialog (File > Project Properties), then
open the skin file(s) for that language.

NOTE: You can replace skin images with .gif, .jpeg, .jpg, and .png image types.
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Segmentation Rules
Sometimes you may have segments in the Translation Editor that you need to join together or split
apart. You can do this in a couple of ways in Lingo—automatically by using segmentation rules or
manually by using the split and join features.
If you want to control segment breaks automatically, you can create segmentation rules. Lingo follows the format specified by Segmentation Rules eXchange (SRX). Therefore, after you create segmentation rules, you can export them to an SRX file. You can also import SRX files that have been
generated in Lingo.

Regular Expressions
Lingo's segmentation rules are based on regular expressions. Therefore, you can use regular expressions in the Segmentation Rules dialog when creating segmentation rules. However, this is purely
optional; it is not required that you enter regular expressions in your segmentation rules.
EXAMPLES
Following are some examples of regular expressions:
Expression

Description

[a-z]

Matches any lowercase letter

[A-Z]

Matches any uppercase letter

\d

Matches any decimal digit

\D

Matches any non-digit

\s

Matches any white-space character

{…}

Explicit quantifier
For example, a{3} finds "aaa"

|

Alternation
For example, gray|grey finds "gray" or "grey"

(…)
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Expression
?

Description
0 or 1 of previous expression; forces minimal matching when expression
might match several strings within a search string
For example, reg(ular expressions?|ex(p|es?) finds "regular expression,"
"regular expressions," regex, regexp, or "regexes"

For more examples and information about regular expressions, see the following:
http://www.regular-expressions.info/
http://regexlib.com/CheatSheet.aspx

NOTE: When using regular expressions in segmentation rules, keep in mind that a period in
a rule (e.g., "break after St."; "do not break after St. and before Augustine") may cause unexpected results. This might occur because in regular expressions a period is used to match
any character. You can avoid this by always placing a period within square brackets (e.g.,
"break after St[.]"; "do not break after St[.] and before Augustine") to ensure only the specific
character for the period is used.
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NOTE: The following MadCap Flare project files are only segmented based on their units
from Flare and not based on regular segmentation rules (periods and other punctuation
rules): .liindexmap, .liconceptmap, .flaix, and .flixl files. Therefore, rules from the Segmentation Editor are not applied to these files.

NOTE: Lingo only supports .NET regular expressions.
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Creating Basic Segmentation Rules
To create basic segmentation rules, start by selecting the Tools ribbon and clicking Segmentation
Rules. In the Segmentation Rules dialog, there are two sections where you can add terms. The section on the left lets you tell Lingo the cases where you do not want segments to break. The section
on the right lets you tell Lingo the cases where you do want segments to break.

Segmentation rules can be especially useful for abbreviations and other terms that may contain
periods (or other punctuation) that Lingo usually recognizes as the end of a sentence.
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Creating Advanced Segmentation Rules
You can also create advanced segmentation rules. Advanced segmentation rules allow you to override or edit Lingo's default segmentation rules and to set segmentation rules for specific languages.

To create advanced segmentation rules, start by selecting the Tools ribbon and clicking Segmentation Rules, then click Advanced. Two new tabs appear in the editor: Rules and Languages.
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RULES TAB
This tab lets you add, edit, or remove segmentation rules using regular expressions.

n

Select a language from the drop-down list. Use the Languages tab to set the languages that
appear in this list. After you select a language, you can add, edit, or remove rules associated
with that language.

n

You can also edit user-defined rules and default rules.
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LANGUAGES TAB
This tab lets you select the languages for which you need to create segmentation rules.

n

To add a language, select it in the Available Languages list. Click
Languages list.

n

To remove a language, select it in the Current Languages list. Click
Current Languages list.

to add it to the Current

to remove it from the

Languages in the Current Languages list appear in a drop-down on the Rules tab.
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If you want to return to the basic editor, click Basic.

NOTE: If you return to the basic editor, the rules you created in the advanced editor remain
active but are hidden. If you create new rules in the basic editor, they are added to the userdefined rule set the next time you open the advanced editor.
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More About Segmentation Rules
Following are some additional points to keep in mind when working with segmentation rules:
n

When creating segmentation rules, keep in mind that you may need to enter spaces (or you
can enter \s if using a regular expression) where necessary (see examples below). Depending on the circumstance, a space may need to be added after the last word in the After
column, or it may need to be added before the first word in the Before column. The reason for
this is that content structures and languages are different. An expert knowledge of regular
expressions may help to remove the guessing from this task.

n

There may be times when you create a rule on the left side of the editor (do not break) that
conflicts with another rule on the right side (break). In that case, the do not break rule overrides the break rule.

n

You can restore Lingo's segmentation rules to their default settings (i.e., clear all custom
rules). To do this, click Restore Default.
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n

Segmentation rules are not tied to the project. They are external and are stored in Documents\LingoSRX. Therefore, all Lingo projects that you create can use the same rules.

n

There are certain default segmentation rules in place (e.g., when Lingo comes across Dr., it
does not break the segment). However, you can create custom rules, which will overwrite the
default rules when conflicts exist.

n

User-defined rules are applied to all languages.

n

When working in the advanced editor, if you add a rule to a language that has multiple language dialects (e.g., English has dialects for countries such as the United States and the
United Kingdom), the rule will be applied to each dialect in that language. However, if you add
a rule to a language's dialect, the rule is not applied to any other dialect in that language or to
the top-level language (e.g., if you add a rule to English (Ireland), it is not applied to English
(Jamaica) or English).

n

You can sort the rules by clicking the column headings.
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n

You can resize the columns by clicking the divider between the column headings and dragging to the left or right.

n

Custom segmentation rules do not work on SDLXLIFF, TTX, and TXML files, because these
files should be segmented already by other tools before they are imported.
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Examples
Following are some examples of how you might create segmentation rules:
EXAMPLE—DO NOT BREAK
Let's say you import a Word document and the segments look like this in the Translation Editor:

Notice that the first two rows should be joined into a single segment, and the final three
rows should be joined together as well.
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To accomplish this with segmentation rules, you can do the following:

With these rules in place, you can update the project and the segments will look like
this:
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EXAMPLE—BREAK
Let's say you import a Word document and the segments look like this in the Translation Editor:
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This is a situation where you want the first segment to remain as it is, but you need the
second segment to break after Dr. You can do this manually by splitting the segment,
or you can do it automatically by creating a segmentation rule like the following:

With this rule in place, you can update the project and the segments will look like this:
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EXAMPLE—DO NOT BREAK (U SING REGU LAR EXPRESSIONS)
Let's say you import a Word document and the segments look like this in the Translation Editor:
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To correct these breaks, you can create a segmentation rule like this:

With this rule in place, you can update the project and the segments will look like this:
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We can edit the rule so that Lingo does not break segments when Vol. or vol. is followed by a number. But if it is followed by a character, it will break. To accomplish this,
we can edit the segmentation rule as shown here:
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The modified rule tells Lingo to avoid breaking a segment when it finds Vol. or vol. followed by a number, including occasions when a space exists before the number. With
this rule altered, you can update the project and the segments will look like this:

NOTE: You can use regular expressions with either basic or advanced segmentation rules.
However, you may choose to use an advanced segmentation rule if you want to set a rule
for a specific language rather than for all languages.
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Importing and Exporting Segmentation Rules
You can use buttons at the bottom of the segmentation rule dialog to import or export SRX files.

After exporting an SRX file, another Lingo user can import it into a project. Only SRX files generated
from Lingo can be imported into Lingo.
NOTE: When you import an SRX file, it replaces your current SRX file, including any custom
rules in it.
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Applying Segmentation Rules
After you create segmentation rules, you must make an edit to the file or create an entirely new project. Then you can update the project to apply rules to the segments.
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About Split/Join
Sometimes you may have segments in the Translation Editor that you need to join together or split
apart. You can do this in a couple of ways in Lingo—automatically by using segmentation rules or
manually by using the split and join features.
Similar to the alignment tool, you can split and join segments manually in the Translation Editor. You
might choose this manual process instead of segmentation rules when you need to quickly split or
join segments and do not anticipate the need to do so automatically in future translations.

Split
To split a segment, simply place your cursor where you want the split to occur and in the local toolbar click
.

EXAMPLE
Let's say you import a Word document and the segments look like this in the Translation Editor:
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Therefore, you click in the segment where you want to create the break. Then in the
local toolbar you click
.

As a result, the segment is split, like this:

NOTE: The split feature is disabled for the following MadCap Flare project files: .liindexmap,
.liconceptmap, .flaix, and .flixl files.
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Join
To join segments, hold down the SHIFT or CTRL key and select the relevant segments. Then in the
local toolbar click
.

EXAMPLE
Let's say you import a Word document and the segments look like this in the Translation Editor:
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Therefore, you hold down your CTRL key and select both segments. Then in the local
toolbar you click
.

As a result, the segments are joined, like this:

NOTE: In order to join segments they must be part of the same translation unit (e.g., same
paragraph, same list item). If you select segments that are not part of the same translation
unit, the join option is disabled.
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Sorting Indexes and Glossaries
There may be times that you want to create a custom sort order for your Flare index or glossary.
You can do this by adding a "Sort As" term to the index or glossary term. Custom sort orders are
especially important when translating a Flare project because terms in each translated language
may have different spellings or pronunciations that are not automatically picked up by Flare.
Because of this, you may need to specify how the index or glossary should sort a term, so the term is
identified correctly when the Lingo project is exported back to Flare.

EXAMPLE
You are translating a project into Japanese, which uses three different character
types. You are translating mostly in kanji, but you want to use katakana in your index
and glossary because these characters are phonetic.
Because of this, you use Lingo's sort as feature to add katakana "Sort As" terms for
each index and glossary word in the Lingo project.
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Later, when the project is exported back to Flare, the index and glossary are sorted
using the katakana alphabet instead of the kanji alphabet.
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HOW TO SORT THE INDEX OR GLOSSARY
1. Open and translate the MadCap Flare glossary (.flglo) and index (.liindexmap) files in your
Lingo project. See "Introduction" on page 6.
2. Select File > Project Properties. The Project Properties dialog opens.
3. Select the Sort Order tab.
4. From the Select file drop-down, select the index or glossary file you want to sort. The terms in
the file appear in the grid below.
NOTE: If your project has been filtered by a target or condition tag, the glossary file
only displays terms that have not been excluded.
5. Review the terms in each Entry column. These are the terms you entered in the MadCap Flare
glossary (.flglo) and index (.liindexmap) files. If you need to enter a new term for sorting, type
it in the Sort As column.
NOTE: You can also see the Entry and Sort As terms from the source project, if applicable.

NOTE: You can only make changes in the Sort As column. If you need to change the
term in the Entry column, you can edit the translation in the glossary or index file.
6. (Optional) Repeat steps 4-5 for any other index and glossary files.
7. Click OK.
When translated project is exported back to Flare, the index and glossary will use the new terms to
alphabetize the entries.
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APPENDIX

PDFs
The following PDFs are available for download from the online Help.
Alignment Guide
Getting Started Guide
Key Features Guide
Shortcuts Guide
Source Control Guide: Git
Source Control Guide: Perforce
Source Control Guide: Subversion
Source Control Guide: Team Foundation Server
Termbases Guide
Touring the Workspace Guide
Translation Guide
What's New Guide
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