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CHAPTER 1

Introduction
Following are the new features in this release of Lingo.
For more information about each feature discussed in this manual, open the online Help and refer to
the "What's New" topic. Links are provided in some feature descriptions, taking you to topics that
contain additional information and steps.
Feature

What's New?

"DeepL Machine Translation" on
page 7

n

Choose DeepL for machine translation

n

Translate projects with DeepL

"Export All Languages" on page 12

n

New drop-down option for all languages when exporting

n

New option to append language code to files

n

New Thesaurus window pane

n

Search for synonyms and apply them to translations

"Thesaurus" on page 16
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Feature
"Additional Features" on page 22
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What's New?
n

Adobe FrameMaker 2019 support

n

Interface themes updated

n

Language drop-down in File List window pane

n

Norwegian Bokmal and Nynorsk language support

n

Source control enhancements (merging and reverting branches)

n

Start Page redesigned

n

Support for new file types (JSON, Flare micro content, SVG)
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CHAPTER 2

DeepL Machine Translation
You can now use DeepL as a machine translation (MT) option. You can connect to DeepL through
the Options dialog or choose the MT provider through the Resources ribbon.
Please refer to the DeepL website for a current list of supported languages.

HOW TO SET DEEPL FOR MACHINE TRANSLATION
1. In the Resources ribbon, click Choose MT. The Machine Translation Providers dialog is displayed.
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2. Click DeepL. The Machine Translation Provider Settings dialog is displayed.

3. Enter the Authentication Key.
4. (Optional) Click Test Connection.
5. (Optional) If you want to save previously used MT results in an XLIFF file, select Cache MT
results as XLIFF alternates. This prevents the MT from looking for new translations for previously translated segments. If the source segment is modified, the MT will look for a new
translation for the updated segment. If this option is disabled, the MT will look for new translations whenever you click a target segment or translate the project with the MT.
6. (Optional) If you want MT suggestions to show up when you are doing a concordance
search, select Use MT in concordance searching. In the Concordance Search window pane,
you can tell whether a suggestion comes from translation memory (TM) or MT by hovering
over a segment.
7. Click OK.
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EXAMPLE
Say you are translating a project from English to Spanish. You have an existing TM in
your project, but also want an MT provider to address any empty segments. So you
add DeepL as an MT to get some additional suggestions. You then open the file you
are translating to Spanish.
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You start clicking through the empty segments, and receive suggestions in the TM
Suggestions pane.
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When you double-click the DeepL suggestion, it populates the target segment. The
Status field remains at 0% because MT suggestions are initially set at this percentage, since Lingo is not making the direct suggestion. Once the suggestion is
added to the TM, the Status field percentage is updated.
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CHAPTER 3

Export All Languages
If you have a multilingual project, you can export all of the languages enabled for that project.
You can also export all languages from the command line prompt.

HOW TO EXPORT ALL LANGUAGES IN LINGO PROJECT
1. Select File > Export.
2. From the Language field, select All Languages.
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3. (Optional) If you are translating non-project files and want to apply a code (e.g., "es" for Spanish) to the individual files you are exporting, select Append language code to files. This setting is beneficial if you want to flatten the exported files so you can see them side by side,
instead of having all instances of the same file name without any language code attached to
those files.
NOTE: If this option is not selected, the language code is used for the parent folder
name for each of the exported languages (e.g., if you are translating to Spanish, the
folder is named “es”). This option is not displayed if you are translating project files.
4. (Optional) In the Destination Filename field, you can keep the name or enter a different one
for the exported project.
5. (Optional) In the Destination Folder field, you can click Browse to find and select a different
location. Typically, you want to export the project to a location where the author can retrieve
it, unless you plan to deliver the file(s) to the author in some other way (e.g., email).
6. (Optional) If you want to create an additional ZIP file when exporting the project, select
Make a zip file after export. If you do not select the check box, the project files are still exported, but a ZIP file is not created. If you do select the check box, the project files are exported
and an extra ZIP file is produced.
NOTE: When you create a ZIP file on export, the folder structure is maintained.
7. Click Export.
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HOW TO EXPORT ALL LANGUAGES FROM COMMAND LINE PROMPT
If you wish to export all of the languages in your Lingo project using the command line, this is the
syntax you would use:
lingoproject.exe -project [project file] -sourcefile [source file]
-exportTo [export path] -syncProject [true/false] -appendLanguage
[true/false]

NOTE: Since the -language argument is omitted from this command, Lingo will export all
languages in the project. The -appendLanguage argument of this command indicates that
a language code will be used for the parent folder name for each of the exported languages of non-project files.

NOTE: The -syncProject argument is optional. It will update the Lingo project with the
source file before exporting.

NOTE: Quotation marks must be used around the location of the project file, source file,
and export path in your command if you have a space in the file or path name.
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EXAMPLE
Say that you have a Lingo project called "San-Diego" that has been translated into
Danish and Dutch. This project is stored in your Translated-Projects folder on your
local C drive. The source Flare project file is also located on your C drive in the
Source-Files folder. You want to export your project to a network location that is
mapped to your S drive. You would first type the path to the Lingo.app folder where
you installed Lingo. If you installed Lingo to the default location, you would type this
and press Enter on your keyboard:
cd\Program Files\MadCap Software\MadCap Lingo 11\Lingo.app
Next, type this and press Enter on your keyboard:
lingoproject.exe -project C:\Translated-Projects\SanDiego.liprjf\San-Diego.liprj -sourcefile C:\SourceFiles\San-Diego.flprj -exportTo S:\Exported-Projects
-syncProject true
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CHAPTER 4

Thesaurus
The Thesaurus window pane displays on the right side of the interface and lets you look up and use
related words in an open file. You can use the thesaurus to apply synonyms to the target segment.
You can switch the language being used at the bottom of the Thesaurus window pane.
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Using the Thesaurus in Lingo
The Thesaurus window pane shows categories of terms related to the word being searched. You
can expand or collapse any of these categories by clicking the arrow buttons. If you click one of the
terms in a category, the window pane dynamically adjusts to show different words and categories
specific to that term.

There are a few ways you can access the thesaurus:
n

Select Tools > Thesaurus.

n

Click a term in the open file, and press SHIFT+F7 to view the results for that term in the
thesaurus.

n

At the top of the Thesaurus window pane is a search field, which lets you manually look for a
term. Simply enter text and click Search.

n

Right-click a term in the open file, and from the context menu select Thesaurus.
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EXAMPLE
Say you want to find a term related to the Spanish word for "apparent." You rightclick the word "evidente" in line 5 in the screenshot below. In the context menu,
select Thesaurus.

The Thesaurus window pane displays related words for "evidente."
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To use a related term in the target segment, you can do either of the following:
n

Right-click the related term in the Thesaurus window pane and in the context menu select
Insert. This replaces the word nearest the cursor in the target segment.

n

Right-click the related term in the Thesaurus window pane and in the context menu select
Copy. Then paste that term anywhere you want.

CHAPTER 4

19

Using Synonyms In The Thesaurus
If there are word matches when using the thesaurus, an option for Synonyms is available when you
right-click the matched word.
EXAMPLE
Say that you are looking up matches for "influencia" using the thesaurus. The following
matches are displayed in the Thesaurus window pane.
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If you right-click "influencia" again in the translation pane, you will see an option for Synonyms in the context menu. When you select Synonyms, the words displayed at the top
of the Thesaurus window pane can easily be selected to replace "influencia."

NOTE: If there are no matches for a word in the thesaurus, the Synonyms option is not displayed in the context menu.

NOTE: Some dictionaries do not support thesauruses. In the Options dialog (File >
Options), click the Spelling tab and look at the Thesaurus column to see if your language
supports it.
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CHAPTER 5

Additional Features
In addition to the features already discussed, some additional new features are being introduced in
this version.
This chapter discusses the following:
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Adobe FrameMaker 2019 Support
If you are translating Adobe FrameMaker files, Lingo now supports FrameMaker 2019.

Interface Themes Updated
The black, classic, and silver interface themes have been redesigned.
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Language Drop-Down in File List Window
Pane
You can select the language of your project in the File List window pane (View > File List), in addition
to the Project Properties dialog (File > Project Properties).
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Norwegian Bokmål and Nynorsk Language
Support
Lingo now supports Norwegian Bokmål and Nynorsk languages. These languages can be selected
when you start a new Lingo project, or in the Project Properties dialog.
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Source Control Enhancements
If you are integrating your Lingo project with Git source control, you can now merge branches and
revert commits you have made in branches.

Merging Branches in Git
In previous versions of Lingo you could merge individual files bound in Git. Now you can merge Git
branches as well.

HOW TO MERGE BRANCHES IN GIT
1. Do one of the following, depending on the part of the user interface you are using:
n

Ribbon Select Source Control > Merge.

n

Right-Click If you have the File List window pane open, right-click any file and select
Source Control > Project > Merge.
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n

Source Control Explorer Click the Merge Branch button.

The Select branch to merge dialog opens.
2. From the drop-down, select the Git branch you wish to merge into the active branch.

CHAPTER 5

29

3. Click OK.
4. When the merge operation is completed, a dialog displays, indicating the merge was a success. Click OK to close the dialog.

EXAMPLE
Let's say you have two feature branches that are bound in Git source control.
In the first feature branch (develop-feature1), you make changes to a file called “Getting-Started” and commit those changes. These changes are specific to the first feature being developed.
In the second feature branch (e.g., develop-feature2), you make changes to the same
"Getting-Started" file and commit those changes. These changes are specific to the
second feature being developed, and are being made in a separate part of the topic
from the develop-feature1 changes.
After you complete and commit your changes on the second feature branch, you
decide you want to merge your changes from the first feature branch to the second
feature branch.
In the Source Control Explorer, you select the develop-feature2 branch. Then, you click
the Merge Branch button. From the drop-down, you select develop-feature1.

You click OK to merge. Since the changes took place in different sections of the "Getting-Started" file, the merging of the first feature branch into the second feature branch
is successful.

NOTE: For more information on how Git branching and merging works, the Git website
provides in-depth workflows and additional details:
https://git-scm.com/book/en/v2/Git-Branching-Basic-Branching-and-Merging.
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Reverting Commits in Git
A revert is a type of commit that undoes a prior commit on your branch. Reverting becomes necessary if changes have been made that are no longer needed. For example, if you have committed
changes for a feature branch that is no longer going to be included in a release, those changes need
to be reverted.
An advantage of reverting a prior commit on your branch is that it will back out any unwanted
changes. If other writers are making changes on the same branch, any reverted commits will be
picked up by the other writers when they pull from that branch.
But one disadvantage of reverting commits in your branch is that it will remove part of your branch
history. The revert removes the part of your branch history that contained the commits that were
undone.

HOW TO REVERT COMMITS IN A GIT BRANCH
1. Select View > Source Control Explorer, and select your branch containing changes that you
want to revert.
2. In the Source Control ribbon, click Branch History. The dialog that opens lets you view and
revert specific commits within your branch.
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The following columns are displayed:
n

Commit Type This indicates the type of changes checked in on the branch. You can
view when a branch was started, when a commit was made, or when a merge occurred.

n

Branches This column displays the branches that are affected by the action taken. If
the changes affect more than one branch then all of the affected branches are displayed in this column.

n

Commit This alphanumerical code provides the commit number used by Git.

n

Commit Time This displays the date, followed by the time the commit was made in your
Git branch.

n

Author This displays the name of the author that committed the specific change in the
branch.

n

Comments This column displays the comments made for each commit.

3. Select the row that contains the commit you want to back out.
4. Click Revert.The Accept reverted modifications dialog opens.
5. Click Accept.
6. A confirmation message confirms the revert was successful. Click OK to close this dialog.
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Start Page Redesigned
The Start Page in Lingo has been redesigned, making it even easier to use. If you do not see it,
select View > Start Page.

CHAPTER 5

33

Support for New File Types
Lingo now supports JSON, micro content, and SVG files.

JSON File Support
Lingo now provides support for translating JSON files. This lets you choose the parts of the JSON
file that are filtered for translation. In the File Filters dialog, click in the File type field and select
JSON Files.

A file filter for JSON is created based on the attributes in the existing JSON file. If you update a project and there are new attributes associated with the JSON file, you will need to manually add it to
the file filter.
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Micro Content File Support
Micro content files can now be translated in Lingo. You can translate phrases and responses contained in the micro content file. For more information on micro content, see the Flare online Help.

SVG File Type Support
Lingo now supports translation of text within SVG files. When you translate the SVG file, the text
within each <text> tag displays as a segment.
EXAMPLE
Say that you want to translate a project that contains multiple SVG files. One of these
SVG files contain three lines of text. There are also three separate <text> tags within
the XML version of this file.
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When this file is brought into Lingo, those lines in the SVG file are represented as three
separate segments.
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The following PDFs are available for download from the online Help.
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Getting Started Guide
Key Features Guide
Shortcuts Guide
Source Control Guide: Git
Source Control Guide: Perforce
Source Control Guide: Subversion
Source Control Guide: Team Foundation Server
Termbases Guide
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Translation Guide
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