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CHAPTER 1

Introduction
You can leverage translation work previously completed outside of Lingo by using the alignment
feature.

Process

1. "Creating Alignment Projects" on page 6

2. "Aligning Files" on page 12 and "Aligning Segments" on page 19

3. "Using Segmentation Rules" on page 30

4. Upload segments to translation memory (click in the local toolbar, or click to upload all
of the segments in the file)

CHAPTER 1  4



EXAMPLE Your company has some legacy content that was created in English using
MadCap Flare (or even another tool such as Microsoft Word). Subsequently, that content
was translated into German using a tool other than Lingo. Now your company has
purchased Lingo and wants to use it to translate future updates to that same
documentation. The problem is that you do not want to lose all of that previous translation
work. The solution is to launch the MadCap Align utility from Lingo and create an
alignment project.

From MadCap Align, you use the Start Alignment Wizard to create the new alignment
project. In the process of doing this, you select the English version of the original Flare
project (or other type of project/file), as well as the German translation of that project or
file. In addition, you make sure the option is selected in the wizard to automatically upload
the translated segments to your translation memory. Therefore, when you translate
content in future Lingo projects, that previously translated content can be used via the
suggestions feature in Lingo.
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CHAPTER 2

Creating Alignment Projects
You can create alignment projects after launching MadCap Align. An alignment project lets you
leverage translation work previously completed outside of Lingo, uploading translated segments to
your translation memory database.

How to Create an Alignment Project
1. Select Tools > MadCap Align.

2. In MadCap Align, select File > New Project. The Start Alignment Wizard opens.

3. Under the Source Version field, click Select File or Select Folder to bring files or folders,
respectively, into the new project.

NOTE If you want to align files from a Flare, Mimic, or Doc-To-Help project, you
must select the project file using the Select File button, rather than selecting the
folder where the project is located.

4. In the dialog that opens, navigate to the original project, file (in the original language), or
folder (of individual files) and double-click it to add it to the alignment project.

5. From the Source Language drop-down, select the original language that is used in the
project you are translating.
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6. Under the Target Version field, click Select File or Select Folder.

NOTE If you selected a file for the source version, Align will disable the Select
Folder button. Likewise, if you selected a folder, Align will disable the Select File
button.

7. In the dialog that opens, navigate to the previously translated version of that same project,
file (in the original language), or folder (of individual files) and double-click it to add it to the
alignment project.

8. From the Target Language drop-down, select the language that you want to use for the
translation.

9. (Optional) Add a translation memory (TM) database to the alignment project. Do one of the
following:

n Select an Existing TM From the Translation Memory drop-down, you can select a
translation memory database.

n Add a New TM Click New Local or New Server to add a new TM.

10. Click Next.

11. In the Project Name field, type an appropriate name for your project.

12. By default, a path to the Documents\My Aligned Projects folder on your hard drive is entered
in the Project Folder field. (This folder is created when you install the program.) All
subfolders and files related to the aligned project will be placed in this folder as you work on
the project.
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13. Select an option for uploading alignments to your TM.

n Review all alignments before upload to translation memory

n Upload aligned files and review only unmapped files and files with imperfect
alignment

NOTE If you select this option, any uploaded segments that are already
matched 100% will not be displayed in the File Map window pane in MadCap
Align. Only files with segments that require alignment will appear in the File
Map window pane.

NOTE In order to use this feature, you must first install a translation memory
database.

n Force segment alignment and upload segments; unmapped files will be
disregarded and no align project will be created

NOTE In order to use this feature, you must first install a translation memory
database.

CHAPTER 2  8



EXAMPLE You are translating a small Flare project. During the original translation,
you translated the topic "Topic.htm" into Spanish. Later, however, an author split
that topic in the source project into two separate files—Topic.htm and Topic2.htm.
There are also nine other files in the project (e.g., glossary files, skin files).

Because there are differences between the translated file and the source file, you
need to create an alignment project. Here's what would happen if you used each
TM alignment option.

n Review all alignments before upload to TM

All 11 files in the project are available for review. This option takes the most
work, because you have the option to review the files that are already aligned
and the files that are not aligned, but it is the best way to be sure that there are
no errors.
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n Upload aligned files and review only unmapped files and files with
imperfect alignment

Align automatically uploads the nine files that are already aligned to the TM.
These files are not shown in the File Map. However, the two files that need to
be aligned—Topic.htm and Topic2.htm—are shown in File Map so you can
manually align them. This is a good option if you have a lot of files in your
project and you only want to find the files that are not aligned.
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n Force segment alignment and upload segments; unmapped files will be
disregarded and no align project will be created

Since there are nine files that are already aligned, these files would be
successfully uploaded to the TM. The remaining files—Topic.htm and
Topic2.htm—would be disregarded. The alignment project would not be
created. This option is the quickest option because it eliminates manual work,
but you may miss out on alignments if there are several unaligned files.

14. Click Finish.
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CHAPTER 3

Aligning Files
When you create an alignment project, the original and translated files are matched and aligned by
name. Although it might not be a common occurrence, there are a variety of reasons that a file from
the original project might not be aligned with the same file in the translated project. The important
thing is that you identify any misalignment and then correct it. You can do this by using the File
Map window pane in MadCap Align.

The File Map window pane groups files found in both projects by file type. For each type, you can
match the files together when necessary. There are a few operations for aligning files; you can
shift the selected cells up and down, or swap two selected cells. After the files are aligned, you can
manually upload them to your translation memory database.
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How to Align Files
1. Select Tools > MadCap Align.

2. In MadCap Align, open the aligned project. Unless you specify otherwise, these types of
projects are stored in the Documents\My Aligned Projects folder on your computer. (Lingo
creates the My Aligned Projects folder when you install the program).

3. The File Map window pane should already be open. If it is not, do one of the following,
depending on the part of the interface you are using.

n Ribbon Select Home > File Map.

n Keyboard Shortcut Press CTRL+SHIFT+R.

4. (Optional) In the File Map window pane, you can use the Filter field in the local toolbar to
choose the types of files to see in the window pane.

5. Select the appropriate cell(s) on either the source language side or the target language side.
You can hold down your SHIFT or CTRL key to click and select multiple cells.

6. In the local toolbar, click one of the buttons to perform an alignment action (so that the
source files on the left are aligned with the proper target files on the right).

If you have selected two cells (one above and one below) and click this button,
the positions of those two cells will be swapped.

Click this button if you want to swap the selected cell(s) with those below it.

Click this button if you want to swap the selected cell(s) with those above it.

NOTE You can only swap a cell with the cell above or below it if the files have the
same extension. If you cannot swap a cell, one or more alignment buttons will be
grayed out.

7. Click to save your work.
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EXAMPLE After creating an alignment project, let's say you open the File Map window
pane and notice that all of the file rows are aligned with identical names, except for two
skin files—"HTML5.flskn" and "Default.flskn."
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To fix this you can select one of the misaligned cells (say, the "HTML5.flskn" file in the first
column) and click the appropriate swap button.
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The files become aligned, like this:

You can then upload the aligned files to the translation memory database.
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You also might encounter situations where one file should actually align with two or more files.

EXAMPLE During the original translation, the topic "Topic.htm" was translated into
Spanish and the resulting topic file name was also "Topic.htm." Later, however, an author
split the topic in the original version into two separate files—Topic.htm and Topic2.htm. In
the File Map window pane of an alignment project, the results might look like this (notice
that about half of the segments are in the source Topic.htm file and the other half are in the
source Topic2.htm file):

You can align and upload the files in order to store all of the translated data in translation
memory. To do this, you would begin by aligning the first topic with the translated file. In
the image above, this is already done (Topic.htm is aligned with Topic.htm on the right).
Then you would double-click the row with the aligned files (Topic.htm and Topic2.htm). In
the Alignment Tool, you would make sure the aligned segments are translated properly
and use one of the buttons in the local toolbar to upload the file or selected segments to
translation memory.
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After this, you would close the Alignment Tool. Then, in the File Map window pane, you
would align the Topic2.htm source file with the Topic.htm target file. For example, with the
Topic.htm source cell selected, you can click . This will swap that cell with the
Topic2.htm cell, like this:

Once this is done, you would double-click the row with the aligned files (i.e., Topic2.htm
and Topic.htm). In the Alignment Tool, you would make sure the aligned segments are
translated properly and use one of the buttons in the local toolbar to upload the file or
selected segments to translation memory.
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CHAPTER 4

Aligning Segments
Whereas the File Map window pane can be used to perform alignment at the file level, the
Alignment Tool can be used to do the same at the segment level. In most cases, you probably will
not need to align segments. However, there may be situations when it is necessary.

To open the Alignment Tool, first open the File Map window pane in the MadCap Align utility (View
> File Map). Then double-click on the associated pair of files. Like the File Map window pane, the
Alignment Tool lets you shift selected cells up and down, or swap two selected cells. In addition,
you can split and join segments.
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How to Align Segments
1. Select Tools > MadCap Align.

2. Open the aligned project. Unless you specify otherwise, these types of projects are stored in
the Documents\My Aligned Projects folder on your computer. Lingo creates the My Aligned
Projects folder when you install the program.

3. In the File Map window pane, double-click on a row with aligned files. The Alignment Tool
opens, displaying all of the segments from those aligned files.

If the File Map window pane is not already open, select Home > File Map or press
CTRL+SHIFT+R on your keyboard.

4. Select the appropriate cell(s) on either the source language side or the target language side.
You can hold down your SHIFT or CTRL key to click and select multiple cells.

5. In the local toolbar, click one of the buttons to perform an alignment action (so that the
source segments on the left are aligned with the proper target segments on the right).

If you have selected two cells (one above and one below) and click this button,
the positions of those two cells will be swapped.

Click this button if you want to swap the selected cell(s) with those below it.

Click this button if you want to swap the selected cell(s) with those above it.

Click this button if you have selected one cell and want to split its content into
two cells. This button is disabled until you double-click in the cell that you want
to split. After double-clicking the cell, place your cursor where you want the split
to occur in the segment. Then click this button.

Click this button if you have selected multiple cells (above and below one
another) and you want to join the content within them into a single cell.
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NOTE Rather than using split and join, you can alternatively use segmentation
rules. See "Using Segmentation Rules" on page 30.

6. Click to save your work.

EXAMPLE After creating an alignment project, let's say you double-click on a pair of files
in the File Map window pane and notice the following in the Alignment Tool.
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The segments are not completely aligned. Therefore, you correct the situation, like this.
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Now the cells are correctly aligned with their counterparts on the left, so you can upload
them to translation memory.
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EXAMPLE — Splitting a Segment Into Two

Here is a situation where two segments are stuck together:
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To split the segments apart, double-click in that cell. Then place your cursor where you
want the split to occur.
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When finished, you can upload the aligned segment(s) to your translation memory
database.
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EXAMPLE — Joining a Segment That is Split

Here is an example where one segment has been broken into two:
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You can join that segment, like this.
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When finished, you can upload the aligned segment(s) to your translation memory
database.

What’s Next?
After you align segments, you should upload them to your translation memory database. If you
select specific segments and click in the local toolbar, only those translations will be uploaded.

If you click in the local toolbar, all translations in the file will be uploaded.
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Using Segmentation Rules
When you are preparing your legacy translation content for Lingo, you may have segments in the
Alignment Editor that you need to join together or split apart. You can do this in a couple of ways in
Lingo—automatically by using segmentation rules or manually by using the split and join features.
By using segmentation rules or split and join features, you can ensure that the segments in your
translation memory are in the best shape possible when you open your legacy project in Lingo.

If you want to control segment breaks automatically, you can create segmentation rules. Lingo
follows the format specified by Segmentation Rules eXchange (SRX). Therefore, after you create
segmentation rules, you can export them to an SRX file. You can also import SRX files that have
been generated in Lingo.

Regular Expressions
Lingo's segmentation rules are based on regular expressions. Therefore, you can use regular
expressions in the Segmentation Rules dialog when creating segmentation rules. However, this is
purely optional; it is not required that you enter regular expressions in your segmentation rules.

[a-z] Matches any lowercase letter

[A-Z] Matches any uppercase letter

\d Matches any decimal digit

\D Matches any non-digit

\s Matches any white-space character

{…} Explicit quantifier

For example, a{3} finds "aaa"

| Alternation

For example, gray|grey finds "gray" or "grey"

(…) Logical grouping
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? 0 or 1 of previous expression; forces minimal matching when expression might match
several strings within a search string

For example, reg(ular expressions?|ex(p|es?) finds "regular expression," "regular
expressions," regex, regexp, or "regexes"

For more examples and information about regular expressions, see the following:

http://www.regular-expressions.info/

http://regexlib.com/CheatSheet.aspx

NOTE When using regular expressions in segmentation rules, keep in mind that a period
in a rule (e.g., "break after St."; "do not break after St. and before Augustine") may cause
unexpected results. This might occur because in regular expressions a period is used to
match any character. You can avoid this by always placing a period within square brackets
(e.g., "break after St[.]"; "do not break after St[.] and before Augustine") to ensure only the
specific character for the period is used.
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NOTE The following MadCap Flare project files are only segmented based on their units
from Flare and not based on regular segmentation rules (periods and other punctuation
rules): .liindexmap, .liconceptmap, .flaix, and .flixl files. Therefore, rules from the
Segmentation Editor are not applied to these files.

NOTE Lingo only supports .NET regular expressions.
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Creating Basic Segmentation Rules
To create basic segmentation rules, start by selecting the Home ribbon and clicking Segmentation
Rules. In the Segmentation Rules dialog, there are two sections where you can add terms. The
section on the left lets you tell Lingo the cases where you do not want segments to break. The
section on the right lets you tell Lingo the cases where you do want segments to break.

Segmentation rules can be especially useful for abbreviations and other terms that may contain
periods (or other punctuation) that Lingo usually recognizes as the end of a sentence.
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Creating Advanced Segmentation Rules
You can also create advanced segmentation rules. Advanced segmentation rules allow you to
override or edit Lingo's default segmentation rules and to set segmentation rules for specific
languages.

To create advanced segmentation rules, start by selecting the Home ribbon and clicking
Segmentation Rules, then click Advanced. Two new tabs appear in the editor: Rules and
Languages.

NOTE Advanced segmentation rules influence the handling of source language
segments, not target language segments.
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Rules Tab
This tab lets you add, edit, or remove segmentation rules using regular expressions.

n Select a language from the drop-down list. Use the Languages tab to set the languages that
appear in this list. After you select a language, you can add, edit, or remove rules associated
with that language.

n You can also edit user-defined rules and default rules.
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Languages Tab
This tab lets you select the languages for which you need to create segmentation rules.

n To add a language, select it in the Available Languages list. Click to add it to the Current
Languages list.
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n To remove a language, select it in the Current Languages list. Click to remove it from the
Current Languages list.

Languages in the Current Languages list appear in a drop-down on the Rules tab.

If you want to return to the basic editor, click Basic.

NOTE If you return to the basic editor, the rules you created in the advanced editor remain
active but are hidden. If you create new rules in the basic editor, they are added to the
user-defined rule set the next time you open the advanced editor.

CHAPTER 4  37



More About Segmentation Rules
Following are some additional points to keep in mind when working with segmentation rules:

n When creating segmentation rules, keep in mind that you may need to enter spaces (or you
can enter \s if using a regular expression) where necessary (see examples below).
Depending on the circumstance, a space may need to be added after the last word in the
After column, or it may need to be added before the first word in the Before column. The
reason for this is that content structures and languages are different. An expert knowledge of
regular expressions may help to remove the guessing from this task.

n There may be times when you create a rule on the left side of the editor (do not break) that
conflicts with another rule on the right side (break). In that case, the do not break rule
overrides the break rule.

n You can restore Lingo's segmentation rules to their default settings (i.e., clear all custom
rules). To do this, click Restore Default.
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n Segmentation rules are not tied to the project. They are external and are stored in
Documents\LingoSRX. Therefore, all Lingo projects that you create can use the same rules.

n There are certain default segmentation rules in place (e.g., when Lingo comes across Dr., it
does not break the segment). However, you can create custom rules, which will overwrite the
default rules when conflicts exist.

n User-defined rules are applied to all languages.

n When working in the advanced editor, if you add a rule to a language that has multiple
language dialects (e.g., English has dialects for countries such as the United States and the
United Kingdom), the rule will be applied to each dialect in that language. However, if you
add a rule to a language's dialect, the rule is not applied to any other dialect in that language
or to the top-level language (e.g., if you add a rule to English (Ireland), it is not applied to
English (Jamaica) or English).

n You can sort the rules by clicking the column headings.
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n You can resize the columns by clicking the divider between the column headings and
dragging to the left or right.

n Custom segmentation rules do not work on SDLXLIFF, TTX, and TXML files, because these
files should be segmented already by other tools before they are imported.
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Examples
Following are some examples of how you might create segmentation rules:

EXAMPLE — Do Not Break

Let's say you open an alignment project and the segments look like this in the Alignment
Tool:

Notice that the segments are already aligned, but they are not segmented the way you
want. The first two rows should be joined into a single segment, and the final three rows
should be joined together as well.
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To accomplish this with segmentation rules, you can do the following:

With these rules in place, you can reimport the project and the segments will look like this:
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EXAMPLE — Break

Let's say you open an alignment project and the segments look like this in the Alignment
Tool:
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The segments are already aligned, but they are not segmented the way you want. You
want the first segment to remain as it is, but you need the second segment to break after
Dr. You can do this manually by splitting the segment, or you can do it automatically by
creating a segmentation rule like the following:
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With this rule in place, you can reimport the project, and the segments will looks like this.
Segmentation rules created in Align are applied to both the source and target segments, if
applicable.
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EXAMPLE — Do Not Break (Using Regular Expressions)

Let's say you open an alignment file and the segments look like this in the Alignment Tool:
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The segments are aligned, but they are not segmented the way you would like them to be.
To correct these breaks, you can create a segmentation rule like this:

With this rule in place, you can reimport the project and the segments will look like this:
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We can edit the rule so that Lingo does not break segments when Vol. or vol. is followed by
a number. But if it is followed by a character, it will break. To accomplish this, we can edit
the segmentation rule as shown here:
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The modified rule tells Lingo to avoid breaking a segment when it finds Vol. or vol. followed
by a number, including occasions when a space exists before the number. With this rule
altered, you can reimport the project and the segments will look like this:

Segmentation rules created in Align are applied to both the source and target segments, if
applicable.

NOTE You can use regular expressions with either basic or advanced segmentation
rules. However, you may choose to use an advanced segmentation rule if you want to set
a rule for a specific language to match the source language.
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Importing and Exporting Segmentation Rules
You can use buttons at the bottom of the segmentation rule dialog to import or export SRX files.

After exporting an SRX file, another Lingo user can import it into a project. Only SRX files
generated from Lingo can be imported into Lingo.

NOTE When you import an SRX file, it replaces your current SRX file, including any
custom rules in it.
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Applying Segmentation Rules
After you create segmentation rules, you will need to create a new Align project to apply the
segmentation rules to the segments. For this reason, it is recommended that you create
segmentation rules in Lingo prior to creating an Align project, and only create new segmentation
rules in Align when necessary.

When you create segmentation rules in Align, they are applied to both the source and target
segments, if applicable.
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APPENDIX

PDFs
The following PDFs are available for download from the online Help.

Cheat Sheets
Shortcuts Cheat Sheet

User Guides
Alignment Guide

Getting Started Guide

Key Features Guide

Source Control Guide: Git

Source Control Guide: Perforce Helix Core

Source Control Guide: Subversion

Source Control Guide: Team Foundation Server

Termbases Guide
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Touring the Workspace Guide

Translation Guide

What's New Guide
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