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CHAPTER 1

Introduction
Welcome to MadCap Lingo—the first native XML, fully integrated computer-aided translation (CAT)
tool and workflow management solution. Translators can use Lingo to translate documents, or you
can use Lingo as a management tool while a translator uses a third-party CAT tool.

This chapter discusses the following:

File Types You Can Translate 6

Major Benefits 8

CAT Tool—Translators 9

Translation Workflow Management—Content Developers 11

Additional Help 13
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File Types You Can Translate
Lingo is a desktop solution that you can use to open and translate many types of files, including the
following:

n Adobe FrameMaker files (FM, MIF, and BOOK)

n Adobe InDesign files (IDML)

n DITA files (DITA, DITAMAP, XML)

n Doc-To-Help projects (D2H)

n HTM and HTML documents

n JSON files

n MadCap Capture image files (BMP, GIF, JPG, JPEG, PNG, TIF, TIFF)

n MadCap Contributor files (MCDOC)

n MadCap Flare package files (FLPRJZIP)

n MadCap Flare projects (FLPRJ)

n MadCap Lingo bundles (ZIP)

n MadCap Mimic movies and collections (MIMOV, MIPRJ)

n Microsoft .NET Resource files (RESX)

n Microsoft Excel documents (XLS, XLSX)

n Microsoft PowerPoint documents (PPT, PPTX)

n Microsoft Word documents (DOC, DOCX)

n Properties files (.properties)

n Rich text files (RTF)

n SDL Trados newer files (SDLXLIFF)

n SDL Trados older files (TTX)

n SQL files

n SVG files

n TXT files

n Wordfast files (TXML)
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n XLIFF 1.2 files (XLF)

n XML files
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Major Benefits
Major benefits of MadCap Lingo include the following:

n Choice between using Lingo in one of the following ways:

l CAT tool (for translators)

OR

l Translation workflow management solution (for content developers who need to get
their files into the hands of a translator)

n Easy-to-use interface

n 32- and 64-bit support

n Support for multilingual projects

n Complete Unicode support for left-to-right (LTR) as well as right-to-left (RTL) languages

n File List window pane, which takes the guessing out of which files need to be translated, and
which do not

n Machine translation (MT) to provide translation suggestions from popular internet translation
services

n A concordance to perform advanced searches in source and target segments, and to search
machine-translated suggestions

n Statistics that let you see how much work has been completed and how much still needs to
be done

n Quality assurance reports to find discrepancies between source and target segments

n Leverage previous translation work with translation memory (TM), including the ability to
import and export Translation Memory eXchange (TMX) files, Termbase eXchange (TBX)
files, and Segmentation Rules eXchange (SRX) files

n Easy review workflow using MadCap Contributor

n No need for out-of-project file transfers, which helps avoid content and formatting corruption
problems that are common with traditional localization workflows
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CAT Tool—Translators
Following are the basic steps that localization experts would follow for translating a project or
standalone files in Lingo. If instead you are content developer and your translator needs to use a
third-party CAT tool to perform the translations, see the steps listed after these.

1. Start Projects You can create a new Lingo project or open an existing one. See "Starting a
Lingo Project" on page 14.

2. (Optional) Create/Import Translation Memory You can create a TM database for the project
so that you can reuse previous translations. Creating a TM database can be done when you
go through the process for creating a Lingo project, or it can be done separately. You can
also import a TMX file into a TM database in case you have previous translation work that
you want to use in the new TM. For more information see the online Help or the Lingo
Translation Guide.

3. Open List of Files to be Translated You can quickly open a list of all files in the project that
need to be translated. For source files such as Flare projects—which contain many unique
types of files—this helps take the guessing out of localization work. All files requiring
translation are displayed in the File List window pane. See "Viewing Files Requiring
Translation" on page 31.

4. Open and Translate Files There are several types of files that you can open and translate.
Lingo's Translation Editor lets you work in Translation (or grid) mode, with the source content
in one column and the target language in the next column. For some types of files—such as
Flare topics, snippets, and template pages; Microsoft Excel, PowerPoint, and Word
documents; DITA files; HTML files; and XML files—you can also switch to Live Preview mode,
which lets you view content in its intended context. A suggestions area at the bottom of the
Translation Editor lets you quickly select and insert matching translations from your TM
database. See "Translating Files" on page 34.

5. (Optional) Use Machine Translation In addition to using previous translations from a TM,
you can also use MT to generate suggestions from a translation service like Google Cloud
Translation, Microsoft Translator, MyMemory, or DeepL. You can use these suggestions to
fill in gaps when pre-translating a project and you do not have a previous translation
available. You can also use the MT to provide suggestions for an entire project, and then
select translations that are appropriate and add them to your existing TM. For more
information see the online Help or the Lingo Translation Guide.
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6. (Optional) Run QA Reports Lingo offers several quality assurance (QA) reports to help you
spot discrepancies in a translated project. These reports can be useful because they can
help find errors that you might not have otherwise noticed, such as formatting inaccuracies,
repeated segments, or termbase errors. By running a QA report, you can locate errors and
correct them early in the translation process, preventing unnecessary rework later. You may
want to run these reports before returning the project to the content developer. For more
information see the online Help.

7. Export Translated Projects When all of the content in a project or file is translated, you can
export the work to the application, file, or location. For example, if a Flare project was
translated, you can export your work out to a new Flare project; if a Word document was
translated, you can export your work out to a new Word document. This translated project or
file can then be opened, and output can be created from it. See "Exporting Translated
Projects" on page 36.

NOTE If you have translated files for a Flare project, you also have the option of
placing your Lingo project where the Flare author can access it. The author can then
link directly to the Lingo project. This way, you do not need to export the Lingo
project back out to a new Flare project. However, in order to use this process, the
author must also have Lingo 11 installed on his or her computer in order to correctly
build the multilingual output.
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Translation Workflow Management—
Content Developers

Following are the basic steps that content developers would follow for using Lingo as a bridge
between their source files and a third-party CAT tool used by the translator. If instead you are a
translator and will be using Lingo to perform the translation work, see the steps listed before these.

1. Create Lingo Project (Author) The author creates a Lingo project based on the project or
files that require translation. See "Creating Projects" on page 15.

2. (Optional) Create/Import Translation Memory (Author) You can create a new translation
memory (TM) database for the project and import a Translation Memory eXchange (TMX) file
from the translator. Your translator's quote should take into account previous translations
from the TMX file (which makes translation work less expensive than translating brand new
segments). You can view statistics (Step 6 below) on the project to see how many
translations from the TMX file match segments in your source documents. For more
information see the online Help or the Lingo Translation Guide.

3. Prepare and Send Bundle (Author) In Lingo, the author bundles the necessary files in the
project. You can bundle all files or only selected files. To do this, open the File List window
pane, select the appropriate files, and click the Prepare Translation Bundle button . Then
send the bundle—which is either a ZIP file (if the translator will be using a third-party tool) or
an LIPRJZIP file (if the translator will be using Lingo). This bundle file consists of the content
files requiring translation, and can also consist of translation memory databases or
termbases.For more information see the online Help.

4. Translate Content, Send ZIP or LIPRJZIP File (Translator) Using a third-party tool or
Lingo, the translator performs the translation work, puts the completed files into a ZIP or
LIPRJZIP file, and sends it back to the author. For more information see the online Help.

NOTE Translators must return a bundle in the same file format as the original
bundle they received. If you sent the translator a Lingo project file (*.LIPRJZIP), you
should receive an LIPRJZIP file back from the translator. Likewise, if you sent the
translator a ZIP file, should receive a ZIP file back.

5. Merge Completed Bundle (Author) The author reintegrates the translator's work with the
Lingo project (by clicking the Merge Completed Bundle button in the File List window
pane). For more information see the online Help.
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6. Ensure Completeness (Author) There are a few ways that the author can ensure
completeness of the translations. For more information see the online Help.

n Statistics You can select File > Compute Statistics. This displays a statistics report
showing detailed information for the project and each file. Using this report, the content
developer can see exactly how many words and segments were translated.

n Reports In addition to running a statistics report, you can also run quality assurance
(QA) reports to find any discrepancies between the source and target segments in your
project. To do this, you can select File > Project QA, then select the type of QA report
you want to run. Using these reports, the content developer can find errors the
translator may have missed, such as formatting or punctuation inaccuracies, misuse of
the termbase, or repeated segments.

n Status The File List window pane lists each content file and various information for
each. One of the columns in this window pane is named "Status." This column displays
the translation status of each file (e.g., Untranslated, In Progress, Completed,
Reviewed, Approved). The translation status can be set manually, or when certain
actions are performed, the status is set automatically. After a translator returns a
bundle and you merge it back into a Lingo project, the status of each file is updated,
depending on the situation. If the translator only partially translates a file, the status
changes to "In Progress." If the translator finishes translating all segments in a file, the
status changes to "Completed." If the translator returns the file untouched, the status
remains "Untranslated."

n Review You can export translated content to a MadCap Contributor review archive file
(LIREV) and send it to a third party for review.

7. Export Translated Projects (Author) After ensuring that everything is completely translated,
the author exports the Lingo project to the necessary file(s) (e.g., a new Flare project, a new
Word document). See "Exporting Translated Projects" on page 36.
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Additional Help
You can use any of the following resources for additional help not provided in this manual.

Knowledge Base
You can browse the online Knowledge Base for articles covering common support issues.

http://kb.madcapsoftware.com/

Peer-to-Peer Online Forums
You can visit the online forums to learn from other users or share your own expertise.

http://forums.madcapsoftware.com/

Contact Lingo Support
You can contact the Lingo support team and get answers to your specific support issues.

http://madcapsoftware.com/support/
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CHAPTER 2

Starting a Lingo Project
The first step in translating a project after you launch Lingo is to start a project. You can create a
new project or open an existing one, as well as add files to a project.

This chapter discusses the following:

Creating Projects 15

Opening Projects 21

Adding Files to Projects 22
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Creating Projects
You can create a new Lingo translation project using the Start New Project Wizard. This wizard lets
you select from many different kinds of files (e.g., MadCap Flare projects, Doc-To-Help projects,
Microsoft Word documents, Adobe FrameMaker, Adobe InDesign, XML files, DITA files), as well
as specify one or more target languages. You can also add entire folders to a project and then
select the file types you want to translate.

How to Create a New Project
1. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select File > New Project.

n Keyboard Shortcut Press CTRL+SHIFT+N.

The Start New Project Wizard opens.

2. In the Name field, type an appropriate name for your project.

EXAMPLE

If you have an English version of a Flare project called "FictionSoftPro," and you
intend to translate the project into German, you might name your Lingo project
something like "FictionSoftPro German."

Or maybe you are translating that project into many languages. Therefore, you might
name the project "FictionSoftPro Translated."

3. By default, a path to the Documents\My Translated Projects folder on your hard drive is
entered in the Folder field. (Lingo creates the My Translated Projects folder when you install
the program.) All subfolders and files related to the translated project will be placed in this
folder as you work on the project.
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4. (Optional) In the Domain field, you can type a subject category for your project, or select one
from the drop-down. If you enter your own custom category in the Domain field, it will appear
in the drop-down the next time you create a new project. Domain metadata appears
throughout the project, such as when you select a suggestion in the translation memory.

EXAMPLE

If you have a project called "FictionSoftPro," and it is for a company that writes
software for publishing companies, you might choose to categorize your project
using the domain "Art/Literary" or "Tech/Engineering."
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Alternatively, you could create a new domain called "Fiction" by typing Fiction in
the Domain field. The next time you want to use that domain, you can select it from
the drop-down.
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5. (Optional) In the Client field, you can type the name of the client you are creating a
translation project for. When you enter a client name in the field, it will appear in the Client
drop-down the next time you create a new project. Client metadata appears throughout the
project, such as when you select a suggestion in the translation memory.

EXAMPLE

If you are creating a translation project for FictionSoft, the company that makes
"FictionSoftPro," enter FictionSoft in the Client field. The next time you create a
translation project for FictionSoft, you can select their client name from the Client
drop-down.
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6. In the Source Language drop-down, select the original language that is used in the project
you are translating. Make sure this language matches the source exactly. For example, you
might select English (en) here, but the source files are actually in the English United States
(en-us) language. Therefore, you should instead select English (United States) in this field.

7. In the Target Languages grid, select the language(s) that you want to use for the translation
and click to move it to the Selected Languages grid. If you need to remove a language

from the Selected Languages grid, click .

EXAMPLE

If your project needs to be translated into French, Italian, and Spanish, select these
three languages from the Target Languages grid, then click .

8. (Optional) If you want to bind the Lingo project to a source control provider, select Bind to
source control.
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9. Click Next.

10. (Optional) If you have selected the "Bind to Source Control" option, click Bind Project. Then
in the Bind Project dialog, complete the fields, depending on the source control application
being used. When you are finished, click Next. For more information about binding to source
control, see the online Help.

11. Click Add File or Add Folder to bring files or folders, respectively, into the new project.
Alternatively, click Add From Source Control to add files or folders to a project from source
control. If you select a folder, the files within it are added. For more information about adding
files and folders to a project, see the online Help.

12. Click Next.

13. (Optional) If you are creating a project using MadCap Flare or DITA source files, select
additional project settings. For more information about Flare and DITA project settings, see
the online Help.

14. Click Next.

15. (Optional) Available translation memory (TM) databases are listed in a grid, and you can
select the ones you want to use for the current project by clicking the Use check box next to
them. You can also add, create, or import TMs from this page of the wizard. For more
information about the TM tasks that you can perform while creating a project, see the online
Help.

16. Click Next.

17. (Optional) Available termbases are listed in a grid, and you can select the ones you want to
use for the current project by clicking the Use check box next to them. You can also add,
create, or import termbases from this page of the wizard. For more information about the
termbase tasks that you can perform while creating a project, see the online Help.

18. Click Finish.

When you create a new Lingo project, a file with an .liprj extension is automatically generated
(e.g., My Project Italian.liprj). This is the main file for the project and is stored at the root level of
the project folder in Windows (e.g., Documents\My Translated Projects\My Project Italian\My
Project Italian.liprj). You can open the project by double-clicking this file.

CHAPTER 2  20



Opening Projects
You can open an existing project by using interface options or dragging files from Windows
Explorer.

How to Open a Project Using Interface Options
Do one of the following, depending on the part of the user interface you are using:

n Start Page On the right side of the Start Page, click Open. You can also click a recently
opened project on the left side. If you do not see the Start Page, select View > Start Page.

n Ribbon Select File > Open.

n Keyboard Shortcut Press CTRL+O.

How to Open a Project by Dragging a File
1. Launch Lingo.

2. Open Windows and navigate to a folder containing a project (FLPRJ) file.

3. Drag the project file from Windows to the application window and drop it on the title bar in
Lingo.
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Adding Files to Projects
In many cases, you can add additional files to a project after the project has been created. This lets
you make changes to your Lingo project at any time without needing to create a new project. It also
prevents you from having to send multiple projects to a translator or a reviewer.

You can add files to any project created from other individual files, such as Word documents or
XML files. You can also add files to any project created from folders.

How to Add Project Files
1. In the local toolbar of the File List window pane, click . The Add Project Files Wizard

opens.

2. Click Add.

3. In the dialog that opens, select the file(s) you want to add to the Lingo project. Click Open.

4. (Optional) If you need to remove a file, select it in the wizard and click Remove.

5. (Optional) If you are adding Word, XML, or text files to your project, you can create a file type
filter to import only certain parts of the file. For more information see the online Help.

6. When you are done adding files, click Finish. The files are added to the project.

NOTE If you are translating a Flare project file, Mimic project file, Doc-To-Help project file,
or a DITA map, you cannot add individual files to the Lingo project after it has been
created.

NOTE Update Project is disabled if you created a project in either of the following ways: 

1. From individual folders and individual files

2. From individual folders, and later you added additional files using the Add Project
Files Wizard
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CHAPTER 3

Updating Projects
If changes were made to source files after you have started working in—or even completed—a Lingo
project, you need to update the project so that the modified files can be translated.
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How to Update a Project
1. Select File > Update Project.

2. Navigate to and select the project or file that has been changed. A processing dialog
temporarily displays as the changed files are integrated into the Lingo project. This dialog
closes automatically when it is finished.

3. (Optional) If you want to update the localized images in your Lingo project with the images
from the source, select Replace localized images for this project, and click OK.

NOTE You may want to replace the localized images if the images in the source
project have changed considerably. Localized images will only be replaced if the
source image is newer (i.e., more recently updated) than the localized image;
localized images that have not changed in the source project will not be replaced.

NOTE You will only be prompted to replace images if there are images in your Lingo
project.
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NOTE If the changed source file has segments that exactly match those in TM, the
segments automatically receive those translations. If there are changes where matches do
not occur in TM, those changes are reflected in the Lingo project in a couple of ways. First,
the Difference column in the File List window pane indicates whether a file has changed.
Also, if you switch to Preview mode in the Translation Editor (for files such as Word
documents, PowerPoint files, and Flare topics, which can be displayed in that mode),
icons are displayed next to segments that have been changed.

NOTE When you use this feature, Lingo only scans files that have been changed, instead
of all files in the project. This results in quicker updates.

NOTE Update Project is disabled if you created a project in either of the following ways: 

1. From individual folders and individual files

2. From individual folders, and later you added additional files using the Add Project
Files Wizard

NOTE If you make changes to a project's filtering or flattening settings in the Project
Properties dialog, you do not need to update the project to apply these settings. Instead,
the changes are applied dynamically.

NOTE If you translate a segment in Lingo and then update the source for that segment,
the source content may no longer match the translation provided by the TM or machine
translation. If this happens, the TM Source column displays "Xliff Alternate," to indicate
that a previous translation is stored in the XLIFF file.
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CHAPTER 4

Multilingual Projects
A multilingual project is a Lingo project that includes more than one target language. Lingo lets you
add as many languages as you like to your projects, and you can add or remove them at any time.
A great benefit to multilingual projects is that you can add all the languages you need to translate
to a single project. This makes it easier for a translator to translate content in multiple languages,
and it makes it easier for a content developer to send files for translation or review.

This chapter discusses the following:

How to Create a Multilingual Project 28

Where Can I Use Multilingual Features In Lingo? 30
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How to Create a Multilingual Project
When you create a new project in Lingo, you can select multiple target languages in the Start New
Project Wizard.

1. In the Source Language drop-down, select the original language that is used in the project
you are translating. Make sure this language matches the source exactly. For example, you
might select English (en) here, but the source files are actually in the English United States
(en-us) language. Therefore, you should instead select English United States in this field.

2. In the Target Languages grid, select the language(s) that you want to use for the translation
and click to move it to the Selected Languages grid. If you need to remove a language

from the Selected Languages grid, click .

Selecting a target language also accomplishes the following:

n Spell Check This affects the language that is used for spell checking. If you are
working with a multilingual project, the language of the file is used for spell checking.

n Find and Replace If you are working with a multilingual project, the active target
language in the Project Properties dialog (File > Project Properties) is used for find
and replace.
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EXAMPLE

If your project needs to be translated into French, Italian, and Spanish, select these
three languages from the Target Languages grid, then click .
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Where Can I Use Multilingual Features
In Lingo?

In addition to creating new projects using multiple languages, you can also find options to switch
between languages in the following areas in Lingo:

n Batch Image Replacement Localize images in your project by replacing the source images
with images specific to each language.

n Bundles Send files in a specific language or in all languages for translation.

n Compute Statistics Calculate statistics to see how many segments are translated for a
specific language, or for all languages.

n Export Finished Translation Export the final translation for any language to Flare or to a
ZIP file.

n File List Window Pane Click the drop-down in this window to select the active language for
multilingual projects.

n Font Mapping Locate fonts used in each file and replace them with fonts that are supported
for each target language.

n Index and Glossary Sort Orders Create a custom sort order for your index or glossary.

n Project Properties Dialog Add or remove languages in the project at any time, and set the
active language for the project. The active language determines the default language
settings for your projects, such as the current translation language.

n QA Reports Run quality assurance reports for files in a specific language, or run reports on
all files.

n Reviews Send files in a specific language or in all languages for review.

n Thesaurus The Thesaurus window pane displays on the right side of the interface and lets
you look up and use related words in an open file. At the bottom of the window pane, you can
switch between languages.

For more information about each of these features, please see the online Help.
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CHAPTER 5

Viewing Files Requiring
Translation
You can quickly open a list of all files in the project that need to be translated. For source files such
as Flare projects—which contain many unique types of files—this helps take the guessing out of
localization work. All files requiring translation are displayed in the File List window pane.

A filter feature in the File List window pane lets you list files by type (e.g., topics, snippets, images,
template pages, movies) when you are using the grid view. The All Files filter option shows all of
the translatable files in your project.
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How to View Files Requiring
Translation
1. By default, the File List window pane opens automatically on the left side of the interface

when you first launch Lingo. If it is not open, do one of the following, depending on the part of
the interface you are using:

n Ribbon Select View > File List.

n Keyboard Shortcut Press CTRL+R.

2. (Optional) By default files are displayed in a grid. If instead you want to view them in a folder
structure, click in the local toolbar. Clicking this button a second time switches you back
to grid view.

3. (Optional—if using the grid view) Next to the Filter field at the top of the window pane, you
can click the down arrow and select one of the options to limit the file types shown (e.g.,
snippets). If you are new to Lingo, you may want to select "All Files" to view all of the
translatable files in your project.

4. To open a file for translation, simply double-click it in the list.
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NOTE If you are working with a multilingual project, you can change the active target
language in the Project Properties dialog (File > Project Properties). This will change the
language of the files shown in the File List window pane.

The translation status displayed in the File List is shown for the active target language (for
example, a file might be translated in Spanish, untranslated in French, and already sent for
review in German).
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CHAPTER 6

Translating Files
Lingo's Translation Editor lets you work in Translation (or grid) mode, with the source content in
one column and the target language in the next column. For some types of files—such as Flare
topics, snippets, and template pages; Microsoft Excel, PowerPoint, and Word documents; DITA
files; HTML files; and XML files—you can also switch to Live Preview mode, which lets you view
content in its intended context. A suggestions area at the bottom of the Translation Editor lets you
quickly select and insert matching translations from your translation memory (TM) database.

Although you do not need to use TM when translating files, it is recommended that you do so.
Therefore, before following the steps below, make sure you have performed the necessary setup
tasks for TM. For more information see the online Help or the Lingo Translation Guide.
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How to Translate Files
1. (Optional) Before you start translating text, you may want to select Home > Translate

project with TM. This scans your translation memory to find 100% matches for untranslated
segments and applies those translations accordingly.

2. From the File List window pane, open the file you want to translate.

The file segments are shown in the Translation Editor. The source text is shown in the left
column. The right column, which is initially empty by default, is where you enter the
translation.

3. Click in a target cell (the right column) of a segment row. The cell may remain empty until you
type in it, or the cell may become immediately filled with a perfectly matching translation from
TM.

4. Do one of the following:

n Type your translation.

n If the TM Suggestions tab below shows a match for the segment that you want to use,
double-click it. The target cell becomes filled with that translation. You can keep the
translation as it is, or you can click in the cell and adjust it.

5. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Home > [one of the Confirm buttons].

n Keyboard Shortcut Press ENTER.

OR

Press CTRL+SHIFT+Down Arrow or CTRL+SHIFT+Up Arrow on your keyboard (to
move to the next or previous untranslated segment, respectively).

n Right-Click Right-click in the cell and from the context menu select Confirm.

The translation is confirmed and focus moves to the next appropriate cell. After a segment is
translated and confirmed, the Status cell becomes gray and a check mark is shown in it.
Also, if you are using TM, the translation is automatically uploaded to the database.

6. Click to save your work.

For more features available in the Translation Editor, and for additional information about
translating files, see the online Help or the Translation Guide PDF.
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CHAPTER 7

Exporting Translated Projects
When all of the content in a project or file is translated, you can export the work to the application,
file, or location. For example, if a Flare project was translated, you can export your work out to a
new Flare project; if a Word document was translated, you can export your work out to a new Word
document. This translated project or file can then be opened, and output can be created from it.

NOTE If you have translated files for a Flare project, you also have the option of placing
your Lingo project where the Flare author can access it. The author can then link directly to
the Lingo project. This way, you do not need to export the Lingo project back out to a new
Flare project. However, in order to use this process, the author must also have Lingo 11
installed on his or her computer in order to correctly build the multilingual output.
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How to Export a Translated Project
1. Select File > Export.

2. (Optional) If you are working with a multilingual project, from the Language drop-down,
select the language to include in the exported project, or select All Languages.

NOTE You will only see this option if you are working with a multilingual project.

NOTE You will not see this option if you are translating files in a multilingual bundle
and need to export the files to return them to the content developer. This is because
you must return all the files in the bundle, regardless of their language.

3. (Optional) If you are translating non-project files and want to apply a code (e.g., "es" for
Spanish) to the individual files you are exporting, select Append language code to files.
This setting is beneficial if you want to flatten the exported files so you can see them side by
side, instead of having all instances of the same file name without any language code
attached to those files.

NOTE If this option is not selected, the language code is used for the parent folder
name for each of the exported languages (e.g., if you are translating to Spanish, the
folder is named “es”). This option is not displayed if you are translating project files.

4. (Optional) In the Destination Filename field, you can keep the name or enter a different one
for the exported project.

5. (Optional) In the Destination Folder field, you can click Browse to find and select a different
location. Typically, you want to export the project to a location where the author can retrieve
it, unless you plan to deliver the file(s) to the author in some other way (e.g., email).

6. (Optional) If you want to create an additional ZIP file when exporting the project, select Make
a zip file after export. If you do not select the check box, the project files are still exported,
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but a ZIP file is not created. If you do select the check box, the project files are exported and
an extra ZIP file is produced.

NOTE When you create a ZIP file on export, the folder structure is maintained.

7. Click Export.

8. (Optional) If you have not translated all of the files in the project, a confirmation dialog asks if
you want to export the project with untranslated files. Click Continue to export the project, or
click Cancel.

9. (Optional) If the project has already been exported to the selected destination, a dialog
informs you that the destination already exists. Lingo will permanently overwrite any updated
files. Click OK to export updated and new files, or click Cancel.

10. When the export completes, a dialog opens. You can click Yes to view the new project, or
you can click No.

11. (Optional) In the Exporting dialog, click one or both of the following:

n Open Exported Project Opens the exported project in the appropriate program.

n Save Log Saves the export log to the project folder.

NOTE You can view saved export logs from the Project Properties dialog.

12. Click Close.
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CHAPTER 8

Other Lingo Features
Some of the other features that you are likely to use in Lingo include translation memory (TM),
machine translation (MT), termbases, a concordance, segmentation rules, dictionaries, source
control, and more.

This chapter discusses the following:

Translation Memory 40

Machine Translation 40

Termbases 40

Concordance 41

Segmentation Rules and Split/Join 41

Statistics Reports 41

Quality Assurance Reports 42

Reviews 42

Dictionaries 42

Thesaurus 43

Source Control 43

Command Line Exports and Updates 43
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Translation Memory
A TM system is a database that consists of content in a source language next to the translated
content in one or more target languages. The great benefit of a TM system is that it remembers
what you have already translated in previous projects and uses it to provide suggestions for future
translation work. You can connect your Lingo project to one or more TM databases.

For more information see the online Help or the Lingo Translation Guide. For links to this manual
and others, see the online Help.

Machine Translation
MT is translation of text by a computer or translation program, such as Google Cloud Translation.
A great benefit of MT is that it allows translators to translate a large amount of content quickly
using an automated translation system, and then make any necessary updates to the translation
on a case-by-case basis (e.g., using a termbase to replace certain words, fixing translations that
are not accurate in context). Then, the translator can add the target segments to an installed TM,
improving the speed for future translations as well.

For more information see the online Help or the Lingo Translation Guide. For links to this manual
and others, see the online Help.

Termbases
A termbase is a concept-oriented database that makes translation work easier and quicker by
letting you create, manage, and reuse multilingual terminology from a single storage area. This
system automatically displays previously translated words from your termbase during the
translation process, thus improving the reliability of translations.

For more information see the online Help or the Lingo Termbase Guide. For links to this manual
and others, see the online Help.
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Concordance
Lingo lets you use a concordance to perform advanced searches in one or more TM databases.
You can also search suggestions from MT providers. This means you can search for words you've
already translated to maintain consistency. The concordance searches the TM and suggestions
from MT; in contrast, the search filter in the Translation Editor looks only in the current file.

For more information see the online Help.

Segmentation Rules and Split/Join
If you want to control segment breaks automatically, you can create segmentation rules. Lingo
follows the format specified by Segmentation Rules eXchange (SRX). Therefore, after you create
segmentation rules, you can export them to an SRX file. You can also import SRX files that have
been generated in Lingo.

Similar to the alignment tool, you can split and join segments manually in the Translation Editor.
You might choose this manual process instead of segmentation rules when you need to quickly
split or join segments and do not anticipate the need to do so automatically in future translations.

For more information see the online Help.

Statistics Reports
You can compute statistics for your Lingo project, displaying information about the translation
work. This is a way to compare the project files against the translation memory database in order
to see how much translation work has been completed and how much still needs to be done. This
report can be useful if you are a translator and need to provide estimates to a client, or if you are a
content developer who is using Lingo to manage the translation process.

For more information see the online Help.
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Quality Assurance Reports
You can run quality assurance (QA) reports to review your translated projects for discrepancies
between the source and target segments. This is a way to check the quality of your translations
before sending your project for review, returning a translation to a client, or exporting the final,
translated project. These reports can be useful because they can help find errors that you might
not have otherwise noticed, such as formatting inaccuracies, repeated segments, or termbase
errors. By running a QA report, you can locate errors and correct them early in the translation
process, preventing unnecessary rework later.

For more information see the online Help.

Reviews
You can send translated content to individuals for review. For example, you might use this feature
if you are an author who has received files back from a translator and you want to send them to a
third party (who does not have access to Lingo) to ensure the translations are correct. When you
use this feature, you can export translations as a MadCap Contributor review package.

Before you send a Contributor review package to a reviewer, be sure the reviewer has the latest
version of Contributor installed. Reviewers do not need to purchase a license to use Contributor
review Lingo files; instead, they can use Contributor's free review mode to review Lingo files.

For more information see the online Help.

Dictionaries
You can see which dictionaries are installed on your computer by opening the Options dialog and
selecting the Spelling tab. You can also use the Options dialog to import more dictionaries that you
have downloaded.

In addition to all of the built-in dictionaries that are installed on your computer and dictionaries that
you have downloaded, you can also use custom global or project dictionaries.

For more information see the online Help.
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Thesaurus
The Thesaurus window pane displays on the right side of the interface and lets you look up and
use related words in an open file.

For more information see the online Help.

Source Control
Lingo provides integrated support for version control applications. Built-in support is available for
Microsoft Team Foundation Server, Perforce Helix Core, Git, and Apache Subversion.
Additionally, because Lingo uses a wide open architecture and stores files as independent XML
files (such as XLF), you can manually manage your files in an external source control system.

For more information see the online Help or the Lingo Source Control Guides. For links to these
manuals and others, see the online Help.

Command Line Exports and Updates
You can use a command line prompt to manage your projects. This lets you use automated
processes (such as the Task Scheduler utility in Windows) to schedule exports or updates.
Depending on the command(s) used, you can accomplish any of the following.

n Export a Lingo project

n Update/sync a Lingo project with the source file

n Export a Lingo project in a specific language

For more information see the online Help.
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APPENDIX

PDFs
The following PDFs are available for download from the online Help.

Cheat Sheets
Shortcuts Cheat Sheet

User Guides
Alignment Guide

Getting Started Guide

Key Features Guide

Source Control Guide: Git

Source Control Guide: Perforce Helix Core

Source Control Guide: Subversion

Source Control Guide: Team Foundation Server

Termbases Guide
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Touring the Workspace Guide

Translation Guide

What's New Guide
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