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CHAPTER 1

Introduction
After you create a movie, you will likely want to make modifications before it is considered finished.
This can mean anything from adjusting movie frames and objects (e.g., buttons, cursors) to adding
audio or slide transitions. Following are some of the many ways that you can modify a movie.
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CHAPTER 2

Frames
A frame is one piece of an overall movie that usually contains a background image, or at least a
background color. Each movie can contain many frames, and each frame of a movie can contain
multiple objects and actions, as well as timing and transitions.

This chapter discusses the following:

Opening Frames 11

Recording New Frames 12

Capturing New Frames 24

Copying Frames 32

Copying Frame Backgrounds 33

Inserting Blank Frames 34

Inserting Duplicate Frames Into a Movie 35

Inserting PowerPoint Slides Into a Movie 36

Moving Frames in a Movie 39

Pausing Frames 40

Removing Images From Frames 42

Removing Frames From a Movie 43

Setting Backgrounds for Frames 44

Frame Libraries 53

Master Frames 57
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Opening Frames
After you create a movie, the frames that form the movie are listed in order in the Frames window
pane. The first frame of the movie is displayed in the Frame Editor, which you can use to add
objects and effects to the frame. You can navigate through the other frames and select them. When
you select a frame, it opens in the Frame Editor.

How to Open Frames
1. Open the movie.

2. Use one of the following methods to move through the movie and open frames.

n Ribbon Select the Frame ribbon, then select one of the following:

l Previous Button Click the face of the Previous button or click the down arrow and
select Previous to open the previous frame. Click the down arrow and select First to
open the first frame of the movie.

l Next Button Click the face of the Next button or click the down arrow and select
Next to open the next frame. Click the down arrow and select Last to open the last
frame of the movie.

n Frames Window Pane Use the scroll bar to move up or down in the frame sequence.
Click a frame when you want to open it in the Frame Editor.
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Recording New Frames
After you create a movie, you might find the need to add more frames to it. One method that you
can use to add frames is to record additional frames, inserting them at any place inside the movie.

How to Record New Frames
1. Prepare your screen or workspace for recording the new frames. This includes opening the

application window(s) that you want to record and/or arranging your desktop exactly as
needed.

2. Open the movie and select View > Frames.

3. In the Frames window pane, select an existing frame. The new recorded frames will be
inserted immediately after that frame.

4. Select Frame > Recording. Mimic minimizes and a rectangle with a red border appears on
your screen, along with a task bar.
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5. (Optional) Rearrange the recording area. You can use several methods and features to do
this.

DRAG EDGE

You can resize the recording area manually by clicking any of the handles (small squares)
around the edge of the rectangle and dragging them to resize the width and/or height.

CHAPTER 2  13



MOVE ENTIRE RECORDING AREA

You can move the entire recording area by clicking the size-all icon in the center of the area
and dragging the area to a new location on your screen.
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TYPE WIDTH OR HEIGHT

You can click in the number fields in the task bar to manually change the width and/or height
of the recording window in pixels.
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MAINTAIN ASPECT RATIO

You can click the chain button in the task bar to maintain the aspect ratio when you change
the width or height of the recording area.

When this feature is disabled, the button displays as an broken chain image. If you then
change one dimension of the capture window, the other dimension will not be resized
automatically. For example, if you drag the window border to the left (to increase the width),
the height will remain the same size.

When this feature is enabled, the button displays as a chain image. If you then change one
dimension of the recording window, the other side will be resized automatically. For example,
if you drag the window border to the left (to increase the width), the height will be resized
accordingly.
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CHOOSE PRE-SET SIZE

You can click the drop-down in the task bar and choose one of the pre-set window sizes.
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SNAP/MOVE INTO RECTANGLE

If you have a particular application or window open, and you want to capture it, you can
choose an option to snap the recording window around that element, or you can choose to
move the element into your recording window. When you use one of these options, the Select
Window dialog opens. You can then choose any of the applications or windows that you have
open.

NOTE If you are using a newer operating system, you may need to enable window-
based recording optimization. For more information, see the online Help.
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NOTE Be aware that new frames will still be created in the same size as the existing
frames in the movie. Therefore, if you make the recording rectangle larger or smaller,
the resulting images in the frames will be stretched or shrunk to compensate for the
size change.

6. (Optional) Click on the task bar to specify the settings in the Recording Options dialog.

Select the appropriate options, as described below. When you are finished, click OK.

n Recording Mode You can select a specific recording mode to determine what happens
when you record the movie.

l Automatic Select this if you want Mimic to automatically capture images as you
perform actions in the recording area. If you perform a dragging action in this
recording mode, a single full-motion video (FMV) frame is created at that spot in the
movie to capture that action.

FMV may also used whenever you perform a typing action, depending on whether
you select the Add typing box shapes (see below).
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NOTE The automatic recording mode may not capture all of the changes
happening on your screen. You can press the PRINT SCREEN key on your
keyboard to manually create additional frames while recording.

l Manual Select this if you do not want Mimic to automatically capture the images.
Instead, you must press the PRINT SCREEN key on your keyboard whenever you
want a new image to be captured during a recording session.

l Video Select this if you want to record FMV in a single frame. For example, you
might use this option if you have an actual video running on your desktop and you
want to capture its action.

n Audio Input Source You can select an audio input source and record narration while
creating a movie. This lets you create audio that is perfectly in sync with a movie, rather
than adding sound to the movie afterward. Mimic automatically includes in the drop-
down the audio input sources that are available on your computer. Depending on the
type of input source, you may need to attach a microphone to your computer. Then, as
you record a movie, you can speak into the computer or microphone and this audio is
automatically added to the movie frames.

NOTE If you are recording a new movie, one audio file will be created for the
entire movie. If you are recording new frames for an existing movie, one audio
file will be created for just those frames.

n Show magnifier when selecting record region When you record a region, a large square
displays on your screen, showing a close-up of the area where your cursor is located.
This helps you to more accurately select a specific area of the screen to record. You
can deselect this option if you do not want to see the magnifier.

n Play sound effects When you record a movie, sounds are made when you perform
actions (e.g., clicking). If necessary, you can disable or re-enable the sounds for movie
recordings by clicking this check box.
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n Add callouts When you record a movie, bubble callouts are automatically added to
areas where you click. You can use these callouts in your movie to provide information
or instructions at each location where you clicked. However, by clicking this check box,
you can exclude the automatic addition of these callouts from movie recordings.

n Record cursor movements When you record a movie, Mimic automatically captures
your mouse movements. In your movie frames, this is reflected by the addition of a
cursor with a keyframe to show its path. The cursor object is indicated by a Cursor row
in the Timeline's Frame View. The movement of the cursor is indicated by a Position
row directly beneath the Cursor row. When the movie is generated and played, the
cursor moves just as you moved it when creating the movie. However, by clicking this
check box, you can exclude the automatic addition of these cursor movements from
movie recordings.

n Add typing box shapes If you select this option, Mimic inserts a typing box object when
you type during a recording session. If you disable this option and type during a
recording session, the frame in question becomes an FMV frame.

n Optimize record region If you are using a newer operating system (e.g., Microsoft
Windows 10 or higher), you may find that windows are cut off when using the "Snap to
Window" or "Move Window into Rectangle" recording options. This can be remedied the
Optimize record region feature. This feature is only recommended if you are using a
newer operating system. Enabling this feature while using an earlier operating system
may cause issues when recording..

n Callout Style: Pick Style This opens the Select Shape Style dialog, where you can
choose the style for bubble callouts if they are automatically added when you record a
movie. You can select a factory style or select a style from any of your palettes.

n Cursor Style: Pick Style This opens the Select Shape Style dialog, where you can choose
the style for cursor shapes if they are automatically added when you record a movie.
You can select a factory style or select a style from any of your palettes.
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7. Click the red record button on the task bar.

You will see a countdown—3, 2, 1—before the recording session begins.

8. After the countdown finishes, perform the actions that you want to record.

CHAPTER 2  22



9. You can use the task bar or the keyboard shortcuts to end, pause, or cancel the recording.

TASK BAR

The task bar is located below the recording area.

KEYBOARD SHORTCUTS

Here are the keyboard shortcuts available.

n END Start/stop

n SHIFT+END Abort

n PAUSE Stop

n SHIFT+PAUSE Pause

n PRINT SCREEN New frame

n SHIFT+PRINT SCREEN Start/stop video recording

After you stop the recording session, the new frames are added to the movie.

10. Click to save your work.
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Capturing New Frames
After you create a movie, you might need to add more frames to it. One method that you can use to
add frames is to capture an image of any area on your screen. A frame is then created based on
that captured image.

How to Capture a New Frame
1. Prepare your screen or workspace for capturing. This includes opening the application

window(s) that you want to capture and/or arranging your desktop exactly as needed.

2. Open the movie.

3. Do one of the following:

n RibbonSelect View > Frames.

n Keyboard Shortcut Press CTRL+J on the keyboard.

The Frames window pane opens.

4. In the Frames window pane, select an existing frame. The new captured frame will be
inserted immediately after that frame.

5. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Frame > Screenshot.

n Right-Click In the Frames window pane, right-click on an existing frame and from the
context menu, select Capture New Frame.

Mimic minimizes and a rectangle with a red border appears on your screen, along with a task
bar.
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6. (Optional) Rearrange the capture area. You can use several methods and features to do this.

DRAG EDGE

You can resize the capture area manually by clicking any of the handles (small squares)
around the edge of the rectangle and dragging them to resize the width and/or height.
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MOVE ENTIRE CAPTURE AREA

You can move the entire capture area by clicking the size-all icon in the center of the area
and dragging the area to a new location on your screen.
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TYPE WIDTH OR HEIGHT

You can click in the number fields in the task bar to manually change the width and/or height
of the capture window in pixels.
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MAINTAIN ASPECT RATIO

You can click the chain button in the task bar to maintain the aspect ratio when you change
the width or height of the capture area.

When this feature is disabled, the button displays as an broken chain image. If you then
change one dimension of the capture window, the other dimension will not be resized
automatically. For example, if you drag the window border to the left (to increase the width),
the height will remain the same size.

When this feature is enabled, the button displays as a chain image. If you then change one
dimension of the capture window, the other side will be resized automatically. For example, if
you drag the window border to the left (to increase the width), the height will be resized
accordingly.
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CHOOSE PRE-SET SIZE

You can click the drop-down in the task bar and choose one of the pre-set window sizes.
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SNAP/MOVE INTO RECTANGLE

If you have a particular application or window open, and you want to capture it, you can
choose an option to snap the capture window around that element, or you can choose to
move the element into your capture window. When you use one of these options, the Select
Window dialog opens. You can then choose any of the applications or windows that you have
open.

NOTE If you are using a newer operating system, you may need to enable window-
based recording optimization. For more information, see the online Help.
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NOTE Be aware that new frames will still be created in the same size as the existing
frames in the movie. Therefore, if you make the capture rectangle larger or smaller,
the resulting images in the frames will be stretched or shrunk to compensate for the
size change.

7. Click the red button on the task bar. The image inside the rectangle is captured and the new
frame is added to the movie.

8. Click to save your work.
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Copying Frames
You can make a copy of a frame and paste the copy anywhere in the movie sequence. The copy is
pasted after the frame that you select. When you copy a frame, all of the objects and effects in that
frame are also copied.

How to Copy a Frame
1. In the Frames window pane, select the frame that you want to copy.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Frame > Copy.

n Right-Click In the Frames window pane, right-click the frame you want to copy and from
the context menu, select Copy Frame.

n Keyboard Shortcut Select the frame you want to copy and press CTRL+C.

3. In the Frames window pane, select the frame below which you want to place the copy.

4. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Frame > Paste.

n Right-Click In the Frames window pane, right-click the frame you want to copy and from
the context menu, select Paste Frame.

n Keyboard Shortcut Select the frame you want to copy and press CTRL+V on the
keyboard.

The copied frame is added after the selected frame.

5. Click to save your work.
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Copying Frame Backgrounds
You can copy the background image in one frame and paste it into another frame, replacing that
background image. When you copy a frame background, only the image is copied. No objects or
effects in the source frame are copied.

How to Copy a Frame Background
1. In the Frames window pane, select the frame whose background you want to copy.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Frame > Copy Background.

n Right-Click Right-click the frame and from the context menu, select Copy Frame
Background.

3. In the Frames window pane, select the frame whose background image you want to replace.

4. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Frame > Paste Background.

n Right-Click Right-click the frame and from the context menu, select Paste Frame
Background.

5. Click to save your work.
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Inserting Blank Frames
You can insert a blank frame after the selected frame. You can then add a background image or
color, as well as objects to that frame.

How to Insert a Blank Frame
1. In the Frames window pane, select the frame that will precede the blank frame.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Frame > Blank.

n Local Toolbar Click .

The new blank frame is added below the current frame.

3. Click to save your work.

CHAPTER 2  34



Inserting Duplicate Frames Into a
Movie

You can insert a new frame into a movie. When you do this, the new frame is added immediately
after the selected frame. If you use this feature, you are essentially creating a link to the image of
the frame in front of it. This means that the image for the new frame will automatically be updated
if the image of the frame in front of it changes. If you move the new frame to a different location, its
image will be updated according to whatever frame now precedes it.

How to Insert a Frame Into a Movie
1. In the Frames window pane, select the frame that will precede the new frame.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Frame > Duplicate.

n Local Toolbar Click .

n Right-Click In the Frames window pane, right-click the frame and from the context
menu, select Frame.

The new frame is added after the selected frame

3. Click to save your work.

CHAPTER 2  35



Inserting PowerPoint Slides Into a
Movie

You can insert slides from a Microsoft PowerPoint presentation into an existing movie. When you
do this, the new frames are added immediately after the selected frame.

How PowerPoint Slides are Handled When
Imported Into Mimic
The following chart describes how certain PowerPoint features are handled when you import slides
into Mimic.

Feature Imported?

Background Images Yes

Images Yes

Master Layout Slides Yes (converted to master frames)

Objects Yes

Shape Groups No

Smart Shapes No

Text Boxes Yes
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How to Insert PowerPoint Slides Into a Movie
1. In the Frames window pane, select a frame where you want the new frames to be inserted

(after the selected frame).

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Choose one of the following:

l Select Frame > PowerPoint.

l Select File > New. In the New dialog, click Import PowerPoint.

n Local Toolbar In the local toolbar of the Collection Editor, click

n Right-Click In the Frames window pane, right-click a frame and from the context menu,
select PowerPoint Slide(s).

The Import PowerPoint Wizard opens.

3. At the end of the PowerPoint File field, click .

4. In the Open dialog, locate and double-click the Microsoft PowerPoint (PPT file) that you want
to import.

5. (Optional) If you have objects such as text boxes or images in your PowerPoint slides, the
default action is to import them into Mimic frames as objects; you can then edit these objects
as you like. However, if you want to flatten all of those objects into each frame when they are
imported, click Import Slides as Background Images.

You might want to keep this option deselected if you want to do lots of editing in the Mimic
movie and need to be able to adjust the objects as needed. On the other hand, you might
select the option if you are content to edit all of your objects beforehand in PowerPoint. When
you import the slides as background images, you will usually end up with a higher quality
image and the objects and text will appear just as they do in PowerPoint, but you won't be
able to edit them further in Mimic.

6. Click Next.
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7. On the next page of the wizard, each slide from the PowerPoint presentation is shown. This
gives you a chance to include or exclude specific slides in the import. By default all slides
have a check mark next to them. To exclude a slide from the import, click the check box next
to it in order to remove the check mark.

You can use "Select All" or "Deselect All" to quickly add or remove check marks for all slides.
In addition, the "Show Images" check box lets you see a visual representation of each slide.

8. Click Import. The new frames are added after the selected frame.

9. Click to save your work.

What’s Noteworthy?
TIP When you import PowerPoint slides, they will be converted to the same size as the
existing frames in the Mimic movie. Therefore, in order to prevent odd results, it is
recommended that you import slides that are the same size as the frames in the movie.
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Moving Frames in a Movie
After you create a movie, you can move frames up or down in the Frames window pane to change
their order in the movie sequence.

How to Move Frames in a Movie
1. Open the movie.

2. Do one of the following:

n Arrow Buttons In the Frames window pane, select the frame that you want to move. In
the local toolbar of the Frames window pane click or to move the frame up or
down in the order.

n Drag and Drop Click on a frame that you want to move, then drag and drop it to its new
location.

3. Click to save your work.
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Pausing Frames
Unless you specify otherwise, a movie will play from the beginning to the end without interruption in
the output.

How to Pause the Action in a Frame
You can add an object (e.g., button) to a frame and apply a "pause" action to it. If the user does not
click the object in the output, the movie continues to play without interruption. If the user clicks the
object, the movie pauses until the object is clicked again.

1. Open the movie.

2. Open the frame.

3. Add the object (e.g., button, shape) that you want to use to pause the action.

4. Double-click the object. The Object Properties window pane opens.

5. Expand the Action section.

6. Select Pause.

7. Click to save your work.

How to Pause the Display Time for a Single
Frame in a Movie
You can disable (i.e., pause) the timing in one frame. This is useful if you add a button to a frame
and want the user to click the button before the movie continues.

1. Open the movie.

2. Open the frame.

3. In the Frame Editor, double-click the frame. The Frame Properties window pane opens.

4. Expand the Frame Transition tab.

5. Select Pause movie at end of frame.
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6. Click to save your work.

Now you can add an object to the frame and apply an action to it (e.g., go to next frame) so
that the user has a way to continue the movie. See "Selecting Actions for Objects" on page
109.

How to Pause the Display Time for All Frames in
a Movie
You can disable (i.e., pause) the timing in all frames in a movie.

1. Open the movie.

2. Select Movie > Properties.

The Movie Properties dialog opens.

3. Select the Transition tab.

4. Select Pause movie at end of frame.

5. Click OK.

6. Click to save your work.

Now you can add objects to any frames in the movie and apply actions to them (e.g., go to
next frame) so that the user has a way to continue the movie. See "Selecting Actions for
Objects" on page 109.
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Removing Images From Frames
You can remove the background image from a movie frame.

How to Remove an Image From a Frame
1. Open the frame.

2. In the Frame Editor, double-click the frame. The Frame Properties window pane opens.

3. Expand the Frame Appearance section.

4. In the Image file field, click Clear.

5. Click to save your work.
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Removing Frames From a Movie
You can easily remove a frame from a movie if you no longer need it.

How to Remove a Frame
1. In the Frames window pane, select the frame that you want to remove.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Frame > Remove.

n Keyboard Shortcut Press the DELETE key.

n Local Toolbar Click .

n Right-Click Right-click the frame and from the context menu, select Remove Frame.

3. Click to save your work.
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Setting Backgrounds for Frames
When you create a movie, it consists of one or more frames. A frame can be blank, display a
background color or gradient, or it can have an image assigned to its background.

How to Set the Background Color for a Frame
You may find it necessary or useful to select a specific color for a frame's background.

EXAMPLE

Let's say you have inserted a blank frame into a movie. If you do not then add a background
image or objects to cover all of the frame, the background is exposed in the default color
(which you may not like). Therefore, you can set the background color as necessary.

1. Double-click the frame. The Frame Properties window pane opens.

2. Expand the Frame Appearance section.

3. Use the Background section to set the color properties.

n Type Select either "Solid" or one of the directional patterns (e.g., Top to Bottom, Left to
Right) if you want to create a gradient background that progresses in a certain direction
from one color to another.

n Color/Gradient Click the down arrow to select a color for the background color. If you
selected a gradient background, you can select two colors, so the frame background
will transition the first color to the second color.
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How to Set a Frame Image by Picking a File
When you record a movie, images are automatically added to each frame, based on your actions
during the recording. If necessary, you can manually set the image, whether you are replacing an
existing image or assigning a new one to a blank frame. When you set an image, it is either
stretched or shrunk (if necessary) to fit the size of the frame.

You can select any image that has a supported file type (PNG, BMP, JPG, JPEG, TIF, TIFF, GIF).

1. Double-click the frame. The Frame Properties window pane opens.

2. Expand the Frame Appearance section.

3. In the Background section, click Image File.

4. In the Open dialog, locate and double-click the image file.

5. Click to save your work.

How to Set a Frame Image by Capturing One
Mimic lets you capture an area on your screen and produce an image as a result.

1. Open the window(s) with regions that you want to capture and/or arrange your desktop
exactly as needed. When you initiate a region capture, the Mimic application will be
minimized, allowing you to capture a region for whatever is directly behind it.

2. In Mimic, open the frame.

3. Double-click the frame. The Frame Properties window pane opens.

4. Expand the Frame Appearance section.

5. In the Background section, click Screen Capture. Mimic minimizes and a rectangle with a red
border appears on your screen, along with a task bar.
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6. (Optional) Rearrange the capture area. You can use several methods and features to do this.

DRAG EDGE

You can resize the capture area manually by clicking any of the handles (small squares)
around the edge of the rectangle and dragging them to resize the width and/or height.
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MOVE ENTIRE CAPTURE AREA

You can move the entire capture area by clicking the size-all icon in the center of the area
and dragging the area to a new location on your screen.
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TYPE WIDTH OR HEIGHT

You can click in the number fields in the task bar to manually change the width and/or height
of the capture window in pixels.
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MAINTAIN ASPECT RATIO

You can click the chain button in the task bar to maintain the aspect ratio when you change
the width or height of the capture area.

When this feature is disabled, the button displays as an broken chain image. If you then
change one dimension of the capture window, the other dimension will not be resized
automatically. For example, if you drag the window border to the left (to increase the width),
the height will remain the same size.

When this feature is enabled, the button displays as a chain image. If you then change one
dimension of the capture window, the other side will be resized automatically. For example, if
you drag the window border to the left (to increase the width), the height will be resized
accordingly.
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CHOOSE PRE-SET SIZE

You can click the drop-down in the task bar and choose one of the pre-set window sizes.
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SNAP/MOVE INTO RECTANGLE

If you have a particular application or window open, and you want to capture it, you can
choose an option to snap the capture window around that element, or you can choose to
move the element into your capture window. When you use one of these options, the Select
Window dialog opens. You can then choose any of the applications or windows that you have
open.

NOTE If you are using a newer operating system, you may need to enable window-
based recording optimization. For more information, see the online Help.

7. Click the red button on the task bar. The image is added to the frame.

8. Click to save your work.
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How to Set a Frame Image by Using the One
From the Previous Frame
This option removes the current image and replaces it with the image from the previous frame. For
example, if you are setting the properties for frame #12 in the movie and click this check box, the
background image will be removed and replaced with the one from frame #11.

When you use this option, both frames use the same image (rather than each frame having its own
copy of the image). The current frame simply points to the image that is used for the previous
frame.

1. Double-click the frame. The Frame Properties window pane opens.

2. Expand the Image section.

3. Click Use same background image as previous frame.

4. Click to save your work.
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Frame Libraries
A frame library lets you store often-used frames so that you can quickly insert them into movies
later.

Creating Frame Libraries
You can use the initial frame library provided by Mimic, but you can create additional frame libraries
if necessary.

How to Create a Frame Library
1. Select View > Frame Libraries.

2. In the local toolbar of the Frame Libraries window pane, click . The New Library dialog
opens.

3. Enter a name for the new library.

4. Click OK. The new empty library opens (by default on the left side of the user interface).

5. Click to save your work.
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Opening Frame Libraries
When you want to work with a frame library, you can open it in the Frame Libraries window pane.

How to Open a Frame Library
1. Select View > Frame Libraries.

2. In the local toolbar of the Frame Libraries window pane, click the drop-down containing the
name of the current frame library .

3. From the list, select the frame library that you want to open. The frame library opens,
displaying the frames contained within it.

Adding Frames to a Library
After you create frames that you want to use in movies in the future, you can add those frames to a
library.

How to Add a Frame to a Library
1. Open a frame library.

2. Open a frame that you want to add to the library.

3. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Frame > Add to Library.

n Right-Click Right-click on the frame and select Add to Library.

The frame displays in the Frame Libraries window pane.
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Using Frames From a Library
When you are working with a movie and want to add a frame that is stored in a library, you can do
so from the Frame Libraries window pane.

How to Use a Frame From a Library
1. Open a movie.

2. Open a frame library.

3. Do one of the following:

n Local Toolbar In the Frame Libraries window pane, click on a frame that you want to
add. In the local toolbar, click .

n Right-Click Right-click on the frame and select Add Frame to Movie.

The frame is added as the last frame of the movie. If you want to move the frame, open the
Frames window pane and drag the frame to the desired position.

4. Click to save your work.
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Adding Frames From a Library to a Master
Frame
When you are working with a movie and want to add a frame that is stored in a library, you can do
so from the Frame Libraries window pane.

How to Add a Frame to a Master Frame
1. Open a movie.

2. Open a frame library.

3. Do one of the following:

n Local Toolbar In the Frame Libraries window pane, click on a frame that you want to
add to the master frame. In the local toolbar, click .

n Right-Click Right-click on the frame and select Add Frame to Master Frame.

The frame is added to the Master Frames window pane and it opens in the Master Frame
Editor, which is nearly identical to the regular Frame Editor, except that it has a blue
background. You can use this editor to make any changes to the master frame.

4. Click to save your work.
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Master Frames
Master frames let you easily and quickly apply certain elements (e.g., buttons, image objects) to
many frames at once. In addition, if you need to make a change to any of those elements, you only
need to do so in the master frame; as a result, all frames using that master frame will automatically
display the changes.

NOTE You can show or hide different master frame objects in the active frame.

Creating Master Frames
The first step to using master frames is to create your frames and then add them to the Master
Frames window pane.

How to Create a Master Frame
1. Create a frame the way you normally would.

2. Arrange the frame just the way you want it.

3. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Frame > Add to Master Frames.

n Right-Click Right-click the frame. From the context menu, select Add Frame to Master
Frames.

The frame is added to the Master Frames window pane and it opens in the Master Frame
Editor, which is nearly identical to the regular Frame Editor, except that it has a blue
background. You can use this editor to make any changes to the master frame.

4. Click to save your work.
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Applying Master Frames
When you want to use a master frame in a movie, you can apply it—either to individual frames or to
an entire movie.

How to Apply a Master Frame to an Individual Frame
1. Open the movie frame.

2. Do one of the following:

n Right-Click Select Pick Master Frames.

n Double-Click Double-click on the frame.

n Ribbon Select Frame > Properties.

The Frame Properties window pane opens. Expand the Master Frames section.

3. Select the appropriate master frame from the Top Layer or Bottom Layer field.

If you use the bottom layer, all other objects on the regular frame (e.g., buttons, cursors,
shapes) will appear "in front" of the objects from the master frame (if they overlap). If you use
the top layer, all other objects on the regular frame will appear "behind" the objects from the
master frame.

4. Click OK. The objects from the master frame are now shown on that frame.

5. Click to save your work.

How to Apply a Master Frame to an Entire Movie
1. Open the movie.

2. Select Movie > Properties.

3. Click the Master Frames tab.

4. Select the appropriate master frame from the Top Layer or Bottom Layer field.
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If you use the bottom layer, all other objects on the regular frames (e.g., buttons, cursors,
shapes) will appear "in front" of the objects from the master frame (if they overlap). If you use
the top layer, all other objects on the regular frames will appear "behind" the objects from the
master frame.

5. Click OK. The objects from the master frame are now shown on all frames on the movie.

6. Click to save your work.

Editing Master Frames
After creating a master frame, you can make changes to it (e.g., background, border, image,
conditions). Your changes will automatically be reflected in any regular frame to which the master
frame has been applied.

How to Edit a Master Frame
1. Select View > Master Frames.

2. Click on any of the frames in the window pane. The frame opens in the Master Frame Editor,
which has a blue background.

3. Make any changes to the frame, just as you would to a regular frame.

4. Click to save your work.
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CHAPTER 3

Objects
An object is an element that you can add in a frame to enhance or explain areas of the frame (e.g.,
callouts), or to incorporate actions into the frame (e.g., buttons, cursor trajectories). Objects can be
elements such as shapes, lines, cursors, buttons, or even other images. Each object is stored on its
own layer in the frame. This enables you to overlap objects and edit them individually.

This chapter discusses the following:

Adding Audio as Objects 62

Adding Callouts Manually 65

Adding Cursors Manually 69

Adding Graphics to Frames 80

Adding Images as Objects 82

Interactive Objects 85

Adding Shapes to Frames 93

Adding Lines 95

Converting an Object 98

Inserting Captured Regions as Objects 99

Inserting Captured UI Elements as Objects 106
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NOTE A very useful tool when working with objects is a palette, which lets you store
objects for future use. For example, if you are including callouts with some frames,
chances are that you'll want to use the same look and feel for all of the callouts you create.
Instead of creating new callouts from scratch each time or copying them from other
frames, you can create an initial model callout and then add it to a palette. Then, when
you're ready to use a callout in another frame, you can just drag your model callout from
the palette to the frame (and make minor changes, such as the text, from there). See
"Palettes" on page 280.

NOTE You can convert any object into an action object. Right-click on the object and select
Advanced > Convert to Action Object. If you want to convert an action object into a regular
object, right-click on the action object and select Advanced > Convert to Timeline Object.

CHAPTER 3  61



Adding Audio as Objects
In addition to the ability to add audio to cursors, you can also add sounds as objects themselves.
As with any other type of object, you can add as many audio objects as you want to a movie frame,
and you can adjust the timing of each audio object in the Timeline window pane's Frame View
option. The Timeline window pane is also the best way to determine if a frame contains an audio
object, since there is no visual indication of this in the frame itself.

How to Add Audio as an Object
1. Open the frame.

2. Select Home > Insert Sound.

The Add Sound to Frame dialog opens.

3. Do any of the following:

TO SELECT EXISTING MP3 OR WAV FILE FROM SOUND LIBRARY

a. If you have already imported or recorded an audio file, click the drop-down on the left
side of the dialog and select Sound Library.

b. In the field below, select an audio file.

TO SELECT SYSTEM SOUND

a. Click the drop-down on the left side of the dialog and select System Sounds.

b. In the field below, select an audio file.

TO IMPORT MP3 OR WAV FILE INTO SOUND LIBRARY

a. Click Import new sound.

b. In the dialog that opens, find and double-click the audio file.
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TO RECORD NEW MP3 FILE

a. Ensure that a recording device is connected to your computer.

b. Click .

c. When you are finished recording, click .

d. (Optional) In the dialog that opens, you can type a new name for the sound.

e. Click OK.

4. (Optional) Click to listen to the file you selected in the Add Sound to Frame dialog.
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5. Click OK. The sound is added to the frame as an object, as indicated by the Sound bar in the
Timeline's Frame View option.

6. Click to save your work.
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Adding Callouts Manually
A callout is a shape that calls attention to something in a frame. For example, you might want to
instruct the user to click a certain area in the frame. A callout is a way to provide the user with the
instructions, as well as point to the appropriate area in the frame.

When you record a movie, callouts are added automatically. If you do not want to use the style of
the default callout, you can create your own look and set it as the default callout style for
recordings. You can also add a callout manually to a frame by following the steps below.

How to Add a Callout to a Frame
1. Open the frame.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Home> Objects > Graphics > Bubble.

n Local Toolbar In the local toolbar of the Frame Editor, select Objects > Graphics >
Bubble.

The cursor changes to small crosshairs.

3. Click and drag to draw a rectangle in the frame. The bubble shape appears on the frame.

4. (Optional) Move the shape. You can do this in two ways.

TO MOVE THE BUBBLE AND ITS POINTER

Click in the middle of the bubble and drag it to the appropriate location in the frame. This
moves the entire bubble, including its pointer.

TO MOVE JUST THE BUBBLE

Click on the small bubble icon in the callout and drag it to the appropriate location in the
frame. This moves the bubble, but its pointer remains fixed in its original location.
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5. (Optional) Click the point (small circle) at the tip of the pointer and drag it to the appropriate
location.

6. To add text to the callout, do one of the following.

TO ENTER TEXT DIRECTLY IN THE CALLOUT

a. Click on the bubble and start typing.

b. When you are finished, click anywhere in the frame to confirm your text.

TO ENTER TEXT IN THE OBJECT PROPERTIES WINDOW PANE

a. Double-click the bubble. The Object Properties window pane opens.

b. Expand the Text section.

c. In the Text section, enter the text that you want to display in the caption. You can use
the buttons and drop-downs in the Home ribbon's Text section to apply bold, italic, or
underline formatting to any part of the text. You can also change the color, font, and
size of the text.

7. Click to save your work.
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Adding Callouts Automatically
When you record a movie, bubble callouts can be automatically added to frames when you perform
actions. You can use these callouts to provide information or instructions for users as each action
is performed in the movie.

How to Automatically Add Callouts to Recorded Movies
1. Select File > Recording Options.

The Recording Options dialog opens.

NOTE You can also open this dialog from the Options button at the bottom of the
recording area. 

2. In the Recording Mode field, select Automatic.

3. In the Options section, click Add callouts.

4. Click OK.

5. Record the movie.

NOTE You can also add callouts to frames manually. See "Adding Callouts Manually" on
page 65.
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Selecting the Callout Style for Recording
When you record a movie, bubble callouts can be automatically added to frames when you perform
actions (see "Adding Callouts Automatically" on the previous page). Unless you specify otherwise,
the default callout style is used.

Before you begin recording a movie, you can select the style to be used for the automatic callouts.
You can select a factory style or you can select a style from any of your palettes.

How to Select the Callout Style for Recording
1. Select File > Recording Options.

The Recording Options dialog opens.

NOTE You can also open this dialog from the Options button at the bottom of the
recording area. 

2. In the Callout Style section, click Pick Style. The Select Shape Style dialog opens.

3. In the Collection column, select either Factory or one of your palettes.

4. Select the style in the area to the right.

5. In the Select Shape Style dialog, click OK.

6. In the Recording Options dialog, click OK.

7. Record the movie.
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Adding Cursors Manually
When you record a movie, bitmaps of cursors are added automatically to the frames, along with
trajectories of their movements. By default, cursors are displayed in a lightly shaded oval shape.
However, you can edit the appearance of the cursor shape (e.g., if you do not want the oval shape to
be seen at all, you could specify that the shape should have no border or fill color). If you do not
want to use the style of the default cursor, you can create your own look and set it as the default
cursor style for recordings. In addition to adding cursors automatically during a recording, you can
add a cursor manually to a frame. You can even set a trajectory for that cursor.

How to Add a Cursor to a Frame
1. Open the frame.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Home> Objects > Graphics > Cursor.

n Local Toolbar In the local toolbar of the Frame Editor, select Objects > Graphics >
Cursor.

The cursor changes to small crosshairs and a small circle.

3. Click and drag to draw an oval shape in the frame. The cursor appears in an oval shape. The
oval will change size when you drag the mouse; however, the size of the cursor in the oval
does not change.

4. (Optional) Click in the middle of the oval and drag it to the appropriate location in the frame.

5. Click to save your work.
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Adding Cursors Automatically
When you record a movie, Mimic can automatically capture your mouse movements. In your movie
frames, this is reflected by the addition of a cursor with a trajectory (path). When the movie is
generated and played, the cursor moves just as you moved it when creating the movie.

How to Add Cursors Automatically
1. Select File > Recording Options.

The Recording Options dialog opens.

NOTE You can also open this dialog from the Options button at the bottom of the
recording area. 

2. In the Options section, click Record cursor movements.

3. Click OK.

4. Record the movie.

NOTE You can also add cursors to frames manually. See "Adding Cursors Manually" on the
previous page.
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Editing Cursor Trajectories
If you automatically add cursors to your recorded movies, you may want to edit their paths, or
trajectories, before you publish your finished movie. You might want to do this to simplify the
cursor motion or to add a motion that you did not capture in the original recording. Likewise, if you
did not automatically add cursors to your recording, you can add a cursor to your movie and create
a new trajectory from scratch.
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How to Change a Cursor's Movement
Cursor movement is controlled using position keyframes. Each position keyframe represents the
cursor's position on the frame at a specific time. If you automatically added cursors to your movie,
position keyframes will be added to the timeline for you.

1. Click on an cursor that contains one or more position keyframes.

A trajectory (blue dotted path) appears near the object.
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2. Click on a point (larger blue circle) within the trajectory. The point you selected turns yellow.

3. Drag the point to a new place in the Frame Editor.

You can also add additional position keyframes if you want the cursor to move along a more
specific path. See "Adding Keyframes" on page 157.

CHAPTER 3  73



How to Change a Cursor's Timing
Cursor timing in a frame is determined by the space between each position keyframe. To change
the speed of the cursor, you need to change the placement of its position keyframes.

1. In the Frame Editor, click on an cursor that contains one or more position keyframes.

2. In the Timeline window pane (View > Timeline), do one of the following:

n If the cursor is a standard object, click Frame View.

n If the cursor is an action object, click Action View.

3. Scroll down to the object's position keyframe bar.

4. Click on a keyframe (diamond) within the keyframe bar.
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5. Drag the desired keyframe(s) to a new location in the keyframe bar. To slow down the cursor,
move the position keyframes farther apart. To speed up the cursor, move them closer
together.

What’s Noteworthy?
TIP When you click on a cursor in a frame, you will see a blue line with circles representing
the beginning and end point of the trajectory. However, this trajectory is based on the
upper-left corner of the object, rather than the center of the object.

The default look for a cursor is a translucent circle with an arrow cursor in it. So if you click
and drag the blue circle representing the end of the trajectory, keep in mind that where you
drop the circle is actually the upper-left of the object when it finishes.

For example, the following cursor was created automatically after a movie was recorded.
The cursor moves so that the arrow finishes on the button that has the A and red bar under
it.
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If you click the Play button at the bottom of the frame (or if you click and drag the
scrubber), you can see the actual path of the trajectory.
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Let's say you decide to adjust the trajectory so that it ends on the paint bucket button.
When dragging the blue circle representing the end point, make sure you drop it to the
upper-left of the paint bucket button, rather than on the button itself. Then test the results
with the Play button or scrubber.

NOTE You can manually edit the keyframes to change their position, timing, and transition
type. See "Editing Keyframes" on page 178.

NOTE When you automatically add cursors to a recorded movie, Mimic automatically adds
opacity keyframes to the timeline, as well. These keyframes change the color of the circle
around the cursor. If desired, you can move and edit these keyframes using the same
process as you used to move and edit the cursor's position keyframes.
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Selecting the Cursor Style for Recording
When you shoot a movie, you can tell Mimic to record your movements and automatically display
the cursor and its trajectory on each frame (see "Adding Cursors Automatically" on page 70). Unless
you specify otherwise, the default cursor style is used.

Before you begin recording a movie, you can select the style to be used for the automatic cursors.
You can select a factory style or you can select a style from any of your palettes.

How to Select the Cursor Style for Recording
1. Select File > Recording Options.

The Recording Options dialog opens.

NOTE You can also open this dialog from the Options button at the bottom of the
recording area. 

2. In the Cursor Style section, click Pick Style.

3. In the Collection column, select either Factory or one of your palettes.

4. Select the style in the area to the right.

5. In the Select Shape Style dialog, click OK.

6. In the Recording Options dialog, click OK.

7. Record the movie.

NOTE You can also add cursors to frames manually. See "Adding Cursors Manually" on
page 69.
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Adding Graphics to Frames
There are various graphics that you can add to a movie, such as bubbles, loops, arrows, and
cursors. All graphics can be found in the Timeline window pane's Frame View.

How to Add Graphics to Frames
1. Open a movie.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Home> Objects > Graphics.

n Frame Editor In the local toolbar of the Frame Editor, select Objects > Graphics.

3. Select the appropriate option:

Click this button to draw a bubble shape (often used for callouts). See "Adding
Callouts Manually" on page 65.

Click this button to draw an arrow. See "Setting the Shape of an Arrow" on page
229.

Click this button to draw a loop. See "Setting the Coordinates for a Loop" on
page 243 and "Setting the Thickness for a Loop" on page 244.

Click this button to draw a cursor. See "Adding Cursors Manually" on page 69.

4. Click on the frame and drag the mouse to draw the shape, then release the mouse button
when you are finished.
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NOTE Each object has properties that can be customized.

5. Click to save your work.
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Adding Images as Objects
In addition to adding objects such as shapes, lines, and buttons to a frame, you can also insert
another image as an object. Like other objects, this image resides in its own layer on the frame. You
can insert any image files of the following types: BMP, JPG, JPEG, GIF, PNG, TIF, TIFF.

How to Add an Image as an Object
1. Open the frame.

2. Select Home > Insert Image.

The Open dialog opens.

3. In the Open dialog, locate and double-click the image file you want to add. The image is added
to the frame as an object.

4. To move the image object, click it and drag it to a new location on the frame.

5. Click to save your work.

Editing Image Objects
After you add an image as an object, you can edit the object in several ways.

How to Modify the Position of the Image Object
The easiest way to modify the position of an image object is to click on the object and drag it.
Alternatively, you can use the following steps.

1. Open the frame.

2. Double-click the image object. The Object Properties window pane opens.

3. Expand the Object Layout section.
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4. Change the numbers in the Position fields.

n Horizontal The left field sets the position of the object on the "X" axis (left and right) on
the frame.

n Vertical The right field sets the position of the object on the "Y" axis (up and down) on
the frame.

5. Click to save your work.

How to Resize the Image Object
The easiest way to resize an image object is to click any point (i.e., small circle) around the edge of
the object and drag it to adjust the width and/or height. Alternatively, you can use the following
steps.

1. Open the frame.

2. Double-click the image object. The Object Properties window pane opens.

3. Expand the Image section.

4. Change the numbers in the Size fields:

n Width The left field sets the width of the image object (in pixels).

n Height The right field sets the height of the image object (in pixels).

5. Click to save your work.

How to Modify the Opacity of the Image Object
1. Open the frame.

2. Double-click the image object. The Object Properties window pane opens.

3. Expand the Object Appearance section.
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4. Change the settings in the Background section:

n Adjust the Opacity slider to set the amount of transparency applied to the image object.
The higher the number, the more transparent the image object will be. The lower the
number, the more solid the image object will be.

5. Click to save your work.

Replacing Image Objects
You can replace an image object at any time. When you replace an image object with a new image,
you retain the original image object's properties, keyframes, and effects. All that changes is the
image that appears in the frame.

How to Replace an Image Object
1. Open a frame with an image object added to it.

2. Double-click the image object. The Object Properties window pane opens.

3. Expand the Image section.

4. Click Image File… to browse for the new image you want to use.

5. In the Open dialog, locate and double-click the image file you want to add. The new image is
added to the frame, replacing the original image object.

6. Click to save your work.
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Interactive Objects
There are various interactive objects you can add to a frame.

Adding Interactive Objects
Interactive objects include input boxes, buttons, and typing boxes. You can associate interactive
objects with an action (or with an action object) to create different kinds of effects in your movie,
such as showing a feedback bubble when a user enters text in an input box.

How to Add an Interactive Object to a Frame
1. Open the frame.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Home> Objects > Interactive. Then choose the shape you want to add.

n Local Toolbar In the local toolbar of the Frame Editor, select Objects > Interactive and
select the appropriate shape.

The following interactive objects are available:

Click this button to draw a button shape.

You can add buttons to frames in a movie. Adding a button is a way to include
navigation and allow a user to move from one frame to another (by applying an
action to the button). See "Adding Buttons" on page 92.

Click this button to draw a typing box.

You can add typing to your movie through the use of animated typing boxes and
user input boxes. See "Adding Animated Typing Boxes" on the next page.
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Click this button to draw an input box.

If you want the user to enter text at a certain frame in the movie, you can
accomplish this by adding an input box. You can then enter the exact content
that you want the user to type. You can also format the text, as well as specify
feedback and actions based on the user's input. See "Adding Input Boxes" on
page 89.

Adding Animated Typing Boxes
When you record a movie, Mimic can capture any typing actions that you perform on screen. This
typing is animated in the movie output. In other words, each letter of the content is typed as the
user watches it. When you record in Automatic mode, you can select whether to add typing box
shapes when you perform typing actions. If you select this option, Mimic inserts a typing box object
when you type during a recording session. If you disable this option and type during a recording
session, the frame in question becomes a full-motion video (FMV) frame. Not only can animated
text boxes be added automatically when you record movies, but you can also add them manually
when you edit the movie.

How to Add an Animated Typing Box
1. Open the frame.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Home> Objects > Interactive > Typing Box.

n Local Toolbar In the local toolbar of the Frame Editor, select Objects > Interactive >
Typing Box.

The cursor changes to small crosshairs.

3. Click in the frame and drag the mouse to draw a rectangle where you want the animated
typing to display. Release the mouse button when you are finished. An empty typing box
appears.

4. Double-click the typing box. The Object Properties window pane opens.
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5. Expand the Typing Box section.

6. Complete any of the following fields.

n Start Text Enter the text (if any) that you want to display in the typing box when it
appears in the output. If you do not want any start text, leave this field empty.

n Typed Text Enter the text that you want to be typed in the box as the frame plays. This
text will follow directly after any start text.

7. (Optional) You can make other modifications to the typing box, including the following.

MODIFY THE LOOK OF THE TYPING BOX

a. Double-click the typing box. The Object Properties window pane opens.

b. Expand the sections and make changes to the typing box properties (e.g., background
color, border, font, animation effects, curve of rectangle). See "Appearance of Frames"
on page 225.

INCREASE OR DECREASE THE TYPING SPEED

a. Double-click the typing box. The Object Properties window pane opens.

b. Expand the General section and make the desired adjustments:

n Time Span If you want the typing box effect to be displayed for a specific period
of time, leave the check mark in this box. If you want to disable timing for the
effect, click this check box to remove the check mark. Disabling the timing is
useful if you want to ensure that the effect continues to display as long as the
frame does.

n Start The time at which the typing box effect will display when the frame is
played. You can manually adjust the start time by clicking and dragging the effect
bar to the desired location in the Timeline.

n Duration The number of seconds you want the typing box effect to last. You can
manually adjust the duration of the effect by clicking and dragging either end of
the effect bar to increase or decrease the size.
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NOTE If you increase the duration of the typing box, be aware that the
timing of the frame must also be long enough to accommodate it.

NOTE Increasing the duration of the typing box applies to how long the
object exists. Text—regardless of if the text is long or short—will be
spaced to fit this duration. Keep this in mind to ensure that the typing
object can be read easily.

MOVE OR RESIZE THE TYPING BOX

n To move the entire typing box, click the box and drag it to the new location.

n To resize the typing box, click any of the points (i.e., small circles) around the edge of
the box and drag it to adjust its size.

8. Click to save your work.

NOTE When you record in Automatic mode, you can select whether to add typing box
shapes when you perform typing actions. If you select this option, it inserts a typing box
object when you type during a recording session. If you disable this option and type during
a recording session, the frame in question becomes a full-motion video (FMV) frame.
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Adding Input Boxes
If you want the user to enter text at a certain frame in the movie, you can accomplish this by adding
an input box. You can then enter the exact content that you want the user to type. You can also
format the text, as well as specify feedback and actions based on the user's input.

How to Add an Input Box
1. Open the frame.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Home> Objects > Interactive > Input Box.

n Local Toolbar In the local toolbar of the Frame Editor, select Objects > Interactive >
Input Box.

The cursor changes to small crosshairs.

3. Click and drag to draw a rectangle in the frame where you want the input box to be displayed.

4. Double-click the input box. The Object Properties window pane opens.

5. Expand the Input Box section.

6. In the Start Text field, enter the text that will display in the box as soon as it appears in the
frame.

NOTE If you enter start text, the user will need to delete it before typing an entry.

7. In the Attempts Allowed field, use the arrows to set the number of attempts the user has to
type the correct text.

OR

Select Infinite Attempts to give the user unlimited attempts to correctly enter the text.
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8. In the Correct Entries area, click to add an entry field, then enter the correct entry
option that you want to user to type in the input box. Continue adding text entry fields until
you have entered all of the possible correct entry options.

NOTE The user only needs to type one of the correct entries correctly in the output to
continue.

9. (Optional) To remove a correct entry option, click .

10. Expand the Action section.

11. Click Add Action.

A set of two fields, Event and Action, appear.

12. From the Event drop-down, select one of the following:

n Click The object changes when the user clicks the object.

n DoubleClick The object changes when the user double-clicks the object.

n MouseEnter The object changes when the user moves the mouse over the object.

n MouseLeave The object changes when the user moves the mouse off of the object.

n MouseUp The object changes when the user clicks, and then releases, the mouse
button. This lets you create a "pressed" effect that changes back to the default settings
when the mouse button is released.

n Success The object changes when an input box has been answered correctly.

n Failed Attempt The object changes when an input box has been answered incorrectly
but the user is still within the allowed number of failed attempts.

n Failure The object changes when an input box has been answered incorrectly the max
number of times allowed.

13. In the Action area, select an action to perform after the user types input and presses ENTER.
For descriptions of each action, see "Selecting Actions for Objects" on page 109.

14. Click OK.
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15. Click to save your work.

NOTE Although you can add more than one input box per frame, any actions associated
with multiple input boxes will not work correctly in the final output. It is recommended to
limit input boxes to one per frame.
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Adding Buttons
You can add buttons to frames in a movie. Adding a button is a way to include navigation and allow
a user to move from one frame to another (by applying an action to the button).

How to Add a Button to a Frame
1. Open the frame.

2. Do one of the following, depending on the part of the user interface you are using:

n RibbonSelect Home> Objects > Interactive > Button.

n Local Toolbar In the local toolbar of the Frame Editor, select Objects > Interactive >
Button .

The cursor changes to small crosshairs.

3. Click and drag to draw a rectangle in the frame.

The button is added to the frame, with the default text "Button." You can change this text if
you wish. See "Editing Text" on page 140.

4. Click to save your work.

TIP Newly created buttons include two default visual states:

n Hover MouseEnter and MouseLeave events create a hover effect.

n Click Click and MouseUp events create a pressed/click effect.

You can edit these visual states and actions to create your own button effects. You can
also use them as a template for creating visual states and actions for other objects.
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Adding Shapes to Frames
There are various shapes that you can add to a frame, such as a polygon, oval, rectangle, and text
rectangle. All shapes are found in the Timeline window pane's Frame View.

How to Add a Shape to a Frame
1. Open the frame.

2. Do one of the following, depending on the part of the user interface you are using:

n RibbonSelect Home> Objects. Then choose the shape you want to add.

n Local Toolbar In the local toolbar of the Frame Editor, select Objects, then select the
appropriate shape.

The following shape options are available:

Converts the cursor to Rectangle mode, which lets you create a square or
rectangle shape by clicking in the frame and dragging in any direction. When
you release the cursor, the shape is created.

Converts the cursor to Oval mode, which lets you create a circle or oval shape
by clicking in the frame and dragging in any direction. When you release the
cursor, the shape is created.

Converts the cursor to Polygon mode, which lets you create a closed plane
shape bounded by three or more line segments. After you select this button, you
can click anywhere in the frame to identify the starting point for the shape.
When you move the cursor, a straight line segment is drawn. If you click the left
mouse button, it signifies the end of that line segment and the start of another
line segment. When you move the cursor, another straight line segment is
drawn. When you double-click, a final line segment joins your starting and
ending points, thus closing off the shape.
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Click this button to draw a text box (i.e., a square or rectangle with your cursor
positioned within to allow for immediate typing).

3. Do one of the following.

TO DRAW AN OVAL OR RECTANGLE

a. Click and drag the mouse to draw the shape.

b. Release the mouse button to complete the shape.

TO DRAW A TEXT BOX

a. Click and drag the mouse to draw the shape.

b. Release the mouse button to complete the shape.

c. Enter the text for the text box.

d. Click outside of the box when you are finished.

TO DRAW A POLYGON

a. Click once in the frame where you want to start the shape.

b. Without clicking your mouse button, move your cursor to draw a line segment.

c. Click the left mouse button to end the line segment and start a new one.

d. Continue creating line segments until you have drawn the shape that you want.

e. Double-click the left mouse button to close the shape.

4. Click to save your work.

CHAPTER 3  94



Adding Lines
Mimic has a polyline tool that lets you create a line with one or more line segments. You can also
specify whether the line should include arrows, a shadow, or other properties.

EXAMPLE

Here is a line with one segment and no arrows.

Here are two intersecting lines with arrows at the head of each line.

Here is a line with three segments, an arrow at the head, an arrow at the tail, and a shadow.
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How to Add a Line to a Frame
1. Open the frame.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Home> Objects > Polyline.

n Local Toolbar In the local toolbar of the Frame Editor, click the down arrow next to
Objects and select Polyline.

3. Click the spot where you want the line to begin.

4. Move your mouse in the direction where you want to add the line. As you do this, the line
appears in the Frame Editor.

5. If you want the line to contain multiple line segments (e.g., you might want a line that goes
left and then up), click each location where you want to add a new segment, then drag the
mouse in the appropriate direction. When you want to signal the end of the line, double-click
your mouse. By default, the line displays with an arrow at the end.

6. If necessary, make adjustments to the line, such as the following.

TO MOVE THE ENTIRE LINE

Click and drag the line to the new location.

NOTE If you have dragged the line outside the current boundaries of the image,
padding is automatically added to compensate for the space needed. Double-click
the image (not the line) to open the Object Properties window pane. Then, expand the
Object Appearance section and use the fields in the Background section as
necessary.

TO MOVE LINE SEGMENTS

If you want to adjust a particular line segment, click the point (small circle) at the end of the
segment and drag it as necessary.
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TO SET ARROWS FOR THE LINE

a. Double-click the line. The Object Properties window pane opens.

b. Expand the Polyline section.

c. In the Arrow Heads and Arrow Tails sections, make modifications to the arrows. See
"Setting the Arrows for a Line" on page 227.

TO SET THE COLOR AND WIDTH FOR THE LINE

a. Double-click the line. The Object Properties window pane opens.

b. Expand the Object Appearance section.

c. In the Line section, set the color and width properties. See "Setting the Color and Width
for a Line" on page 238.

TO ADD A SHADOW TO THE LINE

a. Double-click the line. The Object Properties window pane opens.

b. Expand the Shadow section.

c. In the Shadow section, set the shadow properties. See "Adding Shadow Effects" on
page 326.

7. Click to save your work.
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Converting an Object
You can convert an object from one type to another. This lets you convert regular shapes into
action objects so they will appear only if a particular event occurs (e.g., clicking a button, double-
clicking a shape). Action objects are often associated with interactive objects, such as input boxes
or buttons, but can also be associated with regular shapes, such as rectangles or loops. See
"Interactive Objects" on page 85.

How to Convert an Object
1. Open a movie that has one or more objects.

2. Right-click on an object and select Advanced.

3. Depending on the type of object you clicked, select one of the following:

n Convert to Action Object Select Convert to Action Object to change a regular object into
an action object. Action objects appear in the Timeline window pane's Action View.

n Convert to Timeline Object Select Convert to Timeline Object to change an action
object into a regular object. Regular objects appear in the Timeline window pane's
Frame View.

4. Click to save your work.

NOTE You must convert an object to an action object if you want to assign an end action
to the object.
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Inserting Captured Regions as Objects
You can capture a region on your screen and insert the image as an object. With this type of
capture, you can draw a rectangle over any area of your computer screen and capture that region.
This is useful, for example, if you want to record or capture only a specific portion of a window, but
not the entire window.

Like other objects, this image resides in its own layer in the frame.

How to Insert a Captured Region as an Object
1. Open the frame.

2. Do one of the following:

n Select Home > Insert Screenshot.

n Select Frame > Screenshot.

Mimic minimizes and a square crosshairs and a red border appear on your screen.

3. Click and drag the crosshairs to set the initial capture area. Once you do this, a taskbar
appears.
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4. Rearrange the capture area. You can use several methods and features to do this.

DRAG EDGE

You can resize the capture area manually by clicking any of the handles (small squares)
around the edge of the rectangle and dragging them to resize the width and/or height.
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MOVE ENTIRE CAPTURE AREA

You can move the entire capture area by clicking the size-all icon in the center of the area
and dragging the area to a new location on your screen.

CHAPTER 3  101



TYPE WIDTH OR HEIGHT

You can click in the number fields in the task bar to manually change the width and/or height
of the capture window in pixels.
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MAINTAIN ASPECT RATIO

You can click the chain button in the task bar to maintain the aspect ratio when you change
the width or height of the capture area.

When this feature is disabled, the button displays as an broken chain image. If you then
change one dimension of the capture window, the other dimension will not be resized
automatically. For example, if you drag the window border to the left (to increase the width),
the height will remain the same size.

When this feature is enabled, the button displays as a chain image. If you then change one
dimension of the capture window, the other side will be resized automatically. For example, if
you drag the window border to the left (to increase the width), the height will be resized
accordingly.
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CHOOSE PRE-SET SIZE

You can click the drop-down in the task bar and choose one of the pre-set window sizes.
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SNAP/MOVE INTO RECTANGLE

If you have a particular application or window open, and you want to capture it, you can
choose an option to snap the capture window around that element, or you can choose to
move the element into your capture window. When you use one of these options, the Select
Window dialog opens. You can then choose any of the applications or windows that you have
open.

NOTE If you are using a newer operating system, you may need to enable window-
based recording optimization. For more information, see the online Help.

5. Click the red button on the task bar. The area inside the rectangle is captured and inserted
into the frame as an object.

6. To move the image object, click it and drag it to a new location on the frame.

7. Click to save your work.
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Inserting Captured UI Elements as
Objects

You can capture a UI element in an application and insert the image as an object. This is a type of
capture that records a fixed area of a window (e.g., menu bar, toolbar, editor, individual button,
entire window), depending on where you move your mouse and click. As you move the mouse in an
application, a red border surrounds each separate region.

Like other objects, this image resides in its own layer in the frame.

How to Insert a UI Element as an Object
1. Open the frame.

2. Select Home > Insert Screenshot > Captured UI Element.

Mimic minimizes and a red border surrounds each UI element as you move your cursor over
it.

3. Click the UI element that you want to capture. The image is captured and inserted into the
frame as an object.

4. To move the image object, click it and drag it to a new location on the frame.

5. Click to save your work.
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CHAPTER 4

Actions
An action is a command that you can assign to an object to affect what happens next in the movie.
You can also assign an end action to a movie.

This chapter discusses the following:

Using Preview Mode 108

Selecting Actions for Objects 109

Selecting an End Action for a Cursor 120

Removing Actions From Objects 123

Visual States 124
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Using Preview Mode
Preview mode lets you use Frame Editor to view an action set on an object. This prevents you from
having to build movie output just to see how an action looks when it is executed. In other words, if
you set a shape to turn green when it is clicked, you can use the Preview mode to see that action as
soon as you set it up, without ever leaving the Frame Editor.

How to Use the Preview Mode Feature
1. Open a movie that has an object to which an action has been applied.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Home> .

n Right-Click Right-click anywhere in the Frame Editor, and from the context menu, select
Preview Mode.

3. In the Frame Editor, perform the event that causes the action to take place (e.g., click on the
object, double-click the object, move the mouse over the object).

NOTE Condition tags are considered when viewing a movie in Preview Mode.

NOTE You can also press CTRL+SHIFT and click an object to instantly preview the action.
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Selecting Actions for Objects
After you add an object (e.g., button, input box) to a frame, you can assign an action to it (e.g., go to
next section, go to previous frame). When the user performs a specified event, the action is
triggered (e.g., when the user types clicks a button, the movie advances to the next frame).

How to Select an Action
1. Open the frame.

2. Double-click the object. The Object Properties window pane opens.

3. Expand the Action section.

4. Click Add Action.

A set of two fields, Event and Action, appear.

5. In the Event field, select one of the following:

n Click The object changes when the user clicks the object.

n DoubleClick The object changes when the user double-clicks the object.

n MouseEnter The object changes when the user moves the mouse over the object.

n MouseLeave The object changes when the user moves the mouse off of the object.

n MouseUp The object changes when the user clicks, and then releases, the mouse
button. This lets you create a "pressed" effect that changes back to the default settings
when the mouse button is released.

n Success The object changes when an input box has been answered correctly.

n Failed Attempt The object changes when an input box has been answered incorrectly
but the user is still within the allowed number of failed attempts.

n Failure The object changes when an input box has been answered incorrectly the max
number of times allowed.
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n End The object changes when the frame ends. To use an end event, you must have an
action object in your frame. You can convert an object to an action object by right-
clicking it, then selecting Advanced > Convert to Action Object.

6. Do one of the following:

ASSOCIATE AN ACTION OBJECT WITH AN INTERACTIVE OBJECT OR SHAPE

If you want to trigger an action object to appear when an event occurs, choose the "Play
Action Object" event. For example, you could use an action object to display a feedback
bubble when a user enters information into an input box. You must have action objects on the
frame in order to use this option. Action objects are often used with interactive objects, but
you can associate them with any shape. See "Interactive Objects" on page 85.

a. In the Action field, select Play Action Object.

The Shape field appears.

b. In the Shape field, select from any action objects currently in this frame.

EXAMPLE

You have an input box in the frame so the user can answer a question. You've already
added the correct entry to the input box properties and have set it to allow an infinite
number of answer attempts, but you feedback appear when they enter an incorrect
entry. You also want feedback to appear when they've entered the right answer. First,
add two bubbles to the frame: one to provide a hint when the user enters the
incorrect response, and another to provide success feedback when the user enters
the right answer.
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Next, right-click each of these bubbles and select Advanced > Convert to Action
Object. This lets you associate them with the interactive input box.
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Then, add two actions to the input box. The first one is for the hint.

CHAPTER 4  113



The second action is for the success feedback.

In the output, only the input box displays at first.
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When the user types "close button," and presses ENTER, the hint will appear.

When the user types the correct entry, "X," and presses ENTER, the success feedback
appears.

Use the Preview option (Object > Preview Mode) to check your progress as you work.
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SET A VISUAL STATE FOR AN OBJECT

Choose the "Set Visual State" action when you want an object's look to change when an event
occurs. Visual states can affect either the selected object or another object (e.g., when the
user clicks the selected object, another object changes its state). See "Visual States" on page
124.

a. In the Action field, select Set Visual State. A set of two fields, Shape and Visual State,
appear.

b. In the Shape field, select the object to which you want to apply the visual state.

n (this object) When an action triggers the visual state, it affects the selected
object (e.g., the current object will change color when clicked).

n [another object] When an action triggers the visual state, it affects a different
object (e.g., when the user clicks the current object, a different object on the
frame will change color). Objects you select here must have one or more visual
states available.

c. In the Visual State field, select the visual state you want to apply (e.g., when the cursor
moves over an object, it will use "Visual State 1.").

NOTE After you create and apply a visual state, you can preview how it will
look without building the movie. See "Using Preview Mode" on page 108.
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ADD A RESUME ACTION TO CONTINUE PLAYING THE FRAME

Choose this action when you want the user to click an object in order to continue the movie.
This might be useful if you want to pause the movie until the user makes entries in an input
box.

a. In the Action field, select Pause/Resume Movie.

b. Right-click the frame and select Properties.

c. In the Frame Properties window pane, expand the Frame Transition tab.

d. Click Pause movie at end of frame.

e. Click to save your work.

ADD ANY OTHER ACTION TYPE

There are several other actions that you can add to an object by selecting them from the
Action drop-down. Choose any of the following actions:

n Accept Input Select this option to accept the user's input. Let's say you add an input
box to a frame. After users complete the input box, they can usually simply press
ENTER on the keyboard. However, if you want users to click say, a button, when they
are finished with the input, you can create a button and apply this action to it. After
users finish typing the input, they can click that button to submit the input (instead of
pressing ENTER on the keyboard).

n Open URL Select this option to open a remote file (such as a website) when the
specified event occurs (e.g., click, double-click). When you select this option, the URL
field appears at the bottom of the tab. Enter the full URL in this field. With this option,
the website or other file will open in the viewer used for displaying the movie.

n Open URL in New Window Select this option to open a remote file (such as a website)
when the specified event occurs (e.g., click, double-click). When you select this option,
the URL field appears at the bottom of the tab. Enter the full URL in this field. With this
option, the website or other file will open in the default application for the file type (e.g.,
HTM files open in Internet Explorer, DOC files open in Microsoft Word).

n Go to Frame Select this option to open a specific frame in the movie when the specified
event occurs (e.g., click, double-click). When you select this option, the Frame field

CHAPTER 4  117



appears beneath the Action field. Enter the number or name of the destination frame in
this field. (The name of the frame is identified above it in the Frames window pane. You
can change the name in the Frame Properties window pane.)

n Go to Next Frame Select this option to open the next frame in the movie when the user
clicks the button or other object.

n Go to Previous Frame Select this option to open the previous frame in the movie when
the specified event occurs (e.g., click, double-click).

n Go to First Frame Select this option to open the first frame in the movie when the
specified event occurs (e.g., click, double-click).

n Go to Section Select this option to open a specific movie in the collection when the
specified event occurs (e.g., click, double-click). When you select this option, the
Section field appears beneath the Action field. Select the name of the destination movie
from the drop-down list in this field. This option assumes you have created a collection
and added multiple movies to it.

NOTE If you are linking to a movie that has a name with a number only, Mimic
considers that number to be the movie's position in the collection sequence.
For example, if you enter 2 when specifying the destination movie, Mimic will
link to the second movie in the collection, not necessarily to a movie that you
have named "2."

n Go to Next Section Select this option to open the next movie in the collection when the
specified event occurs (e.g., click, double-click). This option assumes you have created
a collection and added multiple movies to it.

n Go to Previous Section Select this option to open the previous movie in the collection
when the specified event occurs (e.g., click, double-click). This option assumes you
have created a collection and added multiple movies to it.

n Go to First Section Select this option to open the first movie in the collection when the
specified event occurs (e.g., click, double-click). This option assumes you have created
a collection and added multiple movies to it.

7. Click to save your work.
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TIP Newly created buttons include two default visual states:

n Hover MouseEnter and MouseLeave events create a hover effect.

n Click Click and MouseUp events create a pressed/click effect.

You can edit these visual states and actions to create your own button effects. You can
also use them as a template for creating visual states and actions for other objects.

NOTE Multiple actions can be applied to each object.

NOTE Actions applied to an object will remain part of the object if you add it to your
palette.

NOTE You can convert any object into an action object. Right-click on the object and select
Advanced > Convert to Action Object. If you want to convert an action object into a regular
object, right-click on the action object and select Advanced > Convert to Timeline Object.
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Selecting an End Action for a Cursor
By default, when a cursor movement reaches the end of its path (trajectory), the movie will continue
to play in its normal progression. Instead of this default action, you can use End Action to provide a
specific action to take place when the cursor reaches the end of its path.

How to Select an End Action for a Cursor
1. Open the frame.

2. Right-click the cursor. From the context menu, select Advanced > Convert to Action Object.
This lets you add End actions to the cursor.

3. Double-click the cursor shape. The Object Properties window pane opens.

4. Expand the Action section.

5. In the Event field, select End.

6. In the Action field, select the action that will take place when the event is performed:

n Accept Input Select this option to accept the user's input. Let's say you add an input
box to a frame. After users complete the input box, they can usually simply press
ENTER on the keyboard. However, if you want users to click say, a button, when they
are finished with the input, you can create a button and apply this action to it. After
users finish typing the input, they can click that button to submit the input (instead of
pressing ENTER on the keyboard).

n Open URL Select this option to open a remote file (such as a website) when the
specified event occurs (e.g., click, double-click). When you select this option, the URL
field appears at the bottom of the tab. Enter the full URL in this field. With this option,
the website or other file will open in the viewer used for displaying the movie.

n Open URL in New Window Select this option to open a remote file (such as a website)
when the specified event occurs (e.g., click, double-click). When you select this option,
the URL field appears at the bottom of the tab. Enter the full URL in this field. With this
option, the website or other file will open in the default application for the file type (e.g.,
HTM files open in Internet Explorer, DOC files open in Microsoft Word).
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n Go to Frame Select this option to open a specific frame in the movie when the specified
event occurs (e.g., click, double-click). When you select this option, the Frame field
appears beneath the Action field. Enter the number or name of the destination frame in
this field. (The name of the frame is identified above it in the Frames window pane. You
can change the name in the Frame Properties window pane.)

n Go to Next Frame Select this option to open the next frame in the movie when the user
clicks the button or other object.

n Go to Previous Frame Select this option to open the previous frame in the movie when
the specified event occurs (e.g., click, double-click).

n Go to First Frame Select this option to open the first frame in the movie when the
specified event occurs (e.g., click, double-click).

n Go to Section Select this option to open a specific movie in the collection when the
specified event occurs (e.g., click, double-click). When you select this option, the
Section field appears beneath the Action field. Select the name of the destination movie
from the drop-down list in this field. This option assumes you have created a collection
and added multiple movies to it.

NOTE If you are linking to a movie that has a name with a number only, Mimic
considers that number to be the movie's position in the collection sequence.
For example, if you enter 2 when specifying the destination movie, Mimic will
link to the second movie in the collection, not necessarily to a movie that you
have named "2."

n Go to Next Section Select this option to open the next movie in the collection when the
specified event occurs (e.g., click, double-click). This option assumes you have created
a collection and added multiple movies to it.

n Go to Previous Section Select this option to open the previous movie in the collection
when the specified event occurs (e.g., click, double-click). This option assumes you
have created a collection and added multiple movies to it.

CHAPTER 4  121



n Go to First Section Select this option to open the first movie in the collection when the
specified event occurs (e.g., click, double-click). This option assumes you have created
a collection and added multiple movies to it.

7. Click OK.

8. Click to save your work.
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Removing Actions From Objects
If an action is no longer needed, you can remove it from an object.

How to Remove an Action From an Object
1. Open a movie that contains one or more objects.

2. Double-click an object that has an action applied to it.

The Object Properties window pane opens.

3. Expand the Action section.

4. Select the visual state you want to remove. The selected action (as well as its associated
Event, Shape, and Visual State, if applicable) is highlighted in gray.

5. Click . The action is removed from the object.

6. Click to save your work.

NOTE Buttons include a default click action. You should select and delete this click action
before creating a new click action.
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Visual States
You can add different visual states to an object in order to change the object's appearance if certain
actions are performed.

Adding Visual States to an Object
You can add one or more visual states to an object. These states give objects the ability to display a
different appearance when the user performs an action, such as clicking on the object.

Adding a visual state to an object is actually two sets of steps. First, you create the visual state.
Then, you apply the state to the object. In order to create a visual state, you must get your object
ready first. Once you create the visual state, it can be applied to that object. Visual states created
for one object cannot be used on other objects.

How to Create a Visual State
1. Open a frame that contains one or more objects.

2. Double-click an object. The Object Properties window pane opens.

3. Expand the Visual State section.

4. Click New Visual State.

A new visual state is added to the window pane.

5. In the Visual States section, select the new visual state. This will allow you to edit its
properties.

NOTE If you do not select the new visual state, you will change the default properties
for the object. The selected visual state is highlighted in gray.
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6. (Optional) In the Name field, give the visual state a name (e.g., "red to green on click"). This
will help you identify the visual state.

7. Expand the Object Appearance section. Change the opacity and background as needed.

NOTE You can add opacity states to all objects, and background color states to all
objects except polylines and image objects.

8. Expand the Text section. Change the text as needed.

9. (Optional) If you are adding a visual state to a cursor, you can add audio to the visual state.
Expand the Audio section and make changes to the audio settings as needed. For more
information, see the online Help.

How to Apply a Visual State to an Object
1. In the Visual States section, select the (default) visual state.

2. Expand the Action section.

3. Click Add Action.

4. Click the Event drop-down and select one of the following:

n Click The object changes when the user clicks the object.

n DoubleClick The object changes when the user double-clicks the object.

n MouseEnter The object changes when the user moves the mouse over the object.

n MouseLeave The object changes when the user moves the mouse off of the object.

n MouseUp The object changes when the user clicks, and then releases, the mouse
button. This lets you create a "pressed" effect that changes back to the default settings
when the mouse button is released.

n Success The object changes when an input box has been answered correctly.

n Failed Attempt The object changes when an input box has been answered incorrectly
but the user is still within the allowed number of failed attempts.
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n Failure The object changes when an input box has been answered incorrectly the max
number of times allowed.

n End The object changes when the frame ends. To use an end event, you must have an
action object in your frame. You can convert an object to an action object by right-
clicking it, then selecting Advanced > Convert to Action Object.

5. In the Action field, select Set Visual State.

6. In the Shape field, select the object to which you want to apply the visual state.

n (this object) When an action triggers the visual state, it affects the selected object (e.g.,
the current object will change color when clicked).

n [another object] When an action triggers the visual state, it affects a different object
(e.g., when the user clicks the current object, a different object on the frame will change
color). Objects you select here must have one or more visual states available.

NOTE Visual states are created for each object. If you want to apply a visual state to
another object, you must first create a visual state for that object. When you select an
object from the Shape drop-down, the Visual States drop-down updates to show you
the visual states that are available for that shape.

EXAMPLE

Let's say you have two rectangles: a red one and a blue one. The red rectangle has a
red to green visual state assigned to it.

You want the red rectangle's visual state to activate when you click the blue
rectangle. To do this, you would create a "Set Visual State" action in the blue
rectangle's properties. Then you can set the shape to "Red Rectangle," and then
select the "red to green" visual state, which is associated with the red rectangle.
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When you click the blue rectangle, the red rectangle will turn green.

7. In the Visual State field, select the visual state you want to apply (e.g., when the cursor moves
over an object, it will use "Visual State 1.").

8. Click to save your work.

NOTE After you create and apply a visual state, you can preview how it will look
without building the movie.
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EXAMPLE

Let's say you have a rectangle that is red no matter what the user does to the object while
viewing the movie. You would like it to change to green when the user clicks the object.

When you open the Object Properties window pane, you have the option to create a visual
state for the rectangle. The visual state you create is applicable only to the red rectangle.

CHAPTER 4  129



CHAPTER 4  130



Once the visual state is created, select the default visual state (this is because the action
will affect the default state, not the visual state). Then expand the Action section in the
object's properties, and select the action you want to trigger the visual state.
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You can preview the visual state and action by using Preview Mode. Select the Home
ribbon. In the Mode section, click . Now, performing the action on the object
(e.g., clicking, double-clicking) in the Frame Editor will let you see how the visual state
looks.

CHAPTER 4  132



What’s Noteworthy?
TIP Newly created buttons include two default visual states:

n Hover MouseEnter and MouseLeave events create a hover effect.

n Click Click and MouseUp events create a pressed/click effect.

You can edit these visual states and actions to create your own button effects. You can
also use them as a template for creating visual states and actions for other objects.

NOTE If you add an object that contains visual states to a palette, it will retain those visual
states as well as any actions associated with those visual states.
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Editing Visual States
Once you have added a visual state to an object, you can edit the visual state instead of removing it
and creating a new state from scratch.

How to Edit a Visual State
1. Open a movie that contains one or more objects.

2. Double-click an object that has a visual state applied to it. Objects with visual states applied
to them have a visual states icon in the upper right corner.

The Object Properties window pane opens.

3. Expand the Visual State section.

4. In the Visual States section, select the visual state you want to edit. This will allow you to edit
its properties.

NOTE If you do not select the visual state, you will change the default properties for
the object. The selected visual state is highlighted in gray.

5. Expand the Object Appearance section. Change the opacity and background as needed.

NOTE You can add opacity states to all objects, and background color states to all
objects except polylines and image objects.

6. Expand the Text section. Change the text as needed.

7. (Optional) If you are adding a visual state to a cursor, you can add audio to the visual state.
Expand the Audio section and make changes to the audio settings as needed.
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8. If necessary, make changes to the action that triggers the visual state.

9. Click to save your work.

Removing Visual States
If a visual state is no longer needed, you can remove it from an object.

How to Remove a Visual State From an Object
1. Open a movie that contains one or more objects.

2. Double-click an object that has a visual state applied to it. Objects with visual states applied
to them have a visual states icon in the upper right corner.

The Object Properties window pane opens.

3. Expand the Visual State section.

4. Select the visual state you want to remove, then click .

5. Click to save your work.
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CHAPTER 5

Text and Fonts
You can incorporate text into movies and work with fonts.

This chapter discusses the following:

Adding Text 137

Aligning Text 139

Editing Text 140

Setting Font Properties for Text 141

Pinning Fonts 143
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Adding Text
You can add text to a frame by drawing a shape, clicking on it, and typing. You can also use the
Object Properties window pane.

If you want the text to appear by itself, you can edit the properties of the object accordingly so that
the object border or background cannot be seen (e.g., specify no border or color for the shape).
Otherwise, the object will be shown with the text inside.

How to Add Text to an Object
1. Open the frame.

2. Create the object (e.g., shape, button) that will contain the text.

3. Do one of the following, depending on the part of the user interface you are using:

n Keyboard Shortcut Press F2. A cursor appears in the center of the shape.

NOTE If there is already text in the object, pressing F2 highlights the existing
text. Click the highlighted text to place the cursor in the text area. See "Editing
Text" on page 140.

n Double-Click Double-click the object. In the Object Properties window pane, expand the
Text section.

4. Type the content.

5. Edit the text as necessary. You can use the buttons and drop-downs in the Home ribbon's
Text section to apply bold, italic, or underline formatting to any part of the text. You can also
change the color, font, and size of the text.
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NOTE In the Object Properties window pane, you can use the other sections to set
properties for the object and change its look (e.g., fill color, shadow). If you want to
make the object invisible so that only the text displays, select the Object Appearance
tab. Make sure a background color is not selected, and set the Line > Width field to 0.

6. (Optional) You can resize the object by clicking and dragging any of the points around its
edge.

7. Click to save your work.
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Aligning Text
After you add text to an object, you can easily align the text within the object.

How to Align Text
1. Open the frame.

2. Select the object containing the text.

3. Select the Home ribbon and choose one of the following:

Aligns the text along the left edge of the object.

Aligns the text vertically at the center point of the object.

Aligns the text along the right edge of the object.

Aligns the text at the top edge of the object.

Aligns the text horizontally at the middle point of the object.

Aligns the text at the bottom edge of the object.

4. Click to save your work.

CHAPTER 5  139



Editing Text
After you add text to an object, you can edit it as necessary.

How to Edit Text
1. Open the frame containing the object with text that you want to edit.

2. Do any of the following:

TO CHANGE THE CONTENT

a. Do one of the following, depending on the part of the user interface you are using:

n Keyboard Shortcut Press F2 to highlight the existing text. Click the highlighted
text to place the cursor in the text area.

n Double-Click Double-click the object. In the Object Properties window pane,
expand the Text section.

b. Edit the text as needed.

TO CHANGE THE FORMATTING

You can change the font properties of any text on your object. See "Setting Font Properties
for Text" on the next page.

a. Select the object.

b. Select the Home ribbon. The Text section contains all of the text formatting options.

c. Edit the text as necessary. You can use the buttons and drop-downs in the Home
ribbon's Text section to apply bold, italic, or underline formatting to any part of the text.
You can also change the color, font, and size of the text.

3. Click to save your work.
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Setting Font Properties for Text
After you add text to an object, you can adjust the font properties (e.g., font size, color) by using the
Text section in the Home ribbon. In the Object Properties window pane, you can change the text
itself.

After you add text to an object, you can adjust the font properties (e.g., font size, color).
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How to Set Font Properties
1. Do one of the following, depending on the part of the user interface you are using:

n Keyboard Shortcut Press F2 to highlight the text, then click the highlighted text to place
the cursor in the text area.

n Double-Click Double-click the object. In the Object Properties window pane, expand the
Text section.

2. Select the text to which you want to apply the formatting changes.

3. Select the Home ribbon and make changes using any of the options:

Click this button to apply bold to the selected text.

Click this button to apply italics to the selected text.

Click this button to underline the selected text.

Click this button to remove the formatting from the selected
text.
Click the down arrow to choose a color to apply to the
selected text. To see advanced color options, select More
colors.

Choose the font family for the selected text.

Choose a font size for the selected text.

4. Click to save your work.

CHAPTER 5  142



Pinning Fonts
You can pin your favorite fonts so they will appear at the top of the list. This makes them easier to
find later. Pinned fonts appear in a group that you can expand or collapse. This is a way to limit the
list of fonts to those that you use the most and hide from view those that you do not use.

How to Pin Fonts From the Font Family Field
1. Select the Home ribbon and click the down arrow in the Font Family field.

2. Hover over the font you want to pin. A pin appears to the right of the font.

3. To pin the font to the Font Family field, click . The pin changes to to show that the font
has been pinned to the font list. Pinned fonts are also added to the Pinned Fonts group at the
top of the Font Family field.
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4. To unpin the font, click the pin again and it will be moved back to All Fonts group at the
bottom of the list.
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CHAPTER 6

Variables
Variables are brief, non-formatted pieces of content (such as the name of your company’s product
or phone number) that can be edited in one place but used in many places. A variable has two main
components—the variable name and the variable definition. When you insert a variable, the user
sees the variable definition in the output. If you later need to modify the definition of a variable, you
only need to change it in one place and the change is made automatically everywhere that the
variable is inserted.

This chapter discusses the following:

Creating Variables 146

Editing Variables 148

Inserting Variables Into Objects 150

Linking to Flare Projects 152
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Creating Variables
In MadCap Mimic, you can create variables for collections (in which case the variables are available
to all movies within that collection) or for single movies (in which case the variables are available
only for that movie).

How to Create a Variable for a Collection
1. Open the collection. The Collection Editor opens.

2. Select the Variables tab.

3. To enter a new name, definition, or comment for a new variable, click in the appropriate cell.
Then press F2 on your keyboard and type the name, definition, or comment. Press ENTER
after you finish typing. As soon as you begin typing in one of the cells, a new blank row is
added in the editor (to be used for the next variable that you create).

4. Click to save your work.
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How to Create a Variable for a Standalone
Movie

1. Open the movie.

2. Select Movie > Properties.

The Movie Properties dialog opens.

3. Select the Variables tab.

4. To enter a new name, definition, or comment for a new variable, click in the appropriate cell.
Then press F2 on your keyboard and type the name, definition, or comment. Press ENTER
after you finish typing. As soon as you begin typing in one of the cells, a new blank row is
added in the tab (to be used for the next variable that you create).

5. Click OK.

6. Click to save your work.
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Editing Variables
After you create a variable, you can easily edit it in the Collection Editor or Movie Properties dialog
(depending on whether you created the variable for a collection or a movie). If you change the
definition for a variable that has already been inserted into objects, the changes will automatically
be reflected wherever that variable has been inserted.

How to Edit a Variable for a Collection
1. Open the collection. The Collection Editor opens.

2. Select the Variables tab.

3. Click in a cell that you want to edit, then press F2 on your keyboard and type the name,
definition, or comment.

4. Click to save your work.

How to Edit a Variable for a Standalone Movie
1. Open the movie.

2. Select Movie > Properties.

The Movie Properties dialog opens.

3. Select the Variables tab.

4. Click in a cell that you want to edit, then press F2 on your keyboard and type the name,
definition, or comment.

5. Click OK.

6. Click to save your work.
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What’s Noteworthy?

NOTE If you have linked to a Flare project, you cannot change the definitions for the
variables from that project. However, you can change the definitions for variables that you
create in Mimic. If you want to edit a variable from a Flare project, you need to do so from
within Flare.
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Inserting Variables Into Objects
After you create variables or link to existing variables in a MadCap Flare project, you can insert
them into most objects that can be added to a frame (e.g., callouts, rectangles).

How to Insert a Variable Into an Object
1. Open the movie.

2. Open the frame containing the object into which you want to insert the variable.

3. Click the object. In the Object Properties window pane, expand the Text section.

4. Place your cursor at the location in the pop-up window or tab where you want to add a
variable (e.g., before, between, or after any text you have typed).

5. In the Text section, click the Insert a Variable button

The Variables dialog opens, with the variable sets (e.g., Movie, Collection, System, or name of
variable set from Flare project) on the left and the variables associated with the selected set
on the right.

6. Select the appropriate variable set.

n Movie Variables These are variables that you create for a specific movie in MadCap
Mimic. A movie variable is available only for the movie for which it was created. For
more, see "Creating Variables" on page 146.

n Collection Variables These are variables that you create for a specific collection in
MadCap Mimic. A collection variable is available for all movies in that collection. See
"Creating Variables" on page 146.

n System Variables These are variables provided by MadCap Mimic, such as variables for
your system date and time. Also provided are system variables designed to display
specific information about your movies and the frames within them. For example, if you
insert the system variable called "NextFrameName," the output will display the name of
the next frame in the movie (as long as you have entered a name for it in the Frame
Properties window pane).
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n Project Link Variables These are variables that were created in a MadCap Flare project,
which has been linked to a MadCap Mimic movie or collection. Therefore, any variables
in that Flare project can also be used in your MadCap Mimic movie or collection. See
"Linking to Flare Projects" on the next page.

7. Select the variable you want to add.

8. Click OK.

The variable syntax is added to the Text section of the Object Properties window pane.

EXAMPLE

Let's say you insert a variable called "PhoneNumber" from a variable set that is
named "MyVariables." In this case, you will see something like this:

9. Click to save your work.
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Linking to Flare Projects
You can link your Mimic collection or movie to a MadCap Flare project. This lets you automatically
have access to any variables or condition tags found in that Flare project. See "Variables" on page
145 and "Conditions" on page 291.

This link occurs automatically if you insert the Mimic collection or movie into the Flare project.
However, if you have not done that, you can use the following steps to manually link a MadCap
Mimic collection or standalone movie to a Flare project.

EXAMPLE — Links to Flare Variables

Let's say that you have created a MadCap collection containing five movies, and you have
incorporated this Mimic collection into a Flare Help project. You want to use the variables
from that Flare project. Therefore, you open the Collection Editor in Mimic and create a
variable link to the Flare project (using the Project Link tab). All of the variables from that
Flare project automatically become available for you to use in your MadCap Mimic
collection (i.e., they are project link variables). Suppose that you want to use a variable
called "ProductName" in your MadCap Mimic movies. The definition that you have provided
for that variable name in Flare is "OurSoftware Version 1." So in various movie frames in
your MadCap Mimic collection, you might create bubble callouts and select the
ProductName variable to insert within them. The callouts now display any text you may
have typed, plus the definition of the variable (e.g., "Welcome to OurSoftware Version 1").

Now let's say that it is a year later and your company has created another version of the
software, called "OurSoftware Version 2." You need to change this name everywhere in your
Flare project, as well as everywhere it has been used in your MadCap Mimic movies. If you
had not used a variable, you would need to manually find and replace the old name with the
new name. Fortunately, you used a variable, so all you need to do is change the definition in
one place. If you had created the variable within MadCap Mimic, you would edit the
definition in Mimic's Collection Editor (or in the Movie Properties dialog). However, in this
example, you used a variable from your Flare project. Therefore, you would modify the
variable definition from within the Flare project. After you do so, the definition is changed
everywhere that the variable was inserted (including within the callouts in your movies).
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How to Link a Mimic Collection to a Flare
Project

1. Open the collection. The Collection Editor opens.

2. Select the Project Link tab.

3. Click the Browse button .

4. In the dialog that opens, double-click the Flare project you want to link to the collection.

5. Click to save your work.

How to Link a Mimic Movie to a Flare Project
1. Open the movie.

2. Select Movie > Properties.

The Movie Properties dialog opens.

3. Select the Project tab.

4. Click the Browse button .

5. In the dialog that opens, double-click the Flare project you want to link to the movie.

6. In the Movie Properties dialog, click OK.

7. Click to save your work.
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What’s Noteworthy?

NOTE If you link from a MadCap Mimic collection, all of the variables and conditions in the
Flare project will be available to all movies in that Mimic collection. If you link from a
standalone movie, all of the variables and conditions in the Flare project will be available for
only that movie.

NOTE After you link a Flare project to your movie or collection, you can select the newly
linked condition tags or variable sets (for example, the "Default" condition tag set or the
"System" variable set) in the Properties pane or when using the Variables dialog. By default,
Mimic uses the "Movie" condition and variable sets.

If you link a movie or collection to a Flare project and you don't see your linked condition
and variable sets, you may need to close the movie or collection and reopen it to refresh the
available sets.
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CHAPTER 7

Keyframes
Keyframes indicate points within a frame where an object or clip effect will transition from its
current state to a new state. In other words, whenever a keyframe transition happens, the object or
clip effect properties change. Because of this, you can create simple animations, such as a
"bouncing" oval.

This chapter discusses the following:

Keyframe Characteristics 156

Adding Keyframes 157

Editing Keyframes 178

Moving Keyframes 189

Removing Keyframes 191
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Keyframe Characteristics
You can tell that an object or clip effect contains keyframes by looking in the Frame View and
Action View options in the Timeline window pane. If a keyframe type bar containing one or more
diamonds is nested below an object or a clip effect, it contains keyframes.

Additionally, when you add an object that contains keyframes to a palette, it retains the keyframes.
If that object has a clip effect applied to it and that clip effect contains keyframes, they will also
carry over to the palette.

Depending on the object you have selected, keyframes allow many transitions, including:

n Background The object's background color changes.

n Opacity The object's transparency changes.

n Position The object or effect area moves directionally on the frame.

n Size The object or effect area can become larger or smaller.

n Rotation The object rotates, in any direction, on the frame.

n Text Text on the object changes, including what is actually typed, font type, font formatting,
and the position of the text on the object.
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Adding Keyframes
Whenever you add an object to a frame, you have the option to set up keyframes. Additionally, you
can set some types of keyframes on clip effects that have been applied to objects. When viewing
the Object or Effect Properties window pane, object and clip effect attributes (e.g., size, position)
that can include keyframes are indicated by a yellow diamond button . Objects and clip effects
can include more than one keyframe type.

How to Add Keyframes to Objects
1. Open a movie that contains objects, or add an object to a frame.

2. Double-click the object. The Object Properties window pane opens.

3. In the Timeline window pane (View > Timeline), do one of the following:

n For all standard object types, click Frame View. Any action objects converted to objects
will also be in this view.

n For action object types, click Action View. Any objects converted to action objects will
also be in this view.

4. Add one of the following keyframe types:

OPACITY

Altering the object opacity within keyframes can make an object appear to fade in or out of a
frame.

a. In the Object Properties window pane, expand the Object Appearance section.

b. Drag the Opacity slider to the level of transparency that you want the object to start at.
For example, if you pick 100%, the object will start out with a completely opaque look.

c. From beside the Opacity slider, click .
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In the Timeline, an opacity keyframe bar will nest under the object.

d. In the Timeline, drag the playhead to the point of time when the first opacity transition
should begin.

e. Drag the Opacity slider to the desired percentage.

Once you select the desired opacity, a new keyframe will automatically appear in the
opacity keyframe bar. You do not need to click again.

f. (Optional) Repeat steps d and e as needed.

TIP If you want to make an object gradually go from 0-100% opacity (or the other
way around), you really only have to set two keyframes. Set the first one at the
beginning of the object, then set the final state at the very end of the object. The
object is automatically set to have a linear interpolation, so the transition will happen
gradually over the duration of the object's time span.

COLOR

A timed, subtle change to an object's color can redirect attention to that object when the
transition begins.

a. In the Object Properties window pane, expand the Object Appearance section.

b. In the Background section, set the starting color (solid will have one color field, gradient
will have two) for the object. To see advanced color options, select . You can also
click to pick a color from your screen.

c. From beside the color field (first color field if you are using a gradient), click .

In the Timeline, a background keyframe bar will nest under the object.

d. In the Timeline, drag the playhead to the point of time when the first color transition
should begin.
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e. In the Background section, set the next color (solid will have one color field, gradient
will have two) for the object.

Once you select the desired color, a new keyframe will automatically appear in the
background keyframe bar. You do not need to click again.

f. (Optional) Repeat steps d and e to add more background color keyframes.

TIP If you want a gradient to display for one or more keyframes but want a solid
color for the rest of the object's keyframes, choose one of the gradient background
types for the object. For the keyframes you want to remain solid, pick the same color
for both gradient fields.

POSITION

When you create keyframes in order to move the position of an object, a trajectory is
automatically shown in the Frame Editor. Each movement point is indicated by a blue circle
on the trajectory's dotted line.

a. In the Object Properties window pane, expand the Object Layout section.

b. Manually set the starting position of the object by dragging it to the desired location in
the Frame Editor, or set it using the Position fields in the Object Properties window
pane:

i. In the first Position field, select the starting horizontal position for the object.
Increase the number to move the object to the right, or decrease the number to
move the object to the left.

ii. In the second Position field, select the starting vertical position for the object.
increase the number to move the object down, or decrease the number to move
the object up.

c. From beside the Position fields, click .
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In the Timeline, a position keyframe bar will nest under the object. Additionally, a small
blue circle will appear beside the object in the Frame Editor. As you add position
keyframes, these circles will represent each new position, and a dotted path will form
between them, showing you the object motion.

d. In the Timeline, drag the playhead to the point of time when the first position transition
should begin.

e. Manually set the starting position of the object by dragging it to the desired location in
the Frame Editor, or set it using the Position fields in the Object Properties window
pane:

i. In the first Position field, select the next horizontal position for the object.
Increase the number to move the object to the right, or decrease the number to
move the object to the left.

ii. In the second Position field, select the next vertical position for the object.
increase the number to move the object down, or decrease the number to move
the object up.

Once you set one of the positions, a new keyframe will automatically appear in
the position keyframe bar. You do not need to click again.

f. (Optional) Repeat step d and e to continue adding position keyframes.

SIZE

You might want to show an object becoming smaller to accommodate other objects taking
over the focal point of the frame.

a. In the Object Properties window pane, expand the Object Layout section.

b. Manually set the starting size of the object by clicking and dragging the small blue
handles on the object, or set it using the Size fields in the Object Layout section:
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i. In the first Size field, increase the number to add width, or decrease the number
to shrink the width to set the starting size of object.

ii. In the second Size field, increase the number to add length, or decrease the
number to shorten the object to set the starting size of object.

c. From beside the Size fields, click .

In the Timeline, a size keyframe bar will nest under the object.

d. In the Timeline, drag the playhead to the point of time when the first size transition
should begin.

e. Manually set the next size of the object by clicking and dragging the small blue handles
around the object, or set it using the Size fields in the Object Layout section:

i. In the first Size field, select the next width for the object.

ii. In the second Size field, select the next height for the object.

Once you resize the object, a new keyframe will automatically appear in the size
keyframe bar. You do not need to click again.

f. (Optional) Repeat steps e-g to continue adding size keyframes.

NOTE Size keyframes are not available for arrows, bubbles, polygons, and polylines.

ROTATION

Rotating an object on the frame will create a spinning effect.
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a. In the Object Properties window pane, expand the Object Layout section.

b. Rotate the object by clicking and dragging the large blue handle on the object, or by
changing the number in the Rotation field to set the starting look for the object.

c. From beside the Rotation field, click .

In the Timeline, the Rotation keyframe bar will nest under the object.

d. In the Timeline, drag the playhead to the point of time when the first rotation transition
should begin.

e. Rotate the object by clicking and dragging the large blue handle on the object, or by
changing the number in the Rotation field.

Once you change the rotation, a new keyframe will automatically appear in the Rotation
keyframe bar. You do not need to click again.

f. (Optional) Repeat steps d and e to create adding rotation keyframes.

TEXT

Changing the text on an object lets you reuse that object.

a. In the Object Properties window pane, expand the Text section.

b. Click on the object and start typing, or in the Text field, enter the starting text for the
object.

c. From beside the Text field, click .

In the Timeline, the Text keyframe bar will nest under the object.

d. In the Timeline, drag the playhead to the point of time when the first text transition
should begin.

CHAPTER 7  162



e. Click on the object and start typing, or in the Text field, enter the next text you want the
object to show.

Once you change the contents of the Text field, a new keyframe will automatically
appear in the Text keyframe bar. You do not need to click again.

f. (Optional) Repeat steps d and e to continue adding text keyframes.

NOTE All objects do not have the same keyframe options. For example, cursor
objects do not have a rotation property.

5. Continue adding keyframes as needed.

6. Click to save your work.
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How to Add Keyframes to Clip Effects
You can apply keyframes to clip effects.

1. Open a movie that contains an object to which a clip effect has been applied.

2. In the Timeline window pane (View > Timeline), do one of the following:

n For all standard object types, click Frame View. Any action objects converted to objects
will also be in this view.

n For action object types, click Action View. Any objects converted to action objects will
also be in this view.

3. In the Timeline, right-click the effect bar and select Properties.

The Effect Properties window pane opens.

4. Add one of the following keyframe types:

POSITION

When you create keyframes in order to move the position of a clip effect, a trajectory is
automatically shown in the Frame Editor. Each movement point is indicated by a blue circle
on the trajectory's dotted line.

a. In the Effect Properties window pane, expand the Object Layout section.

b. Manually set the starting position of the clip effect area by dragging the red effect
frame to the desired location in the Frame Editor, or set it using the Position fields in
the Effect Properties window pane:

i. In the first Position field, select the starting horizontal position for the effect area.
Increase the number to move the effect area to the right, or decrease the number
to move the effect area to the left.

ii. In the second Position field, select the starting vertical position for the effect
area. increase the number to move the effect area down, or decrease the number
to move the effect area up.
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c. From beside the Position fields, click .

In the Timeline, a position keyframe bar will nest under the effect bar. Additionally, a
small blue circle will appear beside the red effect frame in the Frame Editor. As you add
position keyframes, these circles will represent each new position, and a dotted path
will form between them, showing you the effect area motion.

d. In the Timeline, drag the playhead to the point of time when the first position transition
should begin.

e. Manually set the starting position of the effect area by dragging the red effect area
frame to the desired location in the Frame Editor, or set it using the Position fields in
the Effect Properties window pane:

i. In the first Position field, select the next horizontal position for the effect area.
Increase the number to move the effect area to the right, or decrease the number
to move the effect area to the left.

ii. In the second Position field, select the next vertical position for the effect area.
increase the number to move the effect area down, or decrease the number to
move the effect area up.

Once you set one of the positions, a new keyframe will automatically appear in
the position keyframe bar. You do not need to click again.

f. (Optional) Repeat step d and e to continue adding position keyframes.

SIZE

You might want an effect area to increase to create the feeling of a big reveal, or decrease to
closing in on important information.

a. In the Effect Properties window pane, expand the Object Layout section.

b. Manually set the starting size of the object by clicking and dragging the red effect area
frame, or set it using the Size fields in the Object Layout section:
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i. In the first Size field, increase the number to add width, or decrease the number
to shrink the width to set the starting size of the effect area.

ii. In the second Size field, increase the number to add length, or decrease the
number to shorten the height to set the starting size of the effect area.

c. From beside the Size fields, click .

In the Timeline, the Size keyframe bar will nest under the effect bar.

d. In the Timeline, drag the playhead to the point of time when the first size transition
should begin.

e. Manually set the next size of the effect area by clicking and dragging the red effect area
frame, or set it using the Size fields in the Object Layout section:

i. In the first Size field, select the next width for the effect area.

ii. In the second Size field, select the next height for the effect area.

Once you resize the effect area, a new keyframe will automatically appear in the
size keyframe bar. You do not need to click again.

f. (Optional) Repeat steps e-g to continue adding size keyframes.

5. Continue adding keyframes as needed.

6. Click to save your work.
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EXAMPLE

This frame contains a black rectangle object. Right now, the object is opaque. However, we
want it to change between black and white during the course of the frame. To do this, we
will add a series of background keyframes by using the Keyframe button in the Object
Properties window pane.
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When the object is at the starting point of the transition—in other words, when we first want
the object to change color—click the keyframe button next to the Color property in the
Object Properties window pane. Once the first keyframe has been added, the background
keyframe type bar is added to the object. Each keyframe is indicated by diamond on the
keyframe type bar.
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For each new color setting, drag the playhead to the time at which the object should
change color, then select a new color from the Object Appearance section in the Object
Properties window pane. A new keyframe diamond is automatically added to the Timeline.
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Additionally, you can set an interpolation option when creating keyframes. This changes
the type of transition between each keyframe. To do this, click the keyframe diamond, then
select an option from the Interpolation drop-down in the Keyframe Properties window pane.
In this case, you can pick linear or discrete interpolation. A linear interpolation causes a
gradual fade between each color, while a discrete interpolation causes a distinct change
between the colors precisely when the keyframe is reached.
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EXAMPLE

This frame contains an oval object to which a clip effect has been applied. Right now, the
effect covers the entire object, so you can see the entire oval. However, we want the effect
to gradually move off the oval, so the oval disappears from the frame. To do this, we can
add a series of position keyframes by using the Keyframe button in the Effect Properties
window pane.
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When the object is at the starting point of the effect, in other words, when the entire oval is
contained in the clip effect area rectangle, click the position keyframe button. Once the first
keyframe has been added, the position keyframe type bar is added to the clip effect bar,
and each keyframe is indicated by diamond on the keyframe type bar. Additionally, a blue
trajectory dot is added to the frame to indicate the current location of the effect.
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For each position, drag the playhead to the time at which the effect should move, then drag
the effect rectangle to the right of the oval. A new keyframe diamond is automatically
added to the Timeline, and the trajectory updates.
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Continue to add position keyframes until the entire oval has disappeared.
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What’s Noteworthy?
TIP When applying position keyframes to an object or effect, the position keyframe
location is placed at the upper left corner of the object. Depending on the type of path you
are drawing, you may want to slightly adjust the object's trajectory to account for the space
between the upper left corner of the object and the middle of the object.

For example, if you have a cursor object and you need it to "click" a button, you may want to
position the trajectory slightly above and to the left of the button, so it appears that the
cursor is in the middle of the button.

NOTE The "Snap to Keyframe" option below the Timeline window pane lets you precisely
move the playhead to a keyframe for an object. When this option is enabled and you drag
the playhead, it "snaps" like a magnet to the nearest keyframe. If you attempt to align the
playhead on a keyframe without this option, you might find that you are slightly off target.
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NOTE You can add size and position keyframes to clip effects. Clip is the only effect that
supports keyframes. Note that the opacity keyframe (which can be applied to any object) is
not the same as an opacity effect (which can only be applied to image objects).

NOTE If you set a shape's opacity to 0% (fully transparent), it will be hidden on the frame.
This lets you prevent users from clicking on or selecting a shape accidentally.

NOTE You can copy an object that contains keyframes to a different frame, and the
keyframes will be retained. However, if the new frame is shorter than the original frame,
some keyframes may not be played (because they occur after the frame has ended). If you
want all of the keyframes to play, you may need to move them to fit within the duration of
the new frame.

NOTE When you are creating another keyframe within the same object or clip effect and
keyframe type, you do not need to click the keyframe button again. Any keyframes added
after the first are automatically created when the property is changed.

NOTE If you want to change the way the keyframe transitions from one state to the next,
you will need to edit each keyframe. This includes editing the trajectory (position
keyframes). See "Editing Keyframes" on the next page.

NOTE If you add an object that contains keyframes to a palette, it will retain those
keyframes.
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Editing Keyframes
Once you have set a keyframe, you can easily edit it. This is particularly useful when you only want
to make minor adjustments to your existing keyframe. When you edit a keyframe, you gain access
to the interpolation property, or the way the object or clip effect transitions from one keyframe to
the next.

How to Edit Object Keyframes
1. Open a movie that contains one or more objects with keyframes.

2. In the Timeline window pane (View > Timeline), do one of the following:

n For all standard object types, click Frame View. Any action objects converted to objects
will also be in this view.

n For action object types, click Action View. Any objects converted to action objects will
also be in this view.

3. Scroll down to the object's desired keyframe bar (e.g., opacity, text).

4. Double-click on the keyframe (diamond) within the keyframe bar that corresponds to the
transition that you want to edit.

The Keyframe Properties window pane opens.

5. Do one of the following, depending on the type of keyframe:

TO CHANGE THE OPACITY

a. In the Keyframe Properties window pane, expand the Opacity Keyframe section.

b. In the Properties section, do one of the following:
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n Time Select a different time at which the keyframe will begin.

n Value Select a different percentage for the amount of opacity for this particular
keyframe.

n Interpolation Select one of the following:

l Linear Set a gradual change in opacity from this keyframe to the next.

l Discrete Set an instant change in opacity from this keyframe to the next.

TO CHANGE THE COLOR

A timed, subtle change to an object's background color can redirect attention to that object
when the transition begins.

a. In the Keyframe Properties window pane, expand the Gradient Keyframe section.

b. In the Properties section, do one of the following:

n Time Select a different time at which the keyframe will begin.

n Gradient Select a different color for the object for this particular keyframe. Click
the down arrow in the first field to select a color for the start of the gradient, or
the second field to select a color for the end of the gradient. If you want a solid
color, set both fields to the same color. To see advanced color options, select .
You can also click to pick a color from your screen.

n Interpolation Select one of the following:

l Linear Set a gradual change in color from this keyframe to the next.

l Discrete Set an instant change in color from this keyframe to the next.

TO CHANGE THE POSITION

You have more options for the trajectory when editing a position keyframe. Edit a position
keyframe to change the way the trajectory moves from one keyframe to the next (e.g., curved
path, straight path, no path).
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a. In the Keyframe Properties window pane, expand the Position Keyframe section.

b. In the Properties section, do one of the following:

n Time Select a different time for the keyframe to begin.

n Position Select a different position on the frame for the object for this keyframe.
The first field sets the horizontal position, and the second sets the vertical
position. You can also drag a position keyframe's corresponding trajectory point
in the Frame Editor to move it the object to a new position. This changes the
position numbers automatically.

n Interpolation Select one of the following:

l Linear Set a straight path from this keyframe to the next.

l Discrete Set an instant jump from this keyframe to the next. In other words,
the object will not move along a path; it will appear in one position, and then
the next.

l Bezier Set a curved path from this keyframe to the next. This opens two sets
of Control Point fields. The first control point set is for the length of the
control; the second field is for the position. This lets you customize the depth
of the trajectory's arc (first field) and the position of the trajectory's wave
(second field). As an alternative to using the Control Point fields, you can
manually click and drag the white control point handles in the Frame Editor to
change the path's arc and wave.

o Control Point 1 Controls the trajectory from this keyframe to the previous
keyframe. This control will not work on the first position keyframe as this
keyframe is the starting point.

o Control Point 2 Controls the trajectory between each keyframe.
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EXAMPLE

This rectangle has a linear trajectory. It will move smoothly along the
straight trajectory line.

This rectangle has a discrete trajectory. It will jump from one
trajectory point to the next.
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This rectangle has a bezier trajectory. It will move smoothly along a
curved line. You can adjust the control points (the white dots) to
change the shape of the curve between each keyframe.

TO CHANGE THE SIZE

You might want to show an object become smaller to accommodate other objects taking
over the focal point of the slide.

a. In the Keyframe Properties window pane, expand the Size Keyframe section.

b. In the Properties section, do one of the following:

n Time Select a different time at which the keyframe will begin.

n Size Select a different size for the object for this particular keyframe. The first
field sets the width, and the second field sets the height. Manually set the size of
the object for each keyframe by clicking and dragging the small blue handles on
the object.

n Interpolation Select one of the following:

l Linear Set a gradual change in size from this keyframe to the next.

l Discrete Set an instant change in size from this keyframe to the next.
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TO CHANGE THE ROTATION

Rotating an object on the frame will create a spinning effect.

a. In the Keyframe Properties window pane, expand the Rotation Keyframe section.

b. In the Properties section, do one of the following:

n Time Select a time at which the keyframe will begin.

n Value Select or enter a number for the amount of rotation. A negative number
turns the object counter-clockwise, while a positive number turns it clockwise.
Manually rotate the object by clicking and dragging the large blue handle on the
object.

n Interpolation Select one of the following:

l Linear Set a gradual change in rotation from this keyframe and the next.

l Discrete Set an instant change in rotation from this keyframe to the next.

TO CHANGE THE TEXT

Changing the text on an object lets you reuse that object.

a. In the Keyframe Properties window pane, expand the Text Keyframe section.

b. In the Properties section, do one of the following:

n Time Select a different time at which the keyframe will begin.

n Text In the text box, enter the text that will appear during the keyframe.

n Interpolation The interpolation between text keyframes is always discrete. One
keyframe's text is completely removed before the next keyframe's text appears
on the object. This prevents an overlapping of text between keyframes.

6. Click to save your work.
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How to Edit Clip Effect Keyframes
You can apply keyframes to clip effects. You can edit these keyframes at any time.

1. Open a movie that contains one or more objects to which clip effects with keyframes have
been applied.

2. In the Timeline window pane (View > Timeline), do one of the following:

n For all standard object types, click Frame View. Any action objects converted to objects
will also be in this view.

n For action object types, click Action View. Any objects converted to action objects will
also be in this view.

3. Scroll down to the effect's desired keyframe bar (e.g., position, size).

4. Double-click on the keyframe (diamond) within the keyframe bar that corresponds to the
transition that you want to edit.

The Keyframe Properties window pane opens.

5. Do one of the following, depending on the type of keyframe:

TO CHANGE THE POSITION

Changing a clip effect's position keyframe controls where the effect area is located on or
around the object.

a. In the Keyframe Properties window pane, expand the Position Keyframe section.

b. In the Properties section, do one of the following:

n Time Select a different time at which the keyframe will begin.

n Position Select a different position on the frame for the effect area for this
particular keyframe. The first field sets the horizontal position, and the second
field sets the vertical position. If you want to change the position of the effect
area manually, you can click and drag the red effect area frame to a new location.
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You can also drag a position keyframe's corresponding trajectory point in the
Frame Editor to move it the object to a new position.

n Interpolation Select one of the following:

l Linear Set a straight path from this keyframe to the next.

l Discrete Set an instant jump from this keyframe to the next. In other words,
the object will not move along a path, it will appear in one position, and then in
the next.

l Bezier Set a curved path from this keyframe to the next. Bezier also adds two
sets of Control Point fields. The first field of each control point set is for the
length of the control; the second field is for the position. This lets you
customize the depth of the trajectory's arc (first field) and the position of the
trajectory's wave (second field).

o Control Point 1 Controls the trajectory from this keyframe to the previous
keyframe. This control will not work on the first position keyframe as this
keyframe is the starting point.

o Control Point 2 Controls the trajectory from this keyframe to the next
keyframe.

TO CHANGE THE SIZE

You might want to show a clip effect become larger to cover an entire object.

a. In the Keyframe Properties window pane, expand the Size Keyframe section.

b. In the Properties section, do one of the following:

n Time Select a different time at which the keyframe will begin.

n Size Select a different size for effect area for this particular keyframe. The first
field sets the width, and the second field sets the height. Manually set the size of
the effect area for each keyframe by clicking and dragging the edges of the red
effect area frame.
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n Interpolation Select one of the following:

l Linear Set a gradual change in size from this keyframe to the next.

l Discrete Set an instant change in size from this keyframe to the next.

6. Click to save your work.

EXAMPLE

Let's say you have an oval that goes from red to blue to yellow. You want to change the red
state to a light blue.
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When you click on the first diamond that represents the red state, the Keyframe Properties
window pane opens, showing only the Gradient Keyframe properties.

Once you set the value field to a light blue color, you can preview your movie or save your
work.

What’s Noteworthy?

NOTE Each diamond within a keyframe type bar (e.g., the size bar) is treated separately. In
other words, if a size bar shows five diamonds, each of those diamonds represents an
individual keyframe. Editing one of those diamonds affects only that particular keyframe's
state. If you are trying to achieve a gradual increase in the size if your object or the object
effect, you will want to adjust the diamonds that follow the one you change.
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NOTE You can copy an object that contains keyframes to a different frame, and the
keyframes will be retained. However, if the new frame is shorter than the original frame,
some keyframes may not be played (because they occur after the frame has ended). If you
want all of the keyframes to play, you may need to move them to fit within the duration of
the new frame.

NOTE If you set a shape's opacity to 0% (fully transparent), it will be hidden on the frame.
This lets you prevent users from clicking on or selecting a shape accidentally.

NOTE The "Snap to Keyframe" option below the Timeline window pane lets you precisely
move the playhead to a keyframe for an object. When this option is enabled and you drag
the playhead, it "snaps" like a magnet to the nearest keyframe. If you attempt to align the
playhead on a keyframe without this option, you might find that you are slightly off target.
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Moving Keyframes
For all object keyframe types, you can move individual keyframes to new locations in the timeline
by using the Object Properties window pane or the Timeline window pane. You also have the option
to move position keyframes manually in the Frame Editor.

How to Move Keyframes
1. Open the movie.

2. Do one of the following:

TO MOVE INDIVIDUAL KEYFRAMES IN THE KEYFRAME PROPERTIES WINDOW
PANE

a. In the Frame Editor, click an object that contains one or more keyframes.

b. In the Timeline window pane (View > Timeline), do one of the following:

n For all standard object types, click Frame View. Any action objects converted to
objects will also be in this view.

n For action object types, click Action View. Any objects converted to action
objects will also be in this view.

c. Scroll down to the object's keyframe bar (e.g., opacity, text).

d. Click on a keyframe (diamond) within the keyframe bar.

The Keyframe Properties window pane opens.

e. In the Keyframe Properties window pane, set the Time field to a new point in time at
which the object will change to this state.
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TO MOVE INDIVIDUAL KEYFRAMES IN THE TIMELINE WINDOW PANE

a. In the Frame Editor, click on an object that contains one or more keyframes.

b. In the Timeline window pane (View > Timeline), do one of the following:

n For all standard object types, click Frame View. Any action objects converted to
objects will also be in this view.

n For action object types, click Action View. Any objects converted to action
objects will also be in this view.

c. Scroll down to the object's keyframe bar (e.g., opacity, text).

d. Click on a keyframe (diamond) within the keyframe bar.

e. Drag the keyframe to a new location in the keyframe bar.

TO MOVE POSITION KEYFRAMES IN THE FRAME EDITOR

a. Click on an object that contains one or more position keyframes.

A trajectory (blue dotted path) appears near the object.

b. Click on a point (larger blue circle) within the trajectory.

c. Drag the point to a new place in the Frame Editor.

3. Click to save your work.

TIP If you resize an object bar, the keyframes associated with that object do not
automatically adjust to reflect the object bar's new size. As a result, some keyframes may
play before or after the object's start or end time, and will not appear in the output.
Remember to check your keyframes when adjusting your object timing.
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Removing Keyframes
You can remove a single keyframe manually in the Timeline window pane. Single position keyframe
trajectory points can also be removed in the Frame Editor. Additionally, you can remove entire
keyframe type bars.

How to Remove Individual Keyframes in the
Timeline

1. Open the movie.

2. In the Timeline window pane (View > Timeline), do one of the following:

n For all standard object types, click Frame View. Any action objects converted to objects
will also be in this view.

n For action object types, click Action View. Any objects converted to action objects will
also be in this view.

3. Scroll down to the object or effect's keyframe bar (e.g., size, position).

4. Click on a keyframe (diamond) within the keyframe bar.

5. Do one of the following:

n Press the DELETE key.

n Right-click on the diamond and select Delete.

6. Click to save your work.
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How to Remove Individual Position Keyframes
in the Frame Editor

1. Open the movie.

2. Click the object (in the Frame Editor or the Timeline) or clip effect (in the Timeline) that
contains position keyframes.

A blue trajectory appears in the Frame Editor.

3. Click on a circular blue point within the trajectory.

The selected point will change to yellow.

4. Do one of the following:

n Press the DELETE key.

n Right-click on the point and select Delete.

5. Click to save your work.
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How to Remove Keyframe Type Bars From an
Object

1. Open the movie.

2. In the Timeline window pane (View > Timeline), do one of the following:

n For all standard object types, click Frame View. Any action objects converted to objects
will also be in this view.

n For action object types, click Action View. Any objects converted to action objects will
also be in this view.

3. Scroll down to the object or clip effect's keyframe bar (e.g., size, position).

4. Click and drag your mouse over all of the keyframes in the bar.

Each keyframe diamond changes to yellow.

5. Press the DELETE key.

6. Click to save your work.
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CHAPTER 8

Timing
You can control the amount of time each frame or object displays in the movie (i.e., its timing).

This chapter discusses the following:

Setting Timing for Frames 195

Setting Timing for Objects 198
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Setting Timing for Frames
You can set the timing for frames in a couple of ways.

How to Set the Timing for a Frame in the
Timeline Window Pane

1. Open the frame.

2. Open the Timeline window pane. Do one of the following, depending on the part of the user
interface you are using:

n Ribbon Select View > Timeline.

n Keyboard Shortcut Press CTRL+T on the keyboard.

The Timeline window pane opens.

3. In the Timeline window pane, click Movie View.

4. Click on the right edge that represents the end of the frame and drag it to the left or right to
decrease or increase the timing of the frame. The tick marks at the top of the Timeline
window pane can be used to find the correct end time.
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NOTE If you cannot see the right edge of the frame, you can click at the bottom of
the window pane to decrease the scale.

5. Click to save your work.
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How to Set the Timing for a Frame in the Frame
Properties Window Pane

1. Open the frame.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Frame > Properties.

n Right-Click Right-click the frame and select Properties.

n Double-Click In the Frame Editor, double-click the frame.

The Frame Properties window pane opens.

3. Expand the Frame Transition section.

4. Change the settings in the Time Span section:

n Frame Duration Enter the number of seconds to display the frame.

n Pause movie at end of frame Click this check box to pause the display time. If the box
contains a check, the timing is disabled (i.e., paused). Why would you pause the timing
for a frame? Let's say that you add a button to the frame and you do not want the frame
to finish displaying until the user clicks the button. In this case, you would pause the
movie.

5. Click to save your work.
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Setting Timing for Objects
Not only can you control the timing of frames, but you can also do the same for individual objects
within frames by using the Object Properties window pane or the Timeline window pane. You can
specify the start time of the object as well as how long it plays. In the Timeline window pane, you
can visually arrange the timing and order of frame objects.

How to Set the Timing for an Object in the
Timeline Window Pane

1. Open the frame.

2. Open the Timeline window pane. Do one of the following, depending on the part of the user
interface you are using:

n Ribbon Select View > Timeline.

n Keyboard Shortcut Press CTRL+T on the keyboard.

The Timeline window pane opens.

3. In the Timeline window pane, click Frame View.

4. Click at the beginning or end of an object bar and drag it to the right or the left. You can drag
the left edge of an object to determine its starting point, and the left edge to set its ending
point. In this example, the Timeline window pane shows that there are five objects in the
frame.
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n The first object is a callout that starts playing at the beginning of the frame and plays to
the end of the frame.

n The second object is a cursor that starts playing at the beginning of the frame and
stops after 2 seconds.

n The third object is a rectangle that plays for 2 seconds, starting at 1 second in and
stopping at the end of the frame.

n The fourth object is a polyline that starts playing at the beginning of the frame and
plays to the end of the frame.

n The final object is another rectangle shape that plays for 1.5 seconds, beginning 1
second after the start of the frame and ending .5 seconds before the end of the frame.

NOTE Mimic's live preview only displays the objects present at that point on the
timeline. So in the example above, if the timeline scrubber is at .5 seconds, you would
see the bubble, cursor, and polyline. The two rectangles would not appear until the
scrubber hit the 1 second mark.

NOTE If you cannot drag the object bar in the timeline, you may need to select the
Time Span check box in the Object Properties window pane.

5. Click to save your work.
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How to Set the Timing for an Object in the
Object Properties Window Pane

1. Open the frame.

2. In the Frame Editor, double-click the object whose timing you want to set.

The Object Properties window pane opens.

3. Expand the General section.

4. Change the settings in any of the following fields.

n Time Span If you want the object to be displayed for a specific period of time, leave the
check mark in this box. If you want to disable timing for the object, click this check box
to remove the check mark. Disabling the timing is useful if you want to ensure that the
object continues to display as long as the frame does.

n Start Enter the number of seconds after the start of the frame that you would like the
object to first be displayed. If you want the object to display from the very start of the
frame, leave 0 in this field.

n Duration Enter the number of seconds you would like the object to be displayed in the
frame.

5. Click to save your work.

What’s Noteworthy?
TIP If you resize an object bar, the keyframes associated with that object do not
automatically adjust to reflect the object bar's new size. As a result, some keyframes may
play before or after the object's start or end time, and will not appear in the output.
Remember to check your keyframes when adjusting your object timing.
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CHAPTER 9

Transitions
You can control the way that frames come into view and leave from view (transitions).

This chapter discusses the following:

Setting Transitions for Movies 202

Setting Transitions for Frames 204

CHAPTER 9  201



Setting Transitions for Movies
For all frames in a movie, you can adjust the transitions (i.e., the manner in which the frames come
into view and leave from view). For example, you can specify that frames should transition via fade,
push, or slide.

How to Set the Transition for All Frames in a
Movie

1. Open the movie.

2. Select the Movie ribbon. In the Properties section, select Properties.

The Movie Properties dialog opens.

3. Select the Transition tab.

4. Change the settings in any of the following fields.

n Transition Effect Select the effect to be used when the frames transition at the
beginning and end of their play time. (Use the preview area to see how each effect
looks.)

NOTE If any individual frames have "default" set as the transition in the Frame
Properties window pane, those frames will use the transition specified in this
tab.

n Effect Properties Select this button to open the Effect Properties dialog, which lets you
provide settings for the selected transition effect (e.g., duration and direction).

l Duration Enter the number of seconds that you want the effect to be displayed.

l Direction Select the direction that you want the effect to move.
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5. Click OK.

6. Click to save your work.
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Setting Transitions for Frames
For individual frames in a movie, you can adjust the transition (i.e., the manner in which the frame
comes into view and leaves from view). For example, you can specify that a frame should transition
via fade, push, or slide.

How to Set the Transition for a Frame
1. Open the frame.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Frame > Properties.

n Right-Click Right-click the frame and select Properties.

n Double-Click In the Frame Editor, double-click the frame.

The Frame Properties window pane opens.

3. Expand the Frame Transition section.

4. Change the settings in the Transition section:

n Effect Select the effect to be used when the frame transitions at the beginning and end
of its play time.

n Duration Enter the number of seconds that you want the effect to be displayed.

n Direction Select the direction that you want the effect to move.

5. Click to save your work.
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CHAPTER 10

Audio
You can incorporate audio into movies in various ways.

This chapter discusses the following:

Selecting the Audio Input Source 206

Adding Audio to Movies 208

Adding Audio to Frames 210

Adding Audio to Cursors 212

Recording Audio 213

Looping Audio 220

Editing Audio Files 221

Enabling and Disabling Sound for Recording 224
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Selecting the Audio Input Source
You can record narration while shooting a movie.

How to Select the Audio Input Source
1. Select File > Recording Options.

NOTE You can also open this dialog by clicking at the bottom of the recording
area. 

2. In the Audio Input Source section, select one of the options. This field lists all of the audio
input sources found on your computer. Depending on the type of input source, you may need
to attach a microphone to your computer. Then, as you record a movie, you can speak into
the computer or microphone and this audio is automatically added to the movie frames.
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You can also enable or disable the microphone from the recording task bar.

3. Click OK.

NOTE As an alternative to narrating while you record a movie, you can add narration to the
movie after it has been recorded. See "Adding Audio to Movies" on the next page and
"Adding Audio to Frames" on page 210.
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Adding Audio to Movies
You can apply audio to an entire movie. This includes the ability to select built-in system sounds,
recorded audio, or imported files (such as MP3 and WAV files). For example, you might use this
feature to play music in the background of a movie.

How to Add Audio to a Movie
1. Open the movie.

2. Select Movie > Properties.

The Movie Properties dialog opens.

3. Select the Audio tab.

4. Click Enable Audio.

5. Select the audio file you want to use.

n [Previously Used Files] If you have applied audio to your Mimic movies previously, you
can select a previously used audio file from the Audio drop-down.

n Pick Built-In Sound This opens the Pick System Sound dialog. Select the system sound
from the list and click OK. (Optional: You can also listen to the sound of each effect by
clicking Play. If you choose Play on select, each sound is automatically played as you
click it in the list.)

n Pick From Movie Sound Library This opens the Manage Movie Sound Library dialog.
This dialog lists any audio files that you have imported to the movie previously. If you
want to use a sound from this library, select it in the list and click OK. (Optional: You can
also listen to the sound of each effect by clicking Play. If you choose Play on select,
each sound is automatically played as you click it in the list.)

n Import Into Sound Library In the Open dialog, locate and double-click an audio file (e.g.,
MP3, WAV) that you want to import.
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n Record a New Audio Clip This opens the Record dialog, which lets you record your own
audio file. You must have a microphone in order to record an audio file. After you finish
recording the audio, click OK in the Record dialog.

The audio file you select appears in the Audio field.

6. Click OK.

7. Click to save your work.

NOTE Audio added through the Movie Properties dialog is displayed as a Sound bar
in the Timeline window pane's Movie View option.

CHAPTER 10  209



Adding Audio to Frames
You can apply audio to individual frames in a movie. This includes the ability to select built-in
system sounds (such as applause or electronic beeping), recorded audio, or imported files (such as
MP3 and WAV files). For example, you might use this feature to play recorded narration in order to
help explain an action on a frame.

How to Add Audio to a Frame
1. Open the frame.

2. Double-click the frame. The Frame Properties window pane opens.

3. Expand the Frame Sound section.

4. Click Enable Audio.

5. Click one of the following.

n Pick Built-In Sound This opens the Pick System Sound dialog. Select the system sound
from the list and click OK. (Optional: You can also listen to the sound of each effect by
clicking Play. If you choose Play on select, each sound is automatically played as you
click it in the list.)

n Pick From Movie Sound Library This opens the Manage Movie Sound Library dialog.
This dialog lists any audio files that you have imported to the movie previously. If you
want to use a sound from this library, select it in the list and click OK. (Optional: You can
also listen to the sound of each effect by clicking Play. If you choose Play on select,
each sound is automatically played as you click it in the list.)

n Import Into Sound Library In the Open dialog, locate and double-click an audio file (e.g.,
MP3, WAV) that you want to import.

n Record a New Audio Clip This opens the Record dialog, which lets you record your own
audio file. You must have a microphone in order to record an audio file. After you finish
recording the audio, click OK in the Record dialog.

6. (Optional) If you want the audio file to restart from the beginning each time it finishes, select
Loop Sound.
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7. (Optional) If you want to limit this frame to play only the sound you have indicated, select
Stop Sound of Previous Frame. As long as this option is checked, any sounds on the previous
frame will end as soon as the movie continues to this frame.

8. Click to save your work.

NOTE Audio added through the Frame Properties window pane is displayed as a
Frame Sound bar in the Timeline window pane's Frame View option.
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Adding Audio to Cursors
You can apply audio to cursors in a frame. This includes the ability to select built-in system sounds,
recorded audio, or imported files (such as MP3 and WAV files). For example, you might use this
feature to apply a double-click sound to a cursor object.

How to Add Audio to a Cursor
1. Open the frame.

2. Double-click the cursor or input box to which you want to add audio. The Object Properties
window pane opens.

3. Expand the Audio section.

4. Click Enable Audio.

5. Click one of the following:

n Pick Built-In Sound This opens the Pick System Sound dialog. Select the system sound
from the list and click OK. (Optional: You can also listen to the sound of each effect by
clicking Play. If you choose Play on select, each sound is automatically played as you
click it in the list.)

n Pick From Movie Sound Library This opens the Manage Movie Sound Library dialog.
This dialog lists any audio files that you have imported to the movie previously. If you
want to use a sound from this library, select it in the list and click OK. (Optional: You can
also listen to the sound of each effect by clicking Play. If you choose Play on select,
each sound is automatically played as you click it in the list.)

n Import Into Sound Library In the Open dialog, locate and double-click an audio file (e.g.,
MP3, WAV) that you want to import.

n Record a New Audio Clip This opens the Record dialog, which lets you record your own
audio file. You must have a microphone in order to record an audio file. After you finish
recording the audio, click OK in the Record dialog.

6. Click to save your work.
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Recording Audio
You can record audio for your Mimic movies (e.g., narration). The recorded audio file can be created
for an individual frame, cursors, or an entire movie. Steps for recording audio for existing movies,
frames, and objects are given below. You can also capture audio when recording a new movie or
new frames within a movie.

When you record audio in Mimic, it is stored as an MP3 file in a folder called "Sounds" where your
movie files are located.

For buttons, the audio file plays when the user clicks the button. For cursors, the audio file plays
when the cursor reaches the end of its trajectory.
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How to Record Audio for a Movie
1. Make sure a microphone is connected to your computer.

2. Open the movie.

3. Select Movie > Properties.

The Movie Properties dialog opens.

4. Select the Audio tab.

5. Click Enable Audio.

6. Click Record a New Audio Clip. The Record dialog opens.

7. Complete the options in the dialog.

n Encoding Frequency Select one of the frequency rates in kilohertz (kHz). The available
options are 44.100 kHz, 22.050 kHz, and 11.025 kHz. These options have to do with
how often bits of audio data are sampled when you record audio. (Sampling means to
"record audio on digital media.") The higher the frequency rate, the better the audio
quality. However, a higher frequency rate means more bandwidth is required.

EXAMPLE

CD audio discs: 44.100 kHz

Broadband internet connections: 22.050 kHz and higher

T1 connections: 22.050 kHz

56.6 k modems: 11.025 to 22.050 kHz

28.8 k modems: 11.025 kHz

8. Click Record.

9. When you are finished recording, click Stop.

10. In the Record dialog, click OK.
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11. In the Movie Properties dialog, click OK.

12. Click to save your work. The audio is applied to the movie. When the movie starts, the
audio continues to play from frame to frame until the audio file is completed.

NOTE Audio added through the Movie Properties dialog is displayed as a Sound bar
in the Timeline window pane's Movie View option.
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How to Record Audio for a Frame
1. Make sure a microphone is connected to your computer.

2. Open the frame.

3. Double-click the frame. The Frame Properties window pane opens.

4. Expand the Frame Sound section.

5. Click Enable Audio.

6. Click Record a New Audio Clip. The Record dialog opens.

7. Complete the options in the dialog:

n Encoding Frequency Select one of the frequency rates in kilohertz (kHz). The available
options are 44.100 kHz, 22.050 kHz, and 11.025 kHz. These options have to do with
how often bits of audio data are sampled when you record audio. (Sampling means to
"record audio on digital media.") The higher the frequency rate, the better the audio
quality. However, a higher frequency rate means more bandwidth is required.

EXAMPLE

CD audio discs: 44.100 kHz

Broadband internet connections: 22.050 kHz and higher

T1 connections: 22.050 kHz

56.6 k modems: 11.025 to 22.050 kHz

28.8 k modems: 11.025 kHz

8. Click Record.

9. When you are finished recording, click Stop.

10. In the Record dialog, click OK.

11. Click to save your work.
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NOTE Audio added through the Frame Properties window pane is displayed as a
Frame Sound bar in the Timeline window pane's Frame View option.
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How to Record Audio for a Cursor
Following are steps for adding audio to a cursor. If instead you want to add audio as an object itself,
see "Adding Audio as Objects" on page 62.

1. Make sure a microphone is connected to your computer.

2. Open the frame.

3. Double-click the cursor for which you want to record audio. The Object Properties window
pane opens.

4. Expand the Audio section.

5. Click Enable Audio.

6. Click Record a New Audio Clip. The Record dialog opens.

7. Complete the options in the dialog:

n Encoding Frequency Select one of the frequency rates in kilohertz (kHz). The available
options are 44.100 kHz, 22.050 kHz, and 11.025 kHz. These options have to do with
how often bits of audio data are sampled when you record audio. (Sampling means to
"record audio on digital media.") The higher the frequency rate, the better the audio
quality. However, a higher frequency rate means more bandwidth is required.

EXAMPLE

CD audio discs: 44.100 kHz

Broadband internet connections: 22.050 kHz and higher

T1 connections: 22.050 kHz

56.6 k modems: 11.025 to 22.050 kHz

28.8 k modems: 11.025 kHz

8. Click Record.

9. When you are finished recording, click Stop.
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10. In the Record dialog, click OK.

11. Click to save your work.
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Looping Audio
Use the following steps if you want the audio file to restart when it reaches the end of the playing
time. This is useful, for example, if you want to play background music for the entire duration of a
frame.

You can loop audio for a single frame and cursors.

How to Loop Audio for a Frame
1. Open the frame.

2. Double-click the frame. The Frame Properties window pane opens.

3. Expand the Frame Sound section.

4. Click Enable Audio.

5. Use the options in this section to add audio. See "Adding Audio to Frames" on page 210.

6. Click the check box next to Loop Sound.

7. Click to save your work.

How to Loop Audio for a Cursor
1. Open the frame.

2. Double-click the cursor. The Object Properties window pane opens.

3. Expand the Audio section.

4. Click Enable Audio.

5. Use the options in this section to add audio. See "Adding Audio to Cursors" on page 212.

6. Click the check box next to Loop Sound.

7. Click to save your work.
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Editing Audio Files
After you record an audio file, you can edit the file in several different ways, such as adjusting the
volume, deleting sections, and inserting silent areas.

How to Edit an Audio File
1. Open the movie.

2. Do one of the following, depending on the element for which you have recorded audio:

n Movie For an entire movie, select Movie > Properties, then in the Movie Properties
dialog, select the Audio tab. The recorded audio file should be displayed in the Audio
field.

n Frame For a single frame, double-click the frame. In the Frame Properties window pane,
expand the Frame Sound section. The recorded audio file should be displayed in the
Sound File field.

n Cursor For a cursor, double-click the cursor, then in the Object Properties window pane,
expand the Audio section. The recorded audio file should be displayed in the Sound File
field.

3. Click Edit. The Sound Editor opens.

4. Use the options in the Sound Editor to do any of the following:

TO ADJUST THE VOLUME OF THE AUDIO FILE

a. Click .

b. Set the options in the Adjust Volume dialog. For field descriptions, see the online Help.

c. Click OK.
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TO COPY A SECTION OF THE AUDIO FILE

a. Click and drag in the audio wave to select a portion of the sound file.

b. Click .

c. Click in the display to indicate where to paste the sound.

d. Click .

TO DELETE A SECTION OF THE AUDIO FILE

a. Click and drag in the audio wave to select the area.

b. Press Delete.

TO INSERT A SILENT AREA INTO THE AUDIO FILE

a. Click in the audio wave where you want to insert the silent area.

b. Click .

c. Set the options in the Insert Silence dialog. For field descriptions, see the online Help.

d. Click OK.

TO MOVE A SECTION OF THE AUDIO FILE

a. Click and drag in the audio wave to select a portion of the sound file.

b. Click .

c. Click in the display to indicate where to paste the sound.

d. Click .

TO RECORD NEW SOUNDS FOR THE AUDIO FILE

a. Click in the audio wave where you want to insert the new recording area.

b. Click .

c. In the Record dialog, click Record and add sound (e.g., speak) into your microphone.
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d. Click Stop when you are finished.

e. Click OK.

5. In the Sound Editor, click OK.

6. If using the Movie Properties dialog, click OK. The Object and Frame Properties window
panes require no further action.

7. Click to save your work.

What’s Next?
After editing an audio file, you need to make sure it is added back into your movie:

1. Depending on where you’ve previously added the audio (frame, movie, object), open the
appropriate interface (Frame Properties window pane, Movie Properties dialog, Object
Properties window pane).

2. Click Import Into Sound Library.

3. Select the edited audio file from Windows Explorer and click Open. The Import Sound dialog
opens.

4. Click Overwrite, or rename the audio file and click Import With New Name.

CHAPTER 10  223



Enabling and Disabling Sound for
Recording

When you record a movie, sounds are made when you perform actions. If necessary, you can
disable or re-enable the sounds for movie recordings.

How to Enable or Disable Sound for Recording
1. Select File > Recording Options.

The Recording Options dialog opens.

NOTE You can also open this dialog by clicking at the bottom of the recording
area. 

2. In the Options section, click Play sound effects to add or remove the check mark.

3. Click OK in the Recording Options dialog.
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CHAPTER 11

Appearance of Frames
You can control the appearance of frames in your movies in various ways.

This chapter discusses the following:

Setting the Arrows for a Line 227

Setting the Shape of an Arrow 229

Adding Borders 230

Adding Padding 232

Setting the Color for a Movie Background 234

Setting the Color for an Object 235

Selecting Cursor Types 237

Setting the Color and Width for a Line 238

Setting the Default Look for Objects 239

Using the Default Look for Objects 240

Selecting Styles for Objects 241

Making All Objects Look the Same 242

Setting the Coordinates for a Loop 243

Setting the Thickness for a Loop 244

Adjusting the Pointer on a Bubble Shape 245

Deleting Points in Objects 248

Aligning Objects 250
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Floating and Sinking Objects 254

Moving Objects 257

Rotating Objects 258

Setting Object Anchors 262

Setting the Rectangle Properties for an Object 268

Resizing Movies 269

Resizing Objects 276
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Setting the Arrows for a Line
When you add a line to a frame, an arrow is automatically added at its head. You can change the
position, size, or color of the arrow if you want. You can also remove all arrows from the line so that
it is a simple line.

How to Set Arrows for a Line
1. Open a frame that has a line added to it.

2. Double-click the line. The Object Properties window pane opens.

3. Expand the Polyline section.

4. If necessary, make any of the following modifications.

TO MODIFY THE POSITION OF THE ARROW(S)

a. In the Arrow Heads section, select the location(s) in the line where you want to place
the head arrow(s). You can place the arrow at the head, tail, center, or both ends of the
line. You can also specify that multiple arrows should be placed throughout the line. If
you do not want an arrow, select None.

b. In the Arrow Tails section, select the location(s) in the line where you want to place the
tails arrow(s). You can place the arrow at the head, tail, center, or both ends of the line.
You can also specify that multiple arrows should be placed throughout the line. If you
do not want an arrow, select None.

TO MODIFY THE SIZE OF THE ARROW

In the Length, Center Length, and Width field(s), enter the appropriate sizes in pixels.
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TO MODIFY THE COLOR OF THE ARROW

In the Color field(s), click the down arrow and select a color for the arrow. To see advanced
color options, select More colors.

5. Click to save your work.
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Setting the Shape of an Arrow
You can change many aspects of an arrow to affect its shape.

How to Set the Shape of an Arrow
1. Open a frame that has an arrow added to it.

2. Double-click the arrow. The Object Properties window pane opens.

3. Expand the Arrow section.

4. If necessary, change any of the fields in the Arrow section. You can click in the various Curved
check boxes to add or remove the curve effect from different parts of the arrow. You can
change the numbers in the various other fields to change aspects such as length, width, and
curve factor for different parts of the arrow. The best way to get the look you want is to
change the fields and watch the Frame Editor as the arrow changes its shape.

5. Click to save your work.

CHAPTER 11  229



Adding Borders
You can add a border around a single frame and specify the type and color of that border. You can
also add borders to a movie, which then applies the border to all frames.

How to Add a Border to a Single Frame
1. Open the frame.

2. In the Frame Editor, double-click the frame.

3. Expand the Frame Appearance section.

4. To set the border width, do the following:

a. Click Movie Properties. The Movie Properties dialog opens.

b. In the Width field, enter the size of the border (in pixels).

c. Click OK.

NOTE You only need to set the border width in the movie properties once. If you
change the border width, it will change for all frames in the movie.

5. In the Border section, select the type of border to add (e.g., solid, double, dashed).

6. In the Color field, select a color for the border.

7. Click to save your work.
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How to Add a Border to All Frames in a Movie
1. Open the movie.

2. Select Movie > Properties.

3. Select the Appearance tab.

4. In the Border section, select the type of border to add (e.g., solid, double, dashed).

5. In the Width field, enter the size of the border (in pixels).

6. In the Color field, click the down arrow and select a color for the border.

7. Click OK. The border is added to all frames in the movie.

8. Click to save your work.

How to Add a Border to an Object
1. Click the object in a frame (not the frame itself).

2. In the Object Properties window pane, expand the Object Appearance section.

3. From the Line section, click the down arrow in the Color field and select a color for the border.
To see advanced color options, select . You can also click to pick a color from your
screen.

4. In the Width field, enter the size of the border (in pixels).

5. Click to save your work.

What’s Noteworthy?

NOTE You can change the border width for movies, not for individual frames.

CHAPTER 11  231



Adding Padding
When working with images, you can add padding (or empty space) to increase the area around a
frame. When working with objects, you can add padding between the edge of an object and the text
in it.

How to Add Padding to All Frames in a Movie
1. Open a movie.

2. Select Movie > Properties.

3. Select the Appearance tab.

4. In the Padding section, enter numbers in the Left, Right, Top, and/or Bottom fields to set the
width of the padding (in pixels).

NOTE You can also use the Copy Down button to enter the padding values more
quickly. After you enter a number in the first padding field (Left), you can click this
button to automatically enter the same number in the rest of the fields.

5. Click OK. The padding is added to the frames in the movie, displayed in the default
background color of the frame.

6. Click to save your work.
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How to Add Padding to an Object
1. Open a frame that has an object added to it.

2. Double-click the object (not the frame itself).

3. In the Object Properties window pane, expand the Text section.

4. In the Padding section, enter numbers in the Left, Right, Top, and/or Bottom fields to set the
width of the padding (in pixels).

5. Click to save your work.

What’s Noteworthy?

NOTE Padding can be added only to certain objects.
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Setting the Color for a Movie
Background

You can set the background color for all frames in a movie.

EXAMPLE

You have inserted several blank frames into a movie. If you do not then add a background
image or objects to cover these frames, the background of each of those frames is
exposed in the default color. Therefore, you can set the background color for the entire
movie as necessary. All of the frames will take on the same background color.

How to Set the Background Color for a Movie
1. Open the movie.

2. Select Movie > Properties.

3. Select the Appearance tab.

4. Use the Background section to set the color properties.

n [Pattern] Select either "Solid" or one of the directional patterns (e.g., Top to Bottom, Left
to Right) if you want to create a gradient background that progresses in a certain
direction from one color to another.

n Fill Start Click the down arrow to select a color for the start of the background color. If
you select a different color for the "fill end," the frame background will be displayed as a
gradient of colors moving from the start color to the end color.

n Fill End Click the down arrow to select a color for the end of the background color.

5. Click OK.

6. Click to save your work.
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Setting the Color for an Object
When you add an object (e.g., action object, line) to a frame, you have many options for changing its
look and feel. You can change the look of an object by changing its color settings, such as its
background color, opacity, or line color and width.

How to Set the Transparency for an Object
1. In the Frame Editor, double-click the object (not the frame). The Object Properties window

pane opens.

2. Expand the Object Appearance section.

3. In the Opacity section, use the slider to set the amount of transparency applied to the
background color. The higher the number, the more solid the color will be. The lower the
number, the more transparent the color will be.

How to Set the Color for an Object
1. In the Frame Editor, double-click the object (not the frame). The Object Properties window

pane opens.

2. Expand the Object Appearance section.

3. In the Background section, do one of the following:

TO SET A SOLID BACKGROUND

a. In the Type field, select Solid.

b. Click the down arrow in the Color field and select a color for the object. To see
advanced color options, select . You can also click to pick a color from your
screen.
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TO SET A GRADIENT BACKGROUND

a. In the Type field, select a gradient type (e.g., Top to Bottom, Left to Right).

b. In the Gradient fields, do the following:

i. Click the down arrow in the first gradient field and select a color for the beginning
of the gradient.

ii. Click the down arrow in the second gradient field and select the color for the end
of the gradient.

NOTE To see advanced color options, select . You can also click to
pick a color from your screen.

4. Click to save your work.

How to Set the Line Color and Width for an
Object

1. In the Frame Editor, click the object (not the frame). The Object Properties window pane
opens.

2. Expand the Object Appearance section.

3. In the Line section, click the down arrow in the Color field and select a color for the border (or
line) around the object. To see advanced color options, select . You can also click to
pick a color from your screen.

4. Use the Width field to determine the thickness of the line.

5. Click to save your work.
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Selecting Cursor Types
When you add a cursor object to a frame, it displays by default with an arrow cursor bitmap
inside an oval shape. You can change the cursor type to something other than an arrow (e.g.,
IBeam, cross, hand).

How to Select a Cursor Type
1. Double-click the cursor object. The Object Properties window pane opens.

2. Expand the Cursor section.

3. In the Cursor field, select the type of cursor you want to display. As you select each cursor
type, the cursor updates in the Frame Editor.

4. Click to save your work.
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Setting the Color and Width for a Line
After you add a line to a frame, you can adjust the color and width settings for the line to meet your
needs.

How to Set the Color and Width for a Line
1. Open a frame that has a line added to it.

2. Double-click the line. The Object Properties window pane opens.

3. Expand the Object Appearance section, and adjust the settings in the following fields.

n Color Click the down arrow and select a color for the line. To see advanced color
options, select . You can also click to pick a color from your screen.

n Width Enter a width for the line in pixels.

4. Click to save your work.
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Setting the Default Look for Objects
Each type of object (e.g., oval, rectangle, bubble, polyline) has a default look (i.e., format settings).
You can stray from that look for any object in your movie by manually changing the formatting for
that object. You can then select that object and set it as the new default look. The next time you
draw that type of object, the settings that you specified as the default are automatically used.

EXAMPLE

You draw a rectangle on a frame and make formatting changes to the shape (e.g., color,
border, shading). If you then select this object and set it as the default look, future
rectangles will initially contain these same settings when you draw them.

How to Set the Default Look for Objects
1. On a frame, click the object that contains the formatting that you want to use as the default

for that object type.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Home> .

n Right-Click Right-click the object and select Advanced > Set Default Look.

3. In the message that displays, click Yes.

4. Click to save your work.
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Using the Default Look for Objects
You can add as many objects to a frame as you need. After objects are added, you can format them
in any way you want. And if necessary, you can remove the formatting from the selected object(s)
and apply the default formatting for that particular type of object (e.g., oval, rectangle, bubble, line).

EXAMPLE

Let's say you are drawing a rectangle on a frame. When you select the rectangle tool from
the local toolbar, the default factory settings are such that the rectangle initially has a thin
black border and no fill color. You can apply, say, a green fill color to that object. If you then
decide that you want to return to the default setting (in this case, no fill color), you can use
this feature.

How to Use the Default Look for Objects
1. Select one or more objects on a frame. To select multiple objects, hold down the CTRL key

and click each object.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Home> .

n Right-Click Right-click the object and select Use Default Look.

A message asks if you want to use the default settings of the object type. If you selected
objects based on various types (e.g., oval, rectangle, line), the default settings of the first
object type you selected are used. (The first object selected has orange handles, while the
other selected objects have white handles.)

3. Click Yes.

4. Click to save your work.
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Selecting Styles for Objects
After you add an object to a frame, you can quickly change the look of that object by associating it
with a style that already exists. You can apply a factory style (i.e., one provided by Mimic) or you can
apply a style from any of your palettes.

How to Select a Style for an Object
1. Open the frame.

2. In the Frame Editor, click the object.

3. Select Home> .

The Select Shape Style dialog opens.

4. In the Collection column, select either Factory or one of your palettes.

5. In the area to the right, select the style.

6. Click OK.

7. Click to save your work.
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Making All Objects Look the Same
After objects are added, you can format them in any way you want. Different objects can contain
different formatting settings. However, you can quickly make several objects on an image look the
same, taking on the formatting settings of whichever object that you select.

EXAMPLE

Maybe you have drawn several rectangles on a movie and have made different formatting
changes (e.g., color, border, shading) to each of them. Let's say that one of your rectangles
has a blue fill color. If you want the other rectangles in the movie to look the same way, you
can select the blue rectangle and use this feature. All of the rectangles in the movie will
then contain the same blue fill color.

How to Make All Objects Look the Same
1. On a frame, click the object that contains the formatting that you want to use as the basis for

the other objects.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Home> .

n Right-Click Right-click the object and select Advanced > Make All Look The Same.

3. In the message that displays, click Yes.

4. Click to save your work.
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Setting the Coordinates for a Loop
You can specify the coordinates of a loop to change how the loop looks.

How to Set Coordinates for a Loop
1. Open a frame that has a loop added to it.

2. Double-click the loop. The Object Properties window pane opens.

3. Change any of the fields in the Loop section. You can click in the various fields and change
the horizontal (X) and vertical (Y) percentages for different parts of the loop.

4. Click to save your work.
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Setting the Thickness for a Loop
You can specify the thickness of a loop that you add to a frame.

How to Set the Thickness for a Loop
1. Open a frame that has a loop added to it.

2. Double-click the loop. The Object Properties window pane opens.

3. Change any of the fields on the Loop section. You can click in the various fields in the
Thickness section and change the values for different parts of the loop.

4. Click to save your work.
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Adjusting the Pointer on a Bubble
Shape

The pointer portion of a bubble callout can be curved, and you can adjust the amount of curve used.
In addition, you can make changes to the base of the pointer and specify which edge of the bubble
shape holds the pointer.

How to Adjust the Pointer on a Bubble Shape
1. Open a frame that has a bubble shape added to it.

2. Double-click the bubble shape. The Object Properties window pane opens.

3. Expand the Callout section.

4. Make the changes in this section as necessary.

TO ADD CURVE TO THE TIP

a. In the Tip section, click Curved Pointer.

b. To adjust the amount of curve, change the number in the Curve Factor field. The higher
the number, the greater the curve. You can enter negative numbers too.

c. You can change the numbers in the X and Y fields to alter the distance of the pointer
horizontally and vertically. You can enter negative numbers too.

TO MODIFY THE EDGE POSITION OF THE POINTER

In the Pointer Base section, click Base Edge field and select the side of the bubble where you
want the pointer to be shown (Left, Right, Top, Bottom).

TO MODIFY THE POINTER BASE

n In the Pointer Base section, change the number in the Base Width field. The higher the
number, the wider the base.
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n To set the minimum width for the base, in the Min Base Width field, enter a number of
pixels. This lets you specify the smallest width of the base allowed, in case the bubble
is resized.

EXAMPLE

Let's say you set the "Min Base Width" to 10 pixels and you set the "Base Width"
to 30%. In this case, the base will be 30% of the bubble width at all times,
unless the bubble is resized so much that the base would fall below 10 pixels. If
that were to happen, the 10-pixel threshold would kick in and the 30%
specification would be ignored.

5. Click to save your work.

EXAMPLE

When you first draw a bubble shape, it might look something like this:

After clicking on the shape, the Object Properties window pane opens. You can expand the
Callout section and make the necessary changes in the Pointer Base section.
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Now let's say you want to change the width of the pointer base. In that case, simply adjust
the Base Width and/or Min Base Width fields.
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Deleting Points in Objects
When you edit polylines or polygons, you can delete points (the small colored circles in the object)
in order to turn two line segments into one, thus changing the shape of the object.

How to Delete Points in Objects
1. Open a frame containing an object such as a polyline or polygon.

2. Click on the object.

3. Click on the point in the object that you want to delete (i.e., one of the small colored circles).

4. Select Home> .
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5. Click to save your work.
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Aligning Objects
There are various ways to align objects.

How to Align Multiple Objects in Relation to One
of the Objects
You can align objects so that the left, right, top, or bottom border of each is at the same location on
the frame. The alignment is based on the border of the first object that you select.

1. Open a frame to which you have added objects.

2. Click the object that you want to use as the basis for aligning the other objects.

3. Hold down the CTRL key and click the other objects on the frame that you want to align.

4. Do one of the following, depending on the part of the user interface you are using:
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n Ribbon Select the Home ribbon and choose one of the following:

Horizontally aligns the objects so the left border is at the same location.

Horizontally aligns the objects so the right border is at the same location.

Vertically aligns the objects so the top border is at the same location.

Vertically aligns the objects so the bottom border is at the same location.

Resizes the width of the selected objects so that they are all the same.
The resizing is based on the width of the first object that you select.

Resizes the height of the selected objects so that they are all the same.
The resizing is based on the height of the first object that you select.

Resizes the width and height of the selected objects so that they are all
the same. The resizing is based on the width and height of the first object
that you select.

Vertically aligns the selected objects so that the center of each is at the
same location. The alignment is based on the center of the first object
that you select.

Horizontally aligns the selected objects so that the middle of each is at
the same location. The alignment is based on the middle of the first object
that you select.

NOTE These options are not available for polyline shapes.
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n Right-Click Right-click the object and from the context menu select Make Same, then
select one of the following:

l Align Left Horizontally aligns the objects so the left border is at the same location.

l Align Right Horizontally aligns the objects so the right border is at the same location.

l Align Top Vertically aligns the objects so the top border is at the same location.

l Align Bottom Vertically aligns the objects so the bottom border is at the same
location.

l Same Width Resizes the width of the selected objects so that they are all the same.
The resizing is based on the width of the first object that you select.

l Same Height Resizes the height of the selected objects so that they are all the
same. The resizing is based on the height of the first object that you select.

l Same Size Resizes the width and height of the selected objects so that they are all
the same. The resizing is based on the width and height of the first object that you
select.

l Align Center Vertically aligns the selected objects so that the center of each is at the
same location. The alignment is based on the center of the first object that you
select.

l Align Middle Horizontally aligns the selected objects so that the middle of each is at
the same location. The alignment is based on the middle of the first object that you
select.

NOTE These options are not available for polyline shapes.

5. Click to save your work.
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How to Align Objects on the Canvas
You can align objects so that they are centered on the canvas vertically, horizontally, or both.

1. Open a frame to which you have added objects.

2. Click on the object(s) that you want to align on the canvas. To select multiple objects, hold
down the CTRL key and click the objects.

3. Select the Home ribbon and choose one of the following:

Centers the selected object(s) both vertically and horizontally on the canvas.

Centers the selected object(s) vertically on the canvas.

Centers the selected object(s) horizontally on the canvas.

4. Click to save your work.
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Floating and Sinking Objects
When you add an object, it is placed on its own layer. And each time you add a new object, it is
placed on the top layer with the previous objects on layers beneath it. If necessary, you can "float"
objects that are on lower layers to bring them forward, and you can "sink" objects to send them
backward.

EXAMPLE

Here is an example with three objects (A, B, and C). Currently, "A" is on the top layer, "B" is
on the middle layer, and "C" is on the bottom layer.

In this example, we've moved "C" to the top layer. "A" is now on the middle layer, and "B" is
on the bottom layer.
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How to Float Objects in the Editor
1. Open a frame to which you have added objects.

2. Click on the object that you want to float (bring forward).

3. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Home> (face of the button). This brings the object forward one
layer or click the down arrow next to the float button and from the drop-down menu do
one of the following.

l Click to bring the object forward one layer.

l Click to bring the object forward all the way to the top.

n Right-Click Right-click the object and from the context menu select Order > Float or
Order > Float To Top.

4. Click to save your work.
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How to Sink Objects in the Editor
1. Open a frame to which you have added objects.

2. Click on the object that you want to sink (send backward).

3. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Home> (face of the button). This sends the object back one layer or
click the down arrow next to the sink button and from the drop-down menu do one of
the following.

l Click to send the object back one layer.

l Click to send the object all the way to the bottom.

n Right-Click Right-click the object and from the context menu select Order > Sink or
Order > Sink To Bottom.

4. Click to save your work.
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Moving Objects
After an object is added, you can move it around the frame to place it where you need it. You can do
this by dragging the object.

Hove to Move an Object
1. Open a frame to which you have added objects.

2. Hover over the object until the cursor becomes an arrow .

3. Click on the object and drag it to the appropriate location on the frame.

4. Click to save your work.
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Rotating Objects
You can rotate objects after adding them to frames. You can rotate objects manually, or you can
rotate them using preset increments—1 degree, 45 degrees, or 90 degrees at a time.

EXAMPLE

You might have a rectangle object like this:

You can click on the rectangle and rotate it 45 degrees clockwise. It will then look like this:
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You can also click on the rectangle and manually rotate it slightly counter clockwise from
its original position. It will then look like this:
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How to Rotate an Object
1. Open a frame to which you have added objects.

2. Click the object that you want to rotate.

Blue handles frame the object.

3. Do one of the following:

ROTATE USING THE RIBBON

n Select the Home ribbon and choose from the following:

Rotates the selected object 45 degrees clockwise. Click the down
arrow to select from the following options:

l Rotate Clockwise Turns the object 1 degree clockwise.

l Rotate 45 Clockwise Turns the object 45 degrees clockwise.

l Rotate 90 Clockwise Turns the object 90 degrees clockwise.

Rotates the selected object 45 degrees counter clockwise. Click the
down arrow to select from the following options:

l Rotate Counter Clockwise Turns the object 1 degree counter
clockwise.

l Rotate 45 Counter Clockwise Turns the object 45 degrees counter
clockwise.

l Rotate 90 Counter Clockwise Turns the object 90 degrees counter
clockwise.

Returns the object to its original setting before it was rotated.

ROTATE MANUALLY

You can rotate manually by dragging the rotation handle.
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n Click and hold the largest blue handle, then drag the object to the desired position.

4. Click to save your work.

What’s Noteworthy?

NOTE These options are not available for polylines, cursors, typing boxes, or input boxes.
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Setting Object Anchors
You can set anchors on many objects that you add to a frame. An anchor is a way to "lock" the
position of the object so that it stays in place even if the configuration of the frame is changed (e.g.,
cropped or resized). You can set anchors on any of the four sides of an object—top, bottom, left,
right.

How to Set Object Anchors
1. Open a frame containing an object you want to anchor.

2. Select Tools > Anchors. If the box is checked, the anchors are visible. If the box is unchecked,
the anchors are hidden.

3. Click on the object so that you can see the anchor arrows. Then click on any arrows on the
sides of the object that you want to lock.

4. Click to save your work.

NOTE You can also set anchors on the Rectangle section of the Object Properties window
pane. Simply click the object and then expand the Rectangle section.
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EXAMPLE

Let's say that you have added a bubble callout to a frame, like this:

CHAPTER 11  263



If you were to resize the movie, decreasing its size without any anchors on the callout, the
results would look like this:
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Notice that the position of the callout stayed exactly as it was.

Let's say that you want the callout to remain the same distance from the right and bottom
sides of the frame when it is resized. In order to achieve this, you would first select the
option to show object anchors by selecting the Tools ribbon and in the Object section,
checking the Anchors check box. Now when you click on the object, you will see arrows on
each side of the object.
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To set anchors on the right and bottom sides, you would click those arrows so that they
become colored.

CHAPTER 11  266



Now when you resize the movie, the callout maintains the same distance from the right and
bottom sides of the frame.
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Setting the Rectangle Properties for an
Object

After you add an object to a frame, you can adjust its corners as needed.

How to Set the Rectangle Properties for an
Object

1. Open a frame that has an object added to it.

2. Double-click the object. The Object Properties window pane opens.

3. Expand the Rectangle section.

4. In the Corner Radius field, set the amount of curve for the rectangular edges of the object.
The higher the number, the more curve will be applied to the edges.

5. Click to save your work.
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Resizing Movies
After you create a movie, you may want to enlarge or reduce the size of the frames. This is easily
done by adjusting the settings in the Movie Properties dialog. All frames in the movie will be resized
according to the settings you provide. Any objects on the frames (e.g., callouts, shapes, lines) will
remain their original size.

How to Resize a Movie
1. Select Movie > Properties.

The Movie Properties dialog opens.

2. Select the Movie Size tab.

3. You can resize the movie either by entering the size values manually or by using the screen
rectangle to draw the new size.

TO ENTER SIZE VALUES MANUALLY

Change the values in the appropriate field(s)

n X Enter the distance (in pixels) that you want the frame to be located from the left edge.
This field can be used if you always want to record from a specific position on the
screen.

n Y Enter the distance (in pixels) that you want the frame to be located from the top edge.
This field can be used if you always want to record from a specific position on the
screen.

n Width Enter the new width (in pixels) for the frames.

n Height Enter the new height (in pixels) for the frames.
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TO USE THE SCREEN RECTANGLE

a. Click Pick Screen Rectangle. A rectangle with a red border appears on your screen,
along with a task bar. The task bar displays the current width and height values (in
pixels).

b. Adjust the movie size. You can use several methods and features to do this.

DRAG EDGE

You can resize the area manually by clicking any of the handles (small squares) around
the edge of the rectangle and dragging them to resize the width and/or height.
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MOVE ENTIRE RECORDING AREA

You can move the entire area by clicking the size-all icon in the center of the area
and dragging the area to a new location on your screen.
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TYPE WIDTH OR HEIGHT

You can click in the number fields in the task bar to manually change the width and/or
height of the window in pixels.
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MAINTAIN ASPECT RATIO

You can click the chain button in the task bar to maintain the aspect ratio when you
change the width or height of the area.

When this feature is disabled, the button displays as an broken chain image. If you then
change one dimension of the capture window, the other dimension will not be resized
automatically. For example, if you drag the window border to the left (to increase the
width), the height will remain the same size.

When this feature is enabled, the button displays as a chain image. If you then change
one dimension of the window, the other side will be resized automatically. For example,
if you drag the window border to the left (to increase the width), the height will be
resized accordingly.

CHAPTER 11  273



CHOOSE PRE-SET SIZE

You can click the drop-down in the task bar and choose one of the pre-set window
sizes.
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SNAP/MOVE INTO RECTANGLE

If you have a particular application or window open, and you want to capture it, you can
choose an option to snap the window around that element, or you can choose to move
the element into your window. When you use one of these options, the Select Window
dialog opens. You can then choose any of the applications or windows that you have
open.

NOTE If you are using a newer operating system, you may need to enable
window-based recording optimization. For more information, see the online
Help.

c. When you are finished resizing the rectangle, click the red button in the task bar to
accept the new recording area.

5. In the Movie Properties dialog, click OK. All frames in the movie are resized.

6. Click to save your work.
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Resizing Objects
After an object is added to a frame, you can resize it. You can do this by dragging the edges of the
object or by automatically resizing a group of objects so that the height and/or width are the same.

How to Resize an Object by Dragging the Edges
1. Open a frame to which you have added one or more objects.

2. Click once on the object to display all of the points (small circles) around the edge of the
object.

3. Hover over any of the points around the edge of the object so that the cursor is displayed as a
Size-All cursor .

4. Click and drag your mouse to resize the object.

TIP If you want to maintain the object's aspect ratio (i.e., keep the proportions of the
object the same as you resize it), hold the SHIFT key while you drag the mouse.

5. Click to save your work.
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How to Resize a Group of Objects to Match
1. Open a frame to which you have added one or more objects.

2. Click the object that you want to use as the basis for resizing the other objects.

3. Hold down the CTRL key and click the other objects that you want to resize.

4. Select the Home ribbon and choose one of the following:

Resizes the width of the selected objects so that they are all the
same. The resizing is based on the width of the first object that you
select.

Resizes the height of the selected objects so that they are all the
same. The resizing is based on the height of the first object that you
select.

Resizes the width and height of the selected objects so that they are
all the same. The resizing is based on the width and height of the first
object that you select.

NOTE These options are not available for polyline shapes.

5. Click to save your work.
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Automatically Resizing Objects to Fit Text
You can set Mimic to automatically resize an object in order to better fit the text. If you set this
option at the movie level, all objects will resize automatically to fit text. If set at the object level, only
that particular object will resize as you edit the text within it.

How to Set Movies to Automatically Resize Objects to
Fit Text
Within a movie's properties you can set all applicable objects to auto-size to fit text. This option is
perfect when you have an existing movie that has several objects in it, or if you have just created a
new movie that will contain one or more objects that contain text.

1. Open or create a movie.

2. Select Movie > Properties.

3. In the Movie Properties dialog, select the Appearance tab, then select Auto-size All Objects to
Fit Text.

All objects in the movie will automatically resize to fit text, even if the object was already part
of the movie before this selection was made.

How to Set Individual Objects to Automatically Resize
to Fit Text
You can set each object to auto-size to fit text.

1. Add an object to the frame.

2. Double-click the object. The Object Properties window pane opens.

3. In the Object Properties window pane, expand the Object Layout section and select Auto-size
to fit text.

This setting will only be applied to the selected object.
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NOTE If Auto-size All Objects to Fit Text is set at the movie level, you will not have
the option to set auto-size at the object level.

EXAMPLE

Let's say you add text to a rectangle shape. However, the rectangle you drew is much too
small for the text you added.

To fix this, you enable Auto-size to fit text. The rectangle automatically resizes to fit the
caption. If you make more changes to the text later, the rectangle will resize again to
accommodate the changes.

What’s Noteworthy?

NOTE The auto-resize to fit text options do not apply to polylines, polygons, arrows,
cursors, image objects, and input boxes.
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CHAPTER 12

Palettes
After you create a movie, you can add various types of objects (such as shapes, lines, buttons, and
cursors) to the individual frames. A palette is an element that lets you store objects for later use.

EXAMPLE

You create a button and modify it (adding text, color, shadow, an action), with the intention
of using it in most frames. It would be time consuming to redesign that button each time
you want to use it in a frame. So you save the button to a palette. The next time you want to
add the button to a frame, you double-click it or drag it from the palette.

NOTE Palettes are especially convenient because they are stored in your "Documents\My
Palettes" subfolder. This means that, once created, the palette and its objects become
available to all of your Mimic collections and movies. Not only that, but they are also
available to any images that you edit in Capture.
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This chapter discusses the following:

Opening Palettes 282

Creating Palettes 284

Linking to External Palettes 285

Adding Objects to Palettes 286

Using Objects From Palettes 287

Deleting Palettes 288

Deleting Objects From Palettes 290

CHAPTER 12  281



Opening Palettes
You can open palettes the traditional way, from inside the interface. But you can also open them by
dragging palette files from a Windows folder.

How to Open a Palette From Within the Interface
1. Select View > Palettes.

The Palettes window pane opens.

2. In the local toolbar of the Palettes window pane, click the drop-down containing the name of
the current palette .

3. From the list, select the palette that you want to open. The palette opens, displaying the
objects contained within it.

How to Open a Palette by Dragging It From
Windows

1. Open Windows and navigate to the folder containing your palette file. By default, palette files
are stored in your Documents/My Palettes folder.

2. Launch Mimic.

3. Drag the palette file from Windows to the application window and drop it on the title bar in
Mimic.

NOTE You can also use this method to open any file type that is supported in Mimic.
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NOTE You can use this method to open linked palettes as well. See "Linking to
External Palettes" on page 285.
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Creating Palettes
Mimic provides you with an initial palette to help get you started. However, you can easily create
additional palettes for different purposes.

How to Create a Palette
1. Select View > Palettes.

The Palettes window pane opens.

2. In the local toolbar of the Palettes window pane, click .

3. In the Save As dialog, navigate to the folder where you want to save the palette.

4. In the File name field, enter a name for the palette.

5. Click Save. The new empty palette opens (by default on the left side of the user interface).

6. Click to save your work.
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Linking to External Palettes
Mimic provides you with an initial palette to help get you started. However, you can also link to
external palettes. You might want to do this if you are working on a project and have a palette that
is saved to an external location that is specific to that project, or if you are sharing a palette with a
team.

How to Link to an External Palette
1. Select View > Palettes.

The Palettes window pane opens.

2. In the local toolbar of the Palettes window pane, click .

3. In the Open dialog, find and select the palette you want to open.

4. Click Open. The linked palette opens in the Palettes window pane.

NOTE If a palette is saved to a common location, such as a network drive, any user who
links to the file can make changes to it. When other users save their changes, you will see
the changes in your copy of Mimic. Linking to external palettes is a good way to be sure
that other members of your team always have the most current version of the file.

However, because any user can make changes, it is possible to easily overwrite a file with
undesired edits. You may want to designate one team member to manage all edits to
palettes to prevent unwanted changes.
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Adding Objects to Palettes
After you create or open a palette, you can add objects to it.

How to Add an Object to a Palette
1. Open a custom palette that you have created, or a linked palette (not a factory palette).

2. Open a frame to which you have added one or more objects.

3. In the frame, right-click on the object that you want to add to the palette.

4. In the context menu, select Add to Palette. The object displays in the Palettes window pane.

5. (Optional) You can rearrange the order of the objects in the Palettes window pane by clicking
and dragging the objects up or down.

NOTE Objects can be added only to custom palettes that you have created or to linked
palettes. They cannot be added to read-only factory palettes.

NOTE If you add an object that contains keyframes to a palette, it will retain those
keyframes.
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Using Objects From Palettes
After objects are added to a palette, you can use them in frames whenever necessary.

How to Use an Object From a Palette
1. Open a frame.

2. Open the palette containing the object that you want to use.

3. (Optional) You can rearrange the order of objects in each palette to make them easier to use.
Click and drag the objects in the palette up or down to change their order.

4. Do one of the following:

n Click the object in the palette, drag it to the frame, and drop it.

n Double-click the object in the palette.

5. You can then move, resize, or double-click the object to make property changes to it.

6. Click to save your work.
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Deleting Palettes
You can delete a palette if you no longer need it. All objects within the palette will also be deleted.
Deleting the palette sends it to the Recycle Bin.

If you are working with an external palette, such as one stored on a shared drive, you may only need
it for a short period of time (see "Linking to External Palettes" on page 285). For this reason, you can
remove the palette from Capture when you are finished using it. This breaks the link between
Capture and the palette, and removes it without permanently deleting it. You can add it back into
Capture at any time.

How to Delete a Palette
1. Open the palette that you want to delete. See "Opening Palettes" on page 282.

2. In the local toolbar of the Palettes window pane, click . The Delete or Remove Palette
dialog opens.

3. From the drop-down, select Send the file to the recycle bin.

4. Click OK.

5. In the confirmation dialog, click Yes.

How to Remove an External Palette
1. Open the palette that you want to remove. See "Opening Palettes" on page 282.

2. In the local toolbar of the Palettes window pane, click . The Delete or Remove Palette
dialog opens.

3. From the drop-down, select Remove the file from Capture’s list without deleting.

4. Click OK.

CHAPTER 12  288



What’s Noteworthy?

NOTE You can only remove external palettes. If you need to remove a local palette, you
must delete it.
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Deleting Objects From Palettes
Use the following steps to remove an object from a palette.

How to Delete an Object From a Palette
1. Open the palette containing an object that you want to delete.

2. Select the object.

3. In the Palettes window pane, do one of the following.

n Keyboard On your keyboard press DELETE.

n Right-Click Right-click the object and select Delete.

4. Click to save all files.
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CHAPTER 13

Conditions
A condition tag is a way to mark movies, frames, or objects that you want to include in some
outputs, but exclude from other outputs. They work in conjunction with targets, which are separate
instances of an output type.

This chapter discusses the following:

Creating Condition Tags 296

Applying Condition Tags 298

Associating Condition Tags 303

Previewing Conditions 313
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EXAMPLE

You are creating a movie that will be shown to two different audiences. Perhaps all of the
frames in the movie are appropriate for each audience, except for the final five frames,
which should be shown only to Audience A. In that case, you might create two condition
tags—one called "AudienceA" and the other "AudienceB."
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Then you can mark each of the final five frames so that they are associated with the
AudienceA marker.
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In addition, you can create two targets—perhaps one is called "OutputA" and the other
"OutputB."
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In the OutputA target, you tell Mimic to include the AudienceA condition tag and exclude the
AudienceB condition tag. In the OutputB target, you do the opposite.

When you generate the movie outputs, the movie using OutputA will show the final five
frames. The movie using OutputB will not show the final five frames.

CHAPTER 13  295



Creating Condition Tags
You can create your own condition tags from within Mimic.

How to Create Conditions for a Collection
1. Open the Mimic collection.

2. In the Collection Editor, click the Condition Tags tab.

3. Click in an empty Name cell and type a name for the tag.

4. Click the Background drop-down arrow and select Pick Color.

5. In the dialog, select a new color.

6. Click OK.

7. (Optional) Click in the Comment cell and type an internal comment that helps you identify the
tag. Press ENTER when you are finished.

8. Click to save your work.

How to Create Conditions for a Standalone
Movie

1. Open the standalone movie.

2. Select the Movie ribbon.

3. In the Properties section, click Properties.

4. In the properties dialog, click the Condition Tags tab.

5. Click in an empty Name cell and type a name for the tag.

6. Click the Background drop-down arrow and select Pick Color. The Color Picker dialog opens.

7. Select a new color.

8. Click OK.
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9. (Optional) Click in the Comment cell and type an internal comment that helps you identify the
tag. Press ENTER when you are finished.

10. Click OK.

11. Click to save your work.
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Applying Condition Tags
After you create condition tags or link to a Flare project, you can apply those condition tags to the
appropriate parts of your Mimic collections and movies.

You can apply condition tags to three different kinds of elements, thus indicating that those
elements should be included in any output that does not specifically exclude them. First, you can
apply conditions to objects that have been added to movie frames. Second, you can apply
conditions to entire frames within a movie. And third, if you have created a collection—as opposed
to a standalone movie—you can also apply condition tags to each movie. You do not need to apply
conditions to each and every element that you come across, but rather only to those elements that
should be included in some outputs but excluded from other outputs. If a particular element should
always be included in the output, there is no need to apply a condition tag to it.

How to Apply Conditions to Objects in a Frame
1. Open the movie frame.

2. Click the object to which you want to apply one or more condition tags. The Object Properties
window pane opens.

3. Expand the Conditions section. All of the available condition tags—those that you have
created, as well as those from a linked Flare project—are shown on the right.

4. For each condition tag that you want to apply to the object, click the check box next to the
tag. A check mark appears in the box.

5. Click to save your work. A small square displays on the object, and it shows the color of
the condition tag. If you applied more than one condition tag to the object, each color is
shown. (If you do not see the square, select Tools > Conditional Indicators in the ribbon
interface.)
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NOTE The colored squares are simply used to let you know which objects have
condition tags applied to them. Those squares will not display in the final movie
output.

NOTE Condition tags are considered when viewing a movie in Preview Mode.
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How to Apply Conditions to Frames in a Movie
1. Open the movie.

2. Double-click the frame to which you want to apply one or more condition tags. The Frame
Properties window pane opens.

3. Expand the Conditions section. All of the available condition tags—those that you have
created, as well as those from a linked Flare project—are shown on the right.

4. For each condition tag that you want to apply to the frame, click the check box next to the
tag. A check mark appears in the box.

5. Click to save your work. If you open the Frames window pane (select Tools > Frames in
the ribbon interface, View > Frames in the menu interface, or press CTRL+J on the keyboard),
you will notice a small square displays above the frame, and it shows the color of the
condition tag. If you applied more than one condition tag to the frame, each color is shown.
(If you do not see the square, select Tools > Conditional Indicators in the ribbon interface.)
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How to Apply Conditions to Movies in a
Collection

1. Open the Mimic collection.

2. In the Collection Editor, double-click the movie to which you want to apply one or more
condition tags.

3. Select the Movie ribbon.

4. In the Properties section, select Properties.

The Movie Properties dialog opens.

5. Click the Conditions tab. All of the available condition tags—those that you have created, as
well as those from a linked Flare project—are shown on the right.

6. For each condition tag that you want to apply to the movie, click the check box next to the
tag. A check mark appears in the box.

7. Click OK.
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8. Click to save your work. If you open the Movies window pane (select Tools > Collection
Movies in the ribbon interface, View > Collection Movies in the menu interface, or press
CTRL+W on the keyboard), you will notice a small square displays above the movie, and it
shows the color of the condition tag. If you applied more than one condition tag to the movie,
each color is shown. (If you do not see the square, select Tools > Conditional Indicators in the
ribbon interface.)
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Associating Condition Tags
After applying condition tags to the appropriate elements, you can tell Mimic to include or exclude
those conditions in the output. This can be done in three places—at the movie level (if it is a
standalone movie), at the collection level, or on individual targets. In most cases, you will probably
associate condition tags with targets, which is recommended.

NOTE The following instructions are for the Basic method of associating condition tags,
which uses Include and Exclude check boxes. If you prefer to use the Advanced method—
which uses manual AND, OR, and NOT statements—see "Instructions for the Advanced
Method" on page 307.

How to Associate Conditions With Targets
Targets are very useful because they allow you to generate multiple outputs simultaneously. In
addition, you can create targets for either collections or standalone movies.

1. If you have not done so already, create the target(s) to be used with your collection or
standalone movie.

2. Open the Mimic collection or standalone movie.

3. Do one of the following, depending on whether you are working in a collection or standalone
movie.

n Collection In the Collection Editor, click the Targets tab.

n Standalone Movie Select Movie > Properties. The Movie Properties dialog opens. Click
the Targets tab.

4. Select the target for which you want to set conditions and click the Edit button. An editing
window for that target opens.

5. Click the Conditional Text tab. All of the available condition tags—those that you have
created, as well as those from a linked Flare project—are shown on the right. An Include and
Exclude check box appears next to each condition tag.
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6. If you want to exclude a condition tag from the output for this target, click the Exclude check
box next to it. If you want to make sure a condition tag is included in the output for this target,
click the Include check box next to it. The primary reason for having Include check boxes is to
account for possible conflicts.

EXAMPLE

Suppose you have two condition tags—one called "Beginner" and another called
"Advanced." Let's say that you have a frame containing three objects, one object at
the top of the frame, one in the middle, and one at the bottom. You apply the
Advanced tag to the top two objects, and you apply the Beginner tag to the bottom
two objects. In other words, the object in the middle has both condition tags applied
to it.

Let's say that you want to create output for your advanced users. You obviously want
to include all objects associated with the Advanced tag, but you want to exclude
objects associated with the Beginner tag. By default, Mimic will include objects
associated with both tags, unless you tell it not to. So you tell Mimic to exclude the
objects associated with the Beginner tag. The problem is the middle object. It is
associated with both tags. You have told Mimic to exclude objects associated with
the Beginner tag, and it will do so, overriding the default. But you want to make sure
that object is included in the advanced output. That is why you need to make sure
you select the Include check box next to the Advanced tag.

WARNING The condition feature is an inclusive system. If you do not select any
options at all, all of the tags will automatically be included, as indicated by the gray
text in the Action cell. If you include only some tags and exclude others, any
remaining tags without options specifically set will automatically be included.
However, if you select Include for any of the tags (even just one) and do not select
Exclude for any tags, all of the other tags that do not have the Include option set
explicitly will automatically be excluded. If you have not explicitly set an option for a
condition tag, make sure you look at the gray text in the Action cell to know what will
happen for that tag in the output.

7. Click OK.
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8. If you want to associate conditions for another target, repeat steps 4-7.

9. If you are working in a standalone movie, click OK again.

10. Click to save your work.

How to Associate Conditions With Standalone
Movies

1. Open the standalone movie.

2. Select the Movie ribbon.

3. In the Properties section, click Properties.

The Movie Properties dialog opens.

4. Click the Conditional Text tab. All of the available condition tags—those that you have
created, as well as those from a linked Flare project—are shown on the right. An Include and
Exclude check box appears next to each condition tag.

5. If you want to exclude a condition tag from the output for this movie, click the Exclude check
box next to it. If you want to make sure a condition tag is included in the output for this movie,
click the Include check box next to it. The primary reason for having Include check boxes is to
account for possible conflicts.

6. Click OK.

7. Click to save your work.
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How to Associate Conditions With Collections
1. Open the Mimic collection.

2. In the Collection Editor, click the Conditions tab. All of the available condition tags—those that
you have created, as well as those from a linked Flare project—are shown on the right. An
Include and Exclude check box appears next to each condition tag.

3. If you want to exclude a condition tag from the output for this collection, click the Exclude
check box next to it. If you want to make sure a condition tag is included in the output for this
collection, click the Include check box next to it. The primary reason for having Include check
boxes is to account for possible conflicts.

4. Click to save your work.
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Instructions for the Advanced Method
If you are a more experienced user, you may decide to use the Advanced section to write
expressions manually, rather than clicking check boxes. You can type the names of the condition
tags as well as any of the following tokens: OR, AND, NOT, (). This lets you produce more complex,
robust expressions to control your output (i.e., "and" statements, as well as "or" statements).

You can use the Advanced method to associate conditions with targets, standalone movies, or
collections.

Copy From Basic
When you select Advanced for the first time, the Basic section becomes disabled (i.e., the options
are disabled), and the Advanced section is enabled but empty (even if you've previously selected
conditions in the Basic section). However, you can copy the expression from the Basic section to
the Advanced section. This is a quick and easy way to create an initial expression and then adjust it
with "and" statements.
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Double-Click Tags
Another trick you can use while working in the Advanced section is to double-click any tag from the
Basic section. This adds the condition to the Advanced section so you do not have to type it. Just
make sure your cursor has been placed in the Advanced section before double-clicking a condition
tag. If you don't click in the Advanced section first, the newly added condition tag will overwrite all of
the text you've entered previously in the Advanced section.
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Warning Icon
When you type in the Advanced section, a yellow warning icon displays with relevant text if you
have typed an error.

You can expect to see this icon quickly appear and then disappear as you type. However, if the icon
remains after you finish, you can click it. The error will then be highlighted in the text below.
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Previewing Conditions
You can click a button to see what the frame will look like with the condition tags included or
excluded in the output. This is simply a way to test your conditions before saving the frame.

How to Preview Conditions
1. Open a frame that you want to preview.

2. Make sure you have already applied conditions to objects on the frame and associated the
movie, collection, or target with condition tags (including and excluding). See "Applying
Condition Tags" on page 298 and "Associating Condition Tags" on page 303.

3. Select Tools > Preview Conditions.

The objects that have condition tags set to be shown still appear, but the objects that have
condition tags set to be excluded are hidden.

NOTE Condition tags are also considered when viewing a movie in Preview Mode.
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CHAPTER 14

Effects
An effect is a special element or characteristic that you apply to an object to enhance it.

This chapter discusses the following:

Adding Effects 315

Adding Shadow Effects 326

Editing Effects 328

Editing Shadow Effects 330

Removing Effects 332
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Adding Effects
Effects allow you to change the look of an object. Although the effect area can be spread out over
the frame or moved off of the object completely, it is still associated with that object and is applied
only to that object. If you delete an object to which an effect is applied, even if the effect area is not
on top of the object, the effect is also removed.

EXAMPLE — Opacity, Gray Scale, and Blur

You can associate opacity, gray scale, and blur effects with image objects.

Here is an example of an image object on a frame with a yellow background without any
effects applied.
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This is an example of an opacity effect with the mask set to inside. The area inside of the
red effect area is a little more translucent than the rest of the frame, so you can see the
frame's yellow background through the image object.
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This is an example of a gray scale effect with the mask set to outside. Only the area outside
of the effect area is gray. The effect only changes the color of the image object, so the
frame's yellow background is not affected, even though it is outside of the red effect area
frame.
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This is an example or a blur effect with the mask set to inside and the blur radius set to 20,
meaning that only the two penguins on the left are blurred.
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EXAMPLE — Clip

You can associate a clip effect with any kind of object.

Let's say you want to show part of an object, then slowly widen that area to show more of
the object until the entire object is shown. In other words, you want to do a big reveal. To do
this, you would use a clip effect.

First, add an object to the frame.
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Now select Home > Effects > Clip. In this example, everything except the part of the object
covered by the mask, or the red rectangle, will be "clipped" out of the frame.
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You can now add size and position keyframes to the clip effect in order to slowly widen the
mask area and reveal more of the frame.

You can preview your progress as you work by pressing the Play button in the preview bar,
or by dragging the playhead to the specific keyframe you want to check.
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How to Add an Effect
1. Open a movie that contains objects, or add an object to a frame.

2. Double-click the object. The Object Properties window pane opens.

3. In the Timeline window pane (View > Timeline), do one of the following:

n For all standard object types, click Frame View. Any action objects converted to objects
will also be in this view.

n For action object types, click Action View. Any objects converted to action objects will
also be in this view.

4. Select the Home ribbon. In the Insert section, select Effects, then select one of the following
effect types:

n Clip Adds a clipping mask that lets you hide part or all of the frame. You can apply clip
effects to any object type.

n Opacity Sets the level of transparency of the effect area. You can apply opacity effects
to image objects.

n Gray Scale Changes the effect area to shades of gray. You can apply gray scale effects
to image objects.

n Blur Blurs the effect area. You can apply blur effects to image objects.

After an effect is selected, a red effect area frame appears on the object that was selected,
and the effect bar appears on the Timeline. Additionally, the Object Properties window pane
will change to the Effect Properties window pane.
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5. In the Effect Properties window pane, do the following, if necessary.

TO CHANGE THE POSITION AND SIZE OF THE EFFECT AREA

n Expand the Object Layout section and make the desired adjustments:

l Position Select a different position on the frame for the effect area. The first field
sets the horizontal position, and the second field sets the vertical position. Manually
change the position of the effect area by clicking on the red effect area frame and
dragging it to a new place in the Frame Editor.

l Size Select a different size for the effect area. The first field sets the width, and the
second field sets the height. Manually change the size of the effect area by clicking
on the edges of the red effect area frame and dragging them to the desired height or
width.

TO CHANGE THE DIRECTION OF THE EFFECT AREA

n Expand the Mask section and select from the following:

l Inside Everything inside of the red effect area frame will have the effect applied to it.

l Outside Everything outside of the red effect area frame will have the effect applied
to it.

NOTE Masks are not available for clip effects. You can only clip inside the red effect
area frame.
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TO CHANGE THE MASK PROPERTIES

The mask properties are only applicable to blur and opacity effects.

n Opacity Expand the Opacity Mask section and drag the slider to the desired percentage.
The higher the percentage, the more opaque the effect area will become. In other
words, if you set the opacity to 100%, the object will be displayed as a fully opaque
object. If you set the opacity to 50%, the background will show through the object. If
you set the opacity to 0%, the object will be completely transparent, and you will be able
to clearly see the background.

n Blur Expand the Blur Mask section and enter a number in the Blur Radius field. The
higher the number, the more blurred the effect area will become.

6. Click to save your work.
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What’s Noteworthy?
TIP When applying position keyframes to an object or effect, the position keyframe
location is placed at the upper left corner of the object. Depending on the type of path you
are drawing, you may want to slightly adjust the object's trajectory to account for the space
between the upper left corner of the object and the middle of the object.

For example, if you have a cursor object and you need it to "click" a button, you may want to
position the trajectory slightly above and to the left of the button, so it appears that the
cursor is in the middle of the button.
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Adding Shadow Effects
You can add a shadow effect to an object in a frame. This helps to give your object the appearance
of depth. When you create a shadow effect, you have control over where the shadow appears, how
much shadow is shown, the color of the shadow, and the opacity of the shadow.

How to Add a Shadow Effect to an Object
1. Open a frame that has an object added to it.

2. Click the object.

3. Select Home> Shadow.

A shadow is added to the object.

4. To make adjustments to the shadow, double-click the object. The Object Properties window
pane opens.

5. In the Object Properties window pane, expand the Shadow section.

6. If necessary, make any of the following modifications to the shadow.

TO MODIFY THE POSITION OF THE SHADOW

a. In the Left/Right field, enter the number of pixels that the shadow will be extended to
the right or left of the object. Enter a positive number (e.g., 7) to extend the shadow to
the right. Enter a negative number (e.g., -7) to extend the shadow to the left.

b. In the Up/Down field, enter the number of pixels that the shadow will be extended
below or above the object. Enter a positive number (e.g., 7) to extend the shadow below
the object. Enter a negative number (e.g., -7) to extend the shadow above the object.

TO MODIFY THE COLOR OF THE SHADOW

In the Color field, click the down arrow to select a color for the shadow. To see advanced
color options, select . You can also click to pick a color from your screen.
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TO MODIFY THE TRANSPARENCY OF THE SHADOW

In the Opacity field, drag the slider to change the percentage of transparency applied to the
shadow. The higher the number, the more solid the color will be. The lower the number, the
more transparent the color will be.

7. Click to save your work.
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Editing Effects
You can edit the start time of the effect, the duration of the effect, and the way effect is applied to
the object.

How to Edit an Object Effect
1. Open a movie that contains objects to which effects have been applied.

2. In the Timeline window pane (View > Timeline), do one of the following:

n For all standard object types, click Frame View. Any action objects converted to objects
will also be in this view.

n For action object types, click Action View. Any objects converted to action objects will
also be in this view.

3. In the Timeline window pane, right-click an effect bar and select Properties.

The Effect Properties window pane opens.

4. In the Effect Properties window pane, do the following, if necessary:

TO CHANGE THE POSITION AND SIZE OF THE EFFECT AREA

n Expand the Object Layout section and make the desired adjustments:

l Position Select a different position on the frame for the effect area. The first field
sets the horizontal position, and the second field sets the vertical position. Manually
change the position of the effect area by clicking on the red effect area frame and
dragging it to a new place in the Frame Editor.

l Size Select a different size for the effect area. The first field sets the width, and the
second field sets the height. Manually change the size of the effect area by clicking
on the edges of the red effect area frame and dragging them to the desired height or
width.
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TO CHANGE THE DIRECTION OF THE EFFECT AREA

n Expand the Mask section and select from the following:

l Inside Everything inside of the red effect area frame will have the effect applied to it.

l Outside Everything outside of the red effect area frame will have the effect applied
to it.

NOTE Masks are not available for clip effects. You can only clip inside the red effect
area frame.

TO CHANGE THE MASK PROPERTIES

The mask properties are only applicable to blur and opacity effects.

n Opacity Expand the Opacity Mask section and drag the slider to the desired percentage.
The higher the percentage, the more opaque the effect area will become.

n Blur Expand the Blur Mask section and enter a number in the Blur Radius field. The
higher the number, the more blurred the effect area will become.

5. Click to save your work.

NOTE The shadow effect is edited using the Object Properties window pane. See "Editing
Shadow Effects" on the next page.

NOTE You can add clip and shadow effects to any object type. You can add opacity, gray
scale, and blur effects to image objects.
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Editing Shadow Effects
After you add a shadow effect to an object, you can edit the effect in a few ways or remove it
completely.

How to Edit the Shadow Effect
1. Open a movie that contains an object to which a shadow has been added.

2. Double-click the object. The Object Properties window pane opens.

3. In the Object Properties window pane, expand the Shadow section.

4. Do any of the following:

TO MODIFY THE POSITION OF THE SHADOW

Change the numbers in the Left/Right and Up/Down fields:

n Left/Right Sets the amount of shadow (in pixels) applied to the left or right of the
object. If you enter a positive number, the shadow will appear to the right of the object.
If you enter a negative number, the shadow will appear to the left of the object.

n Up/Down Sets the amount of shadow (in pixels) applied to above or below the object. If
you enter a positive number, the shadow will appear to below the object. If you enter a
negative number, the shadow will appear above the object.

TO MODIFY THE COLOR OF THE SHADOW

Click the down arrow in the Color field to select a new color for the shadow. To see advanced
color options, select . You can also click to pick a color from your screen.

TO MODIFY THE TRANSPARENCY OF THE SHADOW

Drag the slider in the Opacity field to set the amount of transparency applied to the shadow
color. The higher the number, the more solid the color will be. The lower the number, the more
transparent the color will be.
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TO REMOVE THE SHADOW EFFECT

Click the Enable Shadow check box to remove the check mark.

5. Click to save your work.

CHAPTER 14  331



Removing Effects
You can remove effects from any object. The object will still remain in the frame.

How to Remove an Effect
1. Open a movie that contains objects to which effects have been applied.

2. In the Timeline window pane (View > Timeline), do one of the following:

n For all standard object types, click Frame View. Any action objects converted to objects
will also be in this view.

n For action object types, click Action View. Any objects converted to action objects will
also be in this view.

3. Right-click the effect bar and select Delete.

4. Click to save your work.
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CHAPTER 15

Grids
When editing a frame, you can work with grids in the Frame Editor. A grid is simply a series of dots
displayed a certain distance apart on a frame, with each dot representing a specific location on that
frame. They help you more accurately place objects on a frame. The grid does not display in the
output, but is simply shown in the Frame Editor. By dragging and placing the edges of an object
along those dots, you can be assured that the object is positioned more accurately and aligned with
other objects in the frame.

This chapter discusses the following:

How to Show or Hide the Grid 334

How to Snap Objects to the Grid 335

How to Modify Space Between Dots 336
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How to Show or Hide the Grid
1. Open a movie frame.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Tools > Show Grid.

n Local Toolbar In the top toolbar of the Frame Editor, click the arrow next to the Grid
button and select Show Grid.

If the option has a check mark next to it, the grid is shown on the page. If the option does not
have a check mark, the grid is not shown.
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How to Snap Objects to the Grid
1. Open a movie frame.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Tools > Snap to Grid.

n Local Toolbar In the top toolbar of the Frame Editor, click the arrow next to the Grid
button and select Snap to Grid.

If the option has a check mark next to it, the grid is shown on the page. If the option does not
have a check mark, the grid is not shown.
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How to Modify Space Between Dots
1. Open a movie frame.

2. Do one of the following, depending on the part of the user interface you are using:

n Ribbon Select Tools > Edit Grid.

n Local Toolbar In the top toolbar of the Frame Editor, click the arrow next to the Grid
button and select Edit Grid.

The Grid Options dialog opens.

3. In the Size field, enter the amount of space (in pixels) to be shown between dots on the grid.

4. Click OK.
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CHAPTER 16

Previewing Movies
Previewing a movie is an extremely important and useful part of creating a movie. This gives you a
chance to see how a movie looks and works without having to build the movie or collection.

You can preview an entire movie or just an individual frame.
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How to Preview a Movie or Frame
1. Open the movie.

2. (Optional) If you want to preview an individual frame, open the Frames window pane (View >
Frames), then select the frame you want to preview. See "Opening Frames" on page 11.

3. In the Timeline window pane (View > Timeline), do one of the following.

n Preview a Movie Click Movie View.

n Preview a Frame Click Frame View.

4. In the Frame Editor, press the play button in the preview bar.

NOTE You can also preview actions and visual states in a frame or movie. See "Using
Preview Mode" on page 108.
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APPENDIX

PDFs
The following PDFs are available for download from the online Help.

Cheat Sheets
Shortcuts Cheat Sheet

User Guides
Getting Started Guide

Key Features Guide

Movie Creation Guide

Movie Editing Guide

Movie Generation Guide

Touring the Workspace Guide

What's New Guide
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